Prado Manual

Prado 3.1.7 Manual

Created On: 22 Feb 2010
Written By: Qiang Xue, Wei Zhuo
Edited By: Wei Zhuo
Copyright © 2005-2010 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Welcome to the PRADO Quickstart Tutorial

This Quickstart tutorial is provided to help you quickly start building your own Web applications based on PRADO version 3.x.

If you are an existing PRADO 3.x user and would like to learn what enhancements are available for each new version, please check out the new features page. Otherwise, the following sections are helpful for newbies.

You may refer to the following resources if you find this tutorial does not fulfill all your needs.

  • PRADO Classes
  • PRADO API Documentation
  • PRADO Forum
  • PRADO Wiki
  • PRADO Trac
$Id: Introduction.page 1902 2007-05-07 04:17:37Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

What is PRADO?

PRADO is a component-based and event-driven programming framework for developing Web applications in PHP 5. PRADO stands for PHP Rapid Application Development Object-oriented.

A primary goal of PRADO is to enable maximum reusability in Web programming. By reusability, we mean not only reusing one's own code, but also reusing other people's code in an easy way. The latter is more important as it saves the effort of reinventing the wheels and may cut off development time dramatically. The introduction of the concept of component is for this purpose.

To achieve the above goal, PRADO stipulates a protocol of writing and using components to construct Web applications. A component is a software unit that is self-contained and can be reused with trivial customization. New components can be created by simple composition of existing components.

To facilitate interacting with components, PRADO implements an event-driven programming paradigm that allows delegation of extensible behavior to components. End-user activities, such as clicking on a submit button, are captured as server events. Methods or functions may be attached to these events so that when the events happen, they are invoked automatically to respond to the events. Compared with the traditional Web programming in which developers have to deal with the raw POST or GET variables, event-driven programming helps developers better focus on the necessary logic and reduces significantly the low-level repetitive coding.

In summary, developing a PRADO Web application mainly involves instantiating prebuilt component types, configuring them by setting their properties, responding to their events by writing handler functions, and composing them into pages for the application. It is very similar to RAD toolkits, such as Borland Delphi and Microsoft Visual Basic, that are used to develop desktop GUI applications.

Why PRADO?

PRADO is mostly quoted as a unique framework. In fact, it is so unique that it may turn your boring PHP programming into a fun task. The following list is a short summary of the main features of PRADO,

  • Reusability - Code following the PRADO component protocol are highly reusable. This benefits development teams in the long run as they can reuse their previous work and integrate other parties' work easily.
  • Event-driven programming - End-user activities, such as clicking on a submit button, are captured as server events so that developers have better focus on dealing with user interactions.
  • Team integration - Presentation and logic are separately stored. PRADO applications are themable.
  • Powerful Web controls - PRADO comes with a set of powerful components dealing with Web user interfaces. Highly interactive Web pages can be created with a few lines of code. For example, using the datagrid component, one can quickly create a page presenting a data table which allows paging, sorting, editing, and deleting rows of the data.
  • Strong database support - Since version 3.1, PRADO has been equipped with complete database support which is natively written and thus fits seemlessly with the rest part of the PRADO framework. According to the complexity of the business objects, one can choose to use the simple PDO-based data access, or the widely known active record, or the complete business object mapping scheme SqlMap.
  • Seamless AJAX support - Using AJAX in PRADO has never been easier with its innovative active controls introduced since version 3.1. You can easily write an AJAX-enabled application without writing a single line of javascript code. In fact, using active controls is not much different from using the regular non-AJAX enabled Web controls.
  • I18N and L10N support - PRADO includes complete support for building applications with multiple languages and locales.
  • XHTML compliance - Web pages generated by PRADO are XHTML-compliant.
  • Accommodation of existing work - PRADO is a generic framework with focus on the presentational layer. It does not exclude developers from using most existing class libraries or toolkits. For example, one can AdoDB or Creole to deal with DB in his PRADO application.
  • Other features - Powerful error/exception handling and message logging; generic caching and selective output caching; customizable and localizable error handling; extensible authentication and authorization; security measures such as cross-site script (XSS) prevention, cookie protection, etc.

What Is PRADO Best For?

PRADO is best suitable for creating Web applications that are highly user-interactive. It can be used to develop systems as simple as a blog system to those as complex as a content management system (CMS) or a complete e-commerce solution. Because PRADO promotes object-oriented programming through its component-based methodology, it fits extremely well for team work and enterprise development.

PRADO comes with a complete set of caching techniques which help accelerate PRADO Web applications to accommodate high traffic requirement. Its modular architecture allows developers to use or plug in different cache modules for different needs. The output caching enables one to selectively choose to cache part of a rendered Web page.

How Is PRADO Compared with Other Frameworks?

PRADO is often quoted as a unique framework. Its uniqueness mainly lies in the component-based and event-driven programming paradigm that it tries to promote. Although this programming paradigm is not new in desktop application programming and not new in a few Web programming languages, PRADO is perhaps the first PHP framework enabling it.

Most PHP frameworks mainly focuses on separating presentation and logic and promotes the MVC (model-view-controller) design pattern. PRADO achieves the same goal naturally by requiring logic be stored in classes and presentation in templates. PRADO does much more on aspects other than MVC. It fills lot of blank area in PHP Web programming with its component-based programming paradigm, its rich set of Web controls, its powerful database support, its flexible error handling and logging feature, and many others.

Is PRADO Stable Enough?

Yes. PRADO was initially released in August 2004. Many test suites have been written and conducted frequently to ensure its quality. It has been used by thousands of developers and many Web applications have been developed based on it. Bugs and feature requests are managed through TRAC system and we have a great user community and development team to ensure all questions are answered in a timely fashion.

History of PRADO

The very original inspiration of PRADO came from Apache Tapestry. During the design and implementation, I borrowed many ideas from Borland Delphi and Microsoft ASP.NET. The first version of PRADO came out in June 2004 and was written in PHP 4. Driven by the Zend PHP 5 coding contest, I rewrote PRADO in PHP 5, which proved to be a wise move, thanks to the new object model provided by PHP 5. PRADO won the grand prize in the Zend contest, earning the highest votes from both the public and the judges' panel.

In August 2004, PRADO started to be hosted on SourceForge as an open source project. Soon after, the project site xisc.com was announced to public. With the fantastic support of PRADO developer team and PRADO users, PRADO evolved to version 2.0 in mid 2005. In this version, Wei Zhuo contributed to PRADO with the excellent I18N and L10N support.

In May 2005, we decided to completely rewrite the PRADO framework to resolve a few fundamental issues found in version 2.0 and to catch up with some cool features available in Microsoft ASP.NET 2.0. After nearly a year's hard work with over 50,000 lines of new code, version 3.0 was finally made available in April 2006.

Starting from version 3.0, significant efforts are allocated to ensure the quality and stability of PRADO. If we say PRADO v2.x and v1.x are proof-of-concept work, we can say PRADO 3.x has grown up to a project that is suitable for serious business application development.

$Id: AboutPrado.page 1902 2007-05-07 04:17:37Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Installing PRADO

If you are viewing this page from your own Web server, you are already done with the installation.

The minimum requirement by PRADO is that the Web server support PHP 5. PRADO has been tested with Apache Web server on Windows and Linux. Highly possibly it may also run on other platforms with other Web servers, as long as PHP 5 is supported.

Installation of PRADO mainly involves downloading and unpacking.

  1. Go to pradosoft.com to grab the latest version of PRADO.
  2. Unpack the PRADO release file to a Web-accessible directory.

Your installation of PRADO is done and you can start to play with the demo applications included in the PRADO release via URL http://web-server-address/prado/demos/. Here we assume PRADO is unpacked to the prado subdirectory under the DocumentRoot of the Web server.

If you encounter any problems with the demo applications, please use the PRADO requirement checker script, accessible via http://web-server-address/prado/requirements/index.php, to check first if your server configuration fulfills the conditions required by PRADO.

$Id: Installation.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

New Features

This page summarizes the main new features that are introduced in each PRADO release.

Version 3.1.3

  • Added Drag and drop controls
  • Added TActiveDatePicker control

Version 3.1.2

  • Added a new active control TActivePager that allows to paginate a databound control with an ajax callback.
  • Added TFirebugLogRoute to send logs to the Firebug console

Version 3.1.1

  • Added a new control TTabPanel that displays tabbed views.
  • Added a new control TKeyboard that displays a virtual keyboard for text input.
  • Added a new control TCaptcha that displays a CAPTCHA to keep spammers from signing up for certain accounts online. A related validator TCaptchaValidator is also implemented.
  • Added a new control TSlider that displays a slider which can be used for numeric input.
  • Added a new control TConditional that conditionally displays one of the two kinds of content.
  • Added Oracle DB support to Active Record.
  • Added support to TDataGrid to allow grouping consecutive cells with the same content.
  • Added support to allow configuring page properties and authorization rules using authorization based on remote host address.
  • Added a new page state persister TCachePageStatePersister. It allows page state to be stored using a cache module (e.g. TMemCache, TDbCache, etc.)
  • Added support to the auth framework to allow remembering login.
  • Added support to display a prompt item in TDropDownList and TListBox (something like 'Please select:' as the first list item.)
  • Added support to column mapping in Active Record.

Version 3.1.0

  • Added seamless AJAX support. A whole array of AJAX-enabled controls, called active controls, are introduced. The usage of these active controls is very similar to their non-AJAX counterparts, i.e., plug in and use. For more details, see the tutorial about active controls.
  • Added complete database support.
  • Added new controls, modules and services, including TOutputCache, TSessionPageStatePersister, TFeedService, TJsonService, cache dependency classes, TXmlTransform.
  • Enhanced some data controls with renderers. Renderer enables reusing item templates that are commonly found in TRepeater, TDataList and TDataGrid, and makes the configuration on these controls much cleaner. For more details about renders, see the updated tutorials on TDataGrid.
  • Added support to allow subproperty configuration.
  • Added TDbUserManager and TDbUser to simplify authentication and authorization with user accounts stored in a database.
$Id: NewFeatures.page 2517 2008-10-13 13:40:34Z tof $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Upgrading from v2.x and v1.x

PRADO v3.0 is NOT backward compatible with earlier versions of PRADO.

A good news is, properties and events of most controls remain intact, and the syntax of control templates remains largely unchanged. Therefore, developers' knowledge of earlier versions of PRADO are still applicable in v3.0.

We summarize in the following the most significant changes in v3.0 to help developers upgrade their v2.x and v1.x PRADO applications more easily, if needed.

Component Definition

Version 3.0 has completely discarded the need of component specification files. It relies more on conventions for defining component properties and events. In particular, a property is defined by the existence of a getter method and/or a setter method, while an event is defined by the existence of an on-method. Property and event names in v3.0 are both case-insensitive. As a consequence, developers are now required to take care of type conversions when a component property is being set. For example, the following code is used to define the setter method for the Enabled property of TControl, which is of boolean type,

public function setEnabled($value)
{
    $value=TPropertyValue::ensureBoolean($value);
    $this->setViewState('Enabled',$value,true);
}

where TPropertyValue::ensureBoolean() is used to ensure that the input value be a boolean. This is because when the property is configured in template, a string value is passed to the setter. In previous versions, PRADO knows the property type based on the component specification files and does the type conversion for you.

Application Controller

Application controller now implements a modular architecture. Modules can be plugged in and configured in application specifications. Each module assumes a particular functionality, and they are coordinated together by the application specification is also different from earlier versions.

Pages

Pages in v3.0 are organized in directories which may be compared to the module concept in v2.x. Pages are requested using the path to them. For example, a URL index.php?page=Controls.Samples.Sample1 would be used to request for a page named Sample1 stored under the [BasePath]/Controls/Samples directory, where [BasePath] refers to the root page path. The file name of a page template must be ended with .page, mainly to differentiate page templates from non-page control templates whose file names must be ended with .tpl.

Control Relationship

Version 3.0 redefines the relationships between controls. In particular, the parent-child relationship now refers to the enclosure relationship between controls' presentation. And a new naming-container relationship is introduced to help better manage control IDs. For more details, see the controls section.

Template Syntax

The syntax of control templates in v3.0 remains similar to those in earlier versions, with many enhancements. A major change is about the databinding expression. In v3.0, this is done by the following,

<com:MyComponent PropertyName=<%# PHP expression %> .../>

Expression and statement tags are also changed similarly. For more details, see the template definition section.

Theme Syntax

Themes in v3.0 are defined like control templates with a few restrictions.

$Id: Upgrading.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

My First PRADO Application

In this section, we guide you through creating your first PRADO application, the famous "Hello World" application.

"Hello World" perhaps is the simplest interactive PRADO application that you can create. It displays to end-users a page with a submit button whose caption is Click Me. After the user clicks on the button, its caption is changed to Hello World.

There are many approaches that can achieve the above goal. One can submit the page to the server, examine the POST variable, and generate a new page with the button caption updated. Or one can simply use JavaScript to update the button caption upon its onclick client event.

PRADO promotes component-based and event-driven Web programming. The button is represented by a TButton object. It encapsulates the button caption as the Text property and associates the user button click action with a server-side OnClick event. To respond to the user clicking on the button, one simply needs to attach a function to the button's OnClick event. Within the function, the button's Text property is modified as "Hello World". The following diagram shows the above sequence,

Our PRADO application consists of three files, index.php, Home.page and Home.php, which are organized as follows, [image] where each directory is explained as follows. Note, the above directory structure can be customized. For example, one can move the protected directory out of Web directories. You will know how to do this after you go through this tutorial.

  • assets - directory storing published private files. See assets section for more details. This directory must be writable by the Web server process.
  • protected - application base path storing application data and private script files. This directory should be configured as inaccessible to end-users.
  • runtime - application runtime storage path storing application runtime information, such as application state, cached data, etc. This directory must be writable by the Web server process.
  • pages - base path storing all PRADO pages.
Tip:You may also use the framework/prado-cli.php command line script to create the Prado project directory structure. For example, type the command php path/to/prado-cli.php -c helloworld in the directory where you want to create the helloworld project.

The three files that we need are explained as follows.

  • index.php - entry script of the PRADO application. This file is required by all PRADO applications and is the only script file that is directly accessible by end-users. Content in index.php mainly consists of the following three lines,
    require_once('path/to/prado.php');  // include the prado script
$application=new TApplication;      // create a PRADO application instance
$application->run();                // run the application
  • Home.page - template for the default page returned when users do not explicitly specify the page requested. A template specifies the presentational layout of components. In this example, we use two components, TForm and TButton, which correspond to the <form> and <input> HTML tags, respectively. The template contains the following content,
    <html>
  <body>
    <com:TForm>
      <com:TButton Text="Click me" OnClick="buttonClicked" />
    </com:TForm>
  </body>
</html>
  • Home.php - page class for the Home page. It mainly contains the method responding to the OnClick event of the button.
    class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        // $sender refers to the button component
        $sender->Text="Hello World!";
    }
}

The application is now ready and can be accessed via: http://Web-server-address/helloworld/index.php, assuming helloworld is directly under the Web DocumentRoot. Try to change TButton in Home.page to TLinkButton and see what happens.

Complete source code of this demo can be found in the PRADO release. You can also try the online demo.

$Id: HelloWorld.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Sample: Hangman Game

Having seen the simple "Hello World" application, we now build a more complex application called "Hangman Game". In this game, the player is asked to guess a word, a letter at a time. If he guesses a letter right, the letter will be shown in the word. The player can continue to guess as long as the number of his misses is within a prespecified bound. The player wins the game if he finds out the word within the miss bound, or he loses.

To facilitate the building of this game, we show the state transition diagram of the gaming process in the following,

To be continued...

Run Sample View Source
$Id: Hangman.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Building a Simple Currency Converter

This tutorial introduces the Prado web application framework and teaches you how to build a simple web application in a few simple steps. This tutorial assumes that you are familiar with PHP and you have access to a web server that is able to serve PHP5 scripts.

In this tutorial you will build a simple web application that converts a dollar amount to an other currency, given the rate of that currency relative to the dollar. The completed application is shown bellow. You can try the application locally or at Pradosoft.com. Notice that the application still functions exactly the same if javascript is not available on the user's browser.

Downloading and Installing Prado

To install Prado, simply download the latest version of Prado from http://www.pradosoft.com and unzip the file to a directory not accessible by your web server (you may unzip it to a directory accessible by the web server if you wish to see the demos and test). For further detailed installation, see the Quickstart Installation guide.

Creating a new Prado web Application

The quickest and simplest way to create a new Prado web application is to use the command tool prado-cli.php found in the framework directory of the Prado distribution. We create a new application by running the following command in your command prompt or console. The command creates a new directory named currency-converter in your current working directory. You may need to change to the appropriate directory first. See the Command Line Tool for more details.

php prado/framework/prado-cli.php -c currency-converter

The above command creates the necessary directory structure and minimal files (including "index.php" and "Home.page") to run a Prado web application. Now you can point your browser's url to the web server to serve up the index.php script in the currency-converter directory. You should see the message "Welcome to Prado!"

Creating the Currency Converter User Interface

We start by editing the Home.page file found in the currency-converter/protected/pages/ directory. Files ending with ".page" are page templates that contains HTML and Prado controls. We simply add two textboxes, three labels and one button as follows.

<com:TForm>
    <fieldset>
        <legend>Currency Converter</legend>
        <div class="rate-field">
            <com:TLabel ForControl="currencyRate" Text="Exchange Rate per $1:" />
            <com:TTextBox ID="currencyRate" />
        </div>
        <div class="dollar-field">
            <com:TLabel ForControl="dollars" Text="Dollars to Convert:" />
            <com:TTextBox ID="dollars" />
        </div>
        <div class="total-field">
            <span class="total-label">Amount in Other Currency:</span>
            <com:TLabel ID="total" CssClass="result" />
        </div>
        <div class="convert-button">
            <com:TButton Text="Convert" />
        </div>
    </fieldset>
</com:TForm>

If you refresh the page, you should see something similar to the following figure. It may not look very pretty or orderly, but we shall change that later using CSS.

The first component we add is a TForm that basically corresponds to the HTML <form> element. In Prado, only one TForm element is allowed per page.

The next two pair of component we add is the TLabel and TTextBox that basically defines a label and a textbox for the user of the application to enter the currency exchange rate. The ForControl property value determines which component that the label is for. This allows the user of the application to click on the label to focus on the field (a good thing). You could have used a plain HTML <label> element to do the same thing, but you would have to find the correct ID of the textbox (or <input> in HTML) as Prado components may/will render the ID value differently in the HTML output.

The next pair of components are similar and defines the textbox to hold the dollar value to be converted. The TLabel with ID value "total" defines a simple label. Notice that the ForControl property is absent. This means that this label is simply a simple label which we are going to use to display the converted total amount.

The final component is a TButton that the user will click to calculate the results. The Text property sets the button label.

Implementing Currency Conversion

If you tried clicking on the "Convert" button then the page will refresh and does not do anything else. For the button to do some work, we need to add a "Home.php" to where "Home.page" is. The Home class should extends the TPage, the default base class for all Prado pages.

<?php
class Home extends TPage
{

}
?>

Prado uses PHP's __autoload method to load classes. The convention is to use the class name with ".php" extension as filename.

So far there is nothing interesting about Prado, we just declared some "web components" in some template file named Home.page and created a "Home.php" file with a Home class. The more interesting bits are in Prado's event-driven architecture as we shall see next.

We want that when the user click on the "Convert" button, we take the values in the textbox, do some calculation and present the user with the converted total. To handle the user clicking of the "Convert" button we simply add an OnClick property to the "Convert" button in the "Home.page" template and add a corresponding event handler method in the "Home.php".

<com:TButton Text="Convert" OnClick="convert_clicked" />

The value of the OnClick, "convert_clicked", will be the method name in the "Home.php" that will called when the user clicks on the "Convert" button.

class Home extends TPage
{
    public function convert_clicked($sender, $param)
    {
        $rate = floatval($this->currencyRate->Text);
        $dollars = floatval($this->dollars->Text);
        $this->total->Text = $rate * $dollars;
    }
}

If you run the application in your web browser, enter some values and click the "Convert" button then you should see that calculated value displayed next to the "Amount in Other Currency" label.

In the "convert_clicked" method the first parameter, $sender, corresponds to the object that raised the event, in this case, the "Convert" button. The second parameter, $param contains any additional data that the $sender object may wish to have added.

We shall now examine, the three lines that implements the simply currency conversion in the "convert_clicked" method.

$rate = floatval($this->currencyRate->Text);

The statement $this->currencyRate corresponds to the TTextBox component with ID value "currencyRate" in the "Home.page" template. The Text property of the TTextBox contains the value that the user entered. So, we obtain this value by $this->currencyRate->Text which we convert the value to a float value.

$dollars = floatval($this->dollars->Text);

The next line does a similar things, it takes the user value from the TTextBox with ID value "dollars and converts it to a float value.

The third line calculates the new amount and set this value in the Text property of the TLabel with ID="total". Thus, we display the new amount to the user in the label.

$this->total->Text = $rate * $dollars;

Adding Validation

The way we convert the user entered value to float ensures that the total amount is always a number. So the user is free to enter what ever they like, they could even enter letters. The user's experience in using the application can be improved by adding validators to inform the user of the allowed values in the currency rate and the amount to be calcuated.

For the currency rate, we should ensure that

  1. the user enters a value,
  2. the currency rate is a valid number,
  3. the currency rate is positive.

To ensure 1 we add one TRequiredFieldValidator. To ensure 2 and 3, we add one TCompareValidator. We may add these validators any where within the "Home.page" template. Further details regarding these validator and other validators can be found in the Validation Controls page.

<com:TRequiredFieldValidator
    ControlToValidate="currencyRate"
    ErrorMessage="Please enter a currency rate." />
<com:TCompareValidator
    ControlToValidate="currencyRate"
    DataType="Float"
    ValueToCompare="0"
    Operator="GreaterThan"
    ErrorMessage="Please enter a positive currency rate." />

For the amount to be calculated, we should ensure that

  1. the user enters a value,
  2. the value is a valid number (not including any currency or dollar signs).

To ensure 1 we just add another TRequiredFieldValidator, for 2 we could use a TDataTypeValidator. For simplicity we only allow the user to enter a number for the amount they wish to convert.

<com:TRequiredFieldValidator
    ControlToValidate="dollars"
    ErrorMessage="Please enter the amount you wish to calculate." />
<com:TDataTypeValidator
    ControlToValidate="dollars"
    DataType="Float"
    ErrorMessage="Please enter a number." />

Now if you try to enter some invalid data in the application or left out any of the fields the validators will be activated and present the user with error messages. Notice that the error messages are presented without reloading the page. Prado's validators by default validates using both javascript and server side. The server side validation is always performed. For the server side, we should skip the calculation if the validators are not satisfied. This can done as follows.

public function convert_clicked($sender, $param)
{
    if($this->Page->IsValid)
    {
        $rate = floatval($this->currencyRate->Text);
        $dollars = floatval($this->dollars->Text);
        $this->total->Text = $rate * $dollars;
    }
}

Improve User Experience With Active Controls

Requires Prado versions 3.1a or later.

In this simple application we may further improve the user experience by increasing the responsiveness of the application. One way to achieve a faster response is calculate and present the results without reloading the whole page.

We can replace the TButton with the Active Control counter part, TActiveButton, that can trigger a server side click event without reloading the page. In addition, we can change the "totals" TLabel with the Active Control counter part, TActiveLabel, such that the server side can update the browser without reloading the page.

<div class="total-field">
    <span class="total-label">Amount in Other Currency:</span>
         <com:TActiveLabel ID="total" CssClass="result" />
    </div>
    <div class="convert-button">
        <com:TActiveButton Text="Convert" OnClick="convert_clicked" />
</div>

The server side logic remains the same, we just need to import the Active Controls name space as they are not included by default. We add the following line to the begin of "Home.php".

Prado::using('System.Web.UI.ActiveControls.*');

If you try the application now, you may notice that the page no longer needs to reload to calculate and display the converted total amount. However, since there is not page reload, there is no indication or not obvious that by clicking on the "Convert" button any has happened. We can further refine the user experience by change the text of "total" label to "calculating..." when the user clicks on the "Convert" button. The text of the "total" label will still be updated with the new calculate amount as before.

To indicate that the calculation is in progress, we can change the text of the "total" label as follows. We add a ClientSide.OnLoading property to the "Convert" button (since this button is responsible for requesting the calculation).

<com:TActiveButton Text="Convert" OnClick="convert_clicked" >
    <prop:ClientSide.OnLoading>
        $('<%= $this->total->ClientID %>').innerHTML = "calculating..."
    </prop:ClientSide.OnLoading>
</com:TActiveButton>

The ClientSide.OnLoading and various other properties accept a javascript block as their content or value. The javascript code $('...') is a javascript function that is equivalent to document.getElementById('...') that takes a string with the ID of an HTML element. Since Prado renders its components's IDs, we need to use the rendered ID of the "total" label, that is, $this->total->ClientID. We place this bit of code within a <%= %> to obtain the rendered HTML ID for the "total" label. The rest of the javascript code innerHTML = "calculating..." simply changes the content of the "total" label.

Adding Final Touches

So far we have built a simple currency converter web application with little attention of the looks and feel. Now we can add a stylesheet to improve the overall appearance of the application. We can simply add the stylesheet inline with the template code or we may create a "theme".

To create and use a theme with Prado applications, we simply create a new directory "themes/Basic" in the currency-converter directory. You may need to create the themes directory first. Any directory within the themes are considered as a theme with the name of the theme being the directory name. See the Themes and Skins for further details.

We simply create a CSS file named "common.css" and save it in the themes/Basic directory. Then we add the following code to the beginning of "Home.page" (we add a little more HTML as well).

<%@ Theme="Basic" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" >
<com:THead Title="Currency Converter" />
<body>

The first line <%@ Theme="Basic" %> defines the theme to be used for this page. The THead corresponds to the HTML <head> element. In addition to display the Title property by the THead, all CSS files in the themes/Basic directory are also rendered/linked for the current page. Our final currency converter web application looks like the following. This completes introduction tutorial to the Prado web application framework.

$Id: CurrencyConverter.page 1846 2007-04-07 10:35:16Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

A Simple Address Book

This tutorial introduces the basics of connecting to a database using ActiveRecord and using Active Record scaffolds to quickly build a simple address book.

Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Building an AJAX Chat Application

Requires Prado versions 3.1a or later.

This tutorial introduces the Prado web application framework's ActiveRecord and Active Controls to build a Chat web application. It is assumed that you are familiar with PHP and you have access to a web server that is able to serve PHP5 scripts. This basic chat application will utilize the following ideas/components in Prado.

  • Building a custom User Manager class.
  • Authenticating and adding a new user to the database.
  • Using ActiveRecord to interact with the database.
  • Using Active Controls and callbacks to implement the user interface.
  • Separating application logic and application flow.

In this tutorial you will build an AJAX Chat web application that allows multiple users to communicate through their web browser. The application consists of two pages: a login page that asks the user to enter their nickname and the main application chat page. You can try the application locally or at Pradosoft.com. The main application chat page is shown bellow.

Download, Install and Create a New Application

The download and installation steps are similar to those in the Currency converter tutorial. To create the application, we run from the command line the following. See the Command Line Tool for more details.

php prado/framework/prado-cli.php -c chat

The above command creates the necessary directory structure and minimal files (including "index.php" and "Home.page") to run a Prado web application. Now you can point your browser's URL to the web server to serve up the index.php script in the chat directory. You should see the message "Welcome to Prado!"

Authentication and Authorization

The first task for this application is to ensure that each user of the chat application is assigned with a unique (chosen by the user) username. To achieve this, we can secure the main chat application page to deny access to anonymous users. First, let us create the Login page with the following code. We save the Login.php and Login.page in the chat/protected/pages/ directory (there should be a Home.page file created by the command line tool).

<?php
class Login extends TPage
{
}
?>
<!doctype html public "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
    <title>Prado Chat Demo Login</title>
</head>
<body>
<com:TForm>
    <h1 class="login">Prado Chat Demo Login</h1>
    <fieldset class="login">
        <legend>Please enter your name:</legend>
        <div class="username">
            <com:TLabel ForControl="username" Text="Username:" />
            <com:TTextBox ID="username" MaxLength="20" />
            <com:TRequiredFieldValidator
                ControlToValidate="username"
                Display="Dynamic"
                ErrorMessage="Please provide a username." />
        </div>
        <div class="login-button">
            <com:TButton Text="Login" />
        </div>
</com:TForm>
</body>
</html>

The login page contains a TForm, a TTextBox, a TRequiredFieldValidator and a TButton. The resulting page looks like the following (after applying some a style sheet). If you click on the Login button without entering any text in the username textbox, an error message is displayed. This is due to the TRequiredFieldValidator requiring the user to enter some text in the textbox before proceeding.

Securing the Home page

Now we wish that if the user is trying to access the main application page, Home.page, before they have logged in, the user is presented with the Login.page first. We add a chat/protected/application.xml configuration file to import some classes that we shall use later.

<?xml version="1.0" encoding="utf-8"?>
<application id="Chat" Mode="Debug">
  <paths>
    <using namespace="System.Data.*" />
    <using namespace="System.Data.ActiveRecord.*" />
    <using namespace="System.Security.*" />
    <using namespace="System.Web.UI.ActiveControls.*" />
  </paths>
</application>
Next, we add a chat/protected/pages/config.xml configuration file to secure the pages directory.
<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <modules>
    <module id="users" class="TUserManager" />
    <module id="auth" class="TAuthManager" UserManager="users" LoginPage="Login" />
  </modules>
  <authorization>
    <allow pages="Login" users="?" />
    <allow roles="normal" />
    <deny users="*" />
  </authorization>
</configuration>
We setup the authentication using the default classes as explained in the authentication/authorization quickstart. In the authorization definition, we allow anonymous users to access the Login page (anonymous users is specified by the ? question mark). We allow any users with role equal to "normal" (to be defined later) to access all the pages, that is, the Login and Home pages. Lastly, we deny all users without any roles to access any page. The authorization rules are executed on first match basis.

If you now try to access the Home page by pointing your browser to the index.php you will be redirected to the Login page.

Active Record for chat_users table

The TUserManager class only provides a read-only list of users. We need to be able to add or login new users dynamically. So we need to create our own user manager class. First, we shall setup a database with a chat_users table and create an ActiveRecord that can work with the chat_users table with ease. For the demo, we use sqlite as our database for ease of distributing the demo. The demo can be extended to use other databases such as MySQL or Postgres SQL easily. We define the chat_users table as follows.

CREATE TABLE chat_users
(
    username VARCHAR(20) NOT NULL PRIMARY KEY,
    last_activity INTEGER NOT NULL DEFAULT "0"
);
Next we define the corresponding ChatUserRecord class and save it as chat/protected/App_Code/ChatUserRecord.php (you need to create the App_Code directory as well). We also save the sqlite database file as App_Code/chat.db.
class ChatUserRecord extends TActiveRecord
{
    const TABLE='chat_users';

    public $username;
    public $last_activity;

    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}
Before using the ChatUserRecord class we to configure a default database connection for ActiveRecord to function. In the chat/protected/application.xml we import classes from the App_Code directory and add an ActiveRecord configuration module.
<?xml version="1.0" encoding="utf-8"?>
<application id="Chat" Mode="Debug">
  <paths>
    <using namespace="Application.App_Code.*" />
    <using namespace="System.Data.*" />
    <using namespace="System.Data.ActiveRecord.*" />
    <using namespace="System.Security.*" />
    <using namespace="System.Web.UI.ActiveControls.*" />
  </paths>
  <modules>
    <module class="TActiveRecordConfig" EnableCache="true"
        Database.ConnectionString="sqlite:protected/App_Code/chat.db" />
  </modules>
</application>

Custom User Manager class

To implement a custom user manager module class we just need to extends the TModule class and implement the IUserManager interface. The getGuestName(), getUser() and validateUser() methods are required by the IUserManager interface. We save the custom user manager class as App_Code/ChatUserManager.php.

class ChatUserManager extends TModule implements IUserManager
{
    public function getGuestName()
    {
        return 'Guest';
    }

    public function getUser($username=null)
    {
        $user=new TUser($this);
        $user->setIsGuest(true);
        if($username !== null && $this->usernameExists($username))
        {
            $user->setIsGuest(false);
            $user->setName($username);
            $user->setRoles(array('normal'));
        }
        return $user;
    }

    public function addNewUser($username)
    {
        $user = new ChatUserRecord();
        $user->username = $username;
        $user->save();
    }

    public function usernameExists($username)
    {
        $finder = ChatUserRecord::finder();
        $record = $finder->findByUsername($username);
        return $record instanceof ChatUserRecord;
    }

    public function validateUser($username,$password)
    {
        return $this->usernameExists($username);
    }
}

The getGuestName() method simply returns the name for a guest user and is not used in our application. The getUser() method returns a TUser object if the username exists in the database, the TUser object is set with role of "normal" that corresponds to the <authorization> rules defined in our config.xml file.

The addNewUser() and usernameExists() method uses the ActiveRecord corresponding to the chat_users table to add a new user and to check if a username already exists, respectively.

The next thing to do is change the config.xml configuration to use our new custom user manager class. We simply change the <module> configuration with id="users".

<module id="users" class="ChatUserManager" />

Authentication

To perform authentication, we just want the user to enter a unique username. We add a TCustomValidator for validate the uniqueness of the username and add an OnClick event handler for the login button.

<com:TCustomValidator
    ControlToValidate="username"
    Display="Dynamic"
    OnServerValidate="checkUsername"
    ErrorMessage="The username is already taken." />

...

<com:TButton Text="Login" OnClick="createNewUser" />
In the Login.php file, we add the following 2 methods.
function checkUsername($sender, $param)
{
    $manager = $this->Application->Modules['users'];
    if($manager->usernameExists($this->username->Text))
        $param->IsValid = false;
}

function createNewUser($sender, $param)
{
    if($this->Page->IsValid)
    {
        $manager = $this->Application->Modules['users'];
        $manager->addNewUser($this->username->Text);

        //do manual login
        $user = $manager->getUser($this->username->Text);
        $auth = $this->Application->Modules['auth'];
        $auth->updateSessionUser($user);
        $this->Application->User = $user;

        $url = $this->Service->constructUrl($this->Service->DefaultPage);
        $this->Response->redirect($url);
    }
}
The checkUserName() method uses the ChatUserManager class (recall that in the config.xml configuration we set the ID of the custom user manager class as "users") to validate the username is not taken.

In the createNewUser method, when the validation passes (that is, when the user name is not taken) we add a new user. Afterward we perform a manual login process:

  • First we obtain a TUser instance from our custom user manager class using the $manager->getUser(...) method.
  • Using the TAuthManager we set/update the user object in the current session data.
  • Then we set/update the Application's user instance with our new user object.

Finally, we redirect the client to the default Home page.

Default Values for ActiveRecord

If you try to perform a login now, you will receive an error message like "Property 'ChatUserRecord::$last_activity' must not be null as defined by column 'last_activity' in table 'chat_users'.". This means that the $last_activity property value was null when we tried to insert a new record. We need to either define a default value in the corresponding column in the table and allow null values or set the default value in the ChatUserRecord class. We shall demonstrate the later by altering the ChatUserRecord with the addition of a set getter/setter methods for the last_activity property.

private $_last_activity;

public function getLast_Activity()
{
    if($this->_last_activity === null)
        $this->_last_activity = time();
    return $this->_last_activity;
}

public function setLast_Activity($value)
{
    $this->_last_activity = $value;
}
Notice that we renamed $last_activity to $_last_activity (note the underscore after the dollar sign).

Main Chat Application

Now we are ready to build the main chat application. We use a simple layout that consist of one panel holding the chat messages, one panel to hold the users list, a textarea for the user to enter the text message and a button to send the message.

<!doctype html public "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
    <title>Prado Chat Demo</title>
<style>
.messages
{
    width: 500px;
    height: 300px;
    float: left;
    border: 1px solid ButtonFace;
    overflow: auto;
}
.user-list
{
    margin-left: 2px;
    float: left;
    width: 180px;
    height: 300px;
    border: 1px solid ButtonFace;
    overflow: auto;
    font-size: 0.85em;
}
.message-input
{
    float: left;
}

.message-input textarea
{
    margin-top: 3px;
    padding: 0.4em 0.2em;
    width: 493px;
    font-family: Verdana, Geneva, Arial, Helvetica, sans-serif;
    font-size: 0.85em;
    height: 40px;
}
.send-button
{
    margin: 0.5em;
}
</style>
</head>
<body>
<com:TForm>
<h1 id="18014">Prado Chat Demo</h1>
<div id="messages" class="messages">
    <com:TPlaceHolder ID="messageList" />
</div>
<div id="users" class="user-list">
    <com:TPlaceHolder ID="userList" />
</div>
<div class="message-input">
    <com:TActiveTextBox ID="userinput"
        Columns="40" Rows="2" TextMode="MultiLine" />
    <com:TActiveButton ID="sendButton" CssClass="send-button"
        Text="Send" />
</div>
</com:TForm>
<com:TJavascriptLogger />
</body>
</html>
We added two Active Control components: a TActiveTextBox and a TActiveButton. We also added a TJavascriptLogger that will be very useful for understanding how the Active Controls work.

Exploring the Active Controls

We should have some fun before we proceeding with setting up the chat buffering. We want to see how we can update the current page when we receive a message. First, we add an OnClick event handler for the Send button.

<com:TActiveButton ID="sendButton" CssClass="send-button"
    Text="Send" OnClick="processMessage"/>
And the corresponding event handler method in the Home.php class (we need to create this new file too).
class Home extends TPage
{
    function processMessage($sender, $param)
    {
        echo $this->userinput->Text;
    }
}
If you now type something in the main application textbox and click the send button you should see whatever you have typed echoed in the TJavascriptLogger console.

To append or add some content to the message list panel, we need to use some methods in the TCallbackClientScript class which is available through the CallbackClient property of the current TPage object. For example, we do can do

function processMessage($sender, $param)
{
    $this->CallbackClient->appendContent("messages", $this->userinput->Text);
}
This is one way to update some part of the existing page during a callback (AJAX style events) and will be the primary way we will use to implement the chat application.

Active Record for chat_buffer table

To send a message to all the connected users we need to buffer or store the message for each user. We can use the database to buffer the messages. The chat_buffer table is defined as follows.

CREATE TABLE chat_buffer
(
    id INTEGER PRIMARY KEY,
    for_user VARCHAR(20) NOT NULL,
    from_user VARCHAR(20) NOT NULL,
    message TEXT NOT NULL,
    created_on INTEGER NOT NULL DEFAULT "0"
);
The corresponding ChatBufferRecord class is saved as App_Code/ChatBufferRecord.php.
class ChatBufferRecord extends TActiveRecord
{
    const TABLE='chat_buffer';

    public $id;
    public $for_user;
    public $from_user;
    public $message;
    private $_created_on;

    public function getCreated_On()
    {
        if($this->_created_on === null)
            $this->_created_on = time();
        return $this->_created_on;
    }

    public function setCreated_On($value)
    {
        $this->_created_on = $value;
    }

    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

Chat Application Logic

We finally arrive at the guts of the chat application logic. First, we need to save a received message into the chat buffer for all the current users. We add this logic in the ChatBufferRecord class.

public function saveMessage()
{
    foreach(ChatUserRecord::finder()->findAll() as $user)
    {
        $message = new self;
        $message->for_user = $user->username;
        $message->from_user = $this->from_user;
        $message->message = $this->message;
        $message->save();
        if($user->username == $this->from_user)
        {
            $user->last_activity = time(); //update the last activity;
            $user->save();
        }
    }
}
We first find all the current users using the ChatUserRecord finder methods. Then we duplicate the message and save it into the database. In addition, we update the message sender's last activity timestamp. The above piece of code demonstrates the simplicity and succinctness of using ActiveRecords for simple database designs.

The next piece of the logic is to retrieve the users' messages from the buffer. We simply load all the messages for a particular username and format that message appropriately (remember to escape the output to prevent Cross-Site Scripting attacks). After we load the messages, we delete those loaded messages and any older messages that may have been left in the buffer.

public function getUserMessages($user)
{
    $content = '';
    foreach($this->findAll('for_user = ?', $user) as $message)
        $content .= $this->formatMessage($message);
    $this->deleteAll('for_user = ? OR created_on < ?',
                          $user, time() - 300); //5 min inactivity
    return $content;
}

protected function formatMessage($message)
{
    $user = htmlspecialchars($message->from_user);
    $content = htmlspecialchars($message->message);
    return "<div class=\"message\"><strong>{$user}:</strong>"
                  ." <span>{$content}</span></div>";
}
To retrieve a list of current users (formatted), we add this logic to the ChatUserRecord class. We delete any users that may have been inactive for awhile.
public function getUserList()
{
    $this->deleteAll('last_activity < ?', time()-300); //5 min inactivity
    $content = '<ul>';
    foreach($this->findAll() as $user)
        $content .= '<li>'.htmlspecialchars($user->username).'</li>';
    $content .= '</ul>';
    return $content;
}
Note: For simplicity we formatted the messages in these Active Record classes. For large applications, these message formatting tasks should be done using Prado components (e.g. using a TRepeater in the template or a custom component).

Putting It Together

Now comes to put the application flow together. In the Home.php we update the Send buttons OnClick event handler to use the application logic we just implemented.

function processMessage($sender, $param)
{
    if(strlen($this->userinput->Text) > 0)
    {
        $record = new ChatBufferRecord();
        $record->message = $this->userinput->Text;
        $record->from_user = $this->Application->User->Name;
        $record->saveMessage();

        $this->userinput->Text = '';
        $messages = $record->getUserMessages($this->Application->User->Name);
        $this->CallbackClient->appendContent("messages", $messages);
        $this->CallbackClient->focus($this->userinput);
    }
}
We simply save the message to the chat buffer and then ask for all the messages for the current user and update the client side message list using a callback response (AJAX style).

At this point the application is actually already functional, just not very user friendly. If you open two different browsers, you should be able to communicate between the two users whenever the Send button is clicked.

The next part is perhaps the more tricker and fiddly than the other tasks. We need to improve the user experience. First, we want a list of current users as well. So we add the following method to Home.php, we can call this method when ever some callback event is raised, e.g. when the Send button is clicked.

protected function refreshUserList()
{
    $lastUpdate = $this->getViewState('userList','');
    $users = ChatUserRecord::finder()->getUserList();
    if($lastUpdate != $users)
    {
        $this->CallbackClient->update('users', $users);
        $this->setViewstate('userList', $users);
    }
}

Actually, we want to periodically update the messages and user list as new users join in and new message may arrive from other users. So we need to refresh the message list as well.

function processMessage($sender, $param)
{
    ...
    $this->refreshUserList();
    $this->refreshMessageList();
    ...
}

protected function refreshMessageList()
{
    //refresh the message list
    $finder = ChatBufferRecord::finder();
    $content = $finder->getUserMessages($this->Application->User->Name);
    if(strlen($content) > 0)
    {
        $anchor = (string)time();
        $content .= "<a href=\"#\" id=\"{$anchor}\"> </a>";
        $this->CallbackClient->appendContent("messages", $content);
        $this->CallbackClient->focus($anchor);
    }
}
The anchor using time() as ID for a focus point is so that when the message list on the client side gets very long, the focus method will scroll the message list to the latest message (well, it works in most browsers).

Next, we need to redirect the user back to the login page if the user has been inactive for some time, say about 5 mins, we can add this check to any stage of the page life-cycle. Lets add it to the onLoad() stage.

public function onLoad($param)
{
    $username = $this->Application->User->Name;
    if(!$this->Application->Modules['users']->usernameExists($username))
    {
        $auth = $this->Application->Modules['auth'];
        $auth->logout();

        //redirect to login page.
        $this->Response->Redirect($this->Service->ConstructUrl($auth->LoginPage));
    }
}

Improving User Experience

The last few details are to periodically check for new messages and refresh the user list. We can accomplish this by polling the server using a TTimeTriggeredCallback control. We add a TTimeTriggeredCallback to the Home.page and call the refresh handler method defined in Home.php. We set the polling interval to 2 seconds.

<com:TTimeTriggeredCallback OnCallback="refresh"
    Interval="2" StartTimerOnLoad="true" />
function refresh($sender, $param)
{
    $this->refreshUserList();
    $this->refreshMessageList();
}

The final piece requires us to use some javascript. We want that when the user type some text in the textarea and press the Enter key, we want it to send the message without clicking on the Send button. We add to the Home.page some javascript.

<com:TClientScript>
Event.observe($("<%= $this->userinput->ClientID %>"), "keypress", function(ev)
{
    if(Event.keyCode(ev) == Event.KEY_RETURN)
    {
        if(Event.element(ev).value.length > 0)
            new Prado.Callback("<%= $this->sendButton->UniqueID %>");
        Event.stop(ev);
    }
});
</com:TClientScript>
Details regarding the javascript can be explored in the Introduction to Javascript section of the quickstart.

This completes the tutorial on making a basic chat web application using the Prado framework. Hope you have enjoyed it.

$Id: AjaxChat.page 1846 2007-04-07 10:35:16Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Command Line Tool

The optional prado-cli.php PHP script file in the framework directory provides command line tools to perform various tedious takes in Prado. The prado-cli.php can be used to create Prado project skeletons, create initial test fixtures, and access to an interactive PHP shell.

Requirements

To use the command line tool, you need to use your command prompt, command console or terminal. In addition, PHP must be able to execute PHP scripts from the command line.

Usage

If you type php path/to/framework/prado-cli.php, you should see the following information. Alternatively, if you are not on Windows, you may try to change the prado-cli.php into an executable and execute it as a script

Command line tools for Prado 3.0.5.
usage: php prado-cli.php action <parameter> [optional]
example: php prado-cli.php -c mysite

actions:
  -c <directory>
    Creates a Prado project skeleton for the given <directory>.

  -t <directory>
    Create test fixtures in the given <directory>.

  shell [directory]
    Runs a PHP interactive interpreter. Initializes the Prado
    application in the given [directory].

The <parameter> are required parameters and [optional] are optional parameters.

Creating a new Prado project skeleton

To create a Prado project skeleton, do the following:

  1. Change to the directory where you want to create the project skeleton.
  2. Type, php ../prado/framework/prado-cli.php -c helloworld, where helloworld is the directory name that you want to create the project skeleton files.
  3. Type, php ../prado/framework/prado-cli.php -t helloworld to create the test fixtures for the helloworld project.

Interactive Shell

The interactive shell allows you to evaluate PHP statements from the command line. The prado-cli.php script can be used to start the shell and load an existing Prado project. For example, let us load the blog demo project. Assume that your command line is in the prado distribution directory and you type.

$: php framework/prado-cli.php shell demos/blog
The output should be
Command line tools for Prado 3.0.5.
** Loaded Prado application in directory "demos\blog\protected".
PHP-Shell - Version 0.3.1
(c) 2006, Jan Kneschke <jan@kneschke.de>

>> use '?' to open the inline help

>>
Then we will get an instance of the Prado blog application, and from that instance we want an instance of the 'data' module. Notice that a semicolon at the end of the line suppresses the output.
>> $app = Prado::getApplication();

>> $db = $app->getModule('data');
Lastly, we want to use the data module to query for a post with ID=1. Notice that we leave out the semicolon to show the results.
>> $db->queryPostByID(1)
There should not be any errors and you should see the following.
PostRecord#1
(
    [ID] => 1
    [AuthorID] => 1
    [AuthorName] => 'Prado User'
    [CreateTime] => 1148819691
    [ModifyTime] => 0
    [Title] => 'Welcome to Prado Weblog'
    [Content] => 'Congratulations! You have successfully installed Prado Blog --
 a PRADO-driven weblog system. A default administrator account has been created.
 Please login with <b>admin/prado</b> and update your password as soon as possible.'
    [Status] => 0
    [CommentCount] => 0
)

$Id: CommandLine.page 1927 2007-05-10 23:00:04Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Architecture

PRADO is primarily a presentational framework, although it is not limited to be so. The framework focuses on making Web programming, which deals most of the time with user interactions, to be component-based and event-driven so that developers can be more productive. The following class tree depicts some of the major classes provided by PRADO,

When a PRADO application is processing a page request, its static object diagram can be shown as follows,

$Id: Architecture.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Components

A component is an instance of TComponent or its child class. The base class TComponent implements the mechanism of component properties and events.

Component Properties

A component property can be viewed as a public variable describing a specific aspect of the component, such as the background color, the font size, etc. A property is defined by the existence of a getter and/or a setter method in the component class. For example, in TControl, we define its ID property using the following getter and setter methods,

class TControl extends TComponent {
    public function getID() {
        ...
    }
    public function setID($value) {
        ...
    }
}

To get or set the ID property, do as follows, just like working with a variable,

$id = $component->ID;
$component->ID = $id;
This is equivalent to the following,
$id = $component->getID();
$component->setID( $id );

A property is read-only if it has a getter method but no setter method. Since PHP method names are case-insensitive, property names are also case-insensitive. A component class inherits all its ancestor classes' properties.

Subproperties

A subproperty is a property of some object-typed property. For example, TWebControl has a Font property which is of TFont type. Then the Name property of Font is referred to as a subproperty (with respect to TWebControl).

To get or set the Name subproperty, use the following method,

$name = $component->getSubProperty('Font.Name');
$component->setSubProperty('Font.Name', $name);
This is equivalent to the following,
$name = $component->getFont()->getName();
$component->getFont()->setName( $name );

Component Events

Component events are special properties that take method names as their values. Attaching (setting) a method to an event will hook up the method to the places at which the event is raised. Therefore, the behavior of a component can be modified in a way that may not be foreseen during the development of the component.

A component event is defined by the existence of a method whose name starts with the word on. The event name is the method name and is thus case-insensitve. For example, in TButton, we have

class TButton extends TWebControl {
    public function onClick( $param ) {
        ...
    }
}
This defines an event named OnClick, and a handler can be attached to the event using one of the following ways,
$button->OnClick = $callback;
$button->OnClick->add( $callback );
$button->OnClick[] = $callback;
$button->attachEventHandler( 'OnClick' , $callback );
where $callback refers to a valid PHP callback (e.g. a function name, a class method array($object,'method'), etc.)

Namespaces

A namespace refers to a logical grouping of some class names so that they can be differentiated from other class names even if their names are the same. Since PHP does not support namespace intrinsically, you cannot create instances of two classes who have the same name but with different definitions. To differentiate from user defined classes, all PRADO classes are prefixed with a letter 'T' (meaning 'Type'). Users are advised not to name their classes like this. Instead, they may prefix their class names with any other letter(s).

A namespace in PRADO is considered as a directory containing one or several class files. A class may be specified without ambiguity using such a namespace followed by the class name. Each namespace in PRADO is specified in the following format,

PathAlias.Dir1.Dir2
where PathAlias is an alias of some directory, while Dir1 and Dir2 are subdirectories under that directory. A class named MyClass defined under Dir2 may now be fully qualified as PathAlias.Dir1.Dir2.MyClass.

To use a namespace in code, do as follows,

Prado::using('PathAlias.Dir1.Dir2.*');
which appends the directory referred to by PathAlias.Dir1.Dir2 into PHP include path so that classes defined under that directory may be instantiated without the namespace prefix. You may also include an individual class definition by
Prado::using('PathAlias.Dir1.Dir2.MyClass');
which will include the class file if MyClass is not defined.

For more details about defining path aliases, see application configuration section.

Component Instantiation

Component instantiation means creating instances of component classes. There are two types of component instantation: static instantiation and dynamic instantiation. The created components are called static components and dynamic components, respectively.

Dynamic Component Instantiation

Dynamic component instantiation means creating component instances in PHP code. It is the same as the commonly referred object creation in PHP. A component can be dynamically created using one of the following two methods in PHP,

$component = new ComponentClassName;
$component = Prado::createComponent('ComponentType');
where ComponentType refers to a class name or a type name in namespace format (e.g. System.Web.UI.TControl). The second approach is introduced to compensate for the lack of namespace support in PHP.

Static Component Instantiation

Static component instantiation is about creating components via templates. Every component tag in a template specifies a component that will be automatically created by the framework when the template is loaded. For example, in a page template, the following tag will lead to the creation of a TButton component on the page,

<com:TButton Text="Register" />

$Id: Components.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Controls

A control is an instance of class TControl or its subclass. A control is a component defined in addition with user interface. The base class TControl defines the parent-child relationship among controls which reflects the containment relationship among user interface elements.

Control Tree

Controls are related to each other via parent-child relationship. Each parent control can have one or several child controls. A parent control is in charge of the state transition of its child controls. The rendering result of the child controls are usually used to compose the parent control's presentation. The parent-child relationship brings together controls into a control tree. A page is at the root of the tree, whose presentation is returned to the end-users.

The parent-child relationship is usually established by the framework via templates. In code, you may explicitly specify a control as a child of another using one of the following methods,

$parent->Controls->add($child);
$parent->Controls[]=$child;
where the property Controls refers to the child control collection of the parent.

Control Identification

Each control has an ID property that can be uniquely identify itself among its sibling controls. In addition, each control has a UniqueID and a ClientID which can be used to globally identify the control in the tree that the control resides in. UniqueID and ClientID are very similar. The former is used by the framework to determine the location of the corresponding control in the tree, while the latter is mainly used on the client side as HTML tag IDs. In general, you should not rely on the explicit format of UniqueID or ClientID.

Naming Containers

Each control has a naming container which is a control creating a unique namespace for differentiating between controls with the same ID. For example, a TRepeater control creates multiple items each having child controls with the same IDs. To differentiate these child controls, each item serves as a naming container. Therefore, a child control may be uniquely identified using its naming container's ID together with its own ID. As you may already have understood, UniqueID and ClientID rely on the naming containers.

A control can serve as a naming container if it implements the INamingContainer interface.

ViewState and ControlState

HTTP is a stateless protocol, meaning it does not provide functionality to support continuing interaction between a user and a server. Each request is considered as discrete and independent of each other. A Web application, however, often needs to know what a user has done in previous requests. People thus introduce sessions to help remember such state information.

PRADO borrows the viewstate and controlstate concept from Microsoft ASP.NET to provides additional stateful programming mechanism. A value storing in viewstate or controlstate may be available to the next requests if the new requests are form submissions (called postback) to the same page by the same user. The difference between viewstate and controlstate is that the former can be disabled while the latter cannot.

Viewstate and controlstate are implemented in TControl. They are commonly used to define various properties of controls. To save and retrieve values from viewstate or controlstate, use following methods,

$this->getViewState('Name',$defaultValue);
$this->setViewState('Name',$value,$defaultValue);
$this->getControlState('Name',$defaultValue);
$this->setControlState('Name',$value,$defaultValue);
where $this refers to the control instance, Name refers to a key identifying the persistent value, $defaultValue is optional. When retrieving values from viewstate or controlstate, if the corresponding key does not exist, the default value will be returned.

$Id: Controls.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Pages

Pages are top-most controls that have no parent. The presentation of pages are directly displayed to end-users. Users access pages by sending page service requests.

Each page must have a template file. The file name suffix must be .page. The file name (without suffix) is the page name. PRADO will try to locate a page class file under the directory containing the page template file. Such a page class file must have the same file name (suffixed with .php) as the template file. If the class file is not found, the page will take class TPage.

PostBack

A form submission is called postback if the submission is made to the page containing the form. Postback can be considered an event happened on the client side, raised by the user. PRADO will try to identify which control on the server side is responsible for a postback event. If one is determined, for example, a TButton, we call it the postback event sender which will translate the postback event into some specific server-side event (e.g. OnClick and OnCommand events for TButton).

Page Lifecycles

Understanding the page lifecycles is crucial to grasp PRADO programming. Page lifecycles refer to the state transitions of a page when serving this page to end-users. They can be depicted in the following statechart,

$Id: Pages.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Modules

A module is an instance of a class implementing the IModule interface. A module is commonly designed to provide specific functionality that may be plugged into a PRADO application and shared by all components in the application.

PRADO uses configurations to specify whether to load a module, load what kind of modules, and how to initialize the loaded modules. Developers may replace the core modules with their own implementations via application configuration, or they may write new modules to provide additional functionalities. For example, a module may be developed to provide common database logic for one or several pages. For more details, please see the configurations.

There are three core modules that are loaded by default whenever an application runs. They are request module, response module, and error handler module. In addition, session module is loaded when it is used in the application. PRADO provides default implementation for all these modules. Custom modules may be configured or developed to override or supplement these core modules.

Request Module

Request module represents provides storage and access scheme for user request sent via HTTP. User request data comes from several sources, including URL, post data, session data, cookie data, etc. These data can all be accessed via the request module. By default, PRADO uses THttpRequest as request module. The request module can be accessed via the Request property of application and controls.

Response Module

Response module implements the mechanism for sending output to client users. Response module may be configured to control how output are cached on the client side. It may also be used to send cookies back to the client side. By default, PRADO uses THttpResponse as response module. The response module can be accessed via the Response property of application and controls.

Session Module

Session module encapsulates the functionalities related with user session handling. Session module is automatically loaded when an application uses session. By default, PRADO uses THttpSession as session module, which is a simple wrapper of the session functions provided by PHP. The session module can be accessed via the Session property of application and controls.

Error Handler Module

Error handler module is used to capture and process all error conditions in an application. PRADO uses TErrorHandler as error handler module. It captures all PHP warnings, notices and exceptions, and displays in an appropriate form to end-users. The error handler module can be accessed via the ErrorHandler property of the application instance.

Custom Modules

PRADO is released with a few more modules besides the core ones. They include caching modules (TSqliteCache and TMemCache), user management module (TUserManager), authentication and authorization module (TAuthManager), etc.

When TPageService is requested, it also loads modules specific for page service, including asset manager (TAssetManager), template manager (TTemplateManager), theme/skin manager (TThemeManager).

Custom modules and core modules are all configurable via configurations.

$Id: Modules.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Services

A service is an instance of a class implementing the IService interface. Each kind of service processes a specific type of user requests. For example, the page service responds to users' requests for PRADO pages.

A service is uniquely identified by its ID property. By default when THttpRequest is used as the request module, GET variable names are used to identify which service a user is requesting. If a GET variable name is equal to some service ID, the request is considered for that service, and the value of the GET variable is passed as the service parameter. For page service, the name of the GET variable must be page. For example, the following URL requests for the Fundamentals.Services page,

http://hostname/index.php?page=Fundamentals.Services

Developers may implement additional services for their applications. To make a service available, configure it in application configurations.

Page Service

PRADO implements TPageService to process users' page requests. Pages are stored under a directory specified by the BasePath property of the page service. The property defaults to pages directory under the application base path. You may change this default by configuring the service in the application configuration.

Pages may be organized into subdirectories under the BasePath. In each directory, there may be a page configuration file named config.xml, which contains configurations effective only when a page under that directory or a sub-directory is requested. For more details, see the page configuration section.

Service parameter for the page service refers to the page being requested. A parameter like Fundamentals.Services refers to the Services page under the <BasePath>/Fundamentals directory. If such a parameter is absent in a request, a default page named Home is assumed. Using THttpRequest as the request module (default), the following URLs will request for Home, About and Register pages, respectively,

http://hostname/index.php
http://hostname/index.php?page=About
http://hostname/index.php?page=Users.Register
where the first example takes advantage of the fact that the page service is the default service and Home is the default page.

$Id: Services.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Applications

An application is an instance of TApplication or its derived class. It manages modules that provide different functionalities and are loaded when needed. It provides services to end-users. It is the central place to store various parameters used in an application. In a PRADO application, the application instance is the only object that is globally accessible via Prado::getApplication() function call.

Applications are configured via application configurations. They are usually created in entry scripts like the following,

require_once('/path/to/prado.php');
$application = new TApplication;
$application->run();
where the method run() starts the application to handle user requests.

Directory Organization

A minimal PRADO application contains two files: an entry file and a page template file. They must be organized as follows,

  • wwwroot - Web document root or sub-directory.
  • index.php - entry script of the PRADO application.
  • assets - directory storing published private files. See assets section.
  • protected - application base path storing application data and private script files. This directory should be configured inaccessible to Web-inaccessible, or it may be located outside of Web directories.
  • runtime - application runtime storage path. This directory is used by PRADO to store application runtime information, such as application state, cached data, etc.
  • pages - base path storing all PRADO pages. See services section.
  • Home.page - default page returned when users do not explicitly specify the page requested. This is a page template file. The file name without suffix is the page name. The page class is TPage. If there is also a class file Home.php, the page class becomes Home.

A product PRADO application usually needs more files. It may include an application configuration file named application.xml under the application base path protected. The pages may be organized in directories, some of which may contain page configuration files named config.xml. Fore more details, please see configurations section.

Application Deployment

Deploying a PRADO application mainly involves copying directories. For example, to deploy the above minimal application to another server, follow the following steps,

  1. Copy the content under wwwroot to a Web-accessible directory on the new server.
  2. Modify the entry script file index.php so that it includes correctly the prado.php file.
  3. Remove all content under assets and runtime directories and make sure both directories are writable by the Web server process.

Application Lifecycles

Like page lifecycles, an application also has lifecycles. Application modules can register for the lifecycle events. When the application reaches a particular lifecycle and raises the corresponding event, the registered module methods are invoked automatically. Modules included in the PRADO release, such as TAuthManager, are using this way to accomplish their goals.

The application lifecycles can be depicted as follows,

$Id: Applications.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Configuration Overview

PRADO uses configurations to glue together components into pages and applications. There are templates.

Application and page configurations are optional if default values are used. Templates are mainly used by pages and template controls. They are optional, too.

$Id: Overview.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Templates: Part I

Templates are used to specify the presentational layout of controls. A template can contain static text, components, or controls that contribute to the ultimate presentation of the associated control. By default, an instance of TTemplateControl or its subclass may automatically load and instantiate a template from a file whose name is the same as the control class name. For page templates, the file name suffix must be .page; for other regular template controls, the suffix is .tpl.

The template format is like HTML, with a few PRADO-specifc tags, including dynamic property tags. .

Component Tags

A component tag specifies a component as part of the body content of the template control. If the component is a control, it usually will become a child or grand child of the template control, and its rendering result will be inserted at the place where it is appearing in the template.

The format of a component tag is as follows,

<com:ComponentType PropertyName="PropertyValue" ... EventName="EventHandler" ...>
body content
</com:ComponentType>
ComponentType can be either the class name or the dotted type name (e.g. System.Web.UI.TControl) of the component. PropertyName and EventName are both case-insensitive. PropertyName can be a property or subproperty name (e.g. Font.Name). Note, PropertyValue will be HTML-decoded when assigned to the corresponding property. Content enclosed between the opening and closing component tag are normally treated the body of the component.

It is required that component tags nest properly with each other and an opening component tag be paired with a closing tag, similar to that in XML.

The following template shows a component tag specifying the Text property and OnClick event of a button control,

<com:TButton Text="Register" OnClick="registerUser" />
Note, property names and event names are all case-insensitive, while component type names are case-sensitive. Event names always begin with On.

Also note, initial values for properties whose name ends with Template are specially processed. In particular, the initial values are parsed as TTemplate objects. The ItemTemplate property of the TRepeater control is such an example.

To facilitate initializing properties with big trunk of data, the following property initialization tag is introduced. It is equivalent to ...PropertyName="PropertyValue"... in every aspect. Property initialization tags must be directly enclosed between the corresponding opening and closing component tag.

<prop:PropertyName>
PropertyValue
</prop:PropertyName>

Since version 3.1.0, the property initialization tag can also be used to initialize a set of subproperties who share the same parent property. For example, the following is equivalent to HeaderStyle.BackColor="black" and HeaderStyle.ForeColor="red".

<prop:HeaderStyle BackColor="black" ForeColor="red" />

Component IDs

When specified in templates, component ID property has special meaning in addition to its normal property definition. A component tag specified with an ID value in template will register the corresponding component to the template owner control. The component can thus be directly accessed from the template control with its ID value. For example, in Home page's template, the following component tag

<com:TTextBox ID="TextBox" Text="First Name" />
makes it possible to get the textbox object in code using $page->TextBox.

Template Control Tags

A template control tag is used to configure the initial property values of the control owning the template. Its format is as follows,
<%@ PropertyName="PropertyValue" ... %>
Like in component tags, PropertyName is case-insensitive and can be a property or subproperty name.

Initial values specified via the template control tag are assigned to the corresponding properties when the template control is being constructed. Therefore, you may override these property values in a later stage, such as the Init stage of the control.

Template control tag is optional in a template. Each template can contain at most one template control tag. You can place the template control tag anywhere in the template. It is recommended that you place it at the beginning of the template for better visibility.

Comment Tags

Comment tags are used to put in a template developer comments that will not display to end-users. Contents enclosed within a comment tag will be treated as raw text strings and PRADO will not attempt to parse them. Comment tags cannot be used within property values. The format of comment tags is as follows,

<!---
Comments INVISIBLE to end-users
--->
Note: The new comment tag <!--- ... ---> has been introduced since PRADO version 3.1. Previously, it was <!-- ... --!> which was deprecated because some editors have problems in syntax-highlighting such tags.

Include Tags

Since version 3.0.5, PRADO starts to support external template inclusion. This is accomplished via include tags, where external template files are specified in namespace format and their file name must be terminated as .tpl.

<%include path.to.templateFile %>

External templates will be inserted at the places where the include tags occur in the base template.

Note, nested template inclusion is not supported, i.e., you cannot have include tags in an external template.

$Id: Templates1.page 1902 2007-05-07 04:17:37Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Templates: Part II

Dynamic Content Tags

Dynamic content tags are introduced as shortcuts to some commonly used component tags. These tags are mainly used to render contents resulted from evaluating some PHP expressions or statements. They include expression tags, statement tags, databind tags, parameter tags, asset tags and localization tags.

Expression Tags

An expression tag represents a PHP expression that is evaluated when the template control is in PreRender stage. The expression evaluation result is inserted at the place where the tag resides in the template. The context (namely $this) of the expression is the control owning the template.

The format of an expression tag is as follows,

<%= PhpExpression %>

For example, the following expression tag will display the current page title at the place,

<%= $this->Title %>

Statement Tags

Statement tags are similar to expression tags, except that statement tags contain PHP statements rather than expressions. The output of the PHP statements (using for example echo or print in PHP) are displayed at the place where the statement tag resides in the template. The context (namely $this) of the statements is the control owning the template. The format of statement tags is as follows,

<%%
PHP Statements
%>

The following example displays the current time in Dutch at the place,

<%%
setlocale(LC_ALL, 'nl_NL');
echo strftime("%A %e %B %Y",time());
%>

Databind Tags

Databind tags are similar to expression tags, except that the expressions are evaluated only when a dataBind() call is invoked on the controls representing the databind tags. The context (namely $this) of a databind expression is the control owning the template. The format of databind tags is as follows,

<%# PhpExpression %>

Parameter Tags

Parameter tags are used to insert application parameters at the place where they appear in the template. The format of parameter tags is as follows,

<%$ ParameterName %>

Note, application parameters are usually defined in application configurations or page directory configurations. The parameters are evaluated when the template is instantiated.

Asset Tags

Asset tags are used to publish private files and display the corresponding the URLs. For example, if you have an image file that is not Web-accessible and you want to make it visible to end-users, you can use asset tags to publish this file and show the URL to end-users so that they can fetch the published image.

The format of asset tags is as follows,

<%~ LocalFileName %>

where LocalFileName refers to a file path that is relative to the directory containing the current template file. The file path can be a single file or a directory. If the latter, the content in the whole directory will be made accessible by end-users.

BE VERY CAUTIOUS when you are using asset tags as it may expose to end-users files that you probably do not want them to see.

Localization Tags

Localization tags represent localized texts. They are in the following format,

<%[string]%>

where string will be translated to different languages according to the end-user's language preference. Localization tags are in fact shortcuts to the function call Prado::localize(string).

URL Tags

URL tags are used to insert the relative web url path to the Prado application in the template. You can use it in the following format:

<%/ image.jpg %>

If your Prado application is deployed on http://localhost/pradoapp/, the tag above will produce "/pradoapp/image.jpg". This tag will help you to use the correct file path even with UrlFormat set to Path, or if you are using url mappings.

$Id: Templates2.page 2568 2008-11-13 11:27:44Z carlgmathisen $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Templates: Part III

Dynamic Property Tags

Dynamic property tags are very similar to dynamic content tags, except that they are applied to component properties. The purpose of dynamic property tags is to allow more versatile component property configuration. Note, you are not required to use dynamic property tags because what can be done using dynamic property tags can also be done in PHP code. However, using dynamic property tags bring you much more convenience at accomplishing the same tasks. The basic usage of dynamic property tags is as follows,

<com:ComponentType PropertyName=DynamicPropertyTag ...>
body content
</com:ComponentType>

where you may enclose DynamicPropertyTag within single or double quotes for better readability.

Like dynamic content tags, we have expression tags, databind tags, parameter tags, asset tags and localization tags. (Note, there is no statement tag here.)

Expression Tags

An expression tag represents a PHP expression that is evaluated when the control is in PreRender stage. The expression evaluation result is assigned to the corresponding component property. The format of expression tags is as follows,

<%= PhpExpression %>

In the expression, $this refers to the control owning the template. The following example specifies a TLabel control whose Text property is initialized as the current page title when the TLabel control is being constructed,

<com:TLabel Text=<%= $this->Page->Title %> />

Databind Tags

Databind tags are similar to expression tags, except that they can only be used with control properties and the expressions are evaluated only when a dataBind() call is invoked on the controls represented by the component tags. In the expression, $this refers to the control owning the template. Databind tags do not apply to all components. They can only be used for controls.

The format of databind tags is as follows,

<%# PhpExpression %>

Since v3.0.2, expression tags and databind tags can be embedded within static strings. For example, you can write the following in a template,

<com:TLabel>
  <prop:Text>
  Today is <%= date('F d, Y',time()) %>.
  The page class is <%= get_class($this) %>.
  </prop:Text>
</com:TLabel>

Previously, you would have to use a single expression with string concatenations to achieve the same effect.

Parameter Tags

Parameter tags are used to assign application parameter values to the corresponding component properties. The format of parameter tags is as follows,

<%$ ParameterName %>

Note, application parameters are usually defined in application configurations or page directory configurations. The parameters are evaluated when the template is instantiated.

Asset Tags

Asset tags are used to publish private files and assign the corresponding the URLs to the component properties. For example, if you have an image file that is not Web-accessible and you want to make it visible to end-users, you can use asset tags to publish this file and show the URL to end-users so that they can fetch the published image. The asset tags are evaluated when the template is instantiated.

The format of asset tags is as follows,

<%~ LocalFileName %>

where LocalFileName refers to a file path that is relative to the directory containing the current template file. The file path can be a single file or a directory. If the latter, the content in the whole directory will be made accessible by end-users.

BE VERY CAUTIOUS when you are using asset tags as it may expose to end-users files that you probably do not want them to see.

Localization Tags

Localization tags represent localized texts. They are in the following format,

<%[string]%>

where string will be translated to different languages according to the end-user's language preference. The localization tags are evaluated when the template is instantiated. Localization tags are in fact shortcuts to the function call Prado::localize(string).

$Id: Templates3.page 2036 2007-06-26 17:12:54Z xue $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Application Configurations

Application configurations are used to specify the global behavior of an application. They include specification of path aliases, namespace usages, module and service configurations, and parameters.

Configuration for an application is stored in an XML file named application.xml, which should be located under the application base path. Its format is shown in the following. Complete specification of application configurations can be found in the DTD and XSD files.

<application PropertyName="PropertyValue" ...>
  <paths>
    <alias id="AliasID" path="AliasPath" />
    <using namespace="Namespace" />
  </paths>
  <modules>
    <module id="ModuleID" class="ModuleClass"  PropertyName="PropertyValue" ... />
  </modules>
  <parameters>
    <parameter id="ParameterID" class="ParameterClass" PropertyName="PropertyValue" ... />
  </parameters>
  <include file="path.to.extconfig" when="PHP expression" />
  <services>
    <service id="ServiceID" class="ServiceClass" PropertyName="PropertyValue" ... />
  </services>
</application>
  • The outermost element <application> corresponds to the TApplication instance. The PropertyName="PropertyValue" pairs specify the initial values for the properties of TApplication.
  • The <paths> element contains the definition of path aliases and the PHP inclusion paths for the application. Each path alias is specified via an <alias> whose path attribute takes an absolute path or a path relative to the directory containing the application configuration file. The <using> element specifies a particular path (in terms of namespace) to be appended to the PHP include paths when the application runs. PRADO defines two default aliases: System and Application. The former refers to the PRADO framework root directory, and the latter refers to the directory containing the application configuration file.
  • The <modules> element contains the configurations for a list of modules. Each module is specified by a <module> element. Each module is uniquely identified by the id attribute and is of type class. The PropertyName="PropertyValue" pairs specify the initial values for the properties of the module.
  • The <parameters> element contains a list of application-level parameters that are accessible from anywhere in the application. You may specify component-typed parameters like specifying modules, or you may specify string-typed parameters which take a simpler format as follows,
    <parameter id="ParameterID" value="ParameterValue" />
    Note, if the value attribute is not specified, the whole parameter XML node (of type TXmlElement) will be returned as the parameter value. In addition, the System.Util.TParameterModule module provides a way to load parameters from an external XML file. See more details in its API documentation.
  • The <include> element allows one to include external configuration files. It has been introduced since v3.1.0. The file attribute specifies the external configuration file in namespace format. The extension name of the file must be .xml. The when attribute contains a PHP expression and is optional (defaults to true). Only when the expression evaluates true, will the external configuration file be included. The context of the expression is the application, i.e., $this in the expression would refer to the application object.
  • The <services> element is similar to the <modules> element. It mainly specifies the services provided by the application. Within a <service> element, one can have any of the above elements. They will be effective only when the corresponding service is being requested.

An external configuration file has the same format as described above. Although the name of the root element does not matter, it is recommended to be <configuration>. External configurations will append to the main configuration. For example, if a path alias is specified in an external configuration, it will become available in addition to those aliases specified in the main configuration.

By default without explicit configuration, a PRADO application will load a few core modules, such as THttpRequest, THttpResponse, etc. It will also provide the TPageService as a default service. Configuration and usage of these modules and services are covered in individual sections of this tutorial. Note, if your application takes default settings for these modules and service, you do not need to provide an application configuration. However, if these modules or services are not sufficient, or you want to change their behavior by configuring their property values, you will need an application configuration.

$Id: AppConfig.page 1695 2007-02-13 14:16:09Z xue $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Page Configurations

Page configurations are mainly used by TPageService to modify or append the application configuration. As the name indicates, a page configuration is associated with a directory storing some page files. It is stored as an XML file named config.xml.

When a user requests a page stored under <BasePath>/dir1/dir2, the TPageService will try to parse and load config.xml files under <BasePath>, <BasePath>/dir1 and <BasePath>/dir1/dir2. Paths, modules, and parameters specified in these configuration files will be appended or merged into the existing application configuration. Here <BasePath> is as defined in page service.

The format of a page configuration file is as follows,

<configuration>
  <paths>
    <alias id="AliasID" path="AliasPath" />
    <using namespace="Namespace" />
  </paths>
  <modules>
    <module id="ModuleID" class="ModuleClass"  PropertyName="PropertyValue" ... />
  </modules>
  <parameters>
    <parameter id="ParameterID" class="ParameterClass" PropertyName="PropertyValue" ... />
  </parameters>
  <include file="path.to.extconfig" when="PHP expression" />
  <authorization>
    <allow pages="PageID1,PageID2" users="User1,User2" roles="Role1,Role2" verb="get" />
    <deny pages="PageID1,PageID2" users="User1,User2" roles="Role1,Role2" verb="post" />
  </authorization>
  <pages PropertyName="PropertyValue" ...>
    <page id="PageID" PropertyName="PropertyValue" ... />
  </pages>
</configuration>

The <paths>, <modules>, <parameters> and <include> are similar to those in an application configuration. The <authorization> element specifies the authorization rules that apply to the current page directory and all its subdirectories. For more details, see authentication and authorization section. The <pages> element specifies the initial values for the properties of pages. Each <page> element specifies the initial property values for a particular page identified by the id attribute. Initial property values given in the <pages> element apply to all pages in the current directory and all its subdirectories.

Complete specification of page configurations can be found in the DTD and XSD files.

Available from Prado versions 3.1.1 onwards.

Since version 3.1.1, the id attribute in the <page> element can be a relative page path pointing to a page in the subdirectory of the directory containing the page configuration. For example, id="admin.Home" refers to the Home page under the admin directory. The id attribute can also contain wildcard '*' to match all pages under the specified directory. For example, id="admin.*" refers to all pages under the admin directory and its subdirectories. This enhancement allows developers to centralize their page configurations (e.g. put all page initializations in the aplication configuration or the root page configuration.)

$Id: PageConfig.page 2214 2007-09-11 13:01:29Z xue $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

URL Mapping (Friendly URLs)

API Manual

The TUrlMapping module allows PRADO to construct and recognize friendly URLs based on specific patterns.

TUrlMapping consists of a list of URL patterns which are used to match against the currently requested URL. The first matching pattern will then be used to decompose the URL into request parameters (accessible via $this->Request['paramname']). The patterns can also be used to construct customized URLs. In this case, the parameters in an applied pattern will be replaced with the corresponding GET variable values.

To use TUrlMapping, one must set the UrlManager property of the THttpRequest module as the TUrlMapping module ID. See following for an example,

<modules>
    <module id="request" class="THttpRequest" UrlManager="friendly-url" />
    <module id="friendly-url" class="System.Web.TUrlMapping">
        <url ServiceParameter="Posts.ViewPost" pattern="post/{id}/" parameters.id="\d+" />
        <url ServiceParameter="Posts.ListPost" pattern="archive/{time}/" parameters.time="\d{6}" />
        <url ServiceParameter="Posts.ListPost" pattern="category/{cat}/" parameters.cat="\d+" />
    </module>
</modules>

The above example is part of the application configuration of the blog demo in the PRADO release. It enables recognition of the following URL formats:

  • /index.php/post/123 is recognized as /index.php?page=Posts.ViewPost&id=123
  • /index.php/archive/200605 is recognized as /index.php?page=Posts.ListPost&time=200605
  • /index.php/category/2 is recognized as /index.php?page=Posts.ListPost&cat=2

The ServiceParameter and ServiceID (the default ID is 'page') set the service parameter and service ID, respectively, of the Services for further details.

Info: The TUrlMapping must be configured before the request module resolves the request. This means delcaring the TUrlMapping outside of the <services> element in the application configuration. Specifying the mappings in the per directory config.xml is not supported.

Specifying URL Patterns

TUrlMapping enables recognition of customized URL formats based on a list prespecified of URL patterns. Each pattern is specified in a <url> tag.

The Pattern and Parameters attribute values are regular expression patterns that determine the mapping criteria. The Pattern property takes a regular expression with parameter names enclosed between a left brace '{' and a right brace '}'. The patterns for each parameter can be set using Parameters attribute collection. For example,

<url ServiceParameter="ArticleView" pattern="articles/{year}/{month}/{day}"
     parameters.year="\d{4}" parameters.month="\d{2}" parameters.day="\d+" />

The example is equivalent to the following regular expression (it uses the "named group" feature in regular expressions available in PHP):
<url ServiceParameter="ArticleView"
     RegularExpression="/articles\/(?P<year>\d{4})\/(?P<month>\d{2})\/(?P<day>\d+)/u" />

In the above example, the pattern contains 3 parameters named "year", "month" and "day". The pattern for these parameters are, respectively, "\d{4}" (4 digits), "\d{2}" (2 digits) and "\d+" (1 or more digits). Essentially, the Parameters attribute name and values are used as substrings in replacing the placeholders in the Pattern string to form a complete regular expression string.

Note: If you intended to use the RegularExpression property you need to escape the slash in regular expressions.

Following from the above pattern example, an URL http://example.com/index.php/articles/2006/07/21 will be matched and valid. However, http://example.com/index.php/articles/2006/07/hello is not valid since the day parameter pattern is not satisfied. In the default TUrlMappingPattern class, the pattern is matched against the PATH_INFO part of the URL only. For example, only the /articles/2006/07/21 portion of the URL is considered.

The mapped request URL is equivalent to index.php?page=ArticleView&year=2006&month=07&day=21. The request parameter values are available through the standard Request object. For example, $this->Request['year'].

The URL mapping are evaluated in order they are placed and only the first pattern that matches the URL will be used. Cascaded mapping can be achieved by placing the URL mappings in particular order. For example, placing the most specific mappings first.

Since version 3.1.4, Prado also provides wildcard patterns to use friendly URLs for a bunch of pages in a directory with a single rule. Therefore you can use the {*} wildcard in your pattern to let Prado know, where to find the ServiceID in your request URL. You can also specify parameters with these patterns if a lot of pages share common parameters.

<url ServiceParameter="Posts.*" pattern="posts/{*}/{id}" parameters.id="\d+" />
<url ServiceParameter="Posts.*" pattern="posts/{*}" />
<url ServiceParameter="Static.Info.*" pattern="info/{*}" />

With these rules, any of the following URLs will be recognized:

  • /index.php/post/ViewPost/123 is recognized as /index.php?page=Posts.ViewPost&id=123
  • /index.php/post/ListPost/123 is recognized as /index.php?page=Posts.ListPost&id=123
  • /index.php/post/ListPost/123 is recognized as /index.php?page=Posts.ListPost&id=123
  • /index.php/post/MyPost is recognized as /index.php?page=Posts.MyPost
  • /index.php/info/Conditions is recognized as /index.php?page=Static.Info.Conditions
  • /index.php/info/About is recognized as /index.php?page=Static.Info.About

As above, put more specific rules before more common rules as the first matching rule will be used.

To make configuration of friendly URLs for multiple pages even easier, you can also use UrlFormat="Path" in combination with wildcard patterns. In fact, this feature only is available in combination with wildcard rules:

<url ServiceParameter="user.admin.*" pattern="admin/{*}" UrlFormat="Path"/>
<url ServiceParameter="*" pattern="{*}" UrlFormat="Path" />

Parameters will get appended to the specified patterns as name/value pairs, separated by a "/". (You can change the separator character with UrlParamSeparator.)

  • /index.php/list/cat/15/month/12 is recognized as /index.php?page=list&cat=15&month=12
  • /index.php/edit/id/12 is recognized as /index.php?page=list&id=12
  • /index.php/show/name/foo is recognized as /index.php?page=show&name=foo
  • /index.php/admin/edit/id/12 is recognized as /index.php?page=user.admin.edit&id=12

Constructing Customized URLs

Since version 3.1.1, TUrlMapping starts to support constructing customized URLs based on the provided patterns. To enable this feature, set TUrlMapping.EnableCustomUrl to true. When THttpRequest.constrcutUrl() is invoked, the actual URL construction work will be delegated to a matching TUrlMappingPattern instance. It replaces the parameters in the pattern with the corresponding GET variables passed to constructUrl().

A matching pattern is one whose ServiceID and ServiceParameter properties are the same as those passed to constructUrl() and whose named parameters are found in the GET variables. For example, constructUrl('Posts.ListPost',array('cat'=>2)) will use the third pattern in the above example.

By default, TUrlMapping will construct URLs prefixed with the currently requesting PHP script path, such as /path/to/index.php/article/3. Users may change this behavior by explicitly specifying the URL prefix through its UrlPrefix property. For example, if the Web server configuration treats index.php as the default script, we can set UrlPrefix as /path/to and the constructed URL will look like /path/to/article/3.

Note: If you use constructUrl() with string parameters that contain slashes ("/") they will get encoded to %2F. By default most Apache installations give a "404 Not found" if a URL contains a %2F. You can add AllowEncodedSlashes On to your VirtualHost configuration to resolve this. (Available since Apache 2.0.46).
$Id: UrlMapping.page 2601 2009-01-09 09:55:01Z haertl.mike $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Standard Controls

* the tutorial for this control is not completed yet.

  • TButton represents a click button on a Web page. It is mainly used to trigger page postback.
  • TCaptcha displays a CAPTCHA to keep spammers from signing up for certain accounts online.
  • TCheckBox represents a checkbox on a Web page. It can be used to collect two-state user input.
  • TClientScript adds javascript code to the page.
  • TClientScriptLoader loads custom javascript libraries.
  • * TColorPicker represents an input field taking color values via a color dialog.
  • TConditional displays content corresponding to true or false result of a PHP expression.
  • TDatePicker represents an input field taking date values via a calendar dialog.
  • TExpression accepts a PHP expression and displays the evaluation result on a Web page.
  • TFileUpload represents a file upload field. It allows users to upload a file to server.
  • * THead represents the <head> element on an HTML Web page. It is required by a PRADO page should it use themes.
  • THiddenField represents a hidden input field on a Web page.
  • THtmlArea represents a WYSIWYG text input field taking user input that are in HTML format.
  • THyperLink represents a hyperlink on a Web page.
  • TImage represents an image on a Web page.
  • TImageButton represents a click button that has an image as the background. It is mainly used to trigger page postback.
  • TImageMap represents an image on a Web page with clickable hotspot regions.
  • TInlineFrame represents an <iframe> HTML element on a Web page.
  • TJavascriptLogger represents a logger on a Web page that can log various JavaScript information.
  • TKeyboard displays a virtual keyboard for users to enter input into a text box.
  • TLabel represents a label on a Web page. The label can be customized via various CSS attributes.
  • TLinkButton represents a hyperlink that can perform page postbacks.
  • TLiteral represents a static text without any HTML tag surrounding it on a Web page.
  • TMultiView represents a container for a group of TView controls, each of which is container for other controls. At any time, at most one TView is visible.
  • TOutputCache enables caching portions of page output and may significantly improve page response time.
  • TPager generates UI that allows users to interactively specify which page of data to be displayed in a data-bound control.
  • TPanel represents a container for other controls on a Web page. In HTML, it is displayed as a <div> element.
  • TPlaceHolder reserves a place on a control template. It inserts its body content at that place.
  • TRadioButton represents a radiobutton on a Web page. It is mainly used in a group from which users make a choice.
  • XSS).
  • TSlider represents a Slider control
  • TStatements accepts a few PHP statements and displays their standard output on the Web page.
  • TTable represents an HTML table on a Web page. It is used together with TTableRow and TTableCell.
  • TTabPanel displays a tabbed panel consisting of multiple tab views. At any time, only one tab view is visible.
  • TTextBox represents a text input field on a Web page. It can collect single-line, multi-line or password text input from users.
  • TTextHighlighter highlights its body content according to the specified syntax highlighter, such as PHP, XML, PRADO, etc.
  • TWizard represents a multi-step form that can take user input step by step. It resembles to Windows installation wizards.
$Id: Standard.page 2236 2007-09-24 16:03:13Z xue $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Validation Controls

Validation controls, called validators, perform validation on user-entered data values when they are post back to the server. The validation is triggered by a postback control, such as a TButton, a TLinkButton or a TTextBox (under AutoPostBack mode) whose CausesValidation property is true.

Validation is always performed on server side. If EnableClientScript is true and the client browser supports JavaScript, validators may also perform client-side validation. Client-side validation will validate user input before it is sent to the server. The form data will not be submitted if any error is detected. This avoids the round-trip of information necessary for server-side validation.

Validators share a common set of properties, which are defined in the base class TBaseValidator class and listed as follows,

  • ControlToValidate specifies the input control to be validated. This property must be set to the ID path of an input control. An ID path is the dot-connected IDs of the controls reaching from the validator's naming container to the target control.
  • ErrorMessage specifies the error message to be displayed in case the corresponding validator fails.
  • Text is similar to ErrorMessage. If they are both present, Text takes precedence. This property is useful when used together with TValidationSummary.
  • ValidationGroup specifies which group the validator is in. The validator will perform validation only if the current postback is triggered by a control which is in the same group.
  • EnableClientScript specifies whether client-side validation should be performed. By default, it is enabled.
  • Display specifies how error messages are displayed. It takes one of the following three values:
    • None - the error message will not be displayed even if the validator fails.
    • Static - the space for displaying the error message is reserved. Therefore, showing up the error message will not change your existing page layout.
    • Dynamic - the space for displaying the error message is NOT reserved. Therefore, showing up the error message will shift the layout of your page around (usually down).
  • ControlCssClass - the CSS class that is applied to the control being validated in case the validation fails.
  • FocusOnError - set focus at the validating place if the validation fails. Defaults to false.
  • FocusElementID - the ID of the HTML element that will receive focus if validation fails and FocusOnError is true.

Prado Validation Controls

TRequiredFieldValidator

TRequiredFieldValidator ensures that the user enters some data in the specified input field. By default, TRequiredFieldValidator will check if the user input is empty or not. The validation fails if the input is empty. By setting InitialValue, the validator can check if the user input is different from InitialValue. If not, the validation fails.

Run Sample View Source

TRegularExpressionValidator

TRegularExpressionValidator verifies the user input against a regular pattern. The validation fails if the input does not match the pattern. The regular expression can be specified by the RegularExpression property. Some commonly used regular expressions include:

  • At least 6 characters: [\w]{6,}
  • Japanese Phone Number: (0\d{1,4}-|\(0\d{1,4}\) ?)?\d{1,4}-\d{4}
  • Japanese Postal Code: \d{3}(-(\d{4}|\d{2}))?
  • P.R.C. Phone Number: (\(\d{3}\)|\d{3}-)?\d{8}
  • P.R.C. Postal Code: \d{6}
  • P.R.C. Social Security Number: \d{18}|\d{15}
  • U.S. Phone Number: ((\(\d{3}\) ?)|(\d{3}-))?\d{3}-\d{4}
  • U.S. ZIP Code: \d{5}(-\d{4})?
  • U.S. Social Security Number: \d{3}-\d{2}-\d{4}

More regular expression patterns can be found on the Internet, e.g. http://regexlib.com/.

Note, TRegularExpressionValidator only checks for nonempty user input. Use a TRequiredFieldValidator to ensure the user input is not empty.

Run Sample View Source

TEmailAddressValidator

TEmailAddressValidator verifies that the user input is a valid email address. The validator uses a regular expression to check if the input is in a valid email address format. If CheckMXRecord is true, the validator will also check whether the MX record indicated by the email address is valid, provided checkdnsrr() is available in the installed PHP.

Note, if the input being validated is empty, TEmailAddressValidator will not do validation. Use a TRequiredFieldValidator to ensure the value is not empty.

Run Sample View Source

TCompareValidator

TCompareValidator compares the user input with a constant value specified by ValueToCompare, or another user input specified by ControlToCompare. The Operator property specifies how to compare the values, which includes Equal, NotEqual, GreaterThan, GreaterThanEqual, LessThan and LessThanEqual. Before comparison, the values being compared will be converted to the type specified by DataType listed as follows,

  • String - A string data type.
  • Integer - A 32-bit signed integer data type.
  • Float - A double-precision floating point number data type.
  • Date - A date data type. The date format can be specified by setting DateFormat property, which must be recognizable by TSimpleDateFormatter. If the property is not set, the GNU date syntax is assumed.

Note, if the input being validated is empty, TEmailAddressValidator will not do validation. Use a TRequiredFieldValidator to ensure the value is not empty.

N.B. If validating against a TDatePicker.

Run Sample View Source

TDataTypeValidator

TDataTypeValidator verifies if the input data is of specific type indicated by DataType. The data types that can be checked against are the same as those in TCompareValidator.

N.B. If validating against a TDatePicker.

Run Sample View Source

TRangeValidator

TRangeValidator verifies whether an input value is within a specified range. TRangeValidator uses three key properties to perform its validation. The MinValue and MaxValue properties specify the minimum and maximum values of the valid range. The DataType property specifies the data type of the value being validated. The value will be first converted into the specified type and then compare with the valid range. The data types that can be checked against are the same as those in TCompareValidator.

If StrictComparison property is set to true, then the ranges are compared as strictly less than the MaxValue and/or strictly greater than the MinValue.

N.B. If validating against a TDatePicker.

Run Sample View Source

TCustomValidator

TCustomValidator performs user-defined validation (either server-side or client-side or both) on an input control.

To create a server-side validation function, provide a handler for the OnServerValidate event that performs the validation. The data string of the input control to validate can be accessed by the event parameter's Value property. The result of the validation should be stored in the IsValid property of the parameter.

To create a client-side validation function, add the client-side validation javascript function to the page template and assign its name to the ClientValidationFunction property. The function should have the following signature:

<script type="text/javascript">
function ValidationFunctionName(sender, parameter)
{
    // if(parameter == ...)
    //    return true;
    // else
    //    return false;
}
</script>
Run Sample View Source

TValidationSummary

TValidationSummary displays a summary of validation errors inline on a Web page, in a message box, or both.

By default, a validation summary will collect ErrorMessage of all failed validators on the page. If ValidationGroup is not empty, only those validators who belong to the group will show their error messages in the summary.

The summary can be displayed as a list, a bulleted list, or a single paragraph based on the DisplayMode property. The messages shown can be prefixed with HeaderText. The summary can be displayed on the Web page or in a JavaScript message box, by setting the ShowSummary and ShowMessageBox properties, respectively. Note, the latter is only effective when EnableClientScript is true.

Run Sample View Source

Interacting the Validators

Resetting or Clearing of Validators

Validators can be reset on the client-side using javascript by calling the Prado.Validation.reset(groupID) where groupID is the validator grouping name. If groupID is null, then validators without grouping are used.

<script type="text/javascript">
function reset_validator()
{
    Prado.Validation.reset("group1");
}
</script>
Run Sample View Source

Client and Server Side Conditional Validation

All validators contains the following events. The corresponding events for the client side is available as sub-properties of the ClientSide property of the validator.

  • The OnValidate event is raise before the validator validation functions are called.
  • The OnValidationSuccess event is raised after the validator has successfully validate the control.
  • The OnValidationError event is raised after the validator fails validation.
Note: For Prado versions earlier than 3.1 the property names were OnError and OnSuccess. For Prado version 3.1 or later they are OnValidationError and OnValidationSuccess, respectively.

The following example pop-up a message saying "hello" when the validator fails on the client-side.

<com:TRequiredFieldValidator ... >
    <prop:ClientSide.OnValidationError>
        alert("hello");
    </prop:ClientSide.OnValidationError>
</com:TRequiredFieldValidator>
The resulting client-side event callback function is of the following form.
function onErrorHandler(sender, parameter)
{
    alert("hello");
}
Where sender is the current client-side validator and parameter is the control that invoked the validator.

Conditional Validation Example

The following example show the use of client-side and server side validator events. The example demonstrates conditional validation. Notice that, we need to write code for both the server side and client-side. Moreover, on the server side, we need to re-enable the conditional validator so that its javascript code are produced no matter what (otherwise, the client-side validator is not available).

Run Sample View Source

$Id: Validation.page 1902 2007-05-07 04:17:37Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

List Controls

List controls covered in this section all inherit directly or indirectly from TListControl. Therefore, they share the same set of commonly used properties, including,

  • Items - list of items in the control. The items are of type TListItem. The item list can be populated via databinding or specified in templates like the following:
    <com:TListBox>
  <com:TListItem Text="text 1" Value="value 1" />
  <com:TListItem Text="text 2" Value="value 2" Selected="true" />
  <com:TListItem Text="text 3" Value="value 3" />
</com:TListBox>
  • SelectedIndex - the zero-based index of the first selected item in the item list.
  • SelectedIndices - the indices of all selected items.
  • SelectedItem - the first selected item in the item list.
  • SelectedValue - the value of the first selected item in the item list.
  • AutoPostBack - whether changing the selection of the control should trigger postback.
  • CausesValidation - whether validation should be performed when postback is triggered by the list control.

Since TListControl inherits from TDataBoundControl, these list controls also share a common operation known as databinding. The Items can be populated from preexisting data specified by DataSource or DataSourceID. A function call to dataBind() will cause the data population. For list controls, data can be specified in the following two kinds of format:

  • one-dimensional array or objects implementing ITraversable : array keys will be used as list item values, and array values will be used as list item texts. For example
    $listbox->DataSource=array(
    'key 1'=>'item 1',
    'key 2'=>'item 2',
    'key 3'=>'item 3');
$listbox->dataBind();
  • tabular (two-dimensional) data : each row of data populates a single list item. The list item value is specified by the data member indexed with DataValueField, and the list item text by DataTextField. For example,
    $listbox->DataTextField='name';
$listbox->DataValueField='id';
$listbox->DataSource=array(
    array('id'=>'001','name'=>'John','age'=>31),
    array('id'=>'002','name'=>'Mary','age'=>30),
    array('id'=>'003','name'=>'Cary','age'=>20));
$listbox->dataBind();

TListBox

TListBox displays a list box that allows single or multiple selection. Set the property SelectionMode as Single to make a single selection list box, and Multiple a multiple selection list box. The number of rows displayed in the box is specified via the Rows property value.

Run Sample View Source

TDropDownList

TDropDownList displays a dropdown list box that allows users to select a single option from a few prespecified ones.

Since v3.1.1, TDropDownList starts to support prompt text (something like 'Please select:' as the first list item). To use this feature, set either PromptText or PromptValue, or both. If the user chooses the prompt item, the dropdown list will be unselected.

Run Sample View Source

TCheckBoxList

TCheckBoxList displays a list of checkboxes on a Web page. The alignment of the text besides each checkbox can be specified TextAlign. The layout of the checkboxes can be controlled by the following properties:

  • RepeatLayout - can be either Table or Flow. A Table uses HTML table cells to organize the checkboxes, while a Flow uses HTML span tags and breaks for the organization. With Table layout, you can set CellPadding and CellSpacing.
  • RepeatColumns - how many columns the checkboxes should be displayed in.
  • RepeatDirection - how to traverse the checkboxes, in a horizontal way or a vertical way (because the checkboxes are displayed in a matrix-like layout).
Run Sample View Source

TRadioButtonList

TRadioButtonList is similar to TCheckBoxList in every aspect except that each TRadioButtonList displays a group of radiobuttons. Only one of the radiobuttions can be selected (TCheckBoxList allows multiple selections.)

Run Sample View Source

TBulletedList

TBulletedList displays items in a bullet format on a Web page. The style of the bullets can be specified by BulletStyle. When the style is CustomImage, the bullets are displayed as images, which is specified by BulletImageUrl.

TBulletedList displays the item texts in three different modes,

  • Text - the item texts are displayed as static texts;
  • HyperLink - each item is displayed as a hyperlink whose URL is given by the item value, and Target property can be used to specify the target browser window;
  • LinkButton - each item is displayed as a link button which posts back to the page if a user clicks on that, and the event OnClick will be raised under such a circumstance.
Run Sample View Source
$Id: List.page 2256 2007-09-28 02:04:47Z xue $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Data Controls

  • TDataList is used to display or modify a list of data items.
  • TDataGrid displays data in a tabular format with rows and columns.
  • TRepeater displays its content defined in templates repeatedly based on the given data.
$Id: Data.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Active Controls (AJAX enabled Controls)

See the Introduction for a quick overview of the concept behind active controls (AJAX enabled controls). Most active controls have a property of ActiveControl and a sub-property ClientSide that provides many properties to customize the controls. The CallbackClient property of the TPage class provides many methods to update and alter the client-side content during a callback request. Active controls is reliant on a collection of javascript classes.

For a quick demo of active controls, try the TActiveButton control. See also the later part of the Currency Converter tutorial for a more in depth example.

* the tutorial for this control is not completed yet.

Standard Active Controls

  • TActiveButton represents a click button on a Web page. It can be used to trigger a callback request.
  • TActiveCheckBox represents a checkbox on a Web page. It can be used to collect two-state user input and can trigger a callback request.
  • TActiveCustomValidator validates a particular control using a callback request.
  • TActiveHyperLink represents a hyperlink on a Web page.
  • * TActiveImage represents an image on a Web page.
  • * TActiveImageButton represents a click button that has an image as the background. It is can be used to trigger a callback request.
  • * TActiveLabel represents a label on a Web page. The label can be customized via various CSS attributes.
  • * TActiveLinkButton represents a hyperlink that can perform a callback request.
  • * TActivePanel represents a container for other controls on a Web page. In HTML, it is displayed as a <div> element. The panel's contents can be replaced during a callback request.
  • TActivePager generates UI that allows users to interactively specify which page of data to be displayed in a data-bound control.
  • * TActiveRadioButton represents a radiobutton on a Web page. It is mainly used in a group from which users make a choice. It can be used to perform a callback request.
  • * TActiveTextBox represents a text input field on a Web page. It can collect single-line, multi-line or password text input from users. It can be used to perform a callback request.
  • * TCallbackOptions callback options such as OnLoading client-side event handlers.

Active List Controls

  • * TActiveCheckBoxList displays a list of checkboxes on a Web page and each checkbox can trigger a callback request.
  • * TActiveDropDownList displays a dropdown list box that allows users to select a single option from a few prespecified ones. It can be used to perform a callback request.
  • * TActiveListBox displays a list box that allows single or multiple selection. It can be used to perform a callback request.
  • * TActiveRadioButtonList is similar to TActiveCheckBoxList in every aspect except that each TActiveRadioButtonList displays a group of radiobuttons. Each radio button can perform a callback request.

Extended Active Controls

  • TAutoComplete extends TActiveTextBox to offer text completion suggestions.
  • * TCallback a generic control that can perform callback requests.
  • * TEventTriggeredCallback triggers a callback request based on HTML DOM events.
  • * TInPlaceTextBox represents a label that can be edited by clicked.
  • * TTimeTriggeredCallback triggers a callback request based on time elapsed.
  • * TValueTriggeredCallback monitors (using a timer) an attribute of an HTML element and triggers a callback request when the attribute value changes.
  • TDropContainer & TDraggable represents drag and drop containers. The former will make its child controls "draggable" while the latter will raise a callback when a draggable control is dropped on it.

Active Control Abilities

The following table shows the Active Controls that can trigger a callback event and whether the control will raise a PostBack event if Javascript was disabled on the client's browser.

Control Name | Triggers Callback | Falls back to PostBack
TActiveButton | Yes | Yes
TActiveCheckBox | Yes | Yes
TActiveCustomValidator | Yes | Yes
TActiveHyperLink | No | Yes
TActiveImage | No | Yes
TActiveImageButton | Yes | Yes
TActiveLabel | No | Yes
TActiveLinkButton | Yes | No
TActivePanel | No | Yes
TActiveRadioButton | Yes | Yes
TActiveTextBox | Yes | Yes
TCallbackOptions | No | N/A
TActiveCheckBoxList | Yes | Yes
TActiveDropDownList | Yes | Yes
TActiveListBox | Yes | Yes
TActiveRadioButtonList | Yes | Yes
TAutoComplete | Yes | No
TCallback | Yes | No
TEventTriggeredCallback | Yes | No
TInPlaceTextBox | Yes | No
TTimeTriggeredCallback | Yes | No
TValueTriggeredCallback | Yes | No
TDropContainer | Yes | No
TDraggable | No | No

Active Control Infrastructure Classes

The following classes provide the basic infrastructure classes required to realize the active controls.

  • * TActiveControlAdapter tracks the viewstate values of the control and update differences of the client-side HTML element attributes.
  • * TActiveListControlAdapter allows the adapted list controls to change the selections on the client-side during a callback request.
  • * TActivePageAdapter process the page life-cycle for callback requests.
  • * TBaseActiveControl common active control methods and options.
  • * TCallbackClientScript methods to manipulate the client-side HTML elements, also includes methods to invoke javascript Effects on HTML elements.
  • * TCallbackClientSide common client-side callback request options, and client-side event handlers.
  • * TCallbackResponseAdapter HTTP response for callback requests.
$Id: Home.page 2537 2008-10-20 08:05:02Z Christophe.Boulain $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Writing New Controls

Writing new controls is often desired by advanced programmers, because they want to reuse the code that they write for dealing with complex presentation and user interactions.

In general, there are two ways of writing new controls: composition of existing controls and extending existing controls. They all require that the new control inherit from TControl or its child classes.

Composition of Existing Controls

Composition is the easiest way of creating new controls. It mainly involves instantiating existing controls, configuring them and making them the constituent components. The properties of the constituent components are exposed through subproperties.

One can compose a new control in two ways. One is to extend TCompositeControl and override the TControl::createChildControls() method. The other is to extend TTemplateControl (or its child classes) and write a control template. The latter is easier to use and can organize the layout constituent components more intuitively, while the former is more efficient because it does not require parsing of the template.

As an example, we show how to create a labeled textbox called LabeledTextBox using the above two approaches. A labeled textbox displays a label besides a textbox. We want reuse the PRADO provided TLabel and TTextBox to accomplish this task.

Composition by Writing Templates

We need two files: a control class file named LabeledTextBox.php and a control template file named LabeledTextBox.tpl. Both must reside under the same directory.

Like creating a PRADO page, we can easily write down the content in the control template file.

<com:TLabel ID="Label" ForControl="TextBox" />
<com:TTextBox ID="TextBox" />

The above template specifies a TLabel control named Label and a TTextBox control named TextBox. We would to expose these two controls. This can be done by defining a property for each control in the LabeledTextBox class file. For example, we can define a Label property as follows,

class LabeledTextBox extends TTemplateControl {
    public function getLabel() {
        $this->ensureChildControls();
        return $this->getRegisteredObject('Label');
    }
}

In the above, the method call to ensureChildControls() ensures that both the label and the textbox controls are created (from template) when the Label property is accessed. The TextBox property can be implemented similarly.

Run Sample View Source

Composition by Overriding createChildControls()

For a composite control as simple as LabeledTextBox, it is better to create it by extending TCompositeControl and overriding the createChildControls() method, because it does not use templates and thus saves template parsing time.

Complete code for LabeledTextBox is shown as follows,

class LabeledTextBox extends TCompositeControl {
    private $_label;
    private $_textbox;
    public function createChildControls() {
        $this->_label=new TLabel;
        $this->_label->setID('Label');
        // add the label as a child of LabeledTextBox
        $this->getControls()->add($this->_label);
        $this->_textbox=new TTextBox;
        $this->_textbox->setID('TextBox');
        $this->_label->setForControl('TextBox');
        // add the textbox as a child of LabeledTextBox
        $this->getControls()->add($this->_textbox);
    }
    public function getLabel() {
        $this->ensureChildControls();
        return $this->_label;
    }
    public function getTextBox() {
        $this->ensureChildControls();
        return $this->_textbox;
    }
}
Run Sample View Source

Using LabeledTextBox

To use LabeledTextBox control, first we need to include the corresponding class file. Then in a page template, we can write lines like the following,

<com:LabeledTextBox ID="Input" Label.Text="Username" />

In the above, Label.Text is a subproperty of LabeledTextBox, which refers to the Text property of the Label property. For other details of using LabeledTextBox, see the above online examples.

Extending Existing Controls

Extending existing controls is the same as conventional class inheritance. It allows developers to customize existing control classes by overriding their properties, methods, events, or creating new ones.

The difficulty of the task depends on how much an existing class needs to be customized. For example, a simple task could be to customize TLabel control, so that it displays a red label by default. This would merely involves setting the ForeColor property to "red" in the constructor. A difficult task would be to create controls that provide completely innovative functionalities. Usually, this requires the new controls extend from "low level" control classes, such as TControl or TWebControl.

In this section, we mainly introduce the base control classes TControl and TWebControl, showing how they can be customized. We also introduce how to write controls with specific functionalities, such as loading post data, raising post data and databinding with data source.

Extending TControl

TControl is the base class of all control classes. Two methods are of the most importance for derived control classes:

  • addParsedObject() - this method is invoked for each component or text string enclosed within the component tag specifying the control in a template. By default, the enclosed components and text strings are added into the Controls collection of the control. Derived controls may override this method to do special processing about the enclosed content. For example, TListControl only accepts TListItem components to be enclosed within its component tag, and these components are added into the Items collection of TListControl.
  • render() - this method renders the control. By default, it renders items in the Controls collection. Derived controls may override this method to give customized presentation.
Other important properties and methods include:
  • ID - a string uniquely identifying the control among all controls of the same naming container. An automatic ID will be generated if the ID property is not set explicitly.
  • UnqiueID - a fully qualified ID uniquely identifying the control among all controls on the current page hierarchy. It can be used to locate a control in the page hierarchy by calling TControl::findControl() method. User input controls often use it as the value of the name attribute of the HTML input element.
  • ClientID - similar to UniqueID, except that it is mainly used for presentation and is commonly used as HTML element id attribute value. Do not rely on the explicit format of ClientID.
  • Enabled - whether this control is enabled. Note, in some cases, if one of the control's ancestor controls is disabled, the control should also be treated as disabled, even if its Enabled property is true.
  • Parent - parent control of this control. The parent control is in charge of whether to render this control and where to place the rendered result.
  • Page - the page containing this control.
  • Controls - collection of all child controls, including static texts between them. It can be used like an array, as it implements Traversable interface. To add a child to the control, simply insert it into the Controls collection at appropriate position.
  • Attributes - collection of custom attributes. This is useful for allowing users to specify attributes of the output HTML elements that are not covered by control properties.
  • getViewState() and setViewState() - these methods are commonly used for defining properties that are stored in viewstate.
  • saveState() and loadState() - these two methods can be overriden to provide last step state saving and loading.
  • Control lifecycles - Like pages, controls also have lifecycles. Each control undergoes the following lifecycles in order: constructor, onInit(), onLoad(), onPreRender(), render(), and onUnload. More details can be found in the page section.

Extending TWebControl

TWebControl is mainly used as a base class for controls representing HTML elements. It provides a set of properties that are common among HTML elements. It breaks the TControl::render() into the following methods that are more suitable for rendering an HTML element:

  • addAttributesToRender() - adds attributes for the HTML element to be rendered. This method is often overridden by derived classes as they usually have different attributes to be rendered.
  • renderBeginTag() - renders the opening HTML tag.
  • renderContents() - renders the content enclosed within the HTML element. By default, it displays the items in the Controls collection of the control. Derived classes may override this method to render customized contents.
  • renderEndTag() - renders the closing HTML tag.

When rendering the openning HTML tag, TWebControl calls getTagName() to obtain the tag name. Derived classes may override this method to render different tag names.

Creating Controls with Special Functionalities

If a control wants to respond to client-side events and translate them into server side events (called postback events), such as TButton, it has to implement the IPostBackEventHandler interface.

If a control wants to be able to load post data, such as TTextBox, it has to implement the IPostBackDataHandler interface.

If a control wants to get data from some external data source, it can extend TDataBoundControl. TDataBoundControl implements the basic properties and methods that are needed for populating data via databinding. In fact, controls like TListControl, TRepeater are TDataGrid are all derived from it.

$Id: NewControl.page 1741 2007-03-05 16:05:43Z xue $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

SOAP Service

SOAP forms the foundation layer of the Web services stack. It provides a neat way for PHP applications to communicate with each other or with applications written in other languages. PRADO provides TSoapService that makes developing a SOAP server application an extremely easy task.

To use TSoapService, configure it in the application specification like following:

<services>
  <service id="soap" class="System.Web.Services.TSoapService">
    <soap id="stockquote" provider="path.to.StockQuote" />
    <!--
    <soap...other soap service... />
    -->
  </service>
</services>

The example specifies a SOAP service provider named stockquote which implements the getPrice SOAP method in the provider class StockQuote,

class StockQuote
{
    /**
     * @param string $symbol the symbol of the stock
     * @return float the stock price
     * @soapmethod
     */
    public function getPrice($symbol)
    {
        ....return stock price for $symbol
    }
}
Note: TSoapService is based on PHP SOAP extension and thus requires the extension to be installed.

With the above simple code, we already finish a simple SOAP service that allows other applications to query the price of a specific stock. For example, a typical SOAP client may be written as follows to query the stock price of IBM,

$client=new SoapClient('http://path/to/index.php?soap=stockquote.wsdl');
echo $client->getPrice('IBM');

Notice the URL used to construct SoapClient (a class provided by PHP SOAP extension). This is the URL for the WSDL that describes the communication protocol for the SOAP service we just implemented. WSDL is often too complex to be manually written. Fortunately, TSoapService can generate this for us using a WSDL generator. In general, the URL for the automatically generated WSDL in PRADO has the following format:

http://path/to/index.php?SoapServiceID=SoapProviderID.wsdl

In order for the WSDL generator to generate WSDL for a SOAP service, the provider class needs to follow certain syntax. In particular, for methods to be exposed as SOAP methods, a keyword @soapmethod must appear in the phpdoc comment of the method with the following lines specifying method parameters and return value:

  • parameter: @param parameter-type $parameter-name description
  • return value: @return value-type description

Valid parameter and return types include: string, int, boolean, float, array, mixed, etc. You may also specify a class name as the type, which translates into a complex SOAP type. For example, for a complex type Contact

/**
 * Extends TComponent to provide property setter/getter methods
 */
class Contact {
    /**
     * @var string $name
     * @soapproperty
     */
    public $name;

    /**
     * @var Address $address
     * @soapproperty
     */
    private $_address;

    public function setAddress($value) {
        $this->_address=$value;
    }

    public function getAddress() {
        if($this->_address===null)
            $this->_address=new Address;
        return $this->_address;
    }
}

class Address{
    /**
     * @var string $city
     * @soapproperty
     */
    public $city;
}

class ContactManager {
    /**
     * @return Contact[] an array of contacts
     * @soapmethod
     */
    function getAllContacts() {
        return array(new Contact);
    }

    /**
     * @return Contact one contact
     * @soapmethod
     */
    function getContact($name) {
        return new Contact;
    }
}

For a complex soap object, the properties of the object are specified with @soapproperty keyword in the property phpdocs. Furthermore, the propert's type name must be specified as @var type $name where type is any valid type in mentioned earlier and $name will defined a property name (notice that if your class is a TComponent, you can provide property setter/getter methods).

An array of complex objects can also be returned by adding a pair of enclosing square brackets after the type name. For example, to return an array of Contact type, we define @return Contact[] ....

Tip: A very useful tool to test out your web services is the free tool WebServiceStudio 2.0. It can invoke webmethods interactively. The user can provide a WSDL endpoint. On clicking button Get the tool fetches the WSDL, generates .NET proxy from the WSDL and displays the list of methods available. The user can choose any method and provide the required input parameters. The tool requires a MS .NET runtime to be installed.

A similar tool is available for Mac OS X Tiger from http://www.ditchnet.org/soapclient/

TSoapService may be configured and customized in several ways. In the example above, the <soap> element actually specifies a SOAP service using the default TSoapServer implementation. Attributes in <soap> are passed to TSoapServer as its initial property values. For example, the provider attribute initializes the Provider property of TSoapServer. By setting SessionPersistent to be true in <soap> element, the provider instance will persist within the user session. You may develop your own SOAP server class and use it by specifying the class attribute of <soap>.

By default, PHP's soap server will create objects of the type StdClass when objects are received from the client. The soap server can be configured to automatically create objects of certain type objects are received as method parameters. For example, if we have a Soap method that accepts a Contact object as parameter.

/**
 * @param Contact $contact
 * @return boolean true if saved, false otherwise
 * @soapmethod
 */
 function save(Contact $contact)
 {
    return true
 }
The do this, we need to set the ClassMaps property of the TSoapServer in the <soap> tags as a comma separated string of class names that we wish to be automatically converted.
<soap id="contact-manager" provider="path.to.ContactManager"
    ClassMaps="Contact, Address"/>

$Id: SoapService.page 1902 2007-05-07 04:17:37Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Data Access Objects (DAO)

Available from Prado versions 3.1a onwards.

Data Access Objects (DAO) separates a data resource's client interface from its data access mechanisms. It adapts a specific data resource's access API to a generic client interface. As a result, data access mechanisms can be changed independently of the code that uses the data.

Since version 3.1, PRADO starts to provide a DAO that is a thin wrap around PHP Data Objects (PDO). Although PDO has a nice feature set and good APIs, we choose to implement the PRADO DAO on top of PDO because the PRADO DAO classes are component classes and are thus configurable in a PRADO application. Users can use these DAO classes in a more PRADO-preferred way.

Note: Since the PRADO DAO is based on PDO, the PDO PHP extension needs to be installed. In addition, you need to install the corresponding PDO driver for the database to be used in your application. See more details in the PHP Manual.

The PRADO DAO mainly consists of the following four classes (in contrast to PDO which uses only two classes, PDO and PDOStatement):

  • TDbConnection - represents a connection to a database.
  • TDbCommand - represents an SQL statement to execute against a database.
  • TDbDataReader - represents a forward-only stream of rows from a query result set.
  • TDbTransaction - represents a DB transaction.

In the following, we introduce the usage of PRADO DAO in different scenarios.

Establishing Database Connection

To establish a database connection, one creates a TDbConnection instance and activate it. A data source name (DSN) is needed to specify the information required to connect to the database. The database username and password may need to be supplied to establish the connection.

$connection=new TDbConnection($dsn,$username,$password);
// call setAttribute() to pass in additional connection parameters
// $connection->Persistent=true;  // use persistent connection
$connection->Active=true;  // connection is established
....
$connection->Active=false;  // connection is closed

Complete specification of DSN may be found in the PDO documentation. Below is a list of commonly used DSN formats:

  • MySQL - mysql:host=localhost;dbname=test
  • SQLite - sqlite:/path/to/dbfile
  • ODBC - odbc:SAMPLE

In case any error occurs when establishing the connection (such as bad DSN or username/password), a TDbException will be raised.

Executing SQL Statements

Once a database connection is established, SQL statements can be executed through TDbCommand. One creates a TDbCommand by calling TDbConnection.createCommand() with the specified SQL statement:

$command=$connection->createCommand($sqlStatement);
// if needed, the SQL statement may be updated as follows:
$command->Text=$newSqlStatement;

An SQL statement is executed via TDbCommand in one of the following two ways:

  • execute() - performs a non-query SQL statement, such as INSERT, UPDATE and DELETE. If successful, it returns the number of rows that are affected by the execution.
  • query() - performs an SQL statement that returns rows of data, such as SELECT. If successful, it returns a TDbDataReader instance from which one can fetch the resulting rows of data.
$affectedRowCount=$command->execute();  // execute the non-query SQL
$dataReader=$command->query();          // execute a query SQL
$row=$command->queryRow();              // execute a query SQL and return the first row of result
$value=$command->queryScalar();         // execute a query SQL and return the first column value

In case an error occurs during the execution of SQL statements, a TDbException will be raised.

Fetching Query Results

After TDbCommand.query() generates the TDbDataReader instance, one can retrieve rows of resulting data by calling TDbDataReader.read() repeatedly. One can also use TDbDataReader in PHP's foreach language construct to retrieve row by row.

// calling read() repeatedly until it returns false
while(($row=$dataReader->read())!==false) { ... }
// using foreach to traverse through every row of data
foreach($dataReader as $row) { ... }
// retrieving all rows at once in a single array
$rows=$dataReader->readAll();

Using Transactions

When an application executes a few queries, each reading and/or writing information in the database, it is important to be sure that the database is not left with only some of the queries carried out. A transaction, represented as a TDbTransaction instance in PRADO, may be initiated in this case:

  • Begin the transaction.
  • Execute queries one by one. Any updates to the database are not visible to the outside world.
  • Commit the transaction. Updates become visible if the transaction is successful.
  • If one of the queries fails, the entire transaction is rolled back.
$transaction=$connection->beginTransaction();
try
{
    $connection->createCommand($sql1)->execute();
    $connection->createCommand($sql2)->execute();
    //.... other SQL executions
    $transaction->commit();
}
catch(Exception $e) // an exception is raised if a query fails will be raised
{
    $transaction->rollBack();
}

Binding Parameters

To avoid SQL injection attacks and to improve performance of executing repeatedly used SQL statements, one can "prepare" an SQL statement with optional parameter placeholders that are to be replaced with the actual parameters during the parameter binding process.

The parameter placeholders can be either named (represented as unique tokens) or unnamed (represented as question marks). Call TDbCommand.bindParameter() or TDbCommand.bindValue() to replace these placeholders with the actual parameters. The parameters do not need to be quoted: the underlying database driver does it for you. Parameter binding must be done before the SQL statement is executed.

// an SQL with two placeholders ":username" and ":email"
$sql="INSERT INTO users(username, email) VALUES(:username,:email)";
$command=$connection->createCommand($sql);
// replace the placeholder ":username" with the actual username value
$command->bindParameter(":username",$username,PDO::PARAM_STR);
// replace the placeholder ":email" with the actual email value
$command->bindParameter(":email",$email,PDO::PARAM_STR);
$command->execute();
// insert another row with a new set of parameters
$command->bindParameter(":username",$username2,PDO::PARAM_STR);
$command->bindParameter(":email",$email2,PDO::PARAM_STR);
$command->execute();

The methods bindParameter() and bindValue() are very similar. The only difference is that the former binds a parameter with a PHP variable reference while the latter with a value. For parameters that represent large block of data memory, the former is preferred for performance consideration.

For more details about binding parameters, see the relevant PHP documentation.

Binding Columns

When fetching query results, one can also bind columns with PHP variables so that they are automatically populated with the latest data each time a row is fetched.

$sql="SELECT username, email FROM users";
$dataReader=$connection->createCommand($sql)->query();
// bind the 1st column (username) with the $username variable
$dataReader->bindColumn(1,$username);
// bind the 2nd column (email) with the $email variable
$dataReader->bindColumn(2,$email);
while($dataReader->read()!==false)
{
    // $username and $email contain the username and email in the current row
}
$Id: DAO.page 2234 2007-09-23 14:27:54Z xue $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Active Record

Available from Prado versions 3.1a onwards.

Active Records are objects that wrap a row in a database table or view, encapsulate the database access and add domain logic on that data. The basics of an Active Record are business classes, e.g., a Products class, that match very closely the record structure of an underlying database table. Each Active Record will be responsible for saving and loading data to and from the database.

Info: The data structure of an Active Record should match that of a table in the database. Each column of a table should have a corresponding member variable or property in the Active Record class the represents the table.

When to Use It

Active Record is a good choice for domain logic that isn't too complex, such as creates, reads, updates, and deletes. Derivations and validations based on a single record work well in this structure. Active Record has the primary advantage of simplicity. It's easy to build Active Records, and they are easy to understand.

However, as your business logic grows in complexity, you'll soon want to use your object's direct relationships, collections, inheritance, and so forth. These don't map easily onto Active Record, and adding them piecemeal gets very messy. Another argument against Active Record is the fact that it couples the object design to the database design. This makes it more difficult to refactor as a project goes forward.

The alternative is to use a Data Mapper that separates the roles of the business object and how these objects are stored. Prado provides a complimentary choice between Active Record and SqlMap Data Mapper. A SqlMap Data Mapper can be used to load Active Record objects, in turn; these Active Record objects can be used to update the database. The "relationship" between Active Records and SqlMap is illustrated in the following diagram. More details regarding the SqlMap Data Mapper can be found in the SqlMap Manual. Active Records and SqlMap DataMapper

The Active Record class has functionality to perform the following tasks.

  • Create, Retrieve, Update and Delete records.
  • Finder methods to wrap commonly used SQL queries and return Active Record objects.
  • Fetch relationships (related foreign objects) such as "has many", "has one", "belongs to" and "many to many" via association table.
  • Lazy loading of relationships.

Design Implications

Prado's implementation of Active Record does not maintain referential identity. Each object obtained using Active Record is a copy of the data in the database. For example, If you ask for a particular customer and get back a Customer object, the next time you ask for that customer you get back another instance of a Customer object. This implies that a strict comparison (i.e., using ===) will return false, while loose comparison (i.e., using ==) will return true if the object values are equal by loose comparison.

This is design implication related to the following question. "Do you think of the customer as an object, of which there's only one, or do you think of the objects you operate on as copies of the database?" Other O/R mappings will imply that there is only one Customer object with custID 100, and it literally is that customer. If you get the customer and change a field on it, then you have now changed that customer. "That constrasts with: you have changed this copy of the customer, but not that copy. And if two people update the customer on two copies of the object, whoever updates first, or maybe last, wins." [A. Hejlsberg 2003]

Database Supported

The Active Record implementation utilizes the Prado DAO classes for data access. The current Active Record implementation supports the following database.

  • MySQL 4.1 or later
  • Postgres SQL 7.3 or later
  • SQLite 2 and 3
  • MS SQL 2000 or later
  • Oracle Database (alpha)

Support for other databases can be provided when there are sufficient demands.

Defining an Active Record

Let us consider the following "users" table that contains two columns named "username" and "email", where "username" is also the primary key.

CREATE TABLE users
(
    username VARCHAR( 20 ) NOT NULL ,
    email VARCHAR( 200 ) ,
    PRIMARY KEY ( username )
);

Next we define our Active Record class that corresponds to the "users" table.

class UserRecord extends TActiveRecord
{
    const TABLE='users'; //table name

    public $username; //the column named "username" in the "users" table
    public $email;

    /**
     * @return TActiveRecord active record finder instance
     */
    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

Each column of the "users" table must have corresponding property of the same name as the column name in the UserRecord class. Of course, you also define additional member variables or properties that does not exist in the table structure. The class constant TABLE is optional when the class name is the same as the table name in the database, otherwise TABLE must specify the table name that corresponds to your Active Record class.

Tip: You may specify qualified table names. E.g. for MySQL, TABLE = "`database1`.`table1`".
Note: Since version 3.1.3 you can also use a method table() to define the table name. This allows you to dynamically specify which table should be used by the ActiveRecord.
class TeamRecord extends TActiveRecord
{
    public function table() {
        return 'Teams';
    }
}

Since TActiveRecord extends TComponent, setter and getter methods can be defined to allow control over how variables are set and returned. For example, adding a $level property to the UserRecord class:

class UserRecord extends TActiveRecord {
    ... //existing definitions as above

    private $_level;
    public function setLevel($value) {
        $this->_level=TPropertyValue::ensureInteger($value,0);
    }
    public function getLevel($value){
        return $this->_level;
    }
}

More details regarding TComponent can be found in the Components documentation. Later we shall use the getter/setters to allow for lazy loading of relationship objects.

Info: TActiveRecord can also work with database views by specifying the constant TABLE corresponding to the view name. However, objects returned from views are read-only, calling the save() or delete() method will raise an exception.

The static method finder() returns an UserRecord instance that can be used to load records from the database. The loading of records using the finder methods is discussed a little later. The TActiveRecord::finder() static method takes the name of an Active Record class as parameter.

Setting up a database connection

A default database connection for Active Record can be set as follows. See Establishing Database Connection for further details regarding creation of database connection in general.

//create a connection and give it to the Active Record manager.
$dsn = 'pgsql:host=localhost;dbname=test'; //Postgres SQL
$conn = new TDbConnection($dsn, 'dbuser','dbpass');
TActiveRecordManager::getInstance()->setDbConnection($conn);

Alternatively, you can create a base class and override the getDbConnection() method to return a database connection. This is a simple way to permit multiple connections and multiple databases. The following code demonstrates defining the database connection in a base class (not need to set the DB connection anywhere else).

class MyDb1Record extends TActiveRecord
{
    public function getDbConnection()
    {
        static $conn;
        if($conn===null)
            $conn = new TDbConnection('xxx','yyy','zzz');
        return $conn;
    }
}
class MyDb2Record extends TActiveRecord
{
    public function getDbConnection()
    {
        static $conn;
        if($conn===null)
            $conn = new TDbConnection('aaa','bbb','ccc');
        return $conn;
    }
}

Using application.xml within the Prado Framework

The default database connection can also be configured using a <module> tag in the application.xml or config.xml as follows.

<modules>
  <module class="System.Data.ActiveRecord.TActiveRecordConfig" EnableCache="true">
    <database ConnectionString="pgsql:host=localhost;dbname=test"
        Username="dbuser" Password="dbpass" />
  </module>
</modules>
Tip: The EnableCache attribute when set to "true" will cache the table meta data, that is, the table columns names, indexes and constraints are saved in the cache and reused. You must clear or disable the cache if you wish to see changes made to your table definitions. A cache module must also be defined for the cache to function.

A ConnectionID property can be specified with value corresponding to another TDataSourceConfig module configuration's ID value. This allows the same database connection to be used in other modules such as SqlMap.

<modules>
  <module class="System.Data.TDataSourceConfig" id="db1">
    <database ConnectionString="pgsql:host=localhost;dbname=test"
        Username="dbuser" Password="dbpass" />
  </module>

  <module class="System.Data.ActiveRecord.TActiveRecordConfig"
        ConnectionID="db1" EnableCache="true"  />

  <module class="System.Data.SqlMap.TSqlMapConfig"
        ConnectionID="db1"  ... />
</modules>

Loading data from the database

The TActiveRecord class provides many convenient methods to find records from the database. The simplest is finding one record by matching a primary key or a composite key (primary keys that consists of multiple columns). See the API Manual for more details.

Info: All finder methods that may return 1 record only will return null if no matching data is found. All finder methods that return an array of records will return an empty array if no matching data is found.

findByPk()

Finds one record using only a primary key or a composite key.

$finder = UserRecord::finder();
$user = $finder->findByPk($primaryKey);

//when the table uses a composite key
$record = $finder->findByPk($key1, $key2, ...);
$record = $finder->findByPk(array($key1, $key2,...));

findAllByPks()

Finds multiple records using a list of primary keys or composite keys. The following are equivalent for primary keys (primary key consisting of only one column/field).

$finder = UserRecord::finder();
$users = $finder->findAllByPks($key1, $key2, ...);
$users = $finder->findAllByPks(array($key1, $key2, ...));
The following are equivalent for composite keys.
//when the table uses composite keys
$record = $finder->findAllByPks(array($key1, $key2), array($key3, $key4), ...);

$keys = array(  array($key1, $key2), array($key3, $key4), ... );
$record = $finder->findAllByPks($keys);

find()

Finds one single record that matches the criteria. The criteria can be a partial SQL string or a TActiveRecordCriteria object.

$finder = UserRecord::finder();

//:name and :pass are place holders for specific values of $name and $pass
$finder->find('username = :name AND password = :pass',
                          array(':name'=>$name, ':pass'=>$pass));

//using position place holders
$finder->find('username = ? AND password = ?', array($name, $pass));
//same as above
$finder->find('username = ? AND password = ?', $name, $pass);

//$criteria is of TActiveRecordCriteria
$finder->find($criteria); //the 2nd parameter for find() is ignored.

The TActiveRecordCriteria class has the following properties:

  • Parameters -- name value parameter pairs.
  • OrdersBy -- column name and ordering pairs.
  • Condition -- parts of the WHERE SQL conditions.
  • Limit -- maximum number of records to return.
  • Offset -- record offset in the table.
$criteria = new TActiveRecordCriteria;
$criteria->Condition = 'username = :name AND password = :pass';
$criteria->Parameters[':name'] = 'admin';
$criteria->Parameters[':pass'] = 'prado';
$criteria->OrdersBy['level'] = 'desc';
$criteria->OrdersBy['name'] = 'asc';
$criteria->Limit = 10;
$criteria->Offset = 20;
Note: For MSSQL and when Limit and Offset are positive integer values. The actual query to be executed is modified by the TMssqlCommandBuilder class according to http://troels.arvin.dk/db/rdbms/ to emulate the Limit and Offset conditions.

findAll()

Same as find() but returns an array of objects.

findBy*() and findAllBy*()

Dynamic find method using parts of the method name as search criteria. Method names starting with findBy return 1 record only and method names starting with findAllBy return an array of records. The condition is taken as part of the method name after findBy or findAllBy. The following blocks of code are equivalent:

$finder->findByName($name)
$finder->find('Name = ?', $name);
$finder->findByUsernameAndPassword($name,$pass);
$finder->findBy_Username_And_Password($name,$pass);
$finder->find('Username = ? AND Password = ?', $name, $pass);
$finder->findAllByAge($age);
$finder->findAll('Age = ?', $age);
Tip: You may also use a combination of AND and OR as a condition in the dynamic methods.

findBySql() and findAllBySql()

Finds records using full SQL where findBySql() return an Active Record and findAllBySql()returns an array of record objects. For each column returned, the corresponding Active Record class must define a member variable or property for each corresponding column name.

class UserRecord2 extends UserRecord
{
    public $another_value;
}
$sql = "SELECT users.*, 'hello' as another_value FROM users";
$users = TActiveRecord::finder('UserRecord2')->findAllBySql($sql);

count()

Find the number of matchings records, accepts same parameters as the findAll() method.

Inserting and updating records

Add a new record using TActiveRecord is very simple, just create a new Active Record object and call the save() method. E.g.

$user1 = new UserRecord();
$user1->username = "admin";
$user1->email = "admin@example.com";
$user1->save(); //insert a new record

$data = array('username'=>'admin', 'email'=>'admin@example.com');
$user2 = new UserRecord($data); //create by passing some existing data
$user2->save(); //insert a new record
Tip: If you insert a new record into a MySQL table that has columns defined with "autoincrement", the Active Record objects will be updated with the new incremented value.

To update a record in the database, just change one or more properties of the Active Record object that has been loaded from the database and then call the save() method.

$user = UserRecord::finder()->findByName('admin');
$user->email="test@example.com"; //change property
$user->save(); //update it.

Active Record objects have a simple life-cycle illustrated in the following diagram.

Active Records Life Cycle

We see that new TActiveRecord objects are created by either using one of the find*() methods or using creating a new instance by using PHP's new keyword. Objects created by a find*() method starts with clean state. New instance of TActiveRecord created other than by a find*() method starts with new state. Whenever you call the save() method on the TActiveRecord object, the object enters the clean state. Objects in the clean becomes dirty whenever one of more of its internal states are changed. Calling the delete() method on the object ends the object life-cycle, no further actions can be performed on the object.

Deleting existing records

To delete an existing record that is already loaded, just call the delete() method. You can also delete records in the database by primary keys without loading any records using the deleteByPk() method (and equivalently the deleteAllByPks() method). For example, to delete one or several records with tables using one or more primary keys.

$finder->deleteByPk($primaryKey); //delete 1 record
$finder->deleteAllByPks($key1,$key2,...); //delete multiple records
$finder->deleteAllByPks(array($key1,$key2,...)); //delete multiple records

For composite keys (determined automatically from the table definitions):

$finder->deleteByPk(array($key1,$key2)); //delete 1 record

//delete multiple records
$finder->deleteAllByPks(array($key1,$key2), array($key3,$key4),...);

//delete multiple records
$finder->deleteAllByPks(array( array($key1,$key2), array($key3,$key4), .. ));

deleteAll() and deleteBy*()

To delete by a criteria, use deleteAll($criteria) and deleteBy*() with similar syntax to findAll($criteria) and findAllBy*() as described above.

//delete all records with matching Name
$finder->deleteAll('Name = ?', $name);
$finder->deleteByName($name);

//delete by username and password
$finder->deleteBy_Username_And_Password($name,$pass);

Transactions

All Active Record objects contain the property DbConnection that can be used to obtain a transaction object.

$finder = UserRecord::finder();
$finder->DbConnection->Active=true; //open if necessary
$transaction = $finder->DbConnection->beginTransaction();
try
{
    $user = $finder->findByPk('admin');
    $user->email = 'test@example.com'; //alter the $user object
    $user->save();
    $transaction->commit();
}
catch(Exception $e) // an exception is raised if a query fails
{
    $transaction->rollBack();
}

Events

The TActiveRecord offers two events, OnCreateCommand and OnExecuteCommand.

The OnCreateCommand event is raised when a command is prepared and parameter binding is completed. The parameter object is TDataGatewayEventParameter of which the Command property can be inspected to obtain the SQL query to be executed.

The OnExecuteCommand event is raised when a command is executed and the result from the database was returned. The parameter object is TDataGatewayResultEventParameter of which the Result property contains the data return from the database. The data returned can be changed by setting the Result property.

Logging Example

Using the OnExecuteCommand we can attach an event handler to log the entire SQL query executed for a given TActiveRecord class or instance. For example, we define a base class and override either the getDbConnection() or the constructor.

class MyDb1Record extends TActiveRecord
{
    public function getDbConnection()
    {
        static $conn;
        if($conn===null)
        {
            $conn = new TDbConnection('xxx','yyy','zzz');
            $this->OnExecuteCommand[] = array($this,'logger');
        }
        return $conn;
    }
    public function logger($sender,$param)
    {
        var_dump($param->Command->Text);
    }
}
//alternatively as per instance of per finder object
function logger($sender,$param)
{
    var_dump($param->Command->Text);
}
TActiveRecord::finder('MyRecord')->OnExecuteCommand[] = 'logger';
$obj->OnExecuteCommand[] = array($logger, 'log'); //any valid PHP callback.

Active Record Relationships

Available from Prado versions 3.1rc1 onwards.

The Prado Active Record implementation supports the foreign key mappings for database that supports foreign key constraints. For Active Record relationships to function the underlying database must support foreign key constraints (e.g. MySQL using InnoDB).

In the following sections we will consider the following table relationships between Teams, Players, Skills and Profiles.

The goal is to obtain object models that represent to some degree the entity relationships in the above figure.

There is a mismatch between relationships with objects and table relationships. First there's a difference in representation. Objects handle links by storing references that are held by the runtime memory-managed environment. Relational databases handle links by forming a key into another table. Second, objects can easily use collections to handle multiple references from a single field, while normalization forces all entity relation links to be single valued. This leads to reversals of the data structure between objects and tables. The approach taken in the Prado Active Record design is to use the table foreign key constraints to derive object relationships. This implies that the underlying database must support foreign key constraints.

Tip: For SQLite database, you may create tables that defines the foreign key constraints such as the example below. However, these constraints are NOT enforced by the SQLite database itself.
CREATE TABLE foo
(
    id INTEGER NOT NULL PRIMARY KEY,
    id2 CHAR(2)
);
CREATE TABLE bar
(
    id INTEGER NOT NULL PRIMARY KEY,
    foo_id INTEGER
        CONSTRAINT fk_foo_id REFERENCES foo(id) ON DELETE CASCADE
);

Foreign Key Mapping

The entity relationship between the Teams and Players table is what is known as an 1-M relationship. That is, one Team may contain 0 or more Players. In terms of object relationships, we say that a TeamRecord object has many PlayerRecord objects. (Notice the reversal of the direction of relationships between tables and objects.)

Has Many Relationship

We model the Team object as the following Active Record classes.

class TeamRecord extends TActiveRecord
{
    const TABLE='Teams';
    public $name;
    public $location;

    public $players=array();  // this declaration is no longer needed since v3.1.2

    //define the $player member having has many relationship with PlayerRecord
    public static $RELATIONS=array
    (
        'players' => array(self::HAS_MANY, 'PlayerRecord', 'team_name'),
    );

    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

The static $RELATIONS property of TeamRecord defines that the property $players has many PlayerRecords. Multiple relationships is permitted by defining each relationship with an entry in the $RELATIONS array where array key for the entry corresponds to the property name. In array(self::HAS_MANY, 'PlayerRecord'), the first element defines the relationship type, the valid types are self::HAS_MANY, self::HAS_ONE, self::BELONGS_TO and self::MANY_TO_MANY. The second element is a string 'PlayerRecord' that corresponds to the class name of the PlayerRecord class. And the third element 'team_name' refers to the foreign key column in the Players table that references to the Teams table.

Note: As described in the code comment above, since version 3.1.2, related properties no longer need to be explicitly declared. By default, they will be implicitly declared according to keys of the $RELATIONS array. A major benefit of declared related properties implicitly is that related objects can be automatically loaded in a lazy way. For example, assume we have a TeamRecord instance $team. We can access the players via $team->players, even if we have never issued fetch command for players. If $players is explicitly declared, we will have to use the with approach described in the following to fetch the player records.

The foreign key constraint of the Players table is used to determine the corresponding Teams table's corresponding key names. This is done automatically handled in Active Record by inspecting the Players and Teams table definitions.

Info: Since version 3.1.2, Active Record supports multiple foreign key references of the same table. Ambiguity between multiple foreign key references to the same table is resolved by providing the foreign key column name as the 3rd parameter in the relationship array. For example, both of the following foreign keys owner_id and reporter_id references to the same table defined in UserRecord.
class TicketRecord extends TActiveRecord
{
     public $owner_id;
     public $reporter_id;

     public $owner;     // this declaration is no longer needed since v3.1.2
     public $reporter;  // this declaration is no longer needed since v3.1.2

     public static $RELATION=array
     (
         'owner' => array(self::BELONGS_TO, 'UserRecord', 'owner_id'),
         'reporter' => array(self::BELONGS_TO, 'UserRecord', 'reporter_id'),
     );
}
This is applicable to relationships including BELONGS_TO, HAS_ONE and HAS_MANY. See section Self Referenced Association Tables for solving ambiguity of MANY_TO_MANY relationships.

The "has many" relationship is not fetched automatically when you use any of the Active Record finder methods. You will need to explicitly fetch the related objects as follows. In the code below, both lines are equivalent and the method names are case insensitive.

$team = TeamRecord::finder()->withPlayers()->findAll();
$team = TeamRecord::finder()->with_players()->findAll(); //equivalent

The method with_xxx() (where xxx is the relationship property name, in this case, players) fetches the corresponding PlayerRecords using a second query (not by using a join). The with_xxx() accepts the same arguments as other finder methods of TActiveRecord, e.g. with_players('age = ?', 35).

Note: It is essential to understand that the related objects are fetched using additional queries. The first query fetches the source object, e.g. the TeamRecord in the above example code. A second query is used to fetch the corresponding related PlayerRecord objects. The usage of the two query is similar to a single query using Left-Outer join with the exception that null results on the right table are not returned. The consequence of using two or more queries is that the aggregates and other join conditions are not feasible using Active Records. For queries outside the scope of Active Record the SqlMap Data Mapper may be considered.
Info: The above with approach also works with implicitly declared related properties (introduced in version 3.1.2). So what is the difference between the with approach and the lazy loading approach? Lazy loading means we issue an SQL query if a related object is initially accessed and not ready, while the with approach queries for the related objects once for all, no matter the related objects are accessed or not. The lazy loading approach is very convenient since we do not need to explictly load the related objects, while the with approach is more efficient if multiple records are returned, each with some related objects.

Has One Relationship

The entity relationship between Players and Profiles is one to one. That is, each PlayerRecord object has one ProfileRecord object (may be none or null). A has one relationship is nearly identical to a has many relationship with the exception that the related object is only one object (not a collection of objects).

Belongs To Relationship

The "has many" relationship in the above section defines a collection of foreign objects. In particular, we have that a TeamRecord has many (zero or more) PlayerRecord objects. We can also add a back pointer by adding a property in the PlayerRecord class that links back to the TeamRecord object, effectively making the association bidirectional. We say that the $team property in PlayerRecord class belongs to a TeamRecord object. The following code defines the complete PlayerRecord class with 3 relationships.

class PlayerRecord extends TActiveRecord
{
    const TABLE='Players';
    public $player_id;
    public $age;
    public $team_name;

    public $team;              // this declaration is no longer needed since v3.1.2
    public $skills=array();    // this declaration is no longer needed since v3.1.2
    public $profile;           // this declaration is no longer needed since v3.1.2

    public static $RELATIONS=array
    (
        'team' => array(self::BELONGS_TO, 'TeamRecord', 'team_name'),
        'skills' => array(self::MANY_TO_MANY, 'SkillRecord', 'Player_Skills'),
        'profile' => array(self::HAS_ONE, 'ProfileRecord', 'player_id'),
    );

    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

The static $RELATIONS property of PlayerRecord defines that the property $team belongs to a TeamRecord. The $RELATIONS array also defines two other relationships that we shall examine in later sections below. In array(self::BELONGS_TO, 'TeamRecord', 'team_name'), the first element defines the relationship type, in this case self::BELONGS_TO; the second element is a string 'TeamRecord' that corresponds to the class name of the TeamRecord class; and the third element 'team_name' refers to the foreign key of Players referencing Teams. A player object with the corresponding team object may be fetched as follows.

$players = PlayerRecord::finder()->with_team()->findAll();

The method with_xxx() (where xxx is the relationship property name, in this case, team) fetches the corresponding TeamRecords using a second query (not by using a join). The with_xxx() accepts the same arguments as other finder methods of TActiveRecord, e.g. with_team('location = ?', 'Madrid').

Tip: Additional relationships may be fetched by chaining the with_xxx() together as the following example demonstrates.
$players = PlayerRecord::finder()->with_team()->with_skills()->findAll();
Each with_xxx() method will execute an additional SQL query. Every with_xxx() accepts arguments similar to those in the findAll() method and is only applied to that particular relationship query.

The "belongs to" relationship of ProfileRecord class is defined similarly.

class ProfileRecord extends TActiveRecord
{
    const TABLE='Profiles';
    public $player_id;
    public $salary;

    public $player;  // this declaration is no longer needed since v3.1.2

    public static $RELATIONS=array
    (
        'player' => array(self::BELONGS_TO, 'PlayerRecord'),
    );

    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

In essence, there exists a "belongs to" relationship for objects corresponding to entities that has column which are foreign keys. In particular, we see that the Profiles table has a foreign key constraint on the column player_id that relates to the Players table's player_id column. Thus, the ProfileRecord object has a property ($player) that belongs to a PlayerRecord object. Similarly, the Players table has a foreign key constraint on the column team_name that relates to the Teams table's name column. Thus, the PlayerRecord object has a property ($team) that belongs to a TeamRecord object.

Parent Child Relationships

A parent child relationship can be defined using a combination of has many and belongs to relationship that refers to the same class. The following example shows a parent children relationship between "categories" and a "parent category".

class Category extends TActiveRecord
{
    public $cat_id;
    public $category_name;
    public $parent_cat_id;

    public $parent_category;            // this declaration is no longer needed since v3.1.2
    public $child_categories=array();   // this declaration is no longer needed since v3.1.2

    public static $RELATIONS=array
    (
        'parent_category' => array(self::BELONGS_TO, 'Category', 'parent_cat_id'),
        'child_categories' => array(self::HAS_MANY, 'Category', 'parent_cat_id'),
    );
}

Query Criteria for Related Objects

In the above, we show that an Active Record object can reference to its related objects by declaring a static class member $RELATIONS which specifies a list of relations. Each relation is specified as an array consisting of three elements: relation type, related AR class name, and the foreign key(s). For example, we use array(self::HAS_MANY, 'PlayerRecord', 'team_name') to specify the players in a team. There are two more optional elements that can be specified in this array: query condition (the fourth element) and parameters (the fifth element). They are used to control how to query for the related objects. For example, if we want to obtain the players ordered by their age, we can specify array(self::HAS_MANY, 'PlayerRecord', 'team_name', 'ORDER BY age'). If we want to obtain players whose age is smaller than 30, we could use array(self::HAS_MANY, 'PlayerRecord', 'team_name', 'age<:age', array(':age'=>30)). In general, these two additional elements are similar as the parameters passed to the find() method in AR.

Association Table Mapping

Objects can handle multivalued fields quite easily by using collections as field values. Relational databases don't have this feature and are constrained to single-valued fields only. When you're mapping a one-to-many association you can handle this using has many relationships, essentially using a foreign key for the single-valued end of the association. But a many-to-many association can't do this because there is no single-valued end to hold the foreign key.

The answer is the classic resolution that's been used by relational data people for decades: create an extra table (an association table) to record the relationship. The basic idea is using an association table to store the association. This table has only the foreign key IDs for the two tables that are linked together, it has one row for each pair of associated objects.

The association table has no corresponding in-memory object and its primary key is the compound of the two primary keys of the tables that are associated. In simple terms, to load data from the association table you perform two queries (in general, it may also be achieved using one query consisting of joins). Consider loading the SkillRecord collection for a list PlayerRecord objects. In this case, you do queries in two stages. The first stage queries the Players table to find all the rows of the players you want. The second stage finds the SkillRecord object for the related player ID for each row in the Player_Skills association table using an inner join.

The Prado Active Record design implements the two stage approach. For the Players-Skills M-N (many-to-many) entity relationship, we define a many-to-many relationship in the PlayerRecord class and in addition we may define a many-to-many relationship in the SkillRecord class as well. The following sample code defines the complete SkillRecord class with a many-to-many relationship with the PlayerRecord class. (See the PlayerRecord class definition above to the corresponding many-to-many relationship with the SkillRecord class.)

class SkillRecord extends TActiveRecord
{
    const TABLE='Skills';
    public $skill_id;
    public $name;

    public $players=array();    // this declaration is no longer needed since v3.1.2

    public static $RELATIONS=array
    (
        'players' => array(self::MANY_TO_MANY, 'PlayerRecord', 'Player_Skills'),
    );

    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

The static $RELATIONS property of SkillRecord defines that the property $players has many PlayerRecords via an association table 'Player_Skills'. In array(self::MANY_TO_MANY, 'PlayerRecord', 'Player_Skills'), the first element defines the relationship type, in this case self::MANY_TO_MANY, the second element is a string 'PlayerRecord' that corresponds to the class name of the PlayerRecord class, and the third element is the name of the association table name.

Note: Prior to version 3.1.2 (versions up to 3.1.1), the many-to-many relationship was defined using self::HAS_MANY. For version 3.1.2 onwards, this must be changed to self::MANY_TO_MANY. This can be done by searching for the HAS_MANY in your source code and carfully changing the appropriate definitions.

A list of player objects with the corresponding collection of skill objects may be fetched as follows.

$players = PlayerRecord::finder()->withSkills()->findAll();

The method with_xxx() (where xxx is the relationship property name, in this case, Skill) fetches the corresponding SkillRecords using a second query (not by using a join). The with_xxx() accepts the same arguments as other finder methods of TActiveRecord.

Self Referenced Association Tables

For self referenced association tables, that is, the association points to the same table. For example, consider the items table with M-N related item via the related_items association table. The syntax in the following example is valid for a PostgreSQL database. For other database, consult their respective documentation for defining the foreign key constraints.

CREATE TABLE items
(
  "item_id" SERIAL,
  "name" VARCHAR(128) NOT NULL,
  PRIMARY KEY("item_id")
);
CREATE TABLE "related_items"
(
  "item_id" INTEGER NOT NULL,
  "related_item_id" INTEGER NOT NULL,
  CONSTRAINT "related_items_pkey" PRIMARY KEY("item_id", "related_item_id"),
  CONSTRAINT "related_items_item_id_fkey" FOREIGN KEY ("item_id")
    REFERENCES "items"("item_id")
    ON DELETE CASCADE
    ON UPDATE NO ACTION
    NOT DEFERRABLE,
  CONSTRAINT "related_items_related_item_id_fkey" FOREIGN KEY ("related_item_id")
    REFERENCES "items"("item_id")
    ON DELETE CASCADE
    ON UPDATE NO ACTION
    NOT DEFERRABLE
);

The association table name in third element of the relationship array may contain the foreign table column names. The columns defined in the association table must also be defined in the record class (e.g. the $related_item_id property corresponds to the related_item_id column in the related_items table).

class Item extends TActiveRecord
{
    const TABLE="items";
    public $item_id;
    public $details;

    //additional foreign item id defined in the association table
    public $related_item_id;
    public $related_items=array();    // this declaration is no longer needed since v3.1.2

    public static $RELATIONS=array
    (
        'related_items' => array(self::MANY_TO_MANY,
            'Item', 'related_items.related_item_id'),
    );
}
Tip: Compound keys in the foreign table can be specified as comma separated values between brackets. E.g. 'related_items.(id1,id2)'.

Lazy Loading Related Objects

Note: Implicitly declared related properties introduced in version 3.1.2 automatically have lazy loading feature. Therefore, the lazy loading technique described in the following is no longer needed in most of the cases, unless you want to manipulate the related objects through getter/setter.

Using the with_xxx() methods will load the relationship record on demand. Retrieving the related record using lazy loading (that is, only when those related objects are accessed) can be achieved by using a feature of the TComponent that provides accessor methods. In particular, we define a pair of getter and setter methods where the getter method will retrieve the relationship conditionally. The following example illustrates that the PlayerRecord can retrieve its $skills foreign objects conditionally.

class PlayerRecord extends BaseFkRecord
{
    //... other properties and methods as before

    private $_skills; //change to private and default as null

    public function getSkills()
    {
        if($this->_skills===null && $this->player_id !==null)
        {
            //lazy load the skill records
            $this->setSkills($this->withSkills()->findByPk($this->player_id)->skills);
        }
        else if($this->_skills===null)
        {
            //create new TList;
            $this->setSkills(new TList());
        }

        return $this->_skills;
    }

    public function setSkills($value)
    {
        $this->_skills = $value instanceof TList ? $value : new TList($value);
    }
}

We first need to change the $skills=array() declaration to a private property $_skills (notice the underscore) and set it to null instead. This allows us to define the skills property using getter/setter methods (see Components for details). The getSkills() getter method for the skills property will lazy load the corresponding skills foreign record when it is used as follows. Notice that we only do a lazy load when its $player_id is not null (that is, when the record is already fetched from the database or player id was already set).

$player = PlayerRecord::finder()->findByPk(1);
var_dump($player->skills); //lazy load it on first access
var_dump($player->skills[0]); //already loaded skills property
$player->skills[] = new SkillRecord(); //add skill

The setSkills() ensures that the skills property will always be a TList. Using a TList allows us to set the elements of the skills property as if they were arrays. E.g. $player->skills[] = new SkillRecord(). If array was used, a PHP error will be thrown.

Column Mapping

Since v3.1.1, Active Record starts to support column mapping. Column mapping allows developers to address columns in Active Record using a more consistent naming convention. In particular, using column mapping, one can access a column using whatever name he likes, rather than limited by the name defined in the database schema.

To use column mapping, declare a static array named COLUMN_MAPPING in the Active Record class. The keys of the array are column names (called physical column names) as defined in the database schema, while the values are corresponding property names (called logical column names) defined in the Active Record class. The property names can be either public class member variable names or component property names defined via getters/setters. If a physical column name happens to be the same as the logical column name, they do not need to be listed in COLUMN_MAPPING.

class UserRecord extends TActiveRecord
{
    const TABLE='users';
    public static $COLUMN_MAPPING=array
    (
        'user_id'=>'id',
        'email_address'=>'email',
        'first_name'=>'firstName',
        'last_name'=>'lastName',
    );
    public $id;
    public $username; // the physical and logical column names are the same
    public $email;
    public $firstName;
    public $lastName;
    //....
}

With the above column mapping, we can address first_name using $userRecord->firstName instead of $userRecord->first_name. This helps separation of logic and model.

References

  • Fowler et. al. Patterns of Enterprise Application Architecture, Addison Wesley, 2002.
  • B. Venners with B. Eckel. Inappropriate Abstractions - A Conversation with Anders Hejlsberg, Part VI. Artima Developer, 2003.
$Id: ActiveRecord.page 2530 2008-10-16 09:03:39Z mikl $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Active Record Scaffold Views

Available from Prado versions 3.1b onwards.

Active Record classes can be used together with TScaffoldListView and TScaffoldEditView ( TScaffoldView links both TScaffoldListView and TScaffoldEditView) to create simple Create/Read/Update/Delete (CRUD) web applications.

The scaffold views are intended to assist in prototyping web application, they are not designed to be as customiziable as more complex components such as TDataGrid. The scaffold views provide the following builtin functionality:

  • Listing of all active record items.
  • Searching records.
  • Paging and sorting.
  • Deleting an item.
  • Inserting a new item.
  • Updating an existing item.
  • Validates required fields and basic data types.
  • Presents specialized controls such as date pickers.

Scaffold views are dependent on Active Records and currently supports the following databases: Mysql, Sqlite and Postgres SQL. Support for other databases can be considered when there are sufficient demand.

Setting up a Scaffold View

To use the scaffold view, we first define an Active Record class that represents a table or view in the database. Consider the following Active Record class that corresponds to the users table as defined in the Active Record quickstart page.

class UserRecord extends TActiveRecord
{
    const TABLE='users';

    public $username;
    public $email;
}

The scaffold view classes are in the System.Data.ActiveRecord.Scaffold.* namespace. This namespace can be "imported" in the Application Configuration using the application.xml file or through the php code using the Prado::using() method. To start using the TScaffoldView simply set the RecordClass property value equal to an Active Record class name.

<com:TScaffoldView RecordClass="UserRecord" />

The above code will list the current records in the users table. Each record can be edited by clicking on the "edit" button and deleted by clicking on the "delete" button. A new record can be added by clicking on the "Add new record" button, enter some data (notice the automatic validation of required fields and data types), and click the "save" button. Specifying search terms in the search textbox to find particular records. Finally, the record list can be sorted for each column by changing the sorting column and order.

The TScaffoldView is a template control composed of other scaffold controls. The following properties gives access to these composite controls.

  • ListView -- the TScaffoldListView displaying the record list.
  • EditView -- the TScaffoldEditView that renders the inputs for editing and adding records.
  • SearchControl -- the TScaffoldSearch responsible to the search user interface.

All these composite controls can be customized as we shall see below.

TScaffoldListView

A list of Active Records can be displayed using the TScaffoldListView with the following useful properties.

  • Header -- a TRepeater displaying the Active Record property/field names.
  • Sort -- a TDropDownList displaying the combination of properties and its possible ordering.
  • Pager -- a TPager control displaying the links and/or buttons that navigate to different pages in the Active Record data.
  • List -- a TRepeater that renders a row of Active Record data.

Custom rendering of the each Active Record can be achieved by specifying the ItemTemplate and/or AlternatingItemTemplate property of the List repeater. The TScaffoldListView will listen for two command events named "delete" and "edit". A "delete" command will delete a the record for the row where the "delete" command originates. An "edit" command will push the record data to be edited by a TScaffoldEditView with ID specified by the EditViewID property. The following example lists the usernames only with bold formatting.

<com:TScaffoldListView RecordClass="UserRecord" >
    <prop:List.ItemTemplate>
        <strong><%# $this->Data->username %></strong>
    </prop:List.ItemTemplate>
</com:TScaffoldListView>
Info: For the TScaffoldView the list view can be accessed throught the ListView property of a TScaffoldView. Thus, the subproperty ListView.List.ItemTemplate on TScaffoldView is equivalent to the List.ItemTemplate subproperty of TScaffoldListView in the above example.

The SearchCondition property and SearchParameters property (takes array values) can be specified to customize the records to be shown. The SearchCondition will be used as the Condition property of TActiveRecordCriteria and the SearchParameters property corresponds to Parameters property of TActiveRecordCriteria.

TScaffoldEditView

<com:TScaffoldEditView RecordPk="user1" RecordClass="UserRecord" />

Combining list + edit views

<com:TScaffoldEditView ID="edit_view" RecordClass="UserRecord" />
<com:TScaffoldListView EditViewID="edit_view" RecordClass="UserRecord" />

Customizing the TScaffoldView

<com:TScaffoldView RecordClass="UserRecord" >
    <prop:ListView.List.ItemTemplate>
        <%# $this->DataItem->username %>
        <com:TLinkButton Text="Edit" CommandName="edit" />
    </prop:ListView.List.ItemTemplate>
</com:TScaffoldView/>
$Id: Scaffold.page 1902 2007-05-07 04:17:37Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Data Mapper

Available from Prado versions 3.1a onwards.

Data Mappers moves data between objects and a database while keeping them independent of each other and the mapper itself. If you started with Active Records, you may eventually faced with more complex business objects as your project progresses. When you build an object model with a lot of business logic it's valuable to use these mechanisms to better organize the data and the behavior that goes with it. Doing so leads to variant schemas; that is, the object schema and the relational schema don't match up.

The Data Mapper separates the in-memory objects from the database. Its responsibility is to transfer data between the two and also to isolate them from each other. With Data Mapper the in-memory objects needn't know even that there's a database present; they need no SQL interface code, and certainly no knowledge of the database schema. (The database schema is always ignorant of the objects that use it.)

When to Use It

The primary occasion for using Data Mapper is when you want the database schema and the object model to evolve independently. Data Mapper's primary benefit is that when working on the business (or domain) objects you can ignore the database, both in design and in the build and testing process. The domain objects have no idea what the database structure is, because all the correspondence is done by the mappers.

This helps you in the code because you can understand and work with the domain objects without having to understand how they're stored in the database. You can modify the business models or the database without having to alter either. With complicated mappings, particularly those involving existing databases, this is very valuable.

The price, of course, is the extra layer that you don't get with Active Record, so the test for using these patterns is the complexity of the business logic. If you have fairly simple business logic, an Active Record will probably work. For more complicated logic a Data Mapper may be more suitable.

SqlMap Data Mapper

The SqlMap DataMapper framework makes it easier to use a database with a PHP application. SqlMap DataMapper couples objects with stored procedures or SQL statements using a XML descriptor. Simplicity is the biggest advantage of the SqlMap DataMapper over object relational mapping tools. To use SqlMap DataMapper you rely on your own objects, XML, and SQL. There is little to learn that you don't already know. With SqlMap DataMapper you have the full power of both SQL and stored procedures at your fingertip

SqlMap Data Mapper Overview Here's a high level description of the work flow illustrated in the figure above. Provide a parameter, either as an object or a primitive type. The parameter can be used to set runtime values in your SQL statement or stored procedure. If a runtime value is not needed, the parameter can be omitted.

Execute the mapping by passing the parameter and the name you gave the statement or procedure in your XML descriptor. This step is where the magic happens. The framework will prepare the SQL statement or stored procedure, set any runtime values using your parameter, execute the procedure or statement, and return the result.

In the case of an update, the number of rows affected is returned. In the case of a query, a single object, or a collection of objects is returned. Like the parameter, the result object, or collection of objects, can be a plain-old object or a primitive PHP type.

Setting up a database connection and initializing the SqlMap

A database connection for SqlMap can be set as follows. See Establishing Database Connection for futher details regarding creation of database connection in general.

//create a connection and give it to the SqlMap manager.
$dsn = 'pgsql:host=localhost;dbname=test'; //Postgres SQL
$conn = new TDbConnection($dsn, 'dbuser','dbpass');
$manager = new TSqlMapManager($conn);
$manager->configureXml('my-sqlmap.xml');
$sqlmap = $manager->getSqlMapGateway();

The TSqlMapManager is responsible for setting up the database connection and configuring the SqlMap with given XML file(s). The configureXml() method accepts a string that points to a SqlMap XML configuration file. Once configured, call the getSqlMapGateway() method to obtain an instance of the SqlMap gateway interface (use this object to insert/delete/find records).

SqlMap database connection can also be configured using a <module> tag in the application.xml or config.xml as follows.

<modules>
  <module id="my-sqlmap" class="System.Data.SqlMap.TSqlMapConfig"
        EnableCache="true" ConfigFile="my-sqlmap.xml" >
    <database ConnectionString="pgsql:host=localhost;dbname=test"
        Username="dbuser" Password="dbpass" />
  </module>
</modules>

The ConfigFile attribute should point to a SqlMap configuration file (to be detailed later) either using absolute path, relative path or the Prado's namespace dot notation path (must omit the ".xml" extension).

Tip: The EnableCache attribute when set to "true" will cache the parsed configuration. You must clear or disable the cache if you make changes to your configuration file. A cache module must also be defined for the cache to function.

To obtain the SqlMap gateway interface from the <module> configuration, simply do, for example,

class MyPage extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        $sqlmap = $this->Application->Modules['my-sqlmap']->Client;
        $sqlmap->queryForObject(...); //query for some object
    }
}

A quick example

Let us consider the following "users" table that contains two columns named "username" and "email", where "username" is also the primary key.

CREATE TABLE users
(
    username VARCHAR( 20 ) NOT NULL ,
    email VARCHAR( 200 ) ,
    PRIMARY KEY ( username )
);

Next we define our plain User class as follows. Notice that the User is very simple.

class User
{
    public $username;
    public $email;
}

Next, we need to define a SqlMap XMl configuration file, lets name the file as my-sqlmap.xml

<?xml version="1.0" encoding="utf-8" ?>
<sqlMapConfig>
    <select id="SelectUsers" resultClass="User">
        SELECT username, email FROM users
    </select>
</sqlMapConfig>

The <select> tag returns defines an SQL statement. The id attribute will be used as the identifier for the query. The resultClass attribute value is the name of the class the the objects to be returned. We can now query the objects as follows:

//assume that $sqlmap is an TSqlMapGateway instance
$userList = $sqlmap->queryForList("SelectUsers");

//Or just one, if that's all you need:
$user = $sqlmap->queryForObject("SelectUsers");

The above example shows demonstrates only a fraction of the capabilities of the SqlMap Data Mapper. Further details can be found in the SqlMap Manual.

Combining SqlMap with Active Records

The above example may seem trival and it also seems that there is alot work just to retrieve some data. However, notice that the User class is totally unware of been stored in the database, and the database is unware of the User class.

One of advantages of SqlMap is the ability to map complex object relationship, collections from an existing database. On the other hand, Active Record provide a very simple way to interact with the underlying database but unable to do more complicated relationship or collections. A good compromise is to use SqlMap to retrieve complicated relationships and collections as Active Record objects and then using these Active Records to do the updates, inserts and deletes.

Continuing with the previous example, we change the definition of the User class to become an Active Record.

class UserRecord extends TActiveRecord
{
    const TABLE='users'; //table name

    public $username; //the column named "username" in the "users" table
    public $email;

    /**
     * @return TActiveRecord active record finder instance
     */
    public static function finder($className=__CLASS__)
    {
        return parent::finder($className);
    }
}

We also need to change the definition of the SqlMap XML configuration. We just need to change the value of resultClass attribute to UserRecord.

<?xml version="1.0" encoding="utf-8" ?>
<sqlMapConfig>
    <select id="SelectUsers" resultClass="UserRecord">
        SELECT username, email FROM users
    </select>
</sqlMapConfig>

The PHP code for retrieving the users remains the same, but SqlMap returns Active Records instead, and we can take advantage of the Active Record methods.

//assume that $sqlmap is an TSqlMapGateway instance
$user = $sqlmap->queryForObject("SelectUsers");

$user->email = 'test@example.com'; //change data
$user->save(); //save it using Active Record

References

  • Fowler et. al. Patterns of Enterprise Application Architecture, Addison Wesley, 2002.
  • iBatis Team. iBatis Data Mapper, http://ibatis.apache.org.
$Id: SqlMap.page 2136 2007-08-20 12:09:02Z xue $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Collections

Collection is a basic data structure in programming. In traditional PHP programming, array is used widely to represent collection data structure. A PHP array is a mix of cardinal-indexed array and hash table.

To enable object-oriented manipulation of collections, PRADO provides a set of powerful collection classes. Among them, the TList and TMap are the most fundamental and usually serve as the base classes for other collection classes. Since many PRADO components have properties that are of collection type, it is very important for developers to master the usage of PRADO collection classes.

Using TList

A TList object represents a cardinal-indexed array, i.e., an array (object) with the index 0, 1, 2, ...

TList may be used like a PHP array. For example,

$list=new TList; // create a list object
...
$item=$list[$index];  // read the item at the specified index
$list[]=$item;  // append the item at the end
$list[$index]=$item; // replace the item at the specified index
unset($list[$index]); // remove the item at $index
if(isset($list[$index])) // test if the list has an item at $index
foreach($list as $index=>$item) // traverse each item in the list

To obtain the number of items in the list, use the Count property. Note, do not use count($list), as it always returns 1.

In addition, TList implements a few commonly used convenient methods for manipulating the data in a list. These include

  • clear(): removes all items in the list.
  • contains(): tests if the list contains the specified item.
  • indexOf(): obtains the zero-based index of the specified item in the list.
  • toArray(): returns an array representation of the items in the list.
  • copyFrom(): populates the list with data from an array or traversable object (including TList). Existing items will be removed first.
  • mergeWith(): appends the list with data from an array or traversable object (including TList).

Using TList-based component properties

As aforementioned, many PRADO component properties are based on TList or TList-derived collection classes. These properties all share the above usages.

For example, TControl (the base class for all PRADO controls) has a property called Controls which represents the collection of child controls. The type of Controls is TControlCollection which extends TList. Therefore, to append a new child control, we can use the following,

$control->Controls[]=$newControl;

To traverse through the child controls, we can use,

foreach($control->Controls as $childControl) ...

Another example is the Items property, available in list controls, TRepeater, TDataList and TDataGrid. In these controls, the ancestor class of Items is TList.

Extending TList

Often, we want to extend TList to perform additional operations for each addition or removal of an item. The only methods that the child class needs to override are insertAt() and removeAt(). For example, to ensure the list only contains items that are of TControl type, we can override insertAt() as follows,

public function insertAt($index,$item)
{
    if($item instanceof TControl)
        parent::insertAt($index,$item)
    else
        throw new Exception('TControl required.');
}

Using TMap

A TMap object represents a hash table (or we say string-indexed array).

Similar to TList, TMap may be used like an array,

$map=new TMap; // create a map object
...
$map[$key]=$value; // add a key-value pair
unset($map[$key]); // remove the value with the specified key
if(isset($map[$key])) // if the map contains the key
foreach($map as $key=>$value) // traverse the items in the map

The Count property gives the number of items in the map while the Keys property returns a list of keys used in the map.

The following methods are provided by TMap for convenience,

  • clear(): removes all items in the map.
  • contains(): tests if the map contains the specified key.
  • toArray(): returns an array representation of the items in the map.
  • copyFrom(): populates the map with data from an array or traversable object (including TMap). Existing items will be removed first.
  • mergeWith(): appends the map with data from an array or traversable object (including TMap).

Using of TAttributeCollection

TAttributeCollection is a special class extending from TMap. It is mainly used by the Attributes property of TControl.

Besides the normal functionalities provided by TMap, TAttributeCollection allows you to get and set collection items like getting and setting properties. For example,

$collection->Label='value'; // equivalent to: $collection['Label']='value';
echo $collection->Label; // equivalent to: echo $collection['Label'];

Note, in the above $collection does NOT have a Label property.

Unlike TMap, keys in TAttributeCollection are case-insensitive. Therefore, $collection->Label is equivalent to $collection->LABEL.

Because of the above new features, when dealing with the Attributes property of controls, we may take advantage of the subproperty concept and configure control attribute values in a template as follows,

<com:TButton Attributes.onclick="if(!confirm('Are you sure?')) return false;" .../>

which adds an attribute named onclick to the TButton control.

$Id: Collections.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Authentication and Authorization

Authentication is a process of verifying whether someone is who he claims he is. It usually involves a username and a password, but may include any other methods of demonstrating identity, such as a smart card, fingerprints, etc.

Authorization is finding out if the person, once identified, is permitted to manipulate specific resources. This is usually determined by finding out if that person is of a particular role that has access to the resources.

How PRADO Auth Framework Works

PRADO provides an extensible authentication/authorization framework. As described in application lifecycles, TApplication reserves several lifecycles for modules responsible for authentication and authorization. PRADO provides the TAuthManager module for such purposes. Developers can plug in their own auth modules easily. TAuthManager is designed to be used together with TUserManager module, which implements a read-only user database.

When a page request occurs, TAuthManager will try to restore user information from session. If no user information is found, the user is considered as an anonymous or guest user. To facilitate user identity verification, TAuthManager provides two commonly used methods: login() and logout(). A user is logged in (verified) if his username and password entries match a record in the user database managed by TUserManager. A user is logged out if his user information is cleared from session and he needs to re-login if he makes new page requests.

During Authorization application lifecycle, which occurs after Authentication lifecycle, TAuthManager will verify if the current user has access to the requested page according to a set of authorization rules. The authorization is role-based, i.e., a user has access to a page if 1) the page explicitly states that the user has access; 2) or the user is of a particular role that has access to the page. If the user does not have access to the page, TAuthManager will redirect user browser to the login page which is specified by LoginPage property.

Using PRADO Auth Framework

To enable PRADO auth framework, add the TAuthManager module and TUserManager module to application configuration,

<service id="page" class="TPageService">
  <modules>
    <module id="auth" class="System.Security.TAuthManager"
               UserManager="users" LoginPage="UserLogin" />
    <module id="users" class="System.Security.TUserManager"
               PasswordMode="Clear">
      <user name="demo" password="demo" />
      <user name="admin" password="admin" />
    </module>
  </modules>
</service>

In the above, the UserManager property of TAuthManager is set to the users module which is TUserManager. Developers may replace it with a different user management module that is derived from TUserManager.

Authorization rules for pages are specified in page configurations as follows,

<authorization>
    <allow pages="PageID1,PageID2"
              users="User1,User2"
              roles="Role1" />
    <deny pages="PageID1,PageID2"
              users="?"
              verb="post" />
</authorization>

An authorization rule can be either an allow rule or a deny rule. Each rule consists of four optional properties:

  • pages - list of comma-separated page names that this rule applies to. If empty, not set or wildcard '*', this rule will apply to all pages under the current directory and all its subdirectories recursively.
  • users - list of comma-separated user names that this rule applies to. If empty, not set or wildcard '*', this rule will apply to all users including anonymous/guest user. A character ? refers to anonymous/guest user. And a character @ refers to authenticated users (available since v3.1).
  • roles - list of comma-separated user roles that this rule applies to. If empty, not set or wildcard '*', this rule will apply to all user roles.
  • verb - page access method that this rule applies to. It can be either get or post. If empty, not set or wildcard '*', the rule will apply to both methods.

When a page request is being processed, a list of authorization rules may be available. However, only the first effective rule matching the current user will render the authorization result.

  • Rules are ordered bottom-up, i.e., the rules contained in the configuration of current page folder go first. Rules in configurations of parent page folders go after.
  • A rule is effective if the current page is in the listed pages of the rule AND the current user action (get or post) is in the listed actions.
  • A rule matching occurs if the current user name is in the listed user names of an effective rule OR if the user's role is in the listed roles of that rule.
  • If no rule matches, the user is authorized.

In the above example, anonymous users will be denied from posting to PageID1 and PageID2, while User1 and User2 and all users of role Role1 can access the two pages (in both get and post methods).

Available from Prado versions 3.1.1 onwards.

Since version 3.1.1, the pages attribute in the authorization rules can take relative page paths with wildcard '*'. For example, pages="admin.Home" refers to the Home page under the admin directory, and pages="admin.*" would refer to all pages under the admin directory and subdirectories.

Also introduced in version 3.1.1 are IP rules. They are specified by a new attribute ips in authorization rules. The IP rules are used to determine if an authorization rule aplies to an end-user according to his IP address. One can list a few IPs together, separated by comma ','. Wildcard '*' can be used in the rules. For example, ips="192.168.0.2, 192.168.1.*" means the rule applies to users whose IP address is 192.168.0.2 or 192.168.1.*. The latter matches any host in the subnet 192.168.1. If the attribute 'ips' is empty, not set or wildcard '*', the corresponding rule will apply to requests coming from any host address.

Using TUserManager

As aforementioned, TUserManager implements a read-only user database. The user information are specified in either application configuration or an external XML file.

We have seen in the above example that two users are specified in the application configuration. Complete syntax of specifying the user and role information is as follows,

<user name="demo" password="demo" roles="demo,admin" />
<role name="admin" users="demo,demo2" />

where the roles attribute in user element is optional. User roles can be specified in either the user element or in a separate role element.

Using TDbUserManager

TDbUserManager is introduced in v3.1.0. Its main purpose is to simplify the task of managing user accounts that are stored in a database. It requires developers to write a user class that represents the necessary information for a user account. The user class must extend from TDbUser.

To use TDbUserManager, configure it in the application configuration like following:

<module id="db"
     class="System.Data.TDataSourceConfig" ..../>
<module id="users"
     class="System.Security.TDbUserManager"
     UserClass="Path.To.MyUserClass"
     ConnectionID="db" />
<module id="auth"
     class="System.Security.TAuthManager"
     UserManager="users" LoginPage="Path.To.LoginPage" />

In the above, UserClass specifies what class will be used to create user instance. The class must extend from TDbUser. ConnectionID refers to the ID of a TDataSourceConfig module which specifies how to establish database connection to retrieve user information.

The user class has to implement the two abstract methods in TDbUser: validateUser() and createUser(). Since user account information is stored in a database, the user class may make use of its DbConnection property to reach the database.

Available from Prado versions 3.1.1 onwards.

Since 3.1.1, TAuthManager provides support to allow remembering login by setting AllowAutoLogin to true. Accordingly, TDbUser adds two methods to facilitate the implementation of this feature. In particular, two new methods are introduced: createUserFromCookie() and saveUserToCookie(). Developers should implement these two methods if remembering login is needed. Below is a sample implementation:

public function createUserFromCookie($cookie)
{
    if(($data=$cookie->Value)!=='')
    {
        $application=Prado::getApplication();
        if(($data=$application->SecurityManager->validateData($data))!==false)
        {
            $data=unserialize($data);
            if(is_array($data) && count($data)===3)
            {
                list($username,$address,$token)=$data;
                $sql='SELECT passcode FROM user WHERE LOWER(username)=:username';
                $command=$this->DbConnection->createCommand($sql);
                $command->bindValue(':username',strtolower($username));
                if($token===$command->queryScalar() && $token!==false && $address=$application->Request->UserHostAddress)
                    return $this->createUser($username);
            }
        }
    }
    return null;
}

public function saveUserToCookie($cookie)
{
    $application=Prado::getApplication();
    $username=strtolower($this->Name);
    $address=$application->Request->UserHostAddress;
    $sql='SELECT passcode FROM user WHERE LOWER(username)=:username';
    $command=$this->DbConnection->createCommand($sql);
    $command->bindValue(':username',strtolower($username));
    $token=$command->queryScalar();
    $data=array($username,$address,$token);
    $data=serialize($data);
    $data=$application->SecurityManager->hashData($data);
    $cookie->setValue($data);
}
$Id: Auth.page 2245 2007-09-26 13:22:02Z xue $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Security

Viewstate Protection

Viewstate lies at the heart of PRADO. Viewstate represents data that can be used to restore pages to the state that is last seen by end users before making the current request. By default, PRADO uses hidden fields to store viewstate information.

It is extremely important to ensure that viewstate is not tampered by end users. Without protection, malicious users may inject harmful code into viewstate and unwanted instructions may be performed when page state is being restored on server side.

To prevent viewstate from being tampered, PRADO enforces viewstate HMAC (Keyed-Hashing for Message Authentication) check before restoring viewstate. Such a check can detect if the viewstate has been tampered or not by end users. Should the viewstate is modified, PRADO will stop restoring the viewstate and return an error message.

HMAC check requires a private key that should be secret to end users. Developers can either manually specify a key or let PRADO automatically generate a key. Manually specified key is useful when the application runs on a server farm. To do so, configure TSecurityManager in application configuration,

<modules>
    <module id="security"
        class="TSecurityManager"
        ValidationKey="my private key" />
</modules>

HMAC check does not prevent end users from reading the viewstate content. An added security measure is to encrypt the viewstate information so that end users cannot decipher it. To enable viewstate encryption, set the EnableStateEncryption of pages to true. This can be done in page configurations or in page code. Note, encrypting viewstate may degrade the application performance. A better strategy is to store viewstate on the server side, rather than the default hidden field.

Cross Site Scripting Prevention

Cross site scripting (also known as XSS) occurs when a web application gathers malicious data from a user. Often attackers will inject JavaScript, VBScript, ActiveX, HTML, or Flash into a vulnerable application to fool other application users and gather data from them. For example, a poorly design forum system may display user input in forum posts without any checking. An attacker can then inject a piece of malicious JavaScript code into a post so that when other users read this post, the JavaScript runs unexpectedly on their computers.

One of the most important measures to prevent XSS attacks is to check user input before displaying them. One can do HTML-encoding with the user input to achieve this goal. However, in some situations, HTML-encoding may not be preferable because it disables all HTML tags.

PRADO incorporates the work of SafeHTML and provides developers with a useful component called TSafeHtml. By enclosing content within a TSafeHtml component tag, the enclosed content are ensured to be safe to end users. In addition, the commonly used TTextBox has a SafeText property which contains user input that are ensured to be safe if displayed directly to end users.

Cookie Attack Prevention

Protecting cookies from being attacked is of extreme important, as session IDs are commonly stored in cookies. If one gets hold of a session ID, he essentially owns all relevant session information.

There are several countermeasures to prevent cookies from being attacked.

  • An application can use SSL to create a secure communication channel and only pass the authentication cookie over an HTTPS connection. Attackers are thus unable to decipher the contents in the transferred cookies.
  • Expire sessions appropriately, including all cookies and session tokens, to reduce the likelihood of being attacked.
  • Prevent cross-site scripting (XSS) which causes arbitrary code to run in a user's browser and expose his cookies.
  • Validate cookie data and detect if they are altered.

PRADO implements a cookie validation scheme that prevents cookies from being modified. In particular, it does HMAC check for the cookie values if cookie validation is enable.

Cookie validation is disabled by default. To enable it, configure the THttpRequest module as follows,

<modules>
  <module id="request" class="THttpRequest" EnableCookieValidation="true" />
</modules>

To make use of cookie validation scheme provided by PRADO, you also need to retrieve cookies through the Cookies collection of THttpRequest by using the following PHP statements,

foreach($this->Request->Cookies as $cookie)
    // $cookie is of type THttpCookie

To send cookie data encoded with validation information, create new THttpCookie objects and add them to the Cookies collection of THttpResponse,

$cookie=new THttpCookie($name,$value);
$this->Response->Cookies[]=$cookie;
$Id: Security.page 1741 2007-03-05 16:05:43Z xue $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Assets

Assets are resource files (such as images, sounds, videos, CSS stylesheets, javascripts, etc.) that belong to specific component classes. Assets are meant to be provided to Web users. For better reusability and easier deployment of the corresponding component classes, assets should reside together with the component class files . For example, a toggle button may use two images, stored in file down.gif and up.gif, to show different toggle states. If we require the image files be stored under images directory under the Web server document root, it would be inconvenient for the users of the toggle button component, because each time they develop or deploy a new application, they would have to manually copy the image files to that specific directory. To eliminate this requirement, a directory relative to the component class file should be used for storing the image files. A common strategy is to use the directory containing the component class file to store the asset files.

Because directories containing component class files are normally inaccessible by Web users, PRADO implements an asset publishing scheme to make available the assets to Web users. An asset, after being published, will have a URL by which Web users can retrieve the asset file.

Asset Publishing

PRADO provides several methods for publishing assets or directories containing assets:

  • In a template file, you can use asset tags to publish assets and obtain their URLs. Note, the assets must be relative to the directory containing the template file.
  • In PHP code, you can call $object->publishAsset($assetPath) to publish an asset and obtain its URL. Here, $object refers to an instance of TApplicationComponent or derived class, and $assetPath is a file or directory relative to the directory containing the class file.
  • If you want to publish an arbitrary asset, you need to call TAssetManager::publishFilePath($path).

BE AWARE: Be very careful with assets publishing, because it gives Web users access to files that were previously inaccessible to them. Make sure that you do not publish files that do not want Web users to see.

Customization

Asset publishing is managed by the System.Web.TAssetManager module. By default, all published asset files are stored under the [AppEntryPath]/assets directory, where AppEntryPath refers to the directory containing the application entry script. Make sure the assets directory is writable by the Web server process. You may change this directory to another by configuring the BasePath and BaseUrl properties of the TAssetManager module in application configuration,

<modules>
    <module id="asset"
            class="System.Web.TAssetManager"
            BasePath="Web.images"
            BaseUrl="images" />
</modules>

Performance

PRADO uses caching techniques to ensure the efficiency of asset publishing. Publishing an asset essentially requires file copy operation, which is expensive. To save unnecessary file copy operations, System.Web.TAssetManager only publishes an asset when it has a newer file modification time than the published file. When an application runs under the Performance mode, such timestamp checking is also omitted.

ADVISORY: Do not overuse asset publishing. The asset concept is mainly used to help better reuse and redistribute component classes. Normally, you should not use asset publishing for resources that are not bound to any component in an application. For example, you should not use asset publishing for images that are mainly used as design elements (e.g. logos, background images, etc.) Let Web server to directly serve these images will help improve the performance of your application.

A Toggle Button Example

We now use the toggle button example to explain the usage of assets. The control uses two image files up.gif and down.gif, which are stored under the directory containing the control class file. When the button is in Up state, we would like to show the up.gif image. This can be done as follows,

class ToggleButton extends TWebControl {
    ...
    protected function addAttributesToRender($writer) {
        ...
        if($this->getState()==='Up') {
            $url=$this->getAsset('up.gif');
            $writer->addAttribute('src',$url);
        }
        ...
    }
    ...
}

In the above, the call $this->getAsset('up.gif') will publish the up.gif image file and return a URL for the published image file. The URL is then rendered as the src attribute of the HTML image tag.

To redistribute ToggleButton, simply pack together the class file and the image files. Users of ToggleButton merely need to unpack the file, and they can use it right away, without worrying about where to copy the image files to.

$Id: Assets.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Master and Content

Pages in a Web application often share common portions. For example, all pages of this tutorial application share the same header and footer portions. If we repeatedly put header and footer in every page source file, it will be a maintenance headache if in future we want to something in the header or footer. To solve this problem, PRADO introduces the concept of master and content. It is essentially a decorator pattern, with content being decorated by master.

Master and content only apply to template controls (controls extending TTemplateControl or its child classes). A template control can have at most one master control and one or several contents (each represented by a TContent control). Contents will be inserted into the master control at places reserved by TContentPlaceHolder controls. And the presentation of the template control is that of the master control with TContentPlaceHolder replaced by TContent.

For example, assume a template control has the following template:

<%@ MasterClass="MasterControl" %>
<com:TContent ID="A" >
content A
</com:TContent >
<com:TContent ID="B" >
content B
</com:TContent >
<com:TContent ID="B" >
content B
</com:TContent >

which uses MasterControl as its master control. The master control has the following template,

other stuff
<com:TContentPlaceHolder ID="A" />
other stuff
<com:TContentPlaceHolder ID="B" />
other stuff
<com:TContentPlaceHolder ID="C" />
other stuff

Then, the contents are inserted into the master control according to the following diagram, while the resulting parent-child relationship can be shown in the next diagram. Note, the template control discards everything in the template other than the contents, while the master control keeps everything and replaces the content placeholders with the contents according to ID matching.

Master and Content Parent-child relationship between master and content

Master vs. External Template

Master is very similar to external templates which are introduced since version 3.0.5. A special include tag is used to include an external template file into a base template.

Both master and external template can be used to share common contents among pages. A master is a template control whose template contains the common content and whose class file contains the logic associated with the master. An external template, on the other hand, is a pure template file without any class files.

Therefore, use master control if the common content has to be associated with some logic, such as a page header with search box or login box. A master control allows you to specify how the common content should interact with end users. If you use external templates, you will have to put the needed logic in the page or control class who owns the base template.

Performancewise, external template is lighter than master as the latter is a self-contained control participating the page lifecycles, while the former is used only when the template is being parsed.

$Id: MasterContent.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Themes and Skins

Introduction

Themes in PRADO provide a way for developers to provide a consistent look-and-feel across an entire web application. A theme contains a list of initial values for properties of various control types. When applying a theme to a page, all controls on that page will receive the corresponding initial property values from the theme. This allows themes to interact with the rich property sets of the various PRADO controls, meaning that themes can be used to specify a large range of presentational properties that other theming methods (e.g. CSS) cannot. For example, themes could be used to specify the default page size of all data grids across an application by specifying a default value for the PageSize property of the TDataGrid control.

Understanding Themes

A theme is a directory consists of skin files, javascript files and CSS files. Any javascript or CSS files contained in a theme will be registered with the page that the theme is applied to. A skin is a set of initial property values for a particular control type. A control type may have one or several skins, each identified by a unique SkinID. When applying a theme to a page, a skin is applied to a control if the control type and the SkinID value both match to those of the skin. Note, if a skin has an empty SkinID value, it will apply to all controls of the particular type whose SkinID is not set or empty. A skin file consists of one or several skins, for one or several control types. A theme is the union of skins defined in all skin files.

Using Themes

To use a theme, you need to set the Theme property of the page with the theme name, which is the theme directory name. You may set it in either page configurations or in the constructor or onPreInit() method of the page. You cannot set the property after onPreInit() because by that time, child controls of the page are already created (skins must be applied to controls right after they are created.)

To use a particular skin in the theme for a control, set SkinID property of the control in template like following,

<com:TButton SkinID="Blue" ... />

This will apply the 'Blue' skin to the button. Note, the initial property values specified by the 'Blue' skin will overwrite any existing property values of the button. Use stylesheet theme if you do not want them to be overwritten. To use stylesheet theme, set the StyleSheetTheme property of the page instead of Theme (you can have both StyleSheetTheme and Theme).

To use the Javascript files and CSS files contained in a theme, a THead control must be placed on the page template. This is because the theme will register those files with the page and THead is the right place to load those files.

It is possible to specify media types of CSS files contained in a theme. By default, a CSS file applies to all media types. If the CSS file is named like mystyle.print.css, it will be applied only to print media type. As another example, mystyle.screen.css applies to screen media only, and mystyle.css applies to all media types.

Theme Storage

All themes by default must be placed under the [AppEntryPath]/themes directory, where AppEntryPath refers to the directory containing the application entry script. If you want to use a different directory, configure the BasePath and BaseUrl properties of the System.Web.UI.TThemeManager module in application configuration,

<service id="page" class="TPageService">
    <modules>
        <module id="theme"
                class="System.Web.UI.TThemeManager"
                BasePath="mythemes"
                BaseUrl="mythemes" />
    </modules>
</service>

Creating Themes

Creating a theme involves creating the theme directory and writing skin files (and possibly Javascript and CSS files). The name of skin files must be terminated with .skin. The format of skin files are the same as that of control template files. Since skin files do not define parent-child presentational relationship among controls, you cannot place a component tag within another. And any static texts between component tags are discarded. To define the aforementioned 'Blue' skin for TButton, write the following in a skin file,

<com:TButton SkinID="Blue" BackColor="blue" />

As aforementioned, you can put several skins within a single skin file, or split them into several files. A commonly used strategy is that each skin file only contains skins for one type of controls. For example, Button.skin would contain skins only for the TButton control type.

$Id: Themes.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Persistent State

Web applications often need to remember what an end user has done in previous page requests so that the new page request can be served accordingly. State persistence is to address this problem. Traditionally, if a page needs to keep track of user interactions, it will resort to session, cookie, or hidden fields. PRADO provides a new line of state persistence schemes, including view state, control state, and application state.

View State

View state lies at the heart of PRADO. With view state, Web pages become stateful and are capable of restoring pages to the state that end users interacted with before the current page request. Web programming thus resembles to Windows GUI programming, and developers can think continuously without worrying about the round trips between end users and the Web server. For example, with view state, a textbox control is able to detect if the user input changes the content in the textbox.

View state is only available to controls. View state of a control can be disabled by setting its EnableViewState property to false. To store a variable in view state, call the following,

$this->setViewState('Caption',$caption);

where $this refers to the control object, Caption is a unique key identifying the $caption variable stored in viewstate. To retrieve the variable back from view state, call the following,

$caption = $this->getViewState('Caption');

Control State

Control state is like view state in every aspect except that control state cannot be disabled. Control state is intended to be used for storing crucial state information without which a page or control may not work properly.

To store and retrieve a variable in control state, use the following commands,

$this->setControlState('Caption',$caption);
$caption = $this->getControlState('Caption');

Application State

Application state refers to data that is persistent across user sessions and page requests. A typical example of application state is the user visit counter. The counter value is persistent even if the current user session terminates. Note, view state and control state are lost if the user requests for a different page, while session state is lost if the user session terminates.

To store and retrieve a variable in application state, use the following commands,

$application->setGlobalState('Caption',$caption);
$caption = $application->getGlobalState('Caption');

Session State

PRADO encapsulates the traditional session management in THttpSession module. The module can be accessed from within any component by using $this->Session, where $this refers to the component object.

$Id: State.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Logging

PRADO provides a highly flexible and extensible logging functionality. Messages logged can be classified according to log levels and message categories. Using level and category filters, the messages can be further routed to different destinations, such as files, emails, browser windows, etc. The following diagram shows the basic architecture of PRADO logging mechanism,

Using Logging Functions

The following two methods are provided for logging messages in PRADO,

Prado::log($message, $logLevel, $category);
Prado::trace($message, $category);

The difference between Prado::log() and Prado::trace() is that the latter automatically selects the log level according to the application mode. If the application is in Debug mode, stack trace information is appended to the messages. Prado::trace() is widely used in the core code of the PRADO framework.

Message Routing

Messages logged using the above two functions are kept in memory. To make use of the messages, developers need to route them to specific destinations, such as files, emails, or browser windows. The message routing is managed by System.Util.TLogRouter module. When plugged into an application, it can route the messages to different destination in parallel. Currently, PRADO provides four types of routes:

  • TFileLogRoute - filtered messages are stored in a specified log file. By default, this file is named prado.log under the runtime directory of the application. File rotation is provided.
  • TEmailLogRoute - filtered messages are sent to pre-specified email addresses.
  • TBrowserLogRoute - filtered messages are appended to the end of the current page output.
  • TFirebugLogRoute - filtered messages are sent to the Firebug console

To enable message routing, plug in and configure the TLogRouter module in application configuration,

<module id="log" class="System.Util.TLogRouter">
  <route class="TBrowserLogRoute"
      Levels="Info"
      Categories="System.Web.UI.TPage, System.Web.UI.WebControls" />
  <route class="TFileLogRoute"
      Levels="Warning, Error"
      Categories="System.Web" />
</module>

In the above, the Levels and Categories specify the log and category filters to selectively retrieve the messages to the corresponding destinations.

Message Filtering

Messages can be filtered according to their log levels and categories. Each log message is associated with a log level and a category. With levels and categories, developers can selectively retrieve messages that they are interested on.

Log levels defined in System.Util.TLogger include : DEBUG, INFO, NOTICE, WARNING, ERROR, ALERT, FATAL. Messages can be filtered according log level criteria. For example, if a filter specifies WARNING and ERROR levels, then only those messages that are of WARNING and ERROR will be returned.

Message categories are hierarchical. A category whose name is the prefix of another is said to be the ancestor category of the other category. For example, System.Web category is the ancestor of System.Web.UI and System.Web.UI.WebControls categories. Messages can be selectively retrieved using such hierarchical category filters. For example, if the category filter is System.Web, then all messages in the System.Web are returned. In addition, messages in the child categories, such as System.Web.UI.WebControls, are also returned.

By convention, the messages logged in the core code of PRADO are categorized according to the namespace of the corresponding classes. For example, messages logged in TPage will be of category System.Web.UI.TPage.

$Id: Logging.page 2380 2008-02-22 17:24:05Z tof $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Error Handling and Reporting

PRADO provides a complete error handling and reporting framework based on the PHP 5 exception mechanism.

Exception Classes

Errors occur in a PRADO application may be classified into three categories: those caused by PHP script parsing, those caused by wrong code (such as calling an undefined function, setting an unknown property), and those caused by improper use of the Web application by client users (such as attempting to access restricted pages). PRADO is unable to deal with the first category of errors because they cannot be caught in PHP code. PRADO provides an exception hierarchy to deal with the second and third categories.

All errors in PRADO applications are represented as exceptions. The base class for all PRADO exceptions is TException. It provides the message internationalization functionality to all system exceptions. An error message may be translated into different languages according to the user browser's language preference.

Exceptions raised due to improper usage of the PRADO framework inherit from TSystemException, which can be one of the following exception classes:

  • TConfigurationException - improper configuration, such as error in application configuration, control templates, etc.
  • TInvalidDataValueException - data value is incorrect or unexpected.
  • TInvalidDataTypeException - data type is incorrect or unexpected.
  • TInvalidDataFormatException - format of data is incorrect.
  • TInvalidOperationException - invalid operation request.
  • TPhpErrorException - catchable PHP errors, warnings, notices, etc.
  • TSecurityException - errors related with security.
  • TIOException - IO operation error, such as file open failure.
  • TDBException - errors related with database operations.
  • TNotSupportedException - errors caused by requesting for unsupported feature.
  • THttpException - errors to be displayed to Web client users.

Errors due to improper usage of the Web application by client users inherit from TApplicationException.

Raising Exceptions

Raising exceptions in PRADO has no difference than raising a normal PHP exception. The only thing matters is to raise the right exception. In general, exceptions meant to be shown to application users should use THttpException, while exceptions shown to developers should use other exception classes.

Error Capturing and Reporting

Exceptions raised during the runtime of PRADO applications are captured by System.Exceptions.TErrorHandler module. Different output templates are used to display the captured exceptions. THttpException is assumed to contain error messages that are meant for application end users and thus uses a specific group of templates. For all other exceptions, a common template shown as follows is used for presenting the exceptions.

Customizing Error Display

Developers can customize the presentation of exception messages. By default, all error output templates are stored under framework/Exceptions/templates. The location can be changed by configuring TErrorHandler in application configuration,

<module id="error"
    class="TErrorHandler"
    ErrorTemplatePath="Application.ErrorTemplates" />

THttpException uses a set of templates that are differentiated according to different StatusCode property value of THttpException. StatusCode has the same meaning as the status code in HTTP protocol. For example, a status code equal to 404 means the requested URL is not found on the server. The StatusCode value is used to select which output template to use. The output template files use the following naming convention:

error<status code>-<language code>.html

where status code refers to the StatusCode property value of THttpException, and language code must be a valid language such as en, zh, fr, etc. When a THttpException is raised, PRADO will select an appropriate template for displaying the exception message. PRADO will first locate a template file whose name contains the status code and whose language is preferred by the client browser window. If such a template is not present, it will look for a template that has the same status code but without language code.

The naming convention for the template files used for all other exceptions is as follows,

exception-<language code>.html

Again, if the preferred language is not found, PRADO will try to use exception.html, instead.

CAUTION: When saving a template file, please make sure the file is saved using UTF-8 encoding. On Windows, you may use Notepad.exe to accomplish such saving.
$Id: Error.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Internationalization (I18N) and Localization (L10N)

Many web application built with PHP will not have internationalization in mind when it was first written. It may be that it was not intended for use in languages and cultures. Internationalization is an important aspect due to the increase adoption of the Internet in many non-English speaking countries. The process of internationalization and localization will contain difficulties. Below are some general guidelines to internationalize an existing application.

Separate culture/locale sensitive data

Identify and separate data that varies with culture. The most obvious are text/string/message. Other type of data should also be considered. The following list categorize some examples of culture sensitive data

  • Strings, Messages, Text, in relatively small units (e.g. phrases, sentences, paragraphs, but not the full text of a book).
  • Labels on buttons.
  • Help files, large units of text, static text.
  • Sounds.
  • Colors.
  • Graphics,Icons.
  • Dates, Times.
  • Numbers, Currency, Measurements.
  • Phone numbers.
  • Honorific and personal titles.
  • Postal address.
  • Page layout.

If possible all manner of text should be isolated and store in a persistence format. These text include, application error messages, hard coded strings in PHP files, emails, static HTML text, and text on form elements (e.g. buttons).

Configuration

To enable the localization features in PRADO, you need to add a few configuration options in your application configuration. First you need to include the System.I18N.* namespace to your paths.

<paths>
    <using namespace="System.I18N.*" />
</paths>

Then, if you wish to translate some text in your application, you need to add one translation message data source.

<module id="globalization" class="TGlobalization">
    <translation type="XLIFF"
        source="MyApp.messages"
        marker="@@"
        autosave="true" cache="true" />
</module>

Where source in translation is the dot path to a directory where you are going to store your translate message catalogue. The autosave attribute if enabled, saves untranslated messages back into the message catalogue. With cache enabled, translated messages are saved in the application runtime/i18n directory. The marker value is used to surround any untranslated text.

With the configuration complete, we can now start to localize your application. If you have autosave enabled, after running your application with some localization activity (i.e. translating some text), you will see a directory and a messages.xml created within your source directory.

What to do with messages.xml?

The translation message catalogue file, if using type="XLIFF", is a standardized translation message interchange XML format. You can edit the XML file using any UTF-8 aware editor. The format of the XML is something like the following.

<?xml version="1.0"?>
<xliff version="1.0">
    <file original="I18N Example IndexPage"
          source-language="EN"
          datatype="plaintext"
          date="2005-01-24T11:07:53Z">
        <body>

<trans-unit id="1">
<source>Hello world.</source>
<target>Hi World!!!</target>
</trans-unit>

        </body>
    </file>
</xliff>
Each translation message is wrapped within a trans-unit tag, where source is the original message, and target is the translated message. Editors such as Heartsome XLIFF Translation Editor can help in editing these XML files.

Using a Database for translation

Available from Prado versions 3.1.3 onwards.

Since version 3.1.3 the messages can also be stored in a database using the connection id from an existing TDataSourceConfig. You have to create two tables in your database: catalogue and trans_unit. The catalogue table needs an entry for each catalogue you want to use. Example schemas for different databases can be found in the framework's I18N/schema directory. To configure translation with a database use:

<module id="db1" class="System.Data.TDataSourceConfig">
    <database ConnectionString="mysql:host=localhost;dbname=demodb" Username="demo" Password="demo" />
</module>

<module id="globalization" class="TGlobalization">
    <translation
        type="Database"
        autosave="true"
        cache="false"
        source="db1" />
</module>

The translation messages will be stored in the trans_unit table. Add your translation in the target field of that table. You should make sure that you are working on the right catalogue by comparing the message's cat_id with that from the catalogue table.

Setting and Changing Culture

Once globalization is enabled, you can access the globalization settings, such as, Culture, Charset, etc, using

$globalization = $this->getApplication()->getGlobalization();
echo $globalization->Culture;
$globalization->Charset= "GB-2312"; //change the charset

You also change the way the culture is determined by changing the class attribute in the module configuration. For example, to set the culture that depends on the browser settings, you can use the TGlobalizationAutoDetect class.

<module id="globalization" class="TGlobalizationAutoDetect">
   ...
</module>

You may also provide your own globalization class to change how the application culture is set. Lastly, you can change the globalization settings on page by page basis using template control tags. For example, changing the Culture to "zh".

<%@ Application.Globalization.Culture="zh" %>

Localizing your PRADO application

There are two areas in your application that may need message or string localization, in PHP code and in the templates. To localize strings within PHP, use the localize function detailed below. To localize text in the template, use the TTranslate component.

Using localize function to translate text within PHP

The localize function searches for a translated string that matches original from your translation source. First, you need to locate all the hard coded text in PHP that are displayed or sent to the end user. The following example localizes the text of the $sender (assuming, say, the sender is a button). The original code before localization is as follows.

function clickMe($sender,$param)
{
  $sender->Text="Hello, world!";
}

The hard coded message "Hello, world!" is to be localized using the localize function.

function clickMe($sender,$param)
{
  $sender->Text=Prado::localize("Hello, world!");
}

Compound Messages

Compound messages can contain variable data. For example, in the message "There are 12 users online.", the integer 12 may change depending on some data in your application. This is difficult to translate because the position of the variable data may be difference for different languages. In addition, different languages have their own rules for plurals (if any) and/or quantifiers. The following example can not be easily translated, because the sentence structure is fixed by hard coding the variable data within message.

$num_users = 12;
$message = "There are " . $num_users . " users online.";
This problem can be solved using the localize function with string substitution. For example, the $message string above can be constructed as follows.
$num_users = 12;
$message = Prado::localize("There are {num_users} users online.", array('num_users'=>$num_users));

Where the second parameter in localize takes an associative array with the key as the substitution to find in the text and replaced it with the associated value. The localize function does not solve the problem of localizing languages that have plural forms, the solution is to use TChoiceFormat.

The following sample demonstrates the basics of localization in PRADO.

Run Sample View Source

I18N Components

TTranslate

Messages and strings can be localized in PHP or in templates. To translate a message or string in the template, use TTranslate.

<com:TTranslate>Hello World</com:TTranslate>
<com:TTranslate Text="Goodbye" />

TTranslate can also perform string substitution. The Parameters property can be use to add name values pairs for substitution. Substrings in the translation enclosed with "{" and "}" are consider as the parameter names during substitution lookup. The following example will substitute the substring "{time}" with the value of the parameter attribute "Parameters.time=<%= time() %>".

<com:TTranslate Parameters.time=<%= time() %> >
The time is {time}.
</com:TTranslate>

A short for TTranslate is also provided using the following syntax.

<%[string]%>

where string will be translated to different languages according to the end-user's language preference. This syntax can be used with attribute values as well.

<com:TLabel Text="<%[ Hello World! ]%>" />

TDateFormat

Formatting localized date and time is straight forward.

<com:TDateFormat Value="12/01/2005" />

The Pattern property accepts 4 predefined localized date patterns and 4 predefined localized time patterns.

  • fulldate
  • longdate
  • mediumdate
  • shortdate
  • fulltime
  • longtime
  • mediumtime
  • shorttime

The predefined can be used in any combination. If using a combined predefined pattern, the first pattern must be the date, followed by a space, and lastly the time pattern. For example, full date pattern with short time pattern. The actual ordering of the date-time and the actual pattern will be determine automatically from locale data specified by the Culture property.

<com:TDateFormat Pattern="fulldate shorttime" />

You can also specify a custom pattern using the following sub-patterns. The date/time format is specified by means of a string time pattern. In this pattern, all ASCII letters are reserved as pattern letters, which are defined as the following:

Symbol   Meaning                 Presentation        Example
 ------   -------                 ------------        -------
 G        era designator          (Text)              AD
 y        year                    (Number)            1996
 M        month in year           (Text & Number)     July & 07
 d        day in month            (Number)            10
 h        hour in am/pm (1~12)    (Number)            12
 H        hour in day (0~23)      (Number)            0
 m        minute in hour          (Number)            30
 s        second in minute        (Number)            55
 E        day of week             (Text)              Tuesday
 D        day in year             (Number)            189
 F        day of week in month    (Number)            2 (2nd Wed in July)
 w        week in year            (Number)            27
 W        week in month           (Number)            2
 a        am/pm marker            (Text)              PM
 k        hour in day (1~24)      (Number)            24
 K        hour in am/pm (0~11)    (Number)            0
 z        time zone               (Time)              Pacific Standard Time
 '        escape for text         (Delimiter)         'Date='
 ''       single quote            (Literal)           'o''clock'

The count of pattern letters determine the format.

(Text): 4 letters uses full form, less than 4, use short or abbreviated form if it exists. (e.g., "EEEE" produces "Monday", "EEE" produces "Mon")

(Number): the minimum number of digits. Shorter numbers are zero-padded to this amount (e.g. if "m" produces "6", "mm" produces "06"). Year is handled specially; that is, if the count of 'y' is 2, the Year will be truncated to 2 digits. (e.g., if "yyyy" produces "1997", "yy" produces "97".) Unlike other fields, fractional seconds are padded on the right with zero.

(Text and Number): 3 or over, use text, otherwise use number. (e.g., "M" produces "1", "MM" produces "01", "MMM" produces "Jan", and "MMMM" produces "January".)

Any characters in the pattern that are not in the ranges of ['a'..'z'] and ['A'..'Z'] will be treated as quoted text. For instance, characters like ':', '.', ' ', and '@' will appear in the resulting time text even they are not embraced within single quotes.

Examples using the US locale:

Format Pattern                         Result
--------------                         -------
"yyyy.MM.dd G 'at' HH:mm:ss"      ->>  1996.07.10 AD at 15:08:56
"EEE, MMM d, ''yy"                ->>  Wed, Jul 10, '96
"h:mm a"                          ->>  12:08 PM
"hh 'o''clock' a, z"              ->>  12 o'clock PM, Pacific Daylight Time
"K:mm a"                          ->>  0:00 PM
"yyyy.MMMM.dd G hh:mm a"          ->>  1996.July.10 AD 12:08 PM

If the Value property is not specified, the current date and time is used.

TNumberFormat

PRADO's Internationalization framework provide localized currency formatting and number formatting. Please note that the TNumberFormat component provides formatting only, it does not perform current conversion or exchange.

Numbers can be formatted as currency, percentage, decimal or scientific numbers by specifying the Type attribute. The valid types are:

  • currency
  • percentage
  • decimal
  • scientific
<com:TNumberFormat Type="currency" Value="100" />

Culture and Currency properties may be specified to format locale specific numbers.

If someone from US want to see sales figures from a store in Germany (say using the EURO currency), formatted using the german currency, you would need to use the attribute Culture="de_DE" to get the currency right, e.g. 100,00$. The decimal and grouping separator is then also from the de_DE locale. This may lead to some confusion because people from US uses the "," (comma) as thousand separator. Therefore a Currency attribute is available, so that the output from the following example results in $100.00

<com:TNumberFormat Type="currency"
          Culture="en_US" Currency="EUR" Value="100" />

The Pattern property determines the number of digits, thousand grouping positions, the number of decimal points and the decimal position. The actual characters that are used to represent the decimal points and thousand points are culture specific and will change automatically according to the Culture property. The valid Pattern characters are:

  • # (hash) - represents the optional digits
  • 0 (zero) - represents the mandatory digits, zero left filled
  • . (full stop) - the position of the decimal point (only 1 decimal point is allowed)
  • , (comma) - thousand point separation (up to 2 commas are allowed)

For example, consider the Value="1234567.12345" and with Culture="en_US" (which uses "," for thousand point separator and "." for decimal separators).

Pattern                      Output
-------                      ------
##,###.00               ->>  1,234,567.12
##,###.##               ->>  1,234,567.12345
##,##.0000              ->>  1,23,45,67.1235
##,###,##.0             ->>  12,345,67.1
000,000,000.0           ->>  001,234,567.1

TTranslateParameter

Compound messages, i.e., string substitution, can be accomplished with TTranslateParameter. In the following example, the strings "{greeting}" and "{name}" will be replace with the values of "Hello" and "World", respectively.The substitution string must be enclose with "{" and "}". The parameters can be further translated by using TTranslate.

<com:TTranslate>
  {greeting} {name}!
  <com:TTranslateParameter Key="name">World</com:TTranslateParameter>
  <com:TTranslateParameter Key="greeting">Hello</com:TTranslateParameter>
</com:TTranslate>

TChoiceFormat

Using the localize function or TTranslate component to translate messages does not inform the translator the cardinality of the data required to determine the correct plural structure to use. It only informs them that there is a variable data, the data could be anything. Thus, the translator will be unable to determine with respect to the substitution data the correct plural, language structure or phrase to use . E.g. in English, to translate the sentence, "There are {number} of apples.", the resulting translation should be different depending on the number of apples.

The TChoiceFormat component performs message/string choice translation. The following example demonstrated a simple 2 choice message translation.

<com:TChoiceFormat Value="1"/>[1] One Apple. |[2] Two Apples</com:TChoiceFormat>

In the above example, the Value "1" (one), thus the translated string is "One Apple". If the Value was "2", then it will show "Two Apples".

The message/string choices are separated by the pipe "|" followed by a set notation of the form.

  • [1,2] -- accepts values between 1 and 2, inclusive.
  • (1,2) -- accepts values between 1 and 2, excluding 1 and 2.
  • {1,2,3,4} -- only values defined in the set are accepted.
  • [-Inf,0) -- accepts value greater or equal to negative infinity and strictly less than 0

Any non-empty combinations of the delimiters of square and round brackets are acceptable. The string chosen for display depends on the Value property. The Value is evaluated for each set until the Value is found to belong to a particular set.

Available from Prado versions 3.1.1 onwards.

Since version 3.1.1 the following set notation is also possible.

  • {n: n % 10 > 1 && n % 10 < 5} -- matches numbers like 2, 3, 4, 22, 23, 24

Where set is defined by the expression after n:. In particular, the expression accepts the following mathematical/logical operators to form a set of logical conditions on the value given by n:

  • < -- less than.
  • <= -- less than equals.
  • > -- greater than.
  • >= -- greater than equals.
  • == -- of equal value.
  • % -- modulo, e.g., 1 % 10 equals 1, 11 % 10 equals 1.
  • - -- minus, negative.
  • + -- addition.
  • & -- conditional AND.
  • && -- condition AND with short circuit.
  • | -- conditional OR.
  • || -- conditional OR with short circuit.
  • ! -- negation.

Additional round brackets can also be used to perform grouping. The following example represents ordinal values in English such as: "0th", "1st", "2nd", "3rd", "4th", "11th", "21st", "22nd", etc.

<com:TChoiceFormat Value="21">
 {n: n > 0 && n % 10 == 1 && n % 100 != 11} {Value}st
|{n: n > 0 && n % 10 == 2 && n % 100 != 12} {Value}nd
|{n: n > 0 && n % 10 == 3 && n % 100 != 13} {Value}rd
|{n: n > -1 } {Value}th
|(-Inf, 0) {Value}
</com:TChoiceFormat>
$Id: I18N.page 2472 2008-07-01 15:14:40Z mikl $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Performance Tuning

Performance of Web applications is affected by many factors. Database access, file system operations, network bandwidth are all potential affecting factors. PRADO tries in every effort to reduce the performance impact caused by the framework.

Caching

PRADO provides a generic caching technique used by in several core parts of the framework. For example, when caching is enabled, TTemplateManager will save parsed templates in cache and reuse them in the following requests, which saves time for parsing templates. The TThemeManager adopts the similar strategy to deal with theme parsing.

Enabling caching is very easy. Simply add the cache module in the application configuration, and PRADO takes care of the rest.

<modules>
    <module id="cache" class="System.Caching.TSqliteCache" />
</modules>

Developers can also take advantage of the caching technique in their applications. The Cache property of TApplication returns the plugged-in cache module when it is available. To save and retrieve a data item in cache, use the following commands,

if($application->Cache) {
    // saves data item in cache
    $application->Cache->set($keyName,$dataItem);
    // retrieves data item from cache
    $dataItem=$application->Cache->get($keyName);
}

where $keyName should be a string that uniquely identifies the data item stored in cache.

Since v3.1.0, a new control called TOutputCache has been introduced. This control allows users to selectively cache parts of a page's output. When used appropriately, this technique can significant improve pages' performance because the underlying controls are not created at all if the cached versions are hit.

Using pradolite.php

Including many PHP script files may impact application performance significantly. PRADO classes are stored in different files and when processing a page request, it may require including tens of class files.To alleviate this problem, in each PRADO release, a file named pradolite.php is also included. The file is a merge of all core PRADO class files with comments being stripped off and message logging removed.

To use pradolite.php, in your application entry script, replace the inclusion of prado.php with pradolite.php.

Changing Application Mode

Application mode also affects application performance. A PRADO application can be in one of the following modes: Off, Debug, Normal and Performance. The Debug mode should mainly be used during application development, while Normal mode is usually used in early stage after an application is deployed to ensure everything works correctly. After the application is proved to work stably for some period, the mode can be switched to Performance to further improve the performance.

The difference between Debug, Normal and Performance modes is that under Debug mode, application logs will contain debug information, and under Performance mode, timestamp checking is not performed for cached templates and published assets. Therefore, under Performance mode, application may not run properly if templates or assets are modified. Since Performance mode is mainly used when an application is stable, change of templates or assets are not likely.

To switch application mode, configure it in application configuration:

<application Mode="Performance" >
    ......
</application >

Reducing Page Size

By default, PRADO stores page state in hidden fields of the HTML output. The page state could be very large in size if complex controls, such as TDataGrid, is used. To reduce the size of the network transmitted page size, two strategies can be used.

First, you may disable viewstate by setting EnableViewState to false for the page or some controls on the page if they do not need user interactions. Viewstate is mainly used to keep track of page state when a user interacts with that page/control.

Second, you may use a different page state storage. For example, page state may be stored in session, which essentially stores page state on the server side and thus saves the network transmission time. The StatePersisterClass property of the page determines which state persistence class to use. By default, it uses System.Web.UI.TPageStatePersister to store persistent state in hidden fields. You may modify this property to a persister class of your own, as long as the new persister class implements the IPageStatePersister interface. You may configure this property in several places, such as application configuration or page configuration using <pages> or <page> tags,

<pages StatePersisterClass="MyPersister1" ... >
    <page ID="SpecialPage" StatePersisterClass="MyPersister2" ... />
</pages>

Note, in the above the SpecialPage will use MyPersister2 as its persister class, while the rest pages will use MyPersister1. Therefore, you can have different state persister strategies for different pages.

Other Techniques

Server caching techniques are proven to be very effective in improving the performance of PRADO applications. For example, we have observed that by using Zend Optimizer, the RPS (request per second) of a PRADO application can be increased by more than ten times. Of course, this is at the cost of stale output, while PRADO's caching techniques always ensure the correctness of the output.

$Id: Performance.page 1902 2007-05-07 04:17:37Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Introduction to Javascript

This guide is based on the Quick guide to somewhat advanced JavaScript tour of some OO features by Sergio Pereira.

Hey, I didn't know you could do that

If you are a web developer and come from the same place I do, you have probably used quite a bit of Javascript in your web pages, mostly as UI glue.

Until recently, I knew that Javascript had more OO capabilities than I was employing, but I did not feel like I needed to use it. As the browsers started to support a more standardized featureset of Javascript and the DOM, it became viable to write more complex and functional code to run on the client. That helped giving birth to the AJAX phenomena.

As we all start to learn what it takes to write our cool, AJAX applications, we begin to notice that the Javascript we used to know was really just the tip of the iceberg. We now see Javascript being used beyond simple UI chores like input validation and frivolous tasks. The client code now is far more advanced and layered, much like a real desktop application or a client-server thick client. We see class libraries, object models, hierarchies, patterns, and many other things we got used to seeing only in our server side code.

In many ways we can say that suddenly the bar was put much higher than before. It takes a heck lot more proficiency to write applications for the new Web and we need to improve our Javascript skills to get there. If you try to use many of the existing javascript libraries out there, like Prototype.js, Scriptaculous, moo.fx, Behaviour, YUI, etc you'll eventually find yourself reading the JS code. Maybe because you want to learn how they do it, or because you're curious, or more often because that's the only way to figure out how to use it, since documentation does not seem to be highly regarded with most of these libraries. Whatever the case may be, you'll face some kung-fu techniques that will be foreign and scary if you haven't seen anything like that before.

The purpose of this article is precisely explaining the types of constructs that many of us are not familiar with yet.

JSON (JavaScript Object Notation)

JavaScript Object Notation (JSON,) is one of the new buzzwords popping up around the AJAX theme. JSON, simply put, is a way of declaring an object in Javascript. Let's see an example right away and note how simple it is.

var myPet = { color: 'black', leg_count: 4, communicate: function(repeatCount){
for(i=0;i<repeatCount;i++) alert('Woof!');} };

Let's just add little bit of formatting so it looks more like how we usually find out there:

var myPet =
{
    color: 'black',
    legCount: 4,
    communicate: function(repeatCount)
    {
        for(i=0;i<repeatCount;i++)
            alert('Woof!');
    }
};

Here we created a reference to an object with two properties (color and legCount) and a method (communicate.) It's not hard to figure out that the object's properties and methods are defined as a comma delimited list. Each of the members is introduced by name, followed by a colon and then the definition. In the case of the properties it is easy, just the value of the property. The methods are created by assigning an anonymous function, which we will explain better down the line. After the object is created and assigned to the variable myPet, we can use it like this:

alert('my pet is ' + myPet.color);
alert('my pet has ' + myPet.legCount + ' legs');
//if you are a dog, bark three times:
myPet.communicate(3);

You'll see JSON used pretty much everywhere in JS these days, as arguments to functions, as return values, as server responses (in strings,) etc.

What do you mean? A function is an object too?

This might be unusual to developers that never thought about that, but in JS a function is also an object. You can pass a function around as an argument to another function just like you can pass a string, for example. This is extensively used and very handy.

Take a look at this example. We will pass functions to another function that will use them.

var myDog =
{
    bark: function()
    {
        alert('Woof!');
    }
};

var myCat =
{
    meow: function()
    {
        alert('I am a lazy cat. I will not meow for you.');
    }
};

function annoyThePet(petFunction)
{
    //let's see what the pet can do
    petFunction();
}

//annoy the dog:
annoyThePet(myDog.bark);
//annoy the cat:
annoyThePet(myCat.meow);

Note that we pass myDog.bark and myCat.meow without appending parenthesis "()" to them. If we did that we would not be passing the function, rather we would be calling the method and passing the return value, undefined in both cases here.

If you want to make my lazy cat start barking, you can easily do this:

myCat.meow = myDog.bark;
myCat.meow(); //alerts 'Woof!'

Arrays, items, and object members

The following two lines in JS do the same thing.

var a = new Array();
var b = [];

As I'm sure you already know, you can access individual items in an array by using the square brackets:

var a = ['first', 'second', 'third'];
var v1 = a[0];
var v2 = a[1];
var v3 = a[2];

But you are not limited to numeric indices. You can access any member of a JS object by using its name, in a string. The following example creates an empty object, and adds some members by name.

var obj = {}; //new, empty object
obj['member_1'] = 'this is the member value';
obj['flag_2'] = false;
obj['some_function'] = function(){ /* do something */};

The above code has identical effect as the following:

var obj =
{
    member_1:'this is the member value',
    flag_2: false,
    some_function: function(){ /* do something */}
};

In many ways, the idea of objects and associative arrays (hashes) in JS are not distiguishable. The following two lines do the same thing too.

obj.some_function();
obj['some_function']();

Enough about objects, may I have a class now?

The great power of object oriented programming languages derive from the use of classes. I don't think I would have guessed how classes are defined in JS using only my previous experience with other languages. Judge for yourself.

//defining a new class called Pet
var Pet = function(petName, age)
{
    this.name = petName;
    this.age = age;
};

//let's create an object of the Pet class
var famousDog = new Pet('Santa\'s Little Helper', 15);
alert('This pet is called ' + famousDog.name);

Let's see how we add a method to our Pet class. We will be using the prototype property that all classes have. The prototype property is an object that contains all the members that any object of the class will have. Even the default JS classes, like String, Number, and Date have a prototype object that we can add methods and properties to and make any object of that class automatically gain this new member.

Pet.prototype.communicate = function()
{
    alert('I do not know what I should say, but my name is ' + this.name);
};

That's when a library like prototype.js comes in handy. If we are using prototype.js, we can make our code look cleaner (at least in my opinion.)

var Pet = Class.create();
Pet.prototype =
{
    //our 'constructor'
    initialize: function(petName, age)
    {
        this.name = petName;
        this.age = age;
    },

    communicate: function()
    {
        alert('I do not know what I should say, but my name is ' + this.name);
    }
};

Functions as arguments, an interesting pattern

If you have never worked with languages that support closures you may find the following idiom too funky.

var myArray = ['first', 'second', 'third'];
myArray.each( function(item, index)
{
    alert('The item in the position #' + index + ' is:' + item);
});

Whoa! Let's explain what is going on here before you decide I've gone too far and navigate to a better article than this one.

First of all, in the above example we are using the prototype.js library, which adds the each function to the Array class. The each function accepts one argument that is a function object. This function, in turn, will be called once for each item in the array, passing two arguments when called, the item and the index for the current item. Let's call this function our iterator function. We could have also written the code like this.

function myIterator(item, index)
{
    alert('The item in the position #' + index + ' is:' + item);
}

var myArray = ['first', 'second', 'third'];
myArray.each( myIterator );

But then we would not be doing like all the cool kids in school, right? More seriously, though, this last format is simpler to understand but causes us to jump around in the code looking for the myIterator function. It's nice to have the logic of the iterator function right there in the same place it's called. Also, in this case, we will not need the iterator function anywhere else in our code, so we can transform it into an anonymous function without penalty.

This is this but sometimes this is also that

One of the most common troubles we have with JS when we start writing our code it the use of the this keyword. It could be a real tripwire.

As we mentioned before, a function is also an object in JS, and sometimes we do not notice that we are passing a function around.

Take this code snippet as an example.

function buttonClicked()
{
    alert('button ' + this.id + ' was clicked');
}

var myButton = document.getElementById('someButtonID');
var myButton2 = document.getElementById('someOtherButtonID');
myButton.onclick = buttonClicked;
myButton2.onclick = buttonClicked;

Because the buttonClicked function is defined outside any object we may tend to think the this keyword will contain a reference to the window or document object (assuming this code is in the middle of an HTML page viewed in a browser.)

But when we run this code we see that it works as intended and displays the id of the clicked button. What happened here is that we made the onclick method of each button contain the buttonClicked object reference, replacing whatever was there before. Now whenever the button is clicked, the browser will execute something similar to the following line.

myButton.onclick();

That isn't so confusing afterall, is it? But see what happens you start having other objects to deal with and you want to act on these object upon events like the button's click.

var myHelper =
{
    formFields: [ ],
    emptyAllFields: function()
    {
        for(i=0; i < this.formFields.length; i++)
        {
            var elementID = this.formFields[i];
            var field = document.getElementById(elementID);
            field.value = '';
        }
    }
};

//tell which form fields we want to work with
myHelper.formFields.push('txtName');
myHelper.formFields.push('txtEmail');
myHelper.formFields.push('txtAddress');

//clearing the text boxes:
myHelper.emptyAllFields();

var clearButton = document.getElementById('btnClear');
clearButton.onclick = myHelper.emptyAllFields;

So you think, nice, now I can click the Clear button on my page and those three text boxes will be emptied. Then you try clicking the button only to get a runtime error. The error will be related to (guess what?) the this keyword. The problem is that this.formFields is not defined if this contains a referece to the button, which is precisely what's happening. One quick solution would be to rewrite our last line of code.

clearButton.onclick = function()
{
    myHelper.emptyAllFields();
};

That way we create a brand new function that calls our helper method within the helper object's context.

$Id: Scripts.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Developer Notes for prototype.js

This guide is based on the Developer Notes for prototype.js by Sergio Pereira.

What is that?

In case you haven't already used it, prototype.js is a JavaScript library written by Sam Stephenson. This amazingly well thought and well written piece of standards-compliant code takes a lot of the burden associated with creating rich, highly interactive web pages that characterize the Web 2.0 off your back.

If you tried to use this library recently, you probably noticed that documentation is not one of its strongest points. As many other developers before me, I got my head around prototype.js by reading the source code and experimenting with it. I thought it would be nice to take notes while I learned and share with everybody else.

As you read the examples and the reference, developers familiar with the Ruby programming language will notice an intentional similarity between Ruby's built-in classes and many of the extensions implemented by this library.

Using the $() function

The $() function is a handy shortcut to the all-too-frequent document.getElementById() function of the DOM. Like the DOM function, this one returns the element that has the id passed as an argument.

Unlike the DOM function, though, this one goes further. You can pass more than one id and $() will return an Array object with all the requested elements. The example below should illustrate this.

<com:TClientScript UsingClientScripts="prado" />
<div id="myDiv">
    <p id="830731" class="block-content">This is a paragraph</p>
</div>

<div id="myOtherDiv">
    <p id="830732" class="block-content">This is another paragraph</p>
</div>

<input type="button" value=Test1 onclick="test1();" />
<input type="button" value=Test2 onclick="test2();" />

<script type="text/javascript">
/*<![CDATA[*/
function test1()
{
    var d = $('myDiv');
    alert(d.innerHTML);
}

function test2()
{
    var divs = $('myDiv','myOtherDiv');
    for(i=0; i<divs.length; i++)
    {
        alert(divs[i].innerHTML);
    }
}
/*]]>*/
</script>

Another nice thing about this function is that you can pass either the id string or the element object itself, which makes this function very useful when creating other functions that can also take either form of argument.

Using the $F() function

The $F() function is a another welcome shortcut. It returns the value of any field input control, like text boxes or drop-down lists. The function can take as argument either the element id or the element object itself.

<input type="text" id="userName" value="Joe Doe" />
<input type="button" value=Test3 onclick="test3();" />

<script type="text/javascript">
/*<![CDATA[*/
function test3()
{
    alert($F('userName'));
}
/*]]>*/
</script>
$Id: Scripts1.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

DOM Events and Javascript

Basic event handling

The syntax for working with events looks like the code below.

Event.observe(element, name, observer, [useCapture]);

Assuming for a moment that we want to observe when a link was clicked, we could do the following:

// <a id="clicker" href="http://foo.com">Click me</a>
Event.observe('clicker', 'click', function(event)
{
    alert('clicked!');
});

If we wanted to get the element that fired the event, we'd do this:

Event.observe('clicker', 'click', function(event)
{
    alert(Event.element(event));
});

Observing keystrokes

If we wanted to observe keystrokes for the entire document, we could do the following:

Event.observe(document, 'keypress', function(event)
{
    if(Event.keyCode(event) == Event.KEY_TAB)
        alert('Tab Pressed');
});

And lets say we wanted to keep track of what has been typed :

Event.observe('search', 'keypress', function(event)
{
    Element.update('search-results', $F(Event.element(event)));
});

Prototype defines properties inside the event object for some of the more common keys, so feel free to dig around in Prototype to see which ones those are.

A final note on keypress events; If you'd like to detect a left click you can use Event.isLeftClick(event).

Getting the coordinates of the mouse pointer

Drag and drop, dynamic element resizing, games, and much more all require the ability to track the X and Y location of the mouse. Prototype makes this fairly simple. The code below tracks the X and Y position of the mouse and spits out those values into an input box named mouse.

Event.observe(document, 'mousemove', function(event)
{
    $('mouse').value = "X: " + Event.pointerX(event) +
                       "px Y: " + Event.pointerY(event) + "px";
});

If we wanted to observe the mouse location when it was hovering over a certain element, we'd just change the document argument to the id or element that was relevant.

Stopping Propagation

Event.stop(event) will stop the propagation of an event .

Events, Binding, and Objects

Everything has been fairly straight forward so far, but things start getting a little trickier when you need to work with events in and object-oriented environment. You have to deal with binding and funky looking syntax that might take a moment to get your head around.

Lets look at some code so you can get a better understanding of what I'm talking about.

EventDispenser = Class.create();
EventDispenser.prototype =
{
  initialize: function(list)
  {
    this.list = list;

    // Observe clicks on our list items
    $$(this.list + " li").each(function(item)
    {
        Event.observe(item, 'click', this.showTagName.bindEvent(this));
    }.bind(this));

    // Observe when a key on the keyboard is pressed.
    // In the observer, we check for
    // the tab key and alert a message if it is pressed.
    Event.observe(document, 'keypress', this.onKeyPress.bindEvent(this));

    // Observe our fake live search box.  When a user types
    // something into the box, the observer will take that
    // value(-1) and update our search-results div with it.
    Event.observe('search', 'keypress', this.onSearch.bindEvent(this));

    Event.observe(document, 'mousemove', this.onMouseMove.bindEvent(this));
  },

  // Arbitrary functions to respond to events
  showTagName: function(event)
  {
    alert(Event.element(event).tagName);
  },

  onKeyPress: function(event)
  {
    var code = event.keyCode;
    if(code == Event.KEY_TAB)
        alert('Tab key was pressed');
  },

  onSearch: function(event)
  {
    Element.update('search-results', $F(Event.element(event)));
  },

  onMouseMove: function(event)
  {
    $('mouse').value = "X: " + Event.pointerX(event) +
                "px Y: " + Event.pointerY(event) + "px";
  }
}

Whoa! What's going on here? Well, we've defined our a custom class EventDispenser. We're going to be using this class to setup events for our document. Most of this code is a rewrite of the code we looked at earlier except this time, we are working from inside an object.

Looking at the initialize method, we can really see how things are different now. Take a look at the code below:

// Observe clicks on our list items
$$(this.list + " li").each(function(item)
{
    Event.observe(item, 'click', this.showTagName.bindEvent(this));
}.bind(this));

We've got iterators, binding and all sorts of stuff going on. Lets break down what this chunk of code is doing.

First we are hunting for a collection of elements based on it's CSS selector. This uses the Prototype selector function $$(). After we've found the list items we are dealing with we send those into an each iteration where we will add our observers.

Event.observe(item, 'click', this.showTagName.bindEvent(this));

Now looking at the code above, you'll notice the bindEvent function. This takes the method before it showTagName and treats it as the method that will be triggered when, in this case, someone clicks one of our list items.

You'll also notice we pass this as an argument to the bindEvent function. This simply allows us to reference the object in context EventDispenser inside our function showTagName(event). If the showTagName function requires additional parameters, you can attach them to the later parameters of bindEvent. For example

this.showTagName.bindEvent(this, param1, param2);

//where the showTagName function is defined as
showTime : function (event, param1, param2) { ... }

Moving on, you'll see bind(this) attached to our iterator function. This really has nothing to do with events, it is only here to allow me to use this inside the iterator. If we did not use bind(this), I could not reference the method showTagName inside the iterator.

Ok, so we'll move on to looking at our methods that actually get called when an event occurs. Since we've been dealing with showTagName, lets look at it.

showTagName: function(event)
{
    alert(Event.element(event).tagName);
}

As you can see, this function accepts one argument--the event. In order for us to get the element which fired the event we need to pass that argument to Event.element. Now we can manipulate it at will.

This covers the most confusing parts of our code. The text above is also relevant to the remaining parts of our code. If there is anything about this you don't understand, feel free to ask questions in the forum.

Removing Event Listeners

This one threw me for a loop the first time I tried to use it. I tried something similar to what I did in the Event.observe call with the exception of using stopObserving, but nothing seemed to change. In other words, the code below does NOT work.

$$(this.list + " li").each(function(item)
{
    Event.stopObserving(item, 'click', this.showTagName);
}.bind(this));

What's the deal here? The reason this does not work is because there is no pointer to the observer. This means that when we passed this.showTagName in the Event.observe method before hand, we passed it as an anonymous function. We can't reference an anonymous function because it simply does not have a pointer.

So how do we get the job done? All we need to do is give the observing function a pointer, or the jargon free version: Set a variable that points to this.showTagName. Ok, lets change our code a bit.

this.showTagObserver = this.showTagName.bindEvent(this);

// Observe clicks on our list items
$$(this.list + " li").each(function(item)
{
    Event.observe(item, 'click', this.showTagObserver);
}.bind(this));

Now we can remove the event listeners from our list like this:

$$(this.list + " li").each(function(item)
{
    Event.stopObserving(item, 'click', this.showTagObserver);
}.bind(this));
$Id: Scripts2.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Javascript in PRADO, Questions and Answers

How do I include the Javascript libraries distributed with Prado?

The javascript libraries distributed with Prado can be found in the framework/Web/Javascripts/source directory. The packages.php file in that directory defines a list of available package names available to be loaded. They can be loaded as follows.

  • Adding libraries in the template
    <com:TClientScript PradoScripts="effects" />
  • Adding libraries in PHP code
    $this->getPage()->getClientScript()->registerPradoScript("effects");
The available packaged libraries included in Prado are
  • prado : basic PRADO javascript framework based on Prototype
  • effects : visual effects from script.aculo.us
  • ajax : ajax and callback related based on Prototype
  • validator : validation
  • logger : javascript logger and object browser
  • datepicker : datepicker
  • colorpicker : colorpicker

The dependencies for each library are automatically resolved. Components that require a particular library will also automatically load the necessary libraries. For example, if you add a TDatePicker component on the page, the datepicker and its dependencies will be automatically included on the page.

See TClientScript for options of adding your custom Javascript code to the page.

Publishing Javascript Libraries as Assets

Available from Prado versions 3.1b onwards.

Use TClientScriptLoader to publish and combine multiple existing javascript files (e.g. javascript libraries distributed with Prado or otherwise) as packages.

For greater control on what and when to publish, use the registerJavascriptPackages($base, $packages, $debug=null, $gzip=true) method in the TClientScriptManager class, which an instance can be obtained using $this->getPage()->getClientScript() or its equivalents. For example, if multiple controls will use the same set of javascript libraries, write a class to handle the registration of packages required by those controls.

class MyJavascriptLib extends TComponent
{
    private $_packages=array(); //keep track of all registrations

    private $_manager;

    protected function __construct(TPage $owner)
    {
        $this->_manager = $owner->getClientScript();
        $owner->onPreRenderComplete = array($this, 'registerScriptLoader');
    }

    public static function registerPackage(TControl $control, $name)
    {
        static $instance;
        if($instance===null)
            $instance=new self($control->getPage());
        $instance->_packages[$name]=true;
    }

    protected function registerScriptLoader()
    {
        $dir = dirname(__FILE__).'/myscripts'; //contains my javascript files
        $scripts = array_keys($this->_packages);
        $url = $this->_manager->registerJavascriptPackages($dir, $scripts);
        $this->_manager->registerScriptFile($url,$url);
    }
}

// example control class using the javascript packages
class TestComp extends TControl
{
    public function onPreRender($param)
    {
        parent::onPreRender($param);
        MyJavascriptLib::registerPackage($this,'package1');
    }
}
$Id: Scripts3.page 1902 2007-05-07 04:17:37Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO API Manual: Docs For Class IMappedStatement

Interface IMappedStatement (Class Overview)

Interface for all mapping statements.

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

Method Summary
TList | executeQueryForList ( IDbConnection $connection, mixed $parameter, TList $result, integer $skip, integer $max) Executes the SQL and retuns a subset of the rows selected.
TMap | executeQueryForMap ( IDbConnection $connection, mixed $parameter, string $keyProperty, string $valueProperty) Executes the SQL and retuns all rows selected in a map that is keyed on
object result. | executeQueryForObject ( IDbConnection $connection, mixed $parameter, object The $result) Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
integer | executeUpdate ( IDbConnection $connection, mixed $parameter) Execute an update statement. Also used for delete statement. Return the number of row effected.
string | getID ()
TSqlMap | getManager ()
TSqlMapStatement | getStatement ()

            Method Details

executeQueryForList

                                public TList executeQueryForList
                                (IDbConnection $connection , mixed $parameter , TList $result , integer $skip , integer $max )

Executes the SQL and retuns a subset of the rows selected.

Input
IDbConnection | $connection | database connection to execute the query
mixed | $parameter | The object used to set the parameters in the SQL.
TList | $result | A list to populate the result with.
integer | $skip | The number of rows to skip over.
integer | $max | The maximum number of rows to return.
Output
TList | A TList of result objects.
Exception

executeQueryForMap

                                public TMap executeQueryForMap
                                (IDbConnection $connection , mixed $parameter , string $keyProperty , string $valueProperty )

Executes the SQL and retuns all rows selected in a map that is keyed on

the property named in the <tt>$keyProperty</tt> parameter.  The value at  each key will be the value of the property specified  in the  <tt>$valueProperty</tt> parameter.  If <tt>$valueProperty</tt> is  <tt>null</tt>, the entire result object will be entered.

Input
IDbConnection | $connection | database connection to execute the query
mixed | $parameter | The object used to set the parameters in the SQL.
string | $keyProperty | The property of the result object to be used as the key.
string | $valueProperty | The property of the result object to be used as the value (or null)
Output
TMap | A map of object containing the rows keyed by <tt>$keyProperty</tt>.
Exception

executeQueryForObject

                                public object result. executeQueryForObject
                                (IDbConnection $connection , mixed $parameter , object The $result )

Executes an SQL statement that returns a single row as an object  of the type of the <tt>$result</tt> passed in as a parameter.

Input
IDbConnection | $connection | database connection to execute the query
mixed | $parameter | The object used to set the parameters in the SQL.
object The | $result | result object.
Output
Exception

executeUpdate

                                public integer executeUpdate
                                (IDbConnection $connection , mixed $parameter )

Execute an update statement. Also used for delete statement. Return the  number of row effected.

Input
IDbConnection | $connection | database connection to execute the query
mixed | $parameter | The object used to set the parameters in the SQL.
Output
integer | The number of row effected.
Exception

getID

                                public string getID
                                ()

Output

                                    string
                 Name used to identify the MappedStatement amongst the others.

Exception

getManager

                                public TSqlMap getManager
                                ()

Output

                                    TSqlMap
                 The TSqlMap used by this TMappedStatement

Exception

getStatement

                                public TSqlMapStatement getStatement
                                ()

Output

                                    TSqlMapStatement
                 The SQL statment used by this TMappedStatement.

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCachingStatement

Class TCachingStatement (Class Overview)

TCacheingStatement class.

            Since:
            3.1

            Author:
            Wei Zhuo <weizhuo[at]gmail[dot]com>

                    Constructor Summary

                    public

                            __construct
                            Array

Method Summary
protected void | createCommand ( mixed $connection, mixed $parameter, mixed $skip, mixed $max)
void | executeInsert ( mixed $connection, mixed $parameter)
void | executeQueryForList ( mixed $connection, mixed $parameter, mixed $result, mixed $skip, mixed $max, mixed $delegate)
void | executeQueryForMap ( mixed $connection, mixed $parameter, mixed $keyProperty, mixed $valueProperty, mixed $skip, mixed $max, mixed $delegate)
void | executeQueryForObject ( mixed $connection, mixed $parameter, mixed $result)
void | executeUpdate ( mixed $connection, mixed $parameter)
protected void | getCacheKey ( mixed $object)
void | getID ()
void | getManager ()
void | getStatement ()

                    Constructor Details

__construct

                                public __construct
                                Array

            Method Details

createCommand

                                protected void createCommand
                                (mixed $connection , mixed $parameter , mixed $skip , mixed $max )

Input
mixed | $connection
mixed | $parameter
mixed | $skip
mixed | $max
Output
Exception

executeInsert

                                public void executeInsert
                                (mixed $connection , mixed $parameter )

Input
mixed | $connection
mixed | $parameter
Output
Exception

executeQueryForList

                                public void executeQueryForList
                                (mixed $connection , mixed $parameter , mixed $result , mixed $skip , mixed $max , mixed $delegate )

Input
mixed | $connection
mixed | $parameter
mixed | $result
mixed | $skip
mixed | $max
mixed | $delegate
Output
Exception

executeQueryForMap

                                public void executeQueryForMap
                                (mixed $connection , mixed $parameter , mixed $keyProperty , mixed $valueProperty , mixed $skip , mixed $max , mixed $delegate )

Input
mixed | $connection
mixed | $parameter
mixed | $keyProperty
mixed | $valueProperty
mixed | $skip
mixed | $max
mixed | $delegate
Output
Exception

executeQueryForObject

                                public void executeQueryForObject
                                (mixed $connection , mixed $parameter , mixed $result )

Input
mixed | $connection
mixed | $parameter
mixed | $result
Output
Exception

executeUpdate

                                public void executeUpdate
                                (mixed $connection , mixed $parameter )

Input
mixed | $connection
mixed | $parameter
Output
Exception

getCacheKey

                                protected void getCacheKey
                                (mixed $object )

Input

mixed $object

Output

Exception

getID

                                public void getID
                                ()

Output

Exception

getManager

                                public void getManager
                                ()

Output

Exception

getStatement

                                public void getStatement
                                ()

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDeleteMappedStatement

Class TDeleteMappedStatement (Class Overview)

TComponent
   |
   --TMappedStatement
      |
      --TUpdateMappedStatement
         |
         --TDeleteMappedStatement

TDeleteMappedStatement class.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constants Inherited From TMappedStatement
QUERY_FOR_ARRAY, QUERY_FOR_LIST, QUERY_FOR_OBJECT,
Method Summary
Methods Inherited From TUpdateMappedStatement
TUpdateMappedStatement::executeInsert(), TUpdateMappedStatement::executeQueryForList(), TUpdateMappedStatement::executeQueryForMap(), TUpdateMappedStatement::executeQueryForObject()
Methods Inherited From TMappedStatement
TMappedStatement::addResultMapGroupBy(), TMappedStatement::applyResultMap(), TMappedStatement::enquequePostSelect(), TMappedStatement::executeInsert(), TMappedStatement::executePostSelect(), TMappedStatement::executeQueryForList(), TMappedStatement::executeQueryForMap(), TMappedStatement::executeQueryForObject(), TMappedStatement::executeSelectKey(), TMappedStatement::executeSQLQueryLimit(), TMappedStatement::executeUpdate(), TMappedStatement::fillArrayResultMap(), TMappedStatement::fillDefaultResultMap(), TMappedStatement::fillPropertyWithResultMap(), TMappedStatement::fillResultArrayList(), TMappedStatement::fillResultClass(), TMappedStatement::fillResultMap(), TMappedStatement::fillResultObjectProperty(), TMappedStatement::getCommand(), TMappedStatement::getID(), TMappedStatement::getManager(), TMappedStatement::getPostGeneratedSelectKey(), TMappedStatement::getPostSelectKeys(), TMappedStatement::getPreGeneratedSelectKey(), TMappedStatement::getResultMapGroupKey(), TMappedStatement::getScalarResult(), TMappedStatement::getSqlString(), TMappedStatement::getStatement(), TMappedStatement::initialGroupByResults(), TMappedStatement::onExecuteQuery(), TMappedStatement::raiseRowDelegate(), TMappedStatement::runQueryForList(), TMappedStatement::runQueryForMap(), TMappedStatement::runQueryForObject(), TMappedStatement::setObjectProperty()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TInsertMappedStatement

Class TInsertMappedStatement (Class Overview)

TComponent
   |
   --TMappedStatement
      |
      --TInsertMappedStatement

TInsertMappedStatement class.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constants Inherited From TMappedStatement
QUERY_FOR_ARRAY, QUERY_FOR_LIST, QUERY_FOR_OBJECT,
Method Summary
void | executeQueryForList ( mixed $connection, mixed $parameter, mixed $result, mixed $skip, mixed $max)
void | executeQueryForMap ( mixed $connection, mixed $parameter, mixed $keyProperty, mixed $valueProperty)
void | executeQueryForObject ( mixed $connection, mixed $parameter, mixed $result)
void | executeUpdate ( mixed $connection, mixed $parameter)
Methods Inherited From TMappedStatement
TMappedStatement::addResultMapGroupBy(), TMappedStatement::applyResultMap(), TMappedStatement::enquequePostSelect(), TMappedStatement::executeInsert(), TMappedStatement::executePostSelect(), TMappedStatement::executeQueryForList(), TMappedStatement::executeQueryForMap(), TMappedStatement::executeQueryForObject(), TMappedStatement::executeSelectKey(), TMappedStatement::executeSQLQueryLimit(), TMappedStatement::executeUpdate(), TMappedStatement::fillArrayResultMap(), TMappedStatement::fillDefaultResultMap(), TMappedStatement::fillPropertyWithResultMap(), TMappedStatement::fillResultArrayList(), TMappedStatement::fillResultClass(), TMappedStatement::fillResultMap(), TMappedStatement::fillResultObjectProperty(), TMappedStatement::getCommand(), TMappedStatement::getID(), TMappedStatement::getManager(), TMappedStatement::getPostGeneratedSelectKey(), TMappedStatement::getPostSelectKeys(), TMappedStatement::getPreGeneratedSelectKey(), TMappedStatement::getResultMapGroupKey(), TMappedStatement::getScalarResult(), TMappedStatement::getSqlString(), TMappedStatement::getStatement(), TMappedStatement::initialGroupByResults(), TMappedStatement::onExecuteQuery(), TMappedStatement::raiseRowDelegate(), TMappedStatement::runQueryForList(), TMappedStatement::runQueryForMap(), TMappedStatement::runQueryForObject(), TMappedStatement::setObjectProperty()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

executeQueryForList

public void executeQueryForList (mixed $connection , mixed $parameter , mixed $result , mixed $skip , mixed $max )

Input
mixed | $connection
mixed | $parameter
mixed | $result
mixed | $skip
mixed | $max
Output
Exception

executeQueryForMap

public void executeQueryForMap (mixed $connection , mixed $parameter , mixed $keyProperty , mixed $valueProperty )

Input
mixed | $connection
mixed | $parameter
mixed | $keyProperty
mixed | $valueProperty
Output
Exception

executeQueryForObject

public void executeQueryForObject (mixed $connection , mixed $parameter , mixed $result )

Input
mixed | $connection
mixed | $parameter
mixed | $result
Output
Exception

executeUpdate

public void executeUpdate (mixed $connection , mixed $parameter )

Input
mixed | $connection
mixed | $parameter
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMappedStatement

Class TMappedStatement (Class Overview)

TComponent
   |
   --TMappedStatement

Direct Known Sub-classes:

TInsertMappedStatement , TSelectMappedStatement , TUpdateMappedStatement

TMappedStatement class executes SQL mapped statements. Mapped Statements can hold any SQL statement and use Parameter Maps and Result Maps for input and output.

This class is usualy instantiated during SQLMap configuration by TSqlDomBuilder.

Since: 3.0
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Creates a new mapped statement.
Method Summary
protected object result
addResultMapGroupBy ( TResultMap $resultMap, array $row, object the $parent, mixed &$resultObject)
ResultMap with GroupBy property. Save object collection graph in a tree and collect the result later.
protected object the
applyResultMap ( array $row, object the &$resultObject)
Apply result mapping.
protected void
enquequePostSelect ( string $select, TResultMap $resultMap, TResultProperty $property, array $row, object the $resultObject)
Add nested result property to post select queue.
string
executeInsert ( IDbConnection $connection, mixed $parameter)
Execute an insert statement. Fill the parameter object with the ouput parameters if any, also could return the insert generated key.
protected void
executePostSelect ( IDbConnection $connection)
Process 'select' result properties
array
executeQueryForList ( IDbConnection $connection, mixed $parameter, object result $result, integer $skip, integer $max, callback $delegate)
Executes the SQL and retuns a List of result objects.
array
executeQueryForMap ( IDbConnection $connection, mixed $parameter, string $keyProperty, string $valueProperty, callback $skip, mixed $max, mixed $delegate)
Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
${return}
executeQueryForObject ( IDbConnection $connection, mixed $parameter, mixed $result)
Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
protected string
executeSelectKey ( IDbConnection $connection, mixed $parameter, TSqlMapSelectKey $selectKey)
Execute the select key statement, used to obtain last insert ID.
protected mixed
executeSQLQueryLimit ( IDbConnection $connection, array $command, mixed $max, mixed $skip)
Execute SQL Query with limits.
integer
executeUpdate ( IDbConnection $connection, mixed $parameter)
Execute an update statement. Also used for delete statement.
protected array
fillArrayResultMap ( TResultMap $resultMap, array $row, object the $resultObject)
Retrieve the result map as an array.
protected mixed
fillDefaultResultMap ( TResultMap $resultMap, array $row, object the $resultObject)
Fill the result map using default settings. If <tt>$resultMap</tt> is null the result object returned will be guessed from <tt>$resultObject</tt>.
protected boolean
fillPropertyWithResultMap ( TResultMap $resultMap, array $row, object the &$resultObject)
Fills the property with result mapping results.
protected object result
fillResultArrayList ( array $row, object result $resultObject)
Apply the result to a TList or an array.
protected object result
fillResultClass ( string $resultClass, array $row, object the $resultObject)
Fill the result using ResultClass, will creates new result object if required.
protected object result
fillResultMap ( string $resultMapName, array $row, object result $parentGroup, mixed &$resultObject)
Fills the result object according to result mappings.
protected object result
fillResultObjectProperty ( array $row, object result $resultObject)
Apply the result to an object.
TPreparedCommand
getCommand ()
string
getID ()
TSqlMapper
getManager ()
protected string
getPostGeneratedSelectKey ( IDbConnection $connection, mixed $parameter)
Gets the inserted row ID after executing an insert statement.
protected array
getPostSelectKeys ( TResultMap $resultMap, TResultProperty $property, array $row)
Finds in the post select property the SQL statement primary selection keys.
protected string
getPreGeneratedSelectKey ( IDbConnection $connection, mixed $parameter)
Gets the insert generated ID before executing an insert statement.
protected string
getResultMapGroupKey ( TResultMap $resultMap, array $row)
Gets the result 'group by' groupping key for each row.
protected mixed
getScalarResult ( array $result, string $type)
Converts the first array value to scalar value of given type.
void
getSqlString ()
TSqlMapStatement
getStatement ()
protected void
initialGroupByResults ()
Empty the group by results cache.
void
onExecuteQuery ( array $sql)
Raise the execute query event.
protected void
raiseRowDelegate ( object event $handler, mixed $param)
Raises delegate handler.
array
runQueryForList ( IDbConnection $connection, mixed $parameter, array $sql, object result $result, integer $delegate, integer 5, callback 6)
Executes the SQL and retuns a List of result objects.
array
runQueryForMap ( IDbConnection $connection, mixed $parameter, array $command, string $keyProperty, string $valueProperty, callback $delegate)
Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.
object the
runQueryForObject ( IDbConnection $connection, array $command, object The &$result)
Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.
protected void
setObjectProperty ( TResultMap $resultMap, TResultProperty $property, array $row, object the &$resultObject)
Set a property of the result object with appropriate value.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
int | QUERY_FOR_ARRAY
int | QUERY_FOR_LIST
int | QUERY_FOR_OBJECT
Constructor Details

__construct

public __construct Array

Creates a new mapped statement.
Method Details

addResultMapGroupBy

protected object result addResultMapGroupBy (TResultMap $resultMap , array $row , object the $parent , mixed &$resultObject )

ResultMap with GroupBy property. Save object collection graph in a tree and collect the result later.

Input
TResultMap | $resultMap | result mapping details.
array | $row | a result set row retrieved from the database
object the | $parent | result object
mixed | &$resultObject |
Output
object result | object.
Exception

applyResultMap

protected object the applyResultMap (array $row , object the &$resultObject )

Apply result mapping.

Input
array | $row | a result set row retrieved from the database
object the | &$resultObject | result object, will create if necessary.
Output
object the | result filled with data, null if not filled.
Exception

enquequePostSelect

protected void enquequePostSelect (string $select , TResultMap $resultMap , TResultProperty $property , array $row , object the $resultObject )

Add nested result property to post select queue.

Input
string | $select | post select statement ID
TResultMap | $resultMap | current result mapping details.
TResultProperty | $property | current result property.
array | $row | a result set row retrieved from the database
object the | $resultObject | result object
Output
Exception

executeInsert

public string executeInsert (IDbConnection $connection , mixed $parameter )

Execute an insert statement. Fill the parameter object with the ouput parameters if any, also could return the insert generated key.

Input
IDbConnection | $connection | database connection
mixed | $parameter | The parameter object used to fill the statement.
Output
string | the insert generated key.
Exception

executePostSelect

protected void executePostSelect (IDbConnection $connection )

Process 'select' result properties

Input
IDbConnection $connection database connection
Output
Exception

executeQueryForList

public array executeQueryForList (IDbConnection $connection , mixed $parameter , object result $result , integer $skip , integer $max , callback $delegate )

Executes the SQL and retuns a List of result objects.

Input
IDbConnection | $connection | database connection
mixed | $parameter | The object used to set the parameters in the SQL.
object result | $result | collection object.
integer | $skip | The number of rows to skip over.
integer | $max | The maximum number of rows to return.
callback | $delegate | row delegate handler
Output
array | a list of result objects
Exception

executeQueryForMap

public array executeQueryForMap (IDbConnection $connection , mixed $parameter , string $keyProperty , string $valueProperty , callback $skip , mixed $max , mixed $delegate )

Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.

If valueProperty is null, the entire result object will be entered.

Input
IDbConnection | $connection | database connection
mixed | $parameter | The object used to set the parameters in the SQL.
string | $keyProperty | The property of the result object to be used as the key.
string | $valueProperty | The property of the result object to be used as the value (or null).
callback | $skip | row delegate handler
mixed | $max |
mixed | $delegate |
Output
array | An array of object containing the rows keyed by keyProperty.
Exception

executeQueryForObject

public ${return} executeQueryForObject (IDbConnection $connection , mixed $parameter , mixed $result )

Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.

Input
IDbConnection | $connection | database connection
mixed | $parameter | The parameter data (object, arrary, primitive) used to set the parameters in the SQL
mixed | $result | The result object.
Output
Exception

executeSelectKey

protected string executeSelectKey (IDbConnection $connection , mixed $parameter , TSqlMapSelectKey $selectKey )

Execute the select key statement, used to obtain last insert ID.

Input
IDbConnection | $connection | database connection
mixed | $parameter | insert statement parameter
TSqlMapSelectKey | $selectKey | select key statement
Output
string | last insert ID.
Exception

executeSQLQueryLimit

protected mixed executeSQLQueryLimit (IDbConnection $connection , array $command , mixed $max , mixed $skip )

Execute SQL Query with limits.

Input
IDbConnection | $connection | database connection
array | $command | SQL statement and parameters.
mixed | $max |
mixed | $skip |
Output
mixed | record set if applicable.
Exception
throws | TSqlMapExecutionException if execution error or false record set.
throws | TSqlMapQueryExecutionException if any execution error

executeUpdate

public integer executeUpdate (IDbConnection $connection , mixed $parameter )

Execute an update statement. Also used for delete statement.

Return the number of rows effected.

Input
IDbConnection | $connection | database connection
mixed | $parameter | The object used to set the parameters in the SQL.
Output
integer | The number of rows effected.
Exception

fillArrayResultMap

protected array fillArrayResultMap (TResultMap $resultMap , array $row , object the $resultObject )

Retrieve the result map as an array.

Input
TResultMap | $resultMap | result mapping details.
array | $row | a result set row retrieved from the database
object the | $resultObject | result object
Output
array | array list of result objects.
Exception

fillDefaultResultMap

protected mixed fillDefaultResultMap (TResultMap $resultMap , array $row , object the $resultObject )

Fill the result map using default settings. If <tt>$resultMap</tt> is null the result object returned will be guessed from <tt>$resultObject</tt>.

Input
TResultMap | $resultMap | result mapping details.
array | $row | a result set row retrieved from the database
object the | $resultObject | result object
Output
mixed | the result object filled with data.
Exception

fillPropertyWithResultMap

protected boolean fillPropertyWithResultMap (TResultMap $resultMap , array $row , object the &$resultObject )

Fills the property with result mapping results.

Input
TResultMap | $resultMap | nested result mapping details.
array | $row | a result set row retrieved from the database
object the | &$resultObject | result object
Output
boolean | true if the data was found, false otherwise.
Exception

fillResultArrayList

protected object result fillResultArrayList (array $row , object result $resultObject )

Apply the result to a TList or an array.

Input
array | $row | a result set row retrieved from the database
object result | $resultObject | object, array or list
Output
object result | filled with data.
Exception

fillResultClass

protected object result fillResultClass (string $resultClass , array $row , object the $resultObject )

Fill the result using ResultClass, will creates new result object if required.

Input
string | $resultClass | result object class name
array | $row | a result set row retrieved from the database
object the | $resultObject | result object, will create if necessary.
Output
object result | object filled with data
Exception

fillResultMap

protected object result fillResultMap (string $resultMapName , array $row , object result $parentGroup , mixed &$resultObject )

Fills the result object according to result mappings.

Input
string | $resultMapName | result map name.
array | $row | a result set row retrieved from the database
object result | $parentGroup | object to fill, will create new instances if required.
mixed | &$resultObject |
Output
object result | object filled with data.
Exception

fillResultObjectProperty

protected object result fillResultObjectProperty (array $row , object result $resultObject )

Apply the result to an object.

Input
array | $row | a result set row retrieved from the database
object result | $resultObject | object, array or list
Output
object result | filled with data.
Exception

getCommand

public TPreparedCommand getCommand ()

Output
TPreparedCommand command to prepare SQL statements.
Exception

getID

public string getID ()

Output
string Name used to identify the TMappedStatement amongst the others. This the name of the SQL statement by default.
Exception

getManager

public TSqlMapper getManager ()

Output
TSqlMapper The SqlMap used by this MappedStatement
Exception

getPostGeneratedSelectKey

protected string getPostGeneratedSelectKey (IDbConnection $connection , mixed $parameter )

Gets the inserted row ID after executing an insert statement.

Input
IDbConnection | $connection | database connection
mixed | $parameter | insert statement parameter.
Output
string | last insert ID, null otherwise.
Exception

getPostSelectKeys

protected array getPostSelectKeys (TResultMap $resultMap , TResultProperty $property , array $row )

Finds in the post select property the SQL statement primary selection keys.

Input
TResultMap | $resultMap | result mapping details
TResultProperty | $property | result property
array | $row | current row data.
Output
array | list of primary key values.
Exception

getPreGeneratedSelectKey

protected string getPreGeneratedSelectKey (IDbConnection $connection , mixed $parameter )

Gets the insert generated ID before executing an insert statement.

Input
IDbConnection | $connection | database connection
mixed | $parameter | insert statement parameter.
Output
string | new insert ID if pre-select key statement was executed, null otherwise.
Exception

getResultMapGroupKey

protected string getResultMapGroupKey (TResultMap $resultMap , array $row )

Gets the result 'group by' groupping key for each row.

Input
TResultMap | $resultMap | result mapping details.
array | $row | a result set row retrieved from the database
Output
string | groupping key.
Exception

getScalarResult

protected mixed getScalarResult (array $result , string $type )

Converts the first array value to scalar value of given type.

Input
array | $result | list of results
string | $type | scalar type.
Output
mixed | scalar value.
Exception

getSqlString

public void getSqlString ()

Output
Exception

getStatement

public TSqlMapStatement getStatement ()

Output
TSqlMapStatement The SQL statment used by this MappedStatement
Exception

initialGroupByResults

protected void initialGroupByResults ()

Empty the group by results cache.

Output
Exception

onExecuteQuery

public void onExecuteQuery (array $sql )

Raise the execute query event.

Input
array $sql prepared SQL statement and subsititution parameters
Output
Exception

raiseRowDelegate

protected void raiseRowDelegate (object event $handler , mixed $param )

Raises delegate handler.

This method is invoked for each new list item. It is the responsibility of the handler to add the item to the list.

Input
object event | $handler | parameter
mixed | $param |
Output
Exception

runQueryForList

public array runQueryForList (IDbConnection $connection , mixed $parameter , array $sql , object result $result , integer $delegate , integer 5 , callback 6 )

Executes the SQL and retuns a List of result objects.

This method should only be called by internal developers, consider using <tt>executeQueryForList()</tt> first.

Input
IDbConnection | $connection | database connection
mixed | $parameter | The object used to set the parameters in the SQL.
array | $sql | SQL string and subsititution parameters.
object result | $result | collection object.
integer | $delegate | The number of rows to skip over.
integer | 5 | The maximum number of rows to return.
callback | 6 | row delegate handler
Output
array | a list of result objects
Exception

runQueryForMap

public array runQueryForMap (IDbConnection $connection , mixed $parameter , array $command , string $keyProperty , string $valueProperty , callback $delegate )

Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter.

If valueProperty is null, the entire result object will be entered.

This method should only be called by internal developers, consider using <tt>executeQueryForMap()</tt> first.

Input
IDbConnection | $connection | database connection
mixed | $parameter | The object used to set the parameters in the SQL.
array | $command | SQL string and subsititution parameters.
string | $keyProperty | The property of the result object to be used as the key.
string | $valueProperty | The property of the result object to be used as the value (or null).
callback | $delegate | row delegate, a callback function
Output
array | An array of object containing the rows keyed by keyProperty.
Exception

runQueryForObject

public object the runQueryForObject (IDbConnection $connection , array $command , object The &$result )

Executes an SQL statement that returns a single row as an object of the type of the <tt>$result</tt> passed in as a parameter.

This method should only be called by internal developers, consider using <tt>executeQueryForObject()</tt> first.

Input
IDbConnection | $connection | database connection
array | $command | SQL string and subsititution parameters.
object The | &$result | result object.
Output
object the | object.
Exception

setObjectProperty

protected void setObjectProperty (TResultMap $resultMap , TResultProperty $property , array $row , object the &$resultObject )

Set a property of the result object with appropriate value.

Input
TResultMap | $resultMap | result mapping details.
TResultProperty | $property | the result property to fill.
array | $row | a result set row retrieved from the database
object the | &$resultObject | result object
Output
Exception
Constant Details

QUERY_FOR_ARRAY

Type:

int

Value:

1
Var: select is to query for list.

QUERY_FOR_LIST

Type:

int

Value:

0
Var: select is to query for list.

QUERY_FOR_OBJECT

Type:

int

Value:

2
Var: select is to query for object.


PRADO API Manual: Docs For Class TPostSelectBinding

Class TPostSelectBinding (Class Overview)

TPostSelectBinding class.

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

Method Summary
void | getKeys ()
void | getMethod ()
void | getResultObject ()
void | getResultProperty ()
void | getStatement ()
void | setKeys ( mixed $value)
void | setMethod ( mixed $value)
void | setResultObject ( mixed $value)
void | setResultProperty ( mixed $value)
void | setStatement ( mixed $value)

            Method Details

getKeys

                                public void getKeys
                                ()

Output

Exception

getMethod

                                public void getMethod
                                ()

Output

Exception

getResultObject

                                public void getResultObject
                                ()

Output

Exception

getResultProperty

                                public void getResultProperty
                                ()

Output

Exception

getStatement

                                public void getStatement
                                ()

Output

Exception

setKeys

                                public void setKeys
                                (mixed $value )

Input

mixed $value

Output

Exception

setMethod

                                public void setMethod
                                (mixed $value )

Input

mixed $value

Output

Exception

setResultObject

                                public void setResultObject
                                (mixed $value )

Input

mixed $value

Output

Exception

setResultProperty

                                public void setResultProperty
                                (mixed $value )

Input

mixed $value

Output

Exception

setStatement

                                public void setStatement
                                (mixed $value )

Input

mixed $value

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TResultSetListItemParameter

Class TResultSetListItemParameter (Class Overview)

TComponent
   |
   --TResultSetListItemParameter

TResultSetListItemParameter class

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Method Summary
void | getList ()
void | getParameter ()
void | getResult ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Method Details

getList

public void getList ()

Output
Exception

getParameter

public void getParameter ()

Output
Exception

getResult

public void getResult ()

Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TResultSetMapItemParameter

Class TResultSetMapItemParameter (Class Overview)

TComponent
   |
   --TResultSetMapItemParameter

TResultSetMapItemParameter class.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Method Summary
void | getKey ()
void | getMap ()
void | getParameter ()
void | getValue ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Method Details

getKey

public void getKey ()

Output
Exception

getMap

public void getMap ()

Output
Exception

getParameter

public void getParameter ()

Output
Exception

getValue

public void getValue ()

Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapObjectCollectionTree

Class TSqlMapObjectCollectionTree (Class Overview)

TSQLMapObjectCollectionTree class.

Maps object collection graphs as trees. Nodes in the collection can  be add using parent relationships. The object collections can be  build using the collect method.

            Since:
            3.1

            Author:
            Wei Zhuo <weizhuo[at]gmail[dot]com>

Method Summary
void | add ( string $parent, string $node, mixed $object) Add a new node to the object tree graph.
protected boolean | addNode ( array &$childs, string $parent, string $node) Find the parent node and add the new node as its child.
array | collect ()
protected void | collectChildren ( string $parent, array &$nodes) Visit all the child nodes and collect them by removing.
protected array | getCollection ()
protected boolean | hasChildren ( array &$nodes)
boolean | isEmpty ()
protected void | onChildNodesVisited ( string $parent, array $nodes) Set the object properties for all the child nodes visited.

            Method Details

add

                                public void add
                                (string $parent , string $node , mixed $object )

Add a new node to the object tree graph.

Input
string | $parent | parent node id
string | $node | new node id
mixed | $object | node value
Output
Exception

addNode

                                protected boolean addNode
                                (array &$childs , string $parent , string $node )

Find the parent node and add the new node as its child.

Input
array | &$childs | list of nodes to check
string | $parent | parent node id
string | $node | new node id
Output
boolean | true if parent node is found.
Exception

collect

                                public array collect
                                ()

Output

                                    array
                 object collection

Exception

collectChildren

                                protected void collectChildren
                                (string $parent , array &$nodes )

Visit all the child nodes and collect them by removing.

Input
string | $parent | parent node id
array | &$nodes | list of child nodes.
Output
Exception

getCollection

                                protected array getCollection
                                ()

Output

                                    array
                 object collection.

Exception

hasChildren

                                protected boolean hasChildren
                                (array &$nodes )

Input
array | &$nodes | list of nodes to check
Output
boolean | true if all nodes are leaf nodes, false otherwise
Exception

isEmpty

                                public boolean isEmpty
                                ()

Output

                                    boolean
                 true if the graph is empty

Exception

onChildNodesVisited

                                protected void onChildNodesVisited
                                (string $parent , array $nodes )

Set the object properties for all the child nodes visited.

Input
string | $parent | parent node id
array | $nodes | list of child nodes visited.
Output
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPreparedCommand

Class TPreparedCommand (Class Overview)

TPreparedCommand class.

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

Method Summary
protected void | applyParameterMap ( mixed $manager, mixed $command, mixed $prepared, mixed $statement, mixed $parameterObject)
void | create ( TSqlMapManager $manager, mixed $connection, mixed $statement, mixed $parameterObject, mixed $skip, mixed $max)

            Method Details

applyParameterMap

                                protected void applyParameterMap
                                (mixed $manager , mixed $command , mixed $prepared , mixed $statement , mixed $parameterObject )

Input
mixed | $manager
mixed | $command
mixed | $prepared
mixed | $statement
mixed | $parameterObject
Output
Exception

create

                                public void create
                                (TSqlMapManager $manager , mixed $connection , mixed $statement , mixed $parameterObject , mixed $skip , mixed $max )

Input
TSqlMapManager | $manager
mixed | $connection
mixed | $statement
mixed | $parameterObject
mixed | $skip
mixed | $max
Output
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPreparedStatement

Class TPreparedStatement (Class Overview)

TComponent
   |
   --TPreparedStatement

TpreparedStatement class.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct
Method Summary
void | getParameterNames ()
void | getParameterValues ()
void | getPreparedSql ()
void | setParameterNames ( mixed $value)
void | setParameterValues ( mixed $value)
void | setPreparedSql ( mixed $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct

Method Details

getParameterNames

public void getParameterNames ()

Output
Exception

getParameterValues

public void getParameterValues ()

Output
Exception

getPreparedSql

public void getPreparedSql ()

Output
Exception

setParameterNames

public void setParameterNames (mixed $value )

Input
mixed $value
Output
Exception

setParameterValues

public void setParameterValues (mixed $value )

Input
mixed $value
Output
Exception

setPreparedSql

public void setPreparedSql (mixed $value )

Input
mixed $value
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPreparedStatementFactory

Class TPreparedStatementFactory (Class Overview)

TPreparedStatementFactory class.

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

                    Constructor Summary

                    public

                            __construct
                            Array

Method Summary
protected void | createParametersForTextCommand ()
void | prepare ()

                    Constructor Details

__construct

                                public __construct
                                Array

            Method Details

createParametersForTextCommand

                                protected void createParametersForTextCommand
                                ()

Output

Exception

prepare

                                public void prepare
                                ()

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSelectMappedStatement

Class TSelectMappedStatement (Class Overview)

TComponent
   |
   --TMappedStatement
      |
      --TSelectMappedStatement

TSelectMappedStatment class.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constants Inherited From TMappedStatement
QUERY_FOR_ARRAY, QUERY_FOR_LIST, QUERY_FOR_OBJECT,
Method Summary
void | executeInsert ( mixed $connection, mixed $parameter)
void | executeUpdate ( mixed $connection, mixed $parameter)
Methods Inherited From TMappedStatement
TMappedStatement::addResultMapGroupBy(), TMappedStatement::applyResultMap(), TMappedStatement::enquequePostSelect(), TMappedStatement::executeInsert(), TMappedStatement::executePostSelect(), TMappedStatement::executeQueryForList(), TMappedStatement::executeQueryForMap(), TMappedStatement::executeQueryForObject(), TMappedStatement::executeSelectKey(), TMappedStatement::executeSQLQueryLimit(), TMappedStatement::executeUpdate(), TMappedStatement::fillArrayResultMap(), TMappedStatement::fillDefaultResultMap(), TMappedStatement::fillPropertyWithResultMap(), TMappedStatement::fillResultArrayList(), TMappedStatement::fillResultClass(), TMappedStatement::fillResultMap(), TMappedStatement::fillResultObjectProperty(), TMappedStatement::getCommand(), TMappedStatement::getID(), TMappedStatement::getManager(), TMappedStatement::getPostGeneratedSelectKey(), TMappedStatement::getPostSelectKeys(), TMappedStatement::getPreGeneratedSelectKey(), TMappedStatement::getResultMapGroupKey(), TMappedStatement::getScalarResult(), TMappedStatement::getSqlString(), TMappedStatement::getStatement(), TMappedStatement::initialGroupByResults(), TMappedStatement::onExecuteQuery(), TMappedStatement::raiseRowDelegate(), TMappedStatement::runQueryForList(), TMappedStatement::runQueryForMap(), TMappedStatement::runQueryForObject(), TMappedStatement::setObjectProperty()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

executeInsert

public void executeInsert (mixed $connection , mixed $parameter )

Input
mixed | $connection
mixed | $parameter
Output
Exception

executeUpdate

public void executeUpdate (mixed $connection , mixed $parameter )

Input
mixed | $connection
mixed | $parameter
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSimpleDynamicSql

Class TSimpleDynamicSql (Class Overview)

TComponent
   |
   --TStaticSql
      |
      --TSimpleDynamicSql

TSimpleDynamicSql class.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Method Summary
void
replaceDynamicParameter ( mixed $sql, mixed $parameter)
Methods Inherited From TStaticSql
TStaticSql::buildPreparedStatement(), TStaticSql::getPreparedStatement()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Method Details

replaceDynamicParameter

public void replaceDynamicParameter (mixed $sql , mixed $parameter )

Input
mixed | $sql
mixed | $parameter
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapSelect

Class TSqlMapSelect (Class Overview)

TComponent
   |
   --TSqlMapStatement
      |
      --TSqlMapSelect

TSqlMapSelect class file.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
void | getGenerate ()
void | setGenerate ( mixed $value)
Methods Inherited From TSqlMapStatement
TSqlMapStatement::createInstanceOf(), TSqlMapStatement::createInstanceOfListClass(), TSqlMapStatement::createInstanceOfResultClass(), TSqlMapStatement::getCache(), TSqlMapStatement::getCacheModel(), TSqlMapStatement::getExtends(), TSqlMapStatement::getID(), TSqlMapStatement::getListClass(), TSqlMapStatement::getParameterClass(), TSqlMapStatement::getParameterMap(), TSqlMapStatement::getResultClass(), TSqlMapStatement::getResultMap(), TSqlMapStatement::getSqlText(), TSqlMapStatement::initialize(), TSqlMapStatement::parameterMap(), TSqlMapStatement::resultMap(), TSqlMapStatement::setCache(), TSqlMapStatement::setCacheModel(), TSqlMapStatement::setExtends(), TSqlMapStatement::setID(), TSqlMapStatement::setInlineParameterMap(), TSqlMapStatement::setListClass(), TSqlMapStatement::setParameterClass(), TSqlMapStatement::setParameterMap(), TSqlMapStatement::setResultClass(), TSqlMapStatement::setResultMap(), TSqlMapStatement::setSqlText()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getGenerate

public void getGenerate ()

Output
Exception

setGenerate

public void setGenerate (mixed $value )

Input
mixed $value
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TStaticSql

Class TStaticSql (Class Overview)

TComponent
   |
   --TStaticSql

Direct Known Sub-classes:

TSimpleDynamicSql

TStaticSql class.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
void | buildPreparedStatement ( mixed $statement, mixed $sqlString)
void | getPreparedStatement ( mixed $parameter)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

buildPreparedStatement

public void buildPreparedStatement (mixed $statement , mixed $sqlString )

Input
mixed | $statement
mixed | $sqlString
Output
Exception

getPreparedStatement

public void getPreparedStatement (mixed $parameter )

Input
mixed $parameter
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TUpdateMappedStatement

Class TUpdateMappedStatement (Class Overview)

TComponent
   |
   --TMappedStatement
      |
      --TUpdateMappedStatement

Direct Known Sub-classes:

TDeleteMappedStatement

TUpdateMappedStatement class.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constants Inherited From TMappedStatement
QUERY_FOR_ARRAY, QUERY_FOR_LIST, QUERY_FOR_OBJECT,
Method Summary
void | executeInsert ( mixed $connection, mixed $parameter)
void | executeQueryForList ( mixed $connection, mixed $parameter, mixed $result, mixed $skip, mixed $max)
void | executeQueryForMap ( mixed $connection, mixed $parameter, mixed $keyProperty, mixed $valueProperty)
void | executeQueryForObject ( mixed $connection, mixed $parameter, mixed $result)
Methods Inherited From TMappedStatement
TMappedStatement::addResultMapGroupBy(), TMappedStatement::applyResultMap(), TMappedStatement::enquequePostSelect(), TMappedStatement::executeInsert(), TMappedStatement::executePostSelect(), TMappedStatement::executeQueryForList(), TMappedStatement::executeQueryForMap(), TMappedStatement::executeQueryForObject(), TMappedStatement::executeSelectKey(), TMappedStatement::executeSQLQueryLimit(), TMappedStatement::executeUpdate(), TMappedStatement::fillArrayResultMap(), TMappedStatement::fillDefaultResultMap(), TMappedStatement::fillPropertyWithResultMap(), TMappedStatement::fillResultArrayList(), TMappedStatement::fillResultClass(), TMappedStatement::fillResultMap(), TMappedStatement::fillResultObjectProperty(), TMappedStatement::getCommand(), TMappedStatement::getID(), TMappedStatement::getManager(), TMappedStatement::getPostGeneratedSelectKey(), TMappedStatement::getPostSelectKeys(), TMappedStatement::getPreGeneratedSelectKey(), TMappedStatement::getResultMapGroupKey(), TMappedStatement::getScalarResult(), TMappedStatement::getSqlString(), TMappedStatement::getStatement(), TMappedStatement::initialGroupByResults(), TMappedStatement::onExecuteQuery(), TMappedStatement::raiseRowDelegate(), TMappedStatement::runQueryForList(), TMappedStatement::runQueryForMap(), TMappedStatement::runQueryForObject(), TMappedStatement::setObjectProperty()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

executeInsert

public void executeInsert (mixed $connection , mixed $parameter )

Input
mixed | $connection
mixed | $parameter
Output
Exception

executeQueryForList

public void executeQueryForList (mixed $connection , mixed $parameter , mixed $result , mixed $skip , mixed $max )

Input
mixed | $connection
mixed | $parameter
mixed | $result
mixed | $skip
mixed | $max
Output
Exception

executeQueryForMap

public void executeQueryForMap (mixed $connection , mixed $parameter , mixed $keyProperty , mixed $valueProperty )

Input
mixed | $connection
mixed | $parameter
mixed | $keyProperty
mixed | $valueProperty
Output
Exception

executeQueryForObject

public void executeQueryForObject (mixed $connection , mixed $parameter , mixed $result )

Input
mixed | $connection
mixed | $parameter
mixed | $result
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IActiveControl

Interface IActiveControl (Class Overview)

IActiveControl interface.

Active controls must implement IActiveControl interface.

            Since:
            3.1

            Author:
            Wei Zhuo <weizhuo[at]gamil[dot]com>

            Method Summary

                        TBaseActiveControl

                            getActiveControl
                        ()

            Method Details

getActiveControl

                                public TBaseActiveControl getActiveControl
                                ()

Output

                                    TBaseActiveControl
                 Active control properties.

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IBindable

Interface IBindable (Class Overview)

IBindable interface.

This interface must be implemented by classes that are capable of performing databinding.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

            Method Summary

                        void

                            dataBind
                        ()

                            Performs databinding.

            Method Details

dataBind

                                public void dataBind
                                ()

Performs databinding.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class ICache

Interface ICache (Class Overview)

ICache interface.

This interface must be implemented by cache managers.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
boolean | add ( string $id, mixed $value, integer $expire, ICacheDependency $dependency) Stores a value identified by a key into cache if the cache does not contain this key.
boolean | delete ( string $id) Deletes a value with the specified key from cache
void | flush () Deletes all values from cache.
mixed | get ( string $id) Retrieves a value from cache with a specified key.
boolean | set ( string $id, mixed $value, integer $expire, ICacheDependency $dependency) Stores a value identified by a key into cache.

            Method Details

add

                                public boolean add
                                (string $id , mixed $value , integer $expire , ICacheDependency $dependency )

Stores a value identified by a key into cache if the cache does not contain this key.

Nothing will be done if the cache already contains the key.

Input
string | $id | the key identifying the value to be cached
mixed | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
ICacheDependency | $dependency | dependency of the cached item. If the dependency changes, the item is labelled invalid.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception

delete

                                public boolean delete
                                (string $id )

Deletes a value with the specified key from cache

Input
string | $id | the key of the value to be deleted
Output
boolean | if no error happens during deletion
Exception

flush

                                public void flush
                                ()

Deletes all values from cache.

Be careful of performing this operation if the cache is shared by multiple applications.

Output

Exception

get

                                public mixed get
                                (string $id )

Retrieves a value from cache with a specified key.

Input
string | $id | a key identifying the cached value
Output
mixed | the value stored in cache, false if the value is not in the cache or expired.
Exception

set

                                public boolean set
                                (string $id , mixed $value , integer $expire , ICacheDependency $dependency )

Stores a value identified by a key into cache.

If the cache already contains such a key, the existing value and  expiration time will be replaced with the new ones.

Input
string | $id | the key identifying the value to be cached
mixed | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
ICacheDependency | $dependency | dependency of the cached item. If the dependency changes, the item is labelled invalid.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class ICacheDependency

Interface ICacheDependency (Class Overview)

ICacheDependency interface.

This interface must be implemented by classes meant to be used as  cache dependencies.
Classes implementing this interface must support serialization and unserialization.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

            Method Summary

                        boolean

                            getHasChanged
                        ()

            Method Details

getHasChanged

                                public boolean getHasChanged
                                ()

Output

                                    boolean
                 whether the dependency has changed. Defaults to false.

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class ICallbackEventHandler

Interface ICallbackEventHandler (Class Overview)

ICallbackEventHandler interface.

If a control wants to respond to callback event, it must implement this  interface.

            Since:
            3.1

            Author:
            Wei Zhuo <weizhuo[at]gamil[dot]com>

            Method Summary

                        void

                            raiseCallbackEvent
                        (	TCallbackEventParameter $eventArgument)

                            Raises callback event. The implementation of this function should raise  appropriate event(s) (e.g. OnClick, OnCommand) indicating the component  is responsible for the callback event.

            Method Details

raiseCallbackEvent

                                public void raiseCallbackEvent
                                (TCallbackEventParameter $eventArgument )

Raises callback event. The implementation of this function should raise  appropriate event(s) (e.g. OnClick, OnCommand) indicating the component  is responsible for the callback event.

Input

TCallbackEventParameter $eventArgument the parameter associated with the callback event

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IDataRenderer

Interface IDataRenderer (Class Overview)

Direct Known Sub-interfaces:

                                    IScaffoldEditRenderer
                                                , IItemDataRenderer

IDataRenderer interface.

If a control wants to be used a renderer for another data-bound control,  this interface must be implemented.

            Since:
            3.1

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
mixed | getData ()
void | setData ( mixed $value)

            Method Details

getData

                                public mixed getData
                                ()

Output

                                    mixed
                 the data bound to this object

Exception

setData

                                public void setData
                                (mixed $value )

Input

mixed $value the data to be bound to this object

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IModule

Interface IModule (Class Overview)

IModule interface.

This interface must be implemented by application modules.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
string | getID ()
void | init ( TXmlElement $config) Initializes the module.
void | setID ( string $id)

            Method Details

getID

                                public string getID
                                ()

Output

                                    string
                 ID of the module

Exception

init

                                public void init
                                (TXmlElement $config )

Initializes the module.

Input

TXmlElement $config the configuration for the module

Output

Exception

setID

                                public void setID
                                (string $id )

Input

string $id ID of the module

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IRenderable

Interface IRenderable (Class Overview)

IRenderable interface.

This interface must be implemented by classes that can be rendered  to end-users.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

            Method Summary

                        void

                            render
                        (	ITextWriter $writer)

                            Renders the component to end-users.

            Method Details

render

                                public void render
                                (ITextWriter $writer )

Renders the component to end-users.

Input

ITextWriter $writer writer for the rendering purpose

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IService

Interface IService (Class Overview)

IService interface.

This interface must be implemented by services.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
boolean | getEnabled ()
string | getID ()
void | init ( TXmlElement $config) Initializes the service.
void | run () Runs the service.
void | setEnabled ( boolean $value)
void | setID ( string $id)

            Method Details

getEnabled

                                public boolean getEnabled
                                ()

Output

                                    boolean
                 whether the service is enabled

Exception

getID

                                public string getID
                                ()

Output

                                    string
                 ID of the service

Exception

init

                                public void init
                                (TXmlElement $config )

Initializes the service.

Input

TXmlElement $config the configuration for the service

Output

Exception

run

                                public void run
                                ()

Runs the service.

Output

Exception

setEnabled

                                public void setEnabled
                                (boolean $value )

Input

boolean $value whether the service is enabled

Output

Exception

setID

                                public void setID
                                (string $id )

Input

string $id ID of the service

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IStatePersister

Interface IStatePersister (Class Overview)

IStatePersister class.

This interface must be implemented by all state persister classes (such as  TPageStatePersister, TApplicationStatePersister.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
mixed | load () Loads state from a persistent storage.
void | save ( mixed $state) Saves state into a persistent storage.

            Method Details

load

                                public mixed load
                                ()

Loads state from a persistent storage.

Output

                                    mixed
                 the state

Exception

save

                                public void save
                                (mixed $state )

Saves state into a persistent storage.

Input

mixed $state the state to be saved

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IStyleable

Interface IStyleable (Class Overview)

IStyleable interface.

This interface should be implemented by classes that support CSS styles.

            Since:
            3.1.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
void | clearStyle () Removes all styles associated with the object
boolean | getHasStyle ()
TStyle | getStyle ()

            Method Details

clearStyle

                                public void clearStyle
                                ()

Removes all styles associated with the object

Output

Exception

getHasStyle

                                public boolean getHasStyle
                                ()

Output

                                    boolean
                 whether the object has defined any style information

Exception

getStyle

                                public TStyle getStyle
                                ()

Output

                                    TStyle
                 the object representing the css style of the object

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class ITextWriter

Interface ITextWriter (Class Overview)

ITextWriter interface.

This interface must be implemented by writers.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
void | flush () Flushes the content that has been written.
void | write ( string $str) Writes a string.

            Method Details

flush

                                public void flush
                                ()

Flushes the content that has been written.

Output

Exception

write

                                public void write
                                (string $str )

Writes a string.

Input

string $str string to be written

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IUser

Interface IUser (Class Overview)

IUser interface.

This interface must be implemented by user objects.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
boolean | getIsGuest ()
string | getName ()
array | getRoles ()
boolean | isInRole ( string $role)
IUser | loadFromString ( string $string)
string | saveToString ()
void | setIsGuest ( boolean $value)
void | setName ( string $value)
array|string | setRoles ( mixed $value)

            Method Details

getIsGuest

                                public boolean getIsGuest
                                ()

Output

                                    boolean
                 if the user is a guest

Exception

getName

                                public string getName
                                ()

Output

                                    string
                 username

Exception

getRoles

                                public array getRoles
                                ()

Output

                                    array
                 list of roles that the user is of

Exception

isInRole

                                public boolean isInRole
                                (string $role )

Input
string | $role | role to be tested
Output
boolean | whether the user is of this role
Exception

loadFromString

                                public IUser loadFromString
                                (string $string )

Input
string | $string | user data that is serialized and restored from session
Output
IUser | the user object
Exception

saveToString

                                public string saveToString
                                ()

Output

                                    string
                 user data that is serialized and will be stored in session

Exception

setIsGuest

                                public void setIsGuest
                                (boolean $value )

Input

boolean $value if the user is a guest

Output

Exception

setName

                                public void setName
                                (string $value )

Input

string $value username

Output

Exception

setRoles

                                public array|string setRoles
                                (mixed $value )

Input
mixed | $value
Output
array|string | list of roles that the user is of. If it is a string, roles are assumed by separated by comma
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class Prado

Class Prado (Class Overview)

PradoBase
   |
   --Prado

Defines Prado class if not defined.

Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From PradoBase
CLASS_FILE_EXT,
Method Summary
Methods Inherited From PradoBase
PradoBase::autoload(), PradoBase::createComponent(), PradoBase::exceptionHandler(), PradoBase::fatalError(), PradoBase::getApplication(), PradoBase::getFrameworkPath(), PradoBase::getLogger(), PradoBase::getPathAliases(), PradoBase::getPathOfAlias(), PradoBase::getPathOfNamespace(), PradoBase::getPreferredLanguage(), PradoBase::getUserLanguages(), PradoBase::getVersion(), PradoBase::initErrorHandlers(), PradoBase::localize(), PradoBase::log(), PradoBase::phpErrorHandler(), PradoBase::poweredByPrado(), PradoBase::serialize(), PradoBase::setApplication(), PradoBase::setPathOfAlias(), PradoBase::trace(), PradoBase::unserialize(), PradoBase::using(), PradoBase::varDump()
Constant Summary
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class PradoBase

Class PradoBase (Class Overview)

Direct Known Sub-classes:

                                    Prado

PradoBase class.

PradoBase implements a few fundamental static methods.
To use the static methods, Use Prado as the class name rather than PradoBase.  PradoBase is meant to serve as the base class of Prado. The latter might be  rewritten for customization.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
void | autoload ( string $className) Class autoload loader.
TComponent | createComponent ( string $type) Creates a component with the specified type.
void | exceptionHandler ( Exception $exception) Default exception handler.
void | fatalError ( string $msg) Fatal error handler.
TApplication | getApplication ()
string | getFrameworkPath ()
TLogger | getLogger ()
protected void | getPathAliases ()
string | getPathOfAlias ( string $alias)
string | getPathOfNamespace ( string $namespace, string $ext) Translates a namespace into a file path.
string | getPreferredLanguage () Returns the most preferred language by the client user.
array | getUserLanguages () Returns a list of user preferred languages.
string | getVersion ()
void | initErrorHandlers () Initializes error handlers.
string | localize ( string $text, array $parameters, string $catalogue, string $charset) Localize a text to the locale/culture specified in the globalization handler.
void | log ( string $msg, integer $level, string $category) Logs a message.
void | phpErrorHandler ( integer $errno, string $errstr, string $errfile, integer $errline) PHP error handler.
string | poweredByPrado ( integer $logoType)
string | serialize ( mixed $data) Serializes a data.
void | setApplication ( TApplication $application) Stores the application instance in the class static member.
void | setPathOfAlias ( string $alias, string $path)
void | trace ( string $msg, string $category) Writes a log message.
mixed | unserialize ( string $str) Unserializes a data.
void | using ( string $namespace, boolean $checkClassExistence) Uses a namespace.
string | varDump ( mixed $var, integer $depth, boolean $highlight) Converts a variable into a string representation.

            Constant Summary

                    string

                CLASS_FILE_EXT

                    File extension for Prado class files.

            Method Details

autoload

                                public void autoload
                                (string $className )

Class autoload loader.

This method is provided to be invoked within an __autoload() magic method.

Input

string $className class name

Output

Exception

createComponent

                                public TComponent createComponent
                                (string $type )

Creates a component with the specified type.

A component type can be either the component class name  or a namespace referring to the path of the component class file.  For example, 'TButton', 'System.Web.UI.WebControls.TButton' are both  valid component type.  This method can also pass parameters to component constructors.  All parameters passed to this method except the first one (the component type)  will be supplied as component constructor parameters.

Input
string | $type | component type
Output
TComponent | component instance of the specified type
Exception
throws | TInvalidDataValueException if the component type is unknown

exceptionHandler

                                public void exceptionHandler
                                (Exception $exception )

Default exception handler.

This method should be registered as default exception handler using  http://www.php.net/set_exception_handler. The method tries to use the errorhandler  module of the Prado application to handle the exception.  If the application or the module does not exist, it simply echoes the  exception.

Input

Exception $exception exception that is not caught

Output

Exception

fatalError

                                public void fatalError
                                (string $msg )

Fatal error handler.

This method displays an error message together with the current call stack.  The application will exit after calling this method.

Input

string $msg error message

Output

Exception

getApplication

                                public TApplication getApplication
                                ()

Output

                                    TApplication
                 the application singleton, null if the singleton has not be created yet.

Exception

getFrameworkPath

                                public string getFrameworkPath
                                ()

Output

                                    string
                 the path of the framework

Exception

getLogger

                                public TLogger getLogger
                                ()

Output

                                    TLogger
                 message logger

Exception

getPathAliases

                                protected void getPathAliases
                                ()

Output

Exception

getPathOfAlias

                                public string getPathOfAlias
                                (string $alias )

Input
string | $alias | alias to the path
Output
string | the path corresponding to the alias, null if alias not defined.
Exception

getPathOfNamespace

                                public string getPathOfNamespace
                                (string $namespace , string $ext )

Translates a namespace into a file path.

The first segment of the namespace is considered as a path alias  which is replaced with the actual path. The rest segments are  subdirectory names appended to the aliased path.  If the namespace ends with an asterisk '*', it represents a directory;  Otherwise it represents a file whose extension name is specified by the second parameter (defaults to empty).  Note, this method does not ensure the existence of the resulting file path.

Input
string | $namespace | namespace
string | $ext | extension to be appended if the namespace refers to a file
Output
string | file path corresponding to the namespace, null if namespace is invalid
Exception

getPreferredLanguage

                                public string getPreferredLanguage
                                ()

Returns the most preferred language by the client user.

Output

                                    string
                 the most preferred language by the client user, defaults to English.

Exception

getUserLanguages

                                public array getUserLanguages
                                ()

Returns a list of user preferred languages.

The languages are returned as an array. Each array element  represents a single language preference. The languages are ordered  according to user preferences. The first language is the most preferred.

Output

                                    array
                 list of user preferred languages.

Exception

getVersion

                                public string getVersion
                                ()

Output

                                    string
                 the version of Prado framework

Exception

initErrorHandlers

                                public void initErrorHandlers
                                ()

Initializes error handlers.

This method set error and exception handlers to be functions  defined in this class.

Output

Exception

localize

                                public string localize
                                (string $text , array $parameters , string $catalogue , string $charset )

Localize a text to the locale/culture specified in the globalization handler.

Input
string | $text | text to be localized.
array | $parameters | a set of parameters to substitute.
string | $catalogue | a different catalogue to find the localize text.
string | $charset | the input AND output charset.
Output
string | localized text.
Exception

log

                                public void log
                                (string $msg , integer $level , string $category )

Logs a message.

Messages logged by this method may be retrieved via TLogger::getLogs  and may be recorded in different media, such as file, email, database, using  TLogRouter.

Input
string | $msg | message to be logged
integer | $level | level of the message. Valid values include TLogger::DEBUG, TLogger::INFO, TLogger::NOTICE, TLogger::WARNING, TLogger::ERROR, TLogger::ALERT, TLogger::FATAL.
string | $category | category of the message
Output
Exception

phpErrorHandler

                                public void phpErrorHandler
                                (integer $errno , string $errstr , string $errfile , integer $errline )

PHP error handler.

This method should be registered as PHP error handler using  http://www.php.net/set_error_handler. The method throws an exception that  contains the error information.

Input
integer | $errno | the level of the error raised
string | $errstr | the error message
string | $errfile | the filename that the error was raised in
integer | $errline | the line number the error was raised at
Output
Exception

poweredByPrado

                                public string poweredByPrado
                                (integer $logoType )

Input
integer | $logoType | the type of "powered logo". Valid values include 0 and 1.
Output
string | a string that can be displayed on your Web page showing powered-by-PRADO information
Exception

serialize

                                public string serialize
                                (mixed $data )

Serializes a data.

The original PHP serialize function has a bug that may not serialize  properly an object.

Input
mixed | $data | data to be serialized
Output
string | the serialized data
Exception

setApplication

                                public void setApplication
                                (TApplication $application )

Stores the application instance in the class static member.

This method helps implement a singleton pattern for TApplication.  Repeated invocation of this method or the application constructor  will cause the throw of an exception.  This method should only be used by framework developers.

Input
TApplication | $application | the application instance
Output
Exception
throws | TInvalidOperationException if this method is invoked twice or more.

setPathOfAlias

                                public void setPathOfAlias
                                (string $alias , string $path )

Input
string | $alias | alias to the path
string | $path | the path corresponding to the alias
Output
Exception
throws | TInvalidOperationException if the alias is already defined
throws | TInvalidDataValueException if the path is not a valid file path

trace

                                public void trace
                                (string $msg , string $category )

Writes a log message.

This method wraps log() by checking the application mode.  When the application is in Debug mode, debug backtrace information is appended  to the message and the message is logged at DEBUG level.  When the application is in Performance mode, this method does nothing.  Otherwise, the message is logged at INFO level.

Input
string | $msg | message to be logged
string | $category | category of the message
Output
Exception

unserialize

                                public mixed unserialize
                                (string $str )

Unserializes a data.

The original PHP unserialize function has a bug that may not unserialize  properly an object.

Input
string | $str | data to be unserialized
Output
mixed | unserialized data, null if unserialize failed
Exception

using

                                public void using
                                (string $namespace , boolean $checkClassExistence )

Uses a namespace.

A namespace ending with an asterisk '*' refers to a directory, otherwise it represents a PHP file.  If the namespace corresponds to a directory, the directory will be appended  to the include path. If the namespace corresponds to a file, it will be included (include_once).

Input
string | $namespace | namespace to be used
boolean | $checkClassExistence | whether to check the existence of the class after the class file is included
Output
Exception
throws | TInvalidDataValueException if the namespace is invalid

varDump

                                public string varDump
                                (mixed $var , integer $depth , boolean $highlight )

Converts a variable into a string representation.

This method achieves the similar functionality as var_dump and print_r  but is more robust when handling complex objects such as PRADO controls.

Input
mixed | $var | variable to be dumped
integer | $depth | maximum depth that the dumper should go into the variable. Defaults to 10.
boolean | $highlight | whether to syntax highlight the output. Defaults to false.
Output
string | the string representation of the variable
Exception

            Constant Details

CLASS_FILE_EXT

File extension for Prado class files.

Type:

    string

Value:

'.php'

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TReflectionClass

Class TReflectionClass (Class Overview)

ReflectionClass
   |
   --TReflectionClass

TReflectionClass class.

This class was originally written to cope with the incompatibility between different PHP versions. It is equivalent to ReflectionClass for PHP version >= 5.1.0

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TApplication

Class TApplication (Class Overview)

TComponent
   |
   --TApplication

Direct Known Sub-classes:

TShellApplication

TApplication class.

TApplication coordinates modules and services, and serves as a configuration context for all Prado components.

TApplication uses a configuration file to specify the settings of the application, the modules, the services, the parameters, and so on.

TApplication adopts a modular structure. A TApplication instance is a composition of multiple modules. A module is an instance of class implementing IModule interface. Each module accomplishes certain functionalities that are shared by all Prado components in an application. There are default modules and user-defined modules. The latter offers extreme flexibility of extending TApplication in a plug-and-play fashion. Modules cooperate with each other to serve a user request by following a sequence of lifecycles predefined in TApplication.

TApplication has four modes that can be changed by setting Mode property (in the application configuration file).

  • Off mode will prevent the application from serving user requests.
  • Debug mode is mainly used during application development. It ensures the cache is always up-to-date if caching is enabled. It also allows exceptions are displayed with rich context information if they occur.
  • Normal mode is mainly used during production stage. Exception information will only be recorded in system error logs. The cache is ensured to be up-to-date if it is enabled.
  • Performance mode is similar to Normal mode except that it does not ensure the cache is up-to-date.
TApplication dispatches each user request to a particular service which finishes the actual work for the request with the aid from the application modules.

TApplication maintains a lifecycle with the following stages:

  • [construct] : construction of the application instance
  • [initApplication] : load application configuration and instantiate modules and the requested service
  • onBeginRequest : this event happens right after application initialization
  • onAuthentication : this event happens when authentication is needed for the current request
  • onAuthenticationComplete : this event happens right after the authentication is done for the current request
  • onAuthorization : this event happens when authorization is needed for the current request
  • onAuthorizationComplete : this event happens right after the authorization is done for the current request
  • onLoadState : this event happens when application state needs to be loaded
  • onLoadStateComplete : this event happens right after the application state is loaded
  • onPreRunService : this event happens right before the requested service is to run
  • runService : the requested service runs
  • onSaveState : this event happens when application needs to save its state
  • onSaveStateComplete : this event happens right after the application saves its state
  • onPreFlushOutput : this event happens right before the application flushes output to client side.
  • flushOutput : the application flushes output to client side.
  • onEndRequest : this is the last stage a request is being completed
  • [destruct] : destruction of the application instance
Modules and services can attach their methods to one or several of the above events and do appropriate processing when the events are raised. By this way, the application is able to coordinate the activities of modules and services in the above order. To terminate an application before the whole lifecycle completes, call completeRequest.

Examples:

  • Create and run a Prado application:

    1      $application=new TApplication($configFile);
    2      $application->run();

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void | applyConfiguration ( TApplicationConfiguration $config, boolean $withinService) Applies an application configuration.
void | clearGlobalState ( string $key) Clears a global value.
void | completeRequest () Completes current request processing.
void | flushOutput () Flushes output to client side.
IStatePersister | getApplicationStatePersister ()
TAssetManager | getAssetManager ()
TAuthorizationRuleCollection | getAuthorizationRules ()
string | getBasePath ()
ICache | getCache ()
string | getConfigurationFile ()
TErrorHandler | getErrorHandler ()
TGlobalization | getGlobalization ( boolean $createIfNotExists)
mixed | getGlobalState ( string $key, mixed $defaultValue) Returns a global value.
string | getID ()
TApplicationMode | getMode ()
IModule | getModule ( mixed $id)
array | getModules ()
string | getPageServiceID ()
TMap | getParameters () Returns the list of application parameters.
THttpRequest | getRequest ()
boolean | getRequestCompleted ()
THttpResponse | getResponse ()
string | getRuntimePath ()
TSecurityManager | getSecurityManager ()
IService | getService ()
THttpSession | getSession ()
string | getUniqueID ()
IUser | getUser ()
protected void | initApplication ( string 0, string 1) Loads configuration and initializes application.
protected void | loadGlobals () Loads global values from persistent storage.
void | onAuthentication () Raises OnAuthentication event.
void | onAuthenticationComplete () Raises OnAuthenticationComplete event.
void | onAuthorization () Raises OnAuthorization event.
void | onAuthorizationComplete () Raises OnAuthorizationComplete event.
void | onBeginRequest () Raises OnBeginRequest event.
void | onEndRequest () Raises OnEndRequest event.
void | onError ( mixed $param) Raises OnError event.
void | onLoadState () Raises OnLoadState event.
void | onLoadStateComplete () Raises OnLoadStateComplete event.
void | onPreFlushOutput () Raises OnPreFlushOutput event.
void | onPreRunService () Raises OnPreRunService event.
void | onSaveState () Raises OnSaveState event.
void | onSaveStateComplete () Raises OnSaveStateComplete event.
protected void | resolvePaths ( string $basePath) Resolves application-relevant paths.
void | run () Executes the lifecycles of the application.
void | runService () Runs the requested service.
protected void | saveGlobals () Saves global values into persistent storage.
void | setApplicationStatePersister ( IStatePersister $persister)
void | setAssetManager ( TAssetManager $value)
void | setBasePath ( string $value)
void | setCache ( ICache $cache)
void | setConfigurationFile ( string $value)
void | setErrorHandler ( TErrorHandler $handler)
void | setGlobalization ( TGlobalization $glob)
void | setGlobalState ( string $key, mixed $value, mixed $defaultValue) Sets a global value.
void | setID ( string $value)
void | setMode ( TApplicationMode $value)
void | setModule ( string $id, IModule $module) Adds a module to application.
void | setPageServiceID ( string $value)
void | setRequest ( THttpRequest $request)
void | setResponse ( THttpResponse $response)
void | setRuntimePath ( string $value)
void | setSecurityManager ( TSecurityManager $sm)
void | setService ( IService $value)
void | setSession ( THttpSession $session)
void | setUser ( IUser $user)
void | startService ( string $serviceID) Starts the specified service.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | CONFIGCACHE_FILE | Config cache file
string | CONFIG_FILE | Application configuration file name
string | CONFIG_FILE_EXT | File extension for external config files
string | GLOBAL_FILE | Global data file
string | PAGE_SERVICE_ID | Page service ID
string | RUNTIME_PATH | Runtime directory name
string | STATE_DEBUG |
string | STATE_NORMAL |
string | STATE_OFF | possible application mode.
string | STATE_PERFORMANCE |
Constructor Details

__construct

public __construct Array

Constructor.

Sets application base path and initializes the application singleton. Application base path refers to the root directory storing application data and code not directly accessible by Web users. By default, the base path is assumed to be the protected directory under the directory containing the current running script.

Throws: TConfigurationException if configuration file cannot be read or the runtime path is invalid.
Method Details

applyConfiguration

public void applyConfiguration (TApplicationConfiguration $config , boolean $withinService )

Applies an application configuration.

Input
TApplicationConfiguration | $config | the configuration
boolean | $withinService | whether the configuration is specified within a service.
Output
Exception

clearGlobalState

public void clearGlobalState (string $key )

Clears a global value.

The value cleared will no longer be available in this request and the following requests.

Input
string $key the name of the value to be cleared
Output
Exception

completeRequest

public void completeRequest ()

Completes current request processing.

This method can be used to exit the application lifecycles after finishing the current cycle.

Output
Exception

flushOutput

public void flushOutput ()

Flushes output to client side.

Output
Exception

getApplicationStatePersister

public IStatePersister getApplicationStatePersister ()

Output
IStatePersister application state persister
Exception

getAssetManager

public TAssetManager getAssetManager ()

Output
TAssetManager asset manager
Exception

getAuthorizationRules

public TAuthorizationRuleCollection getAuthorizationRules ()

Output
TAuthorizationRuleCollection list of authorization rules for the current request
Exception

getBasePath

public string getBasePath ()

Output
string the directory containing the application configuration file (absolute path)
Exception

getCache

public ICache getCache ()

Output
ICache the cache module, null if cache module is not installed
Exception

getConfigurationFile

public string getConfigurationFile ()

Output
string the application configuration file (absolute path)
Exception

getErrorHandler

public TErrorHandler getErrorHandler ()

Output
TErrorHandler the error handler module
Exception

getGlobalization

public TGlobalization getGlobalization (boolean $createIfNotExists )

Input
boolean | $createIfNotExists | whether to create globalization if it does not exist
Output
TGlobalization | globalization module
Exception

getGlobalState

public mixed getGlobalState (string $key , mixed $defaultValue )

Returns a global value.

A global value is one that is persistent across users sessions and requests.

Input
string | $key | the name of the value to be returned
mixed | $defaultValue | the default value. If $key is not found, $defaultValue will be returned
Output
mixed | the global value corresponding to $key
Exception

getID

public string getID ()

Output
string application ID
Exception

getMode

public TApplicationMode getMode ()

Output
TApplicationMode application mode. Defaults to TApplicationMode::Debug.
Exception

getModule

public IModule getModule (mixed $id )

Input
mixed | $id
Output
IModule | the module with the specified ID, null if not found
Exception

getModules

public array getModules ()

Output
array list of loaded application modules, indexed by module IDs
Exception

getPageServiceID

public string getPageServiceID ()

Output
string page service ID
Exception

getParameters

public TMap getParameters ()

Returns the list of application parameters.

Since the parameters are returned as a TMap object, you may use the returned result to access, add or remove individual parameters.

Output
TMap the list of application parameters
Exception

getRequest

public THttpRequest getRequest ()

Output
THttpRequest the request module
Exception

getRequestCompleted

public boolean getRequestCompleted ()

Output
boolean whether the current request is processed.
Exception

getResponse

public THttpResponse getResponse ()

Output
THttpResponse the response module
Exception

getRuntimePath

public string getRuntimePath ()

Output
string the directory storing cache data and application-level persistent data. (absolute path)
Exception

getSecurityManager

public TSecurityManager getSecurityManager ()

Output
TSecurityManager the security manager module
Exception

getService

public IService getService ()

Output
IService the currently requested service
Exception

getSession

public THttpSession getSession ()

Output
THttpSession the session module, null if session module is not installed
Exception

getUniqueID

public string getUniqueID ()

Output
string an ID that uniquely identifies this Prado application from the others
Exception

getUser

public IUser getUser ()

Output
IUser the application user
Exception

initApplication

protected void initApplication (string 0 , string 1 )

Loads configuration and initializes application.

Configuration file will be read and parsed (if a valid cached version exists, it will be used instead). Then, modules are created and initialized; Afterwards, the requested service is created and initialized.

Input
string | 0 | configuration file path (absolute or relative to current executing script)
string | 1 | cache file path, empty if no present or needed
Output
Exception
throws | TConfigurationException if module is redefined of invalid type, or service not defined or of invalid type

loadGlobals

protected void loadGlobals ()

Loads global values from persistent storage.

This method is invoked when OnLoadState event is raised. After this method, values that are stored in previous requests become available to the current request via getGlobalState.

Output
Exception

onAuthentication

public void onAuthentication ()

Raises OnAuthentication event.

This method is invoked when the user request needs to be authenticated.

Output
Exception

onAuthenticationComplete

public void onAuthenticationComplete ()

Raises OnAuthenticationComplete event.

This method is invoked right after the user request is authenticated.

Output
Exception

onAuthorization

public void onAuthorization ()

Raises OnAuthorization event.

This method is invoked when the user request needs to be authorized.

Output
Exception

onAuthorizationComplete

public void onAuthorizationComplete ()

Raises OnAuthorizationComplete event.

This method is invoked right after the user request is authorized.

Output
Exception

onBeginRequest

public void onBeginRequest ()

Raises OnBeginRequest event.

At the time when this method is invoked, application modules are loaded and initialized, user request is resolved and the corresponding service is loaded and initialized. The application is about to start processing the user request.

Output
Exception

onEndRequest

public void onEndRequest ()

Raises OnEndRequest event.

This method is invoked when the application completes the processing of the request.

Output
Exception

onError

public void onError (mixed $param )

Raises OnError event.

This method is invoked when an exception is raised during the lifecycles of the application.

Input
mixed $param event parameter
Output
Exception

onLoadState

public void onLoadState ()

Raises OnLoadState event.

This method is invoked when the application needs to load state (probably stored in session).

Output
Exception

onLoadStateComplete

public void onLoadStateComplete ()

Raises OnLoadStateComplete event.

This method is invoked right after the application state has been loaded.

Output
Exception

onPreFlushOutput

public void onPreFlushOutput ()

Raises OnPreFlushOutput event.

This method is invoked right before the application flushes output to client.

Output
Exception

onPreRunService

public void onPreRunService ()

Raises OnPreRunService event.

This method is invoked right before the service is to be run.

Output
Exception

onSaveState

public void onSaveState ()

Raises OnSaveState event.

This method is invoked when the application needs to save state (probably stored in session).

Output
Exception

onSaveStateComplete

public void onSaveStateComplete ()

Raises OnSaveStateComplete event.

This method is invoked right after the application state has been saved.

Output
Exception

resolvePaths

protected void resolvePaths (string $basePath )

Resolves application-relevant paths.

This method is invoked by the application constructor to determine the application configuration file, application root path and the runtime path.

Input
string $basePath the application root path or the application configuration file
Output
Exception

run

public void run ()

Executes the lifecycles of the application.

This is the main entry function that leads to the running of the whole Prado application.

Output
Exception

runService

public void runService ()

Runs the requested service.

Output
Exception

saveGlobals

protected void saveGlobals ()

Saves global values into persistent storage.

This method is invoked when OnSaveState event is raised.

Output
Exception

setApplicationStatePersister

public void setApplicationStatePersister (IStatePersister $persister )

Input
IStatePersister $persister application state persister
Output
Exception

setAssetManager

public void setAssetManager (TAssetManager $value )

Input
TAssetManager $value asset manager
Output
Exception

setBasePath

public void setBasePath (string $value )

Input
string $value the directory containing the application configuration file
Output
Exception

setCache

public void setCache (ICache $cache )

Input
ICache $cache the cache module
Output
Exception

setConfigurationFile

public void setConfigurationFile (string $value )

Input
string $value the application configuration file (absolute path)
Output
Exception

setErrorHandler

public void setErrorHandler (TErrorHandler $handler )

Input
TErrorHandler $handler the error handler module
Output
Exception

setGlobalization

public void setGlobalization (TGlobalization $glob )

Input
TGlobalization $glob globalization module
Output
Exception

setGlobalState

public void setGlobalState (string $key , mixed $value , mixed $defaultValue )

Sets a global value.

A global value is one that is persistent across users sessions and requests. Make sure that the value is serializable and unserializable.

Input
string | $key | the name of the value to be set
mixed | $value | the global value to be set
mixed | $defaultValue | the default value. If $key is not found, $defaultValue will be returned
Output
Exception

setID

public void setID (string $value )

Input
string $value application ID
Output
Exception

setMode

public void setMode (TApplicationMode $value )

Input
TApplicationMode $value application mode
Output
Exception

setModule

public void setModule (string $id , IModule $module )

Adds a module to application.

Note, this method does not do module initialization.

Input
string | $id | ID of the module
IModule | $module | module object
Output
Exception

setPageServiceID

public void setPageServiceID (string $value )

Input
string $value page service ID
Output
Exception

setRequest

public void setRequest (THttpRequest $request )

Input
THttpRequest $request the request module
Output
Exception

setResponse

public void setResponse (THttpResponse $response )

Input
THttpResponse $response the request module
Output
Exception

setRuntimePath

public void setRuntimePath (string $value )

Input
string $value the directory storing cache data and application-level persistent data. (absolute path)
Output
Exception

setSecurityManager

public void setSecurityManager (TSecurityManager $sm )

Input
TSecurityManager $sm the security manager module
Output
Exception

setService

public void setService (IService $value )

Input
IService $value the currently requested service
Output
Exception

setSession

public void setSession (THttpSession $session )

Input
THttpSession $session the session module
Output
Exception

setUser

public void setUser (IUser $user )

Input
IUser $user the application user
Output
Exception

startService

public void startService (string $serviceID )

Starts the specified service.

The service instance will be created. Its properties will be initialized and the configurations will be applied, if any.

Input
string $serviceID service ID
Output
Exception

Constant Details

CONFIGCACHE_FILE

Config cache file

Type:

string

Value:

'config.cache'

CONFIG_FILE

Application configuration file name

Type:

string

Value:

'application.xml'

CONFIG_FILE_EXT

File extension for external config files

Type:

string

Value:

'.xml'

GLOBAL_FILE

Global data file

Type:

string

Value:

'global.cache'

PAGE_SERVICE_ID

Page service ID

Type:

string

Value:

'page'

RUNTIME_PATH

Runtime directory name

Type:

string

Value:

'runtime'

STATE_DEBUG

Type:

string

Value:

'Debug'

STATE_NORMAL

Type:

string

Value:

'Normal'

STATE_OFF

possible application mode.

Type:

string

Value:

'Off'
Deprecated: deprecated since version 3.0.4 (use TApplicationMode constants instead)

STATE_PERFORMANCE

Type:

string

Value:

'Performance'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TApplicationConfiguration

Class TApplicationConfiguration (Class Overview)

TComponent
   |
   --TApplicationConfiguration

TApplicationConfiguration class.

This class is used internally by TApplication to parse and represent application configuration.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
array | getAliases () Returns list of path alias definitions.
array | getExternalConfigurations ()
boolean | getIsEmpty ()
array | getModules () Returns list of module configurations.
array | getParameters () Returns list of parameter definitions.
array | getProperties () Returns list of page initial property values.
array | getServices ()
array | getUsings () Returns list of namespaces to be used.
protected void | loadExternalXml ( TXmlElement $includeNode, string $configPath) Loads the external XML configurations.
void | loadFromFile ( string $fname) Parses the application configuration file.
void | loadFromXml ( TXmlElement $dom, string $configPath) Parses the application configuration given in terms of a TXmlElement.
protected void | loadModulesXml ( TXmlElement $modulesNode, string $configPath) Loads the modules XML node.
protected void | loadParametersXml ( TXmlElement $parametersNode, string $configPath) Loads the parameters XML node.
protected void | loadPathsXml ( TXmlElement $pathsNode, string $configPath) Loads the paths XML node.
protected void | loadServicesXml ( TXmlElement $servicesNode, string $configPath) Loads the services XML node.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getAliases

public array getAliases ()

Returns list of path alias definitions.

The definitions are aggregated (top-down) from configuration files along the path to the specified page. Each array element represents a single alias definition, with the key being the alias name and the value the absolute path.

Output
array list of path alias definitions
Exception

getExternalConfigurations

public array getExternalConfigurations ()

Output
array list of external configuration files. Each element is like $filePath=>$condition
Exception

getIsEmpty

public boolean getIsEmpty ()

Output
boolean whether this configuration contains actual stuff
Exception

getModules

public array getModules ()

Returns list of module configurations.

The module configurations are aggregated (top-down) from configuration files along the path to the specified page. Each array element represents a single module configuration, with the key being the module ID and the value the module configuration. Each module configuration is stored in terms of an array with the following content ([0]=>module type, [1]=>module properties, [2]=>complete module configuration) The module properties are an array of property values indexed by property names. The complete module configuration is a TXmlElement object representing the raw module configuration which may contain contents enclosed within module tags.

Output
array list of module configurations to be used
Exception

getParameters

public array getParameters ()

Returns list of parameter definitions.

The parameter definitions are aggregated (top-down) from configuration files along the path to the specified page. Each array element represents a single parameter definition, with the key being the parameter ID and the value the parameter definition. A parameter definition can be either a string representing a string-typed parameter, or an array. The latter defines a component-typed parameter whose format is as follows, ([0]=>component type, [1]=>component properties) The component properties are an array of property values indexed by property names.

Output
array list of parameter definitions to be used
Exception

getProperties

public array getProperties ()

Returns list of page initial property values.

Each array element represents a single property with the key being the property name and the value the initial property value.

Output
array list of page initial property values
Exception

getServices

public array getServices ()

Output
array list of service configurations
Exception

getUsings

public array getUsings ()

Returns list of namespaces to be used.

The namespaces are aggregated (top-down) from configuration files along the path to the specified page. Each array element represents a single namespace usage, with the value being the namespace to be used.

Output
array list of namespaces to be used
Exception

loadExternalXml

protected void loadExternalXml (TXmlElement $includeNode , string $configPath )

Loads the external XML configurations.

Input
TXmlElement | $includeNode | the application DOM element
string | $configPath | the context path (for specifying relative paths)
Output
Exception

loadFromFile

public void loadFromFile (string $fname )

Parses the application configuration file.

Input
string | $fname | configuration file name
Output
Exception
throws | TConfigurationException if there is any parsing error

loadFromXml

public void loadFromXml (TXmlElement $dom , string $configPath )

Parses the application configuration given in terms of a TXmlElement.

Input
TXmlElement | $dom | the XML element
string | $configPath | the context path (for specifying relative paths)
Output
Exception

loadModulesXml

protected void loadModulesXml (TXmlElement $modulesNode , string $configPath )

Loads the modules XML node.

Input
TXmlElement | $modulesNode | the modules XML node
string | $configPath | the context path (for specifying relative paths)
Output
Exception

loadParametersXml

protected void loadParametersXml (TXmlElement $parametersNode , string $configPath )

Loads the parameters XML node.

Input
TXmlElement | $parametersNode | the parameters XML node
string | $configPath | the context path (for specifying relative paths)
Output
Exception

loadPathsXml

protected void loadPathsXml (TXmlElement $pathsNode , string $configPath )

Loads the paths XML node.

Input
TXmlElement | $pathsNode | the paths XML node
string | $configPath | the context path (for specifying relative paths)
Output
Exception

loadServicesXml

protected void loadServicesXml (TXmlElement $servicesNode , string $configPath )

Loads the services XML node.

Input
TXmlElement | $servicesNode | the services XML node
string | $configPath | the context path (for specifying relative paths)
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TApplicationMode

Class TApplicationMode (Class Overview)

TEnumerable
   |
   --TApplicationMode

TApplicationMode class.

TApplicationMode defines the possible mode that an application can be set at by setting TApplication::setMode. In particular, the following modes are defined

  • Off: the application is not running. Any request to the application will obtain an error.
  • Debug: the application is running in debug mode.
  • Normal: the application is running in normal production mode.
  • Performance: the application is running in performance mode.

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Debug
string | Normal
string | Off
string | Performance
Constant Details

Debug

Type:

string

Value:

'Debug'

Normal

Type:

string

Value:

'Normal'

Off

Type:

string

Value:

'Off'

Performance

Type:

string

Value:

'Performance'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TApplicationStatePersister

Class TApplicationStatePersister (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TApplicationStatePersister

TApplicationStatePersister class.

TApplicationStatePersister provides a file-based persistent storage for application state. Application state, when serialized, is stored in a file named 'global.cache' under the 'runtime' directory of the application. Cache will be exploited if it is enabled.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected string | getStateFilePath ()
void | init ( TXmlElement $config) Initializes module.
mixed | load () Loads application state from persistent storage.
void | save ( mixed $state) Saves application state in persistent storage.
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string CACHE_NAME Name of the value stored in cache
Method Details

getStateFilePath

protected string getStateFilePath ()

Output
string the file path storing the application state
Exception

init

public void init (TXmlElement $config )

Initializes module.

Input
TXmlElement $config module configuration (may be null)
Output
Exception

load

public mixed load ()

Loads application state from persistent storage.

Output
mixed application state
Exception

save

public void save (mixed $state )

Saves application state in persistent storage.

Input
mixed $state application state
Output
Exception

Constant Details

CACHE_NAME

Name of the value stored in cache

Type:

string

Value:

'prado:appstate'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TApplicationComponent

Class TApplicationComponent (Class Overview)

TComponent
   |
   --TApplicationComponent

Direct Known Sub-classes:

TModule , TService , TLogRoute , TJsonResponse , TSoapServer , THttpRequest , THttpResponseAdapter , THttpSession , TCallbackClientScript , TClientScriptManager , TControl , TControlAdapter , THtmlWriter , TTemplate , TTheme , TDataGridColumn

TApplicationComponent class

TApplicationComponent is the base class for all components that are application-related, such as controls, modules, services, etc.

TApplicationComponent mainly defines a few properties that are shortcuts to some commonly used methods. The Application property gives the application instance that this component belongs to; Service gives the current running service; Request, Response and Session return the request and response modules, respectively; And User gives the current user instance.

Besides, TApplicationComponent defines two shortcut methods for publishing private files: publishAsset and publishFilePath.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
TApplication | getApplication ()
THttpRequest | getRequest ()
THttpResponse | getResponse ()
IService | getService ()
THttpSession | getSession ()
IUser | getUser ()
string | publishAsset ( string $assetPath, string $className) Publishes a private asset and gets its URL.
string | publishFilePath ( string $fullPath) Publishes a file or directory and returns its URL.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getApplication

public TApplication getApplication ()

Output
TApplication current application instance
Exception

getRequest

public THttpRequest getRequest ()

Output
THttpRequest the current user request
Exception

getResponse

public THttpResponse getResponse ()

Output
THttpResponse the response
Exception

getService

public IService getService ()

Output
IService the current service
Exception

getSession

public THttpSession getSession ()

Output
THttpSession user session
Exception

getUser

public IUser getUser ()

Output
IUser information about the current user
Exception

publishAsset

public string publishAsset (string $assetPath , string $className )

Publishes a private asset and gets its URL.

This method will publish a private asset (file or directory) and gets the URL to the asset. Note, if the asset refers to a directory, all contents under that directory will be published. Also note, it is recommended that you supply a class name as the second parameter to the method (e.g. publishAsset($assetPath,__CLASS__) ). By doing so, you avoid the issue that child classes may not work properly because the asset path will be relative to the directory containing the child class file.

Input
string | $assetPath | path of the asset that is relative to the directory containing the specified class file.
string | $className | name of the class whose containing directory will be prepend to the asset path. If null, it means get_class($this).
Output
string | URL to the asset path.
Exception

publishFilePath

public string publishFilePath (string $fullPath )

Publishes a file or directory and returns its URL.

Input
string | $fullPath | absolute path of the file or directory to be published
Output
string | URL to the published file or directory
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TComponent

Class TComponent (Class Overview)

Direct Known Sub-classes:

                                    TCacheDependency
                                                , TDummyDataSource
                                                , TList
                                                , TMap
                                                , TPagedDataSource
                                                , TQueue
                                                , TStack
                                                , TActiveRecord
                                                , TActiveRecordGateway
                                                , TActiveRecordManager
                                                , TOracleTableInfo
                                                , TDbCommandBuilder
                                                , TDbMetaData
                                                , TDbTableColumn
                                                , TDbTableInfo
                                                , TDataGatewayCommand
                                                , TSqlCriteria
                                                , TTableGateway
                                                , TDiscriminator
                                                , TSubMap
                                                , TParameterMap
                                                , TParameterProperty
                                                , TResultMap
                                                , TResultProperty
                                                , TSqlMapCacheModel
                                                , TSqlMapStatement
                                                , TSqlMapTypeHandler
                                                , TMappedStatement
                                                , TResultSetListItemParameter
                                                , TResultSetMapItemParameter
                                                , TPreparedStatement
                                                , TStaticSql
                                                , TSqlMapGateway
                                                , TSqlMapManager
                                                , TDbCommand
                                                , TDbConnection
                                                , TDbDataReader
                                                , TDbTransaction
                                                , Translation
                                                , TTextWriter
                                                , TAuthorizationRule
                                                , TUser
                                                , TApplication
                                                , TApplicationConfiguration
                                                , TApplicationComponent
                                                , TEventParameter
                                                , TComponentReflection
                                                , TLogger
                                                , TPageConfiguration
                                                , THttpCookie
                                                , TUri
                                                , TUrlMappingPattern
                                                , TAutoCompleteTemplate
                                                , TBaseActiveControl
                                                , TCachePageStatePersister
                                                , TClientSideOptions
                                                , TCompositeLiteral
                                                , TPageStatePersister
                                                , TSessionPageStatePersister
                                                , TDataSourceSelectParameters
                                                , TDataSourceView
                                                , TFont
                                                , TMetaTag
                                                , THotSpot
                                                , TListItem
                                                , TRepeatInfo
                                                , TStyle
                                                , TWizardSideBarTemplate
                                                , TWizardSideBarListItemTemplate
                                                , TWizardNavigationTemplate
                                                , TXmlElement

TComponent class

TComponent is the base class for all PRADO components.  TComponent implements the protocol of defining, using properties and events.
A property is defined by a getter method, and/or a setter method.  Properties can be accessed in the way like accessing normal object members.  Reading or writing a property will cause the invocation of the corresponding  getter or setter method, e.g.,

1      $a=$this->Text;     // equivalent to $a=$this->getText();
1       $this->Text='abc';  // equivalent to $this->setText('abc');
  The signatures of getter and setter methods are as follows,

1      // getter, defines a readable property 'Text'
2       function getText() { ... }
3      // setter, defines a writable property 'Text', with $value being the value to be set to the property
4       function setText($value) { ... }
  Property names are case-insensitive. It is recommended that they are written  in the format of concatenated words, with the first letter of each word  capitalized (e.g. DisplayMode, ItemStyle).
An event is defined by the presence of a method whose name starts with 'on'.  The event name is the method name and is thus case-insensitive.  An event can be attached with one or several methods (called event handlers).  An event can be raised by calling raiseEvent method, upon which  the attached event handlers will be invoked automatically in the order they  are attached to the event. Event handlers must have the following signature,

1      function eventHandlerFuncName($sender,$param) { ... }
  where $sender refers to the object who is responsible for the raising of the event,  and $param refers to a structure that may contain event-specific information.  To raise an event (assuming named as 'Click') of a component, use

1      $component->raiseEvent('OnClick');
  To attach an event handler to an event, use one of the following ways,

1      $component->OnClick=$callback;  // or $component->OnClick->add($callback);
2       $$component->attachEventHandler('OnClick',$callback);
  The first two ways make use of the fact that $component->OnClick refers to  the event handler list TList for the 'OnClick' event.  The variable $callback contains the definition of the event handler that can  be either a string referring to a global function name, or an array whose  first element refers to an object and second element a method name/path that  is reachable by the object, e.g.
  • 'buttonClicked' : buttonClicked($sender,$param);
  • array($object,'buttonClicked') : $object->buttonClicked($sender,$param);
  • array($object,'MainContent.SubmitButton.buttonClicked') :
   $object->MainContent->SubmitButton->buttonClicked($sender,$param);

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
void | addParsedObject ( string|TComponent $object) Processes an object that is created during parsing template.
void | attachEventHandler ( string $name, callback $handler) Attaches an event handler to an event.
boolean | canGetProperty ( string $name) Determines whether a property can be read.
boolean | canSetProperty ( string $name) Determines whether a property can be set.
void | createdOnTemplate ( TComponent $parent) This method is invoked after the component is instantiated by a template.
boolean | detachEventHandler ( string $name, callback $handler) Detaches an existing event handler.
mixed | evaluateExpression ( mixed $expression) Evaluates a PHP expression in the context of this control.
string | evaluateStatements ( string $statements) Evaluates a list of PHP statements.
TList | getEventHandlers ( mixed $name) Returns the list of attached event handlers for an event.
mixed | getSubProperty ( string $path) Evaluates a property path.
boolean | hasEvent ( string $name) Determines whether an event is defined.
boolean | hasEventHandler ( mixed $name)
boolean | hasProperty ( string $name) Determines whether a property is defined.
void | raiseEvent ( string $name, mixed $sender, TEventParameter $param) Raises an event.
void | setSubProperty ( string $path, mixed $value) Sets a value to a property path.
mixed | __get ( string $name) Returns a property value or an event handler list by property or event name.
void | __set ( string $name, mixed $value) Sets value of a component property.

            Method Details

addParsedObject

                                public void addParsedObject
                                (string|TComponent $object )

Processes an object that is created during parsing template.

The object can be either a component or a static text string.  This method can be overridden to customize the handling of newly created objects in template.  Only framework developers and control developers should use this method.

Input

string|TComponent $object text string or component parsed and instantiated in template

Output

Exception

attachEventHandler

                                public void attachEventHandler
                                (string $name , callback $handler )

Attaches an event handler to an event.

The handler must be a valid PHP callback, i.e., a string referring to  a global function name, or an array containing two elements with  the first element being an object and the second element a method name  of the object. In Prado, you can also use method path to refer to  an event handler. For example, array($object,'Parent.buttonClicked')  uses a method path that refers to the method $object->Parent->buttonClicked(...).
The event handler must be of the following signature,

1      function handlerName($sender,$param) {}
  where $sender represents the object that raises the event,  and $param is the event parameter.
This is a convenient method to add an event handler.  It is equivalent to getEventHandlers($name)->add($handler).  For complete management of event handlers, use getEventHandlers  to get the event handler list first, and then do various  TList operations to append, insert or remove  event handlers. You may also do these operations like  getting and setting properties, e.g.,

1      $component->OnClick[]=array($object,'buttonClicked');
2      $component->OnClick->insertAt(0,array($object,'buttonClicked'));
  which are equivalent to the following

1      $component->getEventHandlers('OnClick')->add(array($object,'buttonClicked'));
2      $component->getEventHandlers('OnClick')->insertAt(0,array($object,'buttonClicked'));

Input
string | $name | the event name
callback | $handler | the event handler
Output
Exception
throws | TInvalidOperationException if the event does not exist

canGetProperty

                                public boolean canGetProperty
                                (string $name )

Determines whether a property can be read.

A property can be read if the class has a getter method  for the property name. Note, property name is case-insensitive.

Input
string | $name | the property name
Output
boolean | whether the property can be read
Exception

canSetProperty

                                public boolean canSetProperty
                                (string $name )

Determines whether a property can be set.

A property can be written if the class has a setter method  for the property name. Note, property name is case-insensitive.

Input
string | $name | the property name
Output
boolean | whether the property can be written
Exception

createdOnTemplate

                                public void createdOnTemplate
                                (TComponent $parent )

This method is invoked after the component is instantiated by a template.

When this method is invoked, the component's properties have been initialized.  The default implementation of this method will invoke  the potential parent component's addParsedObject.  This method can be overridden.

Input

TComponent $parent potential parent of this control

Output

Exception

detachEventHandler

                                public boolean detachEventHandler
                                (string $name , callback $handler )

Detaches an existing event handler.

This method is the opposite of attachEventHandler.

Input
string | $name | event name
callback | $handler | the event handler to be removed
Output
boolean | if the removal is successful
Exception

evaluateExpression

                                public mixed evaluateExpression
                                (mixed $expression )

Evaluates a PHP expression in the context of this control.

Input
mixed | $expression
Output
mixed | the expression result
Exception
throws | TInvalidOperationException if the expression is invalid

evaluateStatements

                                public string evaluateStatements
                                (string $statements )

Evaluates a list of PHP statements.

Input
string | $statements | PHP statements
Output
string | content echoed or printed by the PHP statements
Exception
throws | TInvalidOperationException if the statements are invalid

getEventHandlers

                                public TList getEventHandlers
                                (mixed $name )

Returns the list of attached event handlers for an event.

Input
mixed | $name
Output
TList | list of attached event handlers for an event
Exception
throws | TInvalidOperationException if the event is not defined

getSubProperty

                                public mixed getSubProperty
                                (string $path )

Evaluates a property path.

A property path is a sequence of property names concatenated by '.' character.  For example, 'Parent.Page' refers to the 'Page' property of the component's  'Parent' property value (which should be a component also).

Input
string | $path | property path
Output
mixed | the property path value
Exception

hasEvent

                                public boolean hasEvent
                                (string $name )

Determines whether an event is defined.

An event is defined if the class has a method whose name is the event name prefixed with 'on'.  Note, event name is case-insensitive.

Input

string $name the event name

Output

Exception

hasEventHandler

                                public boolean hasEventHandler
                                (mixed $name )

Input
mixed | $name
Output
boolean | whether an event has been attached one or several handlers
Exception

hasProperty

                                public boolean hasProperty
                                (string $name )

Determines whether a property is defined.

A property is defined if there is a getter or setter method  defined in the class. Note, property names are case-insensitive.

Input
string | $name | the property name
Output
boolean | whether the property is defined
Exception

raiseEvent

                                public void raiseEvent
                                (string $name , mixed $sender , TEventParameter $param )

Raises an event.

This method represents the happening of an event and will  invoke all attached event handlers for the event.

Input
string | $name | the event name
mixed | $sender | the event sender object
TEventParameter | $param | the event parameter
Output
Exception
throws | TInvalidOperationException if the event is undefined
throws | TInvalidDataValueException If an event handler is invalid

setSubProperty

                                public void setSubProperty
                                (string $path , mixed $value )

Sets a value to a property path.

A property path is a sequence of property names concatenated by '.' character.  For example, 'Parent.Page' refers to the 'Page' property of the component's  'Parent' property value (which should be a component also).

Input
string | $path | property path
mixed | $value | the property path value
Output
Exception

__get

                                public mixed __get
                                (string $name )

Returns a property value or an event handler list by property or event name.

Do not call this method. This is a PHP magic method that we override  to allow using the following syntax to read a property:

1      $value=$component->PropertyName;
  and to obtain the event handler list for an event,

1      $eventHandlerList=$component->EventName;

Input
string | $name | the property name or the event name
Output
mixed | the property value or the event handler list
Exception
throws | TInvalidOperationException if the property/event is not defined.

__set

                                public void __set
                                (string $name , mixed $value )

Sets value of a component property.

Do not call this method. This is a PHP magic method that we override  to allow using the following syntax to set a property or attach an event handler.

1      $this->PropertyName=$value;
2      $this->EventName=$handler;

Input
string | $name | the property name or event name
mixed | $value | the property value or event handler
Output
Exception
throws | TInvalidOperationException If the property is not defined or read-only.


PRADO API Manual: Docs For Class TComponentReflection

Class TComponentReflection (Class Overview)

TComponent
   |
   --TComponentReflection

TComponentReflection class.

TComponentReflection provides functionalities to inspect the public/protected properties, events and methods defined in a class.

The following code displays the properties and events defined in TDataGrid,

1        $reflection=new TComponentReflection('TDataGrid');
2        Prado::varDump($reflection->getProperties());
3        Prado::varDump($reflection->getEvents());

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
protected string | determinePropertyType ( ReflectionMethod $method) Determines the property type.
string | getClassName ()
array | getEvents ()
array | getMethods ()
array | getProperties ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.

Throws: TInvalidDataTypeException if the object is not a component
Method Details

determinePropertyType

protected string determinePropertyType (ReflectionMethod $method )

Determines the property type.

This method uses the doc comment to determine the property type.

Input
ReflectionMethod | $method
Output
string | the property type, '{unknown}' if type cannot be determined from comment
Exception

getClassName

public string getClassName ()

Output
string class name of the component
Exception

getEvents

public array getEvents ()

Output
array list of component events. Array keys are event names. Each array element is of the following structure: [protected]=>whether the event is protected or not [class]=>the class where the event is inherited from. [comments]=>comments associated with the event.
Exception

getMethods

public array getMethods ()

Output
array list of public/protected methods. Array keys are method names. Each array element is of the following structure: [protected]=>whether the method is protected or not [static]=>whether the method is static or not [class]=>the class where the property is inherited from, [comments]=>comments associated with the event.
Exception

getProperties

public array getProperties ()

Output
array list of component properties. Array keys are property names. Each array element is of the following structure: [type]=>property type, [readonly]=>whether the property is read-only, [protected]=>whether the method is protected or not [class]=>the class where the property is inherited from, [comments]=>comments associated with the property.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TEnumerable

Class TEnumerable (Class Overview)

Direct Known Sub-classes:

                                    TActiveRecordInvalidFinderResult
                                                , TSqlMapCacheTypes
                                                , TDbColumnCaseMode
                                                , TDbNullConversionMode
                                                , TSecurityManagerValidationMode
                                                , TUserManagerPasswordMode
                                                , TApplicationMode
                                                , THttpRequestUrlFormat
                                                , THttpSessionCookieMode
                                                , TDraggableConstraint
                                                , TValidatorDisplayStyle
                                                , TValidationDataType
                                                , TBulletStyle
                                                , TBulletedListDisplayMode
                                                , TButtonType
                                                , TTextAlign
                                                , TColorPickerMode
                                                , TValidationCompareOperator
                                                , TListItemType
                                                , TDataGridPagerMode
                                                , TDataGridPagerButtonType
                                                , TDataGridPagerPosition
                                                , TButtonColumnType
                                                , TDatePickerInputMode
                                                , TDatePickerMode
                                                , TDatePickerPositionMode
                                                , THotSpotMode
                                                , TInlineFrameAlign
                                                , TInlineFrameScrollBars
                                                , TListSelectionMode
                                                , TPagerMode
                                                , TPagerButtonType
                                                , TContentDirection
                                                , TScrollBars
                                                , TRepeatDirection
                                                , TRepeatLayout
                                                , TSliderDirection
                                                , TDisplayStyle
                                                , THorizontalAlign
                                                , TVerticalAlign
                                                , TTableGridLines
                                                , TTableCaptionAlign
                                                , TTableHeaderScope
                                                , TTableRowSection
                                                , TTextBoxMode
                                                , TTextBoxAutoCompleteType
                                                , TTextHighlighterLineNumberStyle
                                                , TValidationSummaryDisplayMode
                                                , TValidationSummaryDisplayStyle
                                                , TWizardNavigationButtonType
                                                , TWizardStepType

TEnumerable class.

TEnumerable is the base class for all enumerable types.  To define an enumerable type, extend TEnumberable and define string constants.  Each constant represents an enumerable value.  The constant name must be the same as the constant value.  For example,

1      class TTextAlign extends TEnumerable
2      {
3          const Left='Left';
4          const Right='Right';
5      }
  Then, one can use the enumerable values such as TTextAlign::Left and  TTextAlign::Right.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TEventParameter

Class TEventParameter (Class Overview)

TComponent
   |
   --TEventParameter

Direct Known Sub-classes:

TPagedListPageChangedEventParameter , TPagedListFetchDataEventParameter , TActiveRecordChangeEventParameter , TDataGatewayEventParameter , TDataGatewayResultEventParameter , TCallbackEventParameter , TDropContainerEventParameter , TBroadcastEventParameter , TCommandEventParameter , TBulletedListEventParameter , TServerValidateEventParameter , TDataGridItemEventParameter , TDataGridPagerEventParameter , TDataGridSortCommandEventParameter , TDataGridPageChangedEventParameter , TDataListItemEventParameter , TImageClickEventParameter , TImageMapEventParameter , TOutputCacheCheckDependencyEventParameter , TOutputCacheCalculateKeyEventParameter , TPagerPageChangedEventParameter , TRepeaterItemEventParameter , TWizardNavigationEventParameter

TEventParameter class.

TEventParameter is the base class for all event parameter classes.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()


PRADO API Manual: Docs For Class TPropertyValue

Class TPropertyValue (Class Overview)

TPropertyValue class

TPropertyValue is a utility class that provides static methods  to convert component property values to specific types.
TPropertyValue is commonly used in component setter methods to ensure  the new property value is of specific type.  For example, a boolean-typed property setter method would be as follows,

1      function setPropertyName($value) {
2          $value=TPropertyValue::ensureBoolean($value);
3          // $value is now of boolean type
4      }
Properties can be of the following types with specific type conversion rules:
  • string: a boolean value will be converted to 'true' or 'false'.
  • boolean: string 'true' (case-insensitive) will be converted to true,
            string 'false' (case-insensitive) will be converted to false.
  • integer
  • float
  • array: string starting with '(' and ending with ')' will be considered as
          as an array expression and will be evaluated. Otherwise, an array
          with the value to be ensured is returned.
  • object
  • enum: enumerable type, represented by an array of strings.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
array | ensureArray ( mixed $value) Converts a value to array type. If the value is a string and it is
boolean | ensureBoolean ( mixed $value) Converts a value to boolean type.
string | ensureEnum ( mixed $value, mixed $enums) Converts a value to enum type.
float | ensureFloat ( mixed $value) Converts a value to float type.
integer | ensureInteger ( mixed $value) Converts a value to integer type.
object | ensureObject ( mixed $value) Converts a value to object type.
string | ensureString ( mixed $value) Converts a value to string type.

            Method Details

ensureArray

                                public array ensureArray
                                (mixed $value )

Converts a value to array type. If the value is a string and it is

in the form (a,b,c) then an array consisting of each of the elements  will be returned. If the value is a string and it is not in this form  then an array consisting of just the string will be returned. If the value  is not a string then

Input

mixed $value the value to be converted.

Output

Exception

ensureBoolean

                                public boolean ensureBoolean
                                (mixed $value )

Converts a value to boolean type.

Note, string 'true' (case-insensitive) will be converted to true,  string 'false' (case-insensitive) will be converted to false.  If a string represents a non-zero number, it will be treated as true.

Input

mixed $value the value to be converted.

Output

Exception

ensureEnum

                                public string ensureEnum
                                (mixed $value , mixed $enums )

Converts a value to enum type.

This method checks if the value is of the specified enumerable type.  A value is a valid enumerable value if it is equal to the name of a constant  in the specified enumerable type (class).  For more details about enumerable, see TEnumerable.
For backward compatibility, this method also supports sanity  check of a string value to see if it is among the given list of strings.

Input
mixed | $value | the value to be converted.
mixed | $enums | class name of the enumerable type, or array of valid enumeration values. If this is not an array, the method considers its parameters are of variable length, and the second till the last parameters are enumeration values.
Output
string | the valid enumeration value
Exception
throws | TInvalidDataValueException if the original value is not in the string array.

ensureFloat

                                public float ensureFloat
                                (mixed $value )

Converts a value to float type.

Input

mixed $value the value to be converted.

Output

Exception

ensureInteger

                                public integer ensureInteger
                                (mixed $value )

Converts a value to integer type.

Input

mixed $value the value to be converted.

Output

Exception

ensureObject

                                public object ensureObject
                                (mixed $value )

Converts a value to object type.

Input

mixed $value the value to be converted.

Output

Exception

ensureString

                                public string ensureString
                                (mixed $value )

Converts a value to string type.

Note, a boolean value will be converted to 'true' if it is true  and 'false' if it is false.

Input

mixed $value the value to be converted.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TModule

Class TModule (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule

Direct Known Sub-classes:

TCache , TDataSourceConfig , TErrorHandler , TGlobalization , TAuthManager , TDbUserManager , TSecurityManager , TUserManager , TApplicationStatePersister , TLogRouter , TParameterModule , TAssetManager , THttpResponse , TUrlManager , TTemplateManager , TThemeManager

TModule class.

TModule implements the basic methods required by IModule and may be used as the basic class for application modules.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
string | getID ()
void | init ( TXmlElement $config) Initializes the module.
void | setID ( string $value)
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getID

public string getID ()

Output
string id of this module
Exception

init

public void init (TXmlElement $config )

Initializes the module.

This method is required by IModule and is invoked by application.

Input
TXmlElement $config module configuration
Output
Exception

setID

public void setID (string $value )

Input
string $value id of this module
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TService

Class TService (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TService

Direct Known Sub-classes:

TFeedService , TJsonService , TPageService , TSoapService

TService class.

TService implements the basic methods required by IService and may be used as the basic class for application services.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
boolean | getEnabled ()
string | getID ()
void | init ( TXmlElement $config) Initializes the service and attaches run to the RunService event of application.
void | run () Runs the service.
void | setEnabled ( boolean $value)
void | setID ( string $value)
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getEnabled

public boolean getEnabled ()

Output
boolean whether the service is enabled
Exception

getID

public string getID ()

Output
string id of this service
Exception

init

public void init (TXmlElement $config )

Initializes the service and attaches run to the RunService event of application.

This method is required by IService and is invoked by application.

Input
TXmlElement $config module configuration
Output
Exception

run

public void run ()

Runs the service.

Output
Exception

setEnabled

public void setEnabled (boolean $value )

Input
boolean $value whether the service is enabled
Output
Exception

setID

public void setID (string $value )

Input
string $value id of this service
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TShellApplication

Class TShellApplication (Class Overview)

TComponent
   |
   --TApplication
      |
      --TShellApplication

TShellApplication class.

TShellApplication is the base class for developing command-line PRADO tools that share the same configurations as their Web application counterparts.

A typical usage of TShellApplication in a command-line PHP script is as follows:

1      require_once('path/to/prado.php');
2      $application=new TShellApplication('path/to/application.xml');
3      $application->run();
3      // perform command-line tasks here

Since the application instance has access to all configurations, including path aliases, modules and parameters, the command-line script has nearly the same accessibility to resources as the PRADO Web applications.

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TApplication
CONFIGCACHE_FILE, CONFIG_FILE, CONFIG_FILE_EXT, GLOBAL_FILE, PAGE_SERVICE_ID, RUNTIME_PATH, STATE_DEBUG, STATE_NORMAL, STATE_OFF, STATE_PERFORMANCE,
Method Summary
void | run () Runs the application.
void | startService ( mixed $serviceID) Override parent implementation. TShellApplication doesn't need to start any service
Methods Inherited From TApplication
TApplication::applyConfiguration(), TApplication::clearGlobalState(), TApplication::completeRequest(), TApplication::flushOutput(), TApplication::getApplicationStatePersister(), TApplication::getAssetManager(), TApplication::getAuthorizationRules(), TApplication::getBasePath(), TApplication::getCache(), TApplication::getConfigurationFile(), TApplication::getErrorHandler(), TApplication::getGlobalization(), TApplication::getGlobalState(), TApplication::getID(), TApplication::getMode(), TApplication::getModule(), TApplication::getModules(), TApplication::getPageServiceID(), TApplication::getParameters(), TApplication::getRequest(), TApplication::getRequestCompleted(), TApplication::getResponse(), TApplication::getRuntimePath(), TApplication::getSecurityManager(), TApplication::getService(), TApplication::getSession(), TApplication::getUniqueID(), TApplication::getUser(), TApplication::initApplication(), TApplication::loadGlobals(), TApplication::onAuthentication(), TApplication::onAuthenticationComplete(), TApplication::onAuthorization(), TApplication::onAuthorizationComplete(), TApplication::onBeginRequest(), TApplication::onEndRequest(), TApplication::onError(), TApplication::onLoadState(), TApplication::onLoadStateComplete(), TApplication::onPreFlushOutput(), TApplication::onPreRunService(), TApplication::onSaveState(), TApplication::onSaveStateComplete(), TApplication::resolvePaths(), TApplication::run(), TApplication::runService(), TApplication::saveGlobals(), TApplication::setApplicationStatePersister(), TApplication::setAssetManager(), TApplication::setBasePath(), TApplication::setCache(), TApplication::setConfigurationFile(), TApplication::setErrorHandler(), TApplication::setGlobalization(), TApplication::setGlobalState(), TApplication::setID(), TApplication::setMode(), TApplication::setModule(), TApplication::setPageServiceID(), TApplication::setRequest(), TApplication::setResponse(), TApplication::setRuntimePath(), TApplication::setSecurityManager(), TApplication::setService(), TApplication::setSession(), TApplication::setUser(), TApplication::startService()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

run

public void run ()

Runs the application.

This method overrides the parent implementation by initializing application with configurations specified when it is created.

Output
Exception

startService

public void startService (mixed $serviceID )

Override parent implementation. TShellApplication doesn't need to start any service

Input
mixed $serviceID
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IUserManager

Interface IUserManager (Class Overview)

IUserManager interface

IUserManager specifies the interface that must be implemented by  a user manager class if it is to be used together with TAuthManager  and TUser.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
string | getGuestName ()
TUser | getUser ( string $username) Returns a user instance given the user name.
TUser | getUserFromCookie ( THttpCookie $cookie) Returns a user instance according to auth data stored in a cookie.
void | saveUserToCookie ( THttpCookie $cookie) Saves user auth data into a cookie.
boolean | validateUser ( string $username, string $password) Validates if the username and password are correct.

            Method Details

getGuestName

                                public string getGuestName
                                ()

Output

                                    string
                 name for a guest user.

Exception

getUser

                                public TUser getUser
                                (string $username )

Returns a user instance given the user name.

Input
string | $username | user name, null if it is a guest.
Output
TUser | the user instance, null if the specified username is not in the user database.
Exception

getUserFromCookie

                                public TUser getUserFromCookie
                                (THttpCookie $cookie )

Returns a user instance according to auth data stored in a cookie.

Input
THttpCookie | $cookie | the cookie storing user authentication information
Output
TUser | the user instance generated based on the cookie auth data, null if the cookie does not have valid auth data.
Exception

saveUserToCookie

                                public void saveUserToCookie
                                (THttpCookie $cookie )

Saves user auth data into a cookie.

Input

THttpCookie $cookie the cookie to receive the user auth data.

Output

Exception

validateUser

                                public boolean validateUser
                                (string $username , string $password )

Validates if the username and password are correct.

Input
string | $username | user name
string | $password | password
Output
boolean | true if validation is successful, false otherwise.
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TAuthManager

Class TAuthManager (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TAuthManager

TAuthManager class

TAuthManager performs user authentication and authorization for a Prado application. TAuthManager works together with a IUserManager module that can be specified via the UserManager property. If an authorization fails, TAuthManager will try to redirect the client browser to a login page that is specified via the LoginPage. To login or logout a user, call login or logout, respectively.

The AuthExpire property can be used to define the time in seconds after which the authentication should expire. AllowAutoLogin specifies if the login information should be stored in a cookie to perform automatic login. Enabling this feature will cause that AuthExpire has no effect since the user will be logged in again on authentication expiration.

To load TAuthManager, configure it in application configuration as follows, <module id="auth" class="System.Security.TAuthManager" UserManager="users" LoginPage="login" /> <module id="users" class="System.Security.TUserManager" />

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | doAuthentication ( mixed $sender, mixed $param) Performs authentication.
void | doAuthorization ( mixed $sender, mixed $param) Performs authorization.
protected string | generateUserKey ()
boolean | getAllowAutoLogin ()
integer | getAuthExpire ()
string | getLoginPage ()
string | getReturnUrl ()
string | getReturnUrlVarName ()
string | getUserKey ()
IUserManager | getUserManager ()
void | init ( TXmlElement $config) Initializes this module.
void | leave ( mixed $sender, mixed $param) Performs login redirect if authorization fails.
boolean | login ( string $username, string $password, integer $expire) Logs in a user with username and password.
void | logout () Logs out a user.
void | onAuthenticate ( mixed $param) Performs the real authentication work.
void | onAuthExpire ( mixed $param) Performs user logout on authentication expiration.
void | onAuthorize ( mixed $param) Performs the real authorization work.
void | setAllowAutoLogin ( boolean $value)
void | setAuthExpire ( integer $value)
void | setLoginPage ( string $pagePath) Sets the login page that the client browser will be redirected to if login is needed.
void | setReturnUrl ( string $value) Sets the URL that the browser should be redirected to when login succeeds.
void | setReturnUrlVarName ( string $value)
void | setUserManager ( string|IUserManager $provider)
boolean | switchUser ( string $username) Switches to a new user.
void | updateSessionUser ( IUser $user) Updates the user data stored in session.
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string RETURN_URL_VAR GET variable name for return url
Method Details

doAuthentication

public void doAuthentication (mixed $sender , mixed $param )

Performs authentication.

This is the event handler attached to application's Authentication event. Do not call this method directly.

Input
mixed | $sender | sender of the Authentication event
mixed | $param | event parameter
Output
Exception

doAuthorization

public void doAuthorization (mixed $sender , mixed $param )

Performs authorization.

This is the event handler attached to application's Authorization event. Do not call this method directly.

Input
mixed | $sender | sender of the Authorization event
mixed | $param | event parameter
Output
Exception

generateUserKey

protected string generateUserKey ()

Output
string a key used to store user information in session
Exception

getAllowAutoLogin

public boolean getAllowAutoLogin ()

Output
boolean whether to allow remembering login so that the user logs on automatically next time. Defaults to false.
Exception

getAuthExpire

public integer getAuthExpire ()

Output
integer authentication expiration time in seconds. Defaults to zero (no expiration).
Exception

getLoginPage

public string getLoginPage ()

Output
string path of login page should login is required
Exception

getReturnUrl

public string getReturnUrl ()

Output
string URL that the browser should be redirected to when login succeeds.
Exception

getReturnUrlVarName

public string getReturnUrlVarName ()

Output
string the name of the session variable storing return URL. It defaults to 'AppID:ReturnUrl'
Exception

getUserKey

public string getUserKey ()

Output
string a unique variable name for storing user session/cookie data
Exception

getUserManager

public IUserManager getUserManager ()

Output
IUserManager user manager instance
Exception

init

public void init (TXmlElement $config )

Initializes this module.

This method is required by the IModule interface.

Input
TXmlElement | $config | configuration for this module, can be null
Output
Exception
throws | TConfigurationException if user manager does not exist or is not IUserManager

leave

public void leave (mixed $sender , mixed $param )

Performs login redirect if authorization fails.

This is the event handler attached to application's EndRequest event. Do not call this method directly.

Input
mixed | $sender | sender of the event
mixed | $param | event parameter
Output
Exception

login

public boolean login (string $username , string $password , integer $expire )

Logs in a user with username and password.

The username and password will be used to validate if login is successful. If yes, a user object will be created for the application.

Input
string | $username | username
string | $password | password
integer | $expire | number of seconds that automatic login will remain effective. If 0, it means user logs out when session ends. This parameter is added since 3.1.1.
Output
boolean | if login is successful
Exception

logout

public void logout ()

Logs out a user.

User session will be destroyed after this method is called.

Output
Exception
throws TConfigurationException if session module is not loaded.

onAuthenticate

public void onAuthenticate (mixed $param )

Performs the real authentication work.

An OnAuthenticate event will be raised if there is any handler attached to it. If the application already has a non-null user, it will return without further authentication. Otherwise, user information will be restored from session data.

Input
mixed | $param | parameter to be passed to OnAuthenticate event
Output
Exception
throws | TConfigurationException if session module does not exist.

onAuthExpire

public void onAuthExpire (mixed $param )

Performs user logout on authentication expiration.

An 'OnAuthExpire' event will be raised if there is any handler attached to it.

Input
mixed $param parameter to be passed to OnAuthExpire event.
Output
Exception

onAuthorize

public void onAuthorize (mixed $param )

Performs the real authorization work.

Authorization rules obtained from the application will be used to check if a user is allowed. If authorization fails, the response status code will be set as 401 and the application terminates.

Input
mixed $param parameter to be passed to OnAuthorize event
Output
Exception

setAllowAutoLogin

public void setAllowAutoLogin (boolean $value )

Input
boolean $value whether to allow remembering login so that the user logs on automatically next time. Users have to enable cookie to make use of this feature.
Output
Exception

setAuthExpire

public void setAuthExpire (integer $value )

Input
integer $value authentication expiration time in seconds. Defaults to zero (no expiration).
Output
Exception

setLoginPage

public void setLoginPage (string $pagePath )

Sets the login page that the client browser will be redirected to if login is needed.

Login page should be specified in the format of page path.

Input
string $pagePath path of login page should login is required
Output
Exception

setReturnUrl

public void setReturnUrl (string $value )

Sets the URL that the browser should be redirected to when login succeeds.

Input
string $value the URL to be redirected to.
Output
Exception

setReturnUrlVarName

public void setReturnUrlVarName (string $value )

Input
string $value the name of the session variable storing return URL.
Output
Exception

setUserManager

public void setUserManager (string|IUserManager $provider )

Input
string|IUserManager | $provider | the user manager module ID or the user manager object
Output
Exception
throws | TInvalidOperationException if the module has been initialized or the user manager object is not IUserManager

switchUser

public boolean switchUser (string $username )

Switches to a new user.

This method will logout the current user first and login with a new one (without password.)

Input
string | $username | the new username
Output
boolean | if the switch is successful
Exception

updateSessionUser

public void updateSessionUser (IUser $user )

Updates the user data stored in session.

Input
IUser | $user | user object
Output
Exception
throws | new TConfigurationException if session module is not loaded.
Constant Details

RETURN_URL_VAR

GET variable name for return url

Type:

string

Value:

'ReturnUrl'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TAuthorizationRule

Class TAuthorizationRule (Class Overview)

TComponent
   |
   --TAuthorizationRule

TAuthorizationRule class

TAuthorizationRule represents a single authorization rule. A rule is specified by an action (required), a list of users (optional), a list of roles (optional), a verb (optional), and a list of IP rules (optional). Action can be either 'allow' or 'deny'. Guest (anonymous, unauthenticated) users are represented by question mark '?'. All users (including guest users) are represented by asterisk '*'. Authenticated users are represented by '@'. Users/roles are case-insensitive. Different users/roles are separated by comma ','. Verb can be either 'get' or 'post'. If it is absent, it means both. IP rules are separated by comma ',' and can contain wild card in the rules (e.g. '192.132.23.33, 192.122.*.*')

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
string | getAction ()
boolean | getAuthenticatedApplied ()
boolean | getEveryoneApplied ()
boolean | getGuestApplied ()
array | getIPRules ()
array | getRoles ()
array | getUsers ()
string | getVerb ()
integer | isUserAllowed ( IUser $user, string $verb, string $ip)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getAction

public string getAction ()

Output
string action, either 'allow' or 'deny'
Exception

getAuthenticatedApplied

public boolean getAuthenticatedApplied ()

Output
boolean if this rule applies to authenticated users
Exception

getEveryoneApplied

public boolean getEveryoneApplied ()

Output
boolean if this rule applies to everyone
Exception

getGuestApplied

public boolean getGuestApplied ()

Output
boolean if this rule applies to everyone
Exception

getIPRules

public array getIPRules ()

Output
array list of IP rules.
Exception

getRoles

public array getRoles ()

Output
array list of roles
Exception

getUsers

public array getUsers ()

Output
array list of user IDs
Exception

getVerb

public string getVerb ()

Output
string verb, may be empty, 'get', or 'post'.
Exception

isUserAllowed

public integer isUserAllowed (IUser $user , string $verb , string $ip )

Input
IUser | $user | the user object
string | $verb | the request verb (GET, PUT)
string | $ip | the request IP address
Output
integer | 1 if the user is allowed, -1 if the user is denied, 0 if the rule does not apply to the user
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TAuthorizationRuleCollection

Class TAuthorizationRuleCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TAuthorizationRuleCollection

TAuthorizationRuleCollection class.

TAuthorizationRuleCollection represents a collection of authorization rules TAuthorizationRule. To check if a user is allowed, call isUserAllowed.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | insertAt ( integer $index, mixed $item) Inserts an item at the specified position.
boolean | isUserAllowed ( IUser $user, string $verb, string $ip)
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by performing additional operations for each newly added TAuthorizationRule object.

Input
integer | $index | the specified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is not a TAuthorizationRule object.

isUserAllowed

public boolean isUserAllowed (IUser $user , string $verb , string $ip )

Input
IUser | $user | the user to be authorized
string | $verb | verb, can be empty, 'post' or 'get'.
string | $ip | the request IP address
Output
boolean | whether the user is allowed
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbUser

Class TDbUser (Class Overview)

TComponent
   |
   --TUser
      |
      --TDbUser

TDbUser class

TDbUser is the base user class for using together with TDbUserManager. Two methods are declared and must be implemented in the descendant classes:

  • validateUser(): validates if username and password are correct entries.
  • createUser(): creates a new user instance given the username

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
abstract TDbUser | createUser ( string $username) Creates a new user instance given the username.
TDbUser | createUserFromCookie ( THttpCookie $cookie) Creates a new user instance given the cookie containing auth data.
TDbConnection | getDbConnection () Returns a database connection that may be used to retrieve data from database.
void | saveUserToCookie ( THttpCookie $cookie) Saves necessary auth data into a cookie.
abstract boolean | validateUser ( string $username, string $password) Validates if username and password are correct entries.
Methods Inherited From TUser
TUser::getIsGuest(), TUser::getManager(), TUser::getName(), TUser::getRoles(), TUser::getState(), TUser::getStateChanged(), TUser::isInRole(), TUser::loadFromString(), TUser::saveToString(), TUser::setIsGuest(), TUser::setName(), TUser::setRoles(), TUser::setState(), TUser::setStateChanged()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createUser

public abstract TDbUser createUser (string $username )

Creates a new user instance given the username.

This method usually needs to retrieve necessary user information (e.g. role, name, rank, etc.) from the user database according to the specified username. The newly created user instance should be initialized with these information.

If the username is invalid (not found in the user database), null should be returned.

You may use DbConnection to deal with database.

Input
string | $username | username (case-sensitive)
Output
TDbUser | the newly created and initialized user instance
Exception

createUserFromCookie

public TDbUser createUserFromCookie (THttpCookie $cookie )

Creates a new user instance given the cookie containing auth data.

This method is invoked when TAuthManager::setAllowAutoLogin is set true. The default implementation simply returns null, meaning no user instance can be created from the given cookie.

If you want to support automatic login (remember login), you should override this method. Typically, you obtain the username and a unique token from the cookie's value. You then verify the token is valid and use the username to create a user instance.

Input
THttpCookie | $cookie | the cookie storing user authentication information
Output
TDbUser | the user instance generated based on the cookie auth data, null if the cookie does not have valid auth data.
Exception

getDbConnection

public TDbConnection getDbConnection ()

Returns a database connection that may be used to retrieve data from database.

Output
TDbConnection database connection that may be used to retrieve data from database
Exception

saveUserToCookie

public void saveUserToCookie (THttpCookie $cookie )

Saves necessary auth data into a cookie.

This method is invoked when TAuthManager::rememberLogin is invoked. The default implementation does nothing, meaning auth data is not stored in the cookie (and thus automatic login is not supported.)

If you want to support automatic login (remember login), you should override this method. Typically, you generate a unique token according to the current login information and save it together with the username in the cookie's value. You should avoid revealing the password in the generated token.

Input
THttpCookie $cookie the cookie to store the user auth information
Output
Exception

validateUser

public abstract boolean validateUser (string $username , string $password )

Validates if username and password are correct entries.

Usually, this is accomplished by checking if the user database contains this (username, password) pair. You may use DbConnection to deal with database.

Input
string | $username | username (case-sensitive)
string | $password | password
Output
boolean | whether the validation succeeds
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbUserManager

Class TDbUserManager (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TDbUserManager

TDbUserManager class

TDbUserManager manages user accounts that are stored in a database. TDbUserManager is mainly designed to be used together with TAuthManager which manages how users are authenticated and authorized in a Prado application.

To use TDbUserManager together with TAuthManager, configure them in the application configuration like following:

1      <module id="db"
2          class="System.Data.TDataSourceConfig" ..../>
3      <module id="users"
4          class="System.Security.TDbUserManager"
5          UserClass="Path.To.MyUserClass"
6          ConnectionID="db" />
7      <module id="auth"
8          class="System.Security.TAuthManager"
9          UserManager="users" LoginPage="Path.To.LoginPage" />

In the above, UserClass specifies what class will be used to create user instance. The class must extend from TDbUser. ConnectionID refers to the ID of a TDataSourceConfig module which specifies how to establish database connection to retrieve user information.

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected TDbConnection | createDbConnection ( string $connectionID) Creates the DB connection.
string | getConnectionID ()
TDbConnection | getDbConnection ()
string | getGuestName ()
TUser | getUser ( string $username) Returns a user instance given the user name.
string | getUserClass ()
TDbUser | getUserFromCookie ( THttpCookie $cookie) Returns a user instance according to auth data stored in a cookie.
void | init ( TXmlElement $config) Initializes the module.
void | saveUserToCookie ( THttpCookie $cookie) Saves user auth data into a cookie.
void | setConnectionID ( string $value) Sets the ID of a TDataSourceConfig module.
void | setGuestName ( string $value)
void | setUserClass ( string $value)
boolean | validateUser ( string $username, string $password) Validates if the username and password are correct.
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createDbConnection

protected TDbConnection createDbConnection (string $connectionID )

Creates the DB connection.

Input
string | $connectionID | the module ID for TDataSourceConfig
Output
TDbConnection | the created DB connection
Exception
throws | TConfigurationException if module ID is invalid or empty

getConnectionID

public string getConnectionID ()

Output
string the ID of a TDataSourceConfig module. Defaults to empty string, meaning not set.
Exception

getDbConnection

public TDbConnection getDbConnection ()

Output
TDbConnection the database connection that may be used to retrieve user data.
Exception

getGuestName

public string getGuestName ()

Output
string guest name, defaults to 'Guest'
Exception

getUser

public TUser getUser (string $username )

Returns a user instance given the user name.

Input
string | $username | user name, null if it is a guest.
Output
TUser | the user instance, null if the specified username is not in the user database.
Exception

getUserClass

public string getUserClass ()

Output
string the user class name in namespace format. Defaults to empty string, meaning not set.
Exception

getUserFromCookie

public TDbUser getUserFromCookie (THttpCookie $cookie )

Returns a user instance according to auth data stored in a cookie.

Input
THttpCookie | $cookie | the cookie storing user authentication information
Output
TDbUser | the user instance generated based on the cookie auth data, null if the cookie does not have valid auth data.
Exception

init

public void init (TXmlElement $config )

Initializes the module.

This method is required by IModule and is invoked by application.

Input
TXmlElement $config module configuration
Output
Exception

saveUserToCookie

public void saveUserToCookie (THttpCookie $cookie )

Saves user auth data into a cookie.

Input
THttpCookie $cookie the cookie to receive the user auth data.
Output
Exception

setConnectionID

public void setConnectionID (string $value )

Sets the ID of a TDataSourceConfig module.

The datasource module will be used to establish the DB connection that will be used by the user manager.

Input
string $value module ID.
Output
Exception

setGuestName

public void setGuestName (string $value )

Input
string $value name to be used for guest users.
Output
Exception

setUserClass

public void setUserClass (string $value )

Input
string $value the user class name in namespace format. The user class must extend from TDbUser.
Output
Exception

validateUser

public boolean validateUser (string $username , string $password )

Validates if the username and password are correct.

Input
string | $username | user name
string | $password | password
Output
boolean | true if validation is successful, false otherwise.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSecurityManager

Class TSecurityManager (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TSecurityManager

TSecurityManager class

TSecurityManager provides private keys, hashing and encryption functionalities that may be used by other PRADO components, such as viewstate persister, cookies.

TSecurityManager is mainly used to protect data from being tampered and viewed. It can generate HMAC and encrypt the data. The private key used to generate HMAC is set by ValidationKey. The key used to encrypt data is specified by EncryptionKey. If the above keys are not explicitly set, random keys will be generated and used.

To prefix data with an HMAC, call hashData(). To validate if data is tampered, call validateData(), which will return the real data if it is not tampered. The algorithm used to generated HMAC is specified by Validation.

To encrypt and decrypt data, call encrypt() and decrypt() respectively. The encryption algorithm can be set by Encryption.

Note, to use encryption, the PHP Mcrypt extension must be loaded.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected string | computeHMAC ( string $data) Computes the HMAC for the data with getValidationKey.
string | decrypt ( string $data) Decrypts data with getEncryptionKey.
string | encrypt ( string $data) Encrypts data with getEncryptionKey.
protected void | generateRandomKey () Generates a random key.
string | getEncryption ()
string | getEncryptionKey ()
TSecurityManagerValidationMode | getValidation ()
string | getValidationKey ()
string | hashData ( string $data) Prefixes data with an HMAC.
void | init ( TXmlElement $config) Initializes the module.
void | setEncryption ( mixed $value)
void | setEncryptionKey ( string $value)
void | setValidation ( TSecurityManagerValidationMode $value)
void | setValidationKey ( string $value)
string | validateData ( string $data) Validates if data is tampered.
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | STATE_ENCRYPTION_KEY
string | STATE_VALIDATION_KEY
Method Details

computeHMAC

protected string computeHMAC (string $data )

Computes the HMAC for the data with getValidationKey.

Input
string | $data | data to be generated HMAC
Output
string | the HMAC for the data
Exception

decrypt

public string decrypt (string $data )

Decrypts data with getEncryptionKey.

Input
string | $data | data to be decrypted.
Output
string | the decrypted data
Exception
throws | TNotSupportedException if PHP Mcrypt extension is not loaded

encrypt

public string encrypt (string $data )

Encrypts data with getEncryptionKey.

Input
string | $data | data to be encrypted.
Output
string | the encrypted data
Exception
throws | TNotSupportedException if PHP Mcrypt extension is not loaded

generateRandomKey

protected void generateRandomKey ()

Generates a random key.

Output
Exception

getEncryption

public string getEncryption ()

Output
string the algorithm used to encrypt/decrypt data. Defaults to '3DES'.
Exception

getEncryptionKey

public string getEncryptionKey ()

Output
string the private key used to encrypt/decrypt data. If the key is not explicitly set, a random one is generated and returned.
Exception

getValidation

public TSecurityManagerValidationMode getValidation ()

Output
TSecurityManagerValidationMode hashing algorithm used to generate HMAC. Defaults to TSecurityManagerValidationMode::SHA1.
Exception

getValidationKey

public string getValidationKey ()

Output
string the private key used to generate HMAC. If the key is not explicitly set, a random one is generated and returned.
Exception

hashData

public string hashData (string $data )

Prefixes data with an HMAC.

Input
string | $data | data to be hashed.
Output
string | data prefixed with HMAC
Exception

init

public void init (TXmlElement $config )

Initializes the module.

The security module is registered with the application.

Input
TXmlElement $config initial module configuration
Output
Exception

setEncryption

public void setEncryption (mixed $value )

Input
mixed | $value
Output
Exception
throws | TNotSupportedException Do not call this method presently.

setEncryptionKey

public void setEncryptionKey (string $value )

Input
string | $value | the key used to encrypt/decrypt data.
Output
Exception
throws | TInvalidDataValueException if the key is empty

setValidation

public void setValidation (TSecurityManagerValidationMode $value )

Input
TSecurityManagerValidationMode $value hashing algorithm used to generate HMAC.
Output
Exception

setValidationKey

public void setValidationKey (string $value )

Input
string | $value | the key used to generate HMAC
Output
Exception
throws | TInvalidDataValueException if the key is empty

validateData

public string validateData (string $data )

Validates if data is tampered.

Input
string | $data | data to be validated. The data must be previously generated using hashData().
Output
string | the real data with HMAC stripped off. False if the data is tampered.
Exception
Constant Details

STATE_ENCRYPTION_KEY

Type:

string

Value:

'prado:securitymanager:encryptionkey'

STATE_VALIDATION_KEY

Type:

string

Value:

'prado:securitymanager:validationkey'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSecurityManagerValidationMode

Class TSecurityManagerValidationMode (Class Overview)

TEnumerable
   |
   --TSecurityManagerValidationMode

TSecurityManagerValidationMode class.

TSecurityManagerValidationMode defines the enumerable type for the possible validation modes that can be used by TSecurityManager.

The following enumerable values are defined:

  • MD5: an MD5 hash is generated from the data and used for validation.
  • SHA1: an SHA1 hash is generated from the data and used for validation.

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | MD5
string | SHA1
Constant Details

MD5

Type:

string

Value:

'MD5'

SHA1

Type:

string

Value:

'SHA1'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TUser

Class TUser (Class Overview)

TComponent
   |
   --TUser

Direct Known Sub-classes:

TDbUser

TUser class

TUser implements basic user functionality for a Prado application. To get the name of the user, use Name property. The property IsGuest tells if the user a guest/anonymous user. To obtain or test the roles that the user is in, use property Roles and call isInRole(), respectively.

TUser is meant to be used together with IUserManager.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
boolean | getIsGuest ()
IUserManager | getManager ()
string | getName ()
array | getRoles ()
protected mixed | getState ( string $key, mixed $defaultValue) Returns the value of a variable that is stored in user session.
boolean | getStateChanged ()
boolean | isInRole ( string $role)
IUser | loadFromString ( string $data)
string | saveToString ()
void | setIsGuest ( boolean $value)
void | setName ( string $value)
array|string | setRoles ( mixed $value)
protected void | setState ( string $key, mixed $value, mixed $defaultValue) Stores a variable in user session.
void | setStateChanged ( boolean $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getIsGuest

public boolean getIsGuest ()

Output
boolean if the user is a guest, defaults to true.
Exception

getManager

public IUserManager getManager ()

Output
IUserManager user manager
Exception

getName

public string getName ()

Output
string username, defaults to empty string.
Exception

getRoles

public array getRoles ()

Output
array list of roles that the user is of
Exception

getState

protected mixed getState (string $key , mixed $defaultValue )

Returns the value of a variable that is stored in user session.

This function is designed to be used by TUser descendant classes who want to store additional user information in user session. A variable, if stored in user session using setState can be retrieved back using this function.

Input
string | $key | variable name
mixed | $defaultValue | default value
Output
mixed | the value of the variable. If it doesn't exist, the provided default value will be returned
Exception

getStateChanged

public boolean getStateChanged ()

Output
boolean whether user session state is changed (i.e., setState() is called)
Exception

isInRole

public boolean isInRole (string $role )

Input
string | $role | role to be tested. Note, role is case-insensitive.
Output
boolean | whether the user is of this role
Exception

loadFromString

public IUser loadFromString (string $data )

Input
string | $data | user data that is serialized and restored from session
Output
IUser | the user object
Exception

saveToString

public string saveToString ()

Output
string user data that is serialized and will be stored in session
Exception

setIsGuest

public void setIsGuest (boolean $value )

Input
boolean $value if the user is a guest
Output
Exception

setName

public void setName (string $value )

Input
string $value username
Output
Exception

setRoles

public array|string setRoles (mixed $value )

Input
mixed | $value
Output
array|string | list of roles that the user is of. If it is a string, roles are assumed by separated by comma
Exception

setState

protected void setState (string $key , mixed $value , mixed $defaultValue )

Stores a variable in user session.

This function is designed to be used by TUser descendant classes who want to store additional user information in user session. By storing a variable using this function, the variable may be retrieved back later using getState. The variable will be persistent across page requests during a user session.

Input
string | $key | variable name
mixed | $value | variable value
mixed | $defaultValue | default value. If $value===$defaultValue, the variable will be removed from persistent storage.
Output
Exception

setStateChanged

public void setStateChanged (boolean $value )

Input
boolean $value whether user session state is changed
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TUserManager

Class TUserManager (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TUserManager

TUserManager class

TUserManager manages a static list of users TUser. The user information is specified via module configuration using the following XML syntax,

1      <module id="users" class="System.Security.TUserManager" PasswordMode="Clear">
2        <user name="Joe" password="demo" />
3        <user name="John" password="demo" />
4        <role name="Administrator" users="John" />
5        <role name="Writer" users="Joe,John" />
6      </module>

In addition, user information can also be loaded from an external file specified by UserFile property. Note, the property only accepts a file path in namespace format. The user file format is similar to the above sample.

The user passwords may be specified as clear text, SH1 or MD5 hashed by setting PasswordMode as Clear, SHA1 or MD5. The default name for a guest user is Guest. It may be changed by setting GuestName property.

TUserManager may be used together with TAuthManager which manages how users are authenticated and authorized in a Prado application.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
string | getGuestName ()
TUserManagerPasswordMode | getPasswordMode ()
array | getRoles () Returns an array of user role information.
TUser | getUser ( string $username) Returns a user instance given the user name.
string | getUserFile ()
TUser | getUserFromCookie ( THttpCookie $cookie) Returns a user instance according to auth data stored in a cookie.
array | getUsers () Returns an array of all users.
void | init ( TXmlElement $config) Initializes the module.
protected void | loadUserData ( TXmlElement $xmlNode) Loads user/role information from an XML node.
void | saveUserToCookie ( THttpCookie $cookie) Saves user auth data into a cookie.
void | setGuestName ( string $value)
void | setPasswordMode ( TUserManagerPasswordMode $value)
void | setUserFile ( string $value)
void | switchToGuest ( TUser $user) Sets a user as a guest.
boolean | validateUser ( string $username, string $password) Validates if the username and password are correct.
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string USER_FILE_EXT extension name to the user file
Method Details

getGuestName

public string getGuestName ()

Output
string guest name, defaults to 'Guest'
Exception

getPasswordMode

public TUserManagerPasswordMode getPasswordMode ()

Output
TUserManagerPasswordMode how password is stored, clear text, or MD5 or SHA1 hashed. Default to TUserManagerPasswordMode::MD5.
Exception

getRoles

public array getRoles ()

Returns an array of user role information.

Each array element represents the roles for a single user. The array key is the username in lower case, and the array value is the roles (represented as an array) that the user is in.

Output
array list of user role information
Exception

getUser

public TUser getUser (string $username )

Returns a user instance given the user name.

Input
string | $username | user name, null if it is a guest.
Output
TUser | the user instance, null if the specified username is not in the user database.
Exception

getUserFile

public string getUserFile ()

Output
string the full path to the file storing user/role information
Exception

getUserFromCookie

public TUser getUserFromCookie (THttpCookie $cookie )

Returns a user instance according to auth data stored in a cookie.

Input
THttpCookie | $cookie | the cookie storing user authentication information
Output
TUser | the user instance generated based on the cookie auth data, null if the cookie does not have valid auth data.
Exception

getUsers

public array getUsers ()

Returns an array of all users.

Each array element represents a single user. The array key is the username in lower case, and the array value is the corresponding user password.

Output
array list of users
Exception

init

public void init (TXmlElement $config )

Initializes the module.

This method is required by IModule and is invoked by application. It loads user/role information from the module configuration.

Input
TXmlElement $config module configuration
Output
Exception

loadUserData

protected void loadUserData (TXmlElement $xmlNode )

Loads user/role information from an XML node.

Input
TXmlElement $xmlNode the XML node containing the user information
Output
Exception

saveUserToCookie

public void saveUserToCookie (THttpCookie $cookie )

Saves user auth data into a cookie.

Input
THttpCookie $cookie the cookie to receive the user auth data.
Output
Exception

setGuestName

public void setGuestName (string $value )

Input
string $value name to be used for guest users.
Output
Exception

setPasswordMode

public void setPasswordMode (TUserManagerPasswordMode $value )

Input
TUserManagerPasswordMode $value how password is stored, clear text, or MD5 or SHA1 hashed.
Output
Exception

setUserFile

public void setUserFile (string $value )

Input
string | $value | user/role data file path (in namespace form). The file format is XML whose content is similar to that user/role block in application configuration.
Output
Exception
throws | TInvalidOperationException if the module is already initialized
throws | TConfigurationException if the file is not in proper namespace format

switchToGuest

public void switchToGuest (TUser $user )

Sets a user as a guest.

User name is changed as guest name, and roles are emptied.

Input
TUser $user the user to be changed to a guest.
Output
Exception

validateUser

public boolean validateUser (string $username , string $password )

Validates if the username and password are correct.

Input
string | $username | user name
string | $password | password
Output
boolean | true if validation is successful, false otherwise.
Exception
Constant Details

USER_FILE_EXT

extension name to the user file

Type:

string

Value:

'.xml'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TUserManagerPasswordMode

Class TUserManagerPasswordMode (Class Overview)

TEnumerable
   |
   --TUserManagerPasswordMode

TUserManagerPasswordMode class.

TUserManagerPasswordMode defines the enumerable type for the possible modes that user passwords can be specified for a TUserManager.

The following enumerable values are defined:

  • Clear: the password is in plain text
  • MD5: the password is recorded as the MD5 hash value of the original password
  • SHA1: the password is recorded as the SHA1 hash value of the original password

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Clear
string | MD5
string | SHA1
Constant Details

Clear

Type:

string

Value:

'Clear'

MD5

Type:

string

Value:

'MD5'

SHA1

Type:

string

Value:

'SHA1'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveButton

Class TActiveButton (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TButton
               |
               --TActiveButton

TActiveButton is the active control counter part to TButton.

When a TActiveButton is clicked, rather than a normal post back request a callback request is initiated.

The OnCallback event is raised during a callback request and it is raise after the OnClick event.

When the TBaseActiveCallbackControl::setEnableUpdate property is true, changing the Text property during callback request will update the button's caption upon callback response completion.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gamil[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected void | addAttributesToRender ( mixed $writer) Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
TBaseActiveCallbackControl | getActiveControl ()
protected string | getClientClassName ()
TCallbackClientSide | getClientSide ()
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by
protected void | renderClientControlScript ( mixed $writer) Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
void | setText ( string $value) Updates the button text on the client-side if the setEnableUpdate property is set to true.
Methods Inherited From TButton
TButton::addAttributesToRender(), TButton::canCauseValidation(), TButton::getButtonType(), TButton::getCausesValidation(), TButton::getClientClassName(), TButton::getCommandName(), TButton::getCommandParameter(), TButton::getData(), TButton::getEnableClientScript(), TButton::getIsDefaultButton(), TButton::getPostBackOptions(), TButton::getTagName(), TButton::getText(), TButton::getValidationGroup(), TButton::needPostBackScript(), TButton::onClick(), TButton::onCommand(), TButton::raisePostBackEvent(), TButton::renderClientControlScript(), TButton::renderContents(), TButton::setButtonType(), TButton::setCausesValidation(), TButton::setCommandName(), TButton::setCommandParameter(), TButton::setData(), TButton::setEnableClientScript(), TButton::setIsDefaultButton(), TButton::setText(), TButton::setValidationGroup()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

addAttributesToRender

protected void addAttributesToRender (mixed $writer )

Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

Input
mixed $writer
Output
Exception

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getClientClassName

protected string getClientClassName ()

Output
string corresponding javascript class name for this TActiveButton.
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by

ICallbackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick event first and then the OnCallback event. This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

Input
mixed $writer
Output
Exception

setText

public void setText (string $value )

Updates the button text on the client-side if the setEnableUpdate property is set to true.

Input
string $value caption of the button
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveCheckBox

Class TActiveCheckBox (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TCheckBox
               |
               --TActiveCheckBox

TActiveCheckBox class.

The active control counter part to checkbox. The AutoPostBack property is set to true by default. Thus, when the checkbox is clicked a OnCallback event is raise after OnCheckedChanged event.

The Text and Checked properties can be changed during a callback.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
TBaseActiveCallbackControl | getActiveControl ()
protected string | getClientClassName ()
TCallbackClientSide | getClientSide ()
protected string | getDefaultLabelID ()
TMap | getLabelAttributes () Overrides parent implementation to ensure label has ID.
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by ICallbackEventHandler interface.
protected void | renderClientControlScript ( mixed $writer) Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
protected void | renderInputTag ( THtmlWriter $writer, string $clientID, string $onclick) Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
protected void | renderLabel ( THtmlWriter $writer, string $clientID, string $text) Renders a label beside the checkbox.
void | setChecked ( boolean $value) Sets a value indicating whether the checkbox is to be checked or not.
void | setText ( string $value) Updates the button text on the client-side if the setEnableUpdate property is set to true.
Methods Inherited From TCheckBox
TCheckBox::getAutoPostBack(), TCheckBox::getCausesValidation(), TCheckBox::getChecked(), TCheckBox::getClientClassName(), TCheckBox::getData(), TCheckBox::getDataChanged(), TCheckBox::getEnableClientScript(), TCheckBox::getInputAttributes(), TCheckBox::getIsValid(), TCheckBox::getLabelAttributes(), TCheckBox::getPostBackOptions(), TCheckBox::getSpanNeeded(), TCheckBox::getSurroundingTagID(), TCheckBox::getTagName(), TCheckBox::getText(), TCheckBox::getTextAlign(), TCheckBox::getValidationGroup(), TCheckBox::getValidationPropertyValue(), TCheckBox::getValue(), TCheckBox::getValueAttribute(), TCheckBox::loadPostData(), TCheckBox::onCheckedChanged(), TCheckBox::onPreRender(), TCheckBox::raisePostDataChangedEvent(), TCheckBox::render(), TCheckBox::renderClientControlScript(), TCheckBox::renderInputTag(), TCheckBox::renderLabel(), TCheckBox::setAutoPostBack(), TCheckBox::setCausesValidation(), TCheckBox::setChecked(), TCheckBox::setData(), TCheckBox::setEnableClientScript(), TCheckBox::setIsValid(), TCheckBox::setText(), TCheckBox::setTextAlign(), TCheckBox::setValidationGroup(), TCheckBox::setValue()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getClientClassName

protected string getClientClassName ()

Output
string corresponding javascript class name for this TActiveCheckBox.
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

getDefaultLabelID

protected string getDefaultLabelID ()

Output
string checkbox label ID;
Exception

getLabelAttributes

public TMap getLabelAttributes ()

Overrides parent implementation to ensure label has ID.

Output
TMap list of attributes to be rendered for label beside the checkbox
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by ICallbackEventHandler interface.

This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

Input
mixed $writer
Output
Exception

renderInputTag

protected void renderInputTag (THtmlWriter $writer , string $clientID , string $onclick )

Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

Since 3.1.4, the javascript code is not rendered if AutoPostBack is false

Input
THtmlWriter | $writer | the writer for the rendering purpose
string | $clientID | checkbox id
string | $onclick | onclick js
Output
Exception

renderLabel

protected void renderLabel (THtmlWriter $writer , string $clientID , string $text )

Renders a label beside the checkbox.

Input
THtmlWriter | $writer | the writer for the rendering purpose
string | $clientID | checkbox id
string | $text | label text
Output
Exception

setChecked

public void setChecked (boolean $value )

Sets a value indicating whether the checkbox is to be checked or not.

Updates checkbox checked state on the client-side if the setEnableUpdate property is set to true.

Input
boolean $value whether the checkbox is to be checked or not.
Output
Exception

setText

public void setText (string $value )

Updates the button text on the client-side if the setEnableUpdate property is set to true.

Input
string $value caption of the button
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveCheckBoxList

Class TActiveCheckBoxList (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TCheckBoxList
                     |
                     --TActiveCheckBoxList

TActiveCheckBoxList class.

The active control counter part to checkbox list control. The AutoPostBack property is set to true by default. Thus, when a checkbox is clicked a OnCallback event is raised after OnSelectedIndexChanged event.

With ActiveControl.EnabledUpdate set to true (default is true), changes to the selection will be updated on the client side.

List items can not be changed dynamically during a callback request.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected TControl | createRepeatedControl () Creates a control used for repetition (used as a template).
TBaseActiveCallbackControl | getActiveControl ()
TCallbackClientSide | getClientSide ()
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by ICallbackEventHandler interface.
protected void | renderClientControlScript ( mixed $writer) Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
Methods Inherited From TCheckBoxList
TCheckBoxList::createRepeatedControl(), TCheckBoxList::createStyle(), TCheckBoxList::findControl(), TCheckBoxList::generateItemStyle(), TCheckBoxList::getCellPadding(), TCheckBoxList::getCellSpacing(), TCheckBoxList::getClientClassName(), TCheckBoxList::getDataChanged(), TCheckBoxList::getHasFooter(), TCheckBoxList::getHasHeader(), TCheckBoxList::getHasSeparators(), TCheckBoxList::getIsMultiSelect(), TCheckBoxList::getIsValid(), TCheckBoxList::getPostBackOptions(), TCheckBoxList::getRepeatColumns(), TCheckBoxList::getRepeatDirection(), TCheckBoxList::getRepeatInfo(), TCheckBoxList::getRepeatLayout(), TCheckBoxList::getSpanNeeded(), TCheckBoxList::getTextAlign(), TCheckBoxList::getValidationPropertyValue(), TCheckBoxList::loadPostData(), TCheckBoxList::onPreRender(), TCheckBoxList::raisePostDataChangedEvent(), TCheckBoxList::render(), TCheckBoxList::renderItem(), TCheckBoxList::setCellPadding(), TCheckBoxList::setCellSpacing(), TCheckBoxList::setEnabled(), TCheckBoxList::setIsValid(), TCheckBoxList::setRepeatColumns(), TCheckBoxList::setRepeatDirection(), TCheckBoxList::setRepeatLayout(), TCheckBoxList::setTextAlign()
Methods Inherited From TListControl
TListControl::addAttributesToRender(), TListControl::addParsedObject(), TListControl::clearSelection(), TListControl::createListItemCollection(), TListControl::formatDataValue(), TListControl::getAppendDataBoundItems(), TListControl::getAutoPostBack(), TListControl::getCausesValidation(), TListControl::getClientClassName(), TListControl::getData(), TListControl::getDataGroupField(), TListControl::getDataTextField(), TListControl::getDataTextFormatString(), TListControl::getDataValueField(), TListControl::getEnableClientScript(), TListControl::getHasItems(), TListControl::getIsMultiSelect(), TListControl::getItemCount(), TListControl::getItems(), TListControl::getPostBackOptions(), TListControl::getPromptText(), TListControl::getPromptValue(), TListControl::getSelectedIndex(), TListControl::getSelectedIndices(), TListControl::getSelectedItem(), TListControl::getSelectedValue(), TListControl::getSelectedValues(), TListControl::getTagName(), TListControl::getText(), TListControl::getValidationGroup(), TListControl::loadState(), TListControl::onSelectedIndexChanged(), TListControl::onTextChanged(), TListControl::performDataBinding(), TListControl::renderClientControlScript(), TListControl::renderContents(), TListControl::renderPrompt(), TListControl::saveState(), TListControl::setAppendDataBoundItems(), TListControl::setAutoPostBack(), TListControl::setCausesValidation(), TListControl::setData(), TListControl::setDataGroupField(), TListControl::setDataTextField(), TListControl::setDataTextFormatString(), TListControl::setDataValueField(), TListControl::setEnableClientScript(), TListControl::setPromptText(), TListControl::setPromptValue(), TListControl::setSelectedIndex(), TListControl::setSelectedIndices(), TListControl::setSelectedValue(), TListControl::setSelectedValues(), TListControl::setText(), TListControl::setValidationGroup()
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

createRepeatedControl

protected TControl createRepeatedControl ()

Creates a control used for repetition (used as a template).

Output
TControl the control to be repeated
Exception

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by ICallbackEventHandler interface.

This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

Input
mixed $writer
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveControlAdapter

Class TActiveControlAdapter (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControlAdapter
         |
         --TActiveControlAdapter

Direct Known Sub-classes:

TActiveListControlAdapter

TActiveControlAdapter class.

Customize the parent TControl class for active control classes. TActiveControlAdapter instantiates a common base active control class throught the BaseActiveControl property. The type of BaseActiveControl can be provided in the second parameter in the constructor. Default is TBaseActiveControl or TBaseActiveCallbackControl if the control adapted implements ICallbackEventHandler.

TActiveControlAdapter will tracking viewstate changes to update the corresponding client-side properties.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
TBaseActiveControl | getBaseActiveControl ()
protected boolean | getIsTrackingPageState ()
TCallbackPageStateTracker | getStateTracker ()
void | onLoad ( mixed $param) Starts viewstate tracking if necessary after when controls has been loaded
void | render ( mixed $writer) Renders the callback client scripts.
protected void | renderCallbackClientScripts () Register the callback clientscripts and sets the post loader IDs.
void | saveState () Saves additional persistent control state. Respond to viewstate changes if necessary.
void | setBaseActiveControl ( TBaseActiveControl $control)
protected void | setBaseControlClass ( string $type)
Methods Inherited From TControlAdapter
TControlAdapter::createChildControls(), TControlAdapter::getControl(), TControlAdapter::getPage(), TControlAdapter::loadState(), TControlAdapter::onInit(), TControlAdapter::onLoad(), TControlAdapter::onPreRender(), TControlAdapter::onUnload(), TControlAdapter::render(), TControlAdapter::renderChildren(), TControlAdapter::saveState()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getBaseActiveControl

public TBaseActiveControl getBaseActiveControl ()

Output
TBaseActiveControl Common active control options.
Exception

getIsTrackingPageState

protected boolean getIsTrackingPageState ()

Output
boolean true if the viewstate needs to be tracked.
Exception

getStateTracker

public TCallbackPageStateTracker getStateTracker ()

Output
TCallbackPageStateTracker state tracker.
Exception

onLoad

public void onLoad (mixed $param )

Starts viewstate tracking if necessary after when controls has been loaded

Input
mixed $param
Output
Exception

render

public void render (mixed $writer )

Renders the callback client scripts.

Input
mixed $writer
Output
Exception

renderCallbackClientScripts

protected void renderCallbackClientScripts ()

Register the callback clientscripts and sets the post loader IDs.

Output
Exception

saveState

public void saveState ()

Saves additional persistent control state. Respond to viewstate changes if necessary.

Output
Exception

setBaseActiveControl

public void setBaseActiveControl (TBaseActiveControl $control )

Input
TBaseActiveControl $control change base active control
Output
Exception

setBaseControlClass

protected void setBaseControlClass (string $type )

Input
string $type base active control instance
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCallbackPageStateTracker

Class TCallbackPageStateTracker (Class Overview)

TCallbackPageStateTracker class.

Tracking changes to the page state during callback.

            Since:
            3.1

            Author:
            Wei Zhuo <weizhuo[at]gmail[dot]com>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Constructor. Add a set of default states to track.

Method Summary
protected void | addStatesToTrack () Add a list of view states to track. Each state is added to the StatesToTrack property with the view state name as key.
protected TCallbackClientScript | client ()
protected array | getChanges ()
protected TMap | getStatesToTrack ()
void | respondToChanges () For each of the changes call the corresponding change handlers.
void | trackChanges () Start tracking view state changes. The clone function on objects are called for those viewstate having an object as value.
protected void | updateAccessKey ( string $value) Updates the modifier access key
protected void | updateAttributes ( array $attributes) Updates/adds a list of attributes on the control.
protected void | updateEnabled ( boolean $enable) Enables or Disables the control on the client-side.
protected void | updateStyle ( array $style) Updates the CSS style on the control on the client-side.
protected void | updateTabIndex ( integer $value) Updates the tab index.
protected void | updateToolTip ( string $value) Updates the tooltip.
protected void | updateVisible ( boolean $visible) Hides or shows the control on the client-side. The control must be already rendered on the client-side.

                    Constructor Details

__construct

                                public __construct
                                Array

Constructor. Add a set of default states to track.

            Method Details

addStatesToTrack

                                protected void addStatesToTrack
                                ()

Add a list of view states to track. Each state is added  to the StatesToTrack property with the view state name as key.

The value should be an array with two enteries. The first entery  is the name of the class that will calculate the state differences.  The second entry is a php function/method callback that handles  the changes in the viewstate.

Output

Exception

client

                                protected TCallbackClientScript client
                                ()

Output

                                    TCallbackClientScript
                 callback client scripting

Exception

getChanges

                                protected array getChanges
                                ()

Output

                                    array
                 list of viewstate and the changed data.

Exception

getStatesToTrack

                                protected TMap getStatesToTrack
                                ()

Output

                                    TMap
                 list of viewstates to track.

Exception

respondToChanges

                                public void respondToChanges
                                ()

For each of the changes call the corresponding change handlers.

Output

Exception

trackChanges

                                public void trackChanges
                                ()

Start tracking view state changes. The clone function on objects are called  for those viewstate having an object as value.

Output

Exception

updateAccessKey

                                protected void updateAccessKey
                                (string $value )

Updates the modifier access key

Input

string $value access key

Output

Exception

updateAttributes

                                protected void updateAttributes
                                (array $attributes )

Updates/adds a list of attributes on the control.

Input

array $attributes list of attribute name-value pairs.

Output

Exception

updateEnabled

                                protected void updateEnabled
                                (boolean $enable )

Enables or Disables the control on the client-side.

Input

boolean $enable true to enable the control, false to disable.

Output

Exception

updateStyle

                                protected void updateStyle
                                (array $style )

Updates the CSS style on the control on the client-side.

Input

array $style list of new CSS style declarations.

Output

Exception

updateTabIndex

                                protected void updateTabIndex
                                (integer $value )

Updates the tab index.

Input

integer $value tab index

Output

Exception

updateToolTip

                                protected void updateToolTip
                                (string $value )

Updates the tooltip.

Input

string $value new tooltip

Output

Exception

updateVisible

                                protected void updateVisible
                                (boolean $visible )

Hides or shows the control on the client-side. The control must be  already rendered on the client-side.

Input

boolean $visible true to show the control, false to hide.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMapCollectionDiff

Class TMapCollectionDiff (Class Overview)

TViewStateDiff
   |
   --TMapCollectionDiff

TAttributesDiff class.

Calculate the changes to attributes collection.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
array
getDifference ()
Methods Inherited From TViewStateDiff
Method Details

getDifference

public array getDifference ()

Output
array updates to the attributes collection.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TScalarDiff

Class TScalarDiff (Class Overview)

TViewStateDiff
   |
   --TScalarDiff

TScalarDiff class.

Calculate the changes to a scalar value.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
mixed
getDifference ()
Methods Inherited From TViewStateDiff
Method Details

getDifference

public mixed getDifference ()

Output
mixed update viewstate value.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TStyleDiff

Class TStyleDiff (Class Overview)

TViewStateDiff
   |
   --TStyleDiff

TStyleDiff class.

Calculates the changes to the Style properties.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
protected array | getCombinedStyle ( TStyle $obj)
protected string | getCssClassDiff ()
array | getDifference ()
protected array | getStyleDiff ()
protected void | getStyleFromString ( string $string, array 1)
Methods Inherited From TViewStateDiff
Method Details

getCombinedStyle

protected array getCombinedStyle (TStyle $obj )

Input
TStyle | $obj | control style
Output
array | all the style properties combined.
Exception

getCssClassDiff

protected string getCssClassDiff ()

Output
string changes to the CSS class name.
Exception

getDifference

public array getDifference ()

Output
array list of changes to the control style and CSS class name.
Exception

getStyleDiff

protected array getStyleDiff ()

Output
array list of changes to the control style.
Exception

getStyleFromString

protected void getStyleFromString (string $string , array 1 )

Input
string | $string | CSS custom style string.
array | 1 | CSS style as name-value array.
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TViewStateDiff

Class TViewStateDiff (Class Overview)

Direct Known Sub-classes:

                                    TScalarDiff
                                                , TStyleDiff
                                                , TMapCollectionDiff

Calculates the viewstate changes during the request.

            Since:
            3.1

            Author:
            Wei Zhuo <weizhuo[at]gmail[dot]com>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Constructor.

            Method Summary

                                                    abstract

                        mixed

                            getDifference
                        ()

                    Constructor Details

__construct

                                public __construct
                                Array

Constructor.

            Method Details

getDifference

                                public abstract mixed getDifference
                                ()

Output

                                    mixed
                 view state changes, nullObject if no difference.

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveCustomValidator

Class TActiveCustomValidator (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TCustomValidator
                     |
                     --TActiveCustomValidator

TActiveCustomValidator Class

Performs custom validation using only server-side onServerValidate validation event. The client-side uses callbacks to raise the onServerValidate event.

Beware that the onServerValidate may be raised when the control to validate on the client side changes value, that is, the server validation may be called many times.

After the callback or postback, the onServerValidate is raised once more. The IsCallback property will be true when validation is made during a callback request.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected void | addAttributesToRender ( mixed $writer) Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
TBaseActiveCallbackControl | getActiveControl ()
protected string | getClientClassName ()
protected array | getClientScriptOptions () Returns an array of javascript validator options.
TCallbackClientSide | getClientSide ()
boolean | getIsCallback ()
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by ICallbackEventHandler interface. The onServerValidate event is raised first and then the onCallback event.
void | setClientValidationFunction ( mixed $value) Client validation function is NOT supported.
void | setErrorMessage ( string $value) Sets the text for the error message. Updates client-side erorr message.
Methods Inherited From TCustomValidator
TCustomValidator::evaluateIsValid(), TCustomValidator::getClientClassName(), TCustomValidator::getClientScriptOptions(), TCustomValidator::getClientValidationFunction(), TCustomValidator::getValidationTarget(), TCustomValidator::onServerValidate(), TCustomValidator::registerClientScriptValidator(), TCustomValidator::setClientValidationFunction()
Methods Inherited From TBaseValidator
TBaseValidator::addAttributesToRender(), TBaseValidator::createClientSide(), TBaseValidator::getClientScriptOptions(), TBaseValidator::getClientSide(), TBaseValidator::getControlCssClass(), TBaseValidator::getControlToValidate(), TBaseValidator::getDisplay(), TBaseValidator::getEnableClientScript(), TBaseValidator::getErrorMessage(), TBaseValidator::getFocusElementID(), TBaseValidator::getFocusOnError(), TBaseValidator::getIsValid(), TBaseValidator::getValidationGroup(), TBaseValidator::getValidationTarget(), TBaseValidator::getValidationValue(), TBaseValidator::onInit(), TBaseValidator::onPreRender(), TBaseValidator::onUnload(), TBaseValidator::onValidate(), TBaseValidator::onValidationError(), TBaseValidator::onValidationSuccess(), TBaseValidator::registerClientScriptValidator(), TBaseValidator::renderClientControlScript(), TBaseValidator::renderContents(), TBaseValidator::setControlCssClass(), TBaseValidator::setControlToValidate(), TBaseValidator::setDisplay(), TBaseValidator::setEnableClientScript(), TBaseValidator::setEnabled(), TBaseValidator::setErrorMessage(), TBaseValidator::setFocusElementID(), TBaseValidator::setFocusOnError(), TBaseValidator::setForControl(), TBaseValidator::setIsValid(), TBaseValidator::setValidationGroup(), TBaseValidator::updateControlCssClass(), TBaseValidator::validate()
Methods Inherited From TLabel
TLabel::addAttributesToRender(), TLabel::getData(), TLabel::getForControl(), TLabel::getTagName(), TLabel::getText(), TLabel::render(), TLabel::renderContents(), TLabel::setData(), TLabel::setForControl(), TLabel::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

addAttributesToRender

protected void addAttributesToRender (mixed $writer )

Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

Input
mixed $writer
Output
Exception

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getClientClassName

protected string getClientClassName ()

Output
string corresponding javascript class name for this this.
Exception

getClientScriptOptions

protected array getClientScriptOptions ()

Returns an array of javascript validator options.

Output
array javascript validator options.
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

getIsCallback

public boolean getIsCallback ()

Output
boolean true if validation is made during a callback request.
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by ICallbackEventHandler interface. The onServerValidate event is raised first and then the onCallback event.

This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

setClientValidationFunction

public void setClientValidationFunction (mixed $value )

Client validation function is NOT supported.

Input
mixed $value
Output
Exception

setErrorMessage

public void setErrorMessage (string $value )

Sets the text for the error message. Updates client-side erorr message.

Input
string $value the error message
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveCustomValidatorClientSide

Class TActiveCustomValidatorClientSide (Class Overview)

TComponent
   |
   --TClientSideOptions
      |
      --TCallbackClientSide
         |
         --TActiveCustomValidatorClientSide

Custom Validator callback client side options class.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
boolean | getObserveChanges ()
string | getOnValidate ()
string | getOnValidationError ()
string | getOnValidationSuccess ()
void | setObserveChanges ( boolean $value)
void | setOnValidate ( string $javascript) Client-side OnValidate validator event is raise before the validators validation functions are called.
void | setOnValidationError ( string $javascript) Client-side OnError event is raised after validation failure.
void | setOnValidationSuccess ( string $javascript) Client-side OnSuccess event is raise after validation is successfull.
Methods Inherited From TCallbackClientSide
TCallbackClientSide::ensureFunction(), TCallbackClientSide::getEnablePageStateUpdate(), TCallbackClientSide::getHasPriority(), TCallbackClientSide::getOnComplete(), TCallbackClientSide::getOnException(), TCallbackClientSide::getOnFailure(), TCallbackClientSide::getOnInteractive(), TCallbackClientSide::getOnLoaded(), TCallbackClientSide::getOnLoading(), TCallbackClientSide::getOnPreDispatch(), TCallbackClientSide::getOnSuccess(), TCallbackClientSide::getOnUninitialized(), TCallbackClientSide::getPostBackParameter(), TCallbackClientSide::getPostBackTarget(), TCallbackClientSide::getPostState(), TCallbackClientSide::getRequestTimeOut(), TCallbackClientSide::setEnablePageStateUpdate(), TCallbackClientSide::setHasPriority(), TCallbackClientSide::setOnComplete(), TCallbackClientSide::setOnException(), TCallbackClientSide::setOnFailure(), TCallbackClientSide::setOnInteractive(), TCallbackClientSide::setOnLoaded(), TCallbackClientSide::setOnLoading(), TCallbackClientSide::setOnPreDispatch(), TCallbackClientSide::setOnSuccess(), TCallbackClientSide::setOnUninitialized(), TCallbackClientSide::setPostBackParameter(), TCallbackClientSide::setPostBackTarget(), TCallbackClientSide::setPostState(), TCallbackClientSide::setRequestTimeOut()
Methods Inherited From TClientSideOptions
TClientSideOptions::ensureFunction(), TClientSideOptions::getOption(), TClientSideOptions::getOptions(), TClientSideOptions::setFunction(), TClientSideOptions::setOption()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getObserveChanges

public boolean getObserveChanges ()

Output
boolean true to observe changes.
Exception

getOnValidate

public string getOnValidate ()

Output
string javascript code for client-side OnValidate event.
Exception

getOnValidationError

public string getOnValidationError ()

Output
string javascript code for client-side OnError event.
Exception

getOnValidationSuccess

public string getOnValidationSuccess ()

Output
string javascript code for client-side OnSuccess event.
Exception

setObserveChanges

public void setObserveChanges (boolean $value )

Input
boolean $value true to revalidate when the control to validate changes value.
Output
Exception

setOnValidate

public void setOnValidate (string $javascript )

Client-side OnValidate validator event is raise before the validators validation functions are called.

Input
string $javascript javascript code for client-side OnValidate event.
Output
Exception

setOnValidationError

public void setOnValidationError (string $javascript )

Client-side OnError event is raised after validation failure.

This will override the default client-side validator behaviour.

Input
string $javascript javascript code for client-side OnError event.
Output
Exception

setOnValidationSuccess

public void setOnValidationSuccess (string $javascript )

Client-side OnSuccess event is raise after validation is successfull.

This will override the default client-side validator behaviour.

Input
string $javascript javascript code for client-side OnSuccess event.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveDatePicker

Class TActiveDatePicker (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --TDatePicker
                  |
                  --TActiveDatePicker

TActiveDatePicker class

The active control counter part to date picker control. When the date selection is changed, the OnCallback event is raised.

Since: 3.1.3
Author: Bradley Booms <Bradley.Booms@nsighttel.com>
Author: Christophe Boulain <Christophe.Boulain@gmail.com>
Constants Inherited From TDatePicker
SCRIPT_PATH,
Constants Inherited From TTextBox
DEFAULT_COLUMNS, DEFAULT_ROWS,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
TBaseActiveCallbackControl | getActiveControl ()
protected array | getDatePickerOptions () Get javascript date picker options.
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by ICallbackEventHandler interface.
protected void | registerCalendarClientScript () Registers the javascript code to initialize the date picker.
void | setText ( string $value) Client-side Text property can only be updated after the OnLoad stage.
Methods Inherited From TDatePicker
TDatePicker::addAttributesToRender(), TDatePicker::createClientScript(), TDatePicker::getAssetUrl(), TDatePicker::getButtonImageUrl(), TDatePicker::getButtonText(), TDatePicker::getCalendarStyle(), TDatePicker::getClientSide(), TDatePicker::getCulturalOptions(), TDatePicker::getCulture(), TDatePicker::getCurrentCulture(), TDatePicker::getData(), TDatePicker::getDate(), TDatePicker::getDateFormat(), TDatePicker::getDateFromPostData(), TDatePicker::getDatePickerButtonID(), TDatePicker::getDatePickerOptions(), TDatePicker::getDropDownDayOptions(), TDatePicker::getFirstDayOfWeek(), TDatePicker::getFromYear(), TDatePicker::getInputMode(), TDatePicker::getLocalizedCalendarInfo(), TDatePicker::getLocalizedMonthNames(), TDatePicker::getMode(), TDatePicker::getPositionMode(), TDatePicker::getShowCalendar(), TDatePicker::getTimeStamp(), TDatePicker::getTimeStampFromText(), TDatePicker::getUpToYear(), TDatePicker::getValidationPropertyValue(), TDatePicker::hasDayPattern(), TDatePicker::loadPostData(), TDatePicker::onPreRender(), TDatePicker::publishCalendarStyle(), TDatePicker::registerCalendarClientScript(), TDatePicker::render(), TDatePicker::renderButtonDatePicker(), TDatePicker::renderCalendarDayOptions(), TDatePicker::renderCalendarMonthOptions(), TDatePicker::renderCalendarSelections(), TDatePicker::renderCalendarYearOptions(), TDatePicker::renderDatePickerButtons(), TDatePicker::renderDropDownListCalendar(), TDatePicker::renderImageButtonDatePicker(), TDatePicker::setAutoPostBack(), TDatePicker::setButtonImageUrl(), TDatePicker::setButtonText(), TDatePicker::setCalendarStyle(), TDatePicker::setCulture(), TDatePicker::setData(), TDatePicker::setDate(), TDatePicker::setDateFormat(), TDatePicker::setFirstDayOfWeek(), TDatePicker::setFromYear(), TDatePicker::setInputMode(), TDatePicker::setMode(), TDatePicker::setPositionMode(), TDatePicker::setShowCalendar(), TDatePicker::setTimeStamp(), TDatePicker::setUpToYear()
Methods Inherited From TTextBox
TTextBox::addAttributesToRender(), TTextBox::getAutoCompleteType(), TTextBox::getAutoPostBack(), TTextBox::getAutoTrim(), TTextBox::getCausesValidation(), TTextBox::getClientClassName(), TTextBox::getColumns(), TTextBox::getData(), TTextBox::getDataChanged(), TTextBox::getEnableClientScript(), TTextBox::getIsValid(), TTextBox::getMaxLength(), TTextBox::getPersistPassword(), TTextBox::getPostBackOptions(), TTextBox::getReadOnly(), TTextBox::getRows(), TTextBox::getSafeText(), TTextBox::getSafeTextParser(), TTextBox::getTagName(), TTextBox::getText(), TTextBox::getTextMode(), TTextBox::getValidationGroup(), TTextBox::getValidationPropertyValue(), TTextBox::getWrap(), TTextBox::loadPostData(), TTextBox::onTextChanged(), TTextBox::raisePostDataChangedEvent(), TTextBox::renderBeginTag(), TTextBox::renderClientControlScript(), TTextBox::renderContents(), TTextBox::setAutoCompleteType(), TTextBox::setAutoPostBack(), TTextBox::setAutoTrim(), TTextBox::setCausesValidation(), TTextBox::setColumns(), TTextBox::setData(), TTextBox::setEnableClientScript(), TTextBox::setIsValid(), TTextBox::setMaxLength(), TTextBox::setPersistPassword(), TTextBox::setReadOnly(), TTextBox::setRows(), TTextBox::setText(), TTextBox::setTextMode(), TTextBox::setValidationGroup(), TTextBox::setWrap()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getDatePickerOptions

protected array getDatePickerOptions ()

Get javascript date picker options.

Output
array date picker client-side options
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by ICallbackEventHandler interface.

This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

registerCalendarClientScript

protected void registerCalendarClientScript ()

Registers the javascript code to initialize the date picker.

Output
Exception

setText

public void setText (string $value )

Client-side Text property can only be updated after the OnLoad stage.

Input
string $value text content for the textbox
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveDropDownList

Class TActiveDropDownList (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TDropDownList
                     |
                     --TActiveDropDownList

TActiveDropDownList class.

The active control counter part to drop down list control. The AutoPostBack property is set to true by default. Thus, when the drop down list selection is changed the OnCallback event is raised after OnSelectedIndexChanged event.

With ActiveControl.EnabledUpdate set to true (default is true), changes to the selection, after OnLoad event has been raised, will be updated. on the client side.

List items can be changed dynamically during a callback request.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected void | addAttributesToRender ( mixed $writer) Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
protected TActiveListItemCollection | createListItemCollection () Creates a collection object to hold list items. A specialized TActiveListItemCollection is created to allow the drop down list options to be added.
TBaseActiveCallbackControl | getActiveControl ()
protected null | getClientClassName () No client class for this control.
TCallbackClientSide | getClientSide ()
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | onPreRender ( mixed $param) Updates the client-side options if the item list has changed after the OnLoad event.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by ICallbackEventHandler interface.
protected void | renderClientControlScript ( mixed $writer) Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
Methods Inherited From TDropDownList
TDropDownList::addAttributesToRender(), TDropDownList::getClientClassName(), TDropDownList::getDataChanged(), TDropDownList::getIsValid(), TDropDownList::getValidationPropertyValue(), TDropDownList::loadPostData(), TDropDownList::raisePostDataChangedEvent(), TDropDownList::setIsValid(), TDropDownList::setSelectedIndices()
Methods Inherited From TListControl
TListControl::addAttributesToRender(), TListControl::addParsedObject(), TListControl::clearSelection(), TListControl::createListItemCollection(), TListControl::formatDataValue(), TListControl::getAppendDataBoundItems(), TListControl::getAutoPostBack(), TListControl::getCausesValidation(), TListControl::getClientClassName(), TListControl::getData(), TListControl::getDataGroupField(), TListControl::getDataTextField(), TListControl::getDataTextFormatString(), TListControl::getDataValueField(), TListControl::getEnableClientScript(), TListControl::getHasItems(), TListControl::getIsMultiSelect(), TListControl::getItemCount(), TListControl::getItems(), TListControl::getPostBackOptions(), TListControl::getPromptText(), TListControl::getPromptValue(), TListControl::getSelectedIndex(), TListControl::getSelectedIndices(), TListControl::getSelectedItem(), TListControl::getSelectedValue(), TListControl::getSelectedValues(), TListControl::getTagName(), TListControl::getText(), TListControl::getValidationGroup(), TListControl::loadState(), TListControl::onSelectedIndexChanged(), TListControl::onTextChanged(), TListControl::performDataBinding(), TListControl::renderClientControlScript(), TListControl::renderContents(), TListControl::renderPrompt(), TListControl::saveState(), TListControl::setAppendDataBoundItems(), TListControl::setAutoPostBack(), TListControl::setCausesValidation(), TListControl::setData(), TListControl::setDataGroupField(), TListControl::setDataTextField(), TListControl::setDataTextFormatString(), TListControl::setDataValueField(), TListControl::setEnableClientScript(), TListControl::setPromptText(), TListControl::setPromptValue(), TListControl::setSelectedIndex(), TListControl::setSelectedIndices(), TListControl::setSelectedValue(), TListControl::setSelectedValues(), TListControl::setText(), TListControl::setValidationGroup()
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

addAttributesToRender

protected void addAttributesToRender (mixed $writer )

Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

Input
mixed $writer
Output
Exception

createListItemCollection

protected TActiveListItemCollection createListItemCollection ()

Creates a collection object to hold list items. A specialized TActiveListItemCollection is created to allow the drop down list options to be added.

This method may be overriden to create a customized collection.

Output
TActiveListItemCollection the collection object
Exception

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getClientClassName

protected null getClientClassName ()

No client class for this control.

This method overrides the parent implementation.

Output
null no javascript class name.
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onPreRender

public void onPreRender (mixed $param )

Updates the client-side options if the item list has changed after the OnLoad event.

Input
mixed $param
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by ICallbackEventHandler interface.

This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

Input
mixed $writer
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveFileUpload

Class TActiveFileUpload (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TFileUpload
               |
               --TActiveFileUpload

TActiveFileUpload

TActiveFileUpload displays a file upload field on a page. Upon postback, the text entered into the field will be treated as the name of the file that will be uploaded to the server. The property HasFile indicates whether the file upload is successful. If successful, the file may be obtained by calling saveAs to save it at a specified place. You can use FileName, FileType, FileSize to get the original client-side file name, the file mime type, and the file size information. If the upload is not successful, ErrorCode contains the error code describing the cause of failure.

TActiveFileUpload raises OnFileUpload event if a file is uploaded (whether it succeeds or not).

TActiveFileUpload actually does a postback in a hidden IFrame, and then does a callback. This callback then raises the OnFileUpload event. After the postback a status icon is displayed; either a green checkmark if the upload is successful, or a red x if there was an error.

Author: Bradley Booms <Bradley.Booms@nsighttel.com>
Author: Christophe Boulain <Christophe.Boulain@gmail.com>
Constants Inherited From TFileUpload
MAX_FILE_SIZE,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
void | addAttributesToRender ( THtmlWriter $writer) Adds ID attribute, and renders the javascript for active component.
void | createChildControls ()
TBaseActiveCallbackControl | getActiveControl ()
protected string | getAssetUrl ( string $file)
boolean | getAutoPostBack ()
TImage | getBusyImage ()
string | getCallbackJavascript ()
protected string | getClientClassName ()
protected array | getClientOptions () Gets the client side options for this control.
TImage | getErrorImage ()
TImage | getSuccessImage ()
string | getTempPath ()
void | onFileUpload ( TEventParameter $param) This method is invoked when a file is uploaded.
void | onInit ( mixed $sender)
void | onPreRender ( mixed $param) Publish the javascript
void | onUnload ( mixed $param) Removes localfile on ending of the callback.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises OnFileUpload event.
boolean | saveAs ( string $fileName, boolean $deleteTempFile) Saves the uploaded file.
void | setAutoPostBack ( boolean $value)
void | setTempPath ( string $value)
Methods Inherited From TFileUpload
TFileUpload::addAttributesToRender(), TFileUpload::getDataChanged(), TFileUpload::getErrorCode(), TFileUpload::getFileName(), TFileUpload::getFileSize(), TFileUpload::getFileType(), TFileUpload::getHasFile(), TFileUpload::getIsValid(), TFileUpload::getLocalName(), TFileUpload::getMaxFileSize(), TFileUpload::getTagName(), TFileUpload::getValidationPropertyValue(), TFileUpload::loadPostData(), TFileUpload::onFileUpload(), TFileUpload::onPreRender(), TFileUpload::raisePostDataChangedEvent(), TFileUpload::saveAs(), TFileUpload::setIsValid(), TFileUpload::setMaxFileSize()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string SCRIPT_PATH
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

addAttributesToRender

public void addAttributesToRender (THtmlWriter $writer )

Adds ID attribute, and renders the javascript for active component.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

createChildControls

public void createChildControls ()

Output
Exception

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getAssetUrl

protected string getAssetUrl (string $file )

Input
string | $file | asset file in the self::SCRIPT_PATH directory.
Output
string | asset file url.
Exception

getAutoPostBack

public boolean getAutoPostBack ()

Output
boolean a value indicating whether an automatic callback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. Defaults to true. Note: When set to false, you will need to trigger the callback yourself.
Exception

getBusyImage

public TImage getBusyImage ()

Output
TImage the image displayed when an upload is in progress.
Exception

getCallbackJavascript

public string getCallbackJavascript ()

Output
string A chuck of javascript that will need to be called if {AutoPostBack is set to false}
Exception

getClientClassName

protected string getClientClassName ()

Output
string corresponding javascript class name for this control.
Exception

getClientOptions

protected array getClientOptions ()

Gets the client side options for this control.

Output
array ( inputID => input client ID, flagID => flag client ID, targetName => target unique ID, formID => form client ID, indicatorID => upload indicator client ID, completeID => complete client ID, errorID => error client ID)
Exception

getErrorImage

public TImage getErrorImage ()

Output
TImage the image displayed when an upload does not complete successfully.
Exception

getSuccessImage

public TImage getSuccessImage ()

Output
TImage the image displayed when an upload completes successfully.
Exception

getTempPath

public string getTempPath ()

Output
string the path where the uploaded file will be stored temporarily, in namespace format default "Application.runtime.*"
Exception

onFileUpload

public void onFileUpload (TEventParameter $param )

This method is invoked when a file is uploaded.

If you override this method, be sure to call the parent implementation to ensure the invocation of the attached event handlers.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onInit

public void onInit (mixed $sender )

Input
mixed | $sender
Output
Exception
throws | TInvalidDataValueException if the TempPath is not writable.

onPreRender

public void onPreRender (mixed $param )

Publish the javascript

Input
mixed $param
Output
Exception

onUnload

public void onUnload (mixed $param )

Removes localfile on ending of the callback.

Input
mixed $param
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises OnFileUpload event.

This method is required by ICallbackEventHandler interface. This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

saveAs

public boolean saveAs (string $fileName , boolean $deleteTempFile )

Saves the uploaded file.

Input
string | $fileName | the file name used to save the uploaded file
boolean | $deleteTempFile | whether to delete the temporary file after saving. If true, you will not be able to save the uploaded file again.
Output
boolean | true if the file saving is successful
Exception

setAutoPostBack

public void setAutoPostBack (boolean $value )

Input
boolean $value a value indicating whether an automatic callback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. Defaults to true. Note: When set to false, you will need to trigger the callback yourself.
Output
Exception

setTempPath

public void setTempPath (string $value )

Input
string $value the path where the uploaded file will be stored temporarily in namespace format default "Application.runtime.*"
Output
Exception

Constant Details

SCRIPT_PATH

Type:

string

Value:

'prado/activefileupload'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveHiddenField

Class TActiveHiddenField (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --THiddenField
            |
            --TActiveHiddenField

TActiveHiddenField class

TActiveHiddenField displays a hidden input field on a Web page. The value of the input field can be accessed via Value property.

Since: 3.1
Author: Carl G. Mathisen <carlgmathisen@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected void | addAttributesToRender ( mixed $writer) Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
TBaseActiveCallbackControl | getActiveControl ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
TCallbackClientSide | getClientSide ()
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by ICallbackEventHandler interface.
protected void | renderClientControlScript ( mixed $writer) Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
void | setValue ( string $value) Client-side Value property can only be updated after the OnLoad stage.
Methods Inherited From THiddenField
THiddenField::focus(), THiddenField::getData(), THiddenField::getDataChanged(), THiddenField::getEnableTheming(), THiddenField::getIsValid(), THiddenField::getTagName(), THiddenField::getValidationPropertyValue(), THiddenField::getValue(), THiddenField::loadPostData(), THiddenField::onValueChanged(), THiddenField::raisePostDataChangedEvent(), THiddenField::render(), THiddenField::setData(), THiddenField::setEnableTheming(), THiddenField::setIsValid(), THiddenField::setSkinID(), THiddenField::setValue()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

addAttributesToRender

protected void addAttributesToRender (mixed $writer )

Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

Input
mixed $writer
Output
Exception

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by ICallbackEventHandler interface.

This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

Input
mixed $writer
Output
Exception

setValue

public void setValue (string $value )

Client-side Value property can only be updated after the OnLoad stage.

Input
string $value text content for the hidden field
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveHyperLink

Class TActiveHyperLink (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --THyperLink
               |
               --TActiveHyperLink

TActiveHyperLink class.

The active control counterpart of THyperLink component. When TBaseActiveControl::setEnableUpdate property is true the during a callback request, setting Text property will also set the text of the label on the client upon callback completion. Similarly, for other properties such as ImageUrl, NavigateUrl and Target.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
TBaseActiveControl | getActiveControl ()
void | setImageUrl ( string $value) Sets the location of image file of the THyperLink.
void | setNavigateUrl ( string $value) Sets the URL to link to when the THyperLink component is clicked.
void | setTarget ( string $value) Sets the target window or frame to display the Web page content linked to when the THyperLink component is clicked.
void | setText ( string $value) On callback response, the inner HTMl of the label is updated.
Methods Inherited From THyperLink
THyperLink::addAttributesToRender(), THyperLink::createImage(), THyperLink::getData(), THyperLink::getImageUrl(), THyperLink::getNavigateUrl(), THyperLink::getTagName(), THyperLink::getTarget(), THyperLink::getText(), THyperLink::renderContents(), THyperLink::setData(), THyperLink::setImageUrl(), THyperLink::setNavigateUrl(), THyperLink::setTarget(), THyperLink::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

getActiveControl

public TBaseActiveControl getActiveControl ()

Output
TBaseActiveControl basic active control options.
Exception

setImageUrl

public void setImageUrl (string $value )

Sets the location of image file of the THyperLink.

Input
string $value the image file location
Output
Exception

setNavigateUrl

public void setNavigateUrl (string $value )

Sets the URL to link to when the THyperLink component is clicked.

Input
string $value the URL
Output
Exception

setTarget

public void setTarget (string $value )

Sets the target window or frame to display the Web page content linked to when the THyperLink component is clicked.

Input
string $value the target window, valid values include '_blank', '_parent', '_self', '_top' and empty string.
Output
Exception

setText

public void setText (string $value )

On callback response, the inner HTMl of the label is updated.

Input
string $value the text value of the label
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveImage

Class TActiveImage (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TImage
               |
               --TActiveImage

TActiveImage class.

TActiveImage allows the AlternateText, ImageAlign, ImageUrl, and DescriptionUrl to be updated during a callback request.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
TBaseActiveControl | getActiveControl ()
void | setAlternateText ( string $value) Sets the alternative text to be displayed in the TImage when the image is unavailable.
void | setDescriptionUrl ( string $value)
void | setImageAlign ( string $value) Sets the alignment of the image with respective to other elements on the page.
void | setImageUrl ( string $value)
Methods Inherited From TImage
TImage::addAttributesToRender(), TImage::getAlternateText(), TImage::getData(), TImage::getDescriptionUrl(), TImage::getImageAlign(), TImage::getImageUrl(), TImage::getTagName(), TImage::renderContents(), TImage::setAlternateText(), TImage::setData(), TImage::setDescriptionUrl(), TImage::setImageAlign(), TImage::setImageUrl()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

getActiveControl

public TBaseActiveControl getActiveControl ()

Output
TBaseActiveControl basic active control options.
Exception

setAlternateText

public void setAlternateText (string $value )

Sets the alternative text to be displayed in the TImage when the image is unavailable.

Input
string $value the alternative text
Output
Exception

setDescriptionUrl

public void setDescriptionUrl (string $value )

Input
string $value the URL to the long description of the image.
Output
Exception

setImageAlign

public void setImageAlign (string $value )

Sets the alignment of the image with respective to other elements on the page.

Possible values include: absbottom, absmiddle, baseline, bottom, left, middle, right, texttop, and top. If an empty string is passed in, imagealign attribute will not be rendered.

Input
string $value the alignment of the image
Output
Exception

setImageUrl

public void setImageUrl (string $value )

Input
string $value the URL of the image file
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveImageButton

Class TActiveImageButton (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TImage
               |
               --TImageButton
                  |
                  --TActiveImageButton

TActiveImageButton class.

TActiveImageButton is the active control counter part to TLinkButton. When a TActiveImageButton is clicked, rather than a normal post back request a callback request is initiated.

The OnCallback event is raised during a callback request and it is raise after the OnClick event.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected void | addAttributesToRender ( mixed $writer) Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
TBaseActiveControl | getActiveControl ()
protected string | getClientClassName ()
TCallbackClientSide | getClientSide ()
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | onPreRender ( THtmlWriter $writer) Register the x and y hidden input names of the position clicked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by
protected void | renderClientControlScript ( mixed $writer) Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
void | setAlternateText ( string $value) Sets the alternative text to be displayed in the TImage when the image is unavailable.
void | setDescriptionUrl ( string $value)
void | setImageAlign ( string $value) Sets the alignment of the image with respective to other elements on the page.
void | setImageUrl ( string $value)
Methods Inherited From TImageButton
TImageButton::addAttributesToRender(), TImageButton::canCauseValidation(), TImageButton::getCausesValidation(), TImageButton::getClientClassName(), TImageButton::getCommandName(), TImageButton::getCommandParameter(), TImageButton::getDataChanged(), TImageButton::getEnableClientScript(), TImageButton::getIsDefaultButton(), TImageButton::getPostBackOptions(), TImageButton::getTagName(), TImageButton::getText(), TImageButton::getValidationGroup(), TImageButton::loadPostData(), TImageButton::needPostBackScript(), TImageButton::onClick(), TImageButton::onCommand(), TImageButton::onPreRender(), TImageButton::raisePostBackEvent(), TImageButton::raisePostDataChangedEvent(), TImageButton::renderClientControlScript(), TImageButton::renderContents(), TImageButton::setCausesValidation(), TImageButton::setCommandName(), TImageButton::setCommandParameter(), TImageButton::setEnableClientScript(), TImageButton::setIsDefaultButton(), TImageButton::setText(), TImageButton::setValidationGroup()
Methods Inherited From TImage
TImage::addAttributesToRender(), TImage::getAlternateText(), TImage::getData(), TImage::getDescriptionUrl(), TImage::getImageAlign(), TImage::getImageUrl(), TImage::getTagName(), TImage::renderContents(), TImage::setAlternateText(), TImage::setData(), TImage::setDescriptionUrl(), TImage::setImageAlign(), TImage::setImageUrl()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

addAttributesToRender

protected void addAttributesToRender (mixed $writer )

Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

Input
mixed $writer
Output
Exception

getActiveControl

public TBaseActiveControl getActiveControl ()

Output
TBaseActiveControl basic active control options.
Exception

getClientClassName

protected string getClientClassName ()

Output
string corresponding javascript class name for this TActiveLinkButton.
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onPreRender

public void onPreRender (THtmlWriter $writer )

Register the x and y hidden input names of the position clicked.

Input
THtmlWriter $writer the renderer.
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by

ICallbackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick event first and then the OnCallback event. This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

Input
mixed $writer
Output
Exception

setAlternateText

public void setAlternateText (string $value )

Sets the alternative text to be displayed in the TImage when the image is unavailable.

Input
string $value the alternative text
Output
Exception

setDescriptionUrl

public void setDescriptionUrl (string $value )

Input
string $value the URL to the long description of the image.
Output
Exception

setImageAlign

public void setImageAlign (string $value )

Sets the alignment of the image with respective to other elements on the page.

Possible values include: absbottom, absmiddle, baseline, bottom, left, middle, right, texttop, and top. If an empty string is passed in, imagealign attribute will not be rendered.

Input
string $value the alignment of the image
Output
Exception

setImageUrl

public void setImageUrl (string $value )

Input
string $value the URL of the image file
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveLabel

Class TActiveLabel (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TActiveLabel

TActiveLabel class

The active control counterpart of TLabel component. When TBaseActiveControl::setEnableUpdate property is true the during a callback request, setting Text property will also set the text of the label on the client upon callback completion. Similarly, setting ForControl will also set the client-side "for" attribute on the label.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute id to the renderer.
TBaseActiveControl | getActiveControl ()
void | setForControl ( string $value) Sets the ID of the control that the label is associated with.
void | setText ( string $value) On callback response, the inner HTML of the label is updated.
Methods Inherited From TLabel
TLabel::addAttributesToRender(), TLabel::getData(), TLabel::getForControl(), TLabel::getTagName(), TLabel::getText(), TLabel::render(), TLabel::renderContents(), TLabel::setData(), TLabel::setForControl(), TLabel::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute id to the renderer.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

getActiveControl

public TBaseActiveControl getActiveControl ()

Output
TBaseActiveControl basic active control options.
Exception

setForControl

public void setForControl (string $value )

Sets the ID of the control that the label is associated with.

The control must be locatable via TControl::findControl using the ID. On callback response, the For attribute of the label is updated.

Input
string $value the associated control ID
Output
Exception

setText

public void setText (string $value )

On callback response, the inner HTML of the label is updated.

Input
string $value the text value of the label
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveLinkButton

Class TActiveLinkButton (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLinkButton
               |
               --TActiveLinkButton

TActiveLinkButton is the active control counter part to TLinkButton.

When a TActiveLinkButton is clicked, rather than a normal post back request a callback request is initiated.

The OnCallback event is raised during a callback request and it is raise after the OnClick event.

When the TBaseActiveCallbackControl::setEnableUpdate property is true, changing the Text property during callback request will update the link text upon callback response completion.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected void | addAttributesToRender ( mixed $writer) Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
TBaseActiveCallbackControl | getActiveControl ()
protected string | getClientClassName ()
TCallbackClientSide | getClientSide ()
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by
protected void | renderClientControlScript ( mixed $writer) Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
void | setText ( string $value) Updates the link text on the client-side if the setEnableUpdate property is set to true.
Methods Inherited From TLinkButton
TLinkButton::addAttributesToRender(), TLinkButton::getCausesValidation(), TLinkButton::getClientClassName(), TLinkButton::getCommandName(), TLinkButton::getCommandParameter(), TLinkButton::getData(), TLinkButton::getEnableClientScript(), TLinkButton::getIsDefaultButton(), TLinkButton::getPostBackOptions(), TLinkButton::getTagName(), TLinkButton::getText(), TLinkButton::getValidationGroup(), TLinkButton::onClick(), TLinkButton::onCommand(), TLinkButton::raisePostBackEvent(), TLinkButton::renderClientControlScript(), TLinkButton::renderContents(), TLinkButton::renderLinkButtonHref(), TLinkButton::setCausesValidation(), TLinkButton::setCommandName(), TLinkButton::setCommandParameter(), TLinkButton::setData(), TLinkButton::setEnableClientScript(), TLinkButton::setIsDefaultButton(), TLinkButton::setText(), TLinkButton::setValidationGroup()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

addAttributesToRender

protected void addAttributesToRender (mixed $writer )

Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

Input
mixed $writer
Output
Exception

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getClientClassName

protected string getClientClassName ()

Output
string corresponding javascript class name for this TActiveLinkButton.
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by

ICallbackEventHandlerICallbackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick event first and then the OnCallback event. This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

Input
mixed $writer
Output
Exception

setText

public void setText (string $value )

Updates the link text on the client-side if the setEnableUpdate property is set to true.

Input
string $value caption of the button
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveListBox

Class TActiveListBox (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TListBox
                     |
                     --TActiveListBox

TActiveListBox class.

List items can be added dynamically during a callback request.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected void | addAttributesToRender ( mixed $writer) Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
protected TActiveListItemCollection | createListItemCollection () Creates a collection object to hold list items. A specialized TActiveListItemCollection is created to allow the drop down list options to be added.
TBaseActiveCallbackControl | getActiveControl ()
protected null | getClientClassName () Javascript client class for this control.
TCallbackClientSide | getClientSide ()
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | onPreRender ( mixed $param) Updates the client-side options if the item list has changed after the OnLoad event.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by ICallbackEventHandler interface.
protected void | renderClientControlScript ( mixed $writer) Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
void | setSelectionMode ( string $value) Sets the selection mode of the list control (Single, Multiple) on the client-side if the setEnableUpdate property is set to true.
Methods Inherited From TListBox
TListBox::addAttributesToRender(), TListBox::getClientClassName(), TListBox::getDataChanged(), TListBox::getIsMultiSelect(), TListBox::getIsValid(), TListBox::getRows(), TListBox::getSelectionMode(), TListBox::getValidationPropertyValue(), TListBox::loadPostData(), TListBox::onPreRender(), TListBox::raisePostDataChangedEvent(), TListBox::setIsValid(), TListBox::setRows(), TListBox::setSelectionMode()
Methods Inherited From TListControl
TListControl::addAttributesToRender(), TListControl::addParsedObject(), TListControl::clearSelection(), TListControl::createListItemCollection(), TListControl::formatDataValue(), TListControl::getAppendDataBoundItems(), TListControl::getAutoPostBack(), TListControl::getCausesValidation(), TListControl::getClientClassName(), TListControl::getData(), TListControl::getDataGroupField(), TListControl::getDataTextField(), TListControl::getDataTextFormatString(), TListControl::getDataValueField(), TListControl::getEnableClientScript(), TListControl::getHasItems(), TListControl::getIsMultiSelect(), TListControl::getItemCount(), TListControl::getItems(), TListControl::getPostBackOptions(), TListControl::getPromptText(), TListControl::getPromptValue(), TListControl::getSelectedIndex(), TListControl::getSelectedIndices(), TListControl::getSelectedItem(), TListControl::getSelectedValue(), TListControl::getSelectedValues(), TListControl::getTagName(), TListControl::getText(), TListControl::getValidationGroup(), TListControl::loadState(), TListControl::onSelectedIndexChanged(), TListControl::onTextChanged(), TListControl::performDataBinding(), TListControl::renderClientControlScript(), TListControl::renderContents(), TListControl::renderPrompt(), TListControl::saveState(), TListControl::setAppendDataBoundItems(), TListControl::setAutoPostBack(), TListControl::setCausesValidation(), TListControl::setData(), TListControl::setDataGroupField(), TListControl::setDataTextField(), TListControl::setDataTextFormatString(), TListControl::setDataValueField(), TListControl::setEnableClientScript(), TListControl::setPromptText(), TListControl::setPromptValue(), TListControl::setSelectedIndex(), TListControl::setSelectedIndices(), TListControl::setSelectedValue(), TListControl::setSelectedValues(), TListControl::setText(), TListControl::setValidationGroup()
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

addAttributesToRender

protected void addAttributesToRender (mixed $writer )

Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

Input
mixed $writer
Output
Exception

createListItemCollection

protected TActiveListItemCollection createListItemCollection ()

Creates a collection object to hold list items. A specialized TActiveListItemCollection is created to allow the drop down list options to be added.

This method may be overriden to create a customized collection.

Output
TActiveListItemCollection the collection object
Exception

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getClientClassName

protected null getClientClassName ()

Javascript client class for this control.

This method overrides the parent implementation.

Output
null no javascript class name.
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onPreRender

public void onPreRender (mixed $param )

Updates the client-side options if the item list has changed after the OnLoad event.

Input
mixed $param
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by ICallbackEventHandler interface.

This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

Input
mixed $writer
Output
Exception

setSelectionMode

public void setSelectionMode (string $value )

Sets the selection mode of the list control (Single, Multiple) on the client-side if the setEnableUpdate property is set to true.

Input
string $value the selection mode
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveListControlAdapter

Class TActiveListControlAdapter (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControlAdapter
         |
         --TActiveControlAdapter
            |
            --TActiveListControlAdapter

TActiveListControlAdapter class.

Adapte the list controls to allows the selections on the client-side to be altered during callback response.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
protected boolean | canUpdateClientSide ()
void | clearSelection () Clears all existing selections on the client side.
void | setSelectedIndex ( integer $index) Selects an item based on zero-base index on the client side.
void | setSelectedIndices ( array $indices) Selects a list of item based on zero-base indices on the client side.
void | setSelectedValue ( string $value) Sets selection by item value on the client side.
void | setSelectedValues ( array $values) Sets selection by a list of item values on the client side.
void | updateListItems () Update the client-side list options.
Methods Inherited From TActiveControlAdapter
TActiveControlAdapter::getBaseActiveControl(), TActiveControlAdapter::getIsTrackingPageState(), TActiveControlAdapter::getStateTracker(), TActiveControlAdapter::onLoad(), TActiveControlAdapter::render(), TActiveControlAdapter::renderCallbackClientScripts(), TActiveControlAdapter::saveState(), TActiveControlAdapter::setBaseActiveControl(), TActiveControlAdapter::setBaseControlClass()
Methods Inherited From TControlAdapter
TControlAdapter::createChildControls(), TControlAdapter::getControl(), TControlAdapter::getPage(), TControlAdapter::loadState(), TControlAdapter::onInit(), TControlAdapter::onLoad(), TControlAdapter::onPreRender(), TControlAdapter::onUnload(), TControlAdapter::render(), TControlAdapter::renderChildren(), TControlAdapter::saveState()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

canUpdateClientSide

protected boolean canUpdateClientSide ()

Output
boolean true if can update client-side attributes.
Exception

clearSelection

public void clearSelection ()

Clears all existing selections on the client side.

Output
Exception

setSelectedIndex

public void setSelectedIndex (integer $index )

Selects an item based on zero-base index on the client side.

Input
integer $index the index (zero-based) of the item to be selected
Output
Exception

setSelectedIndices

public void setSelectedIndices (array $indices )

Selects a list of item based on zero-base indices on the client side.

Input
array $indices list of index of items to be selected
Output
Exception

setSelectedValue

public void setSelectedValue (string $value )

Sets selection by item value on the client side.

Input
string $value the value of the item to be selected.
Output
Exception

setSelectedValues

public void setSelectedValues (array $values )

Sets selection by a list of item values on the client side.

Input
array $values list of the selected item values
Output
Exception

updateListItems

public void updateListItems ()

Update the client-side list options.

Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveListItemCollection

Class TActiveListItemCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TListItemCollection
         |
         --TActiveListItemCollection

TActiveListItemCollection class.

Allows TActiveDropDownList and TActiveListBox to add new options during callback response. New options can only be added after the TControl::onLoad event.

The ListHasChanged property is true when the list items has changed. The control responsible for the list needs to repopulate the client-side options.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
protected boolean | canUpdateClientSide ()
IActiveControl | getControl ()
boolean | getListHasChanged ()
void | insertAt ( integer $index, TListItem $value) Inserts an item into the collection.
void | removeAt ( int $index) Removes an item from at specified index.
void | setControl ( IActiveControl $control)
void | updateClientSide () Update client-side list items.
Methods Inherited From TListItemCollection
TListItemCollection::createListItem(), TListItemCollection::createNewListItem(), TListItemCollection::findIndexByText(), TListItemCollection::findIndexByValue(), TListItemCollection::findItemByText(), TListItemCollection::findItemByValue(), TListItemCollection::insertAt(), TListItemCollection::loadState(), TListItemCollection::saveState()
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

canUpdateClientSide

protected boolean canUpdateClientSide ()

Output
boolean true if active controls can update client-side and the onLoad event has already been raised.
Exception

getControl

public IActiveControl getControl ()

Output
IActiveControl active control using the collection.
Exception

getListHasChanged

public boolean getListHasChanged ()

Output
boolean true if the list has changed after onLoad event.
Exception

insertAt

public void insertAt (integer $index , TListItem $value )

Inserts an item into the collection.

The new option is added on the client-side during callback.

Input
integer | $index | the location where the item will be inserted. The current item at the place and the following ones will be moved backward.
TListItem | $value | the item to be inserted.
Output
Exception
throws | TInvalidDataTypeException if the item being inserted is neither a string nor TListItem

removeAt

public void removeAt (int $index )

Removes an item from at specified index.

Input
int $index zero based index.
Output
Exception

setControl

public void setControl (IActiveControl $control )

Input
IActiveControl $control a active list control.
Output
Exception

updateClientSide

public void updateClientSide ()

Update client-side list items.

Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActivePageAdapter

Class TActivePageAdapter (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControlAdapter
         |
         --TActivePageAdapter

TActivePageAdapter class.

Callback request handler.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gamil[dot]com>
Constructor Summary
public
__construct Array
Constructor, trap errors and exception to let the callback response handle them.
Method Summary
TCallbackClientScript | getCallbackClientHandler () Gets the callback client script handler. It handlers the javascript functions to be executed during the callback response.
string | getCallbackEventParameter () Gets callback parameter. JSON encoding is assumed.
TControl | getCallbackEventTarget ()
void | processCallbackEvent ( THtmlWriter $writer) Process the callback request.
protected void | redirect ( string $url) Redirect url on the client-side using javascript.
void | registerControlToRender ( TControl $control, THtmlWriter $writer) Register a control for defered render() call.
void | renderCallbackResponse ( THtmlWriter $writer) Render the callback response.
protected void | renderResponse ( THtmlWriter $writer) Renders the callback response by adding additional callback data and javascript actions in the header and page state if required.
void | setCallbackEventParameter ( mixed $value)
void | setCallbackEventTarget ( TControl $control) Registers a control to raise callback event in the current request.
protected void | trapCallbackErrorsExceptions () Trap errors and exceptions to be handled by TCallbackErrorHandler.
Methods Inherited From TControlAdapter
TControlAdapter::createChildControls(), TControlAdapter::getControl(), TControlAdapter::getPage(), TControlAdapter::loadState(), TControlAdapter::onInit(), TControlAdapter::onLoad(), TControlAdapter::onPreRender(), TControlAdapter::onUnload(), TControlAdapter::render(), TControlAdapter::renderChildren(), TControlAdapter::saveState()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | CALLBACK_ACTION_HEADER | Callback response client-side action header name.
string | CALLBACK_DATA_HEADER | Callback response data header name.
string | CALLBACK_ERROR_HEADER | Callback error header name.
string | CALLBACK_PAGESTATE_HEADER | Callback page state header name.
string | CALLBACK_REDIRECT | Callback redirect url header name.
Constructor Details

__construct

public __construct Array

Constructor, trap errors and exception to let the callback response handle them.
Method Details

getCallbackClientHandler

public TCallbackClientScript getCallbackClientHandler ()

Gets the callback client script handler. It handlers the javascript functions to be executed during the callback response.

Output
TCallbackClientScript callback client handler.
Exception

getCallbackEventParameter

public string getCallbackEventParameter ()

Gets callback parameter. JSON encoding is assumed.

Output
string postback event parameter
Exception

getCallbackEventTarget

public TControl getCallbackEventTarget ()

Output
TControl the control responsible for the current callback event, null if nonexistent
Exception

processCallbackEvent

public void processCallbackEvent (THtmlWriter $writer )

Process the callback request.

Input
THtmlWriter $writer html content writer.
Output
Exception

redirect

protected void redirect (string $url )

Redirect url on the client-side using javascript.

Input
string $url new url to load.
Output
Exception

registerControlToRender

public void registerControlToRender (TControl $control , THtmlWriter $writer )

Register a control for defered render() call.

Input
TControl | $control | control for defered rendering
THtmlWriter | $writer | the renderer
Output
Exception

renderCallbackResponse

public void renderCallbackResponse (THtmlWriter $writer )

Render the callback response.

Input
THtmlWriter $writer html content writer.
Output
Exception

renderResponse

protected void renderResponse (THtmlWriter $writer )

Renders the callback response by adding additional callback data and javascript actions in the header and page state if required.

Input
THtmlWriter $writer html content writer.
Output
Exception

setCallbackEventParameter

public void setCallbackEventParameter (mixed $value )

Input
mixed $value postback event parameter
Output
Exception

setCallbackEventTarget

public void setCallbackEventTarget (TControl $control )

Registers a control to raise callback event in the current request.

Input
TControl $control control registered to raise callback event.
Output
Exception

trapCallbackErrorsExceptions

protected void trapCallbackErrorsExceptions ()

Trap errors and exceptions to be handled by TCallbackErrorHandler.

Output
Exception

Constant Details

CALLBACK_ACTION_HEADER

Callback response client-side action header name.

Type:

string

Value:

'X-PRADO-ACTIONS'

CALLBACK_DATA_HEADER

Callback response data header name.

Type:

string

Value:

'X-PRADO-DATA'

CALLBACK_ERROR_HEADER

Callback error header name.

Type:

string

Value:

'X-PRADO-ERROR'

CALLBACK_PAGESTATE_HEADER

Callback page state header name.

Type:

string

Value:

'X-PRADO-PAGESTATE'

CALLBACK_REDIRECT

Callback redirect url header name.

Type:

string

Value:

'X-PRADO-REDIRECT'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCallbackErrorHandler

Class TCallbackErrorHandler (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TErrorHandler
            |
            --TCallbackErrorHandler

TCallbackErrorHandler class.

Captures errors and exceptions and send them back during callback response. When the application is in debug mode, the error and exception stack trace are shown. A TJavascriptLogger must be present on the client-side to view the error stack trace.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TErrorHandler
ERROR_FILE_NAME, EXCEPTION_FILE_NAME, SOURCE_LINES,
Method Summary
protected void
displayException ( Exception $exception)
Displays the exceptions to the client-side TJavascriptLogger.
Methods Inherited From TErrorHandler
TErrorHandler::displayException(), TErrorHandler::getErrorTemplate(), TErrorHandler::getErrorTemplatePath(), TErrorHandler::getExceptionTemplate(), TErrorHandler::handleError(), TErrorHandler::handleExternalError(), TErrorHandler::handleRecursiveError(), TErrorHandler::hideSecurityRelated(), TErrorHandler::init(), TErrorHandler::setErrorTemplatePath()
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

displayException

protected void displayException (Exception $exception )

Displays the exceptions to the client-side TJavascriptLogger.

A HTTP 500 status code is sent and the stack trace is sent as JSON encoded.

Input
Exception $exception exception details.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TInvalidCallbackException

Class TInvalidCallbackException (Class Overview)

Exception
   |
   --TException
      |
      --TInvalidCallbackException

TInvalidCallbackException class.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TActivePager

Class TActivePager (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPager
               |
               --TActivePager

TActivePager is the active control counter part of TPager.

When a page change is requested, TActivePager raises a callback instead of the traditional postback.

The OnCallback event is raised during a callback request and it is raise after the OnPageIndexChanged event.

Since: 3.1.2
Author: "gevik" (forum contributor) and Christophe Boulain (Christophe.Boulain@gmail.com)
Constants Inherited From TPager
CMD_PAGE, CMD_PAGE_FIRST, CMD_PAGE_LAST, CMD_PAGE_NEXT, CMD_PAGE_PREV,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected void | buildListPager () Builds a dropdown list pager Override parent implementation to build Active dropdown lists.
protected mixed | createPagerButton ( string $buttonType, boolean $enabled, string $text, string $commandName, string $commandParameter) Creates a pager button.
TBaseActiveControl | getActiveControl ()
TCallbackClientSide | getClientSide ()
void | handleCallback ( mixed $sender, TCallbackEventParameter $param) Event handler to the OnCallback active buttons or active dropdownlist.
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by ICallbackEventHandler interface.
void | render ( mixed $writer)
Methods Inherited From TPager
TPager::bubbleEvent(), TPager::buildListPager(), TPager::buildNextPrevPager(), TPager::buildNumericPager(), TPager::buildPager(), TPager::createPagerButton(), TPager::getButtonType(), TPager::getControlToPaginate(), TPager::getCurrentPageIndex(), TPager::getFirstPageImageUrl(), TPager::getFirstPageText(), TPager::getIsFirstPage(), TPager::getIsLastPage(), TPager::getLastPageImageUrl(), TPager::getLastPageText(), TPager::getMode(), TPager::getNextPageImageUrl(), TPager::getNextPageText(), TPager::getNumericPageImageUrl(), TPager::getPageButtonCount(), TPager::getPageCount(), TPager::getPageImageUrl(), TPager::getPrevPageImageUrl(), TPager::getPrevPageText(), TPager::listIndexChanged(), TPager::loadState(), TPager::onPageIndexChanged(), TPager::onPreRender(), TPager::render(), TPager::setButtonType(), TPager::setControlToPaginate(), TPager::setCurrentPageIndex(), TPager::setFirstPageImageUrl(), TPager::setFirstPageText(), TPager::setLastPageImageUrl(), TPager::setLastPageText(), TPager::setMode(), TPager::setNextPageImageUrl(), TPager::setNextPageText(), TPager::setNumericPageImageUrl(), TPager::setPageButtonCount(), TPager::setPageCount(), TPager::setPrevPageImageUrl(), TPager::setPrevPageText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

buildListPager

protected void buildListPager ()

Builds a dropdown list pager Override parent implementation to build Active dropdown lists.

Output
Exception

createPagerButton

protected mixed createPagerButton (string $buttonType , boolean $enabled , string $text , string $commandName , string $commandParameter )

Creates a pager button.

Override parent implementation to create, depending on the button type, a TActiveLinkButton, a TActiveButton or a TActiveImageButton may be created.

Input
string | $buttonType | button type, either LinkButton or PushButton
boolean | $enabled | whether the button should be enabled
string | $text | caption of the button
string | $commandName | CommandName corresponding to the OnCommand event of the button
string | $commandParameter | CommandParameter corresponding to the OnCommand event of the button
Output
mixed | the button instance
Exception

getActiveControl

public TBaseActiveControl getActiveControl ()

Output
TBaseActiveControl standard active control options.
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

handleCallback

public void handleCallback (mixed $sender , TCallbackEventParameter $param )

Event handler to the OnCallback active buttons or active dropdownlist.

This handler will raise the OnCallback event

Input
mixed | $sender
TCallbackEventParameter | $param
Output
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by ICallbackEventHandler interface.

This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

render

public void render (mixed $writer )

Input
mixed $writer
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActivePanel

Class TActivePanel (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPanel
               |
               --TActivePanel

TActivePanel is the TPanel active control counterpart.

TActivePanel allows the client-side panel contents to be updated during a callback response using the http://www.php.net/flush method.

Example: Assume $param is an instance of TCallbackEventParameter attached to the OnCallback event a TCallback with ID "callback1", and "panel1" is the ID of a TActivePanel.

1      function callback1_requested($sender, $param)
2      {
3             $this->panel1->render($param->getNewWriter());
4      }

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute id to the renderer.
TBaseActiveControl | getActiveControl ()
void | render ( THtmlWriter $writer) Renders and replaces the panel's content on the client-side.
Methods Inherited From TPanel
TPanel::addAttributesToRender(), TPanel::createStyle(), TPanel::getBackImageUrl(), TPanel::getDefaultButton(), TPanel::getDirection(), TPanel::getGroupingText(), TPanel::getHorizontalAlign(), TPanel::getScrollBars(), TPanel::getTagName(), TPanel::getWrap(), TPanel::renderBeginTag(), TPanel::renderEndTag(), TPanel::setBackImageUrl(), TPanel::setDefaultButton(), TPanel::setDirection(), TPanel::setGroupingText(), TPanel::setHorizontalAlign(), TPanel::setScrollBars(), TPanel::setWrap()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute id to the renderer.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

getActiveControl

public TBaseActiveControl getActiveControl ()

Output
TBaseActiveControl standard active control options.
Exception

render

public void render (THtmlWriter $writer )

Renders and replaces the panel's content on the client-side.

When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.

Input
THtmlWriter $writer html writer
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRadioButton

Class TActiveRadioButton (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TCheckBox
               |
               --TRadioButton
                  |
                  --TActiveRadioButton

TActiveRadioButton class.

The active control counter part to radio button. The AutoPostBack property is set to true by default. Thus, when the radio button is clicked a OnCallback event is raise after OnCheckedChanged event.

The Text and Checked properties can be changed during a callback.

The GroupName property may NOT be changed during callback because the client-side <tt>name</tt> attribute is read-only and can not be changed using javascript.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
TBaseActiveCallbackControl | getActiveControl ()
protected string | getClientClassName ()
TCallbackClientSide | getClientSide ()
protected string | getDefaultLabelID ()
TMap | getLabelAttributes () Overrides parent implementation to ensure label has ID.
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by ICallbackEventHandler interface.
protected void | renderClientControlScript ( mixed $writer) Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
protected void | renderInputTag ( mixed $writer, mixed $clientID, mixed $onclick) Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
protected void | renderLabel ( THtmlWriter $writer, string $clientID, string $text) Renders a label beside the radio button.
void | setChecked ( boolean $value) Checks the radio button.
void | setText ( string $value) Updates the button text on the client-side if the setEnableUpdate property is set to true.
Methods Inherited From TRadioButton
TRadioButton::addToPostDataLoader(), TRadioButton::getClientClassName(), TRadioButton::getEnableClientScript(), TRadioButton::getGroupName(), TRadioButton::getRadioButtonsInGroup(), TRadioButton::getUniqueGroupName(), TRadioButton::getValueAttribute(), TRadioButton::loadPostData(), TRadioButton::onInit(), TRadioButton::onUnLoad(), TRadioButton::renderClientControlScript(), TRadioButton::renderInputTag(), TRadioButton::setEnableClientScript(), TRadioButton::setGroupName(), TRadioButton::setUniqueGroupName()
Methods Inherited From TCheckBox
TCheckBox::getAutoPostBack(), TCheckBox::getCausesValidation(), TCheckBox::getChecked(), TCheckBox::getClientClassName(), TCheckBox::getData(), TCheckBox::getDataChanged(), TCheckBox::getEnableClientScript(), TCheckBox::getInputAttributes(), TCheckBox::getIsValid(), TCheckBox::getLabelAttributes(), TCheckBox::getPostBackOptions(), TCheckBox::getSpanNeeded(), TCheckBox::getSurroundingTagID(), TCheckBox::getTagName(), TCheckBox::getText(), TCheckBox::getTextAlign(), TCheckBox::getValidationGroup(), TCheckBox::getValidationPropertyValue(), TCheckBox::getValue(), TCheckBox::getValueAttribute(), TCheckBox::loadPostData(), TCheckBox::onCheckedChanged(), TCheckBox::onPreRender(), TCheckBox::raisePostDataChangedEvent(), TCheckBox::render(), TCheckBox::renderClientControlScript(), TCheckBox::renderInputTag(), TCheckBox::renderLabel(), TCheckBox::setAutoPostBack(), TCheckBox::setCausesValidation(), TCheckBox::setChecked(), TCheckBox::setData(), TCheckBox::setEnableClientScript(), TCheckBox::setIsValid(), TCheckBox::setText(), TCheckBox::setTextAlign(), TCheckBox::setValidationGroup(), TCheckBox::setValue()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getClientClassName

protected string getClientClassName ()

Output
string corresponding javascript class name for this TActiveRadioButton.
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

getDefaultLabelID

protected string getDefaultLabelID ()

Output
string radio button label ID;
Exception

getLabelAttributes

public TMap getLabelAttributes ()

Overrides parent implementation to ensure label has ID.

Output
TMap list of attributes to be rendered for label beside the radio button
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by ICallbackEventHandler interface.

This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

Input
mixed $writer
Output
Exception

renderInputTag

protected void renderInputTag (mixed $writer , mixed $clientID , mixed $onclick )

Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

Since 3.1.4, the javascript code is not rendered if AutoPostBack is false

Input
mixed | $writer
mixed | $clientID
mixed | $onclick
Output
Exception

renderLabel

protected void renderLabel (THtmlWriter $writer , string $clientID , string $text )

Renders a label beside the radio button.

Input
THtmlWriter | $writer | the writer for the rendering purpose
string | $clientID | radio button id
string | $text | label text
Output
Exception

setChecked

public void setChecked (boolean $value )

Checks the radio button.

Updates radio button checked state on the client-side if the setEnableUpdate property is set to true.

Input
boolean $value whether the radio button is to be checked or not.
Output
Exception

setText

public void setText (string $value )

Updates the button text on the client-side if the setEnableUpdate property is set to true.

Input
string $value caption of the button
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRadioButtonList

Class TActiveRadioButtonList (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TCheckBoxList
                     |
                     --TRadioButtonList
                        |
                        --TActiveRadioButtonList

TActiveRadioButtonList class.

The active control counter part to radio button list control. The AutoPostBack property is set to true by default. Thus, when a radio button is clicked a OnCallback event is raised after OnSelectedIndexChanged event.

With ActiveControl.EnabledUpdate set to true (default is true), changes to the selection will be updated on the client side.

List items can not be changed dynamically during a callback request.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected TControl | createRepeatedControl () Creates a control used for repetition (used as a template).
TBaseActiveCallbackControl | getActiveControl ()
TCallbackClientSide | getClientSide ()
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by ICallbackEventHandler interface.
protected void | renderClientControlScript ( mixed $writer) Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
Methods Inherited From TRadioButtonList
TRadioButtonList::createRepeatedControl(), TRadioButtonList::getClientClassName(), TRadioButtonList::getIsMultiSelect(), TRadioButtonList::loadPostData(), TRadioButtonList::setSelectedIndices()
Methods Inherited From TCheckBoxList
TCheckBoxList::createRepeatedControl(), TCheckBoxList::createStyle(), TCheckBoxList::findControl(), TCheckBoxList::generateItemStyle(), TCheckBoxList::getCellPadding(), TCheckBoxList::getCellSpacing(), TCheckBoxList::getClientClassName(), TCheckBoxList::getDataChanged(), TCheckBoxList::getHasFooter(), TCheckBoxList::getHasHeader(), TCheckBoxList::getHasSeparators(), TCheckBoxList::getIsMultiSelect(), TCheckBoxList::getIsValid(), TCheckBoxList::getPostBackOptions(), TCheckBoxList::getRepeatColumns(), TCheckBoxList::getRepeatDirection(), TCheckBoxList::getRepeatInfo(), TCheckBoxList::getRepeatLayout(), TCheckBoxList::getSpanNeeded(), TCheckBoxList::getTextAlign(), TCheckBoxList::getValidationPropertyValue(), TCheckBoxList::loadPostData(), TCheckBoxList::onPreRender(), TCheckBoxList::raisePostDataChangedEvent(), TCheckBoxList::render(), TCheckBoxList::renderItem(), TCheckBoxList::setCellPadding(), TCheckBoxList::setCellSpacing(), TCheckBoxList::setEnabled(), TCheckBoxList::setIsValid(), TCheckBoxList::setRepeatColumns(), TCheckBoxList::setRepeatDirection(), TCheckBoxList::setRepeatLayout(), TCheckBoxList::setTextAlign()
Methods Inherited From TListControl
TListControl::addAttributesToRender(), TListControl::addParsedObject(), TListControl::clearSelection(), TListControl::createListItemCollection(), TListControl::formatDataValue(), TListControl::getAppendDataBoundItems(), TListControl::getAutoPostBack(), TListControl::getCausesValidation(), TListControl::getClientClassName(), TListControl::getData(), TListControl::getDataGroupField(), TListControl::getDataTextField(), TListControl::getDataTextFormatString(), TListControl::getDataValueField(), TListControl::getEnableClientScript(), TListControl::getHasItems(), TListControl::getIsMultiSelect(), TListControl::getItemCount(), TListControl::getItems(), TListControl::getPostBackOptions(), TListControl::getPromptText(), TListControl::getPromptValue(), TListControl::getSelectedIndex(), TListControl::getSelectedIndices(), TListControl::getSelectedItem(), TListControl::getSelectedValue(), TListControl::getSelectedValues(), TListControl::getTagName(), TListControl::getText(), TListControl::getValidationGroup(), TListControl::loadState(), TListControl::onSelectedIndexChanged(), TListControl::onTextChanged(), TListControl::performDataBinding(), TListControl::renderClientControlScript(), TListControl::renderContents(), TListControl::renderPrompt(), TListControl::saveState(), TListControl::setAppendDataBoundItems(), TListControl::setAutoPostBack(), TListControl::setCausesValidation(), TListControl::setData(), TListControl::setDataGroupField(), TListControl::setDataTextField(), TListControl::setDataTextFormatString(), TListControl::setDataValueField(), TListControl::setEnableClientScript(), TListControl::setPromptText(), TListControl::setPromptValue(), TListControl::setSelectedIndex(), TListControl::setSelectedIndices(), TListControl::setSelectedValue(), TListControl::setSelectedValues(), TListControl::setText(), TListControl::setValidationGroup()
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

createRepeatedControl

protected TControl createRepeatedControl ()

Creates a control used for repetition (used as a template).

Output
TControl the control to be repeated
Exception

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by ICallbackEventHandler interface.

This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

Input
mixed $writer
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRatingList

Class TActiveRatingList (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TCheckBoxList
                     |
                     --TRadioButtonList
                        |
                        --TRatingList
                           |
                           --TActiveRatingList

TActiveRatingList Class

Displays clickable images that represent a TRadioButtonList

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Author: Bradley Booms <bradley[dot]booms[at]gmail[dot]com>
Constants Inherited From TRatingList
SCRIPT_PATH,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected void | callClientFunction ( string $func, mixed $value) Calls the client-side static method for this control class.
TBaseActiveCallbackControl | getActiveControl ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
TCallbackClientSide | getClientSide ()
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by ICallbackEventHandler interface.
void | setCaption ( string $value)
void | setRating ( float $value)
void | setReadOnly ( boolean $value)
Methods Inherited From TRatingList
TRatingList::getAllowInput(), TRatingList::getAssetUrl(), TRatingList::getCaption(), TRatingList::getCaptionControl(), TRatingList::getCaptionControlID(), TRatingList::getCaptionID(), TRatingList::getClientClassName(), TRatingList::getHalfRatingInterval(), TRatingList::getPostBackOptions(), TRatingList::getRating(), TRatingList::getRatingIndex(), TRatingList::getRatingStyle(), TRatingList::getRatingStyleCssClass(), TRatingList::getReadOnly(), TRatingList::onPreRender(), TRatingList::onSelectedIndexChanged(), TRatingList::publishImages(), TRatingList::publishStyle(), TRatingList::render(), TRatingList::setAllowInput(), TRatingList::setCaption(), TRatingList::setCaptionID(), TRatingList::setEnabled(), TRatingList::setHalfRatingInterval(), TRatingList::setRating(), TRatingList::setRatingStyle(), TRatingList::setReadOnly(), TRatingList::setRepeatLayout(), TRatingList::setSelectedIndex()
Methods Inherited From TRadioButtonList
TRadioButtonList::createRepeatedControl(), TRadioButtonList::getClientClassName(), TRadioButtonList::getIsMultiSelect(), TRadioButtonList::loadPostData(), TRadioButtonList::setSelectedIndices()
Methods Inherited From TCheckBoxList
TCheckBoxList::createRepeatedControl(), TCheckBoxList::createStyle(), TCheckBoxList::findControl(), TCheckBoxList::generateItemStyle(), TCheckBoxList::getCellPadding(), TCheckBoxList::getCellSpacing(), TCheckBoxList::getClientClassName(), TCheckBoxList::getDataChanged(), TCheckBoxList::getHasFooter(), TCheckBoxList::getHasHeader(), TCheckBoxList::getHasSeparators(), TCheckBoxList::getIsMultiSelect(), TCheckBoxList::getIsValid(), TCheckBoxList::getPostBackOptions(), TCheckBoxList::getRepeatColumns(), TCheckBoxList::getRepeatDirection(), TCheckBoxList::getRepeatInfo(), TCheckBoxList::getRepeatLayout(), TCheckBoxList::getSpanNeeded(), TCheckBoxList::getTextAlign(), TCheckBoxList::getValidationPropertyValue(), TCheckBoxList::loadPostData(), TCheckBoxList::onPreRender(), TCheckBoxList::raisePostDataChangedEvent(), TCheckBoxList::render(), TCheckBoxList::renderItem(), TCheckBoxList::setCellPadding(), TCheckBoxList::setCellSpacing(), TCheckBoxList::setEnabled(), TCheckBoxList::setIsValid(), TCheckBoxList::setRepeatColumns(), TCheckBoxList::setRepeatDirection(), TCheckBoxList::setRepeatLayout(), TCheckBoxList::setTextAlign()
Methods Inherited From TListControl
TListControl::addAttributesToRender(), TListControl::addParsedObject(), TListControl::clearSelection(), TListControl::createListItemCollection(), TListControl::formatDataValue(), TListControl::getAppendDataBoundItems(), TListControl::getAutoPostBack(), TListControl::getCausesValidation(), TListControl::getClientClassName(), TListControl::getData(), TListControl::getDataGroupField(), TListControl::getDataTextField(), TListControl::getDataTextFormatString(), TListControl::getDataValueField(), TListControl::getEnableClientScript(), TListControl::getHasItems(), TListControl::getIsMultiSelect(), TListControl::getItemCount(), TListControl::getItems(), TListControl::getPostBackOptions(), TListControl::getPromptText(), TListControl::getPromptValue(), TListControl::getSelectedIndex(), TListControl::getSelectedIndices(), TListControl::getSelectedItem(), TListControl::getSelectedValue(), TListControl::getSelectedValues(), TListControl::getTagName(), TListControl::getText(), TListControl::getValidationGroup(), TListControl::loadState(), TListControl::onSelectedIndexChanged(), TListControl::onTextChanged(), TListControl::performDataBinding(), TListControl::renderClientControlScript(), TListControl::renderContents(), TListControl::renderPrompt(), TListControl::saveState(), TListControl::setAppendDataBoundItems(), TListControl::setAutoPostBack(), TListControl::setCausesValidation(), TListControl::setData(), TListControl::setDataGroupField(), TListControl::setDataTextField(), TListControl::setDataTextFormatString(), TListControl::setDataValueField(), TListControl::setEnableClientScript(), TListControl::setPromptText(), TListControl::setPromptValue(), TListControl::setSelectedIndex(), TListControl::setSelectedIndices(), TListControl::setSelectedValue(), TListControl::setSelectedValues(), TListControl::setText(), TListControl::setValidationGroup()
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveListControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

callClientFunction

protected void callClientFunction (string $func , mixed $value )

Calls the client-side static method for this control class.

Input
string | $func | static method name
mixed | $value | method parmaeter
Output
Exception

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by ICallbackEventHandler interface.

This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

setCaption

public void setCaption (string $value )

Input
string $value caption text
Output
Exception

setRating

public void setRating (float $value )

Input
float $value rating value, also sets the selected Index
Output
Exception

setReadOnly

public void setReadOnly (boolean $value )

Input
boolean $value whether the items in the column can be edited
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveTextBox

Class TActiveTextBox (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --TActiveTextBox

Direct Known Sub-classes:

TAutoComplete , TInPlaceTextBox

TActiveTextBox class.

TActiveTextBox allows the Text property of the textbox to be changed during callback. When AutoPostBack property is true, changes to the textbox contents will perform a callback request causing OnTextChange to be fired first followed by OnCallback event.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TTextBox
DEFAULT_COLUMNS, DEFAULT_ROWS,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected void | addAttributesToRender ( mixed $writer) Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
TBaseActiveCallbackControl | getActiveControl ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
TCallbackClientSide | getClientSide ()
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by ICallbackEventHandler interface.
protected void | renderClientControlScript ( mixed $writer) Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
void | setText ( string $value) Client-side Text property can only be updated after the OnLoad stage.
Methods Inherited From TTextBox
TTextBox::addAttributesToRender(), TTextBox::getAutoCompleteType(), TTextBox::getAutoPostBack(), TTextBox::getAutoTrim(), TTextBox::getCausesValidation(), TTextBox::getClientClassName(), TTextBox::getColumns(), TTextBox::getData(), TTextBox::getDataChanged(), TTextBox::getEnableClientScript(), TTextBox::getIsValid(), TTextBox::getMaxLength(), TTextBox::getPersistPassword(), TTextBox::getPostBackOptions(), TTextBox::getReadOnly(), TTextBox::getRows(), TTextBox::getSafeText(), TTextBox::getSafeTextParser(), TTextBox::getTagName(), TTextBox::getText(), TTextBox::getTextMode(), TTextBox::getValidationGroup(), TTextBox::getValidationPropertyValue(), TTextBox::getWrap(), TTextBox::loadPostData(), TTextBox::onTextChanged(), TTextBox::raisePostDataChangedEvent(), TTextBox::renderBeginTag(), TTextBox::renderClientControlScript(), TTextBox::renderContents(), TTextBox::setAutoCompleteType(), TTextBox::setAutoPostBack(), TTextBox::setAutoTrim(), TTextBox::setCausesValidation(), TTextBox::setColumns(), TTextBox::setData(), TTextBox::setEnableClientScript(), TTextBox::setIsValid(), TTextBox::setMaxLength(), TTextBox::setPersistPassword(), TTextBox::setReadOnly(), TTextBox::setRows(), TTextBox::setText(), TTextBox::setTextMode(), TTextBox::setValidationGroup(), TTextBox::setWrap()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

addAttributesToRender

protected void addAttributesToRender (mixed $writer )

Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

Input
mixed $writer
Output
Exception

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback control options.
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by ICallbackEventHandler interface.

This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

Input
mixed $writer
Output
Exception

setText

public void setText (string $value )

Client-side Text property can only be updated after the OnLoad stage.

Input
string $value text content for the textbox
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TAutoComplete

Class TAutoComplete (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --TActiveTextBox
                  |
                  --TAutoComplete

TAutoComplete class.

TAutoComplete is a textbox that provides a list of suggestion on the current partial word typed in the textbox. The suggestions are requested using callbacks, and raises the onSuggestion event. The events of the TActiveText (from which TAutoComplete is extended from) and onSuggestion are mutually exculsive. That is, if onTextChange and/or OnCallback events are raise, then onSuggestion will not be raise, and vice versa.

The list of suggestions should be set in the onSuggestion event handler. The partial word to match the suggestion is in the TCallbackEventParameter::getCallbackParameter property. The datasource of the TAutoComplete must be set using setDataSource method. This sets the datasource for the suggestions repeater, available through the Suggestions property. Header, footer templates and other properties of the repeater can be access via the Suggestions property and its sub-properties.

The TextCssClass property if set is used to find the element within the Suggestions.ItemTemplate and Suggestions.AlternatingItemTemplate that contains the actual text for the suggestion selected. That is, only text inside elements with CSS class name equal to TextCssClass will be used as suggestions.

To return the list of suggestions back to the browser, supply a non-empty data source and call databind. For example,

1      function autocomplete_suggestion($sender, $param)
2      {
3        $token = $param->getToken(); //the partial word to match
4        $sender->setDataSource($this->getSuggestionsFor($token)); //set suggestions
5        $sender->dataBind();
6      }

The suggestion will be rendered when the dataBind() method is called <strong>during a callback request</strong>.

When an suggestion is selected, that is, when the use has clicked, pressed the "Enter" key, or pressed the "Tab" key, the OnSuggestionSelected event is raised. The TCallbackEventParameter::getCallbackParameter property contains the index of the selected suggestion.

TAutoComplete allows multiple suggestions within one textbox with each word or phrase separated by any characters specified in the Separator property. The Frequency and MinChars properties sets the delay and minimum number of characters typed, respectively, before requesting for sugggestions.

Use onTextChange and/or OnCallback events to handle post backs due to AutoPostBack.

In the Suggestions TRepater item template, all HTML text elements are considered as text for the suggestion. Text within HTML elements with CSS class name "informal" are ignored as text for suggestions.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TTextBox
DEFAULT_COLUMNS, DEFAULT_ROWS,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected TRepeater | createRepeater ()
protected TPanel | createResultPanel ()
void | dataBind () Overrides parent implementation. Callback renderSuggestions() when page's IsCallback property is true.
protected string | getClientClassName ()
float | getFrequency ()
integer | getMinChars ()
protected array | getPostBackOptions ()
TPanel | getResultPanel ()
string | getSeparator ()
TRepeater | getSuggestions ()
string | getTextCssClass ()
void | onSuggest ( TCallbackEventParameter $param) This method is invoked when an autocomplete suggestion is requested.
void | onSuggestionSelected ( TCallbackEventParameter $param) This method is invoked when an autocomplete suggestion is selected.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is overrides the parent implementation.
void | renderCallback ( THtmlWriter $writer) Renders the suggestions during a callback respones.
protected void | renderClientControlScript ( mixed $writer) Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
void | renderEndTag ( mixed $writer) Renders the end tag and registers javascript effects library.
protected void | renderResultPanel ( THtmlWriter $writer) Renders the result panel.
void | renderSuggestions ( THtmlWriter $writer) Renders the suggestions repeater.
void | setDataSource ( array $data)
void | setFrequency ( float $value)
void | setMinChars ( integer $value)
string | setSeparator ( mixed $value)
void | setTextCssClass ( string $value)
Methods Inherited From TActiveTextBox
TActiveTextBox::addAttributesToRender(), TActiveTextBox::getActiveControl(), TActiveTextBox::getClientClassName(), TActiveTextBox::getClientSide(), TActiveTextBox::onCallback(), TActiveTextBox::raiseCallbackEvent(), TActiveTextBox::renderClientControlScript(), TActiveTextBox::setText()
Methods Inherited From TTextBox
TTextBox::addAttributesToRender(), TTextBox::getAutoCompleteType(), TTextBox::getAutoPostBack(), TTextBox::getAutoTrim(), TTextBox::getCausesValidation(), TTextBox::getClientClassName(), TTextBox::getColumns(), TTextBox::getData(), TTextBox::getDataChanged(), TTextBox::getEnableClientScript(), TTextBox::getIsValid(), TTextBox::getMaxLength(), TTextBox::getPersistPassword(), TTextBox::getPostBackOptions(), TTextBox::getReadOnly(), TTextBox::getRows(), TTextBox::getSafeText(), TTextBox::getSafeTextParser(), TTextBox::getTagName(), TTextBox::getText(), TTextBox::getTextMode(), TTextBox::getValidationGroup(), TTextBox::getValidationPropertyValue(), TTextBox::getWrap(), TTextBox::loadPostData(), TTextBox::onTextChanged(), TTextBox::raisePostDataChangedEvent(), TTextBox::renderBeginTag(), TTextBox::renderClientControlScript(), TTextBox::renderContents(), TTextBox::setAutoCompleteType(), TTextBox::setAutoPostBack(), TTextBox::setAutoTrim(), TTextBox::setCausesValidation(), TTextBox::setColumns(), TTextBox::setData(), TTextBox::setEnableClientScript(), TTextBox::setIsValid(), TTextBox::setMaxLength(), TTextBox::setPersistPassword(), TTextBox::setReadOnly(), TTextBox::setRows(), TTextBox::setText(), TTextBox::setTextMode(), TTextBox::setValidationGroup(), TTextBox::setWrap()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

createRepeater

protected TRepeater createRepeater ()

Output
TRepeater new instance of TRepater to render the list of suggestions.
Exception

createResultPanel

protected TPanel createResultPanel ()

Output
TPanel new instance of result panel. Default uses TPanel.
Exception

dataBind

public void dataBind ()

Overrides parent implementation. Callback renderSuggestions() when page's IsCallback property is true.

Output
Exception

getClientClassName

protected string getClientClassName ()

Output
string corresponding javascript class name for this TActiveButton.
Exception

getFrequency

public float getFrequency ()

Output
float maximum delay (in seconds) before requesting a suggestion.
Exception

getMinChars

public integer getMinChars ()

Output
integer minimum number of characters before requesting a suggestion.
Exception

getPostBackOptions

protected array getPostBackOptions ()

Output
array list of callback options.
Exception

getResultPanel

public TPanel getResultPanel ()

Output
TPanel suggestion results panel.
Exception

getSeparator

public string getSeparator ()

Output
string word or token separators (delimiters).
Exception

getSuggestions

public TRepeater getSuggestions ()

Output
TRepeater suggestion list repeater
Exception

getTextCssClass

public string getTextCssClass ()

Output
string Css class name of the element to use for suggestion.
Exception

onSuggest

public void onSuggest (TCallbackEventParameter $param )

This method is invoked when an autocomplete suggestion is requested.

The method raises 'OnSuggest' event. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onSuggestionSelected

public void onSuggestionSelected (TCallbackEventParameter $param )

This method is invoked when an autocomplete suggestion is selected.

The method raises 'OnSuggestionSelected' event. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is overrides the parent implementation.

If AutoPostBack is enabled it will raise OnTextChanged event event and then the OnCallback event. The OnSuggest event is raise if the request is to find sugggestions, the OnTextChanged and OnCallback events are NOT raised. This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

renderCallback

public void renderCallback (THtmlWriter $writer )

Renders the suggestions during a callback respones.

Input
THtmlWriter $writer the renderer.
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.

Input
mixed $writer
Output
Exception

renderEndTag

public void renderEndTag (mixed $writer )

Renders the end tag and registers javascript effects library.

Input
mixed $writer
Output
Exception

renderResultPanel

protected void renderResultPanel (THtmlWriter $writer )

Renders the result panel.

Input
THtmlWriter $writer the renderer.
Output
Exception

renderSuggestions

public void renderSuggestions (THtmlWriter $writer )

Renders the suggestions repeater.

Input
THtmlWriter $writer the renderer.
Output
Exception

setDataSource

public void setDataSource (array $data )

Input
array $data data source for suggestions.
Output
Exception

setFrequency

public void setFrequency (float $value )

Input
float $value maximum delay (in seconds) before requesting a suggestion. Default is 0.4.
Output
Exception

setMinChars

public void setMinChars (integer $value )

Input
integer $value minimum number of characters before requesting a suggestion.
Output
Exception

setSeparator

public string setSeparator (mixed $value )

Input
mixed | $value
Output
string | word or token separators (delimiters).
Exception

setTextCssClass

public void setTextCssClass (string $value )

Input
string $value Css class name of the element to use for suggestion.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TAutoCompleteEventParameter

Class TAutoCompleteEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TCallbackEventParameter
         |
         --TAutoCompleteEventParameter

TAutCompleteEventParameter contains the getToken requested by the user for a partial match of the suggestions.

The SelectedIndex is a zero-based index of the suggestion selected by the user, -1 if not suggestion is selected.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Creates a new TCallbackEventParameter.
Method Summary
int | getSelectedIndex ()
string | getToken ()
Methods Inherited From TCallbackEventParameter
TCallbackEventParameter::getCallbackParameter(), TCallbackEventParameter::getNewWriter(), TCallbackEventParameter::getResponseData(), TCallbackEventParameter::setResponseData()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Creates a new TCallbackEventParameter.
Method Details

getSelectedIndex

public int getSelectedIndex ()

Output
int selected suggestion zero-based index, -1 if not selected.
Exception

getToken

public string getToken ()

Output
string token for matching a list of suggestions.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TAutoCompleteTemplate

Class TAutoCompleteTemplate (Class Overview)

TComponent
   |
   --TAutoCompleteTemplate

TAutoCompleteTemplate class.

TAutoCompleteTemplate is the default template for TAutoCompleteTemplate item template.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Method Summary
void
instantiateIn ( TControl $parent)
Instantiates the template.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Method Details

instantiateIn

public void instantiateIn (TControl $parent )

Instantiates the template.

It creates a TDataList control.

Input
TControl $parent parent to hold the content within the template
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TBaseActiveCallbackControl

Class TBaseActiveCallbackControl (Class Overview)

TComponent
   |
   --TBaseActiveControl
      |
      --TBaseActiveCallbackControl

TBaseActiveCallbackControl is a common set of options and functionality for active controls that can perform callback requests.

The properties of TBaseActiveCallbackControl can be accessed and changed from each individual active controls' getActiveControl property.

The following example to set the validation group property of a TCallback component.

1          <com:TCallback ActiveControl.ValidationGroup="group1" ... />

Additional client-side options and events can be set using the ClientSide property. The following example to show an alert box when a TCallback component response returns successfully.

1          <com:TCallback Active.Control.ClientSide.OnSuccess="alert('ok!')" ... />

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
boolean | canCauseValidation ()
protected TCallbackClientSide | createClientSide ()
string | getCallbackOptions ()
mixed | getCallbackParameter ()
boolean | getCausesValidation ()
TCallbackClientSide | getClientSide () Callback client-side options can be set by setting the properties of the ClientSide property. E.g. <com:TCallback ActiveControl.ClientSide.OnSuccess="..." /> See TCallbackClientSide for details on the properties of ClientSide.
protected array | getClientSideOptions ()
protected array | getDefaultClientSideOptions () Returns an array of default callback client-side options. The default options are obtained from the client-side options of a TCallbackOptions control with ID specified by setCallbackOptionsID.
string | getJavascript () Returns the javascript callback request instance. To invoke a callback
void | getJsCallbackOptions ( string 0)
string | getValidationGroup ()
void | registerCallbackClientScript ( string $class, array $options) Registers the callback control javascript code. Client-side options are
void | setCallbackOptions ( string $value) Sets default callback options. Takes the ID of a TCallbackOptions component to duplicate the client-side options for this control. The getClientSide subproperties has precendent over the CallbackOptions property.
void | setCallbackParameter ( mixed $value)
void | setCausesValidation ( boolean $value)
void | setClientSide ( TCallbackClientSide $client) Sets the client side options. Can only be set when client side is null.
void | setValidationGroup ( string $value)
Methods Inherited From TBaseActiveControl
TBaseActiveControl::canUpdateClientSide(), TBaseActiveControl::getControl(), TBaseActiveControl::getEnableUpdate(), TBaseActiveControl::getOption(), TBaseActiveControl::getOptions(), TBaseActiveControl::getPage(), TBaseActiveControl::setEnableUpdate(), TBaseActiveControl::setOption()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

canCauseValidation

public boolean canCauseValidation ()

Output
boolean whether to perform validation if the callback is requested.
Exception

createClientSide

protected TCallbackClientSide createClientSide ()

Output
TCallbackClientSide callback client-side options.
Exception

getCallbackOptions

public string getCallbackOptions ()

Output
string ID of a TCallbackOptions control from which ClientSide options are duplicated.
Exception

getCallbackParameter

public mixed getCallbackParameter ()

Output
mixed callback parameter value.
Exception

getCausesValidation

public boolean getCausesValidation ()

Output
boolean whether callback event trigger by this button will cause input validation, default is true
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Callback client-side options can be set by setting the properties of the ClientSide property. E.g. <com:TCallback ActiveControl.ClientSide.OnSuccess="..." /> See TCallbackClientSide for details on the properties of ClientSide.

Output
TCallbackClientSide client-side callback options.
Exception

getClientSideOptions

protected array getClientSideOptions ()

Output
array list of callback javascript options.
Exception

getDefaultClientSideOptions

protected array getDefaultClientSideOptions ()

Returns an array of default callback client-side options. The default options are obtained from the client-side options of a TCallbackOptions control with ID specified by setCallbackOptionsID.

Output
array list of default callback client-side options.
Exception

getJavascript

public string getJavascript ()

Returns the javascript callback request instance. To invoke a callback

request for this control call the <tt>dispatch()</tt> method on the request instance. Example code in javascript

1        var request = <%= $this->mycallback->ActiveControl->Javascript %>;
2        request.setParameter('hello');
2        request.dispatch(); //make the callback request.

Alternatively,

1      //dispatches immediately
2       Prado.Callback("<%= $this->mycallback->UniqueID %>",
3         $this->mycallback->ActiveControl->JsCallbackOptions);

Output
string javascript client-side callback request object (javascript code)
Exception

getJsCallbackOptions

public void getJsCallbackOptions (string 0 )

Input
string 0 callback requestion options as javascript code.
Output
Exception

getValidationGroup

public string getValidationGroup ()

Output
string the group of validators which the button causes validation upon callback
Exception

registerCallbackClientScript

public void registerCallbackClientScript (string $class , array $options )

Registers the callback control javascript code. Client-side options are

merged and passed to the javascript code. This method should be called by Active component developers wanting to register the javascript to initialize the active component with additional options offered by the ClientSide property.

Input
string | $class | client side javascript class name.
array | $options | additional callback options.
Output
Exception

setCallbackOptions

public void setCallbackOptions (string $value )

Sets default callback options. Takes the ID of a TCallbackOptions component to duplicate the client-side options for this control. The getClientSide subproperties has precendent over the CallbackOptions property.

Input
string $value ID of a TCallbackOptions control from which ClientSide options are cloned.
Output
Exception

setCallbackParameter

public void setCallbackParameter (mixed $value )

Input
mixed $value callback parameter value.
Output
Exception

setCausesValidation

public void setCausesValidation (boolean $value )

Input
boolean $value whether callback event trigger by this button will cause input validation
Output
Exception

setClientSide

public void setClientSide (TCallbackClientSide $client )

Sets the client side options. Can only be set when client side is null.

Input
TCallbackClientSide $client client side options.
Output
Exception

setValidationGroup

public void setValidationGroup (string $value )

Input
string $value the group of validators which the button causes validation upon callback
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TBaseActiveControl

Class TBaseActiveControl (Class Overview)

TComponent
   |
   --TBaseActiveControl

Direct Known Sub-classes:

TBaseActiveCallbackControl

TBaseActiveControl class provided additional basic property for every active control. An instance of TBaseActiveControl or its decendent TBaseActiveCallbackControl is created by TActiveControlAdapter::getBaseActiveControl() method.

The EnableUpdate property determines wether the active control is allowed to update the contents of the client-side when the callback response returns.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gamil[dot]com>
Constructor Summary
public
__construct Array
Constructor. Attach a base active control to an active control instance.
Method Summary
boolean | canUpdateClientSide () Returns true if callback response is allowed to update the browser contents.
protected TControl | getControl ()
boolean | getEnableUpdate ()
protected mixed | getOption ( string $name, mixed $default) Gets an option named value. Options are used to store and retrive named values for the base active controls.
protected TMap | getOptions ()
protected TPage | getPage ()
void | setEnableUpdate ( boolean $value)
protected mixed | setOption ( string $name, mixed $value, mixed $default) Sets a named options with a value. Options are used to store and retrive named values for the base active controls.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor. Attach a base active control to an active control instance.
Method Details

canUpdateClientSide

public boolean canUpdateClientSide ()

Returns true if callback response is allowed to update the browser contents.

Is is true if the control is initilized, and is a callback request and the EnabledUpdate property is true and the page is not loading post data.

Output
boolean true if the callback response is allowed update client-side contents.
Exception

getControl

protected TControl getControl ()

Output
TControl the attached control.
Exception

getEnableUpdate

public boolean getEnableUpdate ()

Output
boolean true to allow fine grain callback updates.
Exception

getOption

protected mixed getOption (string $name , mixed $default )

Gets an option named value. Options are used to store and retrive named values for the base active controls.

Input
string | $name | option name.
mixed | $default | default value.
Output
mixed | options value.
Exception

getOptions

protected TMap getOptions ()

Output
TMap active control options
Exception

getPage

protected TPage getPage ()

Output
TPage the page containing the attached control.
Exception

setEnableUpdate

public void setEnableUpdate (boolean $value )

Input
boolean $value true to allow fine grain callback updates.
Output
Exception

setOption

protected mixed setOption (string $name , mixed $value , mixed $default )

Sets a named options with a value. Options are used to store and retrive named values for the base active controls.

Input
string | $name | option name.
mixed | $value | new value.
mixed | $default | default value.
Output
mixed | options value.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCallback

Class TCallback (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCallback

Direct Known Sub-classes:

TTimeTriggeredCallback , TTriggeredCallback

TCallback component class.

The TCallback provides a basic callback handler that can be invoke from the client side by running the javascript code obtained from the TBaseActiveCallbackControl::getJavascript property. The event OnCallback is raise when a callback is requested made.

Example usage:

1          <com:TCallback ID="callback1" OnCallback="callback1_Requested" />
2       <script type="text/javascript">
3              function do_callback1()
4           {
5                var request = <%= $this->callback1->ActiveControl->Javascript %>;
6                  request.dispatch();
7           }
8       </script>
9       <div onclick="do_callback1()">Click Me!</div>

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, call this constructor.
Method Summary
TBaseActiveCallbackControl | getActiveControl ()
TCallbackClientSide | getClientSide ()
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises the callback event. This method is required by ICallbackEventHandler interface. If getCausesValidation is true, it will invoke the page's TPage::validate method first.
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, call this constructor.
Method Details

getActiveControl

public TBaseActiveCallbackControl getActiveControl ()

Output
TBaseActiveCallbackControl standard callback options.
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises the callback event. This method is required by ICallbackEventHandler interface. If getCausesValidation is true, it will invoke the page's TPage::validate method first.

It will raise OnCallback event. This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the event parameter
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCallbackClientScript

Class TCallbackClientScript (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TCallbackClientScript

TCallbackClientScript class.

The TCallbackClientScript class provides corresponding methods that can be executed on the client-side (i.e. the browser client that is viewing the page) during a callback response.

The avaiable methods includes setting/clicking input elements, changing Css styles, hiding/showing elements, and adding visual effects to elements on the page. The client-side methods can be access through the CallbackClient property available in TPage.

For example, to hide "$myTextBox" element during callback response, do

1      $this->getPage()->getCallbackClient()->hide($myTextBox);

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gamil[dot]com>
Constructor Summary
public
__construct
Constructor.
Method Summary
void | addCssClass ( TControl $element, string $cssClass) Add a Css class name to the element.
void | addPostDataLoader ( mixed $name)
void | appear ( TControl $element, array $options) Visual Effect: Gradually make the element appear.
void | appendContent ( TControl $element, string $content) Append a HTML fragement to the element.
void | blindDown ( TControl $element, array $options) Visual Effect: Blind down.
void | blindUp ( TControl $element, array $options) Visual Effect: Blind up.
void | callClientFunction ( string $function, array $params) Executes a client-side statement.
void | check ( TControl $checkbox, boolean $checked) Client script to check or uncheck a checkbox or radio button.
void | click ( TControl $control) Client script to click on an element. This client-side function is unpredictable.
void | dropOut ( TControl $element, array $options) Visual Effect: Drop out.
void | evaluateScript ( THtmlWriter $writer) Evaluate a block of javascript enclosed in a boundary.
void | fade ( TControl $element, array $options) Visual Effect: Gradually fade the element.
void | focus ( TControl $element) Focus on a particular element.
void | fold ( TControl $element, array $options) Visual Effect: Fold.
array | getClientFunctionsToExecute ()
void | grow ( TControl $element, array $options) Visual Effect: Gradually make an element grow to a predetermined size.
void | hide ( TControl $element) Hides an element by changing its CSS display style to "none".
void | highlight ( TControl $element, array $options) Visual Effect: High light the element for about 2 seconds.
void | insertContentAfter ( TControl $element, string $content) Insert a HTML fragement after the element.
void | insertContentBefore ( TControl $element, string $content) Insert a HTML fragement in before the element.
void | prependContent ( TControl $element, string $content) Prepend a HTML fragement to the element.
void | puff ( TControl $element, array $options) Visual Effect: Gradually grow and fade the element.
void | pulsate ( TControl $element, array $options) Visual Effect: Pulsate.
void | raiseClientEvent ( TControl $control, string $eventName) Raise the client side event (given by $eventName) on a particular element.
void | remove ( TControl $element) Removes an element from the HTML page.
void | removeCssClass ( TControl $element, string $cssClass) Remove a Css class name from the element.
protected void | replace ( TControl $element, string $content, string $method, string $boundary) Replace the content of an element with new content. The new content can be a string or a TControl component. If the <tt>content</tt> parameter is a TControl component, its rendered method will be called and its contents will be used for replacement.
void | replaceContent ( TControl $element, string $content) Replace the content of an element with new content contained in writer.
void | scrollTo ( TControl $element) Scroll the top of the browser viewing area to the location of the element.
void | select ( TControl $control, string $method, string|int $value, string $type) Client script to select/clear/check a drop down list, check box list, or radio button list.
void | setAttribute ( TControl $control, string $name, string $value) Sets the attribute of a particular control.
void | setListItems ( TControl $control, TCollection $items) Sets the options of a select input element.
void | setOpacity ( TControl $element, float $value) Set the opacity on a html element or control.
void | setStyle ( TControl $element, array $styles) Sets the style of element. The style must be a key-value array where the key is the style property and the value is the style value.
void | setValue ( TControl $input, string $text) Client script to set the value of a particular input element.
void | shake ( TControl $element, array $options) Visual Effect: Shake the element.
void | show ( TControl $element) Shows an element by changing its CSS display style as empty.
void | shrink ( TControl $element, array $options) Visual Effect: Shrink the element.
void | slideDown ( TControl $element, array $options) Visual Effect: Slide down.
void | slideUp ( TControl $element, array $options) Visual Effect: Side up.
void | squish ( TControl $element, array $options) Visual Effect: Squish the element.
void | switchOff ( TControl $element, array $options) Visual Effect: Switch Off effect.
void | toggle ( TControl $element, string $effect, array $options) Toggles the visibility of the element.
void | update ( TControl $element, TControl $content) Update the element's innerHTML with new content.
void | visualEffect ( string $type, TControl $element, array $options) Add a visual effect the element.
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct

Constructor.
Method Details

addCssClass

public void addCssClass (TControl $element , string $cssClass )

Add a Css class name to the element.

Input
TControl | $element | control element or element id
string | $cssClass | CssClass name to add.
Output
Exception

addPostDataLoader

public void addPostDataLoader (mixed $name )

Input
mixed $name
Output
Exception

appear

public void appear (TControl $element , array $options )

Visual Effect: Gradually make the element appear.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

appendContent

public void appendContent (TControl $element , string $content )

Append a HTML fragement to the element.

Input
TControl | $element | control element or element id
string | $content | HTML fragement or the control to be rendered
Output
Exception

blindDown

public void blindDown (TControl $element , array $options )

Visual Effect: Blind down.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

blindUp

public void blindUp (TControl $element , array $options )

Visual Effect: Blind up.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

callClientFunction

public void callClientFunction (string $function , array $params )

Executes a client-side statement.

Input
string | $function | javascript function name
array | $params | list of arguments for the function
Output
Exception

check

public void check (TControl $checkbox , boolean $checked )

Client script to check or uncheck a checkbox or radio button.

Input
TControl | $checkbox | control element or element id
boolean | $checked | check or uncheck the checkbox or radio button.
Output
Exception

click

public void click (TControl $control )

Client script to click on an element. This client-side function is unpredictable.

Input
TControl $control control element or element id
Output
Exception

dropOut

public void dropOut (TControl $element , array $options )

Visual Effect: Drop out.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

evaluateScript

public void evaluateScript (THtmlWriter $writer )

Evaluate a block of javascript enclosed in a boundary.

Input
THtmlWriter $writer writer for the content.
Output
Exception

fade

public void fade (TControl $element , array $options )

Visual Effect: Gradually fade the element.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

focus

public void focus (TControl $element )

Focus on a particular element.

Input
TControl $element control element or element id.
Output
Exception

fold

public void fold (TControl $element , array $options )

Visual Effect: Fold.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

getClientFunctionsToExecute

public array getClientFunctionsToExecute ()

Output
array list of client function to be executed during callback response.
Exception

grow

public void grow (TControl $element , array $options )

Visual Effect: Gradually make an element grow to a predetermined size.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

hide

public void hide (TControl $element )

Hides an element by changing its CSS display style to "none".

Input
TControl $element control element or element id
Output
Exception

highlight

public void highlight (TControl $element , array $options )

Visual Effect: High light the element for about 2 seconds.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

insertContentAfter

public void insertContentAfter (TControl $element , string $content )

Insert a HTML fragement after the element.

Input
TControl | $element | control element or element id
string | $content | HTML fragement or the control to be rendered
Output
Exception

insertContentBefore

public void insertContentBefore (TControl $element , string $content )

Insert a HTML fragement in before the element.

Input
TControl | $element | control element or element id
string | $content | HTML fragement or the control to be rendered
Output
Exception

prependContent

public void prependContent (TControl $element , string $content )

Prepend a HTML fragement to the element.

Input
TControl | $element | control element or element id
string | $content | HTML fragement or the control to be rendered
Output
Exception

puff

public void puff (TControl $element , array $options )

Visual Effect: Gradually grow and fade the element.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

pulsate

public void pulsate (TControl $element , array $options )

Visual Effect: Pulsate.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

raiseClientEvent

public void raiseClientEvent (TControl $control , string $eventName )

Raise the client side event (given by $eventName) on a particular element.

Input
TControl | $control | control element or element id
string | $eventName | Event name, e.g. "click"
Output
Exception

remove

public void remove (TControl $element )

Removes an element from the HTML page.

Input
TControl $element control element or element id
Output
Exception

removeCssClass

public void removeCssClass (TControl $element , string $cssClass )

Remove a Css class name from the element.

Input
TControl | $element | control element or element id
string | $cssClass | CssClass name to remove.
Output
Exception

replace

protected void replace (TControl $element , string $content , string $method , string $boundary )

Replace the content of an element with new content. The new content can be a string or a TControl component. If the <tt>content</tt> parameter is a TControl component, its rendered method will be called and its contents will be used for replacement.

Input
TControl | $element | control element or HTML element id.
string | $content | HTML fragement or the control to be rendered
string | $method | replacement method, default is to replace the outter html content.
string | $boundary | provide a custom boundary.
Output
Exception

replaceContent

public void replaceContent (TControl $element , string $content )

Replace the content of an element with new content contained in writer.

Input
TControl | $element | control element or HTML element id.
string | $content | HTML fragement or the control to be rendered
Output
Exception

scrollTo

public void scrollTo (TControl $element )

Scroll the top of the browser viewing area to the location of the element.

Input
TControl $element control element or element id
Output
Exception

select

public void select (TControl $control , string $method , string|int $value , string $type )

Client script to select/clear/check a drop down list, check box list, or radio button list.

The second parameter determines the selection method. Valid methods are

  • Value, select or check by value
  • Values, select or check by a list of values
  • Index, select or check by index (zero based index)
  • Indices, select or check by a list of index (zero based index)
  • Clear, clears or selections or checks in the list
  • All, select all
  • Invert, invert the selection.

Input
TControl | $control | list control
string | $method | selection method
string|int | $value | the value or index to select/check.
string | $type | selection control type, either 'check' or 'select'
Output
Exception

setAttribute

public void setAttribute (TControl $control , string $name , string $value )

Sets the attribute of a particular control.

Input
TControl | $control | control element or element id
string | $name | attribute name
string | $value | attribute value
Output
Exception

setListItems

public void setListItems (TControl $control , TCollection $items )

Sets the options of a select input element.

Input
TControl | $control | control element or element id
TCollection | $items | a list of new options
Output
Exception

setOpacity

public void setOpacity (TControl $element , float $value )

Set the opacity on a html element or control.

Input
TControl | $element | control element or element id
float | $value | opacity value between 1 and 0
Output
Exception

setStyle

public void setStyle (TControl $element , array $styles )

Sets the style of element. The style must be a key-value array where the key is the style property and the value is the style value.

Input
TControl | $element | control element or element id
array | $styles | list of key-value pairs as style property and style value.
Output
Exception

setValue

public void setValue (TControl $input , string $text )

Client script to set the value of a particular input element.

Input
TControl | $input | control element to set the new value
string | $text | new value
Output
Exception

shake

public void shake (TControl $element , array $options )

Visual Effect: Shake the element.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

show

public void show (TControl $element )

Shows an element by changing its CSS display style as empty.

Input
TControl $element control element or element id
Output
Exception

shrink

public void shrink (TControl $element , array $options )

Visual Effect: Shrink the element.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

slideDown

public void slideDown (TControl $element , array $options )

Visual Effect: Slide down.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

slideUp

public void slideUp (TControl $element , array $options )

Visual Effect: Side up.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

squish

public void squish (TControl $element , array $options )

Visual Effect: Squish the element.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

switchOff

public void switchOff (TControl $element , array $options )

Visual Effect: Switch Off effect.

Input
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception

toggle

public void toggle (TControl $element , string $effect , array $options )

Toggles the visibility of the element.

Input
TControl | $element | control element or element id
string | $effect | visual effect, such as, 'appear' or 'slide' or 'blind'.
array | $options | additional options.
Output
Exception

update

public void update (TControl $element , TControl $content )

Update the element's innerHTML with new content.

Input
TControl | $element | control element or element id
TControl | $content | new HTML content, if content is of a TControl, the controls render method is called.
Output
Exception

visualEffect

public void visualEffect (string $type , TControl $element , array $options )

Add a visual effect the element.

Input
string | $type | visual effect function name.
TControl | $element | control element or element id
array | $options | visual effect key-value pair options.
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCallbackClientSide

Class TCallbackClientSide (Class Overview)

TComponent
   |
   --TClientSideOptions
      |
      --TCallbackClientSide

Direct Known Sub-classes:

TActiveCustomValidatorClientSide

TCallbackClientSide class.

The following client side events are executing in order if the callback request and response are send and received successfuly.

  • onPreDispatch executed before a request is dispatched.
  • onUninitialized executed when callback request is uninitialized.
  • onLoading* executed when callback request is initiated
  • onLoaded* executed when callback request begins.
  • onInteractive executed when callback request is in progress.
  • onCompleteexecuted when callback response returns.
* Note that theses 2 events are not fired correctly by Opera. To make them work in this browser, Prado will fire them just after onPreDispatch.

In a general way, onUninitialized, onLoading, onLoaded and onInteractive events are not implemented consistently in all browsers.When cross browser compatibility is needed, it is best to avoid use them

The OnSuccess and OnFailure events are raised when the response is returned. A successful request/response will raise OnSuccess event otherwise OnFailure will be raised.

  • onSuccess executed when callback request returns and is successful.
  • onFailure executed when callback request returns and fails.
  • onException raised when callback request fails due to request/response errors.
  • PostState true to collect the form inputs and post them during callback, default is true.
  • RequestTimeOut The request timeout in milliseconds.
  • HasPriority true to ensure that the callback request will be sent immediately and will abort existing prioritized requests. It does not affect callbacks that are not prioritized.
  • EnablePageStateUpdate enable the callback response to enable the viewstate update. This will automatically set HasPrority to true when enabled.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gamil[dot]com>
Method Summary
protected string | ensureFunction ( string $javascript) Returns javascript statement enclosed within a javascript function.
boolean | getEnablePageStateUpdate ()
boolean | getHasPriority ()
string | getOnComplete ()
string | getOnException ()
string | getOnFailure ()
string | getOnInteractive ()
string | getOnLoaded ()
string | getOnLoading ()
string | getOnPreDispatch ()
string | getOnSuccess ()
string | getOnUninitialized ()
string | getPostBackParameter ()
string | getPostBackTarget ()
boolean | getPostState ()
integer | getRequestTimeOut ()
void | setEnablePageStateUpdate ( boolean $value) Set to true to enable the callback response to enable the viewstate update. This will automatically set HasPrority to true.
void | setHasPriority ( boolean $value)
void | setOnComplete ( string $javascript)
void | setOnException ( string $javascript)
void | setOnFailure ( string $javascript)
void | setOnInteractive ( string $javascript)
void | setOnLoaded ( string $javascript)
void | setOnLoading ( string $javascript)
void | setOnPreDispatch ( string $javascript)
void | setOnSuccess ( string $javascript)
void | setOnUninitialized ( string $javascript)
void | setPostBackParameter ( string $value)
void | setPostBackTarget ( string $value)
void | setPostState ( boolean $value)
void | setRequestTimeOut ( integer $value)
Methods Inherited From TClientSideOptions
TClientSideOptions::ensureFunction(), TClientSideOptions::getOption(), TClientSideOptions::getOptions(), TClientSideOptions::setFunction(), TClientSideOptions::setOption()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

ensureFunction

protected string ensureFunction (string $javascript )

Returns javascript statement enclosed within a javascript function.

Input
string | $javascript | javascript statement, if string begins within "javascript:" the whole string is assumed to be a function.
Output
string | javascript statement wrapped in a javascript function
Exception

getEnablePageStateUpdate

public boolean getEnablePageStateUpdate ()

Output
boolean client-side viewstate will be updated on callback response if true. Default is true.
Exception

getHasPriority

public boolean getHasPriority ()

Output
boolean true if the callback request has priority and will abort existing prioritized request in order to send immediately. It does not affect callbacks that are not prioritized. Default is true.
Exception

getOnComplete

public string getOnComplete ()

Output
string javascript code for client-side onComplete event
Exception

getOnException

public string getOnException ()

Output
string javascript code for client-side onException event
Exception

getOnFailure

public string getOnFailure ()

Output
string javascript code for client-side onFailure event
Exception

getOnInteractive

public string getOnInteractive ()

Output
string javascript code for client-side onInteractive event
Exception

getOnLoaded

public string getOnLoaded ()

Output
string javascript code for client-side onLoaded event
Exception

getOnLoading

public string getOnLoading ()

Output
string javascript code for client-side onLoading event
Exception

getOnPreDispatch

public string getOnPreDispatch ()

Output
string javascript code to be executed before a request is dispatched.
Exception

getOnSuccess

public string getOnSuccess ()

Output
string javascript code for client-side onSuccess event
Exception

getOnUninitialized

public string getOnUninitialized ()

Output
string javascript code for client-side onUninitialized event
Exception

getPostBackParameter

public string getPostBackParameter ()

Output
string post back event parameter.
Exception

getPostBackTarget

public string getPostBackTarget ()

Output
string post back target ID
Exception

getPostState

public boolean getPostState ()

Output
boolean true to post the inputs of the form on callback, default is post the inputs on callback.
Exception

getRequestTimeOut

public integer getRequestTimeOut ()

Output
integer callback request timeout.
Exception

setEnablePageStateUpdate

public void setEnablePageStateUpdate (boolean $value )

Set to true to enable the callback response to enable the viewstate update. This will automatically set HasPrority to true.

Input
boolean $value true enables the callback response to update the viewstate.
Output
Exception

setHasPriority

public void setHasPriority (boolean $value )

Input
boolean $value true to ensure that the callback request will be sent immediately and will abort existing prioritized requests. It does not affect callbacks that are not prioritized.
Output
Exception

setOnComplete

public void setOnComplete (string $javascript )

Input
string $javascript javascript code for client-side onComplete event.
Output
Exception

setOnException

public void setOnException (string $javascript )

Input
string $javascript javascript code for client-side onException event.
Output
Exception

setOnFailure

public void setOnFailure (string $javascript )

Input
string $javascript javascript code for client-side onFailure event.
Output
Exception

setOnInteractive

public void setOnInteractive (string $javascript )

Input
string $javascript javascript code for client-side onInteractive event.
Output
Exception

setOnLoaded

public void setOnLoaded (string $javascript )

Input
string $javascript javascript code for client-side onLoaded event.
Output
Exception

setOnLoading

public void setOnLoading (string $javascript )

Input
string $javascript javascript code for client-side onLoading event.
Output
Exception

setOnPreDispatch

public void setOnPreDispatch (string $javascript )

Input
string $javascript javascript code to be executed before a request is dispatched.
Output
Exception

setOnSuccess

public void setOnSuccess (string $javascript )

Input
string $javascript javascript code for client-side onSuccess event.
Output
Exception

setOnUninitialized

public void setOnUninitialized (string $javascript )

Input
string $javascript javascript code for client-side onUninitialized event.
Output
Exception

setPostBackParameter

public void setPostBackParameter (string $value )

Input
string $value post back event parameter.
Output
Exception

setPostBackTarget

public void setPostBackTarget (string $value )

Input
string $value post back target ID
Output
Exception

setPostState

public void setPostState (boolean $value )

Input
boolean $value true to post the inputs of the form with callback requests. Default is to post the inputs.
Output
Exception

setRequestTimeOut

public void setRequestTimeOut (integer $value )

Input
integer $value callback request timeout
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCallbackEventParameter

Class TCallbackEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TCallbackEventParameter

Direct Known Sub-classes:

TAutoCompleteEventParameter

TCallbackEventParameter class.

The TCallbackEventParameter provides the parameter passed during the callback requestion in the CallbackParameter property. The callback response content (e.g. new HTML content) must be rendered using an THtmlWriter obtained from the NewWriter property, which returns a NEW instance of TCallbackResponseWriter.

Each instance TCallbackResponseWriter is associated with a unique boundary delimited. By default each panel only renders its own content. To replace the content of ONE panel with that of rendered from multiple panels use the same writer instance for the panels to be rendered.

The response data (i.e., passing results back to the client-side callback handler function) can be set using ResponseData property.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gamil[dot]com>
Constructor Summary
public
__construct Array
Creates a new TCallbackEventParameter.
Method Summary
mixed | getCallbackParameter ()
TCallbackResponseWriter | getNewWriter ()
mixed | getResponseData ()
void | setResponseData ( mixed $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Creates a new TCallbackEventParameter.
Method Details

getCallbackParameter

public mixed getCallbackParameter ()

Output
mixed callback request parameter.
Exception

getNewWriter

public TCallbackResponseWriter getNewWriter ()

Output
TCallbackResponseWriter holds the response content.
Exception

getResponseData

public mixed getResponseData ()

Output
mixed callback response data.
Exception

setResponseData

public void setResponseData (mixed $value )

Input
mixed $value callback response data.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCallbackOptions

Class TCallbackOptions (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCallbackOptions

TCallbackOptions class.

TCallbackOptions allows common set of callback client-side options to be attached to other active controls.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected TCallbackClientSide | createClientSide ()
TCallbackClientSide | getClientSide () Callback client-side options can be set by setting the properties of the ClientSide property. E.g. <com:TCallbackOptions ClientSide.OnSuccess="..." /> See TCallbackClientSide for details on the properties of ClientSide.
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

createClientSide

protected TCallbackClientSide createClientSide ()

Output
TCallbackClientSide callback client-side options.
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Callback client-side options can be set by setting the properties of the ClientSide property. E.g. <com:TCallbackOptions ClientSide.OnSuccess="..." /> See TCallbackClientSide for details on the properties of ClientSide.

Output
TCallbackClientSide client-side callback options.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCallbackResponseAdapter

Class TCallbackResponseAdapter (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --THttpResponseAdapter
         |
         --TCallbackResponseAdapter

TCallbackResponseAdapter alters the THttpResponse's outputs.

A TCallbackResponseWriter is used instead of the TTextWrite when createHtmlWriter is called. Each call to createHtmlWriter will create a new TCallbackResponseWriter. When flushContent() is called each instance of TCallbackResponseWriter's content is flushed.

The callback response data can be set using the ResponseData property.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
void | createNewHtmlWriter ( string $type, THttpResponse $response) Returns a new instance of THtmlWriter.
void | flushContent () Flushes the contents in the writers.
string | getRedirectedUrl ()
mixed | getResponseData ()
void | httpRedirect ( string $url) Delay the redirect until we process the rest of the page.
void | setResponseData ( mixed $data)
Methods Inherited From THttpResponseAdapter
THttpResponseAdapter::createNewHtmlWriter(), THttpResponseAdapter::flushContent(), THttpResponseAdapter::getResponse(), THttpResponseAdapter::httpRedirect()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createNewHtmlWriter

public void createNewHtmlWriter (string $type , THttpResponse $response )

Returns a new instance of THtmlWriter.

An instance of TCallbackResponseWriter is created to hold the content.

Input
string | $type | writer class name.
THttpResponse | $response | http response handler.
Output
Exception

flushContent

public void flushContent ()

Flushes the contents in the writers.

Output
Exception

getRedirectedUrl

public string getRedirectedUrl ()

Output
string new url for callback response to redirect to.
Exception

getResponseData

public mixed getResponseData ()

Output
mixed callback response data.
Exception

httpRedirect

public void httpRedirect (string $url )

Delay the redirect until we process the rest of the page.

Input
string $url new url to redirect to.
Output
Exception

setResponseData

public void setResponseData (mixed $data )

Input
mixed $data callback response data.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCallbackResponseWriter

Class TCallbackResponseWriter (Class Overview)

TComponent
   |
   --TTextWriter
      |
      --TCallbackResponseWriter

TCallbackResponseWriter class.

TCallbackResponseWriter class enclosed a chunck of content within a html comment boundary. This allows multiple chuncks of content to return in the callback response and update multiple HTML elements.

The Boundary property sets boundary identifier in the HTML comment that forms the boundary. By default, the boundary identifier is generated using microtime.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constructor Summary
public
__construct
Constructor. Generates unique boundary ID using microtime.
Method Summary
string | flush () Returns the text content wrapped within a HTML comment with boundary identifier as its comment content.
string | getBoundary ()
void | setBoundary ( string $value)
Methods Inherited From TTextWriter
TTextWriter::flush(), TTextWriter::write(), TTextWriter::writeLine()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct

Constructor. Generates unique boundary ID using microtime.
Method Details

flush

public string flush ()

Returns the text content wrapped within a HTML comment with boundary identifier as its comment content.

Output
string text content chunck.
Exception

getBoundary

public string getBoundary ()

Output
string boundary identifier.
Exception

setBoundary

public void setBoundary (string $value )

Input
string $value boundary identifier.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDraggable

Class TDraggable (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPanel
               |
               --TDraggable

TDraggable is a control which can be dragged

This control will make "draggable" control.

License: http://www.pradosoft.com/license
Copyright: Copyright &copy; 2008, PradoSoft
Author: Christophe BOULAIN (Christophe.Boulain@gmail.com)
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( mixed $writer) Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
CDraggableConstraint | getConstraint () Determine if the element should be constrainted in one direction or not
boolean | getGhosting () Determine if the element should be cloned when dragged If true, Clones the element and drags the clone, leaving the original in place until the clone is dropped.
string | getHandle () Get the handle id or css class
protected array | getPostBackOptions () Gets the post back options for this textbox.
boolean | getRevert () Determine if draggable element should revert to it orginal position upon release in an non-droppable container.
void | setConstraint ( CDraggableConstraint $value) Set wether the element should be constrainted in one direction
boolean | setGhosting ( mixed $value) Sets wether the element should be cloned when dragged If true, Clones the element and drags the clone, leaving the original in place until the clone is dropped.
void | setHandle ( string $value) Set the handle id or css class
void | setRevert ( boolean $value) Sets whether the draggable element should revert to it orginal position upon release in an non-droppable container.
Methods Inherited From TPanel
TPanel::addAttributesToRender(), TPanel::createStyle(), TPanel::getBackImageUrl(), TPanel::getDefaultButton(), TPanel::getDirection(), TPanel::getGroupingText(), TPanel::getHorizontalAlign(), TPanel::getScrollBars(), TPanel::getTagName(), TPanel::getWrap(), TPanel::renderBeginTag(), TPanel::renderEndTag(), TPanel::setBackImageUrl(), TPanel::setDefaultButton(), TPanel::setDirection(), TPanel::setGroupingText(), TPanel::setHorizontalAlign(), TPanel::setScrollBars(), TPanel::setWrap()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (mixed $writer )

Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

Input
mixed $writer
Output
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getConstraint

public CDraggableConstraint getConstraint ()

Determine if the element should be constrainted in one direction or not

Output
Exception

getGhosting

public boolean getGhosting ()

Determine if the element should be cloned when dragged If true, Clones the element and drags the clone, leaving the original in place until the clone is dropped.

Defaults to false

Output
boolean true to clone the element
Exception

getHandle

public string getHandle ()

Get the handle id or css class

Output
Exception

getPostBackOptions

protected array getPostBackOptions ()

Gets the post back options for this textbox.

Output
Exception

getRevert

public boolean getRevert ()

Determine if draggable element should revert to it orginal position upon release in an non-droppable container.

Output
boolean true to revert
Exception

setConstraint

public void setConstraint (CDraggableConstraint $value )

Set wether the element should be constrainted in one direction

Input
CDraggableConstraint $value
Output
Exception

setGhosting

public boolean setGhosting (mixed $value )

Sets wether the element should be cloned when dragged If true, Clones the element and drags the clone, leaving the original in place until the clone is dropped.

Defaults to false

Input
mixed | $value
Output
boolean | true to clone the element
Exception

setHandle

public void setHandle (string $value )

Set the handle id or css class

Input
string $value
Output
Exception

setRevert

public void setRevert (boolean $value )

Sets whether the draggable element should revert to it orginal position upon release in an non-droppable container.

Input
boolean $value true to revert
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDraggableConstraint

Class TDraggableConstraint (Class Overview)

TEnumerable
   |
   --TDraggableConstraint

TEnumerable class.

TEnumerable is the base class for all enumerable types. To define an enumerable type, extend TEnumberable and define string constants. Each constant represents an enumerable value. The constant name must be the same as the constant value. For example,

1      class TTextAlign extends TEnumerable
2      {
3          const Left='Left';
4          const Right='Right';
5      }
Then, one can use the enumerable values such as TTextAlign::Left and TTextAlign::Right.

Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Horizontal
string | None
string | Vertical
Constant Details

Horizontal

Type:

string

Value:

'Horizontal'

None

Type:

string

Value:

'None'

Vertical

Type:

string

Value:

'Vertical'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDropContainer

Class TDropContainer (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPanel
               |
               --TDropContainer

TDropContainer is a panel where TDraggable controls can be dropped.

When a TDraggable component is dropped into a TDropContainer, the OnDrop event is raised. The TDropContainerEventParameter param will contain the dropped control.

Properties :

AcceptCssClass : a coma delimited classname of elements that the drop container can accept. HoverCssClass: CSS classname of the container when a draggable element hovers over the container.

Events:

OnDrop : raised when a TDraggable control is dropped. The dropped control is encapsulated in the event parameter

License: http://www.pradosoft.com/license
Copyright: Copyright &copy; 2008, PradoSoft
Author: Christophe BOULAIN (Christophe.Boulain@gmail.com)
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Summary
protected void | addAttributesToRender ( mixed $writer) Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
void | createChildControls () Creates child control Override parent implementation to create a container which will contain all child controls. This container will be a TActivePanel, in order to allow user to update its content on callback.
string | getAcceptCssClass () Gets the Css class name that this container can accept.
TBaseActiveControl | getActiveControl ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
TCallbackClientSide | getClientSide ()
TControlCollection | getControls () Override parent implementation to return the container control collection.
string | getHoverCssClass () Gets the Css class name used when a draggble element is hovering over this container.
protected array | getPostBackOptions () Gets the post back options for this textbox.
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | onDrop ( string $dropControlId) Raises the onDrop event.
void | raiseCallbackEvent ( TCallbackEventParameter $param) Raises callback event. This method is required bu ICallbackEventHandler interface.
void | render ( THtmlWriter $writer) Renders and replaces the panel's content on the client-side.
void | setAcceptCssClass ( string $value) Sets the Css class name that this container can accept.
void | setHoverCssClass ( string $value) Sets the Css class name used when a draggble element is hovering over this container.
Methods Inherited From TPanel
TPanel::addAttributesToRender(), TPanel::createStyle(), TPanel::getBackImageUrl(), TPanel::getDefaultButton(), TPanel::getDirection(), TPanel::getGroupingText(), TPanel::getHorizontalAlign(), TPanel::getScrollBars(), TPanel::getTagName(), TPanel::getWrap(), TPanel::renderBeginTag(), TPanel::renderEndTag(), TPanel::setBackImageUrl(), TPanel::setDefaultButton(), TPanel::setDirection(), TPanel::setGroupingText(), TPanel::setHorizontalAlign(), TPanel::setScrollBars(), TPanel::setWrap()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Creates a new callback control, sets the adapter to TActiveControlAdapter. If you override this class, be sure to set the adapter appropriately by, for example, by calling this constructor.
Method Details

addAttributesToRender

protected void addAttributesToRender (mixed $writer )

Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

Input
mixed $writer
Output
Exception

createChildControls

public void createChildControls ()

Creates child control Override parent implementation to create a container which will contain all child controls. This container will be a TActivePanel, in order to allow user to update its content on callback.

Output
Exception

getAcceptCssClass

public string getAcceptCssClass ()

Gets the Css class name that this container can accept.

Output
Exception

getActiveControl

public TBaseActiveControl getActiveControl ()

Output
TBaseActiveControl standard active control options.
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientSide

public TCallbackClientSide getClientSide ()

Output
TCallbackClientSide client side request options.
Exception

getControls

public TControlCollection getControls ()

Override parent implementation to return the container control collection.

Output
Exception

getHoverCssClass

public string getHoverCssClass ()

Gets the Css class name used when a draggble element is hovering over this container.

Output
string css class name during draggable hover.
Exception

getPostBackOptions

protected array getPostBackOptions ()

Gets the post back options for this textbox.

Output
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onDrop

public void onDrop (string $dropControlId )

Raises the onDrop event.

The dropped control is encapsulated into a TDropContainerEventParameter

Input
string $dropControlId
Output
Exception

raiseCallbackEvent

public void raiseCallbackEvent (TCallbackEventParameter $param )

Raises callback event. This method is required bu ICallbackEventHandler interface.

It raises the OnDrop event, then, the OnCallback event This method is mainly used by framework and control developers.

Input
TCallbackEventParameter $param the parameter associated with the callback event
Output
Exception

render

public void render (THtmlWriter $writer )

Renders and replaces the panel's content on the client-side.

When render() is called before the OnPreRender event, such as when render() is called during a callback event handler, the rendering is defered until OnPreRender event is raised.

Input
THtmlWriter $writer html writer
Output
Exception

setAcceptCssClass

public void setAcceptCssClass (string $value )

Sets the Css class name that this container can accept.

Input
string $value comma delimited css class names.
Output
Exception

setHoverCssClass

public void setHoverCssClass (string $value )

Sets the Css class name used when a draggble element is hovering over this container.

Input
string $value css class name during draggable hover.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDropContainerEventParameter

Class TDropContainerEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TDropContainerEventParameter

TDropContainerEventParameter class

TDropContainerEventParameter encapsulate the parameter data for OnDrop event of TDropContainer components

License: http://www.pradosoft.com/license
Copyright: Copyright &copy; 2008, PradoSoft
Author: Christophe BOULAIN (Christophe.Boulain@ceram.fr)
Constructor Summary
public
__construct Array
constructor
Method Summary
TDraggable
getDroppedControl ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

constructor
Method Details

getDroppedControl

public TDraggable getDroppedControl ()

Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TEventTriggeredCallback

Class TEventTriggeredCallback (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCallback
            |
            --TTriggeredCallback
               |
               --TEventTriggeredCallback

TEventTriggeredCallback Class

Triggers a new callback request when a particular EventName on a control with ID given by ControlID is raised.

The default action of the event on the client-side can be prevented when PreventDefaultAction is set to true.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected string | getClientClassName ()
string | getEventName ()
boolean | getPreventDefaultAction ()
protected array | getTriggerOptions ()
void | render ( THtmlWriter $writer) Registers the javascript code for initializing the active control.
void | setEventName ( string $value) Sets the client-side event name that fires the callback request.
void | setPreventDefaultAction ( boolean $value)
Methods Inherited From TTriggeredCallback
TTriggeredCallback::getControlID(), TTriggeredCallback::getTargetControl(), TTriggeredCallback::getTriggerOptions(), TTriggeredCallback::setControlID()
Methods Inherited From TCallback
TCallback::getActiveControl(), TCallback::getClientSide(), TCallback::onCallback(), TCallback::raiseCallbackEvent()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getClientClassName

protected string getClientClassName ()

Output
string corresponding javascript class name for TEventTriggeredCallback.
Exception

getEventName

public string getEventName ()

Output
string The client-side event name the trigger listens to.
Exception

getPreventDefaultAction

public boolean getPreventDefaultAction ()

Output
boolean true to prevent/stop default event action.
Exception

getTriggerOptions

protected array getTriggerOptions ()

Output
array list of timer options for client-side.
Exception

render

public void render (THtmlWriter $writer )

Registers the javascript code for initializing the active control.

Input
THtmlWriter $writer the renderer.
Output
Exception

setEventName

public void setEventName (string $value )

Sets the client-side event name that fires the callback request.

Input
string $value The client-side event name the trigger listens to.
Output
Exception

setPreventDefaultAction

public void setPreventDefaultAction (boolean $value )

Input
boolean $value true to prevent/stop default event action.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TInPlaceTextBox

Class TInPlaceTextBox (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --TActiveTextBox
                  |
                  --TInPlaceTextBox

TInPlaceTextBox Class

* TInPlaceTextBox is a component rendered as a label and allows its contents to be edited by changing the label to a textbox when the label is clicked or when another control or html element with ID given by EditTriggerControlID is clicked.

If the OnLoadingText event is handled, a callback request is made when the label is clicked, while the request is being made the textbox is disabled from editing. The OnLoadingText event allows you to update the content of the textbox before the client is allowed to edit the content. After the callback request returns successfully, the textbox is enabled and the contents is then allowed to be edited.

Once the textbox loses focus, if AutoPostBack is true and the textbox content has changed, a callback request is made and the OnTextChanged event is raised like that of the TActiveTextBox. During the request, the textbox is disabled.

After the callback request returns sucessfully, the textbox is enabled. If the AutoHideTextBox property is true, then the textbox will be hidden and the label is then shown.

Since 3.1.2, you can set the ReadOnly property to make the control not editable. This property can be also changed on callback

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TTextBox
DEFAULT_COLUMNS, DEFAULT_ROWS,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Sets the auto post back to true by default.
Method Summary
protected void | addAttributesToRender ( mixed $writer) Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
protected void | callClientFunction ( string $func, mixed $value) Calls the client-side static method for this control class.
boolean | getAutoHideTextBox ()
protected string | getClientClassName ()
boolean | getDisplayTextBox ()
string | getEditTriggerControlID ()
protected string | getExternalControlID ()
protected string | getLabelClientID ()
protected array | getPostBackOptions ()
protected string | getTagName ()
void | onCallback ( TCallbackEventParameter $param) This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.
void | onLoadingText ( TCallbackEventParameter $param) Raised when editing the content is requsted to be loaded from the server side.
void | renderContents ( THtmlWriter $writer) Renders the body content of the label.
void | setAutoHideTextBox ( boolean $value)
void | setDisplayTextBox ( boolean $value)
void | setEditTriggerControlID ( string $value)
void | setReadOnly ( boolean $value) Update ClientSide Readonly property
void | setText ( string $value) On callback response, the inner HTMl of the label and the
Methods Inherited From TActiveTextBox
TActiveTextBox::addAttributesToRender(), TActiveTextBox::getActiveControl(), TActiveTextBox::getClientClassName(), TActiveTextBox::getClientSide(), TActiveTextBox::onCallback(), TActiveTextBox::raiseCallbackEvent(), TActiveTextBox::renderClientControlScript(), TActiveTextBox::setText()
Methods Inherited From TTextBox
TTextBox::addAttributesToRender(), TTextBox::getAutoCompleteType(), TTextBox::getAutoPostBack(), TTextBox::getAutoTrim(), TTextBox::getCausesValidation(), TTextBox::getClientClassName(), TTextBox::getColumns(), TTextBox::getData(), TTextBox::getDataChanged(), TTextBox::getEnableClientScript(), TTextBox::getIsValid(), TTextBox::getMaxLength(), TTextBox::getPersistPassword(), TTextBox::getPostBackOptions(), TTextBox::getReadOnly(), TTextBox::getRows(), TTextBox::getSafeText(), TTextBox::getSafeTextParser(), TTextBox::getTagName(), TTextBox::getText(), TTextBox::getTextMode(), TTextBox::getValidationGroup(), TTextBox::getValidationPropertyValue(), TTextBox::getWrap(), TTextBox::loadPostData(), TTextBox::onTextChanged(), TTextBox::raisePostDataChangedEvent(), TTextBox::renderBeginTag(), TTextBox::renderClientControlScript(), TTextBox::renderContents(), TTextBox::setAutoCompleteType(), TTextBox::setAutoPostBack(), TTextBox::setAutoTrim(), TTextBox::setCausesValidation(), TTextBox::setColumns(), TTextBox::setData(), TTextBox::setEnableClientScript(), TTextBox::setIsValid(), TTextBox::setMaxLength(), TTextBox::setPersistPassword(), TTextBox::setReadOnly(), TTextBox::setRows(), TTextBox::setText(), TTextBox::setTextMode(), TTextBox::setValidationGroup(), TTextBox::setWrap()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Sets the auto post back to true by default.
Method Details

addAttributesToRender

protected void addAttributesToRender (mixed $writer )

Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.

Input
mixed $writer
Output
Exception

callClientFunction

protected void callClientFunction (string $func , mixed $value )

Calls the client-side static method for this control class.

Input
string | $func | static method name
mixed | $value | method parmaeter
Output
Exception

getAutoHideTextBox

public boolean getAutoHideTextBox ()

Output
boolean true will hide the textbox after losing focus.
Exception

getClientClassName

protected string getClientClassName ()

Output
string corresponding javascript class name for this TInPlaceTextBox
Exception

getDisplayTextBox

public boolean getDisplayTextBox ()

Output
boolean true to display the edit textbox
Exception

getEditTriggerControlID

public string getEditTriggerControlID ()

Output
string ID of the control that can trigger to edit the textbox
Exception

getExternalControlID

protected string getExternalControlID ()

Output
string edit trigger control client ID.
Exception

getLabelClientID

protected string getLabelClientID ()

Output
string label client ID
Exception

getPostBackOptions

protected array getPostBackOptions ()

Output
array callback options.
Exception

getTagName

protected string getTagName ()

Output
string tag name of the label.
Exception

onCallback

public void onCallback (TCallbackEventParameter $param )

This method is invoked when a callback is requested. The method raises 'OnCallback' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onLoadingText

public void onLoadingText (TCallbackEventParameter $param )

Raised when editing the content is requsted to be loaded from the server side.

Input
TCallbackEventParameter $param event parameter to be passed to the event handlers
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders the body content of the label.

Input
THtmlWriter $writer the writer for rendering
Output
Exception

setAutoHideTextBox

public void setAutoHideTextBox (boolean $value )

Input
boolean $value true to hide the textbox after losing focus.
Output
Exception

setDisplayTextBox

public void setDisplayTextBox (boolean $value )

Input
boolean $value true to display the edit textbox
Output
Exception

setEditTriggerControlID

public void setEditTriggerControlID (string $value )

Input
string $value ID of the control that can trigger to edit the textbox
Output
Exception

setReadOnly

public void setReadOnly (boolean $value )

Update ClientSide Readonly property

Input
boolean $value value
Output
Exception

setText

public void setText (string $value )

On callback response, the inner HTMl of the label and the

value of the textbox is updated

Input
string $value the text value of the label
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IListControlAdapter

Interface IListControlAdapter (Class Overview)

IListControlAdapter interface

            Since:
            3.0

            Author:
            Wei Zhuo <weizhuo[at]gmail[dot]com>

Method Summary
void | clearSelection () Clears all existing selections on the client side.
void | setSelectedIndex ( integer $index) Selects an item based on zero-base index on the client side.
void | setSelectedIndices ( array $indices) Selects a list of item based on zero-base indices on the client side.
void | setSelectedValue ( string $value) Sets selection by item value on the client side.
void | setSelectedValues ( array $values) Sets selection by a list of item values on the client side.

            Method Details

clearSelection

                                public void clearSelection
                                ()

Clears all existing selections on the client side.

Output

Exception

setSelectedIndex

                                public void setSelectedIndex
                                (integer $index )

Selects an item based on zero-base index on the client side.

Input

integer $index the index (zero-based) of the item to be selected

Output

Exception

setSelectedIndices

                                public void setSelectedIndices
                                (array $indices )

Selects a list of item based on zero-base indices on the client side.

Input

array $indices list of index of items to be selected

Output

Exception

setSelectedValue

                                public void setSelectedValue
                                (string $value )

Sets selection by item value on the client side.

Input

string $value the value of the item to be selected.

Output

Exception

setSelectedValues

                                public void setSelectedValues
                                (array $values )

Sets selection by a list of item values on the client side.

Input

array $values list of the selected item values

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTimeTriggeredCallback

Class TTimeTriggeredCallback (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCallback
            |
            --TTimeTriggeredCallback

TTimeTriggeredCallback class.

TTimeTriggeredCallback sends callback request every Interval seconds. Upon each callback request, the OnCallback event is raised.

The timer can be started by calling startTimer() and stopped using stopTimer(). The timer can be automatically started when StartTimerOnLoad is true.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected string | getClientClassName ()
float | getInterval ()
boolean | getStartTimerOnLoad ()
protected array | getTriggerOptions ()
void | render ( THtmlWriter $writer) Registers the javascript code for initializing the active control.
void | setInterval ( float $value)
void | setStartTimerOnLoad ( boolean $value)
void | startTimer () Registers the javascript code to start the timer.
void | stopTimer () Registers the javascript code to stop the timer.
Methods Inherited From TCallback
TCallback::getActiveControl(), TCallback::getClientSide(), TCallback::onCallback(), TCallback::raiseCallbackEvent()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getClientClassName

protected string getClientClassName ()

Output
string corresponding javascript class name for TTimeTriggeredCallback.
Exception

getInterval

public float getInterval ()

Output
float seconds between callback requests. Default is 1 second.
Exception

getStartTimerOnLoad

public boolean getStartTimerOnLoad ()

Output
boolean true to start the timer when page loads.
Exception

getTriggerOptions

protected array getTriggerOptions ()

Output
array list of timer options for client-side.
Exception

render

public void render (THtmlWriter $writer )

Registers the javascript code for initializing the active control.

Input
THtmlWriter $writer the renderer.
Output
Exception

setInterval

public void setInterval (float $value )

Input
float $value seconds between callback requests, must be a positive number, default is 1 second.
Output
Exception

setStartTimerOnLoad

public void setStartTimerOnLoad (boolean $value )

Input
boolean $value true to start the timer when page loads.
Output
Exception

startTimer

public void startTimer ()

Registers the javascript code to start the timer.

Output
Exception

stopTimer

public void stopTimer ()

Registers the javascript code to stop the timer.

Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTriggeredCallback

Class TTriggeredCallback (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCallback
            |
            --TTriggeredCallback

Direct Known Sub-classes:

TEventTriggeredCallback , TValueTriggeredCallback

TTriggeredCallback abstract Class

Base class for triggered callback controls. The ControlID property sets the control ID to observe the trigger.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getControlID ()
protected string | getTargetControl ()
protected array | getTriggerOptions ()
void | setControlID ( string $value)
Methods Inherited From TCallback
TCallback::getActiveControl(), TCallback::getClientSide(), TCallback::onCallback(), TCallback::raiseCallbackEvent()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getControlID

public string getControlID ()

Output
string The ID of the server control the trigger is bounded to.
Exception

getTargetControl

protected string getTargetControl ()

Output
string target control client ID or html element ID if control is not found in hierarchy.
Exception

getTriggerOptions

protected array getTriggerOptions ()

Output
array list of trigger callback options.
Exception

setControlID

public void setControlID (string $value )

Input
string $value The ID of the server control the trigger is bounded to.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TValueTriggeredCallback

Class TValueTriggeredCallback (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCallback
            |
            --TTriggeredCallback
               |
               --TValueTriggeredCallback

TValueTriggeredCallback Class

Observes the value with PropertyName of a control with ControlID. Changes to the observed property value will trigger a new callback request. The property value is checked for changes everyInterval seconds.

A DecayRate can be set to increase the polling interval linearly if no changes are observed. Once a change is observe, the polling interval is reset to the original value.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected string | getClientClassName ()
float | getDecayRate () Gets the decay rate between callbacks. Default is 0;
float | getInterval ()
string | getPropertyName ()
protected array | getTriggerOptions ()
void | render ( THtmlWriter $writer) Registers the javascript code for initializing the active control.
void | setDecayRate ( float $value) Sets the decay rate between callback. Default is 0;
void | setInterval ( float $value) Sets the polling interval in seconds to observe property changes.
void | setPropertyName ( string $value) Sets the control property name to observe value changes that fires the callback request.
Methods Inherited From TTriggeredCallback
TTriggeredCallback::getControlID(), TTriggeredCallback::getTargetControl(), TTriggeredCallback::getTriggerOptions(), TTriggeredCallback::setControlID()
Methods Inherited From TCallback
TCallback::getActiveControl(), TCallback::getClientSide(), TCallback::onCallback(), TCallback::raiseCallbackEvent()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getClientClassName

protected string getClientClassName ()

Output
string corresponding javascript class name for TEventTriggeredCallback.
Exception

getDecayRate

public float getDecayRate ()

Gets the decay rate between callbacks. Default is 0;

Output
float decay rate between callbacks.
Exception

getInterval

public float getInterval ()

Output
float polling interval, 1 second default.
Exception

getPropertyName

public string getPropertyName ()

Output
string The control property name to observe value changes.
Exception

getTriggerOptions

protected array getTriggerOptions ()

Output
array list of timer options for client-side.
Exception

render

public void render (THtmlWriter $writer )

Registers the javascript code for initializing the active control.

Input
THtmlWriter $writer the renderer.
Output
Exception

setDecayRate

public void setDecayRate (float $value )

Sets the decay rate between callback. Default is 0;

Input
float $value decay rate between callbacks.
Output
Exception

setInterval

public void setInterval (float $value )

Sets the polling interval in seconds to observe property changes.

Default is 1 second.

Input
float $value polling interval in seconds.
Output
Exception

setPropertyName

public void setPropertyName (string $value )

Sets the control property name to observe value changes that fires the callback request.

Input
string $value The control property name to observe value changes.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRecord

Class TActiveRecord (Class Overview)

TComponent
   |
   --TActiveRecord

Base class for active records.

An active record creates an object that wraps a row in a database table or view, encapsulates the database access, and adds domain logic on that data.

Active record objects are stateful, this is main difference between the TActiveRecord implementation and the TTableGateway implementation.

The essence of an Active Record is an object model of the domain (e.g. products, items) that incorporates both behavior and data in which the classes match very closely the record structure of an underlying database. Each Active Record is responsible for saving and loading to the database and also for any domain logic that acts on the data.

The Active Record provides methods that do the following:

  1. Construct an instance of the Active Record from a SQL result set row.
  2. Construct a new instance for later insertion into the table.
  3. Finder methods to wrap commonly used SQL queries and return Active Record objects.
  4. Update the database and insert into it the data in the Active Record.
Example:

1      class UserRecord extends TActiveRecord
2      {
3          const TABLE='users'; //optional table name.
4
4
5          public $username; //corresponds to the fieldname in the table
6               public $email;
7
8          //returns active record finder instance
9               public static function finder($className=__CLASS__)
10         {
11             return parent::finder($className);
12         }
13     }
14
15     //create a connection and give it to the ActiveRecord manager.
16      $dsn = 'pgsql:host=localhost;dbname=test';
17     $conn = new TDbConnection($dsn, 'dbuser','dbpass');
18     TActiveRecordManager::getInstance()->setDbConnection($conn);
19
20     //load the user record with username (primary key) 'admin'.
21      $user = UserRecord::finder()->findByPk('admin');
22     $user->email = 'admin@example.org';
22     $user->save(); //update the 'admin' record.

Since v3.1.1, TActiveRecord starts to support column mapping. The physical column names (defined in database) can be mapped to logical column names (defined in active classes as public properties.) To use this feature, declare a static class variable COLUMN_MAPPING like the following:

1      class UserRecord extends TActiveRecord
2      {
3          const TABLE='users';
4          public static $COLUMN_MAPPING=array
5          (
6              'user_id'=>'username',
7              'email_address'=>'email',
8          );
9          public $username;
10         public $email;
11     }
In the above, the 'users' table consists of 'user_id' and 'email_address' columns, while the UserRecord class declares 'username' and 'email' properties. By using column mapping, we can regularize the naming convention of column names in active record.

Since v3.1.2, TActiveRecord enhanced its support to access of foreign objects. By declaring a public static variable RELATIONS like the following, one can access the corresponding foreign objects easily:

1      class UserRecord extends TActiveRecord
2      {
3          const TABLE='users';
4          public static $RELATIONS=array
5          (
6              'department'=>array(self::BELONGS_TO, 'DepartmentRecord', 'department_id'),
7              'contacts'=>array(self::HAS_MANY, 'ContactRecord', 'user_id'),
8          );
9      }
In the above, the users table is related with departments table (represented by DepartmentRecord) and contacts table (represented by ContactRecord). Now, given a UserRecord instance $user, one can access its department and contacts simply by: $user->department and $user->contacts. No explicit data fetching is needed. Internally, the foreign objects are fetched in a lazy way, which avoids unnecessary overhead if the foreign objects are not accessed at all.

Since v3.1.2, new events OnInsert, OnUpdate and OnDelete are available. The event OnInsert, OnUpdate and OnDelete methods are executed before inserting, updating, and deleting the current record, respectively. You may override these methods; a TActiveRecordChangeEventParameter parameter is passed to these methods. The property TActiveRecordChangeEventParameter::setIsValid of the parameter can be set to false to prevent the change action to be executed. This can be used, for example, to validate the record before the action is executed. For example, in the following the password property is hashed before a new record is inserted.

1      class UserRecord extends TActiveRecord
2      {
3           function OnInsert($param)
4           {
5               //parent method should be called to raise the event
6               parent::OnInsert($param);
7               $this->nounce = md5(time());
8               $this->password = md5($this->password.$this->nounce);
9           }
10     }

Since v3.1.3 you can also define a method that returns the table name.

1      class UserRecord extends TActiveRecord
2      {
3          public function table()
4          {
5               return 'users';
6          }
7
8      }

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Create a new instance of an active record with given $data. The record can be saved to the database specified by the $connection object.
Method Summary
void | copyFrom ( mixed $data) Copies data from an array or another object.
int | count ( string|TActiveRecordCriteria $criteria, mixed $parameters) Find the number of records.
TActiveRecord | createRecord ( string $type, array $data) Create an AR instance specified by the AR class name and initial data.
protected TActiveRecordRelationContext | createRelationContext ( string $name) Gets a static copy of the relationship context for given property (a key in $RELATIONS), returns null if invalid relationship. Keeps a null reference to all invalid relations called.
boolean | delete () Deletes the current record from the database. Once deleted, this object can not be saved again in the same instance.
int | deleteAll ( string|TActiveRecordCriteria $criteria, mixed $parameters) Delete multiple records using a criteria.
void | deleteAllByPks ( mixed $keys) Alias for deleteByPk()
int | deleteByPk ( mixed $keys) Delete records by primary key. Usage:
boolean | equals ( TActiveRecord $record, boolean $strict) Compare two records using their primary key values (all column values if table does not defined primary keys). The default uses simple == for comparison of their values. Set $strict=true for identity comparison (===).
protected boolean | fetchResultsFor ( string $property) Tries to load the relationship results for the given property. The $property value should correspond to an entry key in the $RELATION array.
TActiveRecord | find ( string|TActiveRecordCriteria $criteria, mixed $parameters) Find one single record that matches the criteria.
array | findAll ( string|TActiveRecordCriteria $criteria, mixed $parameters) Same as find() but returns an array of objects.
array | findAllByIndex ( TActiveRecordCriteria $criteria, array $fields, array $values) Fetches records using the sql clause "(fields) IN (values)", where fields is an array of column names and values is an array of values that the columns must have.
array | findAllByPks ( mixed $keys) Find multiple records matching a list of primary or composite keys.
array | findAllBySql ( string $sql, array $parameters) Find records using full SQL, returns corresponding record object.
TActiveRecord. | findByPk ( mixed $keys) Find one record using only the primary key or composite primary keys. Usage:
TActiveRecord, | findBySql ( string $sql, array $parameters) Find records using full SQL, returns corresponding record object.
TActiveRecord | finder ( string $className) Returns the instance of a active record finder for a particular class.
void | getActiveDbConnection ()
mixed | getColumnValue ( string $columnName) Retrieves the column value according to column name.
TDbConnection | getDbConnection () Gets the current Db connection, the connection object is obtained from the TActiveRecordManager if connection is currently null.
TActiveRecordInvalidFinderResult | getInvalidFinderResult ()
protected TSqlCriteria | getRecordCriteria ( string|TSqlCriteria $criteria, mixed $parameters, array $args) Create a new TSqlCriteria object from a string $criteria. The $args are additional parameters and are used in place of the $parameters if $parameters is not an array and $args is an arrary.
TActiveRecordGateway | getRecordGateway ()
TActiveRecordManager | getRecordManager () Gets the record manager for this object, the default is to call TActiveRecordManager::getInstance().
array | getRecordRelation ( string $property)
array | getRecordRelations ()
TDbTableInfo | getRecordTableInfo ()
protected TActiveRecordRelation, | getRelationHandler ( string $name, array $args) Returns the active record relationship handler for $RELATION with key value equal to the $property value.
boolean | hasRecordRelation ( string $property)
void | onCreateCommand ( TDataGatewayEventParameter $param) Raised when a command is prepared and parameter binding is completed.
void | onDelete ( TActiveRecordChangeEventParameter $param) Raised before the record attempt to delete its data from the database.
void | onExecuteCommand ( TDataGatewayResultEventParameter $param) Raised when a command is executed and the result from the database was returned.
void | onInsert ( TActiveRecordChangeEventParameter $param) Raised before the record attempt to insert its data into the database.
void | onUpdate ( TActiveRecordChangeEventParameter $param) Raised before the record attempt to update its data in the database.
protected TActiveRecord | populateObject ( array $data) Populates a new record with the query result.
protected array | populateObjects ( TDbDataReader $reader)
boolean | save () Saves the current record to the database, insert or update is automatically determined.
void | setColumnValue ( string $columnName, mixed $value) Sets the column value according to column name.
void | setDbConnection ( TDbConnection $connection)
void | setInvalidFinderResult ( TActiveRecordInvalidFinderResult|null $value) Define the way an active record finder react if an invalid magic-finder invoked
mixed | __call ( mixed $method, mixed $args) Dynamic find method using parts of method name as search criteria.
mixed | __get ( string $name) Magic method for reading properties.
void | __set ( string $name, mixed $value) Magic method for writing properties.
void | __sleep () Prevent __call() method creating __sleep() when serializing.
void | __wakeup () Prevent __call() method creating __wakeup() when unserializing.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | BELONGS_TO
string | HAS_MANY
string | HAS_ONE
string | MANY_TO_MANY
int | STATE_DELETED
int | STATE_LOADED
int | STATE_NEW
Constructor Details

__construct

public __construct Array

Create a new instance of an active record with given $data. The record can be saved to the database specified by the $connection object.
Method Details

copyFrom

public void copyFrom (mixed $data )

Copies data from an array or another object.

Input
mixed | $data
Output
Exception
throws | TActiveRecordException if data is not array or not object.

count

public int count (string|TActiveRecordCriteria $criteria , mixed $parameters )

Find the number of records.

Input
string|TActiveRecordCriteria | $criteria | SQL condition or criteria object.
mixed | $parameters | parameter values.
Output
int | number of records.
Exception

createRecord

public TActiveRecord createRecord (string $type , array $data )

Create an AR instance specified by the AR class name and initial data.

If the initial data is empty, the AR object will not be created and null will be returned. (You should use the "new" operator to create the AR instance in that case.)

Input
string | $type | the AR class name
array | $data | initial data to be populated into the AR object.
Output
TActiveRecord | the initialized AR object. Null if the initial data is empty.
Exception

createRelationContext

protected TActiveRecordRelationContext createRelationContext (string $name )

Gets a static copy of the relationship context for given property (a key in $RELATIONS), returns null if invalid relationship. Keeps a null reference to all invalid relations called.

Input
string | $name | relationship/property name corresponding to keys in $RELATION array.
Output
TActiveRecordRelationContext | object containing information on the active record relationships for given property, null if invalid relationship
Exception

delete

public boolean delete ()

Deletes the current record from the database. Once deleted, this object can not be saved again in the same instance.

Output
boolean true if the record was deleted successfully, false otherwise.
Exception

deleteAll

public int deleteAll (string|TActiveRecordCriteria $criteria , mixed $parameters )

Delete multiple records using a criteria.

Input
string|TActiveRecordCriteria | $criteria | SQL condition or criteria object.
mixed | $parameters | parameter values.
Output
int | number of records deleted.
Exception

deleteAllByPks

public void deleteAllByPks (mixed $keys )

Alias for deleteByPk()

Input
mixed $keys
Output
Exception

deleteByPk

public int deleteByPk (mixed $keys )

Delete records by primary key. Usage:

1      $finder->deleteByPk($primaryKey); //delete 1 record
2       $finder->deleteByPk($key1,$key2,...); //delete multiple records
2       $finder->deleteByPk(array($key1,$key2,...)); //delete multiple records

For composite primary keys (determined from the table definitions):

1      $finder->deleteByPk(array($key1,$key2)); //delete 1 record
2
3      //delete multiple records
4       $finder->deleteByPk(array($key1,$key2), array($key3,$key4),...);
5
6      //delete multiple records
7       $finder->deleteByPk(array( array($key1,$key2), array($key3,$key4), .. ));

Input
mixed | $keys | primary key values.
Output
int | number of records deleted.
Exception

equals

public boolean equals (TActiveRecord $record , boolean $strict )

Compare two records using their primary key values (all column values if table does not defined primary keys). The default uses simple == for comparison of their values. Set $strict=true for identity comparison (===).

Input
TActiveRecord | $record | another record to compare with.
boolean | $strict | true to perform strict identity comparison
Output
boolean | true if $record equals, false otherwise.
Exception

fetchResultsFor

protected boolean fetchResultsFor (string $property )

Tries to load the relationship results for the given property. The $property value should correspond to an entry key in the $RELATION array.

This method can be used to lazy load relationships.

1      class TeamRecord extends TActiveRecord
2      {
3          ...
4
5          private $_players;
6          public static $RELATION=array
7          (
8              'players' => array(self::HAS_MANY, 'PlayerRecord'),
9          );
10
11         public function setPlayers($array)
12         {
13             $this->_players=$array;
14         }
15
16         public function getPlayers()
17         {
18             if($this->_players===null)
19                 $this->fetchResultsFor('players');
20             return $this->_players;
21         }
22     }
23     Usage example:
24     $team = TeamRecord::finder()->findByPk(1);
24     var_dump($team->players); //uses lazy load to fetch 'players' relation

Input
string | $property | relationship/property name corresponding to keys in $RELATION array.
Output
boolean | true if relationship exists, false otherwise.
Exception

find

public TActiveRecord find (string|TActiveRecordCriteria $criteria , mixed $parameters )

Find one single record that matches the criteria.

Usage:

1      $finder->find('username = :name AND password = :pass',
2                          array(':name'=>$name, ':pass'=>$pass));
3      $finder->find('username = ? AND password = ?', array($name, $pass));
4      $finder->find('username = ? AND password = ?', $name, $pass);
5      //$criteria is of TActiveRecordCriteria
5       $finder->find($criteria); //the 2nd parameter for find() is ignored.

Input
string|TActiveRecordCriteria | $criteria | SQL condition or criteria object.
mixed | $parameters | parameter values.
Output
TActiveRecord | matching record object. Null if no result is found.
Exception

findAll

public array findAll (string|TActiveRecordCriteria $criteria , mixed $parameters )

Same as find() but returns an array of objects.

Input
string|TActiveRecordCriteria | $criteria | SQL condition or criteria object.
mixed | $parameters | parameter values.
Output
array | matching record objects. Empty array if no result is found.
Exception

findAllByIndex

public array findAllByIndex (TActiveRecordCriteria $criteria , array $fields , array $values )

Fetches records using the sql clause "(fields) IN (values)", where fields is an array of column names and values is an array of values that the columns must have.

This method is to be used by the relationship handler.

Input
TActiveRecordCriteria | $criteria | additional criteria
array | $fields | field names to match with "(fields) IN (values)" sql clause.
array | $values | matching field values.
Output
array | matching active records. Empty array is returned if no result is found.
Exception

findAllByPks

public array findAllByPks (mixed $keys )

Find multiple records matching a list of primary or composite keys.

For scalar primary keys:

1      $finder->findAllByPk($key1, $key2, ...);
2      $finder->findAllByPk(array($key1, $key2, ...));

For composite keys:

1      $finder->findAllByPk(array($key1, $key2), array($key3, $key4), ...);
2      $finder->findAllByPk(array(array($key1, $key2), array($key3, $key4), ...));

Input
mixed | $keys | primary keys
Output
array | matching ActiveRecords. Empty array is returned if no result is found.
Exception

findAllBySql

public array findAllBySql (string $sql , array $parameters )

Find records using full SQL, returns corresponding record object.

The names of the column retrieved must be defined in your Active Record class.

Input
string | $sql | select SQL
array | $parameters |
Output
array | matching active records. Empty array is returned if no result is found.
Exception

findByPk

public TActiveRecord. findByPk (mixed $keys )

Find one record using only the primary key or composite primary keys. Usage:

1      $finder->findByPk($primaryKey);
2      $finder->findByPk($key1, $key2, ...);
3      $finder->findByPk(array($key1,$key2,...));

Input
mixed | $keys | primary keys
Output
TActiveRecord. | Null if no result is found.
Exception

findBySql

public TActiveRecord, findBySql (string $sql , array $parameters )

Find records using full SQL, returns corresponding record object.

The names of the column retrieved must be defined in your Active Record class.

Input
string | $sql | select SQL
array | $parameters |
Output
TActiveRecord, | null if no result is returned.
Exception

finder

public TActiveRecord finder (string $className )

Returns the instance of a active record finder for a particular class.

The finder objects are static instances for each ActiveRecord class. This means that event handlers bound to these finder instances are class wide. Create a new instance of the ActiveRecord class if you wish to bound the event handlers to object instance.

Input
string | $className | active record class name.
Output
TActiveRecord | active record finder instance.
Exception

getActiveDbConnection

public void getActiveDbConnection ()

Output
Exception

getColumnValue

public mixed getColumnValue (string $columnName )

Retrieves the column value according to column name.

This method is used internally.

Input
string | $columnName | the column name (as defined in database schema)
Output
mixed | the corresponding column value
Exception

getDbConnection

public TDbConnection getDbConnection ()

Gets the current Db connection, the connection object is obtained from the TActiveRecordManager if connection is currently null.

Output
TDbConnection current db connection for this object.
Exception

getInvalidFinderResult

public TActiveRecordInvalidFinderResult getInvalidFinderResult ()

Output
TActiveRecordInvalidFinderResult Defaults to 'Null'.
Exception

getRecordCriteria

protected TSqlCriteria getRecordCriteria (string|TSqlCriteria $criteria , mixed $parameters , array $args )

Create a new TSqlCriteria object from a string $criteria. The $args are additional parameters and are used in place of the $parameters if $parameters is not an array and $args is an arrary.

Input
string|TSqlCriteria | $criteria | sql criteria
mixed | $parameters | parameters passed by the user.
array | $args | additional parameters obtained from function_get_args().
Output
TSqlCriteria | criteria object.
Exception

getRecordGateway

public TActiveRecordGateway getRecordGateway ()

Output
TActiveRecordGateway record table gateway.
Exception

getRecordManager

public TActiveRecordManager getRecordManager ()

Gets the record manager for this object, the default is to call TActiveRecordManager::getInstance().

Output
TActiveRecordManager default active record manager.
Exception

getRecordRelation

public array getRecordRelation (string $property )

Input
string | $property | relation property name
Output
array | relation definition for the specified property
Exception

getRecordRelations

public array getRecordRelations ()

Output
array all relation definitions declared in the AR class
Exception

getRecordTableInfo

public TDbTableInfo getRecordTableInfo ()

Output
TDbTableInfo the meta information of the table associated with this AR class.
Exception

getRelationHandler

protected TActiveRecordRelation, getRelationHandler (string $name , array $args )

Returns the active record relationship handler for $RELATION with key value equal to the $property value.

Input
string | $name | relationship/property name corresponding to keys in $RELATION array.
array | $args | method call arguments.
Output
TActiveRecordRelation, | null if the context or the handler doesn't exist
Exception

hasRecordRelation

public boolean hasRecordRelation (string $property )

Input
string | $property | AR property name
Output
boolean | whether a relation is declared for the specified AR property
Exception

onCreateCommand

public void onCreateCommand (TDataGatewayEventParameter $param )

Raised when a command is prepared and parameter binding is completed.

The parameter object is TDataGatewayEventParameter of which the TDataGatewayEventParameter::getCommand property can be inspected to obtain the sql query to be executed.

Note well that the finder objects obtained from ActiveRecord::finder() method are static objects. This means that the event handlers are bound to a static finder object and not to each distinct active record object.

Input
TDataGatewayEventParameter $param
Output
Exception

onDelete

public void onDelete (TActiveRecordChangeEventParameter $param )

Raised before the record attempt to delete its data from the database.

To prevent the delete operation, set the TActiveRecordChangeEventParameter::IsValid parameter to false.

Input
TActiveRecordChangeEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onExecuteCommand

public void onExecuteCommand (TDataGatewayResultEventParameter $param )

Raised when a command is executed and the result from the database was returned.

The parameter object is TDataGatewayResultEventParameter of which the TDataGatewayEventParameter::getResult property contains the data return from the database. The data returned can be changed by setting the TDataGatewayEventParameter::setResult property.

Note well that the finder objects obtained from ActiveRecord::finder() method are static objects. This means that the event handlers are bound to a static finder object and not to each distinct active record object.

Input
TDataGatewayResultEventParameter $param
Output
Exception

onInsert

public void onInsert (TActiveRecordChangeEventParameter $param )

Raised before the record attempt to insert its data into the database.

To prevent the insert operation, set the TActiveRecordChangeEventParameter::IsValid parameter to false.

Input
TActiveRecordChangeEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onUpdate

public void onUpdate (TActiveRecordChangeEventParameter $param )

Raised before the record attempt to update its data in the database.

To prevent the update operation, set the TActiveRecordChangeEventParameter::IsValid parameter to false.

Input
TActiveRecordChangeEventParameter $param event parameter to be passed to the event handlers
Output
Exception

populateObject

protected TActiveRecord populateObject (array $data )

Populates a new record with the query result.

This is a wrapper of createRecord.

Input
array | $data | name value pair of record data
Output
TActiveRecord | object record, null if data is empty.
Exception

populateObjects

protected array populateObjects (TDbDataReader $reader )

Input
TDbDataReader | $reader | data reader
Output
array | the AR objects populated by the query result
Exception

save

public boolean save ()

Saves the current record to the database, insert or update is automatically determined.

Output
boolean true if record was saved successfully, false otherwise.
Exception

setColumnValue

public void setColumnValue (string $columnName , mixed $value )

Sets the column value according to column name.

This method is used internally.

Input
string | $columnName | the column name (as defined in database schema)
mixed | $value | the corresponding column value
Output
Exception

setDbConnection

public void setDbConnection (TDbConnection $connection )

Input
TDbConnection $connection db connection object for this record.
Output
Exception

setInvalidFinderResult

public void setInvalidFinderResult (TActiveRecordInvalidFinderResult|null $value )

Define the way an active record finder react if an invalid magic-finder invoked

Input
TActiveRecordInvalidFinderResult|null $value
Output
Exception

__call

public mixed __call (mixed $method , mixed $args )

Dynamic find method using parts of method name as search criteria.

Method name starting with "findBy" only returns 1 record. Method name starting with "findAllBy" returns 0 or more records. Method name starting with "deleteBy" deletes records by the trail criteria. The condition is taken as part of the method name after "findBy", "findAllBy" or "deleteBy".

The following are equivalent:

1      $finder->findByName($name)
2      $finder->find('Name = ?', $name);

1      $finder->findByUsernameAndPassword($name,$pass); // OR may be used
2       $finder->findBy_Username_And_Password($name,$pass); // _OR_ may be used
3       $finder->find('Username = ? AND Password = ?', $name, $pass);

1      $finder->findAllByAge($age);
2      $finder->findAll('Age = ?', $age);

1      $finder->deleteAll('Name = ?', $name);
2      $finder->deleteByName($name);

Input
mixed | $method
mixed | $args
Output
mixed | single record if method name starts with "findBy", 0 or more records if method name starts with "findAllBy"
Exception

__get

public mixed __get (string $name )

Magic method for reading properties.

This method is overriden to provide read access to the foreign objects via the key names declared in the RELATIONS array.

Input
string | $name | property name
Output
mixed | property value.
Exception

__set

public void __set (string $name , mixed $value )

Magic method for writing properties.

This method is overriden to provide write access to the foreign objects via the key names declared in the RELATIONS array.

Input
string | $name | property name
mixed | $value | property value.
Output
Exception

__sleep

public void __sleep ()

Prevent __call() method creating __sleep() when serializing.

Output
Exception

__wakeup

public void __wakeup ()

Prevent __call() method creating __wakeup() when unserializing.

Output
Exception

Constant Details

BELONGS_TO

Type:

string

Value:

'BELONGS_TO'

HAS_MANY

Type:

string

Value:

'HAS_MANY'

HAS_ONE

Type:

string

Value:

'HAS_ONE'

MANY_TO_MANY

Type:

string

Value:

'MANY_TO_MANY'

STATE_DELETED

Type:

int

Value:

2

STATE_LOADED

Type:

int

Value:

1

STATE_NEW

Type:

int

Value:

0


PRADO API Manual: Docs For Class TActiveRecordChangeEventParameter

Class TActiveRecordChangeEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TActiveRecordChangeEventParameter

TActiveRecordChangeEventParameter class

TActiveRecordChangeEventParameter encapsulates the parameter data for ActiveRecord change commit events that are broadcasted. The following change events may be raise: TActiveRecord::OnInsert, TActiveRecord::OnUpdate and TActiveRecord::OnDelete. The IsValid parameter can be set to false to prevent the requested change event to be performed.

Since: 3.1.2
Author: Wei Zhuo<weizhuo@gmail.com>
Method Summary
boolean | getIsValid ()
void | setIsValid ( boolean $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getIsValid

public boolean getIsValid ()

Output
boolean whether the event should be performed.
Exception

setIsValid

public void setIsValid (boolean $value )

Input
boolean $value set to false to prevent the event.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRecordInvalidFinderResult

Class TActiveRecordInvalidFinderResult (Class Overview)

TEnumerable
   |
   --TActiveRecordInvalidFinderResult

TActiveRecordInvalidFinderResult class.

TActiveRecordInvalidFinderResult defines the enumerable type for possible results if an invalid TActiveRecord::__call invoked.

The following enumerable values are defined:

  • Null: return null (default)
  • Exception: throws a TActiveRecordException

See: TActiveRecord::setInvalidFinderResult
Since: 3.1.5
See: TActiveRecordConfig::setInvalidFinderResult
See: TActiveRecordManager::setInvalidFinderResult
Author: Yves Berkholz <godzilla80@gmx.net>
Constant Summary
string | Exception
string | Null
Constant Details

Exception

Type:

string

Value:

'Exception'

Null

Type:

string

Value:

'Null'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRecordConfig

Class TActiveRecordConfig (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TDataSourceConfig
            |
            --TActiveRecordConfig

TActiveRecordConfig module configuration class.

Database configuration for the default ActiveRecord manager instance.

Example: application.xml configuration

1      <modules>
2          <module class="System.Data.ActiveRecord.TActiveRecordConfig" EnableCache="true">
3              <database ConnectionString="mysql:host=localhost;dbname=test"
4                  Username="dbuser" Password="dbpass" />
5          </module>
6      </modules>

MySQL database definition:

1      CREATE TABLE `blogs` (
2       `blog_id` int(10) unsigned NOT NULL auto_increment,
3       `blog_name` varchar(255) NOT NULL,
4       `blog_author` varchar(255) NOT NULL,
5       PRIMARY KEY  (`blog_id`)
6      ) ENGINE=InnoDB DEFAULT CHARSET=utf8;

Record php class:

1      class Blogs extends TActiveRecord
2      {
3          public $blog_id;
4         public $blog_name;
5         public $blog_author;
6
7         public static function finder($className=__CLASS__)
8         {
9             return parent::finder($className);
10        }
11     }

Usage example:

1      class Home extends TPage
2      {
3          function onLoad($param)
4          {
5              $blogs = Blogs::finder()->findAll();
6           print_r($blogs);
7          }
8      }

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
boolean | getEnableCache ()
TActiveRecordInvalidFinderResult | getInvalidFinderResult ()
void | init ( TXmlDocument $xml) Initialize the active record manager.
void | setEnableCache ( boolean $value) Set true to cache the table meta data.
void | setInvalidFinderResult ( TActiveRecordInvalidFinderResult $value) Define the way an active record finder react if an invalid magic-finder invoked
Methods Inherited From TDataSourceConfig
TDataSourceConfig::findConnectionByID(), TDataSourceConfig::getConnectionClass(), TDataSourceConfig::getConnectionID(), TDataSourceConfig::getDatabase(), TDataSourceConfig::getDbConnection(), TDataSourceConfig::init(), TDataSourceConfig::setConnectionClass(), TDataSourceConfig::setConnectionID()
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getEnableCache

public boolean getEnableCache ()

Output
boolean true if table meta data should be cached, false otherwise.
Exception

getInvalidFinderResult

public TActiveRecordInvalidFinderResult getInvalidFinderResult ()

Output
TActiveRecordInvalidFinderResult Defaults to 'Null'.
Exception

init

public void init (TXmlDocument $xml )

Initialize the active record manager.

Input
TXmlDocument $xml xml configuration.
Output
Exception

setEnableCache

public void setEnableCache (boolean $value )

Set true to cache the table meta data.

Input
boolean $value true to cache sqlmap instance.
Output
Exception

setInvalidFinderResult

public void setInvalidFinderResult (TActiveRecordInvalidFinderResult $value )

Define the way an active record finder react if an invalid magic-finder invoked

Input
TActiveRecordInvalidFinderResult $value
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRecordCriteria

Class TActiveRecordCriteria (Class Overview)

TComponent
   |
   --TSqlCriteria
      |
      --TActiveRecordCriteria

Search criteria for Active Record.

Criteria object for active record finder methods. Usage:

1      $criteria = new TActiveRecordCriteria;
2      $criteria->Condition = 'username = :name AND password = :pass';
3      $criteria->Parameters[':name'] = 'admin';
4      $criteria->Parameters[':pass'] = 'prado';
5      $criteria->OrdersBy['level'] = 'desc';
6      $criteria->OrdersBy['name'] = 'asc';
7      $criteria->Limit = 10;
8      $criteria->Offset = 20;

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
Methods Inherited From TSqlCriteria
TSqlCriteria::getCondition(), TSqlCriteria::getIsNamedParameters(), TSqlCriteria::getLimit(), TSqlCriteria::getOffset(), TSqlCriteria::getOrdersBy(), TSqlCriteria::getParameters(), TSqlCriteria::getSelect(), TSqlCriteria::setCondition(), TSqlCriteria::setLimit(), TSqlCriteria::setOffset(), TSqlCriteria::setOrdersBy(), TSqlCriteria::setParameters(), TSqlCriteria::setSelect(), TSqlCriteria::__toString()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()


PRADO API Manual: Docs For Class TActiveRecordConfigurationException

Class TActiveRecordConfigurationException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException
         |
         --TDbException
            |
            --TActiveRecordException
               |
               --TActiveRecordConfigurationException

Base exception class for Active Records.

Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
Methods Inherited From TActiveRecordException
TActiveRecordException::getErrorMessageFile()
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TActiveRecordException

Class TActiveRecordException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException
         |
         --TDbException
            |
            --TActiveRecordException

Direct Known Sub-classes:

TActiveRecordConfigurationException

Base exception class for Active Records.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected string
getErrorMessageFile ()
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()
Method Details

getErrorMessageFile

protected string getErrorMessageFile ()

Output
string path to the error message file
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRecordGateway

Class TActiveRecordGateway (Class Overview)

TComponent
   |
   --TActiveRecordGateway

TActiveRecordGateway excutes the SQL command queries and returns the data record as arrays (for most finder methods).

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Record gateway constructor.
Method Summary
int | countRecords ( TActiveRecord $record, TActiveRecordCriteria $criteria) Returns the number of records that match the given criteria.
int | delete ( TActiveRecord $record) Delete the record.
int | deleteRecordsByCriteria ( TActiveRecord $record, TActiveRecordCriteria $criteria) Delete multiple records by criteria.
int | deleteRecordsByPk ( TActiveRecord $record, mixed $keys) Delete multiple records using primary keys.
array | findRecordByPK ( TActiveRecord $record, array $keys) Returns record data matching the given primary key(s). If the table uses composite key, specify the name value pairs as an array.
array | findRecordBySql ( TActiveRecord $record, TActiveRecordCriteria $criteria) Return record data from sql query.
mixed | findRecordsByCriteria ( TActiveRecord $record, TActiveRecordCriteria $criteria, boolean $iterator) Returns record data matching the given critera. If $iterator is true, it will return multiple rows as TDbDataReader otherwise it returns the first row data.
void | findRecordsByIndex ( TActiveRecord $record, mixed $criteria, mixed $fields, mixed $values)
array | findRecordsByPks ( TActiveRecord $record, array $keys) Returns records matching the list of given primary keys.
TDbDataReader | findRecordsBySql ( TActiveRecord $record, TActiveRecordCriteria $criteria) Return record data from sql query.
TDataGatewayCommand | getCommand ( TActiveRecord $record)
protected array | getInsertValues ( TActiveRecord $record)
protected TActiveRecordManager | getManager ()
protected void | getPrimaryKeyValues ( TActiveRecord $record)
TDbTableInfo | getRecordTableInfo ( TActiveRecord $record) Returns table information, trys the application cache first.
protected string | getRecordTableName ( TActiveRecord $record) Gets the table name from the 'TABLE' constant of the active record class if defined, otherwise use the class name as table name.
TDbTableInfo | getTableInfo ( TDbConnection $connection, string $tableName) Returns table information for table in the database connection.
protected void | getUpdateValues ( TActiveRecord $record)
int | insert ( TActiveRecord $record) Insert a new record.
void | onCreateCommand ( TDataGatewayCommand $sender, TDataGatewayEventParameter $param) Raised when a command is prepared and parameter binding is completed.
void | onExecuteCommand ( TDataGatewayCommand $sender, TDataGatewayResultEventParameter $param) Raised when a command is executed and the result from the database was returned.
protected void | raiseCommandEvent ( string $event, TDbCommand $command, TActiveRecord $record, TActiveRecordCriteria $criteria) Raise the corresponding command event, insert, update, delete or select.
int | update ( TActiveRecord $record) Update the record.
protected void | updateAssociatedRecords ( TActiveRecord $record, mixed $updateBelongsTo)
protected void | updatePostInsert ( TActiveRecord $record) Sets the last insert ID to the corresponding property of the record if available.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | TABLE_CONST | Constant name for specifying optional table name in TActiveRecord.
string | TABLE_METHOD | Method name for returning optional table name in in TActiveRecord
Constructor Details

__construct

public __construct Array

Record gateway constructor.
Method Details

countRecords

public int countRecords (TActiveRecord $record , TActiveRecordCriteria $criteria )

Returns the number of records that match the given criteria.

Input
TActiveRecord | $record | active record finder instance.
TActiveRecordCriteria | $criteria | search criteria
Output
int | number of records.
Exception

delete

public int delete (TActiveRecord $record )

Delete the record.

Input
TActiveRecord | $record | record to be deleted.
Output
int | number of rows affected.
Exception

deleteRecordsByCriteria

public int deleteRecordsByCriteria (TActiveRecord $record , TActiveRecordCriteria $criteria )

Delete multiple records by criteria.

Input
TActiveRecord | $record | active record finder instance.
TActiveRecordCriteria | $criteria | search criteria
Output
int | number of records.
Exception

deleteRecordsByPk

public int deleteRecordsByPk (TActiveRecord $record , mixed $keys )

Delete multiple records using primary keys.

Input
TActiveRecord | $record | finder instance.
mixed | $keys |
Output
int | number of rows deleted.
Exception

findRecordByPK

public array findRecordByPK (TActiveRecord $record , array $keys )

Returns record data matching the given primary key(s). If the table uses composite key, specify the name value pairs as an array.

Input
TActiveRecord | $record | active record instance.
array | $keys | primary name value pairs
Output
array | record data
Exception

findRecordBySql

public array findRecordBySql (TActiveRecord $record , TActiveRecordCriteria $criteria )

Return record data from sql query.

Input
TActiveRecord | $record | active record finder instance.
TActiveRecordCriteria | $criteria | sql query
Output
array | result.
Exception

findRecordsByCriteria

public mixed findRecordsByCriteria (TActiveRecord $record , TActiveRecordCriteria $criteria , boolean $iterator )

Returns record data matching the given critera. If $iterator is true, it will return multiple rows as TDbDataReader otherwise it returns the first row data.

Input
TActiveRecord | $record | active record finder instance.
TActiveRecordCriteria | $criteria | search criteria.
boolean | $iterator | true to return multiple rows as iterator, false returns first row.
Output
mixed | matching data.
Exception

findRecordsByIndex

public void findRecordsByIndex (TActiveRecord $record , mixed $criteria , mixed $fields , mixed $values )

Input
TActiveRecord | $record
mixed | $criteria
mixed | $fields
mixed | $values
Output
Exception

findRecordsByPks

public array findRecordsByPks (TActiveRecord $record , array $keys )

Returns records matching the list of given primary keys.

Input
TActiveRecord | $record | active record instance.
array | $keys | list of primary name value pairs
Output
array | matching data.
Exception

findRecordsBySql

public TDbDataReader findRecordsBySql (TActiveRecord $record , TActiveRecordCriteria $criteria )

Return record data from sql query.

Input
TActiveRecord | $record | active record finder instance.
TActiveRecordCriteria | $criteria | sql query
Output
TDbDataReader | result iterator.
Exception

getCommand

public TDataGatewayCommand getCommand (TActiveRecord $record )

Input
TActiveRecord $record
Output
Exception

getInsertValues

protected array getInsertValues (TActiveRecord $record )

Input
TActiveRecord | $record | record
Output
array | insert values.
Exception

getManager

protected TActiveRecordManager getManager ()

Output
TActiveRecordManager record manager.
Exception

getPrimaryKeyValues

protected void getPrimaryKeyValues (TActiveRecord $record )

Input
TActiveRecord $record
Output
Exception

getRecordTableInfo

public TDbTableInfo getRecordTableInfo (TActiveRecord $record )

Returns table information, trys the application cache first.

Input
TActiveRecord | $record
Output
TDbTableInfo | table information.
Exception

getRecordTableName

protected string getRecordTableName (TActiveRecord $record )

Gets the table name from the 'TABLE' constant of the active record class if defined, otherwise use the class name as table name.

Input
TActiveRecord | $record | active record instance
Output
string | table name for the given record class.
Exception

getTableInfo

public TDbTableInfo getTableInfo (TDbConnection $connection , string $tableName )

Returns table information for table in the database connection.

Input
TDbConnection | $connection | database connection
string | $tableName | table name
Output
TDbTableInfo | table details.
Exception

getUpdateValues

protected void getUpdateValues (TActiveRecord $record )

Input
TActiveRecord $record
Output
Exception

insert

public int insert (TActiveRecord $record )

Insert a new record.

Input
TActiveRecord | $record | new record.
Output
int | number of rows affected.
Exception

onCreateCommand

public void onCreateCommand (TDataGatewayCommand $sender , TDataGatewayEventParameter $param )

Raised when a command is prepared and parameter binding is completed.

The parameter object is TDataGatewayEventParameter of which the TDataGatewayEventParameter::getCommand property can be inspected to obtain the sql query to be executed. This method also raises the OnCreateCommand event on the ActiveRecord object calling this gateway.

Input
TDataGatewayCommand | $sender | originator $sender
TDataGatewayEventParameter | $param |
Output
Exception

onExecuteCommand

public void onExecuteCommand (TDataGatewayCommand $sender , TDataGatewayResultEventParameter $param )

Raised when a command is executed and the result from the database was returned.

The parameter object is TDataGatewayResultEventParameter of which the TDataGatewayEventParameter::getResult property contains the data return from the database. The data returned can be changed by setting the TDataGatewayEventParameter::setResult property. This method also raises the OnCreateCommand event on the ActiveRecord object calling this gateway.

Input
TDataGatewayCommand | $sender | originator $sender
TDataGatewayResultEventParameter | $param |
Output
Exception

raiseCommandEvent

protected void raiseCommandEvent (string $event , TDbCommand $command , TActiveRecord $record , TActiveRecordCriteria $criteria )

Raise the corresponding command event, insert, update, delete or select.

Input
string | $event | command type
TDbCommand | $command | sql command to be executed.
TActiveRecord | $record | active record
TActiveRecordCriteria | $criteria | data for the command.
Output
Exception

update

public int update (TActiveRecord $record )

Update the record.

Input
TActiveRecord | $record | dirty record.
Output
int | number of rows affected.
Exception

updateAssociatedRecords

protected void updateAssociatedRecords (TActiveRecord $record , mixed $updateBelongsTo )

Input
TActiveRecord | $record
mixed | $updateBelongsTo
Output
Exception

updatePostInsert

protected void updatePostInsert (TActiveRecord $record )

Sets the last insert ID to the corresponding property of the record if available.

Input
TActiveRecord $record record for insertion
Output
Exception

Constant Details

TABLE_CONST

Constant name for specifying optional table name in TActiveRecord.

Type:

string

Value:

'TABLE'

TABLE_METHOD

Method name for returning optional table name in in TActiveRecord

Type:

string

Value:

'table'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRecordManager

Class TActiveRecordManager (Class Overview)

TComponent
   |
   --TActiveRecordManager

TActiveRecordManager provides the default DB connection, default active record gateway, and table meta data inspector.

The default connection can be set as follows:

1      TActiveRecordManager::getInstance()->setDbConnection($conn);
All new active record created after setting the DbConnection will use that connection unless the custom ActiveRecord class overrides the ActiveRecord::getDbConnection().

Set the Cache property to an ICache object to allow the active record gateway to cache the table meta data information.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected TActiveRecordGateway | createRecordGateway ()
ICache | getCache ()
TDbConnection | getDbConnection ()
TActiveRecordManager | getInstance ( mixed $self)
TActiveRecordInvalidFinderResult | getInvalidFinderResult ()
TActiveRecordGateway | getRecordGateway ()
void | setCache ( ICache $value)
void | setDbConnection ( TDbConnection $conn)
void | setInvalidFinderResult ( TActiveRecordInvalidFinderResult $value) Define the way an active record finder react if an invalid magic-finder invoked
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createRecordGateway

protected TActiveRecordGateway createRecordGateway ()

Output
TActiveRecordGateway default record gateway.
Exception

getCache

public ICache getCache ()

Output
ICache application cache.
Exception

getDbConnection

public TDbConnection getDbConnection ()

Output
TDbConnection default database connection
Exception

getInstance

public TActiveRecordManager getInstance (mixed $self )

Input
mixed | $self
Output
TActiveRecordManager | static instance of record manager.
Exception

getInvalidFinderResult

public TActiveRecordInvalidFinderResult getInvalidFinderResult ()

Output
TActiveRecordInvalidFinderResult Defaults to 'Null'.
Exception

getRecordGateway

public TActiveRecordGateway getRecordGateway ()

Output
TActiveRecordGateway record gateway.
Exception

setCache

public void setCache (ICache $value )

Input
ICache $value application cache
Output
Exception

setDbConnection

public void setDbConnection (TDbConnection $conn )

Input
TDbConnection $conn default database connection
Output
Exception

setInvalidFinderResult

public void setInvalidFinderResult (TActiveRecordInvalidFinderResult $value )

Define the way an active record finder react if an invalid magic-finder invoked

Input
TActiveRecordInvalidFinderResult $value
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRecordBelongsTo

Class TActiveRecordBelongsTo (Class Overview)

TActiveRecordRelation
   |
   --TActiveRecordBelongsTo

Implements the foreign key relationship (TActiveRecord::BELONGS_TO) between the source objects and the related foreign object. Consider the entity relationship between a Team and a Player.

1      +------+            +--------+
2      | Team | 1 <----- * | Player |
3      +------+            +--------+
Where one team may have 0 or more players and each player belongs to only one team. We may model Team-Player object relationship as active record as follows.

1      class TeamRecord extends TActiveRecord
2      {
3          // see TActiveRecordHasMany for detailed definition.
4       }
5      class PlayerRecord extends TActiveRecord
6      {
7          const TABLE='player';
8          public $player_id; //primary key
9               public $team_name; //foreign key player.team_name <-> team.name
10                    public $age;
11         public $team; //foreign object TeamRecord
12
12
13         public static $RELATIONS = array
14         (
15                'team' => array(self::BELONGS_TO, 'TeamRecord')
16         );
17
18           public static function finder($className=__CLASS__)
19           {
20               return parent::finder($className);
21           }
22     }
The static <tt>$RELATIONS</tt> property of PlayerRecord defines that the property <tt>$team</tt> belongs to a <tt>TeamRecord</tt>.

The team object may be fetched as follows.

1      $players = PlayerRecord::finder()->with_team()->findAll();
The method <tt>with_xxx()</tt> (where <tt>xxx</tt> is the relationship property name, in this case, <tt>team</tt>) fetchs the corresponding TeamRecords using a second query (not by using a join). The <tt>with_xxx()</tt> accepts the same arguments as other finder methods of TActiveRecord, e.g. <tt>with_team('location = ?', 'Madrid')</tt>.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected void | collectForeignObjects ( array &$results) Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
array | getRelationForeignKeys ()
protected void | setObjectProperty ( TActiveRecord $source, array $properties, mixed &$collections) Sets the foreign objects to the given property on the source object.
boolean | updateAssociatedRecords () Updates the source object first.
Methods Inherited From TActiveRecordRelation
TActiveRecordRelation::fetchResultsInto(), TActiveRecordRelation::findForeignKeys(), TActiveRecordRelation::findForeignObjects(), TActiveRecordRelation::getContext(), TActiveRecordRelation::getCriteria(), TActiveRecordRelation::getIndexValues(), TActiveRecordRelation::getObjectHash(), TActiveRecordRelation::getSourceRecord(), TActiveRecordRelation::populateResult(), TActiveRecordRelation::setObjectProperty(), TActiveRecordRelation::setResultCollection(), TActiveRecordRelation::__call()
Method Details

collectForeignObjects

protected void collectForeignObjects (array &$results )

Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.

Input
array &$results original results.
Output
Exception

getRelationForeignKeys

public array getRelationForeignKeys ()

Output
array foreign key field names as key and object properties as value.
Exception

setObjectProperty

protected void setObjectProperty (TActiveRecord $source , array $properties , mixed &$collections )

Sets the foreign objects to the given property on the source object.

Input
TActiveRecord | $source | source object.
array | $properties | foreign objects.
mixed | &$collections |
Output
Exception

updateAssociatedRecords

public boolean updateAssociatedRecords ()

Updates the source object first.

Output
boolean true if all update are success (including if no update was required), false otherwise .
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRecordHasMany

Class TActiveRecordHasMany (Class Overview)

TActiveRecordRelation
   |
   --TActiveRecordHasMany

Implements TActiveRecord::HAS_MANY relationship between the source object having zero or more foreign objects. Consider the entity relationship between a Team and a Player.

1      +------+            +--------+
2      | Team | 1 <----- * | Player |
3      +------+            +--------+
Where one team may have 0 or more players and each player belongs to only one team. We may model Team-Player object relationship as active record as follows.

1      class TeamRecord extends TActiveRecord
2      {
3          const TABLE='team';
4          public $name; //primary key
5               public $location;
6
7          public $players=array(); //list of players
8
8
9          public static $RELATIONS=array
10         (
11             'players' => array(self::HAS_MANY, 'PlayerRecord')
12         );
13
14           public static function finder($className=__CLASS__)
15           {
16               return parent::finder($className);
17           }
18     }
19     class PlayerRecord extends TActiveRecord
20     {
21         // see TActiveRecordBelongsTo for detailed definition
22      }
The static <tt>$RELATIONS</tt> property of TeamRecord defines that the property <tt>$players</tt> has many <tt>PlayerRecord</tt>s.

The players list may be fetched as follows.

1      $team = TeamRecord::finder()->with_players()->findAll();
The method <tt>with_xxx()</tt> (where <tt>xxx</tt> is the relationship property name, in this case, <tt>players</tt>) fetchs the corresponding PlayerRecords using a second query (not by using a join). The <tt>with_xxx()</tt> accepts the same arguments as other finder methods of TActiveRecord, e.g. <tt>with_players('age < ?', 35)</tt>.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected void | collectForeignObjects ( array &$results) Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
array | getRelationForeignKeys ()
boolean | updateAssociatedRecords () Updates the associated foreign objects.
Methods Inherited From TActiveRecordRelation
TActiveRecordRelation::fetchResultsInto(), TActiveRecordRelation::findForeignKeys(), TActiveRecordRelation::findForeignObjects(), TActiveRecordRelation::getContext(), TActiveRecordRelation::getCriteria(), TActiveRecordRelation::getIndexValues(), TActiveRecordRelation::getObjectHash(), TActiveRecordRelation::getSourceRecord(), TActiveRecordRelation::populateResult(), TActiveRecordRelation::setObjectProperty(), TActiveRecordRelation::setResultCollection(), TActiveRecordRelation::__call()
Method Details

collectForeignObjects

protected void collectForeignObjects (array &$results )

Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.

Input
array &$results original results.
Output
Exception

getRelationForeignKeys

public array getRelationForeignKeys ()

Output
array foreign key field names as key and object properties as value.
Exception

updateAssociatedRecords

public boolean updateAssociatedRecords ()

Updates the associated foreign objects.

Output
boolean true if all update are success (including if no update was required), false otherwise .
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRecordHasManyAssociation

Class TActiveRecordHasManyAssociation (Class Overview)

TActiveRecordRelation
   |
   --TActiveRecordHasManyAssociation

Implements the M-N (many to many) relationship via association table.

Consider the entity relationship between Articles and Categories via the association table <tt>Article_Category</tt>.

1      +---------+            +------------------+            +----------+
2      | Article | * -----> * | Article_Category | * <----- * | Category |
3      +---------+            +------------------+            +----------+
Where one article may have 0 or more categories and each category may have 0 or more articles. We may model Article-Category object relationship as active record as follows.

1      class ArticleRecord
2      {
3          const TABLE='Article';
4          public $article_id;
5
6          public $Categories=array(); //foreign object collection.
7
7
8          public static $RELATIONS = array
9          (
10             'Categories' => array(self::MANY_TO_MANY, 'CategoryRecord', 'Article_Category')
11         );
12
13         public static function finder($className=__CLASS__)
14         {
15             return parent::finder($className);
16         }
17     }
18     class CategoryRecord
19     {
20         const TABLE='Category';
21         public $category_id;
22
23         public $Articles=array();
24
25         public static $RELATIONS = array
26         (
27             'Articles' => array(self::MANY_TO_MANY, 'ArticleRecord', 'Article_Category')
28         );
29
30         public static function finder($className=__CLASS__)
31         {
32             return parent::finder($className);
33         }
34     }

The static <tt>$RELATIONS</tt> property of ArticleRecord defines that the property <tt>$Categories</tt> has many <tt>CategoryRecord</tt>s. Similar, the static <tt>$RELATIONS</tt> property of CategoryRecord defines many ArticleRecords.

The articles with categories list may be fetched as follows.

1      $articles = TeamRecord::finder()->withCategories()->findAll();
The method <tt>with_xxx()</tt> (where <tt>xxx</tt> is the relationship property name, in this case, <tt>Categories</tt>) fetchs the corresponding CategoryRecords using a second query (not by using a join). The <tt>with_xxx()</tt> accepts the same arguments as other finder methods of TActiveRecord.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected void | collectForeignObjects ( array &$results) Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects using association table.
void | createCommand ( TSqlCriteria $criteria, TTableInfo $foreignKeys, array $indexValues, array $sourceKeys)
protected TActiveRecord | createFkObject ( string $type, array $row, array $foreignKeys)
protected void | fetchForeignObjects ( array &$results, array $foreignKeys, mixed $indexValues, mixed $sourceKeys) Fetches the foreign objects using TActiveRecord::findAllByIndex()
protected string | getAssociationJoin ( array $foreignKeys, array $indexValues, array $sourceKeys) SQL inner join for M-N relationship via association table.
protected TDbTableInfo | getAssociationTable ()
protected TDbCommandBuilder | getAssociationTableCommandBuilder ()
protected TDataGatewayCommand | getCommandBuilder ()
protected TDataGatewayCommand | getForeignCommandBuilder ()
protected TDbTableInfo | getForeignTable ()
array | getRelationForeignKeys ()
protected string | getSourceColumns ( array $sourceKeys)
protected TDbTableInfo | getSourceTable ()
boolean | updateAssociatedRecords () Updates the associated foreign objects.
Methods Inherited From TActiveRecordRelation
TActiveRecordRelation::fetchResultsInto(), TActiveRecordRelation::findForeignKeys(), TActiveRecordRelation::findForeignObjects(), TActiveRecordRelation::getContext(), TActiveRecordRelation::getCriteria(), TActiveRecordRelation::getIndexValues(), TActiveRecordRelation::getObjectHash(), TActiveRecordRelation::getSourceRecord(), TActiveRecordRelation::populateResult(), TActiveRecordRelation::setObjectProperty(), TActiveRecordRelation::setResultCollection(), TActiveRecordRelation::__call()
Method Details

collectForeignObjects

protected void collectForeignObjects (array &$results )

Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects using association table.

Input
array &$results original results.
Output
Exception

createCommand

public void createCommand (TSqlCriteria $criteria , TTableInfo $foreignKeys , array $indexValues , array $sourceKeys )

Input
TSqlCriteria | $criteria |
TTableInfo | $foreignKeys | association table info
array | $indexValues | field names
array | $sourceKeys | field values
Output
Exception

createFkObject

protected TActiveRecord createFkObject (string $type , array $row , array $foreignKeys )

Input
string | $type | active record class name.
array | $row | row data
array | $foreignKeys | foreign key column names
Output
Exception

fetchForeignObjects

protected void fetchForeignObjects (array &$results , array $foreignKeys , mixed $indexValues , mixed $sourceKeys )

Fetches the foreign objects using TActiveRecord::findAllByIndex()

Input
array | &$results | field names
array | $foreignKeys | foreign key index values.
mixed | $indexValues |
mixed | $sourceKeys |
Output
Exception

getAssociationJoin

protected string getAssociationJoin (array $foreignKeys , array $indexValues , array $sourceKeys )

SQL inner join for M-N relationship via association table.

Input
array | $foreignKeys | foreign table column key names.
array | $indexValues | source table index values.
array | $sourceKeys | source table column names.
Output
string | inner join condition for M-N relationship via association table.
Exception

getAssociationTable

protected TDbTableInfo getAssociationTable ()

Output
TDbTableInfo association table information.
Exception

getAssociationTableCommandBuilder

protected TDbCommandBuilder getAssociationTableCommandBuilder ()

Output
Exception

getCommandBuilder

protected TDataGatewayCommand getCommandBuilder ()

Output
Exception

getForeignCommandBuilder

protected TDataGatewayCommand getForeignCommandBuilder ()

Output
Exception

getForeignTable

protected TDbTableInfo getForeignTable ()

Output
TDbTableInfo foreign table information.
Exception

getRelationForeignKeys

public array getRelationForeignKeys ()

Output
array 2 arrays of source keys and foreign keys from the association table.
Exception

getSourceColumns

protected string getSourceColumns (array $sourceKeys )

Input
array | $sourceKeys | source table column names.
Output
string | comma separated source column names.
Exception

getSourceTable

protected TDbTableInfo getSourceTable ()

Output
TDbTableInfo source table information.
Exception

updateAssociatedRecords

public boolean updateAssociatedRecords ()

Updates the associated foreign objects.

Output
boolean true if all update are success (including if no update was required), false otherwise .
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRecordHasOne

Class TActiveRecordHasOne (Class Overview)

TActiveRecordRelation
   |
   --TActiveRecordHasOne

TActiveRecordHasOne models the object relationship that a record (the source object) property is an instance of foreign record object having a foreign key related to the source object. The HAS_ONE relation is very similar to the HAS_MANY relationship (in fact, it is equivalent in the entities relationship point of view).

The difference of HAS_ONE from HAS_MANY is that the foreign object is singular. That is, HAS_MANY will return a collection of records while HAS_ONE returns the corresponding record.

Consider the entity relationship between a Car and a Engine.

1      +-----+            +--------+
2      | Car | 1 <----- 1 | Engine |
3      +-----+            +--------+
Where each engine belongs to only one car, that is, the Engine entity has a foreign key to the Car's primary key. We may model Engine-Car object relationship as active record as follows.

1      class CarRecord extends TActiveRecord
2      {
3          const TABLE='car';
4          public $car_id; //primary key
5               public $colour;
6
7          public $engine; //engine foreign object
8
8
9          public static $RELATIONS=array
10         (
11             'engine' => array(self::HAS_ONE, 'EngineRecord')
12         );
13
14           public static function finder($className=__CLASS__)
15           {
16               return parent::finder($className);
17           }
18     }
19     class EngineRecord extends TActiveRecord
20     {
21         const TABLE='engine';
22         public $engine_id;
23         public $capacity;
24         public $car_id; //foreign key to cars
25
25
26           public static function finder($className=__CLASS__)
27           {
28               return parent::finder($className);
29           }
30     }
The static <tt>$RELATIONS</tt> property of CarRecord defines that the property <tt>$engine</tt> that will reference an <tt>EngineRecord</tt> instance.

The car record with engine property list may be fetched as follows.

1      $cars = CarRecord::finder()->with_engine()->findAll();
The method <tt>with_xxx()</tt> (where <tt>xxx</tt> is the relationship property name, in this case, <tt>engine</tt>) fetchs the corresponding EngineRecords using a second query (not by using a join). The <tt>with_xxx()</tt> accepts the same arguments as other finder methods of TActiveRecord, e.g. <tt>with_engine('capacity < ?', 3.8)</tt>.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected void | collectForeignObjects ( array &$results) Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
array | getRelationForeignKeys ()
protected void | setObjectProperty ( TActiveRecord $source, array $properties, mixed &$collections) Sets the foreign objects to the given property on the source object.
boolean | updateAssociatedRecords () Updates the associated foreign objects.
Methods Inherited From TActiveRecordRelation
TActiveRecordRelation::fetchResultsInto(), TActiveRecordRelation::findForeignKeys(), TActiveRecordRelation::findForeignObjects(), TActiveRecordRelation::getContext(), TActiveRecordRelation::getCriteria(), TActiveRecordRelation::getIndexValues(), TActiveRecordRelation::getObjectHash(), TActiveRecordRelation::getSourceRecord(), TActiveRecordRelation::populateResult(), TActiveRecordRelation::setObjectProperty(), TActiveRecordRelation::setResultCollection(), TActiveRecordRelation::__call()
Method Details

collectForeignObjects

protected void collectForeignObjects (array &$results )

Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.

Input
array &$results original results.
Output
Exception

getRelationForeignKeys

public array getRelationForeignKeys ()

Output
array foreign key field names as key and object properties as value.
Exception

setObjectProperty

protected void setObjectProperty (TActiveRecord $source , array $properties , mixed &$collections )

Sets the foreign objects to the given property on the source object.

Input
TActiveRecord | $source | source object.
array | $properties | foreign objects.
mixed | &$collections |
Output
Exception

updateAssociatedRecords

public boolean updateAssociatedRecords ()

Updates the associated foreign objects.

Output
boolean true if all update are success (including if no update was required), false otherwise .
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRecordRelation

Class TActiveRecordRelation (Class Overview)

Direct Known Sub-classes:

                                    TActiveRecordBelongsTo
                                                , TActiveRecordHasMany
                                                , TActiveRecordHasManyAssociation
                                                , TActiveRecordHasOne

Base class for active record relationships.

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

                    Constructor Summary

                    public

                            __construct
                            Array

Method Summary
protected abstract void | collectForeignObjects ( mixed &$results)
boolean | fetchResultsInto ( mixed $obj) Fetch results for current relationship.
protected array | findForeignKeys ( mixed $from, TActiveRecord $matchesRecord, mixed $loose, TActiveRecord $fromRecord) Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value.
protected TActiveRecord[] | findForeignObjects ( array $fields, array $indexValues) Fetches the foreign objects using TActiveRecord::findAllByIndex()
protected TActiveRecordRelationContext | getContext ()
protected TActiveRecordCriteria | getCriteria ()
protected array | getIndexValues ( array $keys, array $results) Obtain the foreign key index values from the results.
protected string | getObjectHash ( mixed $obj, array $properties)
abstract array | getRelationForeignKeys ()
protected TActiveRecord | getSourceRecord ()
protected void | populateResult ( array &$results, array $properties, array &$fkObjects, array $fields) Populate the results with the foreign objects found.
protected void | setObjectProperty ( TActiveRecord $source, array $properties, array &$collections) Sets the foreign objects to the given property on the source object.
protected void | setResultCollection ( array &$results, array &$collections, array $properties) Populates the result array with foreign objects (matched using foreign key hashed property values).
mixed | __call ( string $method, array $args) Dispatch the method calls to the source record finder object. When an instance of TActiveRecord or an array of TActiveRecord is returned the corresponding foreign objects are also fetched and assigned.

                    Constructor Details

__construct

                                public __construct
                                Array

            Method Details

collectForeignObjects

                                protected abstract void collectForeignObjects
                                (mixed &$results )

Input

mixed &$results

Output

Exception

fetchResultsInto

                                public boolean fetchResultsInto
                                (mixed $obj )

Fetch results for current relationship.

Input
mixed | $obj
Output
boolean | always true.
Exception

findForeignKeys

                                protected array findForeignKeys
                                (mixed $from , TActiveRecord $matchesRecord , mixed $loose , TActiveRecord $fromRecord )

Returns foreign keys in $fromRecord with source column names as key  and foreign column names in the corresponding $matchesRecord as value.

The method returns the first matching foreign key between these 2 records.

Input
mixed | $from
TActiveRecord | $matchesRecord
mixed | $loose
TActiveRecord | $fromRecord
Output
array | foreign keys with source column names as key and foreign column names as value.
Exception

findForeignObjects

                                protected TActiveRecord[] findForeignObjects
                                (array $fields , array $indexValues )

Fetches the foreign objects using TActiveRecord::findAllByIndex()

Input
array | $fields | field names
array | $indexValues | foreign key index values.
Output
TActiveRecord[] | foreign objects.
Exception

getContext

                                protected TActiveRecordRelationContext getContext
                                ()

Output

Exception

getCriteria

                                protected TActiveRecordCriteria getCriteria
                                ()

Output

Exception

getIndexValues

                                protected array getIndexValues
                                (array $keys , array $results )

Obtain the foreign key index values from the results.

Input
array | $keys | property names
array | $results | TActiveRecord results
Output
array | foreign key index values.
Exception

getObjectHash

                                protected string getObjectHash
                                (mixed $obj , array $properties )

Input
mixed | $obj | object or array to be hashed
array | $properties | name of property for hashing the properties.
Output
string | object hash using crc32 and serialize.
Exception

getRelationForeignKeys

                                public abstract array getRelationForeignKeys
                                ()

Output

                                    array
                 foreign key field names as key and object properties as value.

Exception

getSourceRecord

                                protected TActiveRecord getSourceRecord
                                ()

Output

Exception

populateResult

                                protected void populateResult
                                (array &$results , array $properties , array &$fkObjects , array $fields )

Populate the results with the foreign objects found.

Input
array | &$results | source results
array | $properties | source property names
array | &$fkObjects | foreign objects
array | $fields | foreign object field names.
Output
Exception

setObjectProperty

                                protected void setObjectProperty
                                (TActiveRecord $source , array $properties , array &$collections )

Sets the foreign objects to the given property on the source object.

Input
TActiveRecord | $source | source object.
array | $properties | source properties
array | &$collections | foreign objects.
Output
Exception

setResultCollection

                                protected void setResultCollection
                                (array &$results , array &$collections , array $properties )

Populates the result array with foreign objects (matched using foreign key hashed property values).

Input
array | &$results |
array | &$collections |
array | $properties | property names
Output
Exception

__call

                                public mixed __call
                                (string $method , array $args )

Dispatch the method calls to the source record finder object. When  an instance of TActiveRecord or an array of TActiveRecord is returned  the corresponding foreign objects are also fetched and assigned.

Multiple relationship calls can be chain together.

Input
string | $method | method name called
array | $args | method arguments
Output
mixed | TActiveRecord or array of TActiveRecord results depending on the method called.
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TActiveRecordRelationContext

Class TActiveRecordRelationContext (Class Overview)

TActiveRecordRelationContext holds information regarding record relationships  such as record relation property name, query criteria and foreign object record  class names.

This class is use internally by passing a context to the TActiveRecordRelation  constructor.

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

                    Constructor Summary

                    public

                            __construct
                            Array

Method Summary
string | getAssociationTable ()
string | getCondition ()
string | getFkField ()
string | getForeignRecordClass ()
TActiveRecord | getForeignRecordFinder ()
array | getParameters ()
string | getProperty ()
void | getPropertyValue ()
array | getRelationForeignKeys ()
TActiveRecordRelation | getRelationHandler ( TActiveRecordCriteria $criteria) Creates and return the TActiveRecordRelation handler for specific relationships.
string | getRelationType ()
TActiveRecord | getSourceRecord ()
boolean | hasAssociationTable ()
boolean | hasFkField ()
boolean | hasRecordRelation ()
protected void | isEmptyFkObject ( mixed $obj)
TActiveRecordRelationCommand | updateAssociatedRecords ( mixed $updateBelongsTo)

                    Constructor Details

__construct

                                public __construct
                                Array

            Method Details

getAssociationTable

                                public string getAssociationTable
                                ()

Output

                                    string
                 the M-N relationship association table name.

Exception

getCondition

                                public string getCondition
                                ()

Output

                                    string
                 the query condition for the relation as specified in RELATIONS

Exception

getFkField

                                public string getFkField
                                ()

Output

                                    string
                 foreign key field names, comma delimited.

Exception

getForeignRecordClass

                                public string getForeignRecordClass
                                ()

Output

                                    string
                 foreign record class name.

Exception

getForeignRecordFinder

                                public TActiveRecord getForeignRecordFinder
                                ()

Output

                                    TActiveRecord
                 corresponding relationship foreign object finder instance.

Exception

getParameters

                                public array getParameters
                                ()

Output

                                    array
                 the query parameters for the relation as specified in RELATIONS

Exception

getProperty

                                public string getProperty
                                ()

Output

                                    string
                 name of the record property that the relationship results will be assigned to.

Exception

getPropertyValue

                                public void getPropertyValue
                                ()

Output

Exception

getRelationForeignKeys

                                public array getRelationForeignKeys
                                ()

Output

                                    array
                 foreign key of this relations, the keys is dependent on the  relationship type.

Exception

getRelationHandler

                                public TActiveRecordRelation getRelationHandler
                                (TActiveRecordCriteria $criteria )

Creates and return the TActiveRecordRelation handler for specific relationships.

An instance of TActiveRecordHasOne, TActiveRecordBelongsTo, TActiveRecordHasMany,  or TActiveRecordHasManyAssocation will be returned.

Input
TActiveRecordCriteria | $criteria | search criteria
Output
TActiveRecordRelation | record relationship handler instnace.
Exception
throws | TActiveRecordException if property is not defined or missing.

getRelationType

                                public string getRelationType
                                ()

Output

                                    string
                 HAS_MANY, HAS_ONE, or BELONGS_TO

Exception

getSourceRecord

                                public TActiveRecord getSourceRecord
                                ()

Output

                                    TActiveRecord
                 the active record instance that queried for its related records.

Exception

hasAssociationTable

                                public boolean hasAssociationTable
                                ()

Output

                                    boolean
                 true if the relationship is HAS_MANY and requires an association table.

Exception

hasFkField

                                public boolean hasFkField
                                ()

Output

                                    boolean
                 true if the 3rd element of an TActiveRecord::$RELATION entry is set.

Exception

hasRecordRelation

                                public boolean hasRecordRelation
                                ()

Output

                                    boolean
                 true if the relation is defined in TActiveRecord::$RELATIONS

Exception

isEmptyFkObject

                                protected void isEmptyFkObject
                                (mixed $obj )

Input

mixed $obj

Output

Exception

updateAssociatedRecords

                                public TActiveRecordRelationCommand updateAssociatedRecords
                                (mixed $updateBelongsTo )

Input

mixed $updateBelongsTo

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TAPCCache

Class TAPCCache (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TCache
            |
            --TAPCCache

TAPCCache class

TAPCCache implements a cache application module based on APC.

By definition, cache does not ensure the existence of a value even if it never expires. Cache is not meant to be an persistent storage.

To use this module, the APC PHP extension must be loaded and set in the php.ini file the following:

1      apc.cache_by_default=0

Some usage examples of TAPCCache are as follows,

1      $cache=new TAPCCache;  // TAPCCache may also be loaded as a Prado application module
2       $cache->init(null);
3      $cache->add('object',$object);
4      $object2=$cache->get('object');

If loaded, TAPCCache will register itself with TApplication as the cache module. It can be accessed via TApplication::getCache().

TAPCCache may be configured in application configuration file as follows

1      <module id="cache" class="System.Caching.TAPCCache" />

Since: 3.0b
Author: Alban Hanry <compte_messagerie@hotmail.com>
Author: Knut Urdalen <knut.urdalen@gmail.com>
Method Summary
protected boolean | addValue ( string $key, string $value, integer $expire) Stores a value identified by a key into cache if the cache does not contain this key.
protected boolean | deleteValue ( string $key) Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
void | flush () Deletes all values from cache.
protected string | getValue ( string $key) Retrieves a value from cache with a specified key.
void | init ( TXmlElement $config) Initializes this module.
protected boolean | setValue ( string $key, string $value, integer $expire) Stores a value identified by a key in cache.
Methods Inherited From TCache
TCache::add(), TCache::delete(), TCache::flush(), TCache::generateUniqueKey(), TCache::get(), TCache::getKeyPrefix(), TCache::getPrimaryCache(), TCache::init(), TCache::offsetExists(), TCache::offsetGet(), TCache::offsetSet(), TCache::offsetUnset(), TCache::set(), TCache::setKeyPrefix(), TCache::setPrimaryCache(),
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

addValue

protected boolean addValue (string $key , string $value , integer $expire )

Stores a value identified by a key into cache if the cache does not contain this key.

This is the implementation of the method declared in the parent class.

Input
string | $key | the key identifying the value to be cached
string | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception

deleteValue

protected boolean deleteValue (string $key )

Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.

Input
string | $key | the key of the value to be deleted
Output
boolean | if no error happens during deletion
Exception

flush

public void flush ()

Deletes all values from cache.

Be careful of performing this operation if the cache is shared by multiple applications.

Output
Exception

getValue

protected string getValue (string $key )

Retrieves a value from cache with a specified key.

This is the implementation of the method declared in the parent class.

Input
string | $key | a unique key identifying the cached value
Output
string | the value stored in cache, false if the value is not in the cache or expired.
Exception

init

public void init (TXmlElement $config )

Initializes this module.

This method is required by the IModule interface.

Input
TXmlElement | $config | configuration for this module, can be null
Output
Exception
throws | TConfigurationException if apc extension is not installed or not started, check your php.ini

setValue

protected boolean setValue (string $key , string $value , integer $expire )

Stores a value identified by a key in cache.

This is the implementation of the method declared in the parent class.

Input
string | $key | the key identifying the value to be cached
string | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TApplicationStateCacheDependency

Class TApplicationStateCacheDependency (Class Overview)

TComponent
   |
   --TCacheDependency
      |
      --TApplicationStateCacheDependency

TApplicationStateCacheDependency class.

TApplicationStateCacheDependency performs dependency checking based on the mode of the currently running PRADO application. The dependency is reportedly as unchanged if and only if the application is running in performance mode.

You may chain this dependency together with other dependencies so that only when the application is not in performance mode the other dependencies will be checked.

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
boolean
getHasChanged ()
Performs the actual dependency checking.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getHasChanged

public boolean getHasChanged ()

Performs the actual dependency checking.

This method returns true if the currently running application is not in performance mode.

Output
boolean whether the dependency is changed or not.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCache

Class TCache (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TCache

Direct Known Sub-classes:

TAPCCache , TDbCache , TMemCache , TSqliteCache , TXCache

TCache class

TCache is the base class for cache classes with different cache storage implementation.

TCache implements the interface ICache with the following methods,

  • get : retrieve the value with a key (if any) from cache
  • set : store the value with a key into cache
  • add : store the value only if cache does not have this key
  • delete : delete the value with the specified key from cache
  • flush : delete all values from cache
Each value is associated with an expiration time. The get operation ensures that any expired value will not be returned. The expiration time by the number of seconds. A expiration time 0 represents never expire.

By definition, cache does not ensure the existence of a value even if it never expires. Cache is not meant to be an persistent storage.

Child classes must implement the following methods:

  • getValue
  • setValue
  • addValue
  • deleteValue
and optionally flush

Since version 3.1.2, TCache implements the ArrayAccess interface such that the cache acts as an array.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
boolean | add ( string $id, mixed $value, integer $expire, ICacheDependency $dependency) Stores a value identified by a key into cache if the cache does not contain this key.
protected abstract boolean | addValue ( string $key, string $value, integer $expire) Stores a value identified by a key into cache if the cache does not contain this key.
boolean | delete ( string $id) Deletes a value with the specified key from cache
protected abstract boolean | deleteValue ( string $key) Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.
void | flush () Deletes all values from cache.
protected sring | generateUniqueKey ( string $key)
mixed | get ( string $id) Retrieves a value from cache with a specified key.
string | getKeyPrefix ()
boolean | getPrimaryCache ()
protected abstract string | getValue ( string $key) Retrieves a value from cache with a specified key.
void | init ( TXmlElement $config) Initializes the cache module.
boolean | offsetExists ( string $id) Returns whether there is a cache entry with a specified key.
void | offsetGet ( mixed $id)
void | offsetSet ( mixed $id, mixed $value)
void | offsetUnset ( mixed $id)
boolean | set ( string $id, mixed $value, integer $expire, ICacheDependency $dependency) Stores a value identified by a key into cache.
void | setKeyPrefix ( string $value)
void | setPrimaryCache ( boolean $value)
protected abstract boolean | setValue ( string $key, string $value, integer $expire) Stores a value identified by a key in cache.
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

add

public boolean add (string $id , mixed $value , integer $expire , ICacheDependency $dependency )

Stores a value identified by a key into cache if the cache does not contain this key.

Nothing will be done if the cache already contains the key or if value is empty.

Input
string | $id | the key identifying the value to be cached
mixed | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
ICacheDependency | $dependency | dependency of the cached item. If the dependency changes, the item is labeled invalid.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception

addValue

protected abstract boolean addValue (string $key , string $value , integer $expire )

Stores a value identified by a key into cache if the cache does not contain this key.

This method should be implemented by child classes to store the data in specific cache storage. The uniqueness and dependency are handled in add() already. So only the implementation of data storage is needed.

Input
string | $key | the key identifying the value to be cached
string | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception

delete

public boolean delete (string $id )

Deletes a value with the specified key from cache

Input
string | $id | the key of the value to be deleted
Output
boolean | if no error happens during deletion
Exception

deleteValue

protected abstract boolean deleteValue (string $key )

Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.

Input
string | $key | the key of the value to be deleted
Output
boolean | if no error happens during deletion
Exception

flush

public void flush ()

Deletes all values from cache.

Be careful of performing this operation if the cache is shared by multiple applications. Child classes may implement this method to realize the flush operation.

Output
Exception
throws TNotSupportedException if this method is not overridden by child classes

generateUniqueKey

protected sring generateUniqueKey (string $key )

Input
string | $key | a key identifying a value to be cached
Output
sring | a key generated from the provided key which ensures the uniqueness across applications
Exception

get

public mixed get (string $id )

Retrieves a value from cache with a specified key.

Input
string | $id | a key identifying the cached value
Output
mixed | the value stored in cache, false if the value is not in the cache or expired.
Exception

getKeyPrefix

public string getKeyPrefix ()

Output
string a unique prefix for the keys of cached values. If it is not explicitly set, it will take the value of TApplication::getUniqueID.
Exception

getPrimaryCache

public boolean getPrimaryCache ()

Output
boolean whether this cache module is used as primary/system cache. A primary cache is used by PRADO core framework to cache data such as parsed templates, themes, etc.
Exception

getValue

protected abstract string getValue (string $key )

Retrieves a value from cache with a specified key.

This method should be implemented by child classes to store the data in specific cache storage. The uniqueness and dependency are handled in get() already. So only the implementation of data retrieval is needed.

Input
string | $key | a unique key identifying the cached value
Output
string | the value stored in cache, false if the value is not in the cache or expired.
Exception

init

public void init (TXmlElement $config )

Initializes the cache module.

This method initializes the cache key prefix and registers the cache module with the application if the cache is primary.

Input
TXmlElement $config the module configuration
Output
Exception

offsetExists

public boolean offsetExists (string $id )

Returns whether there is a cache entry with a specified key.

This method is required by the interface ArrayAccess.

Input
string $id a key identifying the cached value
Output
Exception

offsetGet

public void offsetGet (mixed $id )

Input
mixed $id
Output
Exception

offsetSet

public void offsetSet (mixed $id , mixed $value )

Input
mixed | $id
mixed | $value
Output
Exception

offsetUnset

public void offsetUnset (mixed $id )

Input
mixed $id
Output
Exception

set

public boolean set (string $id , mixed $value , integer $expire , ICacheDependency $dependency )

Stores a value identified by a key into cache.

If the cache already contains such a key, the existing value and expiration time will be replaced with the new ones. If the value is empty, the cache key will be deleted.

Input
string | $id | the key identifying the value to be cached
mixed | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
ICacheDependency | $dependency | dependency of the cached item. If the dependency changes, the item is labeled invalid.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception

setKeyPrefix

public void setKeyPrefix (string $value )

Input
string $value a unique prefix for the keys of cached values
Output
Exception

setPrimaryCache

public void setPrimaryCache (boolean $value )

Input
boolean $value whether this cache module is used as primary/system cache. Defaults to false.
Output
Exception

setValue

protected abstract boolean setValue (string $key , string $value , integer $expire )

Stores a value identified by a key in cache.

This method should be implemented by child classes to store the data in specific cache storage. The uniqueness and dependency are handled in set() already. So only the implementation of data storage is needed.

Input
string | $key | the key identifying the value to be cached
string | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCacheDependency

Class TCacheDependency (Class Overview)

TComponent
   |
   --TCacheDependency

Direct Known Sub-classes:

TFileCacheDependency , TDirectoryCacheDependency , TGlobalStateCacheDependency , TChainedCacheDependency , TApplicationStateCacheDependency

TCacheDependency class.

TCacheDependency is the base class implementing ICacheDependency interface. Descendant classes must implement getHasChanged() to provide actual dependency checking logic.

The property value of getHasChanged tells whether the dependency is changed or not.

You may disable the dependency checking by setting setEnabled to false.

Note, since the dependency objects often need to be serialized so that they can persist across requests, you may need to implement __sleep() and __wakeup() if the dependency objects contain resource handles which are not serializable.

Currently, the following dependency classes are provided in the PRADO release:

  • TFileCacheDependency: checks whether a file is changed or not
  • TDirectoryCacheDependency: checks whether a directory is changed or not
  • TGlobalStateCacheDependency: checks whether a global state is changed or not
  • TChainedCacheDependency: checks whether any of a list of dependencies is changed or not

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()


PRADO API Manual: Docs For Class TCacheDependencyList

Class TCacheDependencyList (Class Overview)

TComponent
   |
   --TList
      |
      --TCacheDependencyList

TCacheDependencyList class.

TCacheDependencyList represents a list of cache dependency objects. Only objects implementing ICacheDependency can be added into this list.

TCacheDependencyList can be used like an array. See TList for more details.

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void
insertAt ( integer $index, mixed $item)
Inserts an item at the specified position.
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by performing additional type checking for each newly added item.

Input
integer | $index | the specified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is not a dependency instance


PRADO API Manual: Docs For Class TChainedCacheDependency

Class TChainedCacheDependency (Class Overview)

TComponent
   |
   --TCacheDependency
      |
      --TChainedCacheDependency

TChainedCacheDependency class.

TChainedCacheDependency represents a list of cache dependency objects and performs the dependency checking based on the checking results of these objects. If any of them reports a dependency change, TChainedCacheDependency will return true for the checking.

To add dependencies to TChainedCacheDependency, use Dependencies which gives a TCacheDependencyList instance and can be used like an array (see TList for more details}).

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
TCacheDependencyList | getDependencies ()
boolean | getHasChanged () Performs the actual dependency checking.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getDependencies

public TCacheDependencyList getDependencies ()

Output
TCacheDependencyList list of dependency objects
Exception

getHasChanged

public boolean getHasChanged ()

Performs the actual dependency checking.

This method returns true if any of the dependency objects reports a dependency change.

Output
boolean whether the dependency is changed or not.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDirectoryCacheDependency

Class TDirectoryCacheDependency (Class Overview)

TComponent
   |
   --TCacheDependency
      |
      --TDirectoryCacheDependency

TDirectoryCacheDependency class.

TDirectoryCacheDependency performs dependency checking based on the modification time of the files contained in the specified directory. The directory being checked is specified via Directory.

By default, all files under the specified directory and subdirectories will be checked. If the last modification time of any of them is changed or if different number of files are contained in a directory, the dependency is reported as changed. By specifying RecursiveCheck and RecursiveLevel, one can limit the checking to a certain depth of the subdirectories.

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
protected array | generateTimestamps ( string $directory, int $level) Determines the last modification time for files under the directory.
string | getDirectory ()
boolean | getHasChanged () Performs the actual dependency checking.
boolean | getRecursiveCheck ()
int | getRecursiveLevel ()
void | setDirectory ( string $directory)
void | setRecursiveCheck ( boolean $value)
void | setRecursiveLevel ( int $value) Sets a value indicating the depth of the subdirectories to be checked.
protected boolean | validateDirectory ( string $directory) Checks to see if the specified subdirectory should be checked for dependency.
protected boolean | validateFile ( string $fileName) Checks to see if the file should be checked for dependency.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

generateTimestamps

protected array generateTimestamps (string $directory , int $level )

Determines the last modification time for files under the directory.

This method may go recursively into subdirectories if RecursiveCheck is set true.

Input
string | $directory | the directory name
int | $level | level of the recursion
Output
array | list of file modification time indexed by the file path
Exception

getDirectory

public string getDirectory ()

Output
string the directory to be checked
Exception

getHasChanged

public boolean getHasChanged ()

Performs the actual dependency checking.

This method returns true if the directory is changed.

Output
boolean whether the dependency is changed or not.
Exception

getRecursiveCheck

public boolean getRecursiveCheck ()

Output
boolean whether the subdirectories of the directory will also be checked. It defaults to true.
Exception

getRecursiveLevel

public int getRecursiveLevel ()

Output
int the depth of the subdirectories to be checked. It defaults to -1, meaning unlimited depth.
Exception

setDirectory

public void setDirectory (string $directory )

Input
string | $directory | the directory to be checked
Output
Exception
throws | TInvalidDataValueException if the directory does not exist

setRecursiveCheck

public void setRecursiveCheck (boolean $value )

Input
boolean $value whether the subdirectories of the directory will also be checked.
Output
Exception

setRecursiveLevel

public void setRecursiveLevel (int $value )

Sets a value indicating the depth of the subdirectories to be checked.

This is meaningful only when RecursiveCheck is true.

Input
int $value the depth of the subdirectories to be checked. If the value is less than 0, it means unlimited depth. If the value is 0, it means checking the files directly under the specified directory.
Output
Exception

validateDirectory

protected boolean validateDirectory (string $directory )

Checks to see if the specified subdirectory should be checked for dependency.

This method is invoked when dependency of the whole directory is being checked. By default, it always returns true, meaning the subdirectory should be checked. You may override this method to check only certain subdirectories.

Input
string | $directory | the name of the subdirectory that may be checked for dependency.
Output
boolean | whether this subdirectory should be checked.
Exception

validateFile

protected boolean validateFile (string $fileName )

Checks to see if the file should be checked for dependency.

This method is invoked when dependency of the whole directory is being checked. By default, it always returns true, meaning the file should be checked. You may override this method to check only certain files.

Input
string | $fileName | the name of the file that may be checked for dependency.
Output
boolean | whether this file should be checked.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TFileCacheDependency

Class TFileCacheDependency (Class Overview)

TComponent
   |
   --TCacheDependency
      |
      --TFileCacheDependency

TFileCacheDependency class.

TFileCacheDependency performs dependency checking based on the last modification time of the file specified via FileName. The dependency is reported as unchanged if and only if the file's last modification time remains unchanged.

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
string | getFileName ()
boolean | getHasChanged () Performs the actual dependency checking.
int | getTimestamp ()
void | setFileName ( string $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getFileName

public string getFileName ()

Output
string the name of the file whose change is to be checked
Exception

getHasChanged

public boolean getHasChanged ()

Performs the actual dependency checking.

This method returns true if the last modification time of the file is changed.

Output
boolean whether the dependency is changed or not.
Exception

getTimestamp

public int getTimestamp ()

Output
int the last modification time of the file
Exception

setFileName

public void setFileName (string $value )

Input
string $value the name of the file whose change is to be checked
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TGlobalStateCacheDependency

Class TGlobalStateCacheDependency (Class Overview)

TComponent
   |
   --TCacheDependency
      |
      --TGlobalStateCacheDependency

TGlobalStateCacheDependency class.

TGlobalStateCacheDependency checks if a global state is changed or not. If the global state is changed, the dependency is reported as changed. To specify which global state this dependency should check with, set StateName to the name of the global state.

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
boolean | getHasChanged () Performs the actual dependency checking.
string | getStateName ()
void | setStateName ( string $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getHasChanged

public boolean getHasChanged ()

Performs the actual dependency checking.

This method returns true if the specified global state is changed.

Output
boolean whether the dependency is changed or not.
Exception

getStateName

public string getStateName ()

Output
string the name of the global state
Exception

setStateName

public void setStateName (string $value )

Input
string $value the name of the global state
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbCache

Class TDbCache (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TCache
            |
            --TDbCache

TDbCache class

TDbCache implements a cache application module by storing cached data in a database.

TDbCache relies on PDO to retrieve data from databases. In order to use TDbCache, you need to enable the PDO extension as well as the corresponding PDO DB driver. For example, to use SQLite database to store cached data, you need both php_pdo and php_pdo_sqlite extensions.

By default, TDbCache creates and uses an SQLite database under the application runtime directory. You may change this default setting by specifying the following properties:

  • ConnectionID or
  • ConnectionString, Username and Pasword.
The cached data is stored in a table in the specified database. By default, the name of the table is called 'pradocache'. If the table does not exist in the database, it will be automatically created with the following structure:

1      CREATE TABLE pradocache (itemkey CHAR(128), value BLOB, expire INT)
2      CREATE INDEX IX_itemkey ON pradocache (itemkey)
3      CREATE INDEX IX_expire ON pradocache (expire)

Note, some DBMS might not support BLOB type. In this case, replace 'BLOB' with a suitable binary data type (e.g. LONGBLOB in MySQL, BYTEA in PostgreSQL.)

Important: Make sure that the indices are non-unique!

If you want to change the cache table name, or if you want to create the table by yourself, you may set CacheTableName and AutoCreateCacheTableName properties.

FlushInterval control how often expired items will be removed from cache. If you prefer to remove expired items manualy e.g. via cronjob you can disable automatic deletion by setting FlushInterval to '0'.

The following basic cache operations are implemented:

  • get : retrieve the value with a key (if any) from cache
  • set : store the value with a key into cache
  • add : store the value only if cache does not have this key
  • delete : delete the value with the specified key from cache
  • flush : delete all values from cache
Each value is associated with an expiration time. The get operation ensures that any expired value will not be returned. The expiration time by the number of seconds. A expiration time 0 represents never expire.

By definition, cache does not ensure the existence of a value even if it never expires. Cache is not meant to be an persistent storage.

Do not use the same database file for multiple applications using TDbCache. Also note, cache is shared by all user sessions of an application.

Some usage examples of TDbCache are as follows,

1      $cache=new TDbCache;  // TDbCache may also be loaded as a Prado application module
2       $cache->init(null);
3      $cache->add('object',$object);
4      $object2=$cache->get('object');

If loaded, TDbCache will register itself with TApplication as the cache module. It can be accessed via TApplication::getCache().

TDbCache may be configured in application configuration file as follows

1      <module id="cache" class="System.Caching.TDbCache" />

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected boolean | addValue ( string $key, string $value, integer $expire) Stores a value identified by a key into cache if the cache does not contain this key.
protected TDbConnection | createDbConnection ( string 0) Creates the DB connection.
protected boolean | deleteValue ( string $key) Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
void | doFlushCacheExpired () Event listener for TApplication.OnSaveState
void | doInitializeCache () Event listener for TApplication.OnLoadStateComplete
void | flush () Deletes all values from cache.
void | flushCacheExpired ( boolean $force) Flush expired values from cache depending on setFlushInterval
boolean | getAutoCreateCacheTable ()
string | getCacheTableName ()
string | getConnectionID ()
string | getConnectionString ()
TDbConnection | getDbConnection ()
integer | getFlushInterval ()
string | getPassword ()
string | getUsername ()
protected string | getValue ( string $key) Retrieves a value from cache with a specified key.
void | init ( TXmlElement $config) Initializes this module.
protected void | initializeCache ( boolean $force) Initialize TDbCache
void | setAutoCreateCacheTable ( boolean $value)
void | setCacheTableName ( string $value) Sets the name of the DB table to store cache content.
void | setConnectionID ( string $value) Sets the ID of a TDataSourceConfig module.
void | setConnectionString ( string $value)
void | setFlushInterval ( integer $value) Sets interval expired items will be removed from cache
void | setPassword ( string $value)
void | setUsername ( string $value)
protected boolean | setValue ( string $key, string $value, integer $expire) Stores a value identified by a key in cache.
Methods Inherited From TCache
TCache::add(), TCache::delete(), TCache::flush(), TCache::generateUniqueKey(), TCache::get(), TCache::getKeyPrefix(), TCache::getPrimaryCache(), TCache::init(), TCache::offsetExists(), TCache::offsetGet(), TCache::offsetSet(), TCache::offsetUnset(), TCache::set(), TCache::setKeyPrefix(), TCache::setPrimaryCache(),
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

addValue

protected boolean addValue (string $key , string $value , integer $expire )

Stores a value identified by a key into cache if the cache does not contain this key.

This is the implementation of the method declared in the parent class.

Input
string | $key | the key identifying the value to be cached
string | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception

createDbConnection

protected TDbConnection createDbConnection (string 0 )

Creates the DB connection.

Input
string | 0 | the module ID for TDataSourceConfig
Output
TDbConnection | the created DB connection
Exception
throws | TConfigurationException if module ID is invalid or empty

deleteValue

protected boolean deleteValue (string $key )

Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.

Input
string | $key | the key of the value to be deleted
Output
boolean | if no error happens during deletion
Exception

doFlushCacheExpired

public void doFlushCacheExpired ()

Event listener for TApplication.OnSaveState

Output
Exception

doInitializeCache

public void doInitializeCache ()

Event listener for TApplication.OnLoadStateComplete

Output
Exception

flush

public void flush ()

Deletes all values from cache.

Be careful of performing this operation if the cache is shared by multiple applications.

Output
Exception

flushCacheExpired

public void flushCacheExpired (boolean $force )

Flush expired values from cache depending on setFlushInterval

Input
boolean $force override FlushInterval and force deletion of expired items
Output
Exception

getAutoCreateCacheTable

public boolean getAutoCreateCacheTable ()

Output
boolean whether the cache DB table should be automatically created if not exists. Defaults to true.
Exception

getCacheTableName

public string getCacheTableName ()

Output
string the name of the DB table to store cache content. Defaults to 'pradocache'.
Exception

getConnectionID

public string getConnectionID ()

Output
string the ID of a TDataSourceConfig module. Defaults to empty string, meaning not set.
Exception

getConnectionString

public string getConnectionString ()

Output
string The Data Source Name, or DSN, contains the information required to connect to the database.
Exception

getDbConnection

public TDbConnection getDbConnection ()

Output
TDbConnection the DB connection instance
Exception

getFlushInterval

public integer getFlushInterval ()

Output
integer Interval in sec expired items will be removed from cache. Default to 60
Exception

getPassword

public string getPassword ()

Output
string the password for establishing DB connection. Defaults to empty string.
Exception

getUsername

public string getUsername ()

Output
string the username for establishing DB connection. Defaults to empty string.
Exception

getValue

protected string getValue (string $key )

Retrieves a value from cache with a specified key.

This is the implementation of the method declared in the parent class.

Input
string | $key | a unique key identifying the cached value
Output
string | the value stored in cache, false if the value is not in the cache or expired.
Exception

init

public void init (TXmlElement $config )

Initializes this module.

This method is required by the IModule interface. attach doInitializeCache to TApplication.OnLoadStateComplete event attach doFlushCacheExpired to TApplication.OnSaveState event

Input
TXmlElement $config configuration for this module, can be null
Output
Exception

initializeCache

protected void initializeCache (boolean $force )

Initialize TDbCache

If AutoCreateCacheTableName is 'true' check existence of cache table and create table if does not exist.

Input
boolean | $force | Force override global state check
Output
Exception
throws | TConfigurationException if any error happens during creating database or cache table.

setAutoCreateCacheTable

public void setAutoCreateCacheTable (boolean $value )

Input
boolean $value whether the cache DB table should be automatically created if not exists.
Output
Exception

setCacheTableName

public void setCacheTableName (string $value )

Sets the name of the DB table to store cache content.

Note, if AutoCreateCacheTable is false and you want to create the DB table manually by yourself, you need to make sure the DB table is of the following structure:

1      CREATE TABLE pradocache (itemkey CHAR(128), value BLOB, expire INT)
2      CREATE INDEX IX_itemkey ON pradocache (itemkey)
3      CREATE INDEX IX_expire ON pradocache (expire)

Note, some DBMS might not support BLOB type. In this case, replace 'BLOB' with a suitable binary data type (e.g. LONGBLOB in MySQL, BYTEA in PostgreSQL.)

Important: Make sure that the indices are non-unique!

Input
string $value the name of the DB table to store cache content
Output
Exception

setConnectionID

public void setConnectionID (string $value )

Sets the ID of a TDataSourceConfig module.

The datasource module will be used to establish the DB connection for this cache module. The database connection can also be specified via ConnectionString. When both ConnectionID and ConnectionString are specified, the former takes precedence.

Input
string $value ID of the TDataSourceConfig module
Output
Exception

setConnectionString

public void setConnectionString (string $value )

Input
string $value The Data Source Name, or DSN, contains the information required to connect to the database.
Output
Exception

setFlushInterval

public void setFlushInterval (integer $value )

Sets interval expired items will be removed from cache

To disable automatic deletion of expired items, e.g. for external flushing via cron you can set value to '0'

Input
integer $value Interval in sec
Output
Exception

setPassword

public void setPassword (string $value )

Input
string $value the password for establishing DB connection
Output
Exception

setUsername

public void setUsername (string $value )

Input
string $value the username for establishing DB connection
Output
Exception

setValue

protected boolean setValue (string $key , string $value , integer $expire )

Stores a value identified by a key in cache.

This is the implementation of the method declared in the parent class.

Input
string | $key | the key identifying the value to be cached
string | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMemCache

Class TMemCache (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TCache
            |
            --TMemCache

TMemCache class

TMemCache implements a cache application module based on memcached.

TMemCache can be configured with the Host and Port properties, which specify the host and port of the memcache server to be used. By default, they take the value 'localhost' and 11211, respectively. These properties must be set before init is invoked.

The following basic cache operations are implemented:

  • get : retrieve the value with a key (if any) from cache
  • set : store the value with a key into cache
  • add : store the value only if cache does not have this key
  • delete : delete the value with the specified key from cache
  • flush : delete all values from cache
Each value is associated with an expiration time. The get operation ensures that any expired value will not be returned. The expiration time can be specified by the number of seconds (maximum 60*60*24*30) or a UNIX timestamp. A expiration time 0 represents never expire.

By definition, cache does not ensure the existence of a value even if it never expires. Cache is not meant to be an persistent storage.

Also note, there is no security measure to protected data in memcache. All data in memcache can be accessed by any process running in the system.

To use this module, the memcache PHP extension must be loaded.

Some usage examples of TMemCache are as follows,

1      $cache=new TMemCache;  // TMemCache may also be loaded as a Prado application module
2       $cache->init(null);
3      $cache->add('object',$object);
4      $object2=$cache->get('object');

You can configure TMemCache two different ways. If you only need one memcache server you may use the method as follows.

1      <module id="cache" class="System.Caching.TMemCache" Host="localhost" Port="11211" />

If you want a more complex configuration, you may use the method as follows.

1      <module id="cache" classs="System.Caching.TMemCache">
2          <server Host="localhost" Port="11211" Weight="1" Timeout="300" RetryInterval="15" />
3          <server Host="anotherhost" Port="11211" Weight="1" Timeout="300" RetryInterval="15" />
4      </module>

If loaded, TMemCache will register itself with TApplication as the cache module. It can be accessed via TApplication::getCache().

TMemCache may be configured in application configuration file as follows

1      <module id="cache" class="System.Caching.TMemCache" Host="localhost" Port="11211" />
where Host and Port are configurable properties of TMemCache.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected boolean | addValue ( string $key, string $value, integer $expire) Stores a value identified by a key into cache if the cache does not contain this key.
protected boolean | deleteValue ( string $key) Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
void | flush () Deletes all values from cache.
string | getHost ()
integer | getPort ()
protected string | getValue ( string $key) Retrieves a value from cache with a specified key.
void | init ( TApplication $config, TXmlElement 1) Initializes this module.
void | setHost ( string $value)
void | setPort ( integer $value)
protected boolean | setValue ( string $key, string $value, integer $expire) Stores a value identified by a key in cache.
Methods Inherited From TCache
TCache::add(), TCache::delete(), TCache::flush(), TCache::generateUniqueKey(), TCache::get(), TCache::getKeyPrefix(), TCache::getPrimaryCache(), TCache::init(), TCache::offsetExists(), TCache::offsetGet(), TCache::offsetSet(), TCache::offsetUnset(), TCache::set(), TCache::setKeyPrefix(), TCache::setPrimaryCache(),
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

addValue

protected boolean addValue (string $key , string $value , integer $expire )

Stores a value identified by a key into cache if the cache does not contain this key.

This is the implementation of the method declared in the parent class.

Input
string | $key | the key identifying the value to be cached
string | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception

deleteValue

protected boolean deleteValue (string $key )

Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.

Input
string | $key | the key of the value to be deleted
Output
boolean | if no error happens during deletion
Exception

flush

public void flush ()

Deletes all values from cache.

Be careful of performing this operation if the cache is shared by multiple applications.

Output
Exception

getHost

public string getHost ()

Output
string host name of the memcache server
Exception

getPort

public integer getPort ()

Output
integer port number of the memcache server
Exception

getValue

protected string getValue (string $key )

Retrieves a value from cache with a specified key.

This is the implementation of the method declared in the parent class.

Input
string | $key | a unique key identifying the cached value
Output
string | the value stored in cache, false if the value is not in the cache or expired.
Exception

init

public void init (TApplication $config , TXmlElement 1 )

Initializes this module.

This method is required by the IModule interface. It makes sure that UniquePrefix has been set, creates a Memcache instance and connects to the memcache server.

Input
TApplication | $config | Prado application, can be null
TXmlElement | 1 | configuration for this module, can be null
Output
Exception
throws | TConfigurationException if memcache extension is not installed or memcache sever connection fails

setHost

public void setHost (string $value )

Input
string | $value | host name of the memcache server
Output
Exception
throws | TInvalidOperationException if the module is already initialized

setPort

public void setPort (integer $value )

Input
integer | $value | port number of the memcache server
Output
Exception
throws | TInvalidOperationException if the module is already initialized

setValue

protected boolean setValue (string $key , string $value , integer $expire )

Stores a value identified by a key in cache.

This is the implementation of the method declared in the parent class.

Input
string | $key | the key identifying the value to be cached
string | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqliteCache

Class TSqliteCache (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TCache
            |
            --TSqliteCache

TSqliteCache class

TSqliteCache implements a cache application module based on SQLite database.

To use this module, the sqlite PHP extension must be loaded. Note, Sqlite extension is no longer loaded by default since PHP 5.1.

Sine PRADO v3.1.0, a new DB-based cache module called TDbCache is provided. If you have PDO extension installed, you may consider using the new cache module instead as it allows you to use different database to store the cached data.

The database file is specified by the DbFile property. If not set, the database file will be created under the system state path. If the specified database file does not exist, it will be created automatically. Make sure the directory containing the specified DB file and the file itself is writable by the Web server process.

The following basic cache operations are implemented:

  • get : retrieve the value with a key (if any) from cache
  • set : store the value with a key into cache
  • add : store the value only if cache does not have this key
  • delete : delete the value with the specified key from cache
  • flush : delete all values from cache
Each value is associated with an expiration time. The get operation ensures that any expired value will not be returned. The expiration time by the number of seconds. A expiration time 0 represents never expire.

By definition, cache does not ensure the existence of a value even if it never expires. Cache is not meant to be an persistent storage.

Do not use the same database file for multiple applications using TSqliteCache. Also note, cache is shared by all user sessions of an application.

Some usage examples of TSqliteCache are as follows,

1      $cache=new TSqliteCache;  // TSqliteCache may also be loaded as a Prado application module
2       $cache->setDbFile($dbFilePath);
3      $cache->init(null);
4      $cache->add('object',$object);
5      $object2=$cache->get('object');

If loaded, TSqliteCache will register itself with TApplication as the cache module. It can be accessed via TApplication::getCache().

TSqliteCache may be configured in application configuration file as follows

1      <module id="cache" class="System.Caching.TSqliteCache" DbFile="Application.Data.site" />
where DbFile is a property specifying the location of the SQLite DB file (in the namespace format).

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected boolean | addValue ( string $key, string $value, integer $expire) Stores a value identified by a key into cache if the cache does not contain this key.
protected boolean | deleteValue ( string $key) Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
void | flush () Deletes all values from cache.
string | getDbFile ()
protected string | getValue ( string $key) Retrieves a value from cache with a specified key.
void | init ( TXmlElement $config) Initializes this module.
void | setDbFile ( string $value)
protected boolean | setValue ( string $key, string $value, integer $expire) Stores a value identified by a key in cache.
Methods Inherited From TCache
TCache::add(), TCache::delete(), TCache::flush(), TCache::generateUniqueKey(), TCache::get(), TCache::getKeyPrefix(), TCache::getPrimaryCache(), TCache::init(), TCache::offsetExists(), TCache::offsetGet(), TCache::offsetSet(), TCache::offsetUnset(), TCache::set(), TCache::setKeyPrefix(), TCache::setPrimaryCache(),
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | CACHE_TABLE | name of the table storing cache data
string | DB_FILE_EXT | extension of the db file name
Method Details

addValue

protected boolean addValue (string $key , string $value , integer $expire )

Stores a value identified by a key into cache if the cache does not contain this key.

This is the implementation of the method declared in the parent class.

Input
string | $key | the key identifying the value to be cached
string | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception

deleteValue

protected boolean deleteValue (string $key )

Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.

Input
string | $key | the key of the value to be deleted
Output
boolean | if no error happens during deletion
Exception

flush

public void flush ()

Deletes all values from cache.

Be careful of performing this operation if the cache is shared by multiple applications.

Output
Exception

getDbFile

public string getDbFile ()

Output
string database file path (in namespace form)
Exception

getValue

protected string getValue (string $key )

Retrieves a value from cache with a specified key.

This is the implementation of the method declared in the parent class.

Input
string | $key | a unique key identifying the cached value
Output
string | the value stored in cache, false if the value is not in the cache or expired.
Exception

init

public void init (TXmlElement $config )

Initializes this module.

This method is required by the IModule interface. It checks if the DbFile property is set, and creates a SQLiteDatabase instance for it. The database or the cache table does not exist, they will be created. Expired values are also deleted.

Input
TXmlElement | $config | configuration for this module, can be null
Output
Exception
throws | TConfigurationException if sqlite extension is not installed, DbFile is set invalid, or any error happens during creating database or cache table.

setDbFile

public void setDbFile (string $value )

Input
string | $value | database file path (in namespace form)
Output
Exception
throws | TInvalidOperationException if the module is already initialized
throws | TConfigurationException if the file is not in proper namespace format

setValue

protected boolean setValue (string $key , string $value , integer $expire )

Stores a value identified by a key in cache.

This is the implementation of the method declared in the parent class.

Input
string | $key | the key identifying the value to be cached
string | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception
Constant Details

CACHE_TABLE

name of the table storing cache data

Type:

string

Value:

'cache'

DB_FILE_EXT

extension of the db file name

Type:

string

Value:

'.db'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TXCache

Class TXCache (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TCache
            |
            --TXCache

TXCache class

TXCache implements a cache application module based on xcache.

By definition, cache does not ensure the existence of a value even if it never expires. Cache is not meant to be an persistent storage.

To use this module, the xcache PHP extension must be loaded and configured in the php.ini.

Some usage examples of TXCache are as follows,

1      $cache=new TXCache;  // TXCache may also be loaded as a Prado application module
2       $cache->init(null);
3      $cache->add('object',$object);
4      $object2=$cache->get('object');

If loaded, TXCache will register itself with TApplication as the cache module. It can be accessed via TApplication::getCache().

TXCache may be configured in application configuration file as follows

1      <module id="cache" class="System.Caching.TXCache" />

Since: 3.1.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
protected boolean | addValue ( string $key, string $value, integer $expire) Stores a value identified by a key into cache if the cache does not contain this key.
protected boolean | deleteValue ( string $key) Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
void | flush () Deletes all values from cache.
protected string | getValue ( string $key) Retrieves a value from cache with a specified key.
void | init ( TXmlElement $config) Initializes this module.
protected boolean | setValue ( string $key, string $value, integer $expire) Stores a value identified by a key in cache.
Methods Inherited From TCache
TCache::add(), TCache::delete(), TCache::flush(), TCache::generateUniqueKey(), TCache::get(), TCache::getKeyPrefix(), TCache::getPrimaryCache(), TCache::init(), TCache::offsetExists(), TCache::offsetGet(), TCache::offsetSet(), TCache::offsetUnset(), TCache::set(), TCache::setKeyPrefix(), TCache::setPrimaryCache(),
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

addValue

protected boolean addValue (string $key , string $value , integer $expire )

Stores a value identified by a key into cache if the cache does not contain this key.

This is the implementation of the method declared in the parent class.

Input
string | $key | the key identifying the value to be cached
string | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception

deleteValue

protected boolean deleteValue (string $key )

Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.

Input
string | $key | the key of the value to be deleted
Output
boolean | if no error happens during deletion
Exception

flush

public void flush ()

Deletes all values from cache.

Be careful of performing this operation if the cache is shared by multiple applications.

Output
Exception

getValue

protected string getValue (string $key )

Retrieves a value from cache with a specified key.

This is the implementation of the method declared in the parent class.

Input
string | $key | a unique key identifying the cached value
Output
string | the value stored in cache, false if the value is not in the cache or expired.
Exception

init

public void init (TXmlElement $config )

Initializes this module.

This method is required by the IModule interface.

Input
TXmlElement | $config | configuration for this module, can be null
Output
Exception
throws | TConfigurationException if xcache extension is not installed or not started, check your php.ini

setValue

protected boolean setValue (string $key , string $value , integer $expire )

Stores a value identified by a key in cache.

This is the implementation of the method declared in the parent class.

Input
string | $key | the key identifying the value to be cached
string | $value | the value to be cached
integer | $expire | the number of seconds in which the cached value will expire. 0 means never expire.
Output
boolean | true if the value is successfully stored into cache, false otherwise
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TAssetManager

Class TAssetManager (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TAssetManager

TAssetManager class

TAssetManager provides a scheme to allow web clients visiting private files that are normally web-inaccessible.

TAssetManager will copy the file to be published into a web-accessible directory. The default base directory for storing the file is "assets", which should be under the application directory. This can be changed by setting the BasePath property together with the BaseUrl property that refers to the URL for accessing the base path.

By default, TAssetManager will not publish a file or directory if it already exists in the publishing directory and has an older modification time. If the application mode is set as 'Performance', the modification time check will be skipped. You can explicitly require a modification time check with the function publishFilePath. This is usually very useful during development.

TAssetManager may be configured in application configuration file as follows,

1      <module id="asset" BasePath="Application.assets" BaseUrl="/assets" />
where BasePath and BaseUrl are configurable properties of TAssetManager. Make sure that BasePath is a namespace pointing to a valid directory writable by the Web server process.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | copyDirectory ( string $src, string $dst) Copies a directory recursively as another.
protected void | copyFile ( string $src, string $dst) Copies a file to a directory.
protected boolean | deployTarFile ( string $path, string $destination) Extracts the tar file to the destination directory.
string | getBasePath ()
string | getBaseUrl ()
protected array | getPublished ()
string | getPublishedPath ( string $path) Returns the published path of a file path.
string | getPublishedUrl ( string $path) Returns the URL of a published file path.
protected string | hash ( string $dir) Generate a CRC32 hash for the directory path. Collisions are higher than MD5 but generates a much smaller hash string.
void | init ( TXmlElement $config) Initializes the module.
string | publishFilePath ( string $path, boolean $checkTimestamp) Publishes a file or a directory (recursively).
string | publishTarFile ( string $tarfile, string $md5sum, boolean $checkTimestamp) Publish a tar file by extracting its contents to the assets directory.
void | setBasePath ( string $value) Sets the root directory storing published asset files.
void | setBaseUrl ( string $value)
protected void | setPublished ( $values $values)
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string DEFAULT_BASEPATH Default web accessible base path for storing private files
Method Details

copyDirectory

public void copyDirectory (string $src , string $dst )

Copies a directory recursively as another.

If the destination directory does not exist, it will be created. File modification time is used to ensure the copied files are latest.

Input
string | $src | the source directory
string | $dst | the destination directory
Output
Exception

copyFile

protected void copyFile (string $src , string $dst )

Copies a file to a directory.

Copying is done only when the destination file does not exist or has an older file modification time.

Input
string | $src | source file path
string | $dst | destination directory (if not exists, it will be created)
Output
Exception

deployTarFile

protected boolean deployTarFile (string $path , string $destination )

Extracts the tar file to the destination directory.

N.B Tar file must not be compressed.

Input
string | $path | tar file
string | $destination | path where the contents of tar file are to be extracted
Output
boolean | true if extract successful, false otherwise.
Exception

getBasePath

public string getBasePath ()

Output
string the root directory storing published asset files
Exception

getBaseUrl

public string getBaseUrl ()

Output
string the base url that the published asset files can be accessed
Exception

getPublished

protected array getPublished ()

Output
array List of published assets
Exception

getPublishedPath

public string getPublishedPath (string $path )

Returns the published path of a file path.

This method does not perform any publishing. It merely tells you if the file path is published, where it will go.

Input
string | $path | directory or file path being published
Output
string | the published file path
Exception

getPublishedUrl

public string getPublishedUrl (string $path )

Returns the URL of a published file path.

This method does not perform any publishing. It merely tells you if the file path is published, what the URL will be to access it.

Input
string | $path | directory or file path being published
Output
string | the published URL for the file path
Exception

hash

protected string hash (string $dir )

Generate a CRC32 hash for the directory path. Collisions are higher than MD5 but generates a much smaller hash string.

Input
string | $dir | string to be hashed.
Output
string | hashed string.
Exception

init

public void init (TXmlElement $config )

Initializes the module.

This method is required by IModule and is invoked by application.

Input
TXmlElement $config module configuration
Output
Exception

publishFilePath

public string publishFilePath (string $path , boolean $checkTimestamp )

Publishes a file or a directory (recursively).

This method will copy the content in a directory (recursively) to a web accessible directory and returns the URL for the directory. If the application is not in performance mode, the file modification time will be used to make sure the published file is latest or not. If not, a file copy will be performed.

Input
string | $path | the path to be published
boolean | $checkTimestamp | If true, file modification time will be checked even if the application is in performance mode.
Output
string | an absolute URL to the published directory
Exception
throws | TInvalidDataValueException if the file path to be published is invalid

publishTarFile

public string publishTarFile (string $tarfile , string $md5sum , boolean $checkTimestamp )

Publish a tar file by extracting its contents to the assets directory.

Each tar file must be accomplished with its own MD5 check sum file. The MD5 file is published when the tar contents are successfully extracted to the assets directory. The presence of the MD5 file as published asset assumes that the tar file has already been extracted.

Input
string | $tarfile | tar filename
string | $md5sum | MD5 checksum for the corresponding tar file.
boolean | $checkTimestamp | Wether or not to check the time stamp of the file for publishing. Defaults to false.
Output
string | URL path to the directory where the tar file was extracted.
Exception

setBasePath

public void setBasePath (string $value )

Sets the root directory storing published asset files.

The directory must be in namespace format.

Input
string | $value | the root directory storing published asset files
Output
Exception
throws | TInvalidOperationException if the module is initialized already

setBaseUrl

public void setBaseUrl (string $value )

Input
string | $value | the base url that the published asset files can be accessed
Output
Exception
throws | TInvalidOperationException if the module is initialized already

setPublished

protected void setPublished ($values $values )

Input
$values $values List of published assets
Output
Exception

Constant Details

DEFAULT_BASEPATH

Default web accessible base path for storing private files

Type:

string

Value:

'assets'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCacheHttpSession

Class TCacheHttpSession (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --THttpSession
         |
         --TCacheHttpSession

TCacheHttpSession class

TCacheHttpSession provides access for storing session data using a cache module (e.g. TMemCache, TDbCache). To specify the cache module for data storage, set the CacheModuleID property which should refer to a valid cache module configured in the application configuration.

The following example shows how we configure TCacheHttpSession:

1       <modules>
2         <module id="cache" class="System.Caching.TMemCache" Host="localhost" Port="11211" />
3         <module id="session" class="System.Web.TCacheHttpSession"
4              CacheModuleID="cache" SessionName="SSID"
5              CookieMode="Allow" AutoStart="true" GCProbability="1"
6              UseTransparentSessionID="true" TimeOut="3600" />
7       </modules>

Beware, by definition cache storage are volatile, which means the data stored on them may be swapped out and get lost. This may not be the case for certain cache storage, such as database. So make sure you manage your cache properly to avoid loss of session data.

Since: 3.1.1
Author: Carl G. Mathisen <carlgmathisen@gmail.com>
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected string | calculateKey ( string $id)
ICache | getCache ()
string | getCacheModuleID ()
string | getKeyPrefix ()
void | init ( TXmlElement $config) Initializes the module.
void | setCacheModuleID ( string $value)
void | setKeyPrefix ( string $value)
boolean | _destroy ( string $id) Session destroy handler.
string | _read ( string $id) Session read handler.
boolean | _write ( string $id, string $data) Session write handler.
Methods Inherited From THttpSession
THttpSession::add(), THttpSession::clear(), THttpSession::close(), THttpSession::contains(), THttpSession::count(), THttpSession::destroy(), THttpSession::getAutoStart(), THttpSession::getCookie(), THttpSession::getCookieMode(), THttpSession::getCount(), THttpSession::getGCProbability(), THttpSession::getID(), THttpSession::getIsStarted(), THttpSession::getIterator(), THttpSession::getKeys(), THttpSession::getSavePath(), THttpSession::getSessionID(), THttpSession::getSessionName(), THttpSession::getTimeout(), THttpSession::getUseCustomStorage(), THttpSession::getUseTransparentSessionID(), THttpSession::init(), THttpSession::itemAt(), THttpSession::offsetExists(), THttpSession::offsetGet(), THttpSession::offsetSet(), THttpSession::offsetUnset(), THttpSession::open(), THttpSession::remove(), THttpSession::setAutoStart(), THttpSession::setCookieMode(), THttpSession::setGCProbability(), THttpSession::setID(), THttpSession::setSavePath(), THttpSession::setSessionID(), THttpSession::setSessionName(), THttpSession::setTimeout(), THttpSession::setUseCustomStorage(), THttpSession::setUseTransparentSessionID(), THttpSession::toArray(), THttpSession::_close(), THttpSession::_destroy(), THttpSession::_gc(), THttpSession::_open(), THttpSession::_read(), THttpSession::_write()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

calculateKey

protected string calculateKey (string $id )

Input
string | $id | session variable name
Output
string | a safe cache key associated with the session variable name
Exception

getCache

public ICache getCache ()

Output
ICache the cache module being used for data storage
Exception

getCacheModuleID

public string getCacheModuleID ()

Output
string the ID of the cache module.
Exception

getKeyPrefix

public string getKeyPrefix ()

Output
string prefix of session variable name to avoid conflict with other cache data. Defaults to 'session'.
Exception

init

public void init (TXmlElement $config )

Initializes the module.

This method is required by IModule. It reads the CacheModule property.

Input
TXmlElement $config module configuration
Output
Exception

setCacheModuleID

public void setCacheModuleID (string $value )

Input
string $value the ID of the cache module.
Output
Exception

setKeyPrefix

public void setKeyPrefix (string $value )

Input
string $value prefix of session variable name to avoid conflict with other cache data
Output
Exception

_destroy

public boolean _destroy (string $id )

Session destroy handler.

This method should be overriden if UseCustomStorage is set true.

Input
string | $id | session ID
Output
boolean | whether session is destroyed successfully
Exception

_read

public string _read (string $id )

Session read handler.

Input
string | $id | session ID
Output
string | the session data
Exception

_write

public boolean _write (string $id , string $data )

Session write handler.

Input
string | $id | session ID
string | $data | session data
Output
boolean | whether session write is successful
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THttpCookie

Class THttpCookie (Class Overview)

TComponent
   |
   --THttpCookie

THttpCookie class.

A THttpCookie instance stores a single cookie, including the cookie name, value, domain, path, expire, and secure.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
string | getDomain ()
integer | getExpire ()
string | getName ()
string | getPath ()
boolean | getSecure ()
string | getValue ()
void | setDomain ( string $value)
void | setExpire ( integer $value)
void | setName ( string $value)
void | setPath ( string $value)
void | setSecure ( boolean $value)
void | setValue ( string $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getDomain

public string getDomain ()

Output
string the domain to associate the cookie with
Exception

getExpire

public integer getExpire ()

Output
integer the time the cookie expires. This is a Unix timestamp so is in number of seconds since the epoch.
Exception

getName

public string getName ()

Output
string the name of the cookie
Exception

getPath

public string getPath ()

Output
string the path on the server in which the cookie will be available on, default is '/'
Exception

getSecure

public boolean getSecure ()

Output
boolean whether the cookie should only be transmitted over a secure HTTPS connection
Exception

getValue

public string getValue ()

Output
string the value of the cookie
Exception

setDomain

public void setDomain (string $value )

Input
string $value the domain to associate the cookie with
Output
Exception

setExpire

public void setExpire (integer $value )

Input
integer $value the time the cookie expires. This is a Unix timestamp so is in number of seconds since the epoch.
Output
Exception

setName

public void setName (string $value )

Input
string $value the name of the cookie
Output
Exception

setPath

public void setPath (string $value )

Input
string $value the path on the server in which the cookie will be available on
Output
Exception

setSecure

public void setSecure (boolean $value )

Input
boolean $value ether the cookie should only be transmitted over a secure HTTPS connection
Output
Exception

setValue

public void setValue (string $value )

Input
string $value the value of the cookie
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THttpCookieCollection

Class THttpCookieCollection (Class Overview)

TComponent
   |
   --TList
      |
      --THttpCookieCollection

THttpCookieCollection class.

THttpCookieCollection implements a collection class to store cookies. Besides using all functionalities from TList, you can also retrieve a cookie by its name using either findCookieByName or simply:

1        $cookie=$collection[$cookieName];

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
THttpCookie | findCookieByName ( string $name) Finds the cookie with the specified name.
void | insertAt ( integer $index, mixed $item) Inserts an item at the specified position.
THttpCookie | itemAt ( integer|string $index)
mixed | removeAt ( integer $index) Removes an item at the specified position.
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

findCookieByName

public THttpCookie findCookieByName (string $name )

Finds the cookie with the specified name.

Input
string | $name | the name of the cookie to be looked for
Output
THttpCookie | the cookie, null if not found
Exception

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by performing additional operations for each newly added THttpCookie object.

Input
integer | $index | the specified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is not a THttpCookie object.

itemAt

public THttpCookie itemAt (integer|string $index )

Input
integer|string | $index | index of the cookie in the collection or the cookie's name
Output
THttpCookie | the cookie found
Exception

removeAt

public mixed removeAt (integer $index )

Removes an item at the specified position.

This overrides the parent implementation by performing additional cleanup work when removing a TCookie object.

Input
integer | $index | the index of the item to be removed.
Output
mixed | the removed item.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THttpRequest

Class THttpRequest (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --THttpRequest

THttpRequest class

THttpRequest provides storage and access scheme for user request sent via HTTP. It also encapsulates a uniform way to parse and construct URLs.

User post data can be retrieved from THttpRequest by using it like an associative array. For example, to test if a user supplies a variable named 'param1', you can use,

1        if(isset($request['param1'])) ...
2        // equivalent to:
2        // if($request->contains('param1')) ...
To get the value of 'param1', use,

1        $value=$request['param1'];
2        // equivalent to:
2        //   $value=$request->itemAt('param1');
To traverse the user post data, use

1        foreach($request as $name=>$value) ...
Note, POST and GET variables are merged together in THttpRequest. If a variable name appears in both POST and GET data, then POST data takes precedence.

To construct a URL that can be recognized by Prado, use constructUrl(). The format of the recognizable URLs is determined according to UrlManager. By default, the following two formats are recognized:

1      /index.php?ServiceID=ServiceParameter&Name1=Value1&Name2=Value2
2      /index.php/ServiceID,ServiceParameter/Name1,Value1/Name2,Value2
The first format is called 'Get' while the second 'Path', which is specified via UrlFormat. For advanced users who want to use their own URL formats, they can write customized URL management modules and install the managers as application modules and set UrlManager.

The ServiceID in the above URLs is as defined in the application configuration (e.g. the default page service's service ID is 'page'). As a consequence, your GET variable names should not conflict with the service IDs that your application supports.

THttpRequest also provides the cookies sent by the user, user information such as his browser capabilities, accepted languages, etc.

By default, THttpRequest is registered with TApplication as the request module. It can be accessed via TApplication::getRequest().

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | add ( mixed $key, mixed $value) Adds an item into the request.
void | clear () Removes all items in the request.
string | constructUrl ( string $serviceID, string $serviceParam, array $getItems, boolean $encodeAmpersand, boolean $encodeGetItems) Constructs a URL that can be recognized by PRADO.
boolean | contains ( mixed $key)
integer | count () Returns the number of items in the request.
string | getAbsoluteApplicationUrl ( boolean $forceSecureConnection)
string | getAcceptTypes ()
string | getApplicationFilePath ()
string | getApplicationUrl ()
string | getBaseUrl ( boolean $forceSecureConnection)
array | getBrowser ()
integer | getCgiFix ()
THttpCookieCollection | getCookies ()
integer | getCount ()
boolean | getEnableCookieValidation ()
array | getEnvironmentVariables ()
string | getHttpProtocolVersion ()
string | getID ()
boolean | getIsSecureConnection ()
Iterator | getIterator () Returns an iterator for traversing the items in the list.
array | getKeys ()
string | getPathInfo ()
string | getQueryString ()
boolean | getRequestResolved ()
string | getRequestType ()
string | getRequestUri ()
string | getServerName ()
integer | getServerPort ()
array | getServerVariables ()
string | getServiceID ()
string | getServiceParameter ()
array | getUploadedFiles ()
TUri | getUrl ()
THttpRequestUrlFormat | getUrlFormat ()
string | getUrlManager ()
TUrlManager | getUrlManagerModule ()
string | getUrlParamSeparator ()
string | getUrlReferrer ()
string | getUserAgent ()
string | getUserHost ()
string | getUserHostAddress ()
array | getUserLanguages () Returns a list of user preferred languages.
void | init ( TXmlElement $config) Initializes the module.
mixed | itemAt ( mixed $key) Returns the item with the specified key.
boolean | offsetExists ( mixed $offset) Returns whether there is an element at the specified offset.
mixed | offsetGet ( integer $offset) Returns the element at the specified offset.
void | offsetSet ( integer $offset, mixed $item) Sets the element at the specified offset.
void | offsetUnset ( mixed $offset) Unsets the element at the specified offset.
protected array | parseUrl () Parses the request URL and returns an array of input parameters (excluding GET variables).
mixed | remove ( mixed $key) Removes an item from the request by its key.
string | resolveRequest ( array $serviceIDs) Resolves the requested service.
void | setCgiFix ( integer $value) Enable this, if you're using PHP via CGI with php.ini setting "cgi.fix_pathinfo=1"
void | setEnableCookieValidation ( boolean $value)
void | setID ( string $value)
void | setServiceID ( string $value) Sets the requested service ID.
void | setServiceParameter ( string $value) Sets the requested service parameter.
void | setUrlFormat ( THttpRequestUrlFormat $value) Sets the format of URLs constructed and interpretted by the request module.
void | setUrlManager ( string $value) Sets the URL manager module.
void | setUrlParamSeparator ( string $value)
mixed | stripSlashes ( mixed &$data) Strips slashes from input data.
array | toArray ()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
int | CGIFIX__PATH_INFO
int | CGIFIX__SCRIPT_NAME
Method Details

add

public void add (mixed $key , mixed $value )

Adds an item into the request.

Note, if the specified key already exists, the old value will be overwritten.

Input
mixed | $key | key
mixed | $value | value
Output
Exception

clear

public void clear ()

Removes all items in the request.

Output
Exception

constructUrl

public string constructUrl (string $serviceID , string $serviceParam , array $getItems , boolean $encodeAmpersand , boolean $encodeGetItems )

Constructs a URL that can be recognized by PRADO.

The actual construction work is done by the URL manager module. This method may append session information to the generated URL if needed. You may provide your own URL manager module by setting UrlManager to provide your own URL scheme.

Note, the constructed URL does not contain the protocol and hostname part. You may obtain an absolute URL by prepending the constructed URL with BaseUrl.

Input
string | $serviceID | service ID
string | $serviceParam | service parameter
array | $getItems | GET parameters, null if not needed
boolean | $encodeAmpersand | whether to encode the ampersand in URL, defaults to true.
boolean | $encodeGetItems | whether to encode the GET parameters (their names and values), defaults to false.
Output
string | URL
Exception

contains

public boolean contains (mixed $key )

Input
mixed | $key | the key
Output
boolean | whether the request contains an item with the specified key
Exception

count

public integer count ()

Returns the number of items in the request.

This method is required by Countable interface.

Output
integer number of items in the request.
Exception

getAbsoluteApplicationUrl

public string getAbsoluteApplicationUrl (boolean $forceSecureConnection )

Input
boolean | $forceSecureConnection | whether to use HTTPS instead of HTTP even if the current request is sent via HTTP
Output
string | entry script URL (w/ host part)
Exception

getAcceptTypes

public string getAcceptTypes ()

Output
string user browser accept types
Exception

getApplicationFilePath

public string getApplicationFilePath ()

Output
string application entry script file path (processed w/ realpath())
Exception

getApplicationUrl

public string getApplicationUrl ()

Output
string entry script URL (w/o host part)
Exception

getBaseUrl

public string getBaseUrl (boolean $forceSecureConnection )

Input
boolean | $forceSecureConnection | whether to use HTTPS instead of HTTP even if the current request is sent via HTTP
Output
string | schema and hostname of the requested URL
Exception

getBrowser

public array getBrowser ()

Output
array user browser capabilities
Exception

getCgiFix

public integer getCgiFix ()

Output
integer whether to use ORIG_PATH_INFO and/or ORIG_SCRIPT_NAME. Defaults to 0.
Exception

getCookies

public THttpCookieCollection getCookies ()

Output
THttpCookieCollection list of cookies to be sent
Exception

getCount

public integer getCount ()

Output
integer the number of items in the request
Exception

getEnableCookieValidation

public boolean getEnableCookieValidation ()

Output
boolean whether cookies should be validated. Defaults to false.
Exception

getEnvironmentVariables

public array getEnvironmentVariables ()

Output
array list of environment variables.
Exception

getHttpProtocolVersion

public string getHttpProtocolVersion ()

Output
string the requested http procolol. Blank string if not defined.
Exception

getID

public string getID ()

Output
string id of this module
Exception

getIsSecureConnection

public boolean getIsSecureConnection ()

Output
boolean if the request is sent via secure channel (https)
Exception

getIterator

public Iterator getIterator ()

Returns an iterator for traversing the items in the list.

This method is required by the interface IteratorAggregate.

Output
Iterator an iterator for traversing the items in the list.
Exception

getKeys

public array getKeys ()

Output
array the key list
Exception

getPathInfo

public string getPathInfo ()

Output
string part of the request URL after script name and before question mark.
Exception

getQueryString

public string getQueryString ()

Output
string part of that request URL after the question mark
Exception

getRequestResolved

public boolean getRequestResolved ()

Output
boolean true if request is already resolved, false otherwise.
Exception

getRequestType

public string getRequestType ()

Output
string request type, can be GET, POST, HEAD, or PUT
Exception

getRequestUri

public string getRequestUri ()

Output
string part of that request URL after the host info (including pathinfo and query string)
Exception

getServerName

public string getServerName ()

Output
string server name
Exception

getServerPort

public integer getServerPort ()

Output
integer server port number
Exception

getServerVariables

public array getServerVariables ()

Output
array list of server variables.
Exception

getServiceID

public string getServiceID ()

Output
string requested service ID
Exception

getServiceParameter

public string getServiceParameter ()

Output
string requested service parameter
Exception

getUploadedFiles

public array getUploadedFiles ()

Output
array list of uploaded files.
Exception

getUrl

public TUri getUrl ()

Output
TUri the request URL
Exception

getUrlFormat

public THttpRequestUrlFormat getUrlFormat ()

Output
THttpRequestUrlFormat the format of URLs. Defaults to THttpRequestUrlFormat::Get.
Exception

getUrlManager

public string getUrlManager ()

Output
string the ID of the URL manager module
Exception

getUrlManagerModule

public TUrlManager getUrlManagerModule ()

Output
TUrlManager the URL manager module
Exception

getUrlParamSeparator

public string getUrlParamSeparator ()

Output
string separator used to separate GET variable name and value when URL format is Path. Defaults to comma ','.
Exception

getUrlReferrer

public string getUrlReferrer ()

Output
string URL referrer, null if not present
Exception

getUserAgent

public string getUserAgent ()

Output
string user agent
Exception

getUserHost

public string getUserHost ()

Output
string user host name, null if cannot be determined
Exception

getUserHostAddress

public string getUserHostAddress ()

Output
string user IP address
Exception

getUserLanguages

public array getUserLanguages ()

Returns a list of user preferred languages.

The languages are returned as an array. Each array element represents a single language preference. The languages are ordered according to user preferences. The first language is the most preferred.

Output
array list of user preferred languages.
Exception

init

public void init (TXmlElement $config )

Initializes the module.

This method is required by IModule and is invoked by application.

Input
TXmlElement $config module configuration
Output
Exception

itemAt

public mixed itemAt (mixed $key )

Returns the item with the specified key.

This method is exactly the same as offsetGet.

Input
mixed | $key | the key
Output
mixed | the element at the offset, null if no element is found at the offset
Exception

offsetExists

public boolean offsetExists (mixed $offset )

Returns whether there is an element at the specified offset.

This method is required by the interface ArrayAccess.

Input
mixed $offset the offset to check on
Output
Exception

offsetGet

public mixed offsetGet (integer $offset )

Returns the element at the specified offset.

This method is required by the interface ArrayAccess.

Input
integer | $offset | the offset to retrieve element.
Output
mixed | the element at the offset, null if no element is found at the offset
Exception

offsetSet

public void offsetSet (integer $offset , mixed $item )

Sets the element at the specified offset.

This method is required by the interface ArrayAccess.

Input
integer | $offset | the offset to set element
mixed | $item | the element value
Output
Exception

offsetUnset

public void offsetUnset (mixed $offset )

Unsets the element at the specified offset.

This method is required by the interface ArrayAccess.

Input
mixed $offset the offset to unset element
Output
Exception

parseUrl

protected array parseUrl ()

Parses the request URL and returns an array of input parameters (excluding GET variables).

You may override this method to support customized URL format.

Output
array list of input parameters, indexed by parameter names
Exception

remove

public mixed remove (mixed $key )

Removes an item from the request by its key.

Input
mixed | $key | the key of the item to be removed
Output
mixed | the removed value, null if no such key exists.
Exception
throws | TInvalidOperationException if the item cannot be removed

resolveRequest

public string resolveRequest (array $serviceIDs )

Resolves the requested service.

This method implements a URL-based service resolution. A URL in the format of /index.php?sp=serviceID.serviceParameter will be resolved with the serviceID and the serviceParameter. You may override this method to provide your own way of service resolution.

Input
array | $serviceIDs | list of valid service IDs
Output
string | the currently requested service ID, null if no service ID is found
Exception

setCgiFix

public void setCgiFix (integer $value )

Enable this, if you're using PHP via CGI with php.ini setting "cgi.fix_pathinfo=1"

and have trouble with friendly URL feature. Enable this only if you really know what you are doing!

Input
integer $value enable bitwise to use ORIG_PATH_INFO and/or ORIG_SCRIPT_NAME.
Output
Exception

setEnableCookieValidation

public void setEnableCookieValidation (boolean $value )

Input
boolean $value whether cookies should be validated.
Output
Exception

setID

public void setID (string $value )

Input
string $value id of this module
Output
Exception

setServiceID

public void setServiceID (string $value )

Sets the requested service ID.

Input
string $value requested service ID
Output
Exception

setServiceParameter

public void setServiceParameter (string $value )

Sets the requested service parameter.

Input
string $value requested service parameter
Output
Exception

setUrlFormat

public void setUrlFormat (THttpRequestUrlFormat $value )

Sets the format of URLs constructed and interpretted by the request module.

A Get URL format is like index.php?name1=value1&name2=value2 while a Path URL format is like index.php/name1,value1/name2,value. Changing the UrlFormat will affect constructUrl and how GET variables are parsed.

Input
THttpRequestUrlFormat $value the format of URLs.
Output
Exception

setUrlManager

public void setUrlManager (string $value )

Sets the URL manager module.

By default, TUrlManager is used for managing URLs. You may specify a different module for URL managing tasks by loading it as an application module and setting this property with the module ID.

Input
string $value the ID of the URL manager module
Output
Exception

setUrlParamSeparator

public void setUrlParamSeparator (string $value )

Input
string | $value | separator used to separate GET variable name and value when URL format is Path.
Output
Exception
throws | TInvalidDataValueException if the separator is not a single character

stripSlashes

public mixed stripSlashes (mixed &$data )

Strips slashes from input data.

This method is applied when magic quotes is enabled.

Input
mixed | &$data | input data to be processed
Output
mixed | processed data
Exception

toArray

public array toArray ()

Output
array the list of items in array
Exception

Constant Details

CGIFIX__PATH_INFO

Type:

int

Value:

1

CGIFIX__SCRIPT_NAME

Type:

int

Value:

2


PRADO API Manual: Docs For Class THttpRequestUrlFormat

Class THttpRequestUrlFormat (Class Overview)

TEnumerable
   |
   --THttpRequestUrlFormat

THttpRequestUrlFormat class.

THttpRequestUrlFormat defines the enumerable type for the possible URL formats that can be recognized by THttpRequest.

The following enumerable values are defined:

  • Get: the URL format is like /path/to/index.php?name1=value1&name2=value2...
  • Path: the URL format is like /path/to/index.php/name1,value1/name2,value2...

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Get
string | Path
Constant Details

Get

Type:

string

Value:

'Get'

Path

Type:

string

Value:

'Path'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TUri

Class TUri (Class Overview)

TComponent
   |
   --TUri

TUri class

TUri represents a URI. Given a URI http://joe:whatever@example.com:8080/path/to/script.php?param=value#anchor it will be decomposed as follows,

  • scheme: http
  • host: example.com
  • port: 8080
  • user: joe
  • password: whatever
  • path: /path/to/script.php
  • query: param=value
  • fragment: anchor

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
string | getFragment ()
string | getHost ()
string | getPassword ()
string | getPath ()
integer | getPort ()
string | getQuery ()
string | getScheme ()
string | getUri ()
string | getUser ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.

Decomposes the specified URI into parts.

Throws: TInvalidDataValueException if URI is of bad format
Method Details

getFragment

public string getFragment ()

Output
string fragment of the URI
Exception

getHost

public string getHost ()

Output
string hostname of the URI
Exception

getPassword

public string getPassword ()

Output
string password of the URI
Exception

getPath

public string getPath ()

Output
string path of the URI
Exception

getPort

public integer getPort ()

Output
integer port number of the URI
Exception

getQuery

public string getQuery ()

Output
string query string of the URI
Exception

getScheme

public string getScheme ()

Output
string scheme of the URI, such as 'http', 'https', 'ftp', etc.
Exception

getUri

public string getUri ()

Output
string URI
Exception

getUser

public string getUser ()

Output
string username of the URI
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THttpResponse

Class THttpResponse (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --THttpResponse

THttpResponse class

THttpResponse implements the mechanism for sending output to client users.

To output a string to client, use write(). By default, the output is buffered until flush() is called or the application ends. The output in the buffer can also be cleaned by clear(). To disable output buffering, set BufferOutput property to false.

To send cookies to client, use getCookies(). To redirect client browser to a new URL, use redirect(). To send a file to client, use writeFile().

By default, THttpResponse is registered with TApplication as the response module. It can be accessed via TApplication::getResponse().

THttpResponse may be configured in application configuration file as follows

<module id="response" class="System.Web.THttpResponse" CacheExpire="20" CacheControl="nocache" BufferOutput="true" />

where CacheExpire, CacheControl and BufferOutput are optional properties of THttpResponse.

THttpResponse sends charset header if either Charset or TGlobalization.Charset is set.

Since 3.1.2, HTTP status code can be set with the StatusCode property.

Note: Some HTTP Status codes can require additional header or body information. So, if you use StatusCode in your application, be sure to add theses informations. E.g : to make an http authentication :

1       public function clickAuth ($sender, $param)
2       {
3          $response=$this->getResponse();
4          $response->setStatusCode(401);
5          $response->appendHeader('WWW-Authenticate: Basic realm="Test"');
6       }

This event handler will sent the 401 status code (Unauthorized) to the browser, with the WWW-Authenticate header field. This will force the browser to ask for a username and a password.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | addCookie ( THttpCookie $cookie) Sends a cookie.
void | appendHeader ( string $value) Sends a header.
void | appendLog ( string $message, integer $messageType, string $destination, string $extraHeaders) Writes a log message into error log.
void | clear () Clears any existing buffered content.
void | createHtmlWriter ( string $type) Creates a new instance of HTML writer.
void | createNewHtmlWriter ( string $type, ITextWriter $writer) Create a new html writer instance.
void | flush () Flush the response contents and headers.
void | flushContent () Outputs the buffered content, sends content-type and charset header.
THttpResponseAdapter | getAdapter ()
boolean | getBufferOutput ()
string | getCacheControl ()
integer | getCacheExpire ()
string|boolean | getCharset ()
string | getContents () Returns the content in the output buffer.
string | getContentType ()
THttpCookieCollection | getCookies ()
boolean | getHasAdapter ()
string | getHtmlWriterType ()
integer | getStatusCode ()
void | getStatusReason ( string 0)
void | httpRedirect ( string $url) Redirect the browser to another URL and exists the current application.
void | init ( TXmlElement $config) Initializes the module.
void | redirect ( string $url) Redirects the browser to the specified URL.
void | reload () Reloads the current page.
void | removeCookie ( THttpCookie $cookie) Deletes a cookie.
protected void | sendContentTypeHeader () Sends content type header with optional charset.
protected void | sendHttpHeader () Send the HTTP header with the status code (defaults to 200) and status reason (defaults to OK)
void | setAdapter ( THttpResponseAdapter $adapter)
void | setBufferOutput ( boolean $value)
void | setCacheControl ( string $value)
void | setCacheExpire ( integer $value)
void | setCharset ( string|boolean $charset)
string | setContentType ( mixed $type)
void | setHtmlWriterType ( string $value)
void | setStatusCode ( integer $status, string $reason) Set the HTTP status code for the response.
void | write ( string $str) Outputs a string.
void | writeFile ( string $fileName, string $content, string $mimeType, array $headers, boolean $forceDownload, string $clientFileName, integer $fileSize) Sends a file back to user.
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | DEFAULT_CHARSET
string | DEFAULT_CONTENTTYPE
Method Details

addCookie

public void addCookie (THttpCookie $cookie )

Sends a cookie.

Do not call this method directly. Operate with the result of getCookies instead.

Input
THttpCookie $cookie cook to be sent
Output
Exception

appendHeader

public void appendHeader (string $value )

Sends a header.

Input
string $value header
Output
Exception

appendLog

public void appendLog (string $message , integer $messageType , string $destination , string $extraHeaders )

Writes a log message into error log.

This method is simple wrapper of PHP function error_log.

Input
string | $message | The error message that should be logged
integer | $messageType | where the error should go
string | $destination | The destination. Its meaning depends on the message parameter as described above
string | $extraHeaders | The extra headers. It's used when the message parameter is set to 1. This message type uses the same internal function as mail() does.
Output
Exception

clear

public void clear ()

Clears any existing buffered content.

Output
Exception

createHtmlWriter

public void createHtmlWriter (string $type )

Creates a new instance of HTML writer.

If the type of the HTML writer is not supplied, HtmlWriterType will be assumed.

Input
string $type type of the HTML writer to be created. If null, HtmlWriterType will be assumed.
Output
Exception

createNewHtmlWriter

public void createNewHtmlWriter (string $type , ITextWriter $writer )

Create a new html writer instance.

This method is used internally. Please use createHtmlWriter instead.

Input
string | $type | type of HTML writer to be created.
ITextWriter | $writer | text writer holding the contents.
Output
Exception

flush

public void flush ()

Flush the response contents and headers.

Output
Exception

flushContent

public void flushContent ()

Outputs the buffered content, sends content-type and charset header.

This method is used internally. Please use flush instead.

Output
Exception

getAdapter

public THttpResponseAdapter getAdapter ()

Output
THttpResponseAdapter response adapter, null if not exist.
Exception

getBufferOutput

public boolean getBufferOutput ()

Output
boolean whether to enable output buffer
Exception

getCacheControl

public string getCacheControl ()

Output
string cache control method to use for session pages
Exception

getCacheExpire

public integer getCacheExpire ()

Output
integer time-to-live for cached session pages in minutes, this has no effect for nocache limiter. Defaults to 180.
Exception

getCharset

public string|boolean getCharset ()

Output
string|boolean output charset.
Exception

getContents

public string getContents ()

Returns the content in the output buffer.

The buffer will NOT be cleared after calling this method. Use clear() is you want to clear the buffer.

Output
string output that is in the buffer.
Exception

getContentType

public string getContentType ()

Output
string current content type
Exception

getCookies

public THttpCookieCollection getCookies ()

Output
THttpCookieCollection list of output cookies
Exception

getHasAdapter

public boolean getHasAdapter ()

Output
boolean true if adapter exists, false otherwise.
Exception

getHtmlWriterType

public string getHtmlWriterType ()

Output
string the type of HTML writer to be used, defaults to THtmlWriter
Exception

getStatusCode

public integer getStatusCode ()

Output
integer HTTP status code, defaults to 200
Exception

getStatusReason

public void getStatusReason (string 0 )

Input
string 0 HTTP status reason
Output
Exception

httpRedirect

public void httpRedirect (string $url )

Redirect the browser to another URL and exists the current application.

This method is used internally. Please use redirect instead.

Input
string $url URL to be redirected to. If the URL is a relative one, the base URL of the current request will be inserted at the beginning.
Output
Exception

init

public void init (TXmlElement $config )

Initializes the module.

This method is required by IModule and is invoked by application. It starts output buffer if it is enabled.

Input
TXmlElement $config module configuration
Output
Exception

redirect

public void redirect (string $url )

Redirects the browser to the specified URL.

The current application will be terminated after this method is invoked.

Input
string $url URL to be redirected to. If the URL is a relative one, the base URL of the current request will be inserted at the beginning.
Output
Exception

reload

public void reload ()

Reloads the current page.

The effect of this method call is the same as user pressing the refresh button on his browser (without post data).

Output
Exception

removeCookie

public void removeCookie (THttpCookie $cookie )

Deletes a cookie.

Do not call this method directly. Operate with the result of getCookies instead.

Input
THttpCookie $cookie cook to be deleted
Output
Exception

sendContentTypeHeader

protected void sendContentTypeHeader ()

Sends content type header with optional charset.

Output
Exception

sendHttpHeader

protected void sendHttpHeader ()

Send the HTTP header with the status code (defaults to 200) and status reason (defaults to OK)

Output
Exception

setAdapter

public void setAdapter (THttpResponseAdapter $adapter )

Input
THttpResponseAdapter $adapter response adapter
Output
Exception

setBufferOutput

public void setBufferOutput (boolean $value )

Input
boolean | $value | whether to enable output buffer
Output
Exception
throws | TInvalidOperationException if session is started already

setCacheControl

public void setCacheControl (string $value )

Input
string $value cache control method to use for session pages. Valid values include none/nocache/private/private_no_expire/public
Output
Exception

setCacheExpire

public void setCacheExpire (integer $value )

Input
integer $value time-to-live for cached session pages in minutes, this has no effect for nocache limiter.
Output
Exception

setCharset

public void setCharset (string|boolean $charset )

Input
string|boolean $charset output charset.
Output
Exception

setContentType

public string setContentType (mixed $type )

Input
mixed | $type
Output
string | content type, default is text/html
Exception

setHtmlWriterType

public void setHtmlWriterType (string $value )

Input
string $value the type of HTML writer to be used, may be the class name or the namespace
Output
Exception

setStatusCode

public void setStatusCode (integer $status , string $reason )

Set the HTTP status code for the response.

The code and its reason will be sent to client using the currently requested http protocol version (see THttpRequest::getHttpProtocolVersion) Keep in mind that HTTP/1.0 clients might not understand all status codes from HTTP/1.1

Input
integer | $status | HTTP status code
string | $reason | HTTP status reason, defaults to standard HTTP reasons
Output
Exception

write

public void write (string $str )

Outputs a string.

It may not be sent back to user immediately if output buffer is enabled.

Input
string $str string to be output
Output
Exception

writeFile

public void writeFile (string $fileName , string $content , string $mimeType , array $headers , boolean $forceDownload , string $clientFileName , integer $fileSize )

Sends a file back to user.

Make sure not to output anything else after calling this method.

Input
string | $fileName | file name
string | $content | content to be set. If null, the content will be read from the server file pointed to by $fileName.
string | $mimeType | mime type of the content.
array | $headers | list of headers to be sent. Each array element represents a header string (e.g. 'Content-Type: text/plain').
boolean | $forceDownload | force download of file, even if browser able to display inline. Defaults to 'true'.
string | $clientFileName | force a specific file name on client side. Defaults to 'null' means auto-detect.
integer | $fileSize | size of file or content in bytes if already known. Defaults to 'null' means auto-detect.
Output
Exception
throws | TInvalidDataValueException if the file cannot be found
Constant Details

DEFAULT_CHARSET

Type:

string

Value:

'UTF-8'

DEFAULT_CONTENTTYPE

Type:

string

Value:

'text/html'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THttpResponseAdapter

Class THttpResponseAdapter (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --THttpResponseAdapter

Direct Known Sub-classes:

TCallbackResponseAdapter

THttpResponseAdapter class.

THttpResponseAdapter allows the base http response class to change behavior without change the class hierarchy.

Since: 3.0
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Constructor. Attach a response to be adapted.
Method Summary
void | createNewHtmlWriter ( string $type, ITextWriter $writer) This method is invoked when a new HtmlWriter needs to be created.
void | flushContent () This method is invoked when the response flushes the content and headers.
THttpResponse | getResponse ()
void | httpRedirect ( string $url) This method is invoked when the response is to redirect to another page.
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor. Attach a response to be adapted.
Method Details

createNewHtmlWriter

public void createNewHtmlWriter (string $type , ITextWriter $writer )

This method is invoked when a new HtmlWriter needs to be created.

Default implementation calls the attached response createNewHtmlWriter method.

Input
string | $type | type of the HTML writer to be created.
ITextWriter | $writer | the writer responsible for holding the content.
Output
Exception

flushContent

public void flushContent ()

This method is invoked when the response flushes the content and headers.

Default implementation calls the attached response flushContent method.

Output
Exception

getResponse

public THttpResponse getResponse ()

Output
THttpResponse the response object adapted.
Exception

httpRedirect

public void httpRedirect (string $url )

This method is invoked when the response is to redirect to another page.

Input
string $url new url to redirect to.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THttpSession

Class THttpSession (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --THttpSession

Direct Known Sub-classes:

TCacheHttpSession

THttpSession class

THttpSession provides session-level data management and the related configurations. To start the session, call open; to complete and send out session data, call close; to destroy the session, call destroy. If AutoStart is true, then the session will be started once the session module is loaded and initialized.

To access data stored in session, use THttpSession like an associative array. For example,

1        $session=new THttpSession;
2        $session->open();
3        $value1=$session['name1'];  // get session variable 'name1'
4           $value2=$session['name2'];  // get session variable 'name2'
5           foreach($session as $name=>$value) // traverse all session variables
5           $session['name3']=$value3;  // set session variable 'name3'

The following configurations are available for session: AutoStart, CookieMode, SavePath, UseCustomStorage, GCProbability, Timeout. See the corresponding setter and getter documentation for more information. Note, these properties must be set before the session is started.

THttpSession can be inherited with customized session storage method. Override _open, _close, _read, _write, _destroy and _gc and set UseCustomStorage to true. Then, the session data will be stored using the above methods.

By default, THttpSession is registered with TApplication as the request module. It can be accessed via TApplication::getSession().

THttpSession may be configured in application configuration file as follows,

1      <module id="session" class="THttpSession" SessionName="SSID" SavePath="/tmp"
2              CookieMode="Allow" UseCustomStorage="false" AutoStart="true" GCProbability="1"
3              UseTransparentSessionID="true" TimeOut="3600" />
where SessionName, SavePath, CookieMode, UseCustomStorage, AutoStart, GCProbability, UseTransparentSessionID and TimeOut are configurable properties of THttpSession.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | add ( mixed $key, mixed $value) Adds a session variable.
void | clear () Removes all session variables
void | close () Ends the current session and store session data.
boolean | contains ( mixed $key)
integer | count () Returns the number of items in the session.
void | destroy () Destroys all data registered to a session.
boolean | getAutoStart ()
THttpCookie | getCookie ()
THttpSessionCookieMode | getCookieMode ()
integer | getCount ()
integer | getGCProbability ()
string | getID ()
boolean | getIsStarted ()
TSessionIterator | getIterator () Returns an iterator for traversing the session variables.
array | getKeys ()
string | getSavePath ()
string | getSessionID ()
string | getSessionName ()
integer | getTimeout ()
boolean | getUseCustomStorage ()
boolean | getUseTransparentSessionID ()
void | init ( TXmlElement $config) Initializes the module.
mixed | itemAt ( mixed $key) Returns the session variable value with the session variable name.
boolean | offsetExists ( mixed $offset) This method is required by the interface ArrayAccess.
mixed | offsetGet ( integer $offset) This method is required by the interface ArrayAccess.
void | offsetSet ( integer $offset, mixed $item) This method is required by the interface ArrayAccess.
void | offsetUnset ( mixed $offset) This method is required by the interface ArrayAccess.
void | open () Starts the session if it has not started yet.
mixed | remove ( mixed $key) Removes a session variable.
void | setAutoStart ( boolean $value)
void | setCookieMode ( THttpSessionCookieMode $value)
void | setGCProbability ( integer $value)
void | setID ( string $value)
void | setSavePath ( string $value)
void | setSessionID ( string $value)
void | setSessionName ( string $value)
void | setTimeout ( integer $value)
void | setUseCustomStorage ( boolean $value)
void | setUseTransparentSessionID ( boolean $value)
array | toArray ()
boolean | _close () Session close handler.
boolean | _destroy ( string $id) Session destroy handler.
boolean | _gc ( integer $maxLifetime) Session GC (garbage collection) handler.
boolean | _open ( string $savePath, string $sessionName) Session open handler.
string | _read ( string $id) Session read handler.
boolean | _write ( string $id, string $data) Session write handler.
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

add

public void add (mixed $key , mixed $value )

Adds a session variable.

Note, if the specified name already exists, the old value will be removed first.

Input
mixed | $key | session variable name
mixed | $value | session variable value
Output
Exception

clear

public void clear ()

Removes all session variables

Output
Exception

close

public void close ()

Ends the current session and store session data.

Output
Exception

contains

public boolean contains (mixed $key )

Input
mixed | $key | session variable name
Output
boolean | whether there is the named session variable
Exception

count

public integer count ()

Returns the number of items in the session.

This method is required by Countable interface.

Output
integer number of items in the session.
Exception

destroy

public void destroy ()

Destroys all data registered to a session.

Output
Exception

getAutoStart

public boolean getAutoStart ()

Output
boolean whether the session should be automatically started when the session module is initialized, defaults to false.
Exception

getCookie

public THttpCookie getCookie ()

Output
THttpCookie cookie that will be used to store session ID
Exception

getCookieMode

public THttpSessionCookieMode getCookieMode ()

Output
THttpSessionCookieMode how to use cookie to store session ID. Defaults to THttpSessionCookieMode::Allow.
Exception

getCount

public integer getCount ()

Output
integer the number of session variables
Exception

getGCProbability

public integer getGCProbability ()

Output
integer the probability (percentage) that the gc (garbage collection) process is started on every session initialization, defaults to 1 meaning 1% chance.
Exception

getID

public string getID ()

Output
string id of this module
Exception

getIsStarted

public boolean getIsStarted ()

Output
boolean whether the session has started
Exception

getIterator

public TSessionIterator getIterator ()

Returns an iterator for traversing the session variables.

This method is required by the interface IteratorAggregate.

Output
TSessionIterator an iterator for traversing the session variables.
Exception

getKeys

public array getKeys ()

Output
array the list of session variable names
Exception

getSavePath

public string getSavePath ()

Output
string the current session save path, defaults to '/tmp'.
Exception

getSessionID

public string getSessionID ()

Output
string the current session ID
Exception

getSessionName

public string getSessionName ()

Output
string the current session name
Exception

getTimeout

public integer getTimeout ()

Output
integer the number of seconds after which data will be seen as 'garbage' and cleaned up, defaults to 1440 seconds.
Exception

getUseCustomStorage

public boolean getUseCustomStorage ()

Output
boolean whether to use user-specified handlers to store session data. Defaults to false.
Exception

getUseTransparentSessionID

public boolean getUseTransparentSessionID ()

Output
boolean whether transparent sid support is enabled or not, defaults to false.
Exception

init

public void init (TXmlElement $config )

Initializes the module.

This method is required by IModule. If AutoStart is true, the session will be started.

Input
TXmlElement $config module configuration
Output
Exception

itemAt

public mixed itemAt (mixed $key )

Returns the session variable value with the session variable name.

This method is exactly the same as offsetGet.

Input
mixed | $key | the session variable name
Output
mixed | the session variable value, null if no such variable exists
Exception

offsetExists

public boolean offsetExists (mixed $offset )

This method is required by the interface ArrayAccess.

Input
mixed $offset the offset to check on
Output
Exception

offsetGet

public mixed offsetGet (integer $offset )

This method is required by the interface ArrayAccess.

Input
integer | $offset | the offset to retrieve element.
Output
mixed | the element at the offset, null if no element is found at the offset
Exception

offsetSet

public void offsetSet (integer $offset , mixed $item )

This method is required by the interface ArrayAccess.

Input
integer | $offset | the offset to set element
mixed | $item | the element value
Output
Exception

offsetUnset

public void offsetUnset (mixed $offset )

This method is required by the interface ArrayAccess.

Input
mixed $offset the offset to unset element
Output
Exception

open

public void open ()

Starts the session if it has not started yet.

Output
Exception

remove

public mixed remove (mixed $key )

Removes a session variable.

Input
mixed | $key | the name of the session variable to be removed
Output
mixed | the removed value, null if no such session variable.
Exception

setAutoStart

public void setAutoStart (boolean $value )

Input
boolean | $value | whether the session should be automatically started when the session module is initialized, defaults to false.
Output
Exception
throws | TInvalidOperationException if session is started already

setCookieMode

public void setCookieMode (THttpSessionCookieMode $value )

Input
THttpSessionCookieMode | $value | how to use cookie to store session ID
Output
Exception
throws | TInvalidOperationException if session is started already

setGCProbability

public void setGCProbability (integer $value )

Input
integer | $value | the probability (percentage) that the gc (garbage collection) process is started on every session initialization.
Output
Exception
throws | TInvalidOperationException if session is started already
throws | TInvalidDataValueException if the value is beyond [0,100].

setID

public void setID (string $value )

Input
string $value id of this module
Output
Exception

setSavePath

public void setSavePath (string $value )

Input
string | $value | the current session save path
Output
Exception
throws | TInvalidOperationException if session is started already

setSessionID

public void setSessionID (string $value )

Input
string | $value | the session ID for the current session
Output
Exception
throws | TInvalidOperationException if session is started already

setSessionName

public void setSessionName (string $value )

Input
string | $value | the session name for the current session, must be an alphanumeric string, defaults to PHPSESSID
Output
Exception
throws | TInvalidOperationException if session is started already

setTimeout

public void setTimeout (integer $value )

Input
integer | $value | the number of seconds after which data will be seen as 'garbage' and cleaned up
Output
Exception
throws | TInvalidOperationException if session is started already

setUseCustomStorage

public void setUseCustomStorage (boolean $value )

Input
boolean $value whether to use user-specified handlers to store session data. If true, make sure the methods _open, _close, _read, _write, _destroy, and _gc are overridden in child class, because they will be used as the callback handlers.
Output
Exception

setUseTransparentSessionID

public void setUseTransparentSessionID (boolean $value )

Input
boolean $value whether transparent sid support is enabled or not.
Output
Exception

toArray

public array toArray ()

Output
array the list of all session variables in array
Exception

_close

public boolean _close ()

Session close handler.

This method should be overridden if UseCustomStorage is set true.

Output
boolean whether session is closed successfully
Exception

_destroy

public boolean _destroy (string $id )

Session destroy handler.

This method should be overridden if UseCustomStorage is set true.

Input
string | $id | session ID
Output
boolean | whether session is destroyed successfully
Exception

_gc

public boolean _gc (integer $maxLifetime )

Session GC (garbage collection) handler.

This method should be overridden if UseCustomStorage is set true.

Input
integer | $maxLifetime | the number of seconds after which data will be seen as 'garbage' and cleaned up.
Output
boolean | whether session is GCed successfully
Exception

_open

public boolean _open (string $savePath , string $sessionName )

Session open handler.

This method should be overridden if UseCustomStorage is set true.

Input
string | $savePath | session save path
string | $sessionName | session name
Output
boolean | whether session is opened successfully
Exception

_read

public string _read (string $id )

Session read handler.

This method should be overridden if UseCustomStorage is set true.

Input
string | $id | session ID
Output
string | the session data
Exception

_write

public boolean _write (string $id , string $data )

Session write handler.

This method should be overridden if UseCustomStorage is set true.

Input
string | $id | session ID
string | $data | session data
Output
boolean | whether session write is successful
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THttpSessionCookieMode

Class THttpSessionCookieMode (Class Overview)

TEnumerable
   |
   --THttpSessionCookieMode

THttpSessionCookieMode class.

THttpSessionCookieMode defines the enumerable type for the possible methods of using cookies to store session ID.

The following enumerable values are defined:

  • None: not using cookie.
  • Allow: using cookie.
  • Only: using cookie only.

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Allow
string | None
string | Only
Constant Details

Allow

Type:

string

Value:

'Allow'

None

Type:

string

Value:

'None'

Only

Type:

string

Value:

'Only'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSessionIterator

Class TSessionIterator (Class Overview)

TSessionIterator class

TSessionIterator implements Iterator interface.
TSessionIterator is used by THttpSession. It allows THttpSession to return a new iterator  for traversing the session variables.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Constructor.

Method Summary
mixed | current () Returns the current array element.
mixed | key () Returns the key of the current array element.
void | next () Moves the internal pointer to the next array element.
void | rewind () Rewinds internal array pointer.
boolean | valid () Returns whether there is an element at current position.

                    Constructor Details

__construct

                                public __construct
                                Array

Constructor.

            Method Details

current

                                public mixed current
                                ()

Returns the current array element.

This method is required by the interface Iterator.

Output

                                    mixed
                 the current array element

Exception

key

                                public mixed key
                                ()

Returns the key of the current array element.

This method is required by the interface Iterator.

Output

                                    mixed
                 the key of the current array element

Exception

next

                                public void next
                                ()

Moves the internal pointer to the next array element.

This method is required by the interface Iterator.

Output

Exception

rewind

                                public void rewind
                                ()

Rewinds internal array pointer.

This method is required by the interface Iterator.

Output

Exception

valid

                                public boolean valid
                                ()

Returns whether there is an element at current position.

This method is required by the interface Iterator.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THttpUtility

Class THttpUtility (Class Overview)

THttpUtility class

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
string | htmlDecode ( string $s) HTML-decodes a string.
string | htmlEncode ( string $s) HTML-encodes a string.

            Method Details

htmlDecode

                                public string htmlDecode
                                (string $s )

HTML-decodes a string.

It is the inverse of htmlEncode.

Input
string | $s | string to be decoded
Output
string | decoded string
Exception

htmlEncode

                                public string htmlEncode
                                (string $s )

HTML-encodes a string.

This method translates the following characters to their corresponding  HTML entities: <, >, "  Note, unlike htmlspeicalchars, & is not translated.

Input
string | $s | string to be encoded
Output
string | encoded string
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TUrlManager

Class TUrlManager (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TUrlManager

Direct Known Sub-classes:

TUrlMapping

TUrlManager class

TUrlManager is the base class for managing URLs that can be recognized by PRADO applications. It provides the default implementation for parsing and constructing URLs.

Derived classes may override constructUrl and parseUrl to provide customized URL schemes.

By default, THttpRequest uses TUrlManager as its URL manager. If you want to use your customized URL manager, load your manager class as an application module and set THttpRequest::setUrlManager with the ID of your URL manager module.

Since: 3.0.6
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
string | constructUrl ( string $serviceID, string $serviceParam, array $getItems, boolean $encodeAmpersand, boolean $encodeGetItems) Constructs a URL that can be recognized by PRADO.
array | parseUrl () Parses the request URL and returns an array of input parameters.
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

constructUrl

public string constructUrl (string $serviceID , string $serviceParam , array $getItems , boolean $encodeAmpersand , boolean $encodeGetItems )

Constructs a URL that can be recognized by PRADO.

This method provides the actual implementation used by THttpRequest::constructUrl. Override this method if you want to provide your own way of URL formatting. If you do so, you may also need to override parseUrl so that the URL can be properly parsed.

The URL is constructed as the following format: /entryscript.php?serviceID=serviceParameter&get1=value1&... If THttpRequest::setUrlFormat is 'Path', the following format is used instead: /entryscript.php/serviceID/serviceParameter/get1,value1/get2,value2...

Input
string | $serviceID | service ID
string | $serviceParam | service parameter
array | $getItems | GET parameters, null if not provided
boolean | $encodeAmpersand | whether to encode the ampersand in URL
boolean | $encodeGetItems | whether to encode the GET parameters (their names and values)
Output
string | URL
Exception

parseUrl

public array parseUrl ()

Parses the request URL and returns an array of input parameters.

This method is automatically invoked by THttpRequest when handling a user request.

In general, this method should parse the path info part of the requesting URL and generate an array of name-value pairs according to some scheme. The current implementation deals with both 'Get' and 'Path' URL formats.

You may override this method to support customized URL format.

Output
array list of input parameters, indexed by parameter names
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TUrlMapping

Class TUrlMapping (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TUrlManager
            |
            --TUrlMapping

TUrlMapping Class

The TUrlMapping module allows PRADO to construct and recognize URLs based on specific patterns.

TUrlMapping consists of a list of URL patterns which are used to match against the currently requested URL. The first matching pattern will then be used to decompose the URL into request parameters (accessible through

1     $this->Request['paramname']
).

The patterns can also be used to construct customized URLs. In this case, the parameters in an applied pattern will be replaced with the corresponding GET variable values.

Since it is derived from TUrlManager, it should be configured globally in the application configuration like the following,

1       <module id="request" class="THttpRequest" UrlManager="friendly-url" />
2       <module id="friendly-url" class="System.Web.TUrlMapping" EnableCustomUrl="true">
3         <url ServiceParameter="Posts.ViewPost" pattern="post/{id}/" parameters.id="\d+" />
4         <url ServiceParameter="Posts.ListPost" pattern="archive/{time}/" parameters.time="\d{6}" />
5         <url ServiceParameter="Posts.ListPost" pattern="category/{cat}/" parameters.cat="\d+" />
6       </module>

In the above, each <tt>&lt;url&gt;</tt> element specifies a URL pattern represented as a TUrlMappingPattern internally. You may create your own pattern classes by extending TUrlMappingPattern and specifying the <tt>&lt;class&gt;</tt> attribute in the element.

The patterns can be also be specified in an external file using the ConfigFile property.

The URL mapping are evaluated in order, only the first mapping that matches the URL will be used. Cascaded mapping can be achieved by placing the URL mappings in particular order. For example, placing the most specific mappings first.

Only the PATH_INFO part of the URL is used to match the available patterns. The matching is strict in the sense that the whole pattern must match the whole PATH_INFO of the URL.

From PRADO v3.1.1, TUrlMapping also provides support for constructing URLs according to the specified pattern. You may enable this functionality by setting EnableCustomUrl to true. When you call THttpRequest::constructUrl() (or via TPageService::constructUrl()), TUrlMapping will examine the available URL mapping patterns using their TUrlMappingPattern::getServiceParameter and TUrlMappingPattern::getPattern properties. A pattern is applied if its TUrlMappingPattern::getServiceParameter matches the service parameter passed to constructUrl() and every parameter in the getPattern is found in the GET variables.

Since: 3.0.5
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
string | constructUrl ( string $serviceID, string $serviceParam, array $getItems, boolean $encodeAmpersand, boolean $encodeGetItems) Constructs a URL that can be recognized by PRADO.
string | getConfigFile ()
string | getDefaultMappingClass ()
boolean | getEnableCustomUrl () Returns a value indicating whether to enable custom constructUrl.
TUrlMappingPattern | getMatchingPattern ()
string | getUrlPrefix ()
void | init ( TXmlElement $xml) Initializes this module.
protected void | loadConfigFile () Initialize the module from configuration file.
protected void | loadUrlMappings ( TXmlElement $xml) Load and configure each url mapping pattern.
array | parseUrl () Parses the request URL and returns an array of input parameters.
void | setConfigFile ( string $value)
void | setDefaultMappingClass ( string $value) Sets the default class of URL mapping patterns.
void | setEnableCustomUrl ( boolean $value) Sets a value indicating whether to enable custom constructUrl.
void | setUrlPrefix ( string $value)
Methods Inherited From TUrlManager
TUrlManager::constructUrl(), TUrlManager::parseUrl()
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string CONFIG_FILE_EXT File extension of external configuration file
Method Details

constructUrl

public string constructUrl (string $serviceID , string $serviceParam , array $getItems , boolean $encodeAmpersand , boolean $encodeGetItems )

Constructs a URL that can be recognized by PRADO.

This method provides the actual implementation used by THttpRequest::constructUrl. Override this method if you want to provide your own way of URL formatting. If you do so, you may also need to override parseUrl so that the URL can be properly parsed.

The URL is constructed as the following format: /entryscript.php?serviceID=serviceParameter&get1=value1&... If THttpRequest::setUrlFormat is 'Path', the following format is used instead: /entryscript.php/serviceID/serviceParameter/get1,value1/get2,value2...

Input
string | $serviceID | service ID
string | $serviceParam | service parameter
array | $getItems | GET parameters, null if not provided
boolean | $encodeAmpersand | whether to encode the ampersand in URL
boolean | $encodeGetItems | whether to encode the GET parameters (their names and values)
Output
string | URL
Exception

getConfigFile

public string getConfigFile ()

Output
string external configuration file. Defaults to null.
Exception

getDefaultMappingClass

public string getDefaultMappingClass ()

Output
string the default class of URL mapping patterns. Defaults to TUrlMappingPattern.
Exception

getEnableCustomUrl

public boolean getEnableCustomUrl ()

Returns a value indicating whether to enable custom constructUrl.

If true, constructUrl() will make use of the URL mapping rules to construct valid URLs.

Output
boolean whether to enable custom constructUrl. Defaults to false.
Exception

getMatchingPattern

public TUrlMappingPattern getMatchingPattern ()

Output
TUrlMappingPattern the matched pattern, null if not found.
Exception

getUrlPrefix

public string getUrlPrefix ()

Output
string the part that will be prefixed to the constructed URLs. Defaults to the requested script path (e.g. /path/to/index.php for a URL http://hostname/path/to/index.php)
Exception

init

public void init (TXmlElement $xml )

Initializes this module.

This method is required by the IModule interface.

Input
TXmlElement | $xml | configuration for this module, can be null
Output
Exception
throws | TConfigurationException if module is configured in the global scope.

loadConfigFile

protected void loadConfigFile ()

Initialize the module from configuration file.

Output
Exception
throws TConfigurationException if ConfigFile is invalid.

loadUrlMappings

protected void loadUrlMappings (TXmlElement $xml )

Load and configure each url mapping pattern.

Input
TXmlElement | $xml | configuration node
Output
Exception
throws | TConfigurationException if specific pattern class is invalid

parseUrl

public array parseUrl ()

Parses the request URL and returns an array of input parameters.

This method overrides the parent implementation. The input parameters do not include GET and POST variables. This method uses the request URL path to find the first matching pattern. If found the matched pattern parameters are used to return as the input parameters.

Output
array list of input parameters
Exception

setConfigFile

public void setConfigFile (string $value )

Input
string | $value | external configuration file in namespace format. The file must be suffixed with '.xml'.
Output
Exception
throws | TInvalidDataValueException if the file is invalid.

setDefaultMappingClass

public void setDefaultMappingClass (string $value )

Sets the default class of URL mapping patterns.

When a URL matching pattern does not specify "class" attribute, it will default to the class specified by this property. You may use either a class name or a namespace format of class (if the class needs to be included first.)

Input
string $value the default class of URL mapping patterns.
Output
Exception

setEnableCustomUrl

public void setEnableCustomUrl (boolean $value )

Sets a value indicating whether to enable custom constructUrl.

If true, constructUrl() will make use of the URL mapping rules to construct valid URLs.

Input
boolean $value whether to enable custom constructUrl.
Output
Exception

setUrlPrefix

public void setUrlPrefix (string $value )

Input
string $value the part that will be prefixed to the constructed URLs. This is used by constructUrl() when EnableCustomUrl is set true.
Output
Exception

Constant Details

CONFIG_FILE_EXT

File extension of external configuration file

Type:

string

Value:

'.xml'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TUrlMappingPattern

Class TUrlMappingPattern (Class Overview)

TComponent
   |
   --TUrlMappingPattern

TUrlMappingPattern class.

TUrlMappingPattern represents a pattern used to parse and construct URLs. If the currently requested URL matches the pattern, it will alter the THttpRequest parameters. If a constructUrl() call matches the pattern parameters, the pattern will generate a valid URL. In both case, only the PATH_INFO part of a URL is parsed/constructed using the pattern.

To specify the pattern, set the Pattern property. Pattern takes a string expression with parameter names enclosed between a left brace '{' and a right brace '}'. The patterns for each parameter can be set using Parameters attribute collection. For example

1      <url ... pattern="articles/{year}/{month}/{day}"
2               parameters.year="\d{4}" parameters.month="\d{2}" parameters.day="\d+" />

In the above example, the pattern contains 3 parameters named "year", "month" and "day". The pattern for these parameters are, respectively, "\d{4}" (4 digits), "\d{2}" (2 digits) and "\d+" (1 or more digits). Essentially, the <tt>Parameters</tt> attribute name and values are used as substrings in replacing the placeholders in the <tt>Pattern</tt> string to form a complete regular expression string.

For more complicated patterns, one may specify the pattern using a regular expression by RegularExpression. For example, the above pattern is equivalent to the following regular expression-based pattern:

1      /^articles\/(?P<year>\d{4})\/(?P<month>\d{2})\/(?P<day>\d+)$/u
The above regular expression used the "named group" feature available in PHP. Notice that you need to escape the slash in regular expressions.

Thus, only an url that matches the pattern will be valid. For example, a URL <tt>http://example.com/index.php/articles/2006/07/21</tt> will match the above pattern, while <tt>http://example.com/index.php/articles/2006/07/hello</tt> will not since the "day" parameter pattern is not satisfied.

The parameter values are available through the <tt>THttpRequest</tt> instance (e.g. <tt>$this->Request['year']</tt>).

The ServiceParameter and ServiceID (the default ID is 'page') set the service parameter and service id respectively.

Since 3.1.4 you can also use simplyfied wildcard patterns to match multiple ServiceParameters with a single rule. The pattern must contain the placeholder {*} for the ServiceParameter. For example

<url ServiceParameter="adminpages.*" pattern="admin/{*}" />

This rule will match an URL like <tt>http://example.com/index.php/admin/edituser</tt> and resolve it to the page Application.pages.admin.edituser. The wildcard matching is non-recursive. That means you have to add a rule for every subdirectory you want to access pages in:

<url ServiceParameter="adminpages.users.*" pattern="useradmin/{*}" />

It is still possible to define an explicit rule for a page in the wildcard path. This rule has to preceed the wildcard rule.

You can also use parameters with wildcard patterns. The parameters are then available with every matching page:

<url ServiceParameter="adminpages.*" pattern="admin/{*}/{id}" parameters.id="\d+" />

To enable automatic parameter encoding in a path format fro wildcard patterns you can set {@setUrlFormat UrlFormat} to 'Path':

<url ServiceParameter="adminpages.*" pattern="admin/{*}" UrlFormat="Path" />

This will create and parse URLs of the form <tt>.../index.php/admin/listuser/param1/value1/param2/value2</tt>.

Use {@setUrlParamSeparator} to define another separator character between parameter name and value. Parameter/value pairs are always separated by a '/'.

<url ServiceParameter="adminpages.*" pattern="admin/{*}" UrlFormat="Path" UrlParamSeparator="-" />

<tt>.../index.php/admin/listuser/param1-value1/param2-value2</tt>.

Since: 3.0.5
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
string | constructUrl ( array $getItems, boolean $encodeAmpersand, boolean $encodeGetItems) Constructs a URL using this pattern.
boolean | getCaseSensitive ()
boolean | getEnableCustomUrl () Returns a value indicating whether to use this pattern to construct URL.
boolean | getIsWildCardPattern ()
TUrlManager | getManager ()
protected string | getParameterizedPattern () Substitute the parameter key value pairs as named groupings in the regular expression matching pattern.
TAttributeCollection | getParameters ()
string | getPattern ()
array | getPatternMatches ( THttpRequest $request) Uses URL pattern (or full regular expression if available) to match the given url path.
string | getRegularExpression ()
string | getServiceID ()
string | getServiceParameter ()
THttpRequestUrlFormat | getUrlFormat ()
string | getUrlParamSeparator ()
void | init ( TXmlElement $config) Initializes the pattern.
void | setCaseSensitive ( boolean $value)
void | setEnableCustomUrl ( boolean $value) Sets a value indicating whether to enable custom constructUrl using this pattern
void | setParameters ( TAttributeCollection $value)
void | setPattern ( string $value)
void | setRegularExpression ( string $value)
void | setServiceID ( string $value)
void | setServiceParameter ( string $value)
void | setUrlFormat ( THttpRequestUrlFormat $value, since 1) Sets the format of URLs constructed and interpreted by this pattern.
void | setUrlParamSeparator ( string $value)
boolean | supportCustomUrl ( array $getItems)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

constructUrl

public string constructUrl (array $getItems , boolean $encodeAmpersand , boolean $encodeGetItems )

Constructs a URL using this pattern.

Input
array | $getItems | list of GET variables
boolean | $encodeAmpersand | whether the ampersand should be encoded in the constructed URL
boolean | $encodeGetItems | whether the GET variables should be encoded in the constructed URL
Output
string | the constructed URL
Exception

getCaseSensitive

public boolean getCaseSensitive ()

Output
boolean whether the Pattern should be treated as case sensititve. Defaults to true.
Exception

getEnableCustomUrl

public boolean getEnableCustomUrl ()

Returns a value indicating whether to use this pattern to construct URL.

Output
boolean whether to enable custom constructUrl. Defaults to true.
Exception

getIsWildCardPattern

public boolean getIsWildCardPattern ()

Output
boolean whether this pattern is a wildcard pattern
Exception

getManager

public TUrlManager getManager ()

Output
TUrlManager the URL manager instance
Exception

getParameterizedPattern

protected string getParameterizedPattern ()

Substitute the parameter key value pairs as named groupings in the regular expression matching pattern.

Output
string regular expression pattern with parameter subsitution
Exception

getParameters

public TAttributeCollection getParameters ()

Output
TAttributeCollection parameter key value pairs.
Exception

getPattern

public string getPattern ()

Output
string url pattern to match. Defaults to ''.
Exception

getPatternMatches

public array getPatternMatches (THttpRequest $request )

Uses URL pattern (or full regular expression if available) to match the given url path.

Input
THttpRequest | $request | the request module
Output
array | matched parameters, empty if no matches.
Exception

getRegularExpression

public string getRegularExpression ()

Output
string full regular expression mapping pattern
Exception

getServiceID

public string getServiceID ()

Output
string service id.
Exception

getServiceParameter

public string getServiceParameter ()

Output
string service parameter, such as page class name.
Exception

getUrlFormat

public THttpRequestUrlFormat getUrlFormat ()

Output
THttpRequestUrlFormat the format of URLs. Defaults to THttpRequestUrlFormat::Get.
Exception

getUrlParamSeparator

public string getUrlParamSeparator ()

Output
string separator used to separate GET variable name and value when URL format is Path. Defaults to slash '/'.
Exception

init

public void init (TXmlElement $config )

Initializes the pattern.

Input
TXmlElement | $config | configuration for this module.
Output
Exception
throws | TConfigurationException if service parameter is not specified

setCaseSensitive

public void setCaseSensitive (boolean $value )

Input
boolean $value whether the Pattern should be treated as case sensititve.
Output
Exception

setEnableCustomUrl

public void setEnableCustomUrl (boolean $value )

Sets a value indicating whether to enable custom constructUrl using this pattern

Input
boolean $value whether to enable custom constructUrl.
Output
Exception

setParameters

public void setParameters (TAttributeCollection $value )

Input
TAttributeCollection $value new parameter key value pairs.
Output
Exception

setPattern

public void setPattern (string $value )

Input
string $value url pattern to match.
Output
Exception

setRegularExpression

public void setRegularExpression (string $value )

Input
string $value full regular expression mapping pattern.
Output
Exception

setServiceID

public void setServiceID (string $value )

Input
string $value service id to handle.
Output
Exception

setServiceParameter

public void setServiceParameter (string $value )

Input
string $value service parameter, such as page class name.
Output
Exception

setUrlFormat

public void setUrlFormat (THttpRequestUrlFormat $value , since 1 )

Sets the format of URLs constructed and interpreted by this pattern.

A Get URL format is like index.php?name1=value1&name2=value2 while a Path URL format is like index.php/name1/value1/name2/value. The separating character between name and value can be configured with setUrlParamSeparator and defaults to '/'. Changing the UrlFormat will affect constructUrl and how GET variables are parsed.

Input
THttpRequestUrlFormat | $value | the format of URLs.
since | 1 | 3.1.4
Output
Exception

setUrlParamSeparator

public void setUrlParamSeparator (string $value )

Input
string | $value | separator used to separate GET variable name and value when URL format is Path.
Output
Exception
throws | TInvalidDataValueException if the separator is not a single character

supportCustomUrl

public boolean supportCustomUrl (array $getItems )

Input
array | $getItems | list of GET items to be put in the constructed URL
Output
boolean | whether this pattern IS the one for constructing the URL with the specified GET items.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TAttributeCollection

Class TAttributeCollection (Class Overview)

TComponent
   |
   --TMap
      |
      --TAttributeCollection

TAttributeCollection class

TAttributeCollection implements a collection for storing attribute names and values.

Besides all functionalities provided by TMap, TAttributeCollection allows you to get and set attribute values like getting and setting properties. For example, the following usages are all valid for a TAttributeCollection object:

1      $collection->Text='text';
2      echo $collection->Text;
They are equivalent to the following:

1      $collection->add('Text','text');
2      echo $collection->itemAt('Text');

Note, attribute names are case-insensitive. They are converted to lower-case in the collection storage.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | add ( mixed $key, mixed $value) Adds an item into the map.
boolean | canGetProperty ( string $name) Determines whether a property can be read.
boolean | canSetProperty ( string $name) Determines whether a property can be set.
boolean | contains ( mixed $key) Returns whether the specified is in the map.
boolean | getCaseSensitive ()
boolean | hasProperty ( string $name) Determines whether a property is defined.
mixed | itemAt ( mixed $key) Returns the item with the specified key.
mixed | remove ( mixed $key) Removes an item from the map by its key.
void | setCaseSensitive ( boolean $value)
mixed | __get ( string $name) Returns a property value or an event handler list by property or event name.
void | __set ( string $name, mixed $value) Sets value of a component property.
Methods Inherited From TMap
TMap::add(), TMap::clear(), TMap::contains(), TMap::copyFrom(), TMap::count(), TMap::getCount(), TMap::getIterator(), TMap::getKeys(), TMap::getReadOnly(), TMap::itemAt(), TMap::mergeWith(), TMap::offsetExists(), TMap::offsetGet(), TMap::offsetSet(), TMap::offsetUnset(), TMap::remove(), TMap::setReadOnly(), TMap::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

add

public void add (mixed $key , mixed $value )

Adds an item into the map.

This overrides the parent implementation by converting the key to lower case first if CaseSensitive is false.

Input
mixed | $key | key
mixed | $value | value
Output
Exception

canGetProperty

public boolean canGetProperty (string $name )

Determines whether a property can be read.

This method overrides parent implementation by returning true if the collection contains the named key.

Input
string | $name | the property name
Output
boolean | whether the property can be read
Exception

canSetProperty

public boolean canSetProperty (string $name )

Determines whether a property can be set.

This method overrides parent implementation by always returning true because you can always add a new value to the collection.

Input
string | $name | the property name
Output
boolean | true
Exception

contains

public boolean contains (mixed $key )

Returns whether the specified is in the map.

This overrides the parent implementation by converting the key to lower case first if CaseSensitive is false.

Input
mixed | $key | the key
Output
boolean | whether the map contains an item with the specified key
Exception

getCaseSensitive

public boolean getCaseSensitive ()

Output
boolean whether the keys are case-sensitive. Defaults to false.
Exception

hasProperty

public boolean hasProperty (string $name )

Determines whether a property is defined.

This method overrides parent implementation by returning true if the collection contains the named key.

Input
string | $name | the property name
Output
boolean | whether the property is defined
Exception

itemAt

public mixed itemAt (mixed $key )

Returns the item with the specified key.

This overrides the parent implementation by converting the key to lower case first if CaseSensitive is false.

Input
mixed | $key | the key
Output
mixed | the element at the offset, null if no element is found at the offset
Exception

remove

public mixed remove (mixed $key )

Removes an item from the map by its key.

This overrides the parent implementation by converting the key to lower case first if CaseSensitive is false.

Input
mixed | $key | the key of the item to be removed
Output
mixed | the removed value, null if no such key exists.
Exception

setCaseSensitive

public void setCaseSensitive (boolean $value )

Input
boolean $value whether the keys are case-sensitive.
Output
Exception

__get

public mixed __get (string $name )

Returns a property value or an event handler list by property or event name.

This method overrides the parent implementation by returning a key value if the key exists in the collection.

Input
string | $name | the property name or the event name
Output
mixed | the property value or the event handler list
Exception
throws | TInvalidOperationException if the property/event is not defined.

__set

public void __set (string $name , mixed $value )

Sets value of a component property.

This method overrides the parent implementation by adding a new key value to the collection.

Input
string | $name | the property name or event name
mixed | $value | the property value or event handler
Output
Exception
throws | TInvalidOperationException If the property is not defined or read-only.


PRADO API Manual: Docs For Class TDummyDataSource

Class TDummyDataSource (Class Overview)

TComponent
   |
   --TDummyDataSource

TDummyDataSource class

TDummyDataSource implements a dummy data collection with a specified number of dummy data items. The number of virtual items can be set via setCount property. You can traverse it using foreach PHP statement like the following,

1      foreach($dummyDataSource as $dataItem)

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
integer | count () Returns the number of (virtual) items in the data source.
integer | getCount ()
Iterator | getIterator ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

count

public integer count ()

Returns the number of (virtual) items in the data source.

This method is required by Countable interface.

Output
integer number of (virtual) items in the data source.
Exception

getCount

public integer getCount ()

Output
integer number of (virtual) items in the data source.
Exception

getIterator

public Iterator getIterator ()

Output
Iterator iterator
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDummyDataSourceIterator

Class TDummyDataSourceIterator (Class Overview)

TDummyDataSourceIterator class

TDummyDataSourceIterator implements Iterator interface.
TDummyDataSourceIterator is used by TDummyDataSource.  It allows TDummyDataSource to return a new iterator  for traversing its dummy items.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Constructor.

Method Summary
mixed | current () Returns the current array item.
integer | key () Returns the key of the current array item.
void | next () Moves the internal pointer to the next array item.
void | rewind () Rewinds internal array pointer.
boolean | valid () Returns whether there is an item at current position.

                    Constructor Details

__construct

                                public __construct
                                Array

Constructor.

            Method Details

current

                                public mixed current
                                ()

Returns the current array item.

This method is required by the interface Iterator.

Output

                                    mixed
                 the current array item

Exception

key

                                public integer key
                                ()

Returns the key of the current array item.

This method is required by the interface Iterator.

Output

                                    integer
                 the key of the current array item

Exception

next

                                public void next
                                ()

Moves the internal pointer to the next array item.

This method is required by the interface Iterator.

Output

Exception

rewind

                                public void rewind
                                ()

Rewinds internal array pointer.

This method is required by the interface Iterator.

Output

Exception

valid

                                public boolean valid
                                ()

Returns whether there is an item at current position.

This method is required by the interface Iterator.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TList

Class TList (Class Overview)

TComponent
   |
   --TList

Direct Known Sub-classes:

TCacheDependencyList , TPagedList , TAuthorizationRuleCollection , THttpCookieCollection , TControlCollection , TDataGridItemCollection , TDataGridColumnCollection , TDataListItemCollection , TMetaTagCollection , THotSpotCollection , TListItemCollection , TRepeaterItemCollection , TWizardStepCollection , TXmlElementList

TList class

TList implements an integer-indexed collection class.

You can access, append, insert, remove an item by using itemAt, add, insert, remove, and removeAt. To get the number of the items in the list, use getCount. TList can also be used like a regular array as follows,

1      $list[]=$item;  // append at the end
2       $list[$index]=$item; // $index must be between 0 and $list->Count
3       unset($list[$index]); // remove the item at $index
4       if(isset($list[$index])) // if the list has an item at $index
5       foreach($list as $index=>$item) // traverse each item in the list
5       $n=count($list); // returns the number of items in the list

To extend TList by doing additional operations with each addition or removal operation, override insertAt(), and removeAt().

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
integer | add ( mixed $item) Appends an item at the end of the list.
void | clear () Removes all items in the list.
boolean | contains ( mixed $item)
void | copyFrom ( mixed $data) Copies iterable data into the list.
integer | count () Returns the number of items in the list.
integer | getCount ()
Iterator | getIterator () Returns an iterator for traversing the items in the list.
boolean | getReadOnly ()
integer | indexOf ( mixed $item)
void | insertAt ( integer $index, mixed $item) Inserts an item at the specified position.
mixed | itemAt ( integer $index) Returns the item at the specified offset.
void | mergeWith ( mixed $data) Merges iterable data into the map.
boolean | offsetExists ( integer $offset) Returns whether there is an item at the specified offset.
mixed | offsetGet ( integer $offset) Returns the item at the specified offset.
void | offsetSet ( integer $offset, mixed $item) Sets the item at the specified offset.
void | offsetUnset ( integer $offset) Unsets the item at the specified offset.
integer | remove ( mixed $item) Removes an item from the list.
mixed | removeAt ( integer $index) Removes an item at the specified position.
protected void | setReadOnly ( boolean $value)
array | toArray ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.

Initializes the list with an array or an iterable object.

Throws: TInvalidDataTypeException If data is not null and neither an array nor an iterator.
Method Details

add

public integer add (mixed $item )

Appends an item at the end of the list.

Input
mixed | $item | new item
Output
integer | the zero-based index at which the item is added
Exception

clear

public void clear ()

Removes all items in the list.

Output
Exception

contains

public boolean contains (mixed $item )

Input
mixed | $item | the item
Output
boolean | whether the list contains the item
Exception

copyFrom

public void copyFrom (mixed $data )

Copies iterable data into the list.

Note, existing data in the list will be cleared first.

Input
mixed | $data | the data to be copied from, must be an array or object implementing Traversable
Output
Exception
throws | TInvalidDataTypeException If data is neither an array nor a Traversable.

count

public integer count ()

Returns the number of items in the list.

This method is required by Countable interface.

Output
integer number of items in the list.
Exception

getCount

public integer getCount ()

Output
integer the number of items in the list
Exception

getIterator

public Iterator getIterator ()

Returns an iterator for traversing the items in the list.

This method is required by the interface IteratorAggregate.

Output
Iterator an iterator for traversing the items in the list.
Exception

getReadOnly

public boolean getReadOnly ()

Output
boolean whether this list is read-only or not. Defaults to false.
Exception

indexOf

public integer indexOf (mixed $item )

Input
mixed | $item | the item
Output
integer | the index of the item in the list (0 based), -1 if not found.
Exception

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

Original item at the position and the next items will be moved one step towards the end.

Input
integer | $index | the specified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataValueException If the index specified exceeds the bound
throws | TInvalidOperationException if the list is read-only

itemAt

public mixed itemAt (integer $index )

Returns the item at the specified offset.

This method is exactly the same as offsetGet.

Input
integer | $index | the index of the item
Output
mixed | the item at the index
Exception
throws | TInvalidDataValueException if the index is out of the range

mergeWith

public void mergeWith (mixed $data )

Merges iterable data into the map.

New data will be appended to the end of the existing data.

Input
mixed | $data | the data to be merged with, must be an array or object implementing Traversable
Output
Exception
throws | TInvalidDataTypeException If data is neither an array nor an iterator.

offsetExists

public boolean offsetExists (integer $offset )

Returns whether there is an item at the specified offset.

This method is required by the interface ArrayAccess.

Input
integer $offset the offset to check on
Output
Exception

offsetGet

public mixed offsetGet (integer $offset )

Returns the item at the specified offset.

This method is required by the interface ArrayAccess.

Input
integer | $offset | the offset to retrieve item.
Output
mixed | the item at the offset
Exception
throws | TInvalidDataValueException if the offset is invalid

offsetSet

public void offsetSet (integer $offset , mixed $item )

Sets the item at the specified offset.

This method is required by the interface ArrayAccess.

Input
integer | $offset | the offset to set item
mixed | $item | the item value
Output
Exception

offsetUnset

public void offsetUnset (integer $offset )

Unsets the item at the specified offset.

This method is required by the interface ArrayAccess.

Input
integer $offset the offset to unset item
Output
Exception

remove

public integer remove (mixed $item )

Removes an item from the list.

The list will first search for the item. The first item found will be removed from the list.

Input
mixed | $item | the item to be removed.
Output
integer | the index at which the item is being removed
Exception
throws | TInvalidDataValueException If the item does not exist

removeAt

public mixed removeAt (integer $index )

Removes an item at the specified position.

Input
integer | $index | the index of the item to be removed.
Output
mixed | the removed item.
Exception
throws | TInvalidDataValueException If the index specified exceeds the bound
throws | TInvalidOperationException if the list is read-only

setReadOnly

protected void setReadOnly (boolean $value )

Input
boolean $value whether this list is read-only or not
Output
Exception

toArray

public array toArray ()

Output
array the list of items in array
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TListIterator

Class TListIterator (Class Overview)

TListIterator class

TListIterator implements Iterator interface.
TListIterator is used by TList. It allows TList to return a new iterator  for traversing the items in the list.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Constructor.

Method Summary
mixed | current () Returns the current array item.
integer | key () Returns the key of the current array item.
void | next () Moves the internal pointer to the next array item.
void | rewind () Rewinds internal array pointer.
boolean | valid () Returns whether there is an item at current position.

                    Constructor Details

__construct

                                public __construct
                                Array

Constructor.

            Method Details

current

                                public mixed current
                                ()

Returns the current array item.

This method is required by the interface Iterator.

Output

                                    mixed
                 the current array item

Exception

key

                                public integer key
                                ()

Returns the key of the current array item.

This method is required by the interface Iterator.

Output

                                    integer
                 the key of the current array item

Exception

next

                                public void next
                                ()

Moves the internal pointer to the next array item.

This method is required by the interface Iterator.

Output

Exception

rewind

                                public void rewind
                                ()

Rewinds internal array pointer.

This method is required by the interface Iterator.

Output

Exception

valid

                                public boolean valid
                                ()

Returns whether there is an item at current position.

This method is required by the interface Iterator.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMap

Class TMap (Class Overview)

TComponent
   |
   --TMap

Direct Known Sub-classes:

TAttributeCollection

TMap class

TMap implements a collection that takes key-value pairs.

You can access, add or remove an item with a key by using itemAt, add, and remove. To get the number of the items in the map, use getCount. TMap can also be used like a regular array as follows,

1      $map[$key]=$value; // add a key-value pair
2       unset($map[$key]); // remove the value with the specified key
3       if(isset($map[$key])) // if the map contains the key
4       foreach($map as $key=>$value) // traverse the items in the map
4       $n=count($map);  // returns the number of items in the map

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void | add ( mixed $key, mixed $value) Adds an item into the map.
void | clear () Removes all items in the map.
boolean | contains ( mixed $key)
void | copyFrom ( mixed $data) Copies iterable data into the map.
integer | count () Returns the number of items in the map.
integer | getCount ()
Iterator | getIterator () Returns an iterator for traversing the items in the list.
array | getKeys ()
boolean | getReadOnly ()
mixed | itemAt ( mixed $key) Returns the item with the specified key.
void | mergeWith ( mixed $data) Merges iterable data into the map.
boolean | offsetExists ( mixed $offset) Returns whether there is an element at the specified offset.
mixed | offsetGet ( integer $offset) Returns the element at the specified offset.
void | offsetSet ( integer $offset, mixed $item) Sets the element at the specified offset.
void | offsetUnset ( mixed $offset) Unsets the element at the specified offset.
mixed | remove ( mixed $key) Removes an item from the map by its key.
protected void | setReadOnly ( boolean $value)
array | toArray ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.

Initializes the list with an array or an iterable object.

Throws: TInvalidDataTypeException If data is not null and neither an array nor an iterator.
Method Details

add

public void add (mixed $key , mixed $value )

Adds an item into the map.

Note, if the specified key already exists, the old value will be overwritten.

Input
mixed | $key | key
mixed | $value | value
Output
Exception
throws | TInvalidOperationException if the map is read-only

clear

public void clear ()

Removes all items in the map.

Output
Exception

contains

public boolean contains (mixed $key )

Input
mixed | $key | the key
Output
boolean | whether the map contains an item with the specified key
Exception

copyFrom

public void copyFrom (mixed $data )

Copies iterable data into the map.

Note, existing data in the map will be cleared first.

Input
mixed | $data | the data to be copied from, must be an array or object implementing Traversable
Output
Exception
throws | TInvalidDataTypeException If data is neither an array nor an iterator.

count

public integer count ()

Returns the number of items in the map.

This method is required by Countable interface.

Output
integer number of items in the map.
Exception

getCount

public integer getCount ()

Output
integer the number of items in the map
Exception

getIterator

public Iterator getIterator ()

Returns an iterator for traversing the items in the list.

This method is required by the interface IteratorAggregate.

Output
Iterator an iterator for traversing the items in the list.
Exception

getKeys

public array getKeys ()

Output
array the key list
Exception

getReadOnly

public boolean getReadOnly ()

Output
boolean whether this map is read-only or not. Defaults to false.
Exception

itemAt

public mixed itemAt (mixed $key )

Returns the item with the specified key.

This method is exactly the same as offsetGet.

Input
mixed | $key | the key
Output
mixed | the element at the offset, null if no element is found at the offset
Exception

mergeWith

public void mergeWith (mixed $data )

Merges iterable data into the map.

Existing data in the map will be kept and overwritten if the keys are the same.

Input
mixed | $data | the data to be merged with, must be an array or object implementing Traversable
Output
Exception
throws | TInvalidDataTypeException If data is neither an array nor an iterator.

offsetExists

public boolean offsetExists (mixed $offset )

Returns whether there is an element at the specified offset.

This method is required by the interface ArrayAccess.

Input
mixed $offset the offset to check on
Output
Exception

offsetGet

public mixed offsetGet (integer $offset )

Returns the element at the specified offset.

This method is required by the interface ArrayAccess.

Input
integer | $offset | the offset to retrieve element.
Output
mixed | the element at the offset, null if no element is found at the offset
Exception

offsetSet

public void offsetSet (integer $offset , mixed $item )

Sets the element at the specified offset.

This method is required by the interface ArrayAccess.

Input
integer | $offset | the offset to set element
mixed | $item | the element value
Output
Exception

offsetUnset

public void offsetUnset (mixed $offset )

Unsets the element at the specified offset.

This method is required by the interface ArrayAccess.

Input
mixed $offset the offset to unset element
Output
Exception

remove

public mixed remove (mixed $key )

Removes an item from the map by its key.

Input
mixed | $key | the key of the item to be removed
Output
mixed | the removed value, null if no such key exists.
Exception
throws | TInvalidOperationException if the map is read-only

setReadOnly

protected void setReadOnly (boolean $value )

Input
boolean $value whether this list is read-only or not
Output
Exception

toArray

public array toArray ()

Output
array the list of items in array
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMapIterator

Class TMapIterator (Class Overview)

TMapIterator class

TMapIterator implements Iterator interface.
TMapIterator is used by TMap. It allows TMap to return a new iterator  for traversing the items in the map.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Constructor.

Method Summary
mixed | current () Returns the current array element.
mixed | key () Returns the key of the current array element.
void | next () Moves the internal pointer to the next array element.
void | rewind () Rewinds internal array pointer.
boolean | valid () Returns whether there is an element at current position.

                    Constructor Details

__construct

                                public __construct
                                Array

Constructor.

            Method Details

current

                                public mixed current
                                ()

Returns the current array element.

This method is required by the interface Iterator.

Output

                                    mixed
                 the current array element

Exception

key

                                public mixed key
                                ()

Returns the key of the current array element.

This method is required by the interface Iterator.

Output

                                    mixed
                 the key of the current array element

Exception

next

                                public void next
                                ()

Moves the internal pointer to the next array element.

This method is required by the interface Iterator.

Output

Exception

rewind

                                public void rewind
                                ()

Rewinds internal array pointer.

This method is required by the interface Iterator.

Output

Exception

valid

                                public boolean valid
                                ()

Returns whether there is an element at current position.

This method is required by the interface Iterator.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPagedDataSource

Class TPagedDataSource (Class Overview)

TComponent
   |
   --TPagedDataSource

TPagedDataSource class

TPagedDataSource implements an integer-indexed collection class with paging functionality.

Data items in TPagedDataSource can be traversed using foreach PHP statement like the following,

1      foreach($pagedDataSource as $dataItem)
The data are fetched from DataSource. Only the items within the specified page will be returned and traversed.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
integer | count () Returns the number of items in the current page.
boolean | getAllowCustomPaging ()
boolean | getAllowPaging ()
integer | getCount ()
integer | getCurrentPageIndex ()
mixed | getDataSource ()
integer | getDataSourceCount ()
integer | getFirstIndexInPage ()
boolean | getIsFirstPage ()
boolean | getIsLastPage ()
Iterator | getIterator ()
integer | getPageCount ()
integer | getPageSize ()
integer | getVirtualItemCount ()
void | setAllowCustomPaging ( boolean $value)
void | setAllowPaging ( boolean $value)
void | setCurrentPageIndex ( integer $value)
void | setDataSource ( mixed $value)
void | setPageSize ( integer $value)
void | setVirtualItemCount ( integer $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

count

public integer count ()

Returns the number of items in the current page.

This method is required by Countable interface.

Output
integer number of items in the current page.
Exception

getAllowCustomPaging

public boolean getAllowCustomPaging ()

Output
boolean whether to allow custom paging. Defaults to false.
Exception

getAllowPaging

public boolean getAllowPaging ()

Output
boolean whether to allow paging. Defaults to false.
Exception

getCount

public integer getCount ()

Output
integer number of items in current page
Exception

getCurrentPageIndex

public integer getCurrentPageIndex ()

Output
integer current page index. Defaults to 0.
Exception

getDataSource

public mixed getDataSource ()

Output
mixed original data source. Defaults to null.
Exception

getDataSourceCount

public integer getDataSourceCount ()

Output
integer number of items in data source, if available
Exception

getFirstIndexInPage

public integer getFirstIndexInPage ()

Output
integer the index of the item in data source, where the item is the first in current page
Exception

getIsFirstPage

public boolean getIsFirstPage ()

Output
boolean whether the current page is the first page Defaults to false.
Exception

getIsLastPage

public boolean getIsLastPage ()

Output
boolean whether the current page is the last page
Exception

getIterator

public Iterator getIterator ()

Output
Iterator iterator
Exception

getPageCount

public integer getPageCount ()

Output
integer number of pages
Exception

getPageSize

public integer getPageSize ()

Output
integer number of items in each page. Defaults to 10.
Exception

getVirtualItemCount

public integer getVirtualItemCount ()

Output
integer user-assigned number of items in data source Defaults to 0.
Exception

setAllowCustomPaging

public void setAllowCustomPaging (boolean $value )

Input
boolean $value whether to allow custom paging
Output
Exception

setAllowPaging

public void setAllowPaging (boolean $value )

Input
boolean $value whether to allow paging
Output
Exception

setCurrentPageIndex

public void setCurrentPageIndex (integer $value )

Input
integer $value current page index
Output
Exception

setDataSource

public void setDataSource (mixed $value )

Input
mixed $value original data source
Output
Exception

setPageSize

public void setPageSize (integer $value )

Input
integer $value number of items in each page
Output
Exception

setVirtualItemCount

public void setVirtualItemCount (integer $value )

Input
integer $value user-assigned number of items in data source
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPagedListIterator

Class TPagedListIterator (Class Overview)

TPagedListIterator class

TPagedListIterator implements Iterator interface.
TPagedListIterator is used by TPagedDataSource. It allows TPagedDataSource  to return a new iterator for traversing the items in a TList object.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Constructor.

Method Summary
mixed | current () Returns the current array item.
integer | key () Returns the key of the current array item.
void | next () Moves the internal pointer to the next array item.
void | rewind () Rewinds internal array pointer.
boolean | valid () Returns whether there is an item at current position.

                    Constructor Details

__construct

                                public __construct
                                Array

Constructor.

            Method Details

current

                                public mixed current
                                ()

Returns the current array item.

This method is required by the interface Iterator.

Output

                                    mixed
                 the current array item

Exception

key

                                public integer key
                                ()

Returns the key of the current array item.

This method is required by the interface Iterator.

Output

                                    integer
                 the key of the current array item

Exception

next

                                public void next
                                ()

Moves the internal pointer to the next array item.

This method is required by the interface Iterator.

Output

Exception

rewind

                                public void rewind
                                ()

Rewinds internal array pointer.

This method is required by the interface Iterator.

Output

Exception

valid

                                public boolean valid
                                ()

Returns whether there is an item at current position.

This method is required by the interface Iterator.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPagedMapIterator

Class TPagedMapIterator (Class Overview)

TPagedMapIterator class

TPagedMapIterator implements Iterator interface.
TPagedMapIterator is used by TPagedDataSource. It allows TPagedDataSource  to return a new iterator for traversing the items in a TMap object.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Constructor.

Method Summary
mixed | current () Returns the current array item.
integer | key () Returns the key of the current array item.
void | next () Moves the internal pointer to the next array item.
void | rewind () Rewinds internal array pointer.
boolean | valid () Returns whether there is an item at current position.

                    Constructor Details

__construct

                                public __construct
                                Array

Constructor.

            Method Details

current

                                public mixed current
                                ()

Returns the current array item.

This method is required by the interface Iterator.

Output

                                    mixed
                 the current array item

Exception

key

                                public integer key
                                ()

Returns the key of the current array item.

This method is required by the interface Iterator.

Output

                                    integer
                 the key of the current array item

Exception

next

                                public void next
                                ()

Moves the internal pointer to the next array item.

This method is required by the interface Iterator.

Output

Exception

rewind

                                public void rewind
                                ()

Rewinds internal array pointer.

This method is required by the interface Iterator.

Output

Exception

valid

                                public boolean valid
                                ()

Returns whether there is an item at current position.

This method is required by the interface Iterator.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPagedList

Class TPagedList (Class Overview)

TComponent
   |
   --TList
      |
      --TPagedList

Direct Known Sub-classes:

TSqlMapPagedList

TPagedList class

TPagedList implements a list with paging functionality.

TPagedList works in one of two modes, managed paging or customized paging, specified by CustomPaging.

  • Managed paging (CustomPaging=false) : the list is assumed to contain all data and it will manage which page of data are available to user.
  • Customized paging (CustomPaging=true) : the list is assumed to contain only one page of data. An OnFetchData event will be raised if the list changes to a different page. Developers can attach a handler to the event and supply the needed data. The event handler can be written as follows,

    1       public function fetchData($sender,$param)
    2       {
    3         $offset=$param->Offset; // beginning index of the data needed
    4         $limit=$param->Limit;   // maximum number of data items needed
    5         // get data according to the above two parameters
    6         $param->Data=$data;
    7       }
Data in TPagedList can be accessed like an integer-indexed array and can be traversed using foreach. For example,

1      $count=$list->Count;
2      for($index=0;$index<$count;++$index)
3          echo $list[$index];
3      foreach($list as $index=>$item) // traverse each item in the list

The PageSize property specifies the number of items in each page. To access different page of data in the list, set CurrentPageIndex or call nextPage(), previousPage(), or gotoPage(). The total number of pages can be obtained by PageCount.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
integer | getCount ()
integer | getCurrentPageIndex ()
boolean | getCustomPaging ()
boolean | getIsFirstPage ()
boolean | getIsLastPage ()
Iterator | getIterator ()
integer | getPageCount ()
integer | getPageSize ()
integer | getVirtualCount ()
integer|boolean | gotoPage ( integer $pageIndex) Changes to a page with the specified page index.
integer | indexOf ( mixed $item)
mixed | itemAt ( integer $index) Returns the item at the specified offset.
integer|boolean | nextPage () Switches to the next page.
boolean | offsetExists ( integer $offset) Returns whether there is an item at the specified offset.
mixed | offsetGet ( integer $offset) Returns the item at the specified offset.
void | onFetchData ( TPagedListFetchDataEventParameter $param) Raises OnFetchData event.
void | onPageIndexChanged ( TPagedListPageChangedEventParameter $param) Raises OnPageIndexChanged event.
integer|boolean | previousPage () Switches to the previous page.
void | setCurrentPageIndex ( integer $value)
void | setCustomPaging ( boolean $value)
void | setPageSize ( integer $value)
void | setVirtualCount ( integer $value)
array | toArray ()
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getCount

public integer getCount ()

Output
integer the number of items in current page
Exception

getCurrentPageIndex

public integer getCurrentPageIndex ()

Output
integer current page index. Defaults to 0.
Exception

getCustomPaging

public boolean getCustomPaging ()

Output
boolean whether to use custom paging. Defaults to false.
Exception

getIsFirstPage

public boolean getIsFirstPage ()

Output
boolean whether the current page is the first page
Exception

getIsLastPage

public boolean getIsLastPage ()

Output
boolean whether the current page is the last page
Exception

getIterator

public Iterator getIterator ()

Output
Iterator iterator
Exception

getPageCount

public integer getPageCount ()

Output
integer number of pages, -1 if under custom paging mode and VirtualCount is not set.
Exception

getPageSize

public integer getPageSize ()

Output
integer number of items in each page. Defaults to 10.
Exception

getVirtualCount

public integer getVirtualCount ()

Output
integer user-assigned number of items in data source. Defaults to 0.
Exception

gotoPage

public integer|boolean gotoPage (integer $pageIndex )

Changes to a page with the specified page index.

Input
integer | $pageIndex | page index
Output
integer|boolean | the new page index, false if page index is out of range.
Exception

indexOf

public integer indexOf (mixed $item )

Input
mixed | $item | the item
Output
integer | the index of the item in the list (0 based), -1 if not found.
Exception

itemAt

public mixed itemAt (integer $index )

Returns the item at the specified offset.

This method is exactly the same as offsetGet.

Input
integer | $index | the index of the item
Output
mixed | the item at the index
Exception
throws | TInvalidDataValueException if the index is out of the range

nextPage

public integer|boolean nextPage ()

Switches to the next page.

Output
integer|boolean the new page index, false if next page is not available.
Exception

offsetExists

public boolean offsetExists (integer $offset )

Returns whether there is an item at the specified offset.

This method is required by the interface ArrayAccess.

Input
integer $offset the offset to check on
Output
Exception

offsetGet

public mixed offsetGet (integer $offset )

Returns the item at the specified offset.

This method is required by the interface ArrayAccess.

Input
integer | $offset | the offset to retrieve item.
Output
mixed | the item at the offset
Exception
throws | TInvalidDataValueException if the offset is invalid

onFetchData

public void onFetchData (TPagedListFetchDataEventParameter $param )

Raises OnFetchData event.

This event is raised each time when the list changes to a different page and needs the new page of data. This event can only be raised when CustomPaging is true.

Input
TPagedListFetchDataEventParameter $param event parameter
Output
Exception

onPageIndexChanged

public void onPageIndexChanged (TPagedListPageChangedEventParameter $param )

Raises OnPageIndexChanged event.

This event is raised each time when the list changes to a different page.

Input
TPagedListPageChangedEventParameter $param event parameter
Output
Exception

previousPage

public integer|boolean previousPage ()

Switches to the previous page.

Output
integer|boolean the new page index, false if previous page is not available.
Exception

setCurrentPageIndex

public void setCurrentPageIndex (integer $value )

Input
integer | $value | current page index
Output
Exception
throws | TInvalidDataValueException if the page index is out of range

setCustomPaging

public void setCustomPaging (boolean $value )

Input
boolean $value whether to allow custom paging
Output
Exception

setPageSize

public void setPageSize (integer $value )

Input
integer $value number of items in each page
Output
Exception

setVirtualCount

public void setVirtualCount (integer $value )

Input
integer $value user-assigned number of items in data source
Output
Exception

toArray

public array toArray ()

Output
array the list of items in array
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPagedListFetchDataEventParameter

Class TPagedListFetchDataEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TPagedListFetchDataEventParameter

TPagedListFetchDataEventParameter class.

TPagedListFetchDataEventParameter is used as the parameter for TPagedList::onFetchData event. To obtain the new page index, use NewPageIndex. The Offset property refers to the index of the first item in the new page, while Limit specifies how many items are requested for the page. Newly fetched data should be saved in Data property.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
mixed | getData ()
integer | getLimit ()
integer | getNewPageIndex ()
integer | getOffset ()
void | setData ( mixed $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getData

public mixed getData ()

Output
mixed new page data
Exception

getLimit

public integer getLimit ()

Output
integer number of items in the new page
Exception

getNewPageIndex

public integer getNewPageIndex ()

Output
integer the zero-based index of the new page
Exception

getOffset

public integer getOffset ()

Output
integer offset of the first item in the new page
Exception

setData

public void setData (mixed $value )

Input
mixed $value new page data
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPagedListPageChangedEventParameter

Class TPagedListPageChangedEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TPagedListPageChangedEventParameter

TPagedListPageChangedEventParameter class.

TPagedListPageChangedEventParameter is used as the parameter for TPagedList::onPageChanged event. To obtain the page index before it was changed, use OldPageIndex.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
integer
getOldPageIndex ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getOldPageIndex

public integer getOldPageIndex ()

Output
integer the index of the page before the list changed to the new page
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TQueue

Class TQueue (Class Overview)

TComponent
   |
   --TQueue

TQueue class

TQueue implements a queue.

The typical queue operations are implemented, which include enqueue(), dequeue() and peek(). In addition, contains() can be used to check if an item is contained in the queue. To obtain the number of the items in the queue, check the Count property.

Items in the queue may be traversed using foreach as follows,

1      foreach($queue as $item) ...

Since: 3.1
Author: Qiang Xue <qiang.xue@gmail.com>
Author: Knut Urdalen <knut.urdalen@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void | clear () Removes all items in the queue.
boolean | contains ( mixed $item)
void | copyFrom ( mixed $data) Copies iterable data into the queue.
integer | count () Returns the number of items in the queue.
mixed | dequeue () Removes and returns the object at the beginning of the queue.
void | enqueue ( mixed $item) Adds an object to the end of the queue.
integer | getCount ()
Iterator | getIterator () Returns an iterator for traversing the items in the queue.
mixed | peek () Returns the item at the top of the queue.
array | toArray ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.

Initializes the queue with an array or an iterable object.

Throws: TInvalidDataTypeException If data is not null and neither an array nor an iterator.
Method Details

clear

public void clear ()

Removes all items in the queue.

Output
Exception

contains

public boolean contains (mixed $item )

Input
mixed | $item | the item
Output
boolean | whether the queue contains the item
Exception

copyFrom

public void copyFrom (mixed $data )

Copies iterable data into the queue.

Note, existing data in the list will be cleared first.

Input
mixed | $data | the data to be copied from, must be an array or object implementing Traversable
Output
Exception
throws | TInvalidDataTypeException If data is neither an array nor a Traversable.

count

public integer count ()

Returns the number of items in the queue.

This method is required by Countable interface.

Output
integer number of items in the queue.
Exception

dequeue

public mixed dequeue ()

Removes and returns the object at the beginning of the queue.

Output
mixed | the item at the beginning of the queue
Exception
throws | TInvalidOperationException if the queue is empty

enqueue

public void enqueue (mixed $item )

Adds an object to the end of the queue.

Input
mixed $item the item to be appended into the queue
Output
Exception

getCount

public integer getCount ()

Output
integer the number of items in the queue
Exception

getIterator

public Iterator getIterator ()

Returns an iterator for traversing the items in the queue.

This method is required by the interface IteratorAggregate.

Output
Iterator an iterator for traversing the items in the queue.
Exception

peek

public mixed peek ()

Returns the item at the top of the queue.

Unlike pop(), this method does not remove the item from the queue.

Output
mixed | item at the top of the queue
Exception
throws | TInvalidOperationException if the queue is empty

toArray

public array toArray ()

Output
array the list of items in queue
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TQueueIterator

Class TQueueIterator (Class Overview)

TQueueIterator class

TQueueIterator implements Iterator interface.
TQueueIterator is used by TQueue. It allows TQueue to return a new iterator  for traversing the items in the queue.

            Since:
            3.1

            Author:
            Qiang Xue <qiang.xue@gmail.com>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Constructor.

Method Summary
mixed | current () Returns the current array item.
integer | key () Returns the key of the current array item.
void | next () Moves the internal pointer to the next array item.
void | rewind () Rewinds internal array pointer.
boolean | valid () Returns whether there is an item at current position.

                    Constructor Details

__construct

                                public __construct
                                Array

Constructor.

            Method Details

current

                                public mixed current
                                ()

Returns the current array item.

This method is required by the interface Iterator.

Output

                                    mixed
                 the current array item

Exception

key

                                public integer key
                                ()

Returns the key of the current array item.

This method is required by the interface Iterator.

Output

                                    integer
                 the key of the current array item

Exception

next

                                public void next
                                ()

Moves the internal pointer to the next array item.

This method is required by the interface Iterator.

Output

Exception

rewind

                                public void rewind
                                ()

Rewinds internal array pointer.

This method is required by the interface Iterator.

Output

Exception

valid

                                public boolean valid
                                ()

Returns whether there is an item at current position.

This method is required by the interface Iterator.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TStack

Class TStack (Class Overview)

TComponent
   |
   --TStack

TStack class

TStack implements a stack.

The typical stack operations are implemented, which include push(), pop() and peek(). In addition, contains() can be used to check if an item is contained in the stack. To obtain the number of the items in the stack, check the Count property.

Items in the stack may be traversed using foreach as follows,

1      foreach($stack as $item) ...

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void | clear () Removes all items in the stack.
boolean | contains ( mixed $item)
void | copyFrom ( mixed $data) Copies iterable data into the stack.
integer | count () Returns the number of items in the stack.
integer | getCount ()
Iterator | getIterator () Returns an iterator for traversing the items in the stack.
mixed | peek () Returns the item at the top of the stack.
mixed | pop () Pops up the item at the top of the stack.
void | push ( mixed $item) Pushes an item into the stack.
array | toArray ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.

Initializes the stack with an array or an iterable object.

Throws: TInvalidDataTypeException If data is not null and neither an array nor an iterator.
Method Details

clear

public void clear ()

Removes all items in the stack.

Output
Exception

contains

public boolean contains (mixed $item )

Input
mixed | $item | the item
Output
boolean | whether the stack contains the item
Exception

copyFrom

public void copyFrom (mixed $data )

Copies iterable data into the stack.

Note, existing data in the list will be cleared first.

Input
mixed | $data | the data to be copied from, must be an array or object implementing Traversable
Output
Exception
throws | TInvalidDataTypeException If data is neither an array nor a Traversable.

count

public integer count ()

Returns the number of items in the stack.

This method is required by Countable interface.

Output
integer number of items in the stack.
Exception

getCount

public integer getCount ()

Output
integer the number of items in the stack
Exception

getIterator

public Iterator getIterator ()

Returns an iterator for traversing the items in the stack.

This method is required by the interface IteratorAggregate.

Output
Iterator an iterator for traversing the items in the stack.
Exception

peek

public mixed peek ()

Returns the item at the top of the stack.

Unlike pop(), this method does not remove the item from the stack.

Output
mixed | item at the top of the stack
Exception
throws | TInvalidOperationException if the stack is empty

pop

public mixed pop ()

Pops up the item at the top of the stack.

Output
mixed | the item at the top of the stack
Exception
throws | TInvalidOperationException if the stack is empty

push

public void push (mixed $item )

Pushes an item into the stack.

Input
mixed $item the item to be pushed into the stack
Output
Exception

toArray

public array toArray ()

Output
array the list of items in stack
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TStackIterator

Class TStackIterator (Class Overview)

TStackIterator class

TStackIterator implements Iterator interface.
TStackIterator is used by TStack. It allows TStack to return a new iterator  for traversing the items in the list.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Constructor.

Method Summary
mixed | current () Returns the current array item.
integer | key () Returns the key of the current array item.
void | next () Moves the internal pointer to the next array item.
void | rewind () Rewinds internal array pointer.
boolean | valid () Returns whether there is an item at current position.

                    Constructor Details

__construct

                                public __construct
                                Array

Constructor.

            Method Details

current

                                public mixed current
                                ()

Returns the current array item.

This method is required by the interface Iterator.

Output

                                    mixed
                 the current array item

Exception

key

                                public integer key
                                ()

Returns the key of the current array item.

This method is required by the interface Iterator.

Output

                                    integer
                 the key of the current array item

Exception

next

                                public void next
                                ()

Moves the internal pointer to the next array item.

This method is required by the interface Iterator.

Output

Exception

rewind

                                public void rewind
                                ()

Rewinds internal array pointer.

This method is required by the interface Iterator.

Output

Exception

valid

                                public boolean valid
                                ()

Returns whether there is an item at current position.

This method is required by the interface Iterator.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TBaseDataList

Class TBaseDataList (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TBaseDataList

Direct Known Sub-classes:

TDataGrid , TDataList

TBaseDataList class

TBaseDataList is the base class for data listing controls, including TDataList and TDataGrid.

The key field in the data source is specified by setKeyField, while getKeyValues stores the key values of each record in a data listing control. You may use the list item index to obtain the corresponding database key value.

TBaseDataList also implements a few properties used for presentation based on tabular layout. The setCaption, whose alignment is specified via setCaptionAlign, is rendered as the table caption. The table cellpadding and cellspacing are specified by CellPadding and CellSpacing properties, respectively. The GridLines specifies how the table should display its borders, and the horizontal alignment of the table content can be specified via HorizontalAlign.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected TTableStyle | createStyle () Creates a style object for the control.
integer | getCellPadding ()
integer | getCellSpacing ()
protected mixed | getDataFieldValue ( mixed $data, mixed $field) Returns the value of the data at the specified field.
string | getDataKeyField ()
TList | getDataKeys ()
TTableGridLines | getGridLines ()
THorizontalAlign | getHorizontalAlign ()
void | onSelectedIndexChanged ( mixed $param) Raises OnSelectedIndexChanged event.
void | setCellPadding ( integer $value)
void | setCellSpacing ( integer $value)
void | setDataKeyField ( string $value)
void | setGridLines ( TTableGridLines $value) Sets the grid line style of the table layout.
void | setHorizontalAlign ( THorizontalAlign $value)
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

createStyle

protected TTableStyle createStyle ()

Creates a style object for the control.

This method creates a TTableStyle to be used by the data list control.

Output
TTableStyle control style to be used
Exception

getCellPadding

public integer getCellPadding ()

Output
integer the cellpadding for the table layout. Defaults to -1, meaning not set.
Exception

getCellSpacing

public integer getCellSpacing ()

Output
integer the cellspacing for the table layout. Defaults to -1, meaning not set.
Exception

getDataFieldValue

protected mixed getDataFieldValue (mixed $data , mixed $field )

Returns the value of the data at the specified field.

If data is an array, TMap or TList, the value will be returned at the index of the specified field. If the data is a component with a property named as the field name, the property value will be returned. Otherwise, an exception will be raised.

Input
mixed | $data | data item
mixed | $field | field name
Output
mixed | data value at the specified field
Exception
throws | TInvalidDataValueException if the data is invalid

getDataKeyField

public string getDataKeyField ()

Output
string the field of the data source that provides the keys of the list items.
Exception

getDataKeys

public TList getDataKeys ()

Output
TList the keys used in the data listing control.
Exception

getGridLines

public TTableGridLines getGridLines ()

Output
TTableGridLines the grid line setting of the table layout. Defaults to TTableGridLines::None.
Exception

getHorizontalAlign

public THorizontalAlign getHorizontalAlign ()

Output
THorizontalAlign the horizontal alignment of the table content. Defaults to THorizontalAlign::NotSet.
Exception

onSelectedIndexChanged

public void onSelectedIndexChanged (mixed $param )

Raises OnSelectedIndexChanged event.

This method is invoked when a different item is selected in a data listing control between posts to the server.

Input
mixed $param event parameter
Output
Exception

setCellPadding

public void setCellPadding (integer $value )

Input
integer $value the cellpadding for the table layout
Output
Exception

setCellSpacing

public void setCellSpacing (integer $value )

Input
integer $value the cellspacing for the table layout.
Output
Exception

setDataKeyField

public void setDataKeyField (string $value )

Input
string $value the field of the data source that provides the keys of the list items.
Output
Exception

setGridLines

public void setGridLines (TTableGridLines $value )

Sets the grid line style of the table layout.

Input
TTableGridLines $value the grid line setting of the table
Output
Exception

setHorizontalAlign

public void setHorizontalAlign (THorizontalAlign $value )

Input
THorizontalAlign $value the horizontal alignment of the table content.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TBaseValidator

Class TBaseValidator (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator

Direct Known Sub-classes:

TCaptchaValidator , TCompareValidator , TCustomValidator , TDataTypeValidator , TListControlValidator , TRangeValidator , TRegularExpressionValidator , TRequiredFieldValidator

TBaseValidator class

TBaseValidator serves as the base class for validator controls.

Validation is performed when a postback control, such as a TButton, a TLinkButton or a TTextBox (under AutoPostBack mode) is submitting the page and its CausesValidation property is true. You can also manually perform validation by calling TPage::validate(). The input control to be validated is specified by ControlToValidate.

Validator controls always validate the associated input control on the serve side. In addition, if EnableClientScript is true, validation will also be performed on the client-side using javascript. Client-side validation will validate user input before it is sent to the server. The form data will not be submitted if any error is detected. This avoids the round-trip of information necessary for server-side validation.

You can use multiple validator controls to validate a single input control, each responsible for validating against a different criteria. For example, on a user registration form, you may want to make sure the user enters a value in the username text box, and the input must consist of only word characters. You can use a TRequiredFieldValidator to ensure the input of username and a TRegularExpressionValidator to ensure the proper input.

If an input control fails validation, the text specified by the ErrorMessage property is displayed in the validation control. However, if the Text property is set, it will be displayed instead. If both ErrorMessage and Text are empty, the body content of the validator will be displayed. Error display is controlled by Display property.

You can also customized the client-side behaviour by adding javascript code to the subproperties of the ClientSide property. See quickstart documentation for further details.

You can also place a TValidationSummary control on a page to display error messages from the validators together. In this case, only the ErrorMessage property of the validators will be displayed in the TValidationSummary control.

Validators can be partitioned into validation groups by setting their ValidationGroup property. If the control causing the validation also sets its ValidationGroup property, only those validators having the same ValidationGroup value will do input validation.

Note, the TPage::getIsValid property of the current TPage instance will be automatically updated by the validation process which occurs after TPage::onLoad of TPage and before the postback events. Therefore, if you use the TPage::getIsValid() property in the TPage::onLoad() method, you must first explicitly call the TPage::validate() method.

Notes to Inheritors When you inherit from TBaseValidator, you must override the method evaluateIsValid.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Constructor.
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attributes to renderer. Calls parent implementation and renders the client control scripts.
protected TValidatorClientSide | createClientSide ()
protected abstract boolean | evaluateIsValid () This is the major method for validation.
protected abstract string | getClientClassName () Gets the name of the javascript class responsible for performing validation for this control.
protected array | getClientScriptOptions () Returns an array of javascript validator options.
TValidatorClientSide | getClientSide () Gets the TValidatorClientSide that allows modification of the client- side validator events.
string | getControlCssClass ()
string | getControlToValidate ()
TValidatorDisplayStyle | getDisplay ()
boolean | getEnableClientScript ()
string | getErrorMessage ()
string | getFocusElementID () Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
boolean | getFocusOnError ()
boolean | getIsValid ()
string | getValidationGroup ()
TControl | getValidationTarget ()
protected string | getValidationValue ( TControl $control) Retrieves the property value of the control being validated.
void | onInit ( mixed $param) Registers the validator with page.
void | onPreRender ( mixed $param) Override parent implementation to update the control CSS Class before
void | onUnload ( mixed $param) Unregisters the validator from page.
void | onValidate () This event is raised right before the validator starts to perform validation.
void | onValidationError () This event is raised when the validator fails in validation.
void | onValidationSuccess () This event is raised when the validator succeeds in validation.
protected void | registerClientScriptValidator () Registers the individual validator client-side javascript code.
void | renderClientControlScript ( THtmlWriter $writer) Renders the javascript code to the end script.
void | renderContents ( THtmlWriter $writer) Renders the validator control.
void | setControlCssClass ( string $value)
void | setControlToValidate ( string $value) Sets the ID path of the input control to validate.
void | setDisplay ( TValidatorDisplayStyle $value)
void | setEnableClientScript ( boolean $value)
void | setEnabled ( boolean $value) This method overrides parent's implementation by setting setIsValid to true if disabled.
void | setErrorMessage ( string $value) Sets the text for the error message.
void | setFocusElementID ( string $value) Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.
void | setFocusOnError ( boolean $value)
void | setForControl ( string $value) This method overrides the parent implementation to forbid setting ForControl.
void | setIsValid ( boolean $value) Sets the value indicating whether the validation succeeds
void | setValidationGroup ( string $value)
protected boolean | updateControlCssClass () Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
boolean | validate () Validates the specified control.
Methods Inherited From TLabel
TLabel::addAttributesToRender(), TLabel::getData(), TLabel::getForControl(), TLabel::getTagName(), TLabel::getText(), TLabel::render(), TLabel::renderContents(), TLabel::setData(), TLabel::setForControl(), TLabel::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Constructor.

This method sets the foreground color to red.
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attributes to renderer. Calls parent implementation and renders the client control scripts.

Input
THtmlWriter $writer the renderer
Output
Exception

createClientSide

protected TValidatorClientSide createClientSide ()

Output
TValidatorClientSide javascript validator event options.
Exception

evaluateIsValid

protected abstract boolean evaluateIsValid ()

This is the major method for validation.

Derived classes should implement this method to provide customized validation.

Output
boolean whether the validation succeeds
Exception

getClientClassName

protected abstract string getClientClassName ()

Gets the name of the javascript class responsible for performing validation for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientScriptOptions

protected array getClientScriptOptions ()

Returns an array of javascript validator options.

Output
array javascript validator options.
Exception

getClientSide

public TValidatorClientSide getClientSide ()

Gets the TValidatorClientSide that allows modification of the client- side validator events.

The client-side validator supports the following events.

  • <tt>OnValidate</tt> -- raised before client-side validation is
executed.
  • <tt>OnValidationSuccess</tt> -- raised after client-side validation is completed
and is successfull, overrides default validator error messages updates.
  • <tt>OnValidationError</tt> -- raised after client-side validation is completed
and failed, overrides default validator error message updates.

You can attach custom javascript code to each of these events

Output
TValidatorClientSide javascript validator event options.
Exception

getControlCssClass

public string getControlCssClass ()

Output
string the css class that is applied to the control being validated in case the validation fails
Exception

getControlToValidate

public string getControlToValidate ()

Output
string the ID path of the input control to validate
Exception

getDisplay

public TValidatorDisplayStyle getDisplay ()

Output
TValidatorDisplayStyle the style of displaying the error message. Defaults to TValidatorDisplayStyle::Fixed.
Exception

getEnableClientScript

public boolean getEnableClientScript ()

Output
boolean whether client-side validation is enabled.
Exception

getErrorMessage

public string getErrorMessage ()

Output
string the text for the error message.
Exception

getFocusElementID

public string getFocusElementID ()

Gets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.

Defaults to the client ID of the ControlToValidate.

Output
string the ID of the HTML element to receive focus
Exception

getFocusOnError

public boolean getFocusOnError ()

Output
boolean whether to set focus at the validating place if the validation fails. Defaults to false.
Exception

getIsValid

public boolean getIsValid ()

Output
boolean whether the validation succeeds
Exception

getValidationGroup

public string getValidationGroup ()

Output
string the group which this validator belongs to
Exception

getValidationTarget

public TControl getValidationTarget ()

Output
TControl | control to be validated. Null if no control is found.
Exception
throws | TConfigurationException if ControlToValidate is empty or does not point to a valid control

getValidationValue

protected string getValidationValue (TControl $control )

Retrieves the property value of the control being validated.

Input
TControl | $control | control being validated
Output
string | property value to be validated
Exception
throws | TInvalidDataTypeException if the control to be validated does not implement IValidatable.

onInit

public void onInit (mixed $param )

Registers the validator with page.

Input
mixed $param event parameter
Output
Exception

onPreRender

public void onPreRender (mixed $param )

Override parent implementation to update the control CSS Class before

the validated control is rendered

Input
mixed $param
Output
Exception

onUnload

public void onUnload (mixed $param )

Unregisters the validator from page.

Input
mixed $param event parameter
Output
Exception

onValidate

public void onValidate ()

This event is raised right before the validator starts to perform validation.

You may use this event to change the behavior of validation. For example, you may disable the validator if certain condition is satisfied. Note, the event will NOT be raised if the validator is invisible.

Output
Exception

onValidationError

public void onValidationError ()

This event is raised when the validator fails in validation.

Output
Exception

onValidationSuccess

public void onValidationSuccess ()

This event is raised when the validator succeeds in validation.

Output
Exception

registerClientScriptValidator

protected void registerClientScriptValidator ()

Registers the individual validator client-side javascript code.

Output
Exception

renderClientControlScript

public void renderClientControlScript (THtmlWriter $writer )

Renders the javascript code to the end script.

If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

Input
THtmlWriter $writer the renderer
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders the validator control.

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

setControlCssClass

public void setControlCssClass (string $value )

Input
string $value the css class that is applied to the control being validated in case the validation fails
Output
Exception

setControlToValidate

public void setControlToValidate (string $value )

Sets the ID path of the input control to validate.

The ID path is the dot-connected IDs of the controls reaching from the validator's naming container to the target control.

Input
string $value the ID path
Output
Exception

setDisplay

public void setDisplay (TValidatorDisplayStyle $value )

Input
TValidatorDisplayStyle $value the style of displaying the error message
Output
Exception

setEnableClientScript

public void setEnableClientScript (boolean $value )

Input
boolean $value whether client-side validation is enabled.
Output
Exception

setEnabled

public void setEnabled (boolean $value )

This method overrides parent's implementation by setting setIsValid to true if disabled.

Input
boolean $value whether the validator is enabled.
Output
Exception

setErrorMessage

public void setErrorMessage (string $value )

Sets the text for the error message.

Input
string $value the error message
Output
Exception

setFocusElementID

public void setFocusElementID (string $value )

Sets the ID of the HTML element that will receive focus if validation fails and getFocusOnError is true.

Input
string $value the ID of the HTML element to receive focus
Output
Exception

setFocusOnError

public void setFocusOnError (boolean $value )

Input
boolean $value whether to set focus at the validating place if the validation fails
Output
Exception

setForControl

public void setForControl (string $value )

This method overrides the parent implementation to forbid setting ForControl.

Input
string | $value | the associated control ID
Output
Exception
throws | TNotSupportedException whenever this method is called

setIsValid

public void setIsValid (boolean $value )

Sets the value indicating whether the validation succeeds

Input
boolean $value whether the validation succeeds
Output
Exception

setValidationGroup

public void setValidationGroup (string $value )

Input
string $value the group which this validator belongs to
Output
Exception

updateControlCssClass

protected boolean updateControlCssClass ()

Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.

Output
boolean true if change, false otherwise.
Exception

validate

public boolean validate ()

Validates the specified control.

Do not override this method. Override evaluateIsValid instead.

Output
boolean whether the validation succeeds
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TValidationDataType

Class TValidationDataType (Class Overview)

TEnumerable
   |
   --TValidationDataType

Direct Known Sub-classes:

TRangeValidationDataType

TValidationDataType class.

TValidationDataType defines the enumerable type for the possible data types that a comparison validator can validate upon.

The following enumerable values are defined:

  • Integer
  • Float
  • Date
  • String

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Date
string | Float
string | Integer
string | String
Constant Details

Date

Type:

string

Value:

'Date'

Float

Type:

string

Value:

'Float'

Integer

Type:

string

Value:

'Integer'

String

Type:

string

Value:

'String'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TValidatorClientSide

Class TValidatorClientSide (Class Overview)

TComponent
   |
   --TClientSideOptions
      |
      --TValidatorClientSide

TValidatorClientSide class.

Client-side validator events can be modified through the TBaseValidator::getClientSide property of a validator. The subproperties of ClientSide are those of the TValidatorClientSide properties. The client-side validator supports the following events.

The <tt>OnValidate</tt> event is raise before the validator validation functions are called.

The <tt>OnValidationSuccess</tt> event is raised after the validator has successfully validate the control.

The <tt>OnValidationError</tt> event is raised after the validator fails validation.

See the quickstart documentation for further details.

Since: 3.0
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
boolean | getObserveChanges ()
string | getOnValidate ()
string | getOnValidationError ()
string | getOnValidationSuccess ()
void | setObserveChanges ( boolean $value)
void | setOnValidate ( string $javascript) Client-side OnValidate validator event is raise before the validators validation functions are called.
void | setOnValidationError ( string $javascript) Client-side OnError event is raised after validation failure.
void | setOnValidationSuccess ( string $javascript) Client-side OnSuccess event is raise after validation is successfull.
Methods Inherited From TClientSideOptions
TClientSideOptions::ensureFunction(), TClientSideOptions::getOption(), TClientSideOptions::getOptions(), TClientSideOptions::setFunction(), TClientSideOptions::setOption()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getObserveChanges

public boolean getObserveChanges ()

Output
boolean true to observe changes.
Exception

getOnValidate

public string getOnValidate ()

Output
string javascript code for client-side OnValidate event.
Exception

getOnValidationError

public string getOnValidationError ()

Output
string javascript code for client-side OnError event.
Exception

getOnValidationSuccess

public string getOnValidationSuccess ()

Output
string javascript code for client-side OnSuccess event.
Exception

setObserveChanges

public void setObserveChanges (boolean $value )

Input
boolean $value true to revalidate when the control to validate changes value.
Output
Exception

setOnValidate

public void setOnValidate (string $javascript )

Client-side OnValidate validator event is raise before the validators validation functions are called.

Input
string $javascript javascript code for client-side OnValidate event.
Output
Exception

setOnValidationError

public void setOnValidationError (string $javascript )

Client-side OnError event is raised after validation failure.

This will override the default client-side validator behaviour.

Input
string $javascript javascript code for client-side OnError event.
Output
Exception

setOnValidationSuccess

public void setOnValidationSuccess (string $javascript )

Client-side OnSuccess event is raise after validation is successfull.

This will override the default client-side validator behaviour.

Input
string $javascript javascript code for client-side OnSuccess event.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TValidatorDisplayStyle

Class TValidatorDisplayStyle (Class Overview)

TEnumerable
   |
   --TValidatorDisplayStyle

TValidatorDisplayStyle class.

TValidatorDisplayStyle defines the enumerable type for the possible styles that a validator control can display the error message.

The following enumerable values are defined:

  • None: the error message is not displayed
  • Dynamic: the error message dynamically appears when the validator fails validation
  • Fixed: Similar to Dynamic except that the error message physically occupies the page layout (even though it may not be visible)

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Dynamic
string | Fixed
string | None
Constant Details

Dynamic

Type:

string

Value:

'Dynamic'

Fixed

Type:

string

Value:

'Fixed'

None

Type:

string

Value:

'None'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TBoundColumn

Class TBoundColumn (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TBoundColumn

TBoundColumn class

TBoundColumn represents a column that is bound to a field in a data source. The cells in the column will be displayed using the data indexed by DataField. You can customize the display by setting DataFormatString.

If ReadOnly is false, TBoundColumn will display cells in edit mode with textboxes. Otherwise, a static text is displayed.

When a datagrid row is in edit mode, the textbox control in the TBoundColumn can be accessed by one of the following two methods:

1      $datagridItem->BoundColumnID->TextBox
2      $datagridItem->BoundColumnID->Controls[0]
The second method is possible because the textbox control created within the datagrid cell is the first child.

Since v3.1.0, TBoundColumn has introduced two new properties ItemRenderer and EditItemRenderer which can be used to specify the layout of the datagrid cells in browsing and editing mode. A renderer refers to a control class that is to be instantiated as a control. For more details, see TRepeater and TDataList.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | dataBindColumn ( mixed $sender, mixed $param) Databinds a cell in the column.
string | getDataField ()
string | getDataFormatString ()
string | getEditItemRenderer ()
string | getItemRenderer ()
boolean | getReadOnly ()
void | initializeCell ( TTableCell $cell, integer $columnIndex, string $itemType) Initializes the specified cell to its initial values.
void | setDataField ( string $value)
void | setDataFormatString ( string $value)
void | setEditItemRenderer ( string $value) Sets the edit item cell renderer class.
void | setItemRenderer ( string $value) Sets the item cell renderer class.
void | setReadOnly ( boolean $value)
Methods Inherited From TDataGridColumn
TDataGridColumn::formatDataValue(), TDataGridColumn::getAllowSorting(), TDataGridColumn::getDataFieldValue(), TDataGridColumn::getEnableCellGrouping(), TDataGridColumn::getFooterRenderer(), TDataGridColumn::getFooterStyle(), TDataGridColumn::getFooterText(), TDataGridColumn::getHeaderImageUrl(), TDataGridColumn::getHeaderRenderer(), TDataGridColumn::getHeaderStyle(), TDataGridColumn::getHeaderText(), TDataGridColumn::getID(), TDataGridColumn::getItemStyle(), TDataGridColumn::getOwner(), TDataGridColumn::getSortExpression(), TDataGridColumn::getViewState(), TDataGridColumn::getVisible(), TDataGridColumn::initialize(), TDataGridColumn::initializeCell(), TDataGridColumn::initializeFooterCell(), TDataGridColumn::initializeHeaderCell(), TDataGridColumn::loadState(), TDataGridColumn::saveState(), TDataGridColumn::setEnableCellGrouping(), TDataGridColumn::setFooterRenderer(), TDataGridColumn::setFooterText(), TDataGridColumn::setHeaderImageUrl(), TDataGridColumn::setHeaderRenderer(), TDataGridColumn::setHeaderText(), TDataGridColumn::setID(), TDataGridColumn::setOwner(), TDataGridColumn::setSortExpression(), TDataGridColumn::setViewState(), TDataGridColumn::setVisible()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

dataBindColumn

public void dataBindColumn (mixed $sender , mixed $param )

Databinds a cell in the column.

This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

Input
mixed | $sender
mixed | $param
Output
Exception

getDataField

public string getDataField ()

Output
string the field name from the data source to bind to the column
Exception

getDataFormatString

public string getDataFormatString ()

Output
string the formatting string used to control how the bound data will be displayed.
Exception

getEditItemRenderer

public string getEditItemRenderer ()

Output
string the class name for the edit item cell renderer. Defaults to empty, meaning not set.
Exception

getItemRenderer

public string getItemRenderer ()

Output
string the class name for the item cell renderer. Defaults to empty, meaning not set.
Exception

getReadOnly

public boolean getReadOnly ()

Output
boolean whether the items in the column can be edited. Defaults to false.
Exception

initializeCell

public void initializeCell (TTableCell $cell , integer $columnIndex , string $itemType )

Initializes the specified cell to its initial values.

This method overrides the parent implementation. It creates a textbox for item in edit mode and the column is not read-only. Otherwise it displays a static text. The caption of the button and the static text are retrieved from the datasource.

Input
TTableCell | $cell | the cell to be initialized.
integer | $columnIndex | the index to the Columns property that the cell resides in.
string | $itemType | the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)
Output
Exception

setDataField

public void setDataField (string $value )

Input
string $value the field name from the data source to bind to the column
Output
Exception

setDataFormatString

public void setDataFormatString (string $value )

Input
string $value the formatting string used to control how the bound data will be displayed.
Output
Exception

setEditItemRenderer

public void setEditItemRenderer (string $value )

Sets the edit item cell renderer class.

If not empty, the class will be used to instantiate as a child control in the item cell that is in edit mode.

If the class implements IDataRenderer, the Data property will be set as the data associated with the datagrid cell during databinding. The data can be either the whole data row or a field of the row if DataField is not empty. If DataFormatString is not empty, the data will be formatted first before passing to the renderer.

Input
string $value the renderer class name in namespace format.
Output
Exception

setItemRenderer

public void setItemRenderer (string $value )

Sets the item cell renderer class.

If not empty, the class will be used to instantiate as a child control in the item cells of the column.

If the class implements IDataRenderer, the Data property will be set as the data associated with the datagrid cell during databinding. The data can be either the whole data row or a field of the row if DataField is not empty. If DataFormatString is not empty, the data will be formatted first before passing to the renderer.

Input
string $value the renderer class name in namespace format.
Output
Exception

setReadOnly

public void setReadOnly (boolean $value )

Input
boolean $value whether the items in the column can be edited
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TBulletedList

Class TBulletedList (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TBulletedList

TBulletedList class

TBulletedList displays items in a bullet format. The bullet style is specified by BulletStyle. When the style is 'CustomImage', the setBackImageUrl specifies the image used as bullets.

TBulletedList displays the item texts in three different modes, specified via DisplayMode. When the mode is Text, the item texts are displayed as static texts; When the mode is 'HyperLink', each item is displayed as a hyperlink whose URL is given by the item value, and the Target property can be used to specify the target browser window; When the mode is 'LinkButton', each item is displayed as a link button which posts back to the page if a user clicks on that and the event OnClick will be raised under such a circumstance.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute name-value pairs to renderer.
protected void | canCauseValidation ()
string | getBulletImageUrl ()
TBulletStyle | getBulletStyle ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
TBulletedListDisplayMode | getDisplayMode ()
integer | getFirstBulletNumber ()
protected array | getPostBackOptions ()
protected string | getTagName ()
string | getTarget ()
void | onClick ( TBulletedListEventParameter $param) Raises 'OnClick' event.
void | raisePostBackEvent ( TEventParameter $param) Raises the postback event.
void | render ( THtmlWriter $writer) Renders the control.
protected void | renderBulletText ( THtmlWriter $writer, TListItem $item, integer $index) Renders each item
void | renderContents ( THtmlWriter $writer) Renders the body contents.
protected void | renderHyperLinkItem ( mixed $writer, mixed $item, mixed $index)
protected void | renderLinkButtonItem ( mixed $writer, mixed $item, mixed $index)
protected void | renderTextItem ( mixed $writer, mixed $item, mixed $index)
void | setAutoPostBack ( mixed $value)
void | setBulletImageUrl ( string $value)
void | setBulletStyle ( TBulletStyle $value)
TBulletedListDisplayMode | setDisplayMode ( mixed $value)
void | setFirstBulletNumber ( integer $value)
void | setSelectedIndex ( mixed $index)
void | setSelectedIndices ( mixed $indices)
void | setSelectedValue ( mixed $value)
void | setSelectedValues ( mixed $values)
void | setTarget ( string $value)
Methods Inherited From TListControl
TListControl::addAttributesToRender(), TListControl::addParsedObject(), TListControl::clearSelection(), TListControl::createListItemCollection(), TListControl::formatDataValue(), TListControl::getAppendDataBoundItems(), TListControl::getAutoPostBack(), TListControl::getCausesValidation(), TListControl::getClientClassName(), TListControl::getData(), TListControl::getDataGroupField(), TListControl::getDataTextField(), TListControl::getDataTextFormatString(), TListControl::getDataValueField(), TListControl::getEnableClientScript(), TListControl::getHasItems(), TListControl::getIsMultiSelect(), TListControl::getItemCount(), TListControl::getItems(), TListControl::getPostBackOptions(), TListControl::getPromptText(), TListControl::getPromptValue(), TListControl::getSelectedIndex(), TListControl::getSelectedIndices(), TListControl::getSelectedItem(), TListControl::getSelectedValue(), TListControl::getSelectedValues(), TListControl::getTagName(), TListControl::getText(), TListControl::getValidationGroup(), TListControl::loadState(), TListControl::onSelectedIndexChanged(), TListControl::onTextChanged(), TListControl::performDataBinding(), TListControl::renderClientControlScript(), TListControl::renderContents(), TListControl::renderPrompt(), TListControl::saveState(), TListControl::setAppendDataBoundItems(), TListControl::setAutoPostBack(), TListControl::setCausesValidation(), TListControl::setData(), TListControl::setDataGroupField(), TListControl::setDataTextField(), TListControl::setDataTextFormatString(), TListControl::setDataValueField(), TListControl::setEnableClientScript(), TListControl::setPromptText(), TListControl::setPromptValue(), TListControl::setSelectedIndex(), TListControl::setSelectedIndices(), TListControl::setSelectedValue(), TListControl::setSelectedValues(), TListControl::setText(), TListControl::setValidationGroup()
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute name-value pairs to renderer.

This overrides the parent implementation with additional bulleted list specific attributes.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

canCauseValidation

protected void canCauseValidation ()

Output
Exception

getBulletImageUrl

public string getBulletImageUrl ()

Output
string image URL used for bullets when BulletStyle is 'CustomImage'.
Exception

getBulletStyle

public TBulletStyle getBulletStyle ()

Output
TBulletStyle style of bullets. Defaults to TBulletStyle::NotSet.
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getDisplayMode

public TBulletedListDisplayMode getDisplayMode ()

Output
TBulletedListDisplayMode display mode of the list. Defaults to TBulletedListDisplayMode::Text.
Exception

getFirstBulletNumber

public integer getFirstBulletNumber ()

Output
integer starting index when BulletStyle is one of the following: 'Numbered', 'LowerAlpha', 'UpperAlpha', 'LowerRoman', 'UpperRoman'. Defaults to 1.
Exception

getPostBackOptions

protected array getPostBackOptions ()

Output
array postback options used for linkbuttons.
Exception

getTagName

protected string getTagName ()

Output
string tag name of the bulleted list
Exception

getTarget

public string getTarget ()

Output
string the target window or frame to display the Web page content linked to when DisplayMode is 'HyperLink' and one of the hyperlinks is clicked.
Exception

onClick

public void onClick (TBulletedListEventParameter $param )

Raises 'OnClick' event.

This method is invoked when the DisplayMode is 'LinkButton' and end-users click on one of the buttons.

Input
TBulletedListEventParameter $param event parameter.
Output
Exception

raisePostBackEvent

public void raisePostBackEvent (TEventParameter $param )

Raises the postback event.

This method is required by IPostBackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick events. This method is mainly used by framework and control developers.

Input
TEventParameter $param the event parameter
Output
Exception

render

public void render (THtmlWriter $writer )

Renders the control.

Input
THtmlWriter $writer the writer for the rendering purpose.
Output
Exception

renderBulletText

protected void renderBulletText (THtmlWriter $writer , TListItem $item , integer $index )

Renders each item

Input
THtmlWriter | $writer | writer for the rendering purpose
TListItem | $item | item to be rendered
integer | $index | index of the item being rendered
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders the body contents.

Input
THtmlWriter $writer the writer for the rendering purpose.
Output
Exception

renderHyperLinkItem

protected void renderHyperLinkItem (mixed $writer , mixed $item , mixed $index )

Input
mixed | $writer
mixed | $item
mixed | $index
Output
Exception

renderLinkButtonItem

protected void renderLinkButtonItem (mixed $writer , mixed $item , mixed $index )

Input
mixed | $writer
mixed | $item
mixed | $index
Output
Exception

renderTextItem

protected void renderTextItem (mixed $writer , mixed $item , mixed $index )

Input
mixed | $writer
mixed | $item
mixed | $index
Output
Exception

setAutoPostBack

public void setAutoPostBack (mixed $value )

Input
mixed | $value
Output
Exception
throws | TNotSupportedException if this method is invoked

setBulletImageUrl

public void setBulletImageUrl (string $value )

Input
string $value image URL used for bullets when BulletStyle is 'CustomImage'.
Output
Exception

setBulletStyle

public void setBulletStyle (TBulletStyle $value )

Input
TBulletStyle $value style of bullets.
Output
Exception

setDisplayMode

public TBulletedListDisplayMode setDisplayMode (mixed $value )

Input
mixed | $value
Output
TBulletedListDisplayMode | display mode of the list.
Exception

setFirstBulletNumber

public void setFirstBulletNumber (integer $value )

Input
integer $value starting index when BulletStyle is one of the following: 'Numbered', 'LowerAlpha', 'UpperAlpha', 'LowerRoman', 'UpperRoman'.
Output
Exception

setSelectedIndex

public void setSelectedIndex (mixed $index )

Input
mixed | $index
Output
Exception
throws | TNotSupportedException if this method is invoked

setSelectedIndices

public void setSelectedIndices (mixed $indices )

Input
mixed | $indices
Output
Exception
throws | TNotSupportedException if this method is invoked

setSelectedValue

public void setSelectedValue (mixed $value )

Input
mixed | $value
Output
Exception
throws | TNotSupportedException if this method is invoked

setSelectedValues

public void setSelectedValues (mixed $values )

Input
mixed | $values
Output
Exception
throws | TNotSupportedException if this method is invoked

setTarget

public void setTarget (string $value )

Input
string $value the target window or frame to display the Web page content linked to when DisplayMode is 'HyperLink' and one of the hyperlinks is clicked.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TBulletedListDisplayMode

Class TBulletedListDisplayMode (Class Overview)

TEnumerable
   |
   --TBulletedListDisplayMode

TBulletedListDisplayMode class.

TBulletedListDisplayMode defines the enumerable type for the possible display mode of a TBulletedList control.

The following enumerable values are defined:

  • Text: the bulleted list items are displayed as plain texts
  • HyperLink: the bulleted list items are displayed as hyperlinks
  • LinkButton: the bulleted list items are displayed as link buttons that can cause postbacks

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | HyperLink
string | LinkButton
string | Text
Constant Details

HyperLink

Type:

string

Value:

'HyperLink'

LinkButton

Type:

string

Value:

'LinkButton'

Text

Type:

string

Value:

'Text'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TBulletedListEventParameter

Class TBulletedListEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TBulletedListEventParameter

TBulletedListEventParameter Event parameter for TBulletedList::onClick event of the bulleted list. The getIndex gives the zero-based index of the item that is currently being clicked.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
integer
getIndex ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getIndex

public integer getIndex ()

Output
integer zero-based index of the item (rendered as a link button) that is clicked
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TBulletStyle

Class TBulletStyle (Class Overview)

TEnumerable
   |
   --TBulletStyle

TBulletStyle class.

TBulletStyle defines the enumerable type for the possible bullet styles that may be used for a TBulletedList control.

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Circle
string | CustomImage
string | Disc
string | LowerAlpha
string | LowerRoman
string | None
string | NotSet
string | Numbered
string | Square
string | UpperAlpha
string | UpperRoman
Constant Details

Circle

Type:

string

Value:

'Circle'

CustomImage

Type:

string

Value:

'CustomImage'

Disc

Type:

string

Value:

'Disc'

LowerAlpha

Type:

string

Value:

'LowerAlpha'

LowerRoman

Type:

string

Value:

'LowerRoman'

None

Type:

string

Value:

'None'

NotSet

Type:

string

Value:

'NotSet'

Numbered

Type:

string

Value:

'Numbered'

Square

Type:

string

Value:

'Square'

UpperAlpha

Type:

string

Value:

'UpperAlpha'

UpperRoman

Type:

string

Value:

'UpperRoman'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TButton

Class TButton (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TButton

Direct Known Sub-classes:

TActiveButton

TButton class

TButton creates a click button on the page. It is mainly used to submit data to a page.

TButton raises two server-side events, OnClick and OnCommand, when it is clicked on the client-side. The difference between these two events is that the event OnCommand is bubbled up to the button's ancestor controls. And within the event parameter for OnCommand contains the reference to the CommandName and CommandParameter property values that are set for the button object. This allows you to create multiple TButton components on a Web page and programmatically determine which one is clicked with what parameter.

Clicking on button can also trigger form validation, if CausesValidation is true. The validation may be restricted within a certain group of validator controls by setting ValidationGroup property. If validation is successful, the data will be post back to the same page.

TButton displays the Text property as the button caption.

TButton can be one of three ButtonType: Submit, Button and Reset. By default, it is a Submit button and the form submission uses the browser's default submission capability. If it is Button or Reset, postback may occur if one of the following conditions is met:

  • an event handler is attached to OnClick event;
  • an event handler is attached to OnCommand event;
  • the button is in a non-empty validation group.
In addition, clicking on a Reset button will clear up all input fields if the button does not cause a postback.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute name-value pairs to renderer.
protected boolean | canCauseValidation ()
TButtonType | getButtonType ()
boolean | getCausesValidation ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
string | getCommandName ()
string | getCommandParameter ()
string | getData () Returns the caption of the button.
boolean | getEnableClientScript ()
boolean | getIsDefaultButton ()
protected array | getPostBackOptions () Returns postback specifications for the button.
protected string | getTagName ()
string | getText ()
string | getValidationGroup ()
protected boolean | needPostBackScript ()
void | onClick ( TEventParameter $param) This method is invoked when the button is clicked.
void | onCommand ( TCommandEventParameter $param) This method is invoked when the button is clicked.
void | raisePostBackEvent ( TEventParameter $param) Raises the postback event.
protected void | renderClientControlScript ( mixed $writer) Renders the client-script code.
void | renderContents ( THtmlWriter $writer) Renders the body content enclosed between the control tag.
void | setButtonType ( TButtonType $value)
void | setCausesValidation ( boolean $value)
void | setCommandName ( string $value)
void | setCommandParameter ( string $value)
void | setData ( string $value) Sets the caption of the button.
void | setEnableClientScript ( boolean $value)
void | setIsDefaultButton ( boolean $value)
void | setText ( string $value)
void | setValidationGroup ( string $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute name-value pairs to renderer.

This overrides the parent implementation with additional button specific attributes.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

canCauseValidation

protected boolean canCauseValidation ()

Output
boolean whether to perform validation if the button is clicked
Exception

getButtonType

public TButtonType getButtonType ()

Output
TButtonType the type of the button. Defaults to TButtonType::Submit.
Exception

getCausesValidation

public boolean getCausesValidation ()

Output
boolean whether postback event trigger by this button will cause input validation, default is true
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getCommandName

public string getCommandName ()

Output
string the command name associated with the OnCommand event.
Exception

getCommandParameter

public string getCommandParameter ()

Output
string the parameter associated with the OnCommand event
Exception

getData

public string getData ()

Returns the caption of the button.

This method is required by IDataRenderer. It is the same as getText().

Output
string caption of the button.
Exception

getEnableClientScript

public boolean getEnableClientScript ()

Output
boolean whether to render javascript.
Exception

getIsDefaultButton

public boolean getIsDefaultButton ()

Output
boolean true if this button is registered as a default button for a panel.
Exception

getPostBackOptions

protected array getPostBackOptions ()

Returns postback specifications for the button.

This method is used by framework and control developers.

Output
array parameters about how the button defines its postback behavior.
Exception

getTagName

protected string getTagName ()

Output
string tag name of the button
Exception

getText

public string getText ()

Output
string caption of the button
Exception

getValidationGroup

public string getValidationGroup ()

Output
string the group of validators which the button causes validation upon postback
Exception

needPostBackScript

protected boolean needPostBackScript ()

Output
boolean whether the button needs javascript to do postback
Exception

onClick

public void onClick (TEventParameter $param )

This method is invoked when the button is clicked.

The method raises 'OnClick' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onCommand

public void onCommand (TCommandEventParameter $param )

This method is invoked when the button is clicked.

The method raises 'OnCommand' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

Input
TCommandEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raisePostBackEvent

public void raisePostBackEvent (TEventParameter $param )

Raises the postback event.

This method is required by IPostBackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick and OnCommand events. This method is mainly used by framework and control developers.

Input
TEventParameter $param the event parameter
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Renders the client-script code.

Input
mixed $writer
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders the body content enclosed between the control tag.

This overrides the parent implementation with nothing to be rendered.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

setButtonType

public void setButtonType (TButtonType $value )

Input
TButtonType $value the type of the button.
Output
Exception

setCausesValidation

public void setCausesValidation (boolean $value )

Input
boolean $value whether postback event trigger by this button will cause input validation
Output
Exception

setCommandName

public void setCommandName (string $value )

Input
string $value the command name associated with the OnCommand event.
Output
Exception

setCommandParameter

public void setCommandParameter (string $value )

Input
string $value the parameter associated with the OnCommand event.
Output
Exception

setData

public void setData (string $value )

Sets the caption of the button.

This method is required by IDataRenderer. It is the same as setText().

Input
string $value caption of the button
Output
Exception

setEnableClientScript

public void setEnableClientScript (boolean $value )

Input
boolean $value whether to render javascript.
Output
Exception

setIsDefaultButton

public void setIsDefaultButton (boolean $value )

Input
boolean $value set by a panel to register this button as the default button for the panel.
Output
Exception

setText

public void setText (string $value )

Input
string $value caption of the button
Output
Exception

setValidationGroup

public void setValidationGroup (string $value )

Input
string $value the group of validators which the button causes validation upon postback
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TButtonType

Class TButtonType (Class Overview)

TEnumerable
   |
   --TButtonType

TButtonType class.

TButtonType defines the enumerable type for the possible types that a TButton can take.

The following enumerable values are defined:

  • Submit: a normal submit button
  • Reset: a reset button
  • Button: a client button (normally does not perform form submission)

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Button
string | Reset
string | Submit
Constant Details

Button

Type:

string

Value:

'Button'

Reset

Type:

string

Value:

'Reset'

Submit

Type:

string

Value:

'Submit'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TButtonColumn

Class TButtonColumn (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TButtonColumn

TButtonColumn class

TButtonColumn contains a user-defined command button, such as Add or Remove, that corresponds with each row in the column.

The caption of the buttons in the column is determined by Text and DataTextField properties. If both are present, the latter takes precedence. The DataTextField property refers to the name of the field in datasource whose value will be used as the button caption. If DataTextFormatString is not empty, the value will be formatted before rendering.

The buttons in the column can be set to display as hyperlinks or push buttons by setting the ButtonType property. The CommandName will assign its value to all button's CommandName property. The datagrid will capture the command event where you can write event handlers based on different command names. The buttons' CausesValidation and ValidationGroup property values are determined by the column's corresponding properties.

The buttons in the column can be accessed by one of the following two methods:

1      $datagridItem->ButtonColumnID->Button
2      $datagridItem->ButtonColumnID->Controls[0]
The second method is possible because the button control created within the datagrid cell is the first child.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | dataBindColumn ( mixed $sender, mixed $param) Databinds a cell in the column.
TButtonColumnType | getButtonType ()
boolean | getCausesValidation ()
string | getCommandName ()
string | getDataImageUrlField ()
string | getDataImageUrlFormatString ()
string | getDataTextField ()
string | getDataTextFormatString ()
string | getImageUrl ()
string | getText ()
string | getValidationGroup ()
void | initializeCell ( TTableCell $cell, integer $columnIndex, string $itemType) Initializes the specified cell to its initial values.
void | setButtonType ( TButtonColumnType $value)
void | setCausesValidation ( boolean $value)
void | setCommandName ( string $value) Sets the command name associated with the Command event.
void | setDataImageUrlField ( string $value)
void | setDataImageUrlFormatString ( string $value)
void | setDataTextField ( string $value)
void | setDataTextFormatString ( string $value)
void | setImageUrl ( string $value)
void | setText ( string $value) Sets the text caption of the button.
void | setValidationGroup ( string $value)
Methods Inherited From TDataGridColumn
TDataGridColumn::formatDataValue(), TDataGridColumn::getAllowSorting(), TDataGridColumn::getDataFieldValue(), TDataGridColumn::getEnableCellGrouping(), TDataGridColumn::getFooterRenderer(), TDataGridColumn::getFooterStyle(), TDataGridColumn::getFooterText(), TDataGridColumn::getHeaderImageUrl(), TDataGridColumn::getHeaderRenderer(), TDataGridColumn::getHeaderStyle(), TDataGridColumn::getHeaderText(), TDataGridColumn::getID(), TDataGridColumn::getItemStyle(), TDataGridColumn::getOwner(), TDataGridColumn::getSortExpression(), TDataGridColumn::getViewState(), TDataGridColumn::getVisible(), TDataGridColumn::initialize(), TDataGridColumn::initializeCell(), TDataGridColumn::initializeFooterCell(), TDataGridColumn::initializeHeaderCell(), TDataGridColumn::loadState(), TDataGridColumn::saveState(), TDataGridColumn::setEnableCellGrouping(), TDataGridColumn::setFooterRenderer(), TDataGridColumn::setFooterText(), TDataGridColumn::setHeaderImageUrl(), TDataGridColumn::setHeaderRenderer(), TDataGridColumn::setHeaderText(), TDataGridColumn::setID(), TDataGridColumn::setOwner(), TDataGridColumn::setSortExpression(), TDataGridColumn::setViewState(), TDataGridColumn::setVisible()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

dataBindColumn

public void dataBindColumn (mixed $sender , mixed $param )

Databinds a cell in the column.

This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

Input
mixed | $sender
mixed | $param
Output
Exception

getButtonType

public TButtonColumnType getButtonType ()

Output
TButtonColumnType the type of command button. Defaults to TButtonColumnType::LinkButton.
Exception

getCausesValidation

public boolean getCausesValidation ()

Output
boolean whether postback event trigger by this button will cause input validation, default is true
Exception

getCommandName

public string getCommandName ()

Output
string the command name associated with the OnCommand event.
Exception

getDataImageUrlField

public string getDataImageUrlField ()

Output
string the field name from the data source to bind to the button image url
Exception

getDataImageUrlFormatString

public string getDataImageUrlFormatString ()

Output
string the formatting string used to control how the button image url will be displayed.
Exception

getDataTextField

public string getDataTextField ()

Output
string the field name from the data source to bind to the button caption
Exception

getDataTextFormatString

public string getDataTextFormatString ()

Output
string the formatting string used to control how the button caption will be displayed.
Exception

getImageUrl

public string getImageUrl ()

Output
string the URL of the image file for image buttons
Exception

getText

public string getText ()

Output
string the text caption of the button
Exception

getValidationGroup

public string getValidationGroup ()

Output
string the group of validators which the button causes validation upon postback
Exception

initializeCell

public void initializeCell (TTableCell $cell , integer $columnIndex , string $itemType )

Initializes the specified cell to its initial values.

This method overrides the parent implementation. It creates a command button within the cell.

Input
TTableCell | $cell | the cell to be initialized.
integer | $columnIndex | the index to the Columns property that the cell resides in.
string | $itemType | the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)
Output
Exception

setButtonType

public void setButtonType (TButtonColumnType $value )

Input
TButtonColumnType $value the type of command button
Output
Exception

setCausesValidation

public void setCausesValidation (boolean $value )

Input
boolean $value whether postback event trigger by this button will cause input validation
Output
Exception

setCommandName

public void setCommandName (string $value )

Sets the command name associated with the Command event.

Input
string $value the text caption to be set
Output
Exception

setDataImageUrlField

public void setDataImageUrlField (string $value )

Input
string $value the field name from the data source to bind to the button image url
Output
Exception

setDataImageUrlFormatString

public void setDataImageUrlFormatString (string $value )

Input
string $value the formatting string used to control how the button image url will be displayed.
Output
Exception

setDataTextField

public void setDataTextField (string $value )

Input
string $value the field name from the data source to bind to the button caption
Output
Exception

setDataTextFormatString

public void setDataTextFormatString (string $value )

Input
string $value the formatting string used to control how the button caption will be displayed.
Output
Exception

setImageUrl

public void setImageUrl (string $value )

Input
string $value the URL of the image file for image buttons
Output
Exception

setText

public void setText (string $value )

Sets the text caption of the button.

Input
string $value the text caption to be set
Output
Exception

setValidationGroup

public void setValidationGroup (string $value )

Input
string $value the group of validators which the button causes validation upon postback
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCaptcha

Class TCaptcha (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TImage
               |
               --TCaptcha

TCaptcha class.

TCaptcha displays a CAPTCHA (a token displayed as an image) that can be used to determine if the input is entered by a real user instead of some program.

Unlike other CAPTCHA scripts, TCaptcha does not need session or cookie.

The token (a string consisting of alphanumeric characters) displayed is automatically generated and can be configured in several ways. To specify the length of characters in the token, set MinTokenLength and MaxTokenLength. To use case-insensitive comparison and generate upper-case-only token, set CaseSensitive to false. Advanced users can try to set TokenAlphabet, which specifies what characters can appear in tokens.

The validation of the token is related with two properties: TestLimit and TokenExpiry. The former specifies how many times a token can be tested with on the server side, and the latter says when a generated token will expire.

To specify the appearance of the generated token image, set TokenImageTheme to be an integer between 0 and 63. And to adjust the generated image size, set TokenFontSize (you may also set TWebControl::setWidth, but the scaled image may not look good.) By setting ChangingTokenBackground to true, the image background of the token will be variating even though the token is the same during postbacks.

Upon postback, user input can be validated by calling validate(). The TCaptchaValidator control can also be used to do validation, which provides client-side validation besides the server-side validation. By default, the token will remain the same during multiple postbacks. A new one can be generated by calling regenerateToken() manually.

The following template shows a typical use of TCaptcha control:

1      <com:TCaptcha ID="Captcha" />
2      <com:TTextBox ID="Input" />
3      <com:TCaptchaValidator CaptchaControl="Captcha"
4                             ControlToValidate="Input"
5                             ErrorMessage="You are challenged!" />

Since: 3.1.1
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
boolean | checkRequirements () Checks the requirements needed for generating CAPTCHA images.
protected string | generatePrivateKeyFile () Generates a file with a randomly generated private key.
protected string | generateRandomKey ()
protected string | generateToken ( string $publicKey, string $privateKey, integer $alphabet, boolean $tokenLength, mixed $caseSensitive) Generates the token.
protected string | getCaptchaScriptFile ()
boolean | getCaseSensitive ()
boolean | getChangingTokenBackground ()
protected void | getFontFile ()
boolean | getIsTokenExpired ()
integer | getMaxTokenLength ()
integer | getMinTokenLength ()
string | getPrivateKey ()
string | getPublicKey ()
integer | getTestLimit ()
string | getToken ()
string | getTokenAlphabet ()
integer | getTokenExpiry ()
integer | getTokenFontSize ()
protected string | getTokenImageOptions ()
integer | getTokenImageTheme ()
protected integer | getTokenLength ()
protected string | hash2string ( string $hex, string $alphabet) Converts a hash string into a string with characters consisting of alphanumeric characters.
void | onPreRender ( mixed $param) Configures the image URL that shows the token.
void | regenerateToken () Regenerates the token to be displayed.
void | setCaseSensitive ( boolean $value)
void | setChangingTokenBackground ( boolean $value)
void | setMaxTokenLength ( integer $value)
void | setMinTokenLength ( integer $value)
void | setPublicKey ( string $value)
void | setTestLimit ( integer $value)
void | setTokenAlphabet ( string $value)
void | setTokenExpiry ( integer $value)
void | setTokenFontSize ( integer $value) Sets the font size used for displaying the token in an image.
void | setTokenImageTheme ( integer $value) Sets the theme of the token image.
boolean | validate ( string $input) Validates a user input with the token.
Methods Inherited From TImage
TImage::addAttributesToRender(), TImage::getAlternateText(), TImage::getData(), TImage::getDescriptionUrl(), TImage::getImageAlign(), TImage::getImageUrl(), TImage::getTagName(), TImage::renderContents(), TImage::setAlternateText(), TImage::setData(), TImage::setDescriptionUrl(), TImage::setImageAlign(), TImage::setImageUrl()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
int | MAX_TOKEN_LENGTH
int | MIN_TOKEN_LENGTH
Method Details

checkRequirements

public boolean checkRequirements ()

Checks the requirements needed for generating CAPTCHA images.

TCaptach requires GD2 with TrueType font support and PNG image support.

Output
boolean whether the requirements are satisfied.
Exception

generatePrivateKeyFile

protected string generatePrivateKeyFile ()

Generates a file with a randomly generated private key.

Output
string the path of the file keeping the private key
Exception

generateRandomKey

protected string generateRandomKey ()

Output
string a randomly generated key
Exception

generateToken

protected string generateToken (string $publicKey , string $privateKey , integer $alphabet , boolean $tokenLength , mixed $caseSensitive )

Generates the token.

Input
string | $publicKey | public key
string | $privateKey | private key
integer | $alphabet | the length of the token
boolean | $tokenLength | whether the token is case sensitive
mixed | $caseSensitive |
Output
string | the token generated.
Exception

getCaptchaScriptFile

protected string getCaptchaScriptFile ()

Output
string the file path of the PHP script generating the token image
Exception

getCaseSensitive

public boolean getCaseSensitive ()

Output
boolean whether the token should be treated as case-sensitive. Defaults to true.
Exception

getChangingTokenBackground

public boolean getChangingTokenBackground ()

Output
boolean whether the background of the token image should be variated during postbacks. Defaults to false.
Exception

getFontFile

protected void getFontFile ()

Output
Exception

getIsTokenExpired

public boolean getIsTokenExpired ()

Output
boolean whether the currently generated token has expired.
Exception

getMaxTokenLength

public integer getMaxTokenLength ()

Output
integer the maximum length of the token. Defaults to 6.
Exception

getMinTokenLength

public integer getMinTokenLength ()

Output
integer the minimum length of the token. Defaults to 4.
Exception

getPrivateKey

public string getPrivateKey ()

Output
string the private key used for generating the token. This is randomly generated and kept in a file for persistency.
Exception

getPublicKey

public string getPublicKey ()

Output
string the public key used for generating the token. A random one will be generated and returned if this is not set.
Exception

getTestLimit

public integer getTestLimit ()

Output
integer how many times a generated token can be tested. Defaults to 5.
Exception

getToken

public string getToken ()

Output
string the token that will be displayed
Exception

getTokenAlphabet

public string getTokenAlphabet ()

Output
string the characters that may appear in the token. Defaults to '234578adefhijmnrtABDEFGHJLMNRT'.
Exception

getTokenExpiry

public integer getTokenExpiry ()

Output
integer the number of seconds that a generated token will remain valid. Defaults to 600 seconds (10 minutes).
Exception

getTokenFontSize

public integer getTokenFontSize ()

Output
integer the font size used for displaying the token in an image. Defaults to 30.
Exception

getTokenImageOptions

protected string getTokenImageOptions ()

Output
string the options to be passed to the token image generator
Exception

getTokenImageTheme

public integer getTokenImageTheme ()

Output
integer the theme of the token image. Defaults to 0.
Exception

getTokenLength

protected integer getTokenLength ()

Output
integer the length of the token to be generated.
Exception

hash2string

protected string hash2string (string $hex , string $alphabet )

Converts a hash string into a string with characters consisting of alphanumeric characters.

Input
string | $hex | the hexadecimal representation of the hash string
string | $alphabet | the alphabet used to represent the converted string. If empty, it means '234578adefhijmnrtwyABDEFGHIJLMNQRTWY', which excludes those confusing characters.
Output
string | the converted string
Exception

onPreRender

public void onPreRender (mixed $param )

Configures the image URL that shows the token.

Input
mixed $param event parameter
Output
Exception

regenerateToken

public void regenerateToken ()

Regenerates the token to be displayed.

By default, a token, once generated, will remain the same during the following page postbacks. Calling this method will generate a new token.

Output
Exception

setCaseSensitive

public void setCaseSensitive (boolean $value )

Input
boolean $value whether the token should be treated as case-sensitive. If false, only upper-case letters will appear in the token.
Output
Exception

setChangingTokenBackground

public void setChangingTokenBackground (boolean $value )

Input
boolean $value whether the background of the token image should be variated during postbacks.
Output
Exception

setMaxTokenLength

public void setMaxTokenLength (integer $value )

Input
integer $value the maximum length of the token. It must be between 2 and 40.
Output
Exception

setMinTokenLength

public void setMinTokenLength (integer $value )

Input
integer $value the minimum length of the token. It must be between 2 and 40.
Output
Exception

setPublicKey

public void setPublicKey (string $value )

Input
string $value the public key used for generating the token. A random one will be generated if this is not set.
Output
Exception

setTestLimit

public void setTestLimit (integer $value )

Input
integer $value how many times a generated token can be tested. For unlimited tests, set it to 0.
Output
Exception

setTokenAlphabet

public void setTokenAlphabet (string $value )

Input
string $value the characters that may appear in the token. At least 2 characters must be specified.
Output
Exception

setTokenExpiry

public void setTokenExpiry (integer $value )

Input
integer $value the number of seconds that a generated token will remain valid. A value smaller than 1 means the token will not expire.
Output
Exception

setTokenFontSize

public void setTokenFontSize (integer $value )

Sets the font size used for displaying the token in an image.

This property affects the generated token image size. The image width is proportional to this font size.

Input
integer $value the font size used for displaying the token in an image. It must be an integer between 20 and 100.
Output
Exception

setTokenImageTheme

public void setTokenImageTheme (integer $value )

Sets the theme of the token image.

You may test each theme to find out the one you like the most. Below is the explanation of the theme value: It is treated as a 5-bit integer. Each bit toggles a specific feature of the image. Bit 0 (the least significant): whether the image is opaque (1) or transparent (0). Bit 1: whether we should add white noise to the image (1) or not (0). Bit 2: whether we should add a grid to the image (1) or not (0). Bit 3: whether we should add some scribbles to the image (1) or not (0). Bit 4: whether the image background should be morphed (1) or not (0). Bit 5: whether the token text should cast a shadow (1) or not (0).

Input
integer $value the theme of the token image. It must be an integer between 0 and 63.
Output
Exception

validate

public boolean validate (string $input )

Validates a user input with the token.

Input
string | $input | user input
Output
boolean | if the user input is not the same as the token.
Exception
Constant Details

MAX_TOKEN_LENGTH

Type:

int

Value:

40

MIN_TOKEN_LENGTH

Type:

int

Value:

2


PRADO API Manual: Docs For Class TCaptchaValidator

Class TCaptchaValidator (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TCaptchaValidator

TCaptchaValidator class

TCaptchaValidator validates user input against a CAPTCHA represented by a TCaptcha control. The input control fails validation if its value is not the same as the token displayed in CAPTCHA. Note, if the user does not enter any thing, it is still considered as failing the validation.

To use TCaptchaValidator, specify the ControlToValidate to be the ID path of the input control (usually a TTextBox control}. Also specify the CaptchaControl to be the ID path of the CAPTCHA control that the user input should be compared with.

Since: 3.1.1
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected boolean | evaluateIsValid () This method overrides the parent's implementation.
protected TCaptchaControl | findCaptchaControl ()
string | getCaptchaControl ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing validation for this control.
protected array | getClientScriptOptions () Returns an array of javascript validator options.
void | setCaptchaControl ( string $value) Sets the ID path of the CAPTCHA control to validate.
Methods Inherited From TBaseValidator
TBaseValidator::addAttributesToRender(), TBaseValidator::createClientSide(), TBaseValidator::getClientScriptOptions(), TBaseValidator::getClientSide(), TBaseValidator::getControlCssClass(), TBaseValidator::getControlToValidate(), TBaseValidator::getDisplay(), TBaseValidator::getEnableClientScript(), TBaseValidator::getErrorMessage(), TBaseValidator::getFocusElementID(), TBaseValidator::getFocusOnError(), TBaseValidator::getIsValid(), TBaseValidator::getValidationGroup(), TBaseValidator::getValidationTarget(), TBaseValidator::getValidationValue(), TBaseValidator::onInit(), TBaseValidator::onPreRender(), TBaseValidator::onUnload(), TBaseValidator::onValidate(), TBaseValidator::onValidationError(), TBaseValidator::onValidationSuccess(), TBaseValidator::registerClientScriptValidator(), TBaseValidator::renderClientControlScript(), TBaseValidator::renderContents(), TBaseValidator::setControlCssClass(), TBaseValidator::setControlToValidate(), TBaseValidator::setDisplay(), TBaseValidator::setEnableClientScript(), TBaseValidator::setEnabled(), TBaseValidator::setErrorMessage(), TBaseValidator::setFocusElementID(), TBaseValidator::setFocusOnError(), TBaseValidator::setForControl(), TBaseValidator::setIsValid(), TBaseValidator::setValidationGroup(), TBaseValidator::updateControlCssClass(), TBaseValidator::validate()
Methods Inherited From TLabel
TLabel::addAttributesToRender(), TLabel::getData(), TLabel::getForControl(), TLabel::getTagName(), TLabel::getText(), TLabel::render(), TLabel::renderContents(), TLabel::setData(), TLabel::setForControl(), TLabel::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

evaluateIsValid

protected boolean evaluateIsValid ()

This method overrides the parent's implementation.

The validation succeeds if the input control has the same value as the one displayed in the corresponding CAPTCHA control.

Output
boolean whether the validation succeeds
Exception

findCaptchaControl

protected TCaptchaControl findCaptchaControl ()

Output
TCaptchaControl | the CAPTCHA control to be validated against
Exception
throws | TConfigurationException if the CAPTCHA cannot be found according to CaptchaControl

getCaptchaControl

public string getCaptchaControl ()

Output
string the ID path of the CAPTCHA control to validate
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing validation for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientScriptOptions

protected array getClientScriptOptions ()

Returns an array of javascript validator options.

Output
array javascript validator options.
Exception

setCaptchaControl

public void setCaptchaControl (string $value )

Sets the ID path of the CAPTCHA control to validate.

The ID path is the dot-connected IDs of the controls reaching from the validator's naming container to the target control.

Input
string $value the ID path
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCheckBox

Class TCheckBox (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TCheckBox

Direct Known Sub-classes:

TActiveCheckBox , TRadioButton

TCheckBox class

TCheckBox displays a check box on the page. You can specify the caption to display beside the check box by setting the Text property. The caption can appear either on the right or left of the check box, which is determined by the TextAlign property.

To determine whether the TCheckBox component is checked, test the Checked property. The OnCheckedChanged event is raised when the Checked state of the TCheckBox component changes between posts to the server. You can provide an event handler for the OnCheckedChanged event to to programmatically control the actions performed when the state of the TCheckBox component changes between posts to the server.

If AutoPostBack is set true, changing the check box state will cause postback action. And if CausesValidation is true, validation will also be processed, which can be further restricted within a ValidationGroup.

Note, Text is rendered as is. Make sure it does not contain unwanted characters that may bring security vulnerabilities.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
boolean | getAutoPostBack ()
boolean | getCausesValidation ()
boolean | getChecked ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
boolean | getData () Returns the value indicating whether the checkbox is checked.
boolean | getDataChanged () Returns a value indicating whether postback has caused the control data change.
boolean | getEnableClientScript ()
TMap | getInputAttributes ()
bool | getIsValid () Returns true if this control validated successfully.
TMap | getLabelAttributes ()
protected array | getPostBackOptions () Gets the post back options for this checkbox.
protected bool | getSpanNeeded () Check if we need a span tag to surround this control. The span tag will be created if the Text property is set for this control.
string | getSurroundingTagID ()
protected string | getTagName ()
string | getText ()
TTextAlign | getTextAlign ()
string | getValidationGroup ()
mixed | getValidationPropertyValue () Returns the value of the property that needs validation.
string | getValue ()
protected string | getValueAttribute ()
boolean | loadPostData ( string $key, array $values) Loads user input data.
void | onCheckedChanged ( TEventParameter $param) Raises OnCheckedChanged event when getChecked changes value during postback.
void | onPreRender ( mixed $param) Registers the checkbox to receive postback data during postback.
void | raisePostDataChangedEvent () Raises postdata changed event.
void | render ( THtmlWriter $writer) Renders the checkbox control.
protected void | renderClientControlScript ( mixed $writer) Renders the client-script code.
protected void | renderInputTag ( THtmlWriter $writer, string $clientID, string $onclick) Renders a checkbox input element.
protected void | renderLabel ( THtmlWriter $writer, string $clientID, string $text) Renders a label beside the checkbox.
void | setAutoPostBack ( boolean $value) Sets a value indicating whether clicking on the checkbox will post the page.
void | setCausesValidation ( boolean $value) Sets the value indicating whether postback event trigger by this checkbox will cause input validation.
void | setChecked ( boolean $value) Sets a value indicating whether the checkbox is to be checked or not.
void | setData ( boolean $value) Sets the value indicating whether the checkbox is to be checked or not.
void | setEnableClientScript ( boolean $value)
void | setIsValid ( bool $value)
void | setText ( string $value) Sets the text caption of the checkbox.
void | setTextAlign ( TTextAlign $value)
void | setValidationGroup ( string $value)
void | setValue ( string $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getAutoPostBack

public boolean getAutoPostBack ()

Output
boolean whether clicking on the checkbox will post the page.
Exception

getCausesValidation

public boolean getCausesValidation ()

Output
boolean whether postback event triggered by this checkbox will cause input validation, default is true.
Exception

getChecked

public boolean getChecked ()

Output
boolean whether the checkbox is checked
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getData

public boolean getData ()

Returns the value indicating whether the checkbox is checked.

This method is required by IDataRenderer. It is the same as getChecked().

Output
boolean whether the checkbox is checked.
Exception

getDataChanged

public boolean getDataChanged ()

Returns a value indicating whether postback has caused the control data change.

This method is required by the IPostBackDataHandler interface.

Output
boolean whether postback has caused the control data change. False if the page is not in postback mode.
Exception

getEnableClientScript

public boolean getEnableClientScript ()

Output
boolean whether to render javascript.
Exception

getInputAttributes

public TMap getInputAttributes ()

Output
TMap list of attributes to be rendered for the checkbox
Exception

getIsValid

public bool getIsValid ()

Returns true if this control validated successfully.

Defaults to true.

Output
bool wether this control validated successfully.
Exception

getLabelAttributes

public TMap getLabelAttributes ()

Output
TMap list of attributes to be rendered for label beside the checkbox
Exception

getPostBackOptions

protected array getPostBackOptions ()

Gets the post back options for this checkbox.

Output
Exception

getSpanNeeded

protected bool getSpanNeeded ()

Check if we need a span tag to surround this control. The span tag will be created if the Text property is set for this control.

Output
bool wether this control needs a surrounding span tag
Exception

getSurroundingTagID

public string getSurroundingTagID ()

Output
string the id of the surrounding tag or this clientID if no such tag needed
Exception

getTagName

protected string getTagName ()

Output
string tag name of the button
Exception

getText

public string getText ()

Output
string the text caption of the checkbox
Exception

getTextAlign

public TTextAlign getTextAlign ()

Output
TTextAlign the alignment (Left or Right) of the text caption, defaults to TTextAlign::Right.
Exception

getValidationGroup

public string getValidationGroup ()

Output
string the group of validators which the checkbox causes validation upon postback
Exception

getValidationPropertyValue

public mixed getValidationPropertyValue ()

Returns the value of the property that needs validation.

Output
mixed the property value to be validated
Exception

getValue

public string getValue ()

Output
string the value of the checkbox. Defaults to empty.
Exception

getValueAttribute

protected string getValueAttribute ()

Output
string the value attribute to be rendered
Exception

loadPostData

public boolean loadPostData (string $key , array $values )

Loads user input data.

This method is primarly used by framework developers.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the control has been changed
Exception

onCheckedChanged

public void onCheckedChanged (TEventParameter $param )

Raises OnCheckedChanged event when getChecked changes value during postback.

If you override this method, be sure to call the parent implementation so that the event delegates can be invoked.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onPreRender

public void onPreRender (mixed $param )

Registers the checkbox to receive postback data during postback.

This is necessary because a checkbox if unchecked, when postback, does not have direct mapping between post data and the checkbox name.

This method overrides the parent implementation and is invoked before render.

Input
mixed $param event parameter
Output
Exception

raisePostDataChangedEvent

public void raisePostDataChangedEvent ()

Raises postdata changed event.

This method raises OnCheckedChanged event. This method is primarly used by framework developers.

Output
Exception

render

public void render (THtmlWriter $writer )

Renders the checkbox control.

This method overrides the parent implementation by rendering a checkbox input element and a span element if needed.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Renders the client-script code.

Input
mixed $writer
Output
Exception

renderInputTag

protected void renderInputTag (THtmlWriter $writer , string $clientID , string $onclick )

Renders a checkbox input element.

Input
THtmlWriter | $writer | the writer for the rendering purpose
string | $clientID | checkbox id
string | $onclick | onclick js
Output
Exception

renderLabel

protected void renderLabel (THtmlWriter $writer , string $clientID , string $text )

Renders a label beside the checkbox.

Input
THtmlWriter | $writer | the writer for the rendering purpose
string | $clientID | checkbox id
string | $text | label text
Output
Exception

setAutoPostBack

public void setAutoPostBack (boolean $value )

Sets a value indicating whether clicking on the checkbox will post the page.

Input
boolean $value whether clicking on the checkbox will post the page.
Output
Exception

setCausesValidation

public void setCausesValidation (boolean $value )

Sets the value indicating whether postback event trigger by this checkbox will cause input validation.

Input
boolean $value whether postback event trigger by this checkbox will cause input validation.
Output
Exception

setChecked

public void setChecked (boolean $value )

Sets a value indicating whether the checkbox is to be checked or not.

Input
boolean $value whether the checkbox is to be checked or not.
Output
Exception

setData

public void setData (boolean $value )

Sets the value indicating whether the checkbox is to be checked or not.

This method is required by IDataRenderer. It is the same as setChecked().

Input
boolean $value whether the checkbox is to be checked
Output
Exception

setEnableClientScript

public void setEnableClientScript (boolean $value )

Input
boolean $value whether to render javascript.
Output
Exception

setIsValid

public void setIsValid (bool $value )

Input
bool $value wether this control is valid.
Output
Exception

setText

public void setText (string $value )

Sets the text caption of the checkbox.

Input
string $value the text caption to be set
Output
Exception

setTextAlign

public void setTextAlign (TTextAlign $value )

Input
TTextAlign $value the alignment of the text caption. Valid values include Left and Right.
Output
Exception

setValidationGroup

public void setValidationGroup (string $value )

Input
string $value the group of validators which the checkbox causes validation upon postback
Output
Exception

setValue

public void setValue (string $value )

Input
string $value the value of the checkbox
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTextAlign

Class TTextAlign (Class Overview)

TEnumerable
   |
   --TTextAlign

TTextAlign class.

TTextAlign defines the enumerable type for the possible text alignments

The following enumerable values are defined:

  • Left: left aligned
  • Right: right aligned

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Left
string | Right
Constant Details

Left

Type:

string

Value:

'Left'

Right

Type:

string

Value:

'Right'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCheckBoxColumn

Class TCheckBoxColumn (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TCheckBoxColumn

TCheckBoxColumn class

TCheckBoxColumn represents a checkbox column that is bound to a field in a data source. The checked state of the checkboxes are determiend by the bound data at DataField. If ReadOnly is false, TCheckBoxColumn will display an enabled checkbox provided the cells are in edit mode. Otherwise, the checkboxes will be disabled to prevent from editting.

The checkbox control in the TCheckBoxColumn can be accessed by one of the following two methods:

1      $datagridItem->CheckBoxColumnID->CheckBox
2      $datagridItem->CheckBoxColumnID->Controls[0]
The second method is possible because the checkbox control created within the datagrid cell is the first child.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | dataBindColumn ( mixed $sender, mixed $param) Databinds a cell in the column.
string | getDataField ()
boolean | getReadOnly ()
void | initializeCell ( TTableCell $cell, integer $columnIndex, string $itemType) Initializes the specified cell to its initial values.
void | setDataField ( string $value)
void | setReadOnly ( boolean $value)
Methods Inherited From TDataGridColumn
TDataGridColumn::formatDataValue(), TDataGridColumn::getAllowSorting(), TDataGridColumn::getDataFieldValue(), TDataGridColumn::getEnableCellGrouping(), TDataGridColumn::getFooterRenderer(), TDataGridColumn::getFooterStyle(), TDataGridColumn::getFooterText(), TDataGridColumn::getHeaderImageUrl(), TDataGridColumn::getHeaderRenderer(), TDataGridColumn::getHeaderStyle(), TDataGridColumn::getHeaderText(), TDataGridColumn::getID(), TDataGridColumn::getItemStyle(), TDataGridColumn::getOwner(), TDataGridColumn::getSortExpression(), TDataGridColumn::getViewState(), TDataGridColumn::getVisible(), TDataGridColumn::initialize(), TDataGridColumn::initializeCell(), TDataGridColumn::initializeFooterCell(), TDataGridColumn::initializeHeaderCell(), TDataGridColumn::loadState(), TDataGridColumn::saveState(), TDataGridColumn::setEnableCellGrouping(), TDataGridColumn::setFooterRenderer(), TDataGridColumn::setFooterText(), TDataGridColumn::setHeaderImageUrl(), TDataGridColumn::setHeaderRenderer(), TDataGridColumn::setHeaderText(), TDataGridColumn::setID(), TDataGridColumn::setOwner(), TDataGridColumn::setSortExpression(), TDataGridColumn::setViewState(), TDataGridColumn::setVisible()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

dataBindColumn

public void dataBindColumn (mixed $sender , mixed $param )

Databinds a cell in the column.

This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

Input
mixed | $sender
mixed | $param
Output
Exception

getDataField

public string getDataField ()

Output
string the field name from the data source to bind to the column
Exception

getReadOnly

public boolean getReadOnly ()

Output
boolean whether the items in the column can be edited. Defaults to false.
Exception

initializeCell

public void initializeCell (TTableCell $cell , integer $columnIndex , string $itemType )

Initializes the specified cell to its initial values.

This method overrides the parent implementation. It creates a checkbox inside the cell. If the column is read-only or if the item is not in edit mode, the checkbox will be set disabled.

Input
TTableCell | $cell | the cell to be initialized.
integer | $columnIndex | the index to the Columns property that the cell resides in.
string | $itemType | the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)
Output
Exception

setDataField

public void setDataField (string $value )

Input
string $value the field name from the data source to bind to the column
Output
Exception

setReadOnly

public void setReadOnly (boolean $value )

Input
boolean $value whether the items in the column can be edited
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCheckBoxList

Class TCheckBoxList (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TCheckBoxList

Direct Known Sub-classes:

TActiveCheckBoxList , TRadioButtonList

TCheckBoxList class

TCheckBoxList displays a list of checkboxes on a Web page.

The layout of the checkbox list is specified via RepeatLayout, which can be either 'Table' (default) or 'Flow'. A table layout uses HTML table cells to organize the checkboxes while a flow layout uses line breaks to organize the checkboxes. When the layout is using 'Table', CellPadding and CellSpacing can be used to adjust the cellpadding and cellpadding of the table.

The number of columns used to display the checkboxes is specified via RepeatColumns property, while the RepeatDirection governs the order of the items being rendered.

The alignment of the text besides each checkbox can be specified via TextAlign.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Constructor.
Method Summary
protected TControl | createRepeatedControl () Creates a control used for repetition (used as a template).
protected TStyle | createStyle () Creates a style object for the control.
TControl | findControl ( string $id) Finds a control by ID.
null | generateItemStyle ( string $itemType, integer $index) Returns a style used for rendering items.
integer | getCellPadding ()
integer | getCellSpacing ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
boolean | getDataChanged () Returns a value indicating whether postback has caused the control data change.
boolean | getHasFooter () Returns a value indicating whether this control contains footer item.
boolean | getHasHeader () Returns a value indicating whether this control contains header item.
boolean | getHasSeparators () Returns a value indicating whether this control contains separator items.
protected boolean | getIsMultiSelect ()
bool | getIsValid () Returns true if this control validated successfully.
protected array | getPostBackOptions () Gets the post back options for this checkbox.
integer | getRepeatColumns ()
string | getRepeatDirection ()
protected TRepeatInfo | getRepeatInfo ()
string | getRepeatLayout ()
protected boolean | getSpanNeeded () Wether the list should be rendered inside a span or not
TTextAlign | getTextAlign ()
mixed | getValidationPropertyValue () Returns the value to be validated.
boolean | loadPostData ( string $key, array $values) Loads user input data.
void | onPreRender ( mixed $param) Registers for post data on postback.
void | raisePostDataChangedEvent () Raises postdata changed event.
void | render ( THtmlWriter $writer) Renders the checkbox list control.
void | renderItem ( THtmlWriter $writer, TRepeatInfo $repeatInfo, string $itemType, integer $index) Renders an item in the list.
void | setCellPadding ( integer $value) Sets the cellpadding for the table keeping the checkbox list.
void | setCellSpacing ( integer $value) Sets the cellspacing for the table keeping the checkbox list.
void | setEnabled ( boolean $value)
void | setIsValid ( bool $value)
void | setRepeatColumns ( integer $value)
void | setRepeatDirection ( string $value)
void | setRepeatLayout ( string $value)
void | setTextAlign ( TTextAlign $value)
Methods Inherited From TListControl
TListControl::addAttributesToRender(), TListControl::addParsedObject(), TListControl::clearSelection(), TListControl::createListItemCollection(), TListControl::formatDataValue(), TListControl::getAppendDataBoundItems(), TListControl::getAutoPostBack(), TListControl::getCausesValidation(), TListControl::getClientClassName(), TListControl::getData(), TListControl::getDataGroupField(), TListControl::getDataTextField(), TListControl::getDataTextFormatString(), TListControl::getDataValueField(), TListControl::getEnableClientScript(), TListControl::getHasItems(), TListControl::getIsMultiSelect(), TListControl::getItemCount(), TListControl::getItems(), TListControl::getPostBackOptions(), TListControl::getPromptText(), TListControl::getPromptValue(), TListControl::getSelectedIndex(), TListControl::getSelectedIndices(), TListControl::getSelectedItem(), TListControl::getSelectedValue(), TListControl::getSelectedValues(), TListControl::getTagName(), TListControl::getText(), TListControl::getValidationGroup(), TListControl::loadState(), TListControl::onSelectedIndexChanged(), TListControl::onTextChanged(), TListControl::performDataBinding(), TListControl::renderClientControlScript(), TListControl::renderContents(), TListControl::renderPrompt(), TListControl::saveState(), TListControl::setAppendDataBoundItems(), TListControl::setAutoPostBack(), TListControl::setCausesValidation(), TListControl::setData(), TListControl::setDataGroupField(), TListControl::setDataTextField(), TListControl::setDataTextFormatString(), TListControl::setDataValueField(), TListControl::setEnableClientScript(), TListControl::setPromptText(), TListControl::setPromptValue(), TListControl::setSelectedIndex(), TListControl::setSelectedIndices(), TListControl::setSelectedValue(), TListControl::setSelectedValues(), TListControl::setText(), TListControl::setValidationGroup()
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Constructor.

Remember to call parent implementation if you override this method
Method Details

createRepeatedControl

protected TControl createRepeatedControl ()

Creates a control used for repetition (used as a template).

Output
TControl the control to be repeated
Exception

createStyle

protected TStyle createStyle ()

Creates a style object for the control.

This method creates a TTableStyle to be used by checkbox list.

Output
TStyle control style to be used
Exception

findControl

public TControl findControl (string $id )

Finds a control by ID.

This method overrides the parent implementation so that it always returns the checkbox list itself (because the checkbox list does not have child controls.)

Input
string | $id | control ID
Output
TControl | control being found
Exception

generateItemStyle

public null generateItemStyle (string $itemType , integer $index )

Returns a style used for rendering items.

This method is required by IRepeatInfoUser interface.

Input
string | $itemType | item type (Header,Footer,Item,AlternatingItem,SelectedItem,EditItem,Separator,Pager)
integer | $index | index of the item being rendered
Output
Exception

getCellPadding

public integer getCellPadding ()

Output
integer the cellpadding for the table keeping the checkbox list. Defaults to -1, meaning not set.
Exception

getCellSpacing

public integer getCellSpacing ()

Output
integer the cellspacing for the table keeping the checkbox list. Defaults to -1, meaning not set.
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getDataChanged

public boolean getDataChanged ()

Returns a value indicating whether postback has caused the control data change.

This method is required by the IPostBackDataHandler interface.

Output
boolean whether postback has caused the control data change. False if the page is not in postback mode.
Exception

getHasFooter

public boolean getHasFooter ()

Returns a value indicating whether this control contains footer item.

This method is required by IRepeatInfoUser interface.

Output
boolean always false.
Exception

getHasHeader

public boolean getHasHeader ()

Returns a value indicating whether this control contains header item.

This method is required by IRepeatInfoUser interface.

Output
boolean always false.
Exception

getHasSeparators

public boolean getHasSeparators ()

Returns a value indicating whether this control contains separator items.

This method is required by IRepeatInfoUser interface.

Output
boolean always false.
Exception

getIsMultiSelect

protected boolean getIsMultiSelect ()

Output
boolean whether this control supports multiple selection. Always true for checkbox list.
Exception

getIsValid

public bool getIsValid ()

Returns true if this control validated successfully.

Defaults to true.

Output
bool wether this control validated successfully.
Exception

getPostBackOptions

protected array getPostBackOptions ()

Gets the post back options for this checkbox.

Output
Exception

getRepeatColumns

public integer getRepeatColumns ()

Output
integer the number of columns that the list should be displayed with. Defaults to 0 meaning not set.
Exception

getRepeatDirection

public string getRepeatDirection ()

Output
string the direction of traversing the list, defaults to 'Vertical'
Exception

getRepeatInfo

protected TRepeatInfo getRepeatInfo ()

Output
TRepeatInfo repeat information (primarily used by control developers)
Exception

getRepeatLayout

public string getRepeatLayout ()

Output
string how the list should be displayed, using table or using line breaks. Defaults to 'Table'.
Exception

getSpanNeeded

protected boolean getSpanNeeded ()

Wether the list should be rendered inside a span or not

Output
boolean true if we need a span
Exception

getTextAlign

public TTextAlign getTextAlign ()

Output
TTextAlign the alignment of the text caption, defaults to TTextAlign::Right.
Exception

getValidationPropertyValue

public mixed getValidationPropertyValue ()

Returns the value to be validated.

This methid is required by IValidatable interface.

Output
mixed the value of the property to be validated.
Exception

loadPostData

public boolean loadPostData (string $key , array $values )

Loads user input data.

This method is primarly used by framework developers.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the control has been changed
Exception

onPreRender

public void onPreRender (mixed $param )

Registers for post data on postback.

This method overrides the parent implementation.

Input
mixed $param event parameter
Output
Exception

raisePostDataChangedEvent

public void raisePostDataChangedEvent ()

Raises postdata changed event.

This method is required by IPostBackDataHandler interface. It is invoked by the framework when SelectedIndices property is changed on postback. This method is primarly used by framework developers.

Output
Exception

render

public void render (THtmlWriter $writer )

Renders the checkbox list control.

This method overrides the parent implementation.

Input
THtmlWriter $writer writer for rendering purpose.
Output
Exception

renderItem

public void renderItem (THtmlWriter $writer , TRepeatInfo $repeatInfo , string $itemType , integer $index )

Renders an item in the list.

This method is required by IRepeatInfoUser interface.

Input
THtmlWriter | $writer | writer for rendering purpose
TRepeatInfo | $repeatInfo | repeat information
string | $itemType | item type (Header,Footer,Item,AlternatingItem,SelectedItem,EditItem,Separator,Pager)
integer | $index | zero-based index of the item in the item list
Output
Exception

setCellPadding

public void setCellPadding (integer $value )

Sets the cellpadding for the table keeping the checkbox list.

Input
integer $value the cellpadding for the table keeping the checkbox list.
Output
Exception

setCellSpacing

public void setCellSpacing (integer $value )

Sets the cellspacing for the table keeping the checkbox list.

Input
integer $value the cellspacing for the table keeping the checkbox list.
Output
Exception

setEnabled

public void setEnabled (boolean $value )

Input
boolean $value whether the control is to be enabled.
Output
Exception

setIsValid

public void setIsValid (bool $value )

Input
bool $value wether this control is valid.
Output
Exception

setRepeatColumns

public void setRepeatColumns (integer $value )

Input
integer $value the number of columns that the list should be displayed with.
Output
Exception

setRepeatDirection

public void setRepeatDirection (string $value )

Input
string $value the direction (Vertical, Horizontal) of traversing the list
Output
Exception

setRepeatLayout

public void setRepeatLayout (string $value )

Input
string $value how the list should be displayed, using table or using line breaks (Table, Flow)
Output
Exception

setTextAlign

public void setTextAlign (TTextAlign $value )

Input
TTextAlign $value the text alignment of the checkboxes
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TClientScript

Class TClientScript (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TClientScript

TClientScript class

Allows importing of Prado Client Scripts from template via the PradoScripts property. Multiple Prado client-scripts can be specified using comma delimited string of the javascript library to include on the page. For example,

1      <com:TClientScript PradoScripts="effects, rico" />

Custom javascript files can be register using the ScriptUrl property.

1      <com:TClientScript ScriptUrl=<%~ test.js %> />

Contents within TClientScript will be treated as javascript code and will be rendered in place.

Since: 3.0
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getPradoScripts ()
string | getScriptUrl ()
void | onPreRender ( mixed $param) Calls the client script manager to add each of the requested client script libraries.
void | render ( THtmlWriter $writer) Renders the body content as javascript block.
protected void | renderCustomScript ( THtmlWriter $writer) Registers the body content as javascript.
protected void | renderCustomScriptFile ( THtmLWriter $writer) Renders the custom script file.
void | setPradoScripts ( string $value) Include javascript library to the current page. The current supported libraries are: "prado", "effects", "ajax", "validator", "logger", "datepicker", "colorpicker". Library dependencies are automatically resolved.
void | setScriptUrl ( string $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getPradoScripts

public string getPradoScripts ()

Output
string comma delimited list of javascript libraries to included on the page.
Exception

getScriptUrl

public string getScriptUrl ()

Output
string custom javascript file url.
Exception

onPreRender

public void onPreRender (mixed $param )

Calls the client script manager to add each of the requested client script libraries.

Input
mixed $param event parameter
Output
Exception

render

public void render (THtmlWriter $writer )

Renders the body content as javascript block.

Overrides parent implementation, parent renderChildren method is called during registerCustomScript.

Input
THtmlWriter $writer the renderer
Output
Exception

renderCustomScript

protected void renderCustomScript (THtmlWriter $writer )

Registers the body content as javascript.

Input
THtmlWriter $writer the renderer
Output
Exception

renderCustomScriptFile

protected void renderCustomScriptFile (THtmLWriter $writer )

Renders the custom script file.

Input
THtmLWriter $writer the renderer
Output
Exception

setPradoScripts

public void setPradoScripts (string $value )

Include javascript library to the current page. The current supported libraries are: "prado", "effects", "ajax", "validator", "logger", "datepicker", "colorpicker". Library dependencies are automatically resolved.

Input
string $value comma delimited list of javascript libraries to include.
Output
Exception

setScriptUrl

public void setScriptUrl (string $value )

Input
string $value custom javascript file url.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TClientScriptLoader

Class TClientScriptLoader (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TClientScriptLoader

The TClientScriptLoader publish a collection of javascript files as assets.

The PackagePath property can be an existing asset directory or a namespace path to the directory containing javascript files. E.g.

1        <com:TClientScriptLoader PackagePath=<%~ mylib/js %> />
2        <com:TClientScriptLoader PackagePath="Application.myscripts" />

When the files in the PackagePath are published as assets, a script loader php file corresponding to TClientScriptManager::SCRIPT_LOADER is also copied to that asset directory.

The script loader, combines multiple javascript files and serve up as gzip if possible. Allowable scripts and script dependencies can be specified in a "packages.php" file with the following format. This "packages.php" is optional, if absent the filenames without ".js" extension are used. The "packages.php" must be in the directory given by PackagePath.

1      <?php
2       $packages = array(
3          'package1' => array('file1.js', 'file2.js'),
4          'package2' => array('file3.js', 'file4.js'));
5
6       $deps = array(
7          'package1' => array('package1'),
8          'package2' => array('package1', 'package2')); //package2 requires package1 first.
9
9
9       return array($packages,$deps); //must return $packages and $deps in an array

Set the PackageScripts property with value 'package1' to serve up the 'package1' scripts. A maxium of 25 packages separated by commas is allowed.

Dependencies of the packages are automatically resolved by the script loader php file. E.g.

1      <com:TClientScriptLoader PackagePath=<%~ mylib/js %> PackageScripts="package2" />

The DebugMode property when false removes comments and whitespaces from the published javascript files. If the DebugMode property is not set, the debug mode is determined from the application mode.

The EnableGzip property (default is true) enables the published javascripts to be served as zipped if the browser and php server allows it.

If the DebugMode is false either explicitly or when the application mode is non-debug, then cache headers are also sent to inform the browser and proxies to cache the file. Moreover, the post-processed (comments removed and zipped) are saved in the assets directory for the next requests. That is, in non-debug mode the scripts are cached in the assets directory until they are deleted.

Since: 3.1
Author: Wei Zhuo<weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute name-value pairs to renderer.
protected string | getClientScriptUrl ()
boolean | getDebugMode ()
boolean | getEnableGzip ()
string | getPackagePath ()
string | getPackageScripts ()
protected string | getTagName ()
void | setDebugMode ( boolean $value)
void | setEnableGzip ( boolean $value)
void | setPackagePath ( string $value)
void | setPackageScripts ( string $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute name-value pairs to renderer.

This overrides the parent implementation with additional button specific attributes.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

getClientScriptUrl

protected string getClientScriptUrl ()

Output
string clientscript.php url.
Exception

getDebugMode

public boolean getDebugMode ()

Output
boolean javascript comments stripped in non-debug mode. Debug mode will depend on the application mode if null.
Exception

getEnableGzip

public boolean getEnableGzip ()

Output
boolean enables gzip compression of the javascript if possible, default is true.
Exception

getPackagePath

public string getPackagePath ()

Output
string custom javascript library directory.
Exception

getPackageScripts

public string getPackageScripts ()

Output
string comma delimited list of javascript library packages to load.
Exception

getTagName

protected string getTagName ()

Output
string tag name of the script element
Exception

setDebugMode

public void setDebugMode (boolean $value )

Input
boolean $value true to enable debug mode, default is null thus dependent on the application mode.
Output
Exception

setEnableGzip

public void setEnableGzip (boolean $value )

Input
boolean $value enables gzip compression of the javascript.
Output
Exception

setPackagePath

public void setPackagePath (string $value )

Input
string $value custom javascript library directory.
Output
Exception

setPackageScripts

public void setPackageScripts (string $value )

Input
string $value load specific packages from the javascript library in the PackagePath, comma delimited package names. A maximum of 25 packages is allowed.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TColorPicker

Class TColorPicker (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --TColorPicker

TColorPicker class.

Be aware, this control is EXPERIMENTAL and is not stablized yet.

Since: 3.0
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TTextBox
DEFAULT_COLUMNS, DEFAULT_ROWS,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected TColorPickerClientSide | createClientSide ()
protected string | getAssetUrl ( string $file)
string | getCancelButtonText ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
TColorPickerClientSide | getClientSide ()
string | getColorPickerStyle ()
TColorPickerMode | getMode ()
string | getOKButtonText ()
protected array | getPostBackOptions () Get javascript color picker options.
boolean | getShowColorPicker ()
void | onPreRender ( mixed $param) Publish the color picker Css asset files.
protected void | publishColorPickerAssets () Publish the color picker assets.
void | renderEndTag ( THtmlWriter $writer) Renders additional body content.
void | setCancelButtonText ( string $value)
void | setColorPickerStyle ( string $value)
void | setMode ( TColorPickerMode $value)
void | setOKButtonText ( string $value)
void | setShowColorPicker ( boolean $value) Sets whether to pop up the color picker when the button is clicked.
Methods Inherited From TTextBox
TTextBox::addAttributesToRender(), TTextBox::getAutoCompleteType(), TTextBox::getAutoPostBack(), TTextBox::getAutoTrim(), TTextBox::getCausesValidation(), TTextBox::getClientClassName(), TTextBox::getColumns(), TTextBox::getData(), TTextBox::getDataChanged(), TTextBox::getEnableClientScript(), TTextBox::getIsValid(), TTextBox::getMaxLength(), TTextBox::getPersistPassword(), TTextBox::getPostBackOptions(), TTextBox::getReadOnly(), TTextBox::getRows(), TTextBox::getSafeText(), TTextBox::getSafeTextParser(), TTextBox::getTagName(), TTextBox::getText(), TTextBox::getTextMode(), TTextBox::getValidationGroup(), TTextBox::getValidationPropertyValue(), TTextBox::getWrap(), TTextBox::loadPostData(), TTextBox::onTextChanged(), TTextBox::raisePostDataChangedEvent(), TTextBox::renderBeginTag(), TTextBox::renderClientControlScript(), TTextBox::renderContents(), TTextBox::setAutoCompleteType(), TTextBox::setAutoPostBack(), TTextBox::setAutoTrim(), TTextBox::setCausesValidation(), TTextBox::setColumns(), TTextBox::setData(), TTextBox::setEnableClientScript(), TTextBox::setIsValid(), TTextBox::setMaxLength(), TTextBox::setPersistPassword(), TTextBox::setReadOnly(), TTextBox::setRows(), TTextBox::setText(), TTextBox::setTextMode(), TTextBox::setValidationGroup(), TTextBox::setWrap()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string SCRIPT_PATH
Method Details

createClientSide

protected TColorPickerClientSide createClientSide ()

Output
TColorPickerClientSide javascript validator event options.
Exception

getAssetUrl

protected string getAssetUrl (string $file )

Input
string | $file | asset file in the self::SCRIPT_PATH directory.
Output
string | asset file url.
Exception

getCancelButtonText

public string getCancelButtonText ()

Output
string text for the color picker Cancel button. Default is "Cancel".
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientSide

public TColorPickerClientSide getClientSide ()

Output
TColorPickerClientSide javascript event options.
Exception

getColorPickerStyle

public string getColorPickerStyle ()

Output
string current color picker style
Exception

getMode

public TColorPickerMode getMode ()

Output
TColorPickerMode current color picker UI mode. Defaults to TColorPickerMode::Basic.
Exception

getOKButtonText

public string getOKButtonText ()

Output
string text for the color picker OK button. Default is "OK".
Exception

getPostBackOptions

protected array getPostBackOptions ()

Get javascript color picker options.

Output
array color picker client-side options
Exception

getShowColorPicker

public boolean getShowColorPicker ()

Output
boolean whether the color picker should pop up when the button is clicked.
Exception

onPreRender

public void onPreRender (mixed $param )

Publish the color picker Css asset files.

Input
mixed $param
Output
Exception

publishColorPickerAssets

protected void publishColorPickerAssets ()

Publish the color picker assets.

Output
Exception

renderEndTag

public void renderEndTag (THtmlWriter $writer )

Renders additional body content.

This method overrides parent implementation by adding additional color picker button.

Input
THtmlWriter $writer writer
Output
Exception

setCancelButtonText

public void setCancelButtonText (string $value )

Input
string $value text for the color picker Cancel button
Output
Exception

setColorPickerStyle

public void setColorPickerStyle (string $value )

Input
string $value set the color picker style
Output
Exception

setMode

public void setMode (TColorPickerMode $value )

Input
TColorPickerMode $value color picker UI mode
Output
Exception

setOKButtonText

public void setOKButtonText (string $value )

Input
string $value text for the color picker OK button
Output
Exception

setShowColorPicker

public void setShowColorPicker (boolean $value )

Sets whether to pop up the color picker when the button is clicked.

Input
boolean $value whether to show the color picker popup
Output
Exception

Constant Details

SCRIPT_PATH

Type:

string

Value:

'prado/colorpicker'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TColorPickerClientSide

Class TColorPickerClientSide (Class Overview)

TComponent
   |
   --TClientSideOptions
      |
      --TColorPickerClientSide

TColorPickerClientSide class.

Client-side javascript code options.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
string | getOnColorSelected ()
void | setOnColorSelected ( string $javascript)
Methods Inherited From TClientSideOptions
TClientSideOptions::ensureFunction(), TClientSideOptions::getOption(), TClientSideOptions::getOptions(), TClientSideOptions::setFunction(), TClientSideOptions::setOption()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getOnColorSelected

public string getOnColorSelected ()

Output
string javascript code for when a color is selected.
Exception

setOnColorSelected

public void setOnColorSelected (string $javascript )

Input
string $javascript javascript code for when a color is selected.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TColorPickerMode

Class TColorPickerMode (Class Overview)

TEnumerable
   |
   --TColorPickerMode

TColorPickerMode class.

TColorPickerMode defines the enumerable type for the possible UI mode that a TColorPicker control can take.

The following enumerable values are defined:

  • Simple
  • Basic
  • Full

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Basic
string | Full
string | Simple
Constant Details

Basic

Type:

string

Value:

'Basic'

Full

Type:

string

Value:

'Full'

Simple

Type:

string

Value:

'Simple'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCompareValidator

Class TCompareValidator (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TCompareValidator

TCompareValidator class

TCompareValidator compares the value entered by the user into an input control with the value entered into another input control or a constant value. To compare the associated input control with another input control, set the ControlToCompare property to the ID path of the control to compare with. To compare the associated input control with a constant value, specify the constant value to compare with by setting the ValueToCompare property.

The DataType property is used to specify the data type of both comparison values. Both values are automatically converted to this data type before the comparison operation is performed. The following value types are supported:

  • Integer A 32-bit signed integer data type.
  • Float A double-precision floating point number data type.
  • Date A date data type. The format can be specified by the DateFormat property
  • String A string data type.
Use the Operator property to specify the type of comparison to perform. Valid operators include Equal, NotEqual, GreaterThan, GreaterThanEqual, LessThan and LessThanEqual.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
boolean | evaluateIsValid () This method overrides the parent's implementation.
protected string | getClientClassName () Gets the name of the javascript class responsible for performing validation for this control.
protected array | getClientScriptOptions () Returns an array of javascript validator options.
protected array | getComparisonValues ( string $value1, string $value2) Parse the pair of values into the appropriate value type.
string | getControlToCompare ()
TValidationDataType | getDataType ()
string | getDateFormat ()
TValidationCompareOperator | getOperator ()
string | getValueToCompare ()
void | setControlToCompare ( string $value) Sets the input component to compare with the input control being validated.
void | setDataType ( TValidationDataType $value) Sets the data type that the values being compared are converted to before the comparison is made.
void | setDateFormat ( string $value) Sets the date format for a date validation
void | setOperator ( TValidationCompareOperator $value) Sets the comparison operation to perform
void | setValueToCompare ( string $value) Sets the constant value to compare with the value entered by the user into the input component being validated.
Methods Inherited From TBaseValidator
TBaseValidator::addAttributesToRender(), TBaseValidator::createClientSide(), TBaseValidator::getClientScriptOptions(), TBaseValidator::getClientSide(), TBaseValidator::getControlCssClass(), TBaseValidator::getControlToValidate(), TBaseValidator::getDisplay(), TBaseValidator::getEnableClientScript(), TBaseValidator::getErrorMessage(), TBaseValidator::getFocusElementID(), TBaseValidator::getFocusOnError(), TBaseValidator::getIsValid(), TBaseValidator::getValidationGroup(), TBaseValidator::getValidationTarget(), TBaseValidator::getValidationValue(), TBaseValidator::onInit(), TBaseValidator::onPreRender(), TBaseValidator::onUnload(), TBaseValidator::onValidate(), TBaseValidator::onValidationError(), TBaseValidator::onValidationSuccess(), TBaseValidator::registerClientScriptValidator(), TBaseValidator::renderClientControlScript(), TBaseValidator::renderContents(), TBaseValidator::setControlCssClass(), TBaseValidator::setControlToValidate(), TBaseValidator::setDisplay(), TBaseValidator::setEnableClientScript(), TBaseValidator::setEnabled(), TBaseValidator::setErrorMessage(), TBaseValidator::setFocusElementID(), TBaseValidator::setFocusOnError(), TBaseValidator::setForControl(), TBaseValidator::setIsValid(), TBaseValidator::setValidationGroup(), TBaseValidator::updateControlCssClass(), TBaseValidator::validate()
Methods Inherited From TLabel
TLabel::addAttributesToRender(), TLabel::getData(), TLabel::getForControl(), TLabel::getTagName(), TLabel::getText(), TLabel::render(), TLabel::renderContents(), TLabel::setData(), TLabel::setForControl(), TLabel::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

evaluateIsValid

public boolean evaluateIsValid ()

This method overrides the parent's implementation.

The validation succeeds if the input data compares successfully. The validation always succeeds if ControlToValidate is not specified or the input data is empty.

Output
boolean whether the validation succeeds
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing validation for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientScriptOptions

protected array getClientScriptOptions ()

Returns an array of javascript validator options.

Output
array javascript validator options.
Exception

getComparisonValues

protected array getComparisonValues (string $value1 , string $value2 )

Parse the pair of values into the appropriate value type.

Input
string | $value1 | value one
string | $value2 | second value
Output
array | appropriate type of the value pair, array($value1, $value2);
Exception

getControlToCompare

public string getControlToCompare ()

Output
string the input component to compare with the input control being validated.
Exception

getDataType

public TValidationDataType getDataType ()

Output
TValidationDataType the data type that the values being compared are converted to before the comparison is made. Defaults to TValidationDataType::String.
Exception

getDateFormat

public string getDateFormat ()

Output
string the date validation date format if any
Exception

getOperator

public TValidationCompareOperator getOperator ()

Output
TValidationCompareOperator the comparison operation to perform. Defaults to TValidationCompareOperator::Equal.
Exception

getValueToCompare

public string getValueToCompare ()

Output
string the constant value to compare with the value entered by the user into the input component being validated.
Exception

setControlToCompare

public void setControlToCompare (string $value )

Sets the input component to compare with the input control being validated.

Input
string $value the ID path of the component to compare with
Output
Exception

setDataType

public void setDataType (TValidationDataType $value )

Sets the data type that the values being compared are converted to before the comparison is made.

Input
TValidationDataType $value the data type
Output
Exception

setDateFormat

public void setDateFormat (string $value )

Sets the date format for a date validation

Input
string $value the date format value
Output
Exception

setOperator

public void setOperator (TValidationCompareOperator $value )

Sets the comparison operation to perform

Input
TValidationCompareOperator $value the comparison operation
Output
Exception

setValueToCompare

public void setValueToCompare (string $value )

Sets the constant value to compare with the value entered by the user into the input component being validated.

Input
string $value the constant value
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TValidationCompareOperator

Class TValidationCompareOperator (Class Overview)

TEnumerable
   |
   --TValidationCompareOperator

TValidationCompareOperator class.

TValidationCompareOperator defines the enumerable type for the comparison operations that TCompareValidator can perform validation with.

The following enumerable values are defined:

  • Equal
  • NotEqual
  • GreaterThan
  • GreaterThanEqual
  • LessThan
  • LessThanEqual

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Equal
string | GreaterThan
string | GreaterThanEqual
string | LessThan
string | LessThanEqual
string | NotEqual
Constant Details

Equal

Type:

string

Value:

'Equal'

GreaterThan

Type:

string

Value:

'GreaterThan'

GreaterThanEqual

Type:

string

Value:

'GreaterThanEqual'

LessThan

Type:

string

Value:

'LessThan'

LessThanEqual

Type:

string

Value:

'LessThanEqual'

NotEqual

Type:

string

Value:

'NotEqual'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TConditional

Class TConditional (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TConditional

TConditional class.

TConditional displays appropriate content based on the evaluation result of a PHP expression specified via Condition. If the result is true, it instantiates the template TrueTemplate; otherwise, the template FalseTemplate is instantiated. The PHP expression is evaluated right before onInit stage of the control lifecycle.

Since Condition is evaluated at a very early stage, it is recommended you set Condition in template and the expression should not refer to objects that are available on or after onInit lifecycle.

A typical usage of TConditional is shown as following:

1      <com:TConditional Condition="$this->User->IsGuest">
2        <prop:TrueTemplate>
3          <a href="path/to/login">Login</a>
4        </prop:TrueTemplate>
5        <prop:FalseTemplate>
6          <a href="path/to/logout">Logout</a>
7        </prop:FalseTemplate>
8      </com:TConditional>

TConditional is very light. It instantiates either TrueTemplate or FalseTemplate, but never both. And the condition is evaluated only once.

Since: 3.1.1
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | addParsedObject ( string|TComponent $object) Processes an object that is created during parsing template.
void | createChildControls () Creates child controls.
string | getCondition ()
ITemplate | getFalseTemplate ()
ITemplate | getTrueTemplate ()
void | setCondition ( string $value) Sets the PHP expression to be evaluated for conditionally displaying content.
void | setFalseTemplate ( ITemplate $value)
void | setTrueTemplate ( ITemplate $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addParsedObject

public void addParsedObject (string|TComponent $object )

Processes an object that is created during parsing template.

This method overrides the parent implementation by removing all contents enclosed in the template tag.

Input
string|TComponent $object text string or component parsed and instantiated in template
Output
Exception

createChildControls

public void createChildControls ()

Creates child controls.

This method overrides the parent implementation. It evaluates Condition and instantiate the corresponding template.

Output
Exception

getCondition

public string getCondition ()

Output
string the PHP expression used for determining which template to use. Defaults to 'true', meaning using TrueTemplate.
Exception

getFalseTemplate

public ITemplate getFalseTemplate ()

Output
ITemplate the template applied when Condition is false.
Exception

getTrueTemplate

public ITemplate getTrueTemplate ()

Output
ITemplate the template applied when Condition is true.
Exception

setCondition

public void setCondition (string $value )

Sets the PHP expression to be evaluated for conditionally displaying content.

The context of the expression is the template control containing TConditional.

Input
string $value the PHP expression used for determining which template to use.
Output
Exception

setFalseTemplate

public void setFalseTemplate (ITemplate $value )

Input
ITemplate $value the template applied when Condition is false.
Output
Exception

setTrueTemplate

public void setTrueTemplate (ITemplate $value )

Input
ITemplate $value the template applied when Condition is true.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TContent

Class TContent (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TContent

TContent class

TContent specifies a block of content on a control's template that will be injected at somewhere of the master control's template. TContentPlaceHolder and TContent together implement a decoration pattern for prado templated controls. A template control (called content control) can specify a master control whose template contains some TContentPlaceHolder controls. TContent controls on the content control's template will replace the corresponding TContentPlaceHolder controls on the master control's template. This is called content injection. It is done by matching the IDs of TContent and TContentPlaceHolder controls.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void
createdOnTemplate ( TControl $parent)
This method is invoked after the control is instantiated on a template.
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

createdOnTemplate

public void createdOnTemplate (TControl $parent )

This method is invoked after the control is instantiated on a template.

This overrides the parent implementation by registering the content control to the template owner control.

Input
TControl $parent potential parent of this control
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TContentPlaceHolder

Class TContentPlaceHolder (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TContentPlaceHolder

TContentPlaceHolder class

TContentPlaceHolder reserves a place on a template where a TContent control can inject itself and its children in. TContentPlaceHolder and TContent together implement a decoration pattern for prado templated controls. A template control (called content control) can specify a master control whose template contains some TContentPlaceHolder controls. TContent controls on the content control's template will replace the corresponding TContentPlaceHolder controls on the master control's template. This is called content injection. It is done by matching the IDs of TContent and TContentPlaceHolder controls.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void
createdOnTemplate ( TControl $parent)
This method is invoked after the control is instantiated on a template.
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

createdOnTemplate

public void createdOnTemplate (TControl $parent )

This method is invoked after the control is instantiated on a template.

This overrides the parent implementation by registering the content placeholder control to the template owner control. The placeholder control will NOT be added to the potential parent control!

Input
TControl $parent potential parent of this control
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCustomValidator

Class TCustomValidator (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TCustomValidator

Direct Known Sub-classes:

TActiveCustomValidator

TCustomValidator class

TCustomValidator performs user-defined validation (either server-side or client-side or both) on an input component.

To create a server-side validation function, provide a handler for the OnServerValidate event that performs the validation. The data string of the input control to validate can be accessed by TServerValidateEventParameter::getValue of the event parameter. The result of the validation should be stored in the TServerValidateEventParameter::getIsValid property of the event parameter.

To create a client-side validation function, add the client-side validation javascript function to the page template. The function should have the following signature:

1      <script type="text/javascript"><!--
2      function ValidationFunctionName(sender, parameter)
3      {
4         // if(parameter == ...)
5         //    return true;
6         // else
7         //    return false;
8      }
9      --></script>
Use the ClientValidationFunction property to specify the name of the client-side validation script function associated with the TCustomValidator.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
boolean | evaluateIsValid () This method overrides the parent's implementation.
protected string | getClientClassName () Gets the name of the javascript class responsible for performing validation for this control.
protected array | getClientScriptOptions () Returns an array of javascript validator options.
string | getClientValidationFunction ()
TControl | getValidationTarget ()
boolean | onServerValidate ( string $value) This method is invoked when the server side validation happens.
protected void | registerClientScriptValidator () Only register the client-side validator if setClientValidationFunction is set.
void | setClientValidationFunction ( string $value) Sets the name of the custom client-side script function used for validation.
Methods Inherited From TBaseValidator
TBaseValidator::addAttributesToRender(), TBaseValidator::createClientSide(), TBaseValidator::getClientScriptOptions(), TBaseValidator::getClientSide(), TBaseValidator::getControlCssClass(), TBaseValidator::getControlToValidate(), TBaseValidator::getDisplay(), TBaseValidator::getEnableClientScript(), TBaseValidator::getErrorMessage(), TBaseValidator::getFocusElementID(), TBaseValidator::getFocusOnError(), TBaseValidator::getIsValid(), TBaseValidator::getValidationGroup(), TBaseValidator::getValidationTarget(), TBaseValidator::getValidationValue(), TBaseValidator::onInit(), TBaseValidator::onPreRender(), TBaseValidator::onUnload(), TBaseValidator::onValidate(), TBaseValidator::onValidationError(), TBaseValidator::onValidationSuccess(), TBaseValidator::registerClientScriptValidator(), TBaseValidator::renderClientControlScript(), TBaseValidator::renderContents(), TBaseValidator::setControlCssClass(), TBaseValidator::setControlToValidate(), TBaseValidator::setDisplay(), TBaseValidator::setEnableClientScript(), TBaseValidator::setEnabled(), TBaseValidator::setErrorMessage(), TBaseValidator::setFocusElementID(), TBaseValidator::setFocusOnError(), TBaseValidator::setForControl(), TBaseValidator::setIsValid(), TBaseValidator::setValidationGroup(), TBaseValidator::updateControlCssClass(), TBaseValidator::validate()
Methods Inherited From TLabel
TLabel::addAttributesToRender(), TLabel::getData(), TLabel::getForControl(), TLabel::getTagName(), TLabel::getText(), TLabel::render(), TLabel::renderContents(), TLabel::setData(), TLabel::setForControl(), TLabel::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

evaluateIsValid

public boolean evaluateIsValid ()

This method overrides the parent's implementation.

The validation succeeds if onServerValidate returns true.

Output
boolean whether the validation succeeds
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing validation for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientScriptOptions

protected array getClientScriptOptions ()

Returns an array of javascript validator options.

Output
array javascript validator options.
Exception

getClientValidationFunction

public string getClientValidationFunction ()

Output
string the name of the custom client-side script function used for validation.
Exception

getValidationTarget

public TControl getValidationTarget ()

Output
TControl control to be validated. Null if no control is found.
Exception

onServerValidate

public boolean onServerValidate (string $value )

This method is invoked when the server side validation happens.

It will raise the OnServerValidate event. The method also allows derived classes to handle the event without attaching a delegate. Note The derived classes should call parent implementation to ensure the OnServerValidate event is raised.

Input
string | $value | the value to be validated
Output
boolean | whether the value is valid
Exception

registerClientScriptValidator

protected void registerClientScriptValidator ()

Only register the client-side validator if setClientValidationFunction is set.

Output
Exception

setClientValidationFunction

public void setClientValidationFunction (string $value )

Sets the name of the custom client-side script function used for validation.

Input
string $value the script function name
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TServerValidateEventParameter

Class TServerValidateEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TServerValidateEventParameter

TServerValidateEventParameter class

TServerValidateEventParameter encapsulates the parameter data for OnServerValidate event of TCustomValidator components.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
boolean | getIsValid ()
string | getValue ()
void | setIsValid ( boolean $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getIsValid

public boolean getIsValid ()

Output
boolean whether the value is valid
Exception

getValue

public string getValue ()

Output
string value to be validated
Exception

setIsValid

public void setIsValid (boolean $value )

Input
boolean $value whether the value is valid
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IItemDataRenderer

Interface IItemDataRenderer (Class Overview)

IDataRenderer
   |
   --IItemDataRenderer

IItemDataRenderer interface.

IItemDataRenderer defines the interface that an item renderer needs to implement. Besides the Data property, a list item renderer also needs to provide ItemIndex and ItemType property.

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
integer | getItemIndex () Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
TListItemType | getItemType ()
void | setItemIndex ( integer $value) Sets the zero-based index for the item.
void | setItemType ( TListItemType $value)
Methods Inherited From IDataRenderer
IDataRenderer::getData(), IDataRenderer::setData()
Method Details

getItemIndex

public integer getItemIndex ()

Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.

If the item is not in the collection (e.g. it is a header item), it returns -1.

Output
integer zero-based index of the item.
Exception

getItemType

public TListItemType getItemType ()

Output
TListItemType the item type.
Exception

setItemIndex

public void setItemIndex (integer $value )

Sets the zero-based index for the item.

If the item is not in the item collection (e.g. it is a header item), -1 should be used.

Input
integer $value zero-based index of the item.
Output
Exception

setItemType

public void setItemType (TListItemType $value )

Input
TListItemType $value the item type.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataBoundControl

Class TDataBoundControl (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl

Direct Known Sub-classes:

TBaseDataList , TListControl , TRepeater

TDataBoundControl class.

TDataBoundControl is the based class for controls that need to populate data from data sources. It provides basic properties and methods that allow the derived controls to associate with data sources and retrieve data from them.

TBC....

TDataBoundControl is equipped with paging capabilities. By setting AllowPaging to true, the input data will be paged and only one page of data is actually populated into the data-bound control. This saves a lot of memory when dealing with larget datasets.

To specify the number of data items displayed on each page, set the PageSize property, and to specify which page of data to be displayed, set CurrentPageIndex.

When the size of the original data is too big to be loaded all in the memory, one can enable custom paging. In custom paging, the total number of data items is specified manually via VirtualItemCount, and the data source only needs to contain the current page of data. To enable custom paging, set AllowCustomPaging to true.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected TPagedDataSource | createPagedDataSource ()
void | dataBind () Performs databinding.
void | dataSourceViewChanged ( mixed $sender, mixed $param)
protected void | determineDataSource ()
protected void | ensureDataBound () Ensures any pending dataBind is called.
boolean | getAllowCustomPaging ()
boolean | getAllowPaging ()
integer | getCurrentPageIndex ()
void | getDataMember ()
Traversable | getDataSource ()
string | getDataSourceID ()
protected void | getDataSourceView ()
protected boolean | getInitialized ()
protected boolean | getIsDataBound ()
integer | getPageCount ()
integer | getPageSize ()
protected boolean | getRequiresDataBinding ()
void | getSelectParameters ()
protected boolean | getUsingDataSourceID ()
integer | getVirtualItemCount ()
void | onDataBound ( mixed $param) Raises OnDataBound event.
void | onDataSourceChanged () Sets setRequiresDataBinding as true if the control is initialized.
void | onInit ( TEventParameter $param) Sets page's OnPreLoad event handler as pagePreLoad.
void | onPreRender ( TEventParameter $param) Ensures any pending databind is performed.
void | pagePreLoad ( mixed $sender, TEventParameter $param) Sets getInitialized as true.
protected abstract void | performDataBinding ( mixed $data)
void | setAllowCustomPaging ( boolean $value) Sets a value indicating whether the custom paging should be enabled.
void | setAllowPaging ( boolean $value)
void | setCurrentPageIndex ( integer $value)
void | setDataMember ( mixed $value)
void | setDataSource ( Traversable|array|string $value) Sets the data source object associated with the databound control.
void | setDataSourceID ( string $value)
protected void | setInitialized ( boolean $value) Sets a value indicating whether the databound control is initialized.
protected void | setIsDataBound ( boolean $value)
void | setPageSize ( integer $value)
protected void | setRequiresDataBinding ( boolean $value) Sets a value indicating whether a databind call is required by the data bound control.
void | setVirtualItemCount ( integer $value)
protected Traversable | validateDataSource ( Traversable|array|string $value) Validates if the parameter is a valid data source.
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

createPagedDataSource

protected TPagedDataSource createPagedDataSource ()

Output
TPagedDataSource creates a paged data source
Exception

dataBind

public void dataBind ()

Performs databinding.

This method overrides the parent implementation by calling performSelect which fetches data from data source and does the actual binding work.

Output
Exception

dataSourceViewChanged

public void dataSourceViewChanged (mixed $sender , mixed $param )

Input
mixed | $sender
mixed | $param
Output
Exception

determineDataSource

protected void determineDataSource ()

Output
Exception

ensureDataBound

protected void ensureDataBound ()

Ensures any pending dataBind is called.

This method calls dataBind if the data source is specified by setDataSourceID or if RequiresDataBinding is true.

Output
Exception

getAllowCustomPaging

public boolean getAllowCustomPaging ()

Output
boolean whether the custom paging is enabled. Defaults to false.
Exception

getAllowPaging

public boolean getAllowPaging ()

Output
boolean whether paging is enabled. Defaults to false.
Exception

getCurrentPageIndex

public integer getCurrentPageIndex ()

Output
integer the zero-based index of the current page. Defaults to 0.
Exception

getDataMember

public void getDataMember ()

Output
Exception

getDataSource

public Traversable getDataSource ()

Output
Traversable data source object, defaults to null.
Exception

getDataSourceID

public string getDataSourceID ()

Output
string ID path to the data source control. Defaults to empty.
Exception

getDataSourceView

protected void getDataSourceView ()

Output
Exception

getInitialized

protected boolean getInitialized ()

Output
boolean whether the databound control has been initialized. By default, the control is initialized after its viewstate has been restored.
Exception

getIsDataBound

protected boolean getIsDataBound ()

Output
boolean whether databind has been invoked in the previous page request
Exception

getPageCount

public integer getPageCount ()

Output
integer number of pages of data items available
Exception

getPageSize

public integer getPageSize ()

Output
integer the number of data items on each page. Defaults to 10.
Exception

getRequiresDataBinding

protected boolean getRequiresDataBinding ()

Output
boolean whether a databind call is required (by the data bound control)
Exception

getSelectParameters

public void getSelectParameters ()

Output
Exception

getUsingDataSourceID

protected boolean getUsingDataSourceID ()

Output
boolean if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource.
Exception

getVirtualItemCount

public integer getVirtualItemCount ()

Output
integer virtual number of data items in the data source. Defaults to 0.
Exception

onDataBound

public void onDataBound (mixed $param )

Raises OnDataBound event.

This method should be invoked after a databind is performed. It is mainly used by framework and component developers.

Input
mixed $param
Output
Exception

onDataSourceChanged

public void onDataSourceChanged ()

Sets setRequiresDataBinding as true if the control is initialized.

This method is invoked when either setDataSource or setDataSourceID is changed.

Output
Exception

onInit

public void onInit (TEventParameter $param )

Sets page's OnPreLoad event handler as pagePreLoad.

If viewstate is disabled and the current request is a postback, RequiresDataBinding will be set true. This method overrides the parent implementation.

Input
TEventParameter $param event parameter
Output
Exception

onPreRender

public void onPreRender (TEventParameter $param )

Ensures any pending databind is performed.

This method overrides the parent implementation.

Input
TEventParameter $param event parameter
Output
Exception

pagePreLoad

public void pagePreLoad (mixed $sender , TEventParameter $param )

Sets getInitialized as true.

This method is invoked when page raises PreLoad event.

Input
mixed | $sender | event sender
TEventParameter | $param | event parameter
Output
Exception

performDataBinding

protected abstract void performDataBinding (mixed $data )

Input
mixed $data
Output
Exception

setAllowCustomPaging

public void setAllowCustomPaging (boolean $value )

Sets a value indicating whether the custom paging should be enabled.

When the pager is in custom paging mode, the VirtualItemCount property is used to determine the paging, and the data items in the DataSource are considered to be in the current page.

Input
boolean $value whether the custom paging is enabled
Output
Exception

setAllowPaging

public void setAllowPaging (boolean $value )

Input
boolean $value whether paging is enabled
Output
Exception

setCurrentPageIndex

public void setCurrentPageIndex (integer $value )

Input
integer | $value | the zero-based index of the current page
Output
Exception
throws | TInvalidDataValueException if the value is less than 0

setDataMember

public void setDataMember (mixed $value )

Input
mixed $value
Output
Exception

setDataSource

public void setDataSource (Traversable|array|string $value )

Sets the data source object associated with the databound control.

The data source must implement Traversable interface. If an array is given, it will be converted to xxx. If a string is given, it will be converted to xxx.

Input
Traversable|array|string $value data source object
Output
Exception

setDataSourceID

public void setDataSourceID (string $value )

Input
string $value ID path to the data source control. The data source control must be locatable via TControl::findControl call.
Output
Exception

setInitialized

protected void setInitialized (boolean $value )

Sets a value indicating whether the databound control is initialized.

If initialized, any modification to DataSource or DataSourceID will set RequiresDataBinding as true.

Input
boolean $value a value indicating whether the databound control is initialized.
Output
Exception

setIsDataBound

protected void setIsDataBound (boolean $value )

Input
boolean $value if databind has been invoked in this page request
Output
Exception

setPageSize

public void setPageSize (integer $value )

Input
integer | $value | the number of data items on each page.
Output
Exception
throws | TInvalidDataValueException if the value is less than 1

setRequiresDataBinding

protected void setRequiresDataBinding (boolean $value )

Sets a value indicating whether a databind call is required by the data bound control.

If true and the control has been prerendered while it uses the data source specified by setDataSourceID, a databind call will be called by this method.

Input
boolean $value whether a databind call is required.
Output
Exception

setVirtualItemCount

public void setVirtualItemCount (integer $value )

Input
integer | $value | virtual number of data items in the data source.
Output
Exception
throws | TInvalidDataValueException if the value is less than 0

validateDataSource

protected Traversable validateDataSource (Traversable|array|string $value )

Validates if the parameter is a valid data source.

If it is a string or an array, it will be converted as a TList object.

Input
Traversable|array|string | $value | data source to be validated
Output
Traversable | the data that is traversable
Exception
throws | TInvalidDataTypeException if the data is neither null nor Traversable


PRADO API Manual: Docs For Class TListItemType

Class TListItemType (Class Overview)

TEnumerable
   |
   --TListItemType

TListItemType class.

TListItemType defines the enumerable type for the possible types that databound list items could take.

The following enumerable values are defined:

  • Header: header item
  • Footer: footer item
  • Item: content item (neither header nor footer)
  • Separator: separator between items
  • AlternatingItem: alternating content item
  • EditItem: content item in edit mode
  • SelectedItem: selected content item
  • Pager: pager

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | AlternatingItem
string | EditItem
string | Footer
string | Header
string | Item
string | Pager
string | SelectedItem
string | Separator
Constant Details

AlternatingItem

Type:

string

Value:

'AlternatingItem'

EditItem

Type:

string

Value:

'EditItem'

Footer

Type:

string

Value:

'Footer'

Header

Type:

string

Value:

'Header'

Item

Type:

string

Value:

'Item'

Pager

Type:

string

Value:

'Pager'

SelectedItem

Type:

string

Value:

'SelectedItem'

Separator

Type:

string

Value:

'Separator'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGrid

Class TDataGrid (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TBaseDataList
                  |
                  --TDataGrid

TDataGrid class

TDataGrid represents a data bound and updatable grid control.

To populate data into the datagrid, sets its DataSource to a tabular data source and call dataBind(). Each row of data will be represented by an item in the Items collection of the datagrid.

An item can be at one of three states: browsing, selected and edit. The state determines how the item will be displayed. For example, if an item is in edit state, it may be displayed as a table row with input text boxes if the columns are of type TBoundColumn; and if in browsing state, they are displayed as static text.

To change the state of an item, set EditItemIndex or SelectedItemIndex property.

Each datagrid item has a TDataGridItem::getItemType which tells the position and state of the item in the datalist. An item in the header of the repeater is of type Header. A body item may be of either Item, AlternatingItem, SelectedItem or EditItem, depending whether the item index is odd or even, whether it is being selected or edited.

A datagrid is specified with a list of columns. Each column specifies how the corresponding table column will be displayed. For example, the header/footer text of that column, the cells in that column, and so on. The following column types are currently provided by the framework,

  • TBoundColumn, associated with a specific field in datasource and displays the corresponding data.
  • TEditCommandColumn, displaying edit/update/cancel command buttons
  • TButtonColumn, displaying generic command buttons that may be bound to specific field in datasource.
  • TDropDownListColumn, displaying a dropdown list when the item is in edit state
  • THyperLinkColumn, displaying a hyperlink that may be bound to specific field in datasource.
  • TCheckBoxColumn, displaying a checkbox that may be bound to specific field in datasource.
  • TTemplateColumn, displaying content based on templates.
There are three ways to specify columns for a datagrid.
  • Automatically generated based on data source. By setting AutoGenerateColumns to true, a list of columns will be automatically generated based on the schema of the data source. Each column corresponds to a column of the data.
  • Specified in template. For example,

    1          <com:TDataGrid ...>
    2             <com:TBoundColumn .../>
    3             <com:TEditCommandColumn .../>
    4          </com:TDataGrid>
  • Manually created in code. Columns can be manipulated via the setColumns property of the datagrid. For example,

    1         $column=new TBoundColumn;
    2         $datagrid->Columns[]=$column;
Note, automatically generated columns cannot be accessed via the Columns property.

TDataGrid supports sorting. If the AllowSorting is set to true, a column with nonempty setSortExpression will have its header text displayed as a clickable link button. Clicking on the link button will raise OnSortCommand event. You can respond to this event, sort the data source according to the event parameter, and then invoke databind() on the datagrid to show to end users the sorted data.

TDataGrid supports paging. If the AllowPaging is set to true, a pager will be displayed on top and/or bottom of the table. How the pager will be displayed is determined by the PagerStyle property. Clicking on a pager button will raise an OnPageIndexChanged event. You can respond to this event, specify the page to be displayed by setting CurrentPageIndex</b> property, and then invoke databind() on the datagrid to show to end users a new page of data.

TDataGrid supports two kinds of paging. The first one is based on the number of data items in datasource. The number of pages PageCount is calculated based the item number and the PageSize property. The datagrid will manage which section of the data source to be displayed based on the CurrentPageIndex property. The second approach calculates the page number based on the VirtualItemCount property and the PageSize property. The datagrid will always display from the beginning of the datasource up to the number of PageSize data items. This approach is especially useful when the datasource may contain too many data items to be managed by the datagrid efficiently.

When the datagrid contains a button control that raises an onCommand event, the event will be bubbled up to the datagrid control. If the event's command name is recognizable by the datagrid control, a corresponding item event will be raised. The following item events will be raised upon a specific command:

  • OnEditCommand, if CommandName=edit
  • OnCancelCommand, if CommandName=cancel
  • OnSelectCommand, if CommandName=select
  • OnDeleteCommand, if CommandName=delete
  • OnUpdateCommand, if CommandName=update
  • onPageIndexChanged, if CommandName=page
  • OnSortCommand, if CommandName=sort
Note, an OnItemCommand event is raised in addition to the above specific command events.

TDataGrid also raises an OnItemCreated event for every newly created datagrid item. You can respond to this event to customize the content or style of the newly created item.

Note, the data bound to the datagrid are reset to null after databinding. There are several ways to access the data associated with a datagrid row:

  • Access the data in OnItemDataBound event
  • Use DataKeys to obtain the data key associated with
the specified datagrid row and use the key to fetch the corresponding data from some persistent storage such as DB.
  • Save the data in viewstate and get it back during postbacks.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | addParsedObject ( mixed $object) Adds objects parsed in template to datagrid.
protected void | applyItemStyles () Applies styles to items, header, footer and separators.
boolean | bubbleEvent ( TControl $sender, TEventParameter $param) This method overrides parent's implementation to handle onItemCommand event which is bubbled from TDataGridItem child controls.
protected void | buildNextPrevPager ( TDataGridPager $pager) Builds a next-prev pager
protected void | buildNumericPager ( TDataGridPager $pager) Builds a numeric pager
protected void | buildPager ( TDataGridPager $pager) Builds the pager content based on pager style.
protected TDataGridColumnCollection | createAutoColumns ( Traversable $dataSource) Automatically generates datagrid columns based on datasource schema
protected TDataGridItem | createItem ( integer $itemIndex, TListItemType $dataSourceIndex, mixed $itemType) Creates a datagrid item instance based on the item type and index.
protected mixed | createPagerButton ( string $buttonType, boolean $enabled, string $text, string $commandName, string $commandParameter) Creates a pager button.
protected TTableStyle | createStyle () Creates a style object for the control.
boolean | getAllowSorting ()
TTableItemStyle | getAlternatingItemStyle ()
TDataGridColumnCollection | getAutoColumns ()
boolean | getAutoGenerateColumns ()
string | getBackImageUrl ()
TDataGridPager | getBottomPager ()
string | getCaption ()
TTableCaptionAlign | getCaptionAlign ()
TDataGridColumnCollection | getColumns ()
TDataGridItem | getEditItem ()
integer | getEditItemIndex ()
TTableItemStyle | getEditItemStyle ()
ITemplate | getEmptyTemplate ()
TDataGridItem | getFooter ()
TTableItemStyle | getFooterStyle ()
TDataGridItem | getHeader ()
TTableItemStyle | getHeaderStyle ()
integer | getItemCount ()
TDataGridItemCollection | getItems ()
TTableItemStyle | getItemStyle ()
TDataGridPagerStyle | getPagerStyle ()
TDataGridItem | getSelectedItem ()
integer | getSelectedItemIndex ()
TTableItemStyle | getSelectedItemStyle ()
boolean | getShowFooter ()
boolean | getShowHeader ()
TStyle | getTableBodyStyle ()
TStyle | getTableFootStyle ()
TStyle | getTableHeadStyle ()
protected string | getTagName ()
TDataGridPager | getTopPager ()
protected void | initializeItem ( TDataGrid $item, TDataGridColumnCollection $columns) Initializes a datagrid item and cells inside it
void | loadState () Loads item count information from viewstate.
void | onCancelCommand ( TDataGridCommandEventParameter $param) Raises OnCancelCommand event.
void | onDeleteCommand ( TDataGridCommandEventParameter $param) Raises OnDeleteCommand event.
void | onEditCommand ( TDataGridCommandEventParameter $param) Raises OnEditCommand event.
void | onItemCommand ( TDataGridCommandEventParameter $param) Raises OnItemCommand event.
void | onItemCreated ( TDataGridItemEventParameter $param) Raises OnItemCreated event.
void | onItemDataBound ( TDataGridItemEventParameter $param) Raises OnItemDataBound event.
void | onPageIndexChanged ( TDataGridPageChangedEventParameter $param) Raises OnPageIndexChanged event.
void | onPagerCreated ( TDataGridPagerEventParameter $param) Raises OnPagerCreated event.
void | onSortCommand ( TDataGridSortCommandEventParameter $param) Raises OnSortCommand event.
void | onUpdateCommand ( TDataGridCommandEventParameter $param) Raises OnUpdateCommand event.
protected void | performDataBinding ( Traversable $data) Performs databinding to populate datagrid items from data source.
void | render ( THtmlWriter $writer) Renders the datagrid.
void | renderBeginTag ( THtmlWriter $writer) Renders the openning tag for the datagrid control which will render table caption if present.
protected void | renderTable ( THtmlWriter $writer) Renders the tabular data.
void | reset () Clears up all items in the datagrid.
protected void | restoreGridFromViewState () Restores datagrid content from viewstate.
void | saveState () Saves item count in viewstate.
void | setAllowSorting ( boolean $value)
void | setAutoGenerateColumns ( boolean $value)
void | setBackImageUrl ( string $value)
void | setCaption ( string $value)
void | setCaptionAlign ( TTableCaptionAlign $value)
void | setEditItemIndex ( integer $value) Edits an item by its index in getItems.
void | setEmptyTemplate ( ITemplate $value)
void | setSelectedItemIndex ( integer $value) Selects an item by its index in getItems.
void | setShowFooter ( boolean $value)
void | setShowHeader ( boolean $value)
Methods Inherited From TBaseDataList
TBaseDataList::createStyle(), TBaseDataList::getCellPadding(), TBaseDataList::getCellSpacing(), TBaseDataList::getDataFieldValue(), TBaseDataList::getDataKeyField(), TBaseDataList::getDataKeys(), TBaseDataList::getGridLines(), TBaseDataList::getHorizontalAlign(), TBaseDataList::onSelectedIndexChanged(), TBaseDataList::setCellPadding(), TBaseDataList::setCellSpacing(), TBaseDataList::setDataKeyField(), TBaseDataList::setGridLines(), TBaseDataList::setHorizontalAlign()
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | CMD_CANCEL |
string | CMD_DELETE |
string | CMD_EDIT |
string | CMD_PAGE |
string | CMD_PAGE_NEXT |
string | CMD_PAGE_PREV |
string | CMD_SELECT | Command name that TDataGrid understands.
string | CMD_SORT |
string | CMD_UPDATE |
string | IT_ALTERNATINGITEM |
string | IT_EDITITEM |
string | IT_FOOTER |
string | IT_HEADER | datagrid item types
string | IT_ITEM |
string | IT_PAGER |
string | IT_SELECTEDITEM |
string | IT_SEPARATOR |
Method Details

addParsedObject

public void addParsedObject (mixed $object )

Adds objects parsed in template to datagrid.

Datagrid columns are added into Columns collection.

Input
mixed $object object parsed in template
Output
Exception

applyItemStyles

protected void applyItemStyles ()

Applies styles to items, header, footer and separators.

Item styles are applied in a hierarchical way. Style in higher hierarchy will inherit from styles in lower hierarchy. Starting from the lowest hierarchy, the item styles include item's own style, ItemStyle, AlternatingItemStyle, SelectedItemStyle, and EditItemStyle. Therefore, if background color is set as red in ItemStyle, EditItemStyle will also have red background color unless it is set to a different value explicitly.

Output
Exception

bubbleEvent

public boolean bubbleEvent (TControl $sender , TEventParameter $param )

This method overrides parent's implementation to handle onItemCommand event which is bubbled from TDataGridItem child controls.

If the event parameter is TDataGridCommandEventParameter and the command name is a recognized one, which includes 'select', 'edit', 'delete', 'update', and 'cancel' (case-insensitive), then a corresponding command event is also raised (such as OnEditCommand). This method should only be used by control developers.

Input
TControl | $sender | the sender of the event
TEventParameter | $param | event parameter
Output
boolean | whether the event bubbling should stop here.
Exception

buildNextPrevPager

protected void buildNextPrevPager (TDataGridPager $pager )

Builds a next-prev pager

Input
TDataGridPager $pager the container for the pager
Output
Exception

buildNumericPager

protected void buildNumericPager (TDataGridPager $pager )

Builds a numeric pager

Input
TDataGridPager $pager the container for the pager
Output
Exception

buildPager

protected void buildPager (TDataGridPager $pager )

Builds the pager content based on pager style.

Input
TDataGridPager $pager the container for the pager
Output
Exception

createAutoColumns

protected TDataGridColumnCollection createAutoColumns (Traversable $dataSource )

Automatically generates datagrid columns based on datasource schema

Input
Traversable $dataSource data source bound to the datagrid
Output
Exception

createItem

protected TDataGridItem createItem (integer $itemIndex , TListItemType $dataSourceIndex , mixed $itemType )

Creates a datagrid item instance based on the item type and index.

Input
integer | $itemIndex | zero-based item index
TListItemType | $dataSourceIndex | item type
mixed | $itemType |
Output
TDataGridItem | created data list item
Exception

createPagerButton

protected mixed createPagerButton (string $buttonType , boolean $enabled , string $text , string $commandName , string $commandParameter )

Creates a pager button.

Depending on the button type, a TLinkButton or a TButton may be created. If it is enabled (clickable), its command name and parameter will also be set. Derived classes may override this method to create additional types of buttons, such as TImageButton.

Input
string | $buttonType | button type, either LinkButton or PushButton
boolean | $enabled | whether the button should be enabled
string | $text | caption of the button
string | $commandName | CommandName corresponding to the OnCommand event of the button
string | $commandParameter | CommandParameter corresponding to the OnCommand event of the button
Output
mixed | the button instance
Exception

createStyle

protected TTableStyle createStyle ()

Creates a style object for the control.

This method creates a TTableStyle to be used by datagrid.

Output
TTableStyle control style to be used
Exception

getAllowSorting

public boolean getAllowSorting ()

Output
boolean whether sorting is enabled. Defaults to false.
Exception

getAlternatingItemStyle

public TTableItemStyle getAlternatingItemStyle ()

Output
TTableItemStyle the style for each alternating item
Exception

getAutoColumns

public TDataGridColumnCollection getAutoColumns ()

Output
TDataGridColumnCollection automatically generated datagrid columns
Exception

getAutoGenerateColumns

public boolean getAutoGenerateColumns ()

Output
boolean whether datagrid columns should be automatically generated. Defaults to true.
Exception

getBackImageUrl

public string getBackImageUrl ()

Output
string the URL of the background image for the datagrid
Exception

getBottomPager

public TDataGridPager getBottomPager ()

Output
TDataGridPager the pager displayed at the bottom of datagrid. It could be null if paging is disabled.
Exception

getCaption

public string getCaption ()

Output
string caption for the datagrid
Exception

getCaptionAlign

public TTableCaptionAlign getCaptionAlign ()

Output
TTableCaptionAlign datagrid caption alignment. Defaults to TTableCaptionAlign::NotSet.
Exception

getColumns

public TDataGridColumnCollection getColumns ()

Output
TDataGridColumnCollection manually specified datagrid columns
Exception

getEditItem

public TDataGridItem getEditItem ()

Output
TDataGridItem the edit item
Exception

getEditItemIndex

public integer getEditItemIndex ()

Output
integer the zero-based index of the edit item in Items. A value -1 means no item is in edit mode.
Exception

getEditItemStyle

public TTableItemStyle getEditItemStyle ()

Output
TTableItemStyle the style for edit item
Exception

getEmptyTemplate

public ITemplate getEmptyTemplate ()

Output
ITemplate the template applied when no data is bound to the datagrid
Exception

getFooter

public TDataGridItem getFooter ()

Output
TDataGridItem the footer item
Exception

getFooterStyle

public TTableItemStyle getFooterStyle ()

Output
TTableItemStyle the style for footer
Exception

getHeader

public TDataGridItem getHeader ()

Output
TDataGridItem the header item
Exception

getHeaderStyle

public TTableItemStyle getHeaderStyle ()

Output
TTableItemStyle the style for header
Exception

getItemCount

public integer getItemCount ()

Output
integer number of items
Exception

getItems

public TDataGridItemCollection getItems ()

Output
TDataGridItemCollection datagrid item collection
Exception

getItemStyle

public TTableItemStyle getItemStyle ()

Output
TTableItemStyle the style for every item
Exception

getPagerStyle

public TDataGridPagerStyle getPagerStyle ()

Output
TDataGridPagerStyle the style for pager
Exception

getSelectedItem

public TDataGridItem getSelectedItem ()

Output
TDataGridItem the selected item, null if no item is selected.
Exception

getSelectedItemIndex

public integer getSelectedItemIndex ()

Output
integer the zero-based index of the selected item in Items. A value -1 means no item selected.
Exception

getSelectedItemStyle

public TTableItemStyle getSelectedItemStyle ()

Output
TTableItemStyle the style for selected item
Exception

getShowFooter

public boolean getShowFooter ()

Output
boolean whether the footer should be displayed. Defaults to false.
Exception

getShowHeader

public boolean getShowHeader ()

Output
boolean whether the header should be displayed. Defaults to true.
Exception

getTableBodyStyle

public TStyle getTableBodyStyle ()

Output
TStyle the style for tbody element, if any
Exception

getTableFootStyle

public TStyle getTableFootStyle ()

Output
TStyle the style for tfoot element, if any
Exception

getTableHeadStyle

public TStyle getTableHeadStyle ()

Output
TStyle the style for thead element, if any
Exception

getTagName

protected string getTagName ()

Output
string tag name (table) of the datagrid
Exception

getTopPager

public TDataGridPager getTopPager ()

Output
TDataGridPager the pager displayed at the top of datagrid. It could be null if paging is disabled.
Exception

initializeItem

protected void initializeItem (TDataGrid $item , TDataGridColumnCollection $columns )

Initializes a datagrid item and cells inside it

Input
TDataGrid | $item | datagrid item to be initialized
TDataGridColumnCollection | $columns | datagrid columns to be used to initialize the cells in the item
Output
Exception

loadState

public void loadState ()

Loads item count information from viewstate.

This method is invoked right after control state is loaded.

Output
Exception

onCancelCommand

public void onCancelCommand (TDataGridCommandEventParameter $param )

Raises OnCancelCommand event.

This method is invoked when a button control raises OnCommand event with cancel command name.

Input
TDataGridCommandEventParameter $param event parameter
Output
Exception

onDeleteCommand

public void onDeleteCommand (TDataGridCommandEventParameter $param )

Raises OnDeleteCommand event.

This method is invoked when a button control raises OnCommand event with delete command name.

Input
TDataGridCommandEventParameter $param event parameter
Output
Exception

onEditCommand

public void onEditCommand (TDataGridCommandEventParameter $param )

Raises OnEditCommand event.

This method is invoked when a button control raises OnCommand event with edit command name.

Input
TDataGridCommandEventParameter $param event parameter
Output
Exception

onItemCommand

public void onItemCommand (TDataGridCommandEventParameter $param )

Raises OnItemCommand event.

This method is invoked when a button control raises OnCommand event.

Input
TDataGridCommandEventParameter $param event parameter
Output
Exception

onItemCreated

public void onItemCreated (TDataGridItemEventParameter $param )

Raises OnItemCreated event.

This method is invoked right after a datagrid item is created and before added to page hierarchy.

Input
TDataGridItemEventParameter $param event parameter
Output
Exception

onItemDataBound

public void onItemDataBound (TDataGridItemEventParameter $param )

Raises OnItemDataBound event.

This method is invoked for each datagrid item after it performs databinding.

Input
TDataGridItemEventParameter $param event parameter
Output
Exception

onPageIndexChanged

public void onPageIndexChanged (TDataGridPageChangedEventParameter $param )

Raises OnPageIndexChanged event.

This method is invoked when current page is changed.

Input
TDataGridPageChangedEventParameter $param event parameter
Output
Exception

onPagerCreated

public void onPagerCreated (TDataGridPagerEventParameter $param )

Raises OnPagerCreated event.

This method is invoked right after a datagrid pager is created and before added to page hierarchy.

Input
TDataGridPagerEventParameter $param event parameter
Output
Exception

onSortCommand

public void onSortCommand (TDataGridSortCommandEventParameter $param )

Raises OnSortCommand event.

This method is invoked when a button control raises OnCommand event with sort command name.

Input
TDataGridSortCommandEventParameter $param event parameter
Output
Exception

onUpdateCommand

public void onUpdateCommand (TDataGridCommandEventParameter $param )

Raises OnUpdateCommand event.

This method is invoked when a button control raises OnCommand event with update command name.

Input
TDataGridCommandEventParameter $param event parameter
Output
Exception

performDataBinding

protected void performDataBinding (Traversable $data )

Performs databinding to populate datagrid items from data source.

This method is invoked by dataBind(). You may override this function to provide your own way of data population.

Input
Traversable $data the bound data
Output
Exception

render

public void render (THtmlWriter $writer )

Renders the datagrid.

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

renderBeginTag

public void renderBeginTag (THtmlWriter $writer )

Renders the openning tag for the datagrid control which will render table caption if present.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderTable

protected void renderTable (THtmlWriter $writer )

Renders the tabular data.

Input
THtmlWriter $writer writer
Output
Exception

reset

public void reset ()

Clears up all items in the datagrid.

Output
Exception

restoreGridFromViewState

protected void restoreGridFromViewState ()

Restores datagrid content from viewstate.

Output
Exception

saveState

public void saveState ()

Saves item count in viewstate.

This method is invoked right before control state is to be saved.

Output
Exception

setAllowSorting

public void setAllowSorting (boolean $value )

Input
boolean $value whether sorting is enabled
Output
Exception

setAutoGenerateColumns

public void setAutoGenerateColumns (boolean $value )

Input
boolean $value whether datagrid columns should be automatically generated
Output
Exception

setBackImageUrl

public void setBackImageUrl (string $value )

Input
string $value the URL of the background image for the datagrid
Output
Exception

setCaption

public void setCaption (string $value )

Input
string $value caption for the datagrid
Output
Exception

setCaptionAlign

public void setCaptionAlign (TTableCaptionAlign $value )

Input
TTableCaptionAlign $value datagrid caption alignment. Valid values include
Output
Exception

setEditItemIndex

public void setEditItemIndex (integer $value )

Edits an item by its index in getItems.

Previously editting item will change to normal item state. If the index is less than 0, any existing edit item will be cleared up.

Input
integer $value the edit item index
Output
Exception

setEmptyTemplate

public void setEmptyTemplate (ITemplate $value )

Input
ITemplate | $value | the template applied when no data is bound to the datagrid
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setSelectedItemIndex

public void setSelectedItemIndex (integer $value )

Selects an item by its index in getItems.

Previously selected item will be un-selected. If the item to be selected is already in edit mode, it will remain in edit mode. If the index is less than 0, any existing selection will be cleared up.

Input
integer $value the selected item index
Output
Exception

setShowFooter

public void setShowFooter (boolean $value )

Input
boolean $value whether the footer should be displayed
Output
Exception

setShowHeader

public void setShowHeader (boolean $value )

Input
boolean $value whether the header should be displayed
Output
Exception

Constant Details

CMD_CANCEL

Type:

string

Value:

'Cancel'

CMD_DELETE

Type:

string

Value:

'Delete'

CMD_EDIT

Type:

string

Value:

'Edit'

CMD_PAGE

Type:

string

Value:

'Page'

CMD_PAGE_NEXT

Type:

string

Value:

'Next'

CMD_PAGE_PREV

Type:

string

Value:

'Previous'

CMD_SELECT

Command name that TDataGrid understands.

Type:

string

Value:

'Select'

CMD_SORT

Type:

string

Value:

'Sort'

CMD_UPDATE

Type:

string

Value:

'Update'

IT_ALTERNATINGITEM

Type:

string

Value:

'AlternatingItem'

IT_EDITITEM

Type:

string

Value:

'EditItem'

IT_FOOTER

Type:

string

Value:

'Footer'

IT_HEADER

datagrid item types

Type:

string

Value:

'Header'
Deprecated: deprecated since version 3.0.4. Use TListItemType constants instead.

IT_ITEM

Type:

string

Value:

'Item'

IT_PAGER

Type:

string

Value:

'Pager'

IT_SELECTEDITEM

Type:

string

Value:

'SelectedItem'

IT_SEPARATOR

Type:

string

Value:

'Separator'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGridColumnCollection

Class TDataGridColumnCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TDataGridColumnCollection

TDataGridColumnCollection class.

TDataGridColumnCollection represents a collection of data grid columns.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
protected TDataGrid | getOwner ()
void | insertAt ( integer $index, mixed $item) Inserts an item at the specified position.
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getOwner

protected TDataGrid getOwner ()

Output
TDataGrid the control that owns this collection.
Exception

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by inserting only TDataGridColumn.

Input
integer | $index | the speicified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is not a TDataGridColumn.


PRADO API Manual: Docs For Class TDataGridCommandEventParameter

Class TDataGridCommandEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TCommandEventParameter
         |
         --TDataGridCommandEventParameter

TDataGridCommandEventParameter class

TDataGridCommandEventParameter encapsulates the parameter data for TDataGrid::onItemCommand event of TDataGrid controls.

The Item property indicates the datagrid item related with the event. The CommandSource refers to the control that originally raises the Command event.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
TControl | getCommandSource ()
TDataGridItem | getItem ()
Methods Inherited From TCommandEventParameter
TCommandEventParameter::getCommandName(), TCommandEventParameter::getCommandParameter()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getCommandSource

public TControl getCommandSource ()

Output
TControl the control originally raises the Command event.
Exception

getItem

public TDataGridItem getItem ()

Output
TDataGridItem the TDataGridItem control responsible for the event.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGridItem

Class TDataGridItem (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableRow
               |
               --TDataGridItem

TDataGridItem class

A TDataGridItem control represents an item in the TDataGrid control, such as heading section, footer section, or a data item. The index and data value of the item can be accessed via ItemIndex> and DataItem properties, respectively. The type of the item is given by ItemType property. Property DataSourceIndex gives the index of the item from the bound data source.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct Array
Constructor.
Method Summary
boolean | bubbleEvent ( TControl $sender, TEventParameter $param) This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
mixed | getData ()
mixed | getDataItem () This property is deprecated since v3.1.0.
integer | getDataSourceIndex ()
integer | getItemIndex ()
TListItemType | getItemType ()
void | setData ( mixed $value)
void | setDataItem ( mixed $value) This property is deprecated since v3.1.0.
void | setItemType ( TListItemType $value)
Methods Inherited From TTableRow
TTableRow::addParsedObject(), TTableRow::createControlCollection(), TTableRow::createStyle(), TTableRow::getCells(), TTableRow::getHorizontalAlign(), TTableRow::getTableSection(), TTableRow::getTagName(), TTableRow::getVerticalAlign(), TTableRow::renderContents(), TTableRow::setHorizontalAlign(), TTableRow::setTableSection(), TTableRow::setVerticalAlign()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

bubbleEvent

public boolean bubbleEvent (TControl $sender , TEventParameter $param )

This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

Input
TControl | $sender | the sender of the event
TEventParameter | $param | event parameter
Output
boolean | whether the event bubbling should stop here.
Exception

getData

public mixed getData ()

Output
mixed data associated with the item
Exception

getDataItem

public mixed getDataItem ()

This property is deprecated since v3.1.0.

Output
mixed data associated with the item
Exception

getDataSourceIndex

public integer getDataSourceIndex ()

Output
integer the index of the datagrid item from the bound data source
Exception

getItemIndex

public integer getItemIndex ()

Output
integer zero-based index of the item in the item collection of datagrid
Exception

getItemType

public TListItemType getItemType ()

Output
TListItemType item type.
Exception

setData

public void setData (mixed $value )

Input
mixed $value data to be associated with the item
Output
Exception

setDataItem

public void setDataItem (mixed $value )

This property is deprecated since v3.1.0.

Input
mixed $value data to be associated with the item
Output
Exception

setItemType

public void setItemType (TListItemType $value )

Input
TListItemType $value item type
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGridItemCollection

Class TDataGridItemCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TDataGridItemCollection

TDataGridItemCollection class.

TDataGridItemCollection represents a collection of data grid items.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void
insertAt ( integer $index, mixed $item)
Inserts an item at the specified position.
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by inserting only TDataGridItem.

Input
integer | $index | the speicified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is not a TDataGridItem.


PRADO API Manual: Docs For Class TDataGridItemEventParameter

Class TDataGridItemEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TDataGridItemEventParameter

TDataGridItemEventParameter class

TDataGridItemEventParameter encapsulates the parameter data for TDataGrid::onItemCreated event of TDataGrid controls. The Item property indicates the datagrid item related with the event.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
TDataGridItem
getItem ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getItem

public TDataGridItem getItem ()

Output
TDataGridItem datagrid item related with the corresponding event
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGridPageChangedEventParameter

Class TDataGridPageChangedEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TDataGridPageChangedEventParameter

TDataGridPageChangedEventParameter class

TDataGridPageChangedEventParameter encapsulates the parameter data for TDataGrid::onPageIndexChanged event of TDataGrid controls.

The CommandSource property refers to the control that originally raises the OnCommand event, while NewPageIndex returns the new page index carried with the page command.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
TControl | getCommandSource ()
integer | getNewPageIndex ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getCommandSource

public TControl getCommandSource ()

Output
TControl the control originally raises the OnCommand event.
Exception

getNewPageIndex

public integer getNewPageIndex ()

Output
integer new page index
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGridPager

Class TDataGridPager (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPanel
               |
               --TDataGridPager

TDataGridPager class.

TDataGridPager represents a datagrid pager.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct Array
Constructor.
Method Summary
boolean | bubbleEvent ( TControl $sender, TEventParameter $param) This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
TDataGrid | getDataGrid ()
string | getItemType ()
Methods Inherited From TPanel
TPanel::addAttributesToRender(), TPanel::createStyle(), TPanel::getBackImageUrl(), TPanel::getDefaultButton(), TPanel::getDirection(), TPanel::getGroupingText(), TPanel::getHorizontalAlign(), TPanel::getScrollBars(), TPanel::getTagName(), TPanel::getWrap(), TPanel::renderBeginTag(), TPanel::renderEndTag(), TPanel::setBackImageUrl(), TPanel::setDefaultButton(), TPanel::setDirection(), TPanel::setGroupingText(), TPanel::setHorizontalAlign(), TPanel::setScrollBars(), TPanel::setWrap()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

bubbleEvent

public boolean bubbleEvent (TControl $sender , TEventParameter $param )

This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

Input
TControl | $sender | the sender of the event
TEventParameter | $param | event parameter
Output
boolean | whether the event bubbling should stop here.
Exception

getDataGrid

public TDataGrid getDataGrid ()

Output
TDataGrid the datagrid owning this pager
Exception

getItemType

public string getItemType ()

Output
string item type.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGridPagerButtonType

Class TDataGridPagerButtonType (Class Overview)

TEnumerable
   |
   --TDataGridPagerButtonType

TDataGridPagerButtonType class.

TDataGridPagerButtonType defines the enumerable type for the possible types of datagrid pager buttons.

The following enumerable values are defined:

  • LinkButton: link buttons
  • PushButton: form submit buttons

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | LinkButton
string | PushButton
Constant Details

LinkButton

Type:

string

Value:

'LinkButton'

PushButton

Type:

string

Value:

'PushButton'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGridPagerEventParameter

Class TDataGridPagerEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TDataGridPagerEventParameter

TDataGridPagerEventParameter class

TDataGridPagerEventParameter encapsulates the parameter data for TDataGrid::onPagerCreated event of TDataGrid controls. The Pager property indicates the datagrid pager related with the event.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
TDataGridPager
getPager ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getPager

public TDataGridPager getPager ()

Output
TDataGridPager datagrid pager related with the corresponding event
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGridPagerMode

Class TDataGridPagerMode (Class Overview)

TEnumerable
   |
   --TDataGridPagerMode

TDataGridPagerMode class.

TDataGridPagerMode defines the enumerable type for the possible modes that a datagrid pager can take.

The following enumerable values are defined:

  • NextPrev: pager buttons are displayed as next and previous pages
  • Numeric: pager buttons are displayed as numeric page numbers

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | NextPrev
string | Numeric
Constant Details

NextPrev

Type:

string

Value:

'NextPrev'

Numeric

Type:

string

Value:

'Numeric'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGridPagerPosition

Class TDataGridPagerPosition (Class Overview)

TEnumerable
   |
   --TDataGridPagerPosition

TDataGridPagerPosition class.

TDataGridPagerPosition defines the enumerable type for the possible positions that a datagrid pager can be located at.

The following enumerable values are defined:

  • Bottom: pager appears only at the bottom of the data grid.
  • Top: pager appears only at the top of the data grid.
  • TopAndBottom: pager appears on both top and bottom of the data grid.

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Bottom
string | Top
string | TopAndBottom
Constant Details

Bottom

Type:

string

Value:

'Bottom'

Top

Type:

string

Value:

'Top'

TopAndBottom

Type:

string

Value:

'TopAndBottom'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGridSortCommandEventParameter

Class TDataGridSortCommandEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TDataGridSortCommandEventParameter

TDataGridSortCommandEventParameter class

TDataGridSortCommandEventParameter encapsulates the parameter data for TDataGrid::onSortCommand event of TDataGrid controls.

The CommandSource property refers to the control that originally raises the OnCommand event, while SortExpression gives the sort expression carried with the sort command.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
TControl | getCommandSource ()
string | getSortExpression ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getCommandSource

public TControl getCommandSource ()

Output
TControl the control originally raises the OnCommand event.
Exception

getSortExpression

public string getSortExpression ()

Output
string sort expression
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TButtonColumnType

Class TButtonColumnType (Class Overview)

TEnumerable
   |
   --TButtonColumnType

TButtonColumnType class.

TButtonColumnType defines the enumerable type for the possible types of buttons that can be used in a TButtonColumn.

The following enumerable values are defined:

  • LinkButton: link buttons
  • PushButton: form buttons
  • ImageButton: image buttons

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | ImageButton
string | LinkButton
string | PushButton
Constant Details

ImageButton

Type:

string

Value:

'ImageButton'

LinkButton

Type:

string

Value:

'LinkButton'

PushButton

Type:

string

Value:

'PushButton'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGridColumn

Class TDataGridColumn (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn

Direct Known Sub-classes:

TBoundColumn , TButtonColumn , TCheckBoxColumn , TDropDownListColumn , TEditCommandColumn , THyperLinkColumn , TLiteralColumn , TTemplateColumn

TDataGridColumn class

TDataGridColumn serves as the base class for the different column types of the TDataGrid control. TDataGridColumn defines the properties and methods that are common among all datagrid column types. In particular, it initializes header and footer cells according to HeaderText and HeaderStyle FooterText and FooterStyle properties. If HeaderImageUrl is specified, the image will be displayed instead in the header cell. The ItemStyle is applied to cells that belong to non-header and -footer datagrid items.

When the datagrid enables sorting, if the SortExpression is not empty, the header cell will display a button (linkbutton or imagebutton) that will bubble the sort command event to the datagrid.

Since v3.1.0, TDataGridColumn has introduced two new properties HeaderRenderer and FooterRenderer which can be used to specify the layout of header and footer column cells. A renderer refers to a control class that is to be instantiated as a control. For more details, see TRepeater and TDataList.

Since v3.1.1, TDataGridColumn has introduced EnableCellGrouping. If a column has this property set true, consecutive cells having the same content in this column will be grouped into one cell. Note, there are some limitations to cell grouping. We determine the cell content according to the cell's TTableCell::getText property. If the text is empty and the cell has some child controls, we will pick up the first control who implements IDataRenderer and obtain its IDataRenderer::getData property.

The following datagrid column types are provided by the framework currently,

  • TBoundColumn, associated with a specific field in datasource and displays the corresponding data.
  • TEditCommandColumn, displaying edit/update/cancel command buttons
  • TDropDownListColumn, displaying a dropdown list when the item is in edit state
  • TButtonColumn, displaying generic command buttons that may be bound to specific field in datasource.
  • THyperLinkColumn, displaying a hyperlink that may be bound to specific field in datasource.
  • TCheckBoxColumn, displaying a checkbox that may be bound to specific field in datasource.
  • TTemplateColumn, displaying content based on templates.
To create your own column class, simply override initializeCell() method, which is the major logic for managing the data and presentation of cells in the column.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected string | formatDataValue ( string $formatString, mixed $value) Formats the text value according to a format string.
boolean | getAllowSorting () Returns a value indicating whether this column allows sorting.
protected mixed | getDataFieldValue ( mixed $data, string $field) Fetches the value of the data at the specified field.
boolean | getEnableCellGrouping ()
string | getFooterRenderer ()
TTableItemStyle | getFooterStyle ( boolean $createStyle)
string | getFooterText ()
string | getHeaderImageUrl ()
string | getHeaderRenderer ()
TTableItemStyle | getHeaderStyle ( boolean $createStyle)
string | getHeaderText ()
string | getID ()
TTableItemStyle | getItemStyle ( boolean $createStyle)
TDataGrid | getOwner ()
string | getSortExpression ()
protected mixed | getViewState ( string $key, mixed $defaultValue) Returns a viewstate value.
boolean | getVisible ( mixed $checkParents)
void | initialize () Initializes the column.
void | initializeCell ( TTableCell $cell, integer $columnIndex, string $itemType) Initializes the specified cell to its initial values.
protected void | initializeFooterCell ( TTableCell $cell, integer $columnIndex) Initializes the footer cell.
protected void | initializeHeaderCell ( TTableCell $cell, integer $columnIndex) Initializes the header cell.
void | loadState ( mixed $state) Loads persistent state values.
mixed | saveState () Saves persistent state values.
void | setEnableCellGrouping ( boolean $value)
void | setFooterRenderer ( string $value) Sets the column footer cell renderer class.
void | setFooterText ( string $value)
void | setHeaderImageUrl ( string $value)
void | setHeaderRenderer ( string $value) Sets the column header cell renderer class.
void | setHeaderText ( string $value)
void | setID ( string $value) Sets the ID of the column.
void | setOwner ( TDataGrid $value)
void | setSortExpression ( string $value)
protected void | setViewState ( string $key, mixed $value, mixed $defaultValue) Sets a viewstate value.
void | setVisible ( boolean $value)
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

formatDataValue

protected string formatDataValue (string $formatString , mixed $value )

Formats the text value according to a format string.

If the format string is empty, the original value is converted into a string and returned. If the format string starts with '#', the string is treated as a PHP expression within which the token '{0}' is translated with the data value to be formated. Otherwise, the format string and the data value are passed as the first and second parameters in http://www.php.net/sprintf.

Input
string | $formatString | format string
mixed | $value | the data to be formatted
Output
string | the formatted result
Exception

getAllowSorting

public boolean getAllowSorting ()

Returns a value indicating whether this column allows sorting.

The column allows sorting only when SortExpression is not empty and the datagrid allows sorting.

Output
boolean whether this column allows sorting
Exception

getDataFieldValue

protected mixed getDataFieldValue (mixed $data , string $field )

Fetches the value of the data at the specified field.

If the data is an array, the field is used as an array key. If the data is an of TMap, TList or their derived class, the field is used as a key value. If the data is a component, the field is used as the name of a property.

Input
mixed | $data | data containing the field of value
string | $field | the data field
Output
mixed | data value at the specified field
Exception
throws | TInvalidDataValueException if the data or the field is invalid.

getEnableCellGrouping

public boolean getEnableCellGrouping ()

Output
boolean whether cells having the same content should be grouped together. Defaults to false.
Exception

getFooterRenderer

public string getFooterRenderer ()

Output
string the class name for the column footer cell renderer. Defaults to empty, meaning not set.
Exception

getFooterStyle

public TTableItemStyle getFooterStyle (boolean $createStyle )

Input
boolean | $createStyle | whether to create a style if previously not existing
Output
TTableItemStyle | the style for footer
Exception

getFooterText

public string getFooterText ()

Output
string the text to be displayed in the footer of this column
Exception

getHeaderImageUrl

public string getHeaderImageUrl ()

Output
string the url of the image to be displayed in header
Exception

getHeaderRenderer

public string getHeaderRenderer ()

Output
string the class name for the column header cell renderer. Defaults to empty, meaning not set.
Exception

getHeaderStyle

public TTableItemStyle getHeaderStyle (boolean $createStyle )

Input
boolean | $createStyle | whether to create a style if previously not existing
Output
TTableItemStyle | the style for header
Exception

getHeaderText

public string getHeaderText ()

Output
string the text to be displayed in the header of this column
Exception

getID

public string getID ()

Output
string the ID of the column.
Exception

getItemStyle

public TTableItemStyle getItemStyle (boolean $createStyle )

Input
boolean | $createStyle | whether to create a style if previously not existing
Output
TTableItemStyle | the style for item
Exception

getOwner

public TDataGrid getOwner ()

Output
TDataGrid datagrid that owns this column
Exception

getSortExpression

public string getSortExpression ()

Output
string the name of the field or expression for sorting
Exception

getViewState

protected mixed getViewState (string $key , mixed $defaultValue )

Returns a viewstate value.

Input
string | $key | the name of the viewstate value to be returned
mixed | $defaultValue | the default value. If $key is not found in viewstate, $defaultValue will be returned
Output
mixed | the viewstate value corresponding to $key
Exception

getVisible

public boolean getVisible (mixed $checkParents )

Input
mixed | $checkParents
Output
boolean | whether the column is visible. Defaults to true.
Exception

initialize

public void initialize ()

Initializes the column.

This method is invoked by TDataGrid when the column is about to be used to initialize datagrid items. Derived classes may override this method to do additional initialization.

Output
Exception

initializeCell

public void initializeCell (TTableCell $cell , integer $columnIndex , string $itemType )

Initializes the specified cell to its initial values.

The default implementation sets the content of header and footer cells. If sorting is enabled by the grid and sort expression is specified in the column, the header cell will show a link/image button. Otherwise, the header/footer cell will only show static text/image. This method can be overriden to provide customized intialization to column cells.

Input
TTableCell | $cell | the cell to be initialized.
integer | $columnIndex | the index to the Columns property that the cell resides in.
string | $itemType | the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)
Output
Exception

initializeFooterCell

protected void initializeFooterCell (TTableCell $cell , integer $columnIndex )

Initializes the footer cell.

This method attempts to use FooterRenderer to instantiate the footer cell. If that is not available, it will populate the cell with a text string specified by getFooterImageUrl

Input
TTableCell | $cell | the cell to be initialized
integer | $columnIndex | the index to the Columns property that the cell resides in.
Output
Exception

initializeHeaderCell

protected void initializeHeaderCell (TTableCell $cell , integer $columnIndex )

Initializes the header cell.

This method attempts to use HeaderRenderer to instantiate the header cell. If that is not available, it will populate the cell with an image or a text string, depending on HeaderImageUrl and HeaderText property values.

If the column allows sorting, image or text will be created as a button which issues Sort command upon user click.

Input
TTableCell | $cell | the cell to be initialized
integer | $columnIndex | the index to the Columns property that the cell resides in.
Output
Exception

loadState

public void loadState (mixed $state )

Loads persistent state values.

Input
mixed $state state values
Output
Exception

saveState

public mixed saveState ()

Saves persistent state values.

Output
mixed values to be saved
Exception

setEnableCellGrouping

public void setEnableCellGrouping (boolean $value )

Input
boolean $value whether cells having the same content should be grouped together.
Output
Exception

setFooterRenderer

public void setFooterRenderer (string $value )

Sets the column footer cell renderer class.

If not empty, the class will be used to instantiate as a child control in the column footer cell. If the class implements IDataRenderer, the Data property will be set as the FooterText.

Input
string $value the renderer class name in namespace format.
Output
Exception

setFooterText

public void setFooterText (string $value )

Input
string $value text to be displayed in the footer of this column
Output
Exception

setHeaderImageUrl

public void setHeaderImageUrl (string $value )

Input
string $value the url of the image to be displayed in header
Output
Exception

setHeaderRenderer

public void setHeaderRenderer (string $value )

Sets the column header cell renderer class.

If not empty, the class will be used to instantiate as a child control in the column header cell. If the class implements IDataRenderer, the Data property will be set as the FooterText.

Input
string $value the renderer class name in namespace format.
Output
Exception

setHeaderText

public void setHeaderText (string $value )

Input
string $value text to be displayed in the header of this column
Output
Exception

setID

public void setID (string $value )

Sets the ID of the column.

By explicitly specifying the column ID, one can access the column by $templateControl->ColumnID.

Input
string | $value | the ID of the column.
Output
Exception
throws | TInvalidDataValueException if the ID is of bad format

setOwner

public void setOwner (TDataGrid $value )

Input
TDataGrid $value datagrid object that owns this column
Output
Exception

setSortExpression

public void setSortExpression (string $value )

Input
string $value the name of the field or expression for sorting
Output
Exception

setViewState

protected void setViewState (string $key , mixed $value , mixed $defaultValue )

Sets a viewstate value.

Make sure that the viewstate value must be serializable and unserializable.

Input
string | $key | the name of the viewstate value
mixed | $value | the viewstate value to be set
mixed | $defaultValue | default value. If $value===$defaultValue, the item will be cleared from the viewstate.
Output
Exception

setVisible

public void setVisible (boolean $value )

Input
boolean $value whether the column is visible
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGridItemRenderer

Class TDataGridItemRenderer (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TDataRenderer
                  |
                  --TItemDataRenderer
                     |
                     --TDataGridItemRenderer

TDataGridItemRenderer class

TDataGridItemRenderer can be used as a convenient base class to define an item renderer class specific for TDataGrid.

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TTemplateControl
EXT_TEMPLATE,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
Methods Inherited From TItemDataRenderer
TItemDataRenderer::getItemIndex(), TItemDataRenderer::getItemType(), TItemDataRenderer::setItemIndex(), TItemDataRenderer::setItemType()
Methods Inherited From TDataRenderer
TDataRenderer::getData(), TDataRenderer::setData()
Methods Inherited From TTemplateControl
TTemplateControl::createChildControls(), TTemplateControl::getIsSourceTemplateControl(), TTemplateControl::getMaster(), TTemplateControl::getMasterClass(), TTemplateControl::getTemplate(), TTemplateControl::getTemplateDirectory(), TTemplateControl::initRecursive(), TTemplateControl::injectContent(), TTemplateControl::loadTemplate(), TTemplateControl::registerContent(), TTemplateControl::registerContentPlaceHolder(), TTemplateControl::setMasterClass(), TTemplateControl::setTemplate()
Methods Inherited From TCompositeControl
TCompositeControl::initRecursive()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGridPagerStyle

Class TDataGridPagerStyle (Class Overview)

TComponent
   |
   --TStyle
      |
      --TPanelStyle
         |
         --TDataGridPagerStyle

TDataGridPagerStyle class.

TDataGridPagerStyle specifies the styles available for a datagrid pager.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | copyFrom ( TStyle $style) Copies the fields in a new style to this style.
TDataGridPagerButtonType | getButtonType ()
TDataGridPagerMode | getMode ()
string | getNextPageText ()
integer | getPageButtonCount ()
TDataGridPagerPosition | getPosition ()
string | getPrevPageText ()
boolean | getVisible ()
void | mergeWith ( TStyle $style) Merges the style with a new one.
void | reset () Resets the style to the original empty state.
void | setButtonType ( TDataGridPagerButtonType $value)
void | setMode ( TDataGridPagerMode $value)
void | setNextPageText ( string $value)
void | setPageButtonCount ( integer $value)
void | setPosition ( TDataGridPagerPosition $value)
void | setPrevPageText ( string $value)
void | setVisible ( boolean $value)
Methods Inherited From TPanelStyle
TPanelStyle::addAttributesToRender(), TPanelStyle::copyFrom(), TPanelStyle::getBackImageUrl(), TPanelStyle::getDirection(), TPanelStyle::getHorizontalAlign(), TPanelStyle::getScrollBars(), TPanelStyle::getWrap(), TPanelStyle::mergeWith(), TPanelStyle::reset(), TPanelStyle::setBackImageUrl(), TPanelStyle::setDirection(), TPanelStyle::setHorizontalAlign(), TPanelStyle::setScrollBars(), TPanelStyle::setWrap()
Methods Inherited From TStyle
TStyle::addAttributesToRender(), TStyle::clearStyleField(), TStyle::copyFrom(), TStyle::getBackColor(), TStyle::getBorderColor(), TStyle::getBorderStyle(), TStyle::getBorderWidth(), TStyle::getCssClass(), TStyle::getCustomStyle(), TStyle::getDisplayStyle(), TStyle::getFont(), TStyle::getForeColor(), TStyle::getHeight(), TStyle::getStyleField(), TStyle::getStyleFields(), TStyle::getWidth(), TStyle::hasCssClass(), TStyle::hasFont(), TStyle::hasStyleField(), TStyle::mergeWith(), TStyle::reset(), TStyle::setBackColor(), TStyle::setBorderColor(), TStyle::setBorderStyle(), TStyle::setBorderWidth(), TStyle::setCssClass(), TStyle::setCustomStyle(), TStyle::setDisplayStyle(), TStyle::setForeColor(), TStyle::setHeight(), TStyle::setStyleField(), TStyle::setWidth(), TStyle::__clone()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

copyFrom

public void copyFrom (TStyle $style )

Copies the fields in a new style to this style.

If a style field is set in the new style, the corresponding field in this style will be overwritten.

Input
TStyle $style the new style
Output
Exception

getButtonType

public TDataGridPagerButtonType getButtonType ()

Output
TDataGridPagerButtonType the type of command button. Defaults to TDataGridPagerButtonType::LinkButton.
Exception

getMode

public TDataGridPagerMode getMode ()

Output
TDataGridPagerMode pager mode. Defaults to TDataGridPagerMode::NextPrev.
Exception

getNextPageText

public string getNextPageText ()

Output
string text for the next page button. Defaults to '>'.
Exception

getPageButtonCount

public integer getPageButtonCount ()

Output
integer maximum number of pager buttons to be displayed. Defaults to 10.
Exception

getPosition

public TDataGridPagerPosition getPosition ()

Output
TDataGridPagerPosition where the pager is to be displayed. Defaults to TDataGridPagerPosition::Bottom.
Exception

getPrevPageText

public string getPrevPageText ()

Output
string text for the previous page button. Defaults to '<'.
Exception

getVisible

public boolean getVisible ()

Output
boolean whether the pager is visible. Defaults to true.
Exception

mergeWith

public void mergeWith (TStyle $style )

Merges the style with a new one.

If a style field is not set in this style, it will be overwritten by the new one.

Input
TStyle $style the new style
Output
Exception

reset

public void reset ()

Resets the style to the original empty state.

Output
Exception

setButtonType

public void setButtonType (TDataGridPagerButtonType $value )

Input
TDataGridPagerButtonType $value the type of command button
Output
Exception

setMode

public void setMode (TDataGridPagerMode $value )

Input
TDataGridPagerMode $value pager mode.
Output
Exception

setNextPageText

public void setNextPageText (string $value )

Input
string $value text for the next page button.
Output
Exception

setPageButtonCount

public void setPageButtonCount (integer $value )

Input
integer | $value | maximum number of pager buttons to be displayed
Output
Exception
throws | TInvalidDataValueException if the value is less than 1.

setPosition

public void setPosition (TDataGridPagerPosition $value )

Input
TDataGridPagerPosition $value where the pager is to be displayed.
Output
Exception

setPrevPageText

public void setPrevPageText (string $value )

Input
string $value text for the next page button.
Output
Exception

setVisible

public void setVisible (boolean $value )

Input
boolean $value whether the pager is visible.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataList

Class TDataList (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TBaseDataList
                  |
                  --TDataList

TDataList class

TDataList represents a data bound and updatable list control.

Like TRepeater, TDataList displays its content repeatedly based on the data fetched from DataSource. The repeated contents in TDataList are called items, which are controls and can be accessed through Items. When dataBind() is invoked, TDataList creates an item for each row of data and binds the data row to the item. Optionally, a TDataList can have a header, a footer and/or separators between items.

TDataList differs from TRepeater in that it supports tiling the items in different manners and it maintains status of items to handle data update.

The layout of the repeated contents are specified by inline templates. TDataList items, header, footer, etc. are being instantiated with the corresponding templates when data is being bound to the repeater.

Since v3.1.0, the layout can also be by renderers. A renderer is a control class that can be instantiated as datalist items, header, etc. A renderer can thus be viewed as an external template (in fact, it can also be non-templated controls).

A renderer can be any control class.

  • If the class implements IDataRenderer, the Data
property will be set as the data row during databinding. Many PRADO controls implement this interface, such as TLabel, TTextBox, etc.
  • If the class implements IItemDataRenderer, the ItemIndex property will be set
as the zero-based index of the item in the datalist item collection, and the ItemType property as the item's type (such as TListItemType::Item). TDataListItemRenderer may be used as the convenient base class which already implements IDataItemRenderer.

The following properties are used to specify different types of template and renderer for a datalist:

  • ItemTemplate, ItemRenderer:
for each repeated row of data
  • AlternatingItemTemplate, AlternatingItemRenderer:
for each alternating row of data. If not set, ItemTemplate or ItemRenderer will be used instead.
  • HeaderTemplate, HeaderRenderer:
for the datalist header.
  • FooterTemplate, FooterRenderer:
for the datalist footer.
  • SeparatorTemplate, SeparatorRenderer:
for content to be displayed between items.
  • EmptyTemplate, EmptyRenderer:
used when data bound to the datalist is empty.
  • EditItemTemplate, EditItemRenderer:
for the row being editted.
  • SelectedItemTemplate, SelectedItemRenderer:
for the row being selected.

If a content type is defined with both a template and a renderer, the latter takes precedence.

When dataBind() is being called, TDataList undergoes the following lifecycles for each row of data:

  • create item based on templates or renderers
  • set the row of data to the item
  • raise OnItemCreated:
  • add the item as a child control
  • call dataBind() of the item
  • raise OnItemDataBound:
TDataList raises an OnItemCommand whenever a button control within some datalist item raises a OnCommand event. Therefore, you can handle all sorts of OnCommand event in a central place by writing an event handler for OnItemCommand.

An additional event is raised if the OnCommand event has one of the following command names:

  • edit: user wants to edit an item. OnEditCommand event will be raised.
  • update: user wants to save the change to an item. OnUpdateCommand event will be raised.
  • select: user selects an item. OnSelectedIndexChanged event will be raised.
  • delete: user deletes an item. OnDeleteCommand event will be raised.
  • cancel: user cancels previously editting action. OnCancelCommand event will be raised.
TDataList provides a few properties to support tiling the items. The number of columns used to display the data items is specified via RepeatColumns property, while the RepeatDirection governs the order of the items being rendered. The layout of the data items in the list is specified via RepeatLayout, which can take one of the following values:
  • Table (default): items are organized using HTML table and cells.
When using this layout, one can set CellPadding and CellSpacing to adjust the cellpadding and cellpadding of the table, and Caption and CaptionAlign to add a table caption with the specified alignment.
  • Flow: items are organized using HTML spans and breaks.
  • Raw: TDataList does not generate any HTML tags to do the tiling.
Items in TDataList can be in one of the three status: normal browsing, being editted and being selected. To change the status of a particular item, set SelectedItemIndex or EditItemIndex. The former will change the indicated item to selected mode, which will cause the item to use SelectedItemTemplate or SelectedItemRenderer for presentation. The latter will change the indicated item to edit mode and to use corresponding template or renderer. Note, if an item is in edit mode, then selecting this item will have no effect.

Different styles may be applied to items in different status. The style application is performed in a hierarchical way: Style in higher hierarchy will inherit from styles in lower hierarchy. Starting from the lowest hierarchy, the item styles include

  • item's own style
  • ItemStyle
  • AlternatingItemStyle
  • SelectedItemStyle
  • EditItemStyle.
Therefore, if background color is set as red in ItemStyle, EditItemStyle will also have red background color unless it is set to a different value explicitly.

When a page containing a datalist is post back, the datalist will restore automatically all its contents, including items, header, footer and separators. However, the data row associated with each item will not be recovered and become null. To access the data, use one of the following ways:

  • Use DataKeys to obtain the data key associated with
the specified datalist item and use the key to fetch the corresponding data from some persistent storage such as DB.
  • Save the whole dataset in viewstate, which will restore the dataset automatically upon postback.
Be aware though, if the size of your dataset is big, your page size will become big. Some complex data may also have serializing problem if saved in viewstate.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | applyItemStyles () Applies styles to items, header, footer and separators.
boolean | bubbleEvent ( TControl $sender, TEventParameter $param) This method overrides parent's implementation to handle onItemCommand event which is bubbled from datalist items and their child controls.
protected void | createEmptyContent () Creates empty datalist content.
protected TControl | createItem ( integer $itemIndex, TListItemType $itemType) Creates a datalist item instance based on the item type and index.
TStyle | generateItemStyle ( string $itemType, integer $index) Returns a style used for rendering items.
string | getAlternatingItemRenderer ()
TTableItemStyle | getAlternatingItemStyle ()
ITemplate | getAlternatingItemTemplate ()
string | getCaption ()
TTableCaptionAlign | getCaptionAlign ()
TControl | getEditItem ()
integer | getEditItemIndex ()
string | getEditItemRenderer ()
TTableItemStyle | getEditItemStyle ()
ITemplate | getEditItemTemplate ()
string | getEmptyRenderer ()
ITemplate | getEmptyTemplate ()
TControl | getFooter ()
string | getFooterRenderer ()
TTableItemStyle | getFooterStyle ()
ITemplate | getFooterTemplate ()
boolean | getHasFooter () Returns a value indicating whether this control contains footer item.
boolean | getHasHeader () Returns a value indicating whether this control contains header item.
boolean | getHasSeparators () Returns a value indicating whether this control contains separator items.
TControl | getHeader ()
string | getHeaderRenderer ()
TTableItemStyle | getHeaderStyle ()
ITemplate | getHeaderTemplate ()
integer | getItemCount ()
string | getItemRenderer ()
TDataListItemCollection | getItems ()
TTableItemStyle | getItemStyle ()
ITemplate | getItemTemplate ()
integer | getRepeatColumns ()
TRepeatDirection | getRepeatDirection ()
protected TRepeatInfo | getRepeatInfo ()
TRepeatLayout | getRepeatLayout ()
mixed | getSelectedDataKey ()
TControl | getSelectedItem ()
integer | getSelectedItemIndex ()
string | getSelectedItemRenderer ()
TTableItemStyle | getSelectedItemStyle ()
ITemplate | getSelectedItemTemplate ()
string | getSeparatorRenderer ()
TTableItemStyle | getSeparatorStyle ()
ITemplate | getSeparatorTemplate ()
boolean | getShowFooter ()
boolean | getShowHeader ()
void | loadState () Loads item count information from viewstate.
void | onCancelCommand ( TDataListCommandEventParameter $param) Raises OnCancelCommand event.
void | onDeleteCommand ( TDataListCommandEventParameter $param) Raises OnDeleteCommand event.
void | onEditCommand ( TDataListCommandEventParameter $param) Raises OnEditCommand event.
void | onItemCommand ( TDataListCommandEventParameter $param) Raises OnItemCommand event.
void | onItemCreated ( TDataListItemEventParameter $param) Raises OnItemCreated event.
void | onItemDataBound ( TDataListItemEventParameter $param) Raises OnItemDataBound event.
void | onUpdateCommand ( TDataListCommandEventParameter $param) Raises OnUpdateCommand event.
protected void | performDataBinding ( Traversable $data) Performs databinding to populate data list items from data source.
void | render ( THtmlWriter $writer) Renders the data list control.
void | renderItem ( THtmlWriter $writer, TRepeatInfo $repeatInfo, string $itemType, integer $index) Renders an item in the list.
void | reset () Clears up all items in the data list.
protected void | restoreItemsFromViewState () Creates data list items based on viewstate information.
void | saveState () Saves item count in viewstate.
void | setAlternatingItemRenderer ( string $value) Sets the alternative item renderer class.
void | setAlternatingItemTemplate ( ITemplate $value)
void | setCaption ( string $value)
TTableCaptionAlign | setCaptionAlign ( mixed $value)
void | setEditItemIndex ( integer $value) Edits an item by its index in getItems.
void | setEditItemRenderer ( string $value) Sets the renderer class for the datalist item being editted.
void | setEditItemTemplate ( ITemplate $value)
void | setEmptyRenderer ( string $value) Sets the datalist empty renderer class.
void | setEmptyTemplate ( ITemplate $value)
void | setFooterRenderer ( string $value) Sets the datalist footer renderer class.
void | setFooterTemplate ( ITemplate $value)
void | setHeaderRenderer ( string $value) Sets the datalist header renderer class.
void | setHeaderTemplate ( ITemplate $value)
void | setItemRenderer ( string $value) Sets the item renderer class.
void | setItemTemplate ( ITemplate $value)
void | setRepeatColumns ( integer $value)
void | setRepeatDirection ( TRepeatDirection $value)
void | setRepeatLayout ( TRepeatLayout $value)
void | setSelectedItemIndex ( integer $value) Selects an item by its index in getItems.
void | setSelectedItemRenderer ( string $value) Sets the renderer class for the datalist item being selected.
void | setSelectedItemTemplate ( ITemplate $value)
void | setSeparatorRenderer ( string $value) Sets the datalist item separator renderer class.
void | setSeparatorTemplate ( ITemplate $value)
void | setShowFooter ( boolean $value)
void | setShowHeader ( boolean $value)
Methods Inherited From TBaseDataList
TBaseDataList::createStyle(), TBaseDataList::getCellPadding(), TBaseDataList::getCellSpacing(), TBaseDataList::getDataFieldValue(), TBaseDataList::getDataKeyField(), TBaseDataList::getDataKeys(), TBaseDataList::getGridLines(), TBaseDataList::getHorizontalAlign(), TBaseDataList::onSelectedIndexChanged(), TBaseDataList::setCellPadding(), TBaseDataList::setCellSpacing(), TBaseDataList::setDataKeyField(), TBaseDataList::setGridLines(), TBaseDataList::setHorizontalAlign()
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | CMD_CANCEL |
string | CMD_DELETE |
string | CMD_EDIT |
string | CMD_SELECT | Command name that TDataList understands. They are case-insensitive.
string | CMD_UPDATE |
Method Details

applyItemStyles

protected void applyItemStyles ()

Applies styles to items, header, footer and separators.

Item styles are applied in a hierarchical way. Style in higher hierarchy will inherit from styles in lower hierarchy. Starting from the lowest hierarchy, the item styles include item's own style, ItemStyle, AlternatingItemStyle, SelectedItemStyle, and EditItemStyle. Therefore, if background color is set as red in ItemStyle, EditItemStyle will also have red background color unless it is set to a different value explicitly.

Output
Exception

bubbleEvent

public boolean bubbleEvent (TControl $sender , TEventParameter $param )

This method overrides parent's implementation to handle onItemCommand event which is bubbled from datalist items and their child controls.

If the event parameter is TDataListCommandEventParameter and the command name is a recognized one, which includes 'select', 'edit', 'delete', 'update', and 'cancel' (case-insensitive), then a corresponding command event is also raised (such as OnEditCommand). This method should only be used by control developers.

Input
TControl | $sender | the sender of the event
TEventParameter | $param | event parameter
Output
boolean | whether the event bubbling should stop here.
Exception

createEmptyContent

protected void createEmptyContent ()

Creates empty datalist content.

Output
Exception

createItem

protected TControl createItem (integer $itemIndex , TListItemType $itemType )

Creates a datalist item instance based on the item type and index.

Input
integer | $itemIndex | zero-based item index
TListItemType | $itemType | item type
Output
TControl | created datalist item
Exception

generateItemStyle

public TStyle generateItemStyle (string $itemType , integer $index )

Returns a style used for rendering items.

This method is required by IRepeatInfoUser interface.

Input
string | $itemType | item type (Header,Footer,Item,AlternatingItem,SelectedItem,EditItem,Separator,Pager)
integer | $index | index of the item being rendered
Output
TStyle | item style
Exception

getAlternatingItemRenderer

public string getAlternatingItemRenderer ()

Output
string the class name for alternative datalist items. Defaults to empty, meaning not set.
Exception

getAlternatingItemStyle

public TTableItemStyle getAlternatingItemStyle ()

Output
TTableItemStyle the style for each alternating item
Exception

getAlternatingItemTemplate

public ITemplate getAlternatingItemTemplate ()

Output
ITemplate the template for each alternating item
Exception

getCaption

public string getCaption ()

Output
string caption of the table layout
Exception

getCaptionAlign

public TTableCaptionAlign getCaptionAlign ()

Output
TTableCaptionAlign alignment of the caption of the table layout. Defaults to TTableCaptionAlign::NotSet.
Exception

getEditItem

public TControl getEditItem ()

Output
TControl the edit item
Exception

getEditItemIndex

public integer getEditItemIndex ()

Output
integer the zero-based index of the edit item in Items. A value -1 means no item is in edit mode.
Exception

getEditItemRenderer

public string getEditItemRenderer ()

Output
string the class name for the datalist item being editted. Defaults to empty, meaning not set.
Exception

getEditItemStyle

public TTableItemStyle getEditItemStyle ()

Output
TTableItemStyle the style for edit item
Exception

getEditItemTemplate

public ITemplate getEditItemTemplate ()

Output
ITemplate the edit item template
Exception

getEmptyRenderer

public string getEmptyRenderer ()

Output
string the class name for empty datalist item. Defaults to empty, meaning not set.
Exception

getEmptyTemplate

public ITemplate getEmptyTemplate ()

Output
ITemplate the template applied when no data is bound to the datalist
Exception

getFooter

public TControl getFooter ()

Output
TControl the footer item
Exception

getFooterRenderer

public string getFooterRenderer ()

Output
string the class name for datalist footer item. Defaults to empty, meaning not set.
Exception

getFooterStyle

public TTableItemStyle getFooterStyle ()

Output
TTableItemStyle the style for footer
Exception

getFooterTemplate

public ITemplate getFooterTemplate ()

Output
ITemplate the footer template
Exception

getHasFooter

public boolean getHasFooter ()

Returns a value indicating whether this control contains footer item.

This method is required by IRepeatInfoUser interface.

Output
boolean whether the datalist has footer
Exception

getHasHeader

public boolean getHasHeader ()

Returns a value indicating whether this control contains header item.

This method is required by IRepeatInfoUser interface.

Output
boolean whether the datalist has header
Exception

getHasSeparators

public boolean getHasSeparators ()

Returns a value indicating whether this control contains separator items.

This method is required by IRepeatInfoUser interface.

Output
boolean always false.
Exception

getHeader

public TControl getHeader ()

Output
TControl the header item
Exception

getHeaderRenderer

public string getHeaderRenderer ()

Output
string the class name for datalist header item. Defaults to empty, meaning not set.
Exception

getHeaderStyle

public TTableItemStyle getHeaderStyle ()

Output
TTableItemStyle the style for header
Exception

getHeaderTemplate

public ITemplate getHeaderTemplate ()

Output
ITemplate the header template
Exception

getItemCount

public integer getItemCount ()

Output
integer number of items
Exception

getItemRenderer

public string getItemRenderer ()

Output
string the class name for datalist items. Defaults to empty, meaning not set.
Exception

getItems

public TDataListItemCollection getItems ()

Output
TDataListItemCollection item list
Exception

getItemStyle

public TTableItemStyle getItemStyle ()

Output
TTableItemStyle the style for item
Exception

getItemTemplate

public ITemplate getItemTemplate ()

Output
ITemplate the template for item
Exception

getRepeatColumns

public integer getRepeatColumns ()

Output
integer the number of columns that the list should be displayed with. Defaults to 0 meaning not set.
Exception

getRepeatDirection

public TRepeatDirection getRepeatDirection ()

Output
TRepeatDirection the direction of traversing the list, defaults to TRepeatDirection::Vertical
Exception

getRepeatInfo

protected TRepeatInfo getRepeatInfo ()

Output
TRepeatInfo repeat information (primarily used by control developers)
Exception

getRepeatLayout

public TRepeatLayout getRepeatLayout ()

Output
TRepeatLayout how the list should be displayed, using table or using line breaks. Defaults to TRepeatLayout::Table.
Exception

getSelectedDataKey

public mixed getSelectedDataKey ()

Output
mixed | the key value of the currently selected item
Exception
throws | TInvalidOperationException if DataKeyField is empty.

getSelectedItem

public TControl getSelectedItem ()

Output
TControl the selected item, null if no item is selected.
Exception

getSelectedItemIndex

public integer getSelectedItemIndex ()

Output
integer the zero-based index of the selected item in Items. A value -1 means no item selected.
Exception

getSelectedItemRenderer

public string getSelectedItemRenderer ()

Output
string the class name for the datalist item being selected. Defaults to empty, meaning not set.
Exception

getSelectedItemStyle

public TTableItemStyle getSelectedItemStyle ()

Output
TTableItemStyle the style for selected item
Exception

getSelectedItemTemplate

public ITemplate getSelectedItemTemplate ()

Output
ITemplate the selected item template
Exception

getSeparatorRenderer

public string getSeparatorRenderer ()

Output
string the class name for datalist item separators. Defaults to empty, meaning not set.
Exception

getSeparatorStyle

public TTableItemStyle getSeparatorStyle ()

Output
TTableItemStyle the style for separator
Exception

getSeparatorTemplate

public ITemplate getSeparatorTemplate ()

Output
ITemplate the separator template
Exception

getShowFooter

public boolean getShowFooter ()

Output
boolean whether the footer should be shown. Defaults to true.
Exception

getShowHeader

public boolean getShowHeader ()

Output
boolean whether the header should be shown. Defaults to true.
Exception

loadState

public void loadState ()

Loads item count information from viewstate.

This method is invoked right after control state is loaded.

Output
Exception

onCancelCommand

public void onCancelCommand (TDataListCommandEventParameter $param )

Raises OnCancelCommand event.

This method is invoked when a child control of the data list raises an OnCommand event and the command name is 'cancel' (case-insensitive).

Input
TDataListCommandEventParameter $param event parameter
Output
Exception

onDeleteCommand

public void onDeleteCommand (TDataListCommandEventParameter $param )

Raises OnDeleteCommand event.

This method is invoked when a child control of the data list raises an OnCommand event and the command name is 'delete' (case-insensitive).

Input
TDataListCommandEventParameter $param event parameter
Output
Exception

onEditCommand

public void onEditCommand (TDataListCommandEventParameter $param )

Raises OnEditCommand event.

This method is invoked when a child control of the data list raises an OnCommand event and the command name is 'edit' (case-insensitive).

Input
TDataListCommandEventParameter $param event parameter
Output
Exception

onItemCommand

public void onItemCommand (TDataListCommandEventParameter $param )

Raises OnItemCommand event.

This method is invoked when a child control of the data list raises an OnCommand event.

Input
TDataListCommandEventParameter $param event parameter
Output
Exception

onItemCreated

public void onItemCreated (TDataListItemEventParameter $param )

Raises OnItemCreated event.

This method is invoked after a data list item is created and instantiated with template, but before added to the page hierarchy. The datalist item control responsible for the event can be determined from the event parameter. If you override this method, be sure to call parent's implementation so that event handlers have chance to respond to the event.

Input
TDataListItemEventParameter $param event parameter
Output
Exception

onItemDataBound

public void onItemDataBound (TDataListItemEventParameter $param )

Raises OnItemDataBound event.

This method is invoked right after an item is data bound. The datalist item control responsible for the event can be determined from the event parameter. If you override this method, be sure to call parent's implementation so that event handlers have chance to respond to the event.

Input
TDataListItemEventParameter $param event parameter
Output
Exception

onUpdateCommand

public void onUpdateCommand (TDataListCommandEventParameter $param )

Raises OnUpdateCommand event.

This method is invoked when a child control of the data list raises an OnCommand event and the command name is 'update' (case-insensitive).

Input
TDataListCommandEventParameter $param event parameter
Output
Exception

performDataBinding

protected void performDataBinding (Traversable $data )

Performs databinding to populate data list items from data source.

This method is invoked by dataBind(). You may override this function to provide your own way of data population.

Input
Traversable $data the data
Output
Exception

render

public void render (THtmlWriter $writer )

Renders the data list control.

This method overrides the parent implementation.

Input
THtmlWriter $writer writer for rendering purpose.
Output
Exception

renderItem

public void renderItem (THtmlWriter $writer , TRepeatInfo $repeatInfo , string $itemType , integer $index )

Renders an item in the list.

This method is required by IRepeatInfoUser interface.

Input
THtmlWriter | $writer | writer for rendering purpose
TRepeatInfo | $repeatInfo | repeat information
string | $itemType | item type (Header,Footer,Item,AlternatingItem,SelectedItem,EditItem,Separator,Pager)
integer | $index | zero-based index of the item in the item list
Output
Exception

reset

public void reset ()

Clears up all items in the data list.

Output
Exception

restoreItemsFromViewState

protected void restoreItemsFromViewState ()

Creates data list items based on viewstate information.

Output
Exception

saveState

public void saveState ()

Saves item count in viewstate.

This method is invoked right before control state is to be saved.

Output
Exception

setAlternatingItemRenderer

public void setAlternatingItemRenderer (string $value )

Sets the alternative item renderer class.

If not empty, the class will be used to instantiate as alternative datalist items. This property takes precedence over AlternatingItemTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setAlternatingItemTemplate

public void setAlternatingItemTemplate (ITemplate $value )

Input
ITemplate | $value | the template for each alternating item
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setCaption

public void setCaption (string $value )

Input
string $value caption of the table layout
Output
Exception

setCaptionAlign

public TTableCaptionAlign setCaptionAlign (mixed $value )

Input
mixed | $value
Output
TTableCaptionAlign | alignment of the caption of the table layout.
Exception

setEditItemIndex

public void setEditItemIndex (integer $value )

Edits an item by its index in getItems.

Previously editting item will change to normal item state. If the index is less than 0, any existing edit item will be cleared up.

Input
integer $value the edit item index
Output
Exception

setEditItemRenderer

public void setEditItemRenderer (string $value )

Sets the renderer class for the datalist item being editted.

If not empty, the class will be used to instantiate as the datalist item. This property takes precedence over EditItemTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setEditItemTemplate

public void setEditItemTemplate (ITemplate $value )

Input
ITemplate | $value | the edit item template
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setEmptyRenderer

public void setEmptyRenderer (string $value )

Sets the datalist empty renderer class.

The empty renderer is created as the child of the datalist if data bound to the datalist is empty. This property takes precedence over EmptyTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setEmptyTemplate

public void setEmptyTemplate (ITemplate $value )

Input
ITemplate | $value | the template applied when no data is bound to the datalist
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setFooterRenderer

public void setFooterRenderer (string $value )

Sets the datalist footer renderer class.

If not empty, the class will be used to instantiate as datalist footer item. This property takes precedence over FooterTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setFooterTemplate

public void setFooterTemplate (ITemplate $value )

Input
ITemplate | $value | the footer template
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setHeaderRenderer

public void setHeaderRenderer (string $value )

Sets the datalist header renderer class.

If not empty, the class will be used to instantiate as datalist header item. This property takes precedence over HeaderTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setHeaderTemplate

public void setHeaderTemplate (ITemplate $value )

Input
ITemplate | $value | the header template
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setItemRenderer

public void setItemRenderer (string $value )

Sets the item renderer class.

If not empty, the class will be used to instantiate as datalist items. This property takes precedence over ItemTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setItemTemplate

public void setItemTemplate (ITemplate $value )

Input
ITemplate | $value | the template for item
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setRepeatColumns

public void setRepeatColumns (integer $value )

Input
integer $value the number of columns that the list should be displayed with.
Output
Exception

setRepeatDirection

public void setRepeatDirection (TRepeatDirection $value )

Input
TRepeatDirection $value the direction of traversing the list
Output
Exception

setRepeatLayout

public void setRepeatLayout (TRepeatLayout $value )

Input
TRepeatLayout $value how the list should be displayed, using table or using line breaks
Output
Exception

setSelectedItemIndex

public void setSelectedItemIndex (integer $value )

Selects an item by its index in getItems.

Previously selected item will be un-selected. If the item to be selected is already in edit mode, it will remain in edit mode. If the index is less than 0, any existing selection will be cleared up.

Input
integer $value the selected item index
Output
Exception

setSelectedItemRenderer

public void setSelectedItemRenderer (string $value )

Sets the renderer class for the datalist item being selected.

If not empty, the class will be used to instantiate as the datalist item. This property takes precedence over SelectedItemTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setSelectedItemTemplate

public void setSelectedItemTemplate (ITemplate $value )

Input
ITemplate | $value | the selected item template
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setSeparatorRenderer

public void setSeparatorRenderer (string $value )

Sets the datalist item separator renderer class.

If not empty, the class will be used to instantiate as datalist item separators. This property takes precedence over SeparatorTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setSeparatorTemplate

public void setSeparatorTemplate (ITemplate $value )

Input
ITemplate | $value | the separator template
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setShowFooter

public void setShowFooter (boolean $value )

Input
boolean $value whether to show footer
Output
Exception

setShowHeader

public void setShowHeader (boolean $value )

Input
boolean $value whether to show header
Output
Exception

Constant Details

CMD_CANCEL

Type:

string

Value:

'Cancel'

CMD_DELETE

Type:

string

Value:

'Delete'

CMD_EDIT

Type:

string

Value:

'Edit'

CMD_SELECT

Command name that TDataList understands. They are case-insensitive.

Type:

string

Value:

'Select'

CMD_UPDATE

Type:

string

Value:

'Update'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataListCommandEventParameter

Class TDataListCommandEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TCommandEventParameter
         |
         --TDataListCommandEventParameter

TDataListCommandEventParameter class

TDataListCommandEventParameter encapsulates the parameter data for TDataList::onItemCommand event of TDataList controls.

The Item property indicates the DataList item related with the event. The CommandSource refers to the control that originally raises the Command event.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
TControl | getCommandSource ()
TControl | getItem ()
Methods Inherited From TCommandEventParameter
TCommandEventParameter::getCommandName(), TCommandEventParameter::getCommandParameter()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getCommandSource

public TControl getCommandSource ()

Output
TControl the control originally raises the OnCommand event.
Exception

getItem

public TControl getItem ()

Output
TControl the datalist item control responsible for the event.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataListItem

Class TDataListItem (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataListItem

TDataListItem class

A TDataListItem control represents an item in the TDataList control, such as heading section, footer section, or a data item. The index and data value of the item can be accessed via ItemIndex> and DataItem properties, respectively. The type of the item is given by ItemType property.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
boolean | bubbleEvent ( TControl $sender, TEventParameter $param) This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
protected TStyle | createStyle () Creates a style object for the control.
mixed | getData ()
mixed | getDataItem () This property is deprecated since v3.1.0.
integer | getItemIndex ()
TListItemType | getItemType ()
protected string | getTagName () Returns the tag name used for this control.
void | setData ( mixed $value)
void | setDataItem ( mixed $value) This property is deprecated since v3.1.0.
void | setItemIndex ( integer $value) Sets the zero-based index for the item.
void | setItemType ( TListItemType $value)
void | setTagName ( string $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

bubbleEvent

public boolean bubbleEvent (TControl $sender , TEventParameter $param )

This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

Input
TControl | $sender | the sender of the event
TEventParameter | $param | event parameter
Output
boolean | whether the event bubbling should stop here.
Exception

createStyle

protected TStyle createStyle ()

Creates a style object for the control.

This method creates a TTableItemStyle to be used by a datalist item.

Output
TStyle control style to be used
Exception

getData

public mixed getData ()

Output
mixed data associated with the item
Exception

getDataItem

public mixed getDataItem ()

This property is deprecated since v3.1.0.

Output
mixed data associated with the item
Exception

getItemIndex

public integer getItemIndex ()

Output
integer zero-based index of the item in the item collection of datalist
Exception

getItemType

public TListItemType getItemType ()

Output
TListItemType item type
Exception

getTagName

protected string getTagName ()

Returns the tag name used for this control.

Output
string tag name of the control to be rendered
Exception

setData

public void setData (mixed $value )

Input
mixed $value data to be associated with the item
Output
Exception

setDataItem

public void setDataItem (mixed $value )

This property is deprecated since v3.1.0.

Input
mixed $value data to be associated with the item
Output
Exception

setItemIndex

public void setItemIndex (integer $value )

Sets the zero-based index for the item.

If the item is not in the item collection (e.g. it is a header item), -1 should be used.

Input
integer $value zero-based index of the item.
Output
Exception

setItemType

public void setItemType (TListItemType $value )

Input
TListItemType $value item type.
Output
Exception

setTagName

public void setTagName (string $value )

Input
string $value tag name of the control to be rendered
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataListItemCollection

Class TDataListItemCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TDataListItemCollection

TDataListItemCollection class.

TDataListItemCollection represents a collection of data list items.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void
insertAt ( integer $index, mixed $item)
Inserts an item at the specified position.
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by inserting only TControl descendants.

Input
integer | $index | the speicified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is not a TControl descendant.


PRADO API Manual: Docs For Class TDataListItemEventParameter

Class TDataListItemEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TDataListItemEventParameter

TDataListItemEventParameter class

TDataListItemEventParameter encapsulates the parameter data for TDataList::onItemCreated event of TDataList controls. The Item property indicates the DataList item related with the event.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
TControl
getItem ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getItem

public TControl getItem ()

Output
TControl datalist item related with the corresponding event
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataListItemRenderer

Class TDataListItemRenderer (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TDataRenderer
                  |
                  --TItemDataRenderer
                     |
                     --TDataListItemRenderer

TDataListItemRenderer class

TDataListItemRenderer can be used as a convenient base class to define an item renderer class specific for TDataList.

TDataListItemRenderer extends TItemDataRenderer and implements the bubbling scheme for the OnCommand event of data list items.

TDataListItemRenderer also implements the IStyleable interface, which allows TDataList to apply CSS styles to the renders.

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TTemplateControl
EXT_TEMPLATE,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute name-value pairs to renderer.
boolean | bubbleEvent ( TControl $sender, TEventParameter $param) This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
void | clearStyle () Removes all style data.
protected TStyle | createStyle () Creates a style object to be used by the control.
boolean | getHasStyle ()
TStyle | getStyle ()
protected string | getTagName () Returns the tag name used for this control.
void | render ( THtmlWriter $writer) Renders the control.
void | renderBeginTag ( THtmlWriter $writer) Renders the openning tag for the control (including attributes) This method is invoked when getTagName is not empty.
void | renderContents ( THtmlWriter $writer) Renders the body content enclosed between the control tag.
void | renderEndTag ( THtmlWriter $writer) Renders the closing tag for the control This method is invoked when getTagName is not empty.
Methods Inherited From TItemDataRenderer
TItemDataRenderer::getItemIndex(), TItemDataRenderer::getItemType(), TItemDataRenderer::setItemIndex(), TItemDataRenderer::setItemType()
Methods Inherited From TDataRenderer
TDataRenderer::getData(), TDataRenderer::setData()
Methods Inherited From TTemplateControl
TTemplateControl::createChildControls(), TTemplateControl::getIsSourceTemplateControl(), TTemplateControl::getMaster(), TTemplateControl::getMasterClass(), TTemplateControl::getTemplate(), TTemplateControl::getTemplateDirectory(), TTemplateControl::initRecursive(), TTemplateControl::injectContent(), TTemplateControl::loadTemplate(), TTemplateControl::registerContent(), TTemplateControl::registerContentPlaceHolder(), TTemplateControl::setMasterClass(), TTemplateControl::setTemplate()
Methods Inherited From TCompositeControl
TCompositeControl::initRecursive()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute name-value pairs to renderer.

By default, this method renders the style string. The method can be overriden to provide customized attribute rendering.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

bubbleEvent

public boolean bubbleEvent (TControl $sender , TEventParameter $param )

This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

Input
TControl | $sender | the sender of the event
TEventParameter | $param | event parameter
Output
boolean | whether the event bubbling should stop here.
Exception

clearStyle

public void clearStyle ()

Removes all style data.

Output
Exception

createStyle

protected TStyle createStyle ()

Creates a style object to be used by the control.

This method may be overriden by controls to provide customized style.

Output
Exception

getHasStyle

public boolean getHasStyle ()

Output
boolean whether the control has defined any style information
Exception

getStyle

public TStyle getStyle ()

Output
TStyle the object representing the css style of the control
Exception

getTagName

protected string getTagName ()

Returns the tag name used for this control.

By default, the tag name is 'span'. You can override this method to provide customized tag names. If the tag name is empty, the opening and closing tag will NOT be rendered.

Output
string tag name of the control to be rendered
Exception

render

public void render (THtmlWriter $writer )

Renders the control.

This method overrides the parent implementation by replacing it with the following sequence:

  • renderBeginTag
  • renderContents
  • renderEndTag
If the TagName is empty, only renderContents is invoked.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderBeginTag

public void renderBeginTag (THtmlWriter $writer )

Renders the openning tag for the control (including attributes) This method is invoked when getTagName is not empty.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders the body content enclosed between the control tag.

By default, child controls and text strings will be rendered. You can override this method to provide customized content rendering.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderEndTag

public void renderEndTag (THtmlWriter $writer )

Renders the closing tag for the control This method is invoked when getTagName is not empty.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataRenderer

Class TDataRenderer (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TDataRenderer

Direct Known Sub-classes:

TItemDataRenderer

TDataRenderer class

TDataRenderer is the convenient base class for template-based renderer controls. It extends TTemplateControl and implements the methods required by the IDataRenderer interface.

The following property is provided by TDataRenderer:

  • Data: data associated with this renderer.

Since: 3.1.2
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TTemplateControl
EXT_TEMPLATE,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
mixed | getData ()
void | setData ( mixed $value)
Methods Inherited From TTemplateControl
TTemplateControl::createChildControls(), TTemplateControl::getIsSourceTemplateControl(), TTemplateControl::getMaster(), TTemplateControl::getMasterClass(), TTemplateControl::getTemplate(), TTemplateControl::getTemplateDirectory(), TTemplateControl::initRecursive(), TTemplateControl::injectContent(), TTemplateControl::loadTemplate(), TTemplateControl::registerContent(), TTemplateControl::registerContentPlaceHolder(), TTemplateControl::setMasterClass(), TTemplateControl::setTemplate()
Methods Inherited From TCompositeControl
TCompositeControl::initRecursive()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getData

public mixed getData ()

Output
mixed data associated with the item
Exception

setData

public void setData (mixed $value )

Input
mixed $value data to be associated with the item
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IDataSource

Interface IDataSource (Class Overview)

IDataSource class

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
void | getView ( mixed $viewName)
void | getViewNames ()
void | onDataSourceChanged ( mixed $param)

            Method Details

getView

                                public void getView
                                (mixed $viewName )

Input

mixed $viewName

Output

Exception

getViewNames

                                public void getViewNames
                                ()

Output

Exception

onDataSourceChanged

                                public void onDataSourceChanged
                                (mixed $param )

Input

mixed $param

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataSourceControl

Class TDataSourceControl (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TDataSourceControl

Direct Known Sub-classes:

TReadOnlyDataSource

TDataSourceControl class

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | focus ()
void | getEnableTheming ()
void | getSkinID ()
void | getView ( mixed $viewName)
void | getViewNames ()
void | getVisible ( mixed $checkParents)
void | onDataSourceChanged ( mixed $param)
void | setEnableTheming ( mixed $value)
void | setSkinID ( mixed $value)
void | setVisible ( mixed $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

focus

public void focus ()

Output
Exception

getEnableTheming

public void getEnableTheming ()

Output
Exception

getSkinID

public void getSkinID ()

Output
Exception

getView

public void getView (mixed $viewName )

Input
mixed $viewName
Output
Exception

getViewNames

public void getViewNames ()

Output
Exception

getVisible

public void getVisible (mixed $checkParents )

Input
mixed $checkParents
Output
Exception

onDataSourceChanged

public void onDataSourceChanged (mixed $param )

Input
mixed $param
Output
Exception

setEnableTheming

public void setEnableTheming (mixed $value )

Input
mixed $value
Output
Exception

setSkinID

public void setSkinID (mixed $value )

Input
mixed $value
Output
Exception

setVisible

public void setVisible (mixed $value )

Input
mixed $value
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TReadOnlyDataSource

Class TReadOnlyDataSource (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TDataSourceControl
            |
            --TReadOnlyDataSource

TDataSourceControl class

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct Array
Method Summary
void
getView ( mixed $viewName)
Methods Inherited From TDataSourceControl
TDataSourceControl::focus(), TDataSourceControl::getEnableTheming(), TDataSourceControl::getSkinID(), TDataSourceControl::getView(), TDataSourceControl::getViewNames(), TDataSourceControl::getVisible(), TDataSourceControl::onDataSourceChanged(), TDataSourceControl::setEnableTheming(), TDataSourceControl::setSkinID(), TDataSourceControl::setVisible()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct Array

Method Details

getView

public void getView (mixed $viewName )

Input
mixed $viewName
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataSourceSelectParameters

Class TDataSourceSelectParameters (Class Overview)

TComponent
   |
   --TDataSourceSelectParameters

TDataSourceSelectParameters class

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | getMaximumRows ()
void | getRetrieveTotalRowCount ()
void | getStartRowIndex ()
void | getTotalRowCount ()
void | setMaximumRows ( mixed $value)
void | setRetrieveTotalRowCount ( mixed $value)
void | setStartRowIndex ( mixed $value)
void | setTotalRowCount ( mixed $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getMaximumRows

public void getMaximumRows ()

Output
Exception

getRetrieveTotalRowCount

public void getRetrieveTotalRowCount ()

Output
Exception

getStartRowIndex

public void getStartRowIndex ()

Output
Exception

getTotalRowCount

public void getTotalRowCount ()

Output
Exception

setMaximumRows

public void setMaximumRows (mixed $value )

Input
mixed $value
Output
Exception

setRetrieveTotalRowCount

public void setRetrieveTotalRowCount (mixed $value )

Input
mixed $value
Output
Exception

setStartRowIndex

public void setStartRowIndex (mixed $value )

Input
mixed $value
Output
Exception

setTotalRowCount

public void setTotalRowCount (mixed $value )

Input
mixed $value
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataSourceView

Class TDataSourceView (Class Overview)

TComponent
   |
   --TDataSourceView

Direct Known Sub-classes:

TReadOnlyDataSourceView

TDataSourceView class

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Method Summary
integer | delete ( array|TMap $keys) Deletes DB row(s) with the specified keys.
void | getCanDelete ()
void | getCanGetRowCount ()
void | getCanInsert ()
void | getCanPage ()
void | getCanSort ()
void | getCanUpdate ()
void | getDataSource ()
void | getName ()
integer | insertAt ( array|TMap $values) Inserts a DB record.
void | onDataSourceViewChanged ( mixed $param)
abstract Traversable | select ( ??? $parameters) Performs DB selection based on specified parameters.
integer | update ( array|TMap $keys, array|TMap $values) Updates DB record(s) with the specified keys and new values
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Method Details

delete

public integer delete (array|TMap $keys )

Deletes DB row(s) with the specified keys.

Input
array|TMap | $keys | keys for specifying the rows to be deleted
Output
integer | affected rows
Exception

getCanDelete

public void getCanDelete ()

Output
Exception

getCanGetRowCount

public void getCanGetRowCount ()

Output
Exception

getCanInsert

public void getCanInsert ()

Output
Exception

getCanPage

public void getCanPage ()

Output
Exception

getCanSort

public void getCanSort ()

Output
Exception

getCanUpdate

public void getCanUpdate ()

Output
Exception

getDataSource

public void getDataSource ()

Output
Exception

getName

public void getName ()

Output
Exception

insertAt

public integer insertAt (array|TMap $values )

Inserts a DB record.

Input
array|TMap | $values
Output
integer | affected rows
Exception

onDataSourceViewChanged

public void onDataSourceViewChanged (mixed $param )

Input
mixed $param
Output
Exception

select

public abstract Traversable select (??? $parameters )

Performs DB selection based on specified parameters.

Input
??? $parameters
Output
Exception

update

public integer update (array|TMap $keys , array|TMap $values )

Updates DB record(s) with the specified keys and new values

Input
array|TMap | $keys | keys for specifying the records to be updated
array|TMap | $values | new values
Output
integer | affected rows
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TReadOnlyDataSourceView

Class TReadOnlyDataSourceView (Class Overview)

TComponent
   |
   --TDataSourceView
      |
      --TReadOnlyDataSourceView

TReadOnlyDataSourceView class

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Method Summary
void
select ( mixed $parameters)
Methods Inherited From TDataSourceView
TDataSourceView::delete(), TDataSourceView::getCanDelete(), TDataSourceView::getCanGetRowCount(), TDataSourceView::getCanInsert(), TDataSourceView::getCanPage(), TDataSourceView::getCanSort(), TDataSourceView::getCanUpdate(), TDataSourceView::getDataSource(), TDataSourceView::getName(), TDataSourceView::insertAt(), TDataSourceView::onDataSourceViewChanged(), TDataSourceView::update()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Method Details

select

public void select (mixed $parameters )

Input
mixed $parameters
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataTypeValidator

Class TDataTypeValidator (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TDataTypeValidator

TDataTypeValidator class

TDataTypeValidator verifies if the input data is of the type specified by DataType. The following data types are supported:

  • Integer A 32-bit signed integer data type.
  • Float A double-precision floating point number data type.
  • Date A date data type.
  • String A string data type.
For Date type, the property DateFormat will be used to determine how to parse the date string. If it is not provided, the string will be assumed to be in GNU datetime format.

Since: 3.0
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected boolean | evaluateDataTypeCheck ( string $value) Determine if the given value is of a particular type using RegExp.
boolean | evaluateIsValid () This method overrides the parent's implementation.
protected string | getClientClassName () Gets the name of the javascript class responsible for performing validation for this control.
protected array | getClientScriptOptions () Returns an array of javascript validator options.
TValidationDataType | getDataType ()
string | getDateFormat ()
void | setDataType ( TValidationDataType $value) Sets the data type that the values being compared are converted to before the comparison is made.
void | setDateFormat ( string $value) Sets the date format for a date validation
Methods Inherited From TBaseValidator
TBaseValidator::addAttributesToRender(), TBaseValidator::createClientSide(), TBaseValidator::getClientScriptOptions(), TBaseValidator::getClientSide(), TBaseValidator::getControlCssClass(), TBaseValidator::getControlToValidate(), TBaseValidator::getDisplay(), TBaseValidator::getEnableClientScript(), TBaseValidator::getErrorMessage(), TBaseValidator::getFocusElementID(), TBaseValidator::getFocusOnError(), TBaseValidator::getIsValid(), TBaseValidator::getValidationGroup(), TBaseValidator::getValidationTarget(), TBaseValidator::getValidationValue(), TBaseValidator::onInit(), TBaseValidator::onPreRender(), TBaseValidator::onUnload(), TBaseValidator::onValidate(), TBaseValidator::onValidationError(), TBaseValidator::onValidationSuccess(), TBaseValidator::registerClientScriptValidator(), TBaseValidator::renderClientControlScript(), TBaseValidator::renderContents(), TBaseValidator::setControlCssClass(), TBaseValidator::setControlToValidate(), TBaseValidator::setDisplay(), TBaseValidator::setEnableClientScript(), TBaseValidator::setEnabled(), TBaseValidator::setErrorMessage(), TBaseValidator::setFocusElementID(), TBaseValidator::setFocusOnError(), TBaseValidator::setForControl(), TBaseValidator::setIsValid(), TBaseValidator::setValidationGroup(), TBaseValidator::updateControlCssClass(), TBaseValidator::validate()
Methods Inherited From TLabel
TLabel::addAttributesToRender(), TLabel::getData(), TLabel::getForControl(), TLabel::getTagName(), TLabel::getText(), TLabel::render(), TLabel::renderContents(), TLabel::setData(), TLabel::setForControl(), TLabel::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

evaluateDataTypeCheck

protected boolean evaluateDataTypeCheck (string $value )

Determine if the given value is of a particular type using RegExp.

Input
string | $value | value to check
Output
boolean | true if value fits the type expression.
Exception

evaluateIsValid

public boolean evaluateIsValid ()

This method overrides the parent's implementation.

The validation succeeds if the input data is of valid type. The validation always succeeds if ControlToValidate is not specified or the input data is empty.

Output
boolean whether the validation succeeds
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing validation for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientScriptOptions

protected array getClientScriptOptions ()

Returns an array of javascript validator options.

Output
array javascript validator options.
Exception

getDataType

public TValidationDataType getDataType ()

Output
TValidationDataType the data type that the values being compared are converted to before the comparison is made. Defaults to TValidationDataType::String.
Exception

getDateFormat

public string getDateFormat ()

Output
string the date validation date format if any
Exception

setDataType

public void setDataType (TValidationDataType $value )

Sets the data type that the values being compared are converted to before the comparison is made.

Input
TValidationDataType $value the data type
Output
Exception

setDateFormat

public void setDateFormat (string $value )

Sets the date format for a date validation

Input
string $value the date format value
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDatePicker

Class TDatePicker (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --TDatePicker

Direct Known Sub-classes:

TActiveDatePicker

TDatePicker class.

TDatePicker displays a text box for date input purpose. When the text box receives focus, a calendar will pop up and users can pick up from it a date that will be automatically entered into the text box. The format of the date string displayed in the text box is determined by the DateFormat property. Valid formats are the combination of the following tokens,

1       Character Format Pattern (en-US)
2       -----------------------------------------
3       d          day digit
4       dd         padded day digit e.g. 01, 02
5       M          month digit
6       MM         padded month digit
7       MMMM       localized month name, e.g. March, April
8       yy         2 digit year
9       yyyy       4 digit year
10      -----------------------------------------

TDatePicker has three Mode to show the date picker popup.

  • Basic -- Only shows a text input, focusing on the input shows the date picker.
  • Button -- Shows a button next to the text input, clicking on the button shows the date, button text can be by the ButtonText property
  • ImageButton -- Shows an image next to the text input, clicking on the image shows the date picker, image source can be change through the ButtonImageUrl property.
The CssClass property can be used to override the css class name for the date picker panel. CalendarStyle property sets the packages styles available. E.g. default.

The InputMode property can be set to "TextBox" or "DropDownList" with default as "TextBox". In <tt>DropDownList</tt> mode, in addition to the popup date picker, three drop down list (day, month and year) are presented to select the date .

The PositionMode property can be set to "Top" or "Bottom" with default as "Bottom". It specifies the position of the calendar popup, relative to the input field.

Since: 3.0
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Author: Carl G. Mathisen <carlgmathisen@gmail.com>
Constants Inherited From TTextBox
DEFAULT_COLUMNS, DEFAULT_ROWS,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Add the client id to the input textbox, and register the client scripts.
protected TDatePickerClientScript | createClientScript ()
protected string | getAssetUrl ( string $file)
string | getButtonImageUrl ()
string | getButtonText ()
string | getCalendarStyle ()
TDatePickerClientScript | getClientSide () Gets the TDatePickerClientScript to set the TDatePicker event handlers.
protected array | getCulturalOptions () Get javascript localization options, e.g. month and weekday names.
string | getCulture () Gets the current culture.
protected string | getCurrentCulture ()
integer | getData () Returns the timestamp selected by the user.
string | getDate ()
string | getDateFormat ()
protected array | getDateFromPostData ( string $key, array $values) Loads date from drop down list data.
protected string | getDatePickerButtonID () Gets the ID for the date picker trigger button.
protected array | getDatePickerOptions () Get javascript date picker options.
protected array | getDropDownDayOptions ()
integer | getFirstDayOfWeek ()
integer | getFromYear ()
TDatePickerInputMode | getInputMode ()
protected DateTimeFormatInfo | getLocalizedCalendarInfo ()
protected array | getLocalizedMonthNames ( DateTimeFormatInfo $info) Returns the localized month names that depends on the month format pattern.
TDatePickerMode | getMode ()
TDatePickerPositionMode | getPositionMode ()
boolean | getShowCalendar ()
integer | getTimeStamp ()
protected integer | getTimeStampFromText () Gets the date from the text input using TSimpleDateFormatter
integer | getUpToYear ()
integer | getValidationPropertyValue () Returns the value to be validated.
protected void | hasDayPattern ()
boolean | loadPostData ( string $key, array $values) Loads user input data. Override parent implementation, when InputMode is DropDownList call getDateFromPostData to get date data.
void | onPreRender ( mixed $param) Publish the date picker Css asset files.
protected string | publishCalendarStyle () Publish the calendar style Css asset file.
protected void | registerCalendarClientScript () Registers the javascript code to initialize the date picker.
void | render ( THtmlWriter $writer) Renders body content.
protected THtmlWriter | renderButtonDatePicker ( mixed $writer) Adds an additional button such that when clicked it shows the date picker.
protected void | renderCalendarDayOptions ( THtmlWriter $writer, mixed $selected) Renders the day drop down list options.
protected void | renderCalendarMonthOptions ( THtmlWriter $writer, mixed $selected) Renders the month drop down list options.
protected void | renderCalendarSelections ( THtmlWriter $writer, array $date) Renders the calendar drop down list depending on the DateFormat pattern.
protected void | renderCalendarYearOptions ( THtmlWriter $writer, mixed $selected) Renders the year drop down list options.
protected void | renderDatePickerButtons ( mixed $writer) Renders the date picker popup buttons.
protected void | renderDropDownListCalendar ( mixed $writer) Renders the drop down list date picker.
protected THtmlWriter | renderImageButtonDatePicker ( mixed $writer) Adds an additional image button such that when clicked it shows the date picker.
void | setAutoPostBack ( mixed $value) AutoPostBack is not supported.
void | setButtonImageUrl ( string $value)
void | setButtonText ( string $value)
void | setCalendarStyle ( string $value)
void | setCulture ( string $value) Sets the culture/language for the date picker.
void | setData ( integer $value) Sets the timestamp represented by this control.
void | setDate ( string $value)
void | setDateFormat ( string $value) Sets the format of the date string.
void | setFirstDayOfWeek ( integer $value) Set the first day of week, with 0 as Sunday, 1 as Monday, etc.
void | setFromYear ( integer $value)
void | setInputMode ( TDatePickerInputMode $value)
void | setMode ( TDatePickerMode $value)
void | setPositionMode ( TDatePickerPositionMode $value)
void | setShowCalendar ( boolean $value) Sets whether to pop up the calendar window when the control receives focus
void | setTimeStamp ( float $value) Sets the date for the date picker using timestamp.
void | setUpToYear ( integer $value)
Methods Inherited From TTextBox
TTextBox::addAttributesToRender(), TTextBox::getAutoCompleteType(), TTextBox::getAutoPostBack(), TTextBox::getAutoTrim(), TTextBox::getCausesValidation(), TTextBox::getClientClassName(), TTextBox::getColumns(), TTextBox::getData(), TTextBox::getDataChanged(), TTextBox::getEnableClientScript(), TTextBox::getIsValid(), TTextBox::getMaxLength(), TTextBox::getPersistPassword(), TTextBox::getPostBackOptions(), TTextBox::getReadOnly(), TTextBox::getRows(), TTextBox::getSafeText(), TTextBox::getSafeTextParser(), TTextBox::getTagName(), TTextBox::getText(), TTextBox::getTextMode(), TTextBox::getValidationGroup(), TTextBox::getValidationPropertyValue(), TTextBox::getWrap(), TTextBox::loadPostData(), TTextBox::onTextChanged(), TTextBox::raisePostDataChangedEvent(), TTextBox::renderBeginTag(), TTextBox::renderClientControlScript(), TTextBox::renderContents(), TTextBox::setAutoCompleteType(), TTextBox::setAutoPostBack(), TTextBox::setAutoTrim(), TTextBox::setCausesValidation(), TTextBox::setColumns(), TTextBox::setData(), TTextBox::setEnableClientScript(), TTextBox::setIsValid(), TTextBox::setMaxLength(), TTextBox::setPersistPassword(), TTextBox::setReadOnly(), TTextBox::setRows(), TTextBox::setText(), TTextBox::setTextMode(), TTextBox::setValidationGroup(), TTextBox::setWrap()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string SCRIPT_PATH Script path relative to the TClientScriptManager::SCRIPT_PATH
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Add the client id to the input textbox, and register the client scripts.

Input
THtmlWriter $writer writer
Output
Exception

createClientScript

protected TDatePickerClientScript createClientScript ()

Output
TDatePickerClientScript javascript validator event options.
Exception

getAssetUrl

protected string getAssetUrl (string $file )

Input
string | $file | date picker asset file in the self::SCRIPT_PATH directory.
Output
string | date picker asset url.
Exception

getButtonImageUrl

public string getButtonImageUrl ()

Output
string the image url for "Image" UI mode.
Exception

getButtonText

public string getButtonText ()

Output
string text for the date picker button. Default is "...".
Exception

getCalendarStyle

public string getCalendarStyle ()

Output
string current calendar style
Exception

getClientSide

public TDatePickerClientScript getClientSide ()

Gets the TDatePickerClientScript to set the TDatePicker event handlers.

The date picker on the client-side supports the following events.

  • <tt>OnDateChanged</tt> -- raised when the date is changed.
You can attach custom javascript code to each of these events

Output
TDatePickerClientScript javascript validator event options.
Exception

getCulturalOptions

protected array getCulturalOptions ()

Get javascript localization options, e.g. month and weekday names.

Output
array localization options.
Exception

getCulture

public string getCulture ()

Gets the current culture.

Output
string current culture, e.g. en_AU.
Exception

getCurrentCulture

protected string getCurrentCulture ()

Output
string the current culture, falls back to application if culture is not set.
Exception

getData

public integer getData ()

Returns the timestamp selected by the user.

This method is required by IDataRenderer. It is the same as getTimeStamp().

Output
integer the timestamp of the TDatePicker control.
Exception

getDate

public string getDate ()

Output
string the date string.
Exception

getDateFormat

public string getDateFormat ()

Output
string the format of the date string
Exception

getDateFromPostData

protected array getDateFromPostData (string $key , array $values )

Loads date from drop down list data.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
array | the date selected
Exception

getDatePickerButtonID

protected string getDatePickerButtonID ()

Gets the ID for the date picker trigger button.

Output
string unique button ID
Exception

getDatePickerOptions

protected array getDatePickerOptions ()

Get javascript date picker options.

Output
array date picker client-side options
Exception

getDropDownDayOptions

protected array getDropDownDayOptions ()

Output
array list of day options for a drop down list.
Exception

getFirstDayOfWeek

public integer getFirstDayOfWeek ()

Output
integer first day of the week
Exception

getFromYear

public integer getFromYear ()

Output
integer date picker starting year, default is -5 years
Exception

getInputMode

public TDatePickerInputMode getInputMode ()

Output
TDatePickerInputMode input method of date values. Defaults to TDatePickerInputMode::TextBox.
Exception

getLocalizedCalendarInfo

protected DateTimeFormatInfo getLocalizedCalendarInfo ()

Output
DateTimeFormatInfo date time format information for the current culture.
Exception

getLocalizedMonthNames

protected array getLocalizedMonthNames (DateTimeFormatInfo $info )

Returns the localized month names that depends on the month format pattern.

"MMMM" will return the month names, "MM" or "MMM" return abbr. month names and "M" return month digits.

Input
DateTimeFormatInfo | $info | localized date format information.
Output
array | localized month names.
Exception

getMode

public TDatePickerMode getMode ()

Output
TDatePickerMode current calendar UI mode.
Exception

getPositionMode

public TDatePickerPositionMode getPositionMode ()

Output
TDatePickerPositionMode current calendar UI position.
Exception

getShowCalendar

public boolean getShowCalendar ()

Output
boolean whether the calendar window should pop up when the control receives focus
Exception

getTimeStamp

public integer getTimeStamp ()

Output
integer current selected date from the date picker as timestamp, NULL if timestamp is not set previously.
Exception

getTimeStampFromText

protected integer getTimeStampFromText ()

Gets the date from the text input using TSimpleDateFormatter

Output
integer current selected date timestamp
Exception

getUpToYear

public integer getUpToYear ()

Output
integer date picker ending year, default +10 years
Exception

getValidationPropertyValue

public integer getValidationPropertyValue ()

Returns the value to be validated.

This methid is required by IValidatable interface.

Output
integer the interger timestamp if valid, otherwise the original text.
Exception

hasDayPattern

protected void hasDayPattern ()

Output
Exception

loadPostData

public boolean loadPostData (string $key , array $values )

Loads user input data. Override parent implementation, when InputMode is DropDownList call getDateFromPostData to get date data.

This method is primarly used by framework developers.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the component has been changed
Exception

onPreRender

public void onPreRender (mixed $param )

Publish the date picker Css asset files.

Input
mixed $param
Output
Exception

publishCalendarStyle

protected string publishCalendarStyle ()

Publish the calendar style Css asset file.

Output
string Css file url.
Exception

registerCalendarClientScript

protected void registerCalendarClientScript ()

Registers the javascript code to initialize the date picker.

Output
Exception

render

public void render (THtmlWriter $writer )

Renders body content.

This method overrides parent implementation by adding additional date picker button if Mode is Button or ImageButton.

Input
THtmlWriter $writer writer
Output
Exception

renderButtonDatePicker

protected THtmlWriter renderButtonDatePicker (mixed $writer )

Adds an additional button such that when clicked it shows the date picker.

Input
mixed | $writer
Output
THtmlWriter | writer
Exception

renderCalendarDayOptions

protected void renderCalendarDayOptions (THtmlWriter $writer , mixed $selected )

Renders the day drop down list options.

Input
THtmlWriter | $writer | the writer used for the rendering purpose
mixed | $selected | selected day.
Output
Exception

renderCalendarMonthOptions

protected void renderCalendarMonthOptions (THtmlWriter $writer , mixed $selected )

Renders the month drop down list options.

Input
THtmlWriter | $writer | the writer used for the rendering purpose
mixed | $selected | selected month.
Output
Exception

renderCalendarSelections

protected void renderCalendarSelections (THtmlWriter $writer , array $date )

Renders the calendar drop down list depending on the DateFormat pattern.

Input
THtmlWriter | $writer | the Html writer to render the drop down lists.
array | $date | the current selected date
Output
Exception

renderCalendarYearOptions

protected void renderCalendarYearOptions (THtmlWriter $writer , mixed $selected )

Renders the year drop down list options.

Input
THtmlWriter | $writer | the writer used for the rendering purpose
mixed | $selected | selected year.
Output
Exception

renderDatePickerButtons

protected void renderDatePickerButtons (mixed $writer )

Renders the date picker popup buttons.

Input
mixed $writer
Output
Exception

renderDropDownListCalendar

protected void renderDropDownListCalendar (mixed $writer )

Renders the drop down list date picker.

Input
mixed $writer
Output
Exception

renderImageButtonDatePicker

protected THtmlWriter renderImageButtonDatePicker (mixed $writer )

Adds an additional image button such that when clicked it shows the date picker.

Input
mixed | $writer
Output
THtmlWriter | writer
Exception

setAutoPostBack

public void setAutoPostBack (mixed $value )

AutoPostBack is not supported.

Input
mixed $value
Output
Exception

setButtonImageUrl

public void setButtonImageUrl (string $value )

Input
string $value the image url for "Image" UI mode.
Output
Exception

setButtonText

public void setButtonText (string $value )

Input
string $value text for the date picker button
Output
Exception

setCalendarStyle

public void setCalendarStyle (string $value )

Input
string $value set the calendar style
Output
Exception

setCulture

public void setCulture (string $value )

Sets the culture/language for the date picker.

Input
string $value a culture string, e.g. en_AU.
Output
Exception

setData

public void setData (integer $value )

Sets the timestamp represented by this control.

This method is required by IDataRenderer. It is the same as setTimeStamp().

Input
integer $value the timestamp of the TDatePicker control.
Output
Exception

setDate

public void setDate (string $value )

Input
string $value date string
Output
Exception

setDateFormat

public void setDateFormat (string $value )

Sets the format of the date string.

Input
string $value the format of the date string
Output
Exception

setFirstDayOfWeek

public void setFirstDayOfWeek (integer $value )

Set the first day of week, with 0 as Sunday, 1 as Monday, etc.

Input
integer $value 0 for Sunday, 1 for Monday, 2 for Tuesday, etc.
Output
Exception

setFromYear

public void setFromYear (integer $value )

Input
integer $value date picker starting year, default is 2000.
Output
Exception

setInputMode

public void setInputMode (TDatePickerInputMode $value )

Input
TDatePickerInputMode $value input method of date values
Output
Exception

setMode

public void setMode (TDatePickerMode $value )

Input
TDatePickerMode $value calendar UI mode
Output
Exception

setPositionMode

public void setPositionMode (TDatePickerPositionMode $value )

Input
TDatePickerPositionMode $value calendar UI position
Output
Exception

setShowCalendar

public void setShowCalendar (boolean $value )

Sets whether to pop up the calendar window when the control receives focus

Input
boolean $value whether to show the calendar window
Output
Exception

setTimeStamp

public void setTimeStamp (float $value )

Sets the date for the date picker using timestamp.

Input
float $value time stamp for the date picker
Output
Exception

setUpToYear

public void setUpToYear (integer $value )

Input
integer $value date picker ending year, default +10 years
Output
Exception

Constant Details

SCRIPT_PATH

Script path relative to the TClientScriptManager::SCRIPT_PATH

Type:

string

Value:

'prado/datepicker'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDatePickerClientScript

Class TDatePickerClientScript (Class Overview)

TComponent
   |
   --TClientSideOptions
      |
      --TDatePickerClientScript

TDatePickerClientScript class.

Client-side date picker event OnDateChanged can be modified through the TDatePicker::getClientSide property of a date picker.

The <tt>OnDateChanged</tt> event is raise when the date picker's date is changed. The formatted date according to TDatePicker::getDateFormat is sent as parameter to this event

Since: 3.0.4
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
string | getOnDateChanged ()
void | setOnDateChanged ( string $javascript) Javascript code to execute when the date picker's date is changed.
Methods Inherited From TClientSideOptions
TClientSideOptions::ensureFunction(), TClientSideOptions::getOption(), TClientSideOptions::getOptions(), TClientSideOptions::setFunction(), TClientSideOptions::setOption()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getOnDateChanged

public string getOnDateChanged ()

Output
string javascript code to execute when the date picker's date is changed.
Exception

setOnDateChanged

public void setOnDateChanged (string $javascript )

Javascript code to execute when the date picker's date is changed.

Input
string $javascript javascript code
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDatePickerInputMode

Class TDatePickerInputMode (Class Overview)

TEnumerable
   |
   --TDatePickerInputMode

TDatePickerInputMode class.

TDatePickerInputMode defines the enumerable type for the possible datepicker input methods.

The following enumerable values are defined:

  • TextBox: text boxes are used to input date values
  • DropDownList: dropdown lists are used to pick up date values

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | DropDownList
string | TextBox
Constant Details

DropDownList

Type:

string

Value:

'DropDownList'

TextBox

Type:

string

Value:

'TextBox'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDatePickerMode

Class TDatePickerMode (Class Overview)

TEnumerable
   |
   --TDatePickerMode

TDatePickerMode class.

TDatePickerMode defines the enumerable type for the possible UI mode that a TDatePicker control can take.

The following enumerable values are defined:

  • Basic: Only shows a text input, focusing on the input shows the date picker
  • Button: Shows a button next to the text input, clicking on the button shows the date, button text can be by the
  • ImageButton: Shows an image next to the text input, clicking on the image shows the date picker,

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Basic
string | Button
string | ImageButton
Constant Details

Basic

Type:

string

Value:

'Basic'

Button

Type:

string

Value:

'Button'

ImageButton

Type:

string

Value:

'ImageButton'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDatePickerPositionMode

Class TDatePickerPositionMode (Class Overview)

TEnumerable
   |
   --TDatePickerPositionMode

TDatePickerPositionMode class.

TDatePickerPositionMode defines the positions available for the calendar popup, relative to the corresponding input.

The following enumerable values are defined:

  • Top: the date picker is placed above the input field
  • Bottom: the date picker is placed below the input field

Since: 3.1.4
Author: Carl G. Mathisen <carlgmathisen@gmail.com>
Constant Summary
string | Bottom
string | Top
Constant Details

Bottom

Type:

string

Value:

'Bottom'

Top

Type:

string

Value:

'Top'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDropDownList

Class TDropDownList (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TDropDownList

Direct Known Sub-classes:

TActiveDropDownList

TDropDownList class

TDropDownList displays a dropdown list on a Web page. It inherits all properties and events from TListControl.

Since v3.0.3, TDropDownList starts to support optgroup. To specify an option group for a list item, set a Group attribute with it,

1       $listitem->Attributes->Group="Group Name";
1       // or <com:TListItem Attributes.Group="Group Name" .../> in template

Since v3.1.1, TDropDownList starts to support prompt text. That is, a prompt item can be displayed as the first list item by specifying either PromptText or PromptValue, or both. Choosing the prompt item will unselect the TDropDownList.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attributes to renderer.
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
boolean | getDataChanged () Returns a value indicating whether postback has caused the control data change.
bool | getIsValid () Returns true if this control validated successfully.
mixed | getValidationPropertyValue () Returns the value to be validated.
boolean | loadPostData ( string $key, array $values) Loads user input data.
void | raisePostDataChangedEvent () Raises postdata changed event.
void | setIsValid ( bool $value)
void | setSelectedIndices ( mixed $indices)
Methods Inherited From TListControl
TListControl::addAttributesToRender(), TListControl::addParsedObject(), TListControl::clearSelection(), TListControl::createListItemCollection(), TListControl::formatDataValue(), TListControl::getAppendDataBoundItems(), TListControl::getAutoPostBack(), TListControl::getCausesValidation(), TListControl::getClientClassName(), TListControl::getData(), TListControl::getDataGroupField(), TListControl::getDataTextField(), TListControl::getDataTextFormatString(), TListControl::getDataValueField(), TListControl::getEnableClientScript(), TListControl::getHasItems(), TListControl::getIsMultiSelect(), TListControl::getItemCount(), TListControl::getItems(), TListControl::getPostBackOptions(), TListControl::getPromptText(), TListControl::getPromptValue(), TListControl::getSelectedIndex(), TListControl::getSelectedIndices(), TListControl::getSelectedItem(), TListControl::getSelectedValue(), TListControl::getSelectedValues(), TListControl::getTagName(), TListControl::getText(), TListControl::getValidationGroup(), TListControl::loadState(), TListControl::onSelectedIndexChanged(), TListControl::onTextChanged(), TListControl::performDataBinding(), TListControl::renderClientControlScript(), TListControl::renderContents(), TListControl::renderPrompt(), TListControl::saveState(), TListControl::setAppendDataBoundItems(), TListControl::setAutoPostBack(), TListControl::setCausesValidation(), TListControl::setData(), TListControl::setDataGroupField(), TListControl::setDataTextField(), TListControl::setDataTextFormatString(), TListControl::setDataValueField(), TListControl::setEnableClientScript(), TListControl::setPromptText(), TListControl::setPromptValue(), TListControl::setSelectedIndex(), TListControl::setSelectedIndices(), TListControl::setSelectedValue(), TListControl::setSelectedValues(), TListControl::setText(), TListControl::setValidationGroup()
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attributes to renderer.

Input
THtmlWriter $writer the renderer
Output
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getDataChanged

public boolean getDataChanged ()

Returns a value indicating whether postback has caused the control data change.

This method is required by the IPostBackDataHandler interface.

Output
boolean whether postback has caused the control data change. False if the page is not in postback mode.
Exception

getIsValid

public bool getIsValid ()

Returns true if this control validated successfully.

Defaults to true.

Output
bool wether this control validated successfully.
Exception

getValidationPropertyValue

public mixed getValidationPropertyValue ()

Returns the value to be validated.

This methid is required by IValidatable interface.

Output
mixed the value of the property to be validated.
Exception

loadPostData

public boolean loadPostData (string $key , array $values )

Loads user input data.

This method is primarly used by framework developers.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the component has been changed
Exception

raisePostDataChangedEvent

public void raisePostDataChangedEvent ()

Raises postdata changed event.

This method is required by IPostBackDataHandler interface. It is invoked by the framework when SelectedIndex property is changed on postback. This method is primarly used by framework developers.

Output
Exception

setIsValid

public void setIsValid (bool $value )

Input
bool $value wether this control is valid.
Output
Exception

setSelectedIndices

public void setSelectedIndices (mixed $indices )

Input
mixed | $indices
Output
Exception
throws | TNotSupportedException if this method is invoked


PRADO API Manual: Docs For Class TDropDownListColumn

Class TDropDownListColumn (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TDropDownListColumn

TDropDownListColumn class

TDropDownListColumn represents a column that is bound to a field in a data source. The cells in the column will be displayed using the data indexed by DataTextField. You can customize the display by setting DataTextFormatString.

If ReadOnly is false, TDropDownListColumn will display cells in edit mode with dropdown lists. Otherwise, a static text is displayed. The currently selected dropndown list item is specified by the data indexed with DataValueField.

There are two approaches to specify the list items available for selection. The first approach uses template syntax as follows,

1        <com:TDropDownListColumn ....>
2          <com:TListItem Value="1" Text="first item" />
3          <com:TListItem Value="2" Text="second item" />
4          <com:TListItem Value="3" Text="third item" />
5        </com:TDropDownListColumn>
The second approach specifies a data source to be bound to the dropdown lists by setting ListDataSource. Like generic list controls, you may also want to specify which data fields are used for item values and texts by setting ListValueField and ListTextField, respectively. Furthermore, the item texts may be formatted by using ListTextFormatString. Note, if you specify ListDataSource, do it before calling the datagrid's dataBind().

The dropdown list control in the TDropDownListColumn can be accessed by one of the following two methods:

1      $datagridItem->DropDownListColumnID->DropDownList
2      $datagridItem->DropDownListColumnID->Controls[0]
The second method is possible because the dropdown list control created within the datagrid cell is the first child.

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct
Method Summary
void | addParsedObject ( mixed $object) Adds object parsed from template to the control.
void | dataBindColumn ( mixed $sender, mixed $param) Databinds a cell in the column.
string | getDataTextField ()
string | getDataTextFormatString ()
string | getDataValueField ()
Traversable | getListDataSource ()
string | getListTextField ()
string | getListTextFormatString ()
string | getListValueField ()
boolean | getReadOnly ()
void | initializeCell ( TTableCell $cell, integer $columnIndex, string $itemType) Initializes the specified cell to its initial values.
void | loadState ( mixed $state) Loads items from viewstate.
void | saveState () Saves items into viewstate.
void | setDataTextField ( string $value) Sets the field of the data source that provides the text content of the column.
void | setDataTextFormatString ( string $value)
void | setDataValueField ( string $value) Sets the field of the data source that provides the key selecting an item in dropdown list.
void | setListDataSource ( Traversable|array|string $value)
void | setListTextField ( string $value)
void | setListTextFormatString ( string $value)
void | setListValueField ( string $value)
void | setReadOnly ( boolean $value)
Methods Inherited From TDataGridColumn
TDataGridColumn::formatDataValue(), TDataGridColumn::getAllowSorting(), TDataGridColumn::getDataFieldValue(), TDataGridColumn::getEnableCellGrouping(), TDataGridColumn::getFooterRenderer(), TDataGridColumn::getFooterStyle(), TDataGridColumn::getFooterText(), TDataGridColumn::getHeaderImageUrl(), TDataGridColumn::getHeaderRenderer(), TDataGridColumn::getHeaderStyle(), TDataGridColumn::getHeaderText(), TDataGridColumn::getID(), TDataGridColumn::getItemStyle(), TDataGridColumn::getOwner(), TDataGridColumn::getSortExpression(), TDataGridColumn::getViewState(), TDataGridColumn::getVisible(), TDataGridColumn::initialize(), TDataGridColumn::initializeCell(), TDataGridColumn::initializeFooterCell(), TDataGridColumn::initializeHeaderCell(), TDataGridColumn::loadState(), TDataGridColumn::saveState(), TDataGridColumn::setEnableCellGrouping(), TDataGridColumn::setFooterRenderer(), TDataGridColumn::setFooterText(), TDataGridColumn::setHeaderImageUrl(), TDataGridColumn::setHeaderRenderer(), TDataGridColumn::setHeaderText(), TDataGridColumn::setID(), TDataGridColumn::setOwner(), TDataGridColumn::setSortExpression(), TDataGridColumn::setViewState(), TDataGridColumn::setVisible()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct

Method Details

addParsedObject

public void addParsedObject (mixed $object )

Adds object parsed from template to the control.

This method adds only TListItem objects into the getItems collection. All other objects are ignored.

Input
mixed $object object parsed from template
Output
Exception

dataBindColumn

public void dataBindColumn (mixed $sender , mixed $param )

Databinds a cell in the column.

This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

Input
mixed | $sender
mixed | $param
Output
Exception

getDataTextField

public string getDataTextField ()

Output
string the field of the data source that provides the text content of the column.
Exception

getDataTextFormatString

public string getDataTextFormatString ()

Output
string the formatting string used to control how the bound data will be displayed.
Exception

getDataValueField

public string getDataValueField ()

Output
string the field of the data source that provides the key selecting an item in dropdown list.
Exception

getListDataSource

public Traversable getListDataSource ()

Output
Traversable data source to be bound to the dropdown list boxes.
Exception

getListTextField

public string getListTextField ()

Output
string the data field used to populate the texts of the dropdown list items. Defaults to empty.
Exception

getListTextFormatString

public string getListTextFormatString ()

Output
string the formatting string used to control how the list item texts will be displayed.
Exception

getListValueField

public string getListValueField ()

Output
string the data field used to populate the values of the dropdown list items. Defaults to empty.
Exception

getReadOnly

public boolean getReadOnly ()

Output
boolean whether the items in the column can be edited. Defaults to false.
Exception

initializeCell

public void initializeCell (TTableCell $cell , integer $columnIndex , string $itemType )

Initializes the specified cell to its initial values.

This method overrides the parent implementation. It creates a textbox for item in edit mode and the column is not read-only. Otherwise it displays a static text. The caption of the button and the static text are retrieved from the datasource.

Input
TTableCell | $cell | the cell to be initialized.
integer | $columnIndex | the index to the Columns property that the cell resides in.
string | $itemType | the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)
Output
Exception

loadState

public void loadState (mixed $state )

Loads items from viewstate.

This method overrides the parent implementation by loading list items

Input
mixed $state state values
Output
Exception

saveState

public void saveState ()

Saves items into viewstate.

This method overrides the parent implementation by saving list items

Output
Exception

setDataTextField

public void setDataTextField (string $value )

Sets the field of the data source that provides the text content of the column.

If this is not set, the data specified via DataValueField will be displayed in the column.

Input
string $value the field of the data source that provides the text content of the column.
Output
Exception

setDataTextFormatString

public void setDataTextFormatString (string $value )

Input
string $value the formatting string used to control how the bound data will be displayed.
Output
Exception

setDataValueField

public void setDataValueField (string $value )

Sets the field of the data source that provides the key selecting an item in dropdown list.

If this is not present, the data specified via DataTextField (without applying the formatting string) will be used for selection, instead.

Input
string $value the field of the data source that provides the key selecting an item in dropdown list.
Output
Exception

setListDataSource

public void setListDataSource (Traversable|array|string $value )

Input
Traversable|array|string $value data source to be bound to the dropdown list boxes.
Output
Exception

setListTextField

public void setListTextField (string $value )

Input
string $value the data field used to populate the texts of the dropdown list items
Output
Exception

setListTextFormatString

public void setListTextFormatString (string $value )

Input
string $value the formatting string used to control how the list item texts will be displayed.
Output
Exception

setListValueField

public void setListValueField (string $value )

Input
string $value the data field used to populate the values of the dropdown list items
Output
Exception

setReadOnly

public void setReadOnly (boolean $value )

Input
boolean $value whether the items in the column can be edited
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TEditCommandColumn

Class TEditCommandColumn (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TEditCommandColumn

TEditCommandColumn class

TEditCommandColumn contains the Edit command buttons for editing data items in each row.

TEditCommandColumn will create an edit button if a cell is not in edit mode. Otherwise an update button and a cancel button will be created within the cell. The button captions are specified using EditText, UpdateText, and CancelText.

The buttons in the column can be set to display as hyperlinks, push or image buttons by setting the ButtonType property.

When an edit button is clicked, the datagrid will generate an onEditCommand event. When an update/cancel button is clicked, the datagrid will generate an onUpdateCommand or an onCancelCommand You can write these event handlers to change the state of specific datagrid item.

The CausesValidation and ValidationGroup properties affect the corresponding properties of the edit and update buttons. The cancel button does not cause validation by default.

The command buttons in the column can be accessed by one of the following methods:

1      $datagridItem->ButtonColumnID->EditButton (or UpdateButton, CancelButton)
2      $datagridItem->ButtonColumnID->Controls[0]
The second method is possible because the button control created within the datagrid cell is the first child.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected mixed | createButton ( string $commandName, string $text, boolean $causesValidation, string $validationGroup) Creates a button and initializes its properties.
TButtonColumnType | getButtonType ()
string | getCancelImageUrl ()
string | getCancelText ()
boolean | getCausesValidation ()
string | getEditImageUrl ()
string | getEditText ()
string | getUpdateImageUrl ()
string | getUpdateText ()
string | getValidationGroup ()
void | initializeCell ( TTableCell $cell, integer $columnIndex, string $itemType) Initializes the specified cell to its initial values.
void | setButtonType ( TButtonColumnType $value)
void | setCancelImageUrl ( string $value)
void | setCancelText ( string $value)
void | setCausesValidation ( boolean $value)
void | setEditImageUrl ( string $value)
void | setEditText ( string $value)
void | setUpdateImageUrl ( string $value)
void | setUpdateText ( string $value)
void | setValidationGroup ( string $value)
Methods Inherited From TDataGridColumn
TDataGridColumn::formatDataValue(), TDataGridColumn::getAllowSorting(), TDataGridColumn::getDataFieldValue(), TDataGridColumn::getEnableCellGrouping(), TDataGridColumn::getFooterRenderer(), TDataGridColumn::getFooterStyle(), TDataGridColumn::getFooterText(), TDataGridColumn::getHeaderImageUrl(), TDataGridColumn::getHeaderRenderer(), TDataGridColumn::getHeaderStyle(), TDataGridColumn::getHeaderText(), TDataGridColumn::getID(), TDataGridColumn::getItemStyle(), TDataGridColumn::getOwner(), TDataGridColumn::getSortExpression(), TDataGridColumn::getViewState(), TDataGridColumn::getVisible(), TDataGridColumn::initialize(), TDataGridColumn::initializeCell(), TDataGridColumn::initializeFooterCell(), TDataGridColumn::initializeHeaderCell(), TDataGridColumn::loadState(), TDataGridColumn::saveState(), TDataGridColumn::setEnableCellGrouping(), TDataGridColumn::setFooterRenderer(), TDataGridColumn::setFooterText(), TDataGridColumn::setHeaderImageUrl(), TDataGridColumn::setHeaderRenderer(), TDataGridColumn::setHeaderText(), TDataGridColumn::setID(), TDataGridColumn::setOwner(), TDataGridColumn::setSortExpression(), TDataGridColumn::setViewState(), TDataGridColumn::setVisible()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createButton

protected mixed createButton (string $commandName , string $text , boolean $causesValidation , string $validationGroup )

Creates a button and initializes its properties.

The button type is determined by ButtonType.

Input
string | $commandName | command name associated with the button
string | $text | button caption
boolean | $causesValidation | whether the button should cause validation
string | $validationGroup | the validation group that the button belongs to
Output
mixed | the newly created button.
Exception

getButtonType

public TButtonColumnType getButtonType ()

Output
TButtonColumnType the type of command button. Defaults to TButtonColumnType::LinkButton.
Exception

getCancelImageUrl

public string getCancelImageUrl ()

Output
string the URL of the image file for cancel image buttons
Exception

getCancelText

public string getCancelText ()

Output
string the caption of the cancel button. Defaults to 'Cancel'.
Exception

getCausesValidation

public boolean getCausesValidation ()

Output
boolean whether postback event trigger by edit or update button will cause input validation, default is true
Exception

getEditImageUrl

public string getEditImageUrl ()

Output
string the URL of the image file for edit image buttons
Exception

getEditText

public string getEditText ()

Output
string the caption of the edit button. Defaults to 'Edit'.
Exception

getUpdateImageUrl

public string getUpdateImageUrl ()

Output
string the URL of the image file for update image buttons
Exception

getUpdateText

public string getUpdateText ()

Output
string the caption of the update button. Defaults to 'Update'.
Exception

getValidationGroup

public string getValidationGroup ()

Output
string the group of validators which the edit or update button causes validation upon postback
Exception

initializeCell

public void initializeCell (TTableCell $cell , integer $columnIndex , string $itemType )

Initializes the specified cell to its initial values.

This method overrides the parent implementation. It creates an update and a cancel button for cell in edit mode. Otherwise it creates an edit button.

Input
TTableCell | $cell | the cell to be initialized.
integer | $columnIndex | the index to the Columns property that the cell resides in.
string | $itemType | the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)
Output
Exception

setButtonType

public void setButtonType (TButtonColumnType $value )

Input
TButtonColumnType $value the type of command button.
Output
Exception

setCancelImageUrl

public void setCancelImageUrl (string $value )

Input
string $value the URL of the image file for cancel image buttons
Output
Exception

setCancelText

public void setCancelText (string $value )

Input
string $value the caption of the cancel button
Output
Exception

setCausesValidation

public void setCausesValidation (boolean $value )

Input
boolean $value whether postback event trigger by edit or update button will cause input validation
Output
Exception

setEditImageUrl

public void setEditImageUrl (string $value )

Input
string $value the URL of the image file for edit image buttons
Output
Exception

setEditText

public void setEditText (string $value )

Input
string $value the caption of the edit button
Output
Exception

setUpdateImageUrl

public void setUpdateImageUrl (string $value )

Input
string $value the URL of the image file for update image buttons
Output
Exception

setUpdateText

public void setUpdateText (string $value )

Input
string $value the caption of the update button
Output
Exception

setValidationGroup

public void setValidationGroup (string $value )

Input
string $value the group of validators which the edit or update button causes validation upon postback
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TEmailAddressValidator

Class TEmailAddressValidator (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TRegularExpressionValidator
                     |
                     --TEmailAddressValidator

TEmailAddressValidator class

TEmailAddressValidator validates whether the value of an associated input component is a valid email address. If CheckMXRecord is true, it will check MX record for the email adress, provided checkdnsrr() is available in the installed PHP.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
array | evaluateIsValid () Returns an array of javascript validator options.
boolean | getCheckMXRecord ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing validation for this control.
string | getRegularExpression ()
void | setCheckMXRecord ( boolean $value)
Methods Inherited From TRegularExpressionValidator
TRegularExpressionValidator::evaluateIsValid(), TRegularExpressionValidator::getClientClassName(), TRegularExpressionValidator::getClientScriptOptions(), TRegularExpressionValidator::getClientSidePatternModifiers(), TRegularExpressionValidator::getPatternModifiers(), TRegularExpressionValidator::getRegularExpression(), TRegularExpressionValidator::setClientSidePatternModifiers(), TRegularExpressionValidator::setPatternModifiers(), TRegularExpressionValidator::setRegularExpression()
Methods Inherited From TBaseValidator
TBaseValidator::addAttributesToRender(), TBaseValidator::createClientSide(), TBaseValidator::getClientScriptOptions(), TBaseValidator::getClientSide(), TBaseValidator::getControlCssClass(), TBaseValidator::getControlToValidate(), TBaseValidator::getDisplay(), TBaseValidator::getEnableClientScript(), TBaseValidator::getErrorMessage(), TBaseValidator::getFocusElementID(), TBaseValidator::getFocusOnError(), TBaseValidator::getIsValid(), TBaseValidator::getValidationGroup(), TBaseValidator::getValidationTarget(), TBaseValidator::getValidationValue(), TBaseValidator::onInit(), TBaseValidator::onPreRender(), TBaseValidator::onUnload(), TBaseValidator::onValidate(), TBaseValidator::onValidationError(), TBaseValidator::onValidationSuccess(), TBaseValidator::registerClientScriptValidator(), TBaseValidator::renderClientControlScript(), TBaseValidator::renderContents(), TBaseValidator::setControlCssClass(), TBaseValidator::setControlToValidate(), TBaseValidator::setDisplay(), TBaseValidator::setEnableClientScript(), TBaseValidator::setEnabled(), TBaseValidator::setErrorMessage(), TBaseValidator::setFocusElementID(), TBaseValidator::setFocusOnError(), TBaseValidator::setForControl(), TBaseValidator::setIsValid(), TBaseValidator::setValidationGroup(), TBaseValidator::updateControlCssClass(), TBaseValidator::validate()
Methods Inherited From TLabel
TLabel::addAttributesToRender(), TLabel::getData(), TLabel::getForControl(), TLabel::getTagName(), TLabel::getText(), TLabel::render(), TLabel::renderContents(), TLabel::setData(), TLabel::setForControl(), TLabel::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string EMAIL_REGEXP Regular expression used to validate the email address
Method Details

evaluateIsValid

public array evaluateIsValid ()

Returns an array of javascript validator options.

Output
array javascript validator options.
Exception

getCheckMXRecord

public boolean getCheckMXRecord ()

Output
boolean whether to check MX record for the email address being validated. Defaults to true.
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing validation for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getRegularExpression

public string getRegularExpression ()

Output
string the regular expression that determines the pattern used to validate a field.
Exception

setCheckMXRecord

public void setCheckMXRecord (boolean $value )

Input
boolean $value whether to check MX record for the email address being validated. Note, if http://www.php.net/checkdnsrr is not available, this check will not be performed.
Output
Exception

Constant Details

EMAIL_REGEXP

Regular expression used to validate the email address

Type:

string

Value:

"\\w+([-+.]\\w+)*@\\w+([-.]\\w+)*\\.\\w+([-.]\\w+)*"


PRADO API Manual: Docs For Class TExpression

Class TExpression (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TExpression

TExpression class

TExpression evaluates a PHP expression and renders the result. The expression is evaluated during the rendering stage. The expression being evaluated can be set via the property Expression. The context of the expression evaluated is the TExpression object itself.

Note, since TExpression allows evaluation of arbitrary PHP expression, make sure Expression does not come directly from user input.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getExpression ()
void | render ( THtmlWriter $writer) Renders the evaluation result of the expression.
void | setExpression ( string $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getExpression

public string getExpression ()

Output
string the expression to be evaluated
Exception

render

public void render (THtmlWriter $writer )

Renders the evaluation result of the expression.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

setExpression

public void setExpression (string $value )

Input
string $value the expression to be evaluated
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TFileUpload

Class TFileUpload (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TFileUpload

Direct Known Sub-classes:

TActiveFileUpload

TFileUpload class

TFileUpload displays a file upload field on a page. Upon postback, the text entered into the field will be treated as the name of the file that will be uploaded to the server. The property HasFile indicates whether the file upload is successful. If successful, the file may be obtained by calling saveAs to save it at a specified place. You can use FileName, FileType, FileSize to get the original client-side file name, the file mime type, and the file size information. If the upload is not successful, ErrorCode contains the error code describing the cause of failure.

TFileUpload raises OnFileUpload event if a file is uploaded (whether it succeeds or not).

Since: 3.0
Author: Marcus Nyeholt <tanus@users.sourceforge.net>, Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Sets name attribute to the unique ID of the control.
boolean | getDataChanged () Returns a value indicating whether postback has caused the control data change.
integer | getErrorCode () Returns an error code describing the status of this file uploading.
string | getFileName ()
integer | getFileSize ()
string | getFileType ()
boolean | getHasFile ()
bool | getIsValid () Returns true if this control validated successfully.
string | getLocalName ()
integer | getMaxFileSize ()
protected string | getTagName ()
mixed | getValidationPropertyValue () Returns the original file name as the property value to be validated.
boolean | loadPostData ( string $key, array $values) Loads user input data.
void | onFileUpload ( TEventParameter $param) This method is invoked when a file is uploaded during a postback.
void | onPreRender ( mixed $param) Sets Enctype of the form on the page.
void | raisePostDataChangedEvent () Raises postdata changed event.
boolean | saveAs ( string $fileName, boolean $deleteTempFile) Saves the uploaded file.
void | setIsValid ( bool $value)
void | setMaxFileSize ( int $size) Sets the maximum size that a file can be uploaded.
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
int MAX_FILE_SIZE Maximum file size (in bytes) allowed to be uploaded, defaults to 1MB.
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Sets name attribute to the unique ID of the control.

This method overrides the parent implementation with additional file update control specific attributes.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

getDataChanged

public boolean getDataChanged ()

Returns a value indicating whether postback has caused the control data change.

This method is required by the IPostBackDataHandler interface.

Output
boolean whether postback has caused the control data change. False if the page is not in postback mode.
Exception

getErrorCode

public integer getErrorCode ()

Returns an error code describing the status of this file uploading.

Output
integer the error code
Exception

getFileName

public string getFileName ()

Output
string the original full path name of the file on the client machine
Exception

getFileSize

public integer getFileSize ()

Output
integer the actual size of the uploaded file in bytes
Exception

getFileType

public string getFileType ()

Output
string the MIME-type of the uploaded file (such as "image/gif"). This mime type is not checked on the server side and do not take its value for granted.
Exception

getHasFile

public boolean getHasFile ()

Output
boolean whether the file is uploaded successfully
Exception

getIsValid

public bool getIsValid ()

Returns true if this control validated successfully.

Defaults to true.

Output
bool wether this control validated successfully.
Exception

getLocalName

public string getLocalName ()

Output
string the local name of the file (where it is after being uploaded). Note, PHP will delete this file automatically after finishing this round of request.
Exception

getMaxFileSize

public integer getMaxFileSize ()

Output
integer the maximum file size, defaults to 1MB (1048576 bytes).
Exception

getTagName

protected string getTagName ()

Output
string tag name of the file upload control
Exception

getValidationPropertyValue

public mixed getValidationPropertyValue ()

Returns the original file name as the property value to be validated.

This method is required by IValidatable property.

Output
mixed the property value to be validated
Exception

loadPostData

public boolean loadPostData (string $key , array $values )

Loads user input data.

This method is primarly used by framework developers.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the control has been changed
Exception

onFileUpload

public void onFileUpload (TEventParameter $param )

This method is invoked when a file is uploaded during a postback.

The method raises OnFileUpload event to fire up the event handler. If you override this method, be sure to call the parent implementation so that the event delegates can be invoked.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onPreRender

public void onPreRender (mixed $param )

Sets Enctype of the form on the page.

This method overrides the parent implementation and is invoked before render.

Input
mixed $param event parameter
Output
Exception

raisePostDataChangedEvent

public void raisePostDataChangedEvent ()

Raises postdata changed event.

This method calls onFileUpload method. This method is primarly used by framework developers.

Output
Exception

saveAs

public boolean saveAs (string $fileName , boolean $deleteTempFile )

Saves the uploaded file.

Input
string | $fileName | the file name used to save the uploaded file
boolean | $deleteTempFile | whether to delete the temporary file after saving. If true, you will not be able to save the uploaded file again.
Output
boolean | true if the file saving is successful
Exception

setIsValid

public void setIsValid (bool $value )

Input
bool $value wether this control is valid.
Output
Exception

setMaxFileSize

public void setMaxFileSize (int $size )

Sets the maximum size that a file can be uploaded.

Note, this is an advisory value to the browser. Sets this property with a reasonably large size to save users the trouble of waiting for a big file being transferred only to find that it was too big and the transfer failed.

Input
int $size the maximum upload size allowed for a file.
Output
Exception

Constant Details

MAX_FILE_SIZE

Maximum file size (in bytes) allowed to be uploaded, defaults to 1MB.

Type:

int

Value:

1048576


PRADO API Manual: Docs For Class TFont

Class TFont (Class Overview)

TComponent
   |
   --TFont

TFont class

TFont encapsulates the CSS style fields related with font settings.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | addAttributesToRender ( THtmlWriter $writer) Adds attributes related to CSS styles to renderer.
void | copyFrom ( TFont $font) Copies the fields in a new font to this font.
boolean | getBold ()
boolean | getIsEmpty ()
boolean | getItalic ()
string | getName ()
boolean | getOverline ()
string | getSize ()
boolean | getStrikeout ()
boolean | getUnderline ()
void | mergeWith ( TFont $font) Merges the font with a new one.
void | reset () Clears up the font.
void | setBold ( boolean $value)
void | setItalic ( boolean $value)
void | setName ( string $value)
void | setOverline ( boolean $value)
void | setSize ( string $value)
void | setStrikeout ( boolean $value)
void | setUnderline ( boolean $value)
string | toString ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
int | IS_BOLD | Bits indicating the font states.
int | IS_ITALIC |
int | IS_OVERLINE |
int | IS_SET_BOLD | Bits indicating whether particular font states are changed.
int | IS_SET_ITALIC |
int | IS_SET_NAME |
int | IS_SET_OVERLINE |
int | IS_SET_SIZE |
int | IS_SET_STRIKEOUT |
int | IS_SET_UNDERLINE |
int | IS_STRIKEOUT |
int | IS_UNDERLINE |
Method Details

addAttributesToRender

public void addAttributesToRender (THtmlWriter $writer )

Adds attributes related to CSS styles to renderer.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

copyFrom

public void copyFrom (TFont $font )

Copies the fields in a new font to this font.

If a font field is set in the new font, the corresponding field in this font will be overwritten.

Input
TFont $font the new font
Output
Exception

getBold

public boolean getBold ()

Output
boolean whether the font is in bold face. Defaults to false.
Exception

getIsEmpty

public boolean getIsEmpty ()

Output
boolean whether the font is empty
Exception

getItalic

public boolean getItalic ()

Output
boolean whether the font is in italic face. Defaults to false.
Exception

getName

public string getName ()

Output
string the font name (family)
Exception

getOverline

public boolean getOverline ()

Output
boolean whether the font is overlined. Defaults to false.
Exception

getSize

public string getSize ()

Output
string the font size
Exception

getStrikeout

public boolean getStrikeout ()

Output
boolean whether the font is strikeout. Defaults to false.
Exception

getUnderline

public boolean getUnderline ()

Output
boolean whether the font is underlined. Defaults to false.
Exception

mergeWith

public void mergeWith (TFont $font )

Merges the font with a new one.

If a font field is not set in the font, it will be overwritten with the new one.

Input
TFont $font the new font
Output
Exception

reset

public void reset ()

Clears up the font.

Output
Exception

setBold

public void setBold (boolean $value )

Input
boolean $value whether the font is in bold face
Output
Exception

setItalic

public void setItalic (boolean $value )

Input
boolean $value whether the font is italic
Output
Exception

setName

public void setName (string $value )

Input
string $value the font name (family)
Output
Exception

setOverline

public void setOverline (boolean $value )

Input
boolean $value whether the font is overlined
Output
Exception

setSize

public void setSize (string $value )

Input
string $value the font size
Output
Exception

setStrikeout

public void setStrikeout (boolean $value )

Input
boolean $value whether the font is strikeout
Output
Exception

setUnderline

public void setUnderline (boolean $value )

Input
boolean $value whether the font is underlined
Output
Exception

toString

public string toString ()

Output
string the font in a css style string representation.
Exception

Constant Details

IS_BOLD

Bits indicating the font states.

Type:

int

Value:

0x01

IS_ITALIC

Type:

int

Value:

0x02

IS_OVERLINE

Type:

int

Value:

0x04

IS_SET_BOLD

Bits indicating whether particular font states are changed.

Type:

int

Value:

0x01000

IS_SET_ITALIC

Type:

int

Value:

0x02000

IS_SET_NAME

Type:

int

Value:

0x40000

IS_SET_OVERLINE

Type:

int

Value:

0x04000

IS_SET_SIZE

Type:

int

Value:

0x20000

IS_SET_STRIKEOUT

Type:

int

Value:

0x08000

IS_SET_UNDERLINE

Type:

int

Value:

0x10000

IS_STRIKEOUT

Type:

int

Value:

0x08

IS_UNDERLINE

Type:

int

Value:

0x10
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMetaTag

Class TMetaTag (Class Overview)

TComponent
   |
   --TMetaTag

TMetaTag class.

TMetaTag represents a meta tag appearing in a page head section. You can set its ID, HttpEquiv, Name, Content, Scheme properties, which correspond to id, http-equiv, name, content, and scheme attributes for a meta tag, respectively.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
string | getContent ()
string | getHttpEquiv ()
string | getID ()
string | getName ()
string | getScheme ()
void | render ( THtmlWriter $writer) Renders the meta tag.
void | setContent ( string $value)
void | setHttpEquiv ( string $value)
void | setID ( string $value)
void | setName ( string $value)
void | setScheme ( string $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getContent

public string getContent ()

Output
string content attribute of the meta tag
Exception

getHttpEquiv

public string getHttpEquiv ()

Output
string http-equiv attribute of the meta tag
Exception

getID

public string getID ()

Output
string id of the meta tag
Exception

getName

public string getName ()

Output
string name attribute of the meta tag
Exception

getScheme

public string getScheme ()

Output
string scheme attribute of the meta tag
Exception

render

public void render (THtmlWriter $writer )

Renders the meta tag.

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

setContent

public void setContent (string $value )

Input
string $value content attribute of the meta tag
Output
Exception

setHttpEquiv

public void setHttpEquiv (string $value )

Input
string $value http-equiv attribute of the meta tag
Output
Exception

setID

public void setID (string $value )

Input
string $value id of the meta tag
Output
Exception

setName

public void setName (string $value )

Input
string $value name attribute of the meta tag
Output
Exception

setScheme

public void setScheme (string $value )

Input
string $value scheme attribute of the meta tag
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMetaTagCollection

Class TMetaTagCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TMetaTagCollection

TMetaTagCollection class

TMetaTagCollection represents a collection of meta tags contained in a THead control.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
integer | findIndexByID ( string $id) Finds the lowest cardinal index of the meta tag whose id is the one being looked for.
TMetaTag | findMetaTagByID ( string $id) Finds the item whose value is the one being looked for.
void | insertAt ( integer $index, mixed $item) Inserts an item at the specified position.
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

findIndexByID

public integer findIndexByID (string $id )

Finds the lowest cardinal index of the meta tag whose id is the one being looked for.

Input
string | $id | the ID of the meta tag to be looked for
Output
integer | the index of the meta tag found, -1 if not found.
Exception

findMetaTagByID

public TMetaTag findMetaTagByID (string $id )

Finds the item whose value is the one being looked for.

Input
string | $id | the id of the meta tag to be looked for
Output
TMetaTag | the meta tag found, null if not found.
Exception

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by performing type check on the item being added.

Input
integer | $index | the speicified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is not a TMetaTag


PRADO API Manual: Docs For Class THiddenField

Class THiddenField (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --THiddenField

Direct Known Sub-classes:

TActiveHiddenField

THiddenField class

THiddenField displays a hidden input field on a Web page. The value of the input field can be accessed via Value property. If upon postback the value is changed, a OnValueChanged event will be raised.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | focus () Sets focus to this control.
string | getData () Returns the value of the hidden field.
boolean | getDataChanged () Returns a value indicating whether postback has caused the control data change.
boolean | getEnableTheming ()
bool | getIsValid () Returns true if this control validated successfully.
protected string | getTagName ()
mixed | getValidationPropertyValue () Returns the value to be validated.
string | getValue ()
boolean | loadPostData ( string $key, array $values) Loads hidden field data.
void | onValueChanged ( TEventParameter $param) This method is invoked when the value of the getValue property changes between posts to the server.
void | raisePostDataChangedEvent () Raises postdata changed event.
void | render ( THtmlWriter $writer) Renders the control.
void | setData ( string $value) Sets the value of the hidden field.
void | setEnableTheming ( boolean $value)
void | setIsValid ( bool $value)
void | setSkinID ( string $value)
void | setValue ( string $value) Sets the value of the THiddenField
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

focus

public void focus ()

Sets focus to this control.

This method overrides the parent implementation by forbidding setting focus to this control.

Output
Exception

getData

public string getData ()

Returns the value of the hidden field.

This method is required by IDataRenderer. It is the same as getValue().

Output
string value of the hidden field
Exception

getDataChanged

public boolean getDataChanged ()

Returns a value indicating whether postback has caused the control data change.

This method is required by the IPostBackDataHandler interface.

Output
boolean whether postback has caused the control data change. False if the page is not in postback mode.
Exception

getEnableTheming

public boolean getEnableTheming ()

Output
boolean whether theming is enabled for this control. Defaults to false.
Exception

getIsValid

public bool getIsValid ()

Returns true if this control validated successfully.

Defaults to true.

Output
bool wether this control validated successfully.
Exception

getTagName

protected string getTagName ()

Output
string tag name of the hidden field.
Exception

getValidationPropertyValue

public mixed getValidationPropertyValue ()

Returns the value to be validated.

This methid is required by IValidatable interface.

Output
mixed the value of the property to be validated.
Exception

getValue

public string getValue ()

Output
string the value of the THiddenField
Exception

loadPostData

public boolean loadPostData (string $key , array $values )

Loads hidden field data.

This method is primarly used by framework developers.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the component has been changed
Exception

onValueChanged

public void onValueChanged (TEventParameter $param )

This method is invoked when the value of the getValue property changes between posts to the server.

The method raises 'OnValueChanged' event to fire up the event delegates. If you override this method, be sure to call the parent implementation so that the attached event handlers can be invoked.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raisePostDataChangedEvent

public void raisePostDataChangedEvent ()

Raises postdata changed event.

This method calls onValueChanged method. This method is primarly used by framework developers.

Output
Exception

render

public void render (THtmlWriter $writer )

Renders the control.

This method overrides the parent implementation by rendering the hidden field input element.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

setData

public void setData (string $value )

Sets the value of the hidden field.

This method is required by IDataRenderer. It is the same as setValue().

Input
string $value value of the hidden field
Output
Exception

setEnableTheming

public void setEnableTheming (boolean $value )

Input
boolean | $value | whether theming is enabled for this control.
Output
Exception
throws | TNotSupportedException This method is always thrown when calling this method.

setIsValid

public void setIsValid (bool $value )

Input
bool $value wether this control is valid.
Output
Exception

setSkinID

public void setSkinID (string $value )

Input
string | $value | Skin ID
Output
Exception
throws | TNotSupportedException This method is always thrown when calling this method.

setValue

public void setValue (string $value )

Sets the value of the THiddenField

Input
string $value the value to be set
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THtmlArea

Class THtmlArea (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox
               |
               --THtmlArea

THtmlArea class

THtmlArea wraps the visual editting functionalities provided by the TinyMCE project http://tinymce.moxiecode.com/.

THtmlArea displays a WYSIWYG text area on the Web page for user input in the HTML format. The text displayed in the THtmlArea component is specified or determined by using the Text property.

To enable the visual editting on the client side, set the property EnableVisualEdit to true (which is default value). To set the size of the editor when the visual editting is enabled, set the Width and Height properties instead of Columns and Rows because the latter has no meaning under the situation.

The default editor gives only the basic tool bar. To change or add additional tool bars, use the Options property to add additional editor options with each options on a new line. See http://tinymce.moxiecode.com/tinymce/docs/index.html for a list of options. The options can be change/added as shown in the following example.

1      <com:THtmlArea>
2           <prop:Options>
3                plugins : "contextmenu,paste"
4                language : "zh_cn"
5           </prop:Options>
6      </com:THtmlArea>

Compatibility The client-side visual editting capability is supported by Internet Explorer 5.0+ for Windows and Gecko-based browser. If the browser does not support the visual editting, a traditional textarea will be displayed.

Browser support

1                         Windows XP        MacOS X 10.4
2      ----------------------------------------------------
3      MSIE 6                  OK
4      MSIE 5.5 SP2            OK
5      MSIE 5.0                OK
6      Mozilla 1.7.x           OK              OK
7      Firefox 1.0.x           OK              OK
8      Firefox 1.5b2           OK              OK
9      Safari 2.0 (412)                        OK(1)
10     Opera 9 Preview 1       OK(1)           OK(1)
11     ----------------------------------------------------
12        * (1) - Partialy working
13     ----------------------------------------------------

Since: 3.0
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TTextBox
DEFAULT_COLUMNS, DEFAULT_ROWS,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Constructor.
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute name-value pairs to renderer.
protected void | copyCustomPlugins ( mixed $url)
boolean | getAutoPostBack ()
array | getAvailablePlugins () Returns a list of plugins to be loaded.
array | getAvailableThemes ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
string | getCulture () Gets the current culture.
string | getCustomPluginPath ()
protected array | getEditorOptions () Default editor options gives basic tool bar only.
boolean | getEnableCompression ()
boolean | getEnableVisualEdit ()
protected string | getLanguageSuffix ( mixed $culture)
string | getOptions () Gets the list of options for the WYSIWYG (TinyMCE) editor
protected string | getScriptDeploymentPath () Gets the editor script base URL by publishing the tarred source via TTarAssetManager.
protected string | getScriptUrl ()
string | getTextMode () Overrides the parent implementation.
protected void | loadJavascriptLibrary ()
protected array | parseEditorOptions ( mixed $string) Parse additional options set in the Options property.
protected void | preLoadCompressedScript ()
protected void | registerEditorClientScript ( mixed $writer) Registers the editor javascript file and code to initialize the editor.
void | setCulture ( string $value) Sets the culture/language for the html area
void | setCustomPluginPath ( string $value)
void | setEnableCompression ( boolean $value)
void | setEnableVisualEdit ( boolean $value) Sets whether to show WYSIWYG text editor.
void | setOptions ( string $value) Sets the list of options for the WYSIWYG (TinyMCE) editor
void | setTextMode ( string $value) Overrides the parent implementation.
Methods Inherited From TTextBox
TTextBox::addAttributesToRender(), TTextBox::getAutoCompleteType(), TTextBox::getAutoPostBack(), TTextBox::getAutoTrim(), TTextBox::getCausesValidation(), TTextBox::getClientClassName(), TTextBox::getColumns(), TTextBox::getData(), TTextBox::getDataChanged(), TTextBox::getEnableClientScript(), TTextBox::getIsValid(), TTextBox::getMaxLength(), TTextBox::getPersistPassword(), TTextBox::getPostBackOptions(), TTextBox::getReadOnly(), TTextBox::getRows(), TTextBox::getSafeText(), TTextBox::getSafeTextParser(), TTextBox::getTagName(), TTextBox::getText(), TTextBox::getTextMode(), TTextBox::getValidationGroup(), TTextBox::getValidationPropertyValue(), TTextBox::getWrap(), TTextBox::loadPostData(), TTextBox::onTextChanged(), TTextBox::raisePostDataChangedEvent(), TTextBox::renderBeginTag(), TTextBox::renderClientControlScript(), TTextBox::renderContents(), TTextBox::setAutoCompleteType(), TTextBox::setAutoPostBack(), TTextBox::setAutoTrim(), TTextBox::setCausesValidation(), TTextBox::setColumns(), TTextBox::setData(), TTextBox::setEnableClientScript(), TTextBox::setIsValid(), TTextBox::setMaxLength(), TTextBox::setPersistPassword(), TTextBox::setReadOnly(), TTextBox::setRows(), TTextBox::setText(), TTextBox::setTextMode(), TTextBox::setValidationGroup(), TTextBox::setWrap()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Constructor.

Sets default width and height.
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute name-value pairs to renderer.

This method overrides the parent implementation by registering additional javacript code.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

copyCustomPlugins

protected void copyCustomPlugins (mixed $url )

Input
mixed $url
Output
Exception

getAutoPostBack

public boolean getAutoPostBack ()

Output
boolean whether change of the content should cause postback. Return false if EnableVisualEdit is true.
Exception

getAvailablePlugins

public array getAvailablePlugins ()

Returns a list of plugins to be loaded.

Override this method to customize.

Output
array list of plugins to be loaded
Exception

getAvailableThemes

public array getAvailableThemes ()

Output
array list of available themese
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getCulture

public string getCulture ()

Gets the current culture.

Output
string current culture, e.g. en_AU.
Exception

getCustomPluginPath

public string getCustomPluginPath ()

Output
string path to custom plugins to be copied.
Exception

getEditorOptions

protected array getEditorOptions ()

Default editor options gives basic tool bar only.

Output
array editor initialization options.
Exception

getEnableCompression

public boolean getEnableCompression ()

Output
boolean enable compression of the javascript files, default is true.
Exception

getEnableVisualEdit

public boolean getEnableVisualEdit ()

Output
boolean whether to show WYSIWYG text editor. Defaults to true.
Exception

getLanguageSuffix

protected string getLanguageSuffix (mixed $culture )

Input
mixed | $culture
Output
string | localized editor interface language extension.
Exception

getOptions

public string getOptions ()

Gets the list of options for the WYSIWYG (TinyMCE) editor

Output
string options
Exception

getScriptDeploymentPath

protected string getScriptDeploymentPath ()

Gets the editor script base URL by publishing the tarred source via TTarAssetManager.

Output
string URL base path to the published editor script
Exception

getScriptUrl

protected string getScriptUrl ()

Output
string editor script URL.
Exception

getTextMode

public string getTextMode ()

Overrides the parent implementation.

TextMode for THtmlArea control is always 'MultiLine'

Output
string the behavior mode of the THtmlArea component.
Exception

loadJavascriptLibrary

protected void loadJavascriptLibrary ()

Output
Exception

parseEditorOptions

protected array parseEditorOptions (mixed $string )

Parse additional options set in the Options property.

Input
mixed | $string
Output
array | additional custom options
Exception

preLoadCompressedScript

protected void preLoadCompressedScript ()

Output
Exception

registerEditorClientScript

protected void registerEditorClientScript (mixed $writer )

Registers the editor javascript file and code to initialize the editor.

Input
mixed $writer
Output
Exception

setCulture

public void setCulture (string $value )

Sets the culture/language for the html area

Input
string $value a culture string, e.g. en_AU.
Output
Exception

setCustomPluginPath

public void setCustomPluginPath (string $value )

Input
string $value path to custom plugins to be copied.
Output
Exception

setEnableCompression

public void setEnableCompression (boolean $value )

Input
boolean $value enable compression of the javascript files, default is true.
Output
Exception

setEnableVisualEdit

public void setEnableVisualEdit (boolean $value )

Sets whether to show WYSIWYG text editor.

Input
boolean $value whether to show WYSIWYG text editor
Output
Exception

setOptions

public void setOptions (string $value )

Sets the list of options for the WYSIWYG (TinyMCE) editor

Input
string $value options
Output
Exception

setTextMode

public void setTextMode (string $value )

Overrides the parent implementation.

TextMode for THtmlArea is always 'MultiLine' and cannot be changed to others.

Input
string $value the text mode
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THtmlElement

Class THtmlElement (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --THtmlElement

THtmlElement class.

THtmlElement represents a generic HTML element whose tag name is specified via TagName property. Because THtmlElement extends from TWebControl, it enjoys all its functionalities.

Since: 3.1.2
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getTagName ()
void | setTagName ( string $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getTagName

public string getTagName ()

Output
string the tag name of this control. Defaults to 'span'.
Exception

setTagName

public void setTagName (string $value )

Input
string $value the tag name of this control.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THyperLink

Class THyperLink (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --THyperLink

Direct Known Sub-classes:

TActiveHyperLink

THyperLink class

THyperLink displays a hyperlink on a page. The hyperlink URL is specified via the NavigateUrl property, and link text is via the Text property. It is also possible to display an image by setting the ImageUrl property. In this case, Text is displayed as the alternate text of the image. The link target is specified via the Target property. If both ImageUrl and Text are empty, the content enclosed within the control tag will be rendered.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attributes related to a hyperlink element to renderer.
protected TImage | createImage ( string $imageUrl) Gets the TImage for rendering the ImageUrl property. This is not for creating dynamic images.
string | getData () Returns the URL to link to when the THyperLink component is clicked.
string | getImageUrl ()
string | getNavigateUrl ()
protected string | getTagName ()
string | getTarget ()
string | getText ()
void | renderContents ( THtmlWriter $writer) Renders the body content of the hyperlink.
void | setData ( string $value) Sets the URL to link to when the THyperLink component is clicked.
void | setImageUrl ( string $value) Sets the location of image file of the THyperLink.
void | setNavigateUrl ( string $value) Sets the URL to link to when the THyperLink component is clicked.
void | setTarget ( string $value) Sets the target window or frame to display the Web page content linked to when the THyperLink component is clicked.
void | setText ( string $value) Sets the text caption of the THyperLink.
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attributes related to a hyperlink element to renderer.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

createImage

protected TImage createImage (string $imageUrl )

Gets the TImage for rendering the ImageUrl property. This is not for creating dynamic images.

Input
string | $imageUrl | image url.
Output
TImage | image control for rendering.
Exception

getData

public string getData ()

Returns the URL to link to when the THyperLink component is clicked.

This method is required by IDataRenderer. It is the same as getText().

Output
string the text caption
Exception

getImageUrl

public string getImageUrl ()

Output
string the location of the image file for the THyperLink
Exception

getNavigateUrl

public string getNavigateUrl ()

Output
string the URL to link to when the THyperLink component is clicked.
Exception

getTagName

protected string getTagName ()

Output
string tag name of the hyperlink
Exception

getTarget

public string getTarget ()

Output
string the target window or frame to display the Web page content linked to when the THyperLink component is clicked.
Exception

getText

public string getText ()

Output
string the text caption of the THyperLink
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders the body content of the hyperlink.

Input
THtmlWriter $writer the writer for rendering
Output
Exception

setData

public void setData (string $value )

Sets the URL to link to when the THyperLink component is clicked.

This method is required by IDataRenderer. It is the same as setText().

Input
string $value the text caption to be set
Output
Exception

setImageUrl

public void setImageUrl (string $value )

Sets the location of image file of the THyperLink.

Input
string $value the image file location
Output
Exception

setNavigateUrl

public void setNavigateUrl (string $value )

Sets the URL to link to when the THyperLink component is clicked.

Input
string $value the URL
Output
Exception

setTarget

public void setTarget (string $value )

Sets the target window or frame to display the Web page content linked to when the THyperLink component is clicked.

Input
string $value the target window, valid values include '_blank', '_parent', '_self', '_top' and empty string.
Output
Exception

setText

public void setText (string $value )

Sets the text caption of the THyperLink.

Input
string $value the text caption to be set
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THyperLinkColumn

Class THyperLinkColumn (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --THyperLinkColumn

THyperLinkColumn class

THyperLinkColumn contains a hyperlink for each item in the column. You can set the text and the url of the hyperlink by Text and NavigateUrl properties, respectively. You can also bind the text and url to specific data field in datasource by setting DataTextField and DataNavigateUrlField. Both can be formatted before rendering according to the DataTextFormatString and and DataNavigateUrlFormatString properties, respectively. If both Text and DataTextField are present, the latter takes precedence. The same rule applies to NavigateUrl and DataNavigateUrlField properties.

The hyperlinks in the column can be accessed by one of the following two methods:

1      $datagridItem->HyperLinkColumnID->HyperLink
2      $datagridItem->HyperLinkColumnID->Controls[0]
The second method is possible because the hyperlink control created within the datagrid cell is the first child.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | dataBindColumn ( mixed $sender, mixed $param) Databinds a cell in the column.
string | getDataNavigateUrlField ()
string | getDataNavigateUrlFormatString ()
string | getDataTextField ()
string | getDataTextFormatString ()
string | getNavigateUrl ()
string | getTarget ()
string | getText ()
void | initializeCell ( TTableCell $cell, integer $columnIndex, string $itemType) Initializes the specified cell to its initial values.
void | setDataNavigateUrlField ( string $value)
void | setDataNavigateUrlFormatString ( string $value)
void | setDataTextField ( string $value)
void | setDataTextFormatString ( string $value)
void | setNavigateUrl ( string $value) Sets the URL to link to when the hyperlink is clicked.
void | setTarget ( string $value) Sets the target window or frame to display the Web page content linked to when the hyperlink is clicked.
void | setText ( string $value) Sets the text caption of the hyperlink.
Methods Inherited From TDataGridColumn
TDataGridColumn::formatDataValue(), TDataGridColumn::getAllowSorting(), TDataGridColumn::getDataFieldValue(), TDataGridColumn::getEnableCellGrouping(), TDataGridColumn::getFooterRenderer(), TDataGridColumn::getFooterStyle(), TDataGridColumn::getFooterText(), TDataGridColumn::getHeaderImageUrl(), TDataGridColumn::getHeaderRenderer(), TDataGridColumn::getHeaderStyle(), TDataGridColumn::getHeaderText(), TDataGridColumn::getID(), TDataGridColumn::getItemStyle(), TDataGridColumn::getOwner(), TDataGridColumn::getSortExpression(), TDataGridColumn::getViewState(), TDataGridColumn::getVisible(), TDataGridColumn::initialize(), TDataGridColumn::initializeCell(), TDataGridColumn::initializeFooterCell(), TDataGridColumn::initializeHeaderCell(), TDataGridColumn::loadState(), TDataGridColumn::saveState(), TDataGridColumn::setEnableCellGrouping(), TDataGridColumn::setFooterRenderer(), TDataGridColumn::setFooterText(), TDataGridColumn::setHeaderImageUrl(), TDataGridColumn::setHeaderRenderer(), TDataGridColumn::setHeaderText(), TDataGridColumn::setID(), TDataGridColumn::setOwner(), TDataGridColumn::setSortExpression(), TDataGridColumn::setViewState(), TDataGridColumn::setVisible()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

dataBindColumn

public void dataBindColumn (mixed $sender , mixed $param )

Databinds a cell in the column.

This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

Input
mixed | $sender
mixed | $param
Output
Exception

getDataNavigateUrlField

public string getDataNavigateUrlField ()

Output
string the field name from the data source to bind to the navigate url of hyperlink
Exception

getDataNavigateUrlFormatString

public string getDataNavigateUrlFormatString ()

Output
string the formatting string used to control how the navigate url of hyperlink will be displayed.
Exception

getDataTextField

public string getDataTextField ()

Output
string the field name from the data source to bind to the hyperlink caption
Exception

getDataTextFormatString

public string getDataTextFormatString ()

Output
string the formatting string used to control how the hyperlink caption will be displayed.
Exception

getNavigateUrl

public string getNavigateUrl ()

Output
string the URL to link to when the hyperlink is clicked.
Exception

getTarget

public string getTarget ()

Output
string the target window or frame to display the Web page content linked to when the hyperlink is clicked.
Exception

getText

public string getText ()

Output
string the text caption of the hyperlink
Exception

initializeCell

public void initializeCell (TTableCell $cell , integer $columnIndex , string $itemType )

Initializes the specified cell to its initial values.

This method overrides the parent implementation. It creates a hyperlink within the cell.

Input
TTableCell | $cell | the cell to be initialized.
integer | $columnIndex | the index to the Columns property that the cell resides in.
string | $itemType | the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)
Output
Exception

setDataNavigateUrlField

public void setDataNavigateUrlField (string $value )

Input
string $value the field name from the data source to bind to the navigate url of hyperlink
Output
Exception

setDataNavigateUrlFormatString

public void setDataNavigateUrlFormatString (string $value )

Input
string $value the formatting string used to control how the navigate url of hyperlink will be displayed.
Output
Exception

setDataTextField

public void setDataTextField (string $value )

Input
string $value the field name from the data source to bind to the hyperlink caption
Output
Exception

setDataTextFormatString

public void setDataTextFormatString (string $value )

Input
string $value the formatting string used to control how the hyperlink caption will be displayed.
Output
Exception

setNavigateUrl

public void setNavigateUrl (string $value )

Sets the URL to link to when the hyperlink is clicked.

Input
string $value the URL
Output
Exception

setTarget

public void setTarget (string $value )

Sets the target window or frame to display the Web page content linked to when the hyperlink is clicked.

Input
string $value the target window, valid values include '_blank', '_parent', '_self', '_top' and empty string.
Output
Exception

setText

public void setText (string $value )

Sets the text caption of the hyperlink.

Input
string $value the text caption to be set
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TImage

Class TImage (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TImage

Direct Known Sub-classes:

TActiveImage , TCaptcha , TImageButton , TImageMap

TImage class

TImage displays an image on a page. The image is specified via the ImageUrl property which takes a relative or absolute URL to the image file. The alignment of the image displayed is set by the ImageAlign property. To set alternative texts or long description of the image, use AlternateText or DescriptionUrl property, respectively.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attributes related to an HTML image element to renderer.
string | getAlternateText ()
string | getData () Returns the URL of the image file.
string | getDescriptionUrl ()
string | getImageAlign ()
string | getImageUrl ()
protected string | getTagName ()
void | renderContents ( THtmlWriter $writer) Renders the body content of the image.
void | setAlternateText ( string $value) Sets the alternative text to be displayed in the TImage when the image is unavailable.
void | setData ( string $value) Sets the URL of the image.
void | setDescriptionUrl ( string $value)
void | setImageAlign ( string $value) Sets the alignment of the image with respective to other elements on the page.
void | setImageUrl ( string $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attributes related to an HTML image element to renderer.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

getAlternateText

public string getAlternateText ()

Output
string the alternative text displayed in the TImage component when the image is unavailable.
Exception

getData

public string getData ()

Returns the URL of the image file.

This method is required by IDataRenderer. It is the same as getImageUrl().

Output
string the URL of the image file.
Exception

getDescriptionUrl

public string getDescriptionUrl ()

Output
string the URL to long description
Exception

getImageAlign

public string getImageAlign ()

Output
string the alignment of the image with respective to other elements on the page, defaults to empty.
Exception

getImageUrl

public string getImageUrl ()

Output
string the URL of the image file
Exception

getTagName

protected string getTagName ()

Output
string tag name of image control
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders the body content of the image.

Nothing to be rendered within image tags.

Input
THtmlWriter $writer the writer for rendering
Output
Exception

setAlternateText

public void setAlternateText (string $value )

Sets the alternative text to be displayed in the TImage when the image is unavailable.

Input
string $value the alternative text
Output
Exception

setData

public void setData (string $value )

Sets the URL of the image.

This method is required by IDataRenderer. It is the same as setImageUrl().

Input
string $value the URL of the image file.
Output
Exception

setDescriptionUrl

public void setDescriptionUrl (string $value )

Input
string $value the URL to the long description of the image.
Output
Exception

setImageAlign

public void setImageAlign (string $value )

Sets the alignment of the image with respective to other elements on the page.

Possible values include: absbottom, absmiddle, baseline, bottom, left, middle, right, texttop, and top. If an empty string is passed in, imagealign attribute will not be rendered.

Input
string $value the alignment of the image
Output
Exception

setImageUrl

public void setImageUrl (string $value )

Input
string $value the URL of the image file
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TImageButton

Class TImageButton (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TImage
               |
               --TImageButton

Direct Known Sub-classes:

TActiveImageButton

TImageButton class

TImageButton creates an image button on the page. It is used to submit data to a page. You can create either a submit button or a command button.

A command button has a command name (specified by the CommandName property) and and a command parameter (specified by CommandParameter property) associated with the button. This allows you to create multiple TLinkButton components on a Web page and programmatically determine which one is clicked with what parameter. You can provide an event handler for OnCommand event to programmatically control the actions performed when the command button is clicked. In the event handler, you can determine the CommandName property value and the CommandParameter property value through the TCommandParameter::getName and TCommandParameter::getParameter properties of the event parameter which is of type TCommandEventParameter.

A submit button does not have a command name associated with the button and clicking on it simply posts the Web page back to the server. By default, a TImageButton control is a submit button. You can provide an event handler for the OnClick event to programmatically control the actions performed when the submit button is clicked. The coordinates of the clicking point can be obtained from the OnClick event parameter, which is of type TImageClickEventParameter.

Clicking on button can trigger form validation, if CausesValidation is true. And the validation may be restricted within a certain group of validator controls by setting ValidationGroup property. If validation is successful, the data will be post back to the same page.

TImageButton displays the Text property as the hint text to the displayed image.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute name-value pairs to renderer.
protected boolean | canCauseValidation ()
boolean | getCausesValidation ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
string | getCommandName ()
string | getCommandParameter ()
boolean | getDataChanged () Returns a value indicating whether postback has caused the control data change.
boolean | getEnableClientScript ()
boolean | getIsDefaultButton ()
protected array | getPostBackOptions () Returns postback specifications for the button.
protected string | getTagName ()
string | getText ()
string | getValidationGroup ()
boolean | loadPostData ( string $key, array $values) This method checks if the TImageButton is clicked and loads the coordinates of the clicking position.
protected boolean | needPostBackScript ()
void | onClick ( TImageClickEventParameter $param) This method is invoked when the button is clicked.
void | onCommand ( TCommandEventParameter $param) This method is invoked when the button is clicked.
void | onPreRender ( mixed $param) Registers the image button to receive postback data during postback.
void | raisePostBackEvent ( TEventParameter $param) Raises the postback event.
void | raisePostDataChangedEvent () A dummy implementation for the IPostBackDataHandler interface.
protected void | renderClientControlScript ( mixed $writer) Renders the client-script code.
void | renderContents ( THtmlWriter $writer) Renders the body content enclosed between the control tag.
void | setCausesValidation ( boolean $value)
void | setCommandName ( string $value)
void | setCommandParameter ( string $value)
void | setEnableClientScript ( boolean $value)
void | setIsDefaultButton ( boolean $value)
void | setText ( string $value)
void | setValidationGroup ( string $value)
Methods Inherited From TImage
TImage::addAttributesToRender(), TImage::getAlternateText(), TImage::getData(), TImage::getDescriptionUrl(), TImage::getImageAlign(), TImage::getImageUrl(), TImage::getTagName(), TImage::renderContents(), TImage::setAlternateText(), TImage::setData(), TImage::setDescriptionUrl(), TImage::setImageAlign(), TImage::setImageUrl()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute name-value pairs to renderer.

This overrides the parent implementation with additional button specific attributes.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

canCauseValidation

protected boolean canCauseValidation ()

Output
boolean whether to perform validation if the button is clicked
Exception

getCausesValidation

public boolean getCausesValidation ()

Output
boolean whether postback event trigger by this button will cause input validation, default is true
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getCommandName

public string getCommandName ()

Output
string the command name associated with the OnCommand event.
Exception

getCommandParameter

public string getCommandParameter ()

Output
string the parameter associated with the OnCommand event
Exception

getDataChanged

public boolean getDataChanged ()

Returns a value indicating whether postback has caused the control data change.

This method is required by the IPostBackDataHandler interface.

Output
boolean whether postback has caused the control data change. False if the page is not in postback mode.
Exception

getEnableClientScript

public boolean getEnableClientScript ()

Output
boolean whether to render javascript.
Exception

getIsDefaultButton

public boolean getIsDefaultButton ()

Output
boolean true if this button is registered as a default button for a panel.
Exception

getPostBackOptions

protected array getPostBackOptions ()

Returns postback specifications for the button.

This method is used by framework and control developers.

Output
array parameters about how the button defines its postback behavior.
Exception

getTagName

protected string getTagName ()

Output
string tag name of the button
Exception

getText

public string getText ()

Output
string caption of the button
Exception

getValidationGroup

public string getValidationGroup ()

Output
string the group of validators which the button causes validation upon postback
Exception

loadPostData

public boolean loadPostData (string $key , array $values )

This method checks if the TImageButton is clicked and loads the coordinates of the clicking position.

This method is primarly used by framework developers.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the component has been changed
Exception

needPostBackScript

protected boolean needPostBackScript ()

Output
boolean whether the button needs javascript to do postback
Exception

onClick

public void onClick (TImageClickEventParameter $param )

This method is invoked when the button is clicked.

The method raises 'OnClick' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TImageClickEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onCommand

public void onCommand (TCommandEventParameter $param )

This method is invoked when the button is clicked.

The method raises 'OnCommand' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

Input
TCommandEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onPreRender

public void onPreRender (mixed $param )

Registers the image button to receive postback data during postback.

This is necessary because an image button, when postback, does not have direct mapping between post data and the image button name. This method overrides the parent implementation and is invoked before render.

Input
mixed $param event parameter
Output
Exception

raisePostBackEvent

public void raisePostBackEvent (TEventParameter $param )

Raises the postback event.

This method is required by IPostBackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick and OnCommand events. This method is mainly used by framework and control developers.

Input
TEventParameter $param the event parameter
Output
Exception

raisePostDataChangedEvent

public void raisePostDataChangedEvent ()

A dummy implementation for the IPostBackDataHandler interface.

Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Renders the client-script code.

Input
mixed $writer
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders the body content enclosed between the control tag.

This overrides the parent implementation with nothing to be rendered.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

setCausesValidation

public void setCausesValidation (boolean $value )

Input
boolean $value whether postback event trigger by this button will cause input validation
Output
Exception

setCommandName

public void setCommandName (string $value )

Input
string $value the command name associated with the OnCommand event.
Output
Exception

setCommandParameter

public void setCommandParameter (string $value )

Input
string $value the parameter associated with the OnCommand event.
Output
Exception

setEnableClientScript

public void setEnableClientScript (boolean $value )

Input
boolean $value whether to render javascript.
Output
Exception

setIsDefaultButton

public void setIsDefaultButton (boolean $value )

Input
boolean $value set by a panel to register this button as the default button for the panel.
Output
Exception

setText

public void setText (string $value )

Input
string $value caption of the button
Output
Exception

setValidationGroup

public void setValidationGroup (string $value )

Input
string $value the group of validators which the button causes validation upon postback
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TImageClickEventParameter

Class TImageClickEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TImageClickEventParameter

TImageClickEventParameter class

TImageClickEventParameter encapsulates the parameter data for TImageButton::onClick event of TImageButton controls.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
integer | getX ()
integer | getY ()
void | setX ( integer $value)
void | setY ( integer $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getX

public integer getX ()

Output
integer X coordinate of the clicking point, defaults to 0
Exception

getY

public integer getY ()

Output
integer Y coordinate of the clicking point, defaults to 0
Exception

setX

public void setX (integer $value )

Input
integer $value X coordinate of the clicking point
Output
Exception

setY

public void setY (integer $value )

Input
integer $value Y coordinate of the clicking point
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCircleHotSpot

Class TCircleHotSpot (Class Overview)

TComponent
   |
   --THotSpot
      |
      --TCircleHotSpot

Class TCircleHotSpot.

TCircleHotSpot defines a circular hot spot region in a TImageMap control.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
string | getCoordinates ()
integer | getRadius ()
string | getShape ()
integer | getX ()
integer | getY ()
void | setRadius ( integer $value)
void | setX ( integer $value)
void | setY ( integer $value)
Methods Inherited From THotSpot
THotSpot::getAccessKey(), THotSpot::getAlternateText(), THotSpot::getAttribute(), THotSpot::getAttributes(), THotSpot::getCausesValidation(), THotSpot::getHasAttributes(), THotSpot::getHotSpotMode(), THotSpot::getNavigateUrl(), THotSpot::getPostBackValue(), THotSpot::getTabIndex(), THotSpot::getTarget(), THotSpot::getValidationGroup(), THotSpot::getViewState(), THotSpot::hasAttribute(), THotSpot::removeAttribute(), THotSpot::render(), THotSpot::setAccessKey(), THotSpot::setAlternateText(), THotSpot::setAttribute(), THotSpot::setCausesValidation(), THotSpot::setHotSpotMode(), THotSpot::setNavigateUrl(), THotSpot::setPostBackValue(), THotSpot::setTabIndex(), THotSpot::setTarget(), THotSpot::setValidationGroup(), THotSpot::setViewState()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getCoordinates

public string getCoordinates ()

Output
string coordinates defining this hotspot shape
Exception

getRadius

public integer getRadius ()

Output
integer radius of the circular HotSpot region. Defaults to 0.
Exception

getShape

public string getShape ()

Output
string shape of this hotspot.
Exception

getX

public integer getX ()

Output
integer the X coordinate of the center of the circular HotSpot region. Defaults to 0.
Exception

getY

public integer getY ()

Output
integer the Y coordinate of the center of the circular HotSpot region. Defaults to 0.
Exception

setRadius

public void setRadius (integer $value )

Input
integer $value radius of the circular HotSpot region.
Output
Exception

setX

public void setX (integer $value )

Input
integer $value the X coordinate of the center of the circular HotSpot region.
Output
Exception

setY

public void setY (integer $value )

Input
integer $value the Y coordinate of the center of the circular HotSpot region.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THotSpot

Class THotSpot (Class Overview)

TComponent
   |
   --THotSpot

Direct Known Sub-classes:

TCircleHotSpot , TRectangleHotSpot , TPolygonHotSpot

THotSpot class.

THotSpot implements the basic functionality common to all hot spot shapes. Derived classes include TCircleHotSpot, TPolygonHotSpot and TRectangleHotSpot.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
string | getAccessKey ()
string | getAlternateText ()
string | getAttribute ( mixed $name)
TAttributeCollection | getAttributes () Returns the list of custom attributes.
boolean | getCausesValidation ()
abstract string | getCoordinates ()
boolean | getHasAttributes ()
THotSpotMode | getHotSpotMode ()
string | getNavigateUrl ()
string | getPostBackValue ()
abstract string | getShape ()
integer | getTabIndex ()
string | getTarget ()
string | getValidationGroup ()
protected mixed | getViewState ( string $key, mixed $defaultValue) Returns a viewstate value.
boolean | hasAttribute ( mixed $name)
string | removeAttribute ( string $name) Removes the named attribute.
void | render ( THtmlWriter $writer) Renders this hotspot.
void | setAccessKey ( string $value)
void | setAlternateText ( string $value)
void | setAttribute ( string $name, string $value) Sets a custom hotspot attribute.
void | setCausesValidation ( boolean $value)
void | setHotSpotMode ( THotSpotMode $value)
void | setNavigateUrl ( string $value)
void | setPostBackValue ( string $value)
void | setTabIndex ( integer $value)
void | setTarget ( string $value)
void | setValidationGroup ( string $value)
protected void | setViewState ( string $key, mixed $value, mixed $defaultValue) Sets a viewstate value.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getAccessKey

public string getAccessKey ()

Output
string the access key that allows you to quickly navigate to the HotSpot region. Defaults to ''.
Exception

getAlternateText

public string getAlternateText ()

Output
string the alternate text to display for a HotSpot object. Defaults to ''.
Exception

getAttribute

public string getAttribute (mixed $name )

Input
mixed | $name
Output
string | attribute value, null if attribute does not exist
Exception

getAttributes

public TAttributeCollection getAttributes ()

Returns the list of custom attributes.

Custom attributes are name-value pairs that may be rendered as HTML tags' attributes.

Output
TAttributeCollection the list of custom attributes
Exception

getCausesValidation

public boolean getCausesValidation ()

Output
boolean whether postback event trigger by this hotspot will cause input validation, default is true
Exception

getCoordinates

public abstract string getCoordinates ()

Output
string coordinates defining the hotspot shape.
Exception

getHasAttributes

public boolean getHasAttributes ()

Output
boolean whether the hotspot has custom attributes
Exception

getHotSpotMode

public THotSpotMode getHotSpotMode ()

Output
THotSpotMode the behavior of a HotSpot object when it is clicked. Defaults to THotSpotMode::NotSet.
Exception

getNavigateUrl

public string getNavigateUrl ()

Output
string the URL to navigate to when a HotSpot object is clicked. Defaults to ''.
Exception

getPostBackValue

public string getPostBackValue ()

Output
string a value that is post back when the HotSpot is clicked. Defaults to ''.
Exception

getShape

public abstract string getShape ()

Output
string shape of the hotspot, can be 'circle', 'rect', 'poly', etc.
Exception

getTabIndex

public integer getTabIndex ()

Output
integer the tab index of the HotSpot region. Defaults to 0.
Exception

getTarget

public string getTarget ()

Output
string the target window or frame to display the new page when the HotSpot region is clicked. Defaults to ''.
Exception

getValidationGroup

public string getValidationGroup ()

Output
string the group of validators which the hotspot causes validation upon postback
Exception

getViewState

protected mixed getViewState (string $key , mixed $defaultValue )

Returns a viewstate value.

This function is very useful in defining getter functions for component properties that must be kept in viewstate.

Input
string | $key | the name of the viewstate value to be returned
mixed | $defaultValue | the default value. If $key is not found in viewstate, $defaultValue will be returned
Output
mixed | the viewstate value corresponding to $key
Exception

hasAttribute

public boolean hasAttribute (mixed $name )

Input
mixed | $name
Output
boolean | whether the named attribute exists
Exception

removeAttribute

public string removeAttribute (string $name )

Removes the named attribute.

Input
string | $name | the name of the attribute to be removed.
Output
string | attribute value removed, null if attribute does not exist.
Exception

render

public void render (THtmlWriter $writer )

Renders this hotspot.

Input
THtmlWriter $writer
Output
Exception

setAccessKey

public void setAccessKey (string $value )

Input
string $value the access key that allows you to quickly navigate to the HotSpot region.
Output
Exception

setAlternateText

public void setAlternateText (string $value )

Input
string $value the alternate text to display for a HotSpot object.
Output
Exception

setAttribute

public void setAttribute (string $name , string $value )

Sets a custom hotspot attribute.

Input
string | $name | attribute name
string | $value | value of the attribute
Output
Exception

setCausesValidation

public void setCausesValidation (boolean $value )

Input
boolean $value whether postback event trigger by this hotspot will cause input validation
Output
Exception

setHotSpotMode

public void setHotSpotMode (THotSpotMode $value )

Input
THotSpotMode $value the behavior of a HotSpot object when it is clicked.
Output
Exception

setNavigateUrl

public void setNavigateUrl (string $value )

Input
string $value the URL to navigate to when a HotSpot object is clicked.
Output
Exception

setPostBackValue

public void setPostBackValue (string $value )

Input
string $value a value that is post back when the HotSpot is clicked.
Output
Exception

setTabIndex

public void setTabIndex (integer $value )

Input
integer $value the tab index of the HotSpot region.
Output
Exception

setTarget

public void setTarget (string $value )

Input
string $value the target window or frame to display the new page when the HotSpot region is clicked.
Output
Exception

setValidationGroup

public void setValidationGroup (string $value )

Input
string $value the group of validators which the hotspot causes validation upon postback
Output
Exception

setViewState

protected void setViewState (string $key , mixed $value , mixed $defaultValue )

Sets a viewstate value.

This function is very useful in defining setter functions for control properties that must be kept in viewstate. Make sure that the viewstate value must be serializable and unserializable.

Input
string | $key | the name of the viewstate value
mixed | $value | the viewstate value to be set
mixed | $defaultValue | default value. If $value===$defaultValue, the item will be cleared from the viewstate.
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THotSpotCollection

Class THotSpotCollection (Class Overview)

TComponent
   |
   --TList
      |
      --THotSpotCollection

THotSpotCollection class.

THotSpotCollection represents a collection of hotspots in an imagemap.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void
insertAt ( integer $index, mixed $item)
Inserts an item at the specified position.
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by inserting only THotSpot.

Input
integer | $index | the speicified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is not a THotSpot.


PRADO API Manual: Docs For Class THotSpotMode

Class THotSpotMode (Class Overview)

TEnumerable
   |
   --THotSpotMode

THotSpotMode class.

THotSpotMode defines the enumerable type for the possible hot spot modes.

The following enumerable values are defined:

  • NotSet: the mode is not specified
  • Navigate: clicking on the hotspot will redirect the browser to a different page
  • PostBack: clicking on the hotspot will cause a postback
  • Inactive: the hotspot is inactive (not clickable)

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Inactive
string | Navigate
string | NotSet
string | PostBack
Constant Details

Inactive

Type:

string

Value:

'Inactive'

Navigate

Type:

string

Value:

'Navigate'

NotSet

Type:

string

Value:

'NotSet'

PostBack

Type:

string

Value:

'PostBack'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TImageMap

Class TImageMap (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TImage
               |
               --TImageMap

TImageMap class

TImageMap represents an image on a page. Hotspot regions can be defined within the image. Depending on the HotSpotMode, clicking on the hotspots may trigger a postback or navigate to a specified URL. The hotspots defined may be accessed via HotSpots. Each hotspot is described as a THotSpot, which can be a circle, rectangle, polygon, etc. To add hotspot in a template, use the following,

1       <com:TImageMap>
2         <com:TCircleHotSpot ... />
3         <com:TRectangleHotSpot ... />
4         <com:TPolygonHotSpot ... />
5       </com:TImageMap>

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute name-value pairs to renderer.
void | addParsedObject ( string|TComponent $object) Processes an object that is created during parsing template.
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
THotSpotMode | getHotSpotMode ()
THotSpotCollection | getHotSpots ()
string | getTarget ()
void | onClick ( TImageMapEventParameter $param) Raises OnClick event.
void | raisePostBackEvent ( TEventParameter $param) Raises the postback event.
void | render ( THtmlWriter $writer) Renders this imagemap.
void | setHotSpotMode ( THotSpotMode $value) Sets the behavior of hotspot regions in this imagemap when they are clicked.
void | setTarget ( string $value)
Methods Inherited From TImage
TImage::addAttributesToRender(), TImage::getAlternateText(), TImage::getData(), TImage::getDescriptionUrl(), TImage::getImageAlign(), TImage::getImageUrl(), TImage::getTagName(), TImage::renderContents(), TImage::setAlternateText(), TImage::setData(), TImage::setDescriptionUrl(), TImage::setImageAlign(), TImage::setImageUrl()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string MAP_NAME_PREFIX
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute name-value pairs to renderer.

This overrides the parent implementation with additional imagemap specific attributes.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

addParsedObject

public void addParsedObject (string|TComponent $object )

Processes an object that is created during parsing template.

This method adds THotSpot objects into the hotspot collection of the imagemap.

Input
string|TComponent $object text string or component parsed and instantiated in template
Output
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getHotSpotMode

public THotSpotMode getHotSpotMode ()

Output
THotSpotMode the behavior of hotspot regions in this imagemap when they are clicked. Defaults to THotSpotMode::NotSet.
Exception

getHotSpots

public THotSpotCollection getHotSpots ()

Output
THotSpotCollection collection of hotspots defined in this imagemap.
Exception

getTarget

public string getTarget ()

Output
string the target window or frame to display the new page when a hotspot region is clicked within the imagemap. Defaults to ''.
Exception

onClick

public void onClick (TImageMapEventParameter $param )

Raises OnClick event.

This method is invoked when a hotspot region is clicked within the imagemap. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TImageMapEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raisePostBackEvent

public void raisePostBackEvent (TEventParameter $param )

Raises the postback event.

This method is required by IPostBackEventHandler interface. This method is mainly used by framework and control developers.

Input
TEventParameter $param the event parameter
Output
Exception

render

public void render (THtmlWriter $writer )

Renders this imagemap.

Input
THtmlWriter $writer
Output
Exception

setHotSpotMode

public void setHotSpotMode (THotSpotMode $value )

Sets the behavior of hotspot regions in this imagemap when they are clicked.

If an individual hotspot has a mode other than 'NotSet', the mode set in this imagemap will be ignored. By default, 'NotSet' is equivalent to 'Navigate'.

Input
THotSpotMode $value the behavior of hotspot regions in this imagemap when they are clicked.
Output
Exception

setTarget

public void setTarget (string $value )

Input
string $value the target window or frame to display the new page when a hotspot region is clicked within the imagemap.
Output
Exception

Constant Details

MAP_NAME_PREFIX

Type:

string

Value:

'ImageMap'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TImageMapEventParameter

Class TImageMapEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TImageMapEventParameter

TImageMapEventParameter class.

TImageMapEventParameter represents a postback event parameter when a hotspot is clicked and posts back in a TImageMap. To retrieve the post back value associated with the hotspot being clicked, access PostBackValue.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
string
getPostBackValue ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getPostBackValue

public string getPostBackValue ()

Output
string post back value associated with the hotspot clicked
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPolygonHotSpot

Class TPolygonHotSpot (Class Overview)

TComponent
   |
   --THotSpot
      |
      --TPolygonHotSpot

Class TPolygonHotSpot.

TPolygonHotSpot defines a polygon hot spot region in a TImageMap control.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
string | getCoordinates ()
string | getShape ()
void | setCoordinates ( string $value)
Methods Inherited From THotSpot
THotSpot::getAccessKey(), THotSpot::getAlternateText(), THotSpot::getAttribute(), THotSpot::getAttributes(), THotSpot::getCausesValidation(), THotSpot::getHasAttributes(), THotSpot::getHotSpotMode(), THotSpot::getNavigateUrl(), THotSpot::getPostBackValue(), THotSpot::getTabIndex(), THotSpot::getTarget(), THotSpot::getValidationGroup(), THotSpot::getViewState(), THotSpot::hasAttribute(), THotSpot::removeAttribute(), THotSpot::render(), THotSpot::setAccessKey(), THotSpot::setAlternateText(), THotSpot::setAttribute(), THotSpot::setCausesValidation(), THotSpot::setHotSpotMode(), THotSpot::setNavigateUrl(), THotSpot::setPostBackValue(), THotSpot::setTabIndex(), THotSpot::setTarget(), THotSpot::setValidationGroup(), THotSpot::setViewState()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getCoordinates

public string getCoordinates ()

Output
string coordinates of the vertices defining the polygon. Coordinates are concatenated together with comma ','. Each pair represents (x,y) of a vertex.
Exception

getShape

public string getShape ()

Output
string shape of this hotspot.
Exception

setCoordinates

public void setCoordinates (string $value )

Input
string $value coordinates of the vertices defining the polygon. Coordinates are concatenated together with comma ','. Each pair represents (x,y) of a vertex.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRectangleHotSpot

Class TRectangleHotSpot (Class Overview)

TComponent
   |
   --THotSpot
      |
      --TRectangleHotSpot

Class TRectangleHotSpot.

TRectangleHotSpot defines a rectangle hot spot region in a TImageMap control.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
integer | getBottom ()
string | getCoordinates ()
integer | getLeft ()
integer | getRight ()
string | getShape ()
integer | getTop ()
void | setBottom ( integer $value)
void | setLeft ( integer $value)
void | setRight ( integer $value)
void | setTop ( integer $value)
Methods Inherited From THotSpot
THotSpot::getAccessKey(), THotSpot::getAlternateText(), THotSpot::getAttribute(), THotSpot::getAttributes(), THotSpot::getCausesValidation(), THotSpot::getHasAttributes(), THotSpot::getHotSpotMode(), THotSpot::getNavigateUrl(), THotSpot::getPostBackValue(), THotSpot::getTabIndex(), THotSpot::getTarget(), THotSpot::getValidationGroup(), THotSpot::getViewState(), THotSpot::hasAttribute(), THotSpot::removeAttribute(), THotSpot::render(), THotSpot::setAccessKey(), THotSpot::setAlternateText(), THotSpot::setAttribute(), THotSpot::setCausesValidation(), THotSpot::setHotSpotMode(), THotSpot::setNavigateUrl(), THotSpot::setPostBackValue(), THotSpot::setTabIndex(), THotSpot::setTarget(), THotSpot::setValidationGroup(), THotSpot::setViewState()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getBottom

public integer getBottom ()

Output
integer the Y coordinate of the bottom side of the rectangle HotSpot region. Defaults to 0.
Exception

getCoordinates

public string getCoordinates ()

Output
string coordinates defining this hotspot shape
Exception

getLeft

public integer getLeft ()

Output
integer the X coordinate of the right side of the rectangle HotSpot region. Defaults to 0.
Exception

getRight

public integer getRight ()

Output
integer the X coordinate of the right side of the rectangle HotSpot region. Defaults to 0.
Exception

getShape

public string getShape ()

Output
string shape of this hotspot.
Exception

getTop

public integer getTop ()

Output
integer the Y coordinate of the top side of the rectangle HotSpot region. Defaults to 0.
Exception

setBottom

public void setBottom (integer $value )

Input
integer $value the Y coordinate of the bottom side of the rectangle HotSpot region.
Output
Exception

setLeft

public void setLeft (integer $value )

Input
integer $value the X coordinate of the right side of the rectangle HotSpot region.
Output
Exception

setRight

public void setRight (integer $value )

Input
integer $value the X coordinate of the right side of the rectangle HotSpot region.
Output
Exception

setTop

public void setTop (integer $value )

Input
integer $value the Y coordinate of the top side of the rectangle HotSpot region.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TInlineFrame

Class TInlineFrame (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TInlineFrame

TInlineFrame class

TInlineFrame displays an inline frame (iframe) on a Web page. The location of the frame content is specified by FrameUrl. The frame's alignment is specified by Align. The MarginWidth and MarginHeight properties define the number of pixels to use as the left/right margins and top/bottom margins, respectively, within the inline frame. The ScrollBars property specifies whether scrollbars are provided for the inline frame. And DescriptionUrl gives the URI of a long description of the frame's contents.

Original Prado v2 IFrame Author Information

Since: 3.0
Author: Jason Ragsdale <jrags@jasrags.net>
Author: Harry Pottash <hpottash@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute name-value pairs to renderer.
TInlineFrameAlign | getAlign ()
string | getData () Returns the URL that this iframe will load content from This method is required by IDataRenderer.
string | getDescriptionUrl ()
string | getFrameUrl ()
integer | getMarginHeight ()
integer | getMarginWidth ()
TInlineFrameScrollBars | getScrollBars ()
boolean | getShowBorder ()
protected string | getTagName ()
void | setAlign ( TInlineFrameAlign $value)
void | setData ( string $value) Sets the URL that this iframe will load content from.
void | setDescriptionUrl ( string $value)
void | setFrameUrl ( string $value)
void | setMarginHeight ( integer $value)
void | setMarginWidth ( integer $value)
void | setScrollBars ( TInlineFrameScrollBars $value)
void | setShowBorder ( boolean $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute name-value pairs to renderer.

This overrides the parent implementation with additional button specific attributes.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

getAlign

public TInlineFrameAlign getAlign ()

Output
TInlineFrameAlign alignment of the iframe. Defaults to TInlineFrameAlign::NotSet.
Exception

getData

public string getData ()

Returns the URL that this iframe will load content from This method is required by IDataRenderer.

It is the same as getFrameUrl().

Output
string the URL that this iframe will load content from
Exception

getDescriptionUrl

public string getDescriptionUrl ()

Output
string the URL to long description
Exception

getFrameUrl

public string getFrameUrl ()

Output
string URL that this iframe will load content from. Defaults to ''.
Exception

getMarginHeight

public integer getMarginHeight ()

Output
integer the amount of space, in pixels, that should be left between the frame's contents and the top and bottom margins. Defaults to -1, meaning not set.
Exception

getMarginWidth

public integer getMarginWidth ()

Output
integer the amount of space, in pixels, that should be left between the frame's contents and the left and right margins. Defaults to -1, meaning not set.
Exception

getScrollBars

public TInlineFrameScrollBars getScrollBars ()

Output
TInlineFrameScrollBars the visibility and position of scroll bars in an iframe. Defaults to TInlineFrameScrollBars::Auto.
Exception

getShowBorder

public boolean getShowBorder ()

Output
boolean whether there should be a visual separator between the frames. Defaults to true.
Exception

getTagName

protected string getTagName ()

Output
string tag name of the iframe.
Exception

setAlign

public void setAlign (TInlineFrameAlign $value )

Input
TInlineFrameAlign $value alignment of the iframe.
Output
Exception

setData

public void setData (string $value )

Sets the URL that this iframe will load content from.

This method is required by IDataRenderer. It is the same as setFrameUrl().

Input
string $value the URL that this iframe will load content from
Output
Exception

setDescriptionUrl

public void setDescriptionUrl (string $value )

Input
string $value the URL to the long description of the image.
Output
Exception

setFrameUrl

public void setFrameUrl (string $value )

Input
string $value URL that this iframe will load content from.
Output
Exception

setMarginHeight

public void setMarginHeight (integer $value )

Input
integer $value the amount of space, in pixels, that should be left between the frame's contents and the top and bottom margins.
Output
Exception

setMarginWidth

public void setMarginWidth (integer $value )

Input
integer $value the amount of space, in pixels, that should be left between the frame's contents and the left and right margins.
Output
Exception

setScrollBars

public void setScrollBars (TInlineFrameScrollBars $value )

Input
TInlineFrameScrollBars $value the visibility and position of scroll bars in an iframe.
Output
Exception

setShowBorder

public void setShowBorder (boolean $value )

Input
boolean $value whether there should be a visual separator between the frames.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TInlineFrameAlign

Class TInlineFrameAlign (Class Overview)

TEnumerable
   |
   --TInlineFrameAlign

TInlineFrameAlign class.

TInlineFrameAlign defines the enumerable type for the possible alignments that the content in a TInlineFrame could be.

The following enumerable values are defined:

  • NotSet: the alignment is not specified.
  • Left: left aligned
  • Right: right aligned
  • Top: top aligned
  • Middle: middle aligned
  • Bottom: bottom aligned

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Bottom
string | Left
string | Middle
string | NotSet
string | Right
string | Top
Constant Details

Bottom

Type:

string

Value:

'Bottom'

Left

Type:

string

Value:

'Left'

Middle

Type:

string

Value:

'Middle'

NotSet

Type:

string

Value:

'NotSet'

Right

Type:

string

Value:

'Right'

Top

Type:

string

Value:

'Top'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TInlineFrameScrollBars

Class TInlineFrameScrollBars (Class Overview)

TEnumerable
   |
   --TInlineFrameScrollBars

TInlineFrameScrollBars class.

TInlineFrameScrollBars defines the enumerable type for the possible scroll bar mode that a TInlineFrame control could use.

The following enumerable values are defined:

  • None: no scroll bars.
  • Auto: scroll bars automatically appeared when needed.
  • Both: show both horizontal and vertical scroll bars all the time.

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Auto
string | Both
string | None
Constant Details

Auto

Type:

string

Value:

'Auto'

Both

Type:

string

Value:

'Both'

None

Type:

string

Value:

'None'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TItemDataRenderer

Class TItemDataRenderer (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TDataRenderer
                  |
                  --TItemDataRenderer

Direct Known Sub-classes:

TDataGridItemRenderer , TDataListItemRenderer , TRepeaterItemRenderer

TItemDataRenderer class

TItemDataRenderer is the convient base class for template-based item data renderers. It implements the IItemDataRenderer interface, and because TItemDataRenderer extends from TTemplateControl, derived child classes can have templates to define their presentational layout.

The following properties are provided by TItemDataRenderer:

  • ItemIndex: zero-based index of this renderer in the item list collection.
  • ItemType: item type of this renderer, such as TListItemType::AlternatingItem
  • Data: data associated with this renderer

Since: 3.1.2
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TTemplateControl
EXT_TEMPLATE,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
integer | getItemIndex () Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
TListItemType | getItemType ()
void | setItemIndex ( integer $value) Sets the zero-based index for the item.
void | setItemType ( TListItemType $value)
Methods Inherited From TDataRenderer
TDataRenderer::getData(), TDataRenderer::setData()
Methods Inherited From TTemplateControl
TTemplateControl::createChildControls(), TTemplateControl::getIsSourceTemplateControl(), TTemplateControl::getMaster(), TTemplateControl::getMasterClass(), TTemplateControl::getTemplate(), TTemplateControl::getTemplateDirectory(), TTemplateControl::initRecursive(), TTemplateControl::injectContent(), TTemplateControl::loadTemplate(), TTemplateControl::registerContent(), TTemplateControl::registerContentPlaceHolder(), TTemplateControl::setMasterClass(), TTemplateControl::setTemplate()
Methods Inherited From TCompositeControl
TCompositeControl::initRecursive()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getItemIndex

public integer getItemIndex ()

Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.

If the item is not in the collection (e.g. it is a header item), it returns -1.

Output
integer zero-based index of the item.
Exception

getItemType

public TListItemType getItemType ()

Output
TListItemType item type
Exception

setItemIndex

public void setItemIndex (integer $value )

Sets the zero-based index for the item.

If the item is not in the item collection (e.g. it is a header item), -1 should be used.

Input
integer $value zero-based index of the item.
Output
Exception

setItemType

public void setItemType (TListItemType $value )

Input
TListItemType $value item type.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TJavascriptLogger

Class TJavascriptLogger (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TJavascriptLogger

TJavascriptLogger class.

Provides logging for client-side javascript. Example: template code

1     <com:TJavascriptLogger />

Client-side javascript code to log info, error, warn, debug

1     Logger.warn('A warning');
2      Logger.info('something happend');

To see the logger and console, press ALT-D (or CTRL-D on OS X). More information on the logger can be found at http://web.archive.org/web/20060512041505/gleepglop.com/javascripts/logger/

Since: 3.0
Author: Wei Zhuo<weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected string | getTagName ()
string | getToggleKey ()
void | onPreRender ( TEventParameter $param) Registers the required logger javascript.
void | renderContents ( THtmlWriter $writer) Register the required javascript libraries and display some general usage information.
void | setToggleKey ( string $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getTagName

protected string getTagName ()

Output
string tag name of the panel
Exception

getToggleKey

public string getToggleKey ()

Output
string keyboard key for toggling the console.
Exception

onPreRender

public void onPreRender (TEventParameter $param )

Registers the required logger javascript.

Input
TEventParameter $param event parameter
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Register the required javascript libraries and display some general usage information.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

setToggleKey

public void setToggleKey (string $value )

Input
string $value keyboard key for toggling the console, default is J.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TKeyboard

Class TKeyboard (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TKeyboard

Class TKeyboard.

TKeyboard displays a virtual keyboard that users can click on to enter input in an associated text box. It helps to reduce the keyboard recording hacking.

To use TKeyboard, write a template like following:

1      <com:TTextBox ID="PasswordInput" />
2      <com:TKeyboard ForControl="PasswordInput" />

A TKeyboard control is associated with a TTextBox control by specifying ForControl to be the ID of that control. When the textbox is in focus, a virtual keyboard will pop up; and when the text box is losing focus, the keyboard will hide automatically. Set AutoHide to false to keep the keyboard showing all the time.

The appearance of the keyboard can also be changed by specifying a customized CSS file via CssUrl. By default, the CSS class name for the keyboard is 'Keyboard'. This may also be changed by specifying KeyboardCssClass.

Since: 3.1.1
Author: Sergey Morkovkin <sergeymorkovkin@mail.ru> and Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute name-value pairs to renderer.
boolean | getAutoHide ()
protected string | getClientClassName ()
protected array | getClientOptions ()
string | getCssUrl ()
string | getForControl ()
string | getKeyboardCssClass ()
void | onPreRender ( mixed $param) Registers CSS and JS.
protected void | registerClientScript () Registers the relevant JavaScript.
protected void | registerStyleSheet () Registers the CSS relevant to the TKeyboard.
void | setAutoHide ( boolean $value)
void | setCssUrl ( string $value)
void | setForControl ( string $value) Sets the ID path of the TTextBox control.
void | setKeyboardCssClass ( string $value) Sets a value indicating the CSS class name for the keyboard <div> element.
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute name-value pairs to renderer.

This method overrides the parent implementation with additional TKeyboard specific attributes.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

getAutoHide

public boolean getAutoHide ()

Output
boolean whether the keyboard should be hidden when the textbox is not in focus. Defaults to true.
Exception

getClientClassName

protected string getClientClassName ()

Output
string the Javascript class name for this control
Exception

getClientOptions

protected array getClientOptions ()

Output
array the JavaScript options for this control
Exception

getCssUrl

public string getCssUrl ()

Output
string the URL for the CSS file to customize the appearance of the keyboard.
Exception

getForControl

public string getForControl ()

Output
string the ID path of the TTextBox control
Exception

getKeyboardCssClass

public string getKeyboardCssClass ()

Output
string the CSS class name for the keyboard <div> element. Defaults to 'Keyboard'.
Exception

onPreRender

public void onPreRender (mixed $param )

Registers CSS and JS.

This method is invoked right before the control rendering, if the control is visible.

Input
mixed $param event parameter
Output
Exception

registerClientScript

protected void registerClientScript ()

Registers the relevant JavaScript.

Output
Exception

registerStyleSheet

protected void registerStyleSheet ()

Registers the CSS relevant to the TKeyboard.

It will register the CSS file specified by CssUrl. If that is not set, it will use the default CSS.

Output
Exception

setAutoHide

public void setAutoHide (boolean $value )

Input
boolean $value whether the keyboard should be hidden when the textbox is not in focus.
Output
Exception

setCssUrl

public void setCssUrl (string $value )

Input
string $value the URL for the CSS file to customize the appearance of the keyboard.
Output
Exception

setForControl

public void setForControl (string $value )

Sets the ID path of the TTextBox control.

The ID path is the dot-connected IDs of the controls reaching from the keyboard's naming container to the target control.

Input
string $value the ID path
Output
Exception

setKeyboardCssClass

public void setKeyboardCssClass (string $value )

Sets a value indicating the CSS class name for the keyboard <div> element.

Note, if you change this property, make sure you also supply a customized CSS file by specifying CssUrl which uses the new CSS class name for styling.

Input
string $value the CSS class name for the keyboard <div> element.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TLabel

Class TLabel (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel

Direct Known Sub-classes:

TActiveLabel , TBaseValidator

TLabel class

TLabel displays a piece of text on a Web page. Use Text property to set the text to be displayed. TLabel will render the contents enclosed within its component tag if Text is empty. To use TLabel as a form label, associate it with a control by setting the ForControl property. The associated control must be locatable within the label's naming container. If the associated control is not visible, the label will not be rendered, either.

Note, Text will NOT be encoded for rendering. Make sure it does not contain dangerous characters that you want to avoid.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attributes to renderer.
string | getData () Returns the text value of the label.
string | getForControl ()
protected string | getTagName ()
string | getText ()
void | render ( THtmlWriter $writer) Renders the label.
void | renderContents ( THtmlWriter $writer) Renders the body content of the label.
void | setData ( string $value) Sets the text value of the label.
void | setForControl ( string $value) Sets the ID of the control that the label is associated with.
void | setText ( string $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attributes to renderer.

Input
THtmlWriter | $writer | the renderer
Output
Exception
throws | TInvalidDataValueException if associated control cannot be found using the ID

getData

public string getData ()

Returns the text value of the label.

This method is required by IDataRenderer. It is the same as getText().

Output
string the text value of the label
Exception

getForControl

public string getForControl ()

Output
string the associated control ID
Exception

getTagName

protected string getTagName ()

Output
string tag name of the label, returns 'label' if there is an associated control, 'span' otherwise.
Exception

getText

public string getText ()

Output
string the text value of the label
Exception

render

public void render (THtmlWriter $writer )

Renders the label.

It overrides the parent implementation by checking if an associated control is visible or not. If not, the label will not be rendered.

Input
THtmlWriter $writer writer
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders the body content of the label.

Input
THtmlWriter $writer the renderer
Output
Exception

setData

public void setData (string $value )

Sets the text value of the label.

This method is required by IDataRenderer. It is the same as setText().

Input
string $value the text value of the label
Output
Exception

setForControl

public void setForControl (string $value )

Sets the ID of the control that the label is associated with.

The control must be locatable via TControl::findControl using the ID.

Input
string $value the associated control ID
Output
Exception

setText

public void setText (string $value )

Input
string $value the text value of the label
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TLinkButton

Class TLinkButton (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLinkButton

Direct Known Sub-classes:

TActiveLinkButton

TLinkButton class

TLinkButton creates a hyperlink style button on the page. TLinkButton has the same appearance as a hyperlink. However, it is mainly used to submit data to a page. Like TButton, you can create either a submit button or a command button.

A command button has a command name (specified by the CommandName property) and and a command parameter (specified by CommandParameter property) associated with the button. This allows you to create multiple TLinkButton components on a Web page and programmatically determine which one is clicked with what parameter. You can provide an event handler for OnCommand event to programmatically control the actions performed when the command button is clicked. In the event handler, you can determine the CommandName property value and the CommandParameter property value through the TCommandParameter::getName and TCommandParameter::getParameter properties of the event parameter which is of type TCommandEventParameter.

A submit button does not have a command name associated with the button and clicking on it simply posts the Web page back to the server. By default, a TLinkButton component is a submit button. You can provide an event handler for the OnClick event to programmatically control the actions performed when the submit button is clicked.

Clicking on button can trigger form validation, if CausesValidation is true. And the validation may be restricted within a certain group of validator controls by setting ValidationGroup property. If validation is successful, the data will be post back to the same page.

TLinkButton will display the Text property value as the hyperlink text. If Text is empty, the body content of TLinkButton will be displayed. Therefore, you can use TLinkButton as an image button by enclosing an &lt;img&gt; tag as the body of TLinkButton.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute name-value pairs to renderer.
boolean | getCausesValidation ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
string | getCommandName ()
string | getCommandParameter ()
string | getData () Returns the caption of the button.
boolean | getEnableClientScript ()
boolean | getIsDefaultButton ()
protected array | getPostBackOptions () Returns postback specifications for the button.
protected string | getTagName ()
string | getText ()
string | getValidationGroup ()
void | onClick ( TEventParameter $param) This method is invoked when the button is clicked.
void | onCommand ( TCommandEventParameter $param) This method is invoked when the button is clicked.
void | raisePostBackEvent ( TEventParameter $param) Raises the postback event.
protected void | renderClientControlScript ( THtmlWriter $writer) Renders the client-script code.
void | renderContents ( THtmlWriter $writer) Renders the body content enclosed between the control tag.
protected void | renderLinkButtonHref ( THtmlWriter $writer) Renders the Href for link button.
void | setCausesValidation ( string $value) Sets the value indicating whether postback event trigger by this button will cause input validation.
void | setCommandName ( string $value)
void | setCommandParameter ( string $value)
void | setData ( string $value) Sets the caption of the button.
void | setEnableClientScript ( boolean $value)
void | setIsDefaultButton ( boolean $value)
void | setText ( string $value)
void | setValidationGroup ( string $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute name-value pairs to renderer.

This overrides the parent implementation with additional button specific attributes.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

getCausesValidation

public boolean getCausesValidation ()

Output
boolean whether postback event trigger by this button will cause input validation
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getCommandName

public string getCommandName ()

Output
string the command name associated with the OnCommand event.
Exception

getCommandParameter

public string getCommandParameter ()

Output
string the parameter associated with the OnCommand event
Exception

getData

public string getData ()

Returns the caption of the button.

This method is required by IDataRenderer. It is the same as getText().

Output
string caption of the button.
Exception

getEnableClientScript

public boolean getEnableClientScript ()

Output
boolean whether to render javascript.
Exception

getIsDefaultButton

public boolean getIsDefaultButton ()

Output
boolean true if this button is registered as a default button for a panel.
Exception

getPostBackOptions

protected array getPostBackOptions ()

Returns postback specifications for the button.

This method is used by framework and control developers.

Output
array parameters about how the button defines its postback behavior.
Exception

getTagName

protected string getTagName ()

Output
string tag name of the button
Exception

getText

public string getText ()

Output
string the text caption of the button
Exception

getValidationGroup

public string getValidationGroup ()

Output
string the group of validators which the button causes validation upon postback
Exception

onClick

public void onClick (TEventParameter $param )

This method is invoked when the button is clicked.

The method raises 'OnClick' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handler can be invoked.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onCommand

public void onCommand (TCommandEventParameter $param )

This method is invoked when the button is clicked.

The method raises 'OnCommand' event to fire up the event handlers. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

Input
TCommandEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raisePostBackEvent

public void raisePostBackEvent (TEventParameter $param )

Raises the postback event.

This method is required by IPostBackEventHandler interface. If CausesValidation is true, it will invoke the page's TPage::validate method first. It will raise OnClick and OnCommand events. This method is mainly used by framework and control developers.

Input
TEventParameter $param the event parameter
Output
Exception

renderClientControlScript

protected void renderClientControlScript (THtmlWriter $writer )

Renders the client-script code.

Input
THtmlWriter $writer renderer
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders the body content enclosed between the control tag.

If Text is not empty, it will be rendered. Otherwise, the body content enclosed in the control tag will be rendered.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderLinkButtonHref

protected void renderLinkButtonHref (THtmlWriter $writer )

Renders the Href for link button.

Input
THtmlWriter $writer renderer
Output
Exception

setCausesValidation

public void setCausesValidation (string $value )

Sets the value indicating whether postback event trigger by this button will cause input validation.

Input
string $value the text caption to be set
Output
Exception

setCommandName

public void setCommandName (string $value )

Input
string $value the command name associated with the OnCommand event.
Output
Exception

setCommandParameter

public void setCommandParameter (string $value )

Input
string $value the parameter associated with the OnCommand event.
Output
Exception

setData

public void setData (string $value )

Sets the caption of the button.

This method is required by IDataRenderer. It is the same as setText().

Input
string $value caption of the button
Output
Exception

setEnableClientScript

public void setEnableClientScript (boolean $value )

Input
boolean $value whether to render javascript.
Output
Exception

setIsDefaultButton

public void setIsDefaultButton (boolean $value )

Input
boolean $value set by a panel to register this button as the default button for the panel.
Output
Exception

setText

public void setText (string $value )

Input
string $value the text caption to be set
Output
Exception

setValidationGroup

public void setValidationGroup (string $value )

Input
string $value the group of validators which the button causes validation upon postback
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TListBox

Class TListBox (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TListBox

Direct Known Sub-classes:

TActiveListBox

TListBox class

TListBox displays a list box on a Web page that allows single or multiple selection. The list box allows multiple selections if SelectionMode is TListSelectionMode::Multiple. It takes single selection only if Single. The property Rows specifies how many rows of options are visible at a time. See TListControl for inherited properties.

Since v3.0.3, TListBox starts to support optgroup. To specify an option group for a list item, set a Group attribute with it,

1       $listitem->Attributes->Group="Group Name";
1       // or <com:TListItem Attributes.Group="Group Name" .../> in template

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute name-value pairs to renderer.
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
boolean | getDataChanged () Returns a value indicating whether postback has caused the control data change.
protected boolean | getIsMultiSelect ()
bool | getIsValid () Returns true if this control validated successfully.
integer | getRows ()
TListSelectionMode | getSelectionMode ()
mixed | getValidationPropertyValue () Returns the value to be validated.
boolean | loadPostData ( string $key, array $values) Loads user input data.
void | onPreRender ( mixed $param) Registers the list control to load post data on postback.
void | raisePostDataChangedEvent () Raises postdata changed event.
void | setIsValid ( bool $value)
void | setRows ( integer $value)
void | setSelectionMode ( TListSelectionMode $value)
Methods Inherited From TListControl
TListControl::addAttributesToRender(), TListControl::addParsedObject(), TListControl::clearSelection(), TListControl::createListItemCollection(), TListControl::formatDataValue(), TListControl::getAppendDataBoundItems(), TListControl::getAutoPostBack(), TListControl::getCausesValidation(), TListControl::getClientClassName(), TListControl::getData(), TListControl::getDataGroupField(), TListControl::getDataTextField(), TListControl::getDataTextFormatString(), TListControl::getDataValueField(), TListControl::getEnableClientScript(), TListControl::getHasItems(), TListControl::getIsMultiSelect(), TListControl::getItemCount(), TListControl::getItems(), TListControl::getPostBackOptions(), TListControl::getPromptText(), TListControl::getPromptValue(), TListControl::getSelectedIndex(), TListControl::getSelectedIndices(), TListControl::getSelectedItem(), TListControl::getSelectedValue(), TListControl::getSelectedValues(), TListControl::getTagName(), TListControl::getText(), TListControl::getValidationGroup(), TListControl::loadState(), TListControl::onSelectedIndexChanged(), TListControl::onTextChanged(), TListControl::performDataBinding(), TListControl::renderClientControlScript(), TListControl::renderContents(), TListControl::renderPrompt(), TListControl::saveState(), TListControl::setAppendDataBoundItems(), TListControl::setAutoPostBack(), TListControl::setCausesValidation(), TListControl::setData(), TListControl::setDataGroupField(), TListControl::setDataTextField(), TListControl::setDataTextFormatString(), TListControl::setDataValueField(), TListControl::setEnableClientScript(), TListControl::setPromptText(), TListControl::setPromptValue(), TListControl::setSelectedIndex(), TListControl::setSelectedIndices(), TListControl::setSelectedValue(), TListControl::setSelectedValues(), TListControl::setText(), TListControl::setValidationGroup()
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute name-value pairs to renderer.

This method overrides the parent implementation with additional list box specific attributes.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getDataChanged

public boolean getDataChanged ()

Returns a value indicating whether postback has caused the control data change.

This method is required by the IPostBackDataHandler interface.

Output
boolean whether postback has caused the control data change. False if the page is not in postback mode.
Exception

getIsMultiSelect

protected boolean getIsMultiSelect ()

Output
boolean whether this control allows multiple selection
Exception

getIsValid

public bool getIsValid ()

Returns true if this control validated successfully.

Defaults to true.

Output
bool wether this control validated successfully.
Exception

getRows

public integer getRows ()

Output
integer the number of rows to be displayed in the list control
Exception

getSelectionMode

public TListSelectionMode getSelectionMode ()

Output
TListSelectionMode the selection mode (Single, Multiple). Defaults to TListSelectionMode::Single.
Exception

getValidationPropertyValue

public mixed getValidationPropertyValue ()

Returns the value to be validated.

This methid is required by IValidatable interface.

Output
mixed the value of the property to be validated.
Exception

loadPostData

public boolean loadPostData (string $key , array $values )

Loads user input data.

This method is primarly used by framework developers.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the component has been changed
Exception

onPreRender

public void onPreRender (mixed $param )

Registers the list control to load post data on postback.

This method overrides the parent implementation.

Input
mixed $param event parameter
Output
Exception

raisePostDataChangedEvent

public void raisePostDataChangedEvent ()

Raises postdata changed event.

This method is required by IPostBackDataHandler interface. It is invoked by the framework when SelectedIndices property is changed on postback. This method is primarly used by framework developers.

Output
Exception

setIsValid

public void setIsValid (bool $value )

Input
bool $value wether this control is valid.
Output
Exception

setRows

public void setRows (integer $value )

Input
integer $value the number of rows to be displayed in the list control
Output
Exception

setSelectionMode

public void setSelectionMode (TListSelectionMode $value )

Input
TListSelectionMode $value the selection mode
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TListSelectionMode

Class TListSelectionMode (Class Overview)

TEnumerable
   |
   --TListSelectionMode

TListSelectionMode class.

TListSelectionMode defines the enumerable type for the possible selection modes of a TListBox.

The following enumerable values are defined:

  • Single: single selection
  • Multiple: allow multiple selection

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Multiple
string | Single
Constant Details

Multiple

Type:

string

Value:

'Multiple'

Single

Type:

string

Value:

'Single'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TListControl

Class TListControl (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl

Direct Known Sub-classes:

TBulletedList , TCheckBoxList , TDropDownList , TListBox

TListControl class

TListControl is a base class for list controls, such as TListBox, TDropDownList, TCheckBoxList, etc. It manages the items and their status in a list control. It also implements how the items can be populated from template and data source.

The property getItems returns a list of the items in the control. To specify or determine which item is selected, use the SelectedIndex property that indicates the zero-based index of the selected item in the item list. You may also use SelectedItem and SelectedValue to get the selected item and its value. For multiple selection lists (such as TCheckBoxList and TListBox), property SelectedIndices is useful.

TListControl implements AutoPostBack which allows a list control to postback the page if the selections of the list items are changed. The CausesValidation and ValidationGroup properties may be used to specify that validation be performed when auto postback occurs.

There are three ways to populate the items in a list control: from template, using DataSource and using DataSourceID. The latter two are covered in TDataBoundControl. To specify items via template, using the following template syntax:

1      <com:TListControl>
2        <com:TListItem Value="xxx" Text="yyy" >
3        <com:TListItem Value="xxx" Text="yyy" Selected="true" >
4        <com:TListItem Value="xxx" Text="yyy" >
5      </com:TListControl>

When DataSource or DataSourceID is used to populate list items, the DataTextField and DataValueField properties are used to specify which columns of the data will be used to populate the text and value of the items. For example, if a data source is as follows,

1      $dataSource=array(
2         array('name'=>'John', 'age'=>31),
3         array('name'=>'Cary', 'age'=>28),
4         array('name'=>'Rose', 'age'=>35),
5      );
setting DataTextField and DataValueField to 'name' and 'age' will make the first item's text be 'John', value be 31, the second item's text be 'Cary', value be 28, and so on. The DataTextFormatString property may be further used to format how the item should be displayed. See formatDataValue() for an explanation of the format string.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attributes to renderer.
void | addParsedObject ( mixed $object) Adds object parsed from template to the control.
void | clearSelection () Clears all existing selections.
protected TListItemCollection | createListItemCollection () Creates a collection object to hold list items.
protected string | formatDataValue ( string $formatString, mixed $value) Formats the text value according to a format string.
boolean | getAppendDataBoundItems ()
boolean | getAutoPostBack ()
boolean | getCausesValidation ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
string | getData () Returns the value of the selected item with the lowest cardinal index.
string | getDataGroupField ()
string | getDataTextField ()
string | getDataTextFormatString ()
string | getDataValueField ()
boolean | getEnableClientScript ()
boolean | getHasItems ()
protected boolean | getIsMultiSelect ()
integer | getItemCount ()
TListItemCollection | getItems ()
protected array | getPostBackOptions ()
string | getPromptText ()
string | getPromptValue ()
integer | getSelectedIndex ()
array | getSelectedIndices ()
TListItem|null | getSelectedItem ()
string | getSelectedValue ()
array | getSelectedValues ()
protected string | getTagName ()
string | getText ()
string | getValidationGroup ()
void | loadState () Loads items from viewstate.
void | onSelectedIndexChanged ( TEventParameter $param) Raises OnSelectedIndexChanged event when selection is changed.
void | onTextChanged ( TEventParameter $param) Raises OnTextChanged event when selection is changed.
protected void | performDataBinding ( Traversable $data) Performs databinding to populate list items from data source.
protected void | renderClientControlScript ( mixed $writer) Renders the javascript for list control.
void | renderContents ( THtmlWriter $writer) Renders body content of the list control.
protected void | renderPrompt ( THtmlWriter $writer) Renders the prompt text, if any.
void | saveState () Saves items into viewstate.
void | setAppendDataBoundItems ( boolean $value)
void | setAutoPostBack ( boolean $value) Sets the value indicating if postback automatically.
void | setCausesValidation ( boolean $value)
void | setData ( string $value) Selects an item by the specified value.
void | setDataGroupField ( string $value)
void | setDataTextField ( string $value)
void | setDataTextFormatString ( string $value) Sets data text format string.
void | setDataValueField ( string $value)
void | setEnableClientScript ( boolean $value)
void | setPromptText ( string $value)
void | setPromptValue ( string $value)
void | setSelectedIndex ( integer $index)
void | setSelectedIndices ( array $indices)
void | setSelectedValue ( string $value) Sets selection by item value.
void | setSelectedValues ( array $values)
void | setText ( string $value)
void | setValidationGroup ( string $value)
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attributes to renderer.

Input
THtmlWriter $writer the renderer
Output
Exception

addParsedObject

public void addParsedObject (mixed $object )

Adds object parsed from template to the control.

This method adds only TListItem objects into the Items collection. All other objects are ignored.

Input
mixed $object object parsed from template
Output
Exception

clearSelection

public void clearSelection ()

Clears all existing selections.

Output
Exception

createListItemCollection

protected TListItemCollection createListItemCollection ()

Creates a collection object to hold list items.

This method may be overriden to create a customized collection.

Output
TListItemCollection the collection object
Exception

formatDataValue

protected string formatDataValue (string $formatString , mixed $value )

Formats the text value according to a format string.

If the format string is empty, the original value is converted into a string and returned. If the format string starts with '#', the string is treated as a PHP expression within which the token '{0}' is translated with the data value to be formated. Otherwise, the format string and the data value are passed as the first and second parameters in http://www.php.net/sprintf.

Input
string | $formatString | format string
mixed | $value | the data to be formatted
Output
string | the formatted result
Exception

getAppendDataBoundItems

public boolean getAppendDataBoundItems ()

Output
boolean whether performing databind should append items or clear the existing ones. Defaults to false.
Exception

getAutoPostBack

public boolean getAutoPostBack ()

Output
boolean a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. Defaults to false.
Exception

getCausesValidation

public boolean getCausesValidation ()

Output
boolean whether postback event trigger by this list control will cause input validation, default is true.
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

Derived classes may override this method and return customized js class names.

Output
string the javascript class name
Exception

getData

public string getData ()

Returns the value of the selected item with the lowest cardinal index.

This method is required by IDataRenderer. It is the same as getSelectedValue().

Output
string the value of the selected item with the lowest cardinal index, empty if no selection.
Exception

getDataGroupField

public string getDataGroupField ()

Output
string the field of the data source that provides the label of the list item groups
Exception

getDataTextField

public string getDataTextField ()

Output
string the field of the data source that provides the text content of the list items.
Exception

getDataTextFormatString

public string getDataTextFormatString ()

Output
string the formatting string used to control how data bound to the list control is displayed.
Exception

getDataValueField

public string getDataValueField ()

Output
string the field of the data source that provides the value of each list item.
Exception

getEnableClientScript

public boolean getEnableClientScript ()

Output
boolean whether to render javascript.
Exception

getHasItems

public boolean getHasItems ()

Output
boolean whether the list control contains any items.
Exception

getIsMultiSelect

protected boolean getIsMultiSelect ()

Output
boolean whether this is a multiselect control. Defaults to false.
Exception

getItemCount

public integer getItemCount ()

Output
integer the number of items in the list control
Exception

getItems

public TListItemCollection getItems ()

Output
TListItemCollection the item collection
Exception

getPostBackOptions

protected array getPostBackOptions ()

Output
array postback options for JS postback code
Exception

getPromptText

public string getPromptText ()

Output
string the prompt text which is to be displayed as the first list item.
Exception

getPromptValue

public string getPromptValue ()

Output
string the prompt selection value.
Exception

getSelectedIndex

public integer getSelectedIndex ()

Output
integer the index (zero-based) of the item being selected, -1 if no item is selected.
Exception

getSelectedIndices

public array getSelectedIndices ()

Output
array list of index of items that are selected
Exception

getSelectedItem

public TListItem|null getSelectedItem ()

Output
TListItem|null the selected item with the lowest cardinal index, null if no item is selected.
Exception

getSelectedValue

public string getSelectedValue ()

Output
string the value of the selected item with the lowest cardinal index, empty if no selection
Exception

getSelectedValues

public array getSelectedValues ()

Output
array list of the selected item values (strings)
Exception

getTagName

protected string getTagName ()

Output
string tag name of the list control
Exception

getText

public string getText ()

Output
string selected value
Exception

getValidationGroup

public string getValidationGroup ()

Output
string the group of validators which the list control causes validation upon postback
Exception

loadState

public void loadState ()

Loads items from viewstate.

This method is invoked right after control state is loaded.

Output
Exception

onSelectedIndexChanged

public void onSelectedIndexChanged (TEventParameter $param )

Raises OnSelectedIndexChanged event when selection is changed.

This method is invoked when the list control has its selection changed by end-users.

Input
TEventParameter $param event parameter
Output
Exception

onTextChanged

public void onTextChanged (TEventParameter $param )

Raises OnTextChanged event when selection is changed.

This method is invoked when the list control has its selection changed by end-users.

Input
TEventParameter $param event parameter
Output
Exception

performDataBinding

protected void performDataBinding (Traversable $data )

Performs databinding to populate list items from data source.

This method is invoked by dataBind(). You may override this function to provide your own way of data population.

Input
Traversable $data the data
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Renders the javascript for list control.

Input
mixed $writer
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders body content of the list control.

This method renders items contained in the list control as the body content.

Input
THtmlWriter $writer writer
Output
Exception

renderPrompt

protected void renderPrompt (THtmlWriter $writer )

Renders the prompt text, if any.

Input
THtmlWriter $writer writer
Output
Exception

saveState

public void saveState ()

Saves items into viewstate.

This method is invoked right before control state is to be saved.

Output
Exception

setAppendDataBoundItems

public void setAppendDataBoundItems (boolean $value )

Input
boolean $value whether performing databind should append items or clear the existing ones.
Output
Exception

setAutoPostBack

public void setAutoPostBack (boolean $value )

Sets the value indicating if postback automatically.

An automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it.

Input
boolean $value the value indicating if postback automatically
Output
Exception

setCausesValidation

public void setCausesValidation (boolean $value )

Input
boolean $value whether postback event trigger by this list control will cause input validation.
Output
Exception

setData

public void setData (string $value )

Selects an item by the specified value.

This method is required by IDataRenderer. It is the same as setSelectedValue().

Input
string $value the value of the item to be selected.
Output
Exception

setDataGroupField

public void setDataGroupField (string $value )

Input
string $value the field of the data source that provides the label of the list item groups
Output
Exception

setDataTextField

public void setDataTextField (string $value )

Input
string $value the field of the data source that provides the text content of the list items.
Output
Exception

setDataTextFormatString

public void setDataTextFormatString (string $value )

Sets data text format string.

The format string is used in TDataValueFormatter::format() to format the Text property value of each item in the list control.

Input
string $value the formatting string used to control how data bound to the list control is displayed.
Output
Exception

setDataValueField

public void setDataValueField (string $value )

Input
string $value the field of the data source that provides the value of each list item.
Output
Exception

setEnableClientScript

public void setEnableClientScript (boolean $value )

Input
boolean $value whether to render javascript.
Output
Exception

setPromptText

public void setPromptText (string $value )

Input
string $value the prompt text which is to be displayed as the first list item.
Output
Exception

setPromptValue

public void setPromptValue (string $value )

Input
string $value the prompt selection value. If empty, PromptText will be used as the value.
Output
Exception

setSelectedIndex

public void setSelectedIndex (integer $index )

Input
integer $index the index (zero-based) of the item to be selected
Output
Exception

setSelectedIndices

public void setSelectedIndices (array $indices )

Input
array $indices list of index of items to be selected
Output
Exception

setSelectedValue

public void setSelectedValue (string $value )

Sets selection by item value.

Existing selections will be cleared if the item value is found in the item collection. Note, if the value is null, existing selections will also be cleared.

Input
string $value the value of the item to be selected.
Output
Exception

setSelectedValues

public void setSelectedValues (array $values )

Input
array $values list of the selected item values
Output
Exception

setText

public void setText (string $value )

Input
string $value value to be selected
Output
Exception

setValidationGroup

public void setValidationGroup (string $value )

Input
string $value the group of validators which the list control causes validation upon postback
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TListItemCollection

Class TListItemCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TListItemCollection

Direct Known Sub-classes:

TActiveListItemCollection

TListItemCollection class.

TListItemCollection maintains a list of TListItem for TListControl.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
TListItem | createListItem ( integer $index) Creates a list item object.
protected TListItem | createNewListItem ( mixed $text)
integer | findIndexByText ( string $text, boolean $includeDisabled) Finds the lowest cardinal index of the item whose text is the one being looked for.
integer | findIndexByValue ( string $value, boolean $includeDisabled) Finds the lowest cardinal index of the item whose value is the one being looked for.
TListItem | findItemByText ( string $text, boolean $includeDisabled) Finds the item whose text is the one being looked for.
TListItem | findItemByValue ( string $value, boolean $includeDisabled) Finds the item whose value is the one being looked for.
void | insertAt ( integer $index, TListItem $item) Inserts an item into the collection.
void | loadState ( array|null $state) Loads state into every item in the collection.
array|null | saveState () Saves state of items.
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createListItem

public TListItem createListItem (integer $index )

Creates a list item object.

This method may be overriden to provide a customized list item object.

Input
integer | $index | index where the newly created item is to be inserted at. If -1, the item will be appended to the end.
Output
TListItem | list item object
Exception

createNewListItem

protected TListItem createNewListItem (mixed $text )

Input
mixed | $text
Output
TListItem | new item.
Exception

findIndexByText

public integer findIndexByText (string $text , boolean $includeDisabled )

Finds the lowest cardinal index of the item whose text is the one being looked for.

Input
string | $text | the text to be looked for
boolean | $includeDisabled | whether to look for disabled items also
Output
integer | the index of the item found, -1 if not found.
Exception

findIndexByValue

public integer findIndexByValue (string $value , boolean $includeDisabled )

Finds the lowest cardinal index of the item whose value is the one being looked for.

Input
string | $value | the value to be looked for
boolean | $includeDisabled | whether to look for disabled items also
Output
integer | the index of the item found, -1 if not found.
Exception

findItemByText

public TListItem findItemByText (string $text , boolean $includeDisabled )

Finds the item whose text is the one being looked for.

Input
string | $text | the text to be looked for
boolean | $includeDisabled | whether to look for disabled items also
Output
TListItem | the item found, null if not found.
Exception

findItemByValue

public TListItem findItemByValue (string $value , boolean $includeDisabled )

Finds the item whose value is the one being looked for.

Input
string | $value | the value to be looked for
boolean | $includeDisabled | whether to look for disabled items also
Output
TListItem | the item found, null if not found.
Exception

insertAt

public void insertAt (integer $index , TListItem $item )

Inserts an item into the collection.

Input
integer | $index | the location where the item will be inserted. The current item at the place and the following ones will be moved backward.
TListItem | $item | the item to be inserted.
Output
Exception
throws | TInvalidDataTypeException if the item being inserted is neither a string nor TListItem

loadState

public void loadState (array|null $state )

Loads state into every item in the collection.

This method should only be used by framework and control developers.

Input
array|null $state state to be loaded.
Output
Exception

saveState

public array|null saveState ()

Saves state of items.

This method should only be used by framework and control developers.

Output
array|null the saved state
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TListControlValidator

Class TListControlValidator (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TListControlValidator

TListControlValidator class.

TListControlValidator checks the number of selection and their values for a TListControl that allows multiple selection.

You can specify the minimum or maximum (or both) number of selections required using the MinSelection and MaxSelection properties, respectively. In addition, you can specify a comma separated list of required selected values via the RequiredSelections property.

Examples

  • At least two selections

    1         <com:TListBox ID="listbox" SelectionMode="Multiple">
    2             <com:TListItem Text="item1" Value="value1" />
    3             <com:TListItem Text="item2" Value="value2" />
    4             <com:TListItem Text="item3" Value="value3" />
    5         </com:TListBox>
    6
    7         <com:TListControlValidator
    8             ControlToValidate="listbox"
    9             MinSelection="2"
    10            ErrorMessage="Please select at least 2" />
  • "value1" must be selected and at least 1 other

    1         <com:TCheckBoxList ID="checkboxes">
    2             <com:TListItem Text="item1" Value="value1" />
    3             <com:TListItem Text="item2" Value="value2" />
    4             <com:TListItem Text="item3" Value="value3" />
    5         </com:TCheckBoxList>
    6
    7         <com:TListControlValidator
    8             ControlToValidate="checkboxes"
    9             RequiredSelections="value1"
    10            MinSelection="2"
    11            ErrorMessage="Please select 'item1' and at least 1 other" />

Since: 3.0
Author: Xiang Wei Zhuo <weizhuo[at]gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected boolean | evaluateIsValid () This method overrides the parent's implementation.
protected string | getClientClassName () Gets the name of the javascript class responsible for performing validation for this control.
protected array | getClientScriptOptions () Returns an array of javascript validator options.
integer | getMaxSelection ()
integer | getMinSelection ()
string | getRequiredSelections () Get a comma separated list of required selected values.
protected array | getRequiredValues ()
protected array | getSelection ( TListControl $control)
void | setMaxSelection ( integer $value)
void | setMinSelection ( integer $value)
void | setRequiredSelections ( string $value) Set the list of required values, using aa comma separated list.
Methods Inherited From TBaseValidator
TBaseValidator::addAttributesToRender(), TBaseValidator::createClientSide(), TBaseValidator::getClientScriptOptions(), TBaseValidator::getClientSide(), TBaseValidator::getControlCssClass(), TBaseValidator::getControlToValidate(), TBaseValidator::getDisplay(), TBaseValidator::getEnableClientScript(), TBaseValidator::getErrorMessage(), TBaseValidator::getFocusElementID(), TBaseValidator::getFocusOnError(), TBaseValidator::getIsValid(), TBaseValidator::getValidationGroup(), TBaseValidator::getValidationTarget(), TBaseValidator::getValidationValue(), TBaseValidator::onInit(), TBaseValidator::onPreRender(), TBaseValidator::onUnload(), TBaseValidator::onValidate(), TBaseValidator::onValidationError(), TBaseValidator::onValidationSuccess(), TBaseValidator::registerClientScriptValidator(), TBaseValidator::renderClientControlScript(), TBaseValidator::renderContents(), TBaseValidator::setControlCssClass(), TBaseValidator::setControlToValidate(), TBaseValidator::setDisplay(), TBaseValidator::setEnableClientScript(), TBaseValidator::setEnabled(), TBaseValidator::setErrorMessage(), TBaseValidator::setFocusElementID(), TBaseValidator::setFocusOnError(), TBaseValidator::setForControl(), TBaseValidator::setIsValid(), TBaseValidator::setValidationGroup(), TBaseValidator::updateControlCssClass(), TBaseValidator::validate()
Methods Inherited From TLabel
TLabel::addAttributesToRender(), TLabel::getData(), TLabel::getForControl(), TLabel::getTagName(), TLabel::getText(), TLabel::render(), TLabel::renderContents(), TLabel::setData(), TLabel::setForControl(), TLabel::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

evaluateIsValid

protected boolean evaluateIsValid ()

This method overrides the parent's implementation.

The validation succeeds if the input component changes its data from the InitialValue or the input component is not given.

Output
boolean whether the validation succeeds
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing validation for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientScriptOptions

protected array getClientScriptOptions ()

Returns an array of javascript validator options.

Output
array javascript validator options.
Exception

getMaxSelection

public integer getMaxSelection ()

Output
integer max number of selections. Defaults to -1, meaning not set.
Exception

getMinSelection

public integer getMinSelection ()

Output
integer min number of selections. Defaults to -1, meaning not set.
Exception

getRequiredSelections

public string getRequiredSelections ()

Get a comma separated list of required selected values.

Output
string comma separated list of required values.
Exception

getRequiredValues

protected array getRequiredValues ()

Output
array list of required values.
Exception

getSelection

protected array getSelection (TListControl $control )

Input
TListControl | $control | control to validate
Output
array | number of selected values and its values.
Exception

setMaxSelection

public void setMaxSelection (integer $value )

Input
integer $value max number of selections.
Output
Exception

setMinSelection

public void setMinSelection (integer $value )

Input
integer $value minimum number of selections.
Output
Exception

setRequiredSelections

public void setRequiredSelections (string $value )

Set the list of required values, using aa comma separated list.

Input
string $value comma separated list of required values.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TListItem

Class TListItem (Class Overview)

TComponent
   |
   --TListItem

TListItem class.

TListItem represents an item in a list control. Each item has a Text property and a Value property. If either one of them is not set, it will take the value of the other property. An item can be Selected or Enabled, and it can have additional Attributes which may be rendered if the list control supports so.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
string | getAttribute ( mixed $name)
TAttributeCollection | getAttributes ()
boolean | getEnabled ()
boolean | getHasAttributes ()
boolean | getSelected ()
string | getText ()
string | getValue ()
boolean | hasAttribute ( string $name)
string | removeAttribute ( string $name) Removes the named attribute.
void | setAttribute ( string $name, string $value)
void | setEnabled ( boolean $value)
void | setSelected ( boolean $value)
void | setText ( string $value)
void | setValue ( string $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getAttribute

public string getAttribute (mixed $name )

Input
mixed | $name
Output
string | the named attribute value, null if attribute does not exist
Exception

getAttributes

public TAttributeCollection getAttributes ()

Output
TAttributeCollection custom attributes
Exception

getEnabled

public boolean getEnabled ()

Output
boolean whether the item is enabled
Exception

getHasAttributes

public boolean getHasAttributes ()

Output
boolean whether the item has any custom attribute
Exception

getSelected

public boolean getSelected ()

Output
boolean whether the item is selected
Exception

getText

public string getText ()

Output
string text of the item
Exception

getValue

public string getValue ()

Output
string value of the item
Exception

hasAttribute

public boolean hasAttribute (string $name )

Input
string | $name | name of the attribute
Output
boolean | whether the named attribute exists
Exception

removeAttribute

public string removeAttribute (string $name )

Removes the named attribute.

Input
string | $name | the name of the attribute to be removed.
Output
string | attribute value removed, empty string if attribute does not exist.
Exception

setAttribute

public void setAttribute (string $name , string $value )

Input
string | $name | attribute name
string | $value | value of the attribute
Output
Exception

setEnabled

public void setEnabled (boolean $value )

Input
boolean $value whether the item is enabled
Output
Exception

setSelected

public void setSelected (boolean $value )

Input
boolean $value whether the item is selected
Output
Exception

setText

public void setText (string $value )

Input
string $value text of the item
Output
Exception

setValue

public void setValue (string $value )

Input
string $value value of the item
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TLiteral

Class TLiteral (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TLiteral

TLiteral class

TLiteral displays a static text on the Web page. TLiteral is similar to the TLabel control, except that the TLiteral control does not have style properties (e.g. BackColor, Font, etc.) You can programmatically control the text displayed in the control by setting the Text property. The text displayed may be HTML-encoded if the Encode property is set true (defaults to false).

TLiteral will render the contents enclosed within its component tag if Text is empty.

Note, if Encode is false, make sure Text does not contain unwanted characters that may bring security vulnerabilities.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getData () Returns the static text of the TLiteral.
boolean | getEncode ()
string | getText ()
void | render ( THtmlWriter $writer) Renders the literal control.
void | setData ( string $value) Sets the static text of the TLiteral.
void | setEncode ( boolean $value)
void | setText ( string $value) Sets the static text of the TLiteral
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getData

public string getData ()

Returns the static text of the TLiteral.

This method is required by IDataRenderer. It is the same as getText().

Output
string the static text of the TLiteral
Exception

getEncode

public boolean getEncode ()

Output
boolean whether the rendered text should be HTML-encoded. Defaults to false.
Exception

getText

public string getText ()

Output
string the static text of the TLiteral
Exception

render

public void render (THtmlWriter $writer )

Renders the literal control.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

setData

public void setData (string $value )

Sets the static text of the TLiteral.

This method is required by IDataRenderer. It is the same as setText().

Input
string $value the static text of the TLiteral
Output
Exception

setEncode

public void setEncode (boolean $value )

Input
boolean $value whether the rendered text should be HTML-encoded.
Output
Exception

setText

public void setText (string $value )

Sets the static text of the TLiteral

Input
string $value the text to be set
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TLiteralColumn

Class TLiteralColumn (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TLiteralColumn

TLiteralColumn class

TLiteralColumn represents a static text column that is bound to a field in a data source. The cells in the column will be displayed with static texts using the data indexed by DataField. You can customize the display by setting DataFormatString.

If DataField is not specified, the cells will be filled with Text.

If Encode is true, the static texts will be HTML-encoded.

Since: 3.0.5
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | dataBindColumn ( mixed $sender, mixed $param) Databinds a cell in the column.
string | getDataField ()
string | getDataFormatString ()
boolean | getEncode ()
string | getText ()
void | initializeCell ( TTableCell $cell, integer $columnIndex, string $itemType) Initializes the specified cell to its initial values.
void | setDataField ( string $value)
void | setDataFormatString ( string $value)
void | setEncode ( boolean $value)
void | setText ( string $value)
Methods Inherited From TDataGridColumn
TDataGridColumn::formatDataValue(), TDataGridColumn::getAllowSorting(), TDataGridColumn::getDataFieldValue(), TDataGridColumn::getEnableCellGrouping(), TDataGridColumn::getFooterRenderer(), TDataGridColumn::getFooterStyle(), TDataGridColumn::getFooterText(), TDataGridColumn::getHeaderImageUrl(), TDataGridColumn::getHeaderRenderer(), TDataGridColumn::getHeaderStyle(), TDataGridColumn::getHeaderText(), TDataGridColumn::getID(), TDataGridColumn::getItemStyle(), TDataGridColumn::getOwner(), TDataGridColumn::getSortExpression(), TDataGridColumn::getViewState(), TDataGridColumn::getVisible(), TDataGridColumn::initialize(), TDataGridColumn::initializeCell(), TDataGridColumn::initializeFooterCell(), TDataGridColumn::initializeHeaderCell(), TDataGridColumn::loadState(), TDataGridColumn::saveState(), TDataGridColumn::setEnableCellGrouping(), TDataGridColumn::setFooterRenderer(), TDataGridColumn::setFooterText(), TDataGridColumn::setHeaderImageUrl(), TDataGridColumn::setHeaderRenderer(), TDataGridColumn::setHeaderText(), TDataGridColumn::setID(), TDataGridColumn::setOwner(), TDataGridColumn::setSortExpression(), TDataGridColumn::setViewState(), TDataGridColumn::setVisible()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

dataBindColumn

public void dataBindColumn (mixed $sender , mixed $param )

Databinds a cell in the column.

This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

Input
mixed | $sender
mixed | $param
Output
Exception

getDataField

public string getDataField ()

Output
string the field name from the data source to bind to the column
Exception

getDataFormatString

public string getDataFormatString ()

Output
string the formatting string used to control how the bound data will be displayed.
Exception

getEncode

public boolean getEncode ()

Output
boolean whether the rendered text should be HTML-encoded. Defaults to false.
Exception

getText

public string getText ()

Output
string static text to be displayed in the column. Defaults to empty.
Exception

initializeCell

public void initializeCell (TTableCell $cell , integer $columnIndex , string $itemType )

Initializes the specified cell to its initial values.

This method overrides the parent implementation.

Input
TTableCell | $cell | the cell to be initialized.
integer | $columnIndex | the index to the Columns property that the cell resides in.
string | $itemType | the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)
Output
Exception

setDataField

public void setDataField (string $value )

Input
string $value the field name from the data source to bind to the column
Output
Exception

setDataFormatString

public void setDataFormatString (string $value )

Input
string $value the formatting string used to control how the bound data will be displayed.
Output
Exception

setEncode

public void setEncode (boolean $value )

Input
boolean $value whether the rendered text should be HTML-encoded.
Output
Exception

setText

public void setText (string $value )

Input
string $value static text to be displayed in the column.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMarkdown

Class TMarkdown (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextProcessor
               |
               --TTextHighlighter
                  |
                  --TMarkdown

TMarkdown class

TMarkdown is a control that produces HTML from code with markdown syntax.

Markdown is a text-to-HTML conversion tool for web writers. Markdown allows you to write using an easy-to-read, easy-to-write plain text format, then convert it to structurally valid XHTML (or HTML). Further documentation regarding Markdown can be found at http://daringfireball.net/projects/markdown/

To use TMarkdown, simply enclose the content to be rendered within the body of TMarkdown in a template.

See http://www.pradosoft.com/demos/quickstart/?page=Markdown for details on the Markdown syntax usage.

TMarkdown also performs syntax highlighting for code blocks whose language is recognized by TTextHighlighter. The language of a code block must be specified in the first line of the block and enclosed within a pair of square brackets (e.g. [php]).

Since: 3.0.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected string | highlightCode ( array $matches) Highlights source code using TTextHighlighter
string | processText ( string $text) Processes a text string.
Methods Inherited From TTextHighlighter
TTextHighlighter::getEnableCopyCode(), TTextHighlighter::getHeaderTemplate(), TTextHighlighter::getLanguage(), TTextHighlighter::getLineNumberStyle(), TTextHighlighter::getShowLineNumbers(), TTextHighlighter::getTabSize(), TTextHighlighter::getTagName(), TTextHighlighter::onPreRender(), TTextHighlighter::processText(), TTextHighlighter::registerStyleSheet(), TTextHighlighter::setEnableCopyCode(), TTextHighlighter::setLanguage(), TTextHighlighter::setLineNumberStyle(), TTextHighlighter::setShowLineNumbers(), TTextHighlighter::setTabSize()
Methods Inherited From TTextProcessor
TTextProcessor::addParsedObject(), TTextProcessor::getText(), TTextProcessor::renderContents(), TTextProcessor::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

highlightCode

protected string highlightCode (array $matches )

Highlights source code using TTextHighlighter

Input
array | $matches | matches of code blocks
Output
string | highlighted code.
Exception

processText

public string processText (string $text )

Processes a text string.

This method is required by the parent class.

Input
string | $text | text string to be processed
Output
string | the processed text result
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMultiView

Class TMultiView (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TMultiView

TMultiView class

TMultiView serves as a container for a group of TView controls. The view collection can be retrieved by Views. Each view contains child controls. TMultiView determines which view and its child controls are visible. At any time, at most one view is visible (called active). To make a view active, set ActiveView or ActiveViewIndex.

TMultiView also responds to specific command events raised from button controls contained in current active view. A command event with name 'NextView' will cause TMultiView to make the next available view active. Other command names recognized by TMultiView include

  • PreviousView : switch to previous view
  • SwitchViewID : switch to a view by its ID path
  • SwitchViewIndex : switch to a view by its index in the Views collection.
TMultiView raises OnActiveViewChanged event when its active view is changed during a postback.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | activateView ( TView $view, boolean $triggerViewChangedEvent) Activates the specified view.
void | addParsedObject ( string|TComponent $object) Processes an object that is created during parsing template.
boolean | bubbleEvent ( TControl $sender, mixed $param) Processes the events bubbled from child controls.
protected TViewCollection | createControlCollection () Creates a control collection object that is to be used to hold child controls
TView | getActiveView ()
integer | getActiveViewIndex ()
TViewCollection | getViews ()
void | ignoreBubbleEvents () Makes the multiview ignore all bubbled events.
void | loadState () Loads state into the wizard.
void | onActiveViewChanged ( TEventParameter $param) Raises OnActiveViewChanged event.
void | onInit ( TEventParameter $param) Initializes the active view if any.
void | render ( THtmlWriter $writer) Renders the currently active view.
void | setActiveView ( TView $view)
void | setActiveViewIndex ( integer $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | CMD_NEXTVIEW
string | CMD_PREVIOUSVIEW
string | CMD_SWITCHVIEWID
string | CMD_SWITCHVIEWINDEX
Method Details

activateView

protected void activateView (TView $view , boolean $triggerViewChangedEvent )

Activates the specified view.

If there is any view currently active, it will be deactivated.

Input
TView | $view | the view to be activated
boolean | $triggerViewChangedEvent | whether to trigger OnActiveViewChanged event.
Output
Exception

addParsedObject

public void addParsedObject (string|TComponent $object )

Processes an object that is created during parsing template.

This method overrides the parent implementation by adding only TView controls as children.

Input
string|TComponent | $object | text string or component parsed and instantiated in template
Output
Exception
throws | TConfigurationException if controls other than TView is being added

bubbleEvent

public boolean bubbleEvent (TControl $sender , mixed $param )

Processes the events bubbled from child controls.

The method handles view-related command events.

Input
TControl | $sender | sender of the event
mixed | $param | event parameter
Output
boolean | whether this event is handled
Exception

createControlCollection

protected TViewCollection createControlCollection ()

Creates a control collection object that is to be used to hold child controls

Output
TViewCollection control collection
Exception

getActiveView

public TView getActiveView ()

Output
TView | the currently active view, null if no active view
Exception
throws | TInvalidDataValueException if the current active view index is invalid

getActiveViewIndex

public integer getActiveViewIndex ()

Output
integer the zero-based index of the current view in the view collection. -1 if no active view. Default is -1.
Exception

getViews

public TViewCollection getViews ()

Output
TViewCollection the view collection
Exception

ignoreBubbleEvents

public void ignoreBubbleEvents ()

Makes the multiview ignore all bubbled events.

This is method is used internally by framework and control developers.

Output
Exception

loadState

public void loadState ()

Loads state into the wizard.

This method is invoked by the framework when the control state is being saved.

Output
Exception

onActiveViewChanged

public void onActiveViewChanged (TEventParameter $param )

Raises OnActiveViewChanged event.

The event is raised when the currently active view is changed to a new one

Input
TEventParameter $param event parameter
Output
Exception

onInit

public void onInit (TEventParameter $param )

Initializes the active view if any.

This method overrides the parent implementation.

Input
TEventParameter $param event parameter
Output
Exception

render

public void render (THtmlWriter $writer )

Renders the currently active view.

Input
THtmlWriter $writer the writer for the rendering purpose.
Output
Exception

setActiveView

public void setActiveView (TView $view )

Input
TView | $view | the view to be activated
Output
Exception
throws | TInvalidOperationException if the view is not in the view collection

setActiveViewIndex

public void setActiveViewIndex (integer $value )

Input
integer | $value | the zero-based index of the current view in the view collection. -1 if no active view.
Output
Exception
throws | TInvalidDataValueException if the view index is invalid
Constant Details

CMD_NEXTVIEW

Type:

string

Value:

'NextView'

CMD_PREVIOUSVIEW

Type:

string

Value:

'PreviousView'

CMD_SWITCHVIEWID

Type:

string

Value:

'SwitchViewID'

CMD_SWITCHVIEWINDEX

Type:

string

Value:

'SwitchViewIndex'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TView

Class TView (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TView

Direct Known Sub-classes:

TWizardStep

TView class

TView is a container for a group of controls. TView must be contained within a TMultiView control in which only one view can be active at one time.

To activate a view, set Active to true. When a view is activated, it raises OnActivate event; and when a view is deactivated, it raises OnDeactivate.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
boolean | getActive ()
boolean | getVisible ( boolean $checkParents)
void | onActivate ( TEventParameter $param) Raises OnActivate event.
void | onDeactivate ( TEventParameter $param) Raises OnDeactivate event.
void | setActive ( boolean $value)
void | setVisible ( boolean $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getActive

public boolean getActive ()

Output
boolean whether this view is active. Defaults to false.
Exception

getVisible

public boolean getVisible (boolean $checkParents )

Input
boolean | $checkParents | whether the parents should also be checked if visible
Output
boolean | whether this view is visible. The view is visible if it is active and its parent is visible.
Exception

onActivate

public void onActivate (TEventParameter $param )

Raises OnActivate event.

Input
TEventParameter $param event parameter
Output
Exception

onDeactivate

public void onDeactivate (TEventParameter $param )

Raises OnDeactivate event.

Input
TEventParameter $param event parameter
Output
Exception

setActive

public void setActive (boolean $value )

Input
boolean $value whether this view is active.
Output
Exception

setVisible

public void setVisible (boolean $value )

Input
boolean | $value
Output
Exception
throws | TInvalidOperationException whenever this method is invoked.


PRADO API Manual: Docs For Class TViewCollection

Class TViewCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TControlCollection
         |
         --TViewCollection

TViewCollection class.

TViewCollection represents a collection that only takes TView instances as collection elements.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void
insertAt ( integer $index, mixed $item)
Inserts an item at the specified position.
Methods Inherited From TControlCollection
TControlCollection::clear(), TControlCollection::getOwner(), TControlCollection::insertAt(), TControlCollection::removeAt()
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by ensuring only TView controls be added into the collection.

Input
integer | $index | the speicified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is neither a string nor a TControl.


PRADO API Manual: Docs For Class TOutputCache

Class TOutputCache (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TOutputCache

TOutputCache class.

TOutputCache enables caching a portion of a Web page, also known as partial caching. The content being cached can be either static or dynamic.

To use TOutputCache, simply enclose the content to be cached within the TOutputCache component tag on a template, e.g.,

1      <com:TOutputCache>
2        content to be cached
3      </com:TOutputCache>
where content to be cached can be static text and/or component tags.

The validity of the cached content is determined based on two factors: the Duration and the cache dependency. The former specifies the number of seconds that the data can remain valid in cache (defaults to 60s), while the latter specifies conditions that the cached data depends on. If a dependency changes, (e.g. relevant data in DB are updated), the cached data will be invalidated.

There are two ways to specify cache dependency. One may write event handlers to respond to the OnCheckDependency event and set the event parameter's TOutputCacheCheckDependencyEventParameter::getIsValid property to indicate whether the cached data remains valid or not. One can also extend TOutputCache and override its getCacheDependency function. While the former is easier to use, the latter offers more extensibility.

The content fetched from cache may be variated with respect to some parameters. It supports variation with respect to request parameters, which is specified by VaryByParam property. If a specified request parameter is different, a different version of cached content is used. This is extremely useful if a page's content may be variated according to some GET parameters. The content being cached may also be variated with user sessions if VaryBySession is set true. To variate the cached content by other factors, override calculateCacheKey() method.

Output caches can be nested. An outer cache takes precedence over an inner cache. This means, if the content cached by the inner cache expires or is invalidated, while that by the outer cache not, the outer cached content will be used.

Note, TOutputCache is effective only for non-postback page requests and when cache module is enabled.

Do not attempt to address child controls of TOutputCache when the cached content is to be used. Use ContentCached property to determine whether the content is cached or not.

Since: 3.1
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected string | calculateCacheKey () Calculates the cache key.
void | getAllowChildControls ( boolean 0) Returns a value indicating whether body contents are allowed for this control.
protected string | getBaseCacheKey ()
protected ICacheDependency | getCacheDependency () Returns the dependency of the data to be cached.
string | getCacheModuleID ()
integer | getCacheTime ()
boolean | getCachingPostBack ()
boolean | getContentCached ()
integer | getDuration ()
string | getVaryByParam ()
boolean | getVaryBySession ()
protected void | initRecursive ( TControl $namingContainer) Performs the Init step for the control and all its child controls.
protected void | loadRecursive ( TControl 0) Performs the Load step for the control and all its child controls.
protected void | loadStateRecursive ( array &$state, boolean $needViewState) Loads state (viewstate and controlstate) into a control and its children.
void | onCalculateKey ( TOutputCacheCalculateKeyEventParameter $param) This event is raised when the output cache is calculating cache key.
void | onCheckDependency ( TOutputCacheCheckDependencyEventParameter $param) This event is raised when the output cache is checking cache dependency.
protected void | preRenderRecursive ( TControl 0) Performs the PreRender step for the control and all its child controls.
void | registerAction ( string $context, string $funcName, array $funcParams) Registers an action associated with the content being cached.
void | render ( THtmlWriter $writer) Renders the output cache control.
protected array | saveStateRecursive ( boolean $needViewState) Saves all control state (viewstate and controlstate) as a collection.
void | setCacheKeyPrefix ( string $value) Sets the prefix of the cache key.
void | setCacheModuleID ( string $value)
void | setCachingPostBack ( boolean $value) Sets a value indicating whether cached output will be used on postback requests.
void | setDuration ( integer $value)
string | setVaryByParam ( mixed $value) Sets the names of the request parameters that should be used in calculating the cache key.
void | setVaryBySession ( boolean $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string CACHE_ID_PREFIX
Method Details

calculateCacheKey

protected string calculateCacheKey ()

Calculates the cache key.

The key is calculated based on the unique ID of this control and the request parameters specified via VaryByParam. If VaryBySession is true, the session ID will also participate in the key calculation. This method may be overriden to support other variations in the calculated cache key.

Output
string cache key
Exception

getAllowChildControls

public void getAllowChildControls (boolean 0 )

Returns a value indicating whether body contents are allowed for this control.

This method overrides the parent implementation by checking if cached content is available or not. If yes, it returns false, otherwise true.

Input
boolean 0 whether body contents are allowed for this control.
Output
Exception

getBaseCacheKey

protected string getBaseCacheKey ()

Output
string basic cache key without variations
Exception

getCacheDependency

protected ICacheDependency getCacheDependency ()

Returns the dependency of the data to be cached.

The default implementation simply returns null, meaning no specific dependency. This method may be overriden to associate the data to be cached with additional dependencies.

Output
Exception

getCacheModuleID

public string getCacheModuleID ()

Output
string the ID of the cache module. Defaults to '', meaning the primary cache module is used.
Exception

getCacheTime

public integer getCacheTime ()

Output
integer the timestamp of the cached content. This is only valid if the content is being cached.
Exception

getCachingPostBack

public boolean getCachingPostBack ()

Output
boolean whether cached output will be used on postback requests. Defaults to false.
Exception

getContentCached

public boolean getContentCached ()

Output
boolean whether content enclosed is cached or not
Exception

getDuration

public integer getDuration ()

Output
integer number of seconds that the data can remain in cache. Defaults to 60 seconds. Note, if cache dependency changes or cache space is limited, the data may be purged out of cache earlier.
Exception

getVaryByParam

public string getVaryByParam ()

Output
string a semicolon-separated list of strings used to vary the output cache. Defaults to ''.
Exception

getVaryBySession

public boolean getVaryBySession ()

Output
boolean whether the content being cached should be differentiated according to user sessions. Defaults to false.
Exception

initRecursive

protected void initRecursive (TControl $namingContainer )

Performs the Init step for the control and all its child controls.

This method overrides the parent implementation by setting up the stack of the output cache in the page. Only framework developers should use this method.

Input
TControl $namingContainer the naming container control
Output
Exception

loadRecursive

protected void loadRecursive (TControl 0 )

Performs the Load step for the control and all its child controls.

This method overrides the parent implementation by setting up the stack of the output cache in the page. If the data is restored from cache, it also recovers the actions associated with the cached data. Only framework developers should use this method.

Input
TControl 0 the naming container control
Output
Exception

loadStateRecursive

protected void loadStateRecursive (array &$state , boolean $needViewState )

Loads state (viewstate and controlstate) into a control and its children.

This method overrides the parent implementation by loading cached state if available. This method should only be used by framework developers.

Input
array | &$state | the collection of the state
boolean | $needViewState | whether the viewstate should be loaded
Output
Exception

onCalculateKey

public void onCalculateKey (TOutputCacheCalculateKeyEventParameter $param )

This event is raised when the output cache is calculating cache key.

By varying cache keys, one can obtain different versions of cached content. An event handler may be written to add variety of the key calculation. The value set in TOutputCacheCalculateKeyEventParameter::setCacheKey of this event parameter will be appended to the default key calculation scheme.

Input
TOutputCacheCalculateKeyEventParameter $param event parameter
Output
Exception

onCheckDependency

public void onCheckDependency (TOutputCacheCheckDependencyEventParameter $param )

This event is raised when the output cache is checking cache dependency.

An event handler may be written to check customized dependency conditions. The checking result should be saved by setting TOutputCacheCheckDependencyEventParameter::setIsValid property of the event parameter (which defaults to true).

Input
TOutputCacheCheckDependencyEventParameter $param event parameter
Output
Exception

preRenderRecursive

protected void preRenderRecursive (TControl 0 )

Performs the PreRender step for the control and all its child controls.

This method overrides the parent implementation by setting up the stack of the output cache in the page. Only framework developers should use this method.

Input
TControl 0 the naming container control
Output
Exception

registerAction

public void registerAction (string $context , string $funcName , array $funcParams )

Registers an action associated with the content being cached.

The registered action will be replayed if the content stored in the cache is served to end-users.

Input
string | $context | context of the action method. This is a property-path referring to the context object (e.g. Page, Page.ClientScript)
string | $funcName | method name of the context object
array | $funcParams | list of parameters to be passed to the action method
Output
Exception

render

public void render (THtmlWriter $writer )

Renders the output cache control.

This method overrides the parent implementation by capturing the output from its child controls and saving it into cache, if output cache is needed.

Input
THtmlWriter $writer
Output
Exception

saveStateRecursive

protected array saveStateRecursive (boolean $needViewState )

Saves all control state (viewstate and controlstate) as a collection.

This method overrides the parent implementation by saving state into cache if needed. This method should only be used by framework developers.

Input
boolean | $needViewState | whether the viewstate should be saved
Output
array | the collection of the control state (including its children's state).
Exception

setCacheKeyPrefix

public void setCacheKeyPrefix (string $value )

Sets the prefix of the cache key.

This method is used internally by TTemplate.

Input
string $value key prefix
Output
Exception

setCacheModuleID

public void setCacheModuleID (string $value )

Input
string $value the ID of the cache module. If empty, the primary cache module will be used.
Output
Exception

setCachingPostBack

public void setCachingPostBack (boolean $value )

Sets a value indicating whether cached output will be used on postback requests.

By default, this is disabled. Be very cautious when enabling it. If the cached content including interactive user controls such as TTextBox, TDropDownList, your page may fail to render on postbacks.

Input
boolean $value whether cached output will be used on postback requests.
Output
Exception

setDuration

public void setDuration (integer $value )

Input
integer | $value | number of seconds that the data can remain in cache. If 0, it means data is not cached.
Output
Exception
throws | TInvalidDataValueException if the value is smaller than 0.

setVaryByParam

public string setVaryByParam (mixed $value )

Sets the names of the request parameters that should be used in calculating the cache key.

The names should be concatenated by semicolons. By setting this value, the output cache will use different cached data for each different set of request parameter values.

Input
mixed | $value
Output
string | a semicolon-separated list of strings used to vary the output cache.
Exception

setVaryBySession

public void setVaryBySession (boolean $value )

Input
boolean $value whether the content being cached should be differentiated according to user sessions.
Output
Exception

Constant Details

CACHE_ID_PREFIX

Type:

string

Value:

'prado:outputcache'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TOutputCacheCalculateKeyEventParameter

Class TOutputCacheCalculateKeyEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TOutputCacheCalculateKeyEventParameter

TOutputCacheCalculateKeyEventParameter class

TOutputCacheCalculateKeyEventParameter encapsulates the parameter data for OnCalculateKey event of TOutputCache control.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
string | getCacheKey ()
void | setCacheKey ( string $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getCacheKey

public string getCacheKey ()

Output
string cache key to be appended to the default calculation scheme.
Exception

setCacheKey

public void setCacheKey (string $value )

Input
string $value cache key to be appended to the default calculation scheme
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TOutputCacheCheckDependencyEventParameter

Class TOutputCacheCheckDependencyEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TOutputCacheCheckDependencyEventParameter

TOutputCacheCheckDependencyEventParameter class

TOutputCacheCheckDependencyEventParameter encapsulates the parameter data for OnCheckDependency event of TOutputCache control.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
integer | getCacheTime ()
boolean | getIsValid ()
void | setCacheTime ( integer $value)
void | setIsValid ( boolean $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getCacheTime

public integer getCacheTime ()

Output
integer the timestamp of the cached result. You may use this to help determine any dependency is changed.
Exception

getIsValid

public boolean getIsValid ()

Output
boolean whether the dependency remains valid. Defaults to true.
Exception

setCacheTime

public void setCacheTime (integer $value )

Input
integer $value the timestamp of the cached result. This is used internally.
Output
Exception

setIsValid

public void setIsValid (boolean $value )

Input
boolean $value whether the dependency remains valid
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPager

Class TPager (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPager

Direct Known Sub-classes:

TActivePager

TPager class.

TPager creates a pager that provides UI for end-users to interactively specify which page of data to be rendered in a TDataBoundControl-derived control, such as TDataList, TRepeater, TCheckBoxList, etc. The target data-bound control is specified by ControlToPaginate, which must be the ID path of the target control reaching from the pager's naming container. Note, the target control must have its TDataBoundControl::setAllowPaging set to true.

TPager can display three different UIs, specified via Mode:

  • NextPrev: a next page and a previous page button are rendered.
  • Numeric: a list of page index buttons are rendered.
  • List: a dropdown list of page indices are rendered.
When the pager mode is either NextPrev or Numeric, the paging buttons may be displayed in three types by setting ButtonType:
  • LinkButton: a hyperlink button
  • PushButton: a normal button
  • ImageButton: an image button (please set XXXPageImageUrl properties accordingly to specify the button images.)
TPager raises an OnPageIndexChanged event when the end-user interacts with it and specifies a new page (e.g. clicking on a page button that leads to a new page.) The new page index may be obtained from the event parameter's property TPagerPageChangedEventParameter::getNewPageIndex. Normally, in the event handler, one can set the TDataBoundControl::getCurrentPageIndex to this new page index so that the new page of data is rendered.

Multiple pagers can be associated with the same data-bound control.

Since: 3.0.2
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
boolean | bubbleEvent ( TControl $sender, TEventParameter $param) Processes a bubbled event.
protected void | buildListPager () Builds a dropdown list pager
protected void | buildNextPrevPager () Builds a next-prev pager
protected void | buildNumericPager () Builds a numeric pager
protected void | buildPager () Builds the pager content based on the pager mode.
protected mixed | createPagerButton ( string $buttonType, boolean $enabled, string $text, string $commandName, string $commandParameter) Creates a pager button.
TPagerButtonType | getButtonType ()
string | getControlToPaginate ()
integer | getCurrentPageIndex ()
string | getFirstPageImageUrl ()
string | getFirstPageText ()
boolean | getIsFirstPage ()
boolean | getIsLastPage ()
string | getLastPageImageUrl ()
string | getLastPageText ()
TPagerMode | getMode ()
string | getNextPageImageUrl ()
string | getNextPageText ()
string | getNumericPageImageUrl ()
integer | getPageButtonCount ()
integer | getPageCount ()
protected void | getPageImageUrl ( string $text, string $commandName)
string | getPrevPageImageUrl ()
string | getPrevPageText ()
void | listIndexChanged ( TDropDownList $sender, TEventParameter $param) Event handler to the OnSelectedIndexChanged event of the dropdown list.
void | loadState () Restores the pager state.
void | onPageIndexChanged ( TPagerPageChangedEventParameter $param) This event is raised when page index is changed due to a page button click.
void | onPreRender ( Traversable $param) Performs databinding to populate data items from data source.
void | render ( THtmlWriter $writer) Renders the control.
void | setButtonType ( TPagerButtonType $value)
void | setControlToPaginate ( string $value) Sets the ID path of the control whose content would be paginated.
protected void | setCurrentPageIndex ( integer $value)
void | setFirstPageImageUrl ( string $value)
void | setFirstPageText ( string $value)
void | setLastPageImageUrl ( string $value)
void | setLastPageText ( string $value)
void | setMode ( TPagerMode $value)
void | setNextPageImageUrl ( string $value)
void | setNextPageText ( string $value)
void | setNumericPageImageUrl ( string $value) Sets the image URL for the numeric page buttons.
void | setPageButtonCount ( integer $value)
protected void | setPageCount ( integer $value)
void | setPrevPageImageUrl ( string $value)
void | setPrevPageText ( string $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | CMD_PAGE | Command name that TPager understands.
string | CMD_PAGE_FIRST |
string | CMD_PAGE_LAST |
string | CMD_PAGE_NEXT |
string | CMD_PAGE_PREV |
Method Details

bubbleEvent

public boolean bubbleEvent (TControl $sender , TEventParameter $param )

Processes a bubbled event.

This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

Input
TControl | $sender | the sender of the event
TEventParameter | $param | event parameter
Output
boolean | whether the event bubbling should stop here.
Exception

buildListPager

protected void buildListPager ()

Builds a dropdown list pager

Output
Exception

buildNextPrevPager

protected void buildNextPrevPager ()

Builds a next-prev pager

Output
Exception

buildNumericPager

protected void buildNumericPager ()

Builds a numeric pager

Output
Exception

buildPager

protected void buildPager ()

Builds the pager content based on the pager mode.

Current implementation includes building 'NextPrev', 'Numeric' and 'DropDownList' pagers. Derived classes may override this method to provide additional pagers.

Output
Exception

createPagerButton

protected mixed createPagerButton (string $buttonType , boolean $enabled , string $text , string $commandName , string $commandParameter )

Creates a pager button.

Depending on the button type, a TLinkButton or a TButton may be created. If it is enabled (clickable), its command name and parameter will also be set. Derived classes may override this method to create additional types of buttons, such as TImageButton.

Input
string | $buttonType | button type, either LinkButton or PushButton
boolean | $enabled | whether the button should be enabled
string | $text | caption of the button.
string | $commandName | CommandName corresponding to the OnCommand event of the button.
string | $commandParameter | CommandParameter corresponding to the OnCommand event of the button
Output
mixed | the button instance
Exception

getButtonType

public TPagerButtonType getButtonType ()

Output
TPagerButtonType the type of command button for paging. Defaults to TPagerButtonType::LinkButton.
Exception

getControlToPaginate

public string getControlToPaginate ()

Output
string the ID path of the control whose content would be paginated.
Exception

getCurrentPageIndex

public integer getCurrentPageIndex ()

Output
integer the zero-based index of the current page. Defaults to 0.
Exception

getFirstPageImageUrl

public string getFirstPageImageUrl ()

Output
string the image URL for the first page button. This is only used when ButtonType is 'ImageButton'.
Exception

getFirstPageText

public string getFirstPageText ()

Output
string text for the first page button. Defaults to ''.
Exception

getIsFirstPage

public boolean getIsFirstPage ()

Output
boolean whether the current page is the first page Defaults to false.
Exception

getIsLastPage

public boolean getIsLastPage ()

Output
boolean whether the current page is the last page
Exception

getLastPageImageUrl

public string getLastPageImageUrl ()

Output
string the image URL for the last page button. This is only used when ButtonType is 'ImageButton'.
Exception

getLastPageText

public string getLastPageText ()

Output
string text for the last page button. Defaults to '>>'.
Exception

getMode

public TPagerMode getMode ()

Output
TPagerMode pager mode. Defaults to TPagerMode::NextPrev.
Exception

getNextPageImageUrl

public string getNextPageImageUrl ()

Output
string the image URL for the next page button. This is only used when ButtonType is 'ImageButton'.
Exception

getNextPageText

public string getNextPageText ()

Output
string text for the next page button. Defaults to '>'.
Exception

getNumericPageImageUrl

public string getNumericPageImageUrl ()

Output
string the image URL for the numeric page buttons. This is only used when ButtonType is 'ImageButton' and Mode is 'Numeric'.
Exception

getPageButtonCount

public integer getPageButtonCount ()

Output
integer maximum number of pager buttons to be displayed. Defaults to 10.
Exception

getPageCount

public integer getPageCount ()

Output
integer number of pages of data items available
Exception

getPageImageUrl

protected void getPageImageUrl (string $text , string $commandName )

Input
string | $text | the caption of the image button
string | $commandName | the command name associated with the image button
Output
Exception

getPrevPageImageUrl

public string getPrevPageImageUrl ()

Output
string the image URL for the previous page button. This is only used when ButtonType is 'ImageButton'.
Exception

getPrevPageText

public string getPrevPageText ()

Output
string text for the previous page button. Defaults to '<'.
Exception

listIndexChanged

public void listIndexChanged (TDropDownList $sender , TEventParameter $param )

Event handler to the OnSelectedIndexChanged event of the dropdown list.

This handler will raise OnPageIndexChanged event.

Input
TDropDownList | $sender | the dropdown list control raising the event
TEventParameter | $param | event parameter
Output
Exception

loadState

public void loadState ()

Restores the pager state.

This method overrides the parent implementation and is invoked when the control is loading persistent state.

Output
Exception

onPageIndexChanged

public void onPageIndexChanged (TPagerPageChangedEventParameter $param )

This event is raised when page index is changed due to a page button click.

Input
TPagerPageChangedEventParameter $param event parameter
Output
Exception

onPreRender

public void onPreRender (Traversable $param )

Performs databinding to populate data items from data source.

This method is invoked by dataBind(). You may override this function to provide your own way of data population.

Input
Traversable $param the bound data
Output
Exception

render

public void render (THtmlWriter $writer )

Renders the control.

The method overrides the parent implementation by rendering the pager only when there are two or more pages.

Input
THtmlWriter $writer the writer
Output
Exception

setButtonType

public void setButtonType (TPagerButtonType $value )

Input
TPagerButtonType $value the type of command button for paging.
Output
Exception

setControlToPaginate

public void setControlToPaginate (string $value )

Sets the ID path of the control whose content would be paginated.

The ID path is the dot-connected IDs of the controls reaching from the pager's naming container to the target control.

Input
string $value the ID path
Output
Exception

setCurrentPageIndex

protected void setCurrentPageIndex (integer $value )

Input
integer | $value | the zero-based index of the current page
Output
Exception
throws | TInvalidDataValueException if the value is less than 0

setFirstPageImageUrl

public void setFirstPageImageUrl (string $value )

Input
string $value the image URL for the first page button. This is only used when ButtonType is 'ImageButton'.
Output
Exception

setFirstPageText

public void setFirstPageText (string $value )

Input
string $value text for the first page button. If empty, the first page button will not be rendered.
Output
Exception

setLastPageImageUrl

public void setLastPageImageUrl (string $value )

Input
string $value the image URL for the last page button. This is only used when ButtonType is 'ImageButton'.
Output
Exception

setLastPageText

public void setLastPageText (string $value )

Input
string $value text for the last page button. If empty, the last page button will not be rendered.
Output
Exception

setMode

public void setMode (TPagerMode $value )

Input
TPagerMode $value pager mode.
Output
Exception

setNextPageImageUrl

public void setNextPageImageUrl (string $value )

Input
string $value the image URL for the next page button. This is only used when ButtonType is 'ImageButton'.
Output
Exception

setNextPageText

public void setNextPageText (string $value )

Input
string $value text for the next page button.
Output
Exception

setNumericPageImageUrl

public void setNumericPageImageUrl (string $value )

Sets the image URL for the numeric page buttons.

This is actually a template for generating a set of URLs corresponding to numeric button 1, 2, 3, .., etc. Use {0} as the placeholder for the numbers. For example, the image URL http://example.com/images/button{0}.gif will be replaced as http://example.com/images/button1.gif, http://example.com/images/button2.gif, etc.

Input
string $value the image URL for the numeric page buttons. This is only used when ButtonType is 'ImageButton' and Mode is 'Numeric'.
Output
Exception

setPageButtonCount

public void setPageButtonCount (integer $value )

Input
integer | $value | maximum number of pager buttons to be displayed
Output
Exception
throws | TInvalidDataValueException if the value is less than 1.

setPageCount

protected void setPageCount (integer $value )

Input
integer | $value | number of pages of data items available
Output
Exception
throws | TInvalidDataValueException if the value is less than 0

setPrevPageImageUrl

public void setPrevPageImageUrl (string $value )

Input
string $value the image URL for the previous page button. This is only used when ButtonType is 'ImageButton'.
Output
Exception

setPrevPageText

public void setPrevPageText (string $value )

Input
string $value text for the next page button.
Output
Exception

Constant Details

CMD_PAGE

Command name that TPager understands.

Type:

string

Value:

'Page'

CMD_PAGE_FIRST

Type:

string

Value:

'First'

CMD_PAGE_LAST

Type:

string

Value:

'Last'

CMD_PAGE_NEXT

Type:

string

Value:

'Next'

CMD_PAGE_PREV

Type:

string

Value:

'Previous'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPagerButtonType

Class TPagerButtonType (Class Overview)

TEnumerable
   |
   --TPagerButtonType

TPagerButtonType class.

TPagerButtonType defines the enumerable type for the possible types of pager buttons.

The following enumerable values are defined:

  • LinkButton: link buttons
  • PushButton: form submit buttons

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | ImageButton
string | LinkButton
string | PushButton
Constant Details

ImageButton

Type:

string

Value:

'ImageButton'

LinkButton

Type:

string

Value:

'LinkButton'

PushButton

Type:

string

Value:

'PushButton'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPagerMode

Class TPagerMode (Class Overview)

TEnumerable
   |
   --TPagerMode

TPagerMode class.

TPagerMode defines the enumerable type for the possible modes that a TPager control can take.

The following enumerable values are defined:

  • NextPrev: pager buttons are displayed as next and previous pages
  • Numeric: pager buttons are displayed as numeric page numbers
  • DropDownList: a dropdown list is used to select pages

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | DropDownList
string | NextPrev
string | Numeric
Constant Details

DropDownList

Type:

string

Value:

'DropDownList'

NextPrev

Type:

string

Value:

'NextPrev'

Numeric

Type:

string

Value:

'Numeric'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPagerPageChangedEventParameter

Class TPagerPageChangedEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TPagerPageChangedEventParameter

TPagerPageChangedEventParameter class

TPagerPageChangedEventParameter encapsulates the parameter data for TPager::onPageIndexChanged event of TPager controls.

The CommandSource property refers to the control that originally raises the OnCommand event, while NewPageIndex returns the new page index carried with the page command.

Since: 3.0.2
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
TControl | getCommandSource ()
integer | getNewPageIndex ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getCommandSource

public TControl getCommandSource ()

Output
TControl the control originally raises the OnCommand event.
Exception

getNewPageIndex

public integer getNewPageIndex ()

Output
integer new page index
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPanel

Class TPanel (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TPanel

Direct Known Sub-classes:

TActivePanel , TDraggable , TDropContainer , TDataGridPager

TPanel class

TPanel represents a component that acts as a container for other component. It is especially useful when you want to generate components programmatically or hide/show a group of components.

By default, TPanel displays a &lt;div&gt; element on a page. Children of TPanel are displayed as the body content of the element. The property Wrap can be used to set whether the body content should wrap or not. HorizontalAlign governs how the content is aligned horizontally, and Direction indicates the content direction (left to right or right to left). You can set BackImageUrl to give a background image to the panel, and you can ste GroupingText so that the panel is displayed as a field set with a legend text. Finally, you can specify a default button to be fired when users press 'return' key within the panel by setting the DefaultButton property.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attributes to renderer.
protected TPanelStyle | createStyle () Creates a style object to be used by the control.
string | getBackImageUrl ()
string | getDefaultButton ()
string | getDirection ()
string | getGroupingText ()
string | getHorizontalAlign ()
string | getScrollBars ()
protected string | getTagName ()
boolean | getWrap ()
void | renderBeginTag ( THtmlWriter $writer) Renders the openning tag for the control (including attributes)
void | renderEndTag ( THtmlWriter $writer) Renders the closing tag for the control
void | setBackImageUrl ( string $value) Sets the URL of the background image for the panel component.
void | setDefaultButton ( string $value) Specifies the default button for the panel.
void | setDirection ( string $value)
void | setGroupingText ( string $value)
void | setHorizontalAlign ( string $value) Sets the horizontal alignment of the contents within the panel.
void | setScrollBars ( string $value)
void | setWrap ( boolean $value) Sets the value indicating whether the content wraps within the panel.
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attributes to renderer.

Input
THtmlWriter | $writer | the renderer
Output
Exception
throws | TInvalidDataValueException if default button is not right.

createStyle

protected TPanelStyle createStyle ()

Creates a style object to be used by the control.

This method overrides the parent impementation by creating a TPanelStyle object.

Output
TPanelStyle the style used by TPanel.
Exception

getBackImageUrl

public string getBackImageUrl ()

Output
string the URL of the background image for the panel component.
Exception

getDefaultButton

public string getDefaultButton ()

Output
string the ID path to the default button. Defaults to empty.
Exception

getDirection

public string getDirection ()

Output
string alignment of the content in the panel. Defaults to 'NotSet'.
Exception

getGroupingText

public string getGroupingText ()

Output
string the legend text when the panel is used as a fieldset. Defaults to empty.
Exception

getHorizontalAlign

public string getHorizontalAlign ()

Output
string the horizontal alignment of the contents within the panel, defaults to 'NotSet'.
Exception

getScrollBars

public string getScrollBars ()

Output
string the visibility and position of scroll bars in a panel control, defaults to None.
Exception

getTagName

protected string getTagName ()

Output
string tag name of the panel
Exception

getWrap

public boolean getWrap ()

Output
boolean whether the content wraps within the panel. Defaults to true.
Exception

renderBeginTag

public void renderBeginTag (THtmlWriter $writer )

Renders the openning tag for the control (including attributes)

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderEndTag

public void renderEndTag (THtmlWriter $writer )

Renders the closing tag for the control

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

setBackImageUrl

public void setBackImageUrl (string $value )

Sets the URL of the background image for the panel component.

Input
string $value the URL
Output
Exception

setDefaultButton

public void setDefaultButton (string $value )

Specifies the default button for the panel.

The default button will be fired (clicked) whenever a user enters 'return' key within the panel. The button must be locatable via the function call TControl::findControl.

Input
string $value the ID path to the default button.
Output
Exception

setDirection

public void setDirection (string $value )

Input
string $value alignment of the content in the panel. Valid values include 'NotSet', 'LeftToRight', 'RightToLeft'.
Output
Exception

setGroupingText

public void setGroupingText (string $value )

Input
string $value the legend text. If this value is not empty, the panel will be rendered as a fieldset.
Output
Exception

setHorizontalAlign

public void setHorizontalAlign (string $value )

Sets the horizontal alignment of the contents within the panel.

Valid values include 'NotSet', 'Justify', 'Left', 'Right', 'Center'

Input
string $value the horizontal alignment
Output
Exception

setScrollBars

public void setScrollBars (string $value )

Input
string $value the visibility and position of scroll bars in a panel control. Valid values include None, Auto, Both, Horizontal and Vertical.
Output
Exception

setWrap

public void setWrap (boolean $value )

Sets the value indicating whether the content wraps within the panel.

Input
boolean $value whether the content wraps within the panel.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TContentDirection

Class TContentDirection (Class Overview)

TEnumerable
   |
   --TContentDirection

TContentDirection class.

TContentDirection defines the enumerable type for the possible directions that a panel can be at.

The following enumerable values are defined:

  • NotSet: the direction is not specified
  • LeftToRight: content in a panel is left to right
  • RightToLeft: content in a panel is right to left

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | LeftToRight
string | NotSet
string | RightToLeft
Constant Details

LeftToRight

Type:

string

Value:

'LeftToRight'

NotSet

Type:

string

Value:

'NotSet'

RightToLeft

Type:

string

Value:

'RightToLeft'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPanelStyle

Class TPanelStyle (Class Overview)

TComponent
   |
   --TStyle
      |
      --TPanelStyle

Direct Known Sub-classes:

TDataGridPagerStyle

TPanelStyle class.

TPanelStyle represents the CSS style specific for panel HTML tag.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | addAttributesToRender ( THtmlWriter $writer) Adds attributes related to CSS styles to renderer.
void | copyFrom ( TStyle $style) Copies the fields in a new style to this style.
string | getBackImageUrl ()
TContentDirection | getDirection ()
THorizontalAlign | getHorizontalAlign ()
TScrollBars | getScrollBars ()
boolean | getWrap ()
void | mergeWith ( TStyle $style) Merges the style with a new one.
void | reset () Sets the style attributes to default values.
void | setBackImageUrl ( string $value) Sets the URL of the background image for the panel component.
void | setDirection ( TContentDirection $value)
void | setHorizontalAlign ( THorizontalAlign $value) Sets the horizontal alignment of the contents within the panel.
void | setScrollBars ( TScrollBars $value)
void | setWrap ( boolean $value) Sets the value indicating whether the content wraps within the panel.
Methods Inherited From TStyle
TStyle::addAttributesToRender(), TStyle::clearStyleField(), TStyle::copyFrom(), TStyle::getBackColor(), TStyle::getBorderColor(), TStyle::getBorderStyle(), TStyle::getBorderWidth(), TStyle::getCssClass(), TStyle::getCustomStyle(), TStyle::getDisplayStyle(), TStyle::getFont(), TStyle::getForeColor(), TStyle::getHeight(), TStyle::getStyleField(), TStyle::getStyleFields(), TStyle::getWidth(), TStyle::hasCssClass(), TStyle::hasFont(), TStyle::hasStyleField(), TStyle::mergeWith(), TStyle::reset(), TStyle::setBackColor(), TStyle::setBorderColor(), TStyle::setBorderStyle(), TStyle::setBorderWidth(), TStyle::setCssClass(), TStyle::setCustomStyle(), TStyle::setDisplayStyle(), TStyle::setForeColor(), TStyle::setHeight(), TStyle::setStyleField(), TStyle::setWidth(), TStyle::__clone()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

addAttributesToRender

public void addAttributesToRender (THtmlWriter $writer )

Adds attributes related to CSS styles to renderer.

This method overrides the parent implementation.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

copyFrom

public void copyFrom (TStyle $style )

Copies the fields in a new style to this style.

If a style field is set in the new style, the corresponding field in this style will be overwritten.

Input
TStyle $style the new style
Output
Exception

getBackImageUrl

public string getBackImageUrl ()

Output
string the URL of the background image for the panel component.
Exception

getDirection

public TContentDirection getDirection ()

Output
TContentDirection alignment of the content in the panel. Defaults to TContentDirection::NotSet.
Exception

getHorizontalAlign

public THorizontalAlign getHorizontalAlign ()

Output
THorizontalAlign the horizontal alignment of the contents within the panel, defaults to THorizontalAlign::NotSet.
Exception

getScrollBars

public TScrollBars getScrollBars ()

Output
TScrollBars the visibility and position of scroll bars in a panel control, defaults to TScrollBars::None.
Exception

getWrap

public boolean getWrap ()

Output
boolean whether the content wraps within the panel. Defaults to true.
Exception

mergeWith

public void mergeWith (TStyle $style )

Merges the style with a new one.

If a style field is not set in this style, it will be overwritten by the new one.

Input
TStyle $style the new style
Output
Exception

reset

public void reset ()

Sets the style attributes to default values.

This method overrides the parent implementation by resetting additional TPanelStyle specific attributes.

Output
Exception

setBackImageUrl

public void setBackImageUrl (string $value )

Sets the URL of the background image for the panel component.

Input
string $value the URL
Output
Exception

setDirection

public void setDirection (TContentDirection $value )

Input
TContentDirection $value alignment of the content in the panel.
Output
Exception

setHorizontalAlign

public void setHorizontalAlign (THorizontalAlign $value )

Sets the horizontal alignment of the contents within the panel.

Input
THorizontalAlign $value the horizontal alignment
Output
Exception

setScrollBars

public void setScrollBars (TScrollBars $value )

Input
TScrollBars $value the visibility and position of scroll bars in a panel control.
Output
Exception

setWrap

public void setWrap (boolean $value )

Sets the value indicating whether the content wraps within the panel.

Input
boolean $value whether the content wraps within the panel.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TScrollBars

Class TScrollBars (Class Overview)

TEnumerable
   |
   --TScrollBars

TScrollBars class.

TScrollBars defines the enumerable type for the possible scroll bar mode that a TPanel control could use.

The following enumerable values are defined:

  • None: no scroll bars.
  • Auto: scroll bars automatically appeared when needed.
  • Both: show both horizontal and vertical scroll bars all the time.
  • Horizontal: horizontal scroll bar only
  • Vertical: vertical scroll bar only

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Auto
string | Both
string | Horizontal
string | None
string | Vertical
Constant Details

Auto

Type:

string

Value:

'Auto'

Both

Type:

string

Value:

'Both'

Horizontal

Type:

string

Value:

'Horizontal'

None

Type:

string

Value:

'None'

Vertical

Type:

string

Value:

'Vertical'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPlaceHolder

Class TPlaceHolder (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TPlaceHolder

TPlaceHolder class

TPlaceHolder reserves a place on a template, where static texts or controls may be inserted. You may add or remove texts or child controls of TPlaceHolder by manipulating the TControl::getControls property.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRadioButton

Class TRadioButton (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TCheckBox
               |
               --TRadioButton

Direct Known Sub-classes:

TActiveRadioButton

TRadioButton class

TRadioButton displays a radio button on the page. You can specify the caption to display beside the radio buttonby setting the Text property. The caption can appear either on the right or left of the radio button, which is determined by the TextAlign property.

To determine whether the TRadioButton component is checked, test the Checked property. The OnCheckedChanged event is raised when the Checked state of the TRadioButton component changes between posts to the server. You can provide an event handler for the OnCheckedChanged event to to programmatically control the actions performed when the state of the TRadioButton component changes between posts to the server.

TRadioButton uses GroupName to group together a set of radio buttons. Once the GroupName is set, you can use the getRadioButtonsInGroup method to get an array of TRadioButtons having the same group name.

If AutoPostBack is set true, changing the radio button state will cause postback action. And if CausesValidation is true, validation will also be processed, which can be further restricted within a ValidationGroup.

Note, Text is rendered as is. Make sure it does not contain unwanted characters that may bring security vulnerabilities.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Constructor.
Method Summary
protected void | addToPostDataLoader () Add the group name as post data loader if group name is set.
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
boolean | getEnableClientScript ()
string | getGroupName ()
array | getRadioButtonsInGroup () Gets an array of radiobuttons whose group name is the same as this radiobutton's.
string | getUniqueGroupName ()
protected string | getValueAttribute ()
boolean | loadPostData ( string $key, array $values) Loads user input data.
void | onInit ( TEventParameter $param) Registers the radio button groupings. If overriding onInit method, ensure to call parent implemenation.
void | onUnLoad ( TEventParameter $param) Unregisters the radio button groupings. If overriding onInit method, ensure to call parent implemenation.
protected void | renderClientControlScript ( mixed $writer) Renders the client-script code.
protected void | renderInputTag ( THtmlWriter $writer, string $clientID, string $onclick) Renders a radiobutton input element.
void | setEnableClientScript ( boolean $value)
void | setGroupName ( string $value) Sets the name of the group that the radio button belongs to.
void | setUniqueGroupName ( string $value) Sets the unique group name that the radio button belongs to.
Methods Inherited From TCheckBox
TCheckBox::getAutoPostBack(), TCheckBox::getCausesValidation(), TCheckBox::getChecked(), TCheckBox::getClientClassName(), TCheckBox::getData(), TCheckBox::getDataChanged(), TCheckBox::getEnableClientScript(), TCheckBox::getInputAttributes(), TCheckBox::getIsValid(), TCheckBox::getLabelAttributes(), TCheckBox::getPostBackOptions(), TCheckBox::getSpanNeeded(), TCheckBox::getSurroundingTagID(), TCheckBox::getTagName(), TCheckBox::getText(), TCheckBox::getTextAlign(), TCheckBox::getValidationGroup(), TCheckBox::getValidationPropertyValue(), TCheckBox::getValue(), TCheckBox::getValueAttribute(), TCheckBox::loadPostData(), TCheckBox::onCheckedChanged(), TCheckBox::onPreRender(), TCheckBox::raisePostDataChangedEvent(), TCheckBox::render(), TCheckBox::renderClientControlScript(), TCheckBox::renderInputTag(), TCheckBox::renderLabel(), TCheckBox::setAutoPostBack(), TCheckBox::setCausesValidation(), TCheckBox::setChecked(), TCheckBox::setData(), TCheckBox::setEnableClientScript(), TCheckBox::setIsValid(), TCheckBox::setText(), TCheckBox::setTextAlign(), TCheckBox::setValidationGroup(), TCheckBox::setValue()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Constructor.

Registers the radiobutton in a global radiobutton collection. If overridden, the parent implementation must be invoked first.
Method Details

addToPostDataLoader

protected void addToPostDataLoader ()

Add the group name as post data loader if group name is set.

Output
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getEnableClientScript

public boolean getEnableClientScript ()

Output
boolean whether to render javascript.
Exception

getGroupName

public string getGroupName ()

Output
string the name of the group that the radio button belongs to. Defaults to empty.
Exception

getRadioButtonsInGroup

public array getRadioButtonsInGroup ()

Gets an array of radiobuttons whose group name is the same as this radiobutton's.

Note, only those radiobuttons that are on the current page hierarchy may be returned in the result.

Output
array list of TRadioButton with the same group
Exception

getUniqueGroupName

public string getUniqueGroupName ()

Output
string the name used to fetch radiobutton post data
Exception

getValueAttribute

protected string getValueAttribute ()

Output
string the value attribute to be rendered
Exception

loadPostData

public boolean loadPostData (string $key , array $values )

Loads user input data.

This method is primarly used by framework developers.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the control has been changed
Exception

onInit

public void onInit (TEventParameter $param )

Registers the radio button groupings. If overriding onInit method, ensure to call parent implemenation.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onUnLoad

public void onUnLoad (TEventParameter $param )

Unregisters the radio button groupings. If overriding onInit method, ensure to call parent implemenation.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Renders the client-script code.

Input
mixed $writer
Output
Exception

renderInputTag

protected void renderInputTag (THtmlWriter $writer , string $clientID , string $onclick )

Renders a radiobutton input element.

Input
THtmlWriter | $writer | the writer for the rendering purpose
string | $clientID | checkbox id
string | $onclick | onclick js
Output
Exception

setEnableClientScript

public void setEnableClientScript (boolean $value )

Input
boolean $value whether to render javascript.
Output
Exception

setGroupName

public void setGroupName (string $value )

Sets the name of the group that the radio button belongs to.

The group is unique among the control's naming container.

Input
string $value the group name
Output
Exception

setUniqueGroupName

public void setUniqueGroupName (string $value )

Sets the unique group name that the radio button belongs to.

A unique group is a radiobutton group unique among the whole page hierarchy, while the GroupName specifies a group that is unique among the control's naming container only. For example, each cell of a TDataGrid is a naming container. If you specify GroupName for a radiobutton in a cell, it groups together radiobutton within a cell, but not the other, even though they have the same GroupName. On the contratry, if UniqueGroupName is used instead, it will group all appropriate radio buttons on the whole page hierarchy. Note, when both UniqueGroupName and GroupName, the former takes precedence.

Input
string $value the group name
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRadioButtonList

Class TRadioButtonList (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TCheckBoxList
                     |
                     --TRadioButtonList

Direct Known Sub-classes:

TActiveRadioButtonList , TRatingList

TRadioButtonList class

TRadioButtonList displays a list of radiobuttons on a Web page.

TRadioButtonList inherits all properties and events of TCheckBoxList. Each TRadioButtonList displays one group of radiobuttons, i.e., at most one radiobutton can be selected at a time.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected TControl | createRepeatedControl () Creates a control used for repetition (used as a template).
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
protected boolean | getIsMultiSelect ()
boolean | loadPostData ( string $key, array $values) Loads user input data.
void | setSelectedIndices ( mixed $indices)
Methods Inherited From TCheckBoxList
TCheckBoxList::createRepeatedControl(), TCheckBoxList::createStyle(), TCheckBoxList::findControl(), TCheckBoxList::generateItemStyle(), TCheckBoxList::getCellPadding(), TCheckBoxList::getCellSpacing(), TCheckBoxList::getClientClassName(), TCheckBoxList::getDataChanged(), TCheckBoxList::getHasFooter(), TCheckBoxList::getHasHeader(), TCheckBoxList::getHasSeparators(), TCheckBoxList::getIsMultiSelect(), TCheckBoxList::getIsValid(), TCheckBoxList::getPostBackOptions(), TCheckBoxList::getRepeatColumns(), TCheckBoxList::getRepeatDirection(), TCheckBoxList::getRepeatInfo(), TCheckBoxList::getRepeatLayout(), TCheckBoxList::getSpanNeeded(), TCheckBoxList::getTextAlign(), TCheckBoxList::getValidationPropertyValue(), TCheckBoxList::loadPostData(), TCheckBoxList::onPreRender(), TCheckBoxList::raisePostDataChangedEvent(), TCheckBoxList::render(), TCheckBoxList::renderItem(), TCheckBoxList::setCellPadding(), TCheckBoxList::setCellSpacing(), TCheckBoxList::setEnabled(), TCheckBoxList::setIsValid(), TCheckBoxList::setRepeatColumns(), TCheckBoxList::setRepeatDirection(), TCheckBoxList::setRepeatLayout(), TCheckBoxList::setTextAlign()
Methods Inherited From TListControl
TListControl::addAttributesToRender(), TListControl::addParsedObject(), TListControl::clearSelection(), TListControl::createListItemCollection(), TListControl::formatDataValue(), TListControl::getAppendDataBoundItems(), TListControl::getAutoPostBack(), TListControl::getCausesValidation(), TListControl::getClientClassName(), TListControl::getData(), TListControl::getDataGroupField(), TListControl::getDataTextField(), TListControl::getDataTextFormatString(), TListControl::getDataValueField(), TListControl::getEnableClientScript(), TListControl::getHasItems(), TListControl::getIsMultiSelect(), TListControl::getItemCount(), TListControl::getItems(), TListControl::getPostBackOptions(), TListControl::getPromptText(), TListControl::getPromptValue(), TListControl::getSelectedIndex(), TListControl::getSelectedIndices(), TListControl::getSelectedItem(), TListControl::getSelectedValue(), TListControl::getSelectedValues(), TListControl::getTagName(), TListControl::getText(), TListControl::getValidationGroup(), TListControl::loadState(), TListControl::onSelectedIndexChanged(), TListControl::onTextChanged(), TListControl::performDataBinding(), TListControl::renderClientControlScript(), TListControl::renderContents(), TListControl::renderPrompt(), TListControl::saveState(), TListControl::setAppendDataBoundItems(), TListControl::setAutoPostBack(), TListControl::setCausesValidation(), TListControl::setData(), TListControl::setDataGroupField(), TListControl::setDataTextField(), TListControl::setDataTextFormatString(), TListControl::setDataValueField(), TListControl::setEnableClientScript(), TListControl::setPromptText(), TListControl::setPromptValue(), TListControl::setSelectedIndex(), TListControl::setSelectedIndices(), TListControl::setSelectedValue(), TListControl::setSelectedValues(), TListControl::setText(), TListControl::setValidationGroup()
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

createRepeatedControl

protected TControl createRepeatedControl ()

Creates a control used for repetition (used as a template).

Output
TControl the control to be repeated
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getIsMultiSelect

protected boolean getIsMultiSelect ()

Output
boolean whether this control supports multiple selection. Always false for radiobutton list.
Exception

loadPostData

public boolean loadPostData (string $key , array $values )

Loads user input data.

This method is primarly used by framework developers.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the control has been changed
Exception

setSelectedIndices

public void setSelectedIndices (mixed $indices )

Input
mixed | $indices
Output
Exception
throws | TNotSupportedException if this method is invoked


PRADO API Manual: Docs For Class TRangeValidationDataType

Class TRangeValidationDataType (Class Overview)

TEnumerable
   |
   --TValidationDataType
      |
      --TRangeValidationDataType

TRangeValidationDataType class.

TRangeValidationDataType defines the enumerable type for the possible data types that a range validator can validate upon.

The following enumerable values are defined:

  • Integer
  • Float
  • Date
  • String
  • StringLength

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TValidationDataType
Date, Float, Integer, String,
Constant Summary
string StringLength
Constant Details

StringLength

Type:

string

Value:

'StringLength'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRangeValidator

Class TRangeValidator (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TRangeValidator

TRangeValidator class

TRangeValidator tests whether an input value is within a specified range.

TRangeValidator uses three key properties to perform its validation. The MinValue and MaxValue properties specify the minimum and maximum values of the valid range. The DataType property is used to specify the data type of the value and the minimum and maximum range values. These values are converted to this data type before the validation operation is performed. The following value types are supported:

  • Integer A 32-bit signed integer data type.
  • Float A double-precision floating point number data type.
  • Date A date data type. The date format can be specified by setting DateFormat property, which must be recognizable by TSimpleDateFormatter. If the property is not set, the GNU date syntax is assumed.
  • String A string data type.
  • StringLength check for string length.
If StrictComparison is true, then the ranges are compared as strictly less than the max value and/or strictly greater than the min value.

The TRangeValidator allows a special DataType "StringLength" that can be used to verify minimum and maximum string length. The Charset property can be used to force a particular charset for comparison. Otherwise, the application charset is used and is defaulted as UTF-8.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected boolean | evaluateIsValid () This method overrides the parent's implementation.
string | getCharset ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing validation for this control.
protected array | getClientScriptOptions () Returns an array of javascript validator options.
TRangeValidationDataType | getDataType ()
string | getDateFormat ()
string | getMaxValue ()
string | getMinValue ()
boolean | getStrictComparison ()
protected void | isGreaterThan ( mixed $left, mixed $right)
protected void | isLessThan ( mixed $left, mixed $right)
protected boolean | isValidDate ( string $value) Determine if the date is within the specified range.
protected boolean | isValidFloat ( string $value) Determine if the value is within the specified float range.
protected boolean | isValidInteger ( string $value) Determine if the value is within the integer range.
protected boolean | isValidString ( string $value) Compare the string with a minimum and a maxiumum value.
protected boolean | isValidStringLength ( string $value)
void | setCharset ( string $value)
void | setDataType ( TRangeValidationDataType $value) Sets the data type that the values being compared are converted to before the comparison is made.
void | setDateFormat ( string $value) Sets the date format for a date validation
void | setMaxValue ( string $value) Sets the maximum value of the validation range.
void | setMinValue ( string $value) Sets the minimum value of the validation range.
void | setStrictComparison ( boolean $value)
Methods Inherited From TBaseValidator
TBaseValidator::addAttributesToRender(), TBaseValidator::createClientSide(), TBaseValidator::getClientScriptOptions(), TBaseValidator::getClientSide(), TBaseValidator::getControlCssClass(), TBaseValidator::getControlToValidate(), TBaseValidator::getDisplay(), TBaseValidator::getEnableClientScript(), TBaseValidator::getErrorMessage(), TBaseValidator::getFocusElementID(), TBaseValidator::getFocusOnError(), TBaseValidator::getIsValid(), TBaseValidator::getValidationGroup(), TBaseValidator::getValidationTarget(), TBaseValidator::getValidationValue(), TBaseValidator::onInit(), TBaseValidator::onPreRender(), TBaseValidator::onUnload(), TBaseValidator::onValidate(), TBaseValidator::onValidationError(), TBaseValidator::onValidationSuccess(), TBaseValidator::registerClientScriptValidator(), TBaseValidator::renderClientControlScript(), TBaseValidator::renderContents(), TBaseValidator::setControlCssClass(), TBaseValidator::setControlToValidate(), TBaseValidator::setDisplay(), TBaseValidator::setEnableClientScript(), TBaseValidator::setEnabled(), TBaseValidator::setErrorMessage(), TBaseValidator::setFocusElementID(), TBaseValidator::setFocusOnError(), TBaseValidator::setForControl(), TBaseValidator::setIsValid(), TBaseValidator::setValidationGroup(), TBaseValidator::updateControlCssClass(), TBaseValidator::validate()
Methods Inherited From TLabel
TLabel::addAttributesToRender(), TLabel::getData(), TLabel::getForControl(), TLabel::getTagName(), TLabel::getText(), TLabel::render(), TLabel::renderContents(), TLabel::setData(), TLabel::setForControl(), TLabel::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

evaluateIsValid

protected boolean evaluateIsValid ()

This method overrides the parent's implementation.

The validation succeeds if the input data is within the range. The validation always succeeds if the input data is empty.

Output
boolean whether the validation succeeds
Exception

getCharset

public string getCharset ()

Output
string charset for string length comparison.
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing validation for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientScriptOptions

protected array getClientScriptOptions ()

Returns an array of javascript validator options.

Output
array javascript validator options.
Exception

getDataType

public TRangeValidationDataType getDataType ()

Output
TRangeValidationDataType the data type that the values being compared are converted to before the comparison is made. Defaults to TRangeValidationDataType::String.
Exception

getDateFormat

public string getDateFormat ()

Output
string the date validation date format if any
Exception

getMaxValue

public string getMaxValue ()

Output
string the maximum value of the validation range.
Exception

getMinValue

public string getMinValue ()

Output
string the minimum value of the validation range.
Exception

getStrictComparison

public boolean getStrictComparison ()

Output
boolean true to perform strict comparison.
Exception

isGreaterThan

protected void isGreaterThan (mixed $left , mixed $right )

Input
mixed | $left
mixed | $right
Output
Exception

isLessThan

protected void isLessThan (mixed $left , mixed $right )

Input
mixed | $left
mixed | $right
Output
Exception

isValidDate

protected boolean isValidDate (string $value )

Determine if the date is within the specified range.

Uses pradoParseDate and strtotime to get the date from string.

Input
string | $value | date as string to validate
Output
boolean | true if within range.
Exception

isValidFloat

protected boolean isValidFloat (string $value )

Determine if the value is within the specified float range.

Input
string | $value | value to validate
Output
boolean | true if within range.
Exception

isValidInteger

protected boolean isValidInteger (string $value )

Determine if the value is within the integer range.

Input
string | $value | value to validate true
Output
boolean | true if within integer range.
Exception

isValidString

protected boolean isValidString (string $value )

Compare the string with a minimum and a maxiumum value.

Uses strcmp for comparision.

Input
string | $value | value to compare with.
Output
boolean | true if the string is within range.
Exception

isValidStringLength

protected boolean isValidStringLength (string $value )

Input
string | $value | string for comparision
Output
boolean | true if min and max string length are satisfied.
Exception

setCharset

public void setCharset (string $value )

Input
string $value charset for string length comparison.
Output
Exception

setDataType

public void setDataType (TRangeValidationDataType $value )

Sets the data type that the values being compared are converted to before the comparison is made.

Input
TRangeValidationDataType $value the data type
Output
Exception

setDateFormat

public void setDateFormat (string $value )

Sets the date format for a date validation

Input
string $value the date format value
Output
Exception

setMaxValue

public void setMaxValue (string $value )

Sets the maximum value of the validation range.

Input
string $value the maximum value
Output
Exception

setMinValue

public void setMinValue (string $value )

Sets the minimum value of the validation range.

Input
string $value the minimum value
Output
Exception

setStrictComparison

public void setStrictComparison (boolean $value )

Input
boolean $value true to perform strict comparison (i.e. strictly less than max and/or strictly greater than min).
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRatingList

Class TRatingList (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TListControl
                  |
                  --TCheckBoxList
                     |
                     --TRadioButtonList
                        |
                        --TRatingList

Direct Known Sub-classes:

TActiveRatingList

TRatingList class.

This class is EXPERIMENTAL.

Since: 3.0
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Author: Bradley Booms <bradley[dot]booms[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Sets the default repeat direction to horizontal.
Method Summary
boolean | getAllowInput () Wrapper for setReadOnly property.
protected string | getAssetUrl ( string $file)
string | getCaption ()
protected void | getCaptionControl ()
protected string | getCaptionControlID ()
string | getCaptionID ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
array | getHalfRatingInterval ()
protected array | getPostBackOptions ()
float | getRating ()
protected int | getRatingIndex ( float $rating)
TRatingListStyle | getRatingStyle ()
protected string | getRatingStyleCssClass ()
boolean | getReadOnly ()
void | onPreRender ( mixed $param) Publish the the rating style css file and rating image files.
void | onSelectedIndexChanged ( int $param)
protected array | publishImages ( string $style, string $fileExt)
protected string | publishStyle ( string $style)
void | render ( THtmlWriter $writer) Add rating style class name to the class attribute when setReadOnly property is true and when the setCssClass property is empty.
void | setAllowInput ( boolean $value) Wrapper for setReadOnly property.
TRatingListStyle | setCaption ( mixed $value)
void | setCaptionID ( string $value)
void | setEnabled ( boolean $value) Wrapper for setReadOnly property.
void | setHalfRatingInterval ( array $value) Sets the interval such that those rating values within the interval will be considered as a half star rating.
void | setRating ( float $value)
void | setRatingStyle ( string $value)
void | setReadOnly ( boolean $value)
void | setRepeatLayout ( string $value) The repeat layout must be Table.
void | setSelectedIndex ( mixed $value)
Methods Inherited From TRadioButtonList
TRadioButtonList::createRepeatedControl(), TRadioButtonList::getClientClassName(), TRadioButtonList::getIsMultiSelect(), TRadioButtonList::loadPostData(), TRadioButtonList::setSelectedIndices()
Methods Inherited From TCheckBoxList
TCheckBoxList::createRepeatedControl(), TCheckBoxList::createStyle(), TCheckBoxList::findControl(), TCheckBoxList::generateItemStyle(), TCheckBoxList::getCellPadding(), TCheckBoxList::getCellSpacing(), TCheckBoxList::getClientClassName(), TCheckBoxList::getDataChanged(), TCheckBoxList::getHasFooter(), TCheckBoxList::getHasHeader(), TCheckBoxList::getHasSeparators(), TCheckBoxList::getIsMultiSelect(), TCheckBoxList::getIsValid(), TCheckBoxList::getPostBackOptions(), TCheckBoxList::getRepeatColumns(), TCheckBoxList::getRepeatDirection(), TCheckBoxList::getRepeatInfo(), TCheckBoxList::getRepeatLayout(), TCheckBoxList::getSpanNeeded(), TCheckBoxList::getTextAlign(), TCheckBoxList::getValidationPropertyValue(), TCheckBoxList::loadPostData(), TCheckBoxList::onPreRender(), TCheckBoxList::raisePostDataChangedEvent(), TCheckBoxList::render(), TCheckBoxList::renderItem(), TCheckBoxList::setCellPadding(), TCheckBoxList::setCellSpacing(), TCheckBoxList::setEnabled(), TCheckBoxList::setIsValid(), TCheckBoxList::setRepeatColumns(), TCheckBoxList::setRepeatDirection(), TCheckBoxList::setRepeatLayout(), TCheckBoxList::setTextAlign()
Methods Inherited From TListControl
TListControl::addAttributesToRender(), TListControl::addParsedObject(), TListControl::clearSelection(), TListControl::createListItemCollection(), TListControl::formatDataValue(), TListControl::getAppendDataBoundItems(), TListControl::getAutoPostBack(), TListControl::getCausesValidation(), TListControl::getClientClassName(), TListControl::getData(), TListControl::getDataGroupField(), TListControl::getDataTextField(), TListControl::getDataTextFormatString(), TListControl::getDataValueField(), TListControl::getEnableClientScript(), TListControl::getHasItems(), TListControl::getIsMultiSelect(), TListControl::getItemCount(), TListControl::getItems(), TListControl::getPostBackOptions(), TListControl::getPromptText(), TListControl::getPromptValue(), TListControl::getSelectedIndex(), TListControl::getSelectedIndices(), TListControl::getSelectedItem(), TListControl::getSelectedValue(), TListControl::getSelectedValues(), TListControl::getTagName(), TListControl::getText(), TListControl::getValidationGroup(), TListControl::loadState(), TListControl::onSelectedIndexChanged(), TListControl::onTextChanged(), TListControl::performDataBinding(), TListControl::renderClientControlScript(), TListControl::renderContents(), TListControl::renderPrompt(), TListControl::saveState(), TListControl::setAppendDataBoundItems(), TListControl::setAutoPostBack(), TListControl::setCausesValidation(), TListControl::setData(), TListControl::setDataGroupField(), TListControl::setDataTextField(), TListControl::setDataTextFormatString(), TListControl::setDataValueField(), TListControl::setEnableClientScript(), TListControl::setPromptText(), TListControl::setPromptValue(), TListControl::setSelectedIndex(), TListControl::setSelectedIndices(), TListControl::setSelectedValue(), TListControl::setSelectedValues(), TListControl::setText(), TListControl::setValidationGroup()
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string SCRIPT_PATH Script path relative to the TClientScriptManager::SCRIPT_PATH
Constructor Details

__construct

public __construct

Sets the default repeat direction to horizontal.
Method Details

getAllowInput

public boolean getAllowInput ()

Wrapper for setReadOnly property.

Output
boolean whether the rating list can be edited. Defaults to true.
Exception

getAssetUrl

protected string getAssetUrl (string $file )

Input
string | $file | asset file in the self::SCRIPT_PATH directory.
Output
string | asset file url.
Exception

getCaption

public string getCaption ()

Output
string caption text. Default is "Rate It:".
Exception

getCaptionControl

protected void getCaptionControl ()

Output
Exception

getCaptionControlID

protected string getCaptionControlID ()

Output
string find the client ID of the caption control.
Exception

getCaptionID

public string getCaptionID ()

Output
string control or html element ID for displaying a caption.
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getHalfRatingInterval

public array getHalfRatingInterval ()

Output
array rating display half value interval, default is array(0.3, 0.7);
Exception

getPostBackOptions

protected array getPostBackOptions ()

Output
array list of post back options.
Exception

getRating

public float getRating ()

Output
float rating value.
Exception

getRatingIndex

protected int getRatingIndex (float $rating )

Input
float | $rating | rating value
Output
int | rating as integer
Exception

getRatingStyle

public TRatingListStyle getRatingStyle ()

Output
TRatingListStyle current rating style
Exception

getRatingStyleCssClass

protected string getRatingStyleCssClass ()

Output
string rating style css class name.
Exception

getReadOnly

public boolean getReadOnly ()

Output
boolean whether the items in the column can be edited. Defaults to false.
Exception

onPreRender

public void onPreRender (mixed $param )

Publish the the rating style css file and rating image files.

Input
mixed $param
Output
Exception

onSelectedIndexChanged

public void onSelectedIndexChanged (int $param )

Input
int $param change the rating selection index
Output
Exception

publishImages

protected array publishImages (string $style , string $fileExt )

Input
string | $style | rating style name
string | $fileExt | rating image file extension, default is '.gif'
Output
array | URL of publish the rating images
Exception

publishStyle

protected string publishStyle (string $style )

Input
string | $style | rating style name
Output
string | URL of the css style file
Exception

render

public void render (THtmlWriter $writer )

Add rating style class name to the class attribute when setReadOnly property is true and when the setCssClass property is empty.

Input
THtmlWriter $writer renderer
Output
Exception

setAllowInput

public void setAllowInput (boolean $value )

Wrapper for setReadOnly property.

Input
boolean $value whether the rating list can be edited
Output
Exception

setCaption

public TRatingListStyle setCaption (mixed $value )

Input
mixed | $value
Output
TRatingListStyle | current rating style
Exception

setCaptionID

public void setCaptionID (string $value )

Input
string $value control or html element ID for displaying a caption.
Output
Exception

setEnabled

public void setEnabled (boolean $value )

Wrapper for setReadOnly property.

Input
boolean $value whether the rating list can be edited
Output
Exception

setHalfRatingInterval

public void setHalfRatingInterval (array $value )

Sets the interval such that those rating values within the interval will be considered as a half star rating.

Input
array $value rating display half value interval, default is array(0.3, 0.7);
Output
Exception

setRating

public void setRating (float $value )

Input
float $value rating value, also sets the selected Index
Output
Exception

setRatingStyle

public void setRatingStyle (string $value )

Input
string $value set the rating style, default is "default"
Output
Exception

setReadOnly

public void setReadOnly (boolean $value )

Input
boolean $value whether the items in the column can be edited
Output
Exception

setRepeatLayout

public void setRepeatLayout (string $value )

The repeat layout must be Table.

Input
string | $value | repeat layout type
Output
Exception
throws | TInvaliddataValueException when repeat layout is not Table.

setSelectedIndex

public void setSelectedIndex (mixed $value )

Input
mixed $value
Output
Exception

Constant Details

SCRIPT_PATH

Script path relative to the TClientScriptManager::SCRIPT_PATH

Type:

string

Value:

'prado/ratings'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRegularExpressionValidator

Class TRegularExpressionValidator (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TRegularExpressionValidator

Direct Known Sub-classes:

TEmailAddressValidator

TRegularExpressionValidator class

TRegularExpressionValidator validates whether the value of an associated input component matches the pattern specified by a regular expression.

You can specify the regular expression by setting the RegularExpression property. Some commonly used regular expressions include:

 French Phone Number: (0( \d|\d ))?\d\d \d\d(\d \d| \d\d )\d\d
 French Postal Code: \d{5}
 German Phone Number: ((\(0\d\d\) |(\(0\d{3}\) )?\d )?\d\d \d\d \d\d|\(0\d{4}\) \d \d\d-\d\d?)
 German Postal Code: (D-)?\d{5}
 Email Address: \w+([-+.]\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*
 Japanese Phone Number: (0\d{1,4}-|\(0\d{1,4}\) ?)?\d{1,4}-\d{4}
 Japanese Postal Code: \d{3}(-(\d{4}|\d{2}))?
 P.R.C. Phone Number: (\(\d{3}\)|\d{3}-)?\d{8}
 P.R.C. Postal Code: \d{6}
 P.R.C. Social Security Number: \d{18}|\d{15}
 U.S. Phone Number: ((\(\d{3}\) ?)|(\d{3}-))?\d{3}-\d{4}
 U.S. ZIP Code: \d{5}(-\d{4})?
 U.S. Social Security Number: \d{3}-\d{2}-\d{4}

Note, the validation succeeds if the associated input control contains empty input. Use a TRequiredFieldValidator to ensure the input is not empty.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
boolean | evaluateIsValid () This method overrides the parent's implementation.
protected string | getClientClassName () Gets the name of the javascript class responsible for performing validation for this control.
protected array | getClientScriptOptions () Returns an array of javascript validator options.
string | getClientSidePatternModifiers ()
string | getPatternModifiers ()
string | getRegularExpression ()
void | setClientSidePatternModifiers ( string $value)
void | setPatternModifiers ( string $value)
void | setRegularExpression ( string $value)
Methods Inherited From TBaseValidator
TBaseValidator::addAttributesToRender(), TBaseValidator::createClientSide(), TBaseValidator::getClientScriptOptions(), TBaseValidator::getClientSide(), TBaseValidator::getControlCssClass(), TBaseValidator::getControlToValidate(), TBaseValidator::getDisplay(), TBaseValidator::getEnableClientScript(), TBaseValidator::getErrorMessage(), TBaseValidator::getFocusElementID(), TBaseValidator::getFocusOnError(), TBaseValidator::getIsValid(), TBaseValidator::getValidationGroup(), TBaseValidator::getValidationTarget(), TBaseValidator::getValidationValue(), TBaseValidator::onInit(), TBaseValidator::onPreRender(), TBaseValidator::onUnload(), TBaseValidator::onValidate(), TBaseValidator::onValidationError(), TBaseValidator::onValidationSuccess(), TBaseValidator::registerClientScriptValidator(), TBaseValidator::renderClientControlScript(), TBaseValidator::renderContents(), TBaseValidator::setControlCssClass(), TBaseValidator::setControlToValidate(), TBaseValidator::setDisplay(), TBaseValidator::setEnableClientScript(), TBaseValidator::setEnabled(), TBaseValidator::setErrorMessage(), TBaseValidator::setFocusElementID(), TBaseValidator::setFocusOnError(), TBaseValidator::setForControl(), TBaseValidator::setIsValid(), TBaseValidator::setValidationGroup(), TBaseValidator::updateControlCssClass(), TBaseValidator::validate()
Methods Inherited From TLabel
TLabel::addAttributesToRender(), TLabel::getData(), TLabel::getForControl(), TLabel::getTagName(), TLabel::getText(), TLabel::render(), TLabel::renderContents(), TLabel::setData(), TLabel::setForControl(), TLabel::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

evaluateIsValid

public boolean evaluateIsValid ()

This method overrides the parent's implementation.

The validation succeeds if the input data matches the regular expression. The validation always succeeds if ControlToValidate is not specified or the regular expression is empty, or the input data is empty.

Output
boolean whether the validation succeeds
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing validation for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientScriptOptions

protected array getClientScriptOptions ()

Returns an array of javascript validator options.

Output
array javascript validator options.
Exception

getClientSidePatternModifiers

public string getClientSidePatternModifiers ()

Output
string clientside pattern modifiers, no modifiers by default.
Exception

getPatternModifiers

public string getPatternModifiers ()

Output
string pattern modifiers, no modifiers by default.
Exception

getRegularExpression

public string getRegularExpression ()

Output
string the regular expression that determines the pattern used to validate a field.
Exception

setClientSidePatternModifiers

public void setClientSidePatternModifiers (string $value )

Input
string $value pattern modifiers for clientside. (Only 'g','i' and 'm' are available.)
Output
Exception

setPatternModifiers

public void setPatternModifiers (string $value )

Input
string $value pattern modifiers for server side validation, see http://www.php.net/manual/en/reference.pcre.pattern.modifiers.php
Output
Exception

setRegularExpression

public void setRegularExpression (string $value )

Input
string $value the regular expression that determines the pattern used to validate a field.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRepeater

Class TRepeater (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TDataBoundControl
               |
               --TRepeater

TRepeater class.

TRepeater displays its content repeatedly based on the data fetched from DataSource. The repeated contents in TRepeater are called items, which are controls and can be accessed through Items. When dataBind() is invoked, TRepeater creates an item for each row of data and binds the data row to the item. Optionally, a repeater can have a header, a footer and/or separators between items.

The layout of the repeated contents are specified by inline templates. Repeater items, header, footer, etc. are being instantiated with the corresponding templates when data is being bound to the repeater.

Since v3.1.0, the layout can also be specified by renderers. A renderer is a control class that can be instantiated as repeater items, header, etc. A renderer can thus be viewed as an external template (in fact, it can also be non-templated controls).

A renderer can be any control class.

  • If the class implements IDataRenderer, the Data
property will be set as the data row during databinding. Many PRADO controls implement this interface, such as TLabel, TTextBox, etc.
  • If the class implements IItemDataRenderer, the ItemIndex property will be set
as the zero-based index of the item in the repeater item collection, and the ItemType property as the item's type (such as TListItemType::Item). TRepeaterItemRenderer may be used as the convenient base class which already implements IDataItemRenderer.

The following properties are used to specify different types of template and renderer for a repeater:

  • ItemTemplate, ItemRenderer:
for each repeated row of data
  • AlternatingItemTemplate, AlternatingItemRenderer:
for each alternating row of data. If not set, ItemTemplate or ItemRenderer will be used instead.
  • HeaderTemplate, HeaderRenderer:
for the repeater header.
  • FooterTemplate, FooterRenderer:
for the repeater footer.
  • SeparatorTemplate, SeparatorRenderer:
for content to be displayed between items.
  • EmptyTemplate, EmptyRenderer:
used when data bound to the repeater is empty.

If a content type is defined with both a template and a renderer, the latter takes precedence.

When dataBind() is being called, TRepeater undergoes the following lifecycles for each row of data:

  • create item based on templates or renderers
  • set the row of data to the item
  • raise OnItemCreated:
  • add the item as a child control
  • call dataBind() of the item
  • raise OnItemDataBound:
TRepeater raises an OnItemCommand whenever a button control within some repeater item raises a OnCommand event. Therefore, you can handle all sorts of OnCommand event in a central place by writing an event handler for OnItemCommand.

When a page containing a repeater is post back, the repeater will restore automatically all its contents, including items, header, footer and separators. However, the data row associated with each item will not be recovered and become null. To access the data, use one of the following ways:

  • Use DataKeys to obtain the data key associated with
the specified repeater item and use the key to fetch the corresponding data from some persistent storage such as DB.
  • Save the whole dataset in viewstate, which will restore the dataset automatically upon postback.
Be aware though, if the size of your dataset is big, your page size will become big. Some complex data may also have serializing problem if saved in viewstate.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
boolean | bubbleEvent ( TControl $sender, TEventParameter $param) This method overrides parent's implementation to handle onItemCommand event which is bubbled from repeater items and their child controls.
protected void | createEmptyContent () Creates empty repeater content.
protected TControl | createItem ( integer $itemIndex, TListItemType $itemType) Creates a repeater item instance based on the item type and index.
string | getAlternatingItemRenderer ()
ITemplate | getAlternatingItemTemplate ()
protected mixed | getDataFieldValue ( mixed $data, mixed $field) Returns the value of the data at the specified field.
string | getDataKeyField ()
TList | getDataKeys ()
string | getEmptyRenderer ()
ITemplate | getEmptyTemplate ()
TControl | getFooter ()
string | getFooterRenderer ()
ITemplate | getFooterTemplate ()
TControl | getHeader ()
string | getHeaderRenderer ()
ITemplate | getHeaderTemplate ()
string | getItemRenderer ()
TRepeaterItemCollection | getItems ()
ITemplate | getItemTemplate ()
string | getSeparatorRenderer ()
ITemplate | getSeparatorTemplate ()
void | loadState () Loads item count information from viewstate.
void | onItemCommand ( TRepeaterCommandEventParameter $param) Raises OnItemCommand event.
void | onItemCreated ( TRepeaterItemEventParameter $param) Raises OnItemCreated event.
void | onItemDataBound ( TRepeaterItemEventParameter $param) Raises OnItemDataBound event.
protected void | performDataBinding ( Traversable $data) Performs databinding to populate repeater items from data source.
void | render ( THtmlWriter $writer) Renders the repeater.
void | reset () Clears up all items in the repeater.
protected void | restoreItemsFromViewState () Creates repeater items based on viewstate information.
void | saveState () Saves item count in viewstate.
void | setAlternatingItemRenderer ( string $value) Sets the alternative item renderer class.
void | setAlternatingItemTemplate ( ITemplate $value)
void | setDataKeyField ( string $value)
void | setEmptyRenderer ( string $value) Sets the repeater empty renderer class.
void | setEmptyTemplate ( ITemplate $value)
void | setFooterRenderer ( string $value) Sets the repeater footer renderer class.
void | setFooterTemplate ( ITemplate $value)
void | setHeaderRenderer ( string $value) Sets the repeater header renderer class.
void | setHeaderTemplate ( ITemplate $value)
void | setItemRenderer ( string $value) Sets the item renderer class.
void | setItemTemplate ( ITemplate $value)
void | setSeparatorRenderer ( string $value) Sets the repeater item separator renderer class.
void | setSeparatorTemplate ( ITemplate $value)
Methods Inherited From TDataBoundControl
TDataBoundControl::createPagedDataSource(), TDataBoundControl::dataBind(), TDataBoundControl::dataSourceViewChanged(), TDataBoundControl::determineDataSource(), TDataBoundControl::ensureDataBound(), TDataBoundControl::getAllowCustomPaging(), TDataBoundControl::getAllowPaging(), TDataBoundControl::getCurrentPageIndex(), TDataBoundControl::getDataMember(), TDataBoundControl::getDataSource(), TDataBoundControl::getDataSourceID(), TDataBoundControl::getDataSourceView(), TDataBoundControl::getInitialized(), TDataBoundControl::getIsDataBound(), TDataBoundControl::getPageCount(), TDataBoundControl::getPageSize(), TDataBoundControl::getRequiresDataBinding(), TDataBoundControl::getSelectParameters(), TDataBoundControl::getUsingDataSourceID(), TDataBoundControl::getVirtualItemCount(), TDataBoundControl::onDataBound(), TDataBoundControl::onDataSourceChanged(), TDataBoundControl::onInit(), TDataBoundControl::onPreRender(), TDataBoundControl::pagePreLoad(), TDataBoundControl::setAllowCustomPaging(), TDataBoundControl::setAllowPaging(), TDataBoundControl::setCurrentPageIndex(), TDataBoundControl::setDataMember(), TDataBoundControl::setDataSource(), TDataBoundControl::setDataSourceID(), TDataBoundControl::setInitialized(), TDataBoundControl::setIsDataBound(), TDataBoundControl::setPageSize(), TDataBoundControl::setRequiresDataBinding(), TDataBoundControl::setVirtualItemCount(), TDataBoundControl::validateDataSource()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | IT_ALTERNATINGITEM |
string | IT_FOOTER |
string | IT_HEADER | Repeater item types
string | IT_ITEM |
string | IT_SEPARATOR |
Method Details

bubbleEvent

public boolean bubbleEvent (TControl $sender , TEventParameter $param )

This method overrides parent's implementation to handle onItemCommand event which is bubbled from repeater items and their child controls.

This method should only be used by control developers.

Input
TControl | $sender | the sender of the event
TEventParameter | $param | event parameter
Output
boolean | whether the event bubbling should stop here.
Exception

createEmptyContent

protected void createEmptyContent ()

Creates empty repeater content.

Output
Exception

createItem

protected TControl createItem (integer $itemIndex , TListItemType $itemType )

Creates a repeater item instance based on the item type and index.

Input
integer | $itemIndex | zero-based item index
TListItemType | $itemType | item type
Output
TControl | created repeater item
Exception

getAlternatingItemRenderer

public string getAlternatingItemRenderer ()

Output
string the class name for alternative repeater items. Defaults to empty, meaning not set.
Exception

getAlternatingItemTemplate

public ITemplate getAlternatingItemTemplate ()

Output
ITemplate the alternative template string for the item
Exception

getDataFieldValue

protected mixed getDataFieldValue (mixed $data , mixed $field )

Returns the value of the data at the specified field.

If data is an array, TMap or TList, the value will be returned at the index of the specified field. If the data is a component with a property named as the field name, the property value will be returned. Otherwise, an exception will be raised.

Input
mixed | $data | data item
mixed | $field | field name
Output
mixed | data value at the specified field
Exception
throws | TInvalidDataValueException if the data is invalid

getDataKeyField

public string getDataKeyField ()

Output
string the field of the data source that provides the keys of the list items.
Exception

getDataKeys

public TList getDataKeys ()

Output
TList the keys used in the data listing control.
Exception

getEmptyRenderer

public string getEmptyRenderer ()

Output
string the class name for empty repeater item. Defaults to empty, meaning not set.
Exception

getEmptyTemplate

public ITemplate getEmptyTemplate ()

Output
ITemplate the template applied when no data is bound to the repeater
Exception

getFooter

public TControl getFooter ()

Output
TControl the footer item
Exception

getFooterRenderer

public string getFooterRenderer ()

Output
string the class name for repeater footer item. Defaults to empty, meaning not set.
Exception

getFooterTemplate

public ITemplate getFooterTemplate ()

Output
ITemplate the footer template
Exception

getHeader

public TControl getHeader ()

Output
TControl the header item
Exception

getHeaderRenderer

public string getHeaderRenderer ()

Output
string the class name for repeater header item. Defaults to empty, meaning not set.
Exception

getHeaderTemplate

public ITemplate getHeaderTemplate ()

Output
ITemplate the header template
Exception

getItemRenderer

public string getItemRenderer ()

Output
string the class name for repeater items. Defaults to empty, meaning not set.
Exception

getItems

public TRepeaterItemCollection getItems ()

Output
TRepeaterItemCollection list of repeater item controls
Exception

getItemTemplate

public ITemplate getItemTemplate ()

Output
ITemplate the template for repeater items
Exception

getSeparatorRenderer

public string getSeparatorRenderer ()

Output
string the class name for repeater item separators. Defaults to empty, meaning not set.
Exception

getSeparatorTemplate

public ITemplate getSeparatorTemplate ()

Output
ITemplate the separator template
Exception

loadState

public void loadState ()

Loads item count information from viewstate.

This method is invoked right after control state is loaded.

Output
Exception

onItemCommand

public void onItemCommand (TRepeaterCommandEventParameter $param )

Raises OnItemCommand event.

This method is invoked after a button control in a template raises OnCommand event. The repeater control responsible for the event can be determined from the event parameter. The event parameter also contains the information about the initial sender of the OnCommand event, command name and command parameter. You may override this method to provide customized event handling. Be sure to call parent's implementation so that event handlers have chance to respond to the event.

Input
TRepeaterCommandEventParameter $param event parameter
Output
Exception

onItemCreated

public void onItemCreated (TRepeaterItemEventParameter $param )

Raises OnItemCreated event.

This method is invoked after a repeater item is created and instantiated with template, but before added to the page hierarchy. The repeater item control responsible for the event can be determined from the event parameter. If you override this method, be sure to call parent's implementation so that event handlers have chance to respond to the event.

Input
TRepeaterItemEventParameter $param event parameter
Output
Exception

onItemDataBound

public void onItemDataBound (TRepeaterItemEventParameter $param )

Raises OnItemDataBound event.

This method is invoked right after an item is data bound. The repeater item control responsible for the event can be determined from the event parameter. If you override this method, be sure to call parent's implementation so that event handlers have chance to respond to the event.

Input
TRepeaterItemEventParameter $param event parameter
Output
Exception

performDataBinding

protected void performDataBinding (Traversable $data )

Performs databinding to populate repeater items from data source.

This method is invoked by dataBind(). You may override this function to provide your own way of data population.

Input
Traversable $data the data
Output
Exception

render

public void render (THtmlWriter $writer )

Renders the repeater.

This method overrides the parent implementation by rendering the body content as the whole presentation of the repeater. Outer tag is not rendered.

Input
THtmlWriter $writer writer
Output
Exception

reset

public void reset ()

Clears up all items in the repeater.

Output
Exception

restoreItemsFromViewState

protected void restoreItemsFromViewState ()

Creates repeater items based on viewstate information.

Output
Exception

saveState

public void saveState ()

Saves item count in viewstate.

This method is invoked right before control state is to be saved.

Output
Exception

setAlternatingItemRenderer

public void setAlternatingItemRenderer (string $value )

Sets the alternative item renderer class.

If not empty, the class will be used to instantiate as alternative repeater items. This property takes precedence over AlternatingItemTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setAlternatingItemTemplate

public void setAlternatingItemTemplate (ITemplate $value )

Input
ITemplate | $value | the alternative item template
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setDataKeyField

public void setDataKeyField (string $value )

Input
string $value the field of the data source that provides the keys of the list items.
Output
Exception

setEmptyRenderer

public void setEmptyRenderer (string $value )

Sets the repeater empty renderer class.

The empty renderer is created as the child of the repeater if data bound to the repeater is empty. This property takes precedence over EmptyTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setEmptyTemplate

public void setEmptyTemplate (ITemplate $value )

Input
ITemplate | $value | the template applied when no data is bound to the repeater
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setFooterRenderer

public void setFooterRenderer (string $value )

Sets the repeater footer renderer class.

If not empty, the class will be used to instantiate as repeater footer item. This property takes precedence over FooterTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setFooterTemplate

public void setFooterTemplate (ITemplate $value )

Input
ITemplate | $value | the footer template
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setHeaderRenderer

public void setHeaderRenderer (string $value )

Sets the repeater header renderer class.

If not empty, the class will be used to instantiate as repeater header item. This property takes precedence over HeaderTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setHeaderTemplate

public void setHeaderTemplate (ITemplate $value )

Input
ITemplate | $value | the header template
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setItemRenderer

public void setItemRenderer (string $value )

Sets the item renderer class.

If not empty, the class will be used to instantiate as repeater items. This property takes precedence over ItemTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setItemTemplate

public void setItemTemplate (ITemplate $value )

Input
ITemplate | $value | the template for repeater items
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setSeparatorRenderer

public void setSeparatorRenderer (string $value )

Sets the repeater item separator renderer class.

If not empty, the class will be used to instantiate as repeater item separators. This property takes precedence over SeparatorTemplate.

Input
string $value the renderer class name in namespace format.
Output
Exception

setSeparatorTemplate

public void setSeparatorTemplate (ITemplate $value )

Input
ITemplate | $value | the separator template
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.
Constant Details

IT_ALTERNATINGITEM

Type:

string

Value:

'AlternatingItem'

IT_FOOTER

Type:

string

Value:

'Footer'

IT_HEADER

Repeater item types

Type:

string

Value:

'Header'
Deprecated: deprecated since version 3.0.4. Use TListItemType constants instead.

IT_ITEM

Type:

string

Value:

'Item'

IT_SEPARATOR

Type:

string

Value:

'Separator'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRepeaterCommandEventParameter

Class TRepeaterCommandEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TCommandEventParameter
         |
         --TRepeaterCommandEventParameter

TRepeaterCommandEventParameter class

TRepeaterCommandEventParameter encapsulates the parameter data for TRepeater::onItemCommand event of TRepeater controls.

The Item property indicates the repeater item related with the event. The CommandSource refers to the control that originally raises the Command event.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
TControl | getCommandSource ()
TControl | getItem ()
Methods Inherited From TCommandEventParameter
TCommandEventParameter::getCommandName(), TCommandEventParameter::getCommandParameter()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getCommandSource

public TControl getCommandSource ()

Output
TControl the control originally raises the OnCommand event.
Exception

getItem

public TControl getItem ()

Output
TControl the repeater item control responsible for the event.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRepeaterItem

Class TRepeaterItem (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TRepeaterItem

TRepeaterItem class

A TRepeaterItem control represents an item in the TRepeater control, such as heading section, footer section, or a data item. The index and data value of the item can be accessed via ItemIndex> and DataItem properties, respectively. The type of the item is given by ItemType property.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
boolean | bubbleEvent ( TControl $sender, TEventParameter $param) This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
mixed | getData ()
mixed | getDataItem () This property is deprecated since v3.1.0.
integer | getItemIndex () Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
TListItemType | getItemType ()
void | setData ( mixed $value)
void | setDataItem ( mixed $value) This property is deprecated since v3.1.0.
void | setItemIndex ( integer $value) Sets the zero-based index for the item.
void | setItemType ( TListItemType $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

bubbleEvent

public boolean bubbleEvent (TControl $sender , TEventParameter $param )

This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

Input
TControl | $sender | the sender of the event
TEventParameter | $param | event parameter
Output
boolean | whether the event bubbling should stop here.
Exception

getData

public mixed getData ()

Output
mixed data associated with the item
Exception

getDataItem

public mixed getDataItem ()

This property is deprecated since v3.1.0.

Output
mixed data associated with the item
Exception

getItemIndex

public integer getItemIndex ()

Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.

If the item is not in the collection (e.g. it is a header item), it returns -1.

Output
integer zero-based index of the item.
Exception

getItemType

public TListItemType getItemType ()

Output
TListItemType item type
Exception

setData

public void setData (mixed $value )

Input
mixed $value data to be associated with the item
Output
Exception

setDataItem

public void setDataItem (mixed $value )

This property is deprecated since v3.1.0.

Input
mixed $value data to be associated with the item
Output
Exception

setItemIndex

public void setItemIndex (integer $value )

Sets the zero-based index for the item.

If the item is not in the item collection (e.g. it is a header item), -1 should be used.

Input
integer $value zero-based index of the item.
Output
Exception

setItemType

public void setItemType (TListItemType $value )

Input
TListItemType $value item type.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRepeaterItemCollection

Class TRepeaterItemCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TRepeaterItemCollection

TRepeaterItemCollection class.

TRepeaterItemCollection represents a collection of repeater items.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void
insertAt ( integer $index, TControl $item)
Inserts an item at the specified position.
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

insertAt

public void insertAt (integer $index , TControl $item )

Inserts an item at the specified position.

This overrides the parent implementation by inserting only objects that are descendant of TControl.

Input
integer | $index | the speicified position.
TControl | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is not a control.


PRADO API Manual: Docs For Class TRepeaterItemEventParameter

Class TRepeaterItemEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TRepeaterItemEventParameter

TRepeaterItemEventParameter class

TRepeaterItemEventParameter encapsulates the parameter data for TRepeater::onItemCreated event of TRepeater controls. The Item property indicates the repeater item related with the event.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
TControl
getItem ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getItem

public TControl getItem ()

Output
TControl repeater item related with the corresponding event
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRepeaterItemRenderer

Class TRepeaterItemRenderer (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TDataRenderer
                  |
                  --TItemDataRenderer
                     |
                     --TRepeaterItemRenderer

TRepeaterItemRenderer class

TRepeaterItemRenderer can be used as a convenient base class to define an item renderer class specific for TRepeater.

TRepeaterItemRenderer extends TItemDataRenderer and implements the bubbling scheme for the OnCommand event of repeater items.

Since: 3.1.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TTemplateControl
EXT_TEMPLATE,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
boolean
bubbleEvent ( TControl $sender, TEventParameter $param)
This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
Methods Inherited From TItemDataRenderer
TItemDataRenderer::getItemIndex(), TItemDataRenderer::getItemType(), TItemDataRenderer::setItemIndex(), TItemDataRenderer::setItemType()
Methods Inherited From TDataRenderer
TDataRenderer::getData(), TDataRenderer::setData()
Methods Inherited From TTemplateControl
TTemplateControl::createChildControls(), TTemplateControl::getIsSourceTemplateControl(), TTemplateControl::getMaster(), TTemplateControl::getMasterClass(), TTemplateControl::getTemplate(), TTemplateControl::getTemplateDirectory(), TTemplateControl::initRecursive(), TTemplateControl::injectContent(), TTemplateControl::loadTemplate(), TTemplateControl::registerContent(), TTemplateControl::registerContentPlaceHolder(), TTemplateControl::setMasterClass(), TTemplateControl::setTemplate()
Methods Inherited From TCompositeControl
TCompositeControl::initRecursive()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

bubbleEvent

public boolean bubbleEvent (TControl $sender , TEventParameter $param )

This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.

Input
TControl | $sender | the sender of the event
TEventParameter | $param | event parameter
Output
boolean | whether the event bubbling should stop here.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IRepeatInfoUser

Interface IRepeatInfoUser (Class Overview)

IRepeatInfoUser interface.

This interface must be implemented by classes who want to use TRepeatInfo.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
TStyle | generateItemStyle ( string $itemType, integer $index)
boolean | getHasFooter ()
boolean | getHasHeader ()
boolean | getHasSeparators ()
integer | getItemCount ()
void | renderItem ( THtmlWriter $writer, TRepeatInfo $repeatInfo, string $itemType, integer $index) Renders an item.

            Method Details

generateItemStyle

                                public TStyle generateItemStyle
                                (string $itemType , integer $index )

Input
string | $itemType | item type (Header,Footer,Item,AlternatingItem,SelectedItem,EditItem,Separator,Pager)
integer | $index | zero-based index of the current rendering item.
Output
TStyle | CSS style used for rendering items (including header, footer and separators)
Exception

getHasFooter

                                public boolean getHasFooter
                                ()

Output

                                    boolean
                 whether the repeat user contains footer

Exception

getHasHeader

                                public boolean getHasHeader
                                ()

Output

                                    boolean
                 whether the repeat user contains header

Exception

getHasSeparators

                                public boolean getHasSeparators
                                ()

Output

                                    boolean
                 whether the repeat user contains separators

Exception

getItemCount

                                public integer getItemCount
                                ()

Output

                                    integer
                 number of items to be rendered (excluding header, footer and separators)

Exception

renderItem

                                public void renderItem
                                (THtmlWriter $writer , TRepeatInfo $repeatInfo , string $itemType , integer $index )

Renders an item.

Input
THtmlWriter | $writer | writer for the rendering purpose
TRepeatInfo | $repeatInfo | repeat information
string | $itemType | item type
integer | $index | zero-based index of the item being rendered
Output
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRepeatDirection

Class TRepeatDirection (Class Overview)

TEnumerable
   |
   --TRepeatDirection

TRepeatDirection class.

TRepeatDirection defines the enumerable type for the possible directions that repeated contents can repeat along

The following enumerable values are defined:

  • Vertical
  • Horizontal

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Horizontal
string | Vertical
Constant Details

Horizontal

Type:

string

Value:

'Horizontal'

Vertical

Type:

string

Value:

'Vertical'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRepeatInfo

Class TRepeatInfo (Class Overview)

TComponent
   |
   --TRepeatInfo

TRepeatInfo class.

TRepeatInfo represents repeat information for controls like TCheckBoxList. The layout of the repeated items is specified via RepeatLayout, which can be either Table (default), Flow or Raw. A table layout uses HTML table cells to organize the items while a flow layout uses line breaks to organize the items. The number of columns used to display the items is specified via RepeatColumns property, while the RepeatDirection governs the order of the items being rendered.

Note, the Raw layout does not contain any formatting tags and thus ignores the column and repeat direction settings.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
string | getCaption ()
TTableCaptionAlign | getCaptionAlign ()
integer | getRepeatColumns ()
TRepeatDirection | getRepeatDirection ()
TRepeatLayout | getRepeatLayout ()
protected void | renderFooter ( THtmlWriter $writer, IRepeatInfoUser $user, boolean $tableLayout, integer $columns) Renders footer.
protected void | renderHeader ( THtmlWriter $writer, IRepeatInfoUser $user, boolean $tableLayout, integer $columns, boolean $needBreak) Renders header.
protected void | renderHorizontalContents ( THtmlWriter $writer, IRepeatInfoUser $user) Renders contents in horizontal repeat direction.
protected void | renderRawContents ( THtmlWriter $writer, IRepeatInfoUser $user) Renders contents in raw format.
void | renderRepeater ( THtmlWriter $writer, IRepeatInfoUser $user) Renders the repeated items.
protected void | renderVerticalContents ( THtmlWriter $writer, IRepeatInfoUser $user) Renders contents in veritcal repeat direction.
void | setCaption ( string $value)
TTableCaptionAlign | setCaptionAlign ( mixed $value)
void | setRepeatColumns ( integer $value)
void | setRepeatDirection ( TRepeatDirection $value)
void | setRepeatLayout ( TRepeatLayout $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getCaption

public string getCaption ()

Output
string caption of the table layout
Exception

getCaptionAlign

public TTableCaptionAlign getCaptionAlign ()

Output
TTableCaptionAlign alignment of the caption of the table layout. Defaults to TTableCaptionAlign::NotSet.
Exception

getRepeatColumns

public integer getRepeatColumns ()

Output
integer the number of columns that the repeated items should be displayed in. Defaults to 0, meaning not set.
Exception

getRepeatDirection

public TRepeatDirection getRepeatDirection ()

Output
TRepeatDirection the direction of traversing the repeated items, defaults to TRepeatDirection::Vertical
Exception

getRepeatLayout

public TRepeatLayout getRepeatLayout ()

Output
TRepeatLayout how the repeated items should be displayed, using table or using line breaks. Defaults to TRepeatLayout::Table.
Exception

renderFooter

protected void renderFooter (THtmlWriter $writer , IRepeatInfoUser $user , boolean $tableLayout , integer $columns )

Renders footer.

Input
THtmlWriter | $writer | writer for the rendering purpose
IRepeatInfoUser | $user | repeat information user
boolean | $tableLayout | whether to render using table layout
integer | $columns | number of columns to be rendered
Output
Exception

renderHeader

protected void renderHeader (THtmlWriter $writer , IRepeatInfoUser $user , boolean $tableLayout , integer $columns , boolean $needBreak )

Renders header.

Input
THtmlWriter | $writer | writer for the rendering purpose
IRepeatInfoUser | $user | repeat information user
boolean | $tableLayout | whether to render using table layout
integer | $columns | number of columns to be rendered
boolean | $needBreak | if a line break is needed at the end
Output
Exception

renderHorizontalContents

protected void renderHorizontalContents (THtmlWriter $writer , IRepeatInfoUser $user )

Renders contents in horizontal repeat direction.

Input
THtmlWriter | $writer | writer for the rendering purpose
IRepeatInfoUser | $user | repeat information user
Output
Exception

renderRawContents

protected void renderRawContents (THtmlWriter $writer , IRepeatInfoUser $user )

Renders contents in raw format.

Input
THtmlWriter | $writer | writer for the rendering purpose
IRepeatInfoUser | $user | repeat information user
Output
Exception

renderRepeater

public void renderRepeater (THtmlWriter $writer , IRepeatInfoUser $user )

Renders the repeated items.

Input
THtmlWriter | $writer | writer for the rendering purpose
IRepeatInfoUser | $user | repeat information user
Output
Exception

renderVerticalContents

protected void renderVerticalContents (THtmlWriter $writer , IRepeatInfoUser $user )

Renders contents in veritcal repeat direction.

Input
THtmlWriter | $writer | writer for the rendering purpose
IRepeatInfoUser | $user | repeat information user
Output
Exception

setCaption

public void setCaption (string $value )

Input
string $value caption of the table layout
Output
Exception

setCaptionAlign

public TTableCaptionAlign setCaptionAlign (mixed $value )

Input
mixed | $value
Output
TTableCaptionAlign | alignment of the caption of the table layout.
Exception

setRepeatColumns

public void setRepeatColumns (integer $value )

Input
integer $value the number of columns that the repeated items should be displayed in.
Output
Exception

setRepeatDirection

public void setRepeatDirection (TRepeatDirection $value )

Input
TRepeatDirection $value the direction of traversing the repeated items
Output
Exception

setRepeatLayout

public void setRepeatLayout (TRepeatLayout $value )

Input
TRepeatLayout $value how the repeated items should be displayed, using table or using line breaks.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRepeatLayout

Class TRepeatLayout (Class Overview)

TEnumerable
   |
   --TRepeatLayout

TRepeatLayout class.

TRepeatLayout defines the enumerable type for the possible layouts that repeated contents can take.

The following enumerable values are defined:

  • Table: the repeated contents are organized using an HTML table
  • Flow: the repeated contents are organized using HTML spans and breaks
  • Raw: the repeated contents are stacked together without any additional decorations

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Flow
string | Raw
string | Table
Constant Details

Flow

Type:

string

Value:

'Flow'

Raw

Type:

string

Value:

'Raw'

Table

Type:

string

Value:

'Table'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TRequiredFieldValidator

Class TRequiredFieldValidator (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TLabel
               |
               --TBaseValidator
                  |
                  --TRequiredFieldValidator

TRequiredFieldValidator class

TRequiredFieldValidator makes the associated input control a required field. The input control fails validation if its value does not change from the InitialValue property upon losing focus.

Validation will also succeed if input is of TListControl type and the number of selected values different from the initial value is greater than zero.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected boolean | evaluateIsValid () This method overrides the parent's implementation.
protected string | getClientClassName () Gets the name of the javascript class responsible for performing validation for this control.
protected array | getClientScriptOptions () Returns an array of javascript validator options.
string | getInitialValue ()
void | setInitialValue ( string $value)
Methods Inherited From TBaseValidator
TBaseValidator::addAttributesToRender(), TBaseValidator::createClientSide(), TBaseValidator::getClientScriptOptions(), TBaseValidator::getClientSide(), TBaseValidator::getControlCssClass(), TBaseValidator::getControlToValidate(), TBaseValidator::getDisplay(), TBaseValidator::getEnableClientScript(), TBaseValidator::getErrorMessage(), TBaseValidator::getFocusElementID(), TBaseValidator::getFocusOnError(), TBaseValidator::getIsValid(), TBaseValidator::getValidationGroup(), TBaseValidator::getValidationTarget(), TBaseValidator::getValidationValue(), TBaseValidator::onInit(), TBaseValidator::onPreRender(), TBaseValidator::onUnload(), TBaseValidator::onValidate(), TBaseValidator::onValidationError(), TBaseValidator::onValidationSuccess(), TBaseValidator::registerClientScriptValidator(), TBaseValidator::renderClientControlScript(), TBaseValidator::renderContents(), TBaseValidator::setControlCssClass(), TBaseValidator::setControlToValidate(), TBaseValidator::setDisplay(), TBaseValidator::setEnableClientScript(), TBaseValidator::setEnabled(), TBaseValidator::setErrorMessage(), TBaseValidator::setFocusElementID(), TBaseValidator::setFocusOnError(), TBaseValidator::setForControl(), TBaseValidator::setIsValid(), TBaseValidator::setValidationGroup(), TBaseValidator::updateControlCssClass(), TBaseValidator::validate()
Methods Inherited From TLabel
TLabel::addAttributesToRender(), TLabel::getData(), TLabel::getForControl(), TLabel::getTagName(), TLabel::getText(), TLabel::render(), TLabel::renderContents(), TLabel::setData(), TLabel::setForControl(), TLabel::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

evaluateIsValid

protected boolean evaluateIsValid ()

This method overrides the parent's implementation.

The validation succeeds if the input component changes its data from the InitialValue or the input control is not given.

Validation will also succeed if input is of TListControl type and the number of selected values different from the initial value is greater than zero.

Output
boolean whether the validation succeeds
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing validation for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientScriptOptions

protected array getClientScriptOptions ()

Returns an array of javascript validator options.

Output
array javascript validator options.
Exception

getInitialValue

public string getInitialValue ()

Output
string the initial value of the associated input control. Defaults to empty string. If the associated input control does not change from this initial value upon postback, the validation fails.
Exception

setInitialValue

public void setInitialValue (string $value )

Input
string $value the initial value of the associated input control. If the associated input control does not change from this initial value upon postback, the validation fails.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSafeHtml

Class TSafeHtml (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TSafeHtml

TSafeHtml class

TSafeHtml is a control that strips down all potentially dangerous HTML content. It is mainly a wrapper of SafeHTML project. According to the SafeHTML project, it tries to safeguard the following situations when the string is to be displayed to end-users,

  • Opening tag without its closing tag
  • closing tag without its opening tag
  • any of these tags: base, basefont, head, html, body, applet, object, iframe, frame, frameset, script, layer, ilayer, embed, bgsound, link, meta, style, title, blink, xml, etc.
  • any of these attributes: on*, data*, dynsrc
  • javascript:/vbscript:/about: etc. protocols
  • expression/behavior etc. in styles
  • any other active content.
To use TSafeHtml, simply enclose the content to be secured within the body of TSafeHtml in a template.

Since: 3.0
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected string | parseSafeHtml ( string $text) Use SafeHTML to remove malicous javascript from the HTML content.
void | render ( THtmlWriter $writer) Renders body content.
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

parseSafeHtml

protected string parseSafeHtml (string $text )

Use SafeHTML to remove malicous javascript from the HTML content.

Input
string | $text | HTML content
Output
string | safer HTML content
Exception

render

public void render (THtmlWriter $writer )

Renders body content.

This method overrides parent implementation by removing malicious javascript code from the body content

Input
THtmlWriter $writer writer
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSlider

Class TSlider (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TSlider

TSlider class

TSlider displays a slider for numeric input purpose. A slider consists of a 'track', which define the range of possible value, and a 'handle' which can slide on the track, to select a value in the range. The track can be either Horizontal or Vertical, depending of the SetDirection property. By default, it's horizontal.

The range boundaries are defined by SetMinValue and SetMaxValue properties. The default range is from 0 to 100. The SetStepSize property can be used to define the step between 2 values inside the range. Notice that this step will be recomputed if there is more than 200 values between the range boundaries. You can also provide the allowed values by setting the SetValues array.

A 'Progress Indicator' can be displayed within the track with the SetProgressIndicator property.

The TSlider control can be easily customized using CssClasses. You can provide your own css file, using the SetCssUrl property. The css class for TSlider can be set by the CssClass property. Default value is "Slider HorizontalSlider" for an horizontal slider, and "Slider VerticalSlider" for a vertical one.

If SetAutoPostBack property is true, postback is sent as soon as the value changed.

TSlider raises the onValueChanged event when the value of the slider has changed during postback.

You can also attach ClientSide javascript events handler to the slider :

  • ClientSide.onSlide is called when the handle is slided on the track. You can get the current value in the value
javascript variable. You can use this event to update on client side a label with the current value
  • ClientSide.onChange is called when the slider value has changed (at the end of a move).

Since: 3.1.1
Author: Christophe Boulain <Christophe.Boulain@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Add the specified css classes to the track
protected TSliderClientScript | createClientScript ()
boolean | getAutoPostBack ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
TSliderClientScript | getClientSide () Gets the TSliderClientScript to set the TSlider event handlers.
string | getCssUrl ()
string | getData () Returns the value of the TSlider control.
boolean | getDataChanged () Returns a value indicating whether postback has caused the control data change.
TSliderDirection | getDirection ()
float | getMaxValue ()
float | getMinValue ()
boolean | getProgressIndicator ()
protected array | getSliderOptions () Get javascript sliderr options.
float | getStepSize ()
string | getTagName ()
float | getValue ()
array | getValues ()
boolean | loadPostData ( string $key, array $values) Loads user input data.
void | onPreRender ( mixed $param) Registers CSS and JS.
void | onValueChanged ( TEventParameter $param) Raises OnValueChanged event.
void | raisePostDataChangedEvent () Raises postdata changed event.
protected void | registerSliderClientScript () Registers the javascript code to initialize the slider.
protected void | registerStyleSheet () Registers the CSS relevant to the TSlider.
void | renderContents ( mixed $writer) Render the body content
void | setAutoPostBack ( boolean $value) Sets the value indicating if postback automatically.
void | setCssUrl ( string $value)
void | setData ( string $value) Sets the value of the TSlider control.
void | setDirection ( TSliderDirection $value)
void | setMaxValue ( float $value)
void | setMinValue ( float $value)
void | setProgressIndicator ( boolean $value)
void | setStepSize ( float $value) Sets the step size used to determine the places where the slider handle can stop at.
void | setValue ( float $value)
void | setValues ( array $value) Sets the possible values that the slider can take.
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
int MAX_STEPS
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Add the specified css classes to the track

Input
THtmlWriter $writer writer
Output
Exception

createClientScript

protected TSliderClientScript createClientScript ()

Output
TSliderClientScript javascript event options.
Exception

getAutoPostBack

public boolean getAutoPostBack ()

Output
boolean a value indicating whether an automatic postback to the server will occur whenever the user modifies the slider value. Defaults to false.
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientSide

public TSliderClientScript getClientSide ()

Gets the TSliderClientScript to set the TSlider event handlers.

The slider on the client-side supports the following events.

  • <tt>OnSliderMove</tt> -- raised when the slider is moved.
  • <tt>OnSliderChanged</tt> -- raised when the slider value is changed
You can attach custom javascript code to each of these events

Output
TSliderClientScript javascript validator event options.
Exception

getCssUrl

public string getCssUrl ()

Output
string URL for the CSS file including all relevant CSS class definitions. Defaults to '' (a default CSS file will be applied in this case.)
Exception

getData

public string getData ()

Returns the value of the TSlider control.

This method is required by IDataRenderer. It is the same as getValue().

Output
string the value of the TSlider control.
Exception

getDataChanged

public boolean getDataChanged ()

Returns a value indicating whether postback has caused the control data change.

This method is required by the IPostBackDataHandler interface.

Output
boolean whether postback has caused the control data change. False if the page is not in postback mode.
Exception

getDirection

public TSliderDirection getDirection ()

Output
TSliderDirection Direction of slider (Horizontal or Vertical). Defaults to Horizontal.
Exception

getMaxValue

public float getMaxValue ()

Output
float Maximum value for the slider. Defaults to 100.0.
Exception

getMinValue

public float getMinValue ()

Output
float Minimum value for slider. Defaults to 0.0.
Exception

getProgressIndicator

public boolean getProgressIndicator ()

Output
boolean wether to display a progress indicator or not. Defaults to true.
Exception

getSliderOptions

protected array getSliderOptions ()

Get javascript sliderr options.

Output
array slider client-side options
Exception

getStepSize

public float getStepSize ()

Output
float Step size. Defaults to 1.0.
Exception

getTagName

public string getTagName ()

Output
string the HTML tag name for slider. Defaults to div.
Exception

getValue

public float getValue ()

Output
float current value of slider
Exception

getValues

public array getValues ()

Output
array list of allowed values the slider can take. Defaults to an empty array.
Exception

loadPostData

public boolean loadPostData (string $key , array $values )

Loads user input data.

This method is primarly used by framework developers.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the component has been changed
Exception

onPreRender

public void onPreRender (mixed $param )

Registers CSS and JS.

This method is invoked right before the control rendering, if the control is visible.

Input
mixed $param event parameter
Output
Exception

onValueChanged

public void onValueChanged (TEventParameter $param )

Raises OnValueChanged event.

This method is invoked when the Value property changes on postback. If you override this method, be sure to call the parent implementation to ensure the invocation of the attached event handlers.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raisePostDataChangedEvent

public void raisePostDataChangedEvent ()

Raises postdata changed event.

This method is required by IPostBackDataHandler interface. It is invoked by the framework when Value property is changed on postback. This method is primarly used by framework developers.

Output
Exception

registerSliderClientScript

protected void registerSliderClientScript ()

Registers the javascript code to initialize the slider.

Output
Exception

registerStyleSheet

protected void registerStyleSheet ()

Registers the CSS relevant to the TSlider.

It will register the CSS file specified by CssUrl. If that is not set, it will use the default CSS.

Output
Exception

renderContents

public void renderContents (mixed $writer )

Render the body content

Input
mixed $writer
Output
Exception

setAutoPostBack

public void setAutoPostBack (boolean $value )

Sets the value indicating if postback automatically.

An automatic postback to the server will occur whenever the user modifies the slider value.

Input
boolean $value the value indicating if postback automatically
Output
Exception

setCssUrl

public void setCssUrl (string $value )

Input
string $value URL for the CSS file including all relevant CSS class definitions.
Output
Exception

setData

public void setData (string $value )

Sets the value of the TSlider control.

This method is required by IDataRenderer. It is the same as setValue().

Input
string $value the value of the TSlider control.
Output
Exception

setDirection

public void setDirection (TSliderDirection $value )

Input
TSliderDirection $value Direction of slider (Horizontal or Vertical)
Output
Exception

setMaxValue

public void setMaxValue (float $value )

Input
float $value Maximum value for slider
Output
Exception

setMinValue

public void setMinValue (float $value )

Input
float $value Minimum value for slider
Output
Exception

setProgressIndicator

public void setProgressIndicator (boolean $value )

Input
boolean $value wether to display a progress indicator or not. Defaults to true.
Output
Exception

setStepSize

public void setStepSize (float $value )

Sets the step size used to determine the places where the slider handle can stop at.

An evenly distributed stop marks will be generated according to MinValue, MaxValue and StepSize. To use uneven stop marks, set Values.

Input
float $value Step size.
Output
Exception

setValue

public void setValue (float $value )

Input
float $value current value of slider
Output
Exception

setValues

public void setValues (array $value )

Sets the possible values that the slider can take.

If this is set, StepSize will be ignored. The latter generates a set of evenly distributed candidate values.

Input
array $value list of allowed values the slider can take
Output
Exception

Constant Details

MAX_STEPS

Type:

int

Value:

200


PRADO API Manual: Docs For Class TSliderClientScript

Class TSliderClientScript (Class Overview)

TComponent
   |
   --TClientSideOptions
      |
      --TSliderClientScript

TSliderClientScript class.

Client-side slider events OnChange and {@line setOnMove OnMove} can be modified through the TSlider:: property of a slider.

The current value of the slider can be get in the 'value' js variable

The <tt>OnMove</tt> event is raised when the slider moves The <tt>OnChange</tt> event is raised when the slider value is changed (or at the end of a move)

Since: 3.1.1
Author: Christophe Boulain <Christophe.Boulain@gmail.com>
Method Summary
string | getOnChange ()
string | getOnSlide ()
void | setOnChange ( string $javascript) Javascript code to execute when the slider value is changed.
void | setOnSlide ( mixed $javascript)
Methods Inherited From TClientSideOptions
TClientSideOptions::ensureFunction(), TClientSideOptions::getOption(), TClientSideOptions::getOptions(), TClientSideOptions::setFunction(), TClientSideOptions::setOption()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getOnChange

public string getOnChange ()

Output
string javascript code to execute when the slider value is changed.
Exception

getOnSlide

public string getOnSlide ()

Output
string javascript code to execute when the slider moves.
Exception

setOnChange

public void setOnChange (string $javascript )

Javascript code to execute when the slider value is changed.

Input
string $javascript javascript code
Output
Exception

setOnSlide

public void setOnSlide (mixed $javascript )

Input
mixed $javascript
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSliderDirection

Class TSliderDirection (Class Overview)

TEnumerable
   |
   --TSliderDirection

TSliderDirection class.

TSliderDirection defines the enumerable type for the possible direction that can be used in a TSlider

The following enumerable values are defined :

  • Horizontal : Horizontal slider
  • Vertical : Vertical slider

Since: 3.1.1
Author: Christophe Boulain <Christophe.Boulain@gmail.com>
Constant Summary
string | Horizontal
string | Vertical
Constant Details

Horizontal

Type:

string

Value:

'Horizontal'

Vertical

Type:

string

Value:

'Vertical'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TStatements

Class TStatements (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TStatements

TStatements class

TStatements executes one or several PHP statements and renders the display generated during the execution. The execution happens during the rendering stage. The PHP statements being executed can be set via the property Statements. The context of the statemenets executed is the TStatements object itself.

Note, since TStatements allows execution of arbitrary PHP statements, make sure Statements does not come directly from user input.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getStatements ()
void | render ( THtmlWriter $writer) Renders the evaluation result of the statements.
void | setStatements ( string $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getStatements

public string getStatements ()

Output
string the statements to be executed
Exception

render

public void render (THtmlWriter $writer )

Renders the evaluation result of the statements.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

setStatements

public void setStatements (string $value )

Input
string $value the PHP statements to be executed
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDisplayStyle

Class TDisplayStyle (Class Overview)

TEnumerable
   |
   --TDisplayStyle

TDisplayStyle defines the enumerable type for the possible styles that a web control can display.

The following enumerable values are defined:

  • None: the control is not displayed and not included in the layout.
  • Dynamic: the control is displayed and included in the layout, the layout flow is dependent on the control (equivalent to display:'' in css).
  • Fixed: Similar to Dynamic with CSS "visibility" set "shown".
  • Hidden: the control is not displayed and is included in the layout.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constant Summary
string | Dynamic
string | Fixed
string | Hidden
string | None
Constant Details

Dynamic

Type:

string

Value:

'Dynamic'

Fixed

Type:

string

Value:

'Fixed'

Hidden

Type:

string

Value:

'Hidden'

None

Type:

string

Value:

'None'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THorizontalAlign

Class THorizontalAlign (Class Overview)

TEnumerable
   |
   --THorizontalAlign

THorizontalAlign class.

THorizontalAlign defines the enumerable type for the possible horizontal alignments in a CSS style.

The following enumerable values are defined:

  • NotSet: the alignment is not specified.
  • Left: left aligned
  • Right: right aligned
  • Center: center aligned
  • Justify: the begin and end are justified

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Center
string | Justify
string | Left
string | NotSet
string | Right
Constant Details

Center

Type:

string

Value:

'Center'

Justify

Type:

string

Value:

'Justify'

Left

Type:

string

Value:

'Left'

NotSet

Type:

string

Value:

'NotSet'

Right

Type:

string

Value:

'Right'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TStyle

Class TStyle (Class Overview)

TComponent
   |
   --TStyle

Direct Known Sub-classes:

TPanelStyle , TTableStyle , TTableItemStyle , TWizardNavigationButtonStyle

TStyle class

TStyle encapsulates the CSS style applied to a control.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void | addAttributesToRender ( THtmlWriter $writer) Adds attributes related to CSS styles to renderer.
void | clearStyleField ( string $name) Clears a single style field value;
void | copyFrom ( TStyle $style) Copies the fields in a new style to this style.
string | getBackColor ()
string | getBorderColor ()
string | getBorderStyle ()
string | getBorderWidth ()
string | getCssClass ()
string | getCustomStyle ()
TDisplayStyle | getDisplayStyle ()
TFont | getFont ()
string | getForeColor ()
string | getHeight ()
string | getStyleField ( mixed $name)
array | getStyleFields ()
string | getWidth ()
boolean | hasCssClass ()
boolean | hasFont ()
boolean | hasStyleField ( mixed $name)
void | mergeWith ( TStyle $style) Merges the style with a new one.
void | reset () Resets the style to the original empty state.
void | setBackColor ( string $value)
void | setBorderColor ( string $value)
void | setBorderStyle ( string $value) Sets the border style of the control.
void | setBorderWidth ( string $value)
void | setCssClass ( string $value)
void | setCustomStyle ( string $value) Sets custom style fields from a string.
void | setDisplayStyle ( TDisplayStyle $value)
void | setForeColor ( string $value)
void | setHeight ( string $value)
void | setStyleField ( string $name, string $value) Sets a single style field value.
void | setWidth ( string $value)
void | __clone () Need to clone the font object.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

addAttributesToRender

public void addAttributesToRender (THtmlWriter $writer )

Adds attributes related to CSS styles to renderer.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

clearStyleField

public void clearStyleField (string $name )

Clears a single style field value;

Input
string $name style field name
Output
Exception

copyFrom

public void copyFrom (TStyle $style )

Copies the fields in a new style to this style.

If a style field is set in the new style, the corresponding field in this style will be overwritten.

Input
TStyle $style the new style
Output
Exception

getBackColor

public string getBackColor ()

Output
string the background color of the control
Exception

getBorderColor

public string getBorderColor ()

Output
string the border color of the control
Exception

getBorderStyle

public string getBorderStyle ()

Output
string the border style of the control
Exception

getBorderWidth

public string getBorderWidth ()

Output
string the border width of the control
Exception

getCssClass

public string getCssClass ()

Output
string the CSS class of the control
Exception

getCustomStyle

public string getCustomStyle ()

Output
string the custom style of the control
Exception

getDisplayStyle

public TDisplayStyle getDisplayStyle ()

Output
TDisplayStyle display style
Exception

getFont

public TFont getFont ()

Output
TFont the font of the control
Exception

getForeColor

public string getForeColor ()

Output
string the foreground color of the control
Exception

getHeight

public string getHeight ()

Output
string the height of the control
Exception

getStyleField

public string getStyleField (mixed $name )

Input
mixed | $name
Output
string | a single style field value set via setStyleField. Defaults to empty string.
Exception

getStyleFields

public array getStyleFields ()

Output
array list of style fields.
Exception

getWidth

public string getWidth ()

Output
string the width of the control
Exception

hasCssClass

public boolean hasCssClass ()

Output
boolean true if CSS is set or empty.
Exception

hasFont

public boolean hasFont ()

Output
boolean true if font is set.
Exception

hasStyleField

public boolean hasStyleField (mixed $name )

Input
mixed | $name
Output
boolean | whether a style field has been defined by setStyleField
Exception

mergeWith

public void mergeWith (TStyle $style )

Merges the style with a new one.

If a style field is not set in this style, it will be overwritten by the new one.

Input
TStyle $style the new style
Output
Exception

reset

public void reset ()

Resets the style to the original empty state.

Output
Exception

setBackColor

public void setBackColor (string $value )

Input
string $value the background color of the control
Output
Exception

setBorderColor

public void setBorderColor (string $value )

Input
string $value the border color of the control
Output
Exception

setBorderStyle

public void setBorderStyle (string $value )

Sets the border style of the control.

Input
string $value the border style of the control
Output
Exception

setBorderWidth

public void setBorderWidth (string $value )

Input
string $value the border width of the control
Output
Exception

setCssClass

public void setCssClass (string $value )

Input
string $value the name of the CSS class of the control
Output
Exception

setCustomStyle

public void setCustomStyle (string $value )

Sets custom style fields from a string.

Custom style fields will be overwritten by style fields explicitly defined.

Input
string $value the custom style of the control
Output
Exception

setDisplayStyle

public void setDisplayStyle (TDisplayStyle $value )

Input
TDisplayStyle $value control display style, default is TDisplayStyle::Fixed
Output
Exception

setForeColor

public void setForeColor (string $value )

Input
string $value the foreground color of the control
Output
Exception

setHeight

public void setHeight (string $value )

Input
string $value the height of the control
Output
Exception

setStyleField

public void setStyleField (string $name , string $value )

Sets a single style field value.

Style fields set by this method will overwrite those set by setCustomStyle.

Input
string | $name | style field name
string | $value | style field value
Output
Exception

setWidth

public void setWidth (string $value )

Input
string $value the width of the control
Output
Exception

__clone

public void __clone ()

Need to clone the font object.

Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTableGridLines

Class TTableGridLines (Class Overview)

TEnumerable
   |
   --TTableGridLines

TTableGridLines class.

TTableGridLines defines the enumerable type for the possible grid line types of an HTML table.

The following enumerable values are defined:

  • None: no grid lines
  • Horizontal: horizontal grid lines only
  • Vertical: vertical grid lines only
  • Both: both horizontal and vertical grid lines are shown

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Both
string | Horizontal
string | None
string | Vertical
Constant Details

Both

Type:

string

Value:

'Both'

Horizontal

Type:

string

Value:

'Horizontal'

None

Type:

string

Value:

'None'

Vertical

Type:

string

Value:

'Vertical'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTableItemStyle

Class TTableItemStyle (Class Overview)

TComponent
   |
   --TStyle
      |
      --TTableItemStyle

TTableItemStyle class.

TTableItemStyle represents the CSS style specific for HTML table item.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | addAttributesToRender ( THtmlWriter $writer) Adds attributes related to CSS styles to renderer.
void | copyFrom ( TStyle $style) Copies the fields in a new style to this style.
THorizontalAlign | getHorizontalAlign ()
TVerticalAlign | getVerticalAlign ()
boolean | getWrap ()
void | mergeWith ( TStyle $style) Merges the style with a new one.
void | reset () Sets the style attributes to default values.
void | setHorizontalAlign ( THorizontalAlign $value) Sets the horizontal alignment of the contents within the table item.
void | setVerticalAlign ( TVerticalAlign $value) Sets the vertical alignment of the contents within the table item.
void | setWrap ( boolean $value) Sets the value indicating whether the content wraps within the table item.
Methods Inherited From TStyle
TStyle::addAttributesToRender(), TStyle::clearStyleField(), TStyle::copyFrom(), TStyle::getBackColor(), TStyle::getBorderColor(), TStyle::getBorderStyle(), TStyle::getBorderWidth(), TStyle::getCssClass(), TStyle::getCustomStyle(), TStyle::getDisplayStyle(), TStyle::getFont(), TStyle::getForeColor(), TStyle::getHeight(), TStyle::getStyleField(), TStyle::getStyleFields(), TStyle::getWidth(), TStyle::hasCssClass(), TStyle::hasFont(), TStyle::hasStyleField(), TStyle::mergeWith(), TStyle::reset(), TStyle::setBackColor(), TStyle::setBorderColor(), TStyle::setBorderStyle(), TStyle::setBorderWidth(), TStyle::setCssClass(), TStyle::setCustomStyle(), TStyle::setDisplayStyle(), TStyle::setForeColor(), TStyle::setHeight(), TStyle::setStyleField(), TStyle::setWidth(), TStyle::__clone()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

addAttributesToRender

public void addAttributesToRender (THtmlWriter $writer )

Adds attributes related to CSS styles to renderer.

This method overrides the parent implementation.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

copyFrom

public void copyFrom (TStyle $style )

Copies the fields in a new style to this style.

If a style field is set in the new style, the corresponding field in this style will be overwritten.

Input
TStyle $style the new style
Output
Exception

getHorizontalAlign

public THorizontalAlign getHorizontalAlign ()

Output
THorizontalAlign the horizontal alignment of the contents within the table item, defaults to THorizontalAlign::NotSet.
Exception

getVerticalAlign

public TVerticalAlign getVerticalAlign ()

Output
TVerticalAlign the vertical alignment of the contents within the table item, defaults to TVerticalAlign::NotSet.
Exception

getWrap

public boolean getWrap ()

Output
boolean whether the content wraps within the table item. Defaults to true.
Exception

mergeWith

public void mergeWith (TStyle $style )

Merges the style with a new one.

If a style field is not set in this style, it will be overwritten by the new one.

Input
TStyle $style the new style
Output
Exception

reset

public void reset ()

Sets the style attributes to default values.

This method overrides the parent implementation by resetting additional TTableItemStyle specific attributes.

Output
Exception

setHorizontalAlign

public void setHorizontalAlign (THorizontalAlign $value )

Sets the horizontal alignment of the contents within the table item.

Input
THorizontalAlign $value the horizontal alignment
Output
Exception

setVerticalAlign

public void setVerticalAlign (TVerticalAlign $value )

Sets the vertical alignment of the contents within the table item.

Input
TVerticalAlign $value the horizontal alignment
Output
Exception

setWrap

public void setWrap (boolean $value )

Sets the value indicating whether the content wraps within the table item.

Input
boolean $value whether the content wraps within the panel.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTableStyle

Class TTableStyle (Class Overview)

TComponent
   |
   --TStyle
      |
      --TTableStyle

TTableStyle class.

TTableStyle represents the CSS style specific for HTML table.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | addAttributesToRender ( THtmlWriter $writer) Adds attributes related to CSS styles to renderer.
void | copyFrom ( TStyle $style) Copies the fields in a new style to this style.
string | getBackImageUrl ()
boolean | getBorderCollapse ()
integer | getCellPadding ()
integer | getCellSpacing ()
TTableGridLines | getGridLines ()
THorizontalAlign | getHorizontalAlign ()
void | mergeWith ( TStyle $style) Merges the style with a new one.
void | reset () Sets the style attributes to default values.
void | setBackImageUrl ( string $value) Sets the URL of the background image for the table
void | setBorderCollapse ( boolean $value)
void | setCellPadding ( integer $value)
void | setCellSpacing ( integer $value)
void | setGridLines ( TTableGridLines $value) Sets the grid line style of the table.
void | setHorizontalAlign ( THorizontalAlign $value) Sets the horizontal alignment of the contents within the table.
Methods Inherited From TStyle
TStyle::addAttributesToRender(), TStyle::clearStyleField(), TStyle::copyFrom(), TStyle::getBackColor(), TStyle::getBorderColor(), TStyle::getBorderStyle(), TStyle::getBorderWidth(), TStyle::getCssClass(), TStyle::getCustomStyle(), TStyle::getDisplayStyle(), TStyle::getFont(), TStyle::getForeColor(), TStyle::getHeight(), TStyle::getStyleField(), TStyle::getStyleFields(), TStyle::getWidth(), TStyle::hasCssClass(), TStyle::hasFont(), TStyle::hasStyleField(), TStyle::mergeWith(), TStyle::reset(), TStyle::setBackColor(), TStyle::setBorderColor(), TStyle::setBorderStyle(), TStyle::setBorderWidth(), TStyle::setCssClass(), TStyle::setCustomStyle(), TStyle::setDisplayStyle(), TStyle::setForeColor(), TStyle::setHeight(), TStyle::setStyleField(), TStyle::setWidth(), TStyle::__clone()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

addAttributesToRender

public void addAttributesToRender (THtmlWriter $writer )

Adds attributes related to CSS styles to renderer.

This method overrides the parent implementation.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

copyFrom

public void copyFrom (TStyle $style )

Copies the fields in a new style to this style.

If a style field is set in the new style, the corresponding field in this style will be overwritten.

Input
TStyle $style the new style
Output
Exception

getBackImageUrl

public string getBackImageUrl ()

Output
string the URL of the background image for the table
Exception

getBorderCollapse

public boolean getBorderCollapse ()

Output
boolean whether the table borders should be collapsed. Defaults to false.
Exception

getCellPadding

public integer getCellPadding ()

Output
integer cellpadding of the table. Defaults to -1, meaning not set.
Exception

getCellSpacing

public integer getCellSpacing ()

Output
integer cellspacing of the table. Defaults to -1, meaning not set.
Exception

getGridLines

public TTableGridLines getGridLines ()

Output
TTableGridLines the grid line setting of the table. Defaults to TTableGridLines::None.
Exception

getHorizontalAlign

public THorizontalAlign getHorizontalAlign ()

Output
THorizontalAlign the horizontal alignment of the contents within the table, defaults to THorizontalAlign::NotSet.
Exception

mergeWith

public void mergeWith (TStyle $style )

Merges the style with a new one.

If a style field is not set in this style, it will be overwritten by the new one.

Input
TStyle $style the new style
Output
Exception

reset

public void reset ()

Sets the style attributes to default values.

This method overrides the parent implementation by resetting additional TTableStyle specific attributes.

Output
Exception

setBackImageUrl

public void setBackImageUrl (string $value )

Sets the URL of the background image for the table

Input
string $value the URL
Output
Exception

setBorderCollapse

public void setBorderCollapse (boolean $value )

Input
boolean $value whether the table borders should be collapsed.
Output
Exception

setCellPadding

public void setCellPadding (integer $value )

Input
integer | $value | cellpadding of the table. A value equal to -1 clears up the setting.
Output
Exception
throws | TInvalidDataValueException if the value is less than -1.

setCellSpacing

public void setCellSpacing (integer $value )

Input
integer | $value | cellspacing of the table. A value equal to -1 clears up the setting.
Output
Exception
throws | TInvalidDataValueException if the value is less than -1.

setGridLines

public void setGridLines (TTableGridLines $value )

Sets the grid line style of the table.

Input
TTableGridLines $value the grid line setting of the table
Output
Exception

setHorizontalAlign

public void setHorizontalAlign (THorizontalAlign $value )

Sets the horizontal alignment of the contents within the table.

Input
THorizontalAlign $value the horizontal alignment
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TVerticalAlign

Class TVerticalAlign (Class Overview)

TEnumerable
   |
   --TVerticalAlign

TVerticalAlign class.

TVerticalAlign defines the enumerable type for the possible vertical alignments in a CSS style.

The following enumerable values are defined:

  • NotSet: the alignment is not specified.
  • Top: top aligned
  • Bottom: bottom aligned
  • Middle: middle aligned

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Bottom
string | Middle
string | NotSet
string | Top
Constant Details

Bottom

Type:

string

Value:

'Bottom'

Middle

Type:

string

Value:

'Middle'

NotSet

Type:

string

Value:

'NotSet'

Top

Type:

string

Value:

'Top'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TStyleSheet

Class TStyleSheet (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TStyleSheet

TStyleSheet class.

TStyleSheet represents the link to a stylesheet file and/or a piece of stylesheet code. To specify the link to a CSS file, set StyleSheetUrl. The child rendering result of TStyleSheet is treated as CSS code and is rendered within an appropriate style HTML element. Therefore, if the child content is not empty, you should place the TStyleSheet control in the head section of your page to conform to the HTML standard. If only CSS file URL is specified, you may place the control anywhere on your page and the style element will be rendered in the right position.

Since: 3.0.2
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getMediaType ()
string | getStyleSheetUrl ()
void | onPreRender ( mixed $param) Registers the stylesheet file and content to be rendered.
void | render ( ITextWriter $writer) Renders the control.
void | setMediaType ( string $value)
void | setStyleSheetUrl ( string $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getMediaType

public string getMediaType ()

Output
string media type of the CSS (such as 'print', 'screen', etc.). Defaults to empty, meaning the CSS applies to all media types.
Exception

getStyleSheetUrl

public string getStyleSheetUrl ()

Output
string URL to the stylesheet file
Exception

onPreRender

public void onPreRender (mixed $param )

Registers the stylesheet file and content to be rendered.

This method overrides the parent implementation and is invoked right before rendering.

Input
mixed $param event parameter
Output
Exception

render

public void render (ITextWriter $writer )

Renders the control.

This method overrides the parent implementation and renders nothing.

Input
ITextWriter $writer writer
Output
Exception

setMediaType

public void setMediaType (string $value )

Input
string $value media type of the CSS (such as 'print', 'screen', etc.). If empty, it means the CSS applies to all media types.
Output
Exception

setStyleSheetUrl

public void setStyleSheetUrl (string $value )

Input
string $value URL to the stylesheet file
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTable

Class TTable (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTable

TTable class

TTable displays an HTML table on a Web page.

A table may have Caption, whose alignment is specified via CaptionAlign. The table cellpadding and cellspacing are specified via CellPadding and CellSpacing properties, respectively. The GridLines specifies how the table should display its borders. The horizontal alignment of the table content can be specified via HorizontalAlign, and BackImageUrl can assign a background image to the table.

A TTable maintains a list of TTableRow controls in its Rows property. Each TTableRow represents an HTML table row.

To populate the table Rows, you may either use control template or dynamically create TTableRow in code. In template, do as follows to create the table rows and cells,

1        <com:TTable>
2          <com:TTableRow>
3            <com:TTableCell Text="content" />
4            <com:TTableCell Text="content" />
5          </com:TTableRow>
6          <com:TTableRow>
7            <com:TTableCell Text="content" />
8            <com:TTableCell Text="content" />
9          </com:TTableRow>
10       </com:TTable>
The above can also be accomplished in code as follows,

1        $table=new TTable;
2        $row=new TTableRow;
3        $cell=new TTableCell; $cell->Text="content"; $row->Cells->add($cell);
4        $cell=new TTableCell; $cell->Text="content"; $row->Cells->add($cell);
5        $table->Rows->add($row);
6        $row=new TTableRow;
7        $cell=new TTableCell; $cell->Text="content"; $row->Cells->add($cell);
8        $cell=new TTableCell; $cell->Text="content"; $row->Cells->add($cell);
9        $table->Rows->add($row);

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attributes to renderer.
void | addParsedObject ( mixed $object) Adds object parsed from template to the control.
protected TTableRowCollection | createControlCollection () Creates a control collection object that is to be used to hold child controls
protected TTableStyle | createStyle () Creates a style object for the control.
string | getBackImageUrl ()
string | getCaption ()
TTableCaptionAlign | getCaptionAlign ()
integer | getCellPadding ()
integer | getCellSpacing ()
TTableGridLines | getGridLines ()
THorizontalAlign | getHorizontalAlign ()
TTableRowCollection | getRows ()
protected string | getTagName ()
void | renderBeginTag ( THtmlWriter $writer) Renders the openning tag for the table control which will render table caption if present.
void | renderContents ( THtmlWriter $writer) Renders body contents of the table.
void | setBackImageUrl ( string $value) Sets the URL of the background image for the table
void | setCaption ( string $value)
void | setCaptionAlign ( TTableCaptionAlign $value)
void | setCellPadding ( integer $value)
void | setCellSpacing ( integer $value)
void | setGridLines ( TTableGridLines $value)
void | setHorizontalAlign ( THorizontalAlign $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attributes to renderer.

Input
THtmlWriter $writer the renderer
Output
Exception

addParsedObject

public void addParsedObject (mixed $object )

Adds object parsed from template to the control.

This method adds only TTableRow objects into the Rows collection. All other objects are ignored.

Input
mixed $object object parsed from template
Output
Exception

createControlCollection

protected TTableRowCollection createControlCollection ()

Creates a control collection object that is to be used to hold child controls

Output
TTableRowCollection control collection
Exception

createStyle

protected TTableStyle createStyle ()

Creates a style object for the control.

This method creates a TTableStyle to be used by the table.

Output
TTableStyle control style to be used
Exception

getBackImageUrl

public string getBackImageUrl ()

Output
string the URL of the background image for the table
Exception

getCaption

public string getCaption ()

Output
string table caption
Exception

getCaptionAlign

public TTableCaptionAlign getCaptionAlign ()

Output
TTableCaptionAlign table caption alignment. Defaults to TTableCaptionAlign::NotSet.
Exception

getCellPadding

public integer getCellPadding ()

Output
integer the cellpadding for the table. Defaults to -1, meaning not set.
Exception

getCellSpacing

public integer getCellSpacing ()

Output
integer the cellspacing for the table. Defaults to -1, meaning not set.
Exception

getGridLines

public TTableGridLines getGridLines ()

Output
TTableGridLines the grid line setting of the table. Defaults to TTableGridLines::None.
Exception

getHorizontalAlign

public THorizontalAlign getHorizontalAlign ()

Output
THorizontalAlign the horizontal alignment of the table content. Defaults to THorizontalAlign::NotSet.
Exception

getRows

public TTableRowCollection getRows ()

Output
TTableRowCollection list of TTableRow controls
Exception

getTagName

protected string getTagName ()

Output
string tag name for the table
Exception

renderBeginTag

public void renderBeginTag (THtmlWriter $writer )

Renders the openning tag for the table control which will render table caption if present.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders body contents of the table.

Input
THtmlWriter $writer the writer used for the rendering purpose.
Output
Exception

setBackImageUrl

public void setBackImageUrl (string $value )

Sets the URL of the background image for the table

Input
string $value the URL
Output
Exception

setCaption

public void setCaption (string $value )

Input
string $value table caption
Output
Exception

setCaptionAlign

public void setCaptionAlign (TTableCaptionAlign $value )

Input
TTableCaptionAlign $value table caption alignment.
Output
Exception

setCellPadding

public void setCellPadding (integer $value )

Input
integer $value the cellpadding for the table. Defaults to -1, meaning not set.
Output
Exception

setCellSpacing

public void setCellSpacing (integer $value )

Input
integer $value the cellspacing for the table. Defaults to -1, meaning not set.
Output
Exception

setGridLines

public void setGridLines (TTableGridLines $value )

Input
TTableGridLines $value the grid line setting of the table
Output
Exception

setHorizontalAlign

public void setHorizontalAlign (THorizontalAlign $value )

Input
THorizontalAlign $value the horizontal alignment of the table content.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTableCaptionAlign

Class TTableCaptionAlign (Class Overview)

TEnumerable
   |
   --TTableCaptionAlign

TTableCaptionAlign class.

TTableCaptionAlign defines the enumerable type for the possible alignments that a table caption can take.

The following enumerable values are defined:

  • NotSet: alignment not specified
  • Top: top aligned
  • Bottom: bottom aligned
  • Left: left aligned
  • Right: right aligned

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Bottom
string | Left
string | NotSet
string | Right
string | Top
Constant Details

Bottom

Type:

string

Value:

'Bottom'

Left

Type:

string

Value:

'Left'

NotSet

Type:

string

Value:

'NotSet'

Right

Type:

string

Value:

'Right'

Top

Type:

string

Value:

'Top'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTableRowCollection

Class TTableRowCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TControlCollection
         |
         --TTableRowCollection

TTableRowCollection class.

TTableRowCollection is used to maintain a list of rows belong to a table.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void
insertAt ( integer $index, mixed $item)
Inserts an item at the specified position.
Methods Inherited From TControlCollection
TControlCollection::clear(), TControlCollection::getOwner(), TControlCollection::insertAt(), TControlCollection::removeAt()
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by performing additional operations for each newly added table row.

Input
integer | $index | the speicified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is not a TTableRow object.


PRADO API Manual: Docs For Class TTableCell

Class TTableCell (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableCell

Direct Known Sub-classes:

TTableHeaderCell

TTableCell class.

TTableCell displays a table cell on a Web page. Content of the table cell is specified by the Text property. If Text is empty, the body contents enclosed by the table cell component tag are rendered. Note, Text is not HTML-encoded when displayed. So make sure it does not contain dangerous characters.

The horizontal and vertical alignments of the contents in the cell are specified via HorizontalAlign and VerticalAlign properties, respectively.

The colspan and rowspan of the cell are specified via ColumnSpan and RowSpan properties. And the Wrap property indicates whether the contents in the cell should be wrapped.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attributes to renderer.
protected TStyle | createStyle () Creates a style object for the control.
integer | getColumnSpan ()
string | getData () Returns the text content of the table cell.
string | getHorizontalAlign ()
integer | getRowSpan ()
protected string | getTagName ()
string | getText ()
string | getVerticalAlign ()
boolean | getWrap ()
void | renderContents ( THtmlWriter $writer) Renders body contents of the table cell.
void | setColumnSpan ( integer $value) Sets the columnspan for the table cell.
void | setData ( string $value) Sets the text content of the table cell.
void | setHorizontalAlign ( string $value) Sets the horizontal alignment of the contents within the table item.
void | setRowSpan ( integer $value) Sets the rowspan for the table cell.
void | setText ( string $value) Sets the text content of the table cell.
void | setVerticalAlign ( string $value) Sets the vertical alignment of the contents within the table item.
void | setWrap ( boolean $value) Sets the value indicating whether the text content wraps within a table cell.
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attributes to renderer.

Input
THtmlWriter $writer the renderer
Output
Exception

createStyle

protected TStyle createStyle ()

Creates a style object for the control.

This method creates a TTableItemStyle to be used by the table cell.

Output
TStyle control style to be used
Exception

getColumnSpan

public integer getColumnSpan ()

Output
integer the columnspan for the table cell, 0 if not set.
Exception

getData

public string getData ()

Returns the text content of the table cell.

This method is required by IDataRenderer. It is the same as getText().

Output
string the text content of the table cell.
Exception

getHorizontalAlign

public string getHorizontalAlign ()

Output
string the horizontal alignment of the contents within the table item, defaults to 'NotSet'.
Exception

getRowSpan

public integer getRowSpan ()

Output
integer the rowspan for the table cell, 0 if not set.
Exception

getTagName

protected string getTagName ()

Output
string tag name for the table cell
Exception

getText

public string getText ()

Output
string the text content of the table cell.
Exception

getVerticalAlign

public string getVerticalAlign ()

Output
string the vertical alignment of the contents within the table item, defaults to 'NotSet'.
Exception

getWrap

public boolean getWrap ()

Output
boolean whether the text content wraps within a table cell. Defaults to true.
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders body contents of the table cell.

Input
THtmlWriter $writer the writer used for the rendering purpose.
Output
Exception

setColumnSpan

public void setColumnSpan (integer $value )

Sets the columnspan for the table cell.

Input
integer $value the columnspan for the table cell, 0 if not set.
Output
Exception

setData

public void setData (string $value )

Sets the text content of the table cell.

This method is required by IDataRenderer. It is the same as setText().

Input
string $value the text content of the table cell.
Output
Exception

setHorizontalAlign

public void setHorizontalAlign (string $value )

Sets the horizontal alignment of the contents within the table item.

Valid values include 'NotSet', 'Justify', 'Left', 'Right', 'Center'

Input
string $value the horizontal alignment
Output
Exception

setRowSpan

public void setRowSpan (integer $value )

Sets the rowspan for the table cell.

Input
integer $value the rowspan for the table cell, 0 if not set.
Output
Exception

setText

public void setText (string $value )

Sets the text content of the table cell.

If the text content is empty, body content (child controls) of the cell will be rendered.

Input
string $value the text content
Output
Exception

setVerticalAlign

public void setVerticalAlign (string $value )

Sets the vertical alignment of the contents within the table item.

Valid values include 'NotSet','Top','Bottom','Middle'

Input
string $value the horizontal alignment
Output
Exception

setWrap

public void setWrap (boolean $value )

Sets the value indicating whether the text content wraps within a table cell.

Input
boolean $value whether the text content wraps within a table cell.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTableFooterRow

Class TTableFooterRow (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableRow
               |
               --TTableFooterRow

TTableFooterRow class.

TTableFooterRow displays a table footer row.

Since: 3.0.1
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getTableSection ()
void | setTableSection ( string $value)
Methods Inherited From TTableRow
TTableRow::addParsedObject(), TTableRow::createControlCollection(), TTableRow::createStyle(), TTableRow::getCells(), TTableRow::getHorizontalAlign(), TTableRow::getTableSection(), TTableRow::getTagName(), TTableRow::getVerticalAlign(), TTableRow::renderContents(), TTableRow::setHorizontalAlign(), TTableRow::setTableSection(), TTableRow::setVerticalAlign()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getTableSection

public string getTableSection ()

Output
string location of a row in a table. Always returns 'Footer'.
Exception

setTableSection

public void setTableSection (string $value )

Input
string | $value | location of a row in a table.
Output
Exception
throws | TInvalidOperationException if this method is invoked


PRADO API Manual: Docs For Class TTableHeaderCell

Class TTableHeaderCell (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableCell
               |
               --TTableHeaderCell

TTableHeaderCell class.

TTableHeaderCell displays a table header cell on a Web page.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attributes to renderer.
string | getAbbreviatedText ()
string | getCategoryText ()
TTableHeaderScope | getScope ()
protected string | getTagName ()
void | setAbbreviatedText ( string $value)
void | setCategoryText ( string $value)
void | setScope ( TTableHeaderScope $value)
Methods Inherited From TTableCell
TTableCell::addAttributesToRender(), TTableCell::createStyle(), TTableCell::getColumnSpan(), TTableCell::getData(), TTableCell::getHorizontalAlign(), TTableCell::getRowSpan(), TTableCell::getTagName(), TTableCell::getText(), TTableCell::getVerticalAlign(), TTableCell::getWrap(), TTableCell::renderContents(), TTableCell::setColumnSpan(), TTableCell::setData(), TTableCell::setHorizontalAlign(), TTableCell::setRowSpan(), TTableCell::setText(), TTableCell::setVerticalAlign(), TTableCell::setWrap()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attributes to renderer.

Input
THtmlWriter $writer the renderer
Output
Exception

getAbbreviatedText

public string getAbbreviatedText ()

Output
string the abbr attribute of the HTML th element
Exception

getCategoryText

public string getCategoryText ()

Output
string the axis attribute of the HTML th element
Exception

getScope

public TTableHeaderScope getScope ()

Output
TTableHeaderScope the scope of the cells that the header cell applies to. Defaults to TTableHeaderScope::NotSet.
Exception

getTagName

protected string getTagName ()

Output
string tag name for the table header cell
Exception

setAbbreviatedText

public void setAbbreviatedText (string $value )

Input
string $value the abbr attribute of the HTML th element
Output
Exception

setCategoryText

public void setCategoryText (string $value )

Input
string $value the axis attribute of the HTML th element
Output
Exception

setScope

public void setScope (TTableHeaderScope $value )

Input
TTableHeaderScope $value the scope of the cells that the header cell applies to.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTableHeaderScope

Class TTableHeaderScope (Class Overview)

TEnumerable
   |
   --TTableHeaderScope

TTableHeaderScope class.

TTableHeaderScope defines the enumerable type for the possible table scopes that a table header is associated with.

The following enumerable values are defined:

  • NotSet: the scope is not specified
  • Row: the scope is row-wise
  • Column: the scope is column-wise

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Column
string | NotSet
string | Row
Constant Details

Column

Type:

string

Value:

'Column'

NotSet

Type:

string

Value:

'NotSet'

Row

Type:

string

Value:

'Row'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTableHeaderRow

Class TTableHeaderRow (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableRow
               |
               --TTableHeaderRow

TTableHeaderRow class.

TTableHeaderRow displays a table header row.

Since: 3.0.1
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getTableSection ()
void | setTableSection ( string $value)
Methods Inherited From TTableRow
TTableRow::addParsedObject(), TTableRow::createControlCollection(), TTableRow::createStyle(), TTableRow::getCells(), TTableRow::getHorizontalAlign(), TTableRow::getTableSection(), TTableRow::getTagName(), TTableRow::getVerticalAlign(), TTableRow::renderContents(), TTableRow::setHorizontalAlign(), TTableRow::setTableSection(), TTableRow::setVerticalAlign()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getTableSection

public string getTableSection ()

Output
string location of a row in a table. Always returns 'Header'.
Exception

setTableSection

public void setTableSection (string $value )

Input
string | $value | location of a row in a table.
Output
Exception
throws | TInvalidOperationException if this method is invoked


PRADO API Manual: Docs For Class TTableCellCollection

Class TTableCellCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TControlCollection
         |
         --TTableCellCollection

TTableCellCollection class.

TTableCellCollection is used to maintain a list of cells belong to a table row.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void
insertAt ( integer $index, mixed $item)
Inserts an item at the specified position.
Methods Inherited From TControlCollection
TControlCollection::clear(), TControlCollection::getOwner(), TControlCollection::insertAt(), TControlCollection::removeAt()
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by performing additional operations for each newly added table cell.

Input
integer | $index | the speicified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is not a TTableCell object.


PRADO API Manual: Docs For Class TTableRow

Class TTableRow (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTableRow

Direct Known Sub-classes:

TDataGridItem , TTableFooterRow , TTableHeaderRow

TTableRow class.

TTableRow displays a table row. The table cells in the row can be accessed via Cells. The horizontal and vertical alignments of the row are specified via HorizontalAlign and VerticalAlign properties, respectively.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | addParsedObject ( mixed $object) Adds object parsed from template to the control.
protected TTableCellCollection | createControlCollection () Creates a control collection object that is to be used to hold child controls
protected TStyle | createStyle () Creates a style object for the control.
TTableCellCollection | getCells ()
string | getHorizontalAlign ()
TTableRowSection | getTableSection ()
protected string | getTagName ()
string | getVerticalAlign ()
void | renderContents ( THtmlWriter $writer) Renders body contents of the table row
void | setHorizontalAlign ( string $value) Sets the horizontal alignment of the contents within the table item.
void | setTableSection ( TTableRowSection $value)
void | setVerticalAlign ( string $value) Sets the vertical alignment of the contents within the table item.
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addParsedObject

public void addParsedObject (mixed $object )

Adds object parsed from template to the control.

This method adds only TTableCell objects into the Cells collection. All other objects are ignored.

Input
mixed $object object parsed from template
Output
Exception

createControlCollection

protected TTableCellCollection createControlCollection ()

Creates a control collection object that is to be used to hold child controls

Output
TTableCellCollection control collection
Exception

createStyle

protected TStyle createStyle ()

Creates a style object for the control.

This method creates a TTableItemStyle to be used by the table row.

Output
TStyle control style to be used
Exception

getCells

public TTableCellCollection getCells ()

Output
TTableCellCollection list of TTableCell controls
Exception

getHorizontalAlign

public string getHorizontalAlign ()

Output
string the horizontal alignment of the contents within the table item, defaults to 'NotSet'.
Exception

getTableSection

public TTableRowSection getTableSection ()

Output
TTableRowSection location of a row in a table. Defaults to TTableRowSection::Body.
Exception

getTagName

protected string getTagName ()

Output
string tag name for the table
Exception

getVerticalAlign

public string getVerticalAlign ()

Output
string the vertical alignment of the contents within the table item, defaults to 'NotSet'.
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders body contents of the table row

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

setHorizontalAlign

public void setHorizontalAlign (string $value )

Sets the horizontal alignment of the contents within the table item.

Valid values include 'NotSet', 'Justify', 'Left', 'Right', 'Center'

Input
string $value the horizontal alignment
Output
Exception

setTableSection

public void setTableSection (TTableRowSection $value )

Input
TTableRowSection $value location of a row in a table.
Output
Exception

setVerticalAlign

public void setVerticalAlign (string $value )

Sets the vertical alignment of the contents within the table item.

Valid values include 'NotSet','Top','Bottom','Middle'

Input
string $value the horizontal alignment
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTableRowSection

Class TTableRowSection (Class Overview)

TEnumerable
   |
   --TTableRowSection

TTableRowSection class.

TTableRowSection defines the enumerable type for the possible table sections that a TTableRow can be within.

The following enumerable values are defined:

  • Header: in table header
  • Body: in table body
  • Footer: in table footer

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Body
string | Footer
string | Header
Constant Details

Body

Type:

string

Value:

'Body'

Footer

Type:

string

Value:

'Footer'

Header

Type:

string

Value:

'Header'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTabPanel

Class TTabPanel (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTabPanel

Class TTabPanel.

TTabPanel displays a tabbed panel. Users can click on the tab bar to switching among different tab views. Each tab view is an independent panel that can contain arbitrary content.

A TTabPanel control consists of one or several TTabView controls representing the possible tab views. At any time, only one tab view is visible (active), which is specified by any of the following properties:

  • ActiveViewIndex - the zero-based integer index of the view in the view collection.
  • ActiveViewID - the text ID of the visible view.
  • ActiveView - the visible view instance.
If both ActiveViewIndex and ActiveViewID are set, the latter takes precedence.

TTabPanel uses CSS to specify the appearance of the tab bar and panel. By default, an embedded CSS file will be published which contains the default CSS for TTabPanel. You may also use your own CSS file by specifying the CssUrl property. The following properties specify the CSS classes used for elements in a TTabPanel:

  • CssClass - the CSS class name for the outer-most div element (defaults to 'tab-panel');
  • TabCssClass - the CSS class name for nonactive tab div elements (defaults to 'tab-normal');
  • ActiveTabCssClass - the CSS class name for the active tab div element (defaults to 'tab-active');
  • ViewCssClass - the CSS class for the div element enclosing view content (defaults to 'tab-view');
To use TTabPanel, write a template like following:

1      <com:TTabPanel>
2        <com:TTabView Caption="View 1">
3          content for view 1
4        </com:TTabView>
5        <com:TTabView Caption="View 2">
6          content for view 2
7        </com:TTabView>
8        <com:TTabView Caption="View 3">
9          content for view 3
10       </com:TTabView>
11     </com:TTabPanel>

Since: 3.1.1
Author: Tomasz Wolny <tomasz.wolny@polecam.to.pl> and Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | activateView ( TTabView $view) Activates the specified view.
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attributes to renderer.
void | addParsedObject ( mixed $object) Adds object parsed from template to the control.
protected TTabViewCollection | createControlCollection () Creates a control collection object that is to be used to hold child controls
string | getActiveTabCssClass ()
TStyle | getActiveTabStyle ()
TTabView | getActiveView () Returns the currently active view.
string | getActiveViewID () Returns the ID of the active tab view.
integer | getActiveViewIndex () Returns the index of the active tab view.
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
protected array | getClientOptions ()
string | getCssClass ()
string | getCssUrl ()
boolean | getDataChanged () Returns a value indicating whether postback has caused the control data change.
string | getTabCssClass ()
TStyle | getTabStyle ()
protected string | getTagName ()
string | getViewCssClass ()
TTabViewCollection | getViews ()
TStyle | getViewStyle ()
boolean | loadPostData ( string $key, array $values) Loads user input data.
void | onPreRender ( mixed $param) Registers CSS and JS.
void | raisePostDataChangedEvent () Raises postdata changed event.
protected void | registerClientScript () Registers the relevant JavaScript.
protected void | registerStyleSheet () Registers the CSS relevant to the TTabControl.
void | renderContents ( THtmlWriter $writer) Renders body contents of the tab control.
void | setActiveTabCssClass ( string $value)
void | setActiveView ( TTabView $view)
void | setActiveViewID ( string $value)
void | setActiveViewIndex ( integer $value)
void | setCssUrl ( string $value)
void | setTabCssClass ( string $value)
void | setViewCssClass ( string $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

activateView

protected void activateView (TTabView $view )

Activates the specified view.

If there is any other view currently active, it will be deactivated.

Input
TTabView $view the view to be activated. If null, all views will be deactivated.
Output
Exception

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attributes to renderer.

Input
THtmlWriter $writer the renderer
Output
Exception

addParsedObject

public void addParsedObject (mixed $object )

Adds object parsed from template to the control.

This method adds only TTabView objects into the Views collection. All other objects are ignored.

Input
mixed $object object parsed from template
Output
Exception

createControlCollection

protected TTabViewCollection createControlCollection ()

Creates a control collection object that is to be used to hold child controls

Output
TTabViewCollection control collection
Exception

getActiveTabCssClass

public string getActiveTabCssClass ()

Output
string CSS class for the active tab. Defaults to 'tab-active'.
Exception

getActiveTabStyle

public TStyle getActiveTabStyle ()

Output
TStyle the style for the active tab div
Exception

getActiveView

public TTabView getActiveView ()

Returns the currently active view.

This method will examin the ActiveViewID, ActiveViewIndex and Views collection to determine which view is currently active. It will update ActiveViewID and ActiveViewIndex accordingly.

Output
TTabView | the currently active view, null if no active view
Exception
throws | TInvalidDataValueException if the active view ID or index set previously is invalid

getActiveViewID

public string getActiveViewID ()

Returns the ID of the active tab view.

Note, this property may not return the correct ID. To ensure the correctness, call getActiveView() first.

Output
string The ID of the active tab view. Defaults to '', meaning not set.
Exception

getActiveViewIndex

public integer getActiveViewIndex ()

Returns the index of the active tab view.

Note, this property may not return the correct index. To ensure the correctness, call getActiveView() first.

Output
integer the zero-based index of the active tab view. If -1, it means no active tab view. Default is 0 (the first view is active).
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getClientOptions

protected array getClientOptions ()

Output
array the options for JavaScript
Exception

getCssClass

public string getCssClass ()

Output
string CSS class for the whole tab control div. Defaults to 'tab-panel'.
Exception

getCssUrl

public string getCssUrl ()

Output
string URL for the CSS file including all relevant CSS class definitions. Defaults to ''.
Exception

getDataChanged

public boolean getDataChanged ()

Returns a value indicating whether postback has caused the control data change.

This method is required by the IPostBackDataHandler interface.

Output
boolean whether postback has caused the control data change. False if the page is not in postback mode.
Exception

getTabCssClass

public string getTabCssClass ()

Output
string CSS class for non-active tabs. Defaults to 'tab-normal'.
Exception

getTabStyle

public TStyle getTabStyle ()

Output
TStyle the style for all the inactive tab div
Exception

getTagName

protected string getTagName ()

Output
string tag name for the control
Exception

getViewCssClass

public string getViewCssClass ()

Output
string CSS class for the currently displayed view div. Defaults to 'tab-view'.
Exception

getViews

public TTabViewCollection getViews ()

Output
TTabViewCollection list of TTabView controls
Exception

getViewStyle

public TStyle getViewStyle ()

Output
TStyle the style for all the view div
Exception

loadPostData

public boolean loadPostData (string $key , array $values )

Loads user input data.

This method is primarly used by framework developers.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the control has been changed
Exception

onPreRender

public void onPreRender (mixed $param )

Registers CSS and JS.

This method is invoked right before the control rendering, if the control is visible.

Input
mixed $param event parameter
Output
Exception

raisePostDataChangedEvent

public void raisePostDataChangedEvent ()

Raises postdata changed event.

This method is required by IPostBackDataHandler interface. It is invoked by the framework when ActiveViewIndex property is changed on postback. This method is primarly used by framework developers.

Output
Exception

registerClientScript

protected void registerClientScript ()

Registers the relevant JavaScript.

Output
Exception

registerStyleSheet

protected void registerStyleSheet ()

Registers the CSS relevant to the TTabControl.

It will register the CSS file specified by CssUrl. If that is not set, it will use the default CSS.

Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders body contents of the tab control.

Input
THtmlWriter $writer the writer used for the rendering purpose.
Output
Exception

setActiveTabCssClass

public void setActiveTabCssClass (string $value )

Input
string $value CSS class for the active tab.
Output
Exception

setActiveView

public void setActiveView (TTabView $view )

Input
TTabView | $view | the view to be activated
Output
Exception
throws | TInvalidOperationException if the view is not in the view collection

setActiveViewID

public void setActiveViewID (string $value )

Input
string $value The ID of the active tab view.
Output
Exception

setActiveViewIndex

public void setActiveViewIndex (integer $value )

Input
integer | $value | the zero-based index of the current view in the view collection. -1 if no active view.
Output
Exception
throws | TInvalidDataValueException if the view index is invalid

setCssUrl

public void setCssUrl (string $value )

Input
string $value URL for the CSS file including all relevant CSS class definitions.
Output
Exception

setTabCssClass

public void setTabCssClass (string $value )

Input
string $value CSS class for non-active tabs.
Output
Exception

setViewCssClass

public void setViewCssClass (string $value )

Input
string $value CSS class for the currently displayed view div.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTabView

Class TTabView (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTabView

TTabView class.

TTabView represents a view in a TTabPanel control.

The content in a TTabView can be specified by the Text property or its child controls. In template syntax, the latter means enclosing the content within the TTabView component element. If both are set, Text takes precedence.

Each TTabView is associated with a tab in the tab bar of the TTabPanel control. The tab caption is specified by Caption. If NavigateUrl is set, the tab will contain a hyperlink pointing to the specified URL. In this case, clicking on the tab will redirect the browser to the specified URL.

TTabView may be toggled between visible (active) and invisible (inactive) by setting the Active property.

Since: 3.1.1
Author: Tomasz Wolny <tomasz.wolny@polecam.to.pl> and Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attributes to renderer.
boolean | getActive ()
string | getCaption ()
string | getNavigateUrl ()
protected the | getTagName ()
string | getText ()
void | renderContents ( THtmlWriter $writer) Renders body contents of the tab view.
void | renderTab ( THtmlWriter $writer) Renders the tab associated with the tab view.
protected void | renderTabContent ( THtmlWriter $writer) Renders the content in the tab.
void | setActive ( boolean $value)
void | setCaption ( string $value)
void | setNavigateUrl ( string $value) Sets the URL of the target page.
void | setText ( string $value) Sets the text content to be displayed on this view.
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attributes to renderer.

Input
THtmlWriter $writer the renderer
Output
Exception

getActive

public boolean getActive ()

Output
boolean whether this tab view is active. Defaults to false.
Exception

getCaption

public string getCaption ()

Output
string the caption displayed on this tab. Defaults to ''.
Exception

getNavigateUrl

public string getNavigateUrl ()

Output
string the URL of the target page. Defaults to ''.
Exception

getTagName

protected the getTagName ()

Output
the tag name for the view element
Exception

getText

public string getText ()

Output
string the text content displayed on this view. Defaults to ''.
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders body contents of the tab view.

Input
THtmlWriter $writer the writer used for the rendering purpose.
Output
Exception

renderTab

public void renderTab (THtmlWriter $writer )

Renders the tab associated with the tab view.

Input
THtmlWriter $writer the writer for rendering purpose.
Output
Exception

renderTabContent

protected void renderTabContent (THtmlWriter $writer )

Renders the content in the tab.

By default, a hyperlink is displayed.

Input
THtmlWriter $writer the HTML writer
Output
Exception

setActive

public void setActive (boolean $value )

Input
boolean $value whether this tab view is active.
Output
Exception

setCaption

public void setCaption (string $value )

Input
string $value the caption displayed on this tab
Output
Exception

setNavigateUrl

public void setNavigateUrl (string $value )

Sets the URL of the target page.

If not empty, clicking on this tab will redirect the browser to the specified URL.

Input
string $value the URL of the target page.
Output
Exception

setText

public void setText (string $value )

Sets the text content to be displayed on this view.

If this is not empty, the child content of the view will be ignored.

Input
string $value the text content displayed on this view
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTabViewCollection

Class TTabViewCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TControlCollection
         |
         --TTabViewCollection

TTabViewCollection class.

TTabViewCollection is used to maintain a list of views belong to a TTabPanel.

Since: 3.1.1
Author: Tomasz Wolny <tomasz.wolny@polecam.to.pl> and Qiang Xue <qiang.xue@gmail.com>
Method Summary
integer | findIndexByID ( string $id) Finds the index of the tab view whose ID is the same as the one being looked for.
void | insertAt ( integer $index, mixed $item) Inserts an item at the specified position.
Methods Inherited From TControlCollection
TControlCollection::clear(), TControlCollection::getOwner(), TControlCollection::insertAt(), TControlCollection::removeAt()
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

findIndexByID

public integer findIndexByID (string $id )

Finds the index of the tab view whose ID is the same as the one being looked for.

Input
string | $id | the explicit ID of the tab view to be looked for
Output
integer | the index of the tab view found, -1 if not found.
Exception

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by performing sanity check on the type of new item.

Input
integer | $index | the speicified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is not a TTabView object.


PRADO API Manual: Docs For Class TTemplateColumn

Class TTemplateColumn (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TDataGridColumn
         |
         --TTemplateColumn

TTemplateColumn class

TTemplateColumn customizes the layout of controls in the column with templates. In particular, you can specify ItemTemplate, EditItemTemplate, HeaderTemplate and FooterTemplate to customize specific type of cells in the column.

Since v3.1.0, TTemplateColumn has introduced two new properties ItemRenderer and EditItemRenderer which can be used to specify the layout of the datagrid cells in browsing and editing mode. A renderer refers to a control class that is to be instantiated as a control. For more details, see TRepeater and TDataList.

When a renderer and a template are both defined for a type of item, the former takes precedence.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | dataBindColumn ( mixed $sender, mixed $param) Databinds a cell in the column.
string | getEditItemRenderer ()
ITemplate | getEditItemTemplate ()
ITemplate | getFooterTemplate ()
ITemplate | getHeaderTemplate ()
string | getItemRenderer ()
ITemplate | getItemTemplate ()
void | initializeCell ( TTableCell $cell, integer $columnIndex, string $itemType) Initializes the specified cell to its initial values.
void | setEditItemRenderer ( string $value) Sets the edit item cell renderer class.
void | setEditItemTemplate ( ITemplate $value)
void | setFooterTemplate ( ITemplate $value)
void | setHeaderTemplate ( ITemplate $value)
void | setItemRenderer ( string $value) Sets the item cell renderer class.
void | setItemTemplate ( ITemplate $value)
Methods Inherited From TDataGridColumn
TDataGridColumn::formatDataValue(), TDataGridColumn::getAllowSorting(), TDataGridColumn::getDataFieldValue(), TDataGridColumn::getEnableCellGrouping(), TDataGridColumn::getFooterRenderer(), TDataGridColumn::getFooterStyle(), TDataGridColumn::getFooterText(), TDataGridColumn::getHeaderImageUrl(), TDataGridColumn::getHeaderRenderer(), TDataGridColumn::getHeaderStyle(), TDataGridColumn::getHeaderText(), TDataGridColumn::getID(), TDataGridColumn::getItemStyle(), TDataGridColumn::getOwner(), TDataGridColumn::getSortExpression(), TDataGridColumn::getViewState(), TDataGridColumn::getVisible(), TDataGridColumn::initialize(), TDataGridColumn::initializeCell(), TDataGridColumn::initializeFooterCell(), TDataGridColumn::initializeHeaderCell(), TDataGridColumn::loadState(), TDataGridColumn::saveState(), TDataGridColumn::setEnableCellGrouping(), TDataGridColumn::setFooterRenderer(), TDataGridColumn::setFooterText(), TDataGridColumn::setHeaderImageUrl(), TDataGridColumn::setHeaderRenderer(), TDataGridColumn::setHeaderText(), TDataGridColumn::setID(), TDataGridColumn::setOwner(), TDataGridColumn::setSortExpression(), TDataGridColumn::setViewState(), TDataGridColumn::setVisible()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

dataBindColumn

public void dataBindColumn (mixed $sender , mixed $param )

Databinds a cell in the column.

This method is invoked when datagrid performs databinding. It populates the content of the cell with the relevant data from data source.

Input
mixed | $sender
mixed | $param
Output
Exception

getEditItemRenderer

public string getEditItemRenderer ()

Output
string the class name for the edit item cell renderer. Defaults to empty, meaning not set.
Exception

getEditItemTemplate

public ITemplate getEditItemTemplate ()

Output
ITemplate the edit item template
Exception

getFooterTemplate

public ITemplate getFooterTemplate ()

Output
ITemplate the footer template
Exception

getHeaderTemplate

public ITemplate getHeaderTemplate ()

Output
ITemplate the header template
Exception

getItemRenderer

public string getItemRenderer ()

Output
string the class name for the item cell renderer. Defaults to empty, meaning not set.
Exception

getItemTemplate

public ITemplate getItemTemplate ()

Output
ITemplate the item template
Exception

initializeCell

public void initializeCell (TTableCell $cell , integer $columnIndex , string $itemType )

Initializes the specified cell to its initial values.

This method overrides the parent implementation. It initializes the cell based on different templates (ItemTemplate, EditItemTemplate, HeaderTemplate, FooterTemplate).

Input
TTableCell | $cell | the cell to be initialized.
integer | $columnIndex | the index to the Columns property that the cell resides in.
string | $itemType | the type of cell (Header,Footer,Item,AlternatingItem,EditItem,SelectedItem)
Output
Exception

setEditItemRenderer

public void setEditItemRenderer (string $value )

Sets the edit item cell renderer class.

If not empty, the class will be used to instantiate as a child control in the item cell that is in edit mode.

If the class implements IDataRenderer, the Data property will be set as the row of the data associated with the datagrid item that this cell resides in.

Input
string $value the renderer class name in namespace format.
Output
Exception

setEditItemTemplate

public void setEditItemTemplate (ITemplate $value )

Input
ITemplate | $value | the edit item template
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setFooterTemplate

public void setFooterTemplate (ITemplate $value )

Input
ITemplate | $value | the footer template
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setHeaderTemplate

public void setHeaderTemplate (ITemplate $value )

Input
ITemplate | $value | the header template.
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.

setItemRenderer

public void setItemRenderer (string $value )

Sets the item cell renderer class.

If not empty, the class will be used to instantiate as a child control in the item cells of the column.

If the class implements IDataRenderer, the Data property will be set as the row of the data associated with the datagrid item that this cell resides in.

Input
string $value the renderer class name in namespace format.
Output
Exception

setItemTemplate

public void setItemTemplate (ITemplate $value )

Input
ITemplate | $value | the item template
Output
Exception
throws | TInvalidDataTypeException if the input is not an ITemplate or not null.


PRADO API Manual: Docs For Class TTextBox

Class TTextBox (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextBox

Direct Known Sub-classes:

TActiveTextBox , TColorPicker , TDatePicker , THtmlArea

TTextBox class

TTextBox displays a text box on the Web page for user input. The text displayed in the TTextBox control is determined by the Text property. You can create a SingleLine, a MultiLine, or a Password text box by setting the TextMode property. If the TTextBox control is a multiline text box, the number of rows it displays is determined by the Rows property, and the Wrap property can be used to determine whether to wrap the text in the component.

To specify the display width of the text box, in characters, set the Columns property. To prevent the text displayed in the component from being modified, set the ReadOnly property to true. If you want to limit the user input to a specified number of characters, set the MaxLength property. To use AutoComplete feature, set the AutoCompleteType property.

If AutoPostBack is set true, updating the text box and then changing the focus out of it will cause postback action. And if CausesValidation is true, validation will also be processed, which can be further restricted within a ValidationGroup.

WARNING: Be careful if you want to display the text collected via TTextBox. Malicious cross-site script may be injected in. You may use SafeText to prevent this problem.

NOTE: If you set Wrap to false or use AutoCompleteType, the generated HTML output for the textbox will not be XHTML-compatible. Currently, no alternatives are available.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute name-value pairs to renderer.
TTextBoxAutoCompleteType | getAutoCompleteType ()
boolean | getAutoPostBack ()
boolean | getAutoTrim ()
boolean | getCausesValidation ()
protected string | getClientClassName () Gets the name of the javascript class responsible for performing postback for this control.
integer | getColumns ()
string | getData () Returns the text content of the TTextBox control.
boolean | getDataChanged () Returns a value indicating whether postback has caused the control data change.
boolean | getEnableClientScript ()
bool | getIsValid () Returns true if this control validated successfully.
integer | getMaxLength ()
boolean | getPersistPassword ()
protected array | getPostBackOptions () Gets the post back options for this textbox.
boolean | getReadOnly ()
integer | getRows ()
string | getSafeText ()
protected mixed | getSafeTextParser ()
protected string | getTagName ()
string | getText ()
TTextBoxMode | getTextMode ()
string | getValidationGroup ()
mixed | getValidationPropertyValue () Returns the value to be validated.
boolean | getWrap ()
boolean | loadPostData ( string $key, array $values) Loads user input data.
void | onTextChanged ( TEventParameter $param) Raises OnTextChanged event.
void | raisePostDataChangedEvent () Raises postdata changed event.
void | renderBeginTag ( THtmlWriter $writer) Renders an additional line-break after the opening tag when it is in MultiLine text mode.
protected void | renderClientControlScript ( mixed $writer) Renders the javascript for textbox.
void | renderContents ( THtmlWriter $writer) Renders the body content of the textbox when it is in MultiLine text mode.
void | setAutoCompleteType ( TTextBoxAutoCompleteType $value)
void | setAutoPostBack ( boolean $value) Sets the value indicating if postback automatically.
void | setAutoTrim ( boolean $value) Sets the value indicating if the input text should be trimmed spaces
void | setCausesValidation ( boolean $value)
void | setColumns ( integer $value) Sets the display width of the text box in characters.
void | setData ( string $value) Sets the text content of the TTextBox control.
void | setEnableClientScript ( boolean $value)
void | setIsValid ( bool $value)
void | setMaxLength ( integer $value) Sets the maximum number of characters allowed in the text box.
void | setPersistPassword ( boolean $value)
void | setReadOnly ( boolean $value)
void | setRows ( integer $value) Sets the number of rows displayed in a multiline text box.
void | setText ( string $value) Sets the text content of the TTextBox control.
void | setTextMode ( TTextBoxMode $value) Sets the behavior mode of the TTextBox component.
void | setValidationGroup ( string $value)
void | setWrap ( boolean $value) Sets the value indicating whether the text content wraps within a multiline text box.
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
int | DEFAULT_COLUMNS | Default number of columns (for MultiLine text box)
int | DEFAULT_ROWS | Default number of rows (for MultiLine text box)
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute name-value pairs to renderer.

This method overrides the parent implementation with additional textbox specific attributes.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

getAutoCompleteType

public TTextBoxAutoCompleteType getAutoCompleteType ()

Output
TTextBoxAutoCompleteType the AutoComplete type of the textbox
Exception

getAutoPostBack

public boolean getAutoPostBack ()

Output
boolean a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. Defaults to false.
Exception

getAutoTrim

public boolean getAutoTrim ()

Output
boolean a value indicating whether the input text should be trimmed spaces. Defaults to false.
Exception

getCausesValidation

public boolean getCausesValidation ()

Output
boolean whether postback event trigger by this text box will cause input validation, default is true.
Exception

getClientClassName

protected string getClientClassName ()

Gets the name of the javascript class responsible for performing postback for this control.

This method overrides the parent implementation.

Output
string the javascript class name
Exception

getColumns

public integer getColumns ()

Output
integer the display width of the text box in characters, default is 0 meaning not set.
Exception

getData

public string getData ()

Returns the text content of the TTextBox control.

This method is required by IDataRenderer. It is the same as getText().

Output
string the text content of the TTextBox control.
Exception

getDataChanged

public boolean getDataChanged ()

Returns a value indicating whether postback has caused the control data change.

This method is required by the IPostBackDataHandler interface.

Output
boolean whether postback has caused the control data change. False if the page is not in postback mode.
Exception

getEnableClientScript

public boolean getEnableClientScript ()

Output
boolean whether to render javascript.
Exception

getIsValid

public bool getIsValid ()

Returns true if this control validated successfully.

Defaults to true.

Output
bool wether this control validated successfully.
Exception

getMaxLength

public integer getMaxLength ()

Output
integer the maximum number of characters allowed in the text box, default is 0 meaning not set.
Exception

getPersistPassword

public boolean getPersistPassword ()

Output
boolean whether password should be displayed in the textbox during postback. Defaults to false. This property only applies when TextMode='Password'.
Exception

getPostBackOptions

protected array getPostBackOptions ()

Gets the post back options for this textbox.

Output
Exception

getReadOnly

public boolean getReadOnly ()

Output
boolean whether the textbox is read only, default is false.
Exception

getRows

public integer getRows ()

Output
integer the number of rows displayed in a multiline text box, default is 4
Exception

getSafeText

public string getSafeText ()

Output
string safe text content with javascript stripped off
Exception

getSafeTextParser

protected mixed getSafeTextParser ()

Output
mixed safe text parser
Exception

getTagName

protected string getTagName ()

Output
string tag name of the textbox
Exception

getText

public string getText ()

Output
string the text content of the TTextBox control.
Exception

getTextMode

public TTextBoxMode getTextMode ()

Output
TTextBoxMode the behavior mode of the TTextBox component. Defaults to TTextBoxMode::SingleLine.
Exception

getValidationGroup

public string getValidationGroup ()

Output
string the group of validators which the text box causes validation upon postback
Exception

getValidationPropertyValue

public mixed getValidationPropertyValue ()

Returns the value to be validated.

This methid is required by IValidatable interface.

Output
mixed the value of the property to be validated.
Exception

getWrap

public boolean getWrap ()

Output
boolean whether the text content wraps within a multiline text box. Defaults to true.
Exception

loadPostData

public boolean loadPostData (string $key , array $values )

Loads user input data.

This method is primarly used by framework developers.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the component has been changed
Exception

onTextChanged

public void onTextChanged (TEventParameter $param )

Raises OnTextChanged event.

This method is invoked when the value of the Text property changes on postback. If you override this method, be sure to call the parent implementation to ensure the invocation of the attached event handlers.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

raisePostDataChangedEvent

public void raisePostDataChangedEvent ()

Raises postdata changed event.

This method is required by IPostBackDataHandler interface. It is invoked by the framework when Text property is changed on postback. This method is primarly used by framework developers.

Output
Exception

renderBeginTag

public void renderBeginTag (THtmlWriter $writer )

Renders an additional line-break after the opening tag when it is in MultiLine text mode.

Input
THtmlWriter $writer the writer used for the rendering purpose^M
Output
Exception

renderClientControlScript

protected void renderClientControlScript (mixed $writer )

Renders the javascript for textbox.

Input
mixed $writer
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders the body content of the textbox when it is in MultiLine text mode.

Input
THtmlWriter $writer the writer for rendering
Output
Exception

setAutoCompleteType

public void setAutoCompleteType (TTextBoxAutoCompleteType $value )

Input
TTextBoxAutoCompleteType | $value | the AutoComplete type of the textbox, default value is TTextBoxAutoCompleteType::None.
Output
Exception
throws | TInvalidDataValueException if the input parameter is not a valid AutoComplete type

setAutoPostBack

public void setAutoPostBack (boolean $value )

Sets the value indicating if postback automatically.

An automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component.

Input
boolean $value the value indicating if postback automatically
Output
Exception

setAutoTrim

public void setAutoTrim (boolean $value )

Sets the value indicating if the input text should be trimmed spaces

Input
boolean $value the value indicating if the input text should be trimmed spaces
Output
Exception

setCausesValidation

public void setCausesValidation (boolean $value )

Input
boolean $value whether postback event trigger by this text box will cause input validation.
Output
Exception

setColumns

public void setColumns (integer $value )

Sets the display width of the text box in characters.

Input
integer $value the display width, set it 0 to clear the setting
Output
Exception

setData

public void setData (string $value )

Sets the text content of the TTextBox control.

This method is required by IDataRenderer. It is the same as setText().

Input
string $value the text content of the TTextBox control.
Output
Exception

setEnableClientScript

public void setEnableClientScript (boolean $value )

Input
boolean $value whether to render javascript.
Output
Exception

setIsValid

public void setIsValid (bool $value )

Input
bool $value wether this control is valid.
Output
Exception

setMaxLength

public void setMaxLength (integer $value )

Sets the maximum number of characters allowed in the text box.

Input
integer $value the maximum length, set it 0 to clear the setting
Output
Exception

setPersistPassword

public void setPersistPassword (boolean $value )

Input
boolean $value whether password should be displayed in the textbox during postback. This property only applies when TextMode='Password'.
Output
Exception

setReadOnly

public void setReadOnly (boolean $value )

Input
boolean $value whether the textbox is read only
Output
Exception

setRows

public void setRows (integer $value )

Sets the number of rows displayed in a multiline text box.

Input
integer $value the number of rows
Output
Exception

setText

public void setText (string $value )

Sets the text content of the TTextBox control.

Input
string $value the text content
Output
Exception

setTextMode

public void setTextMode (TTextBoxMode $value )

Sets the behavior mode of the TTextBox component.

Input
TTextBoxMode | $value | the text mode
Output
Exception
throws | TInvalidDataValueException if the input value is not a valid text mode.

setValidationGroup

public void setValidationGroup (string $value )

Input
string $value the group of validators which the text box causes validation upon postback
Output
Exception

setWrap

public void setWrap (boolean $value )

Sets the value indicating whether the text content wraps within a multiline text box.

Input
boolean $value whether the text content wraps within a multiline text box.
Output
Exception

Constant Details

DEFAULT_COLUMNS

Default number of columns (for MultiLine text box)

Type:

int

Value:

20

DEFAULT_ROWS

Default number of rows (for MultiLine text box)

Type:

int

Value:

4


PRADO API Manual: Docs For Class TTextBoxAutoCompleteType

Class TTextBoxAutoCompleteType (Class Overview)

TEnumerable
   |
   --TTextBoxAutoCompleteType

TTextBoxAutoCompleteType class.

TTextBoxAutoCompleteType defines the possible AutoComplete type that is supported by a TTextBox control.

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | BusinessCity
string | BusinessCountryRegion
string | BusinessFax
string | BusinessPhone
string | BusinessState
string | BusinessStreetAddress
string | BusinessUrl
string | BusinessZipCode
string | Cellular
string | Company
string | Department
string | Disabled
string | DisplayName
string | Email
string | FirstName
string | Gender
string | HomeCity
string | HomeCountryRegion
string | HomeFax
string | Homepage
string | HomePhone
string | HomeState
string | HomeStreetAddress
string | HomeZipCode
string | JobTitle
string | LastName
string | MiddleName
string | None
string | Notes
string | Office
string | Pager
string | Search
Constant Details

BusinessCity

Type:

string

Value:

'BusinessCity'

BusinessCountryRegion

Type:

string

Value:

'BusinessCountryRegion'

BusinessFax

Type:

string

Value:

'BusinessFax'

BusinessPhone

Type:

string

Value:

'BusinessPhone'

BusinessState

Type:

string

Value:

'BusinessState'

BusinessStreetAddress

Type:

string

Value:

'BusinessStreetAddress'

BusinessUrl

Type:

string

Value:

'BusinessUrl'

BusinessZipCode

Type:

string

Value:

'BusinessZipCode'

Cellular

Type:

string

Value:

'Cellular'

Company

Type:

string

Value:

'Company'

Department

Type:

string

Value:

'Department'

Disabled

Type:

string

Value:

'Disabled'

DisplayName

Type:

string

Value:

'DisplayName'

Email

Type:

string

Value:

'Email'

FirstName

Type:

string

Value:

'FirstName'

Gender

Type:

string

Value:

'Gender'

HomeCity

Type:

string

Value:

'HomeCity'

HomeCountryRegion

Type:

string

Value:

'HomeCountryRegion'

HomeFax

Type:

string

Value:

'HomeFax'

Homepage

Type:

string

Value:

'Homepage'

HomePhone

Type:

string

Value:

'HomePhone'

HomeState

Type:

string

Value:

'HomeState'

HomeStreetAddress

Type:

string

Value:

'HomeStreetAddress'

HomeZipCode

Type:

string

Value:

'HomeZipCode'

JobTitle

Type:

string

Value:

'JobTitle'

LastName

Type:

string

Value:

'LastName'

MiddleName

Type:

string

Value:

'MiddleName'

None

Type:

string

Value:

'None'

Notes

Type:

string

Value:

'Notes'

Office

Type:

string

Value:

'Office'

Pager

Type:

string

Value:

'Pager'

Search

Type:

string

Value:

'Search'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTextBoxMode

Class TTextBoxMode (Class Overview)

TEnumerable
   |
   --TTextBoxMode

TTextBoxMode class.

TTextBoxMode defines the enumerable type for the possible mode that a TTextBox control could be at.

The following enumerable values are defined:

  • SingleLine: the textbox will be a regular single line input
  • MultiLine: the textbox will be a textarea allowing multiple line input
  • Password: the textbox will hide user input like a password input box

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | MultiLine
string | Password
string | SingleLine
Constant Details

MultiLine

Type:

string

Value:

'MultiLine'

Password

Type:

string

Value:

'Password'

SingleLine

Type:

string

Value:

'SingleLine'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTextHighlighter

Class TTextHighlighter (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextProcessor
               |
               --TTextHighlighter

Direct Known Sub-classes:

TMarkdown

TTextHighlighter class.

TTextHighlighter does syntax highlighting its body content, including static text and rendering results of child controls. You can set Language to specify what kind of syntax the body content is. Currently, TTextHighlighter supports the following languages: ABAP, CPP, CSS, DIFF, DTD, HTML, JAVA, JAVASCRIPT, MYSQL, PERL, PHP, PYTHON, RUBY, SQL, XML and PRADO, where PRADO refers to PRADO template syntax. By setting ShowLineNumbers to true, the highlighted result may be shown with line numbers.

Note, TTextHighlighter requires THead to be placed on the page template because it needs to insert some CSS styles.

Since: 3.0
Author: Wei Zhuo<weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
boolean | getEnableCopyCode ()
protected string | getHeaderTemplate ()
string | getLanguage ()
TTextHighlighterLineNumberStyle | getLineNumberStyle ()
boolean | getShowLineNumbers ()
integer | getTabSize ()
protected string | getTagName ()
void | onPreRender ( THtmlWriter $writer) Registers css style for the highlighted result.
string | processText ( string $text) Processes a text string.
protected void | registerStyleSheet () Registers the stylesheet for presentation.
void | setEnableCopyCode ( boolean $value)
void | setLanguage ( string $value)
void | setLineNumberStyle ( TTextHighlighterLineNumberStyle $value)
void | setShowLineNumbers ( boolean $value)
void | setTabSize ( integer $value)
Methods Inherited From TTextProcessor
TTextProcessor::addParsedObject(), TTextProcessor::getText(), TTextProcessor::renderContents(), TTextProcessor::setText()
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getEnableCopyCode

public boolean getEnableCopyCode ()

Output
boolean true will show "Copy Code" link. Defaults to false.
Exception

getHeaderTemplate

protected string getHeaderTemplate ()

Output
string header template with "Copy code" link.
Exception

getLanguage

public string getLanguage ()

Output
string language whose syntax is to be used for highlighting. Defaults to 'php'.
Exception

getLineNumberStyle

public TTextHighlighterLineNumberStyle getLineNumberStyle ()

Output
TTextHighlighterLineNumberStyle style of row number, Table by default
Exception

getShowLineNumbers

public boolean getShowLineNumbers ()

Output
boolean whether to show line numbers in the highlighted result.
Exception

getTabSize

public integer getTabSize ()

Output
integer tab size. Defaults to 4.
Exception

getTagName

protected string getTagName ()

Output
string tag name of the panel
Exception

onPreRender

public void onPreRender (THtmlWriter $writer )

Registers css style for the highlighted result.

This method overrides parent implementation.

Input
THtmlWriter $writer writer
Output
Exception

processText

public string processText (string $text )

Processes a text string.

This method is required by the parent class.

Input
string | $text | text string to be processed
Output
string | the processed text result
Exception

registerStyleSheet

protected void registerStyleSheet ()

Registers the stylesheet for presentation.

Output
Exception

setEnableCopyCode

public void setEnableCopyCode (boolean $value )

Input
boolean $value true to show the "Copy Code" link.
Output
Exception

setLanguage

public void setLanguage (string $value )

Input
string $value language (case-insensitive) whose syntax is to be used for highlighting. Valid values are those file names (without suffix) that are contained in '3rdParty/TextHighlighter/Text/Highlighter'. Currently, the following languages are supported: ABAP, CPP, CSS, DIFF, DTD, HTML, JAVA, JAVASCRIPT, MYSQL, PERL, PHP, PRADO, PYTHON, RUBY, SQL, XML If a language is not supported, it will be displayed as plain text.
Output
Exception

setLineNumberStyle

public void setLineNumberStyle (TTextHighlighterLineNumberStyle $value )

Input
TTextHighlighterLineNumberStyle $value style of row number
Output
Exception

setShowLineNumbers

public void setShowLineNumbers (boolean $value )

Input
boolean $value whether to show line numbers in the highlighted result.
Output
Exception

setTabSize

public void setTabSize (integer $value )

Input
integer $value tab size
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTextHighlighterLineNumberStyle

Class TTextHighlighterLineNumberStyle (Class Overview)

TEnumerable
   |
   --TTextHighlighterLineNumberStyle

TEnumerable class.

TEnumerable is the base class for all enumerable types. To define an enumerable type, extend TEnumberable and define string constants. Each constant represents an enumerable value. The constant name must be the same as the constant value. For example,

1      class TTextAlign extends TEnumerable
2      {
3          const Left='Left';
4          const Right='Right';
5      }
Then, one can use the enumerable values such as TTextAlign::Left and TTextAlign::Right.

Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Li
string | Table
Constant Details

Li

Type:

string

Value:

'Li'

Table

Type:

string

Value:

'Table'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TClientSideValidationSummaryOptions

Class TClientSideValidationSummaryOptions (Class Overview)

TComponent
   |
   --TClientSideOptions
      |
      --TClientSideValidationSummaryOptions

TClientSideValidationSummaryOptions class.

Client-side validation summary events such as OnHideSummary and OnShowSummary can be modified through the TBaseValidator:: property of a validation summary.

The <tt>OnHideSummary</tt> event is raise when the validation summary requests to hide the messages.

The <tt>OnShowSummary</tt> event is raised when the validation summary requests to show the messages.

See the quickstart documentation for further details.

Since: 3.0
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
protected string | ensureFunction ( string $javascript) Ensure the string is a valid javascript function. If the string begins with "javascript:" valid javascript function is assumed, otherwise the code block is enclosed with "function(summary, validators){ }" block.
string | getOnHideSummary ()
string | getOnShowSummary ()
void | setOnHideSummary ( string $javascript) Client-side OnHideSummary validation summary event is raise when all the validators are valid. This will override the default client-side validation summary behaviour.
void | setOnShowSummary ( string $javascript) Client-side OnShowSummary event is raise when one or more validators are not valid. This will override the default client-side validation summary behaviour.
Methods Inherited From TClientSideOptions
TClientSideOptions::ensureFunction(), TClientSideOptions::getOption(), TClientSideOptions::getOptions(), TClientSideOptions::setFunction(), TClientSideOptions::setOption()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

ensureFunction

protected string ensureFunction (string $javascript )

Ensure the string is a valid javascript function. If the string begins with "javascript:" valid javascript function is assumed, otherwise the code block is enclosed with "function(summary, validators){ }" block.

Input
string | $javascript | javascript code.
Output
string | javascript function code.
Exception

getOnHideSummary

public string getOnHideSummary ()

Output
string javascript code for client-side OnHideSummary event.
Exception

getOnShowSummary

public string getOnShowSummary ()

Output
string javascript code for client-side OnShowSummary event.
Exception

setOnHideSummary

public void setOnHideSummary (string $javascript )

Client-side OnHideSummary validation summary event is raise when all the validators are valid. This will override the default client-side validation summary behaviour.

Input
string $javascript javascript code for client-side OnHideSummary event.
Output
Exception

setOnShowSummary

public void setOnShowSummary (string $javascript )

Client-side OnShowSummary event is raise when one or more validators are not valid. This will override the default client-side validation summary behaviour.

Input
string $javascript javascript code for client-side OnShowSummary event.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TValidationSummary

Class TValidationSummary (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TValidationSummary

TValidationSummary class

TValidationSummary displays a summary of validation errors inline on a Web page, in a message box, or both. By default, a validation summary will collect TBaseValidator::getErrorMessage of all failed validators on the page. If ValidationGroup is not empty, only those validators who belong to the group will show their error messages in the summary.

The summary can be displayed as a list, as a bulleted list, or as a single paragraph based on the DisplayMode property. The messages shown can be prefixed with HeaderText.

The summary can be displayed on the Web page and in a message box by setting the ShowSummary and ShowMessageBox properties, respectively. Note, the latter is only effective when EnableClientScript is true.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Constructor.
Method Summary
protected void | addAttributesToRender ( mixed $writer)
protected TClientSideValidationSummaryOptions | createClientScript ()
boolean | getAutoUpdate () Gets the auto-update for this summary.
protected array | getClientScriptOptions () Get a list of options for the client-side javascript validation summary.
TClientSideValidationSummaryOptions | getClientSide ()
TValidationSummaryDisplayStyle | getDisplay ()
TValidationSummaryDisplayMode | getDisplayMode ()
boolean | getEnableClientScript ()
protected array | getErrorMessages () Get the list of validation error messages.
string | getHeaderText ()
boolean | getScrollToSummary ()
boolean | getShowAnchor ()
boolean | getShowMessageBox ()
boolean | getShowSummary ()
string | getValidationGroup ()
protected string | renderBulletList ( array $writer, string 1) Render the validation summary as a bullet list.
string | renderContents ( mixed $writer) Overrides parent implementation by rendering TValidationSummary-specific presentation.
protected void | renderHeaderOnly ( THtmlWriter $writer) Render the validation summary header text only.
protected void | renderJsSummary ( array 0) Render the javascript for validation summary.
protected string | renderList ( array $writer, string 1) Render the validation summary as a simple list.
protected string | renderSingleParagraph ( array $writer, string 1) Render the validation summary as a paragraph.
void | setAutoUpdate ( boolean $value) Sets the summary to auto-update on the client-side
void | setDisplay ( TValidationSummaryDisplayStyle $value)
void | setDisplayMode ( TValidationSummaryDisplayMode $value)
void | setEnableClientScript ( boolean $value)
void | setHeaderText ( string $value) Sets the header text to be displayed at the top of the summary
void | setScrollToSummary ( boolean $value)
void | setShowAnchor ( boolean $value)
void | setShowMessageBox ( boolean $value)
void | setShowSummary ( boolean $value)
void | setValidationGroup ( string $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Constructor Details

__construct

public __construct

Constructor.

This method sets the foreground color to red.
Method Details

addAttributesToRender

protected void addAttributesToRender (mixed $writer )

Input
mixed $writer
Output
Exception

createClientScript

protected TClientSideValidationSummaryOptions createClientScript ()

Output
TClientSideValidationSummaryOptions javascript validation summary event options.
Exception

getAutoUpdate

public boolean getAutoUpdate ()

Gets the auto-update for this summary.

Output
boolean automatic client-side summary updates. Defaults to true.
Exception

getClientScriptOptions

protected array getClientScriptOptions ()

Get a list of options for the client-side javascript validation summary.

Output
array list of options for the summary
Exception

getClientSide

public TClientSideValidationSummaryOptions getClientSide ()

Output
TClientSideValidationSummaryOptions client-side validation summary event options.
Exception

getDisplay

public TValidationSummaryDisplayStyle getDisplay ()

Output
TValidationSummaryDisplayStyle the style of displaying the error messages. Defaults to TValidationSummaryDisplayStyle::Fixed.
Exception

getDisplayMode

public TValidationSummaryDisplayMode getDisplayMode ()

Output
TValidationSummaryDisplayMode the mode of displaying error messages. Defaults to TValidationSummaryDisplayMode::BulletList.
Exception

getEnableClientScript

public boolean getEnableClientScript ()

Output
boolean whether the TValidationSummary component updates itself using client-side script. Defaults to true.
Exception

getErrorMessages

protected array getErrorMessages ()

Get the list of validation error messages.

Output
array list of validator error messages.
Exception

getHeaderText

public string getHeaderText ()

Output
string the header text displayed at the top of the summary
Exception

getScrollToSummary

public boolean getScrollToSummary ()

Output
boolean whether scroll summary into viewport or not. Defaults to true.
Exception

getShowAnchor

public boolean getShowAnchor ()

Output
boolean whether the validation summary should be anchored. Defaults to false.
Exception

getShowMessageBox

public boolean getShowMessageBox ()

Output
boolean whether the validation summary is displayed in a message box. Defaults to false.
Exception

getShowSummary

public boolean getShowSummary ()

Output
boolean whether the validation summary is displayed inline. Defaults to true.
Exception

getValidationGroup

public string getValidationGroup ()

Output
string the group which this validator belongs to
Exception

renderBulletList

protected string renderBulletList (array $writer , string 1 )

Render the validation summary as a bullet list.

Input
array | $writer | list of messages
string | 1 | the header text
Output
string | summary bullet list
Exception

renderContents

public string renderContents (mixed $writer )

Overrides parent implementation by rendering TValidationSummary-specific presentation.

Input
mixed | $writer
Output
string | the rendering result
Exception

renderHeaderOnly

protected void renderHeaderOnly (THtmlWriter $writer )

Render the validation summary header text only.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderJsSummary

protected void renderJsSummary (array 0 )

Render the javascript for validation summary.

Input
array 0 list of options for validation summary.
Output
Exception

renderList

protected string renderList (array $writer , string 1 )

Render the validation summary as a simple list.

Input
array | $writer | list of messages
string | 1 | the header text
Output
string | summary list
Exception

renderSingleParagraph

protected string renderSingleParagraph (array $writer , string 1 )

Render the validation summary as a paragraph.

Input
array | $writer | list of messages
string | 1 | the header text
Output
string | summary paragraph
Exception

setAutoUpdate

public void setAutoUpdate (boolean $value )

Sets the summary to auto-update on the client-side

Input
boolean $value true for automatic summary updates.
Output
Exception

setDisplay

public void setDisplay (TValidationSummaryDisplayStyle $value )

Input
TValidationSummaryDisplayStyle $value the style of displaying the error messages
Output
Exception

setDisplayMode

public void setDisplayMode (TValidationSummaryDisplayMode $value )

Input
TValidationSummaryDisplayMode $value the mode of displaying error messages
Output
Exception

setEnableClientScript

public void setEnableClientScript (boolean $value )

Input
boolean $value whether the TValidationSummary component updates itself using client-side script.
Output
Exception

setHeaderText

public void setHeaderText (string $value )

Sets the header text to be displayed at the top of the summary

Input
string $value the header text
Output
Exception

setScrollToSummary

public void setScrollToSummary (boolean $value )

Input
boolean $value whether scroll summary into viewport or not.
Output
Exception

setShowAnchor

public void setShowAnchor (boolean $value )

Input
boolean $value whether the validation summary should be anchored.
Output
Exception

setShowMessageBox

public void setShowMessageBox (boolean $value )

Input
boolean $value whether the validation summary is displayed in a message box.
Output
Exception

setShowSummary

public void setShowSummary (boolean $value )

Input
boolean $value whether the validation summary is displayed inline.
Output
Exception

setValidationGroup

public void setValidationGroup (string $value )

Input
string $value the group which this validator belongs to
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TValidationSummaryDisplayMode

Class TValidationSummaryDisplayMode (Class Overview)

TEnumerable
   |
   --TValidationSummaryDisplayMode

TValidationSummaryDisplayMode class.

TValidationSummaryDisplayMode defines the enumerable type for the possible modes that a TValidationSummary can organize and display the collected error messages.

The following enumerable values are defined:

  • SimpleList: the error messages are displayed as a list without any decorations.
  • SingleParagraph: the error messages are concatenated together into a paragraph.
  • BulletList: the error messages are displayed as a bulleted list.
  • HeaderOnly: only the HeaderText will be display.

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | BulletList
string | HeaderOnly
string | SimpleList
string | SingleParagraph
Constant Details

BulletList

Type:

string

Value:

'BulletList'

HeaderOnly

Type:

string

Value:

'HeaderOnly'

SimpleList

Type:

string

Value:

'SimpleList'

SingleParagraph

Type:

string

Value:

'SingleParagraph'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TValidationSummaryDisplayStyle

Class TValidationSummaryDisplayStyle (Class Overview)

TEnumerable
   |
   --TValidationSummaryDisplayStyle

TValidationSummaryDisplay class.

TValidationSummaryDisplay defines the enumerable type for the possible styles that a TValidationSummary can display the collected error messages.

The following enumerable values are defined:

  • None: the error messages are not displayed
  • Dynamic: the error messages are dynamically added to display as the corresponding validators fail
  • Fixed: Similar to Dynamic except that the error messages physically occupy the page layout (even though they may not be visible)

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Dynamic
string | Fixed
string | None
Constant Details

Dynamic

Type:

string

Value:

'Dynamic'

Fixed

Type:

string

Value:

'Fixed'

None

Type:

string

Value:

'None'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWebControl

Class TWebControl (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl

Direct Known Sub-classes:

TButton , TCheckBox , TClientScriptLoader , TDataBoundControl , TDataListItem , TFileUpload , THtmlElement , THyperLink , TImage , TInlineFrame , TJavascriptLogger , TKeyboard , TLabel , TLinkButton , TPager , TPanel , TSlider , TTable , TTableCell , TTableRow , TTabPanel , TTabView , TTextBox , TTextProcessor , TValidationSummary , TWizard

TWebControl class

TWebControl is the base class for controls that share a common set of UI-related properties and methods. TWebControl-derived controls are usually associated with HTML tags. They thus have tag name, attributes and body contents. You can override getTagName to specify the tag name, addAttributesToRender to specify the attributes to be rendered, and renderContents to customize the body content rendering. TWebControl encapsulates a set of properties related with CSS style fields, such as BackColor, BorderWidth, etc.

Subclasses of TWebControl typically needs to override addAttributesToRender and renderContents. The former is used to render the attributes of the HTML tag associated with the control, while the latter is to render the body contents enclosed within the HTML tag.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds attribute name-value pairs to renderer.
void | clearStyle () Removes all style data.
void | copyBaseAttributes ( TWebControl $control) Copies basic control attributes from another control.
protected TStyle | createStyle () Creates a style object to be used by the control.
string | getAccessKey ()
string | getBackColor ()
string | getBorderColor ()
string | getBorderStyle ()
string | getBorderWidth ()
string | getCssClass ()
TDisplayStyle | getDisplay ()
TFont | getFont ()
string | getForeColor ()
boolean | getHasStyle ()
string | getHeight ()
TStyle | getStyle ()
integer | getTabIndex ()
protected string | getTagName () Returns the tag name used for this control.
string | getToolTip ()
string | getWidth ()
void | render ( THtmlWriter $writer) Renders the control.
void | renderBeginTag ( THtmlWriter $writer) Renders the openning tag for the control (including attributes)
void | renderContents ( THtmlWriter $writer) Renders the body content enclosed between the control tag.
void | renderEndTag ( THtmlWriter $writer) Renders the closing tag for the control
void | setAccessKey ( string $value) Sets the access key of the control.
void | setBackColor ( string $value)
void | setBorderColor ( string $value)
void | setBorderStyle ( string $value)
void | setBorderWidth ( string $value)
void | setCssClass ( string $value)
void | setDisplay ( TDisplayStyle $value)
void | setForeColor ( string $value)
void | setHeight ( string $value)
void | setStyle ( string $value) Sets the css style string of the control.
void | setTabIndex ( integer $value) Sets the tab index of the control.
void | setToolTip ( string $value) Sets the tooltip of the control.
void | setWidth ( string $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds attribute name-value pairs to renderer.

By default, the method will render 'id', 'accesskey', 'disabled', 'tabindex', 'title' and all custom attributes. The method can be overriden to provide customized attribute rendering.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

clearStyle

public void clearStyle ()

Removes all style data.

Output
Exception

copyBaseAttributes

public void copyBaseAttributes (TWebControl $control )

Copies basic control attributes from another control.

Properties including AccessKey, ToolTip, TabIndex, Enabled and Attributes are copied.

Input
TWebControl $control source control
Output
Exception

createStyle

protected TStyle createStyle ()

Creates a style object to be used by the control.

This method may be overriden by controls to provide customized style.

Output
TStyle the default style created for TWebControl
Exception

getAccessKey

public string getAccessKey ()

Output
string the access key of the control
Exception

getBackColor

public string getBackColor ()

Output
string the background color of the control
Exception

getBorderColor

public string getBorderColor ()

Output
string the border color of the control
Exception

getBorderStyle

public string getBorderStyle ()

Output
string the border style of the control
Exception

getBorderWidth

public string getBorderWidth ()

Output
string the border width of the control
Exception

getCssClass

public string getCssClass ()

Output
string the css class of the control
Exception

getDisplay

public TDisplayStyle getDisplay ()

Output
TDisplayStyle display style of the control, default is TDisplayStyle::Fixed
Exception

getFont

public TFont getFont ()

Output
TFont the font of the control
Exception

getForeColor

public string getForeColor ()

Output
string the foreground color of the control
Exception

getHasStyle

public boolean getHasStyle ()

Output
boolean whether the control has defined any style information
Exception

getHeight

public string getHeight ()

Output
string the height of the control
Exception

getStyle

public TStyle getStyle ()

Output
TStyle the object representing the css style of the control
Exception

getTabIndex

public integer getTabIndex ()

Output
integer the tab index of the control
Exception

getTagName

protected string getTagName ()

Returns the tag name used for this control.

By default, the tag name is 'span'. You can override this method to provide customized tag names.

Output
string tag name of the control to be rendered
Exception

getToolTip

public string getToolTip ()

Output
string the tooltip of the control
Exception

getWidth

public string getWidth ()

Output
string the width of the control
Exception

render

public void render (THtmlWriter $writer )

Renders the control.

This method overrides the parent implementation by replacing it with the following sequence:

  • renderBeginTag
  • renderContents
  • renderEndTag

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderBeginTag

public void renderBeginTag (THtmlWriter $writer )

Renders the openning tag for the control (including attributes)

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders the body content enclosed between the control tag.

By default, child controls and text strings will be rendered. You can override this method to provide customized content rendering.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderEndTag

public void renderEndTag (THtmlWriter $writer )

Renders the closing tag for the control

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

setAccessKey

public void setAccessKey (string $value )

Sets the access key of the control.

Only one-character string can be set, or an exception will be raised. Pass in an empty string if you want to disable access key.

Input
string | $value | the access key to be set
Output
Exception
throws | TInvalidDataValueException if the access key is specified with more than one character

setBackColor

public void setBackColor (string $value )

Input
string $value the background color of the control
Output
Exception

setBorderColor

public void setBorderColor (string $value )

Input
string $value the border color of the control
Output
Exception

setBorderStyle

public void setBorderStyle (string $value )

Input
string $value the border style of the control
Output
Exception

setBorderWidth

public void setBorderWidth (string $value )

Input
string $value the border width of the control
Output
Exception

setCssClass

public void setCssClass (string $value )

Input
string $value the css class of the control
Output
Exception

setDisplay

public void setDisplay (TDisplayStyle $value )

Input
TDisplayStyle $value display style of the control, default is TDisplayStyle::Fixed
Output
Exception

setForeColor

public void setForeColor (string $value )

Input
string $value the foreground color of the control
Output
Exception

setHeight

public void setHeight (string $value )

Input
string $value the height of the control
Output
Exception

setStyle

public void setStyle (string $value )

Sets the css style string of the control.

The style string will be prefixed to the styles set via other control properties (e.g. Height, Width).

Input
string | $value | the css style string
Output
Exception
throws | TInvalidDataValueException if the parameter is not a string

setTabIndex

public void setTabIndex (integer $value )

Sets the tab index of the control.

Pass 0 if you want to disable tab index.

Input
integer $value the tab index to be set
Output
Exception

setToolTip

public void setToolTip (string $value )

Sets the tooltip of the control.

Pass an empty string if you want to disable tooltip.

Input
string $value the tooltip to be set
Output
Exception

setWidth

public void setWidth (string $value )

Input
string $value the width of the control
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWebControlAdapter

Class TWebControlAdapter (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControlAdapter
         |
         --TWebControlAdapter

TWebControlAdapter class

TWebControlAdapter is the base class for adapters that customize rendering for the Web control to which the adapter is attached. It may be used to modify the default markup or behavior for specific browsers.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | render ( THtmlWriter $writer) Renders the control to which the adapter is attached.
void | renderBeginTag ( THtmlWriter $writer) Renders the openning tag for the attached control.
void | renderContents ( THtmlWriter $writer) Renders the body contents within the attached control tag.
void | renderEndTag ( THtmlWriter $writer) Renders the closing tag for the attached control.
Methods Inherited From TControlAdapter
TControlAdapter::createChildControls(), TControlAdapter::getControl(), TControlAdapter::getPage(), TControlAdapter::loadState(), TControlAdapter::onInit(), TControlAdapter::onLoad(), TControlAdapter::onPreRender(), TControlAdapter::onUnload(), TControlAdapter::render(), TControlAdapter::renderChildren(), TControlAdapter::saveState()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

render

public void render (THtmlWriter $writer )

Renders the control to which the adapter is attached.

It calls renderBeginTag, renderContents and renderEndTag in order.

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

renderBeginTag

public void renderBeginTag (THtmlWriter $writer )

Renders the openning tag for the attached control.

Default implementation calls the attached control's corresponding method.

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders the body contents within the attached control tag.

Default implementation calls the attached control's corresponding method.

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

renderEndTag

public void renderEndTag (THtmlWriter $writer )

Renders the closing tag for the attached control.

Default implementation calls the attached control's corresponding method.

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCompleteWizardStep

Class TCompleteWizardStep (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TView
            |
            --TWizardStep
               |
               --TCompleteWizardStep

TCompleteWizardStep class.

TCompleteWizardStep represents a wizard step of type TWizardStepType::Complete.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
TWizardStepType | getStepType ()
void | setStepType ( string $value)
Methods Inherited From TWizardStep
TWizardStep::getAllowReturn(), TWizardStep::getStepType(), TWizardStep::getTitle(), TWizardStep::getWizard(), TWizardStep::setAllowReturn(), TWizardStep::setStepType(), TWizardStep::setTitle(), TWizardStep::setWizard()
Methods Inherited From TView
TView::getActive(), TView::getVisible(), TView::onActivate(), TView::onDeactivate(), TView::setActive(), TView::setVisible()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getStepType

public TWizardStepType getStepType ()

Output
TWizardStepType the wizard step type. Always TWizardStepType::Complete.
Exception

setStepType

public void setStepType (string $value )

Input
string | $value | the wizard step type.
Output
Exception
throws | TInvalidOperationException whenever this method is invoked.


PRADO API Manual: Docs For Class TTemplatedWizardStep

Class TTemplatedWizardStep (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TView
            |
            --TWizardStep
               |
               --TTemplatedWizardStep

TTemplatedWizardStep class.

TTemplatedWizardStep represents a wizard step whose content and navigation can be customized using templates. To customize the step content, specify ContentTemplate. To customize navigation specific to the step, specify NavigationTemplate. Note, if the navigation template is not specified, default navigation will be used.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | createChildControls () Creates child controls.
ITemplate | getContentTemplate ()
TWizardNavigationContainer | getNavigationContainer ()
ITemplate | getNavigationTemplate ()
void | instantiateNavigationTemplate () Instantiates the navigation template if any
void | onInit ( mixed $param) Ensures child controls are created.
void | setContentTemplate ( ITemplate $value)
void | setNavigationTemplate ( ITemplate $value)
Methods Inherited From TWizardStep
TWizardStep::getAllowReturn(), TWizardStep::getStepType(), TWizardStep::getTitle(), TWizardStep::getWizard(), TWizardStep::setAllowReturn(), TWizardStep::setStepType(), TWizardStep::setTitle(), TWizardStep::setWizard()
Methods Inherited From TView
TView::getActive(), TView::getVisible(), TView::onActivate(), TView::onDeactivate(), TView::setActive(), TView::setVisible()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

createChildControls

public void createChildControls ()

Creates child controls.

This method mainly instantiates the content template, if any.

Output
Exception

getContentTemplate

public ITemplate getContentTemplate ()

Output
ITemplate the template for the content of the wizard step.
Exception

getNavigationContainer

public TWizardNavigationContainer getNavigationContainer ()

Output
TWizardNavigationContainer the control containing the navigation. It could be null if no navigation template is specified.
Exception

getNavigationTemplate

public ITemplate getNavigationTemplate ()

Output
ITemplate the template for displaying the navigation UI of a wizard step. Defaults to null.
Exception

instantiateNavigationTemplate

public void instantiateNavigationTemplate ()

Instantiates the navigation template if any

Output
Exception

onInit

public void onInit (mixed $param )

Ensures child controls are created.

Input
mixed $param event parameter
Output
Exception

setContentTemplate

public void setContentTemplate (ITemplate $value )

Input
ITemplate $value the template for the content of the wizard step.
Output
Exception

setNavigationTemplate

public void setNavigationTemplate (ITemplate $value )

Input
ITemplate $value the template for displaying the navigation UI of a wizard step.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizard

Class TWizard (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TWizard

Class TWizard.

TWizard splits a large form and presents the user with a series of smaller forms to complete. TWizard is analogous to the installation wizard commonly used to install software in Windows.

The smaller forms are called wizard steps (TWizardStep, which can be accessed via WizardSteps. In template, wizard steps can be added into a wizard using the following syntax,

1        <com:TWizard>
2           <com:TWizardStep Title="step 1">
3               content in step 1, may contain other controls
4           </com:TWizardStep>
5           <com:TWizardStep Title="step 2">
6               content in step 2, may contain other controls
7           </com:TWizardStep>
8        </com:TWizard>

Each wizard step can be one of the following types:

  • Start : the first step in the wizard.
  • Step : the internal steps in the wizard.
  • Finish : the last step that allows user interaction.
  • Complete : the step that shows a summary to user (no interaction is allowed).
  • Auto : the step type is determined by wizard automatically.
At any time, only one step is visible to end-users, which can be obtained by ActiveStep. Its index in the step collection is given by ActiveStepIndex.

Wizard content can be customized in many ways.

The layout of a wizard consists of four parts: header, step content, navigation and side bar. Their content are affected by the following properties, respectively,

  • header: HeaderText and HeaderTemplate. If both are present, the latter takes precedence.
  • step: WizardSteps.
  • navigation: StartNavigationTemplate, StepNavigationTemplate, FinishNavigationTemplate. Default templates will be used if above templates are not set.
  • side bar: SideBarTemplate. A default template will be used if this template is not set. Its visibility is toggled by ShowSideBar.
The style of these wizard layout components can be customized via the following style properties,
  • header: HeaderStyle.
  • step: StepStyle.
  • navigation: NavigationStyle, StartNextButtonStyle, StepNextButtonStyle, StepPreviousButtonStyle, FinishPreviousButtonStyle, FinishCompleteButtonStyle, CancelButtonStyle.
  • side bar: SideBarStyle and SideBarButtonStyle.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | addedWizardStep ( TWizardStep $step) Adds a wizard step to the multiview.
void | addParsedObject ( mixed $object) Adds TWizardStep objects into step collection.
protected boolean | allowNavigationToPreviousStep ()
protected boolean | allowNavigationToStep ( integer $index)
protected void | applyControlProperties () Applies various properties to the components of wizard
protected void | applyHeaderProperties () Applies properties to the wizard header
protected void | applyNavigationProperties () Apply properties to various navigation panels.
protected void | applySideBarProperties () Applies properties to the wizard sidebar
protected void | applyStepContentProperties () Applies properties to the wizard step content
void | bubbleEvent ( mixed $sender, TEventParameter $param) Handles bubbled events.
void | createChildControls () Creates child controls within the wizard
protected void | createFinishNavigation () Creates finish navigation panel.
protected void | createHeader () Creates the wizard header.
protected void | createNavigation () Creates navigation panel.
protected void | createSideBar () Creates the wizard side bar
protected void | createStartNavigation () Creates start navigation panel.
protected void | createStepContent () Creates wizard step content.
protected void | createStepNavigation () Creates step navigation panel.
void | dataListItemCommand ( mixed $sender, TDataListCommandEventParameter $param) Event handler for sidebar datalist's OnItemCommand event.
void | dataListItemDataBound ( mixed $sender, TDataListItemEventParameter $param) Event handler for sidebar datalist's OnItemDataBound event.
TWizardStep | getActiveStep ()
integer | getActiveStepIndex ()
TWizardNavigationButtonStyle | getCancelButtonStyle ()
string | getCancelDestinationUrl ()
TWizardNavigationButtonStyle | getFinishCompleteButtonStyle ()
string | getFinishDestinationUrl ()
TWizardNavigationContainer | getFinishNavigation ()
ITemplate | getFinishNavigationTemplate ()
TWizardNavigationButtonStyle | getFinishPreviousButtonStyle ()
TPanel | getHeader ()
TPanelStyle | getHeaderStyle ()
ITemplate | getHeaderTemplate ()
string | getHeaderText ()
protected TStack | getHistory ()
TMultiView | getMultiView () Returns the multiview that holds the wizard steps.
TStyle | getNavigationButtonStyle ()
TPanelStyle | getNavigationStyle ()
protected void | getPreviousStepIndex ( boolean $popStack) Determines the index of the previous step based on history.
boolean | getShowCancelButton ()
boolean | getShowSideBar ()
TPanel | getSideBar ()
TStyle | getSideBarButtonStyle ()
TPanelStyle | getSideBarStyle ()
ITemplate | getSideBarTemplate ()
TWizardNavigationContainer | getStartNavigation ()
ITemplate | getStartNavigationTemplate ()
TWizardNavigationButtonStyle | getStartNextButtonStyle ()
TPanel | getStepContent ()
TWizardNavigationContainer | getStepNavigation ()
ITemplate | getStepNavigationTemplate ()
TWizardNavigationButtonStyle | getStepNextButtonStyle ()
TWizardNavigationButtonStyle | getStepPreviousButtonStyle ()
TPanelStyle | getStepStyle ()
protected TWizardStepType | getStepType ( TWizardStep $wizardStep) Determines the type of the specified wizard step.
protected string | getTagName ()
boolean | getUseDefaultLayout ()
TWizardStepCollection | getWizardSteps ()
void | onActiveStepChanged ( TEventParameter $param) Raises OnActiveStepChanged event.
void | onCancelButtonClick ( TEventParameter $param) Raises OnCancelButtonClick event.
void | onCompleteButtonClick ( TWizardNavigationEventParameter $param) Raises OnCompleteButtonClick event.
void | onInit ( TEventParameter $param) Creates the child controls of the wizard.
void | onNextButtonClick ( TWizardNavigationEventParameter $param) Raises OnNextButtonClick event.
void | onPreviousButtonClick ( TWizardNavigationEventParameter $param) Raises OnPreviousButtonClick event.
void | onSideBarButtonClick ( TWizardNavigationEventParameter $param) Raises OnSideBarButtonClick event.
void | removedWizardStep ( TWizardStep $step) Removes a wizard step from the multiview.
void | render ( THtmlWriter $writer) Renders the wizard.
protected void | requiresControlsRecreation () Indicates the wizard needs to recreate all child controls.
protected void | reset () Clears up everything within the wizard.
void | saveState () Saves the current active step index into history.
void | setActiveStep ( TWizardStep $step)
void | setActiveStepIndex ( integer $value)
void | setCancelDestinationUrl ( string $value)
void | setFinishDestinationUrl ( string $value)
void | setFinishNavigationTemplate ( ITemplate $value)
void | setHeaderTemplate ( ITemplate $value)
void | setHeaderText ( string $value)
void | setShowCancelButton ( boolean $value)
void | setShowSideBar ( boolean $value)
void | setSideBarTemplate ( ITemplate $value)
void | setStartNavigationTemplate ( ITemplate $value)
void | setStepNavigationTemplate ( ITemplate $value)
void | setUseDefaultLayout ( boolean $value)
void | wizardStepsChanged () Updates the sidebar datalist if any.
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | CMD_CANCEL |
string | CMD_COMPLETE |
string | CMD_MOVETO |
string | CMD_NEXT |
string | CMD_PREVIOUS | Navigation commands.
string | ID_SIDEBAR_BUTTON | Side bar button ID
string | ID_SIDEBAR_LIST | Side bar data list
string | ST_AUTO | Wizard step types.
string | ST_COMPLETE |
string | ST_FINISH |
string | ST_START |
string | ST_STEP |
Method Details

addedWizardStep

public void addedWizardStep (TWizardStep $step )

Adds a wizard step to the multiview.

This method should only be used by control developers. It is invoked when a step is added into the step collection of the wizard.

Input
TWizardStep $step wizard step to be added into multiview.
Output
Exception

addParsedObject

public void addParsedObject (mixed $object )

Adds TWizardStep objects into step collection.

This method overrides the parent implementation and is invoked when template is being instantiated.

Input
mixed $object object instantiated in template
Output
Exception

allowNavigationToPreviousStep

protected boolean allowNavigationToPreviousStep ()

Output
boolean whether navigation to the previous step is allowed
Exception

allowNavigationToStep

protected boolean allowNavigationToStep (integer $index )

Input
integer | $index | index of the step
Output
boolean | whether navigation to the specified step is allowed
Exception

applyControlProperties

protected void applyControlProperties ()

Applies various properties to the components of wizard

Output
Exception

applyHeaderProperties

protected void applyHeaderProperties ()

Applies properties to the wizard header

Output
Exception

applyNavigationProperties

protected void applyNavigationProperties ()

Apply properties to various navigation panels.

Output
Exception

applySideBarProperties

protected void applySideBarProperties ()

Applies properties to the wizard sidebar

Output
Exception

applyStepContentProperties

protected void applyStepContentProperties ()

Applies properties to the wizard step content

Output
Exception

bubbleEvent

public void bubbleEvent (mixed $sender , TEventParameter $param )

Handles bubbled events.

This method mainly translate certain command events into wizard-specific events.

Input
mixed | $sender | sender of the original command event
TEventParameter | $param | event parameter
Output
Exception
throws | TInvalidDataValueException if a navigation command is associated with an invalid parameter

createChildControls

public void createChildControls ()

Creates child controls within the wizard

Output
Exception

createFinishNavigation

protected void createFinishNavigation ()

Creates finish navigation panel.

Output
Exception

createHeader

protected void createHeader ()

Creates the wizard header.

Output
Exception

createNavigation

protected void createNavigation ()

Creates navigation panel.

Output
Exception

createSideBar

protected void createSideBar ()

Creates the wizard side bar

Output
Exception

createStartNavigation

protected void createStartNavigation ()

Creates start navigation panel.

Output
Exception

createStepContent

protected void createStepContent ()

Creates wizard step content.

Output
Exception

createStepNavigation

protected void createStepNavigation ()

Creates step navigation panel.

Output
Exception

dataListItemCommand

public void dataListItemCommand (mixed $sender , TDataListCommandEventParameter $param )

Event handler for sidebar datalist's OnItemCommand event.

This method is used internally by wizard. It mainly sets the active step index according to the button clicked in the sidebar.

Input
mixed | $sender | sender of the event
TDataListCommandEventParameter | $param |
Output
Exception

dataListItemDataBound

public void dataListItemDataBound (mixed $sender , TDataListItemEventParameter $param )

Event handler for sidebar datalist's OnItemDataBound event.

This method is used internally by wizard. It mainly configures the buttons in the sidebar datalist.

Input
mixed | $sender | sender of the event
TDataListItemEventParameter | $param |
Output
Exception

getActiveStep

public TWizardStep getActiveStep ()

Output
TWizardStep the currently active wizard step
Exception

getActiveStepIndex

public integer getActiveStepIndex ()

Output
integer the zero-based index of the active wizard step
Exception

getCancelButtonStyle

public TWizardNavigationButtonStyle getCancelButtonStyle ()

Output
TWizardNavigationButtonStyle the style for the cancel button
Exception

getCancelDestinationUrl

public string getCancelDestinationUrl ()

Output
string the URL that the browser will be redirected to if the cancel button in the wizard is clicked. Defaults to ''.
Exception

getFinishCompleteButtonStyle

public TWizardNavigationButtonStyle getFinishCompleteButtonStyle ()

Output
TWizardNavigationButtonStyle the style for the complete button in the finish wizard step.
Exception

getFinishDestinationUrl

public string getFinishDestinationUrl ()

Output
string the URL that the browser will be redirected to if the wizard finishes. Defaults to ''.
Exception

getFinishNavigation

public TWizardNavigationContainer getFinishNavigation ()

Output
TWizardNavigationContainer container of the finish navigation
Exception

getFinishNavigationTemplate

public ITemplate getFinishNavigationTemplate ()

Output
ITemplate navigation template for the finish step. Defaults to null.
Exception

getFinishPreviousButtonStyle

public TWizardNavigationButtonStyle getFinishPreviousButtonStyle ()

Output
TWizardNavigationButtonStyle the style for the previous button in the start wizard step.
Exception

getHeader

public TPanel getHeader ()

Output
TPanel container of the wizard header
Exception

getHeaderStyle

public TPanelStyle getHeaderStyle ()

Output
TPanelStyle the style for the header.
Exception

getHeaderTemplate

public ITemplate getHeaderTemplate ()

Output
ITemplate template for wizard header. Defaults to null.
Exception

getHeaderText

public string getHeaderText ()

Output
string header text. Defaults to ''.
Exception

getHistory

protected TStack getHistory ()

Output
TStack history containing step indexes that were navigated before
Exception

getMultiView

public TMultiView getMultiView ()

Returns the multiview that holds the wizard steps.

This method should only be used by control developers.

Output
TMultiView the multiview holding wizard steps
Exception

getNavigationButtonStyle

public TStyle getNavigationButtonStyle ()

Output
TStyle the style common for all navigation buttons.
Exception

getNavigationStyle

public TPanelStyle getNavigationStyle ()

Output
TPanelStyle the style for the navigation panel.
Exception

getPreviousStepIndex

protected void getPreviousStepIndex (boolean $popStack )

Determines the index of the previous step based on history.

Input
boolean $popStack whether the first item in the history stack should be popped up after calling this method.
Output
Exception

getShowCancelButton

public boolean getShowCancelButton ()

Output
boolean whether to display a cancel button in each wizard step. Defaults to false.
Exception

getShowSideBar

public boolean getShowSideBar ()

Output
boolean whether to display a side bar that contains links to wizard steps. Defaults to true.
Exception

getSideBar

public TPanel getSideBar ()

Output
TPanel container of the wizard side bar
Exception

getSideBarButtonStyle

public TStyle getSideBarButtonStyle ()

Output
TStyle the style for the buttons displayed in the side bar.
Exception

getSideBarStyle

public TPanelStyle getSideBarStyle ()

Output
TPanelStyle the style for the side bar.
Exception

getSideBarTemplate

public ITemplate getSideBarTemplate ()

Output
ITemplate template for the side bar. Defaults to null.
Exception

getStartNavigation

public TWizardNavigationContainer getStartNavigation ()

Output
TWizardNavigationContainer container of the start navigation
Exception

getStartNavigationTemplate

public ITemplate getStartNavigationTemplate ()

Output
ITemplate navigation template for the start step. Defaults to null.
Exception

getStartNextButtonStyle

public TWizardNavigationButtonStyle getStartNextButtonStyle ()

Output
TWizardNavigationButtonStyle the style for the next button in the start wizard step.
Exception

getStepContent

public TPanel getStepContent ()

Output
TPanel container of the wizard step content
Exception

getStepNavigation

public TWizardNavigationContainer getStepNavigation ()

Output
TWizardNavigationContainer container of the step navigation
Exception

getStepNavigationTemplate

public ITemplate getStepNavigationTemplate ()

Output
ITemplate navigation template for internal steps. Defaults to null.
Exception

getStepNextButtonStyle

public TWizardNavigationButtonStyle getStepNextButtonStyle ()

Output
TWizardNavigationButtonStyle the style for the next button in each internal wizard step.
Exception

getStepPreviousButtonStyle

public TWizardNavigationButtonStyle getStepPreviousButtonStyle ()

Output
TWizardNavigationButtonStyle the style for the previous button in the start wizard step.
Exception

getStepStyle

public TPanelStyle getStepStyle ()

Output
TPanelStyle the style for each internal wizard step.
Exception

getStepType

protected TWizardStepType getStepType (TWizardStep $wizardStep )

Determines the type of the specified wizard step.

Input
TWizardStep | $wizardStep
Output
TWizardStepType | type of the step
Exception

getTagName

protected string getTagName ()

Output
string tag name for the wizard
Exception

getUseDefaultLayout

public boolean getUseDefaultLayout ()

Output
boolean whether to use default layout to arrange side bar and the rest wizard components. Defaults to true.
Exception

getWizardSteps

public TWizardStepCollection getWizardSteps ()

Output
TWizardStepCollection collection of wizard steps
Exception

onActiveStepChanged

public void onActiveStepChanged (TEventParameter $param )

Raises OnActiveStepChanged event.

This event is raised when the current visible step is changed in the wizard.

Input
TEventParameter $param event parameter
Output
Exception

onCancelButtonClick

public void onCancelButtonClick (TEventParameter $param )

Raises OnCancelButtonClick event.

This event is raised when a cancel navigation button is clicked in the current active step.

Input
TEventParameter $param event parameter
Output
Exception

onCompleteButtonClick

public void onCompleteButtonClick (TWizardNavigationEventParameter $param )

Raises OnCompleteButtonClick event.

This event is raised when a finish navigation button is clicked in the current active step.

Input
TWizardNavigationEventParameter $param event parameter
Output
Exception

onInit

public void onInit (TEventParameter $param )

Creates the child controls of the wizard.

This method overrides the parent implementation.

Input
TEventParameter $param event parameter
Output
Exception

onNextButtonClick

public void onNextButtonClick (TWizardNavigationEventParameter $param )

Raises OnNextButtonClick event.

This event is raised when a next navigation button is clicked in the current active step.

Input
TWizardNavigationEventParameter $param event parameter
Output
Exception

onPreviousButtonClick

public void onPreviousButtonClick (TWizardNavigationEventParameter $param )

Raises OnPreviousButtonClick event.

This event is raised when a previous navigation button is clicked in the current active step.

Input
TWizardNavigationEventParameter $param event parameter
Output
Exception

onSideBarButtonClick

public void onSideBarButtonClick (TWizardNavigationEventParameter $param )

Raises OnSideBarButtonClick event.

This event is raised when a link button in the side bar is clicked.

Input
TWizardNavigationEventParameter $param event parameter
Output
Exception

removedWizardStep

public void removedWizardStep (TWizardStep $step )

Removes a wizard step from the multiview.

This method should only be used by control developers. It is invoked when a step is removed from the step collection of the wizard.

Input
TWizardStep $step wizard step to be removed from multiview.
Output
Exception

render

public void render (THtmlWriter $writer )

Renders the wizard.

Input
THtmlWriter $writer
Output
Exception

requiresControlsRecreation

protected void requiresControlsRecreation ()

Indicates the wizard needs to recreate all child controls.

Output
Exception

reset

protected void reset ()

Clears up everything within the wizard.

Output
Exception

saveState

public void saveState ()

Saves the current active step index into history.

This method is invoked by the framework when the control state is being saved.

Output
Exception

setActiveStep

public void setActiveStep (TWizardStep $step )

Input
TWizardStep | $step | step to be activated
Output
Exception
throws | TInvalidOperationException if the step is not in the wizard step collection

setActiveStepIndex

public void setActiveStepIndex (integer $value )

Input
integer $value the zero-based index of the wizard step to be activated
Output
Exception

setCancelDestinationUrl

public void setCancelDestinationUrl (string $value )

Input
string $value the URL that the browser will be redirected to if the cancel button in the wizard is clicked.
Output
Exception

setFinishDestinationUrl

public void setFinishDestinationUrl (string $value )

Input
string $value the URL that the browser will be redirected to if the wizard finishes.
Output
Exception

setFinishNavigationTemplate

public void setFinishNavigationTemplate (ITemplate $value )

Input
ITemplate $value navigation template for the finish step.
Output
Exception

setHeaderTemplate

public void setHeaderTemplate (ITemplate $value )

Input
ITemplate $value template for wizard header.
Output
Exception

setHeaderText

public void setHeaderText (string $value )

Input
string $value header text.
Output
Exception

setShowCancelButton

public void setShowCancelButton (boolean $value )

Input
boolean $value whether to display a cancel button in each wizard step.
Output
Exception

setShowSideBar

public void setShowSideBar (boolean $value )

Input
boolean $value whether to display a side bar that contains links to wizard steps.
Output
Exception

setSideBarTemplate

public void setSideBarTemplate (ITemplate $value )

Input
ITemplate $value template for the side bar.
Output
Exception

setStartNavigationTemplate

public void setStartNavigationTemplate (ITemplate $value )

Input
ITemplate $value navigation template for the start step.
Output
Exception

setStepNavigationTemplate

public void setStepNavigationTemplate (ITemplate $value )

Input
ITemplate $value navigation template for internal steps.
Output
Exception

setUseDefaultLayout

public void setUseDefaultLayout (boolean $value )

Input
boolean $value whether to use default layout to arrange side bar and the rest wizard components. If true, an HTML table will be used which places the side bar in the left cell while the rest components in the right cell.
Output
Exception

wizardStepsChanged

public void wizardStepsChanged ()

Updates the sidebar datalist if any.

This method is invoked when any wizard step is changed.

Output
Exception

Constant Details

CMD_CANCEL

Type:

string

Value:

'Cancel'

CMD_COMPLETE

Type:

string

Value:

'Complete'

CMD_MOVETO

Type:

string

Value:

'MoveTo'

CMD_NEXT

Type:

string

Value:

'NextStep'

CMD_PREVIOUS

Navigation commands.

Type:

string

Value:

'PreviousStep'

ID_SIDEBAR_BUTTON

Side bar button ID

Type:

string

Value:

'SideBarButton'

ID_SIDEBAR_LIST

Side bar data list

Type:

string

Value:

'SideBarList'

ST_AUTO

Wizard step types.

Type:

string

Value:

'Auto'
Deprecated: deprecated since version 3.0.4 (use TWizardStepType constants instead)

ST_COMPLETE

Type:

string

Value:

'Complete'

ST_FINISH

Type:

string

Value:

'Finish'

ST_START

Type:

string

Value:

'Start'

ST_STEP

Type:

string

Value:

'Step'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizardFinishNavigationTemplate

Class TWizardFinishNavigationTemplate (Class Overview)

TComponent
   |
   --TWizardNavigationTemplate
      |
      --TWizardFinishNavigationTemplate

TWizardFinishNavigationTemplate class.

TWizardFinishNavigationTemplate is the template used as default wizard finish navigation panel. It consists of three buttons, Previous, Complete and Cancel.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void
instantiateIn ( TControl $parent)
Instantiates the template.
Methods Inherited From TWizardNavigationTemplate
TWizardNavigationTemplate::createNavigationButton(), TWizardNavigationTemplate::getWizard(), TWizardNavigationTemplate::instantiateIn()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

instantiateIn

public void instantiateIn (TControl $parent )

Instantiates the template.

Input
TControl $parent parent to hold the content within the template
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizardNavigationButtonType

Class TWizardNavigationButtonType (Class Overview)

TEnumerable
   |
   --TWizardNavigationButtonType

TWizardNavigationButtonType class.

TWizardNavigationButtonType defines the enumerable type for the possible types of buttons that can be used in the navigation part of a TWizard.

The following enumerable values are defined:

  • Button: a regular click button
  • Image: an image button
  • Link: a hyperlink button

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Button
string | Image
string | Link
Constant Details

Button

Type:

string

Value:

'Button'

Image

Type:

string

Value:

'Image'

Link

Type:

string

Value:

'Link'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizardNavigationContainer

Class TWizardNavigationContainer (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWizardNavigationContainer

TWizardNavigationContainer class.

TWizardNavigationContainer represents a control containing a wizard navigation. The navigation may contain a few buttons, including PreviousButton, NextButton, CancelButton, CompleteButton.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
mixed | getCancelButton ()
mixed | getCompleteButton ()
mixed | getNextButton ()
mixed | getPreviousButton ()
void | setCancelButton ( mixed $value)
void | setCompleteButton ( mixed $value)
void | setNextButton ( mixed $value)
void | setPreviousButton ( mixed $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getCancelButton

public mixed getCancelButton ()

Output
mixed the cancel button
Exception

getCompleteButton

public mixed getCompleteButton ()

Output
mixed the complete button
Exception

getNextButton

public mixed getNextButton ()

Output
mixed the next button
Exception

getPreviousButton

public mixed getPreviousButton ()

Output
mixed the previous button
Exception

setCancelButton

public void setCancelButton (mixed $value )

Input
mixed $value the cancel button
Output
Exception

setCompleteButton

public void setCompleteButton (mixed $value )

Input
mixed $value the complete button
Output
Exception

setNextButton

public void setNextButton (mixed $value )

Input
mixed $value the next button
Output
Exception

setPreviousButton

public void setPreviousButton (mixed $value )

Input
mixed $value the previous button
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizardNavigationEventParameter

Class TWizardNavigationEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TWizardNavigationEventParameter

TWizardNavigationEventParameter class.

TWizardNavigationEventParameter represents the parameter for TWizard's navigation events.

The index of the currently active step can be obtained from CurrentStepIndex, while the index of the candidate new step is in NextStepIndex. By modifying NextStepIndex, the new step can be changed to another one. If there is anything wrong with the navigation and it is not wanted, set CancelNavigation to true.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
boolean | getCancelNavigation ()
integer | getCurrentStepIndex ()
integer | getNextStepIndex ()
void | setCancelNavigation ( boolean $value)
void | setNextStepIndex ( integer $index)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getCancelNavigation

public boolean getCancelNavigation ()

Output
boolean whether navigation to the next step should be canceled. Default to false.
Exception

getCurrentStepIndex

public integer getCurrentStepIndex ()

Output
integer the zero-based index of the currently active step.
Exception

getNextStepIndex

public integer getNextStepIndex ()

Output
integer the zero-based index of the next step. Default to CurrentStepIndex.
Exception

setCancelNavigation

public void setCancelNavigation (boolean $value )

Input
boolean $value whether navigation to the next step should be canceled.
Output
Exception

setNextStepIndex

public void setNextStepIndex (integer $index )

Input
integer $index the zero-based index of the next step.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizardNavigationTemplate

Class TWizardNavigationTemplate (Class Overview)

TComponent
   |
   --TWizardNavigationTemplate

Direct Known Sub-classes:

TWizardStartNavigationTemplate , TWizardFinishNavigationTemplate , TWizardStepNavigationTemplate

TWizardNavigationTemplate class.

TWizardNavigationTemplate is the base class for various navigation templates.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
protected void | createNavigationButton ( TWizardNavigationButtonStyle $buttonStyle, boolean $causesValidation, string $commandName) Creates a navigation button.
TWizard | getWizard ()
void | instantiateIn ( TControl $parent) Instantiates the template.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

createNavigationButton

protected void createNavigationButton (TWizardNavigationButtonStyle $buttonStyle , boolean $causesValidation , string $commandName )

Creates a navigation button.

It creates a TButton, TLinkButton, or TImageButton, depending on the given parameters.

Input
TWizardNavigationButtonStyle | $buttonStyle | button style
boolean | $causesValidation | whether the button should cause validation
string | $commandName | command name for the button's OnCommand event
Output
Exception
throws | TInvalidDataValueException if the button type is not recognized

getWizard

public TWizard getWizard ()

Output
TWizard the wizard owning this template
Exception

instantiateIn

public void instantiateIn (TControl $parent )

Instantiates the template.

Derived classes should override this method.

Input
TControl $parent parent to hold the content within the template
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizardSideBarListItemTemplate

Class TWizardSideBarListItemTemplate (Class Overview)

TComponent
   |
   --TWizardSideBarListItemTemplate

TWizardSideBarListItemTemplate class.

TWizardSideBarListItemTemplate is the default template for each item in the sidebar datalist.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void
instantiateIn ( TControl $parent)
Instantiates the template.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

instantiateIn

public void instantiateIn (TControl $parent )

Instantiates the template.

It creates a TLinkButton.

Input
TControl $parent parent to hold the content within the template
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizardSideBarTemplate

Class TWizardSideBarTemplate (Class Overview)

TComponent
   |
   --TWizardSideBarTemplate

TWizardSideBarTemplate class.

TWizardSideBarTemplate is the default template for wizard sidebar.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void
instantiateIn ( TControl $parent)
Instantiates the template.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

instantiateIn

public void instantiateIn (TControl $parent )

Instantiates the template.

It creates a TDataList control.

Input
TControl $parent parent to hold the content within the template
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizardStartNavigationTemplate

Class TWizardStartNavigationTemplate (Class Overview)

TComponent
   |
   --TWizardNavigationTemplate
      |
      --TWizardStartNavigationTemplate

TWizardStartNavigationTemplate class.

TWizardStartNavigationTemplate is the template used as default wizard start navigation panel. It consists of two buttons, Next and Cancel.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void
instantiateIn ( TControl $parent)
Instantiates the template.
Methods Inherited From TWizardNavigationTemplate
TWizardNavigationTemplate::createNavigationButton(), TWizardNavigationTemplate::getWizard(), TWizardNavigationTemplate::instantiateIn()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

instantiateIn

public void instantiateIn (TControl $parent )

Instantiates the template.

Input
TControl $parent parent to hold the content within the template
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizardStep

Class TWizardStep (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TView
            |
            --TWizardStep

Direct Known Sub-classes:

TCompleteWizardStep , TTemplatedWizardStep

TWizardStep class.

TWizardStep represents a wizard step. The wizard owning the step can be obtained by Wizard. To specify the type of the step, set StepType; For step title, set Title. If a step can be re-visited, set AllowReturn to true.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
boolean | getAllowReturn ()
TWizardStepType | getStepType ()
string | getTitle ()
TWizard | getWizard ()
void | setAllowReturn ( boolean $value)
void | setStepType ( TWizardStepType $type)
void | setTitle ( string $value)
void | setWizard ( TWizard $wizard) Sets the wizard owning this step.
Methods Inherited From TView
TView::getActive(), TView::getVisible(), TView::onActivate(), TView::onDeactivate(), TView::setActive(), TView::setVisible()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getAllowReturn

public boolean getAllowReturn ()

Output
boolean whether this step can be re-visited. Default to true.
Exception

getStepType

public TWizardStepType getStepType ()

Output
TWizardStepType the wizard step type. Defaults to TWizardStepType::Auto.
Exception

getTitle

public string getTitle ()

Output
string the title for this step.
Exception

getWizard

public TWizard getWizard ()

Output
TWizard the wizard owning this step
Exception

setAllowReturn

public void setAllowReturn (boolean $value )

Input
boolean $value whether this step can be re-visited.
Output
Exception

setStepType

public void setStepType (TWizardStepType $type )

Input
TWizardStepType $type the wizard step type.
Output
Exception

setTitle

public void setTitle (string $value )

Input
string $value the title for this step.
Output
Exception

setWizard

public void setWizard (TWizard $wizard )

Sets the wizard owning this step.

This method is used internally by TWizard.

Input
TWizard $wizard the wizard owning this step
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizardStepCollection

Class TWizardStepCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TWizardStepCollection

TWizardStepCollection class.

TWizardStepCollection represents the collection of wizard steps owned by a TWizard.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void | insertAt ( integer $index, mixed $item) Inserts an item at the specified position.
mixed | removeAt ( integer $index) Removes an item at the specified position.
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This method overrides the parent implementation by checking if the item being added is a TWizardStep.

Input
integer | $index | the speicified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item being added is not TWizardStep.

removeAt

public mixed removeAt (integer $index )

Removes an item at the specified position.

Input
integer | $index | the index of the item to be removed.
Output
mixed | the removed item.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizardStepNavigationTemplate

Class TWizardStepNavigationTemplate (Class Overview)

TComponent
   |
   --TWizardNavigationTemplate
      |
      --TWizardStepNavigationTemplate

TWizardStepNavigationTemplate class.

TWizardStepNavigationTemplate is the template used as default wizard step navigation panel. It consists of three buttons, Previous, Next and Cancel.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void
instantiateIn ( TControl $parent)
Instantiates the template.
Methods Inherited From TWizardNavigationTemplate
TWizardNavigationTemplate::createNavigationButton(), TWizardNavigationTemplate::getWizard(), TWizardNavigationTemplate::instantiateIn()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

instantiateIn

public void instantiateIn (TControl $parent )

Instantiates the template.

Input
TControl $parent parent to hold the content within the template
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizardStepType

Class TWizardStepType (Class Overview)

TEnumerable
   |
   --TWizardStepType

TWizardStepType class.

TWizardStepType defines the enumerable type for the possible types of wizard steps.

The following enumerable values are defined:

  • Auto: the type is automatically determined based on the location of the wizard step in the whole step collection.
  • Complete: the step is the last summary step.
  • Start: the step is the first step
  • Step: the step is between the begin and the end steps.
  • Finish: the last step before the Complete step.

Since: 3.0.4
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | Auto
string | Complete
string | Finish
string | Start
string | Step
Constant Details

Auto

Type:

string

Value:

'Auto'

Complete

Type:

string

Value:

'Complete'

Finish

Type:

string

Value:

'Finish'

Start

Type:

string

Value:

'Start'

Step

Type:

string

Value:

'Step'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TWizardNavigationButtonStyle

Class TWizardNavigationButtonStyle (Class Overview)

TComponent
   |
   --TStyle
      |
      --TWizardNavigationButtonStyle

TWizardNavigationButtonStyle class.

TWizardNavigationButtonStyle defines the style applied to a wizard navigation button. The button type can be specified via ButtonType, which can be 'Button', 'Image' or 'Link'. If the button is an image button, ImageUrl will be used to load the image for the button. Otherwise, ButtonText will be displayed as the button caption.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | apply ( mixed $button) Applies this style to the specified button
void | copyFrom ( TStyle $style) Copies the fields in a new style to this style.
string | getButtonText ()
TWizardNavigationButtonType | getButtonType ()
string | getImageUrl ()
void | mergeWith ( TStyle $style) Merges the style with a new one.
void | reset () Sets the style attributes to default values.
void | setButtonText ( string $value)
void | setButtonType ( TWizardNavigationButtonType $value)
void | setImageUrl ( string $value)
Methods Inherited From TStyle
TStyle::addAttributesToRender(), TStyle::clearStyleField(), TStyle::copyFrom(), TStyle::getBackColor(), TStyle::getBorderColor(), TStyle::getBorderStyle(), TStyle::getBorderWidth(), TStyle::getCssClass(), TStyle::getCustomStyle(), TStyle::getDisplayStyle(), TStyle::getFont(), TStyle::getForeColor(), TStyle::getHeight(), TStyle::getStyleField(), TStyle::getStyleFields(), TStyle::getWidth(), TStyle::hasCssClass(), TStyle::hasFont(), TStyle::hasStyleField(), TStyle::mergeWith(), TStyle::reset(), TStyle::setBackColor(), TStyle::setBorderColor(), TStyle::setBorderStyle(), TStyle::setBorderWidth(), TStyle::setCssClass(), TStyle::setCustomStyle(), TStyle::setDisplayStyle(), TStyle::setForeColor(), TStyle::setHeight(), TStyle::setStyleField(), TStyle::setWidth(), TStyle::__clone()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

apply

public void apply (mixed $button )

Applies this style to the specified button

Input
mixed $button button to be applied with this style
Output
Exception

copyFrom

public void copyFrom (TStyle $style )

Copies the fields in a new style to this style.

If a style field is set in the new style, the corresponding field in this style will be overwritten.

Input
TStyle $style the new style
Output
Exception

getButtonText

public string getButtonText ()

Output
string button caption
Exception

getButtonType

public TWizardNavigationButtonType getButtonType ()

Output
TWizardNavigationButtonType button type. Default to TWizardNavigationButtonType::Button.
Exception

getImageUrl

public string getImageUrl ()

Output
string image URL for the image button
Exception

mergeWith

public void mergeWith (TStyle $style )

Merges the style with a new one.

If a style field is not set in this style, it will be overwritten by the new one.

Input
TStyle $style the new style
Output
Exception

reset

public void reset ()

Sets the style attributes to default values.

This method overrides the parent implementation by resetting additional TWizardNavigationButtonStyle specific attributes.

Output
Exception

setButtonText

public void setButtonText (string $value )

Input
string $value button caption
Output
Exception

setButtonType

public void setButtonType (TWizardNavigationButtonType $value )

Input
TWizardNavigationButtonType $value button type.
Output
Exception

setImageUrl

public void setImageUrl (string $value )

Input
string $value image URL for the image button
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TXmlTransform

Class TXmlTransform (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TXmlTransform

TXmlTransform class

TXmlTransform uses the PHP's XSL extension to perform XSL transformations using the libxslt library.

To associate an XML style sheet with TXmlTransform set the TransformPath property to the namespace or path to the style sheet or set the TransformContent property to the XML style sheet data as a string.

To associate the XML data to be transformed set the DocumentPath property to the namespace or path to the XML document or set the DocumentContent property to the XML data as a string.

To add additional parameters to the transformation process you can use the Parameters property.

Since: 3.1
Author: Knut Urdalen <knut.urdalen@gmail.com>
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Constructor
Method Summary
string | getDocumentContent ()
string | getDocumentPath ()
TAttributeCollection | getParameters () Returns the list of parameters to be applied to the transform.
string | getTransformContent ()
string | getTransformPath ()
void | render ( THtmlWriter $writer) Performs XSL transformation and render the output.
void | setDocumentContent ( string $value)
void | setDocumentPath ( string $value)
void | setTransformContent ( string $value)
void | setTransformPath ( string $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | EXT_XML_FILE
string | EXT_XSL_FILE
Constructor Details

__construct

public __construct

Constructor

Initializes the TXmlTransform object and ensure that the XSL extension is available

Throws: TConfigurationException If XSL extension is not available
Method Details

getDocumentContent

public string getDocumentContent ()

Output
string XML data
Exception

getDocumentPath

public string getDocumentPath ()

Output
string The path to the XML document. It must be in namespace format.
Exception

getParameters

public TAttributeCollection getParameters ()

Returns the list of parameters to be applied to the transform.

Output
TAttributeCollection the list of custom parameters
Exception

getTransformContent

public string getTransformContent ()

Output
string XML style sheet as string
Exception

getTransformPath

public string getTransformPath ()

Output
string The path to the XML style sheet.
Exception

render

public void render (THtmlWriter $writer )

Performs XSL transformation and render the output.

Input
THtmlWriter $writer The writer used for the rendering purpose
Output
Exception

setDocumentContent

public void setDocumentContent (string $value )

Input
string $value XML data. If not empty, it takes precedence over DocumentPath.
Output
Exception

setDocumentPath

public void setDocumentPath (string $value )

Input
string | $value | Namespace or path to XML document
Output
Exception
throws | TInvalidDataValueException

setTransformContent

public void setTransformContent (string $value )

Input
string $value XML style sheet as string
Output
Exception

setTransformPath

public void setTransformPath (string $value )

Input
string $value The path to the XML style sheet. It must be in namespace format.
Output
Exception

Constant Details

EXT_XML_FILE

Type:

string

Value:

'.xml'

EXT_XSL_FILE

Type:

string

Value:

'.xsl'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCachePageStatePersister

Class TCachePageStatePersister (Class Overview)

TComponent
   |
   --TCachePageStatePersister

TCachePageStatePersister class

TCachePageStatePersister implements a page state persistent method based on cache. Page state are stored in cache (e.g. memcache, DB cache, etc.), and only a small token is passed to the client side to identify the state. This greatly reduces the size of the page state that needs to be transmitted between the server and the client. Of course, this is at the cost of using server side resource.

A cache module has to be loaded in order to use TCachePageStatePersister. By default, TCachePageStatePersister will use the primary cache module. A non-primary cache module can be used by setting CacheModuleID. Any cache module, as long as it implements the interface ICache, may be used. For example, one can use TDbCache, TMemCache, TAPCCache, etc.

TCachePageStatePersister uses CacheTimeout to limit the data that stores in cache.

Since server resource is often limited, be cautious if you plan to use TCachePageStatePersister for high-traffic Web pages. You may consider using a small CacheTimeout.

There are a couple of ways to use TCachePageStatePersister. One can override the page's TPage::getStatePersister() method and create a TCachePageStatePersister instance there. Or one can configure the pages to use TCachePageStatePersister in page configurations as follows,

1        <pages StatePersisterClass="System.Web.UI.TCachePageStatePersister"
2               StatePersister.CacheModuleID="mycache"
3               StatePersister.CacheTimeout="3600" />
Note in the above, we use StatePersister.CacheModuleID to configure the cache module ID for the TCachePageStatePersister instance.

The above configuration will affect the pages under the directory containing this configuration and all its subdirectories. To configure individual pages to use TCachePageStatePersister, use

1        <pages>
2          <page id="PageID" StatePersisterClass="System.Web.UI.TCachePageStatePersister" />
3        </pages>

Since: 3.1.1
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected string | calculateKey ( string $timestamp)
ICache | getCache ()
string | getCacheModuleID ()
integer | getCacheTimeout ()
string | getKeyPrefix ()
void | getPage ( TPage 0)
mixed | load () Loads page state from cache.
void | save ( mixed $state) Saves state in cache.
void | setCacheModuleID ( string $value)
void | setCacheTimeout ( integer $value)
void | setKeyPrefix ( string $value)
void | setPage ( TPage $page)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

calculateKey

protected string calculateKey (string $timestamp )

Input
string | $timestamp | micro timestamp when saving state occurs
Output
string | a key that is unique per user request
Exception

getCache

public ICache getCache ()

Output
ICache the cache module being used for data storage
Exception

getCacheModuleID

public string getCacheModuleID ()

Output
string the ID of the cache module.
Exception

getCacheTimeout

public integer getCacheTimeout ()

Output
integer the number of seconds in which the cached state will expire. Defaults to 1800.
Exception

getKeyPrefix

public string getKeyPrefix ()

Output
string prefix of cache variable name to avoid conflict with other cache data. Defaults to 'statepersister'.
Exception

getPage

public void getPage (TPage 0 )

Input
TPage 0 the page that this persister works for
Output
Exception

load

public mixed load ()

Loads page state from cache.

Output
mixed | the restored state
Exception
throws | THttpException if page state is corrupted

save

public void save (mixed $state )

Saves state in cache.

Input
mixed $state state to be stored
Output
Exception

setCacheModuleID

public void setCacheModuleID (string $value )

Input
string $value the ID of the cache module. If not set, the primary cache module will be used.
Output
Exception

setCacheTimeout

public void setCacheTimeout (integer $value )

Input
integer | $value | the number of seconds in which the cached state will expire. 0 means never expire.
Output
Exception
throws | TInvalidDataValueException if the number is smaller than 0.

setKeyPrefix

public void setKeyPrefix (string $value )

Input
string $value prefix of cache variable name to avoid conflict with other cache data
Output
Exception

setPage

public void setPage (TPage $page )

Input
TPage $page the page that this persister works for.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TClientScriptManager

Class TClientScriptManager (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TClientScriptManager

TClientScriptManager class.

TClientScriptManager manages javascript and CSS stylesheets for a page.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
string | getCallbackReference ( ICallbackEventHandler $callbackHandler, array $options) Returns javascript statement that create a new callback request object.
protected array | getDefaultButtonOptions ( string $panelID, string $buttonID)
protected array | getPackagePathUrl ( string $base)
string | getPradoScriptAssetUrl ()
boolean | getRequiresHead ()
boolean | hasBeginScripts ()
boolean | hasEndScripts ()
boolean | isBeginScriptRegistered ( string $key)
boolean | isEndScriptRegistered ( string $key)
boolean | isHeadScriptFileRegistered ( string $key)
boolean | isHeadScriptRegistered ( string $key)
boolean | isHiddenFieldRegistered ( string $key)
boolean | isScriptFileRegistered ( string $key)
boolean | isStyleSheetFileRegistered ( string $key)
boolean | isStyleSheetRegistered ( string $key)
void | registerBeginScript ( string $key, string $script) Registers a javascript script block at the beginning of the form
void | registerCallbackControl ( string $class, array $options) Registers callback javascript for a control.
void | registerDefaultButton ( TControl|string $panel, TControl|string $button) Register a default button to panel. When the $panel is in focus and the 'enter' key is pressed, the $button will be clicked.
void | registerEndScript ( string $key, string $script) Registers a javascript script block at the end of the form
void | registerFocusControl ( string $target) Registers the control to receive default focus.
void | registerHeadScript ( string $key, string $script) Registers a javascript block in the page head.
void | registerHeadScriptFile ( string $key, string $url) Registers a javascript file in the page head
void | registerHiddenField ( string $name, string|array $value) Registers a hidden field to be rendered in the form.
string | registerJavascriptPackages ( string $base, array $packages, boolean $debug, boolean $gzip) Publishes a javascript library path and register packages to be loaded.
void | registerPostBackControl ( string $class, array $options) Registers postback javascript for a control. A null class parameter will prevent the javascript code registration.
void | registerPradoScript ( string $name) Registers Prado javascript by library name. See "Web/Javascripts/source/packages.php" for library names.
void | registerScriptFile ( string $key, string $url) Registers a javascript file to be rendered within the form
void | registerStyleSheet ( string $key, string $css, mixed $media) Registers a CSS block to be rendered in the page head
void | registerStyleSheetFile ( string $key, string $url, string $media) Registers a CSS file to be rendered in the page head
void | renderBeginScripts ( THtmlWriter $writer)
void | renderEndScripts ( THtmlWriter $writer)
void | renderHeadScriptFiles ( THtmlWriter $writer)
void | renderHeadScripts ( THtmlWriter $writer)
void | renderHiddenFields ( THtmlWriter $writer)
protected void | renderPradoScripts ( THtmlWriter $writer) Renders the HTML tags for PRADO js files
void | renderScriptFiles ( THtmlWriter $writer)
void | renderStyleSheetFiles ( THtmlWriter $writer)
void | renderStyleSheets ( THtmlWriter $writer)
protected void | verifyJavascriptPackages ( mixed $base, mixed $path, mixed $scripts)
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | SCRIPT_LOADER | the PHP script for loading Prado javascript files
string | SCRIPT_PATH | directory containing Prado javascript files
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getCallbackReference

public string getCallbackReference (ICallbackEventHandler $callbackHandler , array $options )

Returns javascript statement that create a new callback request object.

Input
ICallbackEventHandler | $callbackHandler | callback response handler
array | $options | additional callback options
Output
string | javascript statement that creates a new callback request.
Exception

getDefaultButtonOptions

protected array getDefaultButtonOptions (string $panelID , string $buttonID )

Input
string | $panelID | the unique ID of the container control
string | $buttonID | the unique ID of the button control
Output
array | default button options.
Exception

getPackagePathUrl

protected array getPackagePathUrl (string $base )

Input
string | $base | javascript package path.
Output
array | tuple($path,$url).
Exception

getPradoScriptAssetUrl

public string getPradoScriptAssetUrl ()

Output
string Prado javascript library base asset url.
Exception

getRequiresHead

public boolean getRequiresHead ()

Output
boolean whether THead is required in order to render CSS and js within head
Exception

hasBeginScripts

public boolean hasBeginScripts ()

Output
boolean true if any begin scripts are registered.
Exception

hasEndScripts

public boolean hasEndScripts ()

Output
boolean true if any end scripts are registered.
Exception

isBeginScriptRegistered

public boolean isBeginScriptRegistered (string $key )

Input
string | $key | a unique key
Output
boolean | whether there is a beginning javascript block registered with the specified key
Exception

isEndScriptRegistered

public boolean isEndScriptRegistered (string $key )

Input
string | $key | a unique key
Output
boolean | whether there is an ending javascript block registered with the specified key
Exception

isHeadScriptFileRegistered

public boolean isHeadScriptFileRegistered (string $key )

Input
string | $key | a unique key
Output
boolean | whether there is a head javascript file registered with the specified key
Exception

isHeadScriptRegistered

public boolean isHeadScriptRegistered (string $key )

Input
string | $key | a unique key
Output
boolean | whether there is a head javascript block registered with the specified key
Exception

isHiddenFieldRegistered

public boolean isHiddenFieldRegistered (string $key )

Input
string | $key | a unique key
Output
boolean | whether there is a hidden field registered with the specified key
Exception

isScriptFileRegistered

public boolean isScriptFileRegistered (string $key )

Input
string | $key | a unique key
Output
boolean | whether there is a javascript file registered with the specified key
Exception

isStyleSheetFileRegistered

public boolean isStyleSheetFileRegistered (string $key )

Input
string | $key | a unique key
Output
boolean | whether there is a CSS file registered with the specified key
Exception

isStyleSheetRegistered

public boolean isStyleSheetRegistered (string $key )

Input
string | $key | a unique key
Output
boolean | whether there is a CSS block registered with the specified key
Exception

registerBeginScript

public void registerBeginScript (string $key , string $script )

Registers a javascript script block at the beginning of the form

Input
string | $key | a unique key identifying the script block
string | $script | javascript block
Output
Exception

registerCallbackControl

public void registerCallbackControl (string $class , array $options )

Registers callback javascript for a control.

Input
string | $class | javascript class responsible for the control being registered for callback
array | $options | callback options
Output
Exception

registerDefaultButton

public void registerDefaultButton (TControl|string $panel , TControl|string $button )

Register a default button to panel. When the $panel is in focus and the 'enter' key is pressed, the $button will be clicked.

Input
TControl|string | $panel | panel (or its unique ID) to register the default button action
TControl|string | $button | button (or its unique ID) to trigger a postback
Output
Exception

registerEndScript

public void registerEndScript (string $key , string $script )

Registers a javascript script block at the end of the form

Input
string | $key | a unique key identifying the script block
string | $script | javascript block
Output
Exception

registerFocusControl

public void registerFocusControl (string $target )

Registers the control to receive default focus.

Input
string $target the client ID of the control to receive default focus
Output
Exception

registerHeadScript

public void registerHeadScript (string $key , string $script )

Registers a javascript block in the page head.

Input
string | $key | a unique key identifying the script block
string | $script | javascript block
Output
Exception

registerHeadScriptFile

public void registerHeadScriptFile (string $key , string $url )

Registers a javascript file in the page head

Input
string | $key | a unique key identifying the file
string | $url | URL to the javascript file
Output
Exception

registerHiddenField

public void registerHiddenField (string $name , string|array $value )

Registers a hidden field to be rendered in the form.

Input
string | $name | a unique key identifying the hidden field
string|array | $value | hidden field value, if the value is an array, every element in the array will be rendered as a hidden field value.
Output
Exception

registerJavascriptPackages

public string registerJavascriptPackages (string $base , array $packages , boolean $debug , boolean $gzip )

Publishes a javascript library path and register packages to be loaded.

See TClientScriptLoader for component that enables users to register custom javascript libraries.

Input
string | $base | javascript library base path
array | $packages | list of packages or javascript files (without .js extension) to be loaded.
boolean | $debug | true to enable keep comments in javascript files loaded, null to use application configuration.
boolean | $gzip | true to gzip the javascript code if browsers and php supports it.
Output
string | javascript src url
Exception

registerPostBackControl

public void registerPostBackControl (string $class , array $options )

Registers postback javascript for a control. A null class parameter will prevent the javascript code registration.

Input
string | $class | javascript class responsible for the control being registered for postback
array | $options | postback options
Output
Exception

registerPradoScript

public void registerPradoScript (string $name )

Registers Prado javascript by library name. See "Web/Javascripts/source/packages.php" for library names.

Input
string $name script library name.
Output
Exception

registerScriptFile

public void registerScriptFile (string $key , string $url )

Registers a javascript file to be rendered within the form

Input
string | $key | a unique key identifying the file
string | $url | URL to the javascript file to be rendered
Output
Exception

registerStyleSheet

public void registerStyleSheet (string $key , string $css , mixed $media )

Registers a CSS block to be rendered in the page head

Input
string | $key | a unique key identifying the CSS block
string | $css | CSS block
mixed | $media |
Output
Exception

registerStyleSheetFile

public void registerStyleSheetFile (string $key , string $url , string $media )

Registers a CSS file to be rendered in the page head

The CSS files in themes are registered in OnPreRenderComplete if you want to override CSS styles in themes you need to register it after this event is completed.

Example:

1      <?php
2      class BasePage extends TPage {
3        public function onPreRenderComplete($param) {
4          parent::onPreRenderComplete($param);
5          $url = 'path/to/your/stylesheet.css';
6          $this->Page->ClientScript->registerStyleSheetFile($url, $url);
7        }
8      }
9      ?>

Input
string | $key | a unique key identifying the file
string | $url | URL to the CSS file
string | $media | media type of the CSS (such as 'print', 'screen', etc.). Defaults to empty, meaning the CSS applies to all media types.
Output
Exception

renderBeginScripts

public void renderBeginScripts (THtmlWriter $writer )

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

renderEndScripts

public void renderEndScripts (THtmlWriter $writer )

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

renderHeadScriptFiles

public void renderHeadScriptFiles (THtmlWriter $writer )

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

renderHeadScripts

public void renderHeadScripts (THtmlWriter $writer )

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

renderHiddenFields

public void renderHiddenFields (THtmlWriter $writer )

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

renderPradoScripts

protected void renderPradoScripts (THtmlWriter $writer )

Renders the HTML tags for PRADO js files

Input
THtmlWriter $writer writer
Output
Exception

renderScriptFiles

public void renderScriptFiles (THtmlWriter $writer )

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

renderStyleSheetFiles

public void renderStyleSheetFiles (THtmlWriter $writer )

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

renderStyleSheets

public void renderStyleSheets (THtmlWriter $writer )

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

verifyJavascriptPackages

protected void verifyJavascriptPackages (mixed $base , mixed $path , mixed $scripts )

Input
mixed | $base
mixed | $path
mixed | $scripts
Output
Exception
throws | TConfigurationException when javascript packages mismatch.
Constant Details

SCRIPT_LOADER

the PHP script for loading Prado javascript files

Type:

string

Value:

'Web/Javascripts/clientscripts.php'

SCRIPT_PATH

directory containing Prado javascript files

Type:

string

Value:

'Web/Javascripts/source'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TClientSideOptions

Class TClientSideOptions (Class Overview)

TComponent
   |
   --TClientSideOptions

Direct Known Sub-classes:

TCallbackClientSide , TValidatorClientSide , TColorPickerClientSide , TDatePickerClientScript , TSliderClientScript , TClientSideValidationSummaryOptions

TClientSideOptions abstract class.

TClientSideOptions manages client-side options for components that have common client-side javascript behaviours and client-side events such as between ActiveControls and validators.

Since: 3.0
Author: <weizhuo[at]gmail[dot]com>
Constructor Summary
public
__construct
Constructor, initialize the options list.
Method Summary
protected void
ensureFunction ( mixed $javascript)
Ensure that the javascript statements are wrapped in a javascript function block as

1     function(sender, parameter){ //code }
.
protected string
getOption ( mixed $name)
TMap
getOptions ()
protected void
setFunction ( string $name, string $code)
Adds on client-side event handler by wrapping the code within a javascript function block. If the code begins with "javascript:", the code is assumed to be a javascript function block rather than arbiturary javascript statements.
protected void
setOption ( string $name, mixed $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct

Constructor, initialize the options list.
Method Details

ensureFunction

protected void ensureFunction (mixed $javascript )

Ensure that the javascript statements are wrapped in a javascript function block as

1     function(sender, parameter){ //code }
.

Input
mixed $javascript
Output
Exception

getOption

protected string getOption (mixed $name )

Input
mixed | $name
Output
string | gets a particular option, null if not set.
Exception

getOptions

public TMap getOptions ()

Output
TMap gets the list of options as TMap
Exception

setFunction

protected void setFunction (string $name , string $code )

Adds on client-side event handler by wrapping the code within a javascript function block. If the code begins with "javascript:", the code is assumed to be a javascript function block rather than arbiturary javascript statements.

Input
string | $name | option name
string | $code | javascript statements.
Output
Exception

setOption

protected void setOption (string $name , mixed $value )

Input
string | $name | option name
mixed | $value | option value.
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCompositeControl

Class TCompositeControl (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl

Direct Known Sub-classes:

TTemplateControl

TCompositeControl class.

TCompositeControl is the base class for controls that are composed by other controls.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void
initRecursive ( TControl $namingContainer)
Performs the OnInit step for the control and all its child controls.
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

initRecursive

protected void initRecursive (TControl $namingContainer )

Performs the OnInit step for the control and all its child controls.

This method overrides the parent implementation by ensuring child controls are created first. Only framework developers should use this method.

Input
TControl $namingContainer the naming container control
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IBroadcastEventReceiver

Interface IBroadcastEventReceiver (Class Overview)

IBroadcastEventReceiver interface

If a control wants to check broadcast event, it must implement this interface.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

            Method Summary

                        void

                            broadcastEventReceived
                        (	TControl $sender, 	TBroadCastEventParameter $param)

                            Handles broadcast event.

            Method Details

broadcastEventReceived

                                public void broadcastEventReceived
                                (TControl $sender , TBroadCastEventParameter $param )

Handles broadcast event.

This method is invoked automatically when an event is broadcasted.  Within this method, you may check the event name given in  the event parameter to determine  whether you should respond to  this event.

Input
TControl | $sender | sender of the event
TBroadCastEventParameter | $param | event parameter
Output
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IButtonControl

Interface IButtonControl (Class Overview)

IButtonControl interface

IButtonControl specifies the common properties and events that must  be implemented by a button control, such as TButton, TLinkButton,  TImageButton.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
boolean | getCausesValidation ()
string | getCommandName ()
string | getCommandParameter ()
boolean | getIsDefaultButton ()
string | getText ()
string | getValidationGroup ()
void | onClick ( TEventParameter $param) Raises OnClick event.
void | onCommand ( TCommandEventParameter $param) Raises OnCommand event.
void | setCausesValidation ( boolean $value)
void | setCommandName ( string $value)
void | setCommandParameter ( string $value)
void | setIsDefaultButton ( boolean $value)
void | setText ( string $value)
void | setValidationGroup ( string $value)

            Method Details

getCausesValidation

                                public boolean getCausesValidation
                                ()

Output

                                    boolean
                 whether postback event trigger by this button will cause input validation

Exception

getCommandName

                                public string getCommandName
                                ()

Output

                                    string
                 the command name associated with the OnCommand event.

Exception

getCommandParameter

                                public string getCommandParameter
                                ()

Output

                                    string
                 the parameter associated with the OnCommand event

Exception

getIsDefaultButton

                                public boolean getIsDefaultButton
                                ()

Output

                                    boolean
                 true if this button is registered as a default button for a panel.

Exception

getText

                                public string getText
                                ()

Output

                                    string
                 caption of the button

Exception

getValidationGroup

                                public string getValidationGroup
                                ()

Output

                                    string
                 the group of validators which the button causes validation upon postback

Exception

onClick

                                public void onClick
                                (TEventParameter $param )

Raises OnClick event.

Input

TEventParameter $param event parameter to be passed to the event handlers

Output

Exception

onCommand

                                public void onCommand
                                (TCommandEventParameter $param )

Raises OnCommand event.

Input

TCommandEventParameter $param event parameter to be passed to the event handlers

Output

Exception

setCausesValidation

                                public void setCausesValidation
                                (boolean $value )

Input

boolean $value whether postback event trigger by this button will cause input validation

Output

Exception

setCommandName

                                public void setCommandName
                                (string $value )

Input

string $value the command name associated with the OnCommand event.

Output

Exception

setCommandParameter

                                public void setCommandParameter
                                (string $value )

Input

string $value the parameter associated with the OnCommand event.

Output

Exception

setIsDefaultButton

                                public void setIsDefaultButton
                                (boolean $value )

Input

boolean $value set by a panel to register this button as the default button for the panel.

Output

Exception

setText

                                public void setText
                                (string $value )

Input

string $value caption of the button

Output

Exception

setValidationGroup

                                public void setValidationGroup
                                (string $value )

Input

string $value the group of validators which the button causes validation upon postback

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class INamingContainer

Interface INamingContainer (Class Overview)

INamingContainer interface.

INamingContainer marks a control as a naming container.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IPostBackDataHandler

Interface IPostBackDataHandler (Class Overview)

IPostBackDataHandler interface

If a control wants to load post data, it must implement this interface.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
boolean | getDataChanged ()
boolean | loadPostData ( string $key, array $values) Loads user input data.
void | raisePostDataChangedEvent () Raises postdata changed event.

            Method Details

getDataChanged

                                public boolean getDataChanged
                                ()

Output

                                    boolean
                 whether postback causes the data change. Defaults to false for non-postback state.

Exception

loadPostData

                                public boolean loadPostData
                                (string $key , array $values )

Loads user input data.

The implementation of this function can use $values[$key] to get the user input  data that are meant for the particular control.

Input
string | $key | the key that can be used to retrieve data from the input data collection
array | $values | the input data collection
Output
boolean | whether the data of the control has been changed
Exception

raisePostDataChangedEvent

                                public void raisePostDataChangedEvent
                                ()

Raises postdata changed event.

The implementation of this function should raise appropriate event(s) (e.g. OnTextChanged)  indicating the control data is changed.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IPostBackEventHandler

Interface IPostBackEventHandler (Class Overview)

IPostBackEventHandler interface

If a control wants to respond to postback event, it must implement this interface.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

            Method Summary

                        void

                            raisePostBackEvent
                        (	string $param)

                            Raises postback event.

            Method Details

raisePostBackEvent

                                public void raisePostBackEvent
                                (string $param )

Raises postback event.

The implementation of this function should raise appropriate event(s) (e.g. OnClick, OnCommand)  indicating the component is responsible for the postback event.

Input

string $param the parameter associated with the postback event

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class ISurroundable

Interface ISurroundable (Class Overview)

ISurroundable interface

Identifies controls that may create an additional surrounding tag. The id of the  tag can be obtained with getSurroundingTagID.

            Since:
            3.1.2

            Method Summary

                        string

                            getSurroundingTagID
                        ()

            Method Details

getSurroundingTagID

                                public string getSurroundingTagID
                                ()

Output

                                    string
                 the id of the embedding tag of the control or the control's clientID if not surrounded

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class ITemplate

Interface ITemplate (Class Overview)

ITemplate interface

ITemplate specifies the interface for classes encapsulating  parsed template structures.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

            Method Summary

                        void

                            instantiateIn
                        (	TControl $parent)

                            Instantiates the template.

            Method Details

instantiateIn

                                public void instantiateIn
                                (TControl $parent )

Instantiates the template.

Content in the template will be instantiated as components and text strings  and passed to the specified parent control.

Input

TControl $parent the parent control

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class ITheme

Interface ITheme (Class Overview)

ITheme interface.

This interface must be implemented by theme.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

            Method Summary

                        void

                            applySkin
                        (	TControl $control)

                            Applies this theme to the specified control.

            Method Details

applySkin

                                public void applySkin
                                (TControl $control )

Applies this theme to the specified control.

Input

TControl $control the control to be applied with this theme

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IValidatable

Interface IValidatable (Class Overview)

IValidatable interface

If a control wants to be validated by a validator, it must implement this interface.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
boolean | getIsValid ()
mixed | getValidationPropertyValue ()
boolean | setIsValid ( mixed $value)

            Method Details

getIsValid

                                public boolean getIsValid
                                ()

Output

                                    boolean
                 wether this control's validators validated successfully (must default to true)

Exception

getValidationPropertyValue

                                public mixed getValidationPropertyValue
                                ()

Output

                                    mixed
                 the value of the property to be validated.

Exception

setIsValid

                                public boolean setIsValid
                                (mixed $value )

Input
mixed | $value
Output
boolean | wether this control's validators validated successfully
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IValidator

Interface IValidator (Class Overview)

IValidator interface

If a control wants to validate user input, it must implement this interface.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
string | getErrorMessage ()
boolean | getIsValid ()
void | setErrorMessage ( string $value)
void | setIsValid ( boolean $value)
boolean | validate () Validates certain data.

            Method Details

getErrorMessage

                                public string getErrorMessage
                                ()

Output

                                    string
                 error message during last validate

Exception

getIsValid

                                public boolean getIsValid
                                ()

Output

                                    boolean
                 whether the previous validate() is successful.

Exception

setErrorMessage

                                public void setErrorMessage
                                (string $value )

Input

string $value error message for the validation

Output

Exception

setIsValid

                                public void setIsValid
                                (boolean $value )

Input

boolean $value whether the validator validates successfully

Output

Exception

validate

                                public boolean validate
                                ()

Validates certain data.

The implementation of this function should validate certain data  (e.g. data entered into TTextBox control).

Output

                                    boolean
                 whether the data passes the validation

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TBroadcastEventParameter

Class TBroadcastEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TBroadcastEventParameter

TBroadcastEventParameter class

TBroadcastEventParameter encapsulates the parameter data for events that are broadcasted. The name of of the event is specified via Name property while the event parameter is via Parameter property.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
string | getName ()
mixed | getParameter ()
void | setName ( string $value)
void | setParameter ( mixed $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getName

public string getName ()

Output
string name of the broadcast event
Exception

getParameter

public mixed getParameter ()

Output
mixed parameter of the broadcast event
Exception

setName

public void setName (string $value )

Input
string $value name of the broadcast event
Output
Exception

setParameter

public void setParameter (mixed $value )

Input
mixed $value parameter of the broadcast event
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCommandEventParameter

Class TCommandEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TCommandEventParameter

Direct Known Sub-classes:

TDataGridCommandEventParameter , TDataListCommandEventParameter , TRepeaterCommandEventParameter

TCommandEventParameter class

TCommandEventParameter encapsulates the parameter data for Command event of button controls. You can access the name of the command via CommandName property, and the parameter carried with the command via CommandParameter property.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
string | getCommandName ()
string | getCommandParameter ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getCommandName

public string getCommandName ()

Output
string name of the command
Exception

getCommandParameter

public string getCommandParameter ()

Output
string parameter of the command
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TCompositeLiteral

Class TCompositeLiteral (Class Overview)

TComponent
   |
   --TCompositeLiteral

TCompositeLiteral class

TCompositeLiteral is used internally by TTemplate for representing consecutive static strings, expressions and statements.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void | dataBind () Performs databindings.
void | evaluateDynamicContent () Evaluates the expressions and/or statements in the component.
TComponent | getContainer ()
void | render ( ITextWriter $writer) Renders the content stored in this component.
void | setContainer ( TComponent $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
int | TYPE_DATABINDING
int | TYPE_EXPRESSION
int | TYPE_STATEMENTS
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

dataBind

public void dataBind ()

Performs databindings.

This method is required by IBindable

Output
Exception

evaluateDynamicContent

public void evaluateDynamicContent ()

Evaluates the expressions and/or statements in the component.

Output
Exception

getContainer

public TComponent getContainer ()

Output
TComponent container of this component. It serves as the evaluation context of expressions and statements.
Exception

render

public void render (ITextWriter $writer )

Renders the content stored in this component.

This method is required by IRenderable

Input
ITextWriter $writer
Output
Exception

setContainer

public void setContainer (TComponent $value )

Input
TComponent $value container of this component. It serves as the evaluation context of expressions and statements.
Output
Exception

Constant Details

TYPE_DATABINDING

Type:

int

Value:

2

TYPE_EXPRESSION

Type:

int

Value:

0

TYPE_STATEMENTS

Type:

int

Value:

1


PRADO API Manual: Docs For Class TControl

Class TControl (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl

Direct Known Sub-classes:

TI18NControl , TTranslateParameter , TCallback , TCallbackOptions , TCompositeControl , TForm , TClientScript , TConditional , TContent , TContentPlaceHolder , TDataSourceControl , TExpression , THead , THiddenField , TLiteral , TMultiView , TView , TOutputCache , TPlaceHolder , TRepeaterItem , TSafeHtml , TStatements , TStyleSheet , TWebControl , TWizardNavigationContainer , TXmlTransform

TControl class

TControl is the base class for all components on a page hierarchy. It implements the following features for UI-related functionalities:

  • databinding feature
  • parent and child relationship
  • naming container and containee relationship
  • viewstate and controlstate features
  • rendering scheme
  • control lifecycles
A property can be data-bound with an expression. By calling dataBind, expressions bound to properties will be evaluated and the results will be set to the corresponding properties.

Parent and child relationship determines how the presentation of controls are enclosed within each other. A parent will determine where to place the presentation of its child controls. For example, a TPanel will enclose all its child controls' presentation within a div html tag. A control's parent can be obtained via Parent property, and its Controls property returns a list of the control's children, including controls and static texts. The property can be manipulated like an array for adding or removing a child (see TList for more details).

A naming container control implements INamingContainer and ensures that its containee controls can be differentiated by their ID property values. Naming container and containee realtionship specifies a protocol to uniquely identify an arbitrary control on a page hierarchy by an ID path (concatenation of all naming containers' IDs and the target control's ID).

Viewstate and controlstate are two approaches to preserve state across page postback requests. ViewState is mainly related with UI specific state and can be disabled if not needed. ControlState represents crucial logic state and cannot be disabled.

A control is rendered via its render() method (the method is invoked by the framework.) Descendant control classes may override this method for customized rendering. By default, render() invokes renderChildren() which is responsible for rendering of children of the control. Control's Visible property governs whether the control should be rendered or not.

Each control on a page will undergo a series of lifecycles, including control construction, Init, Load, PreRender, Render, and OnUnload. They work together with page lifecycles to process a page request.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct
Constructor.
Method Summary
void | addedControl ( TControl $control) Adds a control into the child collection of the control.
void | addParsedObject ( string|TComponent $object) Adds the object instantiated on a template to the child control collection.
protected void | addToPostDataLoader () Add controls implementing IPostBackDataHandler to post data loaders.
void | applyStyleSheetSkin ( TPage $page) Applies a stylesheet skin to a control.
void | autoBindProperty ( string $name, string $expression) Sets up the binding between a property (or property path) and an expression.
protected void | autoDataBindProperties () Auto databinding properties of the control.
void | bindProperty ( string $name, string $expression) Sets up the binding between a property (or property path) and an expression.
void | broadcastEvent ( string $name, TControl $sender, TEventParameter $param) Broadcasts an event.
boolean | bubbleEvent ( TControl $sender, TEventParameter $param) This method responds to a bubbled event.
protected void | clearChildState () Clears up the child state data.
protected void | clearControlState ( string $key) Clears a controlstate value.
void | clearNamingContainer () Resets the control as a naming container.
void | clearViewState ( string $key) Clears a viewstate value.
string | convertUniqueIdToClientId ( string $uniqueID) Converts a unique ID to a client ID.
void | createChildControls () Creates child controls.
protected TControlCollection | createControlCollection () Creates a control collection object that is to be used to hold child controls
void | dataBind () Performs the databinding for this control.
protected void | dataBindChildren () Databinding child controls.
protected void | dataBindProperties () Databinding properties of the control.
void | ensureChildControls () Ensures child controls are created.
TControl|null | findControl ( string $id) Finds a control by ID path within the current naming container.
array | findControlsByID ( string $id) Finds all child and grand-child controls with the specified ID.
array | findControlsByType ( string $type, boolean $strict) Finds all child and grand-child controls that are of the specified type.
void | focus () Sets input focus to this control.
TControlAdapter | getAdapter ()
boolean | getAllowChildControls ()
string | getAttribute ( mixed $name)
TAttributeCollection | getAttributes () Returns the list of custom attributes.
protected boolean | getChildControlsCreated ()
string | getClientID () Returns the client ID of the control.
TControlCollection | getControls ()
protected integer | getControlStage () Gets the lifecycle step the control is currently at.
protected mixed | getControlState ( string $key, mixed $defaultValue) Returns a controlstate value.
mixed | getCustomData () Returns custom data associated with this control.
boolean | getEnabled ( boolean $checkParents) Returns a value indicating whether the control is enabled.
boolean | getEnableTheming ()
boolean | getEnableViewState ( mixed $checkParents)
boolean | getHasAdapter ()
boolean | getHasAttributes ()
boolean | getHasChildInitialized ()
boolean | getHasControls ()
boolean | getHasInitialized ()
boolean | getHasLoaded ()
boolean | getHasLoadedPostData ()
boolean | getHasPreRendered ()
string | getID ( boolean $hideAutoID) Returns the id of the control.
TControl | getNamingContainer ()
TPage | getPage ()
TControl | getParent ()
mixed | getRegisteredObject ( mixed $name) Returns the named registered object.
string | getSkinID ()
TTemplateControl | getSourceTemplateControl ()
TTemplateControl | getTemplateControl ()
string | getUniqueID () Returns a unique ID that identifies the control in the page hierarchy.
mixed | getViewState ( string $key, mixed $defaultValue) Returns a viewstate value.
boolean | getVisible ( boolean $checkParents) Checks if a control is visible.
boolean | hasAttribute ( mixed $name)
protected void | initRecursive ( TControl $namingContainer) Performs the Init step for the control and all its child controls.
protected boolean | isDescendentOf ( TControl $ancestor)
boolean | isObjectRegistered ( mixed $name)
protected void | loadRecursive () Performs the Load step for the control and all its child controls.
void | loadState () This method is invoked right after the control has loaded its state.
protected void | loadStateRecursive ( array &$state, boolean $needViewState) Loads state (viewstate and controlstate) into a control and its children.
void | onDataBinding ( TEventParameter $param) Raises 'OnDataBinding' event.
void | onInit ( TEventParameter $param) This method is invoked when the control enters 'OnInit' stage.
void | onLoad ( TEventParameter $param) This method is invoked when the control enters 'OnLoad' stage.
void | onPreRender ( TEventParameter $param) This method is invoked when the control enters 'OnPreRender' stage.
void | onUnload ( TEventParameter $param) This method is invoked when the control enters 'OnUnload' stage.
protected void | preRenderRecursive () Performs the PreRender step for the control and all its child controls.
protected void | raiseBubbleEvent ( TControl $sender, TEventParameter $param) Invokes the parent's bubbleEvent method.
void | registerObject ( string $name, object object $object) Registers an object by a name.
string | removeAttribute ( string $name) Removes the named attribute.
void | removedControl ( TControl $control) Removes a control from the child collection of the control.
void | render ( THtmlWriter $writer) Renders the control.
void | renderChildren ( THtmlWriter $writer) Renders the children of the control.
void | renderControl ( THtmlWriter $writer) Renders the control.
void | saveState () This method is invoked when control state is to be saved.
protected array | saveStateRecursive ( boolean $needViewState) Saves all control state (viewstate and controlstate) as a collection.
void | setAdapter ( TControlAdapter $adapter)
void | setAttribute ( string $name, string $value) Sets a custom control attribute.
protected void | setChildControlsCreated ( boolean $value) Sets a value indicating whether child controls are created.
protected void | setControlStage ( integer $value) Sets the lifecycle step the control is currently at.
protected void | setControlState ( string $key, mixed $value, mixed $defaultValue) Sets a controlstate value.
void | setCustomData ( mixed $value) Associates custom data with this control.
void | setEnabled ( boolean $value)
void | setEnableTheming ( boolean $value)
void | setEnableViewState ( boolean $value)
void | setID ( string $id)
void | setPage ( TPage $page) Sets the page for a control.
void | setSkinID ( string $value)
void | setTemplateControl ( TTemplateControl $control) Sets the control whose template contains this control.
void | setViewState ( string $key, mixed $value, mixed $defaultValue) Sets a viewstate value.
void | setVisible ( boolean $value)
void | trackViewState ( boolean $enabled) Sets a value indicating whether we should keep data in viewstate.
protected void | traverseChildControls ( mixed $param, callback $preCallback, callback $postCallback) Traverse the whole control hierarchy rooted at this control.
void | unbindProperty ( string $name) Breaks the binding between a property (or property path) and an expression.
protected void | unloadRecursive () Performs the Unload step for the control and all its child controls.
void | unregisterObject ( string $name) Unregisters an object by name.
mixed | __get ( string $name) Returns a property value by name or a control by ID.
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | AUTOMATIC_ID_PREFIX | prefix to an ID automatically generated
string | CLIENT_ID_SEPARATOR | separator char between IDs in a ClientID
int | CS_CHILD_INITIALIZED |
int | CS_CONSTRUCTED | the stage of lifecycles that the control is currently at
int | CS_INITIALIZED |
int | CS_LOADED |
int | CS_PRERENDERED |
int | CS_STATE_LOADED |
string | ID_FORMAT | format of control ID
string | ID_SEPARATOR | separator char between IDs in a UniqueID
int | IS_CHILD_CREATED |
int | IS_CREATING_CHILD |
int | IS_DISABLE_THEMING |
int | IS_DISABLE_VIEWSTATE |
int | IS_ID_SET | State bits.
int | IS_SKIN_APPLIED |
int | IS_STYLESHEET_APPLIED |
int | RF_ADAPTER |
int | RF_AUTO_BINDINGS |
int | RF_CHILD_STATE |
int | RF_CONTROLS | Indexes for the rare fields. In order to save memory, rare fields will only be created if they are needed.
int | RF_CONTROLSTATE |
int | RF_DATA_BINDINGS |
int | RF_EVENTS |
int | RF_NAMED_CONTROLS |
int | RF_NAMED_CONTROLS_ID |
int | RF_NAMED_OBJECTS |
int | RF_SKIN_ID |
Constructor Details

__construct

public __construct

Constructor.
Method Details

addedControl

public void addedControl (TControl $control )

Adds a control into the child collection of the control.

Control lifecycles will be caught up during the addition. Only framework developers should use this method.

Input
TControl $control the new child control
Output
Exception

addParsedObject

public void addParsedObject (string|TComponent $object )

Adds the object instantiated on a template to the child control collection.

This method overrides the parent implementation. Only framework developers and control developers should use this method.

Input
string|TComponent $object text string or component parsed and instantiated in template
Output
Exception

addToPostDataLoader

protected void addToPostDataLoader ()

Add controls implementing IPostBackDataHandler to post data loaders.

Output
Exception

applyStyleSheetSkin

public void applyStyleSheetSkin (TPage $page )

Applies a stylesheet skin to a control.

Input
TPage | $page | the page containing the control
Output
Exception
throws | TInvalidOperationException if the stylesheet skin is applied already

autoBindProperty

public void autoBindProperty (string $name , string $expression )

Sets up the binding between a property (or property path) and an expression.

Unlike regular databinding, the expression bound by this method is automatically evaluated during prerenderRecursive(). The context of the expression is the template control (or the control itself if it is a page).

Input
string | $name | the property name, or property path
string | $expression | the expression
Output
Exception

autoDataBindProperties

protected void autoDataBindProperties ()

Auto databinding properties of the control.

Output
Exception

bindProperty

public void bindProperty (string $name , string $expression )

Sets up the binding between a property (or property path) and an expression.

The context of the expression is the template control (or the control itself if it is a page).

Input
string | $name | the property name, or property path
string | $expression | the expression
Output
Exception

broadcastEvent

public void broadcastEvent (string $name , TControl $sender , TEventParameter $param )

Broadcasts an event.

The event will be sent to all controls on the current page hierarchy. If a control defines the event, the event will be raised for the control. If a control implements IBroadcastEventReceiver, its IBroadcastEventReceiver::broadcastEventReceived method will be invoked which gives the control a chance to respond to the event. For example, when broadcasting event 'OnClick', all controls having 'OnClick' event will have this event raised, and all controls implementing IBroadcastEventReceiver will also have its IBroadcastEventReceiver::broadcastEventReceived invoked.

Input
string | $name | name of the broadcast event
TControl | $sender | sender of this event
TEventParameter | $param | event parameter
Output
Exception

bubbleEvent

public boolean bubbleEvent (TControl $sender , TEventParameter $param )

This method responds to a bubbled event.

This method should be overriden to provide customized response to a bubbled event. Check the type of event parameter to determine what event is bubbled currently.

Input
TControl | $sender | sender of the event
TEventParameter | $param | event parameters
Output
boolean | true if the event bubbling is handled and no more bubbling.
Exception

clearChildState

protected void clearChildState ()

Clears up the child state data.

After a control loads its state, those state that do not belong to any existing child controls are stored as child state. This method will remove these state. Only frameworker developers and control developers should use this method.

Output
Exception

clearControlState

protected void clearControlState (string $key )

Clears a controlstate value.

Input
string $key the name of the controlstate value to be cleared
Output
Exception

clearNamingContainer

public void clearNamingContainer ()

Resets the control as a naming container.

Only framework developers should use this method.

Output
Exception

clearViewState

public void clearViewState (string $key )

Clears a viewstate value.

Input
string $key the name of the viewstate value to be cleared
Output
Exception

convertUniqueIdToClientId

public string convertUniqueIdToClientId (string $uniqueID )

Converts a unique ID to a client ID.

Input
string | $uniqueID | the unique ID of a control
Output
string | the client ID of the control
Exception

createChildControls

public void createChildControls ()

Creates child controls.

This method can be overriden for controls who want to have their controls. Do not call this method directly. Instead, call ensureChildControls to ensure child controls are created only once.

Output
Exception

createControlCollection

protected TControlCollection createControlCollection ()

Creates a control collection object that is to be used to hold child controls

Output
TControlCollection control collection
Exception

dataBind

public void dataBind ()

Performs the databinding for this control.

Output
Exception

dataBindChildren

protected void dataBindChildren ()

Databinding child controls.

Output
Exception

dataBindProperties

protected void dataBindProperties ()

Databinding properties of the control.

Output
Exception

ensureChildControls

public void ensureChildControls ()

Ensures child controls are created.

If child controls are not created yet, this method will invoke createChildControls to create them.

Output
Exception

findControl

public TControl|null findControl (string $id )

Finds a control by ID path within the current naming container.

The current naming container is either the control itself if it implements INamingContainer or the control's naming container. The ID path is an ID sequence separated by TControl::ID_SEPARATOR. For example, 'Repeater1.Item1.Button1' looks for a control with ID 'Button1' whose naming container is 'Item1' whose naming container is 'Repeater1'.

Input
string | $id | ID of the control to be looked up
Output
TControl|null | the control found, null if not found
Exception
throws | TInvalidDataValueException if a control's ID is found not unique within its naming container.

findControlsByID

public array findControlsByID (string $id )

Finds all child and grand-child controls with the specified ID.

Note, this method is different from findControl in that it searches through all controls that have this control as the ancestor while findcontrol only searches through controls that have this control as the direct naming container.

Input
string | $id | the ID being looked for
Output
array | list of controls found
Exception

findControlsByType

public array findControlsByType (string $type , boolean $strict )

Finds all child and grand-child controls that are of the specified type.

Input
string | $type | the class name
boolean | $strict | whether the type comparison is strict or not. If false, controls of the parent classes of the specified class will also be returned.
Output
array | list of controls found
Exception

focus

public void focus ()

Sets input focus to this control.

Output
Exception

getAdapter

public TControlAdapter getAdapter ()

Output
TControlAdapter control adapter. Null if not exists.
Exception

getAllowChildControls

public boolean getAllowChildControls ()

Output
boolean whether body contents are allowed for this control. Defaults to true.
Exception

getAttribute

public string getAttribute (mixed $name )

Input
mixed | $name
Output
string | attribute value, null if attribute does not exist
Exception

getAttributes

public TAttributeCollection getAttributes ()

Returns the list of custom attributes.

Custom attributes are name-value pairs that may be rendered as HTML tags' attributes.

Output
TAttributeCollection the list of custom attributes
Exception

getChildControlsCreated

protected boolean getChildControlsCreated ()

Output
boolean whether child controls have been created
Exception

getClientID

public string getClientID ()

Returns the client ID of the control.

The client ID can be used to uniquely identify the control in client-side scripts (such as JavaScript). Do not rely on the explicit format of the return ID.

Output
string the client ID of the control
Exception

getControls

public TControlCollection getControls ()

Output
TControlCollection the child control collection
Exception

getControlStage

protected integer getControlStage ()

Gets the lifecycle step the control is currently at.

This method should only be used by control developers.

Output
integer the lifecycle step the control is currently at. The value can be CS_CONSTRUCTED, CS_CHILD_INITIALIZED, CS_INITIALIZED, CS_STATE_LOADED, CS_LOADED, CS_PRERENDERED.
Exception

getControlState

protected mixed getControlState (string $key , mixed $defaultValue )

Returns a controlstate value.

This function is mainly used in defining getter functions for control properties that must be kept in controlstate.

Input
string | $key | the name of the controlstate value to be returned
mixed | $defaultValue | the default value. If $key is not found in controlstate, $defaultValue will be returned
Output
mixed | the controlstate value corresponding to $key
Exception

getCustomData

public mixed getCustomData ()

Returns custom data associated with this control.

A control may be associated with some custom data for various purposes. For example, a button may be associated with a string to identify itself in a generic OnClick event handler.

Output
mixed custom data associated with this control. Defaults to null.
Exception

getEnabled

public boolean getEnabled (boolean $checkParents )

Returns a value indicating whether the control is enabled.

A control is enabled if it allows client user interaction. If $checkParents is true, all parent controls will be checked, and unless they are all enabled, false will be returned. The property Enabled is mainly used for TWebControl derived controls.

Input
boolean | $checkParents | whether the parents should also be checked enabled
Output
boolean | whether the control is enabled.
Exception

getEnableTheming

public boolean getEnableTheming ()

Output
boolean whether theming is enabled for this control. The theming is enabled if the control and all its parents have it enabled.
Exception

getEnableViewState

public boolean getEnableViewState (mixed $checkParents )

Input
mixed | $checkParents
Output
boolean | whether viewstate is enabled
Exception

getHasAdapter

public boolean getHasAdapter ()

Output
boolean whether there is an adapter for this control
Exception

getHasAttributes

public boolean getHasAttributes ()

Output
boolean whether the control has custom attributes
Exception

getHasChildInitialized

public boolean getHasChildInitialized ()

Output
boolean true if the child control has been initialized.
Exception

getHasControls

public boolean getHasControls ()

Output
boolean whether the control has child controls
Exception

getHasInitialized

public boolean getHasInitialized ()

Output
boolean true if the onInit event has raised.
Exception

getHasLoaded

public boolean getHasLoaded ()

Output
boolean true if the onLoad event has raised.
Exception

getHasLoadedPostData

public boolean getHasLoadedPostData ()

Output
boolean true if the control has loaded post data.
Exception

getHasPreRendered

public boolean getHasPreRendered ()

Output
boolean true if onPreRender event has raised.
Exception

getID

public string getID (boolean $hideAutoID )

Returns the id of the control.

Control ID can be either manually set or automatically generated. If $hideAutoID is true, automatically generated ID will be returned as an empty string.

Input
boolean | $hideAutoID | whether to hide automatically generated ID
Output
string | the ID of the control
Exception

getNamingContainer

public TControl getNamingContainer ()

Output
TControl the naming container of this control
Exception

getPage

public TPage getPage ()

Output
TPage the page that contains this control
Exception

getParent

public TControl getParent ()

Output
TControl the parent of this control
Exception

getRegisteredObject

public mixed getRegisteredObject (mixed $name )

Returns the named registered object.

A component with explicit ID on a template will be registered to the template owner. This method allows you to obtain this component with the ID.

Input
mixed | $name
Output
mixed | the named registered object. Null if object is not found.
Exception

getSkinID

public string getSkinID ()

Output
string the skin ID of this control, '' if not set
Exception

getSourceTemplateControl

public TTemplateControl getSourceTemplateControl ()

Output
TTemplateControl the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control.
Exception

getTemplateControl

public TTemplateControl getTemplateControl ()

Output
TTemplateControl the control whose template contains this control
Exception

getUniqueID

public string getUniqueID ()

Returns a unique ID that identifies the control in the page hierarchy.

A unique ID is the contenation of all naming container controls' IDs and the control ID. These IDs are separated by '$' character. Control users should not rely on the specific format of UniqueID, however.

Output
string a unique ID that identifies the control in the page hierarchy
Exception

getViewState

public mixed getViewState (string $key , mixed $defaultValue )

Returns a viewstate value.

This function is very useful in defining getter functions for component properties that must be kept in viewstate.

Input
string | $key | the name of the viewstate value to be returned
mixed | $defaultValue | the default value. If $key is not found in viewstate, $defaultValue will be returned
Output
mixed | the viewstate value corresponding to $key
Exception

getVisible

public boolean getVisible (boolean $checkParents )

Checks if a control is visible.

If parent check is required, then a control is visible only if the control and all its ancestors are visible.

Input
boolean | $checkParents | whether the parents should also be checked if visible
Output
boolean | whether the control is visible (default=true).
Exception

hasAttribute

public boolean hasAttribute (mixed $name )

Input
mixed | $name
Output
boolean | whether the named attribute exists
Exception

initRecursive

protected void initRecursive (TControl $namingContainer )

Performs the Init step for the control and all its child controls.

Only framework developers should use this method.

Input
TControl $namingContainer the naming container control
Output
Exception

isDescendentOf

protected boolean isDescendentOf (TControl $ancestor )

Input
TControl | $ancestor | the potential ancestor control
Output
boolean | if the control is a descendent (parent, parent of parent, etc.) of the specified control
Exception

isObjectRegistered

public boolean isObjectRegistered (mixed $name )

Input
mixed | $name
Output
boolean | whether an object has been registered with the name
Exception

loadRecursive

protected void loadRecursive ()

Performs the Load step for the control and all its child controls.

Only framework developers should use this method.

Output
Exception

loadState

public void loadState ()

This method is invoked right after the control has loaded its state.

You can override this method to initialize data from the control state. Parent implementation must be invoked.

Output
Exception

loadStateRecursive

protected void loadStateRecursive (array &$state , boolean $needViewState )

Loads state (viewstate and controlstate) into a control and its children.

This method should only be used by framework developers.

Input
array | &$state | the collection of the state
boolean | $needViewState | whether the viewstate should be loaded
Output
Exception

onDataBinding

public void onDataBinding (TEventParameter $param )

Raises 'OnDataBinding' event.

This method is invoked when dataBind is invoked.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onInit

public void onInit (TEventParameter $param )

This method is invoked when the control enters 'OnInit' stage.

The method raises 'OnInit' event. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onLoad

public void onLoad (TEventParameter $param )

This method is invoked when the control enters 'OnLoad' stage.

The method raises 'OnLoad' event. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onPreRender

public void onPreRender (TEventParameter $param )

This method is invoked when the control enters 'OnPreRender' stage.

The method raises 'OnPreRender' event. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onUnload

public void onUnload (TEventParameter $param )

This method is invoked when the control enters 'OnUnload' stage.

The method raises 'OnUnload' event. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

preRenderRecursive

protected void preRenderRecursive ()

Performs the PreRender step for the control and all its child controls.

Only framework developers should use this method.

Output
Exception

raiseBubbleEvent

protected void raiseBubbleEvent (TControl $sender , TEventParameter $param )

Invokes the parent's bubbleEvent method.

A control who wants to bubble an event must call this method in its onEvent method.

Input
TControl | $sender | sender of the event
TEventParameter | $param | event parameter
Output
Exception

registerObject

public void registerObject (string $name , object object $object )

Registers an object by a name.

A registered object can be accessed like a public member variable. This method should only be used by framework and control developers.

Input
string | $name | name of the object
object object | $object | to be declared
Output
Exception

removeAttribute

public string removeAttribute (string $name )

Removes the named attribute.

Input
string | $name | the name of the attribute to be removed.
Output
string | attribute value removed, null if attribute does not exist.
Exception

removedControl

public void removedControl (TControl $control )

Removes a control from the child collection of the control.

Only framework developers should use this method.

Input
TControl $control the child control removed
Output
Exception

render

public void render (THtmlWriter $writer )

Renders the control.

This method is invoked by renderControl when the control is visible. You can override this method to provide customized rendering of the control. By default, the control simply renders all its child contents.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderChildren

public void renderChildren (THtmlWriter $writer )

Renders the children of the control.

This method iterates through all child controls and static text strings and renders them in order.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

renderControl

public void renderControl (THtmlWriter $writer )

Renders the control.

Only when the control is visible will the control be rendered.

Input
THtmlWriter $writer the writer used for the rendering purpose
Output
Exception

saveState

public void saveState ()

This method is invoked when control state is to be saved.

You can override this method to do last step state saving. Parent implementation must be invoked.

Output
Exception

saveStateRecursive

protected array saveStateRecursive (boolean $needViewState )

Saves all control state (viewstate and controlstate) as a collection.

This method should only be used by framework developers.

Input
boolean | $needViewState | whether the viewstate should be saved
Output
array | the collection of the control state (including its children's state).
Exception

setAdapter

public void setAdapter (TControlAdapter $adapter )

Input
TControlAdapter $adapter control adapter
Output
Exception

setAttribute

public void setAttribute (string $name , string $value )

Sets a custom control attribute.

Input
string | $name | attribute name
string | $value | value of the attribute
Output
Exception

setChildControlsCreated

protected void setChildControlsCreated (boolean $value )

Sets a value indicating whether child controls are created.

If false, any existing child controls will be cleared up.

Input
boolean $value whether child controls are created
Output
Exception

setControlStage

protected void setControlStage (integer $value )

Sets the lifecycle step the control is currently at.

This method should only be used by control developers.

Input
integer $value the lifecycle step the control is currently at. Valid values include CS_CONSTRUCTED, CS_CHILD_INITIALIZED, CS_INITIALIZED, CS_STATE_LOADED, CS_LOADED, CS_PRERENDERED.
Output
Exception

setControlState

protected void setControlState (string $key , mixed $value , mixed $defaultValue )

Sets a controlstate value.

This function is very useful in defining setter functions for control properties that must be kept in controlstate. Make sure that the controlstate value must be serializable and unserializable.

Input
string | $key | the name of the controlstate value
mixed | $value | the controlstate value to be set
mixed | $defaultValue | default value. If $value===$defaultValue, the item will be cleared from controlstate
Output
Exception

setCustomData

public void setCustomData (mixed $value )

Associates custom data with this control.

Note, the custom data must be serializable and unserializable.

Input
mixed $value custom data
Output
Exception

setEnabled

public void setEnabled (boolean $value )

Input
boolean $value whether the control is to be enabled.
Output
Exception

setEnableTheming

public void setEnableTheming (boolean $value )

Input
boolean | $value | whether to enable theming
Output
Exception
throws | TInvalidOperationException if this method is invoked after OnPreInit

setEnableViewState

public void setEnableViewState (boolean $value )

Input
boolean $value set whether to enable viewstate
Output
Exception

setID

public void setID (string $id )

Input
string | $id | the new control ID. The value must consist of word characters [a-zA-Z0-9_] only
Output
Exception
throws | TInvalidDataValueException if ID is in a bad format

setPage

public void setPage (TPage $page )

Sets the page for a control.

Only framework developers should use this method.

Input
TPage $page the page that contains this control
Output
Exception

setSkinID

public void setSkinID (string $value )

Input
string | $value | the skin ID of this control
Output
Exception
throws | TInvalidOperationException if the SkinID is set in a stage later than PreInit, or if the skin is applied already.

setTemplateControl

public void setTemplateControl (TTemplateControl $control )

Sets the control whose template contains this control.

Only framework developers should use this method.

Input
TTemplateControl $control the control whose template contains this control
Output
Exception

setViewState

public void setViewState (string $key , mixed $value , mixed $defaultValue )

Sets a viewstate value.

This function is very useful in defining setter functions for control properties that must be kept in viewstate. Make sure that the viewstate value must be serializable and unserializable.

Input
string | $key | the name of the viewstate value
mixed | $value | the viewstate value to be set
mixed | $defaultValue | default value. If $value===$defaultValue, the item will be cleared from the viewstate.
Output
Exception

setVisible

public void setVisible (boolean $value )

Input
boolean $value whether the control is visible
Output
Exception

trackViewState

public void trackViewState (boolean $enabled )

Sets a value indicating whether we should keep data in viewstate.

When it is false, data saved via setViewState() will not be persisted. By default, it is true, meaning data will be persisted across postbacks.

Input
boolean $enabled whether data should be persisted
Output
Exception

traverseChildControls

protected void traverseChildControls (mixed $param , callback $preCallback , callback $postCallback )

Traverse the whole control hierarchy rooted at this control.

Callback function may be invoked for each control being visited. A pre-callback is invoked before traversing child controls; A post-callback is invoked after traversing child controls. Callback functions can be global functions or class methods. They must be of the following signature:

1      function callback_func($control,$param) {...}
where $control refers to the control being visited and $param is the parameter that is passed originally when calling this traverse function.

Input
mixed | $param | parameter to be passed to callbacks for each control
callback | $preCallback | callback invoked before traversing child controls. If null, it is ignored.
callback | $postCallback | callback invoked after traversing child controls. If null, it is ignored.
Output
Exception

unbindProperty

public void unbindProperty (string $name )

Breaks the binding between a property (or property path) and an expression.

Input
string $name the property name (or property path)
Output
Exception

unloadRecursive

protected void unloadRecursive ()

Performs the Unload step for the control and all its child controls.

Only framework developers should use this method.

Output
Exception

unregisterObject

public void unregisterObject (string $name )

Unregisters an object by name.

Input
string $name name of the object
Output
Exception

__get

public mixed __get (string $name )

Returns a property value by name or a control by ID.

This overrides the parent implementation by allowing accessing a control via its ID using the following syntax,

1      $menuBar=$this->menuBar;
Note, the control must be configured in the template with explicit ID. If the name matches both a property and a control ID, the control ID will take the precedence.

Input
string | $name | the property name or control ID
Output
mixed | the property value or the target control
Exception
throws | TInvalidOperationException if the property is not defined.
Constant Details

AUTOMATIC_ID_PREFIX

prefix to an ID automatically generated

Type:

string

Value:

'ctl'

CLIENT_ID_SEPARATOR

separator char between IDs in a ClientID

Type:

string

Value:

'_'

CS_CHILD_INITIALIZED

Type:

int

Value:

1

CS_CONSTRUCTED

the stage of lifecycles that the control is currently at

Type:

int

Value:

0

CS_INITIALIZED

Type:

int

Value:

2

CS_LOADED

Type:

int

Value:

4

CS_PRERENDERED

Type:

int

Value:

5

CS_STATE_LOADED

Type:

int

Value:

3

ID_FORMAT

format of control ID

Type:

string

Value:

'/^[a-zA-Z_]\\w*$/'

ID_SEPARATOR

separator char between IDs in a UniqueID

Type:

string

Value:

'$'

IS_CHILD_CREATED

Type:

int

Value:

0x20

IS_CREATING_CHILD

Type:

int

Value:

0x40

IS_DISABLE_THEMING

Type:

int

Value:

0x10

IS_DISABLE_VIEWSTATE

Type:

int

Value:

0x02

IS_ID_SET

State bits.

Type:

int

Value:

0x01

IS_SKIN_APPLIED

Type:

int

Value:

0x04

IS_STYLESHEET_APPLIED

Type:

int

Value:

0x08

RF_ADAPTER

Type:

int

Value:

9

RF_AUTO_BINDINGS

Type:

int

Value:

10

RF_CHILD_STATE

Type:

int

Value:

1

RF_CONTROLS

Indexes for the rare fields.

In order to save memory, rare fields will only be created if they are needed.

Type:

int

Value:

0

RF_CONTROLSTATE

Type:

int

Value:

7

RF_DATA_BINDINGS

Type:

int

Value:

5

RF_EVENTS

Type:

int

Value:

6

RF_NAMED_CONTROLS

Type:

int

Value:

2

RF_NAMED_CONTROLS_ID

Type:

int

Value:

3

RF_NAMED_OBJECTS

Type:

int

Value:

8

RF_SKIN_ID

Type:

int

Value:

4


PRADO API Manual: Docs For Class TControlCollection

Class TControlCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TControlCollection

Direct Known Sub-classes:

TEmptyControlCollection , TViewCollection , TTableRowCollection , TTableCellCollection , TTabViewCollection

TControlCollection class

TControlCollection implements a collection that enables controls to maintain a list of their child controls.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void | clear () Overrides the parent implementation by invoking TControl::clearNamingContainer
protected TControl | getOwner ()
void | insertAt ( integer $index, mixed $item) Inserts an item at the specified position.
mixed | removeAt ( integer $index) Removes an item at the specified position.
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

clear

public void clear ()

Overrides the parent implementation by invoking TControl::clearNamingContainer

Output
Exception

getOwner

protected TControl getOwner ()

Output
TControl the control that owns this collection.
Exception

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by performing additional operations for each newly added child control.

Input
integer | $index | the speicified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is neither a string nor a TControl.

removeAt

public mixed removeAt (integer $index )

Removes an item at the specified position.

This overrides the parent implementation by performing additional cleanup work when removing a child control.

Input
integer | $index | the index of the item to be removed.
Output
mixed | the removed item.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TEmptyControlCollection

Class TEmptyControlCollection (Class Overview)

TComponent
   |
   --TList
      |
      --TControlCollection
         |
         --TEmptyControlCollection

TEmptyControlCollection class

TEmptyControlCollection implements an empty control list that prohibits adding controls to it. This is useful for controls that do not allow child controls.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void
insertAt ( integer $index, mixed $item)
Inserts an item at the specified position.
Methods Inherited From TControlCollection
TControlCollection::clear(), TControlCollection::getOwner(), TControlCollection::insertAt(), TControlCollection::removeAt()
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by ignoring new addition.

Input
integer | $index | the speicified position.
mixed | $item | new item
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TControlAdapter

Class TControlAdapter (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControlAdapter

Direct Known Sub-classes:

TActiveControlAdapter , TActivePageAdapter , TWebControlAdapter

TControlAdapter class

TControlAdapter is the base class for adapters that customize various behaviors for the control to which the adapter is attached.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void | createChildControls () Creates child controls for the attached control.
TControl | getControl ()
TPage | getPage ()
void | loadState () Loads additional persistent control state.
void | onInit ( TEventParameter $param) This method is invoked when the control enters 'OnInit' stage.
void | onLoad ( TEventParameter $param) This method is invoked when the control enters 'OnLoad' stage.
void | onPreRender ( TEventParameter $param) This method is invoked when the control enters 'OnPreRender' stage.
void | onUnload ( TEventParameter $param) This method is invoked when the control enters 'OnUnload' stage.
void | render ( THtmlWriter $writer) This method is invoked when the control renders itself.
void | renderChildren ( THtmlWriter $writer) Renders the control's children.
void | saveState () Saves additional persistent control state.
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

createChildControls

public void createChildControls ()

Creates child controls for the attached control.

Default implementation calls the attached control's corresponding method.

Output
Exception

getControl

public TControl getControl ()

Output
TControl the control to which this adapter is attached
Exception

getPage

public TPage getPage ()

Output
TPage the page that contains the attached control
Exception

loadState

public void loadState ()

Loads additional persistent control state.

Default implementation calls the attached control's corresponding method.

Output
Exception

onInit

public void onInit (TEventParameter $param )

This method is invoked when the control enters 'OnInit' stage.

Default implementation calls the attached control's corresponding method.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onLoad

public void onLoad (TEventParameter $param )

This method is invoked when the control enters 'OnLoad' stage.

Default implementation calls the attached control's corresponding method.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onPreRender

public void onPreRender (TEventParameter $param )

This method is invoked when the control enters 'OnPreRender' stage.

Default implementation calls the attached control's corresponding method.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

onUnload

public void onUnload (TEventParameter $param )

This method is invoked when the control enters 'OnUnload' stage.

Default implementation calls the attached control's corresponding method.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

render

public void render (THtmlWriter $writer )

This method is invoked when the control renders itself.

Default implementation calls the attached control's corresponding method.

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

renderChildren

public void renderChildren (THtmlWriter $writer )

Renders the control's children.

Default implementation calls the attached control's corresponding method.

Input
THtmlWriter $writer writer for the rendering purpose
Output
Exception

saveState

public void saveState ()

Saves additional persistent control state.

Default implementation calls the attached control's corresponding method.

Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TForm

Class TForm (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TForm

TForm class

TForm displays an HTML form. Besides regular body content, it displays hidden fields, javascript blocks and files that are registered through TClientScriptManager.

A TForm is required for a page that needs postback. Each page can contain at most one TForm. If multiple HTML forms are needed, please use regular HTML form tags for those forms that post to different URLs.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | addAttributesToRender ( THtmlWriter $writer) Adds form specific attributes to renderer.
string | getDefaultButton ()
string | getEnctype ()
string | getMethod ()
string | getName ()
void | onInit ( mixed $param) Registers the form with the page.
void | render ( THtmlWriter $writer) Renders the form.
void | setDefaultButton ( string $value) Sets a button to be default one in a form.
void | setEnctype ( string $value)
void | setMethod ( string $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addAttributesToRender

protected void addAttributesToRender (THtmlWriter $writer )

Adds form specific attributes to renderer.

Input
THtmlWriter $writer writer
Output
Exception

getDefaultButton

public string getDefaultButton ()

Output
string id path to the default button control.
Exception

getEnctype

public string getEnctype ()

Output
string the encoding type a browser uses to post data back to the server
Exception

getMethod

public string getMethod ()

Output
string form submission method. Defaults to 'post'.
Exception

getName

public string getName ()

Output
string form name, which is equal to UniqueID.
Exception

onInit

public void onInit (mixed $param )

Registers the form with the page.

Input
mixed $param event parameter
Output
Exception

render

public void render (THtmlWriter $writer )

Renders the form.

Input
THtmlWriter $writer writer
Output
Exception

setDefaultButton

public void setDefaultButton (string $value )

Sets a button to be default one in a form.

A default button will be clicked if a user presses 'Enter' key within the form.

Input
string $value id path to the default button control.
Output
Exception

setEnctype

public void setEnctype (string $value )

Input
string $valuethe encoding type a browser uses to post data back to the server. Commonly used types include
  • application/x-www-form-urlencoded : Form data is encoded as name/value pairs. This is the standard encoding format.
  • multipart/form-data : Form data is encoded as a message with a separate part for each control on the page.
  • text/plain : Form data is encoded in plain text, without any control or formatting characters.
Output
Exception

setMethod

public void setMethod (string $value )

Input
string $value form submission method. Valid values include 'post' and 'get'.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THead

Class THead (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --THead

THead class

THead displays a head element on a page. It displays the content enclosed in its body and the page title set by the Title property. In addition, stylesheets and JavaScripts registered via TClientScriptManager::registerStyleSheet, TClientScriptManager::registerStyleSheetFile TClientScriptManager::registerHeadJavaScript, and TClientScriptManager::registerHeadJavaScriptFile will also be displayed in the head. THead also manages and displays meta tags through its MetaTags property. You can add a meta object to the collection in code dynamically, or add it in template using the following syntax,

1      <com:THead>
2        <com:TMetaTag HttpEquiv="Pragma" Content="no-cache" />
3        <com:TMetaTag Name="keywords" Content="Prado" />
4      </com:THead>

Note, TPage has a property TPage::getHead that refers to the THead control currently on the page. A page can have at most once THead control. Although not required, it is recommended to place a THead on your page. Without a THead on the page, stylesheets and javascripts in the current page theme will not be rendered.

Since: 3.0
Author: Marcus Nyeholt <tanus@users.sourceforge.net> and Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | addParsedObject ( string|TComponent $object) Processes an object that is created during parsing template.
string | getBaseUrl ()
TMetaTagCollection | getMetaTags ()
string | getShortcutIcon ()
string | getTitle ()
void | onInit ( TEventParameter $param) Registers the head control with the current page.
void | render ( THtmlWriter $writer) Renders the head control.
void | setBaseUrl ( string $url)
void | setShortcutIcon ( string $url)
void | setTitle ( string $value) Sets the page title.
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addParsedObject

public void addParsedObject (string|TComponent $object )

Processes an object that is created during parsing template.

This method adds TMetaTag components into the MetaTags collection of the head control.

Input
string|TComponent $object text string or component parsed and instantiated in template
Output
Exception

getBaseUrl

public string getBaseUrl ()

Output
string base URL of the page. This URL is rendered as the 'href' attribute of <base> tag. Defaults to ''.
Exception

getMetaTags

public TMetaTagCollection getMetaTags ()

Output
TMetaTagCollection meta tag collection
Exception

getShortcutIcon

public string getShortcutIcon ()

Output
string the URL for the shortcut icon of the page. Defaults to ''.
Exception

getTitle

public string getTitle ()

Output
string the page title.
Exception

onInit

public void onInit (TEventParameter $param )

Registers the head control with the current page.

This method is invoked when the control enters 'Init' stage. The method raises 'Init' event. If you override this method, be sure to call the parent implementation so that the event handlers can be invoked.

Input
TEventParameter $param event parameter to be passed to the event handlers
Output
Exception

render

public void render (THtmlWriter $writer )

Renders the head control.

Input
THtmlWriter $writer the writer for rendering purpose.
Output
Exception

setBaseUrl

public void setBaseUrl (string $url )

Input
string $url base URL of the page. This URL is rendered as the 'href' attribute of <base> tag.
Output
Exception

setShortcutIcon

public void setShortcutIcon (string $url )

Input
string $url the URL for the shortcut icon of the page.
Output
Exception

setTitle

public void setTitle (string $value )

Sets the page title.

This title will be rendered only if the TPage::getTitle property of the page is empty.

Input
string $value the page title.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THtmlWriter

Class THtmlWriter (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --THtmlWriter

THtmlWriter class

THtmlWriter is a writer that renders valid XHTML outputs. It provides functions to render tags, their attributes and stylesheet fields. Attribute and stylesheet values will be automatically HTML-encoded if they require so. For example, the 'value' attribute in an input tag will be encoded.

A common usage of THtmlWriter is as the following sequence:

1       $writer->addAttribute($name1,$value1);
2       $writer->addAttribute($name2,$value2);
3       $writer->renderBeginTag($tagName);
4       // ... render contents enclosed within the tag here
5         $writer->renderEndTag();
Make sure each invocation of renderBeginTag is accompanied with a renderEndTag and they are properly nested, like nesting tags in HTML and XHTML.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void | addAttribute ( string $name, string $value) Adds an attribute to be rendered.
void | addAttributes ( array $attrs) Adds a list of attributes to be rendered.
void | addStyleAttribute ( string $name, string $value) Adds a stylesheet attribute to be rendered
void | addStyleAttributes ( array $attrs) Adds a list of stylesheet attributes to be rendered.
void | flush () Flushes the rendering result.
void | getWriter ()
void | removeAttribute ( string $name) Removes the named attribute from rendering
void | removeStyleAttribute ( string $name) Removes the named stylesheet attribute from rendering
void | renderBeginTag ( string $tagName) Renders the openning tag.
void | renderEndTag () Renders the closing tag.
void | setWriter ( mixed $writer)
void | write ( string $str) Renders a string.
void | writeBreak () Renders an HTML break.
void | writeLine ( string $str) Renders a string and appends a newline to it.
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

addAttribute

public void addAttribute (string $name , string $value )

Adds an attribute to be rendered.

Input
string | $name | name of the attribute
string | $value | value of the attribute
Output
Exception

addAttributes

public void addAttributes (array $attrs )

Adds a list of attributes to be rendered.

Input
array $attrs list of attributes to be rendered
Output
Exception

addStyleAttribute

public void addStyleAttribute (string $name , string $value )

Adds a stylesheet attribute to be rendered

Input
string | $name | stylesheet attribute name
string | $value | stylesheet attribute value
Output
Exception

addStyleAttributes

public void addStyleAttributes (array $attrs )

Adds a list of stylesheet attributes to be rendered.

Input
array $attrs list of stylesheet attributes to be rendered
Output
Exception

flush

public void flush ()

Flushes the rendering result.

This will invoke the underlying writer's flush method.

Output
Exception

getWriter

public void getWriter ()

Output
Exception

removeAttribute

public void removeAttribute (string $name )

Removes the named attribute from rendering

Input
string $name name of the attribute to be removed
Output
Exception

removeStyleAttribute

public void removeStyleAttribute (string $name )

Removes the named stylesheet attribute from rendering

Input
string $name name of the stylesheet attribute to be removed
Output
Exception

renderBeginTag

public void renderBeginTag (string $tagName )

Renders the openning tag.

Input
string $tagName tag name
Output
Exception

renderEndTag

public void renderEndTag ()

Renders the closing tag.

Output
Exception

setWriter

public void setWriter (mixed $writer )

Input
mixed $writer
Output
Exception

write

public void write (string $str )

Renders a string.

Input
string $str string to be rendered
Output
Exception

writeBreak

public void writeBreak ()

Renders an HTML break.

Output
Exception

writeLine

public void writeLine (string $str )

Renders a string and appends a newline to it.

Input
string $str string to be rendered
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IPageStatePersister

Interface IPageStatePersister (Class Overview)

IPageStatePersister interface.

IPageStatePersister interface is required for all page state persister  classes.

            Since:
            3.1

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
void | getPage ( TPage 0)
mixed | load () Loads page state from persistent storage
void | save ( mixed $state) Saves state to persistent storage.
void | setPage ( TPage $page)

            Method Details

getPage

                                public void getPage
                                (TPage 0 )

Input

TPage 0 the page that this persister works for

Output

Exception

load

                                public mixed load
                                ()

Loads page state from persistent storage

Output

                                    mixed
                 the restored state

Exception

save

                                public void save
                                (mixed $state )

Saves state to persistent storage.

Input

mixed $state state to be stored

Output

Exception

setPage

                                public void setPage
                                (TPage $page )

Input

TPage $page the page that this persister works for

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPage

Class TPage (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TPage

TPage class

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TTemplateControl
EXT_TEMPLATE,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Constructor Summary
public
__construct
Constructor.
Method Summary
void | applyControlSkin ( TControl $control) Applies a skin in the current theme to a control.
void | applyControlStyleSheet ( TControl $control) Applies a stylesheet skin in the current theme to a control.
void | beginFormRender ( mixed $writer)
void | endFormRender ( mixed $writer)
void | ensureRenderInForm ( TControl $control) Ensures the control is rendered within a form.
TStack | getCachingStack ()
TCallbackClientScript | getCallbackClient () Gets the callback client script handler that allows javascript functions to be executed during the callback response.
string | getCallbackEventParameter () Callback parameter is decoded assuming JSON encoding.
TControl | getCallbackEventTarget ()
TClientScriptManager | getClientScript ()
string | getClientState () Returns the state to be stored on the client side.
boolean | getClientSupportsJavaScript ()
boolean | getEnableStateCompression ()
boolean | getEnableStateEncryption ()
boolean | getEnableStateValidation ()
TForm | getForm ()
THead | getHead ()
boolean | getIsCallback ()
boolean | getIsLoadingPostData ()
boolean | getIsPostBack ()
boolean | getIsValid () Returns whether user input is valid or not.
string | getPagePath ()
string | getPostBackEventParameter ()
TControl | getPostBackEventTarget ()
array | getPostDataLoaders () Get a list of IDs of controls that are enabled and require post data.
string | getRequestClientState ()
IPageStatePersister | getStatePersister ()
string | getStatePersisterClass ()
TTheme | getStyleSheetTheme ()
TTheme | getTheme ()
string | getTitle ()
TList | getValidators ( string $validationGroup) Returns a list of registered validators.
protected boolean | isSystemPostField ( string $field)
protected void | loadPageState () Loads page state from persistent storage.
void | loadState () This method is invoked right after the control has loaded its state.
void | onInitComplete ( mixed $param) Raises OnInitComplete event.
void | onLoadComplete ( mixed $param) Raises OnLoadComplete event.
void | onPreInit ( mixed $param) Raises OnPreInit event.
void | onPreLoad ( mixed $param) Raises OnPreLoad event.
void | onPreRenderComplete ( mixed $param) Raises OnPreRenderComplete event.
void | onSaveStateComplete ( mixed $param) Raises OnSaveStateComplete event.
protected void | processCallbackRequest ( mixed $writer) Sets Adapter to TActivePageAdapter and calls apter to process the callback request.
protected void | processNormalRequest ( mixed $writer)
protected void | processPostBackRequest ( mixed $writer)
protected void | processPostData ( TMap $postData, boolean $beforeLoad) Processes post data.
void | registerCachingAction ( string $context, string $funcName, array $funcParams) Registers an action associated with the content being cached.
void | registerPostDataLoader ( TControl $control) Register post data loaders for Callback to collect post data.
void | registerRequiresPostData ( TControl $control) Registers a control for loading post data in the next postback.
void | run ( THtmlTextWriter $writer) Runs through the page lifecycles.
protected void | savePageState () Saves page state from persistent storage.
void | saveState () This method is invoked when control state is to be saved.
void | setCallbackClient ( TCallbackClientScript $client) Set a new callback client handler.
void | setCallbackEventParameter ( mixed $value)
void | setCallbackEventTarget ( TControl $control) Registers a control to raise callback event in the current request.
void | setClientState ( string $state) Sets the state to be stored on the client side.
void | setClientSupportsJavaScript ( boolean $value)
void | setEnableStateCompression ( boolean $value)
void | setEnableStateEncryption ( boolean $value)
void | setEnableStateValidation ( boolean $value)
void | setFocus ( TControl|string $value) Sets input focus on a control after the page is rendered to users.
void | setForm ( TForm $form) Registers a TForm instance to the page.
void | setHead ( THead $value)
void | setPagePath ( string $value)
void | setPostBackEventParameter ( string $value)
void | setPostBackEventTarget ( TControl $control) Registers a control to raise postback event in the current request.
void | setStatePersisterClass ( string $value)
void | setStyleSheetTheme ( string|TTheme $value) Sets the stylesheet theme to be used for the page.
void | setTheme ( string|TTheme $value) Sets the theme to be used for the page.
void | setTitle ( string $value) Sets the page title.
void | validate ( string $validationGroup) Performs input validation.
Methods Inherited From TTemplateControl
TTemplateControl::createChildControls(), TTemplateControl::getIsSourceTemplateControl(), TTemplateControl::getMaster(), TTemplateControl::getMasterClass(), TTemplateControl::getTemplate(), TTemplateControl::getTemplateDirectory(), TTemplateControl::initRecursive(), TTemplateControl::injectContent(), TTemplateControl::loadTemplate(), TTemplateControl::registerContent(), TTemplateControl::registerContentPlaceHolder(), TTemplateControl::setMasterClass(), TTemplateControl::setTemplate()
Methods Inherited From TCompositeControl
TCompositeControl::initRecursive()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | FIELD_CALLBACK_PARAMETER |
string | FIELD_CALLBACK_TARGET |
string | FIELD_LASTFOCUS |
string | FIELD_PAGESTATE |
string | FIELD_POSTBACK_PARAMETER |
string | FIELD_POSTBACK_TARGET | system post fields
Constructor Details

__construct

public __construct

Constructor.

Sets the page object to itself. Derived classes must call parent implementation.
Method Details

applyControlSkin

public void applyControlSkin (TControl $control )

Applies a skin in the current theme to a control.

This method should only be used by framework developers.

Input
TControl $control a control to be applied skin with
Output
Exception

applyControlStyleSheet

public void applyControlStyleSheet (TControl $control )

Applies a stylesheet skin in the current theme to a control.

This method should only be used by framework developers.

Input
TControl $control a control to be applied stylesheet skin with
Output
Exception

beginFormRender

public void beginFormRender (mixed $writer )

Input
mixed $writer
Output
Exception

endFormRender

public void endFormRender (mixed $writer )

Input
mixed $writer
Output
Exception

ensureRenderInForm

public void ensureRenderInForm (TControl $control )

Ensures the control is rendered within a form.

Input
TControl | $control | the control to be rendered
Output
Exception
throws | TConfigurationException if the control is outside of the form

getCachingStack

public TStack getCachingStack ()

Output
TStack stack of TOutputCache objects
Exception

getCallbackClient

public TCallbackClientScript getCallbackClient ()

Gets the callback client script handler that allows javascript functions to be executed during the callback response.

Output
TCallbackClientScript interface to client-side javascript code.
Exception

getCallbackEventParameter

public string getCallbackEventParameter ()

Callback parameter is decoded assuming JSON encoding.

Output
string callback event parameter
Exception

getCallbackEventTarget

public TControl getCallbackEventTarget ()

Output
TControl the control responsible for the current callback event, null if nonexistent
Exception

getClientScript

public TClientScriptManager getClientScript ()

Output
TClientScriptManager client script manager
Exception

getClientState

public string getClientState ()

Returns the state to be stored on the client side.

This method should only be used by framework and control developers.

Output
string the state to be stored on the client side
Exception

getClientSupportsJavaScript

public boolean getClientSupportsJavaScript ()

Output
boolean whether client supports javascript. Defaults to true.
Exception

getEnableStateCompression

public boolean getEnableStateCompression ()

Output
boolean whether page state should be compressed. Defaults to true.
Exception

getEnableStateEncryption

public boolean getEnableStateEncryption ()

Output
boolean whether page state should be encrypted. Defaults to false.
Exception

getEnableStateValidation

public boolean getEnableStateValidation ()

Output
boolean whether page state should be HMAC validated. Defaults to true.
Exception

getForm

public TForm getForm ()

Output
TForm the form on the page
Exception

getHead

public THead getHead ()

Output
THead page head, null if not available
Exception

getIsCallback

public boolean getIsCallback ()

Output
boolean whether this is a callback request
Exception

getIsLoadingPostData

public boolean getIsLoadingPostData ()

Output
boolean true if loading post data.
Exception

getIsPostBack

public boolean getIsPostBack ()

Output
boolean whether the current page request is a postback
Exception

getIsValid

public boolean getIsValid ()

Returns whether user input is valid or not.

This method must be invoked after validate is called.

Output
boolean | whether the user input is valid or not.
Exception
throws | TInvalidOperationException if validate is not invoked yet.

getPagePath

public string getPagePath ()

Output
string the requested page path for this page
Exception

getPostBackEventParameter

public string getPostBackEventParameter ()

Output
string postback event parameter
Exception

getPostBackEventTarget

public TControl getPostBackEventTarget ()

Output
TControl the control responsible for the current postback event, null if nonexistent
Exception

getPostDataLoaders

public array getPostDataLoaders ()

Get a list of IDs of controls that are enabled and require post data.

Output
array list of IDs implementing IPostBackDataHandler
Exception

getRequestClientState

public string getRequestClientState ()

Output
string the state postback from client side
Exception

getStatePersister

public IPageStatePersister getStatePersister ()

Output
IPageStatePersister page state persister
Exception

getStatePersisterClass

public string getStatePersisterClass ()

Output
string class name of the page state persister. Defaults to TPageStatePersister.
Exception

getStyleSheetTheme

public TTheme getStyleSheetTheme ()

Output
TTheme the stylesheet theme used for the page. Defaults to null.
Exception

getTheme

public TTheme getTheme ()

Output
TTheme the theme used for the page. Defaults to null.
Exception

getTitle

public string getTitle ()

Output
string page title.
Exception

getValidators

public TList getValidators (string $validationGroup )

Returns a list of registered validators.

If validation group is specified, only the validators in that group will be returned.

Input
string | $validationGroup | validation group
Output
TList | registered validators in the requested group. If the group is null, all validators will be returned.
Exception

isSystemPostField

protected boolean isSystemPostField (string $field )

Input
string | $field | the field name
Output
boolean | whether the specified field is a system field in postback data
Exception

loadPageState

protected void loadPageState ()

Loads page state from persistent storage.

Output
Exception

loadState

public void loadState ()

This method is invoked right after the control has loaded its state.

You can override this method to initialize data from the control state. Parent implementation must be invoked.

Output
Exception

onInitComplete

public void onInitComplete (mixed $param )

Raises OnInitComplete event.

This method is invoked right after OnInit stage and before OnLoad stage. You may override this method to provide additional initialization that should be done after OnInit. Remember to call the parent implementation to ensure OnInitComplete event is raised.

Input
mixed $param event parameter
Output
Exception

onLoadComplete

public void onLoadComplete (mixed $param )

Raises OnLoadComplete event.

This method is invoked right after OnLoad stage. You may override this method to provide additional page loading logic that should be done after OnLoad. Remember to call the parent implementation to ensure OnLoadComplete event is raised.

Input
mixed $param event parameter
Output
Exception

onPreInit

public void onPreInit (mixed $param )

Raises OnPreInit event.

This method is invoked right before OnInit stage. You may override this method to provide additional initialization that should be done before OnInit (e.g. setting Theme or StyleSheetTheme). Remember to call the parent implementation to ensure OnPreInit event is raised.

Input
mixed $param event parameter
Output
Exception

onPreLoad

public void onPreLoad (mixed $param )

Raises OnPreLoad event.

This method is invoked right before OnLoad stage. You may override this method to provide additional page loading logic that should be done before OnLoad. Remember to call the parent implementation to ensure OnPreLoad event is raised.

Input
mixed $param event parameter
Output
Exception

onPreRenderComplete

public void onPreRenderComplete (mixed $param )

Raises OnPreRenderComplete event.

This method is invoked right after OnPreRender stage. You may override this method to provide additional preparation for page rendering that should be done after OnPreRender. Remember to call the parent implementation to ensure OnPreRenderComplete event is raised.

Input
mixed $param event parameter
Output
Exception

onSaveStateComplete

public void onSaveStateComplete (mixed $param )

Raises OnSaveStateComplete event.

This method is invoked right after onSaveState stage. You may override this method to provide additional logic after page state is saved. Remember to call the parent implementation to ensure OnSaveStateComplete event is raised.

Input
mixed $param event parameter
Output
Exception

processCallbackRequest

protected void processCallbackRequest (mixed $writer )

Sets Adapter to TActivePageAdapter and calls apter to process the callback request.

Input
mixed $writer
Output
Exception

processNormalRequest

protected void processNormalRequest (mixed $writer )

Input
mixed $writer
Output
Exception

processPostBackRequest

protected void processPostBackRequest (mixed $writer )

Input
mixed $writer
Output
Exception

processPostData

protected void processPostData (TMap $postData , boolean $beforeLoad )

Processes post data.

Input
TMap | $postData | post data to be processed
boolean | $beforeLoad | whether this method is invoked before OnLoad.
Output
Exception

registerCachingAction

public void registerCachingAction (string $context , string $funcName , array $funcParams )

Registers an action associated with the content being cached.

The registered action will be replayed if the content stored in the cache is served to end-users.

Input
string | $context | context of the action method. This is a property-path referring to the context object (e.g. Page, Page.ClientScript).
string | $funcName | method name of the context object
array | $funcParams | list of parameters to be passed to the action method
Output
Exception

registerPostDataLoader

public void registerPostDataLoader (TControl $control )

Register post data loaders for Callback to collect post data.

This method should only be called by framework developers.

Input
TControl $control control that requires post data.
Output
Exception

registerRequiresPostData

public void registerRequiresPostData (TControl $control )

Registers a control for loading post data in the next postback.

This method needs to be invoked if the control to load post data may not have a post variable in some cases. For example, a checkbox, if not checked, will not have a post value.

Input
TControl $control control registered for loading post data
Output
Exception

run

public void run (THtmlTextWriter $writer )

Runs through the page lifecycles.

Input
THtmlTextWriter $writer the HTML writer
Output
Exception

savePageState

protected void savePageState ()

Saves page state from persistent storage.

Output
Exception

saveState

public void saveState ()

This method is invoked when control state is to be saved.

You can override this method to do last step state saving. Parent implementation must be invoked.

Output
Exception

setCallbackClient

public void setCallbackClient (TCallbackClientScript $client )

Set a new callback client handler.

Input
TCallbackClientScript $client new callback client script handler.
Output
Exception

setCallbackEventParameter

public void setCallbackEventParameter (mixed $value )

Input
mixed $value callback event parameter
Output
Exception

setCallbackEventTarget

public void setCallbackEventTarget (TControl $control )

Registers a control to raise callback event in the current request.

Input
TControl $control control registered to raise callback event.
Output
Exception

setClientState

public void setClientState (string $state )

Sets the state to be stored on the client side.

This method should only be used by framework and control developers.

Input
string $state the state to be stored on the client side
Output
Exception

setClientSupportsJavaScript

public void setClientSupportsJavaScript (boolean $value )

Input
boolean $value whether client supports javascript. If false, javascript will not be generated for controls.
Output
Exception

setEnableStateCompression

public void setEnableStateCompression (boolean $value )

Input
boolean $value whether page state should be compressed.
Output
Exception

setEnableStateEncryption

public void setEnableStateEncryption (boolean $value )

Input
boolean $value whether page state should be encrypted.
Output
Exception

setEnableStateValidation

public void setEnableStateValidation (boolean $value )

Input
boolean $value whether page state should be HMAC validated.
Output
Exception

setFocus

public void setFocus (TControl|string $value )

Sets input focus on a control after the page is rendered to users.

Input
TControl|string $value control to receive focus, or the ID of the element on the page to receive focus
Output
Exception

setForm

public void setForm (TForm $form )

Registers a TForm instance to the page.

Note, a page can contain at most one TForm instance.

Input
TForm | $form | the form on the page
Output
Exception
throws | TInvalidOperationException if this method is invoked twice or more.

setHead

public void setHead (THead $value )

Input
THead | $value | page head
Output
Exception
throws | TInvalidOperationException if a head already exists

setPagePath

public void setPagePath (string $value )

Input
string $value the requested page path for this page
Output
Exception

setPostBackEventParameter

public void setPostBackEventParameter (string $value )

Input
string $value postback event parameter
Output
Exception

setPostBackEventTarget

public void setPostBackEventTarget (TControl $control )

Registers a control to raise postback event in the current request.

Input
TControl $control control registered to raise postback event.
Output
Exception

setStatePersisterClass

public void setStatePersisterClass (string $value )

Input
string $value class name of the page state persister.
Output
Exception

setStyleSheetTheme

public void setStyleSheetTheme (string|TTheme $value )

Sets the stylesheet theme to be used for the page.

Input
string|TTheme $value the stylesheet theme name or the stylesheet theme object to be used for the page.
Output
Exception

setTheme

public void setTheme (string|TTheme $value )

Sets the theme to be used for the page.

Input
string|TTheme $value the theme name or the theme object to be used for the page.
Output
Exception

setTitle

public void setTitle (string $value )

Sets the page title.

Note, a THead control needs to place on the page in order that this title be rendered.

Input
string $value page title. This will override the title set in Head.
Output
Exception

validate

public void validate (string $validationGroup )

Performs input validation.

This method will invoke the registered validators to perform the actual validation. If validation group is specified, only the validators in that group will be invoked.

Input
string $validationGroup validation group. If null, all validators will perform validation.
Output
Exception

Constant Details

FIELD_CALLBACK_PARAMETER

Type:

string

Value:

'PRADO_CALLBACK_PARAMETER'

FIELD_CALLBACK_TARGET

Type:

string

Value:

'PRADO_CALLBACK_TARGET'

FIELD_LASTFOCUS

Type:

string

Value:

'PRADO_LASTFOCUS'

FIELD_PAGESTATE

Type:

string

Value:

'PRADO_PAGESTATE'

FIELD_POSTBACK_PARAMETER

Type:

string

Value:

'PRADO_POSTBACK_PARAMETER'

FIELD_POSTBACK_TARGET

system post fields

Type:

string

Value:

'PRADO_POSTBACK_TARGET'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPageStateFormatter

Class TPageStateFormatter (Class Overview)

TPageStateFormatter class.

TPageStateFormatter is a utility class to transform the page state  into and from a string that can be properly saved in persistent storage.
Depending on the EnableStateValidation  and EnableStateEncryption,  TPageStateFormatter may do HMAC validation and encryption to prevent  the state data from being tampered or viewed.  The private keys and hashing/encryption methods are determined by  SecurityManager.

            Since:
            3.1

            Author:
            Qiang Xue <qiang.xue@gmail.com>

Method Summary
string | serialize ( TPage $page, mixed $data)
mixed | unserialize ( TPage $page, string $data)

            Method Details

serialize

                                public string serialize
                                (TPage $page , mixed $data )

Input
TPage | $page |
mixed | $data | state data
Output
string | serialized data
Exception

unserialize

                                public mixed unserialize
                                (TPage $page , string $data )

Input
TPage | $page |
string | $data | serialized data
Output
mixed | unserialized state data, null if data is corrupted
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPageStatePersister

Class TPageStatePersister (Class Overview)

TComponent
   |
   --TPageStatePersister

TPageStatePersister class

TPageStatePersister implements a page state persistent method based on form hidden fields.

Since page state can be very big for complex pages, consider using alternative persisters, such as TSessionPageStatePersister, which store page state on the server side and thus reduce the network traffic for transmitting bulky page state.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
TPage | getPage ()
mixed | load () Loads page state from hidden fields.
void | save ( mixed $state) Saves state in hidden fields.
void | setPage ( TPage $page)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getPage

public TPage getPage ()

Output
TPage the page that this persister works for
Exception

load

public mixed load ()

Loads page state from hidden fields.

Output
mixed | the restored state
Exception
throws | THttpException if page state is corrupted

save

public void save (mixed $state )

Saves state in hidden fields.

Input
mixed $state state to be stored
Output
Exception

setPage

public void setPage (TPage $page )

Input
TPage $page the page that this persister works for
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSessionPageStatePersister

Class TSessionPageStatePersister (Class Overview)

TComponent
   |
   --TSessionPageStatePersister

TSessionPageStatePersister class

TSessionPageStatePersister implements a page state persistent method based on sessions. Page state are stored in user sessions and therefore, this persister requires session to be started and available.

TSessionPageStatePersister keeps limited number of history states in session, mainly to preserve the precious server storage. The number is specified by HistorySize, which defaults to 10.

There are a couple of ways to use TSessionPageStatePersister. One can override the page's TPage::getStatePersister() method and create a TSessionPageStatePersister instance there. Or one can configure the pages to use TSessionPageStatePersister in page configurations as follows,

1        <pages StatePersisterClass="System.Web.UI.TSessionPageStatePersister" />
The above configuration will affect the pages under the directory containing this configuration and all its subdirectories. To configure individual pages to use TSessionPageStatePersister, use

1        <pages>
2          <page id="PageID" StatePersisterClass="System.Web.UI.TSessionPageStatePersister" />
3        </pages>

Since: 3.1
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
integer | getHistorySize ()
void | getPage ( TPage 0)
mixed | load () Loads page state from session.
void | save ( mixed $state) Saves state in session.
void | setHistorySize ( integer $value)
void | setPage ( TPage $page)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | QUEUE_SESSION_KEY
string | STATE_SESSION_KEY
Method Details

getHistorySize

public integer getHistorySize ()

Output
integer maximum number of page states that should be kept in session. Defaults to 10.
Exception

getPage

public void getPage (TPage 0 )

Input
TPage 0 the page that this persister works for
Output
Exception

load

public mixed load ()

Loads page state from session.

Output
mixed | the restored state
Exception
throws | THttpException if page state is corrupted

save

public void save (mixed $state )

Saves state in session.

Input
mixed $state state to be stored
Output
Exception

setHistorySize

public void setHistorySize (integer $value )

Input
integer | $value | maximum number of page states that should be kept in session
Output
Exception
throws | TInvalidDataValueException if the number is smaller than 1.

setPage

public void setPage (TPage $page )

Input
TPage $page the page that this persister works for.
Output
Exception

Constant Details

QUEUE_SESSION_KEY

Type:

string

Value:

'PRADO_SESSION_STATEQUEUE'

STATE_SESSION_KEY

Type:

string

Value:

'PRADO_SESSION_PAGESTATE'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTemplateControl

Class TTemplateControl (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl

Direct Known Sub-classes:

TScaffoldBase , TPage , TDataRenderer

TTemplateControl class.

TTemplateControl is the base class for all controls that use templates. By default, a control template is assumed to be in a file under the same directory with the control class file. They have the same file name and different extension name. For template file, the extension name is ".tpl".

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | createChildControls () Creates child controls.
boolean | getIsSourceTemplateControl ()
TTemplateControl|null | getMaster ()
string | getMasterClass ()
ITemplate|null | getTemplate () Returns the template object associated with this control object.
string | getTemplateDirectory ()
protected void | initRecursive ( TControl $namingContainer) Performs the OnInit step for the control and all its child controls.
void | injectContent ( string $id, TContent $content) Injects all content controls (and their children) to the corresponding content placeholders.
protected ITemplate | loadTemplate () Loads the template associated with this control class.
void | registerContent ( string $id, TContent $object) Registers a content control.
void | registerContentPlaceHolder ( string $id, TContentPlaceHolder $object) Registers a content placeholder to this template control.
void | setMasterClass ( string $value)
void | setTemplate ( ITemplate $value) Sets the parsed template.
Methods Inherited From TCompositeControl
TCompositeControl::initRecursive()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string EXT_TEMPLATE template file extension.
Method Details

createChildControls

public void createChildControls ()

Creates child controls.

This method is overridden to load and instantiate control template. This method should only be used by framework and control developers.

Output
Exception

getIsSourceTemplateControl

public boolean getIsSourceTemplateControl ()

Output
boolean whether this control is a source template control. A source template control loads its template from external storage, such as file, db, rather than from within another template.
Exception

getMaster

public TTemplateControl|null getMaster ()

Output
TTemplateControl|null master control associated with this control, null if none
Exception

getMasterClass

public string getMasterClass ()

Output
string master class name (in namespace form)
Exception

getTemplate

public ITemplate|null getTemplate ()

Returns the template object associated with this control object.

Output
ITemplate|null the parsed template, null if none
Exception

getTemplateDirectory

public string getTemplateDirectory ()

Output
string the directory containing the template. Empty if no template available.
Exception

initRecursive

protected void initRecursive (TControl $namingContainer )

Performs the OnInit step for the control and all its child controls.

This method overrides the parent implementation by ensuring child controls are created first, and if master class is set, master will be applied. Only framework developers should use this method.

Input
TControl $namingContainer the naming container control
Output
Exception

injectContent

public void injectContent (string $id , TContent $content )

Injects all content controls (and their children) to the corresponding content placeholders.

This method should only be used by framework and control developers.

Input
string | $id | ID of the content control
TContent | $content | the content to be injected
Output
Exception

loadTemplate

protected ITemplate loadTemplate ()

Loads the template associated with this control class.

Output
ITemplate the parsed template structure
Exception

registerContent

public void registerContent (string $id , TContent $object )

Registers a content control.

Input
string | $id | ID of the content
TContent | $object |
Output
Exception

registerContentPlaceHolder

public void registerContentPlaceHolder (string $id , TContentPlaceHolder $object )

Registers a content placeholder to this template control.

This method should only be used by framework and control developers.

Input
string | $id | placeholder ID
TContentPlaceHolder | $object | placeholder control
Output
Exception

setMasterClass

public void setMasterClass (string $value )

Input
string $value master control class name (in namespace form)
Output
Exception

setTemplate

public void setTemplate (ITemplate $value )

Sets the parsed template.

Note, the template will be applied to the whole control class. This method should only be used by framework and control developers.

Input
ITemplate $value the parsed template
Output
Exception

Constant Details

EXT_TEMPLATE

template file extension.

Type:

string

Value:

'.tpl'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTemplate

Class TTemplate (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TTemplate

TTemplate implements PRADO template parsing logic.

A TTemplate object represents a parsed PRADO control template. It can instantiate the template as child controls of a specified control. The template format is like HTML, with the following special tags introduced,

  • component tags: a component tag represents the configuration of a component.
The tag name is in the format of com:ComponentType, where ComponentType is the component class name. Component tags must be well-formed. Attributes of the component tag are treated as either property initial values, event handler attachment, or regular tag attributes.
  • property tags: property tags are used to set large block of attribute values.
The property tag name is in the format of <prop:AttributeName> where AttributeName can be a property name, an event name or a regular tag attribute name.
  • group subproperty tags: subproperties of a common property can be configured using
<prop:MainProperty SubProperty1="Value1" SubProperty2="Value2" .../>
  • directive: directive specifies the property values for the template owner.
It is in the format of <%@ property name-value pairs %>;
  • expressions: They are in the formate of <%= PHP expression %> and <%% PHP statements %>
  • comments: There are two kinds of comments, regular HTML comments and special template comments.
The former is in the format of <!-- comments -->, which will be treated as text strings. The latter is in the format of <!-- comments --!>, which will be stripped out.

Tags other than the above are not required to be well-formed.

A TTemplate object represents a parsed PRADO template. To instantiate the template for a particular control, call instantiateIn($control), which will create and intialize all components specified in the template and set their parent as $control.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
protected void | configureComponent ( TComponent $component, string $name, mixed $value) Configures a property of a non-control component.
protected void | configureControl ( TControl $control, string $name, mixed $value) Configures a property/event of a control.
protected void | configureEvent ( TControl $control, string $name, string $value, TControl $contextControl) Configures an event for a control.
protected void | configureProperty ( TComponent $component, string $name, mixed $value) Configures a simple property for a component.
protected void | configureSubProperty ( TComponent $component, string $name, mixed $value) Configures a subproperty for a component.
string | getContextPath ()
array | getDirective ()
string | getHashCode ()
array | getIncludedFiles ()
boolean | getIsSourceTemplate ()
array | getItems ()
string | getTemplateFile ()
protected void | handleException ( Exception $e, int $line, string $input) Handles template parsing exception.
void | instantiateIn ( TControl $tplControl, TControl $parentControl) Instantiates the template.
protected void | parse ( string $input) Parses a template string.
protected array | parseAttribute ( string $value) Parses a single attribute.
protected array | parseAttributes ( string $str, mixed $offset) Parses the attributes of a tag from a string.
protected void | parseTemplateProperty ( mixed $content, mixed $offset)
protected string | preprocess ( string $input) Preprocesses the template string by including external templates
protected void | validateAttributes ( mixed $type, mixed $attributes)
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
int | CONFIG_ASSET |
int | CONFIG_DATABIND | Different configurations of component property/event/attribute
int | CONFIG_EXPRESSION |
int | CONFIG_LOCALIZATION |
int | CONFIG_PARAMETER |
int | CONFIG_TEMPLATE |
string | REGEX_RULES | '<!--.*?--!>' - template comments '<!--.*?-->' - HTML comments '<\/?com:([\w\.]+)((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?"|\s*[\w\.]+\s*=\s*<%.*?%>)*)\s*\/?>' - component tags '<\/?prop:([\w\.]+)\s*>' - property tags '<%@\s*((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?")*)\s*%>' - directives '<%[%#~\/\\$=\\[](.*?)%>' - expressions '<prop:([\w\.]+)((?:\s*[\w\.]+=\'.*?\'|\s*[\w\.]+=".*?"|\s*[\w\.]+=<%.*?%>)*)\s*\/>' - group subproperty tags
Constructor Details

__construct

public __construct Array

Constructor.

The template will be parsed after construction.
Method Details

configureComponent

protected void configureComponent (TComponent $component , string $name , mixed $value )

Configures a property of a non-control component.

Input
TComponent | $component | component to be configured
string | $name | property name
mixed | $value | property initial value
Output
Exception

configureControl

protected void configureControl (TControl $control , string $name , mixed $value )

Configures a property/event of a control.

Input
TControl | $control | control to be configured
string | $name | property name
mixed | $value | property initial value
Output
Exception

configureEvent

protected void configureEvent (TControl $control , string $name , string $value , TControl $contextControl )

Configures an event for a control.

Input
TControl | $control | control to be configured
string | $name | event name
string | $value | event handler
TControl | $contextControl | context control
Output
Exception

configureProperty

protected void configureProperty (TComponent $component , string $name , mixed $value )

Configures a simple property for a component.

Input
TComponent | $component | component to be configured
string | $name | property name
mixed | $value | property initial value
Output
Exception

configureSubProperty

protected void configureSubProperty (TComponent $component , string $name , mixed $value )

Configures a subproperty for a component.

Input
TComponent | $component | component to be configured
string | $name | subproperty name
mixed | $value | subproperty initial value
Output
Exception

getContextPath

public string getContextPath ()

Output
string context directory path
Exception

getDirective

public array getDirective ()

Output
array name-value pairs declared in the directive
Exception

getHashCode

public string getHashCode ()

Output
string hash code that can be used to identify the template
Exception

getIncludedFiles

public array getIncludedFiles ()

Output
array list of included external template files
Exception

getIsSourceTemplate

public boolean getIsSourceTemplate ()

Output
boolean whether this template is a source template, i.e., this template is loaded from some external storage rather than from within another template.
Exception

getItems

public array getItems ()

Output
array the parsed template
Exception

getTemplateFile

public string getTemplateFile ()

Output
string template file path if available, null otherwise.
Exception

handleException

protected void handleException (Exception $e , int $line , string $input )

Handles template parsing exception.

This method rethrows the exception caught during template parsing. It adjusts the error location by giving out correct error line number and source file.

Input
Exception | $e | template exception
int | $line | line number
string | $input | template string if no source file is used
Output
Exception

instantiateIn

public void instantiateIn (TControl $tplControl , TControl $parentControl )

Instantiates the template.

Content in the template will be instantiated as components and text strings and passed to the specified parent control.

Input
TControl | $tplControl | the control who owns the template
TControl | $parentControl | the control who will become the root parent of the controls on the template. If null, it uses the template control.
Output
Exception

parse

protected void parse (string $input )

Parses a template string.

This template parser recognizes five types of data: regular string, well-formed component tags, well-formed property tags, directives, and expressions.

The parsing result is returned as an array. Each array element can be of three types:

  • a string, 0: container index; 1: string content;
  • a component tag, 0: container index; 1: component type; 2: attributes (name=>value pairs)
If a directive is found in the template, it will be parsed and can be retrieved via getDirective, which returns an array consisting of name-value pairs in the directive.

Note, attribute names are treated as case-insensitive and will be turned into lower cases. Component and directive types are case-sensitive. Container index is the index to the array element that stores the container object. If an object has no container, its container index is -1.

Input
string | $input | the template string
Output
Exception
throws | TConfigurationException if a parsing error is encountered

parseAttribute

protected array parseAttribute (string $value )

Parses a single attribute.

Input
string | $value | the string to be parsed.
Output
array | attribute initialization
Exception

parseAttributes

protected array parseAttributes (string $str , mixed $offset )

Parses the attributes of a tag from a string.

Input
string | $str | the string to be parsed.
mixed | $offset |
Output
array | attribute values indexed by names.
Exception

parseTemplateProperty

protected void parseTemplateProperty (mixed $content , mixed $offset )

Input
mixed | $content
mixed | $offset
Output
Exception

preprocess

protected string preprocess (string $input )

Preprocesses the template string by including external templates

Input
string | $input | template string
Output
string | expanded template string
Exception

validateAttributes

protected void validateAttributes (mixed $type , mixed $attributes )

Input
mixed | $type
mixed | $attributes
Output
Exception
Constant Details

CONFIG_ASSET

Type:

int

Value:

2

CONFIG_DATABIND

Different configurations of component property/event/attribute

Type:

int

Value:

0

CONFIG_EXPRESSION

Type:

int

Value:

1

CONFIG_LOCALIZATION

Type:

int

Value:

4

CONFIG_PARAMETER

Type:

int

Value:

3

CONFIG_TEMPLATE

Type:

int

Value:

5

REGEX_RULES

'<!--.*?--!>' - template comments

'<!--.*?-->' - HTML comments '<\/?com:([\w\.]+)((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?"|\s*[\w\.]+\s*=\s*<%.*?%>)*)\s*\/?>' - component tags '<\/?prop:([\w\.]+)\s*>' - property tags '<%@\s*((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?")*)\s*%>' - directives '<%[%#~\/\\$=\\[](.*?)%>' - expressions '<prop:([\w\.]+)((?:\s*[\w\.]+=\'.*?\'|\s*[\w\.]+=".*?"|\s*[\w\.]+=<%.*?%>)*)\s*\/>' - group subproperty tags

Type:

string

Value:

'/<!--.*?--!>|<!---.*?--->|<\/?com:([\w\.]+)((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?"|\s*[\w\.]+\s*=\s*<%.*?%>)*)\s*\/?>|<\/?prop:([\w\.]+)\s*>|<%@\s*((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?")*)\s*%>|<%[%#~\/\\$=\\[](.*?)%>|<prop:([\w\.]+)((?:\s*[\w\.]+\s*=\s*\'.*?\'|\s*[\w\.]+\s*=\s*".*?"|\s*[\w\.]+\s*=\s*<%.*?%>)*)\s*\/>/msS'


PRADO API Manual: Docs For Class TTemplateManager

Class TTemplateManager (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TTemplateManager

TTemplateManager class

TTemplateManager manages the loading and parsing of control templates.

There are two ways of loading a template, either by the associated template control class name, or the template file name. The former is via calling getTemplateByClassName, which tries to locate the corresponding template file under the directory containing the class file. The name of the template file is the class name with the extension '.tpl'. To load a template from a template file path, call getTemplateByFileName.

By default, TTemplateManager is registered with TPageService as the template manager module that can be accessed via TPageService::getTemplateManager().

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected string|null | getLocalizedTemplate ( string $filename) Finds a localized template file.
ITemplate | getTemplateByClassName ( mixed $className) Loads the template corresponding to the specified class name.
ITemplate | getTemplateByFileName ( mixed $fileName) Loads the template from the specified file.
void | init ( TXmlElement $config) Initializes the module.
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | TEMPLATE_CACHE_PREFIX | Prefix of the cache variable name for storing parsed templates
string | TEMPLATE_FILE_EXT | Template file extension
Method Details

getLocalizedTemplate

protected string|null getLocalizedTemplate (string $filename )

Finds a localized template file.

Input
string | $filename | template file.
Output
string|null | a localized template file if found, null otherwise.
Exception

getTemplateByClassName

public ITemplate getTemplateByClassName (mixed $className )

Loads the template corresponding to the specified class name.

Input
mixed | $className
Output
ITemplate | template for the class name, null if template doesn't exist.
Exception

getTemplateByFileName

public ITemplate getTemplateByFileName (mixed $fileName )

Loads the template from the specified file.

Input
mixed | $fileName
Output
ITemplate | template parsed from the specified file, null if the file doesn't exist.
Exception

init

public void init (TXmlElement $config )

Initializes the module.

This method is required by IModule and is invoked by application. It starts output buffer if it is enabled.

Input
TXmlElement $config module configuration
Output
Exception

Constant Details

TEMPLATE_CACHE_PREFIX

Prefix of the cache variable name for storing parsed templates

Type:

string

Value:

'prado:template:'

TEMPLATE_FILE_EXT

Template file extension

Type:

string

Value:

'.tpl'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTextProcessor

Class TTextProcessor (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TWebControl
            |
            --TTextProcessor

Direct Known Sub-classes:

TTextHighlighter

TTextProcessor class.

TTextProcessor is the base class for classes that process or transform text content into different forms. The text content to be processed is specified by Text property. If it is not set, the body content enclosed within the processor control will be processed and rendered. The body content includes static text strings and the rendering result of child controls.

Note, all child classes must implement processText method.

Since: 3.0.1
Author: Qiang Xue <qiang.xue@gmail.com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | addParsedObject ( mixed $object) HTML-decodes static text.
string | getText ()
abstract string | processText ( string $text) Processes a text string.
void | renderContents ( THtmlWriter $writer) Renders body content.
void | setText ( string $value)
Methods Inherited From TWebControl
TWebControl::addAttributesToRender(), TWebControl::clearStyle(), TWebControl::copyBaseAttributes(), TWebControl::createStyle(), TWebControl::getAccessKey(), TWebControl::getBackColor(), TWebControl::getBorderColor(), TWebControl::getBorderStyle(), TWebControl::getBorderWidth(), TWebControl::getCssClass(), TWebControl::getDisplay(), TWebControl::getFont(), TWebControl::getForeColor(), TWebControl::getHasStyle(), TWebControl::getHeight(), TWebControl::getStyle(), TWebControl::getTabIndex(), TWebControl::getTagName(), TWebControl::getToolTip(), TWebControl::getWidth(), TWebControl::render(), TWebControl::renderBeginTag(), TWebControl::renderContents(), TWebControl::renderEndTag(), TWebControl::setAccessKey(), TWebControl::setBackColor(), TWebControl::setBorderColor(), TWebControl::setBorderStyle(), TWebControl::setBorderWidth(), TWebControl::setCssClass(), TWebControl::setDisplay(), TWebControl::setForeColor(), TWebControl::setHeight(), TWebControl::setStyle(), TWebControl::setTabIndex(), TWebControl::setToolTip(), TWebControl::setWidth()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

addParsedObject

public void addParsedObject (mixed $object )

HTML-decodes static text.

This method overrides parent implementation.

Input
mixed $object object to be added as body content
Output
Exception

getText

public string getText ()

Output
string text to be processed
Exception

processText

public abstract string processText (string $text )

Processes a text string.

This method must be implemented by child classes.

Input
string | $text | text string to be processed
Output
string | the processed text result
Exception

renderContents

public void renderContents (THtmlWriter $writer )

Renders body content.

This method overrides the parent implementation by replacing the body content with the processed text content.

Input
THtmlWriter $writer writer
Output
Exception

setText

public void setText (string $value )

Input
string $value text to be processed
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTheme

Class TTheme (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TTheme

TTheme class

TTheme represents a particular theme. It is merely a collection of skins that are applicable to the corresponding controls.

Each theme is stored as a directory and files under that directory. The theme name is the directory name. When TTheme is created, the files whose name has the extension ".skin" are parsed and saved as controls skins.

A skin is essentially a list of initial property values that are to be applied to a control when the skin is applied. Each type of control can have multiple skins identified by the SkinID. If a skin does not have SkinID, it is the default skin that will be applied to controls that do not specify particular SkinID.

Whenever possible, TTheme will try to make use of available cache to save the parsing time.

To apply a theme to a particular control, call applySkin.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
boolean | applySkin ( TControl $control) Applies the theme to a particular control.
string | getBasePath ()
string | getBaseUrl ()
array | getJavaScriptFiles ()
string | getName ()
array | getSkins ()
array | getStyleSheetFiles ()
protected void | setBasePath ( string $value)
protected void | setBaseUrl ( string $value)
protected void | setJavaScriptFiles ( array $value)
protected void | setName ( string $value)
protected void | setSkins ( array $value)
protected void | setStyleSheetFiles ( array $value)
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | SKIN_FILE_EXT | Extension name of skin files
string | THEME_CACHE_PREFIX | prefix for cache variable name used to store parsed themes
Constructor Details

__construct

public __construct Array

Constructor.

Throws: TConfigurationException if theme path does not exist or any parsing error of the skin files
Method Details

applySkin

public boolean applySkin (TControl $control )

Applies the theme to a particular control.

The control's class name and SkinID value will be used to identify which skin to be applied. If the control's SkinID is empty, the default skin will be applied.

Input
TControl | $control | the control to be applied with a skin
Output
boolean | if a skin is successfully applied
Exception
throws | TConfigurationException if any error happened during the skin application

getBasePath

public string getBasePath ()

Output
string the file path to the theme folder
Exception

getBaseUrl

public string getBaseUrl ()

Output
string the URL to the theme folder (without ending slash)
Exception

getJavaScriptFiles

public array getJavaScriptFiles ()

Output
array list of Javascript files (URL) in the theme
Exception

getName

public string getName ()

Output
string theme name
Exception

getSkins

public array getSkins ()

Output
array list of skins for the theme
Exception

getStyleSheetFiles

public array getStyleSheetFiles ()

Output
array list of CSS files (URL) in the theme
Exception

setBasePath

protected void setBasePath (string $value )

Input
string $value tthe file path to the theme folder
Output
Exception

setBaseUrl

protected void setBaseUrl (string $value )

Input
string $value the URL to the theme folder
Output
Exception

setJavaScriptFiles

protected void setJavaScriptFiles (array $value )

Input
array $value list of Javascript files (URL) in the theme
Output
Exception

setName

protected void setName (string $value )

Input
string $value theme name
Output
Exception

setSkins

protected void setSkins (array $value )

Input
array $value list of skins for the theme
Output
Exception

setStyleSheetFiles

protected void setStyleSheetFiles (array $value )

Input
array $value list of CSS files (URL) in the theme
Output
Exception

Constant Details

SKIN_FILE_EXT

Extension name of skin files

Type:

string

Value:

'.skin'

THEME_CACHE_PREFIX

prefix for cache variable name used to store parsed themes

Type:

string

Value:

'prado:theme:'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TThemeManager

Class TThemeManager (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TThemeManager

TThemeManager class

TThemeManager manages the themes used in a Prado application.

Themes are stored under the directory specified by the BasePath property. The themes can be accessed via URL BaseUrl. Each theme is represented by a subdirectory and all the files under that directory. The name of a theme is the name of the corresponding subdirectory. By default, the base path of all themes is a directory named "themes" under the directory containing the application entry script. To get a theme (normally you do not need to), call getTheme.

TThemeManager may be configured within page service tag in application configuration file as follows, <module id="themes" class="System.Web.UI.TThemeManager" BasePath="Application.themes" BaseUrl="/themes" /> where getCacheExpire, getCacheControl and getBufferOutput are configurable properties of THttpResponse.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
array | getAvailableThemes ()
string | getBasePath ()
string | getBaseUrl ()
TTheme | getTheme ( string $name)
void | init ( TXmlElement $config) Initializes the module.
void | setBasePath ( string $value)
void | setBaseUrl ( string $value)
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string DEFAULT_BASEPATH default themes base path
Method Details

getAvailableThemes

public array getAvailableThemes ()

Output
array list of available theme names
Exception

getBasePath

public string getBasePath ()

Output
string | the base path for all themes. It is returned as an absolute path.
Exception
throws | TConfigurationException if base path is not set and "themes" directory does not exist.

getBaseUrl

public string getBaseUrl ()

Output
string | the base URL for all themes.
Exception
throws | TConfigurationException If base URL is not set and a correct one cannot be determined by Prado.

getTheme

public TTheme getTheme (string $name )

Input
string | $name | name of the theme to be retrieved
Output
TTheme | the theme retrieved
Exception

init

public void init (TXmlElement $config )

Initializes the module.

This method is required by IModule and is invoked by application.

Input
TXmlElement $config module configuration
Output
Exception

setBasePath

public void setBasePath (string $value )

Input
string | $value | the base path for all themes. It must be in the format of a namespace.
Output
Exception
throws | TInvalidDataValueException if the base path is not a proper namespace.

setBaseUrl

public void setBaseUrl (string $value )

Input
string $value the base URL for all themes.
Output
Exception

Constant Details

DEFAULT_BASEPATH

default themes base path

Type:

string

Value:

'themes'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TChoiceFormat

Class TChoiceFormat (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TI18NControl
            |
            --TTranslate
               |
               --TChoiceFormat

TChoiceFormat class.

This component performs message/string choice translation. The translation source is set in the TGlobalization module. The following example demonstrates a simple 2 choice message translation.

1      <com:TChoiceFormat Value="1">[1] One Apple. |[2] Two Apples</com:TChoiceFormat>

The Choice has Value "1" (one), thus the translated string is "One Apple". If the Value is "2", then it will show "Two Apples".

The message/string choices are separated by the pipe "|" followed by a set notation of the form

  • <tt>[1,2]</tt> -- accepts values between 1 and 2, inclusive.
  • <tt>(1,2)</tt> -- accepts values between 1 and 2, excluding 1 and 2.
  • <tt>{1,2,3,4}</tt> -- only values defined in the set are accepted.
  • <tt>[-Inf,0)</tt> -- accepts value greater or equal to negative infinity and strictly less than 0
Any non-empty combinations of the delimiters of square and round brackets are acceptable.

The string choosen for display depends on the Value property. The Value is evaluated for each set until the Value is found to belong to a particular set.

Properties

  • Value, float,
    Gets or sets the Value that determines which string choice to display.
Since version 3.1.2 the following set notation is also possible.

  • <tt>{n: n % 10 > 1 && n % 10 < 5}</tt> -- matches numbers like 2, 3, 4, 22, 23, 24
Where set is defined by the expression after <tt>n:</tt>. In particular, the expression accepts the following mathematical/logical operators to form a set of logical conditions on the value given by <tt>n</tt>:
  • <tt>&lt;</tt> -- less than.
  • <tt>&lt;=</tt> -- less than equals.
  • <tt>&gt;</tt> -- greater than.
  • <tt>&gt=</tt> -- greater than equals.
  • <tt>==</tt> -- of equal value.
  • <tt>%</tt> -- modulo, e.g., 1 % 10 equals 1, 11 % 10 equals 1.
  • <tt>-</tt> -- minus, negative.
  • <tt>+</tt> -- addition.
  • <tt>&amp;</tt> -- conditional AND.
  • <tt>&amp;&amp;</tt> -- condition AND with short circuit.
  • <tt>|</tt> -- conditional OR.
  • <tt>||</tt> -- conditional OR with short circuit.
  • <tt>!</tt> -- negation.
Additional round brackets can also be used to perform grouping.

Author: Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
float | getValue ()
void | setValue ( float $value) Sets the numerical choice value
protected void | translateText ( mixed $text, mixed $subs) Display the choosen translated string.
Methods Inherited From TTranslate
TTranslate::getCatalogue(), TTranslate::getKey(), TTranslate::getParameter(), TTranslate::getParameters(), TTranslate::getText(), TTranslate::getTrim(), TTranslate::hasParameter(), TTranslate::removeParameter(), TTranslate::render(), TTranslate::setCatalogue(), TTranslate::setKey(), TTranslate::setParameter(), TTranslate::setText(), TTranslate::setTrim(), TTranslate::translateText()
Methods Inherited From TI18NControl
TI18NControl::getCharset(), TI18NControl::getCulture(), TI18NControl::setCharset(), TI18NControl::setCulture()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getValue

public float getValue ()

Output
float the numerical value.
Exception

setValue

public void setValue (float $value )

Sets the numerical choice value

Input
float $value the choice value
Output
Exception

translateText

protected void translateText (mixed $text , mixed $subs )

Display the choosen translated string.

Overrides the parent method, also calls parent's renderBody to translate.

Input
mixed | $text
mixed | $subs
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDateFormat

Class TDateFormat (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TI18NControl
            |
            --TDateFormat

To format dates and/or time according to the current locale use

1      <com:TDateFormat Pattern="dd:MMM:yyyy" Value="01/01/2001" />
The date will be formatted according to the current locale (or culture) using the format specified by 'Pattern' attribute.

To format date and/or time for a locale (e.g. de_DE) include a Culture attribute, for example:

1      <com:TDateFormat Culture="de_DE" Value="01/01/2001 12:00" />
The date will be formatted according to this format.

If no Pattern was specified then the date will be formatted with the default format (both date and time). If no value for the date is specified then the current date will be used. E.g.:

1     <com:TDateFormat />
will result in the current date, formatted with default localized pattern.

Namespace: System.I18N

Properties

  • Value, date,
    Gets or sets the date to format. The tag content is used as Value if the Value property is not specified.
  • Pattern, string,
    Gets or sets the formatting pattern. The predefined patterns are 'fulldate', 'longdate', 'mediumdate', 'shortdate', 'fulltime',
'longtime', 'mediumtime', and 'shorttime'. Custom patterns can specified when the Pattern property does not match the predefined patterns.
  • DefaultText, string,
    Gets or sets the default text. If Value is not set, DefaultText will be
shown instead of todays date and time.

Author: Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getData () Get the date-time value for this control.
string | getDefaultText () Get the default text value for this control.
protected void | getFormattedDate () Renders the localized version of the date-time value.
string | getPattern () Gets the date time format pattern.
protected string | getPreset ( string $string) For a given string, try and find a preset pattern.
string | getValue () Get the date-time value for this control.
void | render ( mixed $writer)
void | setData ( string $value) Set the date-time value for this control.
void | setDefaultText ( string $value) Set the default text value for this control.
void | setPattern ( string $value) Sets the date time formatting pattern.
void | setValue ( string $value) Set the date-time value for this control.
Methods Inherited From TI18NControl
TI18NControl::getCharset(), TI18NControl::getCulture(), TI18NControl::setCharset(), TI18NControl::setCulture()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getData

public string getData ()

Get the date-time value for this control.

This method is required by IDataRenderer. It is the same as getValue().

Output
string date time value.
Exception

getDefaultText

public string getDefaultText ()

Get the default text value for this control.

Output
string default text value
Exception

getFormattedDate

protected void getFormattedDate ()

Renders the localized version of the date-time value.

If the culture is not specified, the default application culture will be used. This method overrides parent's implementation.

Output
Exception

getPattern

public string getPattern ()

Gets the date time format pattern.

Output
string format pattern.
Exception

getPreset

protected string getPreset (string $string )

For a given string, try and find a preset pattern.

Input
string | $string | the preset pattern name
Output
string | a preset pattern if found, null otherwise.
Exception

getValue

public string getValue ()

Get the date-time value for this control.

Output
string date time value.
Exception

render

public void render (mixed $writer )

Input
mixed $writer
Output
Exception

setData

public void setData (string $value )

Set the date-time value for this control.

This method is required by IDataRenderer. It is the same as setValue().

Input
string $value the date-time value.
Output
Exception

setDefaultText

public void setDefaultText (string $value )

Set the default text value for this control.

Input
string $value default text value
Output
Exception

setPattern

public void setPattern (string $value )

Sets the date time formatting pattern.

Input
string $value format pattern.
Output
Exception

setValue

public void setValue (string $value )

Set the date-time value for this control.

Input
string $value the date-time value.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TGlobalization

Class TGlobalization (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TGlobalization

Direct Known Sub-classes:

TGlobalizationAutoDetect

TGlobalization contains settings for Culture, Charset and TranslationConfiguration.

TGlobalization can be subclassed to change how the Culture, Charset are determined. See TGlobalizationAutoDetect for example of setting the Culture based on browser settings.

Since: 3.0
Author: Wei Zhuo<weizhuo[at]gmail[dot]com>
Method Summary
string | getCharset ()
string | getCulture ()
array | getCultureVariants ( string $culture) Gets all the variants of a specific culture. If the parameter $culture is null, the current culture is used.
string | getDefaultCharset ()
string | getDefaultCulture ()
array | getLocalizedResource ( string $file, string $culture) Returns a list of possible localized files. Example
string | getTranslationCatalogue ()
TMap | getTranslationConfiguration ()
void | init ( TXmlElement $xml) Initialize the Culture and Charset for this application.
void | setCharset ( string $charset)
void | setCulture ( string $culture)
void | setDefaultCharset ( string $charset)
void | setDefaultCulture ( string $culture)
void | setTranslationCatalogue ( string $value)
protected void | setTranslationConfiguration ( TMap $config) Sets the translation configuration. Example configuration:
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getCharset

public string getCharset ()

Output
string localization charset
Exception

getCulture

public string getCulture ()

Output
string current application culture
Exception

getCultureVariants

public array getCultureVariants (string $culture )

Gets all the variants of a specific culture. If the parameter $culture is null, the current culture is used.

Input
string | $culture | the Culture string
Output
array | variants of the culture.
Exception

getDefaultCharset

public string getDefaultCharset ()

Output
string default charset set
Exception

getDefaultCulture

public string getDefaultCulture ()

Output
string default culture
Exception

getLocalizedResource

public array getLocalizedResource (string $file , string $culture )

Returns a list of possible localized files. Example

1      $files = $app->getLocalizedResource("path/to/Home.page","en_US");
will return
 array
   0 => 'path/to/en_US/Home.page'
   1 => 'path/to/en/Home.page'
   2 => 'path/to/Home.en_US.page'
   3 => 'path/to/Home.en.page'
   4 => 'path/to/Home.page'
Note that you still need to verify the existance of these files.

Input
string | $file | filename
string | $culture | culture string, null to use current culture
Output
array | list of possible localized resource files.
Exception

getTranslationCatalogue

public string getTranslationCatalogue ()

Output
string current translation catalogue.
Exception

getTranslationConfiguration

public TMap getTranslationConfiguration ()

Output
TMap translation source configuration.
Exception

init

public void init (TXmlElement $xml )

Initialize the Culture and Charset for this application.

You should override this method if you want a different way of setting the Culture and/or Charset for your application. If you override this method, call parent::init($xml) first.

Input
TXmlElement $xml application configuration
Output
Exception

setCharset

public void setCharset (string $charset )

Input
string $charset localization charset, e.g. <tt>UTF-8</tt>
Output
Exception

setCulture

public void setCulture (string $culture )

Input
string $culture culture, e.g. <tt>en_US</tt> for American English
Output
Exception

setDefaultCharset

public void setDefaultCharset (string $charset )

Input
string $charset default localization charset, e.g. <tt>UTF-8</tt>
Output
Exception

setDefaultCulture

public void setDefaultCulture (string $culture )

Input
string $culture default culture, e.g. <tt>en_US</tt> for American English
Output
Exception

setTranslationCatalogue

public void setTranslationCatalogue (string $value )

Input
string $value update the translation catalogue.
Output
Exception

setTranslationConfiguration

protected void setTranslationConfiguration (TMap $config )

Sets the translation configuration. Example configuration:

1      $config['type'] = 'XLIFF'; //XLIFF, gettext, Database or MySQL (deprecated)
2       $config['source'] = 'Path.to.directory'; // for types XLIFF and gettext
3       $config['source'] = 'connectionId'; // for type Database
4       $config['source'] = 'mysql://user:pw@host/db'; // for type MySQL (deprecated)
5       $config['catalogue'] = 'messages'; //default catalog
6       $config['autosave'] = 'true'; //save untranslated message
7       $config['cache'] = 'true'; //cache translated message
7       $config['marker'] = '@@'; // surround untranslated text with '@@'
Throws exception is source is not found.

Input
TMap $config configuration options
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TGlobalizationAutoDetect

Class TGlobalizationAutoDetect (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TGlobalization
            |
            --TGlobalizationAutoDetect

TGlobalizationAutoDetect class will automatically try to resolve the default culture using the user browser language settings.

Author: Wei Zhuo<weizhuo[at]gmail[dot]com>
Method Summary
void | getDetectedLanguage ()
void | init ( mixed $xml)
Methods Inherited From TGlobalization
TGlobalization::getCharset(), TGlobalization::getCulture(), TGlobalization::getCultureVariants(), TGlobalization::getDefaultCharset(), TGlobalization::getDefaultCulture(), TGlobalization::getLocalizedResource(), TGlobalization::getTranslationCatalogue(), TGlobalization::getTranslationConfiguration(), TGlobalization::init(), TGlobalization::setCharset(), TGlobalization::setCulture(), TGlobalization::setDefaultCharset(), TGlobalization::setDefaultCulture(), TGlobalization::setTranslationCatalogue(), TGlobalization::setTranslationConfiguration()
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getDetectedLanguage

public void getDetectedLanguage ()

Output
Exception

init

public void init (mixed $xml )

Input
mixed $xml
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TI18NControl

Class TI18NControl (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TI18NControl

Direct Known Sub-classes:

TDateFormat , TNumberFormat , TTranslate

TI18NControl class.

Base class for I18N components, providing Culture and Charset properties. Namespace: System.I18N

Properties

  • Culture, string,
    Gets or sets the culture for formatting. If the Culture property is not specified. The culture from the Application/Page is used.
  • Charset, string,
    Gets or sets the charset for both input and output. If the Charset property is not specified. The charset from the Application/Page is used. The default is UTF-8.

Author: Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getCharset () Gets the charset.
string | getCulture ( parameter 0) Get the specific culture for this control.
void | setCharset ( string $value) Sets the charset for message output
void | setCulture ( string $culture) Get the custom culture identifier.
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getCharset

public string getCharset ()

Gets the charset.

It is evaluated in the following order: 1) application charset, 2) the default charset in globalization 3) UTF-8

Output
string charset
Exception

getCulture

public string getCulture (parameter 0 )

Get the specific culture for this control.

Input
parameter | 0
Output
string | culture identifier.
Exception

setCharset

public void setCharset (string $value )

Sets the charset for message output

Input
string $value the charset, e.g. UTF-8
Output
Exception

setCulture

public void setCulture (string $culture )

Get the custom culture identifier.

Input
string $culture culture identifier.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TNumberFormat

Class TNumberFormat (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TI18NControl
            |
            --TNumberFormat

To format numbers in locale sensitive manner use

1      <com:TNumberFormat Pattern="0.##" value="2.0" />

Numbers can be formatted as currency, percentage, decimal or scientific numbers by specifying the Type attribute. The known types are "currency", "percentage", "decimal" and "scientific".

If someone from US want to see sales figures from a store in Germany (say using the EURO currency), formatted using the german currency, you would need to use the attribute Culture="de_DE" to get the currency right, e.g. 100,00. The decimal and grouping separator is then also from the de_DE locale. This may lead to some confusion because people from US know the "," as thousand separator. Therefore a "Currency" attribute is available, so that the output from the following example results in 100.00.

1      <com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" />

Namespace: System.I18N

Properties

  • Value, number,
    Gets or sets the number to format. The tag content is used as Value if the Value property is not specified.
  • Type, string,
    Gets or sets the formatting type. The valid types are 'decimal', 'currency', 'percentage' and 'scientific'.
  • Currency, string,
    Gets or sets the currency symbol for the currency format. The default is 'USD' if the Currency property is not specified.
  • Pattern, string,
    Gets or sets the custom number formatting pattern.
  • DefaultText, string,
    Gets or sets the default text. If Value is not set, DefaultText will be
shown instead of the default currency Value/Pattern.

Author: Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getCurrency ()
string | getData () Get the numberic value for this control.
string | getDefaultText () Get the default text value for this control.
protected string | getFormattedValue () Formats the localized number, be it currency or decimal, or percentage.
string | getPattern () Get the number formatting pattern.
string | getType () Get the formatting type for this control.
string | getValue () Get the numberic value for this control.
void | render ( mixed $writer)
void | setCurrency ( string $currency) Set the 3-letter ISO 4217 code. For example, the code "USD" represents the US Dollar and "EUR" represents the Euro currency.
void | setData ( string $value) Set the numberic value for this control.
void | setDefaultText ( string $value) Set the default text value for this control.
void | setPattern ( string $pattern) Set the number format pattern.
void | setType ( string $type) Set the formatting type for this control.
void | setValue ( string $value) Set the numberic value for this control.
Methods Inherited From TI18NControl
TI18NControl::getCharset(), TI18NControl::getCulture(), TI18NControl::setCharset(), TI18NControl::setCulture()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getCurrency

public string getCurrency ()

Output
string 3 letter currency code. Defaults to 'USD'.
Exception

getData

public string getData ()

Get the numberic value for this control.

This method is required by IDataRenderer. It is the same as getValue().

Output
string number
Exception

getDefaultText

public string getDefaultText ()

Get the default text value for this control.

Output
string default text value
Exception

getFormattedValue

protected string getFormattedValue ()

Formats the localized number, be it currency or decimal, or percentage.

If the culture is not specified, the default application culture will be used.

Output
string formatted number
Exception

getPattern

public string getPattern ()

Get the number formatting pattern.

Output
string format pattern.
Exception

getType

public string getType ()

Get the formatting type for this control.

Output
string formatting type.
Exception

getValue

public string getValue ()

Get the numberic value for this control.

Output
string number
Exception

render

public void render (mixed $writer )

Input
mixed $writer
Output
Exception

setCurrency

public void setCurrency (string $currency )

Set the 3-letter ISO 4217 code. For example, the code "USD" represents the US Dollar and "EUR" represents the Euro currency.

Input
string $currency currency code.
Output
Exception

setData

public void setData (string $value )

Set the numberic value for this control.

This method is required by IDataRenderer. It is the same as setValue().

Input
string $value the number value
Output
Exception

setDefaultText

public void setDefaultText (string $value )

Set the default text value for this control.

Input
string $value default text value
Output
Exception

setPattern

public void setPattern (string $pattern )

Set the number format pattern.

Input
string $pattern format pattern.
Output
Exception

setType

public void setType (string $type )

Set the formatting type for this control.

Input
string | $type | formatting type, either "decimal", "currency","percentage" or "scientific"
Output
Exception
throws | TPropertyTypeInvalidException

setValue

public void setValue (string $value )

Set the numberic value for this control.

Input
string $value the number value
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class Translation

Class Translation (Class Overview)

TComponent
   |
   --Translation

Translation class.

Provides translation using a static MessageFormatter.

Author: Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
MessageFormat | formatter ( mixed $catalogue) Get the static formatter from this component.
void | init ( mixed $catalogue) Initialize the TTranslate translation components
void | saveMessages () Save untranslated messages to the catalogue.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

formatter

public MessageFormat formatter (mixed $catalogue )

Get the static formatter from this component.

Input
mixed | $catalogue
Output
MessageFormat | formattter.
Exception

init

public void init (mixed $catalogue )

Initialize the TTranslate translation components

Input
mixed $catalogue
Output
Exception

saveMessages

public void saveMessages ()

Save untranslated messages to the catalogue.

Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTranslate

Class TTranslate (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TI18NControl
            |
            --TTranslate

Direct Known Sub-classes:

TChoiceFormat

TTranslate class.

This component performs message/string translation. The translation source is set in the TGlobalization handler. The following example demonstrated a simple message translation.

1      <com:TTranslate Text="Goodbye" />

Depending on the culture set on the page, the phrase "Goodbye" will be translated.

The Parameters property can be use to add name values pairs for substitution. Substrings enclosed with "{" and "}" in the translation message are consider as the parameter names during substitution lookup. The following example will substitute the substring "{time}" with the value of the parameter attribute "Parameters.time=<%= time() %>. Note that the value of the parameter named "time" is evaluated.

1      <com:TTranslate Parameters.time=<%= time() %> >
2        The unix-time is "{time}".
3      </com:TTranslate>

More complex string substitution can be applied using the TTranslateParameter component.

Namespace: System.I18N

Properties

  • Text, string,
    Gets or sets the string to translate.
  • Catalogue, string,
    Gets or sets the catalogue for message translation. The default catalogue can be set by the @Page directive.
  • Key, string,
    Gets or sets the key used to message look up.
  • Trim, boolean,
    Gets or sets an option to trim the contents. Default is to trim the contents.

Author: Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getCatalogue () Get the message catalogue.
string | getKey () Get the key for message lookup.
string | getParameter ( mixed $name)
TAttributeCollection | getParameters () Returns the list of custom parameters.
string | getText ()
boolean | getTrim () Trim the content or not.
boolean | hasParameter ( mixed $name)
string | removeParameter ( string $name) Removes the named parameter.
void | render ( mixed $writer) renders the translated string.
void | setCatalogue ( string $value) Set the message catalogue.
void | setKey ( string $value) Set the key for message lookup.
void | setParameter ( string $name, string $value)
void | setText ( string $value) Sets the text for localization.
void | setTrim ( boolean $value) Set the option to trim the contents.
protected string | translateText ( string $text, array $subs) Translates the text with subsititution.
Methods Inherited From TI18NControl
TI18NControl::getCharset(), TI18NControl::getCulture(), TI18NControl::setCharset(), TI18NControl::setCulture()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getCatalogue

public string getCatalogue ()

Get the message catalogue.

Output
string catalogue.
Exception

getKey

public string getKey ()

Get the key for message lookup.

Output
string key
Exception

getParameter

public string getParameter (mixed $name )

Input
mixed | $name
Output
string | parameter value, null if parameter does not exist
Exception

getParameters

public TAttributeCollection getParameters ()

Returns the list of custom parameters.

Custom parameters are name-value pairs that may subsititute translation place holders during rendering.

Output
TAttributeCollection the list of custom parameters
Exception

getText

public string getText ()

Output
string the text to be localized/translated.
Exception

getTrim

public boolean getTrim ()

Trim the content or not.

Output
boolean trim or not.
Exception

hasParameter

public boolean hasParameter (mixed $name )

Input
mixed | $name
Output
boolean | whether the named parameter exists
Exception

removeParameter

public string removeParameter (string $name )

Removes the named parameter.

Input
string | $name | the name of the parameter to be removed.
Output
string | parameter value removed, null if parameter does not exist.
Exception

render

public void render (mixed $writer )

renders the translated string.

Input
mixed $writer
Output
Exception

setCatalogue

public void setCatalogue (string $value )

Set the message catalogue.

Input
string $value catalogue.
Output
Exception

setKey

public void setKey (string $value )

Set the key for message lookup.

Input
string $value key
Output
Exception

setParameter

public void setParameter (string $name , string $value )

Input
string | $name | parameter name
string | $value | value of the parameter
Output
Exception

setText

public void setText (string $value )

Sets the text for localization.

Input
string $value the text for translation.
Output
Exception

setTrim

public void setTrim (boolean $value )

Set the option to trim the contents.

Input
boolean $value trim or not.
Output
Exception

translateText

protected string translateText (string $text , array $subs )

Translates the text with subsititution.

Input
string | $text | text for translation
array | $subs | list of substitutions
Output
string | translated text
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTranslateParameter

Class TTranslateParameter (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TTranslateParameter

TTranslateParameter component should be used inside the TTranslate component to allow parameter substitution.

For example, the strings "{greeting}" and "{name}" will be replace with the values of "Hello" and "World", respectively. The substitution string must be enclose with "{" and "}". The parameters can be further translated by using TTranslate.

1      <com:TTranslate>
2        {greeting} {name}!
3        <com:TTranslateParameter Key="name">World</com:TTranslateParameter>
4        <com:TTranslateParameter Key="greeting">Hello</com:TTranslateParameter>
5      </com:TTranslate>

Namespace: System.I18N

Properties

  • Key, string, required.
    Gets or sets the string in TTranslate to substitute.
  • Trim, boolean,
    Gets or sets an option to trim the contents of the TParam. Default is to trim the contents.

Author: Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
string | getKey () Get the parameter substitution key.
string | getParameter ()
boolean | getTrim () Trim the content or not.
void | getValue ()
void | setKey ( string $value) Set the parameter substitution key.
void | setTrim ( boolean $value) Set the option to trim the contents.
void | setValue ( mixed $value)
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getKey

public string getKey ()

Get the parameter substitution key.

Output
string substitution key.
Exception

getParameter

public string getParameter ()

Output
string parameter contents.
Exception

getTrim

public boolean getTrim ()

Trim the content or not.

Output
boolean trim or not.
Exception

getValue

public void getValue ()

Output
Exception

setKey

public void setKey (string $value )

Set the parameter substitution key.

Input
string $value substitution key.
Output
Exception

setTrim

public void setTrim (boolean $value )

Set the option to trim the contents.

Input
boolean $value trim or not.
Output
Exception

setValue

public void setValue (mixed $value )

Input
mixed $value
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataFieldAccessor

Class TDataFieldAccessor (Class Overview)

TDataFieldAccessor class

TDataFieldAccessor is a utility class that provides access to a field of some data.  The accessor attempts to obtain the field value in the following order:
  • If the data is an array, then the field is treated as an array index
   and the corresponding element value is returned;
  • If the data is a TMap or TList object, then the field is treated as a key
   into the map or list, and the corresponding value is returned.
  • If the data is an object, the field is treated as a property or sub-property
   defined with getter methods. For example, if the object has a method called
   getMyValue(), then field 'MyValue' will retrieve the result of this method call.
   If getMyValue() returns an object which contains a method getMySubValue(),
   then field 'MyValue.MySubValue' will return that method call result.

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

            Method Summary

                        mixed

                            getDataFieldValue
                        (	mixed $data, 	mixed $field)

                            Evaluates the data value at the specified field.

            Method Details

getDataFieldValue

                                public mixed getDataFieldValue
                                (mixed $data , mixed $field )

Evaluates the data value at the specified field.

  • If the data is an array, then the field is treated as an array index
   and the corresponding element value is returned;
  • If the data is a TMap or TList object, then the field is treated as a key
   into the map or list, and the corresponding value is returned.
  • If the data is an object, the field is treated as a property or sub-property
   defined with getter methods. For example, if the object has a method called
   getMyValue(), then field 'MyValue' will retrieve the result of this method call.
   If getMyValue() returns an object which contains a method getMySubValue(),
   then field 'MyValue.MySubValue' will return that method call result.

Input
mixed | $data | data containing the field value, can be an array, TMap, TList or object.
mixed | $field | field value
Output
mixed | value at the specified field
Exception
throws | TInvalidDataValueException if field or data is invalid


PRADO API Manual: Docs For Class TDateTimeStamp

Class TDateTimeStamp (Class Overview)

TDateTimeStamp Class

TDateTimeStamp Class is adpated from the ADOdb Date Library,  part of the ADOdb abstraction library  Download: http://phplens.com/phpeverywhere/
http://phplens.com/phpeverywhere/adodb_date_library
PHP native date functions use integer timestamps for computations.  Because of this, dates are restricted to the years 1901-2038 on Unix  and 1970-2038 on Windows due to integer overflow for dates beyond  those years. This library overcomes these limitations by replacing the  native function's signed integers (normally 32-bits) with PHP floating  point numbers (normally 64-bits).
Dates from 100 A.D. to 3000 A.D. and later have been tested. The minimum  is 100 A.D. as <100 will invoke the 2 => 4 digit year conversion.  The maximum is billions of years in the future, but this is a theoretical  limit as the computation of that year would take too long with the  current implementation of getTimeStamp.
PERFORMANCE  For high speed, this library uses the native date functions where  possible, and only switches to PHP code when the dates fall outside  the 32-bit signed integer range.

            Since:
            3.0.4

            Author:
            Wei Zhuo <weizhuo[at]gmail[dot]com>

Method Summary
protected integer | digitCheck ( mixed $y) Fix 2-digit years. Works for any century.
string | formatDate ( mixed $fmt, mixed $d, mixed $is_gmt)
void | get4DigitYear ( mixed $y)
array | getDate ( mixed $d, mixed $fast)
void | getDayofWeek ( mixed $year, mixed $month, mixed $day) Gets day of week, 0 = Sunday,... 6=Saturday.
integer | getGMTDiff ()
integer|float | getTimeStamp ( mixed $hr, mixed $min, mixed $sec, mixed $mon, mixed $day, mixed $year, mixed $is_gmt) Not a very fast algorithm - O(n) operation. Could be optimized to O(1).
boolean | isLeapYear ( float $year) Checks for leap year, returns true if it is. No 2-digit year check. Also handles julian calendar correctly.
boolean | isValidDate ( mixed $y, mixed $m, mixed $d)
protected array | _getDateInternal ( float $origd, boolean $fast, boolean $is_gmt) Low-level function that returns the getdate() array. We have a special $fast flag, which if set to true, will return fewer array values, and is much faster as it does not calculate dow, etc.

            Method Details

digitCheck

                                protected integer digitCheck
                                (mixed $y )

Fix 2-digit years. Works for any century.

Assumes that if 2-digit is more than 30 years in future, then previous century.

Input
mixed | $y
Output
integer | change two digit year into multiple digits
Exception

formatDate

                                public string formatDate
                                (mixed $fmt , mixed $d , mixed $is_gmt )

Input
mixed | $fmt
mixed | $d
mixed | $is_gmt
Output
string | formatted date based on timestamp $d
Exception

get4DigitYear

                                public void get4DigitYear
                                (mixed $y )

Input

mixed $y

Output

Exception

getDate

                                public array getDate
                                (mixed $d , mixed $fast )

Input
mixed | $d
mixed | $fast
Output
array | an array with date info.
Exception

getDayofWeek

                                public void getDayofWeek
                                (mixed $year , mixed $month , mixed $day )

Gets day of week, 0 = Sunday,... 6=Saturday.

Algorithm from PEAR::Date_Calc

Input
mixed | $year
mixed | $month
mixed | $day
Output
Exception

getGMTDiff

                                public integer getGMTDiff
                                ()

Output

                                    integer
                 get local time zone offset from GMT

Exception

getTimeStamp

                                public integer|float getTimeStamp
                                (mixed $hr , mixed $min , mixed $sec , mixed $mon , mixed $day , mixed $year , mixed $is_gmt )

Not a very fast algorithm - O(n) operation. Could be optimized to O(1).

Input
mixed | $hr
mixed | $min
mixed | $sec
mixed | $mon
mixed | $day
mixed | $year
mixed | $is_gmt
Output
integer|float | a timestamp given a local time. Originally by jackbbs.
Exception

isLeapYear

                                public boolean isLeapYear
                                (float $year )

Checks for leap year, returns true if it is. No 2-digit year check. Also  handles julian calendar correctly.

Input
float | $year | year to check
Output
boolean | true if is leap year
Exception

isValidDate

                                public boolean isValidDate
                                (mixed $y , mixed $m , mixed $d )

Input
mixed | $y
mixed | $m
mixed | $d
Output
boolean | true if valid date, semantic check only.
Exception

_getDateInternal

                                protected array _getDateInternal
                                (float $origd , boolean $fast , boolean $is_gmt )

Low-level function that returns the getdate() array. We have a special  $fast flag, which if set to true, will return fewer array values,  and is much faster as it does not calculate dow, etc.

Input
float | $origd | original date
boolean | $fast | false to compute the day of the week, default is true
boolean | $is_gmt | true to calculate the GMT dates
Output
array | an array with date info.
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TLogger

Class TLogger (Class Overview)

TComponent
   |
   --TLogger

TLogger class.

TLogger records log messages in memory and implements the methods to retrieve the messages with filter conditions, including log levels and log categories.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | getLogs ( integer $levels, string $categories, array 2) Retrieves log messages.
void | log ( string $message, integer $level, string $category) Logs a message.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
int | ALERT |
int | DEBUG | Log levels.
int | ERROR |
int | FATAL |
int | INFO |
int | NOTICE |
int | WARNING |
Method Details

getLogs

public void getLogs (integer $levels , string $categories , array 2 )

Retrieves log messages.

Messages may be filtered by log levels and/or categories. A level filter is specified by an integer, whose bits indicate the levels interested. For example, (TLogger::INFO | TLogger::WARNING) specifies INFO and WARNING levels. A category filter is specified by concatenating interested category names with commas. A message whose category name starts with any filtering category will be returned. For example, a category filter 'System.Web, System.IO' will return messages under categories such as 'System.Web', 'System.IO', 'System.Web.UI', 'System.Web.UI.WebControls', etc. Level filter and category filter are combinational, i.e., only messages satisfying both filter conditions will they be returned.

Input
integer | $levels | level filter
string | $categories | category filter
array | 2 | list of messages. Each array elements represents one message with the following structure: array( [0] => message [1] => level [2] => category [3] => timestamp (by microtime(), float number));
Output
Exception

log

public void log (string $message , integer $level , string $category )

Logs a message.

Messages logged by this method may be retrieved via getLogs.

Input
string | $message | message to be logged
integer | $level | level of the message. Valid values include TLogger::DEBUG, TLogger::INFO, TLogger::NOTICE, TLogger::WARNING, TLogger::ERROR, TLogger::ALERT, TLogger::FATAL.
string | $category | category of the message
Output
Exception
Constant Details

ALERT

Type:

int

Value:

0x20

DEBUG

Log levels.

Type:

int

Value:

0x01

ERROR

Type:

int

Value:

0x10

FATAL

Type:

int

Value:

0x40

INFO

Type:

int

Value:

0x02

NOTICE

Type:

int

Value:

0x04

WARNING

Type:

int

Value:

0x08
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TBrowserLogRoute

Class TBrowserLogRoute (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute
         |
         --TBrowserLogRoute

Direct Known Sub-classes:

TFirebugLogRoute

TBrowserLogRoute class.

TBrowserLogRoute prints selected log messages in the response.

Since: 3.0
Author: Xiang Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
protected void | getColorLevel ( mixed $level)
string | getCssClass ()
void | processLogs ( mixed $logs)
protected void | renderFooter ()
protected void | renderHeader ()
protected void | renderMessage ( mixed $log, mixed $info)
void | setCssClass ( string $value)
Methods Inherited From TLogRoute
TLogRoute::collectLogs(), TLogRoute::formatLogMessage(), TLogRoute::getCategories(), TLogRoute::getLevelName(), TLogRoute::getLevels(), TLogRoute::getLevelValue(), TLogRoute::init(), TLogRoute::setCategories(), TLogRoute::setLevels()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getColorLevel

protected void getColorLevel (mixed $level )

Input
mixed $level
Output
Exception

getCssClass

public string getCssClass ()

Output
string the css class of the control
Exception

processLogs

public void processLogs (mixed $logs )

Input
mixed $logs
Output
Exception

renderFooter

protected void renderFooter ()

Output
Exception

renderHeader

protected void renderHeader ()

Output
Exception

renderMessage

protected void renderMessage (mixed $log , mixed $info )

Input
mixed | $log
mixed | $info
Output
Exception

setCssClass

public void setCssClass (string $value )

Input
string $value the css class of the control
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbLogRoute

Class TDbLogRoute (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute
         |
         --TDbLogRoute

TDbLogRoute class

TDbLogRoute stores log messages in a database table. To specify the database table, set ConnectionID to be the ID of a TDataSourceConfig module and LogTableName. If they are not setting, an SQLite3 database named 'sqlite3.log' will be created and used under the runtime directory.

By default, the database table name is 'pradolog'. It has the following structure:

1         CREATE TABLE pradolog
2       (
3             log_id INTEGER NOT NULL PRIMARY KEY,
4             level INTEGER,
5             category VARCHAR(128),
6             logtime VARCHAR(20),
7             message VARCHAR(255)
8        );

Since: 3.1.2
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected TDbConnection | createDbConnection ( string 0) Creates the DB connection.
protected void | createDbTable () Creates the DB table for storing log messages.
boolean | getAutoCreateLogTable ()
string | getConnectionID ()
TDbConnection | getDbConnection ()
string | getLogTableName ()
void | init ( TXmlElement $config) Initializes this module.
protected void | processLogs ( array $logs) Stores log messages into database.
void | setAutoCreateLogTable ( boolean $value)
void | setConnectionID ( string $value) Sets the ID of a TDataSourceConfig module.
void | setLogTableName ( string $value) Sets the name of the DB table to store log content.
Methods Inherited From TLogRoute
TLogRoute::collectLogs(), TLogRoute::formatLogMessage(), TLogRoute::getCategories(), TLogRoute::getLevelName(), TLogRoute::getLevels(), TLogRoute::getLevelValue(), TLogRoute::init(), TLogRoute::setCategories(), TLogRoute::setLevels()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createDbConnection

protected TDbConnection createDbConnection (string 0 )

Creates the DB connection.

Input
string | 0 | the module ID for TDataSourceConfig
Output
TDbConnection | the created DB connection
Exception
throws | TConfigurationException if module ID is invalid or empty

createDbTable

protected void createDbTable ()

Creates the DB table for storing log messages.

Output
Exception

getAutoCreateLogTable

public boolean getAutoCreateLogTable ()

Output
boolean whether the log DB table should be automatically created if not exists. Defaults to true.
Exception

getConnectionID

public string getConnectionID ()

Output
string the ID of a TDataSourceConfig module. Defaults to empty string, meaning not set.
Exception

getDbConnection

public TDbConnection getDbConnection ()

Output
TDbConnection the DB connection instance
Exception

getLogTableName

public string getLogTableName ()

Output
string the name of the DB table to store log content. Defaults to 'pradolog'.
Exception

init

public void init (TXmlElement $config )

Initializes this module.

This method is required by the IModule interface. It initializes the database for logging purpose.

Input
TXmlElement | $config | configuration for this module, can be null
Output
Exception
throws | TConfigurationException if the DB table does not exist.

processLogs

protected void processLogs (array $logs )

Stores log messages into database.

Input
array $logs list of log messages
Output
Exception

setAutoCreateLogTable

public void setAutoCreateLogTable (boolean $value )

Input
boolean $value whether the log DB table should be automatically created if not exists.
Output
Exception

setConnectionID

public void setConnectionID (string $value )

Sets the ID of a TDataSourceConfig module.

The datasource module will be used to establish the DB connection for this log route.

Input
string $value ID of the TDataSourceConfig module
Output
Exception

setLogTableName

public void setLogTableName (string $value )

Sets the name of the DB table to store log content.

Note, if AutoCreateLogTable is false and you want to create the DB table manually by yourself, you need to make sure the DB table is of the following structure: (key CHAR(128) PRIMARY KEY, value BLOB, expire INT)

Input
string $value the name of the DB table to store log content
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TEmailLogRoute

Class TEmailLogRoute (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute
         |
         --TEmailLogRoute

TEmailLogRoute class.

TEmailLogRoute sends selected log messages to email addresses. The target email addresses may be specified via Emails property. Optionally, you may set the email Subject and the SentFrom address.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
array | getEmails ()
string | getSentFrom ()
string | getSubject ()
void | init ( TXmlElement $config) Initializes the route.
protected void | processLogs ( array $logs) Sends log messages to specified email addresses.
array|string | setEmails ( mixed $emails)
void | setSentFrom ( string $value)
void | setSubject ( string $value)
Methods Inherited From TLogRoute
TLogRoute::collectLogs(), TLogRoute::formatLogMessage(), TLogRoute::getCategories(), TLogRoute::getLevelName(), TLogRoute::getLevels(), TLogRoute::getLevelValue(), TLogRoute::init(), TLogRoute::setCategories(), TLogRoute::setLevels()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | DEFAULT_SUBJECT | Default email subject.
string | EMAIL_PATTERN | Regex pattern for email address.
Method Details

getEmails

public array getEmails ()

Output
array list of destination email addresses
Exception

getSentFrom

public string getSentFrom ()

Output
string send from address of the email
Exception

getSubject

public string getSubject ()

Output
string email subject. Defaults to TEmailLogRoute::DEFAULT_SUBJECT
Exception

init

public void init (TXmlElement $config )

Initializes the route.

Input
TXmlElement | $config | configurations specified in TLogRouter.
Output
Exception
throws | TConfigurationException if SentFrom is empty and 'sendmail_from' in php.ini is also empty.

processLogs

protected void processLogs (array $logs )

Sends log messages to specified email addresses.

Input
array $logs list of log messages
Output
Exception

setEmails

public array|string setEmails (mixed $emails )

Input
mixed | $emails
Output
array|string | list of destination email addresses. If the value is a string, it is assumed to be comma-separated email addresses.
Exception

setSentFrom

public void setSentFrom (string $value )

Input
string $value send from address of the email
Output
Exception

setSubject

public void setSubject (string $value )

Input
string $value email subject.
Output
Exception

Constant Details

DEFAULT_SUBJECT

Default email subject.

Type:

string

Value:

'Prado Application Log'

EMAIL_PATTERN

Regex pattern for email address.

Type:

string

Value:

'/^([0-9a-zA-Z]+[-._+&])*[0-9a-zA-Z]+@([-0-9a-zA-Z]+[.])+[a-zA-Z]{2,6}$/'


PRADO API Manual: Docs For Class TFileLogRoute

Class TFileLogRoute (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute
         |
         --TFileLogRoute

TFileLogRoute class.

TFileLogRoute records log messages in files. The log files are stored under LogPath and the file name is specified by LogFile. If the size of the log file is greater than MaxFileSize (in kilo-bytes), a rotation is performed, which renames the current log file by suffixing the file name with '.1'. All existing log files are moved backwards one place, i.e., '.2' to '.3', '.1' to '.2'. The property MaxLogFiles specifies how many files to be kept.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
string | getLogFile ()
string | getLogPath ()
integer | getMaxFileSize ()
integer | getMaxLogFiles ()
protected void | processLogs ( array $logs) Saves log messages in files.
protected void | rotateFiles () Rotates log files.
void | setLogFile ( string $value)
void | setLogPath ( string $value)
void | setMaxFileSize ( integer $value)
void | setMaxLogFiles ( integer $value)
Methods Inherited From TLogRoute
TLogRoute::collectLogs(), TLogRoute::formatLogMessage(), TLogRoute::getCategories(), TLogRoute::getLevelName(), TLogRoute::getLevels(), TLogRoute::getLevelValue(), TLogRoute::init(), TLogRoute::setCategories(), TLogRoute::setLevels()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getLogFile

public string getLogFile ()

Output
string log file name. Defaults to 'prado.log'.
Exception

getLogPath

public string getLogPath ()

Output
string directory storing log files. Defaults to application runtime path.
Exception

getMaxFileSize

public integer getMaxFileSize ()

Output
integer maximum log file size in kilo-bytes (KB). Defaults to 1024 (1MB).
Exception

getMaxLogFiles

public integer getMaxLogFiles ()

Output
integer number of files used for rotation. Defaults to 2.
Exception

processLogs

protected void processLogs (array $logs )

Saves log messages in files.

Input
array $logs list of log messages
Output
Exception

rotateFiles

protected void rotateFiles ()

Rotates log files.

Output
Exception

setLogFile

public void setLogFile (string $value )

Input
string $value log file name
Output
Exception

setLogPath

public void setLogPath (string $value )

Input
string | $value | directory (in namespace format) storing log files.
Output
Exception
throws | TConfigurationException if log path is invalid

setMaxFileSize

public void setMaxFileSize (integer $value )

Input
integer | $value | maximum log file size in kilo-bytes (KB).
Output
Exception
throws | TInvalidDataValueException if the value is smaller than 1.

setMaxLogFiles

public void setMaxLogFiles (integer $value )

Input
integer $value number of files used for rotation.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TFirebugLogRoute

Class TFirebugLogRoute (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute
         |
         --TBrowserLogRoute
            |
            --TFirebugLogRoute

TFirebugLogRoute class.

TFirebugLogRoute prints selected log messages in the firebug log console.

FireBug Website

Since: 3.1.2
Author: Enrico Stahn <mail@enricostahn.com>, Christophe Boulain <Christophe.Boulain@gmail.com>
Method Summary
protected void | getFirebugLoggingFunction ( mixed $level)
protected void | renderFooter ()
protected void | renderHeader ()
protected void | renderMessage ( mixed $log, mixed $info)
Methods Inherited From TBrowserLogRoute
TBrowserLogRoute::getColorLevel(), TBrowserLogRoute::getCssClass(), TBrowserLogRoute::processLogs(), TBrowserLogRoute::renderFooter(), TBrowserLogRoute::renderHeader(), TBrowserLogRoute::renderMessage(), TBrowserLogRoute::setCssClass()
Methods Inherited From TLogRoute
TLogRoute::collectLogs(), TLogRoute::formatLogMessage(), TLogRoute::getCategories(), TLogRoute::getLevelName(), TLogRoute::getLevels(), TLogRoute::getLevelValue(), TLogRoute::init(), TLogRoute::setCategories(), TLogRoute::setLevels()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getFirebugLoggingFunction

protected void getFirebugLoggingFunction (mixed $level )

Input
mixed $level
Output
Exception

renderFooter

protected void renderFooter ()

Output
Exception

renderHeader

protected void renderHeader ()

Output
Exception

renderMessage

protected void renderMessage (mixed $log , mixed $info )

Input
mixed | $log
mixed | $info
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TFirePhpLogRoute

Class TFirePhpLogRoute (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute
         |
         --TFirePhpLogRoute

TFirePhpLogRoute class.

TFirePhpLogRoute prints log messages in the firebug log console via firephp.

FireBug Website FirePHP Website

Since: 3.1.5
Author: Yves Berkholz <godzilla80[at]gmx[dot]net>
Method Summary
string | getGroupLabel ()
void | processLogs ( mixed $logs)
void | setGroupLabel ( string $value)
protected void | translateLogLevel ( mixed $level)
Methods Inherited From TLogRoute
TLogRoute::collectLogs(), TLogRoute::formatLogMessage(), TLogRoute::getCategories(), TLogRoute::getLevelName(), TLogRoute::getLevels(), TLogRoute::getLevelValue(), TLogRoute::init(), TLogRoute::setCategories(), TLogRoute::setLevels()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string DEFAULT_LABEL Default group label
Method Details

getGroupLabel

public string getGroupLabel ()

Output
string group label. Defaults to TFirePhpLogRoute::DEFAULT_LABEL
Exception

processLogs

public void processLogs (mixed $logs )

Input
mixed $logs
Output
Exception

setGroupLabel

public void setGroupLabel (string $value )

Input
string $value group label.
Output
Exception

translateLogLevel

protected void translateLogLevel (mixed $level )

Input
mixed $level
Output
Exception

Constant Details

DEFAULT_LABEL

Default group label

Type:

string

Value:

'System.Util.TLogRouter(TFirePhpLogRoute)'


PRADO API Manual: Docs For Class TLogRoute

Class TLogRoute (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TLogRoute

Direct Known Sub-classes:

TFileLogRoute , TEmailLogRoute , TBrowserLogRoute , TDbLogRoute , TFirePhpLogRoute

TLogRoute class.

TLogRoute is the base class for all log route classes. A log route object retrieves log messages from a logger and sends it somewhere, such as files, emails. The messages being retrieved may be filtered first before being sent to the destination. The filters include log level filter and log category filter.

To specify level filter, set Levels property, which takes a string of comma-separated desired level names (e.g. 'Error, Debug'). To specify category filter, set Categories property, which takes a string of comma-separated desired category names (e.g. 'System.Web, System.IO').

Level filter and category filter are combinational, i.e., only messages satisfying both filter conditions will they be returned.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | collectLogs ( TLogger $logger) Retrieves log messages from logger to log route specific destination.
protected string | formatLogMessage ( string $message, integer $level, string $category, integer $time) Formats a log message given different fields.
array | getCategories ()
protected string | getLevelName ( integer $level)
integer | getLevels ()
protected integer | getLevelValue ( string $level)
void | init ( TXmlElement $config) Initializes the route.
protected abstract void | processLogs ( array $logs) Processes log messages and sends them to specific destination.
void | setCategories ( array|string $categories)
void | setLevels ( integer|string $levels)
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

collectLogs

public void collectLogs (TLogger $logger )

Retrieves log messages from logger to log route specific destination.

Input
TLogger $logger logger instance
Output
Exception

formatLogMessage

protected string formatLogMessage (string $message , integer $level , string $category , integer $time )

Formats a log message given different fields.

Input
string | $message | message content
integer | $level | message level
string | $category | message category
integer | $time | timestamp
Output
string | formatted message
Exception

getCategories

public array getCategories ()

Output
array list of categories to be looked for
Exception

getLevelName

protected string getLevelName (integer $level )

Input
integer | $level | level value
Output
string | level name
Exception

getLevels

public integer getLevels ()

Output
integer log level filter
Exception

getLevelValue

protected integer getLevelValue (string $level )

Input
string | $level | level name
Output
integer | level value
Exception

init

public void init (TXmlElement $config )

Initializes the route.

Input
TXmlElement $config configurations specified in TLogRouter.
Output
Exception

processLogs

protected abstract void processLogs (array $logs )

Processes log messages and sends them to specific destination.

Derived child classes must implement this method.

Input
array $logs list of messages. Each array elements represents one message with the following structure: array( [0] => message [1] => level [2] => category [3] => timestamp);
Output
Exception

setCategories

public void setCategories (array|string $categories )

Input
array|string $categories list of categories to be looked for. If the value is a string, it is assumed to be comma-separated category names.
Output
Exception

setLevels

public void setLevels (integer|string $levels )

Input
integer|string $levels integer log level filter (in bits). If the value is a string, it is assumed to be comma-separated level names. Valid level names include 'Debug', 'Info', 'Notice', 'Warning', 'Error', 'Alert' and 'Fatal'.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TLogRouter

Class TLogRouter (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TLogRouter

TLogRouter class.

TLogRouter manages routes that record log messages in different media different ways. For example, a file log route TFileLogRoute records log messages in log files. An email log route TEmailLogRoute sends log messages to email addresses.

Log routes may be configured in application or page folder configuration files or an external configuration file specified by ConfigFile. The format is as follows,

1        <route class="TFileLogRoute" Categories="System.Web.UI" Levels="Warning" />
2        <route class="TEmailLogRoute" Categories="Application" Levels="Fatal" Emails="admin@pradosoft.com" />
You can specify multiple routes with different filtering conditions and different targets, even if the routes are of the same type.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
void | addRoute ( TLogRoute $route) Adds a TLogRoute instance to the log router.
void | collectLogs ( mixed $param) Collects log messages from a logger.
string | getConfigFile ()
void | init ( TXmlElement $config) Initializes this module.
void | setConfigFile ( string $value)
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string CONFIG_FILE_EXT File extension of external configuration file
Method Details

addRoute

public void addRoute (TLogRoute $route )

Adds a TLogRoute instance to the log router.

Input
TLogRoute | $route
Output
Exception
throws | TInvalidDataTypeException if the route object is invalid

collectLogs

public void collectLogs (mixed $param )

Collects log messages from a logger.

This method is an event handler to application's EndRequest event.

Input
mixed $param event parameter
Output
Exception

getConfigFile

public string getConfigFile ()

Output
string external configuration file. Defaults to null.
Exception

init

public void init (TXmlElement $config )

Initializes this module.

This method is required by the IModule interface.

Input
TXmlElement | $config | configuration for this module, can be null
Output
Exception
throws | TConfigurationException if ConfigFile is invalid.

setConfigFile

public void setConfigFile (string $value )

Input
string | $value | external configuration file in namespace format. The file must be suffixed with '.xml'.
Output
Exception
throws | TConfigurationException if the file is invalid.
Constant Details

CONFIG_FILE_EXT

File extension of external configuration file

Type:

string

Value:

'.xml'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TParameterModule

Class TParameterModule (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TParameterModule

TParameterModule class

TParameterModule enables loading application parameters from external storage other than the application configuration. To load parameters from an XML file, configure the module by setting its ParameterFile property. Note, the property only accepts a file path in namespace format with file extension being '.xml'. The file format is as follows, which is similar to the parameter portion in an application configuration,

1      <parameters>
2        <parameter id="param1" value="paramValue1" />
3        <parameter id="param2" Property1="Value1" Property2="Value2" ... />
4      </parameters>

In addition, any content enclosed within the module tag is also treated as parameters, e.g.,

1      <module class="System.Util.TParameterModule">
2        <parameter id="param1" value="paramValue1" />
3        <parameter id="param2" Property1="Value1" Property2="Value2" ... />
4      </module>

If a parameter is defined both in the external file and within the module tag, the former takes precedence.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
string | getParameterFile ()
void | init ( TXmlElement $config) Initializes the module by loading parameters.
protected void | loadParameters ( TXmlElement $xmlNode) Loads parameters into application.
void | setParameterFile ( string $value)
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string PARAM_FILE_EXT
Method Details

getParameterFile

public string getParameterFile ()

Output
string the parameter file path
Exception

init

public void init (TXmlElement $config )

Initializes the module by loading parameters.

Input
TXmlElement $config content enclosed within the module tag
Output
Exception

loadParameters

protected void loadParameters (TXmlElement $xmlNode )

Loads parameters into application.

Input
TXmlElement | $xmlNode | XML representation of the parameters
Output
Exception
throws | TConfigurationException if the parameter file format is invalid

setParameterFile

public void setParameterFile (string $value )

Input
string | $value | the parameter file path. It must be in namespace format and the file extension is '.xml'.
Output
Exception
throws | TInvalidOperationException if the module is initialized
throws | TConfigurationException if the file is invalid
Constant Details

PARAM_FILE_EXT

Type:

string

Value:

'.xml'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSimpleDateFormatter

Class TSimpleDateFormatter (Class Overview)

TSimpleDateFormatter class.

Formats and parses dates using the SimpleDateFormat pattern.  This pattern is compatible with the I18N and java's SimpleDateFormatter.

1      Pattern |      Description
2      ----------------------------------------------------
3      d       | Day of month 1 to 31, no padding
4      dd      | Day of monath 01 to 31, zero leading
5      M       | Month digit 1 to 12, no padding
6      MM      | Month digit 01 to 12, zero leading
7      yy      | 2 year digit, e.g., 96, 05
8      yyyy    | 4 year digit, e.g., 2005
9      ----------------------------------------------------
Usage example, to format a date

1      $formatter = new TSimpleDateFormatter("dd/MM/yyy");
2      echo $formatter->format(time());
To parse the date string into a date timestamp.

1      $formatter = new TSimpleDateFormatter("d-M-yyy");
2      echo $formatter->parse("24-6-2005");

            Since:
            3.0

            Author:
            Wei Zhuo <weizhuo[at]gmail[dot]com>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Constructor, create a new date time formatter.

Method Summary
string | format ( string|int $value) Format the date according to the pattern.
string | getCharset ()
void | getDayMonthYearOrdering ()
void | getDayPattern ()
void | getMonthPattern ()
string | getPattern ()
void | getYearPattern ()
boolean | isValidDate ( mixed $value)
int | parse ( string|int $value, mixed $defaultToCurrentTime) Parse the string according to the pattern.
void | setCharset ( string $charset)
void | setPattern ( string $pattern)

                    Constructor Details

__construct

                                public __construct
                                Array

Constructor, create a new date time formatter.

            Method Details

format

                                public string format
                                (string|int $value )

Format the date according to the pattern.

Input
string|int | $value | the date to format, either integer or a string readable by strtotime.
Output
string | formatted date.
Exception

getCharset

                                public string getCharset
                                ()

Output

                                    string
                 formatting charset.

Exception

getDayMonthYearOrdering

                                public void getDayMonthYearOrdering
                                ()

Output

Exception

getDayPattern

                                public void getDayPattern
                                ()

Output

Exception

getMonthPattern

                                public void getMonthPattern
                                ()

Output

Exception

getPattern

                                public string getPattern
                                ()

Output

                                    string
                 formatting pattern.

Exception

getYearPattern

                                public void getYearPattern
                                ()

Output

Exception

isValidDate

                                public boolean isValidDate
                                (mixed $value )

Input
mixed | $value
Output
boolean | true if the given value matches with the date pattern.
Exception

parse

                                public int parse
                                (string|int $value , mixed $defaultToCurrentTime )

Parse the string according to the pattern.

Input
string|int | $value | date string or integer to parse
mixed | $defaultToCurrentTime |
Output
int | date time stamp
Exception
throws | TInvalidDataValueException if date string is malformed.

setCharset

                                public void setCharset
                                (string $charset )

Input

string $charset formatting charset.

Output

Exception

setPattern

                                public void setPattern
                                (string $pattern )

Input

string $pattern formatting pattern.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TVarDumper

Class TVarDumper (Class Overview)

TVarDumper class.

TVarDumper is intended to replace the buggy PHP function var_dump and print_r.  It can correctly identify the recursively referenced objects in a complex  object structure. It also has a recursive depth control to avoid indefinite  recursive display of some peculiar variables.
TVarDumper can be used as follows,

1        echo TVarDumper::dump($var);

            Since:
            3.0

            Author:
            Qiang Xue <qiang.xue@gmail.com>

            Method Summary

                        string

                            dump
                        (	mixed $var, 	integer $depth, 	mixed $highlight)

                            Converts a variable into a string representation.

            Method Details

dump

                                public string dump
                                (mixed $var , integer $depth , mixed $highlight )

Converts a variable into a string representation.

This method achieves the similar functionality as var_dump and print_r  but is more robust when handling complex objects such as PRADO controls.

Input
mixed | $var | variable to be dumped
integer | $depth | maximum depth that the dumper should go into the variable. Defaults to 10.
mixed | $highlight |
Output
string | the string representation of the variable
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGatewayCommand

Class TDataGatewayCommand (Class Overview)

TComponent
   |
   --TDataGatewayCommand

TDataGatewayCommand is command builder and executor class for TTableGateway and TActiveRecordGateway.

TDataGatewayCommand builds the TDbCommand for TTableGateway and TActiveRecordGateway commands such as find(), update(), insert(), etc, using the TDbCommandBuilder classes (database specific TDbCommandBuilder classes are used).

Once the command is built and the query parameters are binded, the OnCreateCommand event is raised. Event handlers for the OnCreateCommand event should not alter the Command property nor the Criteria property of the TDataGatewayEventParameter.

TDataGatewayCommand excutes the TDbCommands and returns the result obtained from the database (returned value depends on the method executed). The OnExecuteCommand event is raised after the command is executed and resulting data is set in the TDataGatewayResultEventParameter object's Result property.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Method Summary
integer | count ( TSqlCriteria $criteria)
TActiveRecordCriteria | createCriteriaFromString ( string $method, string $condition, array $args)
integer | delete ( TSqlCriteria $criteria) Executes a delete command.
integer | deleteByPk ( array $keys)
protected array | extractMatchingConditions ( string $method, string $condition) Calculates the AND/OR condition from dynamic method substrings using table meta data, allows for any AND-OR combinations.
array | find ( TSqlCriteria $criteria) Find one record matching the critera.
TDbDataReader | findAll ( TSqlCriteria $criteria) Find one or more matching records.
void | findAllByIndex ( mixed $criteria, mixed $fields, mixed $values)
TDbDataReader | findAllByPk ( array $keys)
TDbDataReader | findAllBySql ( TSqlCriteria $criteria) Find zero or more matching records for arbituary SQL.
array | findByPk ( mixed $keys)
TDbDataReader | findBySql ( TSqlCriteria $criteria) Find one matching records for arbituary SQL.
TDbCommandBuilder | getBuilder ()
protected void | getCompositeKeyCondition ( array $values, string 1) Construct a "pk IN ('key1', 'key2', ...)" criteria.
TDbConnection | getDbConnection ()
protected TDbCommand. | getFindCommand ( TSqlCriteria $criteria) Build the find command from the criteria. Limit, Offset and Ordering are applied if applicable.
void | getIndexKeyCondition ( mixed $table, mixed $fields, mixed $values)
mixed | getLastInsertID () Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
protected array | getPrimaryKeyCondition ( array $values) Create the condition and parameters for find by primary.
protected TDbCommand | getSqlCommand ( TSqlCriteria $criteria) Build sql command from the criteria. Limit, Offset and Ordering are applied if applicable.
TDbTableInfo | getTableInfo ()
mixed | insert ( array $data) Inserts a new record into the table. Each array key must correspond to a column name in the table unless a null value is permitted.
void | onCreateCommand ( TDataGatewayCommand $command, TDataGatewayEventParameter $criteria) Raised when a command is prepared and parameter binding is completed.
void | onExecuteCommand ( TDataGatewayCommand $command, TDataGatewayResultEventParameter $result) Raised when a command is executed and the result from the database was returned.
protected string | quoteTuple ( TDbConnection $array, array 1)
integer | update ( array $data, TSqlCriteria $criteria) Updates the table with new data.
integer | updateByPk ( array $data, array $keys)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Method Details

count

public integer count (TSqlCriteria $criteria )

Input
TSqlCriteria | $criteria
Output
integer | number of records.
Exception

createCriteriaFromString

public TActiveRecordCriteria createCriteriaFromString (string $method , string $condition , array $args )

Input
string | $method | __call method name
string | $condition | criteria conditions
array | $args | method arguments
Output
TActiveRecordCriteria | criteria created from the method name and its arguments.
Exception

delete

public integer delete (TSqlCriteria $criteria )

Executes a delete command.

Input
TSqlCriteria | $criteria | delete conditions and parameters.
Output
integer | number of records affected.
Exception

deleteByPk

public integer deleteByPk (array $keys )

Input
array | $keys | multiple primary key values or composite value arrays
Output
integer | number of rows affected.
Exception

extractMatchingConditions

protected array extractMatchingConditions (string $method , string $condition )

Calculates the AND/OR condition from dynamic method substrings using table meta data, allows for any AND-OR combinations.

Input
string | $method | dynamic method name
string | $condition | dynamic method search criteria
Output
array | search condition substrings
Exception

find

public array find (TSqlCriteria $criteria )

Find one record matching the critera.

Input
TSqlCriteria | $criteria | find conditions and parameters.
Output
array | matching record.
Exception

findAll

public TDbDataReader findAll (TSqlCriteria $criteria )

Find one or more matching records.

Input
TSqlCriteria | $criteria
Output
TDbDataReader | record reader.
Exception

findAllByIndex

public void findAllByIndex (mixed $criteria , mixed $fields , mixed $values )

Input
mixed | $criteria
mixed | $fields
mixed | $values
Output
Exception

findAllByPk

public TDbDataReader findAllByPk (array $keys )

Input
array | $keys | multiple primary key values or composite value arrays
Output
TDbDataReader | record reader.
Exception

findAllBySql

public TDbDataReader findAllBySql (TSqlCriteria $criteria )

Find zero or more matching records for arbituary SQL.

Input
TSqlCriteria | $criteria
Output
TDbDataReader | record reader.
Exception

findByPk

public array findByPk (mixed $keys )

Input
mixed | $keys | primary key value, or composite key values as array.
Output
array | matching record.
Exception

findBySql

public TDbDataReader findBySql (TSqlCriteria $criteria )

Find one matching records for arbituary SQL.

Input
TSqlCriteria | $criteria
Output
TDbDataReader | record reader.
Exception

getBuilder

public TDbCommandBuilder getBuilder ()

Output
Exception

getCompositeKeyCondition

protected void getCompositeKeyCondition (array $values , string 1 )

Construct a "pk IN ('key1', 'key2', ...)" criteria.

Input
array | $values | values for IN predicate
string | 1 | SQL string for primary keys IN a list.
Output
Exception

getDbConnection

public TDbConnection getDbConnection ()

Output
Exception

getFindCommand

protected TDbCommand. getFindCommand (TSqlCriteria $criteria )

Build the find command from the criteria. Limit, Offset and Ordering are applied if applicable.

Input
TSqlCriteria $criteria
Output
Exception

getIndexKeyCondition

public void getIndexKeyCondition (mixed $table , mixed $fields , mixed $values )

Input
mixed | $table
mixed | $fields
mixed | $values
Output
Exception

getLastInsertID

public mixed getLastInsertID ()

Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.

Output
mixed last insert id, null if none is found.
Exception

getPrimaryKeyCondition

protected array getPrimaryKeyCondition (array $values )

Create the condition and parameters for find by primary.

Input
array | $values | primary key values
Output
array | tuple($where, $parameters)
Exception

getSqlCommand

protected TDbCommand getSqlCommand (TSqlCriteria $criteria )

Build sql command from the criteria. Limit, Offset and Ordering are applied if applicable.

Input
TSqlCriteria | $criteria
Output
TDbCommand | command corresponding to the criteria.
Exception

getTableInfo

public TDbTableInfo getTableInfo ()

Output
Exception

insert

public mixed insert (array $data )

Inserts a new record into the table. Each array key must correspond to a column name in the table unless a null value is permitted.

Input
array | $data | new record data.
Output
mixed | last insert id if one column contains a serial or sequence, otherwise true if command executes successfully and affected 1 or more rows.
Exception

onCreateCommand

public void onCreateCommand (TDataGatewayCommand $command , TDataGatewayEventParameter $criteria )

Raised when a command is prepared and parameter binding is completed.

The parameter object is TDataGatewayEventParameter of which the TDataGatewayEventParameter::getCommand property can be inspected to obtain the sql query to be executed.

Input
TDataGatewayCommand | $command | originator $sender
TDataGatewayEventParameter | $criteria |
Output
Exception

onExecuteCommand

public void onExecuteCommand (TDataGatewayCommand $command , TDataGatewayResultEventParameter $result )

Raised when a command is executed and the result from the database was returned.

The parameter object is TDataGatewayResultEventParameter of which the TDataGatewayEventParameter::getResult property contains the data return from the database. The data returned can be changed by setting the TDataGatewayEventParameter::setResult property.

Input
TDataGatewayCommand | $command | originator $sender
TDataGatewayResultEventParameter | $result |
Output
Exception

quoteTuple

protected string quoteTuple (TDbConnection $array , array 1 )

Input
TDbConnection | $array | database connection.
array | 1 | values
Output
string | quoted recursive tuple values, e.g. "('val1', 'val2')".
Exception

update

public integer update (array $data , TSqlCriteria $criteria )

Updates the table with new data.

Input
array | $data | date for update.
TSqlCriteria | $criteria | update conditions and parameters.
Output
integer | number of records affected.
Exception

updateByPk

public integer updateByPk (array $data , array $keys )

Input
array | $data | update for update
array | $keys | primary key-value name pairs.
Output
integer | number of records affected.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGatewayEventParameter

Class TDataGatewayEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TDataGatewayEventParameter

TDataGatewayEventParameter class contains the TDbCommand to be executed as well as the criteria object.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Method Summary
TDbCommand | getCommand () The database command to be executed. Do not rebind the parameters or change the sql query string.
TSqlCriteria | getCriteria ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Method Details

getCommand

public TDbCommand getCommand ()

The database command to be executed. Do not rebind the parameters or change the sql query string.

Output
TDbCommand command to be executed.
Exception

getCriteria

public TSqlCriteria getCriteria ()

Output
TSqlCriteria criteria used to bind the sql query parameters.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataGatewayResultEventParameter

Class TDataGatewayResultEventParameter (Class Overview)

TComponent
   |
   --TEventParameter
      |
      --TDataGatewayResultEventParameter

TDataGatewayResultEventParameter contains the TDbCommand executed and the resulting data returned from the database. The data can be changed by changing the setResult property.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Method Summary
TDbCommand | getCommand ()
mixed | getResult ()
void | setResult ( mixed $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Method Details

getCommand

public TDbCommand getCommand ()

Output
TDbCommand database command executed.
Exception

getResult

public mixed getResult ()

Output
mixed result returned from executing the command.
Exception

setResult

public void setResult (mixed $value )

Input
mixed $value change the result returned by the gateway.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlCriteria

Class TSqlCriteria (Class Overview)

TComponent
   |
   --TSqlCriteria

Direct Known Sub-classes:

TActiveRecordCriteria

Search criteria for TDbDataGateway.

Criteria object for data gateway finder methods. Usage:

1      $criteria = new TSqlCriteria();
2      $criteria->Parameters[':name'] = 'admin';
3      $criteria->Parameters[':pass'] = 'prado';
4      $criteria->OrdersBy['level'] = 'desc';
5      $criteria->OrdersBy['name'] = 'asc';
6      $criteria->Limit = 10;
7      $criteria->Offset = 20;

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Creates a new criteria with given condition;
Method Summary
string | getCondition ()
boolean | getIsNamedParameters ()
int | getLimit ()
int | getOffset ()
TAttributeCollection | getOrdersBy ()
TAttributeCollection | getParameters ()
mixed | getSelect () Gets the field list to be placed after the SELECT in the SQL. Default to '*'
void | setCondition ( string $value) Sets the search conditions to be placed after the WHERE clause in the SQL.
void | setLimit ( int $value)
void | setOffset ( int $value)
void | setOrdersBy ( mixed $value)
void | setParameters ( ArrayAccess $value)
void | setSelect ( mixed $value) Sets the field list to be placed after the SELECT in the SQL.
string | __toString ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Creates a new criteria with given condition;
Method Details

getCondition

public string getCondition ()

Output
string search conditions.
Exception

getIsNamedParameters

public boolean getIsNamedParameters ()

Output
boolean true if the parameter index are string base, false otherwise.
Exception

getLimit

public int getLimit ()

Output
int maximum number of records to return.
Exception

getOffset

public int getOffset ()

Output
int record offset.
Exception

getOrdersBy

public TAttributeCollection getOrdersBy ()

Output
TAttributeCollection ordering clause.
Exception

getParameters

public TAttributeCollection getParameters ()

Output
TAttributeCollection list of named parameters and values.
Exception

getSelect

public mixed getSelect ()

Gets the field list to be placed after the SELECT in the SQL. Default to '*'

Output
Exception

setCondition

public void setCondition (string $value )

Sets the search conditions to be placed after the WHERE clause in the SQL.

Input
string $value search conditions.
Output
Exception

setLimit

public void setLimit (int $value )

Input
int $value maximum number of records to return.
Output
Exception

setOffset

public void setOffset (int $value )

Input
int $value record offset.
Output
Exception

setOrdersBy

public void setOrdersBy (mixed $value )

Input
mixed $value ordering clause.
Output
Exception

setParameters

public void setParameters (ArrayAccess $value )

Input
ArrayAccess $value named parameters.
Output
Exception

setSelect

public void setSelect (mixed $value )

Sets the field list to be placed after the SELECT in the SQL.

Different behavior depends on type of assigned value string usage without modification

null will be expanded to full list of quoted table column names (quoting depends on database)

array

  • Column names will be quoted if used as key or value of array

    1          array('col1', 'col2', 'col2')
    1          // SELECT `col1`, `col2`, `col3` FROM...
  • Column aliasing

    1      array('mycol1' => 'col1', 'mycol2' => 'COUNT(*)')
    1      // SELECT `col1` AS mycol1, COUNT(*) AS mycol2 FROM...
  • NULL and scalar values (strings will be quoted depending on database)

    1      array('col1' => 'my custom string', 'col2' => 1.0, 'col3' => 'NULL')
    1      // SELECT "my custom string" AS `col1`, 1.0 AS `col2`, NULL AS `col3` FROM...
  • If the *-wildcard char is used as key or value, add the full list of quoted table column names

    1      array('col1' => 'NULL', '*')
    1      // SELECT `col1`, `col2`, `col3`, NULL AS `col1` FROM...

Input
mixed $value
Output
Exception

__toString

public string __toString ()

Output
string string representation of the parameters. Useful for debugging.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTableGateway

Class TTableGateway (Class Overview)

TComponent
   |
   --TTableGateway

TTableGateway class provides several find methods to get data from the database and update, insert, and delete methods.

Each method maps the input parameters into a SQL call and executes the SQL against a database connection. The TTableGateway is stateless (with respect to the data and data objects), as its role is to push data back and forth.

Example usage:

1      //create a connection
2       $dsn = 'pgsql:host=localhost;dbname=test';
3      $conn = new TDbConnection($dsn, 'dbuser','dbpass');
4
5      //create a table gateway for table/view named 'address'
6       $table = new TTableGateway('address', $conn);
7
8      //insert a new row, returns last insert id (if applicable)
9       $id = $table->insert(array('name'=>'wei', 'phone'=>'111111'));
10
11     $record1 = $table->findByPk($id); //find inserted record
12
13     //finds all records, returns an iterator
14      $records = $table->findAll();
15     print_r($records->readAll());
16
17     //update the row
18      $table->updateByPk($record1, $id);

All methods that may return more than one row of data will return an TDbDataReader iterator.

The OnCreateCommand event is raised when a command is prepared and parameter binding is completed. The parameter object is a TDataGatewayEventParameter of which the TDataGatewayEventParameter::getCommand property can be inspected to obtain the sql query to be executed.

The OnExecuteCommand event is raised when a command is executed and the result from the database was returned. The parameter object is a TDataGatewayResultEventParameter of which the TDataGatewayEventParameter::getResult property contains the data return from the database. The data returned can be changed by setting the TDataGatewayEventParameter::setResult property.

1      $table->OnCreateCommand[] = 'log_it'; //any valid PHP callback statement
2       $table->OnExecuteCommand[] = array($obj, 'method_name'); // calls 'method_name' on $obj
3
3
4      function log_it($sender, $param)
5      {
6          var_dump($param); //TDataGatewayEventParameter object.
7      }

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Creates a new generic table gateway for a given table or view name and a database connection.
Method Summary
int | count ( string|TSqlCriteria $criteria, mixed $parameters) Find the number of records.
integer | deleteAll ( string $criteria, array $parameters) Delete records from the table with condition given by $where and binding values specified by $parameter argument.
void | deleteAllByPks ( mixed $keys) Alias for deleteByPk()
int | deleteByPk ( mixed $keys) Delete records by primary key. Usage:
array | find ( string|TSqlCriteria $criteria, mixed $parameters) Find one single record that matches the criteria.
TDbDataReader | findAll ( string|TSqlCriteria $criteria, mixed $parameters) Accepts same parameters as find(), but returns TDbDataReader instead.
TDbDataReader | findAllByPks ( mixed $keys) Similar to findByPk(), but returns TDbDataReader instead.
TDbDataReader | findAllBySql ( string $sql, array $parameters) Execute arbituary sql command with binding parameters.
array | findByPk ( mixed $keys) Find one record using only the primary key or composite primary keys. Usage:
array | findBySql ( string $sql, array $parameters) Execute arbituary sql command with binding parameters.
protected TDataGatewayCommand | getCommand ()
protected TSqlCriteria | getCriteria ( string|TSqlCriteria $criteria, mixed $parameters, array $args) Create a new TSqlCriteria object from a string $criteria. The $args are additional parameters and are used in place of the $parameters if $parameters is not an array and $args is an arrary.
TDbConnection | getDbConnection ()
mixed | getLastInsertId ()
void | getTableInfo ()
void | getTableName ()
protected void | initCommandBuilder ( TDbCommandBuilder $builder)
mixed | insert ( array $data) Inserts a new record into the table. Each array key must correspond to a column name in the table unless a null value is permitted.
void | onCreateCommand ( TDataGatewayCommand $sender, TDataGatewayEventParameter $param) Raised when a command is prepared and parameter binding is completed.
void | onExecuteCommand ( TDataGatewayCommand $sender, TDataGatewayResultEventParameter $param) Raised when a command is executed and the result from the database was returned.
protected void | setTableInfo ( TDbTableInfo $tableInfo)
protected void | setTableName ( string $tableName) Sets up the command builder for the given table.
integer | update ( array $data, string $criteria, array $parameters) Updates the table with new name-value pair $data. Each array key must correspond to a column name in the table. The update condition is specified by the $where argument and additional binding values can be specified using the $parameter argument.
mixed | __call ( mixed $method, mixed $args) Dynamic find method using parts of method name as search criteria.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Creates a new generic table gateway for a given table or view name and a database connection.
Method Details

count

public int count (string|TSqlCriteria $criteria , mixed $parameters )

Find the number of records.

Input
string|TSqlCriteria | $criteria | SQL condition or criteria object.
mixed | $parameters | parameter values.
Output
int | number of records.
Exception

deleteAll

public integer deleteAll (string $criteria , array $parameters )

Delete records from the table with condition given by $where and binding values specified by $parameter argument.

This method uses additional arguments as $parameters. E.g.

1      $table->delete('age > ? AND location = ?', $age, $location);

Input
string | $criteria | delete condition.
array | $parameters | condition parameters.
Output
integer | number of records deleted.
Exception

deleteAllByPks

public void deleteAllByPks (mixed $keys )

Alias for deleteByPk()

Input
mixed $keys
Output
Exception

deleteByPk

public int deleteByPk (mixed $keys )

Delete records by primary key. Usage:

1      $table->deleteByPk($primaryKey); //delete 1 record
2       $table->deleteByPk($key1,$key2,...); //delete multiple records
2       $table->deleteByPk(array($key1,$key2,...)); //delete multiple records

For composite primary keys (determined from the table definitions):

1      $table->deleteByPk(array($key1,$key2)); //delete 1 record
2
3      //delete multiple records
4       $table->deleteByPk(array($key1,$key2), array($key3,$key4),...);
5
6      //delete multiple records
7       $table->deleteByPk(array( array($key1,$key2), array($key3,$key4), .. ));

Input
mixed | $keys | primary key values.
Output
int | number of records deleted.
Exception

find

public array find (string|TSqlCriteria $criteria , mixed $parameters )

Find one single record that matches the criteria.

Usage:

1      $table->find('username = :name AND password = :pass',
2                          array(':name'=>$name, ':pass'=>$pass));
3      $table->find('username = ? AND password = ?', array($name, $pass));
4      $table->find('username = ? AND password = ?', $name, $pass);
5      //$criteria is of TSqlCriteria
5       $table->find($criteria); //the 2nd parameter for find() is ignored.

Input
string|TSqlCriteria | $criteria | SQL condition or criteria object.
mixed | $parameters | parameter values.
Output
array | matching record object.
Exception

findAll

public TDbDataReader findAll (string|TSqlCriteria $criteria , mixed $parameters )

Accepts same parameters as find(), but returns TDbDataReader instead.

Input
string|TSqlCriteria | $criteria | SQL condition or criteria object.
mixed | $parameters | parameter values.
Output
TDbDataReader | matching records.
Exception

findAllByPks

public TDbDataReader findAllByPks (mixed $keys )

Similar to findByPk(), but returns TDbDataReader instead.

For scalar primary keys:

1      $table->findAllByPk($key1, $key2, ...);
2      $table->findAllByPk(array($key1, $key2, ...));

For composite keys:

1      $table->findAllByPk(array($key1, $key2), array($key3, $key4), ...);
2      $table->findAllByPk(array(array($key1, $key2), array($key3, $key4), ...));

Input
mixed | $keys | primary keys
Output
TDbDataReader | data reader.
Exception

findAllBySql

public TDbDataReader findAllBySql (string $sql , array $parameters )

Execute arbituary sql command with binding parameters.

Input
string | $sql | SQL query string.
array | $parameters | binding parameters, positional or named.
Output
TDbDataReader | query results.
Exception

findByPk

public array findByPk (mixed $keys )

Find one record using only the primary key or composite primary keys. Usage:

1      $table->findByPk($primaryKey);
2      $table->findByPk($key1, $key2, ...);
3      $table->findByPk(array($key1,$key2,...));

Input
mixed | $keys | primary keys
Output
array | matching record.
Exception

findBySql

public array findBySql (string $sql , array $parameters )

Execute arbituary sql command with binding parameters.

Input
string | $sql | SQL query string.
array | $parameters | binding parameters, positional or named.
Output
array | query results.
Exception

getCommand

protected TDataGatewayCommand getCommand ()

Output
TDataGatewayCommand command builder and executor.
Exception

getCriteria

protected TSqlCriteria getCriteria (string|TSqlCriteria $criteria , mixed $parameters , array $args )

Create a new TSqlCriteria object from a string $criteria. The $args are additional parameters and are used in place of the $parameters if $parameters is not an array and $args is an arrary.

Input
string|TSqlCriteria | $criteria | sql criteria
mixed | $parameters | parameters passed by the user.
array | $args | additional parameters obtained from function_get_args().
Output
TSqlCriteria | criteria object.
Exception

getDbConnection

public TDbConnection getDbConnection ()

Output
TDbConnection database connection.
Exception

getLastInsertId

public mixed getLastInsertId ()

Output
mixed last insert id, null if none is found.
Exception

getTableInfo

public void getTableInfo ()

Output
Exception

getTableName

public void getTableName ()

Output
Exception

initCommandBuilder

protected void initCommandBuilder (TDbCommandBuilder $builder )

Input
TDbCommandBuilder $builder database specific command builder.
Output
Exception

insert

public mixed insert (array $data )

Inserts a new record into the table. Each array key must correspond to a column name in the table unless a null value is permitted.

Input
array | $data | new record data.
Output
mixed | last insert id if one column contains a serial or sequence, otherwise true if command executes successfully and affected 1 or more rows.
Exception

onCreateCommand

public void onCreateCommand (TDataGatewayCommand $sender , TDataGatewayEventParameter $param )

Raised when a command is prepared and parameter binding is completed.

The parameter object is TDataGatewayEventParameter of which the TDataGatewayEventParameter::getCommand property can be inspected to obtain the sql query to be executed.

Input
TDataGatewayCommand | $sender | originator $sender
TDataGatewayEventParameter | $param |
Output
Exception

onExecuteCommand

public void onExecuteCommand (TDataGatewayCommand $sender , TDataGatewayResultEventParameter $param )

Raised when a command is executed and the result from the database was returned.

The parameter object is TDataGatewayResultEventParameter of which the TDataGatewayEventParameter::getResult property contains the data return from the database. The data returned can be changed by setting the TDataGatewayEventParameter::setResult property.

Input
TDataGatewayCommand | $sender | originator $sender
TDataGatewayResultEventParameter | $param |
Output
Exception

setTableInfo

protected void setTableInfo (TDbTableInfo $tableInfo )

Input
TDbTableInfo $tableInfo table or view information.
Output
Exception

setTableName

protected void setTableName (string $tableName )

Sets up the command builder for the given table.

Input
string $tableName table or view name.
Output
Exception

update

public integer update (array $data , string $criteria , array $parameters )

Updates the table with new name-value pair $data. Each array key must correspond to a column name in the table. The update condition is specified by the $where argument and additional binding values can be specified using the $parameter argument.

This method uses additional arguments as $parameters. E.g.

1      $gateway->update($data, 'age > ? AND location = ?', $age, $location);

Input
array | $data | new record data.
string | $criteria | update condition
array | $parameters | additional binding name-value pairs.
Output
integer | number of records updated.
Exception

__call

public mixed __call (mixed $method , mixed $args )

Dynamic find method using parts of method name as search criteria.

Method name starting with "findBy" only returns 1 record. Method name starting with "findAllBy" returns 0 or more records. Method name starting with "deleteBy" deletes records by the trail criteria. The condition is taken as part of the method name after "findBy", "findAllBy" or "deleteBy".

The following are equivalent:

1      $table->findByName($name)
2      $table->find('Name = ?', $name);

1      $table->findByUsernameAndPassword($name,$pass); // OR may be used
2       $table->findBy_Username_And_Password($name,$pass); // _OR_ may be used
3       $table->find('Username = ? AND Password = ?', $name, $pass);

1      $table->findAllByAge($age);
2      $table->findAll('Age = ?', $age);

1      $table->deleteAll('Name = ?', $name);
2      $table->deleteByName($name);

Input
mixed | $method
mixed | $args
Output
mixed | single record if method name starts with "findBy", 0 or more records if method name starts with "findAllBy"
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDataSourceConfig

Class TDataSourceConfig (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TDataSourceConfig

Direct Known Sub-classes:

TActiveRecordConfig , TSqlMapConfig

TDataSourceConfig module class provides <module> configuration for database connections.

Example usage: mysql connection

1      <modules>
2          <module id="db1">
3              <database ConnectionString="mysqli:host=localhost;dbname=test"
4                  username="dbuser" password="dbpass" />
5          </module>
6      </modules>

Usage in php:

1      class Home extends TPage
2      {
3              function onLoad($param)
4              {
5                  $db = $this->Application->Modules['db1']->DbConnection;
6                  $db->createCommand('...'); //...
7              }
8      }

The properties of <connection> are those of the class TDbConnection. Set setConnectionClass attribute for a custom database connection class that extends the TDbConnection class.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected TDbConnection | findConnectionByID ( string $id) Finds the database connection instance from the Application modules.
void | getConnectionClass ( string 0)
string | getConnectionID ()
TDbConnection | getDatabase () Alias for getDbConnection().
TDbConnection | getDbConnection () Gets the TDbConnection from another module if setConnectionID is supplied and valid. Otherwise, a connection of type given by setConnectionClass is created.
void | init ( TXmlDocument $xml) Initalize the database connection properties from attributes in <database> tag.
void | setConnectionClass ( string $value) The database connection class name to be created when getDbConnection
void | setConnectionID ( string $value) The module ID of another TDataSourceConfig. The getDbConnection property of this configuration will equal to getDbConnection of the given TDataSourceConfig module.
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

findConnectionByID

protected TDbConnection findConnectionByID (string $id )

Finds the database connection instance from the Application modules.

Input
string | $id | Database connection module ID.
Output
TDbConnection | database connection.
Exception
throws | TConfigurationException when module is not of TDbConnection or TDataSourceConfig.

getConnectionClass

public void getConnectionClass (string 0 )

Input
string 0 Database connection class name to be created.
Output
Exception

getConnectionID

public string getConnectionID ()

Output
string connection module ID.
Exception

getDatabase

public TDbConnection getDatabase ()

Alias for getDbConnection().

Output
TDbConnection database connection.
Exception

getDbConnection

public TDbConnection getDbConnection ()

Gets the TDbConnection from another module if setConnectionID is supplied and valid. Otherwise, a connection of type given by setConnectionClass is created.

Output
TDbConnection database connection.
Exception

init

public void init (TXmlDocument $xml )

Initalize the database connection properties from attributes in <database> tag.

Input
TXmlDocument $xml xml configuration.
Output
Exception

setConnectionClass

public void setConnectionClass (string $value )

The database connection class name to be created when getDbConnection

method is called and ConnectionID is null. The ConnectionClass property must be set before calling getDbConnection if you wish to create the connection using the given class name.

Input
string | $value | Database connection class name.
Output
Exception
throws | TConfigurationException when database connection is already established.

setConnectionID

public void setConnectionID (string $value )

The module ID of another TDataSourceConfig. The getDbConnection property of this configuration will equal to getDbConnection of the given TDataSourceConfig module.

Input
string $value module ID.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbCommand

Class TDbCommand (Class Overview)

TComponent
   |
   --TDbCommand

TDbCommand class.

TDbCommand represents an SQL statement to execute against a database. It is usually created by calling TDbConnection::createCommand. The SQL statement to be executed may be set via Text.

To execute a non-query SQL (such as insert, delete, update), call execute. To execute an SQL statement that returns result data set (such as select), use query or its convenient versions queryRow and queryScalar.

If an SQL statement returns results (such as a SELECT SQL), the results can be accessed via the returned TDbDataReader.

TDbCommand supports SQL statment preparation and parameter binding. Call bindParameter to bind a PHP variable to a parameter in SQL. Call bindValue to bind a value to an SQL parameter. When binding a parameter, the SQL statement is automatically prepared. You may also call prepare to explicitly prepare an SQL statement.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void | bindParameter ( mixed $name, mixed &$value, int $dataType, int $length) Binds a parameter to the SQL statement to be executed.
void | bindValue ( mixed $name, mixed $value, int $dataType) Binds a value to a parameter.
void | cancel () Cancels the execution of the SQL statement.
integer | execute () Executes the SQL statement.
TDbConnection | getConnection ()
String | getDebugStatementText ()
PDOStatement | getPdoStatement ()
string | getText ()
void | prepare () Prepares the SQL statement to be executed.
TDbDataReader | query () Executes the SQL statement and returns query result.
array | queryColumn () Executes the SQL statement and returns the first column of the result.
array | queryRow ( boolean $fetchAssociative) Executes the SQL statement and returns the first row of the result.
mixed | queryScalar () Executes the SQL statement and returns the value of the first column in the first row of data.
void | setText ( string $value) Specifies the SQL statement to be executed.
void | __sleep () Set the statement to null when serializing.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

bindParameter

public void bindParameter (mixed $name , mixed &$value , int $dataType , int $length )

Binds a parameter to the SQL statement to be executed.

Input
mixed | $name | Parameter identifier. For a prepared statement using named placeholders, this will be a parameter name of the form :name. For a prepared statement using question mark placeholders, this will be the 1-indexed position of the parameter.
mixed | &$value | Name of the PHP variable to bind to the SQL statement parameter
int | $dataType | SQL data type of the parameter
int | $length | length of the data type
Output
Exception

bindValue

public void bindValue (mixed $name , mixed $value , int $dataType )

Binds a value to a parameter.

Input
mixed | $name | Parameter identifier. For a prepared statement using named placeholders, this will be a parameter name of the form :name. For a prepared statement using question mark placeholders, this will be the 1-indexed position of the parameter.
mixed | $value | The value to bind to the parameter
int | $dataType | SQL data type of the parameter
Output
Exception

cancel

public void cancel ()

Cancels the execution of the SQL statement.

Output
Exception

execute

public integer execute ()

Executes the SQL statement.

This method is meant only for executing non-query SQL statement. No result set will be returned.

Output
integer | number of rows affected by the execution.
Exception
throws | TDbException execution failed

getConnection

public TDbConnection getConnection ()

Output
TDbConnection the connection associated with this command
Exception

getDebugStatementText

public String getDebugStatementText ()

Output
String prepared SQL text for debugging purposes.
Exception

getPdoStatement

public PDOStatement getPdoStatement ()

Output
PDOStatement the underlying PDOStatement for this command It could be null if the statement is not prepared yet.
Exception

getText

public string getText ()

Output
string the SQL statement to be executed
Exception

prepare

public void prepare ()

Prepares the SQL statement to be executed.

For complex SQL statement that is to be executed multiple times, this may improve performance. For SQL statement with binding parameters, this method is invoked automatically.

Output
Exception

query

public TDbDataReader query ()

Executes the SQL statement and returns query result.

This method is for executing an SQL query that returns result set.

Output
TDbDataReader | the reader object for fetching the query result
Exception
throws | TDbException execution failed

queryColumn

public array queryColumn ()

Executes the SQL statement and returns the first column of the result.

This is a convenient method of query when only the first column of data is needed. Note, the column returned will contain the first element in each row of result.

Output
array | the first column of the query result. Empty array if no result.
Exception
throws | TDbException execution failed

queryRow

public array queryRow (boolean $fetchAssociative )

Executes the SQL statement and returns the first row of the result.

This is a convenient method of query when only the first row of data is needed.

Input
boolean | $fetchAssociative | whether the row should be returned as an associated array with column names as the keys or the array keys are column indexes (0-based).
Output
array | the first row of the query result, false if no result.
Exception
throws | TDbException execution failed

queryScalar

public mixed queryScalar ()

Executes the SQL statement and returns the value of the first column in the first row of data.

This is a convenient method of query when only a single scalar value is needed (e.g. obtaining the count of the records).

Output
mixed | the value of the first column in the first row of the query result. False is returned if there is no value.
Exception
throws | TDbException execution failed

setText

public void setText (string $value )

Specifies the SQL statement to be executed.

Any previous execution will be terminated or cancel.

Input
string $value the SQL statement to be executed
Output
Exception

__sleep

public void __sleep ()

Set the statement to null when serializing.

Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbColumnCaseMode

Class TDbColumnCaseMode (Class Overview)

TEnumerable
   |
   --TDbColumnCaseMode

TDbColumnCaseMode

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | LowerCase | Column names are converted to lower case
string | Preserved | Column name cases are kept as is from the database
string | UpperCase | Column names are converted to upper case
Constant Details

LowerCase

Column names are converted to lower case

Type:

string

Value:

'LowerCase'

Preserved

Column name cases are kept as is from the database

Type:

string

Value:

'Preserved'

UpperCase

Column names are converted to upper case

Type:

string

Value:

'UpperCase'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbConnection

Class TDbConnection (Class Overview)

TComponent
   |
   --TDbConnection

TDbConnection class

TDbConnection represents a connection to a database.

TDbConnection works together with TDbCommand, TDbDataReader and TDbTransaction to provide data access to various DBMS in a common set of APIs. They are a thin wrapper of the PDO PHP extension.

To establish a connection, set Active to true after specifying ConnectionString, Username and Password.

Since 3.1.2, the connection charset can be set (for MySQL and PostgreSQL databases only) using the Charset property. The value of this property is database dependant. e.g. for mysql, you can use 'latin1' for cp1252 West European, 'utf8' for unicode, ...

The following example shows how to create a TDbConnection instance and establish the actual connection:

1      $connection=new TDbConnection($dsn,$username,$password);
2      $connection->Active=true;

After the DB connection is established, one can execute an SQL statement like the following:

1      $command=$connection->createCommand($sqlStatement);
2      $command->execute();   // a non-query SQL statement execution
3      // or execute an SQL query and fetch the result set
4       $reader=$command->query();
5
6      // each $row is an array representing a row of data
7       foreach($reader as $row) ...

One can do prepared SQL execution and bind parameters to the prepared SQL:

1      $command=$connection->createCommand($sqlStatement);
2      $command->bindParameter($name1,$value1);
3      $command->bindParameter($name2,$value2);
4      $command->execute();

To use transaction, do like the following:

1      $transaction=$connection->beginTransaction();
2      try
3      {
4         $connection->createCommand($sql1)->execute();
5         $connection->createCommand($sql2)->execute();
6         //.... other SQL executions
7             $transaction->commit();
8      }
9      catch(Exception $e)
10     {
11        $transaction->rollBack();
12     }

TDbConnection provides a set of methods to support setting and querying of certain DBMS attributes, such as NullConversion.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
TDbTransaction | beginTransaction () Starts a transaction.
protected void | close () Closes the currently active DB connection.
TDbCommand | createCommand ( string $sql) Creates a command for execution.
boolean | getActive ()
mixed | getAttribute ( int $name) Obtains a specific DB connection attribute information.
boolean | getAutoCommit ()
array | getAvailableDrivers ()
string | getCharset ()
string | getClientVersion ()
TDbColumnCaseMode | getColumnCase ()
string | getConnectionStatus ()
string | getConnectionString ()
TDbTransaction | getCurrentTransaction ()
string | getDriverName ()
string | getLastInsertID ( string $sequenceName) Returns the ID of the last inserted row or sequence value.
TDbNullConversionMode | getNullConversion ()
string | getPassword ()
PDO | getPdoInstance ()
boolean | getPersistent ()
boolean | getPrefetch ()
string | getServerInfo ()
string | getServerVersion ()
int | getTimeout ()
string | getTransactionClass ()
string | getUsername ()
protected void | open () Opens DB connection if it is currently not
string | quoteString ( string $str) Quotes a string for use in a query.
void | setActive ( boolean $value) Open or close the DB connection.
void | setAttribute ( int $name, mixed $value) Sets an attribute on the database connection.
void | setAutoCommit ( boolean $value)
void | setCharset ( string $value)
void | setColumnCase ( TDbColumnCaseMode $value)
protected void | setConnectionCharset ()
void | setConnectionString ( string $value)
void | setNullConversion ( TDbNullConversionMode $value)
void | setPassword ( string $value)
void | setPersistent ( boolean $value)
void | setTransactionClass ( string $value)
void | setUsername ( string $value)
void | __sleep () Close the connection when serializing.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string DEFAULT_TRANSACTION_CLASS
Constructor Details

__construct

public __construct Array

Constructor.

Note, the DB connection is not established when this connection instance is created. Set Active property to true to establish the connection. Since 3.1.2, you can set the charset for MySql connection

See: http://www.php.net/manual/en/function.PDO-construct.php
Method Details

beginTransaction

public TDbTransaction beginTransaction ()

Starts a transaction.

Output
TDbTransaction | the transaction initiated
Exception
throws | TDbException if the connection is not active

close

protected void close ()

Closes the currently active DB connection.

It does nothing if the connection is already closed.

Output
Exception

createCommand

public TDbCommand createCommand (string $sql )

Creates a command for execution.

Input
string | $sql | SQL statement associated with the new command.
Output
TDbCommand | the DB command
Exception
throws | TDbException if the connection is not active

getActive

public boolean getActive ()

Output
boolean whether the DB connection is established
Exception

getAttribute

public mixed getAttribute (int $name )

Obtains a specific DB connection attribute information.

Input
int | $name | the attribute to be queried
Output
mixed | the corresponding attribute information
Exception

getAutoCommit

public boolean getAutoCommit ()

Output
boolean whether creating or updating a DB record will be automatically committed. Some DBMS (such as sqlite) may not support this feature.
Exception

getAvailableDrivers

public array getAvailableDrivers ()

Output
array list of available PDO drivers
Exception

getCharset

public string getCharset ()

Output
string the charset used for database connection. Defaults to emtpy string.
Exception

getClientVersion

public string getClientVersion ()

Output
string the version information of the DB driver
Exception

getColumnCase

public TDbColumnCaseMode getColumnCase ()

Output
TDbColumnCaseMode the case of the column names
Exception

getConnectionStatus

public string getConnectionStatus ()

Output
string the status of the connection Some DBMS (such as sqlite) may not support this feature.
Exception

getConnectionString

public string getConnectionString ()

Output
string The Data Source Name, or DSN, contains the information required to connect to the database.
Exception

getCurrentTransaction

public TDbTransaction getCurrentTransaction ()

Output
TDbTransaction the currently active transaction. Null if no active transaction.
Exception

getDriverName

public string getDriverName ()

Output
string name of the DB driver
Exception

getLastInsertID

public string getLastInsertID (string $sequenceName )

Returns the ID of the last inserted row or sequence value.

Input
string | $sequenceName | name of the sequence object (required by some DBMS)
Output
string | the row ID of the last row inserted, or the last value retrieved from the sequence object
Exception

getNullConversion

public TDbNullConversionMode getNullConversion ()

Output
TDbNullConversionMode how the null and empty strings are converted
Exception

getPassword

public string getPassword ()

Output
string the password for establishing DB connection. Defaults to empty string.
Exception

getPdoInstance

public PDO getPdoInstance ()

Output
PDO the PDO instance, null if the connection is not established yet
Exception

getPersistent

public boolean getPersistent ()

Output
boolean whether the connection is persistent or not Some DBMS (such as sqlite) may not support this feature.
Exception

getPrefetch

public boolean getPrefetch ()

Output
boolean whether the connection performs data prefetching
Exception

getServerInfo

public string getServerInfo ()

Output
string the information of DBMS server
Exception

getServerVersion

public string getServerVersion ()

Output
string the version information of DBMS server
Exception

getTimeout

public int getTimeout ()

Output
int timeout settings for the connection
Exception

getTransactionClass

public string getTransactionClass ()

Output
string Transaction class name to be created by calling TDbConnection::beginTransaction. Defaults to 'System.Data.TDbTransaction'.
Exception

getUsername

public string getUsername ()

Output
string the username for establishing DB connection. Defaults to empty string.
Exception

open

protected void open ()

Opens DB connection if it is currently not

Output
Exception
throws TDbException if connection fails

quoteString

public string quoteString (string $str )

Quotes a string for use in a query.

Input
string | $str | string to be quoted
Output
string | the properly quoted string
Exception

setActive

public void setActive (boolean $value )

Open or close the DB connection.

Input
boolean | $value | whether to open or close DB connection
Output
Exception
throws | TDbException if connection fails

setAttribute

public void setAttribute (int $name , mixed $value )

Sets an attribute on the database connection.

Input
int | $name | the attribute to be set
mixed | $value | the attribute value
Output
Exception

setAutoCommit

public void setAutoCommit (boolean $value )

Input
boolean $value whether creating or updating a DB record will be automatically committed. Some DBMS (such as sqlite) may not support this feature.
Output
Exception

setCharset

public void setCharset (string $value )

Input
string $value the charset used for database connection
Output
Exception

setColumnCase

public void setColumnCase (TDbColumnCaseMode $value )

Input
TDbColumnCaseMode $value the case of the column names
Output
Exception

setConnectionCharset

protected void setConnectionCharset ()

Output
Exception

setConnectionString

public void setConnectionString (string $value )

Input
string $value The Data Source Name, or DSN, contains the information required to connect to the database.
Output
Exception

setNullConversion

public void setNullConversion (TDbNullConversionMode $value )

Input
TDbNullConversionMode $value how the null and empty strings are converted
Output
Exception

setPassword

public void setPassword (string $value )

Input
string $value the password for establishing DB connection
Output
Exception

setPersistent

public void setPersistent (boolean $value )

Input
boolean $value whether the connection is persistent or not Some DBMS (such as sqlite) may not support this feature.
Output
Exception

setTransactionClass

public void setTransactionClass (string $value )

Input
string $value Transaction class name to be created by calling TDbConnection::beginTransaction.
Output
Exception

setUsername

public void setUsername (string $value )

Input
string $value the username for establishing DB connection
Output
Exception

__sleep

public void __sleep ()

Close the connection when serializing.

Output
Exception

Constant Details

DEFAULT_TRANSACTION_CLASS

Type:

string

Value:

'System.Data.TDbTransaction'
Since: 3.1.7
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbNullConversionMode

Class TDbNullConversionMode (Class Overview)

TEnumerable
   |
   --TDbNullConversionMode

TDbNullConversionMode

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constant Summary
string | EmptyStringToNull | Empty string is converted to NULL
string | NullToEmptyString | NULL is converted to empty string
string | Preserved | No conversion is performed for null and empty values.
Constant Details

EmptyStringToNull

Empty string is converted to NULL

Type:

string

Value:

'EmptyStringToNull'

NullToEmptyString

NULL is converted to empty string

Type:

string

Value:

'NullToEmptyString'

Preserved

No conversion is performed for null and empty values.

Type:

string

Value:

'Preserved'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbDataReader

Class TDbDataReader (Class Overview)

TComponent
   |
   --TDbDataReader

TDbDataReader class.

TDbDataReader represents a forward-only stream of rows from a query result set.

To read the current row of data, call read. The method readAll returns all the rows in a single array.

One can also retrieve the rows of data in TDbDataReader by using foreach:

1      foreach($reader as $row)
1          // $row represents a row of data
Since TDbDataReader is a forward-only stream, you can only traverse it once.

It is possible to use a specific mode of data fetching by setting FetchMode. See http://www.php.net/manual/en/function.PDOStatement-setFetchMode.php for more details.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void | bindColumn ( mixed $column, mixed &$value, int $dataType) Binds a column to a PHP variable.
void | close () Closes the reader.
mixed | current () Returns the current row.
int | getColumnCount ()
boolean | getIsClosed ()
int | getRowCount ()
integer | key () Returns the index of the current row.
void | next () Moves the internal pointer to the next row.
void | nextResult () Advances the reader to the next result when reading the results of a batch of statements.
array|false | read () Advances the reader to the next row in a result set.
array | readAll () Reads the whole result set into an array.
mixed|false | readColumn ( int $columnIndex) Returns a single column from the next row of a result set.
mixed|false | readObject ( string $className, array $fields) Returns a single column from the next row of a result set.
void | rewind () Resets the iterator to the initial state.
void | setFetchMode ( mixed $mode)
boolean | valid () Returns whether there is a row of data at current position.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

bindColumn

public void bindColumn (mixed $column , mixed &$value , int $dataType )

Binds a column to a PHP variable.

When rows of data are being fetched, the corresponding column value will be set in the variable. Note, the fetch mode must include PDO::FETCH_BOUND.

Input
mixed | $column | Number of the column (1-indexed) or name of the column in the result set. If using the column name, be aware that the name should match the case of the column, as returned by the driver.
mixed | &$value | Name of the PHP variable to which the column will be bound.
int | $dataType | Data type of the parameter
Output
Exception

close

public void close ()

Closes the reader.

Any further data reading will result in an exception.

Output
Exception

current

public mixed current ()

Returns the current row.

This method is required by the interface Iterator.

Output
mixed the current row.
Exception

getColumnCount

public int getColumnCount ()

Output
int the number of columns in the result set. Note, even there's no row in the reader, this still gives correct column number.
Exception

getIsClosed

public boolean getIsClosed ()

Output
boolean whether the reader is closed or not.
Exception

getRowCount

public int getRowCount ()

Output
int number of rows contained in the result. Note, most DBMS may not give a meaningful count. In this case, use "SELECT COUNT(*) FROM tableName" to obtain the number of rows.
Exception

key

public integer key ()

Returns the index of the current row.

This method is required by the interface Iterator.

Output
integer the index of the current row.
Exception

next

public void next ()

Moves the internal pointer to the next row.

This method is required by the interface Iterator.

Output
Exception

nextResult

public void nextResult ()

Advances the reader to the next result when reading the results of a batch of statements.

This method is only useful when there are multiple result sets returned by the query. Not all DBMS support this feature.

Output
Exception

read

public array|false read ()

Advances the reader to the next row in a result set.

Output
array|false the current row, false if no more row available
Exception

readAll

public array readAll ()

Reads the whole result set into an array.

Output
array the result set (each array element represents a row of data). An empty array will be returned if the result contains no row.
Exception

readColumn

public mixed|false readColumn (int $columnIndex )

Returns a single column from the next row of a result set.

Input
int | $columnIndex | zero-based column index
Output
mixed|false | the column of the current row, false if no more row available
Exception

readObject

public mixed|false readObject (string $className , array $fields )

Returns a single column from the next row of a result set.

Input
string | $className | class name of the object to be created and populated
array | $fields | list of column names whose values are to be passed as parameters in the constructor of the class being created
Output
mixed|false | the populated object, false if no more row of data available
Exception

rewind

public void rewind ()

Resets the iterator to the initial state.

This method is required by the interface Iterator.

Output
Exception
throws TDbException if this method is invoked twice

setFetchMode

public void setFetchMode (mixed $mode )

Input
mixed $mode
Output
Exception

valid

public boolean valid ()

Returns whether there is a row of data at current position.

This method is required by the interface Iterator.

Output
boolean whether there is a row of data at current position.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbTransaction

Class TDbTransaction (Class Overview)

TComponent
   |
   --TDbTransaction

TDbTransaction class.

TDbTransaction represents a DB transaction. It is usually created by calling TDbConnection::beginTransaction.

The following code is a common scenario of using transactions:

1      try
2      {
3         $transaction=$connection->beginTransaction();
4         $connection->createCommand($sql1)->execute();
5         $connection->createCommand($sql2)->execute();
6         //.... other SQL executions
7             $transaction->commit();
8      }
9      catch(Exception $e)
10     {
11        $transaction->rollBack();
12     }

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
void | commit () Commits a transaction.
boolean | getActive ()
TDbConnection | getConnection ()
void | rollback () Rolls back a transaction.
protected void | setActive ( boolean $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.

See: TDbConnection::beginTransaction
Method Details

commit

public void commit ()

Commits a transaction.

Output
Exception
throws TDbException if the transaction or the DB connection is not active.

getActive

public boolean getActive ()

Output
boolean whether this transaction is active
Exception

getConnection

public TDbConnection getConnection ()

Output
TDbConnection the DB connection for this transaction
Exception

rollback

public void rollback ()

Rolls back a transaction.

Output
Exception
throws TDbException if the transaction or the DB connection is not active.

setActive

protected void setActive (boolean $value )

Input
boolean $value whether this transaction is active
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbCommandBuilder

Class TDbCommandBuilder (Class Overview)

TComponent
   |
   --TDbCommandBuilder

Direct Known Sub-classes:

TMssqlCommandBuilder , TMysqlCommandBuilder , TOracleCommandBuilder , TPgsqlCommandBuilder , TSqliteCommandBuilder

TDbCommandBuilder provides basic methods to create query commands for tables giving by setTableInfo the property.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Method Summary
void | applyCriterias ( mixed $sql, mixed $parameters, mixed $ordering, mixed $limit, mixed $offset)
string | applyLimitOffset ( string $sql, integer $limit, integer $offset) Alters the sql to apply $limit and $offset. Default implementation is applicable for PostgreSQL, MySQL and SQLite.
string | applyOrdering ( string $sql, array $ordering)
void | bindArrayValues ( TDbCommand $command, array $values)
void | bindColumnValues ( TDbCommand $command, array $values) Bind the name-value pairs of $values where the array keys correspond to column names.
TDbCommand | createCommand ( string $sql)
TDbCommand | createCountCommand ( string $where, array $parameters, mixed $ordering, mixed $limit, mixed $offset) Creates a count(*) command for the table described in setTableInfo.
TDbCommand | createDeleteCommand ( string $where, array $parameters) Creates a delete command for the table described in setTableInfo.
TDbCommand | createFindCommand ( string $where, array $parameters, mixed $ordering, mixed $limit, mixed $offset, mixed $select) Appends the $where condition to the string "SELECT * FROM tableName WHERE ".
TDbCommand | createInsertCommand ( array $data) Creates an insert command for the table described in setTableInfo for the given data.
TDbCommand | createUpdateCommand ( array $data, string $where, array $parameters) Creates an update command for the table described in setTableInfo for the given data.
protected string | getColumnBindings ( array $values, boolean $position) Create a name-value or position-value if $position=true binding strings.
TDbConnection | getDbConnection ()
protected array | getInsertFieldBindings ( object array $values) Returns a list of insert field name and a list of binding names.
mixed | getLastInsertID () Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
integer | getPdoType ( mixed $value)
protected string | getSearchCondition ( string $column, array $words)
string | getSearchExpression ( array $fields, string $keywords) Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).
array | getSelectFieldList ( mixed $data, mixed $value) Different behavior depends on type of passed data string usage without modification
void | getTableInfo ( TDbTableInfo 0)
protected boolean | hasIntegerKey ( array $array)
void | setDbConnection ( TDbConnection $value)
void | setTableInfo ( TDbTableInfo $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Method Details

applyCriterias

public void applyCriterias (mixed $sql , mixed $parameters , mixed $ordering , mixed $limit , mixed $offset )

Input
mixed | $sql
mixed | $parameters
mixed | $ordering
mixed | $limit
mixed | $offset
Output
Exception

applyLimitOffset

public string applyLimitOffset (string $sql , integer $limit , integer $offset )

Alters the sql to apply $limit and $offset. Default implementation is applicable for PostgreSQL, MySQL and SQLite.

Input
string | $sql | SQL query string.
integer | $limit | maximum number of rows, -1 to ignore limit.
integer | $offset | row offset, -1 to ignore offset.
Output
string | SQL with limit and offset.
Exception

applyOrdering

public string applyOrdering (string $sql , array $ordering )

Input
string | $sql | SQL string without existing ordering.
array | $ordering | pairs of column names as key and direction as value.
Output
string | modified SQL applied with ORDER BY.
Exception

bindArrayValues

public void bindArrayValues (TDbCommand $command , array $values )

Input
TDbCommand | $command | database command
array | $values | values for binding.
Output
Exception

bindColumnValues

public void bindColumnValues (TDbCommand $command , array $values )

Bind the name-value pairs of $values where the array keys correspond to column names.

Input
TDbCommand | $command | database command.
array | $values | name-value pairs.
Output
Exception

createCommand

public TDbCommand createCommand (string $sql )

Input
string | $sql | SQL query string.
Output
TDbCommand | corresponding database command.
Exception

createCountCommand

public TDbCommand createCountCommand (string $where , array $parameters , mixed $ordering , mixed $limit , mixed $offset )

Creates a count(*) command for the table described in setTableInfo.

Input
string | $where | count condition.
array | $parameters | binding parameters.
mixed | $ordering |
mixed | $limit |
mixed | $offset |
Output
TDbCommand | count command.
Exception

createDeleteCommand

public TDbCommand createDeleteCommand (string $where , array $parameters )

Creates a delete command for the table described in setTableInfo.

The conditions for delete is given by the $where argument and the parameters for the condition is given by $parameters.

Input
string | $where | delete condition.
array | $parameters | delete parameters.
Output
TDbCommand | delete command.
Exception

createFindCommand

public TDbCommand createFindCommand (string $where , array $parameters , mixed $ordering , mixed $limit , mixed $offset , mixed $select )

Appends the $where condition to the string "SELECT * FROM tableName WHERE ".

The tableName is obtained from the TableInfo property.

Input
string | $where | query condition
array | $parameters | condition parameters.
mixed | $ordering |
mixed | $limit |
mixed | $offset |
mixed | $select |
Output
TDbCommand | query command.
Exception

createInsertCommand

public TDbCommand createInsertCommand (array $data )

Creates an insert command for the table described in setTableInfo for the given data.

Each array key in the $data array must correspond to the column name of the table (if a column allows to be null, it may be omitted) to be inserted with the corresponding array value.

Input
array | $data | name-value pairs of new data to be inserted.
Output
TDbCommand | insert command
Exception

createUpdateCommand

public TDbCommand createUpdateCommand (array $data , string $where , array $parameters )

Creates an update command for the table described in setTableInfo for the given data.

Each array key in the $data array must correspond to the column name to be updated with the corresponding array value.

Input
array | $data | name-value pairs of data to be updated.
string | $where | update condition.
array | $parameters | update parameters.
Output
TDbCommand | update command.
Exception

getColumnBindings

protected string getColumnBindings (array $values , boolean $position )

Create a name-value or position-value if $position=true binding strings.

Input
array | $values | data for binding.
boolean | $position | true to bind as position values.
Output
string | update column names with corresponding binding substrings.
Exception

getDbConnection

public TDbConnection getDbConnection ()

Output
TDbConnection database connection.
Exception

getInsertFieldBindings

protected array getInsertFieldBindings (object array $values )

Returns a list of insert field name and a list of binding names.

Input
object array | $values | or object to be inserted.
Output
array | tuple ($fields, $bindings)
Exception

getLastInsertID

public mixed getLastInsertID ()

Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.

Output
mixed last insert id, null if none is found.
Exception

getPdoType

public integer getPdoType (mixed $value )

Input
mixed | $value | PHP value
Output
integer | PDO parameter types.
Exception

getSearchCondition

protected string getSearchCondition (string $column , array $words )

Input
string | $column | column name.
array | $words | keywords
Output
string | search condition for all words in one column.
Exception

getSearchExpression

public string getSearchExpression (array $fields , string $keywords )

Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).

Input
array | $fields | list of column id for potential search condition.
string | $keywords | string of keywords
Output
string | SQL search condition matching on a set of columns.
Exception

getSelectFieldList

public array getSelectFieldList (mixed $data , mixed $value )

Different behavior depends on type of passed data string usage without modification

null will be expanded to full list of quoted table column names (quoting depends on database)

array

  • Column names will be quoted if used as key or value of array

    1          array('col1', 'col2', 'col2')
    1          // SELECT `col1`, `col2`, `col3` FROM...
  • Column aliasing

    1      array('mycol1' => 'col1', 'mycol2' => 'COUNT(*)')
    1      // SELECT `col1` AS mycol1, COUNT(*) AS mycol2 FROM...
  • NULL and scalar values (strings will be quoted depending on database)

    1      array('col1' => 'my custom string', 'col2' => 1.0, 'col3' => 'NULL')
    1      // SELECT "my custom string" AS `col1`, 1.0 AS `col2`, NULL AS `col3` FROM...
  • If the *-wildcard char is used as key or value, add the full list of quoted table column names

    1      array('col1' => 'NULL', '*')
    1      // SELECT `col1`, `col2`, `col3`, NULL AS `col1` FROM...

Input
mixed | $data
mixed | $value
Output
array | of generated fields - use implode(', ', $selectfieldlist) to collapse field list for usage
Exception

getTableInfo

public void getTableInfo (TDbTableInfo 0 )

Input
TDbTableInfo 0 table information.
Output
Exception

hasIntegerKey

protected boolean hasIntegerKey (array $array )

Input
array | $array
Output
boolean | true if any array key is an integer.
Exception

setDbConnection

public void setDbConnection (TDbConnection $value )

Input
TDbConnection $value database connection.
Output
Exception

setTableInfo

public void setTableInfo (TDbTableInfo $value )

Input
TDbTableInfo $value table information.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbMetaData

Class TDbMetaData (Class Overview)

TComponent
   |
   --TDbMetaData

Direct Known Sub-classes:

TMssqlMetaData , TMysqlMetaData , TOracleMetaData , TPgsqlMetaData , TSqliteMetaData

TDbMetaData is the base class for retrieving metadata information, such as table and columns information, from a database connection.

Use the getTableInfo method to retrieve a table information.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Method Summary
TDbCommandBuilder | createCommandBuilder ( string $tableName) Creates a command builder for a given table name.
protected abstract TDbTableInfo | createTableInfo ( mixed $tableName) This method should be implemented by decendent classes.
TDbConnection | getDbConnection ()
TDbMetaData | getInstance ( TDbConnection $conn) Obtain database specific TDbMetaData class using the driver name of the database connection.
TDbTableInfo | getTableInfo ( string $tableName) Obtains table meta data information for the current connection and given table name.
protected string | getTableInfoClass ()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Method Details

createCommandBuilder

public TDbCommandBuilder createCommandBuilder (string $tableName )

Creates a command builder for a given table name.

Input
string | $tableName | table name.
Output
TDbCommandBuilder | command builder instance for the given table.
Exception

createTableInfo

protected abstract TDbTableInfo createTableInfo (mixed $tableName )

This method should be implemented by decendent classes.

Input
mixed | $tableName
Output
TDbTableInfo | driver dependent create builder.
Exception

getDbConnection

public TDbConnection getDbConnection ()

Output
TDbConnection database connection.
Exception

getInstance

public TDbMetaData getInstance (TDbConnection $conn )

Obtain database specific TDbMetaData class using the driver name of the database connection.

Input
TDbConnection | $conn | database connection.
Output
TDbMetaData | database specific TDbMetaData.
Exception

getTableInfo

public TDbTableInfo getTableInfo (string $tableName )

Obtains table meta data information for the current connection and given table name.

Input
string | $tableName | table or view name
Output
TDbTableInfo | table information.
Exception

getTableInfoClass

protected string getTableInfoClass ()

Output
string TDbTableInfo class name.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbTableColumn

Class TDbTableColumn (Class Overview)

TComponent
   |
   --TDbTableColumn

Direct Known Sub-classes:

TMssqlTableColumn , TMysqlTableColumn , TOracleTableColumn , TPgsqlTableColumn , TSqliteTableColumn

TDbTableColumn class describes the column meta data of the schema for a database table.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Sets the table column meta data.
Method Summary
boolean | getAllowNull ()
string | getColumnId ()
integer | getColumnIndex ()
string | getColumnName ()
string | getColumnSize ()
string | getDbType ()
mixed | getDefaultValue ()
protected mixed | getInfo ( string $name, mixed $default)
boolean | getIsExcluded ()
boolean | getIsForeignKey ()
boolean | getIsPrimaryKey ()
void | getMaxiumNumericConstraint ()
string | getNumericPrecision ()
string | getNumericScale ()
void | getPdoType ( integer 0)
string | getPHPType () Returns the derived PHP primitive type from the db type. Default returns 'string'.
void | getSequenceName ( string 0)
boolean | hasSequence ()
protected void | setInfo ( string $name, mixed $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string UNDEFINED_VALUE
Constructor Details

__construct

public __construct Array

Sets the table column meta data.
Method Details

getAllowNull

public boolean getAllowNull ()

Output
boolean specifies whether value Null is allowed, default is false.
Exception

getColumnId

public string getColumnId ()

Output
string name of the column with quoted identifier.
Exception

getColumnIndex

public integer getColumnIndex ()

Output
integer zero-based ordinal position of the column in the table.
Exception

getColumnName

public string getColumnName ()

Output
string name of the column in the table (identifier quoted).
Exception

getColumnSize

public string getColumnSize ()

Output
string size of the column.
Exception

getDbType

public string getDbType ()

Output
string column type.
Exception

getDefaultValue

public mixed getDefaultValue ()

Output
mixed default column value if column value was null.
Exception

getInfo

protected mixed getInfo (string $name , mixed $default )

Input
string | $name | information array key name
mixed | $default | default value if information array value is null
Output
mixed | information array value.
Exception

getIsExcluded

public boolean getIsExcluded ()

Output
boolean whether this column is excluded from insert and update.
Exception

getIsForeignKey

public boolean getIsForeignKey ()

Output
boolean whether this column is a foreign key, default is false.
Exception

getIsPrimaryKey

public boolean getIsPrimaryKey ()

Output
boolean whether this column is a primary key for the table, default is false.
Exception

getMaxiumNumericConstraint

public void getMaxiumNumericConstraint ()

Output
Exception

getNumericPrecision

public string getNumericPrecision ()

Output
string precision of the column data, if the data is numeric.
Exception

getNumericScale

public string getNumericScale ()

Output
string scale of the column data, if the data is numeric.
Exception

getPdoType

public void getPdoType (integer 0 )

Input
integer 0 PDO bind param/value types, default returns string.
Output
Exception

getPHPType

public string getPHPType ()

Returns the derived PHP primitive type from the db type. Default returns 'string'.

Output
string derived PHP primitive type from the column db type.
Exception

getSequenceName

public void getSequenceName (string 0 )

Input
string 0 sequence name, only applicable if column is a sequence
Output
Exception

hasSequence

public boolean hasSequence ()

Output
boolean whether the column is a sequence.
Exception

setInfo

protected void setInfo (string $name , mixed $value )

Input
string | $name | information array key name
mixed | $value | new information array value.
Output
Exception
Constant Details

UNDEFINED_VALUE

Type:

string

Value:

INF
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDbTableInfo

Class TDbTableInfo (Class Overview)

TComponent
   |
   --TDbTableInfo

Direct Known Sub-classes:

TMssqlTableInfo , TMysqlTableInfo , TPgsqlTableInfo , TSqliteTableInfo

TDbTableInfo class describes the meta data of a database table.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Sets the database table meta data information.
Method Summary
TDbCommandBuilder | createCommandBuilder ( TDbConnection $connection)
TDbTableColumn | getColumn ( string $name)
array | getColumnNames ( array 0)
TMap | getColumns ()
array | getForeignKeys ()
protected mixed | getInfo ( string $name, mixed $default)
boolean | getIsView ()
array | getLowerCaseColumnNames ()
string[] | getPrimaryKeys ()
string | getTableFullName ()
string | getTableName ()
protected void | setInfo ( string $name, mixed $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Sets the database table meta data information.
Method Details

createCommandBuilder

public TDbCommandBuilder createCommandBuilder (TDbConnection $connection )

Input
TDbConnection | $connection | database connection.
Output
TDbCommandBuilder | new command builder
Exception

getColumn

public TDbTableColumn getColumn (string $name )

Input
string | $name | column id
Output
TDbTableColumn | column information.
Exception

getColumnNames

public array getColumnNames (array 0 )

Input
array | 0 | list of column Id, empty to get all columns.
Output
array | table column names (identifier quoted)
Exception

getColumns

public TMap getColumns ()

Output
TMap TDbTableColumn column meta data.
Exception

getForeignKeys

public array getForeignKeys ()

Output
array tuples of foreign table and column name.
Exception

getInfo

protected mixed getInfo (string $name , mixed $default )

Input
string | $name | information array key name
mixed | $default | default value if information array value is null
Output
mixed | information array value.
Exception

getIsView

public boolean getIsView ()

Output
boolean whether the table is a view, default is false.
Exception

getLowerCaseColumnNames

public array getLowerCaseColumnNames ()

Output
array lowercased column key names mapped to normal column ids.
Exception

getPrimaryKeys

public string[] getPrimaryKeys ()

Output
string[] names of primary key columns.
Exception

getTableFullName

public string getTableFullName ()

Output
string full name of the table, database dependent.
Exception

getTableName

public string getTableName ()

Output
string name of the table this column belongs to.
Exception

setInfo

protected void setInfo (string $name , mixed $value )

Input
string | $name | information array key name
mixed | $value | new information array value.
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMssqlCommandBuilder

Class TMssqlCommandBuilder (Class Overview)

TComponent
   |
   --TDbCommandBuilder
      |
      --TMssqlCommandBuilder

TMssqlCommandBuilder provides specifics methods to create limit/offset query commands for MSSQL servers.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
string | applyLimitOffset ( string $sql, integer $limit, integer $offset) Overrides parent implementation. Alters the sql to apply $limit and $offset.
protected array | findOrdering ( string $sql) Base on simplified syntax http://msdn2.microsoft.com/en-us/library/aa259187(SQL.80).aspx
integer | getLastInsertID () Overrides parent implementation. Uses "SELECT @@Identity".
protected string | joinOrdering ( array $orders)
protected array | reverseDirection ( array $orders)
protected sql | rewriteLimitOffsetSql ( string $sql, integer $limit, integer $offset) Rewrite sql to apply $limit > and $offset > 0 for MSSQL database.
Methods Inherited From TDbCommandBuilder
TDbCommandBuilder::applyCriterias(), TDbCommandBuilder::applyLimitOffset(), TDbCommandBuilder::applyOrdering(), TDbCommandBuilder::bindArrayValues(), TDbCommandBuilder::bindColumnValues(), TDbCommandBuilder::createCommand(), TDbCommandBuilder::createCountCommand(), TDbCommandBuilder::createDeleteCommand(), TDbCommandBuilder::createFindCommand(), TDbCommandBuilder::createInsertCommand(), TDbCommandBuilder::createUpdateCommand(), TDbCommandBuilder::getColumnBindings(), TDbCommandBuilder::getDbConnection(), TDbCommandBuilder::getInsertFieldBindings(), TDbCommandBuilder::getLastInsertID(), TDbCommandBuilder::getPdoType(), TDbCommandBuilder::getSearchCondition(), TDbCommandBuilder::getSearchExpression(), TDbCommandBuilder::getSelectFieldList(), TDbCommandBuilder::getTableInfo(), TDbCommandBuilder::hasIntegerKey(), TDbCommandBuilder::setDbConnection(), TDbCommandBuilder::setTableInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

applyLimitOffset

public string applyLimitOffset (string $sql , integer $limit , integer $offset )

Overrides parent implementation. Alters the sql to apply $limit and $offset.

The idea for limit with offset is done by modifying the sql on the fly with numerous assumptions on the structure of the sql string. The modification is done with reference to the notes from http://troels.arvin.dk/db/rdbms/#select-limit-offset

1      SELECT * FROM (
2       SELECT TOP n * FROM (
3         SELECT TOP z columns      -- (z=n+skip)
4         FROM tablename
5         ORDER BY key ASC
6       ) AS FOO ORDER BY key DESC -- ('FOO' may be anything)
7      ) AS BAR ORDER BY key ASC    -- ('BAR' may be anything)

Regular expressions are used to alter the SQL query. The resulting SQL query may be malformed for complex queries. The following restrictions apply

  • In particular, commas should NOT be used as part of the ordering expression or identifier. Commas must only be used for separating the ordering clauses.
  • In the ORDER BY clause, the column name should NOT be be qualified with a table name or view name. Alias the column names or use column index.
  • No clauses should follow the ORDER BY clause, e.g. no COMPUTE or FOR clauses.

Input
string | $sql | SQL query string.
integer | $limit | maximum number of rows, -1 to ignore limit.
integer | $offset | row offset, -1 to ignore offset.
Output
string | SQL with limit and offset.
Exception

findOrdering

protected array findOrdering (string $sql )

Base on simplified syntax http://msdn2.microsoft.com/en-us/library/aa259187(SQL.80).aspx

Input
string | $sql
Output
array | ordering expression as key and ordering direction as value
Exception

getLastInsertID

public integer getLastInsertID ()

Overrides parent implementation. Uses "SELECT @@Identity".

Output
integer last insert id, null if none is found.
Exception

joinOrdering

protected string joinOrdering (array $orders )

Input
array | $orders | ordering obtained from findOrdering()
Output
string | concat the orderings
Exception

reverseDirection

protected array reverseDirection (array $orders )

Input
array | $orders | original ordering
Output
array | ordering with reversed direction.
Exception

rewriteLimitOffsetSql

protected sql rewriteLimitOffsetSql (string $sql , integer $limit , integer $offset )

Rewrite sql to apply $limit > and $offset > 0 for MSSQL database.

See http://troels.arvin.dk/db/rdbms/#select-limit-offset

Input
string | $sql | sql query
integer | $limit | > 0
integer | $offset | > 0
Output
sql | modified sql query applied with limit and offset.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMysqlCommandBuilder

Class TMysqlCommandBuilder (Class Overview)

TComponent
   |
   --TDbCommandBuilder
      |
      --TMysqlCommandBuilder

TMysqlCommandBuilder implements default TDbCommandBuilder

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
Methods Inherited From TDbCommandBuilder
TDbCommandBuilder::applyCriterias(), TDbCommandBuilder::applyLimitOffset(), TDbCommandBuilder::applyOrdering(), TDbCommandBuilder::bindArrayValues(), TDbCommandBuilder::bindColumnValues(), TDbCommandBuilder::createCommand(), TDbCommandBuilder::createCountCommand(), TDbCommandBuilder::createDeleteCommand(), TDbCommandBuilder::createFindCommand(), TDbCommandBuilder::createInsertCommand(), TDbCommandBuilder::createUpdateCommand(), TDbCommandBuilder::getColumnBindings(), TDbCommandBuilder::getDbConnection(), TDbCommandBuilder::getInsertFieldBindings(), TDbCommandBuilder::getLastInsertID(), TDbCommandBuilder::getPdoType(), TDbCommandBuilder::getSearchCondition(), TDbCommandBuilder::getSearchExpression(), TDbCommandBuilder::getSelectFieldList(), TDbCommandBuilder::getTableInfo(), TDbCommandBuilder::hasIntegerKey(), TDbCommandBuilder::setDbConnection(), TDbCommandBuilder::setTableInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()


PRADO API Manual: Docs For Class TOracleCommandBuilder

Class TOracleCommandBuilder (Class Overview)

TComponent
   |
   --TDbCommandBuilder
      |
      --TOracleCommandBuilder

TOracleCommandBuilder provides specifics methods to create limit/offset query commands for Oracle database.

Since: 3.1
Author: Marcos Nobre <marconobre[at]gmail[dot]com>
Method Summary
string | applyLimitOffset ( string $sql, integer $limit, integer $offset) Overrides parent implementation to use Oracle way of get paginated RecordSet instead of using LIMIT sql clause.
string | getSearchExpression ( array $fields, string $keywords) Overrides parent implementation. Only column of type text or character (and its variants) accepts the LIKE criteria.
protected boolean | isSearchableColumn ( mixed $column)
Methods Inherited From TDbCommandBuilder
TDbCommandBuilder::applyCriterias(), TDbCommandBuilder::applyLimitOffset(), TDbCommandBuilder::applyOrdering(), TDbCommandBuilder::bindArrayValues(), TDbCommandBuilder::bindColumnValues(), TDbCommandBuilder::createCommand(), TDbCommandBuilder::createCountCommand(), TDbCommandBuilder::createDeleteCommand(), TDbCommandBuilder::createFindCommand(), TDbCommandBuilder::createInsertCommand(), TDbCommandBuilder::createUpdateCommand(), TDbCommandBuilder::getColumnBindings(), TDbCommandBuilder::getDbConnection(), TDbCommandBuilder::getInsertFieldBindings(), TDbCommandBuilder::getLastInsertID(), TDbCommandBuilder::getPdoType(), TDbCommandBuilder::getSearchCondition(), TDbCommandBuilder::getSearchExpression(), TDbCommandBuilder::getSelectFieldList(), TDbCommandBuilder::getTableInfo(), TDbCommandBuilder::hasIntegerKey(), TDbCommandBuilder::setDbConnection(), TDbCommandBuilder::setTableInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

applyLimitOffset

public string applyLimitOffset (string $sql , integer $limit , integer $offset )

Overrides parent implementation to use Oracle way of get paginated RecordSet instead of using LIMIT sql clause.

Input
string | $sql | SQL query string.
integer | $limit | maximum number of rows, -1 to ignore limit.
integer | $offset | row offset, -1 to ignore offset.
Output
string | SQL with limit and offset in Oracle way.
Exception

getSearchExpression

public string getSearchExpression (array $fields , string $keywords )

Overrides parent implementation. Only column of type text or character (and its variants) accepts the LIKE criteria.

Input
array | $fields | list of column id for potential search condition.
string | $keywords | string of keywords
Output
string | SQL search condition matching on a set of columns.
Exception

isSearchableColumn

protected boolean isSearchableColumn (mixed $column )

Input
mixed | $column
Output
boolean | true if column can be used for LIKE searching.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TOracleTableInfo

Class TOracleTableInfo (Class Overview)

TComponent
   |
   --TOracleTableInfo

TDbTableInfo class describes the meta data of a database table.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Sets the database table meta data information.
Method Summary
TDbCommandBuilder | createCommandBuilder ( TDbConnection $connection)
TDbTableColumn | getColumn ( string $name)
array | getColumnNames ( array 0)
TMap | getColumns ()
array | getForeignKeys ()
mixed | getInfo ( string $name, mixed $default)
boolean | getIsView ()
array | getLowerCaseColumnNames ()
string[] | getPrimaryKeys ()
string | getTableFullName ()
string | getTableName ()
protected void | setInfo ( string $name, mixed $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Sets the database table meta data information.
Method Details

createCommandBuilder

public TDbCommandBuilder createCommandBuilder (TDbConnection $connection )

Input
TDbConnection | $connection | database connection.
Output
TDbCommandBuilder | new command builder
Exception

getColumn

public TDbTableColumn getColumn (string $name )

Input
string | $name | column id
Output
TDbTableColumn | column information.
Exception

getColumnNames

public array getColumnNames (array 0 )

Input
array | 0 | list of column Id, empty to get all columns.
Output
array | table column names (identifier quoted)
Exception

getColumns

public TMap getColumns ()

Output
TMap TDbTableColumn column meta data.
Exception

getForeignKeys

public array getForeignKeys ()

Output
array tuples of foreign table and column name.
Exception

getInfo

public mixed getInfo (string $name , mixed $default )

Input
string | $name | information array key name
mixed | $default | default value if information array value is null
Output
mixed | information array value.
Exception

getIsView

public boolean getIsView ()

Output
boolean whether the table is a view, default is false.
Exception

getLowerCaseColumnNames

public array getLowerCaseColumnNames ()

Output
array lowercased column key names mapped to normal column ids.
Exception

getPrimaryKeys

public string[] getPrimaryKeys ()

Output
string[] names of primary key columns.
Exception

getTableFullName

public string getTableFullName ()

Output
string full name of the table, database dependent.
Exception

getTableName

public string getTableName ()

Output
string name of the table this column belongs to.
Exception

setInfo

protected void setInfo (string $name , mixed $value )

Input
string | $name | information array key name
mixed | $value | new information array value.
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPgsqlCommandBuilder

Class TPgsqlCommandBuilder (Class Overview)

TComponent
   |
   --TDbCommandBuilder
      |
      --TPgsqlCommandBuilder

TPgsqlCommandBuilder provides specifics methods to create limit/offset query commands for Pgsql database.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected string | getSearchCondition ( string $column, array $words) Overrides parent implementation to use PostgreSQL's ILIKE instead of LIKE (case-sensitive).
string | getSearchExpression ( array $fields, string $keywords) Overrides parent implementation. Only column of type text or character (and its variants) accepts the LIKE criteria.
protected boolean | isSearchableColumn ( mixed $column)
Methods Inherited From TDbCommandBuilder
TDbCommandBuilder::applyCriterias(), TDbCommandBuilder::applyLimitOffset(), TDbCommandBuilder::applyOrdering(), TDbCommandBuilder::bindArrayValues(), TDbCommandBuilder::bindColumnValues(), TDbCommandBuilder::createCommand(), TDbCommandBuilder::createCountCommand(), TDbCommandBuilder::createDeleteCommand(), TDbCommandBuilder::createFindCommand(), TDbCommandBuilder::createInsertCommand(), TDbCommandBuilder::createUpdateCommand(), TDbCommandBuilder::getColumnBindings(), TDbCommandBuilder::getDbConnection(), TDbCommandBuilder::getInsertFieldBindings(), TDbCommandBuilder::getLastInsertID(), TDbCommandBuilder::getPdoType(), TDbCommandBuilder::getSearchCondition(), TDbCommandBuilder::getSearchExpression(), TDbCommandBuilder::getSelectFieldList(), TDbCommandBuilder::getTableInfo(), TDbCommandBuilder::hasIntegerKey(), TDbCommandBuilder::setDbConnection(), TDbCommandBuilder::setTableInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getSearchCondition

protected string getSearchCondition (string $column , array $words )

Overrides parent implementation to use PostgreSQL's ILIKE instead of LIKE (case-sensitive).

Input
string | $column | column name.
array | $words | keywords
Output
string | search condition for all words in one column.
Exception

getSearchExpression

public string getSearchExpression (array $fields , string $keywords )

Overrides parent implementation. Only column of type text or character (and its variants) accepts the LIKE criteria.

Input
array | $fields | list of column id for potential search condition.
string | $keywords | string of keywords
Output
string | SQL search condition matching on a set of columns.
Exception

isSearchableColumn

protected boolean isSearchableColumn (mixed $column )

Input
mixed | $column
Output
boolean | true if column can be used for LIKE searching.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqliteCommandBuilder

Class TSqliteCommandBuilder (Class Overview)

TComponent
   |
   --TDbCommandBuilder
      |
      --TSqliteCommandBuilder

TSqliteCommandBuilder provides specifics methods to create limit/offset query commands for Sqlite database.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
string
applyLimitOffset ( string $sql, integer $limit, integer $offset)
Alters the sql to apply $limit and $offset.
Methods Inherited From TDbCommandBuilder
TDbCommandBuilder::applyCriterias(), TDbCommandBuilder::applyLimitOffset(), TDbCommandBuilder::applyOrdering(), TDbCommandBuilder::bindArrayValues(), TDbCommandBuilder::bindColumnValues(), TDbCommandBuilder::createCommand(), TDbCommandBuilder::createCountCommand(), TDbCommandBuilder::createDeleteCommand(), TDbCommandBuilder::createFindCommand(), TDbCommandBuilder::createInsertCommand(), TDbCommandBuilder::createUpdateCommand(), TDbCommandBuilder::getColumnBindings(), TDbCommandBuilder::getDbConnection(), TDbCommandBuilder::getInsertFieldBindings(), TDbCommandBuilder::getLastInsertID(), TDbCommandBuilder::getPdoType(), TDbCommandBuilder::getSearchCondition(), TDbCommandBuilder::getSearchExpression(), TDbCommandBuilder::getSelectFieldList(), TDbCommandBuilder::getTableInfo(), TDbCommandBuilder::hasIntegerKey(), TDbCommandBuilder::setDbConnection(), TDbCommandBuilder::setTableInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

applyLimitOffset

public string applyLimitOffset (string $sql , integer $limit , integer $offset )

Alters the sql to apply $limit and $offset.

Input
string | $sql | SQL query string.
integer | $limit | maximum number of rows, -1 to ignore limit.
integer | $offset | row offset, -1 to ignore offset.
Output
string | SQL with limit and offset.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TDiscriminator

Class TDiscriminator (Class Overview)

TComponent
   |
   --TDiscriminator

The TDiscriminator corresponds to the <discriminator> tag within a <resultMap>.

TDiscriminator allows inheritance logic in SqlMap result mappings. SqlMap compares the data found in the discriminator column to the different <submap> values using the column value's string equivalence. When the string values matches a particular <submap>, SqlMap will use the <resultMap> defined by resultMapping property for loading the object data.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
void | addSubMap ( TSubMap $subMap)
string | getColumn ()
int | getColumnIndex ()
TResultProperty | getMapping ()
mixed | getNullValue ()
TResultMap | getSubMap ( string $value)
void | getType ( string 0)
string | getTypeHandler ()
void | initialize ( TSqlMapManager $manager) Set the result maps for particular sub-mapping values.
void | initMapping ( TResultMap $resultMap) Copies the discriminator properties to a new TResultProperty.
void | setColumn ( string $value)
void | setColumnIndex ( int $value) The columnIndex attribute value is the index of the column in the ResultSet from which the value will be used to populate the object property.
void | setNullValue ( mixed $value)
string | setType ( mixed $value) The type attribute is used to explicitly specify the property type of the parameter to be set. If the attribute type is not set and the framework cannot otherwise determine the type, the type is assumed from the default value of the property.
void | setTypeHandler ( string $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

addSubMap

public void addSubMap (TSubMap $subMap )

Input
TSubMap $subMap add new sub mapping.
Output
Exception

getColumn

public string getColumn ()

Output
string the name of the column in the result set from which the value will be used to populate the property.
Exception

getColumnIndex

public int getColumnIndex ()

Output
int index of the column in the ResultSet
Exception

getMapping

public TResultProperty getMapping ()

Output
TResultProperty result property for the discriminator column.
Exception

getNullValue

public mixed getNullValue ()

Output
mixed outgoing null value replacement.
Exception

getSubMap

public TResultMap getSubMap (string $value )

Input
string | $value | database value
Output
TResultMap | result mapping.
Exception

getType

public void getType (string 0 )

Input
string 0 property type of the parameter to be set.
Output
Exception

getTypeHandler

public string getTypeHandler ()

Output
string custom type handler class name (may use namespace).
Exception

initialize

public void initialize (TSqlMapManager $manager )

Set the result maps for particular sub-mapping values.

Input
TSqlMapManager $manager sql map manager instance.
Output
Exception

initMapping

public void initMapping (TResultMap $resultMap )

Copies the discriminator properties to a new TResultProperty.

Input
TResultMap $resultMap result map holding the discriminator.
Output
Exception

setColumn

public void setColumn (string $value )

Input
string $value the name of the column in the result set from which the value will be used to populate the property.
Output
Exception

setColumnIndex

public void setColumnIndex (int $value )

The columnIndex attribute value is the index of the column in the ResultSet from which the value will be used to populate the object property.

Input
int $value index of the column in the ResultSet
Output
Exception

setNullValue

public void setNullValue (mixed $value )

Input
mixed $value outgoing null value replacement.
Output
Exception

setType

public string setType (mixed $value )

The type attribute is used to explicitly specify the property type of the parameter to be set. If the attribute type is not set and the framework cannot otherwise determine the type, the type is assumed from the default value of the property.

Input
mixed | $value
Output
string | property type of the parameter to be set.
Exception

setTypeHandler

public void setTypeHandler (string $value )

Input
string $value custom type handler class name (may use namespace).
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSubMap

Class TSubMap (Class Overview)

TComponent
   |
   --TSubMap

TSubMap class defines a submapping value and the corresponding <resultMap>

The Value property is used for comparison with the discriminator column value. When the Value matches that of the discriminator column value, the corresponding ResultMapping is used inplace of the current result map.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
string | getResultMapping () The result map to use when the Value matches the discriminator column value.
string | getValue ()
void | setResultMapping ( string $value)
void | setValue ( string $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getResultMapping

public string getResultMapping ()

The result map to use when the Value matches the discriminator column value.

Output
string ID of a result map
Exception

getValue

public string getValue ()

Output
string value for comparison with discriminator column value.
Exception

setResultMapping

public void setResultMapping (string $value )

Input
string $value ID of a result map
Output
Exception

setValue

public void setValue (string $value )

Input
string $value value for comparison with discriminator column value.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TInlineParameterMapParser

Class TInlineParameterMapParser (Class Overview)

TInlineParameterMapParser class.

The inline parameter map syntax lets you embed the property name,  the property type, the column type, and a null value replacement into a  parametrized SQL statement.

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

Method Summary
array | parse ( string $sqlText, array $scope) Parse the sql text for inline parameters.
protected void | parseMapping ( string $token, array $scope) Parse inline parameter with syntax as

            Constant Summary

                    string

                PARAMETER_TOKEN_REGEXP

                    Regular expression for parsing inline parameter maps.

            Method Details

parse

                                public array parse
                                (string $sqlText , array $scope )

Parse the sql text for inline parameters.

Input
string | $sqlText | sql text
array | $scope | file and node details for exception message.
Output
array | 'sql' and 'parameters' name value pairs.
Exception

parseMapping

                                protected void parseMapping
                                (string $token , array $scope )

Parse inline parameter with syntax as

#propertyName,type=string,dbype=Varchar,nullValue=N/A,handler=string#

Input
string | $token | parameter token
array | $scope | file and node details for exception message.
Output
Exception

            Constant Details

PARAMETER_TOKEN_REGEXP

Regular expression for parsing inline parameter maps.

Type:

    string

Value:

 '/#([^#]+)#/'


PRADO API Manual: Docs For Class TParameterMap

Class TParameterMap (Class Overview)

TComponent
   |
   --TParameterMap

TParameterMap corresponds to the <parameterMap> element.

TParameterMap holds one or more parameter child elements that map object properties to placeholders in a SQL statement.

A TParameterMap defines an ordered list of values that match up with the placeholders of a parameterized query statement. While the attributes specified by the map still need to be in the correct order, each parameter is named. You can populate the underlying class in any order, and the TParameterMap ensures each value is passed in the correct order.

Parameter Maps can be provided as an external element and inline. The <parameterMap> element accepts two attributes: id (required) and extends (optional).

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct
Initialize the properties and property map collections.
Method Summary
void | addProperty ( TParameterProperty $property)
protected TSqlMapTypeHandler | createTypeHandler ( TParameterProperty $property, TSqlMapTypeHandlerRegistry $registry) Create type handler from Type or TypeHandler.
string | getExtends ()
string | getID ()
protected mixed | getObjectValue ( mixed $object, TParameterProperty $property)
TParameterProperty[] | getProperties ()
TParameterProperty | getProperty ( string $index)
array | getPropertyNames ()
unknown | getPropertyValue ( TSqlMapTypeHandlerRegistry $registry, TParameterProperty $property, mixed $parameterValue) Get the value of a property from the the parameter object.
void | insertProperty ( int $index, TParameterProperty $property)
protected mixed | nullifyDefaultValue ( TParameterProperty $property, mixed $value) When the actual value matches the NullValue, set the current value to null.
void | setExtends ( string $value)
void | setID ( string $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct

Initialize the properties and property map collections.
Method Details

addProperty

public void addProperty (TParameterProperty $property )

Input
TParameterProperty $property new parameter property
Output
Exception

createTypeHandler

protected TSqlMapTypeHandler createTypeHandler (TParameterProperty $property , TSqlMapTypeHandlerRegistry $registry )

Create type handler from Type or TypeHandler.

Input
TParameterProperty | $property | parameter property
TSqlMapTypeHandlerRegistry | $registry | type handler registry
Output
TSqlMapTypeHandler | type handler.
Exception

getExtends

public string getExtends ()

Output
string name of another <parameterMap> upon which to base this TParameterMap.
Exception

getID

public string getID ()

Output
string a unique identifier for the <parameterMap>.
Exception

getObjectValue

protected mixed getObjectValue (mixed $object , TParameterProperty $property )

Input
mixed | $object | object to obtain the property from.
TParameterProperty | $property | parameter property.
Output
mixed | property value.
Exception
throws | TSqlMapException if property access is invalid.

getProperties

public TParameterProperty[] getProperties ()

Output
TParameterProperty[] list of properties for the parameter map.
Exception

getProperty

public TParameterProperty getProperty (string $index )

Input
string | $index | name of a parameter property.
Output
TParameterProperty | parameter property.
Exception
throws | TSqlMapException if index is not string nor integer.

getPropertyNames

public array getPropertyNames ()

Output
array list of property names.
Exception

getPropertyValue

public unknown getPropertyValue (TSqlMapTypeHandlerRegistry $registry , TParameterProperty $property , mixed $parameterValue )

Get the value of a property from the the parameter object.

Input
TSqlMapTypeHandlerRegistry | $registry | type handler registry.
TParameterProperty | $property | parameter proproperty.
mixed | $parameterValue | parameter object to get the value from.
Output
Exception

insertProperty

public void insertProperty (int $index , TParameterProperty $property )

Input
int | $index | parameter property index
TParameterProperty | $property | new parameter property.
Output
Exception

nullifyDefaultValue

protected mixed nullifyDefaultValue (TParameterProperty $property , mixed $value )

When the actual value matches the NullValue, set the current value to null.

Input
TParameterProperty | $property | parameter property.
mixed | $value | current property value
Output
mixed | null if NullValue matches currrent value.
Exception

setExtends

public void setExtends (string $value )

Input
string $value name of another <parameterMap> upon which to base this TParameterMap.
Output
Exception

setID

public void setID (string $value )

Input
string $value a unique identifier for the <parameterMap>.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TParameterProperty

Class TParameterProperty (Class Overview)

TComponent
   |
   --TParameterProperty

TParameterProperty corresponds to the <property> tag and defines one object property for the <parameterMap>

The NullValue attribute can be set to any valid value (based on property type). The NullValue attribute is used to specify an inbound null value replacement. What this means is that when the value is detected in the object property, a NULL will be written to the database (the opposite behavior of an inbound null value replacement). This allows you to use a magic null number in your application for types that do not support null values (such as int, double, float). When these types of properties contain a matching null value (for example, say, -9999), a NULL will be written to the database instead of the value.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
string | getColumn ()
string | getDbType ()
mixed | getNullValue ()
string | getProperty ()
string | getType ()
string | getTypeHandler ()
void | setColumn ( string $value)
void | setDbType ( string $value)
void | setNullValue ( mixed $value) The nullValue attribute is used to specify an outgoing null value replacement.
void | setProperty ( string $value)
void | setType ( string $value)
void | setTypeHandler ( string $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getColumn

public string getColumn ()

Output
string name of a parameter to be used in the SQL statement.
Exception

getDbType

public string getDbType ()

Output
string the database column type of the parameter to be set by this property.
Exception

getNullValue

public mixed getNullValue ()

Output
mixed null value replacement
Exception

getProperty

public string getProperty ()

Output
string name of a property of the parameter object.
Exception

getType

public string getType ()

Output
string type of the parameter's property
Exception

getTypeHandler

public string getTypeHandler ()

Output
string class name of a custom type handler.
Exception

setColumn

public void setColumn (string $value )

Input
string $value name of a parameter to be used in the SQL statement.
Output
Exception

setDbType

public void setDbType (string $value )

Input
string $value the database column type of the parameter to be set by this property.
Output
Exception

setNullValue

public void setNullValue (mixed $value )

The nullValue attribute is used to specify an outgoing null value replacement.

Input
mixed $value null value replacement.
Output
Exception

setProperty

public void setProperty (string $value )

Input
string $value name of a property of the parameter object.
Output
Exception

setType

public void setType (string $value )

Input
string $value type of the parameter's property
Output
Exception

setTypeHandler

public void setTypeHandler (string $value )

Input
string $value class name of a custom type handler.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TResultMap

Class TResultMap (Class Overview)

TComponent
   |
   --TResultMap

TResultMap corresponds to <resultMap> mapping tag.

A TResultMap lets you control how data is extracted from the result of a query, and how the columns are mapped to object properties. A TResultMap can describe the column type, a null value replacement, and complex property mappings including Collections.

The <resultMap> can contain any number of property mappings that map object properties to the columns of a result element. The property mappings are applied, and the columns are read, in the order that they are defined. Maintaining the element order ensures consistent results between different drivers and providers.

The Class property must be a PHP class object or array instance.

The optional Extends attribute can be set to the ID of another <resultMap> upon which to base this <resultMap>. All properties of the "parent" <resultMap> will be included as part of this <resultMap>, and values from the "parent" <resultMap> are set before any values specified by this <resultMap>.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct
Initialize the columns collection.
Method Summary
void | addResultProperty ( TResultProperty $property) Add a TResultProperty to result mapping.
mixed | createInstanceOfResult ( TSqlMapTypeHandlerRegistry $registry) Create a new instance of the class of this result map.
string | getClass ()
TMap | getColumns ()
TDiscriminator | getDiscriminator ()
string | getExtends ()
string | getGroupBy ()
string | getID ()
TResultMap | resolveSubMap ( TSqlMapTypeHandlerRegistry $registry, array $row) Result sub-mappings using the discriminiator column.
void | setClass ( string $value)
void | setDiscriminator ( TDiscriminator $value)
void | setExtends ( string $value)
void | setGroupBy ( string $value)
void | setID ( string $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct

Initialize the columns collection.
Method Details

addResultProperty

public void addResultProperty (TResultProperty $property )

Add a TResultProperty to result mapping.

Input
TResultProperty $property result property.
Output
Exception

createInstanceOfResult

public mixed createInstanceOfResult (TSqlMapTypeHandlerRegistry $registry )

Create a new instance of the class of this result map.

Input
TSqlMapTypeHandlerRegistry | $registry | type handler registry.
Output
mixed | new result object.
Exception
throws | TSqlMapException

getClass

public string getClass ()

Output
string result class name.
Exception

getColumns

public TMap getColumns ()

Output
TMap result columns.
Exception

getDiscriminator

public TDiscriminator getDiscriminator ()

Output
TDiscriminator result class discriminator.
Exception

getExtends

public string getExtends ()

Output
string result map extends another result map.
Exception

getGroupBy

public string getGroupBy ()

Output
string result map groups by.
Exception

getID

public string getID ()

Output
string a unique identifier for the <resultMap>.
Exception

resolveSubMap

public TResultMap resolveSubMap (TSqlMapTypeHandlerRegistry $registry , array $row )

Result sub-mappings using the discriminiator column.

Input
TSqlMapTypeHandlerRegistry | $registry | type handler registry
array | $row | row data.
Output
TResultMap | result sub-map.
Exception

setClass

public void setClass (string $value )

Input
string $value result class name.
Output
Exception

setDiscriminator

public void setDiscriminator (TDiscriminator $value )

Input
TDiscriminator $value result class discriminator.
Output
Exception

setExtends

public void setExtends (string $value )

Input
string $value result map extends another result map.
Output
Exception

setGroupBy

public void setGroupBy (string $value )

Input
string $value result map group by
Output
Exception

setID

public void setID (string $value )

Input
string $value a unique identifier for the <resultMap>.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TResultProperty

Class TResultProperty (Class Overview)

TComponent
   |
   --TResultProperty

TResultProperty corresponds a <property> tags inside a <resultMap> tag.

The NullValue attribute can be set to any valid value (based on property type). The NullValue attribute is used to specify an outgoing null value replacement. What this means is that when a null value is detected in the result, the corresponding value of the NullValue will be used instead.

The Select property is used to describe a relationship between objects and to automatically load complex (i.e. user defined) property types. The value of the Select property must be the name of another mapped statement. The value of the database Column that is defined in the same property element as this statement attribute will be passed to the related mapped statement as the parameter. The LazyLoad attribute can be specified with the Select .

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Gets the containing result map ID.
Method Summary
protected TSqlMapTypeHandler | createTypeHandler ( TSqlMapTypeHandlerRegistry $registry) Create type handler from Type or TypeHandler.
string | getColumn ()
int | getColumnIndex ()
boolean | getLazyLoad ()
TResultMap | getNestedResultMap ()
mixed | getNullValue ()
string | getProperty ()
mixed | getPropertyValue ( TSqlMapTypeHandlerRegistry $registry, array $row) Gets the value for the current property, converts to applicable type if necessary.
protected int | getPropertyValueType () Determines if the type is an instance of ArrayAccess, TList or an array.
string | getResultMapping ()
string | getSelect ()
string | getType ()
protected mixed | getTypedValue ( TSqlMapTypeHandlerRegistry $registry, mixed $value)
string | getTypeHandler ()
boolean | instanceOfArrayType ( object result $target) Returns true if the result property Type is of ArrayAccess
boolean | instanceOfListType ( object result $target) Returns true if the result property Type is of TList type or that the actual result object is an instance of TList.
void | setColumn ( string $value)
void | setColumnIndex ( int $value)
void | setLazyLoad ( boolean $value)
void | setNestedResultMap ( TResult $value)
void | setNullValue ( mixed $value)
void | setProperty ( string $value)
void | setResultMapping ( mixed $value)
void | setSelect ( string $value) The select property is used to describe a relationship between objects and to automatically load complex (i.e. user defined) property types.
void | setType ( string $value)
void | setTypeHandler ( string $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
int | ARRAY_TYPE
int | LIST_TYPE
Constructor Details

__construct

public __construct Array

Gets the containing result map ID.
Method Details

createTypeHandler

protected TSqlMapTypeHandler createTypeHandler (TSqlMapTypeHandlerRegistry $registry )

Create type handler from Type or TypeHandler.

Input
TSqlMapTypeHandlerRegistry | $registry | type handler registry
Output
TSqlMapTypeHandler | type handler.
Exception

getColumn

public string getColumn ()

Output
string name of the column in the result set from which the value will be used to populate the property.
Exception

getColumnIndex

public int getColumnIndex ()

Output
int index of the column in the ResultSet from which the value will be used to populate the object property
Exception

getLazyLoad

public boolean getLazyLoad ()

Output
boolean indicate whether or not the select statement's results should be lazy loaded
Exception

getNestedResultMap

public TResultMap getNestedResultMap ()

Output
TResultMap nested result map.
Exception

getNullValue

public mixed getNullValue ()

Output
mixed null value replacement.
Exception

getProperty

public string getProperty ()

Output
string name of a property of the result object that will be set to.
Exception

getPropertyValue

public mixed getPropertyValue (TSqlMapTypeHandlerRegistry $registry , array $row )

Gets the value for the current property, converts to applicable type if necessary.

Input
TSqlMapTypeHandlerRegistry | $registry | type handler registry
array | $row | result row
Output
mixed | property value.
Exception

getPropertyValueType

protected int getPropertyValueType ()

Determines if the type is an instance of ArrayAccess, TList or an array.

Output
int TResultProperty::LIST_TYPE or TResultProperty::ARRAY_TYPE
Exception

getResultMapping

public string getResultMapping ()

Output
string ID of another <resultMap> used to fill the property.
Exception

getSelect

public string getSelect ()

Output
string name of another mapped statement
Exception

getType

public string getType ()

Output
string property type of the object property to be set.
Exception

getTypedValue

protected mixed getTypedValue (TSqlMapTypeHandlerRegistry $registry , mixed $value )

Input
TSqlMapTypeHandlerRegistry | $registry | type handler registry
mixed | $value | raw property value
Output
mixed | property value casted to specific type.
Exception

getTypeHandler

public string getTypeHandler ()

Output
string custom type handler class name (may use namespace).
Exception

instanceOfArrayType

public boolean instanceOfArrayType (object result $target )

Returns true if the result property Type is of ArrayAccess

or that the actual result object is an array or implements ArrayAccess

Input
object result | $target | object
Output
boolean | true if the result object is an instance of ArrayAccess or is an array.
Exception

instanceOfListType

public boolean instanceOfListType (object result $target )

Returns true if the result property Type is of TList type or that the actual result object is an instance of TList.

Input
object result | $target | object
Output
boolean | true if the result object is an instance of TList
Exception

setColumn

public void setColumn (string $value )

Input
string $value name of the column in the result set from which the value will be used to populate the property.
Output
Exception

setColumnIndex

public void setColumnIndex (int $value )

Input
int $value index of the column in the ResultSet from which the value will be used to populate the object property
Output
Exception

setLazyLoad

public void setLazyLoad (boolean $value )

Input
boolean $value indicate whether or not the select statement's results should be lazy loaded
Output
Exception

setNestedResultMap

public void setNestedResultMap (TResult $value )

Input
TResult $value nested result map.
Output
Exception

setNullValue

public void setNullValue (mixed $value )

Input
mixed $value null value replacement.
Output
Exception

setProperty

public void setProperty (string $value )

Input
string $value name of a property of the result object that will be set to.
Output
Exception

setResultMapping

public void setResultMapping (mixed $value )

Input
mixed $value
Output
Exception

setSelect

public void setSelect (string $value )

The select property is used to describe a relationship between objects and to automatically load complex (i.e. user defined) property types.

Input
string $value name of another mapped statement.
Output
Exception

setType

public void setType (string $value )

Input
string $value property type of the object property to be set.
Output
Exception

setTypeHandler

public void setTypeHandler (string $value )

Input
string $value custom type handler class name (may use namespace).
Output
Exception

Constant Details

ARRAY_TYPE

Type:

int

Value:

1

LIST_TYPE

Type:

int

Value:

0


PRADO API Manual: Docs For Class TSimpleDynamicParser

Class TSimpleDynamicParser (Class Overview)

TSimpleDynamicParser finds place holders $name$ in the sql text and replaces  it with a TSimpleDynamicParser::DYNAMIC_TOKEN.

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

            Method Summary

                        array

                            parse
                        (	string $sqlText)

                            Parse the sql text for dynamic place holders of the form $name$.

Constant Summary
string | DYNAMIC_TOKEN
string | PARAMETER_TOKEN_REGEXP

            Method Details

parse

                                public array parse
                                (string $sqlText )

Parse the sql text for dynamic place holders of the form $name$.

Input
string | $sqlText | Sql text.
Output
array | name value pairs 'sql' and 'parameters'.
Exception

            Constant Details

DYNAMIC_TOKEN

Type:

    string

Value:

 '`!`'

PARAMETER_TOKEN_REGEXP

Type:

    string

Value:

 '/\$([^\$]+)\$/'


PRADO API Manual: Docs For Class TSqlMapCacheKey

Class TSqlMapCacheKey (Class Overview)

TSqlMapCacheKey class.

Provides a hash of the object to be cached.

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

                    Constructor Summary

                    public

                            __construct
                            Array

Method Summary
protected string | generateKey ( string $string)
string | getHash ()

                    Constructor Details

__construct

                                public __construct
                                Array

            Method Details

generateKey

                                protected string generateKey
                                (string $string )

Input
string | $string | serialized object
Output
string | crc32 hash of the serialized object.
Exception

getHash

                                public string getHash
                                ()

Output

                                    string
                 object hash.

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapCacheModel

Class TSqlMapCacheModel (Class Overview)

TComponent
   |
   --TSqlMapCacheModel

TSqlMapCacheModel corresponds to the <cacheModel> sql mapping configuration tag.

The results from a query Mapped Statement can be cached simply by specifying the CacheModel property in <statement> tag. A cache model is a configured cache that is defined within the sql map configuration file. Cache models are configured using the <cacheModel> element.

The cache model uses a pluggable framework for supporting different types of caches. The choice of cache is specified by the Implementation property. The class name specified must be one of TSqlMapCacheTypes.

The cache implementations, LRU and FIFO cache below do not persist across requests. That is, once the request is complete, all cache data is lost. These caches are useful queries that results in the same repeated data during the current request.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
void | flush () Clears the cache.
mixed | get ( TSqlMapCacheKey|string $key)
integer | getFlushInterval ()
float | getHitRatio ()
string | getID ()
string | getImplementation ()
string | getImplementationClass ()
void | initialize ( ISqLMapCache $cache) Initialize the cache implementation, sets the actual cache contain if supplied.
void | registerTriggerStatement ( TMappedStatement $mappedStatement) Register a mapped statement that will trigger a cache flush.
void | set ( TSqlMapCacheKey|string $key, mixed $value)
void | setFlushInterval ( integer $value)
void | setID ( string $value)
void | setImplementation ( string $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

flush

public void flush ()

Clears the cache.

Output
Exception

get

public mixed get (TSqlMapCacheKey|string $key )

Input
TSqlMapCacheKey|string | $key | cache key
Output
mixed | cached value.
Exception

getFlushInterval

public integer getFlushInterval ()

Output
integer cache duration.
Exception

getHitRatio

public float getHitRatio ()

Output
float cache hit ratio.
Exception

getID

public string getID ()

Output
string unique cache model identifier.
Exception

getImplementation

public string getImplementation ()

Output
string cache implements of TSqlMapCacheTypes, either 'Basic', 'LRU' or 'FIFO'.
Exception

getImplementationClass

public string getImplementationClass ()

Output
string cache implementation class name.
Exception

initialize

public void initialize (ISqLMapCache $cache )

Initialize the cache implementation, sets the actual cache contain if supplied.

Input
ISqLMapCache $cache cache implementation instance.
Output
Exception

registerTriggerStatement

public void registerTriggerStatement (TMappedStatement $mappedStatement )

Register a mapped statement that will trigger a cache flush.

Input
TMappedStatement $mappedStatement mapped statement that may flush the cache.
Output
Exception

set

public void set (TSqlMapCacheKey|string $key , mixed $value )

Input
TSqlMapCacheKey|string | $key | cache key
mixed | $value | value to be cached.
Output
Exception

setFlushInterval

public void setFlushInterval (integer $value )

Input
integer $value the number of seconds in which the cached value will expire. 0 means never expire.
Output
Exception

setID

public void setID (string $value )

Input
string $value unique cache model identifier.
Output
Exception

setImplementation

public void setImplementation (string $value )

Input
string $value cache implements of TSqlMapCacheTypes, either 'Basic', 'LRU' or 'FIFO'.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapCacheTypes

Class TSqlMapCacheTypes (Class Overview)

TEnumerable
   |
   --TSqlMapCacheTypes

TSqlMapCacheTypes enumerable class.

Implemented cache are 'Basic', 'FIFO' and 'LRU'.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constant Summary
string | Basic
string | FIFO
string | LRU
Constant Details

Basic

Type:

string

Value:

'Basic'

FIFO

Type:

string

Value:

'FIFO'

LRU

Type:

string

Value:

'LRU'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapDelete

Class TSqlMapDelete (Class Overview)

TComponent
   |
   --TSqlMapStatement
      |
      --TSqlMapUpdate
         |
         --TSqlMapDelete

TSqlMapDelete class corresponds to the <delete> element.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
Methods Inherited From TSqlMapStatement
TSqlMapStatement::createInstanceOf(), TSqlMapStatement::createInstanceOfListClass(), TSqlMapStatement::createInstanceOfResultClass(), TSqlMapStatement::getCache(), TSqlMapStatement::getCacheModel(), TSqlMapStatement::getExtends(), TSqlMapStatement::getID(), TSqlMapStatement::getListClass(), TSqlMapStatement::getParameterClass(), TSqlMapStatement::getParameterMap(), TSqlMapStatement::getResultClass(), TSqlMapStatement::getResultMap(), TSqlMapStatement::getSqlText(), TSqlMapStatement::initialize(), TSqlMapStatement::parameterMap(), TSqlMapStatement::resultMap(), TSqlMapStatement::setCache(), TSqlMapStatement::setCacheModel(), TSqlMapStatement::setExtends(), TSqlMapStatement::setID(), TSqlMapStatement::setInlineParameterMap(), TSqlMapStatement::setListClass(), TSqlMapStatement::setParameterClass(), TSqlMapStatement::setParameterMap(), TSqlMapStatement::setResultClass(), TSqlMapStatement::setResultMap(), TSqlMapStatement::setSqlText()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()


PRADO API Manual: Docs For Class TSqlMapInsert

Class TSqlMapInsert (Class Overview)

TComponent
   |
   --TSqlMapStatement
      |
      --TSqlMapInsert

TSqlMapInsert class corresponds to the <insert> element.

The <insert> element allows <selectKey> child elements that can be used to generate a key to be used for the insert command.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
TSqlMapSelectKey | getSelectKey ()
void | setSelectKey ( TSqlMapSelectKey $value)
Methods Inherited From TSqlMapStatement
TSqlMapStatement::createInstanceOf(), TSqlMapStatement::createInstanceOfListClass(), TSqlMapStatement::createInstanceOfResultClass(), TSqlMapStatement::getCache(), TSqlMapStatement::getCacheModel(), TSqlMapStatement::getExtends(), TSqlMapStatement::getID(), TSqlMapStatement::getListClass(), TSqlMapStatement::getParameterClass(), TSqlMapStatement::getParameterMap(), TSqlMapStatement::getResultClass(), TSqlMapStatement::getResultMap(), TSqlMapStatement::getSqlText(), TSqlMapStatement::initialize(), TSqlMapStatement::parameterMap(), TSqlMapStatement::resultMap(), TSqlMapStatement::setCache(), TSqlMapStatement::setCacheModel(), TSqlMapStatement::setExtends(), TSqlMapStatement::setID(), TSqlMapStatement::setInlineParameterMap(), TSqlMapStatement::setListClass(), TSqlMapStatement::setParameterClass(), TSqlMapStatement::setParameterMap(), TSqlMapStatement::setResultClass(), TSqlMapStatement::setResultMap(), TSqlMapStatement::setSqlText()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getSelectKey

public TSqlMapSelectKey getSelectKey ()

Output
TSqlMapSelectKey select key element.
Exception

setSelectKey

public void setSelectKey (TSqlMapSelectKey $value )

Input
TSqlMapSelectKey $value select key.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapSelectKey

Class TSqlMapSelectKey (Class Overview)

TComponent
   |
   --TSqlMapStatement
      |
      --TSqlMapSelectKey

TSqlMapSelect corresponds to the <selectKey> element.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
boolean | getIsAfter ()
string | getProperty ()
string | getType ()
void | setExtends ( mixed $value)
void | setProperty ( string $value)
void | setType ( string $value)
Methods Inherited From TSqlMapStatement
TSqlMapStatement::createInstanceOf(), TSqlMapStatement::createInstanceOfListClass(), TSqlMapStatement::createInstanceOfResultClass(), TSqlMapStatement::getCache(), TSqlMapStatement::getCacheModel(), TSqlMapStatement::getExtends(), TSqlMapStatement::getID(), TSqlMapStatement::getListClass(), TSqlMapStatement::getParameterClass(), TSqlMapStatement::getParameterMap(), TSqlMapStatement::getResultClass(), TSqlMapStatement::getResultMap(), TSqlMapStatement::getSqlText(), TSqlMapStatement::initialize(), TSqlMapStatement::parameterMap(), TSqlMapStatement::resultMap(), TSqlMapStatement::setCache(), TSqlMapStatement::setCacheModel(), TSqlMapStatement::setExtends(), TSqlMapStatement::setID(), TSqlMapStatement::setInlineParameterMap(), TSqlMapStatement::setListClass(), TSqlMapStatement::setParameterClass(), TSqlMapStatement::setParameterMap(), TSqlMapStatement::setResultClass(), TSqlMapStatement::setResultMap(), TSqlMapStatement::setSqlText()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getIsAfter

public boolean getIsAfter ()

Output
boolean true if key is generated after insert command, false otherwise.
Exception

getProperty

public string getProperty ()

Output
string property name for the generated key.
Exception

getType

public string getType ()

Output
string select generated key type, 'post' or 'pre'.
Exception

setExtends

public void setExtends (mixed $value )

Input
mixed | $value
Output
Exception
throws | TSqlMapConfigurationException extends is unsupported.

setProperty

public void setProperty (string $value )

Input
string $value property name for the generated key.
Output
Exception

setType

public void setType (string $value )

Input
string $value select generated key type, 'post' or 'pre'.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapStatement

Class TSqlMapStatement (Class Overview)

TComponent
   |
   --TSqlMapStatement

Direct Known Sub-classes:

TSqlMapSelect , TSqlMapInsert , TSqlMapUpdate , TSqlMapSelectKey

TSqlMapStatement class corresponds to <statement> element.

Mapped Statements can hold any SQL statement and can use Parameter Maps and Result Maps for input and output.

The <statement> element is a general "catch all" element that can be used for any type of SQL statement. Generally it is a good idea to use one of the more specific statement-type elements. The more specific elements provided better error-checking and even more functionality. (For example, the insert statement can return a database-generated key.)

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected mixed | createInstanceOf ( TSqlMapTypeHandlerRegistry $registry, string $type, array $row) Create a new instance of a given type.
ArrayAccess | createInstanceOfListClass ( TSqlMapTypeHandlerRegistry $registry)
mixed | createInstanceOfResultClass ( TSqlMapTypeHandlerRegistry $registry, array $row) Create a new instance of result class.
TSqlMapCacheModel | getCache ()
string | getCacheModel ()
string | getExtends ()
string | getID ()
string | getListClass ()
string | getParameterClass ()
string | getParameterMap ()
string | getResultClass ()
string | getResultMap ()
TStaticSql | getSqlText ()
void | initialize ( TSqlMapManager $manager)
TParameterMap | parameterMap ()
TResultMap | resultMap ()
void | setCache ( TSqlMapCacheModel $value)
void | setCacheModel ( string $value)
void | setExtends ( string $value)
void | setID ( string $value)
void | setInlineParameterMap ( TInlineParameterMap $map)
void | setListClass ( string $value) An ArrayAccess class can be specified to handle the type of objects in the collection.
void | setParameterClass ( string $value) If a ParameterMap property is not specified, you may specify a ParameterClass instead and use inline parameters.
void | setParameterMap ( string $value) A Parameter Map defines an ordered list of values that match up with the "?" placeholders of a standard, parameterized query statement.
void | setResultClass ( string $value) If a ResultMap is not specified, you may specify a
void | setResultMap ( string $value) A Result Map lets you control how data is extracted from the result of a query, and how the columns are mapped to object properties.
void | setSqlText ( TStaticSql $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createInstanceOf

protected mixed createInstanceOf (TSqlMapTypeHandlerRegistry $registry , string $type , array $row )

Create a new instance of a given type.

Input
TSqlMapTypeHandlerRegistry | $registry | type handler registry
string | $type | result class name.
array | $row | result data.
Output
mixed | result object.
Exception

createInstanceOfListClass

public ArrayAccess createInstanceOfListClass (TSqlMapTypeHandlerRegistry $registry )

Input
TSqlMapTypeHandlerRegistry | $registry | type handler registry
Output
ArrayAccess | new instance of list class.
Exception

createInstanceOfResultClass

public mixed createInstanceOfResultClass (TSqlMapTypeHandlerRegistry $registry , array $row )

Create a new instance of result class.

Input
TSqlMapTypeHandlerRegistry | $registry | type handler registry
array | $row | result data.
Output
mixed | result object.
Exception

getCache

public TSqlMapCacheModel getCache ()

Output
TSqlMapCacheModel cache implementation instance for this statement.
Exception

getCacheModel

public string getCacheModel ()

Output
string cache mode name.
Exception

getExtends

public string getExtends ()

Output
string another statement element name.
Exception

getID

public string getID ()

Output
string name for this statement, unique to each sql map manager.
Exception

getListClass

public string getListClass ()

Output
string name of a PHP class that implements ArrayAccess.
Exception

getParameterClass

public string getParameterClass ()

Output
string parameter class name.
Exception

getParameterMap

public string getParameterMap ()

Output
string name of a parameter map.
Exception

getResultClass

public string getResultClass ()

Output
string result class name.
Exception

getResultMap

public string getResultMap ()

Output
string result map name.
Exception

getSqlText

public TStaticSql getSqlText ()

Output
TStaticSql sql text container.
Exception

initialize

public void initialize (TSqlMapManager $manager )

Input
TSqlMapManager $manager initialize the statement, sets the result and parameter maps.
Output
Exception

parameterMap

public TParameterMap parameterMap ()

Output
TParameterMap the parameter map corresponding to the ParameterMap property.
Exception

resultMap

public TResultMap resultMap ()

Output
TResultMap the result map corresponding to the ResultMap property.
Exception

setCache

public void setCache (TSqlMapCacheModel $value )

Input
TSqlMapCacheModel $value cache implementation instance for this statement.
Output
Exception

setCacheModel

public void setCacheModel (string $value )

Input
string $value cache mode name.
Output
Exception

setExtends

public void setExtends (string $value )

Input
string $value name of another statement element to extend.
Output
Exception

setID

public void setID (string $value )

Input
string $value name for this statement, which must be unique for each sql map manager.
Output
Exception

setInlineParameterMap

public void setInlineParameterMap (TInlineParameterMap $map )

Input
TInlineParameterMap $map parameter extracted from the sql text.
Output
Exception

setListClass

public void setListClass (string $value )

An ArrayAccess class can be specified to handle the type of objects in the collection.

Input
string $value name of a PHP class that implements ArrayAccess.
Output
Exception

setParameterClass

public void setParameterClass (string $value )

If a ParameterMap property is not specified, you may specify a ParameterClass instead and use inline parameters.

The value of the parameterClass attribute can be any existing PHP class name.

Input
string $value parameter class name.
Output
Exception

setParameterMap

public void setParameterMap (string $value )

A Parameter Map defines an ordered list of values that match up with the "?" placeholders of a standard, parameterized query statement.

Input
string $value parameter map name.
Output
Exception

setResultClass

public void setResultClass (string $value )

If a ResultMap is not specified, you may specify a

ResultClass instead. The value of the ResultClass property can be the name of a PHP class or primitives like integer, string, or array. The class specified will be automatically mapped to the columns in the result, based on the result metadata.

Input
string $value result class name.
Output
Exception

setResultMap

public void setResultMap (string $value )

A Result Map lets you control how data is extracted from the result of a query, and how the columns are mapped to object properties.

Input
string $value result map name.
Output
Exception

setSqlText

public void setSqlText (TStaticSql $value )

Input
TStaticSql $value sql text container.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapUpdate

Class TSqlMapUpdate (Class Overview)

TComponent
   |
   --TSqlMapStatement
      |
      --TSqlMapUpdate

Direct Known Sub-classes:

TSqlMapDelete

TSqlMapUpdate class corresponds to <update> element.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
Methods Inherited From TSqlMapStatement
TSqlMapStatement::createInstanceOf(), TSqlMapStatement::createInstanceOfListClass(), TSqlMapStatement::createInstanceOfResultClass(), TSqlMapStatement::getCache(), TSqlMapStatement::getCacheModel(), TSqlMapStatement::getExtends(), TSqlMapStatement::getID(), TSqlMapStatement::getListClass(), TSqlMapStatement::getParameterClass(), TSqlMapStatement::getParameterMap(), TSqlMapStatement::getResultClass(), TSqlMapStatement::getResultMap(), TSqlMapStatement::getSqlText(), TSqlMapStatement::initialize(), TSqlMapStatement::parameterMap(), TSqlMapStatement::resultMap(), TSqlMapStatement::setCache(), TSqlMapStatement::setCacheModel(), TSqlMapStatement::setExtends(), TSqlMapStatement::setID(), TSqlMapStatement::setInlineParameterMap(), TSqlMapStatement::setListClass(), TSqlMapStatement::setParameterClass(), TSqlMapStatement::setParameterMap(), TSqlMapStatement::setResultClass(), TSqlMapStatement::setResultMap(), TSqlMapStatement::setSqlText()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()


PRADO API Manual: Docs For Class TSqlMapXmlConfigBuilder

Class TSqlMapXmlConfigBuilder (Class Overview)

Direct Known Sub-classes:

                                    TSqlMapXmlConfiguration
                                                , TSqlMapXmlMappingConfiguration

TSqlMapXmlConfig class file.

            Author:
            Wei Zhuo <weizhuo[at]gmail[dot]com>

Method Summary
protected Object | createObjectFromNode ( SimpleXmlNode $node) Create an instance of an object give by the attribute named 'class' in the node and set the properties on the object given by attribute names and values.
protected string | getAbsoluteFilePath ( string $basefile, string $resource) Gets the filename relative to the basefile.
protected abstract string | getConfigFile ()
protected SimpleXmlElement | getElementByIdValue ( SimpleXmlDocument $document, string $tag, string $value) Get element node by ID value (try for attribute name ID as case insensitive).
protected SimpleXmlElement | loadXmlDocument ( string $filename, TSqlMapXmlConfiguration $config) Load document using simple xml.
protected void | setObjectPropFromNode ( Object $obj, SimpleXmlNode $node, array $except) For each attributes (excluding attribute named in $except) set the property of the $obj given by the name of the attribute with the value of the attribute.

            Method Details

createObjectFromNode

                                protected Object createObjectFromNode
                                (SimpleXmlNode $node )

Create an instance of an object give by the attribute named 'class' in the  node and set the properties on the object given by attribute names and values.

Input
SimpleXmlNode | $node | property node
Output
Object | new instance of class with class name given by 'class' attribute value.
Exception

getAbsoluteFilePath

                                protected string getAbsoluteFilePath
                                (string $basefile , string $resource )

Gets the filename relative to the basefile.

Input
string | $basefile | base filename
string | $resource | relative filename
Output
string | absolute filename.
Exception

getConfigFile

                                protected abstract string getConfigFile
                                ()

Output

                                    string
                 configuration file.

Exception

getElementByIdValue

                                protected SimpleXmlElement getElementByIdValue
                                (SimpleXmlDocument $document , string $tag , string $value )

Get element node by ID value (try for attribute name ID as case insensitive).

Input
SimpleXmlDocument | $document |
string | $tag | tag name.
string | $value | id value.
Output
SimpleXmlElement | node if found, null otherwise.
Exception

loadXmlDocument

                                protected SimpleXmlElement loadXmlDocument
                                (string $filename , TSqlMapXmlConfiguration $config )

Load document using simple xml.

Input
string | $filename | filename.
TSqlMapXmlConfiguration | $config |
Output
SimpleXmlElement | xml document.
Exception

setObjectPropFromNode

                                protected void setObjectPropFromNode
                                (Object $obj , SimpleXmlNode $node , array $except )

For each attributes (excluding attribute named in $except) set the  property of the $obj given by the name of the attribute with the value  of the attribute.

Input
Object | $obj | object instance
SimpleXmlNode | $node | property node
array | $except | exception property name
Output
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapXmlConfiguration

Class TSqlMapXmlConfiguration (Class Overview)

TSqlMapXmlConfigBuilder
   |
   --TSqlMapXmlConfiguration

TSqlMapXmlConfig class.

Configures the TSqlMapManager using xml configuration file.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Method Summary
protected void | attachCacheModels () Set the cache for each statement having a cache model property.
void | configure ( string $filename) Configure the TSqlMapManager using the given xml file.
protected void | getConfigFile ()
void | getManager ()
protected void | loadDatabaseConnection ( SimpleXmlElement $node) Load the database connection tag.
protected void | loadGlobalProperty ( SimpleXmlElement $node) Load global replacement property.
protected void | loadSqlMappingFiles ( unknown_type $node) Load SqlMap mapping configuration.
protected void | loadTypeHandler ( SimpleXmlElement $node) Load the type handler configurations.
string | replaceProperties ( string $string) Replace the place holders ${name} in text with properties the corresponding global property value.
protected void | resolveResultMapping () Resolve nest result mappings.
Methods Inherited From TSqlMapXmlConfigBuilder
TSqlMapXmlConfigBuilder::createObjectFromNode(), TSqlMapXmlConfigBuilder::getAbsoluteFilePath(), TSqlMapXmlConfigBuilder::getElementByIdValue(), TSqlMapXmlConfigBuilder::loadXmlDocument(), TSqlMapXmlConfigBuilder::setObjectPropFromNode()
Constructor Details

__construct

public __construct Array

Method Details

attachCacheModels

protected void attachCacheModels ()

Set the cache for each statement having a cache model property.

Output
Exception

configure

public void configure (string $filename )

Configure the TSqlMapManager using the given xml file.

Input
string $filename SqlMap configuration xml file.
Output
Exception

getConfigFile

protected void getConfigFile ()

Output
Exception

getManager

public void getManager ()

Output
Exception

loadDatabaseConnection

protected void loadDatabaseConnection (SimpleXmlElement $node )

Load the database connection tag.

Input
SimpleXmlElement $node connection node.
Output
Exception

loadGlobalProperty

protected void loadGlobalProperty (SimpleXmlElement $node )

Load global replacement property.

Input
SimpleXmlElement $node property node.
Output
Exception

loadSqlMappingFiles

protected void loadSqlMappingFiles (unknown_type $node )

Load SqlMap mapping configuration.

Input
unknown_type $node
Output
Exception

loadTypeHandler

protected void loadTypeHandler (SimpleXmlElement $node )

Load the type handler configurations.

Input
SimpleXmlElement $node type handler node
Output
Exception

replaceProperties

public string replaceProperties (string $string )

Replace the place holders ${name} in text with properties the corresponding global property value.

Input
string | $string | original string.
Output
string | string with global property replacement.
Exception

resolveResultMapping

protected void resolveResultMapping ()

Resolve nest result mappings.

Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapXmlMappingConfiguration

Class TSqlMapXmlMappingConfiguration (Class Overview)

TSqlMapXmlConfigBuilder
   |
   --TSqlMapXmlMappingConfiguration

Loads the statements, result maps, parameters maps from xml configuration.

description

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Method Summary
protected void | applyInlineParameterMap ( TSqlMapStatement $statement, string $sqlStatement, SimpleXmlElement $node) Extract inline parameter maps.
void | configure ( string $filename) Configure an XML mapping.
protected TSqlMapInsert | createInsertStatement ( SimpleXmlElement $node) Create new insert statement from xml node.
protected TParameterMap | createParameterMap ( SimpleXmlElement $node) Create a new parameter map from xml node.
protected TResultMap | createResultMap ( SimpleXmlElement $node) Create a new result map and its associated result properties, disciminiator and sub maps.
protected void | getConfigFile ()
protected void | loadCacheModel ( SimpleXmlElement $node) Load cache models from xml mapping.
protected void | loadDeleteTag ( SimpleXmlElement $node) Load delete statement from xml mapping.
protected void | loadFlushInterval ( TSqlMapCacheModel $cacheModel, SimpleXmlElement $node) Load the flush interval
protected void | loadFlushOnCache ( TSqlMapCacheModel $cacheModel, SimpleXmlElement $parent, SimpleXmlElement $node) Load the flush on cache properties.
protected void | loadInsertTag ( SimpleXmlElement $node) Load insert statement from xml mapping.
protected void | loadParameterMap ( SimpleXmlElement $node) Load parameter map from xml.
protected void | loadProcedureTag ( SimpleXmlElement $node) Load procedure statement from xml mapping.
protected void | loadResultMap ( SimpleXmlElement $node) Load the result maps.
protected void | loadSelectKeyTag ( SimpleXmlElement $insert, mixed $node) Load the selectKey statement from xml mapping.
protected void | loadSelectTag ( SimpleXmlElement $node) Load select statement from xml mapping.
protected void | loadStatementTag ( SimpleXmlElement $node) Load statement mapping from xml configuration file.
protected void | loadUpdateTag ( SimpleXmlElement $node) Load update statement from xml mapping.
protected void | prepareSql ( TSqlMapStatement $statement, string $sqlStatement, SimpleXmlElement $node) Prepare the sql text (may extend to dynamic sql).
protected void | processSqlStatement ( TSqlMapStatement $statement, SimpleXmlElement $node) Load extended SQL statements if application. Replaces global properties in the sql text. Extracts inline parameter maps.
protected void | registerCacheTriggers () Attach CacheModel to statement and register trigger statements for cache models
Methods Inherited From TSqlMapXmlConfigBuilder
TSqlMapXmlConfigBuilder::createObjectFromNode(), TSqlMapXmlConfigBuilder::getAbsoluteFilePath(), TSqlMapXmlConfigBuilder::getElementByIdValue(), TSqlMapXmlConfigBuilder::loadXmlDocument(), TSqlMapXmlConfigBuilder::setObjectPropFromNode()
Constant Summary
string | ESCAPED_INLINE_SYMBOL_REGEXP |
string | ESCAPED_SIMPLE_MARK_REGEXP |
string | INLINE_PLACEHOLDER |
string | INLINE_SYMBOL |
string | SIMPLE_MARK | Regular expressions for escaping simple/inline parameter symbols
string | SIMPLE_PLACEHOLDER |
Constructor Details

__construct

public __construct Array

Method Details

applyInlineParameterMap

protected void applyInlineParameterMap (TSqlMapStatement $statement , string $sqlStatement , SimpleXmlElement $node )

Extract inline parameter maps.

Input
TSqlMapStatement | $statement | statement object.
string | $sqlStatement | sql text
SimpleXmlElement | $node | statement node.
Output
Exception

configure

public void configure (string $filename )

Configure an XML mapping.

Input
string $filename xml mapping filename.
Output
Exception

createInsertStatement

protected TSqlMapInsert createInsertStatement (SimpleXmlElement $node )

Create new insert statement from xml node.

Input
SimpleXmlElement | $node | insert node.
Output
TSqlMapInsert | insert statement.
Exception

createParameterMap

protected TParameterMap createParameterMap (SimpleXmlElement $node )

Create a new parameter map from xml node.

Input
SimpleXmlElement | $node | parameter map node.
Output
TParameterMap | new parameter mapping.
Exception

createResultMap

protected TResultMap createResultMap (SimpleXmlElement $node )

Create a new result map and its associated result properties, disciminiator and sub maps.

Input
SimpleXmlElement | $node | result map node
Output
TResultMap | SqlMap result mapping.
Exception

getConfigFile

protected void getConfigFile ()

Output
Exception

loadCacheModel

protected void loadCacheModel (SimpleXmlElement $node )

Load cache models from xml mapping.

Input
SimpleXmlElement $node cache node.
Output
Exception

loadDeleteTag

protected void loadDeleteTag (SimpleXmlElement $node )

Load delete statement from xml mapping.

Input
SimpleXmlElement $node delete node.
Output
Exception

loadFlushInterval

protected void loadFlushInterval (TSqlMapCacheModel $cacheModel , SimpleXmlElement $node )

Load the flush interval

Input
TSqlMapCacheModel | $cacheModel | cache model
SimpleXmlElement | $node | cache node
Output
Exception

loadFlushOnCache

protected void loadFlushOnCache (TSqlMapCacheModel $cacheModel , SimpleXmlElement $parent , SimpleXmlElement $node )

Load the flush on cache properties.

Input
TSqlMapCacheModel | $cacheModel | cache model
SimpleXmlElement | $parent | parent node.
SimpleXmlElement | $node | flush node.
Output
Exception

loadInsertTag

protected void loadInsertTag (SimpleXmlElement $node )

Load insert statement from xml mapping.

Input
SimpleXmlElement $node insert node.
Output
Exception

loadParameterMap

protected void loadParameterMap (SimpleXmlElement $node )

Load parameter map from xml.

Input
SimpleXmlElement $node parameter map node.
Output
Exception

loadProcedureTag

protected void loadProcedureTag (SimpleXmlElement $node )

Load procedure statement from xml mapping.

Input
SimpleXmlElement $node procedure node
Output
Exception

loadResultMap

protected void loadResultMap (SimpleXmlElement $node )

Load the result maps.

Input
SimpleXmlElement $node result map node.
Output
Exception

loadSelectKeyTag

protected void loadSelectKeyTag (SimpleXmlElement $insert , mixed $node )

Load the selectKey statement from xml mapping.

Input
SimpleXmlElement | $insert | selectkey node
mixed | $node |
Output
Exception

loadSelectTag

protected void loadSelectTag (SimpleXmlElement $node )

Load select statement from xml mapping.

Input
SimpleXmlElement $node select node.
Output
Exception

loadStatementTag

protected void loadStatementTag (SimpleXmlElement $node )

Load statement mapping from xml configuration file.

Input
SimpleXmlElement $node statement node.
Output
Exception

loadUpdateTag

protected void loadUpdateTag (SimpleXmlElement $node )

Load update statement from xml mapping.

Input
SimpleXmlElement $node update node.
Output
Exception

prepareSql

protected void prepareSql (TSqlMapStatement $statement , string $sqlStatement , SimpleXmlElement $node )

Prepare the sql text (may extend to dynamic sql).

Input
TSqlMapStatement | $statement | mapped statement.
string | $sqlStatement | sql text.
SimpleXmlElement | $node | statement node.
Output
Exception

processSqlStatement

protected void processSqlStatement (TSqlMapStatement $statement , SimpleXmlElement $node )

Load extended SQL statements if application. Replaces global properties in the sql text. Extracts inline parameter maps.

Input
TSqlMapStatement | $statement | mapped statement.
SimpleXmlElement | $node | statement node.
Output
Exception

registerCacheTriggers

protected void registerCacheTriggers ()

Attach CacheModel to statement and register trigger statements for cache models

Output
Exception

Constant Details

ESCAPED_INLINE_SYMBOL_REGEXP

Type:

string

Value:

'/\#\#/'

ESCAPED_SIMPLE_MARK_REGEXP

Type:

string

Value:

'/\$\$/'

INLINE_PLACEHOLDER

Type:

string

Value:

'`!!!`'

INLINE_SYMBOL

Type:

string

Value:

'#'

SIMPLE_MARK

Regular expressions for escaping simple/inline parameter symbols

Type:

string

Value:

'$'

SIMPLE_PLACEHOLDER

Type:

string

Value:

'`!!`'


PRADO API Manual: Docs For Class TErrorHandler

Class TErrorHandler (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TErrorHandler

Direct Known Sub-classes:

TCallbackErrorHandler

TErrorHandler class

TErrorHandler handles all PHP user errors and exceptions generated during servicing user requests. It displays these errors using different templates and if possible, using languages preferred by the client user. Note, PHP parsing errors cannot be caught and handled by TErrorHandler.

The templates used to format the error output are stored under System.Exceptions. You may choose to use your own templates, should you not like the templates provided by Prado. Simply set ErrorTemplatePath to the path (in namespace format) storing your own templates.

There are two sets of templates, one for errors to be displayed to client users (called external errors), one for errors to be displayed to system developers (called internal errors). The template file name for the former is error[StatusCode][-LanguageCode].html, and for the latter it is exception[-LanguageCode].html, where StatusCode refers to response status code (e.g. 404, 500) specified when THttpException is thrown, and LanguageCode is the client user preferred language code (e.g. en, zh, de). The templates error.html and exception.html are default ones that are used if no other appropriate templates are available. Note, these templates are not Prado control templates. They are simply html files with keywords (e.g. %%ErrorMessage%%, %%Version%%) to be replaced with the corresponding information.

By default, TErrorHandler is registered with TApplication as the error handler module. It can be accessed via TApplication::getErrorHandler(). You seldom need to deal with the error handler directly. It is mainly used by the application object to handle errors.

TErrorHandler may be configured in application configuration file as follows <module id="error" class="TErrorHandler" ErrorTemplatePath="System.Exceptions" />

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected void | displayException ( Exception $exception) Displays exception information.
protected string | getErrorTemplate ( integer $statusCode, Exception $exception) Retrieves the template used for displaying external exceptions.
string | getErrorTemplatePath ()
protected string | getExceptionTemplate ( Exception $exception) Retrieves the template used for displaying internal exceptions.
void | handleError ( mixed $sender, mixed $param) Handles PHP user errors and exceptions.
protected void | handleExternalError ( integer $statusCode, Exception $exception) Displays error to the client user.
protected void | handleRecursiveError ( Exception $exception) Handles error occurs during error handling (called recursive error).
protected string | hideSecurityRelated ( string $value, Exception|null$exception $exception)
void | init ( TXmlElement $config) Initializes the module.
void | setErrorTemplatePath ( string $value) Sets the path storing all error and exception template files.
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | ERROR_FILE_NAME | error template file basename
string | EXCEPTION_FILE_NAME | exception template file basename
int | SOURCE_LINES | number of lines before and after the error line to be displayed in case of an exception
Method Details

displayException

protected void displayException (Exception $exception )

Displays exception information.

Exceptions are displayed with rich context information, including the call stack and the context source code. This method is only invoked when application is in Debug mode.

Input
Exception $exception exception instance
Output
Exception

getErrorTemplate

protected string getErrorTemplate (integer $statusCode , Exception $exception )

Retrieves the template used for displaying external exceptions.

External exceptions are those displayed to end-users. They do not contain error source code. Therefore, you might want to override this method to provide your own error template for displaying certain external exceptions. The following tokens in the template will be replaced with corresponding content: %%StatusCode%% : the status code of the exception %%ErrorMessage%% : the error message (HTML encoded). %%ServerAdmin%% : the server admin information (retrieved from Web server configuration) %%Version%% : the version information of the Web server. %%Time%% : the time the exception occurs at

Input
integer | $statusCode | status code (such as 404, 500, etc.)
Exception | $exception | the exception to be displayed
Output
string | the template content
Exception

getErrorTemplatePath

public string getErrorTemplatePath ()

Output
string the directory containing error template files.
Exception

getExceptionTemplate

protected string getExceptionTemplate (Exception $exception )

Retrieves the template used for displaying internal exceptions.

Internal exceptions will be displayed with source code causing the exception. This occurs when the application is in debug mode.

Input
Exception | $exception | the exception to be displayed
Output
string | the template content
Exception

handleError

public void handleError (mixed $sender , mixed $param )

Handles PHP user errors and exceptions.

This is the event handler responding to the Error event raised in TApplication. The method mainly uses appropriate template to display the error/exception. It terminates the application immediately after the error is displayed.

Input
mixed | $sender | sender of the event
mixed | $param | event parameter (if the event is raised by TApplication, it refers to the exception instance)
Output
Exception

handleExternalError

protected void handleExternalError (integer $statusCode , Exception $exception )

Displays error to the client user.

THttpException and errors happened when the application is in Debug mode will be displayed to the client user.

Input
integer | $statusCode | response status code
Exception | $exception | exception instance
Output
Exception

handleRecursiveError

protected void handleRecursiveError (Exception $exception )

Handles error occurs during error handling (called recursive error).

THttpException and errors happened when the application is in Debug mode will be displayed to the client user. Error is displayed without using existing template to prevent further errors.

Input
Exception $exception exception instance
Output
Exception

hideSecurityRelated

protected string hideSecurityRelated (string $value , Exception|null$exception $exception )

Input
string | $value
Exception|null$exception | $exception
Output
Exception

init

public void init (TXmlElement $config )

Initializes the module.

This method is required by IModule and is invoked by application.

Input
TXmlElement $config module configuration
Output
Exception

setErrorTemplatePath

public void setErrorTemplatePath (string $value )

Sets the path storing all error and exception template files.

The path must be in namespace format, such as System.Exceptions (which is the default).

Input
string | $value | template path in namespace format
Output
Exception
throws | TConfigurationException if the template path is invalid
Constant Details

ERROR_FILE_NAME

error template file basename

Type:

string

Value:

'error'

EXCEPTION_FILE_NAME

exception template file basename

Type:

string

Value:

'exception'

SOURCE_LINES

number of lines before and after the error line to be displayed in case of an exception

Type:

int

Value:

12


PRADO API Manual: Docs For Class TApplicationException

Class TApplicationException (Class Overview)

Exception
   |
   --TException
      |
      --TApplicationException

TApplicationException class

TApplicationException is the base class for all user application-level exceptions.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TConfigurationException

Class TConfigurationException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException
         |
         --TConfigurationException

Direct Known Sub-classes:

TTemplateException

TConfigurationException class

TConfigurationException represents an exception caused by invalid configurations, such as error in an application configuration file or control template file.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TDbConnectionException

Class TDbConnectionException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException
         |
         --TDbException
            |
            --TDbConnectionException

TDbConnectionException class

TDbConnectionException represents an exception caused by DB connection failure.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TDbException

Class TDbException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException
         |
         --TDbException

Direct Known Sub-classes:

TActiveRecordException , TDbConnectionException

TDbException class

TDbException represents an exception related with DB operations.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TException

Class TException (Class Overview)

Exception
   |
   --TException

Direct Known Sub-classes:

TSqlMapException , TSystemException , TApplicationException , TInvalidCallbackException

TException class

TException is the base class for all PRADO exceptions.

TException provides the functionality of translating an error code into a descriptive error message in a language that is preferred by user browser. Additional parameters may be passed together with the error code so that the translated message contains more detailed information.

By default, TException looks for a message file by calling getErrorMessageFile() method, which uses the "message-xx.txt" file located under "System.Exceptions" folder, where "xx" is the code of the user preferred language. If such a file is not found, "message.txt" will be used instead.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
string | getErrorCode ()
string | getErrorMessage ()
protected string | getErrorMessageFile ()
void | setErrorCode ( string $code)
protected void | setErrorMessage ( string $message)
protected string | translateErrorMessage ( string $key) Translates an error code into an error message.
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getErrorCode

public string getErrorCode ()

Output
string error code
Exception

getErrorMessage

public string getErrorMessage ()

Output
string error message
Exception

getErrorMessageFile

protected string getErrorMessageFile ()

Output
string path to the error message file
Exception

setErrorCode

public void setErrorCode (string $code )

Input
string $code error code
Output
Exception

setErrorMessage

protected void setErrorMessage (string $message )

Input
string $message error message
Output
Exception

translateErrorMessage

protected string translateErrorMessage (string $key )

Translates an error code into an error message.

Input
string | $key | error code that is passed in the exception constructor.
Output
string | the translated error message
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class THttpException

Class THttpException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException
         |
         --THttpException

THttpException class

THttpException represents an exception that is caused by invalid operations of end-users. The StatusCode gives the type of HTTP error. It is used by TErrorHandler to provide different error output to users.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
integer
getStatusCode ()
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getStatusCode

public integer getStatusCode ()

Output
integer HTTP status code, such as 404, 500, etc.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TInvalidDataTypeException

Class TInvalidDataTypeException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException
         |
         --TInvalidDataTypeException

TInvalidDataTypeException class

TInvalidDataTypeException represents an exception caused by invalid data type.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TInvalidDataValueException

Class TInvalidDataValueException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException
         |
         --TInvalidDataValueException

TInvalidDataValueException class

TInvalidDataValueException represents an exception caused by invalid data value.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TInvalidOperationException

Class TInvalidOperationException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException
         |
         --TInvalidOperationException

TInvalidOperationException class

TInvalidOperationException represents an exception caused by invalid operations.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TIOException

Class TIOException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException
         |
         --TIOException

TIOException class

TIOException represents an exception related with improper IO operations.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TNotSupportedException

Class TNotSupportedException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException
         |
         --TNotSupportedException

TNotSupportedException class

TNotSupportedException represents an exception caused by using an unsupported PRADO feature.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TPhpErrorException

Class TPhpErrorException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException
         |
         --TPhpErrorException

TPhpErrorException class

TPhpErrorException represents an exception caused by a PHP error. This exception is mainly thrown within a PHP error handler.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()
Constructor Details

__construct

public __construct Array

Constructor.


PRADO API Manual: Docs For Class TSystemException

Class TSystemException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException

Direct Known Sub-classes:

TInvalidOperationException , TInvalidDataTypeException , TInvalidDataValueException , TConfigurationException , TIOException , TDbException , TNotSupportedException , TPhpErrorException , THttpException

TSystemException class

TSystemException is the base class for all framework-level exceptions.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TTemplateException

Class TTemplateException (Class Overview)

Exception
   |
   --TException
      |
      --TSystemException
         |
         --TConfigurationException
            |
            --TTemplateException

TTemplateException class

TTemplateException represents an exception caused by invalid template syntax.

Since: 3.1
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
integer | getLineNumber ()
string | getTemplateFile ()
string | getTemplateSource ()
void | setLineNumber ( integer $value)
void | setTemplateFile ( string $value)
void | setTemplateSource ( string $value)
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()
Method Details

getLineNumber

public integer getLineNumber ()

Output
integer the line number at which the template has error
Exception

getTemplateFile

public string getTemplateFile ()

Output
string the template file that causes the exception. This could be empty if the template is an embedded template. In this case, use TemplateSource to obtain the actual template content.
Exception

getTemplateSource

public string getTemplateSource ()

Output
string the template source code that causes the exception. This is empty if TemplateFile is not empty.
Exception

setLineNumber

public void setLineNumber (integer $value )

Input
integer $value the line number at which the template has error
Output
Exception

setTemplateFile

public void setTemplateFile (string $value )

Input
string $value the template file that causes the exception
Output
Exception

setTemplateSource

public void setTemplateSource (string $value )

Input
string $value the template source code that causes the exception
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IFeedContentProvider

Interface IFeedContentProvider (Class Overview)

IFeedContentProvider interface.

IFeedContentProvider interface must be implemented by a feed class who  provides feed content.

            Since:
            3.1

            Author:
            Qiang Xue <qiang.xue@gmail.com>

            Author:
            Knut Urdalen <knut.urdalen@gmail.com>

Method Summary
string | getContentType () Sets the content type of the feed content to be sent.
string | getFeedContent ()
void | init ( TXmlElement $config) Initializes the feed content provider.

            Method Details

getContentType

                                public string getContentType
                                ()

Sets the content type of the feed content to be sent.

Some examples are:  RSS 1.0 feed: application/rdf+xml  RSS 2.0 feed: application/rss+xml or application/xml or text/xml  ATOM feed: application/atom+xml

Output

                                    string
                 the content type for the feed content.

Exception

getFeedContent

                                public string getFeedContent
                                ()

Output

                                    string
                 feed content in proper XML format

Exception

init

                                public void init
                                (TXmlElement $config )

Initializes the feed content provider.

This method is invoked (before getFeedContent)  when the feed provider is requested by a user.

Input

TXmlElement $config configurations specified within the &lt;feed&gt; element  corresponding to this feed provider when configuring TFeedService.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TFeedService

Class TFeedService (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TService
         |
         --TFeedService

TFeedService class

TFeedService provides to end-users feed content.

TFeedService manages a set of feeds. The service parameter, referring to the ID of the feed, specifies which feed content to be provided to end-users.

To use TFeedService, configure it in application configuration as follows,

1       <service id="feed" class="System.Web.Services.TFeedService">
2         <feed id="ch1" class="Path.To.FeedClass1" .../>
3         <feed id="ch2" class="Path.To.FeedClass2" .../>
4         <feed id="ch3" class="Path.To.FeedClass3" .../>
5       </service>
where each &lt;feed&gt; element specifies a feed identified by its "id" value (case-sensitive). The class attribute indicates which PHP class will provide the actual feed content. Note, the class must implement IFeedContentProvider interface. Other initial properties for the feed class may also be specified in the corresponding &lt;feed&gt; element.

To retrieve the feed content identified by "ch2", use the URL

1     /path/to/index.php?feed=ch2

Since: 3.1
Author: Qiang Xue <qiang.xue@gmail.com>
Author: Knut Urdalen <knut.urdalen@gmail.com>
Method Summary
protected string | determineRequestedFeedPath ()
void | init ( TXmlElement $config) Initializes this module.
void | run () Runs the service.
Methods Inherited From TService
TService::getEnabled(), TService::getID(), TService::init(), TService::run(), TService::setEnabled(), TService::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

determineRequestedFeedPath

protected string determineRequestedFeedPath ()

Output
string the requested feed path
Exception

init

public void init (TXmlElement $config )

Initializes this module.

This method is required by the IModule interface.

Input
TXmlElement $config configuration for this module, can be null
Output
Exception

run

public void run ()

Runs the service.

This method is invoked by application automatically.

Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TJsonResponse

Class TJsonResponse (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TJsonResponse

TJsonResponse Class

TJsonResponse is the base class for all JSON response provider classes.

Derived classes must implement getJsonContent() to return an object or literals to be converted to JSON format. The response will be empty if the returned content is null.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
string | getID ()
abstract object json | getJsonContent ()
void | init ( TXmlElement $config) Initializes the feed.
void | setID ( string $value)
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

getID

public string getID ()

Output
string ID of this response
Exception

getJsonContent

public abstract object json getJsonContent ()

Output
object json response content, null to suppress output.
Exception

init

public void init (TXmlElement $config )

Initializes the feed.

Input
TXmlElement $config configurations specified in TJsonService.
Output
Exception

setID

public void setID (string $value )

Input
string $value ID of this response
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TJsonService

Class TJsonService (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TService
         |
         --TJsonService

TJsonService class provides to end-users javascript content response in JSON format.

TJsonService manages a set of TJsonResponse, each representing specific response with javascript content. The service parameter, referring to the ID of the service, specifies which javascript content to be provided to end-users.

To use TJsonService, configure it in application configuration as follows,

1       <service id="json" class="System.Web.Services.TJsonService">
2         <json id="get_article" class="Path.To.JsonResponseClass1" .../>
3         <json id="register_rating" class="Path.To.JsonResponseClass2" .../>
4       </service>
where each JSON response is specified via a &lt;json&gt; element. Initial property values can be configured in a &lt;json&gt; element.

To retrieve the JSON content provided by "get_article", use the URL

1     index.php?json=get_article

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
protected void | createJsonResponse ( mixed $service, mixed $properties, mixed $config) Renders content provided by TJsonResponse::getJsonContent() as javascript in JSON format.
void | init ( TXmlElement $xml) Initializes this module.
protected void | loadJsonServices ( TXmlElement $xml) Load the service definitions.
void | run () Runs the service.
Methods Inherited From TService
TService::getEnabled(), TService::getID(), TService::init(), TService::run(), TService::setEnabled(), TService::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createJsonResponse

protected void createJsonResponse (mixed $service , mixed $properties , mixed $config )

Renders content provided by TJsonResponse::getJsonContent() as javascript in JSON format.

Input
mixed | $service
mixed | $properties
mixed | $config
Output
Exception

init

public void init (TXmlElement $xml )

Initializes this module.

This method is required by the IModule interface.

Input
TXmlElement $xml configuration for this module, can be null
Output
Exception

loadJsonServices

protected void loadJsonServices (TXmlElement $xml )

Load the service definitions.

Input
TXmlElement $xml configuration for this module, can be null
Output
Exception

run

public void run ()

Runs the service.

This method is invoked by application automatically.

Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPageConfiguration

Class TPageConfiguration (Class Overview)

TComponent
   |
   --TPageConfiguration

TPageConfiguration class

TPageConfiguration represents the configuration for a page. The page is specified by a dot-connected path. Configurations along this path are merged together to be provided for the page.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
array | getApplicationConfigurations ()
array | getExternalConfigurations ()
array | getProperties () Returns list of page initial property values.
TAuthorizationRuleCollection | getRules () Returns list of authorization rules.
void | loadApplicationConfigurationFromXml ( TXmlElement $dom, string $configPath) Loads the configuration specific for application part
void | loadFromFile ( string $fname, string $configPagePath) Loads a specific config file.
void | loadFromFiles ( string $basePath) Loads configuration for a page specified in a path format.
void | loadFromXml ( TXmlElement $dom, string $configPath, string $configPagePath) Loads a page configuration.
void | loadPageConfigurationFromXml ( TXmlElement $dom, string $configPath, string $configPagePath) Loads the configuration specific for page service.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getApplicationConfigurations

public array getApplicationConfigurations ()

Output
array list of application configurations specified along page path
Exception

getExternalConfigurations

public array getExternalConfigurations ()

Output
array list of external configuration files. Each element is like $filePath=>$condition
Exception

getProperties

public array getProperties ()

Returns list of page initial property values.

Each array element represents a single property with the key being the property name and the value the initial property value.

Output
array list of page initial property values
Exception

getRules

public TAuthorizationRuleCollection getRules ()

Returns list of authorization rules.

The authorization rules are aggregated (bottom-up) from configuration files along the path to the specified page.

Output
TAuthorizationRuleCollection collection of authorization rules
Exception

loadApplicationConfigurationFromXml

public void loadApplicationConfigurationFromXml (TXmlElement $dom , string $configPath )

Loads the configuration specific for application part

Input
TXmlElement | $dom | config xml element
string | $configPath | base path corresponding to this xml element
Output
Exception

loadFromFile

public void loadFromFile (string $fname , string $configPagePath )

Loads a specific config file.

Input
string | $fname | config file name
string | $configPagePath | the page path that the config file is associated with. The page path doesn't include the page name.
Output
Exception

loadFromFiles

public void loadFromFiles (string $basePath )

Loads configuration for a page specified in a path format.

Input
string $basePath root path for pages
Output
Exception

loadFromXml

public void loadFromXml (TXmlElement $dom , string $configPath , string $configPagePath )

Loads a page configuration.

The configuration includes information for both application and page service.

Input
TXmlElement | $dom | config xml element
string | $configPath | the directory containing this configuration
string | $configPagePath | the page path that the config XML is associated with. The page path doesn't include the page name.
Output
Exception

loadPageConfigurationFromXml

public void loadPageConfigurationFromXml (TXmlElement $dom , string $configPath , string $configPagePath )

Loads the configuration specific for page service.

Input
TXmlElement | $dom | config xml element
string | $configPath | base path corresponding to this xml element
string | $configPagePath | the page path that the config XML is associated with. The page path doesn't include the page name.
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPageService

Class TPageService (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TService
         |
         --TPageService

TPageService class.

TPageService implements the service for serving user page requests.

Pages that are available to client users are stored under a directory specified by BasePath. The directory may contain subdirectories. Pages serving for a similar goal are usually placed under the same directory. A directory may contain a configuration file config.xml whose content is similar to that of application configuration file.

A page is requested via page path, which is a dot-connected directory names appended by the page name. Assume '<BasePath>/Users/Admin' is the directory containing the page 'Update'. Then the page can be requested via 'Users.Admin.Update'. By default, the BasePath of the page service is the "pages" directory under the application base path. You may change this default by setting BasePath with a different path you prefer.

Page name refers to the file name (without extension) of the page template. In order to differentiate from the common control template files, the extension name of the page template files must be '.page'. If there is a PHP file with the same page name under the same directory as the template file, that file will be considered as the page class file and the file name is the page class name. If such a file is not found, the page class is assumed as TPage.

Modules can be configured and loaded in page directory configurations. Configuration of a module in a subdirectory will overwrite its parent directory's configuration, if both configurations refer to the same module.

By default, TPageService will automatically load two modules:

  • TTemplateManager : manages page and control templates
  • TThemeManager : manages themes used in a Prado application
In page directory configurations, static authorization rules can also be specified, which governs who and which roles can access particular pages. Refer to TAuthorizationRule for more details about authorization rules. Page authorization rules can be configured within an <authorization> tag in each page directory configuration as follows, <authorization> <deny pages="Update" users="?" /> <allow pages="Admin" roles="administrator" /> <deny pages="Admin" users="*" /> </authorization> where the 'pages' attribute may be filled with a sequence of comma-separated page IDs. If 'pages' attribute does not appear in a rule, the rule will be applied to all pages in this directory and all subdirectories (recursively). Application of authorization rules are in a bottom-up fashion, starting from the directory containing the requested page up to all parent directories. The first matching rule will be used. The last rule always allows all users accessing to any resources.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected void | applyConfiguration ( TPageConfiguration $config) Applies a page configuration.
string | constructUrl ( string $pagePath, array $getParams, boolean $encodeAmpersand, boolean $encodeGetItems) Constructs a URL with specified page path and GET parameters.
protected TPage | createPage ( string $pagePath) Creates a page instance based on requested page path.
protected string | determineRequestedPagePath () Determines the requested page path.
string | getBasePageClass ()
string | getBasePath ()
string | getClientScriptManagerClass ()
string | getDefaultPage ()
string | getDefaultPageUrl ()
TPage | getRequestedPage ()
string | getRequestedPagePath ()
TTemplateManager | getTemplateManager ()
TThemeManager | getThemeManager ()
void | init ( TXmlElement $config) Initializes the service.
protected void | initPageContext ( TPageConfiguration $pageConfig) Initializes page context.
protected TPageConfiguration | loadPageConfig ( TXmlElement $config) Collects configuration for a page.
void | run () Runs the service.
protected void | runPage ( TPage $page, array $properties) Executes a page.
void | setBasePageClass ( string $value) Sets the base page class name (in namespace format).
void | setBasePath ( string $value)
void | setClientScriptManagerClass ( string $value) Sets the clientscript manager class (in namespace format).
void | setDefaultPage ( string $value)
void | setTemplateManager ( TTemplateManager $value)
void | setThemeManager ( TThemeManager $value)
Methods Inherited From TService
TService::getEnabled(), TService::getID(), TService::init(), TService::run(), TService::setEnabled(), TService::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | CONFIG_CACHE_PREFIX | Prefix of ID used for storing parsed configuration in cache
string | CONFIG_FILE | Configuration file name
string | DEFAULT_BASEPATH | Default base path
string | PAGE_FILE_EXT | Page template file extension
Method Details

applyConfiguration

protected void applyConfiguration (TPageConfiguration $config )

Applies a page configuration.

Input
TPageConfiguration $config the configuration
Output
Exception

constructUrl

public string constructUrl (string $pagePath , array $getParams , boolean $encodeAmpersand , boolean $encodeGetItems )

Constructs a URL with specified page path and GET parameters.

Input
string | $pagePath | page path
array | $getParams | list of GET parameters, null if no GET parameters required
boolean | $encodeAmpersand | whether to encode the ampersand in URL, defaults to true.
boolean | $encodeGetItems | whether to encode the GET parameters (their names and values), defaults to true.
Output
string | URL for the page and GET parameters
Exception

createPage

protected TPage createPage (string $pagePath )

Creates a page instance based on requested page path.

Input
string | $pagePath | requested page path
Output
TPage | the requested page instance
Exception
throws | THttpException if requested page path is invalid
throws | TConfigurationException if the page class cannot be found

determineRequestedPagePath

protected string determineRequestedPagePath ()

Determines the requested page path.

Output
string page path requested
Exception

getBasePageClass

public string getBasePageClass ()

Output
string base page class name in namespace format. Defaults to 'TPage'.
Exception

getBasePath

public string getBasePath ()

Output
string the root directory for storing pages. Defaults to the 'pages' directory under the application base path.
Exception

getClientScriptManagerClass

public string getClientScriptManagerClass ()

Output
string clientscript manager class in namespace format. Defaults to 'System.Web.UI.TClientScriptManager'.
Exception

getDefaultPage

public string getDefaultPage ()

Output
string default page path to be served if no explicit page is request. Defaults to 'Home'.
Exception

getDefaultPageUrl

public string getDefaultPageUrl ()

Output
string the URL for the default page
Exception

getRequestedPage

public TPage getRequestedPage ()

Output
TPage the requested page
Exception

getRequestedPagePath

public string getRequestedPagePath ()

Output
string the requested page path
Exception

getTemplateManager

public TTemplateManager getTemplateManager ()

Output
TTemplateManager template manager
Exception

getThemeManager

public TThemeManager getThemeManager ()

Output
TThemeManager theme manager
Exception

init

public void init (TXmlElement $config )

Initializes the service.

This method is required by IService interface and is invoked by application.

Input
TXmlElement $config service configuration
Output
Exception

initPageContext

protected void initPageContext (TPageConfiguration $pageConfig )

Initializes page context.

Page context includes path alias settings, namespace usages, parameter initialization, module loadings, page initial properties and authorization rules.

Input
TPageConfiguration $pageConfig
Output
Exception

loadPageConfig

protected TPageConfiguration loadPageConfig (TXmlElement $config )

Collects configuration for a page.

Input
TXmlElement $config additional configuration specified in the application configuration
Output
Exception

run

public void run ()

Runs the service.

This will create the requested page, initializes it with the property values specified in the configuration, and executes the page.

Output
Exception

runPage

protected void runPage (TPage $page , array $properties )

Executes a page.

Input
TPage | $page | the page instance to be run
array | $properties | list of initial page properties
Output
Exception

setBasePageClass

public void setBasePageClass (string $value )

Sets the base page class name (in namespace format).

If a page only has a template file without page class file, this base page class will be instantiated.

Input
string $value class name
Output
Exception

setBasePath

public void setBasePath (string $value )

Input
string | $value | root directory (in namespace form) storing pages
Output
Exception
throws | TInvalidOperationException if the service is initialized already or basepath is invalid

setClientScriptManagerClass

public void setClientScriptManagerClass (string $value )

Sets the clientscript manager class (in namespace format).

Input
string $value class name
Output
Exception

setDefaultPage

public void setDefaultPage (string $value )

Input
string | $value | default page path to be served if no explicit page is request
Output
Exception
throws | TInvalidOperationException if the page service is initialized

setTemplateManager

public void setTemplateManager (TTemplateManager $value )

Input
TTemplateManager $value template manager
Output
Exception

setThemeManager

public void setThemeManager (TThemeManager $value )

Input
TThemeManager $value theme manager
Output
Exception

Constant Details

CONFIG_CACHE_PREFIX

Prefix of ID used for storing parsed configuration in cache

Type:

string

Value:

'prado:pageservice:'

CONFIG_FILE

Configuration file name

Type:

string

Value:

'config.xml'

DEFAULT_BASEPATH

Default base path

Type:

string

Value:

'pages'

PAGE_FILE_EXT

Page template file extension

Type:

string

Value:

'.page'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSoapServer

Class TSoapServer (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TSoapServer

TSoapServer class.

TSoapServer is a wrapper of the PHP SoapServer class. It associates a SOAP provider class to the SoapServer object. It also manages the URI for the SOAP service and WSDL.

Since: 3.1
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
protected SoapServer | createServer () Creates the SoapServer instance.
void | fault ( string $title, mixed $details, string $code, string $actor, string $name) Generate a SOAP fault message.
string | getActor ()
string | getClassMaps ()
string | getEncoding ()
string | getID ()
protected array | getOptions ()
string | getProvider ()
string | getRequestedMethod () Soap method guessed from the SOAP message received.
boolean | getSessionPersistent ()
string | getUri ()
string | getVersion ()
string | getWsdl () Returns the WSDL content of the SOAP server.
string | getWsdlUri ()
protected void | guessMethodCallRequested ( string $class) Guess the SOAP method request from the actual SOAP message
void | run () Handles the SOAP request.
void | setActor ( string $value)
string | setClassMaps ( mixed $classes)
void | setEncoding ( string $value)
void | setID ( string $id)
void | setProvider ( string $provider)
void | setSessionPersistent ( boolean $value)
void | setUri ( string $uri)
void | setVersion ( string $value)
void | setWsdlUri ( string $value)
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string WSDL_CACHE_PREFIX
Method Details

createServer

protected SoapServer createServer ()

Creates the SoapServer instance.

Output
Exception

fault

public void fault (string $title , mixed $details , string $code , string $actor , string $name )

Generate a SOAP fault message.

Input
string | $title | message title
mixed | $details | message details
string | $code | message code, defalt is 'SERVER'.
string | $actor | actors
string | $name | message name
Output
Exception

getActor

public string getActor ()

Output
string actor of the SOAP service
Exception

getClassMaps

public string getClassMaps ()

Output
string comma delimit list of complex type classes.
Exception

getEncoding

public string getEncoding ()

Output
string encoding of the SOAP service
Exception

getID

public string getID ()

Output
string the ID of the SOAP server
Exception

getOptions

protected array getOptions ()

Output
array options for creating SoapServer instance
Exception

getProvider

public string getProvider ()

Output
string the SOAP provider class (in namespace format)
Exception

getRequestedMethod

public string getRequestedMethod ()

Soap method guessed from the SOAP message received.

Output
string soap method request, null if not found.
Exception

getSessionPersistent

public boolean getSessionPersistent ()

Output
boolean whether the SOAP service is persistent within session. Defaults to false.
Exception

getUri

public string getUri ()

Output
string the URI for the SOAP service
Exception

getVersion

public string getVersion ()

Output
string SOAP version, defaults to empty (meaning not set).
Exception

getWsdl

public string getWsdl ()

Returns the WSDL content of the SOAP server.

If WsdlUri is set, its content will be returned. If not, the Provider class will be investigated and the WSDL will be automatically genearted.

Output
string the WSDL content of the SOAP server
Exception

getWsdlUri

public string getWsdlUri ()

Output
string the URI for WSDL
Exception

guessMethodCallRequested

protected void guessMethodCallRequested (string $class )

Guess the SOAP method request from the actual SOAP message

Input
string $class current handler class.
Output
Exception

run

public void run ()

Handles the SOAP request.

Output
Exception

setActor

public void setActor (string $value )

Input
string $value actor of the SOAP service
Output
Exception

setClassMaps

public string setClassMaps (mixed $classes )

Input
mixed | $classes
Output
string | comma delimit list of class names
Exception

setEncoding

public void setEncoding (string $value )

Input
string $value encoding of the SOAP service
Output
Exception

setID

public void setID (string $id )

Input
string | $id | the ID of the SOAP server
Output
Exception
throws | TInvalidDataValueException if the ID ends with '.wsdl'.

setProvider

public void setProvider (string $provider )

Input
string $provider the SOAP provider class (in namespace format)
Output
Exception

setSessionPersistent

public void setSessionPersistent (boolean $value )

Input
boolean $value whether the SOAP service is persistent within session.
Output
Exception

setUri

public void setUri (string $uri )

Input
string $uri the URI for the SOAP service
Output
Exception

setVersion

public void setVersion (string $value )

Input
string | $value | SOAP version, either '1.1' or '1.2'
Output
Exception
throws | TInvalidDataValueException if neither '1.1' nor '1.2'

setWsdlUri

public void setWsdlUri (string $value )

Input
string $value the URI for WSDL
Output
Exception

Constant Details

WSDL_CACHE_PREFIX

Type:

string

Value:

'wsdl.'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSoapService

Class TSoapService (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TService
         |
         --TSoapService

TSoapService class

TSoapService processes SOAP requests for a PRADO application. TSoapService requires PHP SOAP extension to be loaded.

TSoapService manages a set of SOAP providers. Each SOAP provider is a class that implements a set of SOAP methods which are exposed to SOAP clients for remote invocation. TSoapService generates WSDL automatically for the SOAP providers by default.

To use TSoapService, configure it in the application specification like following:

1        <services>
2          <service id="soap" class="System.Web.Services.TSoapService">
3            <soap id="stockquote" provider="MyStockQuote" />
4          </service>
5        </services>

The above example specifies a single SOAP provider named "stockquote" whose class is "MyStockQuote". A SOAP client can then obtain the WSDL for this provider via the following URL:

0        http://hostname/path/to/index.php?soap=stockquote.wsdl

The WSDL for the provider class "MyStockQuote" is generated based on special comment tags in the class. In particular, if a class method's comment contains the keyword "@soapmethod", it is considered to be a SOAP method and will be exposed to SOAP clients. For example,

1        class MyStockQuote {
2           / **
3            * @param string $symbol the stock symbol
4            * @return float the stock price
5            * @soapmethod
6            * /
7           public function getQuote($symbol) {...}
8        }

With the above SOAP provider, a typical SOAP client may call the method "getQuote" remotely like the following:

1        $client=new SoapClient("http://hostname/path/to/index.php?soap=stockquote.wsdl");
2        echo $client->getQuote("ibm");

Each <soap> element in the application specification actually configures the properties of a SOAP server which defaults to TSoapServer. Therefore, any writable property of TSoapServer may appear as an attribute in the <soap> element. For example, the "provider" attribute refers to the TSoapServer::setProvider property of TSoapServer. The following configuration specifies that the SOAP server is persistent within the user session (that means a MyStockQuote object will be stored in session)

1        <services>
2          <service id="soap" class="System.Web.Services.TSoapService">
3            <soap id="stockquote" provider="MyStockQuote" SessionPersistent="true" />
4          </service>
5        </services>

You may also use your own SOAP server class by specifying the "class" attribute of <soap>.

Since: 3.1
Author: Knut Urdalen <knut.urdalen@gmail.com>
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct
Constructor.
Method Summary
string | constructUrl ( string $serverID, array $getParams, boolean $encodeAmpersand, boolean $encodeGetItems) Constructs a URL with specified page path and GET parameters.
protected TSoapServer | createServer () Creates the requested SOAP server.
string | getConfigFile ()
boolean | getIsWsdlRequest ()
string | getServerID ()
void | init ( TXmlElement $config) Initializes this module.
protected void | resolveRequest () Resolves the request parameter.
void | run () Runs the service.
void | setConfigFile ( string $value)
Methods Inherited From TService
TService::getEnabled(), TService::getID(), TService::init(), TService::run(), TService::setEnabled(), TService::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string | CONFIG_FILE_EXT
string | DEFAULT_SOAP_SERVER
Constructor Details

__construct

public __construct

Constructor.

Sets default service ID to 'soap'.
Method Details

constructUrl

public string constructUrl (string $serverID , array $getParams , boolean $encodeAmpersand , boolean $encodeGetItems )

Constructs a URL with specified page path and GET parameters.

Input
string | $serverID | soap server ID
array | $getParams | list of GET parameters, null if no GET parameters required
boolean | $encodeAmpersand | whether to encode the ampersand in URL, defaults to true.
boolean | $encodeGetItems | whether to encode the GET parameters (their names and values), defaults to true.
Output
string | URL for the page and GET parameters
Exception

createServer

protected TSoapServer createServer ()

Creates the requested SOAP server.

The SOAP server is initialized with the property values specified in the configuration.

Output
TSoapServer the SOAP server instance
Exception

getConfigFile

public string getConfigFile ()

Output
string external configuration file. Defaults to null.
Exception

getIsWsdlRequest

public boolean getIsWsdlRequest ()

Output
boolean whether this is a request for WSDL
Exception

getServerID

public string getServerID ()

Output
string the SOAP server ID
Exception

init

public void init (TXmlElement $config )

Initializes this module.

This method is required by the IModule interface.

Input
TXmlElement | $config | configuration for this module, can be null
Output
Exception
throws | TConfigurationException if ConfigFile is invalid.

resolveRequest

protected void resolveRequest ()

Resolves the request parameter.

It identifies the server ID and whether the request is for WSDL.

Output
Exception
throws THttpException if the server ID cannot be found

run

public void run ()

Runs the service.

If the service parameter ends with '.wsdl', it will serve a WSDL file for the specified soap server. Otherwise, it will handle the soap request using the specified server.

Output
Exception

setConfigFile

public void setConfigFile (string $value )

Input
string | $value | external configuration file in namespace format. The file must be suffixed with '.xml'.
Output
Exception
throws | TInvalidDataValueException if the file is invalid.
Constant Details

CONFIG_FILE_EXT

Type:

string

Value:

'.xml'

DEFAULT_SOAP_SERVER

Type:

string

Value:

'TSoapServer'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TIbmScaffoldInput

Class TIbmScaffoldInput (Class Overview)

TScaffoldInputBase
   |
   --TScaffoldInputCommon
      |
      --TIbmScaffoldInput

TIbmScaffoldInput class file.

License: http://www.pradosoft.com/license/
Copyright: Copyright &copy; 2005-2008 PradoSoft
Link: http://www.pradosoft.com/
Author: Cesar Ramos <cramos[at]gmail[dot]com>
Constants Inherited From TScaffoldInputBase
DEFAULT_ID,
Method Summary
protected void | createControl ( mixed $container, mixed $column, mixed $record)
protected void | getControlValue ( mixed $container, mixed $column, mixed $record)
Methods Inherited From TScaffoldInputCommon
TScaffoldInputCommon::createBooleanControl(), TScaffoldInputCommon::createDateControl(), TScaffoldInputCommon::createDateTimeControl(), TScaffoldInputCommon::createDefaultControl(), TScaffoldInputCommon::createEnumControl(), TScaffoldInputCommon::createFloatControl(), TScaffoldInputCommon::createIntegerControl(), TScaffoldInputCommon::createMultiLineControl(), TScaffoldInputCommon::createRangeValidator(), TScaffoldInputCommon::createRequiredValidator(), TScaffoldInputCommon::createSetControl(), TScaffoldInputCommon::createTimeControl(), TScaffoldInputCommon::createTypeValidator(), TScaffoldInputCommon::createYearControl(), TScaffoldInputCommon::getDateTimeValue(), TScaffoldInputCommon::getDefaultControlValue(), TScaffoldInputCommon::getEnumValue(), TScaffoldInputCommon::getMatchingIndices(), TScaffoldInputCommon::getSetValue(), TScaffoldInputCommon::getTimeValue(), TScaffoldInputCommon::setDefaultProperty(), TScaffoldInputCommon::setNotNullProperty()
Methods Inherited From TScaffoldInputBase
TScaffoldInputBase::createControl(), TScaffoldInputBase::createControlLabel(), TScaffoldInputBase::createInputBuilder(), TScaffoldInputBase::createScaffoldInput(), TScaffoldInputBase::getControlValue(), TScaffoldInputBase::getIsEnabled(), TScaffoldInputBase::getParent(), TScaffoldInputBase::getRecordPropertyValue(), TScaffoldInputBase::loadScaffoldInput(), TScaffoldInputBase::setRecordPropertyValue()
Constant Summary
Method Details

createControl

protected void createControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

getControlValue

protected void getControlValue (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMssqlScaffoldInput

Class TMssqlScaffoldInput (Class Overview)

TScaffoldInputBase
   |
   --TScaffoldInputCommon
      |
      --TMssqlScaffoldInput

TMssqlScaffoldInput class file.

License: http://www.pradosoft.com/license/
Copyright: Copyright &copy; 2005-2008 PradoSoft
Link: http://www.pradosoft.com/
Constants Inherited From TScaffoldInputBase
DEFAULT_ID,
Method Summary
protected void | createControl ( mixed $container, mixed $column, mixed $record)
protected void | getControlValue ( mixed $container, mixed $column, mixed $record)
Methods Inherited From TScaffoldInputCommon
TScaffoldInputCommon::createBooleanControl(), TScaffoldInputCommon::createDateControl(), TScaffoldInputCommon::createDateTimeControl(), TScaffoldInputCommon::createDefaultControl(), TScaffoldInputCommon::createEnumControl(), TScaffoldInputCommon::createFloatControl(), TScaffoldInputCommon::createIntegerControl(), TScaffoldInputCommon::createMultiLineControl(), TScaffoldInputCommon::createRangeValidator(), TScaffoldInputCommon::createRequiredValidator(), TScaffoldInputCommon::createSetControl(), TScaffoldInputCommon::createTimeControl(), TScaffoldInputCommon::createTypeValidator(), TScaffoldInputCommon::createYearControl(), TScaffoldInputCommon::getDateTimeValue(), TScaffoldInputCommon::getDefaultControlValue(), TScaffoldInputCommon::getEnumValue(), TScaffoldInputCommon::getMatchingIndices(), TScaffoldInputCommon::getSetValue(), TScaffoldInputCommon::getTimeValue(), TScaffoldInputCommon::setDefaultProperty(), TScaffoldInputCommon::setNotNullProperty()
Methods Inherited From TScaffoldInputBase
TScaffoldInputBase::createControl(), TScaffoldInputBase::createControlLabel(), TScaffoldInputBase::createInputBuilder(), TScaffoldInputBase::createScaffoldInput(), TScaffoldInputBase::getControlValue(), TScaffoldInputBase::getIsEnabled(), TScaffoldInputBase::getParent(), TScaffoldInputBase::getRecordPropertyValue(), TScaffoldInputBase::loadScaffoldInput(), TScaffoldInputBase::setRecordPropertyValue()
Constant Summary
Method Details

createControl

protected void createControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

getControlValue

protected void getControlValue (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMysqlScaffoldInput

Class TMysqlScaffoldInput (Class Overview)

TScaffoldInputBase
   |
   --TScaffoldInputCommon
      |
      --TMysqlScaffoldInput

TMysqlScaffoldInput class file.

License: http://www.pradosoft.com/license/
Copyright: Copyright &copy; 2005-2008 PradoSoft
Link: http://www.pradosoft.com/
Constants Inherited From TScaffoldInputBase
DEFAULT_ID,
Method Summary
protected void | createControl ( mixed $container, mixed $column, mixed $record)
protected void | createIntegerControl ( mixed $container, mixed $column, mixed $record)
protected void | getControlValue ( mixed $container, mixed $column, mixed $record)
protected void | getIntBooleanValue ( mixed $container, mixed $column, mixed $record)
Methods Inherited From TScaffoldInputCommon
TScaffoldInputCommon::createBooleanControl(), TScaffoldInputCommon::createDateControl(), TScaffoldInputCommon::createDateTimeControl(), TScaffoldInputCommon::createDefaultControl(), TScaffoldInputCommon::createEnumControl(), TScaffoldInputCommon::createFloatControl(), TScaffoldInputCommon::createIntegerControl(), TScaffoldInputCommon::createMultiLineControl(), TScaffoldInputCommon::createRangeValidator(), TScaffoldInputCommon::createRequiredValidator(), TScaffoldInputCommon::createSetControl(), TScaffoldInputCommon::createTimeControl(), TScaffoldInputCommon::createTypeValidator(), TScaffoldInputCommon::createYearControl(), TScaffoldInputCommon::getDateTimeValue(), TScaffoldInputCommon::getDefaultControlValue(), TScaffoldInputCommon::getEnumValue(), TScaffoldInputCommon::getMatchingIndices(), TScaffoldInputCommon::getSetValue(), TScaffoldInputCommon::getTimeValue(), TScaffoldInputCommon::setDefaultProperty(), TScaffoldInputCommon::setNotNullProperty()
Methods Inherited From TScaffoldInputBase
TScaffoldInputBase::createControl(), TScaffoldInputBase::createControlLabel(), TScaffoldInputBase::createInputBuilder(), TScaffoldInputBase::createScaffoldInput(), TScaffoldInputBase::getControlValue(), TScaffoldInputBase::getIsEnabled(), TScaffoldInputBase::getParent(), TScaffoldInputBase::getRecordPropertyValue(), TScaffoldInputBase::loadScaffoldInput(), TScaffoldInputBase::setRecordPropertyValue()
Constant Summary
Method Details

createControl

protected void createControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createIntegerControl

protected void createIntegerControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

getControlValue

protected void getControlValue (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

getIntBooleanValue

protected void getIntBooleanValue (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPgsqlScaffoldInput

Class TPgsqlScaffoldInput (Class Overview)

TScaffoldInputBase
   |
   --TScaffoldInputCommon
      |
      --TPgsqlScaffoldInput

TPgsqlScaffoldInput class file.

License: http://www.pradosoft.com/license/
Copyright: Copyright &copy; 2005-2008 PradoSoft
Link: http://www.pradosoft.com/
Constants Inherited From TScaffoldInputBase
DEFAULT_ID,
Method Summary
protected void | createControl ( mixed $container, mixed $column, mixed $record)
protected void | getControlValue ( mixed $container, mixed $column, mixed $record)
Methods Inherited From TScaffoldInputCommon
TScaffoldInputCommon::createBooleanControl(), TScaffoldInputCommon::createDateControl(), TScaffoldInputCommon::createDateTimeControl(), TScaffoldInputCommon::createDefaultControl(), TScaffoldInputCommon::createEnumControl(), TScaffoldInputCommon::createFloatControl(), TScaffoldInputCommon::createIntegerControl(), TScaffoldInputCommon::createMultiLineControl(), TScaffoldInputCommon::createRangeValidator(), TScaffoldInputCommon::createRequiredValidator(), TScaffoldInputCommon::createSetControl(), TScaffoldInputCommon::createTimeControl(), TScaffoldInputCommon::createTypeValidator(), TScaffoldInputCommon::createYearControl(), TScaffoldInputCommon::getDateTimeValue(), TScaffoldInputCommon::getDefaultControlValue(), TScaffoldInputCommon::getEnumValue(), TScaffoldInputCommon::getMatchingIndices(), TScaffoldInputCommon::getSetValue(), TScaffoldInputCommon::getTimeValue(), TScaffoldInputCommon::setDefaultProperty(), TScaffoldInputCommon::setNotNullProperty()
Methods Inherited From TScaffoldInputBase
TScaffoldInputBase::createControl(), TScaffoldInputBase::createControlLabel(), TScaffoldInputBase::createInputBuilder(), TScaffoldInputBase::createScaffoldInput(), TScaffoldInputBase::getControlValue(), TScaffoldInputBase::getIsEnabled(), TScaffoldInputBase::getParent(), TScaffoldInputBase::getRecordPropertyValue(), TScaffoldInputBase::loadScaffoldInput(), TScaffoldInputBase::setRecordPropertyValue()
Constant Summary
Method Details

createControl

protected void createControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

getControlValue

protected void getControlValue (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TScaffoldInputBase

Class TScaffoldInputBase (Class Overview)

Direct Known Sub-classes:

                                    TScaffoldInputCommon

TScaffoldInputBase class file.

            License:
            http://www.pradosoft.com/license/

            Copyright:
            Copyright &copy; 2005-2008 PradoSoft

            Link:
            http://www.pradosoft.com/

Method Summary
protected void | createControl ( mixed $container, mixed $column, mixed $record)
protected void | createControlLabel ( mixed $label, mixed $column, mixed $record)
void | createInputBuilder ( mixed $record)
void | createScaffoldInput ( mixed $parent, mixed $item, mixed $column, mixed $record)
protected void | getControlValue ( mixed $container, mixed $column, mixed $record)
protected void | getIsEnabled ( mixed $column, mixed $record)
protected void | getParent ()
protected void | getRecordPropertyValue ( mixed $column, mixed $record)
void | loadScaffoldInput ( mixed $parent, mixed $item, mixed $column, mixed $record)
protected void | setRecordPropertyValue ( mixed $item, mixed $record, mixed $input)

            Constant Summary

                    string

                DEFAULT_ID

            Method Details

createControl

                                protected void createControl
                                (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createControlLabel

                                protected void createControlLabel
                                (mixed $label , mixed $column , mixed $record )

Input
mixed | $label
mixed | $column
mixed | $record
Output
Exception

createInputBuilder

                                public void createInputBuilder
                                (mixed $record )

Input

mixed $record

Output

Exception

createScaffoldInput

                                public void createScaffoldInput
                                (mixed $parent , mixed $item , mixed $column , mixed $record )

Input
mixed | $parent
mixed | $item
mixed | $column
mixed | $record
Output
Exception

getControlValue

                                protected void getControlValue
                                (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

getIsEnabled

                                protected void getIsEnabled
                                (mixed $column , mixed $record )

Input
mixed | $column
mixed | $record
Output
Exception

getParent

                                protected void getParent
                                ()

Output

Exception

getRecordPropertyValue

                                protected void getRecordPropertyValue
                                (mixed $column , mixed $record )

Input
mixed | $column
mixed | $record
Output
Exception

loadScaffoldInput

                                public void loadScaffoldInput
                                (mixed $parent , mixed $item , mixed $column , mixed $record )

Input
mixed | $parent
mixed | $item
mixed | $column
mixed | $record
Output
Exception

setRecordPropertyValue

                                protected void setRecordPropertyValue
                                (mixed $item , mixed $record , mixed $input )

Input
mixed | $item
mixed | $record
mixed | $input
Output
Exception

            Constant Details

DEFAULT_ID

Type:

    string

Value:

 'scaffold_input'

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TScaffoldInputCommon

Class TScaffoldInputCommon (Class Overview)

TScaffoldInputBase
   |
   --TScaffoldInputCommon

Direct Known Sub-classes:

TIbmScaffoldInput , TMssqlScaffoldInput , TMysqlScaffoldInput , TPgsqlScaffoldInput , TSqliteScaffoldInput

TScaffoldInputCommon class file.

License: http://www.pradosoft.com/license/
Copyright: Copyright &copy; 2005-2008 PradoSoft
Link: http://www.pradosoft.com/
Constants Inherited From TScaffoldInputBase
DEFAULT_ID,
Method Summary
protected void | createBooleanControl ( mixed $container, mixed $column, mixed $record)
protected void | createDateControl ( mixed $container, mixed $column, mixed $record)
protected void | createDateTimeControl ( mixed $container, mixed $column, mixed $record)
protected void | createDefaultControl ( mixed $container, mixed $column, mixed $record)
protected void | createEnumControl ( mixed $container, mixed $column, mixed $record)
protected void | createFloatControl ( mixed $container, mixed $column, mixed $record)
protected void | createIntegerControl ( mixed $container, mixed $column, mixed $record)
protected void | createMultiLineControl ( mixed $container, mixed $column, mixed $record)
protected void | createRangeValidator ( mixed $container, mixed $column, mixed $record)
protected void | createRequiredValidator ( mixed $container, mixed $column, mixed $record)
protected void | createSetControl ( mixed $container, mixed $column, mixed $record)
protected void | createTimeControl ( mixed $container, mixed $column, mixed $record)
protected void | createTypeValidator ( mixed $container, mixed $column, mixed $record)
protected void | createYearControl ( mixed $container, mixed $column, mixed $record)
protected void | getDateTimeValue ( mixed $container, mixed $column, mixed $record)
protected void | getDefaultControlValue ( mixed $container, mixed $column, mixed $record)
protected void | getEnumValue ( mixed $container, mixed $column, mixed $record)
protected void | getMatchingIndices ( mixed $checks, mixed $values)
protected void | getSetValue ( mixed $container, mixed $column, mixed $record)
protected void | getTimeValue ( mixed $container, mixed $column, mixed $record)
protected void | setDefaultProperty ( mixed $container, mixed $control, mixed $column, mixed $record)
protected void | setNotNullProperty ( mixed $container, mixed $control, mixed $column, mixed $record)
Methods Inherited From TScaffoldInputBase
TScaffoldInputBase::createControl(), TScaffoldInputBase::createControlLabel(), TScaffoldInputBase::createInputBuilder(), TScaffoldInputBase::createScaffoldInput(), TScaffoldInputBase::getControlValue(), TScaffoldInputBase::getIsEnabled(), TScaffoldInputBase::getParent(), TScaffoldInputBase::getRecordPropertyValue(), TScaffoldInputBase::loadScaffoldInput(), TScaffoldInputBase::setRecordPropertyValue()
Constant Summary
Method Details

createBooleanControl

protected void createBooleanControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createDateControl

protected void createDateControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createDateTimeControl

protected void createDateTimeControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createDefaultControl

protected void createDefaultControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createEnumControl

protected void createEnumControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createFloatControl

protected void createFloatControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createIntegerControl

protected void createIntegerControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createMultiLineControl

protected void createMultiLineControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createRangeValidator

protected void createRangeValidator (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createRequiredValidator

protected void createRequiredValidator (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createSetControl

protected void createSetControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createTimeControl

protected void createTimeControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createTypeValidator

protected void createTypeValidator (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createYearControl

protected void createYearControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

getDateTimeValue

protected void getDateTimeValue (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

getDefaultControlValue

protected void getDefaultControlValue (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

getEnumValue

protected void getEnumValue (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

getMatchingIndices

protected void getMatchingIndices (mixed $checks , mixed $values )

Input
mixed | $checks
mixed | $values
Output
Exception

getSetValue

protected void getSetValue (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

getTimeValue

protected void getTimeValue (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

setDefaultProperty

protected void setDefaultProperty (mixed $container , mixed $control , mixed $column , mixed $record )

Input
mixed | $container
mixed | $control
mixed | $column
mixed | $record
Output
Exception

setNotNullProperty

protected void setNotNullProperty (mixed $container , mixed $control , mixed $column , mixed $record )

Input
mixed | $container
mixed | $control
mixed | $column
mixed | $record
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqliteScaffoldInput

Class TSqliteScaffoldInput (Class Overview)

TScaffoldInputBase
   |
   --TScaffoldInputCommon
      |
      --TSqliteScaffoldInput

TSqliteScaffoldInput class file.

License: http://www.pradosoft.com/license/
Copyright: Copyright &copy; 2005-2008 PradoSoft
Link: http://www.pradosoft.com/
Constants Inherited From TScaffoldInputBase
DEFAULT_ID,
Method Summary
protected void | createControl ( mixed $container, mixed $column, mixed $record)
protected void | createDateControl ( mixed $container, mixed $column, mixed $record)
protected void | createDateTimeControl ( mixed $container, mixed $column, mixed $record)
protected void | getControlValue ( mixed $container, mixed $column, mixed $record)
protected void | getDateTimeValue ( mixed $container, mixed $column, mixed $record)
Methods Inherited From TScaffoldInputCommon
TScaffoldInputCommon::createBooleanControl(), TScaffoldInputCommon::createDateControl(), TScaffoldInputCommon::createDateTimeControl(), TScaffoldInputCommon::createDefaultControl(), TScaffoldInputCommon::createEnumControl(), TScaffoldInputCommon::createFloatControl(), TScaffoldInputCommon::createIntegerControl(), TScaffoldInputCommon::createMultiLineControl(), TScaffoldInputCommon::createRangeValidator(), TScaffoldInputCommon::createRequiredValidator(), TScaffoldInputCommon::createSetControl(), TScaffoldInputCommon::createTimeControl(), TScaffoldInputCommon::createTypeValidator(), TScaffoldInputCommon::createYearControl(), TScaffoldInputCommon::getDateTimeValue(), TScaffoldInputCommon::getDefaultControlValue(), TScaffoldInputCommon::getEnumValue(), TScaffoldInputCommon::getMatchingIndices(), TScaffoldInputCommon::getSetValue(), TScaffoldInputCommon::getTimeValue(), TScaffoldInputCommon::setDefaultProperty(), TScaffoldInputCommon::setNotNullProperty()
Methods Inherited From TScaffoldInputBase
TScaffoldInputBase::createControl(), TScaffoldInputBase::createControlLabel(), TScaffoldInputBase::createInputBuilder(), TScaffoldInputBase::createScaffoldInput(), TScaffoldInputBase::getControlValue(), TScaffoldInputBase::getIsEnabled(), TScaffoldInputBase::getParent(), TScaffoldInputBase::getRecordPropertyValue(), TScaffoldInputBase::loadScaffoldInput(), TScaffoldInputBase::setRecordPropertyValue()
Constant Summary
Method Details

createControl

protected void createControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createDateControl

protected void createDateControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

createDateTimeControl

protected void createDateTimeControl (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

getControlValue

protected void getControlValue (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception

getDateTimeValue

protected void getDateTimeValue (mixed $container , mixed $column , mixed $record )

Input
mixed | $container
mixed | $column
mixed | $record
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TLazyLoadList

Class TLazyLoadList (Class Overview)

TLazyLoadList executes mapped statements when the proxy collection is first accessed.

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

                    Constructor Summary

                    protected

                            __construct
                            Array

                            Create a new proxy list that will execute the mapped statement when any  of the list's method are accessed for the first time.

Method Summary
protected void | fetchListData () Load the data by executing the mapped statement.
boolean | hasMethod ( string $method) Try to fetch the data when any of the proxy collection method is called.
void | intercept ( string $method, array $arguments) Relay the method call to the underlying collection.
TObjectProxy | newInstance ( TMappedStatement $mappedStatement, mixed $param, object result $target, string $propertyName) Create a new instance of a lazy collection.

                    Constructor Details

__construct

                                protected __construct
                                Array

Create a new proxy list that will execute the mapped statement when any  of the list's method are accessed for the first time.

            Method Details

fetchListData

                                protected void fetchListData
                                ()

Load the data by executing the mapped statement.

Output

Exception

hasMethod

                                public boolean hasMethod
                                (string $method )

Try to fetch the data when any of the proxy collection method is called.

Input
string | $method | method name.
Output
boolean | true if the underlying collection has the corresponding method name.
Exception

intercept

                                public void intercept
                                (string $method , array $arguments )

Relay the method call to the underlying collection.

Input
string | $method | method name.
array | $arguments | method parameters.
Output
Exception

newInstance

                                public TObjectProxy newInstance
                                (TMappedStatement $mappedStatement , mixed $param , object result $target , string $propertyName )

Create a new instance of a lazy collection.

Input
TMappedStatement | $mappedStatement | statement to be executed to load the data.
mixed | $param | parameter value for the statement.
object result | $target | object that contains the lazy collection.
string | $propertyName | property of the result object to set the loaded collection.
Output
TObjectProxy | proxied collection object.
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TObjectProxy

Class TObjectProxy (Class Overview)

TObjectProxy sets up a simple object that intercepts method calls to a  particular object and relays the call to handler object.

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

                    Constructor Summary

                    public

                            __construct
                            Array

            Method Summary

                        mixed

                            __call
                        (	string $method, 	array $params)

                            Relay the method call to the handler object (if able to be handled), otherwise  it calls the proxied object's method.

                    Constructor Details

__construct

                                public __construct
                                Array

            Method Details

__call

                                public mixed __call
                                (string $method , array $params )

Relay the method call to the handler object (if able to be handled), otherwise  it calls the proxied object's method.

Input
string | $method | method name called
array | $params | method arguments
Output
mixed | method return value.
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPropertyAccess

Class TPropertyAccess (Class Overview)

TPropertyAccess class provides dot notation stype property access and setting.

Access object's properties (and subproperties) using dot path notation.  The following are equivalent.

1      echo $obj->property1;
2      echo $obj->getProperty1();
3      echo $obj['property1']; //$obj may be an array or object
4       echo TPropertyAccess($obj, 'property1');
Setting a property value.

1      $obj1->propert1 = 'hello';
2      $obj->setProperty('hello');
3      $obj['property1'] = 'hello'; //$obj may be an array or object
4       TPropertyAccess($obj, 'property1', 'hello');
Subproperties are supported using the dot notation. E.g.

1      echo $obj->property1->property2->property3
2      echo TPropertyAccess::get($obj, 'property1.property2.property3');

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

Method Summary
mixed | get ( mixed $object, string $path) Gets the property value.
boolean | has ( mixed $object, string $path)
void | set ( mixed &$originalObject, string $path, mixed $value) Sets the property value.

            Method Details

get

                                public mixed get
                                (mixed $object , string $path )

Gets the property value.

Input
mixed | $object | object or path.
string | $path | property path.
Output
mixed | property value.
Exception
throws | TInvalidDataValueException if property path is invalid.

has

                                public boolean has
                                (mixed $object , string $path )

Input
mixed | $object | object or array
string | $path | property path.
Output
boolean | true if property path is valid
Exception

set

                                public void set
                                (mixed &$originalObject , string $path , mixed $value )

Sets the property value.

Input
mixed | &$originalObject | object or array
string | $path | property path.
mixed | $value | new property value.
Output
Exception
throws | TInvalidDataValueException if property path is invalid.


PRADO API Manual: Docs For Class TSqlMapApplicationCache

Class TSqlMapApplicationCache (Class Overview)

TSqlMapApplicationCache uses the default Prado application cache for  caching SqlMap results.

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Create a new cache with limited cache size.

Method Summary
void | add ( mixed $id, mixed $value, mixed $expire, mixed $dependency)
void | delete ( string $key)
void | flush () Deletes all items in the cache, only for data cached by sqlmap cachemodel
mixed | get ( mixed $key)
protected ICache | getCache ()
protected TList | getKeyList () Retreive keylist from cache or create it if it doesn't exists
protected string | getKeyListId ()
void | set ( string $key, mixed $value, mixed $expire, mixed $dependency) Stores a value identified by a key into cache.
protected void | setKeyList ( mixed $keyList)

                    Constructor Details

__construct

                                public __construct
                                Array

Create a new cache with limited cache size.

            Method Details

add

                                public void add
                                (mixed $id , mixed $value , mixed $expire , mixed $dependency )

Input
mixed | $id
mixed | $value
mixed | $expire
mixed | $dependency
Output
Exception
throws | TSqlMapException not implemented.

delete

                                public void delete
                                (string $key )

Input

string $key item to be deleted.

Output

Exception

flush

                                public void flush
                                ()

Deletes all items in the cache, only for data cached by sqlmap cachemodel

Output

Exception

get

                                public mixed get
                                (mixed $key )

Input
mixed | $key
Output
mixed | Gets a cached object with the specified key.
Exception

getCache

                                protected ICache getCache
                                ()

Output

                                    ICache
                 Application cache instance.

Exception

getKeyList

                                protected TList getKeyList
                                ()

Retreive keylist from cache or create it if it doesn't exists

Output

Exception

getKeyListId

                                protected string getKeyListId
                                ()

Output

                                    string
                 a KeyListID for the cache model.

Exception

set

                                public void set
                                (string $key , mixed $value , mixed $expire , mixed $dependency )

Stores a value identified by a key into cache.

Input
string | $key | the key identifying the value to be cached
mixed | $value | the value to be cached
mixed | $expire |
mixed | $dependency |
Output
Exception

setKeyList

                                protected void setKeyList
                                (mixed $keyList )

Input

mixed $keyList

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapCache

Class TSqlMapCache (Class Overview)

Direct Known Sub-classes:

                                    TSqlMapFifoCache
                                                , TSqlMapLruCache

Allow different implementation of caching strategy. See <tt>TSqlMapFifoCache</tt>  for a first-in-first-out implementation. See <tt>TSqlMapLruCache</tt> for  a least-recently-used cache implementation.

            Since:
            3.1

            Author:
            Wei Zhuo <weizhuo[at]gmail[dot]com>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Create a new cache with limited cache size.

Method Summary
void | add ( mixed $id, mixed $value, mixed $expire, mixed $dependency)
object the | delete ( mixed $key)
void | flush () Clears the cache.
int | getCacheSize ()
void | setCacheSize ( int $value) Maximum number of items to cache. Default size is 100.

                    Constructor Details

__construct

                                public __construct
                                Array

Create a new cache with limited cache size.

            Method Details

add

                                public void add
                                (mixed $id , mixed $value , mixed $expire , mixed $dependency )

Input
mixed | $id
mixed | $value
mixed | $expire
mixed | $dependency
Output
Exception
throws | TSqlMapException not implemented.

delete

                                public object the delete
                                (mixed $key )

Input
mixed | $key
Output
object the | object removed if exists, null otherwise.
Exception

flush

                                public void flush
                                ()

Clears the cache.

Output

Exception

getCacheSize

                                public int getCacheSize
                                ()

Output

                                    int
                 cache size.

Exception

setCacheSize

                                public void setCacheSize
                                (int $value )

Maximum number of items to cache. Default size is 100.

Input

int $value cache size.

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapFifoCache

Class TSqlMapFifoCache (Class Overview)

TSqlMapCache
   |
   --TSqlMapFifoCache

First-in-First-out cache implementation, removes object that was first added when the cache is full.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
mixed | get ( mixed $key)
void | set ( string $key, mixed $value, mixed $expire, mixed $dependency) Stores a value identified by a key into cache.
Methods Inherited From TSqlMapCache
TSqlMapCache::add(), TSqlMapCache::delete(), TSqlMapCache::flush(), TSqlMapCache::getCacheSize(), TSqlMapCache::setCacheSize()
Method Details

get

public mixed get (mixed $key )

Input
mixed | $key
Output
mixed | Gets a cached object with the specified key.
Exception

set

public void set (string $key , mixed $value , mixed $expire , mixed $dependency )

Stores a value identified by a key into cache.

The expire and dependency parameters are ignored.

Input
string | $key | cache key
mixed | $value | value to cache.
mixed | $expire |
mixed | $dependency |
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapLruCache

Class TSqlMapLruCache (Class Overview)

TSqlMapCache
   |
   --TSqlMapLruCache

Least recently used cache implementation, removes object that was accessed last when the cache is full.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Method Summary
mixed | get ( mixed $key)
void | set ( string $key, mixed $value, mixed $expire, mixed $dependency) Stores a value identified by a key into cache.
Methods Inherited From TSqlMapCache
TSqlMapCache::add(), TSqlMapCache::delete(), TSqlMapCache::flush(), TSqlMapCache::getCacheSize(), TSqlMapCache::setCacheSize()
Method Details

get

public mixed get (mixed $key )

Input
mixed | $key
Output
mixed | Gets a cached object with the specified key.
Exception

set

public void set (string $key , mixed $value , mixed $expire , mixed $dependency )

Stores a value identified by a key into cache.

The expire and dependency parameters are ignored.

Input
string | $key | the key identifying the value to be cached
mixed | $value | the value to be cached
mixed | $expire |
mixed | $dependency |
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapConfig

Class TSqlMapConfig (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TModule
         |
         --TDataSourceConfig
            |
            --TSqlMapConfig

TSqlMapConfig module configuration class.

Database connection and TSqlMapManager configuration.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected boolean | cacheSqlMapManager ( mixed $manager) Saves the current SqlMap manager to cache.
void | clearCache () Deletes the configuration cache.
protected TSqlMapGateway | createSqlMapGateway ()
TSqlMapGateway | getClient () Initialize the sqlmap if necessary, returns the TSqlMapGateway instance.
string | getConfigFile ()
boolean | getEnableCache ()
TSqlMapManager | getSqlMapManager () Create and configure the data mapper using sqlmap configuration file.
protected TSqlMapManager | loadCachedSqlMapManager () Loads SqlMap manager from cache.
void | setConfigFile ( string $value)
void | setEnableCache ( boolean $value) Set true to cache sqlmap instances.
Methods Inherited From TDataSourceConfig
TDataSourceConfig::findConnectionByID(), TDataSourceConfig::getConnectionClass(), TDataSourceConfig::getConnectionID(), TDataSourceConfig::getDatabase(), TDataSourceConfig::getDbConnection(), TDataSourceConfig::init(), TDataSourceConfig::setConnectionClass(), TDataSourceConfig::setConnectionID()
Methods Inherited From TModule
TModule::getID(), TModule::init(), TModule::setID()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
string CONFIG_FILE_EXT File extension of external configuration file
Method Details

cacheSqlMapManager

protected boolean cacheSqlMapManager (mixed $manager )

Saves the current SqlMap manager to cache.

Input
mixed | $manager
Output
boolean | true if SqlMap manager was cached, false otherwise.
Exception

clearCache

public void clearCache ()

Deletes the configuration cache.

Output
Exception

createSqlMapGateway

protected TSqlMapGateway createSqlMapGateway ()

Output
TSqlMapGateway SqlMap gateway instance.
Exception

getClient

public TSqlMapGateway getClient ()

Initialize the sqlmap if necessary, returns the TSqlMapGateway instance.

Output
TSqlMapGateway SqlMap gateway instance.
Exception

getConfigFile

public string getConfigFile ()

Output
string SqlMap configuration file.
Exception

getEnableCache

public boolean getEnableCache ()

Output
boolean true if configuration should be cached, false otherwise.
Exception

getSqlMapManager

public TSqlMapManager getSqlMapManager ()

Create and configure the data mapper using sqlmap configuration file.

Or if cache is enabled and manager already cached load from cache. If cache is enabled, the data mapper instance is cached.

Output
TSqlMapManager SqlMap manager instance
Exception

loadCachedSqlMapManager

protected TSqlMapManager loadCachedSqlMapManager ()

Loads SqlMap manager from cache.

Output
TSqlMapManager SqlMap manager intance if load was successful, null otherwise.
Exception

setConfigFile

public void setConfigFile (string $value )

Input
string | $value | external configuration file in namespace format. The file extension must be '.xml'.
Output
Exception
throws | TConfigurationException if the file is invalid.

setEnableCache

public void setEnableCache (boolean $value )

Set true to cache sqlmap instances.

Input
boolean $value true to cache sqlmap instance.
Output
Exception

Constant Details

CONFIG_FILE_EXT

File extension of external configuration file

Type:

string

Value:

'.xml'
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TInvalidPropertyException

Class TInvalidPropertyException (Class Overview)

Exception
   |
   --TException
      |
      --TSqlMapException
         |
         --TInvalidPropertyException

TInvalidPropertyException, raised when setting or getting an invalid property.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
Methods Inherited From TSqlMapException
TSqlMapException::getErrorMessageFile(), TSqlMapException::implodeNode()
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TSqlMapConfigurationException

Class TSqlMapConfigurationException (Class Overview)

Exception
   |
   --TException
      |
      --TSqlMapException
         |
         --TSqlMapConfigurationException

TSqlMapConfigurationException, raised during configuration file parsing.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
Methods Inherited From TSqlMapException
TSqlMapException::getErrorMessageFile(), TSqlMapException::implodeNode()
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TSqlMapDuplicateException

Class TSqlMapDuplicateException (Class Overview)

Exception
   |
   --TException
      |
      --TSqlMapException
         |
         --TSqlMapDuplicateException

TSqlMapDuplicateException, raised when a duplicate mapped statement is found.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
Methods Inherited From TSqlMapException
TSqlMapException::getErrorMessageFile(), TSqlMapException::implodeNode()
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TSqlMapException

Class TSqlMapException (Class Overview)

Exception
   |
   --TException
      |
      --TSqlMapException

Direct Known Sub-classes:

TSqlMapConfigurationException , TSqlMapUndefinedException , TSqlMapDuplicateException , TInvalidPropertyException , TSqlMapExecutionException

TSqlMapException is the base exception class for all SqlMap exceptions.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Constructor, similar to the parent constructor. For parameters that are of SimpleXmlElement, the tag name and its attribute names and values are expanded into a string.
Method Summary
protected string | getErrorMessageFile ()
protected string | implodeNode ( SimpleXmlElement $node)
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()
Constructor Details

__construct

public __construct Array

Constructor, similar to the parent constructor. For parameters that are of SimpleXmlElement, the tag name and its attribute names and values are expanded into a string.
Method Details

getErrorMessageFile

protected string getErrorMessageFile ()

Output
string path to the error message file
Exception

implodeNode

protected string implodeNode (SimpleXmlElement $node )

Input
SimpleXmlElement | $node | node
Output
string | tag name and attribute names and values.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapExecutionException

Class TSqlMapExecutionException (Class Overview)

Exception
   |
   --TException
      |
      --TSqlMapException
         |
         --TSqlMapExecutionException

TSqlMapException is the base exception class for all SqlMap exceptions.

Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
Methods Inherited From TSqlMapException
TSqlMapException::getErrorMessageFile(), TSqlMapException::implodeNode()
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TSqlMapUndefinedException

Class TSqlMapUndefinedException (Class Overview)

Exception
   |
   --TException
      |
      --TSqlMapException
         |
         --TSqlMapUndefinedException

TSqlMapUndefinedException, raised when mapped statemented are undefined.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
Methods Inherited From TSqlMapException
TSqlMapException::getErrorMessageFile(), TSqlMapException::implodeNode()
Methods Inherited From TException
TException::getErrorCode(), TException::getErrorMessage(), TException::getErrorMessageFile(), TException::setErrorCode(), TException::setErrorMessage(), TException::translateErrorMessage()


PRADO API Manual: Docs For Class TSqlMapGateway

Class TSqlMapGateway (Class Overview)

TComponent
   |
   --TSqlMapGateway

DataMapper client, a fascade to provide access the rest of the DataMapper framework. It provides three core functions:

  • execute an update query (including insert and delete).
  • execute a select query for a single object
  • execute a select query for a list of objects
This class should be instantiated from a TSqlMapManager instance.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Method Summary
integer
delete ( string $statementName, mixed $parameter)
Executes a Sql DELETE statement. Delete returns the number of rows effected.
void
flushCaches ()
Flushes all cached objects that belong to this SqlMap
TDbConnection
getDbConnection ()
TSqlMapManager
getSqlMapManager ()
mixed
insert ( string $statementName, string $parameter)
Executes a Sql INSERT statement.
TList
queryForList ( string $statementName, mixed $parameter, TList $result, int $skip, int $max)
Executes a Sql SELECT statement that returns data to populate a number of result objects.
TMap
queryForMap ( string $statementName, mixed $parameter, string $keyProperty, string $valueProperty, mixed $skip, mixed $max)
Executes the SQL and retuns all rows selected in a map that is keyed on
TMap
queryForMapWithRowDelegate ( string $statementName, callback $delegate, mixed $parameter, string $keyProperty, string $valueProperty, mixed $skip, mixed $max)
Runs a query with a custom object that gets a chance to deal with each row as it is processed.
object A
queryForObject ( string $statementName, mixed $parameter, mixed $result)
Executes a Sql SELECT statement that returns that returns data to populate a single object instance.
TPagedList
queryForPagedList ( string $statementName, mixed $parameter, integer $pageSize, integer $page)
Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.
TPagedList
queryForPagedListWithRowDelegate ( string $statementName, callback $delegate, mixed $parameter, integer $pageSize, integer $page)
Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.
TList
queryWithRowDelegate ( string $statementName, callback $delegate, mixed $parameter, TList $result, int $skip, int $max)
Runs a query for list with a custom object that gets a chance to deal with each row as it is processed.
void
registerTypeHandler ( TSqlMapTypeHandler $typeHandler)
integer
update ( string $statementName, mixed $parameter)
Executes a Sql UPDATE statement.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Method Details

delete

public integer delete (string $statementName , mixed $parameter )

Executes a Sql DELETE statement. Delete returns the number of rows effected.

Input
string | $statementName | The name of the statement to execute.
mixed | $parameter | The parameter object.
Output
integer | The number of rows effected.
Exception

flushCaches

public void flushCaches ()

Flushes all cached objects that belong to this SqlMap

Output
Exception

getDbConnection

public TDbConnection getDbConnection ()

Output
TDbConnection database connection.
Exception

getSqlMapManager

public TSqlMapManager getSqlMapManager ()

Output
TSqlMapManager sqlmap manager.
Exception

insert

public mixed insert (string $statementName , string $parameter )

Executes a Sql INSERT statement.

Insert is a bit different from other update methods, as it provides facilities for returning the primary key of the newly inserted row (rather than the effected rows),

The parameter object is generally used to supply the input data for the INSERT values.

Input
string | $statementName | The name of the statement to execute.
string | $parameter | The parameter object.
Output
mixed | The primary key of the newly inserted row. This might be automatically generated by the RDBMS, or selected from a sequence table or other source.
Exception

queryForList

public TList queryForList (string $statementName , mixed $parameter , TList $result , int $skip , int $max )

Executes a Sql SELECT statement that returns data to populate a number of result objects.

The parameter object is generally used to supply the input data for the WHERE clause parameter(s) of the SELECT statement.

Input
string | $statementName | The name of the sql statement to execute.
mixed | $parameter | The object used to set the parameters in the SQL.
TList | $result | An Ilist object used to hold the objects, pass in null if want to return a list instead.
int | $skip | The number of rows to skip over.
int | $max | The maximum number of rows to return.
Output
TList | A List of result objects.
Exception

queryForMap

public TMap queryForMap (string $statementName , mixed $parameter , string $keyProperty , string $valueProperty , mixed $skip , mixed $max )

Executes the SQL and retuns all rows selected in a map that is keyed on

the property named in the keyProperty parameter. The value at each key will be the value of the property specified in the valueProperty parameter. If valueProperty is null, the entire result object will be entered.

Input
string | $statementName | The name of the sql statement to execute.
mixed | $parameter | The object used to set the parameters in the SQL.
string | $keyProperty | The property of the result object to be used as the key.
string | $valueProperty | The property of the result object to be used as the value.
mixed | $skip |
mixed | $max |
Output
TMap | Array object containing the rows keyed by keyProperty.
Exception

queryForMapWithRowDelegate

public TMap queryForMapWithRowDelegate (string $statementName , callback $delegate , mixed $parameter , string $keyProperty , string $valueProperty , mixed $skip , mixed $max )

Runs a query with a custom object that gets a chance to deal with each row as it is processed.

Example: $sqlmap->queryForMapWithRowDelegate('getAccounts', array($this, 'rowHandler'));

Input
string | $statementName | The name of the sql statement to execute.
callback | $delegate | Row delegate handler, a valid callback required.
mixed | $parameter | The object used to set the parameters in the SQL.
string | $keyProperty | The property of the result object to be used as the key.
string | $valueProperty | The property of the result object to be used as the value.
mixed | $skip |
mixed | $max |
Output
TMap | Array object containing the rows keyed by keyProperty.
Exception

queryForObject

public object A queryForObject (string $statementName , mixed $parameter , mixed $result )

Executes a Sql SELECT statement that returns that returns data to populate a single object instance.

The parameter object is generally used to supply the input data for the WHERE clause parameter(s) of the SELECT statement.

Input
string | $statementName | The name of the sql statement to execute.
mixed | $parameter | The object used to set the parameters in the SQL.
mixed | $result | An object of the type to be returned.
Output
object A | single result object populated with the result set data.
Exception

queryForPagedList

public TPagedList queryForPagedList (string $statementName , mixed $parameter , integer $pageSize , integer $page )

Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.

Input
string | $statementName | The name of the sql statement to execute.
mixed | $parameter | The object used to set the parameters in the SQL.
integer | $pageSize | The maximum number of objects to store in each page.
integer | $page | The number of the page to initially load into the list.
Output
TPagedList | A PaginatedList of beans containing the rows.
Exception

queryForPagedListWithRowDelegate

public TPagedList queryForPagedListWithRowDelegate (string $statementName , callback $delegate , mixed $parameter , integer $pageSize , integer $page )

Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.

Runs paged list query with row delegate Example: $sqlmap->queryForPagedListWithRowDelegate('getAccounts', array($this, 'rowHandler'));

Input
string | $statementName | The name of the sql statement to execute.
callback | $delegate | Row delegate handler, a valid callback required.
mixed | $parameter | The object used to set the parameters in the SQL.
integer | $pageSize | The maximum number of objects to store in each page.
integer | $page | The number of the page to initially load into the list.
Output
TPagedList | A PaginatedList of beans containing the rows.
Exception

queryWithRowDelegate

public TList queryWithRowDelegate (string $statementName , callback $delegate , mixed $parameter , TList $result , int $skip , int $max )

Runs a query for list with a custom object that gets a chance to deal with each row as it is processed.

Example: $sqlmap->queryWithRowDelegate('getAccounts', array($this, 'rowHandler'));

Input
string | $statementName | The name of the sql statement to execute.
callback | $delegate | Row delegate handler, a valid callback required.
mixed | $parameter | The object used to set the parameters in the SQL.
TList | $result | An Ilist object used to hold the objects, pass in null if want to return a list instead.
int | $skip | The number of rows to skip over.
int | $max | The maximum number of rows to return.
Output
TList | A List of result objects.
Exception

registerTypeHandler

public void registerTypeHandler (TSqlMapTypeHandler $typeHandler )

Input
TSqlMapTypeHandler $typeHandler new type handler.
Output
Exception

update

public integer update (string $statementName , mixed $parameter )

Executes a Sql UPDATE statement.

Update can also be used for any other update statement type, such as inserts and deletes. Update returns the number of rows effected.

The parameter object is generally used to supply the input data for the UPDATE values as well as the WHERE clause parameter(s).

Input
string | $statementName | The name of the statement to execute.
mixed | $parameter | The parameter object.
Output
integer | The number of rows effected.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapManager

Class TSqlMapManager (Class Overview)

TComponent
   |
   --TSqlMapManager

TSqlMapManager class holds the sqlmap configuation result maps, statements parameter maps and a type handler factory.

Use SqlMapGateway property to obtain the gateway instance used for querying statements defined in the SqlMap configuration files.

1      $conn = new TDbConnection($dsn,$dbuser,$dbpass);
2      $manager = new TSqlMapManager($conn);
3      $manager->configureXml('mydb-sqlmap.xml');
4      $sqlmap = $manager->getSqlMapGateway();
5      $result = $sqlmap->queryForObject('Products');

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Constructor, create a new SqlMap manager.
Method Summary
void | addCacheModel ( TSqlMapCacheModel $cacheModel) Adds a named cache.
void | addMappedStatement ( IMappedStatement $statement, IMappedStatement 1) Adds a (named) MappedStatement.
void | addParameterMap ( TParameterMap $parameter)
void | addResultMap ( TResultMap $result)
void | configureXml ( string $file) Loads and parses the SqlMap configuration file.
protected TSqlMapGateway | createSqlMapGateway () Configures the current TSqlMapManager using the given xml configuration file defined in ConfigFile.
void | flushCacheModels () Flushes all cached objects that belong to this SqlMap
TChainedCacheDependency | getCacheDependencies ()
TSqlMapCacheModel | getCacheModel ( string $name) Gets a cache by name
TDbConnection | getDbConnection ()
IMappedStatement | getMappedStatement ( string $name) Gets a MappedStatement by name.
TMap | getMappedStatements ()
TParameterMap | getParameterMap ( string $name)
TMap | getParameterMaps ()
TResultMap | getResultMap ( string $name) Gets a named result map
TMap | getResultMaps ()
TSqlMapGateway | getSqlmapGateway ()
TTypeHandlerFactory | getTypeHandlers ()
void | setDbConnection ( TDbConnection $conn)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor, create a new SqlMap manager.
Method Details

addCacheModel

public void addCacheModel (TSqlMapCacheModel $cacheModel )

Adds a named cache.

Input
TSqlMapCacheModel | $cacheModel | the cache to add.
Output
Exception
throws | TSqlMapConfigurationException

addMappedStatement

public void addMappedStatement (IMappedStatement $statement , IMappedStatement 1 )

Adds a (named) MappedStatement.

Input
IMappedStatement | $statement | The key name
IMappedStatement | 1 | The statement to add
Output
Exception
throws | TSqlMapDuplicateException

addParameterMap

public void addParameterMap (TParameterMap $parameter )

Input
TParameterMap | $parameter | add a new parameter map to this SQLMap.
Output
Exception
throws | TSqlMapDuplicateException

addResultMap

public void addResultMap (TResultMap $result )

Input
TResultMap | $result | add a new result map to this SQLMap
Output
Exception
throws | TSqlMapDuplicateException

configureXml

public void configureXml (string $file )

Loads and parses the SqlMap configuration file.

Input
string $file xml configuration file.
Output
Exception

createSqlMapGateway

protected TSqlMapGateway createSqlMapGateway ()

Configures the current TSqlMapManager using the given xml configuration file defined in ConfigFile.

Output
TSqlMapGateway create and configure a new TSqlMapGateway.
Exception

flushCacheModels

public void flushCacheModels ()

Flushes all cached objects that belong to this SqlMap

Output
Exception

getCacheDependencies

public TChainedCacheDependency getCacheDependencies ()

Output
Exception

getCacheModel

public TSqlMapCacheModel getCacheModel (string $name )

Gets a cache by name

Input
string | $name | the name of the cache to get.
Output
TSqlMapCacheModel | the cache object.
Exception
throws | TSqlMapConfigurationException

getDbConnection

public TDbConnection getDbConnection ()

Output
TDbConnection default database connection
Exception

getMappedStatement

public IMappedStatement getMappedStatement (string $name )

Gets a MappedStatement by name.

Input
string | $name | The name of the statement.
Output
IMappedStatement | The MappedStatement
Exception
throws | TSqlMapUndefinedException

getMappedStatements

public TMap getMappedStatements ()

Output
TMap mapped statements collection.
Exception

getParameterMap

public TParameterMap getParameterMap (string $name )

Input
string | $name | parameter map ID name.
Output
TParameterMap | the parameter with given ID.
Exception
throws | TSqlMapUndefinedException

getParameterMaps

public TMap getParameterMaps ()

Output
TMap parameter maps collection.
Exception

getResultMap

public TResultMap getResultMap (string $name )

Gets a named result map

Input
string | $name | result name.
Output
TResultMap | the result map.
Exception
throws | TSqlMapUndefinedException

getResultMaps

public TMap getResultMaps ()

Output
TMap result maps collection.
Exception

getSqlmapGateway

public TSqlMapGateway getSqlmapGateway ()

Output
TSqlMapGateway SqlMap gateway.
Exception

getTypeHandlers

public TTypeHandlerFactory getTypeHandlers ()

Output
TTypeHandlerFactory The TypeHandlerFactory
Exception

setDbConnection

public void setDbConnection (TDbConnection $conn )

Input
TDbConnection $conn default database connection
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapPagedList

Class TSqlMapPagedList (Class Overview)

TComponent
   |
   --TList
      |
      --TPagedList
         |
         --TSqlMapPagedList

TSqlMapPagedList implements a list with paging functionality that retrieves data from a SqlMap statement.

The maximum number of records fetched is 3 times the page size. It fetches the current, the previous and the next page at a time. This allows the paged list to determine if the page is a the begin, the middle or the end of the list.

The paged list does not need to know about the total number of records.

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constructor Summary
public
__construct Array
Create a new SqlMap paged list.
Method Summary
protected void | fetchDataFromStatement ( TPageList $sender, TPagedListFetchDataEventParameter $param) Fetch data by executing the SqlMap statement.
boolean | getIsLastPage ()
boolean | getIsMiddlePage ()
boolean | getIsNextPageAvailable ()
boolean | getIsPreviousPageAvailable ()
protected array | getOffsetAndLimit ( TPagedListFetchDataEventParameter $param) Calculate the data fetch offsets and limits.
protected void | initialize ( IMappedStatement $statement, mixed $parameter, int $pageSize, int $page) Initialize the paged list.
integer|boolean | nextPage () Switches to the next page.
protected void | populateData ( TPagedListFetchDataEventParameter $param, array $data) Populate the list with the fetched data.
integer|boolean | previousPage () Switches to the previous page.
void | setCustomPaging ( mixed $value)
Methods Inherited From TPagedList
TPagedList::getCount(), TPagedList::getCurrentPageIndex(), TPagedList::getCustomPaging(), TPagedList::getIsFirstPage(), TPagedList::getIsLastPage(), TPagedList::getIterator(), TPagedList::getPageCount(), TPagedList::getPageSize(), TPagedList::getVirtualCount(), TPagedList::gotoPage(), TPagedList::indexOf(), TPagedList::itemAt(), TPagedList::nextPage(), TPagedList::offsetExists(), TPagedList::offsetGet(), TPagedList::onFetchData(), TPagedList::onPageIndexChanged(), TPagedList::previousPage(), TPagedList::setCurrentPageIndex(), TPagedList::setCustomPaging(), TPagedList::setPageSize(), TPagedList::setVirtualCount(), TPagedList::toArray()
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Create a new SqlMap paged list.
Method Details

fetchDataFromStatement

protected void fetchDataFromStatement (TPageList $sender , TPagedListFetchDataEventParameter $param )

Fetch data by executing the SqlMap statement.

Input
TPageList | $sender | current object.
TPagedListFetchDataEventParameter | $param | fetch parameters
Output
Exception

getIsLastPage

public boolean getIsLastPage ()

Output
boolean true if is the very last page, false otherwise.
Exception

getIsMiddlePage

public boolean getIsMiddlePage ()

Output
boolean true if is not first nor last page, false otherwise.
Exception

getIsNextPageAvailable

public boolean getIsNextPageAvailable ()

Output
boolean true if the next page is available, false otherwise.
Exception

getIsPreviousPageAvailable

public boolean getIsPreviousPageAvailable ()

Output
boolean true if the previous page is available, false otherwise.
Exception

getOffsetAndLimit

protected array getOffsetAndLimit (TPagedListFetchDataEventParameter $param )

Calculate the data fetch offsets and limits.

Input
TPagedListFetchDataEventParameter | $param | fetch parameters
Output
array | 1st element is the offset, 2nd element is the limit.
Exception

initialize

protected void initialize (IMappedStatement $statement , mixed $parameter , int $pageSize , int $page )

Initialize the paged list.

Input
IMappedStatement | $statement | SqlMap statement.
mixed | $parameter | query parameters
int | $pageSize | page size.
int | $page | number of page.
Output
Exception

nextPage

public integer|boolean nextPage ()

Switches to the next page.

Output
integer|boolean the new page index, false if next page is not availabe.
Exception

populateData

protected void populateData (TPagedListFetchDataEventParameter $param , array $data )

Populate the list with the fetched data.

Input
TPagedListFetchDataEventParameter | $param | fetch parameters
array | $data | fetched data.
Output
Exception

previousPage

public integer|boolean previousPage ()

Switches to the previous page.

Output
integer|boolean the new page index, false if previous page is not availabe.
Exception

setCustomPaging

public void setCustomPaging (mixed $value )

Input
mixed | $value
Output
Exception
throws | TSqlMapException custom paging must be enabled.


PRADO API Manual: Docs For Class TSqlMapTypeHandler

Class TSqlMapTypeHandler (Class Overview)

TComponent
   |
   --TSqlMapTypeHandler

A simple interface for implementing custom type handlers.

Using this interface, you can implement a type handler that will perform customized processing before parameters are set on and after values are retrieved from the database. Using a custom type handler you can extend the framework to handle types that are not supported, or handle supported types in a different way. For example, you might use a custom type handler to implement proprietary BLOB support (e.g. Oracle), or you might use it to handle booleans using "Y" and "N" instead of the more typical 0/1.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
abstract mixed | createNewInstance ( array $row) Casts the string representation of a value into a type recognized by
string | getDbType ()
abstract void | getParameter ( object The $object, object The 1) Performs processing on a value before it is used to set the parameter of a IDbCommand.
abstract mixed | getResult ( object The $string) Performs processing on a value before after it has been retrieved
void | getType ()
void | setDbType ( string $value)
void | setType ( mixed $value)
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createNewInstance

public abstract mixed createNewInstance (array $row )

Casts the string representation of a value into a type recognized by

this type handler. This method is used to translate nullValue values into types that can be appropriately compared. If your custom type handler cannot support nullValues, or if there is no reasonable string representation for this type (e.g. File type), you can simply return the String representation as it was passed in. It is not recommended to return null, unless null was passed in.

Input
array $row result row.
Output
Exception

getDbType

public string getDbType ()

Output
string database field type.
Exception

getParameter

public abstract void getParameter (object The $object , object The 1 )

Performs processing on a value before it is used to set the parameter of a IDbCommand.

Input
object The | $object | interface for setting the value.
object The | 1 | value to be set.
Output
Exception

getResult

public abstract mixed getResult (object The $string )

Performs processing on a value before after it has been retrieved

from a database

Input
object The | $string | interface for getting the value.
Output
mixed | The processed value.
Exception

getType

public void getType ()

Output
Exception

setDbType

public void setDbType (string $value )

Input
string $value database field type.
Output
Exception

setType

public void setType (mixed $value )

Input
mixed $value
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqlMapTypeHandlerRegistry

Class TSqlMapTypeHandlerRegistry (Class Overview)

TTypeHandlerFactory provides type handler classes to convert database field type  to PHP types and vice versa.

            Since:
            3.1

            Author:
            Wei Zhuo <weizho[at]gmail[dot]com>

Method Summary
mixed | convertToType ( string $type, mixed $value) Converts the value to given type using PHP's settype() function.
mixed | createInstanceOf ( string $type) Creates a new instance of a particular class (for PHP primative types, their corresponding default value for given type is used).
TSqlMapTypeHandler | getDbTypeHandler ( string $dbType)
TSqlMapTypeHandler | getTypeHandler ( string $class)
void | registerTypeHandler ( TSqlMapTypeHandler $handler)

            Method Details

convertToType

                                public mixed convertToType
                                (string $type , mixed $value )

Converts the value to given type using PHP's settype() function.

Input
string | $type | PHP primative type.
mixed | $value | value to be casted
Output
mixed | type casted value.
Exception

createInstanceOf

                                public mixed createInstanceOf
                                (string $type )

Creates a new instance of a particular class (for PHP primative types,  their corresponding default value for given type is used).

Input
string | $type | PHP type name
Output
mixed | default type value, if no type is specified null is returned.
Exception
throws | TSqlMapException if class name is not found.

getDbTypeHandler

                                public TSqlMapTypeHandler getDbTypeHandler
                                (string $dbType )

Input
string | $dbType | database field type
Output
TSqlMapTypeHandler | type handler for give database field type.
Exception

getTypeHandler

                                public TSqlMapTypeHandler getTypeHandler
                                (string $class )

Input
string | $class | type handler class name
Output
TSqlMapTypeHandler | type handler
Exception

registerTypeHandler

                                public void registerTypeHandler
                                (TSqlMapTypeHandler $handler )

Input

TSqlMapTypeHandler $handler registers a new type handler

Output

Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMssqlMetaData

Class TMssqlMetaData (Class Overview)

TComponent
   |
   --TDbMetaData
      |
      --TMssqlMetaData

TMssqlMetaData loads MSSQL database table and column information.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected TMssqlTableInfo | createNewTableInfo ( string $col, string 1)
protected TMssqlTableInfo | createTableInfo ( string $table) Get the column definitions for given table.
protected array | getCatalogSchemaTableName ( string $table)
protected array | getConstraintKeys ( string $col, string 1) Gets the primary and foreign key column details for the given table.
protected array | getForeignConstraints ( string $col, string 1) Gets foreign relationship constraint keys and table name
protected string | getTableInfoClass ()
protected boolean | isForeignKeyColumn ( string $columnId, TPgsqlTableInfo $tableInfo)
protected void | processColumn ( TMssqlTableInfo $tableInfo, array $col)
Methods Inherited From TDbMetaData
TDbMetaData::createCommandBuilder(), TDbMetaData::getDbConnection(), TDbMetaData::getInstance(), TDbMetaData::getTableInfo(), TDbMetaData::getTableInfoClass()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createNewTableInfo

protected TMssqlTableInfo createNewTableInfo (string $col , string 1 )

Input
string | $col | table schema name
string | 1 | table name.
Output
Exception

createTableInfo

protected TMssqlTableInfo createTableInfo (string $table )

Get the column definitions for given table.

Input
string | $table | table name.
Output
TMssqlTableInfo | table information.
Exception

getCatalogSchemaTableName

protected array getCatalogSchemaTableName (string $table )

Input
string | $table | table name
Output
array | tuple($catalogName,$schemaName,$tableName)
Exception

getConstraintKeys

protected array getConstraintKeys (string $col , string 1 )

Gets the primary and foreign key column details for the given table.

Input
string | $col | schema name
string | 1 | table name.
Output
array | tuple ($primary, $foreign)
Exception

getForeignConstraints

protected array getForeignConstraints (string $col , string 1 )

Gets foreign relationship constraint keys and table name

Input
string | $col | database name
string | 1 | table name
Output
array | foreign relationship table name and keys.
Exception

getTableInfoClass

protected string getTableInfoClass ()

Output
string TDbTableInfo class name.
Exception

isForeignKeyColumn

protected boolean isForeignKeyColumn (string $columnId , TPgsqlTableInfo $tableInfo )

Input
string | $columnId | column name.
TPgsqlTableInfo | $tableInfo | table information.
Output
boolean | true if column is a foreign key.
Exception

processColumn

protected void processColumn (TMssqlTableInfo $tableInfo , array $col )

Input
TMssqlTableInfo | $tableInfo | table information.
array | $col | column information.
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMssqlTableColumn

Class TMssqlTableColumn (Class Overview)

TComponent
   |
   --TDbTableColumn
      |
      --TMssqlTableColumn

Describes the column metadata of the schema for a Mssql database table.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constants Inherited From TDbTableColumn
UNDEFINED_VALUE,
Method Summary
boolean | getAutoIncrement ()
boolean | getIsExcluded ()
boolean | getPHPType () Overrides parent implementation, returns PHP type from the db type.
boolean | hasSequence ()
Methods Inherited From TDbTableColumn
TDbTableColumn::getAllowNull(), TDbTableColumn::getColumnId(), TDbTableColumn::getColumnIndex(), TDbTableColumn::getColumnName(), TDbTableColumn::getColumnSize(), TDbTableColumn::getDbType(), TDbTableColumn::getDefaultValue(), TDbTableColumn::getInfo(), TDbTableColumn::getIsExcluded(), TDbTableColumn::getIsForeignKey(), TDbTableColumn::getIsPrimaryKey(), TDbTableColumn::getMaxiumNumericConstraint(), TDbTableColumn::getNumericPrecision(), TDbTableColumn::getNumericScale(), TDbTableColumn::getPdoType(), TDbTableColumn::getPHPType(), TDbTableColumn::getSequenceName(), TDbTableColumn::hasSequence(), TDbTableColumn::setInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getAutoIncrement

public boolean getAutoIncrement ()

Output
boolean true if the column has identity (auto-increment)
Exception

getIsExcluded

public boolean getIsExcluded ()

Output
boolean true if db type is 'timestamp'.
Exception

getPHPType

public boolean getPHPType ()

Overrides parent implementation, returns PHP type from the db type.

Output
boolean derived PHP primitive type from the column db type.
Exception

hasSequence

public boolean hasSequence ()

Output
boolean true if auto increments.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMssqlTableInfo

Class TMssqlTableInfo (Class Overview)

TComponent
   |
   --TDbTableInfo
      |
      --TMssqlTableInfo

TMssqlTableInfo class provides additional table information for Mssql database.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
TDbCommandBuilder | createCommandBuilder ( TDbConnection $connection)
string | getCatalogName ()
string | getSchemaName ()
string | getTableFullName ()
Methods Inherited From TDbTableInfo
TDbTableInfo::createCommandBuilder(), TDbTableInfo::getColumn(), TDbTableInfo::getColumnNames(), TDbTableInfo::getColumns(), TDbTableInfo::getForeignKeys(), TDbTableInfo::getInfo(), TDbTableInfo::getIsView(), TDbTableInfo::getLowerCaseColumnNames(), TDbTableInfo::getPrimaryKeys(), TDbTableInfo::getTableFullName(), TDbTableInfo::getTableName(), TDbTableInfo::setInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createCommandBuilder

public TDbCommandBuilder createCommandBuilder (TDbConnection $connection )

Input
TDbConnection | $connection | database connection.
Output
TDbCommandBuilder | new command builder
Exception

getCatalogName

public string getCatalogName ()

Output
string catalog name (database name)
Exception

getSchemaName

public string getSchemaName ()

Output
string name of the schema this column belongs to.
Exception

getTableFullName

public string getTableFullName ()

Output
string full name of the table, database dependent.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMysqlMetaData

Class TMysqlMetaData (Class Overview)

TComponent
   |
   --TDbMetaData
      |
      --TMysqlMetaData

TMysqlMetaData loads Mysql version 4.1.x and 5.x database table and column information.

For Mysql version 4.1.x, PHP 5.1.3 or later is required. See http://netevil.org/node.php?nid=795&SC=1

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected TMysqlTableInfo | createNewTableInfo ( string $table, string 1)
protected TMysqlTableInfo | createTableInfo ( string $table) Get the column definitions for given table.
protected array | findForeignConstraints ( string $schemaName, string $tableName) Extract foreign key constraints by extracting the contraints from SHOW CREATE TABLE result.
protected array | getConstraintKeys ( string $schemaName, string $tableName) Gets the primary and foreign key column details for the given table.
protected array | getForeignConstraints ( string $schemaName, string $tableName) Gets foreign relationship constraint keys and table name
protected boolean | getIsView ( string $schemaName, string $tableName) For MySQL version 5.0.1 or later we can use SHOW FULL TABLES http://dev.mysql.com/doc/refman/5.0/en/show-tables.html
protected array | getSchemaTableName ( string $table)
protected float | getServerVersion ()
protected string | getShowCreateTable ( string $schemaName, string $tableName)
protected string | getTableInfoClass ()
protected boolean | isEnumSetType ( mixed $type)
protected boolean | isForeignKeyColumn ( string $columnId, TPgsqlTableInfo $tableInfo)
protected boolean | isPrecisionType ( mixed $type)
protected void | isValidIdentifier ( string $name, boolean 1) http://dev.mysql.com/doc/refman/5.0/en/identifiers.html
protected void | processColumn ( TMysqlTableInfo $tableInfo, array $col)
Methods Inherited From TDbMetaData
TDbMetaData::createCommandBuilder(), TDbMetaData::getDbConnection(), TDbMetaData::getInstance(), TDbMetaData::getTableInfo(), TDbMetaData::getTableInfoClass()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createNewTableInfo

protected TMysqlTableInfo createNewTableInfo (string $table , string 1 )

Input
string | $table | table schema name
string | 1 | table name.
Output
Exception

createTableInfo

protected TMysqlTableInfo createTableInfo (string $table )

Get the column definitions for given table.

Input
string | $table | table name.
Output
TMysqlTableInfo | table information.
Exception

findForeignConstraints

protected array findForeignConstraints (string $schemaName , string $tableName )

Extract foreign key constraints by extracting the contraints from SHOW CREATE TABLE result.

Input
string | $schemaName | database name
string | $tableName | table name
Output
array | foreign relationship table name and keys.
Exception

getConstraintKeys

protected array getConstraintKeys (string $schemaName , string $tableName )

Gets the primary and foreign key column details for the given table.

Input
string | $schemaName | schema name
string | $tableName | table name.
Output
array | tuple ($primary, $foreign)
Exception

getForeignConstraints

protected array getForeignConstraints (string $schemaName , string $tableName )

Gets foreign relationship constraint keys and table name

Input
string | $schemaName | database name
string | $tableName | table name
Output
array | foreign relationship table name and keys.
Exception

getIsView

protected boolean getIsView (string $schemaName , string $tableName )

For MySQL version 5.0.1 or later we can use SHOW FULL TABLES http://dev.mysql.com/doc/refman/5.0/en/show-tables.html

For MySQL version 5.0.1 or ealier, this always return false.

Input
string | $schemaName | database name, null to use default connection database.
string | $tableName | table or view name.
Output
boolean | true if is view, false otherwise.
Exception
throws | TDbException if table or view does not exist.

getSchemaTableName

protected array getSchemaTableName (string $table )

Input
string | $table | table name, may be quoted with back-ticks and may contain database name.
Output
array | tuple ($schema,$table), $schema may be null.
Exception
throws | TDbException when table name contains invalid identifier bytes.

getServerVersion

protected float getServerVersion ()

Output
float server version.
Exception

getShowCreateTable

protected string getShowCreateTable (string $schemaName , string $tableName )

Input
string | $schemaName | database name
string | $tableName | table name
Output
string | SQL command to create the table.
Exception
throws | TDbException if PHP version is less than 5.1.3

getTableInfoClass

protected string getTableInfoClass ()

Output
string TDbTableInfo class name.
Exception

isEnumSetType

protected boolean isEnumSetType (mixed $type )

Input
mixed | $type
Output
boolean | true if column type if "enum" or "set".
Exception

isForeignKeyColumn

protected boolean isForeignKeyColumn (string $columnId , TPgsqlTableInfo $tableInfo )

Input
string | $columnId | column name.
TPgsqlTableInfo | $tableInfo | table information.
Output
boolean | true if column is a foreign key.
Exception

isPrecisionType

protected boolean isPrecisionType (mixed $type )

Input
mixed | $type
Output
boolean | true if column type if "numeric", "interval" or begins with "time".
Exception

isValidIdentifier

protected void isValidIdentifier (string $name , boolean 1 )

http://dev.mysql.com/doc/refman/5.0/en/identifiers.html

Input
string | $name | identifier name
boolean | 1 | true if valid identifier.
Output
Exception

processColumn

protected void processColumn (TMysqlTableInfo $tableInfo , array $col )

Input
TMysqlTableInfo | $tableInfo | table information.
array | $col | column information.
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqliteMetaData

Class TSqliteMetaData (Class Overview)

TComponent
   |
   --TDbMetaData
      |
      --TSqliteMetaData

TSqliteMetaData loads SQLite database table and column information.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected TPgsqlTableInfo | createTableInfo ( string $tableName) Get the column definitions for given table.
protected array | getForeignKeys ( string $table)
protected boolean | getIsView ( string $tableName)
protected string | getTableInfoClass ()
protected boolean | isForeignKeyColumn ( string $columnId, array $foreign)
protected TSqliteTableColumn | processColumn ( array $col, array $foreign)
Methods Inherited From TDbMetaData
TDbMetaData::createCommandBuilder(), TDbMetaData::getDbConnection(), TDbMetaData::getInstance(), TDbMetaData::getTableInfo(), TDbMetaData::getTableInfoClass()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createTableInfo

protected TPgsqlTableInfo createTableInfo (string $tableName )

Get the column definitions for given table.

Input
string | $tableName | table name.
Output
TPgsqlTableInfo | table information.
Exception

getForeignKeys

protected array getForeignKeys (string $table )

Input
string | $table | quoted table name.
Output
array | foreign key details.
Exception

getIsView

protected boolean getIsView (string $tableName )

Input
string | $tableName | table name.
Output
boolean | true if the table is a view.
Exception

getTableInfoClass

protected string getTableInfoClass ()

Output
string TDbTableInfo class name.
Exception

isForeignKeyColumn

protected boolean isForeignKeyColumn (string $columnId , array $foreign )

Input
string | $columnId | column name.
array | $foreign | foreign key column names.
Output
boolean | true if column is a foreign key.
Exception

processColumn

protected TSqliteTableColumn processColumn (array $col , array $foreign )

Input
array | $col | column information.
array | $foreign | foreign key details.
Output
TSqliteTableColumn | column details.
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMysqlTableColumn

Class TMysqlTableColumn (Class Overview)

TComponent
   |
   --TDbTableColumn
      |
      --TMysqlTableColumn

Describes the column metadata of the schema for a Mysql database table.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constants Inherited From TDbTableColumn
UNDEFINED_VALUE,
Method Summary
boolean | getAutoIncrement ()
void | getDbTypeValues ()
boolean | getPHPType () Overrides parent implementation, returns PHP type from the db type.
boolean | hasSequence ()
Methods Inherited From TDbTableColumn
TDbTableColumn::getAllowNull(), TDbTableColumn::getColumnId(), TDbTableColumn::getColumnIndex(), TDbTableColumn::getColumnName(), TDbTableColumn::getColumnSize(), TDbTableColumn::getDbType(), TDbTableColumn::getDefaultValue(), TDbTableColumn::getInfo(), TDbTableColumn::getIsExcluded(), TDbTableColumn::getIsForeignKey(), TDbTableColumn::getIsPrimaryKey(), TDbTableColumn::getMaxiumNumericConstraint(), TDbTableColumn::getNumericPrecision(), TDbTableColumn::getNumericScale(), TDbTableColumn::getPdoType(), TDbTableColumn::getPHPType(), TDbTableColumn::getSequenceName(), TDbTableColumn::hasSequence(), TDbTableColumn::setInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getAutoIncrement

public boolean getAutoIncrement ()

Output
boolean true if column will auto-increment when the column value is inserted as null.
Exception

getDbTypeValues

public void getDbTypeValues ()

Output
Exception

getPHPType

public boolean getPHPType ()

Overrides parent implementation, returns PHP type from the db type.

Output
boolean derived PHP primitive type from the column db type.
Exception

hasSequence

public boolean hasSequence ()

Output
boolean true if auto increment is true.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TMysqlTableInfo

Class TMysqlTableInfo (Class Overview)

TComponent
   |
   --TDbTableInfo
      |
      --TMysqlTableInfo

TMysqlTableInfo class provides additional table information for MySQL database.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
TDbCommandBuilder | createCommandBuilder ( TDbConnection $connection)
string | getSchemaName ()
string | getTableFullName ()
Methods Inherited From TDbTableInfo
TDbTableInfo::createCommandBuilder(), TDbTableInfo::getColumn(), TDbTableInfo::getColumnNames(), TDbTableInfo::getColumns(), TDbTableInfo::getForeignKeys(), TDbTableInfo::getInfo(), TDbTableInfo::getIsView(), TDbTableInfo::getLowerCaseColumnNames(), TDbTableInfo::getPrimaryKeys(), TDbTableInfo::getTableFullName(), TDbTableInfo::getTableName(), TDbTableInfo::setInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createCommandBuilder

public TDbCommandBuilder createCommandBuilder (TDbConnection $connection )

Input
TDbConnection | $connection | database connection.
Output
TDbCommandBuilder | new command builder
Exception

getSchemaName

public string getSchemaName ()

Output
string name of the schema this column belongs to.
Exception

getTableFullName

public string getTableFullName ()

Output
string full name of the table, database dependent.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TOracleMetaData

Class TOracleMetaData (Class Overview)

TComponent
   |
   --TDbMetaData
      |
      --TOracleMetaData

TOracleMetaData loads Oracle database table and column information.

Since: 3.1
Author: Marcos Nobre <marconobre[at]gmail[dot]com>
Method Summary
protected string | assertIdentifier ( string $name)
protected TOracleTableInfo | createNewTableInfo ( string $schemaName, string $tableName)
protected TOracleTableInfo | createTableInfo ( string $table) Get the column definitions for given table.
protected array | getConstraintKeys ( string $schemaName, string $tableName) Gets the primary and foreign key column details for the given table.
string | getDefaultSchema ()
protected array | getForeignKeys ( string $src) Gets foreign relationship constraint keys and table name
protected boolean | getIsView ( string $schemaName, string $tableName)
protected array | getPrimaryKeys ( string $src) Gets the primary key field names
protected array | getSchemaTableName ( string $table)
protected string | getSequenceName ( mixed $tableInfo, mixed $src)
protected string | getTableInfoClass ()
protected boolean | isForeignKeyColumn ( string $columnId, TOracleTableInfo $tableInfo)
protected boolean | isPrecisionType ( mixed $type)
protected void | processColumn ( TOracleTableInfo $tableInfo, array $col)
void | setDefaultSchema ( string $schema)
Methods Inherited From TDbMetaData
TDbMetaData::createCommandBuilder(), TDbMetaData::getDbConnection(), TDbMetaData::getInstance(), TDbMetaData::getTableInfo(), TDbMetaData::getTableInfoClass()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

assertIdentifier

protected string assertIdentifier (string $name )

Input
string | $name | table name, schema name or column name.
Output
string | a valid identifier.
Exception
throws | TDbException when table name contains a double quote (").

createNewTableInfo

protected TOracleTableInfo createNewTableInfo (string $schemaName , string $tableName )

Input
string | $schemaName | table schema name
string | $tableName | table name.
Output
Exception

createTableInfo

protected TOracleTableInfo createTableInfo (string $table )

Get the column definitions for given table.

Input
string | $table | table name.
Output
TOracleTableInfo | table information.
Exception

getConstraintKeys

protected array getConstraintKeys (string $schemaName , string $tableName )

Gets the primary and foreign key column details for the given table.

Input
string | $schemaName | schema name
string | $tableName | table name.
Output
array | tuple ($primary, $foreign)
Exception

getDefaultSchema

public string getDefaultSchema ()

Output
string default schema.
Exception

getForeignKeys

protected array getForeignKeys (string $src )

Gets foreign relationship constraint keys and table name

Input
string | $src | Oracle foreign key definition
Output
array | foreign relationship table name and keys, null otherwise
Exception

getIsView

protected boolean getIsView (string $schemaName , string $tableName )

Input
string | $schemaName | table schema name
string | $tableName | table name.
Output
boolean | true if the table is a view.
Exception

getPrimaryKeys

protected array getPrimaryKeys (string $src )

Gets the primary key field names

Input
string | $src | Oracle primary key definition
Output
array | primary key field names.
Exception

getSchemaTableName

protected array getSchemaTableName (string $table )

Input
string | $table | table name with optional schema name prefix, uses default schema name prefix is not provided.
Output
array | tuple as ($schemaName,$tableName)
Exception

getSequenceName

protected string getSequenceName (mixed $tableInfo , mixed $src )

Input
mixed | $tableInfo
mixed | $src
Output
string | serial name if found, null otherwise.
Exception

getTableInfoClass

protected string getTableInfoClass ()

Output
string TDbTableInfo class name.
Exception

isForeignKeyColumn

protected boolean isForeignKeyColumn (string $columnId , TOracleTableInfo $tableInfo )

Input
string | $columnId | column name.
TOracleTableInfo | $tableInfo | table information.
Output
boolean | true if column is a foreign key.
Exception

isPrecisionType

protected boolean isPrecisionType (mixed $type )

Input
mixed | $type
Output
boolean | true if column type if "numeric", "interval" or begins with "time".
Exception

processColumn

protected void processColumn (TOracleTableInfo $tableInfo , array $col )

Input
TOracleTableInfo | $tableInfo | table information.
array | $col | column information.
Output
Exception

setDefaultSchema

public void setDefaultSchema (string $schema )

Input
string $schema default schema.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TOracleTableColumn

Class TOracleTableColumn (Class Overview)

TComponent
   |
   --TDbTableColumn
      |
      --TOracleTableColumn

Describes the column metadata of the schema for a PostgreSQL database table.

Since: 3.1
Author: Marcos Nobre <marconobre[at]gmail[dot]com>
Constants Inherited From TDbTableColumn
UNDEFINED_VALUE,
Method Summary
boolean
getPHPType ()
Overrides parent implementation, returns PHP type from the db type.
Methods Inherited From TDbTableColumn
TDbTableColumn::getAllowNull(), TDbTableColumn::getColumnId(), TDbTableColumn::getColumnIndex(), TDbTableColumn::getColumnName(), TDbTableColumn::getColumnSize(), TDbTableColumn::getDbType(), TDbTableColumn::getDefaultValue(), TDbTableColumn::getInfo(), TDbTableColumn::getIsExcluded(), TDbTableColumn::getIsForeignKey(), TDbTableColumn::getIsPrimaryKey(), TDbTableColumn::getMaxiumNumericConstraint(), TDbTableColumn::getNumericPrecision(), TDbTableColumn::getNumericScale(), TDbTableColumn::getPdoType(), TDbTableColumn::getPHPType(), TDbTableColumn::getSequenceName(), TDbTableColumn::hasSequence(), TDbTableColumn::setInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getPHPType

public boolean getPHPType ()

Overrides parent implementation, returns PHP type from the db type.

Output
boolean derived PHP primitive type from the column db type.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPgsqlMetaData

Class TPgsqlMetaData (Class Overview)

TComponent
   |
   --TDbMetaData
      |
      --TPgsqlMetaData

TPgsqlMetaData loads PostgreSQL database table and column information.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
protected string | assertIdentifier ( string $name)
protected TPgsqlTableInfo | createNewTableInfo ( string $schemaName, string $tableName)
protected TPgsqlTableInfo | createTableInfo ( string $table) Get the column definitions for given table.
protected array | getConstraintKeys ( string $schemaName, string $tableName) Gets the primary and foreign key column details for the given table.
string | getDefaultSchema ()
protected array | getForeignKeys ( string $src) Gets foreign relationship constraint keys and table name
protected boolean | getIsView ( string $schemaName, string $tableName)
protected array | getPrimaryKeys ( string $tableName, mixed $schemaName, mixed $columnIndex) Gets the primary key field names
protected array | getSchemaTableName ( string $table)
protected string | getSequenceName ( mixed $tableInfo, mixed $src)
protected string | getTableInfoClass ()
protected boolean | isForeignKeyColumn ( string $columnId, TPgsqlTableInfo $tableInfo)
protected boolean | isPrecisionType ( mixed $type)
protected void | processColumn ( TPgsqlTableInfo $tableInfo, array $col)
void | setDefaultSchema ( string $schema)
Methods Inherited From TDbMetaData
TDbMetaData::createCommandBuilder(), TDbMetaData::getDbConnection(), TDbMetaData::getInstance(), TDbMetaData::getTableInfo(), TDbMetaData::getTableInfoClass()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

assertIdentifier

protected string assertIdentifier (string $name )

Input
string | $name | table name, schema name or column name.
Output
string | a valid identifier.
Exception
throws | TDbException when table name contains a double quote (").

createNewTableInfo

protected TPgsqlTableInfo createNewTableInfo (string $schemaName , string $tableName )

Input
string | $schemaName | table schema name
string | $tableName | table name.
Output
Exception

createTableInfo

protected TPgsqlTableInfo createTableInfo (string $table )

Get the column definitions for given table.

Input
string | $table | table name.
Output
TPgsqlTableInfo | table information.
Exception

getConstraintKeys

protected array getConstraintKeys (string $schemaName , string $tableName )

Gets the primary and foreign key column details for the given table.

Input
string | $schemaName | schema name
string | $tableName | table name.
Output
array | tuple ($primary, $foreign)
Exception

getDefaultSchema

public string getDefaultSchema ()

Output
string default schema.
Exception

getForeignKeys

protected array getForeignKeys (string $src )

Gets foreign relationship constraint keys and table name

Input
string | $src | pgsql foreign key definition
Output
array | foreign relationship table name and keys, null otherwise
Exception

getIsView

protected boolean getIsView (string $schemaName , string $tableName )

Input
string | $schemaName | table schema name
string | $tableName | table name.
Output
boolean | true if the table is a view.
Exception

getPrimaryKeys

protected array getPrimaryKeys (string $tableName , mixed $schemaName , mixed $columnIndex )

Gets the primary key field names

Input
string | $tableName | pgsql primary key definition
mixed | $schemaName |
mixed | $columnIndex |
Output
array | primary key field names.
Exception

getSchemaTableName

protected array getSchemaTableName (string $table )

Input
string | $table | table name with optional schema name prefix, uses default schema name prefix is not provided.
Output
array | tuple as ($schemaName,$tableName)
Exception

getSequenceName

protected string getSequenceName (mixed $tableInfo , mixed $src )

Input
mixed | $tableInfo
mixed | $src
Output
string | serial name if found, null otherwise.
Exception

getTableInfoClass

protected string getTableInfoClass ()

Output
string TDbTableInfo class name.
Exception

isForeignKeyColumn

protected boolean isForeignKeyColumn (string $columnId , TPgsqlTableInfo $tableInfo )

Input
string | $columnId | column name.
TPgsqlTableInfo | $tableInfo | table information.
Output
boolean | true if column is a foreign key.
Exception

isPrecisionType

protected boolean isPrecisionType (mixed $type )

Input
mixed | $type
Output
boolean | true if column type if "numeric", "interval" or begins with "time".
Exception

processColumn

protected void processColumn (TPgsqlTableInfo $tableInfo , array $col )

Input
TPgsqlTableInfo | $tableInfo | table information.
array | $col | column information.
Output
Exception

setDefaultSchema

public void setDefaultSchema (string $schema )

Input
string $schema default schema.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPgsqlTableColumn

Class TPgsqlTableColumn (Class Overview)

TComponent
   |
   --TDbTableColumn
      |
      --TPgsqlTableColumn

Describes the column metadata of the schema for a PostgreSQL database table.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constants Inherited From TDbTableColumn
UNDEFINED_VALUE,
Method Summary
boolean
getPHPType ()
Overrides parent implementation, returns PHP type from the db type.
Methods Inherited From TDbTableColumn
TDbTableColumn::getAllowNull(), TDbTableColumn::getColumnId(), TDbTableColumn::getColumnIndex(), TDbTableColumn::getColumnName(), TDbTableColumn::getColumnSize(), TDbTableColumn::getDbType(), TDbTableColumn::getDefaultValue(), TDbTableColumn::getInfo(), TDbTableColumn::getIsExcluded(), TDbTableColumn::getIsForeignKey(), TDbTableColumn::getIsPrimaryKey(), TDbTableColumn::getMaxiumNumericConstraint(), TDbTableColumn::getNumericPrecision(), TDbTableColumn::getNumericScale(), TDbTableColumn::getPdoType(), TDbTableColumn::getPHPType(), TDbTableColumn::getSequenceName(), TDbTableColumn::hasSequence(), TDbTableColumn::setInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getPHPType

public boolean getPHPType ()

Overrides parent implementation, returns PHP type from the db type.

Output
boolean derived PHP primitive type from the column db type.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TPgsqlTableInfo

Class TPgsqlTableInfo (Class Overview)

TComponent
   |
   --TDbTableInfo
      |
      --TPgsqlTableInfo

TPgsqlTableInfo class provides additional table information for PostgreSQL database.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
TDbCommandBuilder | createCommandBuilder ( TDbConnection $connection)
string | getSchemaName ()
string | getTableFullName ()
Methods Inherited From TDbTableInfo
TDbTableInfo::createCommandBuilder(), TDbTableInfo::getColumn(), TDbTableInfo::getColumnNames(), TDbTableInfo::getColumns(), TDbTableInfo::getForeignKeys(), TDbTableInfo::getInfo(), TDbTableInfo::getIsView(), TDbTableInfo::getLowerCaseColumnNames(), TDbTableInfo::getPrimaryKeys(), TDbTableInfo::getTableFullName(), TDbTableInfo::getTableName(), TDbTableInfo::setInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createCommandBuilder

public TDbCommandBuilder createCommandBuilder (TDbConnection $connection )

Input
TDbConnection | $connection | database connection.
Output
TDbCommandBuilder | new command builder
Exception

getSchemaName

public string getSchemaName ()

Output
string name of the schema this column belongs to.
Exception

getTableFullName

public string getTableFullName ()

Output
string full name of the table, database dependent.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TScaffoldBase

Class TScaffoldBase (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TScaffoldBase

Direct Known Sub-classes:

TScaffoldEditView , TScaffoldListView , TScaffoldSearch , TScaffoldView

Base class for Active Record scaffold views.

Provides common properties for all scaffold views (such as, TScaffoldListView, TScaffoldEditView, TScaffoldListView and TScaffoldView).

During the OnPrRender stage the default css style file (filename style.css) is published and registered. To override the default style, provide your own stylesheet file explicitly.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constants Inherited From TTemplateControl
EXT_TEMPLATE,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
protected void | clearRecordObject () Unset the current record instance and table information.
protected void | copyFrom ( TScaffoldBase $obj) Copy the view details from another scaffold view instance.
string | getDefaultStyle ()
boolean | getEnableDefaultStyle ()
string | getRecordClass () Name of the Active Record class to be viewed or scaffolded.
protected TActiveRecord | getRecordFinder ()
protected TActiveRecord | getRecordObject ( array $pk) Gets the current Active Record instance. Creates new instance if the primary key value is null otherwise the record is fetched from the db.
protected array | getRecordPkValues ( TActiveRecord $record)
protected array | getRecordPropertyValues ( TActiveRecord $record)
protected TDbMetaData | getTableInfo ()
void | onPreRender ( mixed $param) Publish the default stylesheet file.
void | setDefaultStyle ( string $value)
void | setEnableDefaultStyle ( boolean $value)
void | setRecordClass ( string $value) Name of the Active Record class to be viewed or scaffolded.
protected void | setRecordObject ( TActiveRecord $value)
Methods Inherited From TTemplateControl
TTemplateControl::createChildControls(), TTemplateControl::getIsSourceTemplateControl(), TTemplateControl::getMaster(), TTemplateControl::getMasterClass(), TTemplateControl::getTemplate(), TTemplateControl::getTemplateDirectory(), TTemplateControl::initRecursive(), TTemplateControl::injectContent(), TTemplateControl::loadTemplate(), TTemplateControl::registerContent(), TTemplateControl::registerContentPlaceHolder(), TTemplateControl::setMasterClass(), TTemplateControl::setTemplate()
Methods Inherited From TCompositeControl
TCompositeControl::initRecursive()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

clearRecordObject

protected void clearRecordObject ()

Unset the current record instance and table information.

Output
Exception

copyFrom

protected void copyFrom (TScaffoldBase $obj )

Copy the view details from another scaffold view instance.

Input
TScaffoldBase $obj scaffold view.
Output
Exception

getDefaultStyle

public string getDefaultStyle ()

Output
string default scaffold stylesheet name
Exception

getEnableDefaultStyle

public boolean getEnableDefaultStyle ()

Output
boolean enable default stylesheet, default is true.
Exception

getRecordClass

public string getRecordClass ()

Name of the Active Record class to be viewed or scaffolded.

Output
string Active Record class name.
Exception

getRecordFinder

protected TActiveRecord getRecordFinder ()

Output
TActiveRecord Active Record finder instance
Exception

getRecordObject

protected TActiveRecord getRecordObject (array $pk )

Gets the current Active Record instance. Creates new instance if the primary key value is null otherwise the record is fetched from the db.

Input
array | $pk | primary key value
Output
TActiveRecord | record instance
Exception

getRecordPkValues

protected array getRecordPkValues (TActiveRecord $record )

Input
TActiveRecord | $record | record instance
Output
array | record primary key values.
Exception

getRecordPropertyValues

protected array getRecordPropertyValues (TActiveRecord $record )

Input
TActiveRecord | $record | record instance
Output
array | record property values
Exception

getTableInfo

protected TDbMetaData getTableInfo ()

Output
TDbMetaData table/view information
Exception

onPreRender

public void onPreRender (mixed $param )

Publish the default stylesheet file.

Input
mixed $param
Output
Exception

setDefaultStyle

public void setDefaultStyle (string $value )

Input
string $value default scaffold stylesheet name
Output
Exception

setEnableDefaultStyle

public void setEnableDefaultStyle (boolean $value )

Input
boolean $value enable default stylesheet, default is true.
Output
Exception

setRecordClass

public void setRecordClass (string $value )

Name of the Active Record class to be viewed or scaffolded.

Input
string $value Active Record class name.
Output
Exception

setRecordObject

protected void setRecordObject (TActiveRecord $value )

Input
TActiveRecord $value Active Record instance.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class IScaffoldEditRenderer

Interface IScaffoldEditRenderer (Class Overview)

IDataRenderer
   |
   --IScaffoldEditRenderer

IScaffoldEditRenderer interface.

IScaffoldEditRenderer defines the interface that an edit renderer needs to implement. Besides the Data property, an edit renderer also needs to provide updateRecord method that is called before the save() method is called on the TActiveRecord.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
void
updateRecord ( TActiveRecord $record)
This method should update the record with the user input data.
Methods Inherited From IDataRenderer
IDataRenderer::getData(), IDataRenderer::setData()
Method Details

updateRecord

public void updateRecord (TActiveRecord $record )

This method should update the record with the user input data.

Input
TActiveRecord $record record to be saved.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TScaffoldEditView

Class TScaffoldEditView (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TScaffoldBase
                  |
                  --TScaffoldEditView

Template control for editing an Active Record instance.

The RecordClass determines the Active Record class to be edited. A particular record can be edited by specifying the RecordPk value (may be an array for composite keys).

The default editor input controls are created based on the column types. The editor layout can be specified by a renderer by set the value of the EditRenderer property to the class name of a class that implements TScaffoldEditRenderer. A renderer is an external template control that implements IScaffoldEditRenderer.

The Data of the IScaffoldEditRenderer will be set as the current Active Record to be edited. The UpdateRecord() method of IScaffoldEditRenderer is called when request to save the record is requested.

Validators in the custom external editor template should have the TBaseValidator::setValidationGroup property set to the value of the getValidationGroup of the TScaffoldEditView instance (the edit view instance is the Parent of the IScaffoldEditRenderer in most cases.

Cosmetic changes to the default editor should be done using Cascading Stylesheets. For example, a particular field/property can be hidden by specifying "display:none" for the corresponding style (each field/property has unique Css class name as "property_xxx", where xxx is the property name).

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constants Inherited From TTemplateControl
EXT_TEMPLATE,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | bubbleEvent ( mixed $sender, mixed $param) Bubble the command name event. Stops bubbling when the page validator false.
protected void | createEditRenderer ( TActiveRecord $record, string $classPath) Instantiate the external edit renderer.
protected void | createRepeaterEditItem ( mixed $sender, mixed $param) Initialize the default editor using the scaffold input builder.
protected boolean | doSave () Check the validators, then tries to save the record.
TButton | getCancelButton ()
TButton | getClearButton ()
protected TActiveRecord | getCurrentRecord ()
string | getEditRenderer ()
protected TRepeater | getInputRepeater ()
array | getRecordPk ()
TButton | getSaveButton ()
protected TScaffoldInputBase | getScaffoldInputBuilder ( TActiveRecord $record) Create the default scaffold editor control factory.
string | getValidationGroup ()
void | initializeEditForm () Initialize the editor form
void | onLoad ( mixed $param) Initialize the editor form if it is Visible.
void | setEditRenderer ( string $value)
void | setRecordPk ( array $value)
Methods Inherited From TScaffoldBase
TScaffoldBase::clearRecordObject(), TScaffoldBase::copyFrom(), TScaffoldBase::getDefaultStyle(), TScaffoldBase::getEnableDefaultStyle(), TScaffoldBase::getRecordClass(), TScaffoldBase::getRecordFinder(), TScaffoldBase::getRecordObject(), TScaffoldBase::getRecordPkValues(), TScaffoldBase::getRecordPropertyValues(), TScaffoldBase::getTableInfo(), TScaffoldBase::onPreRender(), TScaffoldBase::setDefaultStyle(), TScaffoldBase::setEnableDefaultStyle(), TScaffoldBase::setRecordClass(), TScaffoldBase::setRecordObject()
Methods Inherited From TTemplateControl
TTemplateControl::createChildControls(), TTemplateControl::getIsSourceTemplateControl(), TTemplateControl::getMaster(), TTemplateControl::getMasterClass(), TTemplateControl::getTemplate(), TTemplateControl::getTemplateDirectory(), TTemplateControl::initRecursive(), TTemplateControl::injectContent(), TTemplateControl::loadTemplate(), TTemplateControl::registerContent(), TTemplateControl::registerContentPlaceHolder(), TTemplateControl::setMasterClass(), TTemplateControl::setTemplate()
Methods Inherited From TCompositeControl
TCompositeControl::initRecursive()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

bubbleEvent

public void bubbleEvent (mixed $sender , mixed $param )

Bubble the command name event. Stops bubbling when the page validator false.

Otherwise, the bubble event is continued.

Input
mixed | $sender
mixed | $param
Output
Exception

createEditRenderer

protected void createEditRenderer (TActiveRecord $record , string $classPath )

Instantiate the external edit renderer.

Input
TActiveRecord | $record | record to be edited
string | $classPath | external edit renderer class name.
Output
Exception
throws | TConfigurationException raised when renderer is not an instance of IScaffoldEditRenderer.

createRepeaterEditItem

protected void createRepeaterEditItem (mixed $sender , mixed $param )

Initialize the default editor using the scaffold input builder.

Input
mixed | $sender
mixed | $param
Output
Exception

doSave

protected boolean doSave ()

Check the validators, then tries to save the record.

Output
boolean true if the validators are true, false otherwise.
Exception

getCancelButton

public TButton getCancelButton ()

Output
TButton Button to cancel the edit action (e.g. hide the edit view).
Exception

getClearButton

public TButton getClearButton ()

Output
TButton Button to clear the editor inputs.
Exception

getCurrentRecord

protected TActiveRecord getCurrentRecord ()

Output
TActiveRecord current Active Record instance
Exception

getEditRenderer

public string getEditRenderer ()

Output
string the class name for scaffold editor. Defaults to empty, meaning not set.
Exception

getInputRepeater

protected TRepeater getInputRepeater ()

Output
TRepeater default editor input controls repeater
Exception

getRecordPk

public array getRecordPk ()

Output
array Active Record primary key value.
Exception

getSaveButton

public TButton getSaveButton ()

Output
TButton Button triggered to save the Active Record.
Exception

getScaffoldInputBuilder

protected TScaffoldInputBase getScaffoldInputBuilder (TActiveRecord $record )

Create the default scaffold editor control factory.

Input
TActiveRecord | $record | record instance.
Output
TScaffoldInputBase | scaffold editor control factory.
Exception

getValidationGroup

public string getValidationGroup ()

Output
string editor validation group name.
Exception

initializeEditForm

public void initializeEditForm ()

Initialize the editor form

Output
Exception

onLoad

public void onLoad (mixed $param )

Initialize the editor form if it is Visible.

Input
mixed $param
Output
Exception

setEditRenderer

public void setEditRenderer (string $value )

Input
string $value the class name for scaffold editor. Defaults to empty, meaning not set.
Output
Exception

setRecordPk

public void setRecordPk (array $value )

Input
array $value Active Record primary key value to be edited.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TScaffoldListView

Class TScaffoldListView (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TScaffoldBase
                  |
                  --TScaffoldListView

TScaffoldListView displays a list of Active Records.

The Header property is a TRepeater displaying the Active Record property/field names. The Sort property is a drop down list displaying the combination of properties and its possible ordering. The Pager property is a TPager control displaying the links and/or buttons that navigate to different pages in the Active Record data. The List property is a TRepeater that renders a row of Active Record data.

Custom rendering of the each Active Record can be achieved by specifying the ItemTemplate or AlternatingItemTemplate property of the main {@linnk getList List} repeater.

The TScaffoldListView will listen for two command events named "delete" and "edit". A "delete" command will delete a the record for the row where the "delete" command is originates. An "edit" command will push the record data to be edited by a TScaffoldEditView with ID specified by the EditViewID.

Additional SearchCondition and SearchParameters (takes array values) can be specified to customize the records to be shown. The SearchCondition will be used as the Condition property of TActiveRecordCriteria, and similarly the SearchParameters will be the corresponding Parameters property of TActiveRecordCriteria.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constants Inherited From TTemplateControl
EXT_TEMPLATE,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | bubbleEvent ( mixed $sender, mixed $param) Continue bubbling the "edit" command, "delete" command is handled in this class.
protected void | deleteRecord ( mixed $sender, mixed $param) Deletes an Active Record.
protected TScaffoldEditView | getEditViewControl ()
string | getEditViewID ()
TRepeater | getHeader ()
TRepeater | getList ()
TPager | getPager ()
protected TActiveRecordCriteria | getRecordCriteria ()
void | getSearchCondition ( string 0)
array | getSearchParameters ()
TDropDownList | getSort ()
protected void | initializeEdit ( mixed $sender, mixed $param) Initialize the edit view control form when EditViewID is set.
protected void | initializeSort () Initialize the sort drop down list and the column names repeater.
protected void | listItemCreated ( mixed $sender, mixed $param) Initialize the default display for each Active Record item.
protected void | loadRecordData () Fetch the records and data bind it to the list.
void | onPreRender ( mixed $param) Loads and display the data.
protected void | pageChanged ( mixed $sender, mixed $param) Updates repeater page index with the pager new index value.
protected void | populateField ( mixed $sender, mixed $param) Sets the Record primary key to the current repeater item's CustomData.
void | setEditViewID ( string $value)
void | setSearchCondition ( string $value)
void | setSearchParameters ( array $value)
Methods Inherited From TScaffoldBase
TScaffoldBase::clearRecordObject(), TScaffoldBase::copyFrom(), TScaffoldBase::getDefaultStyle(), TScaffoldBase::getEnableDefaultStyle(), TScaffoldBase::getRecordClass(), TScaffoldBase::getRecordFinder(), TScaffoldBase::getRecordObject(), TScaffoldBase::getRecordPkValues(), TScaffoldBase::getRecordPropertyValues(), TScaffoldBase::getTableInfo(), TScaffoldBase::onPreRender(), TScaffoldBase::setDefaultStyle(), TScaffoldBase::setEnableDefaultStyle(), TScaffoldBase::setRecordClass(), TScaffoldBase::setRecordObject()
Methods Inherited From TTemplateControl
TTemplateControl::createChildControls(), TTemplateControl::getIsSourceTemplateControl(), TTemplateControl::getMaster(), TTemplateControl::getMasterClass(), TTemplateControl::getTemplate(), TTemplateControl::getTemplateDirectory(), TTemplateControl::initRecursive(), TTemplateControl::injectContent(), TTemplateControl::loadTemplate(), TTemplateControl::registerContent(), TTemplateControl::registerContentPlaceHolder(), TTemplateControl::setMasterClass(), TTemplateControl::setTemplate()
Methods Inherited From TCompositeControl
TCompositeControl::initRecursive()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

bubbleEvent

public void bubbleEvent (mixed $sender , mixed $param )

Continue bubbling the "edit" command, "delete" command is handled in this class.

Input
mixed | $sender
mixed | $param
Output
Exception

deleteRecord

protected void deleteRecord (mixed $sender , mixed $param )

Deletes an Active Record.

Input
mixed | $sender
mixed | $param
Output
Exception

getEditViewControl

protected TScaffoldEditView getEditViewControl ()

Output
TScaffoldEditView control for editing selected Active Record, null if EditViewID is not set.
Exception

getEditViewID

public string getEditViewID ()

Output
string TScaffoldEditView control ID for editing selected Active Record.
Exception

getHeader

public TRepeater getHeader ()

Output
TRepeater Repeater control for record property names.
Exception

getList

public TRepeater getList ()

Output
TRepeater Repeater control for Active Record instances.
Exception

getPager

public TPager getPager ()

Output
TPager List pager control.
Exception

getRecordCriteria

protected TActiveRecordCriteria getRecordCriteria ()

Output
TActiveRecordCriteria sort/search/paging criteria
Exception

getSearchCondition

public void getSearchCondition (string 0 )

Input
string 0 SQL search condition for list display.
Output
Exception

getSearchParameters

public array getSearchParameters ()

Output
array search parameters
Exception

getSort

public TDropDownList getSort ()

Output
TDropDownList Control that displays and controls the record ordering.
Exception

initializeEdit

protected void initializeEdit (mixed $sender , mixed $param )

Initialize the edit view control form when EditViewID is set.

Input
mixed | $sender
mixed | $param
Output
Exception

initializeSort

protected void initializeSort ()

Initialize the sort drop down list and the column names repeater.

Output
Exception

listItemCreated

protected void listItemCreated (mixed $sender , mixed $param )

Initialize the default display for each Active Record item.

Input
mixed | $sender
mixed | $param
Output
Exception

loadRecordData

protected void loadRecordData ()

Fetch the records and data bind it to the list.

Output
Exception

onPreRender

public void onPreRender (mixed $param )

Loads and display the data.

Input
mixed $param
Output
Exception

pageChanged

protected void pageChanged (mixed $sender , mixed $param )

Updates repeater page index with the pager new index value.

Input
mixed | $sender
mixed | $param
Output
Exception

populateField

protected void populateField (mixed $sender , mixed $param )

Sets the Record primary key to the current repeater item's CustomData.

Binds the inner repeater with properties of the current Active Record.

Input
mixed | $sender
mixed | $param
Output
Exception

setEditViewID

public void setEditViewID (string $value )

Input
string $value TScaffoldEditView control ID for editing selected Active Record.
Output
Exception

setSearchCondition

public void setSearchCondition (string $value )

Input
string $value search condition, the SQL string after the WHERE clause.
Output
Exception

setSearchParameters

public void setSearchParameters (array $value )

Input
array $value search parameters
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TScaffoldSearch

Class TScaffoldSearch (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TScaffoldBase
                  |
                  --TScaffoldSearch

TScaffoldSearch provide a simple textbox and a button that is used to perform search on a TScaffoldListView with ID given by setListViewID.

The SearchText property is a TTextBox and the SearchButton property is a TButton with label value "Search".

Searchable fields of the Active Record can be restricted by specifying a comma delimited string of allowable fields in the SearchableFields property. The default is null, meaning that most text type fields are searched (the default searchable fields are database dependent).

Since: 3.1
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TTemplateControl
EXT_TEMPLATE,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | bubbleEvent ( mixed $sender, mixed $param) Sets the SearchCondition of the TScaffoldListView as the search terms given by the text of the search text box.
protected string | createSearchCondition ()
protected array | getFields ()
protected TScaffoldListView | getListView ()
string | getListViewID ()
string | getSearchableFields ()
TButton | getSearchButton ()
TTextBox | getSearchText ()
void | setListViewID ( string $value)
void | setSearchableFields ( string $value)
Methods Inherited From TScaffoldBase
TScaffoldBase::clearRecordObject(), TScaffoldBase::copyFrom(), TScaffoldBase::getDefaultStyle(), TScaffoldBase::getEnableDefaultStyle(), TScaffoldBase::getRecordClass(), TScaffoldBase::getRecordFinder(), TScaffoldBase::getRecordObject(), TScaffoldBase::getRecordPkValues(), TScaffoldBase::getRecordPropertyValues(), TScaffoldBase::getTableInfo(), TScaffoldBase::onPreRender(), TScaffoldBase::setDefaultStyle(), TScaffoldBase::setEnableDefaultStyle(), TScaffoldBase::setRecordClass(), TScaffoldBase::setRecordObject()
Methods Inherited From TTemplateControl
TTemplateControl::createChildControls(), TTemplateControl::getIsSourceTemplateControl(), TTemplateControl::getMaster(), TTemplateControl::getMasterClass(), TTemplateControl::getTemplate(), TTemplateControl::getTemplateDirectory(), TTemplateControl::initRecursive(), TTemplateControl::injectContent(), TTemplateControl::loadTemplate(), TTemplateControl::registerContent(), TTemplateControl::registerContentPlaceHolder(), TTemplateControl::setMasterClass(), TTemplateControl::setTemplate()
Methods Inherited From TCompositeControl
TCompositeControl::initRecursive()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

bubbleEvent

public void bubbleEvent (mixed $sender , mixed $param )

Sets the SearchCondition of the TScaffoldListView as the search terms given by the text of the search text box.

Input
mixed | $sender
mixed | $param
Output
Exception

createSearchCondition

protected string createSearchCondition ()

Output
string the search criteria for the search terms in the search text box.
Exception

getFields

protected array getFields ()

Output
array list of fields to be searched.
Exception

getListView

protected TScaffoldListView getListView ()

Output
TScaffoldListView the scaffold list view this search box belongs to.
Exception

getListViewID

public string getListViewID ()

Output
string ID of the TScaffoldListView this search control belongs to.
Exception

getSearchableFields

public string getSearchableFields ()

Output
string comma delimited list of fields that may be searched.
Exception

getSearchButton

public TButton getSearchButton ()

Output
TButton button with default label "Search".
Exception

getSearchText

public TTextBox getSearchText ()

Output
TTextBox search text box.
Exception

setListViewID

public void setListViewID (string $value )

Input
string $value ID of the TScaffoldListView this search control belongs to.
Output
Exception

setSearchableFields

public void setSearchableFields (string $value )

Input
string $value comma delimited list of fields that may be searched.
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TScaffoldView

Class TScaffoldView (Class Overview)

TComponent
   |
   --TApplicationComponent
      |
      --TControl
         |
         --TCompositeControl
            |
            --TTemplateControl
               |
               --TScaffoldBase
                  |
                  --TScaffoldView

TScaffoldView is a composite control consisting of TScaffoldListView

with a TScaffoldSearch. In addition, it will display a TScaffoldEditView when an "edit" command is raised from the TScaffoldListView (when the edit button is clicked). Futher more, the "add" button can be clicked that shows an empty data TScaffoldListView for creating new records.

The ListView property gives a TScaffoldListView for display the record data. The EditView is the TScaffoldEditView that renders the inputs for editing and adding records. The SearchControl is a TScaffoldSearch responsible to the search user interface.

Set the RecordClass property to the name of the Active Record class to be displayed/edited/added.

Since: 3.0
Author: Wei Zhuo <weizhuo[at]gmail[dot]com>
Constants Inherited From TTemplateControl
EXT_TEMPLATE,
Constants Inherited From TControl
AUTOMATIC_ID_PREFIX, CLIENT_ID_SEPARATOR, CS_CHILD_INITIALIZED, CS_CONSTRUCTED, CS_INITIALIZED, CS_LOADED, CS_PRERENDERED, CS_STATE_LOADED, ID_FORMAT, ID_SEPARATOR, IS_CHILD_CREATED, IS_CREATING_CHILD, IS_DISABLE_THEMING, IS_DISABLE_VIEWSTATE, IS_ID_SET, IS_SKIN_APPLIED, IS_STYLESHEET_APPLIED, RF_ADAPTER, RF_AUTO_BINDINGS, RF_CHILD_STATE, RF_CONTROLS, RF_CONTROLSTATE, RF_DATA_BINDINGS, RF_EVENTS, RF_NAMED_CONTROLS, RF_NAMED_CONTROLS_ID, RF_NAMED_OBJECTS, RF_SKIN_ID,
Method Summary
void | bubbleEvent ( mixed $sender, mixed $param) Handle the "edit" and "new" commands by displaying the edit view.
TButton | getAddButton ()
TScaffoldEditView | getEditView ()
TScaffoldListView | getListView ()
TScaffoldSearch | getSearchControl ()
void | onPreRender ( mixed $param) Copy basic record details to the list/edit/search controls.
protected void | showAddView ( mixed $sender, mixed $param) Shows the add record view.
protected void | showEditView ( mixed $sender, mixed $param) Shows the edit record view.
protected void | showListView ( mixed $sender, mixed $param) Shows the view for listing the records.
Methods Inherited From TScaffoldBase
TScaffoldBase::clearRecordObject(), TScaffoldBase::copyFrom(), TScaffoldBase::getDefaultStyle(), TScaffoldBase::getEnableDefaultStyle(), TScaffoldBase::getRecordClass(), TScaffoldBase::getRecordFinder(), TScaffoldBase::getRecordObject(), TScaffoldBase::getRecordPkValues(), TScaffoldBase::getRecordPropertyValues(), TScaffoldBase::getTableInfo(), TScaffoldBase::onPreRender(), TScaffoldBase::setDefaultStyle(), TScaffoldBase::setEnableDefaultStyle(), TScaffoldBase::setRecordClass(), TScaffoldBase::setRecordObject()
Methods Inherited From TTemplateControl
TTemplateControl::createChildControls(), TTemplateControl::getIsSourceTemplateControl(), TTemplateControl::getMaster(), TTemplateControl::getMasterClass(), TTemplateControl::getTemplate(), TTemplateControl::getTemplateDirectory(), TTemplateControl::initRecursive(), TTemplateControl::injectContent(), TTemplateControl::loadTemplate(), TTemplateControl::registerContent(), TTemplateControl::registerContentPlaceHolder(), TTemplateControl::setMasterClass(), TTemplateControl::setTemplate()
Methods Inherited From TCompositeControl
TCompositeControl::initRecursive()
Methods Inherited From TControl
TControl::addedControl(), TControl::addParsedObject(), TControl::addToPostDataLoader(), TControl::applyStyleSheetSkin(), TControl::autoBindProperty(), TControl::autoDataBindProperties(), TControl::bindProperty(), TControl::broadcastEvent(), TControl::bubbleEvent(), TControl::clearChildState(), TControl::clearControlState(), TControl::clearNamingContainer(), TControl::clearViewState(), TControl::convertUniqueIdToClientId(), TControl::createChildControls(), TControl::createControlCollection(), TControl::dataBind(), TControl::dataBindChildren(), TControl::dataBindProperties(), TControl::ensureChildControls(), TControl::findControl(), TControl::findControlsByID(), TControl::findControlsByType(), TControl::focus(), TControl::getAdapter(), TControl::getAllowChildControls(), TControl::getAttribute(), TControl::getAttributes(), TControl::getChildControlsCreated(), TControl::getClientID(), TControl::getControls(), TControl::getControlStage(), TControl::getControlState(), TControl::getCustomData(), TControl::getEnabled(), TControl::getEnableTheming(), TControl::getEnableViewState(), TControl::getHasAdapter(), TControl::getHasAttributes(), TControl::getHasChildInitialized(), TControl::getHasControls(), TControl::getHasInitialized(), TControl::getHasLoaded(), TControl::getHasLoadedPostData(), TControl::getHasPreRendered(), TControl::getID(), TControl::getNamingContainer(), TControl::getPage(), TControl::getParent(), TControl::getRegisteredObject(), TControl::getSkinID(), TControl::getSourceTemplateControl(), TControl::getTemplateControl(), TControl::getUniqueID(), TControl::getViewState(), TControl::getVisible(), TControl::hasAttribute(), TControl::initRecursive(), TControl::isDescendentOf(), TControl::isObjectRegistered(), TControl::loadRecursive(), TControl::loadState(), TControl::loadStateRecursive(), TControl::onDataBinding(), TControl::onInit(), TControl::onLoad(), TControl::onPreRender(), TControl::onUnload(), TControl::preRenderRecursive(), TControl::raiseBubbleEvent(), TControl::registerObject(), TControl::removeAttribute(), TControl::removedControl(), TControl::render(), TControl::renderChildren(), TControl::renderControl(), TControl::saveState(), TControl::saveStateRecursive(), TControl::setAdapter(), TControl::setAttribute(), TControl::setChildControlsCreated(), TControl::setControlStage(), TControl::setControlState(), TControl::setCustomData(), TControl::setEnabled(), TControl::setEnableTheming(), TControl::setEnableViewState(), TControl::setID(), TControl::setPage(), TControl::setSkinID(), TControl::setTemplateControl(), TControl::setViewState(), TControl::setVisible(), TControl::trackViewState(), TControl::traverseChildControls(), TControl::unbindProperty(), TControl::unloadRecursive(), TControl::unregisterObject(), TControl::__get()
Methods Inherited From TApplicationComponent
TApplicationComponent::getApplication(), TApplicationComponent::getRequest(), TApplicationComponent::getResponse(), TApplicationComponent::getService(), TApplicationComponent::getSession(), TApplicationComponent::getUser(), TApplicationComponent::publishAsset(), TApplicationComponent::publishFilePath()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

bubbleEvent

public void bubbleEvent (mixed $sender , mixed $param )

Handle the "edit" and "new" commands by displaying the edit view.

Default command shows the list view.

Input
mixed | $sender
mixed | $param
Output
Exception

getAddButton

public TButton getAddButton ()

Output
TButton "Add new record" button.
Exception

getEditView

public TScaffoldEditView getEditView ()

Output
TScaffoldEditView scaffold edit view.
Exception

getListView

public TScaffoldListView getListView ()

Output
TScaffoldListView scaffold list view.
Exception

getSearchControl

public TScaffoldSearch getSearchControl ()

Output
TScaffoldSearch scaffold search textbox and button.
Exception

onPreRender

public void onPreRender (mixed $param )

Copy basic record details to the list/edit/search controls.

Input
mixed $param
Output
Exception

showAddView

protected void showAddView (mixed $sender , mixed $param )

Shows the add record view.

Input
mixed | $sender
mixed | $param
Output
Exception

showEditView

protected void showEditView (mixed $sender , mixed $param )

Shows the edit record view.

Input
mixed | $sender
mixed | $param
Output
Exception

showListView

protected void showListView (mixed $sender , mixed $param )

Shows the view for listing the records.

Input
mixed | $sender
mixed | $param
Output
Exception
Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqliteTableColumn

Class TSqliteTableColumn (Class Overview)

TComponent
   |
   --TDbTableColumn
      |
      --TSqliteTableColumn

Describes the column metadata of the schema for a PostgreSQL database table.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Constants Inherited From TDbTableColumn
UNDEFINED_VALUE,
Method Summary
boolean | getAutoIncrement ()
boolean | getPHPType () Overrides parent implementation, returns PHP type from the db type.
boolean | hasSequence ()
Methods Inherited From TDbTableColumn
TDbTableColumn::getAllowNull(), TDbTableColumn::getColumnId(), TDbTableColumn::getColumnIndex(), TDbTableColumn::getColumnName(), TDbTableColumn::getColumnSize(), TDbTableColumn::getDbType(), TDbTableColumn::getDefaultValue(), TDbTableColumn::getInfo(), TDbTableColumn::getIsExcluded(), TDbTableColumn::getIsForeignKey(), TDbTableColumn::getIsPrimaryKey(), TDbTableColumn::getMaxiumNumericConstraint(), TDbTableColumn::getNumericPrecision(), TDbTableColumn::getNumericScale(), TDbTableColumn::getPdoType(), TDbTableColumn::getPHPType(), TDbTableColumn::getSequenceName(), TDbTableColumn::hasSequence(), TDbTableColumn::setInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constant Summary
Method Details

getAutoIncrement

public boolean getAutoIncrement ()

Output
boolean true if column will auto-increment when the column value is inserted as null.
Exception

getPHPType

public boolean getPHPType ()

Overrides parent implementation, returns PHP type from the db type.

Output
boolean derived PHP primitive type from the column db type.
Exception

hasSequence

public boolean hasSequence ()

Output
boolean true if auto increment is true.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TSqliteTableInfo

Class TSqliteTableInfo (Class Overview)

TComponent
   |
   --TDbTableInfo
      |
      --TSqliteTableInfo

TSqliteTableInfo class provides additional table information for PostgreSQL database.

Since: 3.1
Author: Wei Zhuo <weizho[at]gmail[dot]com>
Method Summary
TDbCommandBuilder | createCommandBuilder ( TDbConnection $connection)
string | getTableFullName ()
Methods Inherited From TDbTableInfo
TDbTableInfo::createCommandBuilder(), TDbTableInfo::getColumn(), TDbTableInfo::getColumnNames(), TDbTableInfo::getColumns(), TDbTableInfo::getForeignKeys(), TDbTableInfo::getInfo(), TDbTableInfo::getIsView(), TDbTableInfo::getLowerCaseColumnNames(), TDbTableInfo::getPrimaryKeys(), TDbTableInfo::getTableFullName(), TDbTableInfo::getTableName(), TDbTableInfo::setInfo()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

createCommandBuilder

public TDbCommandBuilder createCommandBuilder (TDbConnection $connection )

Input
TDbConnection | $connection | database connection.
Output
TDbCommandBuilder | new command builder
Exception

getTableFullName

public string getTableFullName ()

Output
string full name of the table, database dependent.
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTarFileExtractor

Class TTarFileExtractor (Class Overview)

TTarFileExtractor class

            Since:
            3.0

            Author:
            Vincent Blavet <vincent@phpconcept.net>

                    Constructor Summary

                    public

                            __construct
                            Array

                            Archive_Tar Class constructor. This flavour of the constructor only  declare a new Archive_Tar object, identifying it by the name of the  tar file.

Method Summary
void | extract ( mixed $p_path)
protected boolean | extractModify ( string $p_path, string $p_remove_path) This method extract all the content of the archive in the directory indicated by $p_path. When relevant the memorized path of the files/dir can be modified by removing the $p_remove_path path at the beginning of the file/dir path.
protected bool | _dirCheck ( string $p_dir) Check if a directory exists and create it (including parent dirs) if not.
protected void | _error ( mixed $p_message)
protected void | _extractList ( mixed $p_path, mixed &$p_list_detail, mixed $p_mode, mixed $p_file_list, mixed $p_remove_path)
protected void | _translateWinPath ( mixed $p_path, mixed $p_remove_disk_letter)

                    Constructor Details

__construct

                                public __construct
                                Array

Archive_Tar Class constructor. This flavour of the constructor only  declare a new Archive_Tar object, identifying it by the name of the  tar file.

            Method Details

extract

                                public void extract
                                (mixed $p_path )

Input

mixed $p_path

Output

Exception

extractModify

                                protected boolean extractModify
                                (string $p_path , string $p_remove_path )

This method extract all the content of the archive in the directory  indicated by $p_path. When relevant the memorized path of the  files/dir can be modified by removing the $p_remove_path path at the  beginning of the file/dir path.

While extracting a file, if the directory path does not exists it is  created.  While extracting a file, if the file already exists it is replaced  without looking for last modification date.  While extracting a file, if the file already exists and is write  protected, the extraction is aborted.  While extracting a file, if a directory with the same name already  exists, the extraction is aborted.  While extracting a directory, if a file with the same name already  exists, the extraction is aborted.  While extracting a file/directory if the destination directory exist  and is write protected, or does not exist but can not be created,  the extraction is aborted.  If after extraction an extracted file does not show the correct  stored file size, the extraction is aborted.  When the extraction is aborted, a PEAR error text is set and false  is returned. However the result can be a partial extraction that may  need to be manually cleaned.

Input
string | $p_path | The path of the directory where the files/dir need to by extracted.
string | $p_remove_path | Part of the memorized path that can be removed if present at the beginning of the file/dir path.
Output
boolean | true on success, false on error.
Exception

_dirCheck

                                protected bool _dirCheck
                                (string $p_dir )

Check if a directory exists and create it (including parent  dirs) if not.

Input
string | $p_dir | directory to check
Output
bool | true if the directory exists or was created
Exception

_error

                                protected void _error
                                (mixed $p_message )

Input

mixed $p_message

Output

Exception

_extractList

                                protected void _extractList
                                (mixed $p_path , mixed &$p_list_detail , mixed $p_mode , mixed $p_file_list , mixed $p_remove_path )

Input
mixed | $p_path
mixed | &$p_list_detail
mixed | $p_mode
mixed | $p_file_list
mixed | $p_remove_path
Output
Exception

_translateWinPath

                                protected void _translateWinPath
                                (mixed $p_path , mixed $p_remove_disk_letter )

Input
mixed | $p_path
mixed | $p_remove_disk_letter
Output
Exception

  Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TTextWriter

Class TTextWriter (Class Overview)

TComponent
   |
   --TTextWriter

Direct Known Sub-classes:

TCallbackResponseWriter

TTextWriter class.

TTextWriter implements a memory-based text writer. Content written by TTextWriter are stored in memory and can be obtained by calling flush().

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Method Summary
string | flush () Flushes the content that has been written.
void | write ( string $str) Writes a string.
void | writeLine ( string $str) Writers a string and terminates it with a newline.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Method Details

flush

public string flush ()

Flushes the content that has been written.

Output
string the content being flushed
Exception

write

public void write (string $str )

Writes a string.

Input
string $str string to be written
Output
Exception

writeLine

public void writeLine (string $str )

Writers a string and terminates it with a newline.

Input
string $str content to be written
Output
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TXmlDocument

Class TXmlDocument (Class Overview)

TComponent
   |
   --TXmlElement
      |
      --TXmlDocument

TXmlDocument class.

TXmlDocument represents a DOM representation of an XML file. Besides all properties and methods inherited from TXmlElement, you can load an XML file or string by loadFromFile or loadFromString. You can also get the version and encoding of the XML document by the Version and Encoding properties.

To construct an XML string, you may do the following:

1      $doc=new TXmlDocument('1.0','utf-8');
2      $doc->TagName='Root';
3
4      $proc=new TXmlElement('Proc');
5      $proc->setAttribute('Name','xxxx');
6      $doc->Elements[]=$proc;
7
8      $query=new TXmlElement('Query');
9      $query->setAttribute('ID','xxxx');
10     $proc->Elements[]=$query;
11
12     $attr=new TXmlElement('Attr');
13     $attr->setAttribute('Name','aaa');
14     $attr->Value='1';
15     $query->Elements[]=$attr;
16
17     $attr=new TXmlElement('Attr');
18     $attr->setAttribute('Name','bbb');
19     $attr->Value='1';
20     $query->Elements[]=$attr;
The above code represents the following XML string:

1      <?xml version="1.0" encoding="utf-8"?>
2      <Root>
3        <Proc Name="xxxx">
4          <Query ID="xxxx">
5            <Attr Name="aaa">1</Attr>
6            <Attr Name="bbb">1</Attr>
7          </Query>
8        </Proc>
9      </Root>

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
string | getEncoding ()
string | getVersion ()
boolean | loadFromFile ( string $file) Loads and parses an XML document.
boolean | loadFromString ( string $string) Loads and parses an XML string.
void | saveToFile ( string $file) Saves this XML document as an XML file.
string | saveToString () Saves this XML document as an XML string
void | setEncoding ( string $encoding)
void | setVersion ( string $version)
string | __toString () Magic-method override. Called whenever this document is used as a string.
Methods Inherited From TXmlElement
TXmlElement::getAttribute(), TXmlElement::getAttributes(), TXmlElement::getElementByTagName(), TXmlElement::getElements(), TXmlElement::getElementsByTagName(), TXmlElement::getHasAttribute(), TXmlElement::getHasElement(), TXmlElement::getParent(), TXmlElement::getTagName(), TXmlElement::getValue(), TXmlElement::setAttribute(), TXmlElement::setParent(), TXmlElement::setTagName(), TXmlElement::setValue(), TXmlElement::toString(), TXmlElement::__toString()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getEncoding

public string getEncoding ()

Output
string encoding of this XML document
Exception

getVersion

public string getVersion ()

Output
string version of this XML document
Exception

loadFromFile

public boolean loadFromFile (string $file )

Loads and parses an XML document.

Input
string | $file | the XML file path
Output
boolean | whether the XML file is parsed successfully
Exception
throws | TIOException if the file fails to be opened.

loadFromString

public boolean loadFromString (string $string )

Loads and parses an XML string.

The version and encoding will be determined based on the parsing result.

Input
string | $string | the XML string
Output
boolean | whether the XML string is parsed successfully
Exception

saveToFile

public void saveToFile (string $file )

Saves this XML document as an XML file.

Input
string | $file | the name of the file to be stored with XML output
Output
Exception
throws | TIOException if the file cannot be written

saveToString

public string saveToString ()

Saves this XML document as an XML string

Output
string the XML string of this XML document
Exception

setEncoding

public void setEncoding (string $encoding )

Input
string $encoding encoding of this XML document
Output
Exception

setVersion

public void setVersion (string $version )

Input
string $version version of this XML document
Output
Exception

__toString

public string __toString ()

Magic-method override. Called whenever this document is used as a string.

1      $document = new TXmlDocument();
2      $document->TagName = 'root';
3      echo $document;
or

1      $document = new TXmlDocument();
2      $document->TagName = 'root';
3      $xml = (string)$document;

Output
string string representation of this document
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TXmlElement

Class TXmlElement (Class Overview)

TComponent
   |
   --TXmlElement

Direct Known Sub-classes:

TXmlDocument

TXmlElement class.

TXmlElement represents an XML element node. You can obtain its tag-name, attributes, text between the opening and closing tags via the TagName, Attributes, and Value properties, respectively. You can also retrieve its parent and child elements by Parent and Elements properties, respectively.

TBD: xpath

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
string | getAttribute ( mixed $name)
TMap | getAttributes ()
TXmlElement | getElementByTagName ( mixed $tagName)
TXmlElementList | getElements ()
TList | getElementsByTagName ( mixed $tagName)
boolean | getHasAttribute ()
boolean | getHasElement ()
TXmlElement | getParent ()
string | getTagName ()
string | getValue ()
void | setAttribute ( string $name, string $value)
void | setParent ( TXmlElement $parent)
void | setTagName ( string $tagName)
void | setValue ( string $value)
string | toString ( mixed $indent)
string | __toString () Magic-method override. Called whenever this element is used as a string.
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getAttribute

public string getAttribute (mixed $name )

Input
mixed | $name
Output
string | the attribute specified by the name, null if no such attribute
Exception

getAttributes

public TMap getAttributes ()

Output
TMap list of attributes
Exception

getElementByTagName

public TXmlElement getElementByTagName (mixed $tagName )

Input
mixed | $tagName
Output
TXmlElement | the first child element that has the specified tag-name, null if not found
Exception

getElements

public TXmlElementList getElements ()

Output
TXmlElementList list of child elements
Exception

getElementsByTagName

public TList getElementsByTagName (mixed $tagName )

Input
mixed | $tagName
Output
TList | list of all child elements that have the specified tag-name
Exception

getHasAttribute

public boolean getHasAttribute ()

Output
boolean true if this element has attributes
Exception

getHasElement

public boolean getHasElement ()

Output
boolean true if this element has child elements
Exception

getParent

public TXmlElement getParent ()

Output
TXmlElement parent element of this element
Exception

getTagName

public string getTagName ()

Output
string tag-name of this element
Exception

getValue

public string getValue ()

Output
string text enclosed between opening and closing tag of this element
Exception

setAttribute

public void setAttribute (string $name , string $value )

Input
string | $name | attribute name
string | $value | attribute value
Output
Exception

setParent

public void setParent (TXmlElement $parent )

Input
TXmlElement $parent parent element of this element
Output
Exception

setTagName

public void setTagName (string $tagName )

Input
string $tagName tag-name of this element
Output
Exception

setValue

public void setValue (string $value )

Input
string $value text enclosed between opening and closing tag of this element
Output
Exception

toString

public string toString (mixed $indent )

Input
mixed | $indent
Output
string | string representation of this element
Exception

__toString

public string __toString ()

Magic-method override. Called whenever this element is used as a string.

1      $element = new TXmlElement('tag');
2      echo $element;
or

1      $element = new TXmlElement('tag');
2      $xml = (string)$element;

Output
string string representation of this element
Exception

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs For Class TXmlElementList

Class TXmlElementList (Class Overview)

TComponent
   |
   --TList
      |
      --TXmlElementList

TXmlElementList class.

TXmlElementList represents a collection of TXmlElement. You may manipulate the collection with the operations defined in TList.

Since: 3.0
Author: Qiang Xue <qiang.xue@gmail.com>
Constructor Summary
public
__construct Array
Constructor.
Method Summary
protected TXmlElement | getOwner ()
void | insertAt ( integer $index, mixed $item) Inserts an item at the specified position.
mixed | removeAt ( integer $index) Removes an item at the specified position.
Methods Inherited From TList
TList::add(), TList::clear(), TList::contains(), TList::copyFrom(), TList::count(), TList::getCount(), TList::getIterator(), TList::getReadOnly(), TList::indexOf(), TList::insertAt(), TList::itemAt(), TList::mergeWith(), TList::offsetExists(), TList::offsetGet(), TList::offsetSet(), TList::offsetUnset(), TList::remove(), TList::removeAt(), TList::setReadOnly(), TList::toArray()
Methods Inherited From TComponent
TComponent::addParsedObject(), TComponent::attachEventHandler(), TComponent::canGetProperty(), TComponent::canSetProperty(), TComponent::createdOnTemplate(), TComponent::detachEventHandler(), TComponent::evaluateExpression(), TComponent::evaluateStatements(), TComponent::getEventHandlers(), TComponent::getSubProperty(), TComponent::hasEvent(), TComponent::hasEventHandler(), TComponent::hasProperty(), TComponent::raiseEvent(), TComponent::setSubProperty(), TComponent::__get(), TComponent::__set()
Constructor Details

__construct

public __construct Array

Constructor.
Method Details

getOwner

protected TXmlElement getOwner ()

Output
TXmlElement owner of this list
Exception

insertAt

public void insertAt (integer $index , mixed $item )

Inserts an item at the specified position.

This overrides the parent implementation by performing additional operations for each newly added TXmlElement object.

Input
integer | $index | the specified position.
mixed | $item | new item
Output
Exception
throws | TInvalidDataTypeException if the item to be inserted is not a TXmlElement object.

removeAt

public mixed removeAt (integer $index )

Removes an item at the specified position.

This overrides the parent implementation by performing additional cleanup work when removing a TXmlElement object.

Input
integer | $index | the index of the item to be removed.
Output
mixed | the removed item.
Exception
Copyright © 2006 by Prado Software Group.


PRADO - Documentation of Prado

Namespace: System
Inheritance: PradoBase »
Prado
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | autoload | Class autoload loader. (inherited from PradoBase)
S | createComponent | Creates a component with the specified type. (inherited from PradoBase)
S | exceptionHandler | Default exception handler. (inherited from PradoBase)
S | fatalError | Fatal error handler. (inherited from PradoBase)
S | getApplication | the application singleton, null if the singleton has not be created yet. (inherited from PradoBase)
S | getFrameworkPath | the path of the framework. (inherited from PradoBase)
S | getLogger | message logger. (inherited from PradoBase)
SP | getPathAliases | . (inherited from PradoBase)
S | getPathOfAlias | the path corresponding to the alias, null if alias not defined. (inherited from PradoBase)
S | getPathOfNamespace | Translates a namespace into a file path. (inherited from PradoBase)
S | getPreferredLanguage | Returns the most preferred language by the client user. (inherited from PradoBase)
S | getUserLanguages | Returns a list of user preferred languages. (inherited from PradoBase)
S | getVersion | the version of Prado framework. (inherited from PradoBase)
S | initErrorHandlers | Initializes error handlers. (inherited from PradoBase)
S | localize | Localize a text to the locale/culture specified in the globalization handler. (inherited from PradoBase)
S | log | Logs a message. (inherited from PradoBase)
S | phpErrorHandler | PHP error handler. (inherited from PradoBase)
S | poweredByPrado | a string that can be displayed on your Web page showing powered-by-PRADO information. (inherited from PradoBase)
S | serialize | Serializes a data. (inherited from PradoBase)
S | setApplication | Stores the application instance in the class static member. (inherited from PradoBase)
S | setPathOfAlias | . (inherited from PradoBase)
S | trace | Writes a log message. (inherited from PradoBase)
S | unserialize | Unserializes a data. (inherited from PradoBase)
S | using | Uses a namespace. (inherited from PradoBase)
S | varDump | Converts a variable into a string representation. (inherited from PradoBase)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of PradoBase

Namespace: System
PradoBase
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | autoload | Class autoload loader.
S | createComponent | Creates a component with the specified type.
S | exceptionHandler | Default exception handler.
S | fatalError | Fatal error handler.
S | getApplication | the application singleton, null if the singleton has not be created yet.
S | getFrameworkPath | the path of the framework.
S | getLogger | message logger.
SP | getPathAliases | .
S | getPathOfAlias | the path corresponding to the alias, null if alias not defined.
S | getPathOfNamespace | Translates a namespace into a file path.
S | getPreferredLanguage | Returns the most preferred language by the client user.
S | getUserLanguages | Returns a list of user preferred languages.
S | getVersion | the version of Prado framework.
S | initErrorHandlers | Initializes error handlers.
S | localize | Localize a text to the locale/culture specified in the globalization handler.
S | log | Logs a message.
S | phpErrorHandler | PHP error handler.
S | poweredByPrado | a string that can be displayed on your Web page showing powered-by-PRADO information.
S | serialize | Serializes a data.
S | setApplication | Stores the application instance in the class static member.
S | setPathOfAlias | .
S | trace | Writes a log message.
S | unserialize | Unserializes a data.
S | using | Uses a namespace.
S | varDump | Converts a variable into a string representation.
Derived classes
  • Prado
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAPCCache

Namespace: System.Caching
Inheritance: TComponent » TApplicationComponent » TModule » TCache »
TAPCCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
 | KeyPrefix | string | a unique prefix for the keys of cached values. (inherited from TCache)
 | PrimaryCache | boolean | whether this cache module is used as primary/system cache. (inherited from TCache)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | add | Stores a value identified by a key into cache if the cache does not contain this key. (inherited from TCache)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addValue | Stores a value identified by a key into cache if the cache does not contain this key.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes a value with the specified key from cache . (inherited from TCache)
P | deleteValue | Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Deletes all values from cache.
P | generateUniqueKey | a key generated from the provided key which ensures the uniqueness across applications. (inherited from TCache)
 | get | Retrieves a value from cache with a specified key. (inherited from TCache)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValue | Retrieves a value from cache with a specified key.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | offsetExists | Returns whether there is a cache entry with a specified key. (inherited from TCache)
 | offsetGet | . (inherited from TCache)
 | offsetSet | . (inherited from TCache)
 | offsetUnset | . (inherited from TCache)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | set | Stores a value identified by a key into cache. (inherited from TCache)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setValue | Stores a value identified by a key in cache.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveButton

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TButton »
TActiveButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | ButtonType | TButtonType | the type of the button. (inherited from TButton)
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation, default is true. (inherited from TButton)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveButton.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
 | CommandName | string | the command name associated with the OnCommand event. (inherited from TButton)
 | CommandParameter | string | the parameter associated with the OnCommand event. (inherited from TButton)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the caption of the button. (inherited from TButton)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TButton)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsDefaultButton | boolean | true if this button is registered as a default button for a panel. (inherited from TButton)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the button. (inherited from TButton)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button. (inherited from TButton)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | caption of the button. (inherited from TButton)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback. (inherited from TButton)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnClick | This method is invoked when the button is clicked. (inherited from TButton)
OnCommand | This method is invoked when the button is clicked. (inherited from TButton)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | canCauseValidation | whether to perform validation if the button is clicked. (inherited from TButton)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | needPostBackScript | whether the button needs javascript to do postback. (inherited from TButton)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event. (inherited from TButton)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TButton)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveCheckBox

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TCheckBox »
TActiveCheckBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | whether clicking on the checkbox will post the page. (inherited from TCheckBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event triggered by this checkbox will cause input validation, default is true. (inherited from TCheckBox)
 | Checked | boolean | whether the checkbox is checked. (inherited from TCheckBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveCheckBox.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | boolean | Returns the value indicating whether the checkbox is checked. (inherited from TCheckBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBox)
RP | DefaultLabelID | string | checkbox label ID;.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TCheckBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | InputAttributes | TMap | list of attributes to be rendered for the checkbox. (inherited from TCheckBox)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBox)
R | LabelAttributes | TMap | Overrides parent implementation to ensure label has ID.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox. (inherited from TCheckBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | bool | Check if we need a span tag to surround this control. (inherited from TCheckBox)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | SurroundingTagID | string | the id of the surrounding tag or this clientID if no such tag needed. (inherited from TCheckBox)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button. (inherited from TCheckBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the checkbox. (inherited from TCheckBox)
 | TextAlign | TTextAlign | the alignment (Left or Right) of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the checkbox causes validation upon postback. (inherited from TCheckBox)
R | ValidationPropertyValue | mixed | Returns the value of the property that needs validation. (inherited from TCheckBox)
 | Value | string | the value of the checkbox. (inherited from TCheckBox)
RP | ValueAttribute | string | the value attribute to be rendered. (inherited from TCheckBox)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnCheckedChanged | Raises OnCheckedChanged event when Checked changes value during postback. (inherited from TCheckBox)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the checkbox to receive postback data during postback. (inherited from TCheckBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TCheckBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox control. (inherited from TCheckBox)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderInputTag | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
P | renderLabel | Renders a label beside the checkbox.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveCheckBoxList

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TCheckBoxList »
TActiveCheckBoxList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
 | CellPadding | integer | the cellpadding for the table keeping the checkbox list. (inherited from TCheckBoxList)
 | CellSpacing | integer | the cellspacing for the table keeping the checkbox list. (inherited from TCheckBoxList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control. (inherited from TCheckBoxList)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBoxList)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item. (inherited from TCheckBoxList)
R | HasHeader | boolean | Returns a value indicating whether this control contains header item. (inherited from TCheckBoxList)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items. (inherited from TCheckBoxList)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control supports multiple selection. (inherited from TCheckBoxList)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBoxList)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox. (inherited from TCheckBoxList)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
 | RepeatColumns | integer | the number of columns that the list should be displayed with. (inherited from TCheckBoxList)
 | RepeatDirection | string | the direction of traversing the list, defaults to 'Vertical'. (inherited from TCheckBoxList)
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers). (inherited from TCheckBoxList)
 | RepeatLayout | string | how the list should be displayed, using table or using line breaks. (inherited from TCheckBoxList)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | boolean | Wether the list should be rendered inside a span or not . (inherited from TCheckBoxList)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | TextAlign | TTextAlign | the alignment of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBoxList)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TCheckBoxList)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers for post data on postback. (inherited from TCheckBoxList)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TListControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createRepeatedControl | Creates a control used for repetition (used as a template).
P | createStyle | Creates a style object for the control. (inherited from TCheckBoxList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID. (inherited from TCheckBoxList)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | generateItemStyle | Returns a style used for rendering items. (inherited from TCheckBoxList)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TCheckBoxList)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBoxList)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox list control. (inherited from TCheckBoxList)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list. (inherited from TCheckBoxList)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveControlAdapter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControlAdapter »
TActiveControlAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | BaseActiveControl | TBaseActiveControl | Common active control options.
R | Control | TControl | the control to which this adapter is attached. (inherited from TControlAdapter)
RP | IsTrackingPageState | boolean | true if the viewstate needs to be tracked.
R | Page | TPage | the page that contains the attached control. (inherited from TControlAdapter)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | StateTracker | TCallbackPageStateTracker | state tracker.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Name | Description
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControlAdapter)
OnLoad | Starts viewstate tracking if necessary after when controls has been loaded.
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControlAdapter)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControlAdapter)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createChildControls | Creates child controls for the attached control. (inherited from TControlAdapter)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | loadState | Loads additional persistent control state. (inherited from TControlAdapter)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | render | Renders the callback client scripts.
P | renderCallbackClientScripts | Register the callback clientscripts and sets the post loader IDs.
 | renderChildren | Renders the control's children. (inherited from TControlAdapter)
 | saveState | Saves additional persistent control state.
P | setBaseControlClass | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TActiveListControlAdapter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveCustomValidator

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator » TCustomValidator »
TActiveCustomValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this this.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TCallbackClientSide | client side request options.
 | ClientValidationFunction | string | the name of the custom client-side script function used for validation. (inherited from TCustomValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsCallback | boolean | true if validation is made during a callback request.
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TCustomValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnServerValidate | This method is invoked when the server side validation happens. (inherited from TCustomValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateIsValid | This method overrides the parent's implementation. (inherited from TCustomValidator)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Only register the client-side validator if ClientValidationFunction is set. (inherited from TCustomValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveCustomValidatorClientSide

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TClientSideOptions » TCallbackClientSide »
TActiveCustomValidatorClientSide
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | EnablePageStateUpdate | boolean | client-side viewstate will be updated on callback response if true. (inherited from TCallbackClientSide)
 | HasPriority | boolean | true if the callback request has priority and will abort existing prioritized request in order to send immediately. (inherited from TCallbackClientSide)
 | ObserveChanges | boolean | true to observe changes.
 | OnComplete | string | javascript code for client-side onComplete event. (inherited from TCallbackClientSide)
 | OnException | string | javascript code for client-side onException event. (inherited from TCallbackClientSide)
 | OnFailure | string | javascript code for client-side onFailure event. (inherited from TCallbackClientSide)
 | OnInteractive | string | javascript code for client-side onInteractive event. (inherited from TCallbackClientSide)
 | OnLoaded | string | javascript code for client-side onLoaded event. (inherited from TCallbackClientSide)
 | OnLoading | string | javascript code for client-side onLoading event. (inherited from TCallbackClientSide)
 | OnPreDispatch | string | javascript code to be executed before a request is dispatched. (inherited from TCallbackClientSide)
 | OnSuccess | string | javascript code for client-side onSuccess event. (inherited from TCallbackClientSide)
 | OnUninitialized | string | javascript code for client-side onUninitialized event. (inherited from TCallbackClientSide)
 | OnValidate | string | javascript code for client-side OnValidate event.
 | OnValidationError | string | javascript code for client-side OnError event.
 | OnValidationSuccess | string | javascript code for client-side OnSuccess event.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
 | PostBackParameter | string | post back event parameter. (inherited from TCallbackClientSide)
 | PostBackTarget | string | post back target ID. (inherited from TCallbackClientSide)
 | PostState | boolean | true to post the inputs of the form on callback, default is post the inputs on callback. (inherited from TCallbackClientSide)
 | RequestTimeOut | integer | callback request timeout. (inherited from TCallbackClientSide)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Returns javascript statement enclosed within a javascript function. (inherited from TCallbackClientSide)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveDatePicker

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox » TDatePicker »
TActiveDatePicker
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
RP | AssetUrl | string | date picker asset url. (inherited from TDatePicker)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. (inherited from TTextBox)
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | ButtonImageUrl | string | the image url for "Image" UI mode. (inherited from TDatePicker)
 | ButtonText | string | text for the date picker button. (inherited from TDatePicker)
 | CalendarStyle | string | current calendar style. (inherited from TDatePicker)
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control. (inherited from TTextBox)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TDatePickerClientScript | Gets the TDatePickerClientScript to set the TDatePicker event handlers. (inherited from TDatePicker)
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
RP | CulturalOptions | array | Get javascript localization options, e. (inherited from TDatePicker)
 | Culture | string | Gets the current culture. (inherited from TDatePicker)
RP | CurrentCulture | string | the current culture, falls back to application if culture is not set. (inherited from TDatePicker)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | integer | Returns the timestamp selected by the user. (inherited from TDatePicker)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
 | Date | string | the date string. (inherited from TDatePicker)
 | DateFormat | string | the format of the date string. (inherited from TDatePicker)
RP | DatePickerButtonID | string | Gets the ID for the date picker trigger button. (inherited from TDatePicker)
RP | DatePickerOptions | array | Get javascript date picker options.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
RP | DropDownDayOptions | array | list of day options for a drop down list. (inherited from TDatePicker)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | FirstDayOfWeek | integer | first day of the week. (inherited from TDatePicker)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | FromYear | integer | date picker starting year, default is -5 years. (inherited from TDatePicker)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | InputMode | TDatePickerInputMode | input method of date values. (inherited from TDatePicker)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
RP | LocalizedCalendarInfo | DateTimeFormatInfo | date time format information for the current culture. (inherited from TDatePicker)
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
 | Mode | TDatePickerMode | current calendar UI mode. (inherited from TDatePicker)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
 | PositionMode | TDatePickerPositionMode | current calendar UI position. (inherited from TDatePicker)
RP | PostBackOptions | array | Gets the post back options for this textbox. (inherited from TTextBox)
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowCalendar | boolean | whether the calendar window should pop up when the control receives focus. (inherited from TDatePicker)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox. (inherited from TTextBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component. (inherited from TTextBox)
 | TimeStamp | integer | current selected date from the date picker as timestamp, NULL if timestamp is not set previously. (inherited from TDatePicker)
RP | TimeStampFromText | integer | Gets the date from the text input using TSimpleDateFormatter . (inherited from TDatePicker)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
 | UpToYear | integer | date picker ending year, default +10 years. (inherited from TDatePicker)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | integer | Returns the value to be validated. (inherited from TDatePicker)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the date picker Css asset files. (inherited from TDatePicker)
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Add the client id to the input textbox, and register the client scripts. (inherited from TDatePicker)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientScript | javascript validator event options. (inherited from TDatePicker)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDateFromPostData | Loads date from drop down list data. (inherited from TDatePicker)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLocalizedMonthNames | Returns the localized month names that depends on the month format pattern. (inherited from TDatePicker)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
P | hasDayPattern | . (inherited from TDatePicker)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TDatePicker)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
P | publishCalendarStyle | Publish the calendar style Css asset file. (inherited from TDatePicker)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
P | registerCalendarClientScript | Registers the javascript code to initialize the date picker.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders body content. (inherited from TDatePicker)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
P | renderButtonDatePicker | Adds an additional button such that when clicked it shows the date picker. (inherited from TDatePicker)
P | renderCalendarDayOptions | Renders the day drop down list options. (inherited from TDatePicker)
P | renderCalendarMonthOptions | Renders the month drop down list options. (inherited from TDatePicker)
P | renderCalendarSelections | Renders the calendar drop down list depending on the DateFormat pattern. (inherited from TDatePicker)
P | renderCalendarYearOptions | Renders the year drop down list options. (inherited from TDatePicker)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for textbox. (inherited from TTextBox)
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode. (inherited from TTextBox)
 | renderControl | Renders the control. (inherited from TControl)
P | renderDatePickerButtons | Renders the date picker popup buttons. (inherited from TDatePicker)
P | renderDropDownListCalendar | Renders the drop down list date picker. (inherited from TDatePicker)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderImageButtonDatePicker | Adds an additional image button such that when clicked it shows the date picker. (inherited from TDatePicker)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveDropDownList

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TDropDownList »
TActiveDropDownList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | null | No client class for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TDropDownList)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this is a multiselect control. (inherited from TListControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TDropDownList)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | postback options for JS postback code. (inherited from TListControl)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TDropDownList)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Updates the client-side options if the item list has changed after the OnLoad event.
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items.
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TDropDownList)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TDropDownList)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveFileUpload

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TFileUpload »
TActiveFileUpload
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
RP | AssetUrl | string | asset file url.
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic callback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | BusyImage | TImage | the image displayed when an upload is in progress.
R | CallbackJavascript | string | A chuck of javascript that will need to be called if {AutoPostBack is set to false}.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientOptions | array | Gets the client side options for this control.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TFileUpload)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | ErrorCode | integer | Returns an error code describing the status of this file uploading. (inherited from TFileUpload)
R | ErrorImage | TImage | the image displayed when an upload does not complete successfully.
R | FileName | string | the original full path name of the file on the client machine. (inherited from TFileUpload)
R | FileSize | integer | the actual size of the uploaded file in bytes. (inherited from TFileUpload)
R | FileType | string | the MIME-type of the uploaded file (such as "image/gif"). (inherited from TFileUpload)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFile | boolean | whether the file is uploaded successfully. (inherited from TFileUpload)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TFileUpload)
R | LocalName | string | the local name of the file (where it is after being uploaded). (inherited from TFileUpload)
 | MaxFileSize | integer | the maximum file size, defaults to 1MB (1048576 bytes). (inherited from TFileUpload)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | SuccessImage | TImage | the image displayed when an upload completes successfully.
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the file upload control. (inherited from TFileUpload)
 | TempPath | string | the path where the uploaded file will be stored temporarily, in namespace format default "Application.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ValidationPropertyValue | mixed | Returns the original file name as the property value to be validated. (inherited from TFileUpload)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnFileUpload | This method is invoked when a file is uploaded.
OnInit | .
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the javascript.
OnUnload | Removes localfile on ending of the callback.
Methods
 | Name | Description
 | addAttributesToRender | Adds ID attribute, and renders the javascript for active component.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | .
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TFileUpload)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises OnFileUpload event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TFileUpload)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveAs | Saves the uploaded file.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveHiddenField

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » THiddenField »
TActiveHiddenField
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the hidden field. (inherited from THiddenField)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from THiddenField)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from THiddenField)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from THiddenField)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TagName | string | tag name of the hidden field. (inherited from THiddenField)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from THiddenField)
 | Value | string | the value of the THiddenField. (inherited from THiddenField)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
OnValueChanged | This method is invoked when the value of the Value property changes between posts to the server. (inherited from THiddenField)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets focus to this control. (inherited from THiddenField)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads hidden field data. (inherited from THiddenField)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from THiddenField)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from THiddenField)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveHyperLink

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » THyperLink »
TActiveHyperLink
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | basic active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL to link to when the THyperLink component is clicked. (inherited from THyperLink)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageUrl | string | the location of the image file for the THyperLink. (inherited from THyperLink)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | NavigateUrl | string | the URL to link to when the THyperLink component is clicked. (inherited from THyperLink)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the hyperlink. (inherited from THyperLink)
 | Target | string | the target window or frame to display the Web page content linked to when the THyperLink component is clicked. (inherited from THyperLink)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the THyperLink. (inherited from THyperLink)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes related to a hyperlink element to renderer. (inherited from THyperLink)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createImage | Gets the TImage for rendering the ImageUrl property. (inherited from THyperLink)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the hyperlink. (inherited from THyperLink)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveImage

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TImage »
TActiveImage
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | basic active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AlternateText | string | the alternative text displayed in the TImage component when the image is unavailable. (inherited from TImage)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL of the image file. (inherited from TImage)
 | DescriptionUrl | string | the URL to long description. (inherited from TImage)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageAlign | string | the alignment of the image with respective to other elements on the page, defaults to empty. (inherited from TImage)
 | ImageUrl | string | the URL of the image file. (inherited from TImage)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of image control. (inherited from TImage)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes related to an HTML image element to renderer. (inherited from TImage)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the image. (inherited from TImage)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveImageButton

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TImage » TImageButton »
TActiveImageButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | basic active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AlternateText | string | the alternative text displayed in the TImage component when the image is unavailable. (inherited from TImage)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation, default is true. (inherited from TImageButton)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveLinkButton.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
 | CommandName | string | the command name associated with the OnCommand event. (inherited from TImageButton)
 | CommandParameter | string | the parameter associated with the OnCommand event. (inherited from TImageButton)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL of the image file. (inherited from TImage)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TImageButton)
 | DescriptionUrl | string | the URL to long description. (inherited from TImage)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TImageButton)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageAlign | string | the alignment of the image with respective to other elements on the page, defaults to empty. (inherited from TImage)
 | ImageUrl | string | the URL of the image file. (inherited from TImage)
 | IsDefaultButton | boolean | true if this button is registered as a default button for a panel. (inherited from TImageButton)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the button. (inherited from TImageButton)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button. (inherited from TImageButton)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | caption of the button. (inherited from TImageButton)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback. (inherited from TImageButton)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnClick | This method is invoked when the button is clicked. (inherited from TImageButton)
OnCommand | This method is invoked when the button is clicked. (inherited from TImageButton)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Register the x and y hidden input names of the position clicked.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | canCauseValidation | whether to perform validation if the button is clicked. (inherited from TImageButton)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | This method checks if the TImageButton is clicked and loads the coordinates of the clicking position. (inherited from TImageButton)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | needPostBackScript | whether the button needs javascript to do postback. (inherited from TImageButton)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event. (inherited from TImageButton)
 | raisePostDataChangedEvent | A dummy implementation for the IPostBackDataHandler interface. (inherited from TImageButton)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TImageButton)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveLabel

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel »
TActiveLabel
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | basic active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute id to the renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the label. (inherited from TLabel)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveLinkButton

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLinkButton »
TActiveLinkButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation. (inherited from TLinkButton)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveLinkButton.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
 | CommandName | string | the command name associated with the OnCommand event. (inherited from TLinkButton)
 | CommandParameter | string | the parameter associated with the OnCommand event. (inherited from TLinkButton)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the caption of the button. (inherited from TLinkButton)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TLinkButton)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsDefaultButton | boolean | true if this button is registered as a default button for a panel. (inherited from TLinkButton)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the button. (inherited from TLinkButton)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button. (inherited from TLinkButton)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the button. (inherited from TLinkButton)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback. (inherited from TLinkButton)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnClick | This method is invoked when the button is clicked. (inherited from TLinkButton)
OnCommand | This method is invoked when the button is clicked. (inherited from TLinkButton)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event. (inherited from TLinkButton)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TLinkButton)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderLinkButtonHref | Renders the Href for link button. (inherited from TLinkButton)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveListBox

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TListBox »
TActiveListBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | null | Javascript client class for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TListBox)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control allows multiple selection. (inherited from TListBox)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TListBox)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | postback options for JS postback code. (inherited from TListControl)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows to be displayed in the list control. (inherited from TListBox)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
 | SelectionMode | TListSelectionMode | the selection mode (Single, Multiple). (inherited from TListBox)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TListBox)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Updates the client-side options if the item list has changed after the OnLoad event.
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items.
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TListBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TListBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveListControlAdapter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControlAdapter » TActiveControlAdapter »
TActiveListControlAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | BaseActiveControl | TBaseActiveControl | Common active control options. (inherited from TActiveControlAdapter)
R | Control | TControl | the control to which this adapter is attached. (inherited from TControlAdapter)
RP | IsTrackingPageState | boolean | true if the viewstate needs to be tracked. (inherited from TActiveControlAdapter)
R | Page | TPage | the page that contains the attached control. (inherited from TControlAdapter)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | StateTracker | TCallbackPageStateTracker | state tracker. (inherited from TActiveControlAdapter)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Name | Description
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControlAdapter)
OnLoad | Starts viewstate tracking if necessary after when controls has been loaded. (inherited from TActiveControlAdapter)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControlAdapter)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControlAdapter)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | canUpdateClientSide | true if can update client-side attributes.
 | clearSelection | Clears all existing selections on the client side.
 | createChildControls | Creates child controls for the attached control. (inherited from TControlAdapter)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | loadState | Loads additional persistent control state. (inherited from TControlAdapter)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | render | Renders the callback client scripts. (inherited from TActiveControlAdapter)
P | renderCallbackClientScripts | Register the callback clientscripts and sets the post loader IDs. (inherited from TActiveControlAdapter)
 | renderChildren | Renders the control's children. (inherited from TControlAdapter)
 | saveState | Saves additional persistent control state. (inherited from TActiveControlAdapter)
P | setBaseControlClass | . (inherited from TActiveControlAdapter)
 | setSelectedIndex | Selects an item based on zero-base index on the client side.
 | setSelectedIndices | Selects a list of item based on zero-base indices on the client side.
 | setSelectedValue | Sets selection by item value on the client side.
 | setSelectedValues | Sets selection by a list of item values on the client side.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | updateListItems | Update the client-side list options.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveListItemCollection

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TList » TListItemCollection »
TActiveListItemCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Control | IActiveControl | active control using the collection.
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
R | ListHasChanged | boolean | true if the list has changed after onLoad event.
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
 | Name | Description
 | add | Appends an item at the end of the list. (inherited from TList)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | canUpdateClientSide | true if active controls can update client-side and the onLoad event has already been raised.
 | clear | Removes all items in the list. (inherited from TList)
 | contains | whether the list contains the item. (inherited from TList)
 | copyFrom | Copies iterable data into the list. (inherited from TList)
 | count | Returns the number of items in the list. (inherited from TList)
 | createListItem | Creates a list item object. (inherited from TListItemCollection)
P | createNewListItem | new item. (inherited from TListItemCollection)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findIndexByText | Finds the lowest cardinal index of the item whose text is the one being looked for. (inherited from TListItemCollection)
 | findIndexByValue | Finds the lowest cardinal index of the item whose value is the one being looked for. (inherited from TListItemCollection)
 | findItemByText | Finds the item whose text is the one being looked for. (inherited from TListItemCollection)
 | findItemByValue | Finds the item whose value is the one being looked for. (inherited from TListItemCollection)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
 | insertAt | Inserts an item into the collection.
 | itemAt | Returns the item at the specified offset. (inherited from TList)
 | loadState | Loads state into every item in the collection. (inherited from TListItemCollection)
 | mergeWith | Merges iterable data into the map. (inherited from TList)
 | offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
 | offsetGet | Returns the item at the specified offset. (inherited from TList)
 | offsetSet | Sets the item at the specified offset. (inherited from TList)
 | offsetUnset | Unsets the item at the specified offset. (inherited from TList)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | remove | Removes an item from the list. (inherited from TList)
 | removeAt | Removes an item from at specified index.
 | saveState | Saves state of items. (inherited from TListItemCollection)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | toArray | the list of items in array. (inherited from TList)
 | updateClientSide | Update client-side list items.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActivePageAdapter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControlAdapter »
TActivePageAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | CallbackClientHandler | TCallbackClientScript | Gets the callback client script handler.
 | CallbackEventParameter | string | Gets callback parameter.
 | CallbackEventTarget | TControl | the control responsible for the current callback event, null if nonexistent.
R | Control | TControl | the control to which this adapter is attached. (inherited from TControlAdapter)
R | Page | TPage | the page that contains the attached control. (inherited from TControlAdapter)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Name | Description
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControlAdapter)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControlAdapter)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControlAdapter)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControlAdapter)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createChildControls | Creates child controls for the attached control. (inherited from TControlAdapter)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | loadState | Loads additional persistent control state. (inherited from TControlAdapter)
 | processCallbackEvent | Process the callback request.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | redirect | Redirect url on the client-side using javascript.
 | registerControlToRender | Register a control for defered render() call.
 | render | This method is invoked when the control renders itself. (inherited from TControlAdapter)
 | renderCallbackResponse | Render the callback response.
 | renderChildren | Renders the control's children. (inherited from TControlAdapter)
P | renderResponse | Renders the callback response by adding additional callback data and javascript actions in the header and page state if required.
 | saveState | Saves additional persistent control state. (inherited from TControlAdapter)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | trapCallbackErrorsExceptions | Trap errors and exceptions to be handled by TCallbackErrorHandler.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActivePager

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TPager »
TActivePager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | standard active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | ButtonType | TPagerButtonType | the type of command button for paging. (inherited from TPager)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToPaginate | string | the ID path of the control whose content would be paginated. (inherited from TPager)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TPager)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | FirstPageImageUrl | string | the image URL for the first page button. (inherited from TPager)
 | FirstPageText | string | text for the first page button. (inherited from TPager)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsFirstPage | boolean | whether the current page is the first page Defaults to false. (inherited from TPager)
R | IsLastPage | boolean | whether the current page is the last page. (inherited from TPager)
 | LastPageImageUrl | string | the image URL for the last page button. (inherited from TPager)
 | LastPageText | string | text for the last page button. (inherited from TPager)
 | Mode | TPagerMode | pager mode. (inherited from TPager)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | NextPageImageUrl | string | the image URL for the next page button. (inherited from TPager)
 | NextPageText | string | text for the next page button. (inherited from TPager)
 | NumericPageImageUrl | string | the image URL for the numeric page buttons. (inherited from TPager)
 | Page | TPage | the page that contains this control. (inherited from TControl)
 | PageButtonCount | integer | maximum number of pager buttons to be displayed. (inherited from TPager)
 | PageCount | integer | number of pages of data items available. (inherited from TPager)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PrevPageImageUrl | string | the image URL for the previous page button. (inherited from TPager)
 | PrevPageText | string | text for the previous page button. (inherited from TPager)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPageIndexChanged | This event is raised when page index is changed due to a page button click. (inherited from TPager)
OnPreRender | Performs databinding to populate data items from data source. (inherited from TPager)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Processes a bubbled event. (inherited from TPager)
P | buildListPager | Builds a dropdown list pager Override parent implementation to build Active dropdown lists.
P | buildNextPrevPager | Builds a next-prev pager. (inherited from TPager)
P | buildNumericPager | Builds a numeric pager. (inherited from TPager)
P | buildPager | Builds the pager content based on the pager mode. (inherited from TPager)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createPagerButton | Creates a pager button.
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPageImageUrl | . (inherited from TPager)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | handleCallback | Event handler to the OnCallback active buttons or active dropdownlist.
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | listIndexChanged | Event handler to the OnSelectedIndexChanged event of the dropdown list. (inherited from TPager)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Restores the pager state. (inherited from TPager)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | .
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActivePanel

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TPanel »
TActivePanel
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | standard active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the panel component. (inherited from TPanel)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultButton | string | the ID path to the default button. (inherited from TPanel)
 | Direction | string | alignment of the content in the panel. (inherited from TPanel)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GroupingText | string | the legend text when the panel is used as a fieldset. (inherited from TPanel)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the panel, defaults to 'NotSet'. (inherited from TPanel)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScrollBars | string | the visibility and position of scroll bars in a panel control, defaults to None. (inherited from TPanel)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the panel. (inherited from TPanel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the content wraps within the panel. (inherited from TPanel)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute id to the renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TPanel)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders and replaces the panel's content on the client-side.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TPanel)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TPanel)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRadioButton

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TCheckBox » TRadioButton »
TActiveRadioButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | whether clicking on the checkbox will post the page. (inherited from TCheckBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event triggered by this checkbox will cause input validation, default is true. (inherited from TCheckBox)
 | Checked | boolean | whether the checkbox is checked. (inherited from TCheckBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveRadioButton.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | boolean | Returns the value indicating whether the checkbox is checked. (inherited from TCheckBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBox)
RP | DefaultLabelID | string | radio button label ID;.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TRadioButton)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GroupName | string | the name of the group that the radio button belongs to. (inherited from TRadioButton)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | InputAttributes | TMap | list of attributes to be rendered for the checkbox. (inherited from TCheckBox)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBox)
R | LabelAttributes | TMap | Overrides parent implementation to ensure label has ID.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox. (inherited from TCheckBox)
R | RadioButtonsInGroup | array | Gets an array of radiobuttons whose group name is the same as this radiobutton's. (inherited from TRadioButton)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | bool | Check if we need a span tag to surround this control. (inherited from TCheckBox)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | SurroundingTagID | string | the id of the surrounding tag or this clientID if no such tag needed. (inherited from TCheckBox)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button. (inherited from TCheckBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the checkbox. (inherited from TCheckBox)
 | TextAlign | TTextAlign | the alignment (Left or Right) of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
 | UniqueGroupName | string | the name used to fetch radiobutton post data. (inherited from TRadioButton)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the checkbox causes validation upon postback. (inherited from TCheckBox)
R | ValidationPropertyValue | mixed | Returns the value of the property that needs validation. (inherited from TCheckBox)
 | Value | string | the value of the checkbox. (inherited from TCheckBox)
RP | ValueAttribute | string | the value attribute to be rendered. (inherited from TRadioButton)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnCheckedChanged | Raises OnCheckedChanged event when Checked changes value during postback. (inherited from TCheckBox)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the radio button groupings. (inherited from TRadioButton)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the checkbox to receive postback data during postback. (inherited from TCheckBox)
OnUnLoad | Unregisters the radio button groupings. (inherited from TRadioButton)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add the group name as post data loader if group name is set. (inherited from TRadioButton)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TRadioButton)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox control. (inherited from TCheckBox)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderInputTag | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
P | renderLabel | Renders a label beside the radio button.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRadioButtonList

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TCheckBoxList » TRadioButtonList »
TActiveRadioButtonList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
 | CellPadding | integer | the cellpadding for the table keeping the checkbox list. (inherited from TCheckBoxList)
 | CellSpacing | integer | the cellspacing for the table keeping the checkbox list. (inherited from TCheckBoxList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control. (inherited from TRadioButtonList)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBoxList)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item. (inherited from TCheckBoxList)
R | HasHeader | boolean | Returns a value indicating whether this control contains header item. (inherited from TCheckBoxList)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items. (inherited from TCheckBoxList)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control supports multiple selection. (inherited from TRadioButtonList)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBoxList)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox. (inherited from TCheckBoxList)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
 | RepeatColumns | integer | the number of columns that the list should be displayed with. (inherited from TCheckBoxList)
 | RepeatDirection | string | the direction of traversing the list, defaults to 'Vertical'. (inherited from TCheckBoxList)
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers). (inherited from TCheckBoxList)
 | RepeatLayout | string | how the list should be displayed, using table or using line breaks. (inherited from TCheckBoxList)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | boolean | Wether the list should be rendered inside a span or not . (inherited from TCheckBoxList)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | TextAlign | TTextAlign | the alignment of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBoxList)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TCheckBoxList)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers for post data on postback. (inherited from TCheckBoxList)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TListControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createRepeatedControl | Creates a control used for repetition (used as a template).
P | createStyle | Creates a style object for the control. (inherited from TCheckBoxList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID. (inherited from TCheckBoxList)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | generateItemStyle | Returns a style used for rendering items. (inherited from TCheckBoxList)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TRadioButtonList)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBoxList)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox list control. (inherited from TCheckBoxList)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list. (inherited from TCheckBoxList)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRatingList

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TCheckBoxList » TRadioButtonList » TRatingList »
TActiveRatingList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowInput | boolean | Wrapper for ReadOnly property. (inherited from TRatingList)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
RP | AssetUrl | string | asset file url. (inherited from TRatingList)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Caption | string | caption text. (inherited from TRatingList)
RP | CaptionControl | {unknown} | . (inherited from TRatingList)
RP | CaptionControlID | string | find the client ID of the caption control. (inherited from TRatingList)
 | CaptionID | string | control or html element ID for displaying a caption. (inherited from TRatingList)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
 | CellPadding | integer | the cellpadding for the table keeping the checkbox list. (inherited from TCheckBoxList)
 | CellSpacing | integer | the cellspacing for the table keeping the checkbox list. (inherited from TCheckBoxList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBoxList)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | HalfRatingInterval | array | rating display half value interval, default is array(0. (inherited from TRatingList)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item. (inherited from TCheckBoxList)
R | HasHeader | boolean | Returns a value indicating whether this control contains header item. (inherited from TCheckBoxList)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items. (inherited from TCheckBoxList)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control supports multiple selection. (inherited from TRadioButtonList)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBoxList)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | list of post back options. (inherited from TRatingList)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
 | Rating | float | rating value. (inherited from TRatingList)
 | RatingStyle | TRatingListStyle | current rating style. (inherited from TRatingList)
RP | RatingStyleCssClass | string | rating style css class name. (inherited from TRatingList)
 | ReadOnly | boolean | whether the items in the column can be edited. (inherited from TRatingList)
 | RepeatColumns | integer | the number of columns that the list should be displayed with. (inherited from TCheckBoxList)
 | RepeatDirection | string | the direction of traversing the list, defaults to 'Vertical'. (inherited from TCheckBoxList)
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers). (inherited from TCheckBoxList)
 | RepeatLayout | string | how the list should be displayed, using table or using line breaks. (inherited from TCheckBoxList)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | boolean | Wether the list should be rendered inside a span or not . (inherited from TCheckBoxList)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | TextAlign | TTextAlign | the alignment of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBoxList)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TCheckBoxList)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the the rating style css file and rating image files. (inherited from TRatingList)
OnSelectedIndexChanged | . (inherited from TRatingList)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TListControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | callClientFunction | Calls the client-side static method for this control class.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createRepeatedControl | Creates a control used for repetition (used as a template). (inherited from TRadioButtonList)
P | createStyle | Creates a style object for the control. (inherited from TCheckBoxList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID. (inherited from TCheckBoxList)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | generateItemStyle | Returns a style used for rendering items. (inherited from TCheckBoxList)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRatingIndex | rating as integer. (inherited from TRatingList)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TRadioButtonList)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | publishImages | URL of publish the rating images. (inherited from TRatingList)
P | publishStyle | URL of the css style file. (inherited from TRatingList)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBoxList)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Add rating style class name to the class attribute when ReadOnly property is true and when the CssClass property is empty. (inherited from TRatingList)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list. (inherited from TCheckBoxList)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecord

Namespace: System.Data.ActiveRecord
Inheritance: TComponent »
TActiveRecord
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | Gets the current Db connection, the connection object is obtained from the TActiveRecordManager if connection is currently null.
 | InvalidFinderResult | TActiveRecordInvalidFinderResult | Defaults to 'Null'.
R | RecordGateway | TActiveRecordGateway | record table gateway.
R | RecordRelations | array | all relation definitions declared in the AR class @since 3.
R | RecordTableInfo | TDbTableInfo | the meta information of the table associated with this AR class.
Events
Name | Description
OnCreateCommand | Raised when a command is prepared and parameter binding is completed.
OnDelete | Raised before the record attempt to delete its data from the database.
OnExecuteCommand | Raised when a command is executed and the result from the database was returned.
OnInsert | Raised before the record attempt to insert its data into the database.
OnUpdate | Raised before the record attempt to update its data in the database.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | copyFrom | Copies data from an array or another object.
 | count | Find the number of records.
S | createRecord | Create an AR instance specified by the AR class name and initial data.
P | createRelationContext | Gets a static copy of the relationship context for given property (a key in $RELATIONS), returns null if invalid relationship.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes the current record from the database.
 | deleteAll | Delete multiple records using a criteria.
 | deleteAllByPks | Alias for deleteByPk().
 | deleteByPk | Delete records by primary key.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | equals | Compare two records using their primary key values (all column values if table does not defined primary keys).
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | fetchResultsFor | Tries to load the relationship results for the given property.
 | find | Find one single record that matches the criteria.
 | findAll | Same as find() but returns an array of objects.
 | findAllByIndex | Fetches records using the sql clause "(fields) IN (values)", where fields is an array of column names and values is an array of values that the columns must have.
 | findAllByPks | Find multiple records matching a list of primary or composite keys.
 | findAllBySql | Find records using full SQL, returns corresponding record object.
 | findByPk | Find one record using only the primary key or composite primary keys.
 | findBySql | Find records using full SQL, returns corresponding record object.
S | finder | Returns the instance of a active record finder for a particular class.
S | getActiveDbConnection | .
 | getColumnValue | Retrieves the column value according to column name.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRecordCriteria | Create a new TSqlCriteria object from a string $criteria.
S | getRecordManager | Gets the record manager for this object, the default is to call TActiveRecordManager::getInstance().
 | getRecordRelation | relation definition for the specified property @since 3.
P | getRelationHandler | Returns the active record relationship handler for $RELATION with key value equal to the $property value.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasRecordRelation | whether a relation is declared for the specified AR property @since 3.
P | populateObject | Populates a new record with the query result.
P | populateObjects | the AR objects populated by the query result @since 3.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | save | Saves the current record to the database, insert or update is automatically determined.
 | setColumnValue | Sets the column value according to column name.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordBelongsTo

Namespace: System.Data.ActiveRecord.Relations
Inheritance: TActiveRecordRelation »
TActiveRecordBelongsTo
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | collectForeignObjects | Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
 | fetchResultsInto | Fetch results for current relationship. (inherited from TActiveRecordRelation)
P | findForeignKeys | Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value. (inherited from TActiveRecordRelation)
P | findForeignObjects | Fetches the foreign objects using TActiveRecord::findAllByIndex() . (inherited from TActiveRecordRelation)
P | getContext | . (inherited from TActiveRecordRelation)
P | getCriteria | . (inherited from TActiveRecordRelation)
P | getIndexValues | Obtain the foreign key index values from the results. (inherited from TActiveRecordRelation)
P | getObjectHash | object hash using crc32 and serialize. (inherited from TActiveRecordRelation)
 | getRelationForeignKeys | foreign key field names as key and object properties as value.
P | getSourceRecord | . (inherited from TActiveRecordRelation)
P | populateResult | Populate the results with the foreign objects found. (inherited from TActiveRecordRelation)
P | setObjectProperty | Sets the foreign objects to the given property on the source object.
P | setResultCollection | Populates the result array with foreign objects (matched using foreign key hashed property values). (inherited from TActiveRecordRelation)
 | updateAssociatedRecords | Updates the source object first.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordChangeEventParameter

Namespace: System.Data.ActiveRecord
Inheritance: TComponent » TEventParameter »
TActiveRecordChangeEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
IsValid | boolean | whether the event should be performed.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordConfig

Namespace: System.Data.ActiveRecord
Inheritance: TComponent » TApplicationComponent » TModule » TDataSourceConfig »
TActiveRecordConfig
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ConnectionClass | {unknown} | . (inherited from TDataSourceConfig)
 | ConnectionID | string | connection module ID. (inherited from TDataSourceConfig)
R | Database | TDbConnection | Alias for getDbConnection(). (inherited from TDataSourceConfig)
R | DbConnection | TDbConnection | Gets the TDbConnection from another module if ConnectionID is supplied and valid. (inherited from TDataSourceConfig)
 | EnableCache | boolean | true if table meta data should be cached, false otherwise.
 | ID | string | id of this module. (inherited from TModule)
 | InvalidFinderResult | TActiveRecordInvalidFinderResult | Defaults to 'Null'.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | findConnectionByID | Finds the database connection instance from the Application modules. (inherited from TDataSourceConfig)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initialize the active record manager.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordConfigurationException

Namespace: System.Data.ActiveRecord
Inheritance: TException » TSystemException » TDbException » TActiveRecordException »
TActiveRecordConfigurationException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TActiveRecordException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordCriteria

Namespace: System.Data.ActiveRecord
Inheritance: TComponent » TSqlCriteria »
TActiveRecordCriteria
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Condition | string | search conditions. (inherited from TSqlCriteria)
R | IsNamedParameters | boolean | true if the parameter index are string base, false otherwise. (inherited from TSqlCriteria)
 | Limit | int | maximum number of records to return. (inherited from TSqlCriteria)
 | Offset | int | record offset. (inherited from TSqlCriteria)
 | OrdersBy | TAttributeCollection | ordering clause. (inherited from TSqlCriteria)
 | Parameters | TAttributeCollection | list of named parameters and values. (inherited from TSqlCriteria)
 | Select | mixed | Gets the field list to be placed after the SELECT in the SQL. (inherited from TSqlCriteria)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordException

Namespace: System.Data.ActiveRecord
Inheritance: TException » TSystemException » TDbException »
TActiveRecordException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file.
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
  • TActiveRecordConfigurationException
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordGateway

Namespace: System.Data.ActiveRecord
Inheritance: TComponent »
TActiveRecordGateway
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
RP | Manager | TActiveRecordManager | record manager.
Events
Name | Description
OnCreateCommand | Raised when a command is prepared and parameter binding is completed.
OnExecuteCommand | Raised when a command is executed and the result from the database was returned.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | countRecords | Returns the number of records that match the given criteria.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Delete the record.
 | deleteRecordsByCriteria | Delete multiple records by criteria.
 | deleteRecordsByPk | Delete multiple records using primary keys.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findRecordByPK | Returns record data matching the given primary key(s).
 | findRecordBySql | Return record data from sql query.
 | findRecordsByCriteria | Returns record data matching the given critera.
 | findRecordsByIndex | .
 | findRecordsByPks | Returns records matching the list of given primary keys.
 | findRecordsBySql | Return record data from sql query.
 | getCommand | .
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertValues | insert values.
P | getPrimaryKeyValues | .
 | getRecordTableInfo | Returns table information, trys the application cache first.
P | getRecordTableName | Gets the table name from the 'TABLE' constant of the active record class if defined, otherwise use the class name as table name.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getTableInfo | Returns table information for table in the database connection.
P | getUpdateValues | .
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | insert | Insert a new record.
P | raiseCommandEvent | Raise the corresponding command event, insert, update, delete or select.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | update | Update the record.
P | updateAssociatedRecords | .
P | updatePostInsert | Sets the last insert ID to the corresponding property of the record if available.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordHasMany

Namespace: System.Data.ActiveRecord.Relations
Inheritance: TActiveRecordRelation »
TActiveRecordHasMany
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | collectForeignObjects | Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
 | fetchResultsInto | Fetch results for current relationship. (inherited from TActiveRecordRelation)
P | findForeignKeys | Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value. (inherited from TActiveRecordRelation)
P | findForeignObjects | Fetches the foreign objects using TActiveRecord::findAllByIndex() . (inherited from TActiveRecordRelation)
P | getContext | . (inherited from TActiveRecordRelation)
P | getCriteria | . (inherited from TActiveRecordRelation)
P | getIndexValues | Obtain the foreign key index values from the results. (inherited from TActiveRecordRelation)
P | getObjectHash | object hash using crc32 and serialize. (inherited from TActiveRecordRelation)
 | getRelationForeignKeys | foreign key field names as key and object properties as value.
P | getSourceRecord | . (inherited from TActiveRecordRelation)
P | populateResult | Populate the results with the foreign objects found. (inherited from TActiveRecordRelation)
P | setObjectProperty | Sets the foreign objects to the given property on the source object. (inherited from TActiveRecordRelation)
P | setResultCollection | Populates the result array with foreign objects (matched using foreign key hashed property values). (inherited from TActiveRecordRelation)
 | updateAssociatedRecords | Updates the associated foreign objects.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordHasManyAssociation

Namespace: System.Data.ActiveRecord.Relations
Inheritance: TActiveRecordRelation »
TActiveRecordHasManyAssociation
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | collectForeignObjects | Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects using association table.
 | createCommand | .
P | createFkObject | .
P | fetchForeignObjects | Fetches the foreign objects using TActiveRecord::findAllByIndex() .
 | fetchResultsInto | Fetch results for current relationship. (inherited from TActiveRecordRelation)
P | findForeignKeys | Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value. (inherited from TActiveRecordRelation)
P | findForeignObjects | Fetches the foreign objects using TActiveRecord::findAllByIndex() . (inherited from TActiveRecordRelation)
P | getAssociationJoin | SQL inner join for M-N relationship via association table.
P | getAssociationTable | association table information.
P | getAssociationTableCommandBuilder | .
P | getCommandBuilder | .
P | getContext | . (inherited from TActiveRecordRelation)
P | getCriteria | . (inherited from TActiveRecordRelation)
P | getForeignCommandBuilder | .
P | getForeignTable | foreign table information.
P | getIndexValues | Obtain the foreign key index values from the results. (inherited from TActiveRecordRelation)
P | getObjectHash | object hash using crc32 and serialize. (inherited from TActiveRecordRelation)
 | getRelationForeignKeys | 2 arrays of source keys and foreign keys from the association table.
P | getSourceColumns | comma separated source column names.
P | getSourceRecord | . (inherited from TActiveRecordRelation)
P | getSourceTable | source table information.
P | populateResult | Populate the results with the foreign objects found. (inherited from TActiveRecordRelation)
P | setObjectProperty | Sets the foreign objects to the given property on the source object. (inherited from TActiveRecordRelation)
P | setResultCollection | Populates the result array with foreign objects (matched using foreign key hashed property values). (inherited from TActiveRecordRelation)
 | updateAssociatedRecords | Updates the associated foreign objects.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordHasOne

Namespace: System.Data.ActiveRecord.Relations
Inheritance: TActiveRecordRelation »
TActiveRecordHasOne
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | collectForeignObjects | Get the foreign key index values from the results and make calls to the database to find the corresponding foreign objects.
 | fetchResultsInto | Fetch results for current relationship. (inherited from TActiveRecordRelation)
P | findForeignKeys | Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value. (inherited from TActiveRecordRelation)
P | findForeignObjects | Fetches the foreign objects using TActiveRecord::findAllByIndex() . (inherited from TActiveRecordRelation)
P | getContext | . (inherited from TActiveRecordRelation)
P | getCriteria | . (inherited from TActiveRecordRelation)
P | getIndexValues | Obtain the foreign key index values from the results. (inherited from TActiveRecordRelation)
P | getObjectHash | object hash using crc32 and serialize. (inherited from TActiveRecordRelation)
 | getRelationForeignKeys | foreign key field names as key and object properties as value.
P | getSourceRecord | . (inherited from TActiveRecordRelation)
P | populateResult | Populate the results with the foreign objects found. (inherited from TActiveRecordRelation)
P | setObjectProperty | Sets the foreign objects to the given property on the source object.
P | setResultCollection | Populates the result array with foreign objects (matched using foreign key hashed property values). (inherited from TActiveRecordRelation)
 | updateAssociatedRecords | Updates the associated foreign objects.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordInvalidFinderResult

Namespace: System.Data.ActiveRecord
Inheritance: TEnumerable »
TActiveRecordInvalidFinderResult
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordManager

Namespace: System.Data.ActiveRecord
Inheritance: TComponent »
TActiveRecordManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Cache | ICache | application cache.
 | DbConnection | TDbConnection | default database connection.
 | InvalidFinderResult | TActiveRecordInvalidFinderResult | Defaults to 'Null'.
R | RecordGateway | TActiveRecordGateway | record gateway.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createRecordGateway | default record gateway.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
S | getInstance | static instance of record manager.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordRelation

Namespace: System.Data.ActiveRecord.Relations
TActiveRecordRelation
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | collectForeignObjects | .
 | fetchResultsInto | Fetch results for current relationship.
P | findForeignKeys | Returns foreign keys in $fromRecord with source column names as key and foreign column names in the corresponding $matchesRecord as value.
P | findForeignObjects | Fetches the foreign objects using TActiveRecord::findAllByIndex() .
P | getContext | .
P | getCriteria | .
P | getIndexValues | Obtain the foreign key index values from the results.
P | getObjectHash | object hash using crc32 and serialize.
 | getRelationForeignKeys | foreign key field names as key and object properties as value.
P | getSourceRecord | .
P | populateResult | Populate the results with the foreign objects found.
P | setObjectProperty | Sets the foreign objects to the given property on the source object.
P | setResultCollection | Populates the result array with foreign objects (matched using foreign key hashed property values).
Derived classes
  • TActiveRecordBelongsTo
  • TActiveRecordHasMany
  • TActiveRecordHasManyAssociation
  • TActiveRecordHasOne
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveRecordRelationContext

Namespace: System.Data.ActiveRecord.Relations
TActiveRecordRelationContext
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getAssociationTable | the M-N relationship association table name.
 | getCondition | the query condition for the relation as specified in RELATIONS @since 3.
 | getFkField | foreign key field names, comma delimited.
 | getForeignRecordClass | foreign record class name.
 | getForeignRecordFinder | corresponding relationship foreign object finder instance.
 | getParameters | the query parameters for the relation as specified in RELATIONS @since 3.
 | getProperty | name of the record property that the relationship results will be assigned to.
 | getPropertyValue | .
 | getRelationForeignKeys | foreign key of this relations, the keys is dependent on the relationship type.
 | getRelationHandler | Creates and return the TActiveRecordRelation handler for specific relationships.
 | getRelationType | HAS_MANY, HAS_ONE, or BELONGS_TO.
 | getSourceRecord | the active record instance that queried for its related records.
 | hasAssociationTable | true if the relationship is HAS_MANY and requires an association table.
 | hasFkField | true if the 3rd element of an TActiveRecord::$RELATION entry is set.
 | hasRecordRelation | true if the relation is defined in TActiveRecord::$RELATIONS @since 3.
P | isEmptyFkObject | .
 | updateAssociatedRecords | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TActiveTextBox

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox »
TActiveTextBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. (inherited from TTextBox)
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the TTextBox control. (inherited from TTextBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
RP | PostBackOptions | array | Gets the post back options for this textbox. (inherited from TTextBox)
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox. (inherited from TTextBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component. (inherited from TTextBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TTextBox)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TTextBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode. (inherited from TTextBox)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TAutoComplete
  • TInPlaceTextBox
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplication

Namespace: System
Inheritance: TComponent »
TApplication
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | ApplicationStatePersister | IStatePersister | application state persister.
 | AssetManager | TAssetManager | asset manager.
R | AuthorizationRules | TAuthorizationRuleCollection | list of authorization rules for the current request.
 | BasePath | string | the directory containing the application configuration file (absolute path).
 | Cache | ICache | the cache module, null if cache module is not installed.
 | ConfigurationFile | string | the application configuration file (absolute path).
 | ErrorHandler | TErrorHandler | the error handler module.
 | Globalization | TGlobalization | globalization module.
 | ID | string | application ID.
 | Mode | TApplicationMode | application mode.
R | Modules | array | list of loaded application modules, indexed by module IDs.
 | PageServiceID | string | page service ID.
R | Parameters | TMap | Returns the list of application parameters.
 | Request | THttpRequest | the request module.
R | RequestCompleted | boolean | whether the current request is processed.
 | Response | THttpResponse | the response module.
 | RuntimePath | string | the directory storing cache data and application-level persistent data.
 | SecurityManager | TSecurityManager | the security manager module.
 | Service | IService | the currently requested service.
 | Session | THttpSession | the session module, null if session module is not installed.
R | UniqueID | string | an ID that uniquely identifies this Prado application from the others.
 | User | IUser | the application user.
Events
Name | Description
OnAuthentication | Raises OnAuthentication event.
OnAuthenticationComplete | Raises OnAuthenticationComplete event.
OnAuthorization | Raises OnAuthorization event.
OnAuthorizationComplete | Raises OnAuthorizationComplete event.
OnBeginRequest | Raises OnBeginRequest event.
OnEndRequest | Raises OnEndRequest event.
OnError | Raises OnError event.
OnLoadState | Raises OnLoadState event.
OnLoadStateComplete | Raises OnLoadStateComplete event.
OnPreFlushOutput | Raises OnPreFlushOutput event.
OnPreRunService | Raises OnPreRunService event.
OnSaveState | Raises OnSaveState event.
OnSaveStateComplete | Raises OnSaveStateComplete event.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyConfiguration | Applies an application configuration.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clearGlobalState | Clears a global value.
 | completeRequest | Completes current request processing.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flushOutput | Flushes output to client side.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getGlobalState | Returns a global value.
 | getModule | the module with the specified ID, null if not found.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initApplication | Loads configuration and initializes application.
P | loadGlobals | Loads global values from persistent storage.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | resolvePaths | Resolves application-relevant paths.
 | run | Executes the lifecycles of the application.
 | runService | Runs the requested service.
P | saveGlobals | Saves global values into persistent storage.
 | setGlobalState | Sets a global value.
 | setModule | Adds a module to application.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | startService | Starts the specified service.
Derived classes
  • TShellApplication
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplicationComponent

Namespace: System
Inheritance: TComponent »
TApplicationComponent
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance.
R | Request | THttpRequest | the current user request.
R | Response | THttpResponse | the response.
R | Service | IService | the current service.
R | Session | THttpSession | user session.
R | User | IUser | information about the current user.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
publishAsset | Publishes a private asset and gets its URL.
publishFilePath | Publishes a file or directory and returns its URL.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TCallbackClientScript
  • TClientScriptManager
  • TControl
  • TControlAdapter
  • TDataGridColumn
  • THtmlWriter
  • THttpRequest
  • THttpResponseAdapter
  • THttpSession
  • TJsonResponse
  • TLogRoute
  • TModule
  • TService
  • TSoapServer
  • TTemplate
  • TTheme
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplicationConfiguration

Namespace: System
Inheritance: TComponent »
TApplicationConfiguration
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Aliases | array | Returns list of path alias definitions.
R | ExternalConfigurations | array | list of external configuration files.
R | IsEmpty | boolean | whether this configuration contains actual stuff.
R | Modules | array | Returns list of module configurations.
R | Parameters | array | Returns list of parameter definitions.
R | Properties | array | Returns list of page initial property values.
R | Services | array | list of service configurations.
R | Usings | array | Returns list of namespaces to be used.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | loadExternalXml | Loads the external XML configurations.
 | loadFromFile | Parses the application configuration file.
 | loadFromXml | Parses the application configuration given in terms of a TXmlElement.
P | loadModulesXml | Loads the modules XML node.
P | loadParametersXml | Loads the parameters XML node.
P | loadPathsXml | Loads the paths XML node.
P | loadServicesXml | Loads the services XML node.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplicationException

Namespace: System.Exceptions
Inheritance: TException »
TApplicationException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplicationMode

Namespace: System
Inheritance: TEnumerable »
TApplicationMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplicationStateCacheDependency

Namespace: System.Caching
Inheritance: TComponent » TCacheDependency »
TApplicationStateCacheDependency
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | HasChanged | boolean | Performs the actual dependency checking.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TApplicationStatePersister

Namespace: System
Inheritance: TComponent » TApplicationComponent » TModule »
TApplicationStatePersister
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
RP | StateFilePath | string | the file path storing the application state.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes module.
load | Loads application state from persistent storage.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
save | Saves application state in persistent storage.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAssetManager

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent » TModule »
TAssetManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | BasePath | string | the root directory storing published asset files.
 | BaseUrl | string | the base url that the published asset files can be accessed.
 | ID | string | id of this module. (inherited from TModule)
P | Published | array | List of published assets @since 3.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | copyDirectory | Copies a directory recursively as another.
P | copyFile | Copies a file to a directory.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
P | deployTarFile | Extracts the tar file to the destination directory.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getPublishedPath | Returns the published path of a file path.
 | getPublishedUrl | Returns the URL of a published file path.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | hash | Generate a CRC32 hash for the directory path.
 | init | Initializes the module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or a directory (recursively).
 | publishTarFile | Publish a tar file by extracting its contents to the assets directory.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAttributeCollection

Namespace: System.Collections
Inheritance: TComponent » TMap »
TAttributeCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | CaseSensitive | boolean | whether the keys are case-sensitive.
R | Count | integer | the number of items in the map. (inherited from TMap)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TMap)
R | Keys | array | the key list. (inherited from TMap)
 | ReadOnly | boolean | whether this map is read-only or not. (inherited from TMap)
Events
Methods
Name | Description
add | Adds an item into the map.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read.
canSetProperty | Determines whether a property can be set.
clear | Removes all items in the map. (inherited from TMap)
contains | Returns whether the specified is in the map.
copyFrom | Copies iterable data into the map. (inherited from TMap)
count | Returns the number of items in the map. (inherited from TMap)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined.
itemAt | Returns the item with the specified key.
mergeWith | Merges iterable data into the map. (inherited from TMap)
offsetExists | Returns whether there is an element at the specified offset. (inherited from TMap)
offsetGet | Returns the element at the specified offset. (inherited from TMap)
offsetSet | Sets the element at the specified offset. (inherited from TMap)
offsetUnset | Unsets the element at the specified offset. (inherited from TMap)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the map by its key.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TMap)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAuthManager

Namespace: System.Security
Inheritance: TComponent » TApplicationComponent » TModule »
TAuthManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AllowAutoLogin | boolean | whether to allow remembering login so that the user logs on automatically next time.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | AuthExpire | integer | authentication expiration time in seconds.
 | ID | string | id of this module. (inherited from TModule)
 | LoginPage | string | path of login page should login is required.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ReturnUrl | string | URL that the browser should be redirected to when login succeeds.
 | ReturnUrlVarName | string | the name of the session variable storing return URL.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | UserKey | string | a unique variable name for storing user session/cookie data @since 3.
 | UserManager | IUserManager | user manager instance.
Events
Name | Description
OnAuthExpire | Performs user logout on authentication expiration.
OnAuthenticate | Performs the real authentication work.
OnAuthorize | Performs the real authorization work.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | doAuthentication | Performs authentication.
 | doAuthorization | Performs authorization.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | generateUserKey | a key used to store user information in session @since 3.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | leave | Performs login redirect if authorization fails.
 | login | Logs in a user with username and password.
 | logout | Logs out a user.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | switchUser | Switches to a new user.
 | updateSessionUser | Updates the user data stored in session.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAuthorizationRule

Namespace: System.Security
Inheritance: TComponent »
TAuthorizationRule
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Action | string | action, either 'allow' or 'deny'.
R | AuthenticatedApplied | boolean | if this rule applies to authenticated users.
R | EveryoneApplied | boolean | if this rule applies to everyone.
R | GuestApplied | boolean | if this rule applies to everyone.
R | IPRules | array | list of IP rules.
R | Roles | array | list of roles.
R | Users | array | list of user IDs.
R | Verb | string | verb, may be empty, 'get', or 'post'.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
isUserAllowed | 1 if the user is allowed, -1 if the user is denied, 0 if the rule does not apply to the user.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAuthorizationRuleCollection

Namespace: System.Security
Inheritance: TComponent » TList »
TAuthorizationRuleCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
isUserAllowed | whether the user is allowed.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAutoComplete

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox » TActiveTextBox »
TAutoComplete
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options. (inherited from TActiveTextBox)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. (inherited from TTextBox)
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TActiveButton.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options. (inherited from TActiveTextBox)
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the TTextBox control. (inherited from TTextBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | Frequency | float | maximum delay (in seconds) before requesting a suggestion.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
 | MinChars | integer | minimum number of characters before requesting a suggestion.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
RP | PostBackOptions | array | list of callback options.
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | ResultPanel | TPanel | suggestion results panel.
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
 | Separator | string | word or token separators (delimiters).
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | Suggestions | TRepeater | suggestion list repeater.
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox. (inherited from TTextBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextCssClass | string | Css class name of the element to use for suggestion.
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component. (inherited from TTextBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TTextBox)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested. (inherited from TActiveTextBox)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnSuggest | This method is invoked when an autocomplete suggestion is requested.
OnSuggestionSelected | This method is invoked when an autocomplete suggestion is selected.
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control. (inherited from TActiveTextBox)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createRepeater | new instance of TRepater to render the list of suggestions.
P | createResultPanel | new instance of result panel.
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Overrides parent implementation.
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TTextBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
 | renderCallback | Renders the suggestions during a callback respones.
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender.
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode. (inherited from TTextBox)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the end tag and registers javascript effects library.
P | renderResultPanel | Renders the result panel.
 | renderSuggestions | Renders the suggestions repeater.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setDataSource | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAutoCompleteEventParameter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TEventParameter » TCallbackEventParameter »
TAutoCompleteEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CallbackParameter | mixed | callback request parameter. (inherited from TCallbackEventParameter)
R | NewWriter | TCallbackResponseWriter | holds the response content. (inherited from TCallbackEventParameter)
 | ResponseData | mixed | callback response data. (inherited from TCallbackEventParameter)
R | SelectedIndex | int | selected suggestion zero-based index, -1 if not selected.
R | Token | string | token for matching a list of suggestions.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TAutoCompleteTemplate

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent »
TAutoCompleteTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
instantiateIn | Instantiates the template.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBaseActiveCallbackControl

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TBaseActiveControl »
TBaseActiveCallbackControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | CallbackOptions | string | ID of a TCallbackOptions control from which ClientSide options are duplicated.
 | CallbackParameter | mixed | callback parameter value.
 | CausesValidation | boolean | whether callback event trigger by this button will cause input validation, default is true.
 | ClientSide | TCallbackClientSide | Callback client-side options can be set by setting the properties of the ClientSide property.
RP | ClientSideOptions | array | list of callback javascript options.
RP | Control | TControl | the attached control. (inherited from TBaseActiveControl)
RP | DefaultClientSideOptions | array | Returns an array of default callback client-side options.
 | EnableUpdate | boolean | true to allow fine grain callback updates. (inherited from TBaseActiveControl)
R | Javascript | string | Returns the javascript callback request instance.
R | JsCallbackOptions | {unknown} | .
RP | Options | TMap | active control options. (inherited from TBaseActiveControl)
RP | Page | TPage | the page containing the attached control. (inherited from TBaseActiveControl)
 | ValidationGroup | string | the group of validators which the button causes validation upon callback.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canCauseValidation | whether to perform validation if the callback is requested.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | canUpdateClientSide | Returns true if callback response is allowed to update the browser contents. (inherited from TBaseActiveControl)
P | createClientSide | callback client-side options.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | Gets an option named value. (inherited from TBaseActiveControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerCallbackClientScript | Registers the callback control javascript code.
P | setOption | Sets a named options with a value. (inherited from TBaseActiveControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBaseActiveControl

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent »
TBaseActiveControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
RP | Control | TControl | the attached control.
 | EnableUpdate | boolean | true to allow fine grain callback updates.
RP | Options | TMap | active control options.
RP | Page | TPage | the page containing the attached control.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | canUpdateClientSide | Returns true if callback response is allowed to update the browser contents.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | Gets an option named value.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setOption | Sets a named options with a value.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TBaseActiveCallbackControl
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBaseDataList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl »
TBaseDataList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CellPadding | integer | the cellpadding for the table layout.
 | CellSpacing | integer | the cellspacing for the table layout.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DataKeyField | string | the field of the data source that provides the keys of the list items.
R | DataKeys | TList | the keys used in the data listing control.
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GridLines | TTableGridLines | the grid line setting of the table layout.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the table content.
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDataFieldValue | Returns the value of the data at the specified field.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | . (inherited from TDataBoundControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TDataGrid
  • TDataList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBaseValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel »
TBaseValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events.
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate.
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | Display | TValidatorDisplayStyle | the style of displaying the error message.
 | EnableClientScript | boolean | whether client-side validation is enabled.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | ErrorMessage | string | the text for the error message.
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true.
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to.
R | ValidationTarget | TControl | control to be validated.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered.
OnUnload | Unregisters the validator from page.
OnValidate | This event is raised right before the validator starts to perform validation.
OnValidationError | This event is raised when the validator fails in validation.
OnValidationSuccess | This event is raised when the validator succeeds in validation.
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
P | evaluateIsValid | This is the major method for validation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated.
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script.
 | renderContents | Renders the validator control.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid.
 | validate | Validates the specified control.
Derived classes
  • TCaptchaValidator
  • TCompareValidator
  • TCustomValidator
  • TDataTypeValidator
  • TListControlValidator
  • TRangeValidator
  • TRegularExpressionValidator
  • TRequiredFieldValidator
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBoundColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TBoundColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataField | string | the field name from the data source to bind to the column.
 | DataFormatString | string | the formatting string used to control how the bound data will be displayed.
 | EditItemRenderer | string | the class name for the edit item cell renderer.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
 | ItemRenderer | string | the class name for the item cell renderer.
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
 | ReadOnly | boolean | whether the items in the column can be edited.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBroadcastEventParameter

Namespace: System.Web.UI
Inheritance: TComponent » TEventParameter »
TBroadcastEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Name | string | name of the broadcast event.
Parameter | mixed | parameter of the broadcast event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBrowserLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TLogRoute »
TBrowserLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Categories | array | list of categories to be looked for. (inherited from TLogRoute)
 | CssClass | string | the css class of the control.
 | Levels | integer | log level filter. (inherited from TLogRoute)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination. (inherited from TLogRoute)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields. (inherited from TLogRoute)
P | getColorLevel | .
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLevelName | level name. (inherited from TLogRoute)
P | getLevelValue | level value. (inherited from TLogRoute)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the route. (inherited from TLogRoute)
 | processLogs | .
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | renderFooter | .
P | renderHeader | .
P | renderMessage | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TFirebugLogRoute
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBulletStyle

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TBulletStyle
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBulletedList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl »
TBulletedList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | BulletImageUrl | string | image URL used for bullets when BulletStyle is 'CustomImage'.
 | BulletStyle | TBulletStyle | style of bullets.
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | DisplayMode | TBulletedListDisplayMode | display mode of the list.
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | FirstBulletNumber | integer | starting index when BulletStyle is one of the following: 'Numbered', 'LowerAlpha', 'UpperAlpha', 'LowerRoman', 'UpperRoman'.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this is a multiselect control. (inherited from TListControl)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | postback options used for linkbuttons.
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the bulleted list.
 | Target | string | the target window or frame to display the Web page content linked to when DisplayMode is 'HyperLink' and one of the hyperlinks is clicked.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnClick | Raises 'OnClick' event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | canCauseValidation | .
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
P | renderBulletText | Renders each item .
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders the body contents.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderHyperLinkItem | .
P | renderLinkButtonItem | .
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
P | renderTextItem | .
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBulletedListDisplayMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TBulletedListDisplayMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TBulletedListEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TBulletedListEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Index | integer | zero-based index of the item (rendered as a link button) that is clicked.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TButton

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | ButtonType | TButtonType | the type of the button.
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation, default is true.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | CommandName | string | the command name associated with the OnCommand event.
 | CommandParameter | string | the parameter associated with the OnCommand event.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the caption of the button.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsDefaultButton | boolean | true if this button is registered as a default button for a panel.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the button.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | caption of the button.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnClick | This method is invoked when the button is clicked.
OnCommand | This method is invoked when the button is clicked.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | canCauseValidation | whether to perform validation if the button is clicked.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | needPostBackScript | whether the button needs javascript to do postback.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the client-script code.
 | renderContents | Renders the body content enclosed between the control tag.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveButton
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TButtonColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TButtonColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ButtonType | TButtonColumnType | the type of command button.
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation, default is true.
 | CommandName | string | the command name associated with the OnCommand event.
 | DataImageUrlField | string | the field name from the data source to bind to the button image url.
 | DataImageUrlFormatString | string | the formatting string used to control how the button image url will be displayed.
 | DataTextField | string | the field name from the data source to bind to the button caption.
 | DataTextFormatString | string | the formatting string used to control how the button caption will be displayed.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
 | ImageUrl | string | the URL of the image file for image buttons.
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
 | Text | string | the text caption of the button.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback.
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TButtonColumnType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TButtonColumnType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TButtonType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TButtonType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCache

Namespace: System.Caching
Inheritance: TComponent » TApplicationComponent » TModule »
TCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
 | KeyPrefix | string | a unique prefix for the keys of cached values.
 | PrimaryCache | boolean | whether this cache module is used as primary/system cache.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | add | Stores a value identified by a key into cache if the cache does not contain this key.
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addValue | Stores a value identified by a key into cache if the cache does not contain this key.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes a value with the specified key from cache .
P | deleteValue | Deletes a value with the specified key from cache This method should be implemented by child classes to delete the data from actual cache storage.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Deletes all values from cache.
P | generateUniqueKey | a key generated from the provided key which ensures the uniqueness across applications.
 | get | Retrieves a value from cache with a specified key.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValue | Retrieves a value from cache with a specified key.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the cache module.
 | offsetExists | Returns whether there is a cache entry with a specified key.
 | offsetGet | .
 | offsetSet | .
 | offsetUnset | .
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | set | Stores a value identified by a key into cache.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setValue | Stores a value identified by a key in cache.
Derived classes
  • TAPCCache
  • TDbCache
  • TMemCache
  • TSqliteCache
  • TXCache
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCacheDependency

Namespace: System.Caching
Inheritance: TComponent »
TCacheDependency
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | HasChanged | boolean | whether the dependency has changed. (inherited from ICacheDependency)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TApplicationStateCacheDependency
  • TChainedCacheDependency
  • TDirectoryCacheDependency
  • TFileCacheDependency
  • TGlobalStateCacheDependency
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCacheDependencyList

Namespace: System.Caching
Inheritance: TComponent » TList »
TCacheDependencyList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCacheHttpSession

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent » THttpSession »
TCacheHttpSession
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | AutoStart | boolean | whether the session should be automatically started when the session module is initialized, defaults to false. (inherited from THttpSession)
R | Cache | ICache | the cache module being used for data storage.
 | CacheModuleID | string | the ID of the cache module.
R | Cookie | THttpCookie | cookie that will be used to store session ID. (inherited from THttpSession)
 | CookieMode | THttpSessionCookieMode | how to use cookie to store session ID. (inherited from THttpSession)
R | Count | integer | the number of session variables. (inherited from THttpSession)
 | GCProbability | integer | the probability (percentage) that the gc (garbage collection) process is started on every session initialization, defaults to 1 meaning 1% chance. (inherited from THttpSession)
 | ID | string | id of this module. (inherited from THttpSession)
R | IsStarted | boolean | whether the session has started. (inherited from THttpSession)
R | Iterator | TSessionIterator | Returns an iterator for traversing the session variables. (inherited from THttpSession)
 | KeyPrefix | string | prefix of session variable name to avoid conflict with other cache data.
R | Keys | array | the list of session variable names. (inherited from THttpSession)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | SavePath | string | the current session save path, defaults to '/tmp'. (inherited from THttpSession)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SessionID | string | the current session ID. (inherited from THttpSession)
 | SessionName | string | the current session name. (inherited from THttpSession)
 | Timeout | integer | the number of seconds after which data will be seen as 'garbage' and cleaned up, defaults to 1440 seconds. (inherited from THttpSession)
 | UseCustomStorage | boolean | whether to use user-specified handlers to store session data. (inherited from THttpSession)
 | UseTransparentSessionID | boolean | whether transparent sid support is enabled or not, defaults to false. (inherited from THttpSession)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | _close | Session close handler. (inherited from THttpSession)
 | _destroy | Session destroy handler.
 | _gc | Session GC (garbage collection) handler. (inherited from THttpSession)
 | _open | Session open handler. (inherited from THttpSession)
 | _read | Session read handler.
 | _write | Session write handler.
 | add | Adds a session variable. (inherited from THttpSession)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
P | calculateKey | a safe cache key associated with the session variable name.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clear | Removes all session variables. (inherited from THttpSession)
 | close | Ends the current session and store session data. (inherited from THttpSession)
 | contains | whether there is the named session variable. (inherited from THttpSession)
 | count | Returns the number of items in the session. (inherited from THttpSession)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | destroy | Destroys all data registered to a session. (inherited from THttpSession)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the module.
 | itemAt | Returns the session variable value with the session variable name. (inherited from THttpSession)
 | offsetExists | This method is required by the interface ArrayAccess. (inherited from THttpSession)
 | offsetGet | This method is required by the interface ArrayAccess. (inherited from THttpSession)
 | offsetSet | This method is required by the interface ArrayAccess. (inherited from THttpSession)
 | offsetUnset | This method is required by the interface ArrayAccess. (inherited from THttpSession)
 | open | Starts the session if it has not started yet. (inherited from THttpSession)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | remove | Removes a session variable. (inherited from THttpSession)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | toArray | the list of all session variables in array. (inherited from THttpSession)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCachePageStatePersister

Namespace: System.Web.UI
Inheritance: TComponent »
TCachePageStatePersister
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Cache | ICache | the cache module being used for data storage.
 | CacheModuleID | string | the ID of the cache module.
 | CacheTimeout | integer | the number of seconds in which the cached state will expire.
 | KeyPrefix | string | prefix of cache variable name to avoid conflict with other cache data.
 | Page | {unknown} | .
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
P | calculateKey | a key that is unique per user request.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | load | Loads page state from cache.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | save | Saves state in cache.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCachingStatement

Namespace: System.Data.SqlMap.Statements
TCachingStatement
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createCommand | .
 | executeInsert | .
 | executeQueryForList | .
 | executeQueryForMap | .
 | executeQueryForObject | .
 | executeUpdate | .
P | getCacheKey | .
 | getID | .
 | getManager | .
 | getStatement | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallback

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl »
TCallback
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ActiveControl | TBaseActiveCallbackControl | standard callback options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TTimeTriggeredCallback
  • TTriggeredCallback
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackClientScript

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent »
TCallbackClientScript
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | ClientFunctionsToExecute | array | list of client function to be executed during callback response.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addCssClass | Add a Css class name to the element.
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | addPostDataLoader | .
 | appear | Visual Effect: Gradually make the element appear.
 | appendContent | Append a HTML fragement to the element.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | blindDown | Visual Effect: Blind down.
 | blindUp | Visual Effect: Blind up.
 | callClientFunction | Executes a client-side statement.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | check | Client script to check or uncheck a checkbox or radio button.
 | click | Client script to click on an element.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | dropOut | Visual Effect: Drop out.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateScript | Evaluate a block of javascript enclosed in a boundary.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | fade | Visual Effect: Gradually fade the element.
 | focus | Focus on a particular element.
 | fold | Visual Effect: Fold.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | grow | Visual Effect: Gradually make an element grow to a predetermined size.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hide | Hides an element by changing its CSS display style to "none".
 | highlight | Visual Effect: High light the element for about 2 seconds.
 | insertContentAfter | Insert a HTML fragement after the element.
 | insertContentBefore | Insert a HTML fragement in before the element.
 | prependContent | Prepend a HTML fragement to the element.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | puff | Visual Effect: Gradually grow and fade the element.
 | pulsate | Visual Effect: Pulsate.
 | raiseClientEvent | Raise the client side event (given by $eventName) on a particular element.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | remove | Removes an element from the HTML page.
 | removeCssClass | Remove a Css class name from the element.
P | replace | Replace the content of an element with new content.
 | replaceContent | Replace the content of an element with new content contained in writer.
 | scrollTo | Scroll the top of the browser viewing area to the location of the element.
 | select | Client script to select/clear/check a drop down list, check box list, or radio button list.
 | setAttribute | Sets the attribute of a particular control.
 | setListItems | Sets the options of a select input element.
 | setOpacity | Set the opacity on a html element or control.
 | setStyle | Sets the style of element.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setValue | Client script to set the value of a particular input element.
 | shake | Visual Effect: Shake the element.
 | show | Shows an element by changing its CSS display style as empty.
 | shrink | Visual Effect: Shrink the element.
 | slideDown | Visual Effect: Slide down.
 | slideUp | Visual Effect: Side up.
 | squish | Visual Effect: Squish the element.
 | switchOff | Visual Effect: Switch Off effect.
 | toggle | Toggles the visibility of the element.
 | update | Update the element's innerHTML with new content.
 | visualEffect | Add a visual effect the element.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackClientSide

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TClientSideOptions »
TCallbackClientSide
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | EnablePageStateUpdate | boolean | client-side viewstate will be updated on callback response if true.
 | HasPriority | boolean | true if the callback request has priority and will abort existing prioritized request in order to send immediately.
 | OnComplete | string | javascript code for client-side onComplete event.
 | OnException | string | javascript code for client-side onException event.
 | OnFailure | string | javascript code for client-side onFailure event.
 | OnInteractive | string | javascript code for client-side onInteractive event.
 | OnLoaded | string | javascript code for client-side onLoaded event.
 | OnLoading | string | javascript code for client-side onLoading event.
 | OnPreDispatch | string | javascript code to be executed before a request is dispatched.
 | OnSuccess | string | javascript code for client-side onSuccess event.
 | OnUninitialized | string | javascript code for client-side onUninitialized event.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
 | PostBackParameter | string | post back event parameter.
 | PostBackTarget | string | post back target ID.
 | PostState | boolean | true to post the inputs of the form on callback, default is post the inputs on callback.
 | RequestTimeOut | integer | callback request timeout.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Returns javascript statement enclosed within a javascript function.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TActiveCustomValidatorClientSide
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackErrorHandler

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TModule » TErrorHandler »
TCallbackErrorHandler
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ErrorTemplatePath | string | the directory containing error template files. (inherited from TErrorHandler)
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | displayException | Displays the exceptions to the client-side TJavascriptLogger.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getErrorTemplate | Retrieves the template used for displaying external exceptions. (inherited from TErrorHandler)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getExceptionTemplate | Retrieves the template used for displaying internal exceptions. (inherited from TErrorHandler)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | handleError | Handles PHP user errors and exceptions. (inherited from TErrorHandler)
P | handleExternalError | Displays error to the client user. (inherited from TErrorHandler)
P | handleRecursiveError | Handles error occurs during error handling (called recursive error). (inherited from TErrorHandler)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
SP | hideSecurityRelated | @since 3. (inherited from TErrorHandler)
 | init | Initializes the module. (inherited from TErrorHandler)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackEventParameter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TEventParameter »
TCallbackEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CallbackParameter | mixed | callback request parameter.
R | NewWriter | TCallbackResponseWriter | holds the response content.
 | ResponseData | mixed | callback response data.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TAutoCompleteEventParameter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackOptions

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl »
TCallbackOptions
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | Callback client-side options can be set by setting the properties of the ClientSide property.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | callback client-side options.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackPageStateTracker

Namespace: System.Web.UI.ActiveControls
TCallbackPageStateTracker
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | addStatesToTrack | Add a list of view states to track.
P | client | callback client scripting.
P | getChanges | list of viewstate and the changed data.
P | getStatesToTrack | list of viewstates to track.
 | respondToChanges | For each of the changes call the corresponding change handlers.
 | trackChanges | Start tracking view state changes.
P | updateAccessKey | Updates the modifier access key .
P | updateAttributes | Updates/adds a list of attributes on the control.
P | updateEnabled | Enables or Disables the control on the client-side.
P | updateStyle | Updates the CSS style on the control on the client-side.
P | updateTabIndex | Updates the tab index.
P | updateToolTip | Updates the tooltip.
P | updateVisible | Hides or shows the control on the client-side.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackResponseAdapter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » THttpResponseAdapter »
TCallbackResponseAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | RedirectedUrl | string | new url for callback response to redirect to.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response object adapted. (inherited from THttpResponseAdapter)
 | ResponseData | mixed | callback response data.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createNewHtmlWriter | Returns a new instance of THtmlWriter.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flushContent | Flushes the contents in the writers.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
httpRedirect | Delay the redirect until we process the rest of the page.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCallbackResponseWriter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TTextWriter »
TCallbackResponseWriter
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Boundary | string | boundary identifier.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flush | Returns the text content wrapped within a HTML comment with boundary identifier as its comment content.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
write | Writes a string. (inherited from TTextWriter)
writeLine | Writers a string and terminates it with a newline. (inherited from TTextWriter)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCaptcha

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TImage »
TCaptcha
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AlternateText | string | the alternative text displayed in the TImage component when the image is unavailable. (inherited from TImage)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
RP | CaptchaScriptFile | string | the file path of the PHP script generating the token image.
 | CaseSensitive | boolean | whether the token should be treated as case-sensitive.
 | ChangingTokenBackground | boolean | whether the background of the token image should be variated during postbacks.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL of the image file. (inherited from TImage)
 | DescriptionUrl | string | the URL to long description. (inherited from TImage)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
RP | FontFile | {unknown} | .
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageAlign | string | the alignment of the image with respective to other elements on the page, defaults to empty. (inherited from TImage)
 | ImageUrl | string | the URL of the image file. (inherited from TImage)
R | IsTokenExpired | boolean | whether the currently generated token has expired.
 | MaxTokenLength | integer | the maximum length of the token.
 | MinTokenLength | integer | the minimum length of the token.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | PrivateKey | string | the private key used for generating the token.
 | PublicKey | string | the public key used for generating the token.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of image control. (inherited from TImage)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | TestLimit | integer | how many times a generated token can be tested.
R | Token | string | the token that will be displayed.
 | TokenAlphabet | string | the characters that may appear in the token.
 | TokenExpiry | integer | the number of seconds that a generated token will remain valid.
 | TokenFontSize | integer | the font size used for displaying the token in an image.
RP | TokenImageOptions | string | the options to be passed to the token image generator.
 | TokenImageTheme | integer | the theme of the token image.
RP | TokenLength | integer | the length of the token to be generated.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Configures the image URL that shows the token.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes related to an HTML image element to renderer. (inherited from TImage)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
S | checkRequirements | Checks the requirements needed for generating CAPTCHA images.
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | generatePrivateKeyFile | Generates a file with a randomly generated private key.
P | generateRandomKey | a randomly generated key.
P | generateToken | Generates the token.
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | hash2string | Converts a hash string into a string with characters consisting of alphanumeric characters.
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | regenerateToken | Regenerates the token to be displayed.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the image. (inherited from TImage)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
 | validate | Validates a user input with the token.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCaptchaValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TCaptchaValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CaptchaControl | string | the ID path of the CAPTCHA control to validate.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
P | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | findCaptchaControl | the CAPTCHA control to be validated against @throws TConfigurationException if the CAPTCHA cannot be found according to CaptchaControl.
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TChainedCacheDependency

Namespace: System.Caching
Inheritance: TComponent » TCacheDependency »
TChainedCacheDependency
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Dependencies | TCacheDependencyList | list of dependency objects.
R | HasChanged | boolean | Performs the actual dependency checking.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCheckBox

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TCheckBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | whether clicking on the checkbox will post the page.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event triggered by this checkbox will cause input validation, default is true.
 | Checked | boolean | whether the checkbox is checked.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | boolean | Returns the value indicating whether the checkbox is checked.
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | InputAttributes | TMap | list of attributes to be rendered for the checkbox.
 | IsValid | bool | Returns true if this control validated successfully.
R | LabelAttributes | TMap | list of attributes to be rendered for label beside the checkbox.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | bool | Check if we need a span tag to surround this control.
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | SurroundingTagID | string | the id of the surrounding tag or this clientID if no such tag needed.
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the checkbox.
 | TextAlign | TTextAlign | the alignment (Left or Right) of the text caption, defaults to TTextAlign::Right.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the checkbox causes validation upon postback.
R | ValidationPropertyValue | mixed | Returns the value of the property that needs validation.
 | Value | string | the value of the checkbox.
RP | ValueAttribute | string | the value attribute to be rendered.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCheckedChanged | Raises OnCheckedChanged event when Checked changes value during postback.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the checkbox to receive postback data during postback.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the client-script code.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderInputTag | Renders a checkbox input element.
P | renderLabel | Renders a label beside the checkbox.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveCheckBox
  • TRadioButton
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCheckBoxColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TCheckBoxColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataField | string | the field name from the data source to bind to the column.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
 | ReadOnly | boolean | whether the items in the column can be edited.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCheckBoxList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl »
TCheckBoxList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
 | CellPadding | integer | the cellpadding for the table keeping the checkbox list.
 | CellSpacing | integer | the cellspacing for the table keeping the checkbox list.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item.
R | HasHeader | boolean | Returns a value indicating whether this control contains header item.
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items.
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control supports multiple selection.
 | IsValid | bool | Returns true if this control validated successfully.
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox.
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
 | RepeatColumns | integer | the number of columns that the list should be displayed with.
 | RepeatDirection | string | the direction of traversing the list, defaults to 'Vertical'.
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers).
 | RepeatLayout | string | how the list should be displayed, using table or using line breaks.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | boolean | Wether the list should be rendered inside a span or not .
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | TextAlign | TTextAlign | the alignment of the text caption, defaults to TTextAlign::Right.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated.
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers for post data on postback.
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TListControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createRepeatedControl | Creates a control used for repetition (used as a template).
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID.
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | generateItemStyle | Returns a style used for rendering items.
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox list control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list.
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TActiveCheckBoxList
  • TRadioButtonList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TChoiceFormat

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TControl » TI18NControl » TTranslate »
TChoiceFormat
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | Catalogue | string | Get the message catalogue. (inherited from TTranslate)
 | Charset | string | Gets the charset. (inherited from TI18NControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | Culture | string | Get the specific culture for this control. (inherited from TI18NControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | Key | string | Get the key for message lookup. (inherited from TTranslate)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parameters | TAttributeCollection | Returns the list of custom parameters. (inherited from TTranslate)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text to be localized/translated. (inherited from TTranslate)
 | Trim | boolean | Trim the content or not. (inherited from TTranslate)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Value | float | the numerical value.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getParameter | parameter value, null if parameter does not exist. (inherited from TTranslate)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasParameter | whether the named parameter exists. (inherited from TTranslate)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removeParameter | Removes the named parameter. (inherited from TTranslate)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | renders the translated string. (inherited from TTranslate)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setParameter | . (inherited from TTranslate)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | translateText | Display the choosen translated string.
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCircleHotSpot

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » THotSpot »
TCircleHotSpot
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key that allows you to quickly navigate to the HotSpot region. (inherited from THotSpot)
 | AlternateText | string | the alternate text to display for a HotSpot object. (inherited from THotSpot)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from THotSpot)
 | CausesValidation | boolean | whether postback event trigger by this hotspot will cause input validation, default is true. (inherited from THotSpot)
R | Coordinates | string | coordinates defining this hotspot shape.
R | HasAttributes | boolean | whether the hotspot has custom attributes. (inherited from THotSpot)
 | HotSpotMode | THotSpotMode | the behavior of a HotSpot object when it is clicked. (inherited from THotSpot)
 | NavigateUrl | string | the URL to navigate to when a HotSpot object is clicked. (inherited from THotSpot)
 | PostBackValue | string | a value that is post back when the HotSpot is clicked. (inherited from THotSpot)
 | Radius | integer | radius of the circular HotSpot region.
R | Shape | string | shape of this hotspot.
 | TabIndex | integer | the tab index of the HotSpot region. (inherited from THotSpot)
 | Target | string | the target window or frame to display the new page when the HotSpot region is clicked. (inherited from THotSpot)
 | ValidationGroup | string | the group of validators which the hotspot causes validation upon postback. (inherited from THotSpot)
 | X | integer | the X coordinate of the center of the circular HotSpot region.
 | Y | integer | the Y coordinate of the center of the circular HotSpot region.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from THotSpot)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from THotSpot)
 | hasAttribute | whether the named attribute exists. (inherited from THotSpot)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | removeAttribute | Removes the named attribute. (inherited from THotSpot)
 | render | Renders this hotspot. (inherited from THotSpot)
 | setAttribute | Sets a custom hotspot attribute. (inherited from THotSpot)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from THotSpot)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TClientScript

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TClientScript
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PradoScripts | string | comma delimited list of javascript libraries to included on the page.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScriptUrl | string | custom javascript file url.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Calls the client script manager to add each of the requested client script libraries.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the body content as javascript block.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
P | renderCustomScript | Registers the body content as javascript.
P | renderCustomScriptFile | Renders the custom script file.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TClientScriptLoader

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TClientScriptLoader
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptUrl | string | clientscript.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DebugMode | boolean | javascript comments stripped in non-debug mode.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableGzip | boolean | enables gzip compression of the javascript if possible, default is true.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | PackagePath | string | custom javascript library directory.
 | PackageScripts | string | comma delimited list of javascript library packages to load.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the script element.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TClientScriptManager

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent »
TClientScriptManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | PradoScriptAssetUrl | string | Prado javascript library base asset url.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | RequiresHead | boolean | whether THead is required in order to render CSS and js within head @since 3.
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getCallbackReference | Returns javascript statement that create a new callback request object.
P | getDefaultButtonOptions | default button options.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPackagePathUrl | tuple($path,$url).
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasBeginScripts | true if any begin scripts are registered.
 | hasEndScripts | true if any end scripts are registered.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | isBeginScriptRegistered | whether there is a beginning javascript block registered with the specified key.
 | isEndScriptRegistered | whether there is an ending javascript block registered with the specified key.
 | isHeadScriptFileRegistered | whether there is a head javascript file registered with the specified key.
 | isHeadScriptRegistered | whether there is a head javascript block registered with the specified key.
 | isHiddenFieldRegistered | whether there is a hidden field registered with the specified key.
 | isScriptFileRegistered | whether there is a javascript file registered with the specified key.
 | isStyleSheetFileRegistered | whether there is a CSS file registered with the specified key.
 | isStyleSheetRegistered | whether there is a CSS block registered with the specified key.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerBeginScript | Registers a javascript script block at the beginning of the form .
 | registerCallbackControl | Registers callback javascript for a control.
 | registerDefaultButton | Register a default button to panel.
 | registerEndScript | Registers a javascript script block at the end of the form .
 | registerFocusControl | Registers the control to receive default focus.
 | registerHeadScript | Registers a javascript block in the page head.
 | registerHeadScriptFile | Registers a javascript file in the page head .
 | registerHiddenField | Registers a hidden field to be rendered in the form.
 | registerJavascriptPackages | Publishes a javascript library path and register packages to be loaded.
 | registerPostBackControl | Registers postback javascript for a control.
 | registerPradoScript | Registers Prado javascript by library name.
 | registerScriptFile | Registers a javascript file to be rendered within the form .
 | registerStyleSheet | Registers a CSS block to be rendered in the page head .
 | registerStyleSheetFile | Registers a CSS file to be rendered in the page head The CSS files in themes are registered in onPreRenderComplete if you want to override CSS styles in themes you need to register it after this event is completed.
 | renderBeginScripts | .
 | renderEndScripts | .
 | renderHeadScriptFiles | .
 | renderHeadScripts | .
 | renderHiddenFields | .
P | renderPradoScripts | Renders the HTML tags for PRADO js files .
 | renderScriptFiles | .
 | renderStyleSheetFiles | .
 | renderStyleSheets | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | verifyJavascriptPackages | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TClientSideOptions

Namespace: System.Web.UI
Inheritance: TComponent »
TClientSideOptions
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Options | TMap | gets the list of options as TMap.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Ensure that the javascript statements are wrapped in a javascript function block as function(sender, parameter){ //code }.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block.
P | setOption | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TCallbackClientSide
  • TClientSideValidationSummaryOptions
  • TColorPickerClientSide
  • TDatePickerClientScript
  • TSliderClientScript
  • TValidatorClientSide
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TClientSideValidationSummaryOptions

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TClientSideOptions »
TClientSideValidationSummaryOptions
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | OnHideSummary | string | javascript code for client-side OnHideSummary event.
 | OnShowSummary | string | javascript code for client-side OnShowSummary event.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Ensure the string is a valid javascript function.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TColorPicker

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox »
TColorPicker
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
RP | AssetUrl | string | asset file url.
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. (inherited from TTextBox)
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CancelButtonText | string | text for the color picker Cancel button.
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TColorPickerClientSide | javascript event options.
 | ColorPickerStyle | string | current color picker style.
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the TTextBox control. (inherited from TTextBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
 | Mode | TColorPickerMode | current color picker UI mode.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | OKButtonText | string | text for the color picker OK button.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
RP | PostBackOptions | array | Get javascript color picker options.
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowColorPicker | boolean | whether the color picker should pop up when the button is clicked.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox. (inherited from TTextBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component. (inherited from TTextBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TTextBox)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the color picker Css asset files.
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TTextBox)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TTextBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
P | publishColorPickerAssets | Publish the color picker assets.
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for textbox. (inherited from TTextBox)
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode. (inherited from TTextBox)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders additional body content.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TColorPickerClientSide

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TClientSideOptions »
TColorPickerClientSide
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | OnColorSelected | string | javascript code for when a color is selected.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Ensure that the javascript statements are wrapped in a javascript function block as function(sender, parameter){ //code }. (inherited from TClientSideOptions)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TColorPickerMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TColorPickerMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCommandEventParameter

Namespace: System.Web.UI
Inheritance: TComponent » TEventParameter »
TCommandEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandName | string | name of the command.
R | CommandParameter | string | parameter of the command.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TDataGridCommandEventParameter
  • TDataListCommandEventParameter
  • TRepeaterCommandEventParameter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCompareValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TCompareValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToCompare | string | the input component to compare with the input control being validated.
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | DataType | TValidationDataType | the data type that the values being compared are converted to before the comparison is made.
 | DateFormat | string | the date validation date format if any.
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Operator | TValidationCompareOperator | the comparison operation to perform.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | ValueToCompare | string | the constant value to compare with the value entered by the user into the input component being validated.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getComparisonValues | Parse the pair of values into the appropriate value type.
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCompleteWizardStep

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TView » TWizardStep »
TCompleteWizardStep
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Active | boolean | whether this view is active. (inherited from TView)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowReturn | boolean | whether this step can be re-visited. (inherited from TWizardStep)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StepType | TWizardStepType | the wizard step type.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Title | string | the title for this step. (inherited from TWizardStep)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether this view is visible. (inherited from TView)
 | Wizard | TWizard | the wizard owning this step. (inherited from TWizardStep)
Events
Name | Description
OnActivate | Raises OnActivate event. (inherited from TView)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDeactivate | Raises OnDeactivate event. (inherited from TView)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TComponent

Namespace: System
TComponent
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template.
attachEventHandler | Attaches an event handler to an event.
canGetProperty | Determines whether a property can be read.
canSetProperty | Determines whether a property can be set.
createdOnTemplate | This method is invoked after the component is instantiated by a template.
detachEventHandler | Detaches an existing event handler.
evaluateExpression | Evaluates a PHP expression in the context of this control.
evaluateStatements | Evaluates a list of PHP statements.
getEventHandlers | Returns the list of attached event handlers for an event.
getSubProperty | Evaluates a property path.
hasEvent | Determines whether an event is defined.
hasEventHandler | whether an event has been attached one or several handlers.
hasProperty | Determines whether a property is defined.
raiseEvent | Raises an event.
setSubProperty | Sets a value to a property path.
Derived classes
  • TActiveRecord
  • TActiveRecordGateway
  • TActiveRecordManager
  • TApplication
  • TApplicationComponent
  • TApplicationConfiguration
  • TAuthorizationRule
  • TAutoCompleteTemplate
  • TBaseActiveControl
  • TCacheDependency
  • TCachePageStatePersister
  • TClientSideOptions
  • TComponentReflection
  • TCompositeLiteral
  • TDataGatewayCommand
  • TDataSourceSelectParameters
  • TDataSourceView
  • TDbCommand
  • TDbCommandBuilder
  • TDbConnection
  • TDbDataReader
  • TDbMetaData
  • TDbTableColumn
  • TDbTableInfo
  • TDbTransaction
  • TDiscriminator
  • TDummyDataSource
  • TEventParameter
  • TFont
  • THotSpot
  • THttpCookie
  • TList
  • TListItem
  • TLogger
  • TMap
  • TMappedStatement
  • TMetaTag
  • TOracleTableInfo
  • TPageConfiguration
  • TPageStatePersister
  • TPagedDataSource
  • TParameterMap
  • TParameterProperty
  • TPreparedStatement
  • TQueue
  • TRepeatInfo
  • TResultMap
  • TResultProperty
  • TResultSetListItemParameter
  • TResultSetMapItemParameter
  • TSessionPageStatePersister
  • TSqlCriteria
  • TSqlMapCacheModel
  • TSqlMapGateway
  • TSqlMapManager
  • TSqlMapStatement
  • TSqlMapTypeHandler
  • TStack
  • TStaticSql
  • TStyle
  • TSubMap
  • TTableGateway
  • TTextWriter
  • TUri
  • TUrlMappingPattern
  • TUser
  • TWizardNavigationTemplate
  • TWizardSideBarListItemTemplate
  • TWizardSideBarTemplate
  • TXmlElement
  • Translation
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TComponentReflection

Namespace: System
Inheritance: TComponent »
TComponentReflection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ClassName | string | class name of the component.
R | Events | array | list of component events.
R | Methods | array | list of public/protected methods.
R | Properties | array | list of component properties.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determinePropertyType | Determines the property type.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCompositeControl

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TControl »
TCompositeControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls.
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TTemplateControl
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCompositeLiteral

Namespace: System.Web.UI
Inheritance: TComponent »
TCompositeLiteral
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Container | TComponent | container of this component.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
dataBind | Performs databindings.
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateDynamicContent | Evaluates the expressions and/or statements in the component.
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
render | Renders the content stored in this component.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TConditional

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TConditional
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | Condition | string | the PHP expression used for determining which template to use.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | FalseTemplate | ITemplate | the template applied when Condition is false.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | TrueTemplate | ITemplate | the template applied when Condition is true.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TConfigurationException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TConfigurationException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
  • TTemplateException
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TContent

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TContent
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the control is instantiated on a template.
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TContentDirection

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TContentDirection
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TContentPlaceHolder

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TContentPlaceHolder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the control is instantiated on a template.
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TControl

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent »
TControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter.
R | AllowChildControls | boolean | whether body contents are allowed for this control.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes.
P | ChildControlsCreated | boolean | whether child controls have been created.
R | ClientID | string | Returns the client ID of the control.
P | ControlStage | integer | Gets the lifecycle step the control is currently at.
R | Controls | TControlCollection | the child control collection.
 | CustomData | mixed | Returns custom data associated with this control.
 | EnableTheming | boolean | whether theming is enabled for this control.
 | EnableViewState | boolean | whether viewstate is enabled.
 | Enabled | boolean | Returns a value indicating whether the control is enabled.
R | HasAdapter | boolean | whether there is an adapter for this control.
R | HasAttributes | boolean | whether the control has custom attributes.
R | HasChildInitialized | boolean | true if the child control has been initialized.
R | HasControls | boolean | whether the control has child controls.
R | HasInitialized | boolean | true if the onInit event has raised.
R | HasLoaded | boolean | true if the onLoad event has raised.
R | HasLoadedPostData | boolean | true if the control has loaded post data.
R | HasPreRendered | boolean | true if onPreRender event has raised.
 | ID | string | Returns the id of the control.
R | NamingContainer | TControl | the naming container of this control.
 | Page | TPage | the page that contains this control.
R | Parent | TControl | the parent of this control.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set.
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control.
 | TemplateControl | TTemplateControl | the control whose template contains this control.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible.
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event.
OnInit | This method is invoked when the control enters 'OnInit' stage.
OnLoad | This method is invoked when the control enters 'OnLoad' stage.
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage.
OnUnload | This method is invoked when the control enters 'OnUnload' stage.
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders.
 | addedControl | Adds a control into the child collection of the control.
 | applyStyleSheetSkin | Applies a stylesheet skin to a control.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression.
P | autoDataBindProperties | Auto databinding properties of the control.
 | bindProperty | Sets up the binding between a property (or property path) and an expression.
 | broadcastEvent | Broadcasts an event.
 | bubbleEvent | This method responds to a bubbled event.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data.
P | clearControlState | Clears a controlstate value.
 | clearNamingContainer | Resets the control as a naming container.
 | clearViewState | Clears a viewstate value.
S | convertUniqueIdToClientId | Converts a unique ID to a client ID.
 | createChildControls | Creates child controls.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls .
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control.
P | dataBindChildren | Databinding child controls.
P | dataBindProperties | Databinding properties of the control.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container.
 | findControlsByID | Finds all child and grand-child controls with the specified ID.
 | findControlsByType | Finds all child and grand-child controls that are of the specified type.
 | focus | Sets input focus to this control.
 | getAttribute | attribute value, null if attribute does not exist.
P | getControlState | Returns a controlstate value.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value.
 | hasAttribute | whether the named attribute exists.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls.
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc.
 | isObjectRegistered | whether an object has been registered with the name @see registerObject.
P | loadRecursive | Performs the Load step for the control and all its child controls.
 | loadState | This method is invoked right after the control has loaded its state.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name.
 | removeAttribute | Removes the named attribute.
 | removedControl | Removes a control from the child collection of the control.
 | render | Renders the control.
 | renderChildren | Renders the children of the control.
 | renderControl | Renders the control.
 | saveState | This method is invoked when control state is to be saved.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection.
 | setAttribute | Sets a custom control attribute.
P | setControlState | Sets a controlstate value.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value.
 | trackViewState | Sets a value indicating whether we should keep data in viewstate.
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control.
 | unbindProperty | Breaks the binding between a property (or property path) and an expression.
P | unloadRecursive | Performs the Unload step for the control and all its child controls.
 | unregisterObject | Unregisters an object by name.
Derived classes
  • TCallback
  • TCallbackOptions
  • TClientScript
  • TCompositeControl
  • TConditional
  • TContent
  • TContentPlaceHolder
  • TDataSourceControl
  • TExpression
  • TForm
  • THead
  • THiddenField
  • TI18NControl
  • TLiteral
  • TMultiView
  • TOutputCache
  • TPlaceHolder
  • TRepeaterItem
  • TSafeHtml
  • TStatements
  • TStyleSheet
  • TTranslateParameter
  • TView
  • TWebControl
  • TWizardNavigationContainer
  • TXmlTransform
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TControlAdapter

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent »
TControlAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Control | TControl | the control to which this adapter is attached.
R | Page | TPage | the page that contains the attached control.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Name | Description
OnInit | This method is invoked when the control enters 'OnInit' stage.
OnLoad | This method is invoked when the control enters 'OnLoad' stage.
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage.
OnUnload | This method is invoked when the control enters 'OnUnload' stage.
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createChildControls | Creates child controls for the attached control.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
loadState | Loads additional persistent control state.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
render | This method is invoked when the control renders itself.
renderChildren | Renders the control's children.
saveState | Saves additional persistent control state.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TActiveControlAdapter
  • TActivePageAdapter
  • TWebControlAdapter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TControlCollection

Namespace: System.Web.UI
Inheritance: TComponent » TList »
TControlCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TControl | the control that owns this collection.
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Overrides the parent implementation by invoking clearNamingContainer.
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
  • TEmptyControlCollection
  • TTabViewCollection
  • TTableCellCollection
  • TTableRowCollection
  • TViewCollection
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TCustomValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TCustomValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ClientValidationFunction | string | the name of the custom client-side script function used for validation.
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnServerValidate | This method is invoked when the server side validation happens.
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Only register the client-side validator if ClientValidationFunction is set.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
  • TActiveCustomValidator
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataBoundControl

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TDataBoundControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled.
 | AllowPaging | boolean | whether paging is enabled.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DataMember | {unknown} | .
 | DataSource | Traversable | data source object, defaults to null.
 | DataSourceID | string | ID path to the data source control.
RP | DataSourceView | {unknown} | .
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized.
P | IsDataBound | boolean | whether databind has been invoked in the previous page request.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available.
 | PageSize | integer | the number of data items on each page.
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control).
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | .
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource.
 | VirtualItemCount | integer | virtual number of data items in the data source.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event.
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized.
OnInit | Sets page's OnPreLoad event handler as pagePreLoad.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createPagedDataSource | creates a paged data source.
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding.
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | .
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | .
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true.
P | performDataBinding | .
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source.
Derived classes
  • TBaseDataList
  • TListControl
  • TRepeater
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataFieldAccessor

Namespace: System.Util
TDataFieldAccessor
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | getDataFieldValue | Evaluates the data value at the specified field.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGatewayCommand

Namespace: System.Data.DataGateway
Inheritance: TComponent »
TDataGatewayCommand
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Builder | TDbCommandBuilder | .
R | DbConnection | TDbConnection | .
R | LastInsertID | mixed | Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
R | TableInfo | TDbTableInfo | .
Events
Name | Description
OnCreateCommand | Raised when a command is prepared and parameter binding is completed.
OnExecuteCommand | Raised when a command is executed and the result from the database was returned.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | count | number of records.
 | createCriteriaFromString | criteria created from the method name and its arguments.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Executes a delete command.
 | deleteByPk | number of rows affected.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | extractMatchingConditions | Calculates the AND/OR condition from dynamic method substrings using table meta data, allows for any AND-OR combinations.
 | find | Find one record matching the critera.
 | findAll | Find one or more matching records.
 | findAllByIndex | .
 | findAllByPk | record reader.
 | findAllBySql | Find zero or more matching records for arbituary SQL.
 | findByPk | matching record.
 | findBySql | Find one matching records for arbituary SQL.
P | getCompositeKeyCondition | Construct a "pk IN ('key1', 'key2', .
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getFindCommand | Build the find command from the criteria.
 | getIndexKeyCondition | .
P | getPrimaryKeyCondition | Create the condition and parameters for find by primary.
P | getSqlCommand | Build sql command from the criteria.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | insert | Inserts a new record into the table.
P | quoteTuple | quoted recursive tuple values, e.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | update | Updates the table with new data.
 | updateByPk | number of records affected.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGatewayEventParameter

Namespace: System.Data.DataGateway
Inheritance: TComponent » TEventParameter »
TDataGatewayEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TDbCommand | The database command to be executed.
R | Criteria | TSqlCriteria | criteria used to bind the sql query parameters.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGatewayResultEventParameter

Namespace: System.Data.DataGateway
Inheritance: TComponent » TEventParameter »
TDataGatewayResultEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TDbCommand | database command executed.
 | Result | mixed | result returned from executing the command.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGrid

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TBaseDataList »
TDataGrid
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AllowSorting | boolean | whether sorting is enabled.
R | AlternatingItemStyle | TTableItemStyle | the style for each alternating item.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
R | AutoColumns | TDataGridColumnCollection | automatically generated datagrid columns.
 | AutoGenerateColumns | boolean | whether datagrid columns should be automatically generated.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the datagrid.
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | BottomPager | TDataGridPager | the pager displayed at the bottom of datagrid.
 | Caption | string | caption for the datagrid.
 | CaptionAlign | TTableCaptionAlign | datagrid caption alignment.
 | CellPadding | integer | the cellpadding for the table layout. (inherited from TBaseDataList)
 | CellSpacing | integer | the cellspacing for the table layout. (inherited from TBaseDataList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | Columns | TDataGridColumnCollection | manually specified datagrid columns.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DataKeyField | string | the field of the data source that provides the keys of the list items. (inherited from TBaseDataList)
R | DataKeys | TList | the keys used in the data listing control. (inherited from TBaseDataList)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
R | EditItem | TDataGridItem | the edit item.
 | EditItemIndex | integer | the zero-based index of the edit item in Items.
R | EditItemStyle | TTableItemStyle | the style for edit item.
 | EmptyTemplate | ITemplate | the template applied when no data is bound to the datagrid.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
R | Footer | TDataGridItem | the footer item.
R | FooterStyle | TTableItemStyle | the style for footer.
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GridLines | TTableGridLines | the grid line setting of the table layout. (inherited from TBaseDataList)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
R | Header | TDataGridItem | the header item.
R | HeaderStyle | TTableItemStyle | the style for header.
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the table content. (inherited from TBaseDataList)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
R | ItemCount | integer | number of items.
R | ItemStyle | TTableItemStyle | the style for every item.
R | Items | TDataGridItemCollection | datagrid item collection.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | PagerStyle | TDataGridPagerStyle | the style for pager.
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
R | SelectedItem | TDataGridItem | the selected item, null if no item is selected.
 | SelectedItemIndex | integer | the zero-based index of the selected item in Items.
R | SelectedItemStyle | TTableItemStyle | the style for selected item.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowFooter | boolean | whether the footer should be displayed.
 | ShowHeader | boolean | whether the header should be displayed.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
R | TableBodyStyle | TStyle | the style for tbody element, if any @since 3.
R | TableFootStyle | TStyle | the style for tfoot element, if any @since 3.
R | TableHeadStyle | TStyle | the style for thead element, if any @since 3.
RP | TagName | string | tag name (table) of the datagrid.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | TopPager | TDataGridPager | the pager displayed at the top of datagrid.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCancelCommand | Raises OnCancelCommand event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnDeleteCommand | Raises OnDeleteCommand event.
OnEditCommand | Raises OnEditCommand event.
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnItemCommand | Raises OnItemCommand event.
OnItemCreated | Raises OnItemCreated event.
OnItemDataBound | Raises OnItemDataBound event.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPageIndexChanged | Raises OnPageIndexChanged event.
OnPagerCreated | Raises OnPagerCreated event.
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event. (inherited from TBaseDataList)
OnSortCommand | Raises OnSortCommand event.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
OnUpdateCommand | Raises OnUpdateCommand event.
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds objects parsed in template to datagrid.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
P | applyItemStyles | Applies styles to items, header, footer and separators.
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation to handle OnItemCommand event which is bubbled from TDataGridItem child controls.
P | buildNextPrevPager | Builds a next-prev pager .
P | buildNumericPager | Builds a numeric pager .
P | buildPager | Builds the pager content based on pager style.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
P | createAutoColumns | Automatically generates datagrid columns based on datasource schema .
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createItem | Creates a datagrid item instance based on the item type and index.
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createPagerButton | Creates a pager button.
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDataFieldValue | Returns the value of the data at the specified field. (inherited from TBaseDataList)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | initializeItem | Initializes a datagrid item and cells inside it .
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads item count information from viewstate.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate datagrid items from data source.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the datagrid.
 | renderBeginTag | Renders the openning tag for the datagrid control which will render table caption if present.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderTable | Renders the tabular data.
 | reset | Clears up all items in the datagrid.
P | restoreGridFromViewState | Restores datagrid content from viewstate.
 | saveState | Saves item count in viewstate.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent »
TDataGridColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together.
 | FooterRenderer | string | the class name for the column footer cell renderer.
R | FooterStyle | TTableItemStyle | the style for footer.
 | FooterText | string | the text to be displayed in the footer of this column.
 | HeaderImageUrl | string | the url of the image to be displayed in header.
 | HeaderRenderer | string | the class name for the column header cell renderer.
R | HeaderStyle | TTableItemStyle | the style for header.
 | HeaderText | string | the text to be displayed in the header of this column.
 | ID | string | the ID of the column.
R | ItemStyle | TTableItemStyle | the style for item.
 | Owner | TDataGrid | datagrid that owns this column.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string.
P | getDataFieldValue | Fetches the value of the data at the specified field.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column.
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell.
P | initializeHeaderCell | Initializes the header cell.
 | loadState | Loads persistent state values.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value.
Derived classes
  • TBoundColumn
  • TButtonColumn
  • TCheckBoxColumn
  • TDropDownListColumn
  • TEditCommandColumn
  • THyperLinkColumn
  • TLiteralColumn
  • TTemplateColumn
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridColumnCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList »
TDataGridColumnCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TDataGrid | the control that owns this collection.
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridCommandEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter » TCommandEventParameter »
TDataGridCommandEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandName | string | name of the command. (inherited from TCommandEventParameter)
R | CommandParameter | string | parameter of the command. (inherited from TCommandEventParameter)
R | CommandSource | TControl | the control originally raises the Command event.
R | Item | TDataGridItem | the TDataGridItem control responsible for the event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridItem

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTableRow »
TDataGridItem
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | Cells | TTableCellCollection | list of TTableCell controls. (inherited from TTableRow)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item @since 3.
 | DataItem | mixed | This property is deprecated since v3.
R | DataSourceIndex | integer | the index of the datagrid item from the bound data source.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | ItemIndex | integer | zero-based index of the item in the item collection of datagrid.
 | ItemType | TListItemType | item type.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TableSection | TTableRowSection | location of a row in a table. (inherited from TTableRow)
RP | TagName | string | tag name for the table. (inherited from TTableRow)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TTableRow)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TTableRow)
P | createStyle | Creates a style object for the control. (inherited from TTableRow)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table row . (inherited from TTableRow)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridItemCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList »
TDataGridItemCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridItemEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TDataGridItemEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Item | TDataGridItem | datagrid item related with the corresponding event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridItemRenderer

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TDataRenderer » TItemDataRenderer »
TDataGridItemRenderer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item. (inherited from TDataRenderer)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
 | ItemIndex | integer | Returns a value indicating the zero-based index of the item in the corresponding data control's item collection. (inherited from TItemDataRenderer)
 | ItemType | TListItemType | item type. (inherited from TItemDataRenderer)
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPageChangedEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TDataGridPageChangedEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandSource | TControl | the control originally raises the OnCommand event.
R | NewPageIndex | integer | new page index.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPager

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TPanel »
TDataGridPager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the panel component. (inherited from TPanel)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | DataGrid | TDataGrid | the datagrid owning this pager.
 | DefaultButton | string | the ID path to the default button. (inherited from TPanel)
 | Direction | string | alignment of the content in the panel. (inherited from TPanel)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GroupingText | string | the legend text when the panel is used as a fieldset. (inherited from TPanel)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the panel, defaults to 'NotSet'. (inherited from TPanel)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | ItemType | string | item type.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScrollBars | string | the visibility and position of scroll bars in a panel control, defaults to None. (inherited from TPanel)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the panel. (inherited from TPanel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the content wraps within the panel. (inherited from TPanel)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TPanel)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TPanel)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TPanel)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TPanel)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPagerButtonType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDataGridPagerButtonType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPagerEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TDataGridPagerEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Pager | TDataGridPager | datagrid pager related with the corresponding event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPagerMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDataGridPagerMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPagerPosition

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDataGridPagerPosition
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridPagerStyle

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TStyle » TPanelStyle »
TDataGridPagerStyle
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | BackColor | string | the background color of the control. (inherited from TStyle)
 | BackImageUrl | string | the URL of the background image for the panel component. (inherited from TPanelStyle)
 | BorderColor | string | the border color of the control. (inherited from TStyle)
 | BorderStyle | string | the border style of the control. (inherited from TStyle)
 | BorderWidth | string | the border width of the control. (inherited from TStyle)
 | ButtonType | TDataGridPagerButtonType | the type of command button.
 | CssClass | string | the CSS class of the control. (inherited from TStyle)
 | CustomStyle | string | the custom style of the control. (inherited from TStyle)
 | Direction | TContentDirection | alignment of the content in the panel. (inherited from TPanelStyle)
 | DisplayStyle | TDisplayStyle | display style. (inherited from TStyle)
R | Font | TFont | the font of the control. (inherited from TStyle)
 | ForeColor | string | the foreground color of the control. (inherited from TStyle)
 | Height | string | the height of the control. (inherited from TStyle)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the contents within the panel, defaults to THorizontalAlign::NotSet. (inherited from TPanelStyle)
 | Mode | TDataGridPagerMode | pager mode.
 | NextPageText | string | text for the next page button.
 | PageButtonCount | integer | maximum number of pager buttons to be displayed.
 | Position | TDataGridPagerPosition | where the pager is to be displayed.
 | PrevPageText | string | text for the previous page button.
 | ScrollBars | TScrollBars | the visibility and position of scroll bars in a panel control, defaults to TScrollBars::None. (inherited from TPanelStyle)
R | StyleFields | array | list of style fields. (inherited from TStyle)
 | Visible | boolean | whether the pager is visible.
 | Width | string | the width of the control. (inherited from TStyle)
 | Wrap | boolean | whether the content wraps within the panel. (inherited from TPanelStyle)
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer. (inherited from TPanelStyle)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clearStyleField | Clears a single style field value; . (inherited from TStyle)
copyFrom | Copies the fields in a new style to this style.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getStyleField | a single style field value set via setStyleField. (inherited from TStyle)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasCssClass | true if CSS is set or empty. (inherited from TStyle)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasFont | true if font is set. (inherited from TStyle)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
hasStyleField | whether a style field has been defined by setStyleField. (inherited from TStyle)
mergeWith | Merges the style with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Resets the style to the original empty state.
setStyleField | Sets a single style field value. (inherited from TStyle)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataGridSortCommandEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TDataGridSortCommandEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandSource | TControl | the control originally raises the OnCommand event.
R | SortExpression | string | sort expression.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TBaseDataList »
TDataList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AlternatingItemRenderer | string | the class name for alternative datalist items.
R | AlternatingItemStyle | TTableItemStyle | the style for each alternating item.
 | AlternatingItemTemplate | ITemplate | the template for each alternating item.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Caption | string | caption of the table layout.
 | CaptionAlign | TTableCaptionAlign | alignment of the caption of the table layout.
 | CellPadding | integer | the cellpadding for the table layout. (inherited from TBaseDataList)
 | CellSpacing | integer | the cellspacing for the table layout. (inherited from TBaseDataList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DataKeyField | string | the field of the data source that provides the keys of the list items. (inherited from TBaseDataList)
R | DataKeys | TList | the keys used in the data listing control. (inherited from TBaseDataList)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
R | EditItem | TControl | the edit item.
 | EditItemIndex | integer | the zero-based index of the edit item in Items.
 | EditItemRenderer | string | the class name for the datalist item being editted.
R | EditItemStyle | TTableItemStyle | the style for edit item.
 | EditItemTemplate | ITemplate | the edit item template.
 | EmptyRenderer | string | the class name for empty datalist item.
 | EmptyTemplate | ITemplate | the template applied when no data is bound to the datalist.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
R | Footer | TControl | the footer item.
 | FooterRenderer | string | the class name for datalist footer item.
R | FooterStyle | TTableItemStyle | the style for footer.
 | FooterTemplate | ITemplate | the footer template.
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GridLines | TTableGridLines | the grid line setting of the table layout. (inherited from TBaseDataList)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item.
R | HasHeader | boolean | Returns a value indicating whether this control contains header item.
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items.
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
R | Header | TControl | the header item.
 | HeaderRenderer | string | the class name for datalist header item.
R | HeaderStyle | TTableItemStyle | the style for header.
 | HeaderTemplate | ITemplate | the header template.
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the table content. (inherited from TBaseDataList)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
R | ItemCount | integer | number of items.
 | ItemRenderer | string | the class name for datalist items.
R | ItemStyle | TTableItemStyle | the style for item.
 | ItemTemplate | ITemplate | the template for item.
R | Items | TDataListItemCollection | item list.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RepeatColumns | integer | the number of columns that the list should be displayed with.
 | RepeatDirection | TRepeatDirection | the direction of traversing the list, defaults to TRepeatDirection::Vertical.
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers).
 | RepeatLayout | TRepeatLayout | how the list should be displayed, using table or using line breaks.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
R | SelectedDataKey | mixed | the key value of the currently selected item @throws TInvalidOperationException if DataKeyField is empty.
R | SelectedItem | TControl | the selected item, null if no item is selected.
 | SelectedItemIndex | integer | the zero-based index of the selected item in Items.
 | SelectedItemRenderer | string | the class name for the datalist item being selected.
R | SelectedItemStyle | TTableItemStyle | the style for selected item.
 | SelectedItemTemplate | ITemplate | the selected item template.
 | SeparatorRenderer | string | the class name for datalist item separators.
R | SeparatorStyle | TTableItemStyle | the style for separator.
 | SeparatorTemplate | ITemplate | the separator template.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowFooter | boolean | whether the footer should be shown.
 | ShowHeader | boolean | whether the header should be shown.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCancelCommand | Raises OnCancelCommand event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnDeleteCommand | Raises OnDeleteCommand event.
OnEditCommand | Raises OnEditCommand event.
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnItemCommand | Raises OnItemCommand event.
OnItemCreated | Raises OnItemCreated event.
OnItemDataBound | Raises OnItemDataBound event.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event. (inherited from TBaseDataList)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
OnUpdateCommand | Raises OnUpdateCommand event.
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
P | applyItemStyles | Applies styles to items, header, footer and separators.
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation to handle OnItemCommand event which is bubbled from datalist items and their child controls.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createEmptyContent | Creates empty datalist content.
P | createItem | Creates a datalist item instance based on the item type and index.
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object for the control. (inherited from TBaseDataList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | generateItemStyle | Returns a style used for rendering items.
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDataFieldValue | Returns the value of the data at the specified field. (inherited from TBaseDataList)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads item count information from viewstate.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate data list items from data source.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the data list control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list.
 | reset | Clears up all items in the data list.
P | restoreItemsFromViewState | Creates data list items based on viewstate information.
 | saveState | Saves item count in viewstate.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataListCommandEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter » TCommandEventParameter »
TDataListCommandEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandName | string | name of the command. (inherited from TCommandEventParameter)
R | CommandParameter | string | parameter of the command. (inherited from TCommandEventParameter)
R | CommandSource | TControl | the control originally raises the OnCommand event.
R | Item | TControl | the datalist item control responsible for the event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataListItem

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TDataListItem
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item @since 3.
 | DataItem | mixed | This property is deprecated since v3.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ItemIndex | integer | zero-based index of the item in the item collection of datalist.
 | ItemType | TListItemType | item type.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
P | TagName | string | Returns the tag name used for this control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataListItemCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList »
TDataListItemCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataListItemEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TDataListItemEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Item | TControl | datalist item related with the corresponding event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataListItemRenderer

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TDataRenderer » TItemDataRenderer »
TDataListItemRenderer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item. (inherited from TDataRenderer)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
 | ItemIndex | integer | Returns a value indicating the zero-based index of the item in the corresponding data control's item collection. (inherited from TItemDataRenderer)
 | ItemType | TListItemType | item type. (inherited from TItemDataRenderer)
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
R | Style | TStyle | the object representing the css style of the control.
RP | TagName | string | Returns the tag name used for this control.
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data.
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) This method is invoked when TagName is not empty.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control This method is invoked when TagName is not empty.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataRenderer

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl »
TDataRenderer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TItemDataRenderer
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataSourceConfig

Namespace: System.Data
Inheritance: TComponent » TApplicationComponent » TModule »
TDataSourceConfig
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ConnectionClass | {unknown} | .
 | ConnectionID | string | connection module ID.
R | Database | TDbConnection | Alias for getDbConnection().
R | DbConnection | TDbConnection | Gets the TDbConnection from another module if ConnectionID is supplied and valid.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | findConnectionByID | Finds the database connection instance from the Application modules.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initalize the database connection properties from attributes in tag.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TActiveRecordConfig
  • TSqlMapConfig
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataSourceControl

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TDataSourceControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | {unknown} | .
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | {unknown} | .
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ViewNames | {unknown} | .
 | Visible | {unknown} | .
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataSourceChanged | .
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | .
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getView | .
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TReadOnlyDataSource
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataSourceSelectParameters

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TDataSourceSelectParameters
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
MaximumRows | {unknown} | .
RetrieveTotalRowCount | {unknown} | .
StartRowIndex | {unknown} | .
TotalRowCount | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataSourceView

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TDataSourceView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CanDelete | {unknown} | .
R | CanGetRowCount | {unknown} | .
R | CanInsert | {unknown} | .
R | CanPage | {unknown} | .
R | CanSort | {unknown} | .
R | CanUpdate | {unknown} | .
R | DataSource | {unknown} | .
R | Name | {unknown} | .
Events
Name | Description
OnDataSourceViewChanged | .
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
delete | Deletes DB row(s) with the specified keys.
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
insertAt | Inserts a DB record.
raiseEvent | Raises an event. (inherited from TComponent)
select | Performs DB selection based on specified parameters.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
update | Updates DB record(s) with the specified keys and new values .
Derived classes
  • TReadOnlyDataSourceView
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDataTypeValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TDataTypeValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | DataType | TValidationDataType | the data type that the values being compared are converted to before the comparison is made.
 | DateFormat | string | the date validation date format if any.
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | evaluateDataTypeCheck | Determine if the given value is of a particular type using RegExp.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDateFormat

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TControl » TI18NControl »
TDateFormat
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | Charset | string | Gets the charset. (inherited from TI18NControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | Culture | string | Get the specific culture for this control. (inherited from TI18NControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Get the date-time value for this control.
 | DefaultText | string | Get the default text value for this control.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
RP | FormattedDate | {unknown} | Renders the localized version of the date-time value.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | Pattern | string | Gets the date time format pattern.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Value | string | Get the date-time value for this control.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPreset | For a given string, try and find a preset pattern.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | .
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDatePicker

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox »
TDatePicker
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
RP | AssetUrl | string | date picker asset url.
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. (inherited from TTextBox)
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | ButtonImageUrl | string | the image url for "Image" UI mode.
 | ButtonText | string | text for the date picker button.
 | CalendarStyle | string | current calendar style.
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control. (inherited from TTextBox)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TDatePickerClientScript | Gets the TDatePickerClientScript to set the TDatePicker event handlers.
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
RP | CulturalOptions | array | Get javascript localization options, e.
 | Culture | string | Gets the current culture.
RP | CurrentCulture | string | the current culture, falls back to application if culture is not set.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | integer | Returns the timestamp selected by the user.
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
 | Date | string | the date string.
 | DateFormat | string | the format of the date string.
RP | DatePickerButtonID | string | Gets the ID for the date picker trigger button.
RP | DatePickerOptions | array | Get javascript date picker options.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
RP | DropDownDayOptions | array | list of day options for a drop down list.
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | FirstDayOfWeek | integer | first day of the week.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | FromYear | integer | date picker starting year, default is -5 years.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | InputMode | TDatePickerInputMode | input method of date values.
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
RP | LocalizedCalendarInfo | DateTimeFormatInfo | date time format information for the current culture.
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
 | Mode | TDatePickerMode | current calendar UI mode.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
 | PositionMode | TDatePickerPositionMode | current calendar UI position.
RP | PostBackOptions | array | Gets the post back options for this textbox. (inherited from TTextBox)
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowCalendar | boolean | whether the calendar window should pop up when the control receives focus.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox. (inherited from TTextBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component. (inherited from TTextBox)
 | TimeStamp | integer | current selected date from the date picker as timestamp, NULL if timestamp is not set previously.
RP | TimeStampFromText | integer | Gets the date from the text input using TSimpleDateFormatter .
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
 | UpToYear | integer | date picker ending year, default +10 years.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | integer | Returns the value to be validated.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the date picker Css asset files.
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Add the client id to the input textbox, and register the client scripts.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientScript | javascript validator event options.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDateFromPostData | Loads date from drop down list data.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLocalizedMonthNames | Returns the localized month names that depends on the month format pattern.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
P | hasDayPattern | .
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
P | publishCalendarStyle | Publish the calendar style Css asset file.
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
P | registerCalendarClientScript | Registers the javascript code to initialize the date picker.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders body content.
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
P | renderButtonDatePicker | Adds an additional button such that when clicked it shows the date picker.
P | renderCalendarDayOptions | Renders the day drop down list options.
P | renderCalendarMonthOptions | Renders the month drop down list options.
P | renderCalendarSelections | Renders the calendar drop down list depending on the DateFormat pattern.
P | renderCalendarYearOptions | Renders the year drop down list options.
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for textbox. (inherited from TTextBox)
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode. (inherited from TTextBox)
 | renderControl | Renders the control. (inherited from TControl)
P | renderDatePickerButtons | Renders the date picker popup buttons.
P | renderDropDownListCalendar | Renders the drop down list date picker.
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderImageButtonDatePicker | Adds an additional image button such that when clicked it shows the date picker.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveDatePicker
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDatePickerClientScript

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TClientSideOptions »
TDatePickerClientScript
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | OnDateChanged | string | javascript code to execute when the date picker's date is changed.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Ensure that the javascript statements are wrapped in a javascript function block as function(sender, parameter){ //code }. (inherited from TClientSideOptions)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDatePickerInputMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDatePickerInputMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDatePickerMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDatePickerMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDatePickerPositionMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDatePickerPositionMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDateTimeStamp

Namespace: System.Util
TDateTimeStamp
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | _getDateInternal | Low-level function that returns the getdate() array.
P | digitCheck | Fix 2-digit years.
 | formatDate | formatted date based on timestamp $d.
 | get4DigitYear | .
 | getDate | an array with date info.
 | getDayofWeek | Gets day of week, 0 = Sunday,.
 | getGMTDiff | get local time zone offset from GMT.
 | getTimeStamp | Not a very fast algorithm - O(n) operation.
 | isLeapYear | Checks for leap year, returns true if it is.
 | isValidDate | true if valid date, semantic check only.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbCache

Namespace: System.Caching
Inheritance: TComponent » TApplicationComponent » TModule » TCache »
TDbCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | AutoCreateCacheTable | boolean | whether the cache DB table should be automatically created if not exists.
 | CacheTableName | string | the name of the DB table to store cache content.
 | ConnectionID | string | the ID of a TDataSourceConfig module.
 | ConnectionString | string | The Data Source Name, or DSN, contains the information required to connect to the database.
R | DbConnection | TDbConnection | the DB connection instance.
 | FlushInterval | integer | Interval in sec expired items will be removed from cache.
 | ID | string | id of this module. (inherited from TModule)
 | KeyPrefix | string | a unique prefix for the keys of cached values. (inherited from TCache)
 | Password | string | the password for establishing DB connection.
 | PrimaryCache | boolean | whether this cache module is used as primary/system cache. (inherited from TCache)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Username | string | the username for establishing DB connection.
Events
Methods
 | Name | Description
 | add | Stores a value identified by a key into cache if the cache does not contain this key. (inherited from TCache)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addValue | Stores a value identified by a key into cache if the cache does not contain this key.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createDbConnection | Creates the DB connection.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes a value with the specified key from cache . (inherited from TCache)
P | deleteValue | Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | doFlushCacheExpired | Event listener for TApplication.
 | doInitializeCache | Event listener for TApplication.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Deletes all values from cache.
 | flushCacheExpired | Flush expired values from cache depending on FlushInterval .
P | generateUniqueKey | a key generated from the provided key which ensures the uniqueness across applications. (inherited from TCache)
 | get | Retrieves a value from cache with a specified key. (inherited from TCache)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValue | Retrieves a value from cache with a specified key.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
P | initializeCache | Initialize TDbCache If AutoCreateCacheTableName is 'true' check existence of cache table and create table if does not exist.
 | offsetExists | Returns whether there is a cache entry with a specified key. (inherited from TCache)
 | offsetGet | . (inherited from TCache)
 | offsetSet | . (inherited from TCache)
 | offsetUnset | . (inherited from TCache)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | set | Stores a value identified by a key into cache. (inherited from TCache)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setValue | Stores a value identified by a key in cache.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbColumnCaseMode

Namespace: System.Data
Inheritance: TEnumerable »
TDbColumnCaseMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbCommand

Namespace: System.Data
Inheritance: TComponent »
TDbCommand
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Connection | TDbConnection | the connection associated with this command.
R | DebugStatementText | String | prepared SQL text for debugging purposes.
R | PdoStatement | PDOStatement | the underlying PDOStatement for this command It could be null if the statement is not prepared yet.
 | Text | string | the SQL statement to be executed.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
bindParameter | Binds a parameter to the SQL statement to be executed.
bindValue | Binds a value to a parameter.
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
cancel | Cancels the execution of the SQL statement.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
execute | Executes the SQL statement.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
prepare | Prepares the SQL statement to be executed.
query | Executes the SQL statement and returns query result.
queryColumn | Executes the SQL statement and returns the first column of the result.
queryRow | Executes the SQL statement and returns the first row of the result.
queryScalar | Executes the SQL statement and returns the value of the first column in the first row of data.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbCommandBuilder

Namespace: System.Data.Common
Inheritance: TComponent »
TDbCommandBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | database connection.
R | LastInsertID | mixed | Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial.
R | SelectFieldList | array | Different behavior depends on type of passed data string usage without modification null will be expanded to full list of quoted table column names (quoting depends on database) array - Column names will be quoted if used as key or value of array array('col1', 'col2', 'col2') // SELECT `col1`, `col2`, `col3` FROM.
 | TableInfo | {unknown} | .
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyCriterias | .
 | applyLimitOffset | Alters the sql to apply $limit and $offset.
 | applyOrdering | modified SQL applied with ORDER BY.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | bindArrayValues | .
 | bindColumnValues | Bind the name-value pairs of $values where the array keys correspond to column names.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommand | corresponding database command.
 | createCountCommand | Creates a count(*) command for the table described in TableInfo.
 | createDeleteCommand | Creates a delete command for the table described in TableInfo.
 | createFindCommand | Appends the $where condition to the string "SELECT * FROM tableName WHERE ".
 | createInsertCommand | Creates an insert command for the table described in TableInfo for the given data.
 | createUpdateCommand | Creates an update command for the table described in TableInfo for the given data.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getColumnBindings | Create a name-value or position-value if $position=true binding strings.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertFieldBindings | Returns a list of insert field name and a list of binding names.
S | getPdoType | PDO parameter types.
P | getSearchCondition | search condition for all words in one column.
 | getSearchExpression | Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords).
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
P | hasIntegerKey | true if any array key is an integer.
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TMssqlCommandBuilder
  • TMysqlCommandBuilder
  • TOracleCommandBuilder
  • TPgsqlCommandBuilder
  • TSqliteCommandBuilder
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbConnection

Namespace: System.Data
Inheritance: TComponent »
TDbConnection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Active | boolean | whether the DB connection is established.
 | AutoCommit | boolean | whether creating or updating a DB record will be automatically committed.
 | Charset | string | the charset used for database connection.
R | ClientVersion | string | the version information of the DB driver.
 | ColumnCase | TDbColumnCaseMode | the case of the column names.
R | ConnectionStatus | string | the status of the connection Some DBMS (such as sqlite) may not support this feature.
 | ConnectionString | string | The Data Source Name, or DSN, contains the information required to connect to the database.
R | CurrentTransaction | TDbTransaction | the currently active transaction.
R | DriverName | string | name of the DB driver.
R | LastInsertID | string | Returns the ID of the last inserted row or sequence value.
 | NullConversion | TDbNullConversionMode | how the null and empty strings are converted.
 | Password | string | the password for establishing DB connection.
R | PdoInstance | PDO | the PDO instance, null if the connection is not established yet.
 | Persistent | boolean | whether the connection is persistent or not Some DBMS (such as sqlite) may not support this feature.
R | Prefetch | boolean | whether the connection performs data prefetching.
R | ServerInfo | string | the information of DBMS server.
R | ServerVersion | string | the version information of DBMS server.
R | Timeout | int | timeout settings for the connection.
 | TransactionClass | string | Transaction class name to be created by calling beginTransaction.
 | Username | string | the username for establishing DB connection.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | beginTransaction | Starts a transaction.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | close | Closes the currently active DB connection.
 | createCommand | Creates a command for execution.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getAttribute | Obtains a specific DB connection attribute information.
S | getAvailableDrivers | list of available PDO drivers @see http://www.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | open | Opens DB connection if it is currently not .
 | quoteString | Quotes a string for use in a query.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setAttribute | Sets an attribute on the database connection.
P | setConnectionCharset | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbConnectionException

Namespace: System.Exceptions
Inheritance: TException » TSystemException » TDbException »
TDbConnectionException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbDataReader

Namespace: System.Data
Inheritance: TComponent »
TDbDataReader
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ColumnCount | int | the number of columns in the result set.
R | IsClosed | boolean | whether the reader is closed or not.
R | RowCount | int | number of rows contained in the result.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
bindColumn | Binds a column to a PHP variable.
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
close | Closes the reader.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
current | Returns the current row.
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
key | Returns the index of the current row.
next | Moves the internal pointer to the next row.
nextResult | Advances the reader to the next result when reading the results of a batch of statements.
raiseEvent | Raises an event. (inherited from TComponent)
read | Advances the reader to the next row in a result set.
readAll | Reads the whole result set into an array.
readColumn | Returns a single column from the next row of a result set.
readObject | Returns a single column from the next row of a result set.
rewind | Resets the iterator to the initial state.
setFetchMode | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
valid | Returns whether there is a row of data at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TDbException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
  • TActiveRecordException
  • TDbConnectionException
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TLogRoute »
TDbLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | AutoCreateLogTable | boolean | whether the log DB table should be automatically created if not exists.
 | Categories | array | list of categories to be looked for. (inherited from TLogRoute)
 | ConnectionID | string | the ID of a TDataSourceConfig module.
R | DbConnection | TDbConnection | the DB connection instance.
 | Levels | integer | log level filter. (inherited from TLogRoute)
 | LogTableName | string | the name of the DB table to store log content.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination. (inherited from TLogRoute)
P | createDbConnection | Creates the DB connection.
P | createDbTable | Creates the DB table for storing log messages.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields. (inherited from TLogRoute)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLevelName | level name. (inherited from TLogRoute)
P | getLevelValue | level value. (inherited from TLogRoute)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
P | processLogs | Stores log messages into database.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbMetaData

Namespace: System.Data.Common
Inheritance: TComponent »
TDbMetaData
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection.
R | TableInfo | TDbTableInfo | Obtains table meta data information for the current connection and given table name.
RP | TableInfoClass | string | TDbTableInfo class name.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | Creates a command builder for a given table name.
P | createTableInfo | This method should be implemented by decendent classes.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
S | getInstance | Obtain database specific TDbMetaData class using the driver name of the database connection.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TMssqlMetaData
  • TMysqlMetaData
  • TOracleMetaData
  • TPgsqlMetaData
  • TSqliteMetaData
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbNullConversionMode

Namespace: System.Data
Inheritance: TEnumerable »
TDbNullConversionMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbTableColumn

Namespace: System.Data.Common
Inheritance: TComponent »
TDbTableColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowNull | boolean | specifies whether value Null is allowed, default is false.
R | ColumnId | string | name of the column with quoted identifier.
R | ColumnIndex | integer | zero-based ordinal position of the column in the table.
R | ColumnName | string | name of the column in the table (identifier quoted).
R | ColumnSize | string | size of the column.
R | DbType | string | column type.
R | DefaultValue | mixed | default column value if column value was null.
R | IsExcluded | boolean | whether this column is excluded from insert and update.
R | IsForeignKey | boolean | whether this column is a foreign key, default is false.
R | IsPrimaryKey | boolean | whether this column is a primary key for the table, default is false.
R | MaxiumNumericConstraint | {unknown} | .
R | NumericPrecision | string | precision of the column data, if the data is numeric.
R | NumericScale | string | scale of the column data, if the data is numeric.
R | PHPType | string | Returns the derived PHP primitive type from the db type.
R | PdoType | {unknown} | .
R | SequenceName | {unknown} | .
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasSequence | whether the column is a sequence.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TMssqlTableColumn
  • TMysqlTableColumn
  • TOracleTableColumn
  • TPgsqlTableColumn
  • TSqliteTableColumn
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbTableInfo

Namespace: System.Data.Common
Inheritance: TComponent »
TDbTableInfo
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ColumnNames | array | table column names (identifier quoted).
R | Columns | TMap | TDbTableColumn column meta data.
R | ForeignKeys | array | tuples of foreign table and column name.
R | IsView | boolean | whether the table is a view, default is false.
R | LowerCaseColumnNames | array | lowercased column key names mapped to normal column ids.
R | PrimaryKeys | string[] | .
R | TableFullName | string | full name of the table, database dependent.
R | TableName | string | name of the table this column belongs to.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | new command builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getColumn | column information.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TMssqlTableInfo
  • TMysqlTableInfo
  • TPgsqlTableInfo
  • TSqliteTableInfo
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbTransaction

Namespace: System.Data
Inheritance: TComponent »
TDbTransaction
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Active | boolean | whether this transaction is active.
R | Connection | TDbConnection | the DB connection for this transaction.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
commit | Commits a transaction.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
rollback | Rolls back a transaction.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbUser

Namespace: System.Security
Inheritance: TComponent » TUser »
TDbUser
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | Returns a database connection that may be used to retrieve data from database.
 | IsGuest | boolean | if the user is a guest, defaults to true. (inherited from TUser)
R | Manager | IUserManager | user manager. (inherited from TUser)
 | Name | string | username, defaults to empty string. (inherited from TUser)
 | Roles | array | list of roles that the user is of. (inherited from TUser)
 | StateChanged | boolean | whether user session state is changed (i. (inherited from TUser)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createUser | Creates a new user instance given the username.
 | createUserFromCookie | Creates a new user instance given the cookie containing auth data.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getState | Returns the value of a variable that is stored in user session. (inherited from TUser)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | isInRole | whether the user is of this role. (inherited from TUser)
 | loadFromString | the user object. (inherited from TUser)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveToString | user data that is serialized and will be stored in session. (inherited from TUser)
 | saveUserToCookie | Saves necessary auth data into a cookie.
P | setState | Stores a variable in user session. (inherited from TUser)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | validateUser | Validates if username and password are correct entries.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDbUserManager

Namespace: System.Security
Inheritance: TComponent » TApplicationComponent » TModule »
TDbUserManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ConnectionID | string | the ID of a TDataSourceConfig module.
R | DbConnection | TDbConnection | the database connection that may be used to retrieve user data.
 | GuestName | string | guest name, defaults to 'Guest'.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | TUser | Returns a user instance given the user name.
 | UserClass | string | the user class name in namespace format.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createDbConnection | Creates the DB connection.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getUserFromCookie | Returns a user instance according to auth data stored in a cookie.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveUserToCookie | Saves user auth data into a cookie.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | validateUser | Validates if the username and password are correct.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDeleteMappedStatement

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent » TMappedStatement » TUpdateMappedStatement »
TDeleteMappedStatement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TPreparedCommand | command to prepare SQL statements. (inherited from TMappedStatement)
R | ID | string | Name used to identify the TMappedStatement amongst the others. (inherited from TMappedStatement)
R | Manager | TSqlMapper | The SqlMap used by this MappedStatement. (inherited from TMappedStatement)
R | SqlString | {unknown} | . (inherited from TMappedStatement)
R | Statement | TSqlMapStatement | The SQL statment used by this MappedStatement. (inherited from TMappedStatement)
Events
Name | Description
OnExecuteQuery | Raise the execute query event. (inherited from TMappedStatement)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addResultMapGroupBy | ResultMap with GroupBy property. (inherited from TMappedStatement)
P | applyResultMap | Apply result mapping. (inherited from TMappedStatement)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | enquequePostSelect | Add nested result property to post select queue. (inherited from TMappedStatement)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | executeInsert | . (inherited from TUpdateMappedStatement)
P | executePostSelect | Process 'select' result properties . (inherited from TMappedStatement)
 | executeQueryForList | . (inherited from TUpdateMappedStatement)
 | executeQueryForMap | . (inherited from TUpdateMappedStatement)
 | executeQueryForObject | . (inherited from TUpdateMappedStatement)
P | executeSQLQueryLimit | Execute SQL Query with limits. (inherited from TMappedStatement)
P | executeSelectKey | Execute the select key statement, used to obtain last insert ID. (inherited from TMappedStatement)
 | executeUpdate | Execute an update statement. (inherited from TMappedStatement)
P | fillArrayResultMap | Retrieve the result map as an array. (inherited from TMappedStatement)
P | fillDefaultResultMap | Fill the result map using default settings. (inherited from TMappedStatement)
P | fillPropertyWithResultMap | Fills the property with result mapping results. (inherited from TMappedStatement)
P | fillResultArrayList | Apply the result to a TList or an array. (inherited from TMappedStatement)
P | fillResultClass | Fill the result using ResultClass, will creates new result object if required. (inherited from TMappedStatement)
P | fillResultMap | Fills the result object according to result mappings. (inherited from TMappedStatement)
P | fillResultObjectProperty | Apply the result to an object. (inherited from TMappedStatement)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPostGeneratedSelectKey | Gets the inserted row ID after executing an insert statement. (inherited from TMappedStatement)
P | getPostSelectKeys | Finds in the post select property the SQL statement primary selection keys. (inherited from TMappedStatement)
P | getPreGeneratedSelectKey | Gets the insert generated ID before executing an insert statement. (inherited from TMappedStatement)
P | getResultMapGroupKey | Gets the result 'group by' groupping key for each row. (inherited from TMappedStatement)
P | getScalarResult | Converts the first array value to scalar value of given type. (inherited from TMappedStatement)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initialGroupByResults | Empty the group by results cache. (inherited from TMappedStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | raiseRowDelegate | Raises delegate handler. (inherited from TMappedStatement)
 | runQueryForList | Executes the SQL and retuns a List of result objects. (inherited from TMappedStatement)
 | runQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. (inherited from TMappedStatement)
 | runQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter. (inherited from TMappedStatement)
P | setObjectProperty | Set a property of the result object with appropriate value. (inherited from TMappedStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDirectoryCacheDependency

Namespace: System.Caching
Inheritance: TComponent » TCacheDependency »
TDirectoryCacheDependency
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Directory | string | the directory to be checked.
R | HasChanged | boolean | Performs the actual dependency checking.
 | RecursiveCheck | boolean | whether the subdirectories of the directory will also be checked.
 | RecursiveLevel | int | the depth of the subdirectories to be checked.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | generateTimestamps | Determines the last modification time for files under the directory.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | validateDirectory | Checks to see if the specified subdirectory should be checked for dependency.
P | validateFile | Checks to see if the file should be checked for dependency.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDiscriminator

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TDiscriminator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Column | string | the name of the column in the result set from which the value will be used to populate the property.
 | ColumnIndex | int | index of the column in the ResultSet.
R | Mapping | TResultProperty | result property for the discriminator column.
 | NullValue | mixed | outgoing null value replacement.
 | Type | {unknown} | .
 | TypeHandler | string | custom type handler class name (may use namespace).
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
addSubMap | .
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubMap | result mapping.
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
initMapping | Copies the discriminator properties to a new TResultProperty.
initialize | Set the result maps for particular sub-mapping values.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDisplayStyle

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TDisplayStyle
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDraggable

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TPanel »
TDraggable
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the panel component. (inherited from TPanel)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | Constraint | CDraggableConstraint | Determine if the element should be constrainted in one direction or not .
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultButton | string | the ID path to the default button. (inherited from TPanel)
 | Direction | string | alignment of the content in the panel. (inherited from TPanel)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | Ghosting | boolean | Determine if the element should be cloned when dragged If true, Clones the element and drags the clone, leaving the original in place until the clone is dropped.
 | GroupingText | string | the legend text when the panel is used as a fieldset. (inherited from TPanel)
 | Handle | string | Get the handle id or css class .
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the panel, defaults to 'NotSet'. (inherited from TPanel)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this textbox.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Revert | boolean | Determine if draggable element should revert to it orginal position upon release in an non-droppable container.
 | ScrollBars | string | the visibility and position of scroll bars in a panel control, defaults to None. (inherited from TPanel)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the panel. (inherited from TPanel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the content wraps within the panel. (inherited from TPanel)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TPanel)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TPanel)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TPanel)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDraggableConstraint

Namespace: System.Web.UI.ActiveControls
Inheritance: TEnumerable »
TDraggableConstraint
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDropContainer

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TPanel »
TDropContainer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AcceptCssClass | string | Gets the Css class name that this container can accept.
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveControl | standard active control options.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the panel component. (inherited from TPanel)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | Override parent implementation to return the container control collection.
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultButton | string | the ID path to the default button. (inherited from TPanel)
 | Direction | string | alignment of the content in the panel. (inherited from TPanel)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GroupingText | string | the legend text when the panel is used as a fieldset. (inherited from TPanel)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the panel, defaults to 'NotSet'. (inherited from TPanel)
 | HoverCssClass | string | Gets the Css class name used when a draggble element is hovering over this container.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this textbox.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScrollBars | string | the visibility and position of scroll bars in a panel control, defaults to None. (inherited from TPanel)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the panel. (inherited from TPanel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the content wraps within the panel. (inherited from TPanel)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDrop | Raises the onDrop event.
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child control Override parent implementation to create a container which will contain all child controls.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TPanel)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises callback event.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders and replaces the panel's content on the client-side.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TPanel)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TPanel)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDropContainerEventParameter

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TEventParameter »
TDropContainerEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DroppedControl | TDraggable | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDropDownList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl »
TDropDownList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this is a multiselect control. (inherited from TListControl)
 | IsValid | bool | Returns true if this control validated successfully.
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | postback options for JS postback code. (inherited from TListControl)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated.
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TActiveDropDownList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDropDownListColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TDropDownListColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataTextField | string | the field of the data source that provides the text content of the column.
 | DataTextFormatString | string | the formatting string used to control how the bound data will be displayed.
 | DataValueField | string | the field of the data source that provides the key selecting an item in dropdown list.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | ListDataSource | Traversable | data source to be bound to the dropdown list boxes.
 | ListTextField | string | the data field used to populate the texts of the dropdown list items.
 | ListTextFormatString | string | the formatting string used to control how the list item texts will be displayed.
 | ListValueField | string | the data field used to populate the values of the dropdown list items.
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
 | ReadOnly | boolean | whether the items in the column can be edited.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Adds object parsed from template to the control.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads items from viewstate.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves items into viewstate.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDummyDataSource

Namespace: System.Collections
Inheritance: TComponent »
TDummyDataSource
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | number of (virtual) items in the data source.
R | Iterator | Iterator | iterator.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
count | Returns the number of (virtual) items in the data source.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TDummyDataSourceIterator

Namespace: System.Collections
TDummyDataSourceIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array item.
key | Returns the key of the current array item.
next | Moves the internal pointer to the next array item.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an item at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEditCommandColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TEditCommandColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ButtonType | TButtonColumnType | the type of command button.
 | CancelImageUrl | string | the URL of the image file for cancel image buttons.
 | CancelText | string | the caption of the cancel button.
 | CausesValidation | boolean | whether postback event trigger by edit or update button will cause input validation, default is true.
 | EditImageUrl | string | the URL of the image file for edit image buttons.
 | EditText | string | the caption of the edit button.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
 | UpdateImageUrl | string | the URL of the image file for update image buttons.
 | UpdateText | string | the caption of the update button.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the edit or update button causes validation upon postback.
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createButton | Creates a button and initializes its properties.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEmailAddressValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator » TRegularExpressionValidator »
TEmailAddressValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CheckMXRecord | boolean | whether to check MX record for the email address being validated.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options. (inherited from TRegularExpressionValidator)
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ClientSidePatternModifiers | string | clientside pattern modifiers, no modifiers by default. (inherited from TRegularExpressionValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PatternModifiers | string | pattern modifiers, no modifiers by default. (inherited from TRegularExpressionValidator)
 | RegularExpression | string | the regular expression that determines the pattern used to validate a field.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateIsValid | Returns an array of javascript validator options.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEmailLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TLogRoute »
TEmailLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Categories | array | list of categories to be looked for. (inherited from TLogRoute)
 | Emails | array | list of destination email addresses.
 | Levels | integer | log level filter. (inherited from TLogRoute)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | SentFrom | string | send from address of the email.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | Subject | string | email subject.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination. (inherited from TLogRoute)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields. (inherited from TLogRoute)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLevelName | level name. (inherited from TLogRoute)
P | getLevelValue | level value. (inherited from TLogRoute)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the route.
P | processLogs | Sends log messages to specified email addresses.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEmptyControlCollection

Namespace: System.Web.UI
Inheritance: TComponent » TList » TControlCollection »
TEmptyControlCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TControl | the control that owns this collection. (inherited from TControlCollection)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Overrides the parent implementation by invoking clearNamingContainer. (inherited from TControlCollection)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TControlCollection)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEnumerable

Namespace: System
TEnumerable
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
  • TActiveRecordInvalidFinderResult
  • TApplicationMode
  • TBulletStyle
  • TBulletedListDisplayMode
  • TButtonColumnType
  • TButtonType
  • TColorPickerMode
  • TContentDirection
  • TDataGridPagerButtonType
  • TDataGridPagerMode
  • TDataGridPagerPosition
  • TDatePickerInputMode
  • TDatePickerMode
  • TDatePickerPositionMode
  • TDbColumnCaseMode
  • TDbNullConversionMode
  • TDisplayStyle
  • TDraggableConstraint
  • THorizontalAlign
  • THotSpotMode
  • THttpRequestUrlFormat
  • THttpSessionCookieMode
  • TInlineFrameAlign
  • TInlineFrameScrollBars
  • TListItemType
  • TListSelectionMode
  • TPagerButtonType
  • TPagerMode
  • TRepeatDirection
  • TRepeatLayout
  • TScrollBars
  • TSecurityManagerValidationMode
  • TSliderDirection
  • TSqlMapCacheTypes
  • TTableCaptionAlign
  • TTableGridLines
  • TTableHeaderScope
  • TTableRowSection
  • TTextAlign
  • TTextBoxAutoCompleteType
  • TTextBoxMode
  • TTextHighlighterLineNumberStyle
  • TUserManagerPasswordMode
  • TValidationCompareOperator
  • TValidationDataType
  • TValidationSummaryDisplayMode
  • TValidationSummaryDisplayStyle
  • TValidatorDisplayStyle
  • TVerticalAlign
  • TWizardNavigationButtonType
  • TWizardStepType
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TErrorHandler

Namespace: System.Exceptions
Inheritance: TComponent » TApplicationComponent » TModule »
TErrorHandler
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ErrorTemplatePath | string | the directory containing error template files.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | displayException | Displays exception information.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getErrorTemplate | Retrieves the template used for displaying external exceptions.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getExceptionTemplate | Retrieves the template used for displaying internal exceptions.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | handleError | Handles PHP user errors and exceptions.
P | handleExternalError | Displays error to the client user.
P | handleRecursiveError | Handles error occurs during error handling (called recursive error).
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
SP | hideSecurityRelated | @since 3.
 | init | Initializes the module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TCallbackErrorHandler
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEventParameter

Namespace: System
Inheritance: TComponent »
TEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TActiveRecordChangeEventParameter
  • TBroadcastEventParameter
  • TBulletedListEventParameter
  • TCallbackEventParameter
  • TCommandEventParameter
  • TDataGatewayEventParameter
  • TDataGatewayResultEventParameter
  • TDataGridItemEventParameter
  • TDataGridPageChangedEventParameter
  • TDataGridPagerEventParameter
  • TDataGridSortCommandEventParameter
  • TDataListItemEventParameter
  • TDropContainerEventParameter
  • TImageClickEventParameter
  • TImageMapEventParameter
  • TOutputCacheCalculateKeyEventParameter
  • TOutputCacheCheckDependencyEventParameter
  • TPagedListFetchDataEventParameter
  • TPagedListPageChangedEventParameter
  • TPagerPageChangedEventParameter
  • TRepeaterItemEventParameter
  • TServerValidateEventParameter
  • TWizardNavigationEventParameter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TEventTriggeredCallback

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TCallback » TTriggeredCallback »
TEventTriggeredCallback
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ActiveControl | TBaseActiveCallbackControl | standard callback options. (inherited from TCallback)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for TEventTriggeredCallback.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options. (inherited from TCallback)
 | ControlID | string | The ID of the server control the trigger is bounded to. (inherited from TTriggeredCallback)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | EventName | string | The client-side event name the trigger listens to.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PreventDefaultAction | boolean | true to prevent/stop default event action.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TargetControl | string | target control client ID or html element ID if control is not found in hierarchy. (inherited from TTriggeredCallback)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
RP | TriggerOptions | array | list of timer options for client-side.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested. (inherited from TCallback)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event. (inherited from TCallback)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Registers the javascript code for initializing the active control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TException

Namespace: System.Exceptions
TException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code.
 | getErrorMessage | error message.
P | getErrorMessageFile | path to the error message file.
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | .
P | setErrorMessage | .
P | translateErrorMessage | Translates an error code into an error message.
Derived classes
  • TApplicationException
  • TInvalidCallbackException
  • TSqlMapException
  • TSystemException
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TExpression

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TExpression
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | Expression | string | the expression to be evaluated.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the evaluation result of the expression.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFeedService

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent » TService »
TFeedService
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Enabled | boolean | whether the service is enabled. (inherited from TService)
 | ID | string | id of this service. (inherited from TService)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineRequestedFeedPath | the requested feed path.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | run | Runs the service.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFileCacheDependency

Namespace: System.Caching
Inheritance: TComponent » TCacheDependency »
TFileCacheDependency
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | FileName | string | the name of the file whose change is to be checked.
R | HasChanged | boolean | Performs the actual dependency checking.
R | Timestamp | int | the last modification time of the file.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFileLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TLogRoute »
TFileLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Categories | array | list of categories to be looked for. (inherited from TLogRoute)
 | Levels | integer | log level filter. (inherited from TLogRoute)
 | LogFile | string | log file name.
 | LogPath | string | directory storing log files.
 | MaxFileSize | integer | maximum log file size in kilo-bytes (KB).
 | MaxLogFiles | integer | number of files used for rotation.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination. (inherited from TLogRoute)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields. (inherited from TLogRoute)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLevelName | level name. (inherited from TLogRoute)
P | getLevelValue | level value. (inherited from TLogRoute)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the route. (inherited from TLogRoute)
P | processLogs | Saves log messages in files.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | rotateFiles | Rotates log files.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFileUpload

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TFileUpload
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | ErrorCode | integer | Returns an error code describing the status of this file uploading.
R | FileName | string | the original full path name of the file on the client machine.
R | FileSize | integer | the actual size of the uploaded file in bytes.
R | FileType | string | the MIME-type of the uploaded file (such as "image/gif").
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFile | boolean | whether the file is uploaded successfully.
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully.
R | LocalName | string | the local name of the file (where it is after being uploaded).
 | MaxFileSize | integer | the maximum file size, defaults to 1MB (1048576 bytes).
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the file upload control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ValidationPropertyValue | mixed | Returns the original file name as the property value to be validated.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnFileUpload | This method is invoked when a file is uploaded during a postback.
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Sets Enctype of the form on the page.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Sets name attribute to the unique ID of the control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveAs | Saves the uploaded file.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveFileUpload
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFirePhpLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TLogRoute »
TFirePhpLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Categories | array | list of categories to be looked for. (inherited from TLogRoute)
 | GroupLabel | string | group label.
 | Levels | integer | log level filter. (inherited from TLogRoute)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination. (inherited from TLogRoute)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields. (inherited from TLogRoute)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLevelName | level name. (inherited from TLogRoute)
P | getLevelValue | level value. (inherited from TLogRoute)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the route. (inherited from TLogRoute)
 | processLogs | .
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
SP | translateLogLevel | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFirebugLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TLogRoute » TBrowserLogRoute »
TFirebugLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Categories | array | list of categories to be looked for. (inherited from TLogRoute)
 | CssClass | string | the css class of the control. (inherited from TBrowserLogRoute)
 | Levels | integer | log level filter. (inherited from TLogRoute)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination. (inherited from TLogRoute)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields. (inherited from TLogRoute)
P | getColorLevel | . (inherited from TBrowserLogRoute)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getFirebugLoggingFunction | .
P | getLevelName | level name. (inherited from TLogRoute)
P | getLevelValue | level value. (inherited from TLogRoute)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the route. (inherited from TLogRoute)
 | processLogs | . (inherited from TBrowserLogRoute)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | renderFooter | .
P | renderHeader | .
P | renderMessage | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TFont

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TFont
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Bold | boolean | whether the font is in bold face.
R | IsEmpty | boolean | whether the font is empty.
 | Italic | boolean | whether the font is in italic face.
 | Name | string | the font name (family).
 | Overline | boolean | whether the font is overlined.
 | Size | string | the font size.
 | Strikeout | boolean | whether the font is strikeout.
 | Underline | boolean | whether the font is underlined.
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
copyFrom | Copies the fields in a new font to this font.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
mergeWith | Merges the font with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Clears up the font.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toString | the font in a css style string representation.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TForm

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TControl »
TForm
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultButton | string | id path to the default button control.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | Enctype | string | the encoding type a browser uses to post data back to the server.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | Method | string | form submission method.
R | Name | string | form name, which is equal to UniqueID.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the form with the page.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds form specific attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the form.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TGlobalStateCacheDependency

Namespace: System.Caching
Inheritance: TComponent » TCacheDependency »
TGlobalStateCacheDependency
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | HasChanged | boolean | Performs the actual dependency checking.
 | StateName | string | the name of the global state.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TGlobalization

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TModule »
TGlobalization
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Charset | string | localization charset.
 | Culture | string | current application culture.
R | CultureVariants | array | Gets all the variants of a specific culture.
 | DefaultCharset | string | default charset set.
 | DefaultCulture | string | default culture.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | TranslationCatalogue | string | current translation catalogue.
 | TranslationConfiguration | TMap | translation source configuration.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getLocalizedResource | Returns a list of possible localized files.
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initialize the Culture and Charset for this application.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TGlobalizationAutoDetect
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TGlobalizationAutoDetect

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TModule » TGlobalization »
TGlobalizationAutoDetect
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Charset | string | localization charset. (inherited from TGlobalization)
 | Culture | string | current application culture. (inherited from TGlobalization)
R | CultureVariants | array | Gets all the variants of a specific culture. (inherited from TGlobalization)
 | DefaultCharset | string | default charset set. (inherited from TGlobalization)
 | DefaultCulture | string | default culture. (inherited from TGlobalization)
R | DetectedLanguage | {unknown} | .
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | TranslationCatalogue | string | current translation catalogue. (inherited from TGlobalization)
 | TranslationConfiguration | TMap | translation source configuration. (inherited from TGlobalization)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getLocalizedResource | Returns a list of possible localized files. (inherited from TGlobalization)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | .
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THead

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TControl »
THead
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BaseUrl | string | base URL of the page.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | MetaTags | TMetaTagCollection | meta tag collection.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShortcutIcon | string | the URL for the shortcut icon of the page.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Title | string | the page title.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the head control with the current page.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the head control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THiddenField

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
THiddenField
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the hidden field.
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | EnableTheming | boolean | whether theming is enabled for this control.
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TagName | string | tag name of the hidden field.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ValidationPropertyValue | mixed | Returns the value to be validated.
 | Value | string | the value of the THiddenField.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
OnValueChanged | This method is invoked when the value of the Value property changes between posts to the server.
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets focus to this control.
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads hidden field data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveHiddenField
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THorizontalAlign

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
THorizontalAlign
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THotSpot

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
THotSpot
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key that allows you to quickly navigate to the HotSpot region.
 | AlternateText | string | the alternate text to display for a HotSpot object.
R | Attributes | TAttributeCollection | Returns the list of custom attributes.
 | CausesValidation | boolean | whether postback event trigger by this hotspot will cause input validation, default is true.
R | Coordinates | string | coordinates defining the hotspot shape.
R | HasAttributes | boolean | whether the hotspot has custom attributes.
 | HotSpotMode | THotSpotMode | the behavior of a HotSpot object when it is clicked.
 | NavigateUrl | string | the URL to navigate to when a HotSpot object is clicked.
 | PostBackValue | string | a value that is post back when the HotSpot is clicked.
R | Shape | string | shape of the hotspot, can be 'circle', 'rect', 'poly', etc.
 | TabIndex | integer | the tab index of the HotSpot region.
 | Target | string | the target window or frame to display the new page when the HotSpot region is clicked.
 | ValidationGroup | string | the group of validators which the hotspot causes validation upon postback.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getAttribute | attribute value, null if attribute does not exist.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value.
 | hasAttribute | whether the named attribute exists.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | removeAttribute | Removes the named attribute.
 | render | Renders this hotspot.
 | setAttribute | Sets a custom hotspot attribute.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value.
Derived classes
  • TCircleHotSpot
  • TPolygonHotSpot
  • TRectangleHotSpot
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THotSpotCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList »
THotSpotCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THotSpotMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
THotSpotMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THtmlArea

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox »
THtmlArea
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoPostBack | boolean | whether change of the content should cause postback.
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
R | AvailablePlugins | array | Returns a list of plugins to be loaded.
R | AvailableThemes | array | list of available themese.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | Culture | string | Gets the current culture.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | CustomPluginPath | string | path to custom plugins to be copied.
 | Data | string | Returns the text content of the TTextBox control. (inherited from TTextBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
RP | EditorOptions | array | Default editor options gives basic tool bar only.
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableCompression | boolean | enable compression of the javascript files, default is true.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | EnableVisualEdit | boolean | whether to show WYSIWYG text editor.
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Options | string | Gets the list of options for the WYSIWYG (TinyMCE) editor .
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
RP | PostBackOptions | array | Gets the post back options for this textbox. (inherited from TTextBox)
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
RP | ScriptDeploymentPath | string | Gets the editor script base URL by publishing the tarred source via TTarAssetManager.
RP | ScriptUrl | string | editor script URL.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox. (inherited from TTextBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextMode | string | Overrides the parent implementation.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TTextBox)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
P | copyCustomPlugins | .
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLanguageSuffix | localized editor interface language extension.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadJavascriptLibrary | .
 | loadPostData | Loads user input data. (inherited from TTextBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | parseEditorOptions | Parse additional options set in the Options property.
P | preLoadCompressedScript | .
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
P | registerEditorClientScript | Registers the editor javascript file and code to initialize the editor.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for textbox. (inherited from TTextBox)
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode. (inherited from TTextBox)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THtmlElement

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
THtmlElement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TagName | string | the tag name of this control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THtmlWriter

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent »
THtmlWriter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Writer | {unknown} | .
Events
Methods
Name | Description
addAttribute | Adds an attribute to be rendered.
addAttributes | Adds a list of attributes to be rendered.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
addStyleAttribute | Adds a stylesheet attribute to be rendered .
addStyleAttributes | Adds a list of stylesheet attributes to be rendered.
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flush | Flushes the rendering result.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
removeAttribute | Removes the named attribute from rendering .
removeStyleAttribute | Removes the named stylesheet attribute from rendering .
renderBeginTag | Renders the openning tag.
renderEndTag | Renders the closing tag.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
write | Renders a string.
writeBreak | Renders an HTML break.
writeLine | Renders a string and appends a newline to it.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpCookie

Namespace: System.Web
Inheritance: TComponent »
THttpCookie
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Domain | string | the domain to associate the cookie with.
Expire | integer | the time the cookie expires.
Name | string | the name of the cookie.
Path | string | the path on the server in which the cookie will be available on, default is '/'.
Secure | boolean | whether the cookie should only be transmitted over a secure HTTPS connection.
Value | string | the value of the cookie.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpCookieCollection

Namespace: System.Web
Inheritance: TComponent » TList »
THttpCookieCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
findCookieByName | Finds the cookie with the specified name.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | the cookie found.
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
THttpException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getStatusCode | HTTP status code, such as 404, 500, etc.
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpRequest

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent »
THttpRequest
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AbsoluteApplicationUrl | string | entry script URL (w/ host part).
R | AcceptTypes | string | user browser accept types.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | ApplicationFilePath | string | application entry script file path (processed w/ realpath()).
R | ApplicationUrl | string | entry script URL (w/o host part).
R | BaseUrl | string | schema and hostname of the requested URL.
R | Browser | array | user browser capabilities @see get_browser.
 | CgiFix | integer | whether to use ORIG_PATH_INFO and/or ORIG_SCRIPT_NAME.
R | Cookies | THttpCookieCollection | list of cookies to be sent.
R | Count | integer | the number of items in the request.
 | EnableCookieValidation | boolean | whether cookies should be validated.
R | EnvironmentVariables | array | list of environment variables.
R | HttpProtocolVersion | string | the requested http procolol.
 | ID | string | id of this module.
R | IsSecureConnection | boolean | if the request is sent via secure channel (https).
R | Iterator | Iterator | Returns an iterator for traversing the items in the list.
R | Keys | array | the key list.
R | PathInfo | string | part of the request URL after script name and before question mark.
R | QueryString | string | part of that request URL after the question mark.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | RequestResolved | boolean | true if request is already resolved, false otherwise.
R | RequestType | string | request type, can be GET, POST, HEAD, or PUT.
R | RequestUri | string | part of that request URL after the host info (including pathinfo and query string).
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | ServerName | string | server name.
R | ServerPort | integer | server port number.
R | ServerVariables | array | list of server variables.
R | Service | IService | the current service. (inherited from TApplicationComponent)
 | ServiceID | string | requested service ID.
 | ServiceParameter | string | requested service parameter.
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | UploadedFiles | array | list of uploaded files.
R | Url | TUri | the request URL.
 | UrlFormat | THttpRequestUrlFormat | the format of URLs.
 | UrlManager | string | the ID of the URL manager module.
R | UrlManagerModule | TUrlManager | the URL manager module.
 | UrlParamSeparator | string | separator used to separate GET variable name and value when URL format is Path.
R | UrlReferrer | string | URL referrer, null if not present.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | UserAgent | string | user agent.
R | UserHost | string | user host name, null if cannot be determined.
R | UserHostAddress | string | user IP address.
R | UserLanguages | array | Returns a list of user preferred languages.
Events
Methods
 | Name | Description
 | add | Adds an item into the request.
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clear | Removes all items in the request.
 | constructUrl | Constructs a URL that can be recognized by PRADO.
 | contains | whether the request contains an item with the specified key.
 | count | Returns the number of items in the request.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the module.
 | itemAt | Returns the item with the specified key.
 | offsetExists | Returns whether there is an element at the specified offset.
 | offsetGet | Returns the element at the specified offset.
 | offsetSet | Sets the element at the specified offset.
 | offsetUnset | Unsets the element at the specified offset.
P | parseUrl | Parses the request URL and returns an array of input parameters (excluding GET variables).
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | remove | Removes an item from the request by its key.
 | resolveRequest | Resolves the requested service.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | stripSlashes | Strips slashes from input data.
 | toArray | the list of items in array.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpRequestUrlFormat

Namespace: System.Web
Inheritance: TEnumerable »
THttpRequestUrlFormat
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpResponse

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent » TModule »
THttpResponse
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | THttpResponseAdapter | response adapter, null if not exist.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | BufferOutput | boolean | whether to enable output buffer.
 | CacheControl | string | cache control method to use for session pages.
 | CacheExpire | integer | time-to-live for cached session pages in minutes, this has no effect for nocache limiter.
 | Charset | string|boolean | output charset.
 | ContentType | string | current content type.
R | Contents | string | Returns the content in the output buffer.
R | Cookies | THttpCookieCollection | list of output cookies.
R | HasAdapter | boolean | true if adapter exists, false otherwise.
 | HtmlWriterType | string | the type of HTML writer to be used, defaults to THtmlWriter.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | StatusCode | integer | HTTP status code, defaults to 200.
R | StatusReason | {unknown} | .
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addCookie | Sends a cookie.
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | appendHeader | Sends a header.
 | appendLog | Writes a log message into error log.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clear | Clears any existing buffered content.
 | createHtmlWriter | Creates a new instance of HTML writer.
 | createNewHtmlWriter | Create a new html writer instance.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Flush the response contents and headers.
 | flushContent | Outputs the buffered content, sends content-type and charset header.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | httpRedirect | Redirect the browser to another URL and exists the current application.
 | init | Initializes the module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | redirect | Redirects the browser to the specified URL.
 | reload | Reloads the current page.
 | removeCookie | Deletes a cookie.
P | sendContentTypeHeader | Sends content type header with optional charset.
P | sendHttpHeader | Send the HTTP header with the status code (defaults to 200) and status reason (defaults to OK).
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | write | Outputs a string.
 | writeFile | Sends a file back to user.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpResponseAdapter

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent »
THttpResponseAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response object adapted.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createNewHtmlWriter | This method is invoked when a new HtmlWriter needs to be created.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flushContent | This method is invoked when the response flushes the content and headers.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
httpRedirect | This method is invoked when the response is to redirect to another page.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TCallbackResponseAdapter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpSession

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent »
THttpSession
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | AutoStart | boolean | whether the session should be automatically started when the session module is initialized, defaults to false.
R | Cookie | THttpCookie | cookie that will be used to store session ID.
 | CookieMode | THttpSessionCookieMode | how to use cookie to store session ID.
R | Count | integer | the number of session variables.
 | GCProbability | integer | the probability (percentage) that the gc (garbage collection) process is started on every session initialization, defaults to 1 meaning 1% chance.
 | ID | string | id of this module.
R | IsStarted | boolean | whether the session has started.
R | Iterator | TSessionIterator | Returns an iterator for traversing the session variables.
R | Keys | array | the list of session variable names.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | SavePath | string | the current session save path, defaults to '/tmp'.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SessionID | string | the current session ID.
 | SessionName | string | the current session name.
 | Timeout | integer | the number of seconds after which data will be seen as 'garbage' and cleaned up, defaults to 1440 seconds.
 | UseCustomStorage | boolean | whether to use user-specified handlers to store session data.
 | UseTransparentSessionID | boolean | whether transparent sid support is enabled or not, defaults to false.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
_close | Session close handler.
_destroy | Session destroy handler.
_gc | Session GC (garbage collection) handler.
_open | Session open handler.
_read | Session read handler.
_write | Session write handler.
add | Adds a session variable.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all session variables.
close | Ends the current session and store session data.
contains | whether there is the named session variable.
count | Returns the number of items in the session.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
destroy | Destroys all data registered to a session.
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the module.
itemAt | Returns the session variable value with the session variable name.
offsetExists | This method is required by the interface ArrayAccess.
offsetGet | This method is required by the interface ArrayAccess.
offsetSet | This method is required by the interface ArrayAccess.
offsetUnset | This method is required by the interface ArrayAccess.
open | Starts the session if it has not started yet.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes a session variable.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of all session variables in array.
Derived classes
  • TCacheHttpSession
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpSessionCookieMode

Namespace: System.Web
Inheritance: TEnumerable »
THttpSessionCookieMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THttpUtility

Namespace: System.Web
THttpUtility
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | htmlDecode | HTML-decodes a string.
S | htmlEncode | HTML-encodes a string.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THyperLink

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
THyperLink
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL to link to when the THyperLink component is clicked.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageUrl | string | the location of the image file for the THyperLink.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | NavigateUrl | string | the URL to link to when the THyperLink component is clicked.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the hyperlink.
 | Target | string | the target window or frame to display the Web page content linked to when the THyperLink component is clicked.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the THyperLink.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes related to a hyperlink element to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createImage | Gets the TImage for rendering the ImageUrl property.
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the hyperlink.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveHyperLink
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of THyperLinkColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
THyperLinkColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataNavigateUrlField | string | the field name from the data source to bind to the navigate url of hyperlink.
 | DataNavigateUrlFormatString | string | the formatting string used to control how the navigate url of hyperlink will be displayed.
 | DataTextField | string | the field name from the data source to bind to the hyperlink caption.
 | DataTextFormatString | string | the formatting string used to control how the hyperlink caption will be displayed.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | NavigateUrl | string | the URL to link to when the hyperlink is clicked.
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
 | Target | string | the target window or frame to display the Web page content linked to when the hyperlink is clicked.
 | Text | string | the text caption of the hyperlink.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TI18NControl

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TControl »
TI18NControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | Charset | string | Gets the charset.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | Culture | string | Get the specific culture for this control.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TDateFormat
  • TNumberFormat
  • TTranslate
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TIOException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TIOException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TIbmScaffoldInput

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
Inheritance: TScaffoldInputBase » TScaffoldInputCommon »
TIbmScaffoldInput
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createBooleanControl | . (inherited from TScaffoldInputCommon)
P | createControl | .
P | createControlLabel | . (inherited from TScaffoldInputBase)
P | createDateControl | . (inherited from TScaffoldInputCommon)
P | createDateTimeControl | . (inherited from TScaffoldInputCommon)
P | createDefaultControl | . (inherited from TScaffoldInputCommon)
P | createEnumControl | . (inherited from TScaffoldInputCommon)
P | createFloatControl | . (inherited from TScaffoldInputCommon)
S | createInputBuilder | . (inherited from TScaffoldInputBase)
P | createIntegerControl | . (inherited from TScaffoldInputCommon)
P | createMultiLineControl | . (inherited from TScaffoldInputCommon)
P | createRangeValidator | . (inherited from TScaffoldInputCommon)
P | createRequiredValidator | . (inherited from TScaffoldInputCommon)
 | createScaffoldInput | . (inherited from TScaffoldInputBase)
P | createSetControl | . (inherited from TScaffoldInputCommon)
P | createTimeControl | . (inherited from TScaffoldInputCommon)
P | createTypeValidator | . (inherited from TScaffoldInputCommon)
P | createYearControl | . (inherited from TScaffoldInputCommon)
P | getControlValue | .
P | getDateTimeValue | . (inherited from TScaffoldInputCommon)
P | getDefaultControlValue | . (inherited from TScaffoldInputCommon)
P | getEnumValue | . (inherited from TScaffoldInputCommon)
P | getIsEnabled | . (inherited from TScaffoldInputBase)
P | getMatchingIndices | . (inherited from TScaffoldInputCommon)
P | getParent | . (inherited from TScaffoldInputBase)
P | getRecordPropertyValue | . (inherited from TScaffoldInputBase)
P | getSetValue | . (inherited from TScaffoldInputCommon)
P | getTimeValue | . (inherited from TScaffoldInputCommon)
 | loadScaffoldInput | . (inherited from TScaffoldInputBase)
P | setDefaultProperty | . (inherited from TScaffoldInputCommon)
P | setNotNullProperty | . (inherited from TScaffoldInputCommon)
P | setRecordPropertyValue | . (inherited from TScaffoldInputBase)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TImage

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TImage
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AlternateText | string | the alternative text displayed in the TImage component when the image is unavailable.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL of the image file.
 | DescriptionUrl | string | the URL to long description.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageAlign | string | the alignment of the image with respective to other elements on the page, defaults to empty.
 | ImageUrl | string | the URL of the image file.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of image control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes related to an HTML image element to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the image.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveImage
  • TCaptcha
  • TImageButton
  • TImageMap
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TImageButton

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TImage »
TImageButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AlternateText | string | the alternative text displayed in the TImage component when the image is unavailable. (inherited from TImage)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation, default is true.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | CommandName | string | the command name associated with the OnCommand event.
 | CommandParameter | string | the parameter associated with the OnCommand event.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL of the image file. (inherited from TImage)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | DescriptionUrl | string | the URL to long description. (inherited from TImage)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageAlign | string | the alignment of the image with respective to other elements on the page, defaults to empty. (inherited from TImage)
 | ImageUrl | string | the URL of the image file. (inherited from TImage)
 | IsDefaultButton | boolean | true if this button is registered as a default button for a panel.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the button.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | caption of the button.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnClick | This method is invoked when the button is clicked.
OnCommand | This method is invoked when the button is clicked.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the image button to receive postback data during postback.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | canCauseValidation | whether to perform validation if the button is clicked.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | This method checks if the TImageButton is clicked and loads the coordinates of the clicking position.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | needPostBackScript | whether the button needs javascript to do postback.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event.
 | raisePostDataChangedEvent | A dummy implementation for the IPostBackDataHandler interface.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the client-script code.
 | renderContents | Renders the body content enclosed between the control tag.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveImageButton
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TImageClickEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TImageClickEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
X | integer | X coordinate of the clicking point, defaults to 0.
Y | integer | Y coordinate of the clicking point, defaults to 0.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TImageMap

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TImage »
TImageMap
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AlternateText | string | the alternative text displayed in the TImage component when the image is unavailable. (inherited from TImage)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL of the image file. (inherited from TImage)
 | DescriptionUrl | string | the URL to long description. (inherited from TImage)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HotSpotMode | THotSpotMode | the behavior of hotspot regions in this imagemap when they are clicked.
R | HotSpots | THotSpotCollection | collection of hotspots defined in this imagemap.
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ImageAlign | string | the alignment of the image with respective to other elements on the page, defaults to empty. (inherited from TImage)
 | ImageUrl | string | the URL of the image file. (inherited from TImage)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of image control. (inherited from TImage)
 | Target | string | the target window or frame to display the new page when a hotspot region is clicked within the imagemap.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnClick | Raises OnClick event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Processes an object that is created during parsing template.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders this imagemap.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the image. (inherited from TImage)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TImageMapEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TImageMapEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | PostBackValue | string | post back value associated with the hotspot clicked.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInPlaceTextBox

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextBox » TActiveTextBox »
TInPlaceTextBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
R | ActiveControl | TBaseActiveCallbackControl | standard callback control options. (inherited from TActiveTextBox)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox. (inherited from TTextBox)
 | AutoHideTextBox | boolean | true will hide the textbox after losing focus.
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component. (inherited from TTextBox)
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces. (inherited from TTextBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true. (inherited from TTextBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for this TInPlaceTextBox.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options. (inherited from TActiveTextBox)
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set. (inherited from TTextBox)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the TTextBox control. (inherited from TTextBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TTextBox)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | DisplayTextBox | boolean | true to display the edit textbox.
 | EditTriggerControlID | string | ID of the control that can trigger to edit the textbox.
 | EnableClientScript | boolean | whether to render javascript. (inherited from TTextBox)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
RP | ExternalControlID | string | edit trigger control client ID.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TTextBox)
RP | LabelClientID | string | label client ID.
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set. (inherited from TTextBox)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback. (inherited from TTextBox)
RP | PostBackOptions | array | callback options.
 | ReadOnly | boolean | whether the textbox is read only, default is false. (inherited from TTextBox)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4. (inherited from TTextBox)
R | SafeText | string | safe text content with javascript stripped off. (inherited from TTextBox)
RP | SafeTextParser | mixed | safe text parser. (inherited from TTextBox)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control. (inherited from TTextBox)
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component. (inherited from TTextBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback. (inherited from TTextBox)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TTextBox)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box. (inherited from TTextBox)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnLoadingText | Raised when editing the content is requsted to be loaded from the server side.
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnTextChanged | Raises OnTextChanged event. (inherited from TTextBox)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Ensure that the ID attribute is rendered and registers the javascript code for initializing the active control.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | callClientFunction | Calls the client-side static method for this control class.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TTextBox)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event. (inherited from TActiveTextBox)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TTextBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode. (inherited from TTextBox)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Override parent implementation, no javascript is rendered here instead the javascript required for active control is registered in addAttributesToRender. (inherited from TActiveTextBox)
 | renderContents | Renders the body content of the label.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInlineFrame

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TInlineFrame
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
 | Align | TInlineFrameAlign | alignment of the iframe.
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the URL that this iframe will load content from This method is required by IDataRenderer.
 | DescriptionUrl | string | the URL to long description.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | FrameUrl | string | URL that this iframe will load content from.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | MarginHeight | integer | the amount of space, in pixels, that should be left between the frame's contents and the top and bottom margins.
 | MarginWidth | integer | the amount of space, in pixels, that should be left between the frame's contents and the left and right margins.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScrollBars | TInlineFrameScrollBars | the visibility and position of scroll bars in an iframe.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowBorder | boolean | whether there should be a visual separator between the frames.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the iframe.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInlineFrameAlign

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TInlineFrameAlign
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInlineFrameScrollBars

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TInlineFrameScrollBars
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInlineParameterMapParser

Namespace: System.Data.SqlMap.Configuration
TInlineParameterMapParser
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | parse | Parse the sql text for inline parameters.
P | parseMapping | Parse inline parameter with syntax as #propertyName,type=string,dbype=Varchar,nullValue=N/A,handler=string# .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInsertMappedStatement

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent » TMappedStatement »
TInsertMappedStatement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TPreparedCommand | command to prepare SQL statements. (inherited from TMappedStatement)
R | ID | string | Name used to identify the TMappedStatement amongst the others. (inherited from TMappedStatement)
R | Manager | TSqlMapper | The SqlMap used by this MappedStatement. (inherited from TMappedStatement)
R | SqlString | {unknown} | . (inherited from TMappedStatement)
R | Statement | TSqlMapStatement | The SQL statment used by this MappedStatement. (inherited from TMappedStatement)
Events
Name | Description
OnExecuteQuery | Raise the execute query event. (inherited from TMappedStatement)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addResultMapGroupBy | ResultMap with GroupBy property. (inherited from TMappedStatement)
P | applyResultMap | Apply result mapping. (inherited from TMappedStatement)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | enquequePostSelect | Add nested result property to post select queue. (inherited from TMappedStatement)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | executeInsert | Execute an insert statement. (inherited from TMappedStatement)
P | executePostSelect | Process 'select' result properties . (inherited from TMappedStatement)
 | executeQueryForList | .
 | executeQueryForMap | .
 | executeQueryForObject | .
P | executeSQLQueryLimit | Execute SQL Query with limits. (inherited from TMappedStatement)
P | executeSelectKey | Execute the select key statement, used to obtain last insert ID. (inherited from TMappedStatement)
 | executeUpdate | .
P | fillArrayResultMap | Retrieve the result map as an array. (inherited from TMappedStatement)
P | fillDefaultResultMap | Fill the result map using default settings. (inherited from TMappedStatement)
P | fillPropertyWithResultMap | Fills the property with result mapping results. (inherited from TMappedStatement)
P | fillResultArrayList | Apply the result to a TList or an array. (inherited from TMappedStatement)
P | fillResultClass | Fill the result using ResultClass, will creates new result object if required. (inherited from TMappedStatement)
P | fillResultMap | Fills the result object according to result mappings. (inherited from TMappedStatement)
P | fillResultObjectProperty | Apply the result to an object. (inherited from TMappedStatement)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPostGeneratedSelectKey | Gets the inserted row ID after executing an insert statement. (inherited from TMappedStatement)
P | getPostSelectKeys | Finds in the post select property the SQL statement primary selection keys. (inherited from TMappedStatement)
P | getPreGeneratedSelectKey | Gets the insert generated ID before executing an insert statement. (inherited from TMappedStatement)
P | getResultMapGroupKey | Gets the result 'group by' groupping key for each row. (inherited from TMappedStatement)
P | getScalarResult | Converts the first array value to scalar value of given type. (inherited from TMappedStatement)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initialGroupByResults | Empty the group by results cache. (inherited from TMappedStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | raiseRowDelegate | Raises delegate handler. (inherited from TMappedStatement)
 | runQueryForList | Executes the SQL and retuns a List of result objects. (inherited from TMappedStatement)
 | runQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. (inherited from TMappedStatement)
 | runQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter. (inherited from TMappedStatement)
P | setObjectProperty | Set a property of the result object with appropriate value. (inherited from TMappedStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInvalidCallbackException

Namespace: System.Web.UI.ActiveControls
Inheritance: TException »
TInvalidCallbackException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInvalidDataTypeException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TInvalidDataTypeException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInvalidDataValueException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TInvalidDataValueException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInvalidOperationException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TInvalidOperationException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TInvalidPropertyException

Namespace: System.Data.SqlMap
Inheritance: TException » TSqlMapException »
TInvalidPropertyException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TSqlMapException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
P | implodeNode | tag name and attribute names and values. (inherited from TSqlMapException)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TItemDataRenderer

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TDataRenderer »
TItemDataRenderer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item. (inherited from TDataRenderer)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
 | ItemIndex | integer | Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
 | ItemType | TListItemType | item type.
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TDataGridItemRenderer
  • TDataListItemRenderer
  • TRepeaterItemRenderer
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TJSON

Namespace: System.Web.Javascripts
TJSON
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | dec | decodes a JSON string into appropriate variable; alias for decode() .
 | decode | decodes a JSON string into appropriate variable .
 | enc | encodes an arbitrary variable into JSON format, alias for encode() .
 | encode | encodes an arbitrary variable into JSON format .
P | name_value | function name_value array-walking function for use in generating JSON-formatted name-value pairs .
P | reduce_string | reduce a string by removing leading and trailing comments and whitespace .
P | unicode_to_utf8 | This function converts a Unicode array back to its UTF-8 representation .
P | utf16be_to_utf8 | UTF-8 to UTF-16BE conversion.
P | utf8_to_unicode | This function returns any UTF-8 encoded text as a list of Unicode values: .
P | utf8_to_utf16be | UTF-8 to UTF-16BE conversion.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TJavaScript

Namespace: System.Web.Javascripts
TJavaScript
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | encode | Encodes a PHP variable into javascript representation.
S | isFunction | true if string is raw javascript function code, i.
S | jsonDecode | Decodes a javascript string into PHP variable.
S | jsonEncode | Encodes a PHP variable into javascript string.
S | quoteFunction | considers the string as raw javascript function code.
S | quoteString | Quotes a javascript string.
S | renderScriptBlock | Renders javascript block .
S | renderScriptBlocks | Renders a list of javascript blocks .
S | renderScriptFile | Renders a javascript file .
S | renderScriptFiles | Renders a list of javascript files .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TJavascriptLogger

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TJavascriptLogger
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the panel.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToggleKey | string | keyboard key for toggling the console.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the required logger javascript.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Register the required javascript libraries and display some general usage information.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TJsonResponse

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent »
TJsonResponse
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | ID of this response.
R | JsonContent | object | json response content, null to suppress output.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the feed.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TJsonService

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent » TService »
TJsonService
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Enabled | boolean | whether the service is enabled. (inherited from TService)
 | ID | string | id of this service. (inherited from TService)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createJsonResponse | Renders content provided by TJsonResponse::getJsonContent() as javascript in JSON format.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
P | loadJsonServices | Load the service definitions.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | run | Runs the service.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TKeyboard

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TKeyboard
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoHide | boolean | whether the keyboard should be hidden when the textbox is not in focus.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | the Javascript class name for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientOptions | array | the JavaScript options for this control.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CssUrl | string | the URL for the CSS file to customize the appearance of the keyboard.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the ID path of the TTextBox control.
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | KeyboardCssClass | string | the CSS class name for the keyboard element.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers CSS and JS.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScript | Registers the relevant JavaScript.
 | registerObject | Registers an object by a name. (inherited from TControl)
P | registerStyleSheet | Registers the CSS relevant to the TKeyboard.
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLabel

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TLabel
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID.
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content of the label.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveLabel
  • TBaseValidator
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLazyLoadList

Namespace: System.Data.SqlMap
TLazyLoadList
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | fetchListData | Load the data by executing the mapped statement.
 | hasMethod | Try to fetch the data when any of the proxy collection method is called.
 | intercept | Relay the method call to the underlying collection.
S | newInstance | Create a new instance of a lazy collection.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLinkButton

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TLinkButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this button will cause input validation.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | CommandName | string | the command name associated with the OnCommand event.
 | CommandParameter | string | the parameter associated with the OnCommand event.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the caption of the button.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsDefaultButton | boolean | true if this button is registered as a default button for a panel.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Returns postback specifications for the button.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the button.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the button causes validation upon postback.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnClick | This method is invoked when the button is clicked.
OnCommand | This method is invoked when the button is clicked.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostBackEvent | Raises the postback event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the client-script code.
 | renderContents | Renders the body content enclosed between the control tag.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderLinkButtonHref | Renders the Href for link button.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveLinkButton
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TList

Namespace: System.Collections
Inheritance: TComponent »
TList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list.
R | Iterator | Iterator | Returns an iterator for traversing the items in the list.
 | ReadOnly | boolean | whether this list is read-only or not.
Events
Methods
Name | Description
add | Appends an item at the end of the list.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list.
contains | whether the list contains the item.
copyFrom | Copies iterable data into the list.
count | Returns the number of items in the list.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found.
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset.
mergeWith | Merges iterable data into the map.
offsetExists | Returns whether there is an item at the specified offset.
offsetGet | Returns the item at the specified offset.
offsetSet | Sets the item at the specified offset.
offsetUnset | Unsets the item at the specified offset.
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list.
removeAt | Removes an item at the specified position.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array.
Derived classes
  • TAuthorizationRuleCollection
  • TCacheDependencyList
  • TControlCollection
  • TDataGridColumnCollection
  • TDataGridItemCollection
  • TDataListItemCollection
  • THotSpotCollection
  • THttpCookieCollection
  • TListItemCollection
  • TMetaTagCollection
  • TPagedList
  • TRepeaterItemCollection
  • TWizardStepCollection
  • TXmlElementList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListBox

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl »
TListBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control allows multiple selection.
 | IsValid | bool | Returns true if this control validated successfully.
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | postback options for JS postback code. (inherited from TListControl)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows to be displayed in the list control.
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
 | SelectionMode | TListSelectionMode | the selection mode (Single, Multiple).
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated.
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the list control to load post data on postback.
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TActiveListBox
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListControl

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl »
TListControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index.
 | DataGroupField | string | the field of the data source that provides the label of the list item groups.
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items.
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed.
 | DataValueField | string | the field of the data source that provides the value of each list item.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items.
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this is a multiselect control.
R | ItemCount | integer | the number of items in the list control.
R | Items | TListItemCollection | the item collection.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | postback options for JS postback code.
 | PromptText | string | the prompt text which is to be displayed as the first list item.
 | PromptValue | string | the prompt selection value.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected.
 | SelectedIndices | array | list of index of items that are selected.
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected.
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection.
 | SelectedValues | array | list of the selected item values (strings).
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback.
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed.
OnTextChanged | Raises OnTextChanged event when selection is changed.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds object parsed from template to the control.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections.
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items.
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string.
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control.
 | renderContents | Renders body content of the list control.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderPrompt | Renders the prompt text, if any.
 | saveState | Saves items into viewstate.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TBulletedList
  • TCheckBoxList
  • TDropDownList
  • TListBox
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListControlValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TListControlValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
 | MaxSelection | integer | max number of selections.
 | MinSelection | integer | min number of selections.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
 | RequiredSelections | string | Get a comma separated list of required selected values.
RP | RequiredValues | array | list of required values.
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
P | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
P | getSelection | number of selected values and its values.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListItem

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TListItem
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Attributes | TAttributeCollection | custom attributes.
 | Enabled | boolean | whether the item is enabled.
R | HasAttributes | boolean | whether the item has any custom attribute.
 | Selected | boolean | whether the item is selected.
 | Text | string | text of the item.
 | Value | string | value of the item.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getAttribute | the named attribute value, null if attribute does not exist.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasAttribute | whether the named attribute exists.
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
removeAttribute | Removes the named attribute.
setAttribute | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListItemCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList »
TListItemCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
 | Name | Description
 | add | Appends an item at the end of the list. (inherited from TList)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clear | Removes all items in the list. (inherited from TList)
 | contains | whether the list contains the item. (inherited from TList)
 | copyFrom | Copies iterable data into the list. (inherited from TList)
 | count | Returns the number of items in the list. (inherited from TList)
 | createListItem | Creates a list item object.
P | createNewListItem | new item.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findIndexByText | Finds the lowest cardinal index of the item whose text is the one being looked for.
 | findIndexByValue | Finds the lowest cardinal index of the item whose value is the one being looked for.
 | findItemByText | Finds the item whose text is the one being looked for.
 | findItemByValue | Finds the item whose value is the one being looked for.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
 | insertAt | Inserts an item into the collection.
 | itemAt | Returns the item at the specified offset. (inherited from TList)
 | loadState | Loads state into every item in the collection.
 | mergeWith | Merges iterable data into the map. (inherited from TList)
 | offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
 | offsetGet | Returns the item at the specified offset. (inherited from TList)
 | offsetSet | Sets the item at the specified offset. (inherited from TList)
 | offsetUnset | Unsets the item at the specified offset. (inherited from TList)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | remove | Removes an item from the list. (inherited from TList)
 | removeAt | Removes an item at the specified position. (inherited from TList)
 | saveState | Saves state of items.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | toArray | the list of items in array. (inherited from TList)
Derived classes
  • TActiveListItemCollection
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListItemType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TListItemType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListIterator

Namespace: System.Collections
TListIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array item.
key | Returns the key of the current array item.
next | Moves the internal pointer to the next array item.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an item at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TListSelectionMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TListSelectionMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLiteral

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TLiteral
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the static text of the TLiteral.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | Encode | boolean | whether the rendered text should be HTML-encoded.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the static text of the TLiteral.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the literal control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLiteralColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TLiteralColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DataField | string | the field name from the data source to bind to the column.
 | DataFormatString | string | the formatting string used to control how the bound data will be displayed.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | Encode | boolean | whether the rendered text should be HTML-encoded.
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
 | Text | string | static text to be displayed in the column.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLogRoute

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent »
TLogRoute
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Categories | array | list of categories to be looked for.
 | Levels | integer | log level filter.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | collectLogs | Retrieves log messages from logger to log route specific destination.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatLogMessage | Formats a log message given different fields.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLevelName | level name.
P | getLevelValue | level value.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the route.
P | processLogs | Processes log messages and sends them to specific destination.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TBrowserLogRoute
  • TDbLogRoute
  • TEmailLogRoute
  • TFileLogRoute
  • TFirePhpLogRoute
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLogRouter

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TModule »
TLogRouter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ConfigFile | string | external configuration file.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
addRoute | Adds a TLogRoute instance to the log router.
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
collectLogs | Collects log messages from a logger.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes this module.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TLogger

Namespace: System.Util
Inheritance: TComponent »
TLogger
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Logs | {unknown} | Retrieves log messages.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
log | Logs a message.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMap

Namespace: System.Collections
Inheritance: TComponent »
TMap
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the map.
R | Iterator | Iterator | Returns an iterator for traversing the items in the list.
R | Keys | array | the key list.
 | ReadOnly | boolean | whether this map is read-only or not.
Events
Methods
Name | Description
add | Adds an item into the map.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the map.
contains | whether the map contains an item with the specified key.
copyFrom | Copies iterable data into the map.
count | Returns the number of items in the map.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
itemAt | Returns the item with the specified key.
mergeWith | Merges iterable data into the map.
offsetExists | Returns whether there is an element at the specified offset.
offsetGet | Returns the element at the specified offset.
offsetSet | Sets the element at the specified offset.
offsetUnset | Unsets the element at the specified offset.
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the map by its key.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array.
Derived classes
  • TAttributeCollection
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMapCollectionDiff

Namespace: System.Web.UI.ActiveControls
Inheritance: TViewStateDiff »
TMapCollectionDiff
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
getDifference | updates to the attributes collection.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMapIterator

Namespace: System.Collections
TMapIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array element.
key | Returns the key of the current array element.
next | Moves the internal pointer to the next array element.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an element at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMappedStatement

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent »
TMappedStatement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TPreparedCommand | command to prepare SQL statements.
R | ID | string | Name used to identify the TMappedStatement amongst the others.
R | Manager | TSqlMapper | The SqlMap used by this MappedStatement.
R | SqlString | {unknown} | .
R | Statement | TSqlMapStatement | The SQL statment used by this MappedStatement.
Events
Name | Description
OnExecuteQuery | Raise the execute query event.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addResultMapGroupBy | ResultMap with GroupBy property.
P | applyResultMap | Apply result mapping.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | enquequePostSelect | Add nested result property to post select queue.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | executeInsert | Execute an insert statement.
P | executePostSelect | Process 'select' result properties .
 | executeQueryForList | Executes the SQL and retuns a List of result objects.
 | executeQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter.
 | executeQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter.
P | executeSQLQueryLimit | Execute SQL Query with limits.
P | executeSelectKey | Execute the select key statement, used to obtain last insert ID.
 | executeUpdate | Execute an update statement.
P | fillArrayResultMap | Retrieve the result map as an array.
P | fillDefaultResultMap | Fill the result map using default settings.
P | fillPropertyWithResultMap | Fills the property with result mapping results.
P | fillResultArrayList | Apply the result to a TList or an array.
P | fillResultClass | Fill the result using ResultClass, will creates new result object if required.
P | fillResultMap | Fills the result object according to result mappings.
P | fillResultObjectProperty | Apply the result to an object.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPostGeneratedSelectKey | Gets the inserted row ID after executing an insert statement.
P | getPostSelectKeys | Finds in the post select property the SQL statement primary selection keys.
P | getPreGeneratedSelectKey | Gets the insert generated ID before executing an insert statement.
P | getResultMapGroupKey | Gets the result 'group by' groupping key for each row.
P | getScalarResult | Converts the first array value to scalar value of given type.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initialGroupByResults | Empty the group by results cache.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | raiseRowDelegate | Raises delegate handler.
 | runQueryForList | Executes the SQL and retuns a List of result objects.
 | runQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter.
 | runQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter.
P | setObjectProperty | Set a property of the result object with appropriate value.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TInsertMappedStatement
  • TSelectMappedStatement
  • TUpdateMappedStatement
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMarkdown

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextProcessor » TTextHighlighter »
TMarkdown
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableCopyCode | boolean | true will show "Copy Code" link. (inherited from TTextHighlighter)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
RP | HeaderTemplate | string | header template with "Copy code" link. (inherited from TTextHighlighter)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | Language | string | language whose syntax is to be used for highlighting. (inherited from TTextHighlighter)
 | LineNumberStyle | TTextHighlighterLineNumberStyle | style of row number, Table by default. (inherited from TTextHighlighter)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowLineNumbers | boolean | whether to show line numbers in the highlighted result. (inherited from TTextHighlighter)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TabSize | integer | tab size. (inherited from TTextHighlighter)
RP | TagName | string | tag name of the panel. (inherited from TTextHighlighter)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | text to be processed. (inherited from TTextProcessor)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers css style for the highlighted result. (inherited from TTextHighlighter)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | HTML-decodes static text. (inherited from TTextProcessor)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | highlightCode | Highlights source code using TTextHighlighter .
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | processText | Processes a text string.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
P | registerStyleSheet | Registers the stylesheet for presentation. (inherited from TTextHighlighter)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body content. (inherited from TTextProcessor)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMemCache

Namespace: System.Caching
Inheritance: TComponent » TApplicationComponent » TModule » TCache »
TMemCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Host | string | host name of the memcache server.
 | ID | string | id of this module. (inherited from TModule)
 | KeyPrefix | string | a unique prefix for the keys of cached values. (inherited from TCache)
 | Port | integer | port number of the memcache server.
 | PrimaryCache | boolean | whether this cache module is used as primary/system cache. (inherited from TCache)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | add | Stores a value identified by a key into cache if the cache does not contain this key. (inherited from TCache)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addValue | Stores a value identified by a key into cache if the cache does not contain this key.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes a value with the specified key from cache . (inherited from TCache)
P | deleteValue | Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Deletes all values from cache.
P | generateUniqueKey | a key generated from the provided key which ensures the uniqueness across applications. (inherited from TCache)
 | get | Retrieves a value from cache with a specified key. (inherited from TCache)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValue | Retrieves a value from cache with a specified key.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | offsetExists | Returns whether there is a cache entry with a specified key. (inherited from TCache)
 | offsetGet | . (inherited from TCache)
 | offsetSet | . (inherited from TCache)
 | offsetUnset | . (inherited from TCache)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | set | Stores a value identified by a key into cache. (inherited from TCache)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setValue | Stores a value identified by a key in cache.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMetaTag

Namespace: System.Web.UI
Inheritance: TComponent »
TMetaTag
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Content | string | content attribute of the meta tag.
HttpEquiv | string | http-equiv attribute of the meta tag.
ID | string | id of the meta tag.
Name | string | name attribute of the meta tag.
Scheme | string | scheme attribute of the meta tag.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
render | Renders the meta tag.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMetaTagCollection

Namespace: System.Web.UI
Inheritance: TComponent » TList »
TMetaTagCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
findIndexByID | Finds the lowest cardinal index of the meta tag whose id is the one being looked for.
findMetaTagByID | Finds the item whose value is the one being looked for.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TModule

Namespace: System
Inheritance: TComponent » TApplicationComponent »
TModule
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the module.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TApplicationStatePersister
  • TAssetManager
  • TAuthManager
  • TCache
  • TDataSourceConfig
  • TDbUserManager
  • TErrorHandler
  • TGlobalization
  • THttpResponse
  • TLogRouter
  • TParameterModule
  • TSecurityManager
  • TTemplateManager
  • TThemeManager
  • TUrlManager
  • TUserManager
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMssqlCommandBuilder

Namespace: System.Data.Common
Inheritance: TComponent » TDbCommandBuilder »
TMssqlCommandBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | database connection. (inherited from TDbCommandBuilder)
R | LastInsertID | integer | Overrides parent implementation.
R | SelectFieldList | array | Different behavior depends on type of passed data string usage without modification null will be expanded to full list of quoted table column names (quoting depends on database) array - Column names will be quoted if used as key or value of array array('col1', 'col2', 'col2') // SELECT `col1`, `col2`, `col3` FROM. (inherited from TDbCommandBuilder)
 | TableInfo | {unknown} | . (inherited from TDbCommandBuilder)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyCriterias | . (inherited from TDbCommandBuilder)
 | applyLimitOffset | Overrides parent implementation.
 | applyOrdering | modified SQL applied with ORDER BY. (inherited from TDbCommandBuilder)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | bindArrayValues | . (inherited from TDbCommandBuilder)
 | bindColumnValues | Bind the name-value pairs of $values where the array keys correspond to column names. (inherited from TDbCommandBuilder)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommand | corresponding database command. (inherited from TDbCommandBuilder)
 | createCountCommand | Creates a count(*) command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createDeleteCommand | Creates a delete command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createFindCommand | Appends the $where condition to the string "SELECT * FROM tableName WHERE ". (inherited from TDbCommandBuilder)
 | createInsertCommand | Creates an insert command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createUpdateCommand | Creates an update command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | findOrdering | Base on simplified syntax http://msdn2.
P | getColumnBindings | Create a name-value or position-value if $position=true binding strings. (inherited from TDbCommandBuilder)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertFieldBindings | Returns a list of insert field name and a list of binding names. (inherited from TDbCommandBuilder)
S | getPdoType | PDO parameter types. (inherited from TDbCommandBuilder)
P | getSearchCondition | search condition for all words in one column. (inherited from TDbCommandBuilder)
 | getSearchExpression | Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords). (inherited from TDbCommandBuilder)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
P | hasIntegerKey | true if any array key is an integer. (inherited from TDbCommandBuilder)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | joinOrdering | concat the orderings.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | reverseDirection | ordering with reversed direction.
P | rewriteLimitOffsetSql | Rewrite sql to apply $limit > and $offset > 0 for MSSQL database.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMssqlMetaData

Namespace: System.Data.Common.Pgsql
Inheritance: TComponent » TDbMetaData »
TMssqlMetaData
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection. (inherited from TDbMetaData)
R | TableInfo | TDbTableInfo | Obtains table meta data information for the current connection and given table name. (inherited from TDbMetaData)
RP | TableInfoClass | string | TDbTableInfo class name.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | Creates a command builder for a given table name. (inherited from TDbMetaData)
P | createNewTableInfo | .
P | createTableInfo | Get the column definitions for given table.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getCatalogSchemaTableName | tuple($catalogName,$schemaName,$tableName).
P | getConstraintKeys | Gets the primary and foreign key column details for the given table.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getForeignConstraints | Gets foreign relationship constraint keys and table name .
S | getInstance | Obtain database specific TDbMetaData class using the driver name of the database connection. (inherited from TDbMetaData)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isForeignKeyColumn | true if column is a foreign key.
P | processColumn | .
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMssqlScaffoldInput

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
Inheritance: TScaffoldInputBase » TScaffoldInputCommon »
TMssqlScaffoldInput
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createBooleanControl | . (inherited from TScaffoldInputCommon)
P | createControl | .
P | createControlLabel | . (inherited from TScaffoldInputBase)
P | createDateControl | . (inherited from TScaffoldInputCommon)
P | createDateTimeControl | . (inherited from TScaffoldInputCommon)
P | createDefaultControl | . (inherited from TScaffoldInputCommon)
P | createEnumControl | . (inherited from TScaffoldInputCommon)
P | createFloatControl | . (inherited from TScaffoldInputCommon)
S | createInputBuilder | . (inherited from TScaffoldInputBase)
P | createIntegerControl | . (inherited from TScaffoldInputCommon)
P | createMultiLineControl | . (inherited from TScaffoldInputCommon)
P | createRangeValidator | . (inherited from TScaffoldInputCommon)
P | createRequiredValidator | . (inherited from TScaffoldInputCommon)
 | createScaffoldInput | . (inherited from TScaffoldInputBase)
P | createSetControl | . (inherited from TScaffoldInputCommon)
P | createTimeControl | . (inherited from TScaffoldInputCommon)
P | createTypeValidator | . (inherited from TScaffoldInputCommon)
P | createYearControl | . (inherited from TScaffoldInputCommon)
P | getControlValue | .
P | getDateTimeValue | . (inherited from TScaffoldInputCommon)
P | getDefaultControlValue | . (inherited from TScaffoldInputCommon)
P | getEnumValue | . (inherited from TScaffoldInputCommon)
P | getIsEnabled | . (inherited from TScaffoldInputBase)
P | getMatchingIndices | . (inherited from TScaffoldInputCommon)
P | getParent | . (inherited from TScaffoldInputBase)
P | getRecordPropertyValue | . (inherited from TScaffoldInputBase)
P | getSetValue | . (inherited from TScaffoldInputCommon)
P | getTimeValue | . (inherited from TScaffoldInputCommon)
 | loadScaffoldInput | . (inherited from TScaffoldInputBase)
P | setDefaultProperty | . (inherited from TScaffoldInputCommon)
P | setNotNullProperty | . (inherited from TScaffoldInputCommon)
P | setRecordPropertyValue | . (inherited from TScaffoldInputBase)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMssqlTableColumn

Namespace: System.Data.Common.Mssql
Inheritance: TComponent » TDbTableColumn »
TMssqlTableColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowNull | boolean | specifies whether value Null is allowed, default is false. (inherited from TDbTableColumn)
R | AutoIncrement | boolean | true if the column has identity (auto-increment).
R | ColumnId | string | name of the column with quoted identifier. (inherited from TDbTableColumn)
R | ColumnIndex | integer | zero-based ordinal position of the column in the table. (inherited from TDbTableColumn)
R | ColumnName | string | name of the column in the table (identifier quoted). (inherited from TDbTableColumn)
R | ColumnSize | string | size of the column. (inherited from TDbTableColumn)
R | DbType | string | column type. (inherited from TDbTableColumn)
R | DefaultValue | mixed | default column value if column value was null. (inherited from TDbTableColumn)
R | IsExcluded | boolean | true if db type is 'timestamp'.
R | IsForeignKey | boolean | whether this column is a foreign key, default is false. (inherited from TDbTableColumn)
R | IsPrimaryKey | boolean | whether this column is a primary key for the table, default is false. (inherited from TDbTableColumn)
R | MaxiumNumericConstraint | {unknown} | . (inherited from TDbTableColumn)
R | NumericPrecision | string | precision of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | NumericScale | string | scale of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | PHPType | boolean | Overrides parent implementation, returns PHP type from the db type.
R | PdoType | {unknown} | . (inherited from TDbTableColumn)
R | SequenceName | {unknown} | . (inherited from TDbTableColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableColumn)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasSequence | true if auto increments.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMssqlTableInfo

Namespace: System.Data.Common.Mssql
Inheritance: TComponent » TDbTableInfo »
TMssqlTableInfo
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CatalogName | string | catalog name (database name).
R | ColumnNames | array | table column names (identifier quoted). (inherited from TDbTableInfo)
R | Columns | TMap | TDbTableColumn column meta data. (inherited from TDbTableInfo)
R | ForeignKeys | array | tuples of foreign table and column name. (inherited from TDbTableInfo)
R | IsView | boolean | whether the table is a view, default is false. (inherited from TDbTableInfo)
R | LowerCaseColumnNames | array | lowercased column key names mapped to normal column ids. (inherited from TDbTableInfo)
R | PrimaryKeys | string[] | . (inherited from TDbTableInfo)
R | SchemaName | string | name of the schema this column belongs to.
R | TableFullName | string | full name of the table, database dependent.
R | TableName | string | name of the table this column belongs to. (inherited from TDbTableInfo)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | new command builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getColumn | column information. (inherited from TDbTableInfo)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableInfo)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableInfo)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMultiView

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TMultiView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | ActiveView | TView | the currently active view, null if no active view @throws TInvalidDataValueException if the current active view index is invalid.
 | ActiveViewIndex | integer | the zero-based index of the current view in the view collection.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | Views | TViewCollection | the view collection.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnActiveViewChanged | Raises OnActiveViewChanged event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Initializes the active view if any.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | activateView | Activates the specified view.
 | addParsedObject | Processes an object that is created during parsing template.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Processes the events bubbled from child controls.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls .
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | ignoreBubbleEvents | Makes the multiview ignore all bubbled events.
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads state into the wizard.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the currently active view.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMysqlCommandBuilder

Namespace: System.Data.Common
Inheritance: TComponent » TDbCommandBuilder »
TMysqlCommandBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | database connection. (inherited from TDbCommandBuilder)
R | LastInsertID | mixed | Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial. (inherited from TDbCommandBuilder)
R | SelectFieldList | array | Different behavior depends on type of passed data string usage without modification null will be expanded to full list of quoted table column names (quoting depends on database) array - Column names will be quoted if used as key or value of array array('col1', 'col2', 'col2') // SELECT `col1`, `col2`, `col3` FROM. (inherited from TDbCommandBuilder)
 | TableInfo | {unknown} | . (inherited from TDbCommandBuilder)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyCriterias | . (inherited from TDbCommandBuilder)
 | applyLimitOffset | Alters the sql to apply $limit and $offset. (inherited from TDbCommandBuilder)
 | applyOrdering | modified SQL applied with ORDER BY. (inherited from TDbCommandBuilder)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | bindArrayValues | . (inherited from TDbCommandBuilder)
 | bindColumnValues | Bind the name-value pairs of $values where the array keys correspond to column names. (inherited from TDbCommandBuilder)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommand | corresponding database command. (inherited from TDbCommandBuilder)
 | createCountCommand | Creates a count(*) command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createDeleteCommand | Creates a delete command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createFindCommand | Appends the $where condition to the string "SELECT * FROM tableName WHERE ". (inherited from TDbCommandBuilder)
 | createInsertCommand | Creates an insert command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createUpdateCommand | Creates an update command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getColumnBindings | Create a name-value or position-value if $position=true binding strings. (inherited from TDbCommandBuilder)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertFieldBindings | Returns a list of insert field name and a list of binding names. (inherited from TDbCommandBuilder)
S | getPdoType | PDO parameter types. (inherited from TDbCommandBuilder)
P | getSearchCondition | search condition for all words in one column. (inherited from TDbCommandBuilder)
 | getSearchExpression | Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords). (inherited from TDbCommandBuilder)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
P | hasIntegerKey | true if any array key is an integer. (inherited from TDbCommandBuilder)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMysqlMetaData

Namespace: System.Data.Common.Mysql
Inheritance: TComponent » TDbMetaData »
TMysqlMetaData
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection. (inherited from TDbMetaData)
RP | ServerVersion | float | server version.
R | TableInfo | TDbTableInfo | Obtains table meta data information for the current connection and given table name. (inherited from TDbMetaData)
RP | TableInfoClass | string | TDbTableInfo class name.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | Creates a command builder for a given table name. (inherited from TDbMetaData)
P | createNewTableInfo | .
P | createTableInfo | Get the column definitions for given table.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | findForeignConstraints | Extract foreign key constraints by extracting the contraints from SHOW CREATE TABLE result.
P | getConstraintKeys | Gets the primary and foreign key column details for the given table.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getForeignConstraints | Gets foreign relationship constraint keys and table name .
S | getInstance | Obtain database specific TDbMetaData class using the driver name of the database connection. (inherited from TDbMetaData)
P | getIsView | For MySQL version 5.
P | getSchemaTableName | tuple ($schema,$table), $schema may be null.
P | getShowCreateTable | SQL command to create the table.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isEnumSetType | true if column type if "enum" or "set".
P | isForeignKeyColumn | true if column is a foreign key.
P | isPrecisionType | true if column type if "numeric", "interval" or begins with "time".
P | isValidIdentifier | http://dev.
P | processColumn | .
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMysqlScaffoldInput

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
Inheritance: TScaffoldInputBase » TScaffoldInputCommon »
TMysqlScaffoldInput
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createBooleanControl | . (inherited from TScaffoldInputCommon)
P | createControl | .
P | createControlLabel | . (inherited from TScaffoldInputBase)
P | createDateControl | . (inherited from TScaffoldInputCommon)
P | createDateTimeControl | . (inherited from TScaffoldInputCommon)
P | createDefaultControl | . (inherited from TScaffoldInputCommon)
P | createEnumControl | . (inherited from TScaffoldInputCommon)
P | createFloatControl | . (inherited from TScaffoldInputCommon)
S | createInputBuilder | . (inherited from TScaffoldInputBase)
P | createIntegerControl | .
P | createMultiLineControl | . (inherited from TScaffoldInputCommon)
P | createRangeValidator | . (inherited from TScaffoldInputCommon)
P | createRequiredValidator | . (inherited from TScaffoldInputCommon)
 | createScaffoldInput | . (inherited from TScaffoldInputBase)
P | createSetControl | . (inherited from TScaffoldInputCommon)
P | createTimeControl | . (inherited from TScaffoldInputCommon)
P | createTypeValidator | . (inherited from TScaffoldInputCommon)
P | createYearControl | . (inherited from TScaffoldInputCommon)
P | getControlValue | .
P | getDateTimeValue | . (inherited from TScaffoldInputCommon)
P | getDefaultControlValue | . (inherited from TScaffoldInputCommon)
P | getEnumValue | . (inherited from TScaffoldInputCommon)
P | getIntBooleanValue | .
P | getIsEnabled | . (inherited from TScaffoldInputBase)
P | getMatchingIndices | . (inherited from TScaffoldInputCommon)
P | getParent | . (inherited from TScaffoldInputBase)
P | getRecordPropertyValue | . (inherited from TScaffoldInputBase)
P | getSetValue | . (inherited from TScaffoldInputCommon)
P | getTimeValue | . (inherited from TScaffoldInputCommon)
 | loadScaffoldInput | . (inherited from TScaffoldInputBase)
P | setDefaultProperty | . (inherited from TScaffoldInputCommon)
P | setNotNullProperty | . (inherited from TScaffoldInputCommon)
P | setRecordPropertyValue | . (inherited from TScaffoldInputBase)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMysqlTableColumn

Namespace: System.Data.Common.Mysql
Inheritance: TComponent » TDbTableColumn »
TMysqlTableColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowNull | boolean | specifies whether value Null is allowed, default is false. (inherited from TDbTableColumn)
R | AutoIncrement | boolean | true if column will auto-increment when the column value is inserted as null.
R | ColumnId | string | name of the column with quoted identifier. (inherited from TDbTableColumn)
R | ColumnIndex | integer | zero-based ordinal position of the column in the table. (inherited from TDbTableColumn)
R | ColumnName | string | name of the column in the table (identifier quoted). (inherited from TDbTableColumn)
R | ColumnSize | string | size of the column. (inherited from TDbTableColumn)
R | DbType | string | column type. (inherited from TDbTableColumn)
R | DbTypeValues | {unknown} | .
R | DefaultValue | mixed | default column value if column value was null. (inherited from TDbTableColumn)
R | IsExcluded | boolean | whether this column is excluded from insert and update. (inherited from TDbTableColumn)
R | IsForeignKey | boolean | whether this column is a foreign key, default is false. (inherited from TDbTableColumn)
R | IsPrimaryKey | boolean | whether this column is a primary key for the table, default is false. (inherited from TDbTableColumn)
R | MaxiumNumericConstraint | {unknown} | . (inherited from TDbTableColumn)
R | NumericPrecision | string | precision of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | NumericScale | string | scale of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | PHPType | boolean | Overrides parent implementation, returns PHP type from the db type.
R | PdoType | {unknown} | . (inherited from TDbTableColumn)
R | SequenceName | {unknown} | . (inherited from TDbTableColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableColumn)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasSequence | true if auto increment is true.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TMysqlTableInfo

Namespace: System.Data.Common.Mysql
Inheritance: TComponent » TDbTableInfo »
TMysqlTableInfo
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ColumnNames | array | table column names (identifier quoted). (inherited from TDbTableInfo)
R | Columns | TMap | TDbTableColumn column meta data. (inherited from TDbTableInfo)
R | ForeignKeys | array | tuples of foreign table and column name. (inherited from TDbTableInfo)
R | IsView | boolean | whether the table is a view, default is false. (inherited from TDbTableInfo)
R | LowerCaseColumnNames | array | lowercased column key names mapped to normal column ids. (inherited from TDbTableInfo)
R | PrimaryKeys | string[] | . (inherited from TDbTableInfo)
R | SchemaName | string | name of the schema this column belongs to.
R | TableFullName | string | full name of the table, database dependent.
R | TableName | string | name of the table this column belongs to. (inherited from TDbTableInfo)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | new command builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getColumn | column information. (inherited from TDbTableInfo)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableInfo)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableInfo)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TNotSupportedException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TNotSupportedException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TNumberFormat

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TControl » TI18NControl »
TNumberFormat
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | Charset | string | Gets the charset. (inherited from TI18NControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | Culture | string | Get the specific culture for this control. (inherited from TI18NControl)
 | Currency | string | 3 letter currency code.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Get the numberic value for this control.
 | DefaultText | string | Get the default text value for this control.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
RP | FormattedValue | string | Formats the localized number, be it currency or decimal, or percentage.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | Pattern | string | Get the number formatting pattern.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Type | string | Get the formatting type for this control.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Value | string | Get the numberic value for this control.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | .
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TObjectProxy

Namespace: System.Data.SqlMap
TObjectProxy
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOracleCommandBuilder

Namespace: System.Data.Common
Inheritance: TComponent » TDbCommandBuilder »
TOracleCommandBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | database connection. (inherited from TDbCommandBuilder)
R | LastInsertID | mixed | Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial. (inherited from TDbCommandBuilder)
R | SelectFieldList | array | Different behavior depends on type of passed data string usage without modification null will be expanded to full list of quoted table column names (quoting depends on database) array - Column names will be quoted if used as key or value of array array('col1', 'col2', 'col2') // SELECT `col1`, `col2`, `col3` FROM. (inherited from TDbCommandBuilder)
 | TableInfo | {unknown} | . (inherited from TDbCommandBuilder)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyCriterias | . (inherited from TDbCommandBuilder)
 | applyLimitOffset | Overrides parent implementation to use Oracle way of get paginated RecordSet instead of using LIMIT sql clause.
 | applyOrdering | modified SQL applied with ORDER BY. (inherited from TDbCommandBuilder)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | bindArrayValues | . (inherited from TDbCommandBuilder)
 | bindColumnValues | Bind the name-value pairs of $values where the array keys correspond to column names. (inherited from TDbCommandBuilder)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommand | corresponding database command. (inherited from TDbCommandBuilder)
 | createCountCommand | Creates a count(*) command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createDeleteCommand | Creates a delete command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createFindCommand | Appends the $where condition to the string "SELECT * FROM tableName WHERE ". (inherited from TDbCommandBuilder)
 | createInsertCommand | Creates an insert command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createUpdateCommand | Creates an update command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getColumnBindings | Create a name-value or position-value if $position=true binding strings. (inherited from TDbCommandBuilder)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertFieldBindings | Returns a list of insert field name and a list of binding names. (inherited from TDbCommandBuilder)
S | getPdoType | PDO parameter types. (inherited from TDbCommandBuilder)
P | getSearchCondition | search condition for all words in one column. (inherited from TDbCommandBuilder)
 | getSearchExpression | Overrides parent implementation.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
P | hasIntegerKey | true if any array key is an integer. (inherited from TDbCommandBuilder)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isSearchableColumn | true if column can be used for LIKE searching.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOracleMetaData

Namespace: System.Data.Common.Oracle
Inheritance: TComponent » TDbMetaData »
TOracleMetaData
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection. (inherited from TDbMetaData)
 | DefaultSchema | string | default schema.
R | TableInfo | TDbTableInfo | Obtains table meta data information for the current connection and given table name. (inherited from TDbMetaData)
RP | TableInfoClass | string | TDbTableInfo class name.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | assertIdentifier | a valid identifier.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | Creates a command builder for a given table name. (inherited from TDbMetaData)
P | createNewTableInfo | .
P | createTableInfo | Get the column definitions for given table.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getConstraintKeys | Gets the primary and foreign key column details for the given table.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getForeignKeys | Gets foreign relationship constraint keys and table name .
S | getInstance | Obtain database specific TDbMetaData class using the driver name of the database connection. (inherited from TDbMetaData)
P | getIsView | true if the table is a view.
P | getPrimaryKeys | Gets the primary key field names .
P | getSchemaTableName | tuple as ($schemaName,$tableName).
P | getSequenceName | serial name if found, null otherwise.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isForeignKeyColumn | true if column is a foreign key.
P | isPrecisionType | true if column type if "numeric", "interval" or begins with "time".
P | processColumn | .
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOracleTableColumn

Namespace: System.Data.Common.Oracle
Inheritance: TComponent » TDbTableColumn »
TOracleTableColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowNull | boolean | specifies whether value Null is allowed, default is false. (inherited from TDbTableColumn)
R | ColumnId | string | name of the column with quoted identifier. (inherited from TDbTableColumn)
R | ColumnIndex | integer | zero-based ordinal position of the column in the table. (inherited from TDbTableColumn)
R | ColumnName | string | name of the column in the table (identifier quoted). (inherited from TDbTableColumn)
R | ColumnSize | string | size of the column. (inherited from TDbTableColumn)
R | DbType | string | column type. (inherited from TDbTableColumn)
R | DefaultValue | mixed | default column value if column value was null. (inherited from TDbTableColumn)
R | IsExcluded | boolean | whether this column is excluded from insert and update. (inherited from TDbTableColumn)
R | IsForeignKey | boolean | whether this column is a foreign key, default is false. (inherited from TDbTableColumn)
R | IsPrimaryKey | boolean | whether this column is a primary key for the table, default is false. (inherited from TDbTableColumn)
R | MaxiumNumericConstraint | {unknown} | . (inherited from TDbTableColumn)
R | NumericPrecision | string | precision of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | NumericScale | string | scale of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | PHPType | boolean | Overrides parent implementation, returns PHP type from the db type.
R | PdoType | {unknown} | . (inherited from TDbTableColumn)
R | SequenceName | {unknown} | . (inherited from TDbTableColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableColumn)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasSequence | whether the column is a sequence. (inherited from TDbTableColumn)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOracleTableInfo

Namespace: System.Data.Common
Inheritance: TComponent »
TOracleTableInfo
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ColumnNames | array | table column names (identifier quoted).
R | Columns | TMap | TDbTableColumn column meta data.
R | ForeignKeys | array | tuples of foreign table and column name.
R | IsView | boolean | whether the table is a view, default is false.
R | LowerCaseColumnNames | array | lowercased column key names mapped to normal column ids.
R | PrimaryKeys | string[] | .
R | TableFullName | string | full name of the table, database dependent.
R | TableName | string | name of the table this column belongs to.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | new command builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getColumn | column information.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getInfo | information array value.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOutputCache

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TOutputCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | {unknown} | Returns a value indicating whether body contents are allowed for this control.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
RP | BaseCacheKey | string | basic cache key without variations.
RP | CacheDependency | ICacheDependency | Returns the dependency of the data to be cached.
 | CacheModuleID | string | the ID of the cache module.
R | CacheTime | integer | the timestamp of the cached content.
 | CachingPostBack | boolean | whether cached output will be used on postback requests.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ContentCached | boolean | whether content enclosed is cached or not.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Duration | integer | number of seconds that the data can remain in cache.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VaryByParam | string | a semicolon-separated list of strings used to vary the output cache.
 | VaryBySession | boolean | whether the content being cached should be differentiated according to user sessions.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCalculateKey | This event is raised when the output cache is calculating cache key.
OnCheckDependency | This event is raised when the output cache is checking cache dependency.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
P | calculateCacheKey | Calculates the cache key.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls.
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls.
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerAction | Registers an action associated with the content being cached.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the output cache control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection.
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
 | setCacheKeyPrefix | Sets the prefix of the cache key.
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOutputCacheCalculateKeyEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TOutputCacheCalculateKeyEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
CacheKey | string | cache key to be appended to the default calculation scheme.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TOutputCacheCheckDependencyEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TOutputCacheCheckDependencyEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
CacheTime | integer | the timestamp of the cached result.
IsValid | boolean | whether the dependency remains valid.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPage

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl »
TPage
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
R | CachingStack | TStack | stack of TOutputCache objects.
 | CallbackClient | TCallbackClientScript | Gets the callback client script handler that allows javascript functions to be executed during the callback response.
 | CallbackEventParameter | string | Callback parameter is decoded assuming JSON encoding.
 | CallbackEventTarget | TControl | the control responsible for the current callback event, null if nonexistent.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientScript | TClientScriptManager | client script manager.
 | ClientState | string | Returns the state to be stored on the client side.
 | ClientSupportsJavaScript | boolean | whether client supports javascript.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableStateCompression | boolean | whether page state should be compressed.
 | EnableStateEncryption | boolean | whether page state should be encrypted.
 | EnableStateValidation | boolean | whether page state should be HMAC validated.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | Form | TForm | the form on the page.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | Head | THead | page head, null if not available.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsCallback | boolean | whether this is a callback request.
R | IsLoadingPostData | boolean | true if loading post data.
R | IsPostBack | boolean | whether the current page request is a postback.
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
R | IsValid | boolean | Returns whether user input is valid or not.
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
 | PagePath | string | the requested page path for this page.
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PostBackEventParameter | string | postback event parameter.
 | PostBackEventTarget | TControl | the control responsible for the current postback event, null if nonexistent.
R | PostDataLoaders | array | Get a list of IDs of controls that are enabled and require post data.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | RequestClientState | string | the state postback from client side.
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
R | StatePersister | IPageStatePersister | page state persister.
 | StatePersisterClass | string | class name of the page state persister.
 | StyleSheetTheme | TTheme | the stylesheet theme used for the page.
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
 | Theme | TTheme | the theme used for the page.
 | Title | string | page title.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | Validators | TList | Returns a list of registered validators.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnInitComplete | Raises OnInitComplete event.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnLoadComplete | Raises OnLoadComplete event.
OnPreInit | Raises OnPreInit event.
OnPreLoad | Raises OnPreLoad event.
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnPreRenderComplete | Raises OnPreRenderComplete event.
OnSaveStateComplete | Raises OnSaveStateComplete event.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyControlSkin | Applies a skin in the current theme to a control.
 | applyControlStyleSheet | Applies a stylesheet skin in the current theme to a control.
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | beginFormRender | .
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | endFormRender | .
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | ensureRenderInForm | Ensures the control is rendered within a form.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | isSystemPostField | whether the specified field is a system field in postback data.
P | loadPageState | Loads page state from persistent storage.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
P | processCallbackRequest | Sets Adapter to TActivePageAdapter and calls apter to process the callback request.
P | processNormalRequest | .
P | processPostBackRequest | .
P | processPostData | Processes post data.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerCachingAction | Registers an action associated with the content being cached.
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | registerPostDataLoader | Register post data loaders for Callback to collect post data.
 | registerRequiresPostData | Registers a control for loading post data in the next postback.
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | run | Runs through the page lifecycles.
P | savePageState | Saves page state from persistent storage.
 | saveState | This method is invoked when control state is to be saved.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setFocus | Sets input focus on a control after the page is rendered to users.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
 | validate | Performs input validation.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPageConfiguration

Namespace: System.Web.Services
Inheritance: TComponent »
TPageConfiguration
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ApplicationConfigurations | array | list of application configurations specified along page path.
R | ExternalConfigurations | array | list of external configuration files.
R | Properties | array | Returns list of page initial property values.
R | Rules | TAuthorizationRuleCollection | Returns list of authorization rules.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
loadApplicationConfigurationFromXml | Loads the configuration specific for application part .
loadFromFile | Loads a specific config file.
loadFromFiles | Loads configuration for a page specified in a path format.
loadFromXml | Loads a page configuration.
loadPageConfigurationFromXml | Loads the configuration specific for page service.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPageService

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent » TService »
TPageService
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | BasePageClass | string | base page class name in namespace format.
 | BasePath | string | the root directory for storing pages.
 | ClientScriptManagerClass | string | clientscript manager class in namespace format.
 | DefaultPage | string | default page path to be served if no explicit page is request.
R | DefaultPageUrl | string | the URL for the default page.
 | Enabled | boolean | whether the service is enabled. (inherited from TService)
 | ID | string | id of this service. (inherited from TService)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | RequestedPage | TPage | the requested page.
R | RequestedPagePath | string | the requested page path.
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | TemplateManager | TTemplateManager | template manager.
 | ThemeManager | TThemeManager | theme manager.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | applyConfiguration | Applies a page configuration.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | constructUrl | Constructs a URL with specified page path and GET parameters.
P | createPage | Creates a page instance based on requested page path.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineRequestedPagePath | Determines the requested page path.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the service.
P | initPageContext | Initializes page context.
P | loadPageConfig | Collects configuration for a page.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | run | Runs the service.
P | runPage | Executes a page.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPageStateFormatter

Namespace: System.Web.UI
TPageStateFormatter
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | serialize | serialized data.
S | unserialize | unserialized state data, null if data is corrupted.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPageStatePersister

Namespace: System.Web.UI
Inheritance: TComponent »
TPageStatePersister
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Page | TPage | the page that this persister works for.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
load | Loads page state from hidden fields.
raiseEvent | Raises an event. (inherited from TComponent)
save | Saves state in hidden fields.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagedDataSource

Namespace: System.Collections
Inheritance: TComponent »
TPagedDataSource
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AllowCustomPaging | boolean | whether to allow custom paging.
 | AllowPaging | boolean | whether to allow paging.
R | Count | integer | number of items in current page.
 | CurrentPageIndex | integer | current page index.
 | DataSource | mixed | original data source.
R | DataSourceCount | integer | number of items in data source, if available.
R | FirstIndexInPage | integer | the index of the item in data source, where the item is the first in current page.
R | IsFirstPage | boolean | whether the current page is the first page Defaults to false.
R | IsLastPage | boolean | whether the current page is the last page.
R | Iterator | Iterator | iterator.
R | PageCount | integer | number of pages.
 | PageSize | integer | number of items in each page.
 | VirtualItemCount | integer | user-assigned number of items in data source Defaults to 0.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
count | Returns the number of items in the current page.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagedList

Namespace: System.Collections
Inheritance: TComponent » TList »
TPagedList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in current page.
 | CurrentPageIndex | integer | current page index.
 | CustomPaging | boolean | whether to use custom paging.
R | IsFirstPage | boolean | whether the current page is the first page.
R | IsLastPage | boolean | whether the current page is the last page.
R | Iterator | Iterator | iterator.
R | PageCount | integer | number of pages, -1 if under custom paging mode and VirtualCount is not set.
 | PageSize | integer | number of items in each page.
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
 | VirtualCount | integer | user-assigned number of items in data source.
Events
Name | Description
OnFetchData | Raises OnFetchData event.
OnPageIndexChanged | Raises OnPageIndexChanged event.
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
gotoPage | Changes to a page with the specified page index.
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found.
insertAt | Inserts an item at the specified position. (inherited from TList)
itemAt | Returns the item at the specified offset.
mergeWith | Merges iterable data into the map. (inherited from TList)
nextPage | Switches to the next page.
offsetExists | Returns whether there is an item at the specified offset.
offsetGet | Returns the item at the specified offset.
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
previousPage | Switches to the previous page.
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array.
Derived classes
  • TSqlMapPagedList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagedListFetchDataEventParameter

Namespace: System.Collections
Inheritance: TComponent » TEventParameter »
TPagedListFetchDataEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Data | mixed | new page data.
R | Limit | integer | number of items in the new page.
R | NewPageIndex | integer | the zero-based index of the new page.
R | Offset | integer | offset of the first item in the new page.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagedListIterator

Namespace: System.Collections
TPagedListIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array item.
key | Returns the key of the current array item.
next | Moves the internal pointer to the next array item.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an item at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagedListPageChangedEventParameter

Namespace: System.Collections
Inheritance: TComponent » TEventParameter »
TPagedListPageChangedEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | OldPageIndex | integer | the index of the page before the list changed to the new page.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagedMapIterator

Namespace: System.Collections
TPagedMapIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array item.
key | Returns the key of the current array item.
next | Moves the internal pointer to the next array item.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an item at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPager

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TPager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | ButtonType | TPagerButtonType | the type of command button for paging.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToPaginate | string | the ID path of the control whose content would be paginated.
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | FirstPageImageUrl | string | the image URL for the first page button.
 | FirstPageText | string | text for the first page button.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsFirstPage | boolean | whether the current page is the first page Defaults to false.
R | IsLastPage | boolean | whether the current page is the last page.
 | LastPageImageUrl | string | the image URL for the last page button.
 | LastPageText | string | text for the last page button.
 | Mode | TPagerMode | pager mode.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | NextPageImageUrl | string | the image URL for the next page button.
 | NextPageText | string | text for the next page button.
 | NumericPageImageUrl | string | the image URL for the numeric page buttons.
 | Page | TPage | the page that contains this control. (inherited from TControl)
 | PageButtonCount | integer | maximum number of pager buttons to be displayed.
 | PageCount | integer | number of pages of data items available.
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PrevPageImageUrl | string | the image URL for the previous page button.
 | PrevPageText | string | text for the previous page button.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPageIndexChanged | This event is raised when page index is changed due to a page button click.
OnPreRender | Performs databinding to populate data items from data source.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Processes a bubbled event.
P | buildListPager | Builds a dropdown list pager.
P | buildNextPrevPager | Builds a next-prev pager.
P | buildNumericPager | Builds a numeric pager.
P | buildPager | Builds the pager content based on the pager mode.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createPagerButton | Creates a pager button.
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPageImageUrl | .
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | listIndexChanged | Event handler to the OnSelectedIndexChanged event of the dropdown list.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Restores the pager state.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActivePager
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagerButtonType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TPagerButtonType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagerMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TPagerMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPagerPageChangedEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TPagerPageChangedEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandSource | TControl | the control originally raises the OnCommand event.
R | NewPageIndex | integer | new page index.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPanel

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TPanel
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the panel component.
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultButton | string | the ID path to the default button.
 | Direction | string | alignment of the content in the panel.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GroupingText | string | the legend text when the panel is used as a fieldset.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the panel, defaults to 'NotSet'.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScrollBars | string | the visibility and position of scroll bars in a panel control, defaults to None.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the panel.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the content wraps within the panel.
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) .
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control .
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActivePanel
  • TDataGridPager
  • TDraggable
  • TDropContainer
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPanelStyle

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TStyle »
TPanelStyle
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | BackColor | string | the background color of the control. (inherited from TStyle)
 | BackImageUrl | string | the URL of the background image for the panel component.
 | BorderColor | string | the border color of the control. (inherited from TStyle)
 | BorderStyle | string | the border style of the control. (inherited from TStyle)
 | BorderWidth | string | the border width of the control. (inherited from TStyle)
 | CssClass | string | the CSS class of the control. (inherited from TStyle)
 | CustomStyle | string | the custom style of the control. (inherited from TStyle)
 | Direction | TContentDirection | alignment of the content in the panel.
 | DisplayStyle | TDisplayStyle | display style. (inherited from TStyle)
R | Font | TFont | the font of the control. (inherited from TStyle)
 | ForeColor | string | the foreground color of the control. (inherited from TStyle)
 | Height | string | the height of the control. (inherited from TStyle)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the contents within the panel, defaults to THorizontalAlign::NotSet.
 | ScrollBars | TScrollBars | the visibility and position of scroll bars in a panel control, defaults to TScrollBars::None.
R | StyleFields | array | list of style fields. (inherited from TStyle)
 | Width | string | the width of the control. (inherited from TStyle)
 | Wrap | boolean | whether the content wraps within the panel.
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clearStyleField | Clears a single style field value; . (inherited from TStyle)
copyFrom | Copies the fields in a new style to this style.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getStyleField | a single style field value set via setStyleField. (inherited from TStyle)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasCssClass | true if CSS is set or empty. (inherited from TStyle)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasFont | true if font is set. (inherited from TStyle)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
hasStyleField | whether a style field has been defined by setStyleField. (inherited from TStyle)
mergeWith | Merges the style with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Sets the style attributes to default values.
setStyleField | Sets a single style field value. (inherited from TStyle)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TDataGridPagerStyle
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TParameterMap

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TParameterMap
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Extends | string | name of another upon which to base this TParameterMap.
 | ID | string | a unique identifier for the .
R | Properties | TParameterProperty[] | .
R | PropertyNames | array | list of property names.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | addProperty | .
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createTypeHandler | Create type handler from setType() or setTypeHandler.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getObjectValue | property value.
 | getProperty | parameter property.
 | getPropertyValue | Get the value of a property from the the parameter object.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | insertProperty | .
P | nullifyDefaultValue | When the actual value matches the setNullValue(), set the current value to null.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TParameterModule

Namespace: System.Util
Inheritance: TComponent » TApplicationComponent » TModule »
TParameterModule
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
 | ParameterFile | string | the parameter file path.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the module by loading parameters.
P | loadParameters | Loads parameters into application.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TParameterProperty

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TParameterProperty
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Column | string | name of a parameter to be used in the SQL statement.
DbType | string | the database column type of the parameter to be set by this property.
NullValue | mixed | null value replacement.
Property | string | name of a property of the parameter object.
Type | string | type of the parameter's property.
TypeHandler | string | class name of a custom type handler.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPgsqlCommandBuilder

Namespace: System.Data.Common
Inheritance: TComponent » TDbCommandBuilder »
TPgsqlCommandBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | database connection. (inherited from TDbCommandBuilder)
R | LastInsertID | mixed | Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial. (inherited from TDbCommandBuilder)
R | SelectFieldList | array | Different behavior depends on type of passed data string usage without modification null will be expanded to full list of quoted table column names (quoting depends on database) array - Column names will be quoted if used as key or value of array array('col1', 'col2', 'col2') // SELECT `col1`, `col2`, `col3` FROM. (inherited from TDbCommandBuilder)
 | TableInfo | {unknown} | . (inherited from TDbCommandBuilder)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyCriterias | . (inherited from TDbCommandBuilder)
 | applyLimitOffset | Alters the sql to apply $limit and $offset. (inherited from TDbCommandBuilder)
 | applyOrdering | modified SQL applied with ORDER BY. (inherited from TDbCommandBuilder)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | bindArrayValues | . (inherited from TDbCommandBuilder)
 | bindColumnValues | Bind the name-value pairs of $values where the array keys correspond to column names. (inherited from TDbCommandBuilder)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommand | corresponding database command. (inherited from TDbCommandBuilder)
 | createCountCommand | Creates a count(*) command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createDeleteCommand | Creates a delete command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createFindCommand | Appends the $where condition to the string "SELECT * FROM tableName WHERE ". (inherited from TDbCommandBuilder)
 | createInsertCommand | Creates an insert command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createUpdateCommand | Creates an update command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getColumnBindings | Create a name-value or position-value if $position=true binding strings. (inherited from TDbCommandBuilder)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertFieldBindings | Returns a list of insert field name and a list of binding names. (inherited from TDbCommandBuilder)
S | getPdoType | PDO parameter types. (inherited from TDbCommandBuilder)
P | getSearchCondition | Overrides parent implementation to use PostgreSQL's ILIKE instead of LIKE (case-sensitive).
 | getSearchExpression | Overrides parent implementation.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
P | hasIntegerKey | true if any array key is an integer. (inherited from TDbCommandBuilder)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isSearchableColumn | true if column can be used for LIKE searching.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPgsqlMetaData

Namespace: System.Data.Common.Pgsql
Inheritance: TComponent » TDbMetaData »
TPgsqlMetaData
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection. (inherited from TDbMetaData)
 | DefaultSchema | string | default schema.
R | TableInfo | TDbTableInfo | Obtains table meta data information for the current connection and given table name. (inherited from TDbMetaData)
RP | TableInfoClass | string | TDbTableInfo class name.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | assertIdentifier | a valid identifier.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | Creates a command builder for a given table name. (inherited from TDbMetaData)
P | createNewTableInfo | .
P | createTableInfo | Get the column definitions for given table.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getConstraintKeys | Gets the primary and foreign key column details for the given table.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getForeignKeys | Gets foreign relationship constraint keys and table name .
S | getInstance | Obtain database specific TDbMetaData class using the driver name of the database connection. (inherited from TDbMetaData)
P | getIsView | true if the table is a view.
P | getPrimaryKeys | Gets the primary key field names .
P | getSchemaTableName | tuple as ($schemaName,$tableName).
P | getSequenceName | serial name if found, null otherwise.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isForeignKeyColumn | true if column is a foreign key.
P | isPrecisionType | true if column type if "numeric", "interval" or begins with "time".
P | processColumn | .
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPgsqlScaffoldInput

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
Inheritance: TScaffoldInputBase » TScaffoldInputCommon »
TPgsqlScaffoldInput
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createBooleanControl | . (inherited from TScaffoldInputCommon)
P | createControl | .
P | createControlLabel | . (inherited from TScaffoldInputBase)
P | createDateControl | . (inherited from TScaffoldInputCommon)
P | createDateTimeControl | . (inherited from TScaffoldInputCommon)
P | createDefaultControl | . (inherited from TScaffoldInputCommon)
P | createEnumControl | . (inherited from TScaffoldInputCommon)
P | createFloatControl | . (inherited from TScaffoldInputCommon)
S | createInputBuilder | . (inherited from TScaffoldInputBase)
P | createIntegerControl | . (inherited from TScaffoldInputCommon)
P | createMultiLineControl | . (inherited from TScaffoldInputCommon)
P | createRangeValidator | . (inherited from TScaffoldInputCommon)
P | createRequiredValidator | . (inherited from TScaffoldInputCommon)
 | createScaffoldInput | . (inherited from TScaffoldInputBase)
P | createSetControl | . (inherited from TScaffoldInputCommon)
P | createTimeControl | . (inherited from TScaffoldInputCommon)
P | createTypeValidator | . (inherited from TScaffoldInputCommon)
P | createYearControl | . (inherited from TScaffoldInputCommon)
P | getControlValue | .
P | getDateTimeValue | . (inherited from TScaffoldInputCommon)
P | getDefaultControlValue | . (inherited from TScaffoldInputCommon)
P | getEnumValue | . (inherited from TScaffoldInputCommon)
P | getIsEnabled | . (inherited from TScaffoldInputBase)
P | getMatchingIndices | . (inherited from TScaffoldInputCommon)
P | getParent | . (inherited from TScaffoldInputBase)
P | getRecordPropertyValue | . (inherited from TScaffoldInputBase)
P | getSetValue | . (inherited from TScaffoldInputCommon)
P | getTimeValue | . (inherited from TScaffoldInputCommon)
 | loadScaffoldInput | . (inherited from TScaffoldInputBase)
P | setDefaultProperty | . (inherited from TScaffoldInputCommon)
P | setNotNullProperty | . (inherited from TScaffoldInputCommon)
P | setRecordPropertyValue | . (inherited from TScaffoldInputBase)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPgsqlTableColumn

Namespace: System.Data.Common.Pgsql
Inheritance: TComponent » TDbTableColumn »
TPgsqlTableColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowNull | boolean | specifies whether value Null is allowed, default is false. (inherited from TDbTableColumn)
R | ColumnId | string | name of the column with quoted identifier. (inherited from TDbTableColumn)
R | ColumnIndex | integer | zero-based ordinal position of the column in the table. (inherited from TDbTableColumn)
R | ColumnName | string | name of the column in the table (identifier quoted). (inherited from TDbTableColumn)
R | ColumnSize | string | size of the column. (inherited from TDbTableColumn)
R | DbType | string | column type. (inherited from TDbTableColumn)
R | DefaultValue | mixed | default column value if column value was null. (inherited from TDbTableColumn)
R | IsExcluded | boolean | whether this column is excluded from insert and update. (inherited from TDbTableColumn)
R | IsForeignKey | boolean | whether this column is a foreign key, default is false. (inherited from TDbTableColumn)
R | IsPrimaryKey | boolean | whether this column is a primary key for the table, default is false. (inherited from TDbTableColumn)
R | MaxiumNumericConstraint | {unknown} | . (inherited from TDbTableColumn)
R | NumericPrecision | string | precision of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | NumericScale | string | scale of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | PHPType | boolean | Overrides parent implementation, returns PHP type from the db type.
R | PdoType | {unknown} | . (inherited from TDbTableColumn)
R | SequenceName | {unknown} | . (inherited from TDbTableColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableColumn)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasSequence | whether the column is a sequence. (inherited from TDbTableColumn)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPgsqlTableInfo

Namespace: System.Data.Common.Pgsql
Inheritance: TComponent » TDbTableInfo »
TPgsqlTableInfo
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ColumnNames | array | table column names (identifier quoted). (inherited from TDbTableInfo)
R | Columns | TMap | TDbTableColumn column meta data. (inherited from TDbTableInfo)
R | ForeignKeys | array | tuples of foreign table and column name. (inherited from TDbTableInfo)
R | IsView | boolean | whether the table is a view, default is false. (inherited from TDbTableInfo)
R | LowerCaseColumnNames | array | lowercased column key names mapped to normal column ids. (inherited from TDbTableInfo)
R | PrimaryKeys | string[] | . (inherited from TDbTableInfo)
R | SchemaName | string | name of the schema this column belongs to.
R | TableFullName | string | full name of the table, database dependent.
R | TableName | string | name of the table this column belongs to. (inherited from TDbTableInfo)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | new command builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getColumn | column information. (inherited from TDbTableInfo)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableInfo)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableInfo)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPhpErrorException

Namespace: System.Exceptions
Inheritance: TException » TSystemException »
TPhpErrorException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPlaceHolder

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TPlaceHolder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPolygonHotSpot

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » THotSpot »
TPolygonHotSpot
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key that allows you to quickly navigate to the HotSpot region. (inherited from THotSpot)
 | AlternateText | string | the alternate text to display for a HotSpot object. (inherited from THotSpot)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from THotSpot)
 | CausesValidation | boolean | whether postback event trigger by this hotspot will cause input validation, default is true. (inherited from THotSpot)
 | Coordinates | string | coordinates of the vertices defining the polygon.
R | HasAttributes | boolean | whether the hotspot has custom attributes. (inherited from THotSpot)
 | HotSpotMode | THotSpotMode | the behavior of a HotSpot object when it is clicked. (inherited from THotSpot)
 | NavigateUrl | string | the URL to navigate to when a HotSpot object is clicked. (inherited from THotSpot)
 | PostBackValue | string | a value that is post back when the HotSpot is clicked. (inherited from THotSpot)
R | Shape | string | shape of this hotspot.
 | TabIndex | integer | the tab index of the HotSpot region. (inherited from THotSpot)
 | Target | string | the target window or frame to display the new page when the HotSpot region is clicked. (inherited from THotSpot)
 | ValidationGroup | string | the group of validators which the hotspot causes validation upon postback. (inherited from THotSpot)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from THotSpot)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from THotSpot)
 | hasAttribute | whether the named attribute exists. (inherited from THotSpot)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | removeAttribute | Removes the named attribute. (inherited from THotSpot)
 | render | Renders this hotspot. (inherited from THotSpot)
 | setAttribute | Sets a custom hotspot attribute. (inherited from THotSpot)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from THotSpot)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPostSelectBinding

Namespace: System.Data.SqlMap.Statements
TPostSelectBinding
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
getKeys | .
getMethod | .
getResultObject | .
getResultProperty | .
getStatement | .
setKeys | .
setMethod | .
setResultObject | .
setResultProperty | .
setStatement | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPreparedCommand

Namespace: System.Data.SqlMap.Statements
TPreparedCommand
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | applyParameterMap | .
 | create | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPreparedStatement

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent »
TPreparedStatement
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
ParameterNames | {unknown} | .
ParameterValues | {unknown} | .
PreparedSql | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPreparedStatementFactory

Namespace: System.Data.SqlMap.Statements
TPreparedStatementFactory
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createParametersForTextCommand | .
 | prepare | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPropertyAccess

Namespace: System.Data.SqlMap
TPropertyAccess
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | get | Gets the property value.
S | has | true if property path is valid.
S | set | Sets the property value.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TPropertyValue

Namespace: System
TPropertyValue
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | ensureArray | Converts a value to array type.
S | ensureBoolean | Converts a value to boolean type.
S | ensureEnum | Converts a value to enum type.
S | ensureFloat | Converts a value to float type.
S | ensureInteger | Converts a value to integer type.
S | ensureObject | Converts a value to object type.
S | ensureString | Converts a value to string type.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TQueue

Namespace: System.Collections
Inheritance: TComponent »
TQueue
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the queue.
R | Iterator | Iterator | Returns an iterator for traversing the items in the queue.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the queue.
contains | whether the queue contains the item.
copyFrom | Copies iterable data into the queue.
count | Returns the number of items in the queue.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
dequeue | Removes and returns the object at the beginning of the queue.
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
enqueue | Adds an object to the end of the queue.
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
peek | Returns the item at the top of the queue.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in queue.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TQueueIterator

Namespace: System.Collections
TQueueIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array item.
key | Returns the key of the current array item.
next | Moves the internal pointer to the next array item.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an item at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRadioButton

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TCheckBox »
TRadioButton
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | whether clicking on the checkbox will post the page. (inherited from TCheckBox)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event triggered by this checkbox will cause input validation, default is true. (inherited from TCheckBox)
 | Checked | boolean | whether the checkbox is checked. (inherited from TCheckBox)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | boolean | Returns the value indicating whether the checkbox is checked. (inherited from TCheckBox)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBox)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GroupName | string | the name of the group that the radio button belongs to.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | InputAttributes | TMap | list of attributes to be rendered for the checkbox. (inherited from TCheckBox)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBox)
R | LabelAttributes | TMap | list of attributes to be rendered for label beside the checkbox. (inherited from TCheckBox)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox. (inherited from TCheckBox)
R | RadioButtonsInGroup | array | Gets an array of radiobuttons whose group name is the same as this radiobutton's.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | bool | Check if we need a span tag to surround this control. (inherited from TCheckBox)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
R | SurroundingTagID | string | the id of the surrounding tag or this clientID if no such tag needed. (inherited from TCheckBox)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the button. (inherited from TCheckBox)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text caption of the checkbox. (inherited from TCheckBox)
 | TextAlign | TTextAlign | the alignment (Left or Right) of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBox)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
 | UniqueGroupName | string | the name used to fetch radiobutton post data.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the checkbox causes validation upon postback. (inherited from TCheckBox)
R | ValidationPropertyValue | mixed | Returns the value of the property that needs validation. (inherited from TCheckBox)
 | Value | string | the value of the checkbox. (inherited from TCheckBox)
RP | ValueAttribute | string | the value attribute to be rendered.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnCheckedChanged | Raises OnCheckedChanged event when Checked changes value during postback. (inherited from TCheckBox)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the radio button groupings.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the checkbox to receive postback data during postback. (inherited from TCheckBox)
OnUnLoad | Unregisters the radio button groupings.
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add the group name as post data loader if group name is set.
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBox)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox control. (inherited from TCheckBox)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the client-script code.
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderInputTag | Renders a radiobutton input element.
P | renderLabel | Renders a label beside the checkbox. (inherited from TCheckBox)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveRadioButton
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRadioButtonList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TCheckBoxList »
TRadioButtonList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
 | CellPadding | integer | the cellpadding for the table keeping the checkbox list. (inherited from TCheckBoxList)
 | CellSpacing | integer | the cellspacing for the table keeping the checkbox list. (inherited from TCheckBoxList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBoxList)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item. (inherited from TCheckBoxList)
R | HasHeader | boolean | Returns a value indicating whether this control contains header item. (inherited from TCheckBoxList)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items. (inherited from TCheckBoxList)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control supports multiple selection.
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBoxList)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | Gets the post back options for this checkbox. (inherited from TCheckBoxList)
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
 | RepeatColumns | integer | the number of columns that the list should be displayed with. (inherited from TCheckBoxList)
 | RepeatDirection | string | the direction of traversing the list, defaults to 'Vertical'. (inherited from TCheckBoxList)
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers). (inherited from TCheckBoxList)
 | RepeatLayout | string | how the list should be displayed, using table or using line breaks. (inherited from TCheckBoxList)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | boolean | Wether the list should be rendered inside a span or not . (inherited from TCheckBoxList)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | TextAlign | TTextAlign | the alignment of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBoxList)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TCheckBoxList)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers for post data on postback. (inherited from TCheckBoxList)
OnSelectedIndexChanged | Raises OnSelectedIndexChanged event when selection is changed. (inherited from TListControl)
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TListControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createRepeatedControl | Creates a control used for repetition (used as a template).
P | createStyle | Creates a style object for the control. (inherited from TCheckBoxList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID. (inherited from TCheckBoxList)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | generateItemStyle | Returns a style used for rendering items. (inherited from TCheckBoxList)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBoxList)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the checkbox list control. (inherited from TCheckBoxList)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list. (inherited from TCheckBoxList)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TActiveRadioButtonList
  • TRatingList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRangeValidationDataType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable » TValidationDataType »
TRangeValidationDataType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRangeValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TRangeValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Charset | string | charset for string length comparison.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | DataType | TRangeValidationDataType | the data type that the values being compared are converted to before the comparison is made.
 | DateFormat | string | the date validation date format if any.
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
 | MaxValue | string | the maximum value of the validation range.
 | MinValue | string | the minimum value of the validation range.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StrictComparison | boolean | true to perform strict comparison.
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
P | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
P | isGreaterThan | .
P | isLessThan | .
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | isValidDate | Determine if the date is within the specified range.
P | isValidFloat | Determine if the value is within the specified float range.
P | isValidInteger | Determine if the value is within the integer range.
P | isValidString | Compare the string with a minimum and a maxiumum value.
P | isValidStringLength | true if min and max string length are satisfied.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRatingList

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl » TListControl » TCheckBoxList » TRadioButtonList »
TRatingList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowInput | boolean | Wrapper for ReadOnly property.
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AppendDataBoundItems | boolean | whether performing databind should append items or clear the existing ones. (inherited from TListControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
RP | AssetUrl | string | asset file url.
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user makes change to the list control and then tabs out of it. (inherited from TListControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Caption | string | caption text.
RP | CaptionControl | {unknown} | .
RP | CaptionControlID | string | find the client ID of the caption control.
 | CaptionID | string | control or html element ID for displaying a caption.
 | CausesValidation | boolean | whether postback event trigger by this list control will cause input validation, default is true. (inherited from TListControl)
 | CellPadding | integer | the cellpadding for the table keeping the checkbox list. (inherited from TCheckBoxList)
 | CellSpacing | integer | the cellspacing for the table keeping the checkbox list. (inherited from TCheckBoxList)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the selected item with the lowest cardinal index. (inherited from TListControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change. (inherited from TCheckBoxList)
 | DataGroupField | string | the field of the data source that provides the label of the list item groups. (inherited from TListControl)
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | DataTextField | string | the field of the data source that provides the text content of the list items. (inherited from TListControl)
 | DataTextFormatString | string | the formatting string used to control how data bound to the list control is displayed. (inherited from TListControl)
 | DataValueField | string | the field of the data source that provides the value of each list item. (inherited from TListControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript. (inherited from TListControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | HalfRatingInterval | array | rating display half value interval, default is array(0.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasFooter | boolean | Returns a value indicating whether this control contains footer item. (inherited from TCheckBoxList)
R | HasHeader | boolean | Returns a value indicating whether this control contains header item. (inherited from TCheckBoxList)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasItems | boolean | whether the list control contains any items. (inherited from TListControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasSeparators | boolean | Returns a value indicating whether this control contains separator items. (inherited from TCheckBoxList)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
RP | IsMultiSelect | boolean | whether this control supports multiple selection. (inherited from TRadioButtonList)
 | IsValid | bool | Returns true if this control validated successfully. (inherited from TCheckBoxList)
R | ItemCount | integer | the number of items in the list control. (inherited from TListControl)
R | Items | TListItemCollection | the item collection. (inherited from TListControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
RP | PostBackOptions | array | list of post back options.
 | PromptText | string | the prompt text which is to be displayed as the first list item. (inherited from TListControl)
 | PromptValue | string | the prompt selection value. (inherited from TListControl)
 | Rating | float | rating value.
 | RatingStyle | TRatingListStyle | current rating style.
RP | RatingStyleCssClass | string | rating style css class name.
 | ReadOnly | boolean | whether the items in the column can be edited.
 | RepeatColumns | integer | the number of columns that the list should be displayed with. (inherited from TCheckBoxList)
 | RepeatDirection | string | the direction of traversing the list, defaults to 'Vertical'. (inherited from TCheckBoxList)
RP | RepeatInfo | TRepeatInfo | repeat information (primarily used by control developers). (inherited from TCheckBoxList)
 | RepeatLayout | string | how the list should be displayed, using table or using line breaks. (inherited from TCheckBoxList)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SelectedIndex | integer | the index (zero-based) of the item being selected, -1 if no item is selected. (inherited from TListControl)
 | SelectedIndices | array | list of index of items that are selected. (inherited from TListControl)
R | SelectedItem | TListItem|null | the selected item with the lowest cardinal index, null if no item is selected. (inherited from TListControl)
 | SelectedValue | string | the value of the selected item with the lowest cardinal index, empty if no selection. (inherited from TListControl)
 | SelectedValues | array | list of the selected item values (strings). (inherited from TListControl)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | SpanNeeded | boolean | Wether the list should be rendered inside a span or not . (inherited from TCheckBoxList)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the list control. (inherited from TListControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | selected value. (inherited from TListControl)
 | TextAlign | TTextAlign | the alignment of the text caption, defaults to TTextAlign::Right. (inherited from TCheckBoxList)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | ValidationGroup | string | the group of validators which the list control causes validation upon postback. (inherited from TListControl)
R | ValidationPropertyValue | mixed | Returns the value to be validated. (inherited from TCheckBoxList)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the the rating style css file and rating image files.
OnSelectedIndexChanged | .
OnTextChanged | Raises OnTextChanged event when selection is changed. (inherited from TListControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TListControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TListControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearSelection | Clears all existing selections. (inherited from TListControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createListItemCollection | Creates a collection object to hold list items. (inherited from TListControl)
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createRepeatedControl | Creates a control used for repetition (used as a template). (inherited from TRadioButtonList)
P | createStyle | Creates a style object for the control. (inherited from TCheckBoxList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID. (inherited from TCheckBoxList)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
P | formatDataValue | Formats the text value according to a format string. (inherited from TListControl)
 | generateItemStyle | Returns a style used for rendering items. (inherited from TCheckBoxList)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRatingIndex | rating as integer.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data. (inherited from TRadioButtonList)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads items from viewstate. (inherited from TListControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate list items from data source. (inherited from TListControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | publishImages | URL of publish the rating images.
P | publishStyle | URL of the css style file.
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event. (inherited from TCheckBoxList)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Add rating style class name to the class attribute when ReadOnly property is true and when the CssClass property is empty.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for list control. (inherited from TListControl)
 | renderContents | Renders body content of the list control. (inherited from TListControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderItem | Renders an item in the list. (inherited from TCheckBoxList)
P | renderPrompt | Renders the prompt text, if any. (inherited from TListControl)
 | saveState | Saves items into viewstate. (inherited from TListControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
  • TActiveRatingList
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TReadOnlyDataSource

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TDataSourceControl »
TReadOnlyDataSource
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | {unknown} | . (inherited from TDataSourceControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | {unknown} | . (inherited from TDataSourceControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ViewNames | {unknown} | . (inherited from TDataSourceControl)
 | Visible | {unknown} | . (inherited from TDataSourceControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataSourceChanged | . (inherited from TDataSourceControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | . (inherited from TDataSourceControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getView | .
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TReadOnlyDataSourceView

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TDataSourceView »
TReadOnlyDataSourceView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CanDelete | {unknown} | . (inherited from TDataSourceView)
R | CanGetRowCount | {unknown} | . (inherited from TDataSourceView)
R | CanInsert | {unknown} | . (inherited from TDataSourceView)
R | CanPage | {unknown} | . (inherited from TDataSourceView)
R | CanSort | {unknown} | . (inherited from TDataSourceView)
R | CanUpdate | {unknown} | . (inherited from TDataSourceView)
R | DataSource | {unknown} | . (inherited from TDataSourceView)
R | Name | {unknown} | . (inherited from TDataSourceView)
Events
Name | Description
OnDataSourceViewChanged | . (inherited from TDataSourceView)
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
delete | Deletes DB row(s) with the specified keys. (inherited from TDataSourceView)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
insertAt | Inserts a DB record. (inherited from TDataSourceView)
raiseEvent | Raises an event. (inherited from TComponent)
select | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
update | Updates DB record(s) with the specified keys and new values . (inherited from TDataSourceView)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRectangleHotSpot

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » THotSpot »
TRectangleHotSpot
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key that allows you to quickly navigate to the HotSpot region. (inherited from THotSpot)
 | AlternateText | string | the alternate text to display for a HotSpot object. (inherited from THotSpot)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from THotSpot)
 | Bottom | integer | the Y coordinate of the bottom side of the rectangle HotSpot region.
 | CausesValidation | boolean | whether postback event trigger by this hotspot will cause input validation, default is true. (inherited from THotSpot)
R | Coordinates | string | coordinates defining this hotspot shape.
R | HasAttributes | boolean | whether the hotspot has custom attributes. (inherited from THotSpot)
 | HotSpotMode | THotSpotMode | the behavior of a HotSpot object when it is clicked. (inherited from THotSpot)
 | Left | integer | the X coordinate of the right side of the rectangle HotSpot region.
 | NavigateUrl | string | the URL to navigate to when a HotSpot object is clicked. (inherited from THotSpot)
 | PostBackValue | string | a value that is post back when the HotSpot is clicked. (inherited from THotSpot)
 | Right | integer | the X coordinate of the right side of the rectangle HotSpot region.
R | Shape | string | shape of this hotspot.
 | TabIndex | integer | the tab index of the HotSpot region. (inherited from THotSpot)
 | Target | string | the target window or frame to display the new page when the HotSpot region is clicked. (inherited from THotSpot)
 | Top | integer | the Y coordinate of the top side of the rectangle HotSpot region.
 | ValidationGroup | string | the group of validators which the hotspot causes validation upon postback. (inherited from THotSpot)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from THotSpot)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from THotSpot)
 | hasAttribute | whether the named attribute exists. (inherited from THotSpot)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | removeAttribute | Removes the named attribute. (inherited from THotSpot)
 | render | Renders this hotspot. (inherited from THotSpot)
 | setAttribute | Sets a custom hotspot attribute. (inherited from THotSpot)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from THotSpot)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TReflectionClass

Namespace: System
TReflectionClass
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | export | . (inherited from ReflectionClass)
 | getConstant | . (inherited from ReflectionClass)
 | getConstants | . (inherited from ReflectionClass)
 | getConstructor | . (inherited from ReflectionClass)
 | getDefaultProperties | . (inherited from ReflectionClass)
 | getDocComment | . (inherited from ReflectionClass)
 | getEndLine | . (inherited from ReflectionClass)
 | getExtension | . (inherited from ReflectionClass)
 | getExtensionName | . (inherited from ReflectionClass)
 | getFileName | . (inherited from ReflectionClass)
 | getInterfaceNames | . (inherited from ReflectionClass)
 | getInterfaces | . (inherited from ReflectionClass)
 | getMethod | . (inherited from ReflectionClass)
 | getMethods | . (inherited from ReflectionClass)
 | getModifiers | . (inherited from ReflectionClass)
 | getName | . (inherited from ReflectionClass)
 | getNamespaceName | . (inherited from ReflectionClass)
 | getParentClass | . (inherited from ReflectionClass)
 | getProperties | . (inherited from ReflectionClass)
 | getProperty | . (inherited from ReflectionClass)
 | getShortName | . (inherited from ReflectionClass)
 | getStartLine | . (inherited from ReflectionClass)
 | getStaticProperties | . (inherited from ReflectionClass)
 | getStaticPropertyValue | . (inherited from ReflectionClass)
 | hasConstant | . (inherited from ReflectionClass)
 | hasMethod | . (inherited from ReflectionClass)
 | hasProperty | . (inherited from ReflectionClass)
 | implementsInterface | . (inherited from ReflectionClass)
 | inNamespace | . (inherited from ReflectionClass)
 | isAbstract | . (inherited from ReflectionClass)
 | isFinal | . (inherited from ReflectionClass)
 | isInstance | . (inherited from ReflectionClass)
 | isInstantiable | . (inherited from ReflectionClass)
 | isInterface | . (inherited from ReflectionClass)
 | isInternal | . (inherited from ReflectionClass)
 | isIterateable | . (inherited from ReflectionClass)
 | isSubclassOf | . (inherited from ReflectionClass)
 | isUserDefined | . (inherited from ReflectionClass)
 | newInstance | . (inherited from ReflectionClass)
 | newInstanceArgs | . (inherited from ReflectionClass)
 | setStaticPropertyValue | . (inherited from ReflectionClass)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRegularExpressionValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TRegularExpressionValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ClientSidePatternModifiers | string | clientside pattern modifiers, no modifiers by default.
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PatternModifiers | string | pattern modifiers, no modifiers by default.
 | RegularExpression | string | the regular expression that determines the pattern used to validate a field.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
  • TEmailAddressValidator
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeatDirection

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TRepeatDirection
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeatInfo

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TRepeatInfo
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Caption | string | caption of the table layout.
CaptionAlign | TTableCaptionAlign | alignment of the caption of the table layout.
RepeatColumns | integer | the number of columns that the repeated items should be displayed in.
RepeatDirection | TRepeatDirection | the direction of traversing the repeated items, defaults to TRepeatDirection::Vertical.
RepeatLayout | TRepeatLayout | how the repeated items should be displayed, using table or using line breaks.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | renderFooter | Renders footer.
P | renderHeader | Renders header.
P | renderHorizontalContents | Renders contents in horizontal repeat direction.
P | renderRawContents | Renders contents in raw format.
 | renderRepeater | Renders the repeated items.
P | renderVerticalContents | Renders contents in veritcal repeat direction.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeatLayout

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TRepeatLayout
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeater

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TDataBoundControl »
TRepeater
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowCustomPaging | boolean | whether the custom paging is enabled. (inherited from TDataBoundControl)
 | AllowPaging | boolean | whether paging is enabled. (inherited from TDataBoundControl)
 | AlternatingItemRenderer | string | the class name for alternative repeater items.
 | AlternatingItemTemplate | ITemplate | the alternative template string for the item.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CurrentPageIndex | integer | the zero-based index of the current page. (inherited from TDataBoundControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DataKeyField | string | the field of the data source that provides the keys of the list items.
R | DataKeys | TList | the keys used in the data listing control.
 | DataMember | {unknown} | . (inherited from TDataBoundControl)
 | DataSource | Traversable | data source object, defaults to null. (inherited from TDataBoundControl)
 | DataSourceID | string | ID path to the data source control. (inherited from TDataBoundControl)
RP | DataSourceView | {unknown} | . (inherited from TDataBoundControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EmptyRenderer | string | the class name for empty repeater item.
 | EmptyTemplate | ITemplate | the template applied when no data is bound to the repeater.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
R | Footer | TControl | the footer item.
 | FooterRenderer | string | the class name for repeater footer item.
 | FooterTemplate | ITemplate | the footer template.
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
R | Header | TControl | the header item.
 | HeaderRenderer | string | the class name for repeater header item.
 | HeaderTemplate | ITemplate | the header template.
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
P | Initialized | boolean | whether the databound control has been initialized. (inherited from TDataBoundControl)
P | IsDataBound | boolean | whether databind has been invoked in the previous page request. (inherited from TDataBoundControl)
 | ItemRenderer | string | the class name for repeater items.
 | ItemTemplate | ITemplate | the template for repeater items.
R | Items | TRepeaterItemCollection | list of repeater item controls.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | PageCount | integer | number of pages of data items available. (inherited from TDataBoundControl)
 | PageSize | integer | the number of data items on each page. (inherited from TDataBoundControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
P | RequiresDataBinding | boolean | whether a databind call is required (by the data bound control). (inherited from TDataBoundControl)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SelectParameters | {unknown} | . (inherited from TDataBoundControl)
 | SeparatorRenderer | string | the class name for repeater item separators.
 | SeparatorTemplate | ITemplate | the separator template.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
RP | UsingDataSourceID | boolean | if the databound control uses the data source specified by setDataSourceID, or it uses the data source object specified by setDataSource. (inherited from TDataBoundControl)
 | VirtualItemCount | integer | virtual number of data items in the data source. (inherited from TDataBoundControl)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDataBound | Raises OnDataBound event. (inherited from TDataBoundControl)
OnDataSourceChanged | Sets RequiresDataBinding as true if the control is initialized. (inherited from TDataBoundControl)
OnInit | Sets page's OnPreLoad event handler as pagePreLoad. (inherited from TDataBoundControl)
OnItemCommand | Raises OnItemCommand event.
OnItemCreated | Raises OnItemCreated event.
OnItemDataBound | Raises OnItemDataBound event.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Ensures any pending databind is performed. (inherited from TDataBoundControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation to handle OnItemCommand event which is bubbled from repeater items and their child controls.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createEmptyContent | Creates empty repeater content.
P | createItem | Creates a repeater item instance based on the item type and index.
P | createPagedDataSource | creates a paged data source. (inherited from TDataBoundControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs databinding. (inherited from TDataBoundControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataSourceViewChanged | . (inherited from TDataBoundControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | determineDataSource | . (inherited from TDataBoundControl)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
P | ensureDataBound | Ensures any pending dataBind is called. (inherited from TDataBoundControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
P | getDataFieldValue | Returns the value of the data at the specified field.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | Loads item count information from viewstate.
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
 | pagePreLoad | Sets getInitialized as true. (inherited from TDataBoundControl)
P | performDataBinding | Performs databinding to populate repeater items from data source.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the repeater.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | reset | Clears up all items in the repeater.
P | restoreItemsFromViewState | Creates repeater items based on viewstate information.
 | saveState | Saves item count in viewstate.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | validateDataSource | Validates if the parameter is a valid data source. (inherited from TDataBoundControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeaterCommandEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter » TCommandEventParameter »
TRepeaterCommandEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CommandName | string | name of the command. (inherited from TCommandEventParameter)
R | CommandParameter | string | parameter of the command. (inherited from TCommandEventParameter)
R | CommandSource | TControl | the control originally raises the OnCommand event.
R | Item | TControl | the repeater item control responsible for the event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeaterItem

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TRepeaterItem
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item @since 3.
 | DataItem | mixed | This property is deprecated since v3.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | ItemIndex | integer | Returns a value indicating the zero-based index of the item in the corresponding data control's item collection.
 | ItemType | TListItemType | item type.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeaterItemCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList »
TRepeaterItemCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TList)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeaterItemEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TRepeaterItemEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Item | TControl | repeater item related with the corresponding event.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRepeaterItemRenderer

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TDataRenderer » TItemDataRenderer »
TRepeaterItemRenderer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | mixed | data associated with the item. (inherited from TDataRenderer)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
 | ItemIndex | integer | Returns a value indicating the zero-based index of the item in the corresponding data control's item collection. (inherited from TItemDataRenderer)
 | ItemType | TListItemType | item type. (inherited from TItemDataRenderer)
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method overrides parent's implementation by wrapping event parameter for OnCommand event with item information.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TRequiredFieldValidator

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TLabel » TBaseValidator »
TRequiredFieldValidator
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing validation for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Returns an array of javascript validator options.
R | ClientSide | TValidatorClientSide | Gets the TValidatorClientSide that allows modification of the client- side validator events. (inherited from TBaseValidator)
 | ControlCssClass | string | the css class that is applied to the control being validated in case the validation fails. (inherited from TBaseValidator)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
 | ControlToValidate | string | the ID path of the input control to validate. (inherited from TBaseValidator)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text value of the label. (inherited from TLabel)
 | Display | TValidatorDisplayStyle | the style of displaying the error message. (inherited from TBaseValidator)
 | EnableClientScript | boolean | whether client-side validation is enabled. (inherited from TBaseValidator)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
 | ErrorMessage | string | the text for the error message. (inherited from TBaseValidator)
 | FocusElementID | string | Gets the ID of the HTML element that will receive focus if validation fails and FocusOnError is true. (inherited from TBaseValidator)
 | FocusOnError | boolean | whether to set focus at the validating place if the validation fails. (inherited from TBaseValidator)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForControl | string | the associated control ID. (inherited from TLabel)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | InitialValue | string | the initial value of the associated input control.
 | IsValid | boolean | whether the validation succeeds. (inherited from TBaseValidator)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the label, returns 'label' if there is an associated control, 'span' otherwise. (inherited from TLabel)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text value of the label. (inherited from TLabel)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to. (inherited from TBaseValidator)
R | ValidationTarget | TControl | control to be validated. (inherited from TBaseValidator)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Registers the validator with page. (inherited from TBaseValidator)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Override parent implementation to update the control CSS Class before the validated control is rendered. (inherited from TBaseValidator)
OnUnload | Unregisters the validator from page. (inherited from TBaseValidator)
OnValidate | This event is raised right before the validator starts to perform validation. (inherited from TBaseValidator)
OnValidationError | This event is raised when the validator fails in validation. (inherited from TBaseValidator)
OnValidationSuccess | This event is raised when the validator succeeds in validation. (inherited from TBaseValidator)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer. (inherited from TBaseValidator)
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientSide | javascript validator event options. (inherited from TBaseValidator)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
P | evaluateIsValid | This method overrides the parent's implementation.
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValidationValue | Retrieves the property value of the control being validated. (inherited from TBaseValidator)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | registerClientScriptValidator | Registers the individual validator client-side javascript code. (inherited from TBaseValidator)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the label. (inherited from TLabel)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderClientControlScript | Renders the javascript code to the end script. (inherited from TBaseValidator)
 | renderContents | Renders the validator control. (inherited from TBaseValidator)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
P | updateControlCssClass | Update the ControlToValidate component's css class depending if the ControlCssClass property is set, and whether this is valid. (inherited from TBaseValidator)
 | validate | Validates the specified control. (inherited from TBaseValidator)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TResultMap

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TResultMap
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Class | string | result class name.
R | Columns | TMap | result columns.
 | Discriminator | TDiscriminator | result class discriminator.
 | Extends | string | result map extends another result map.
 | GroupBy | string | result map groups by.
 | ID | string | a unique identifier for the .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
addResultProperty | Add a TResultProperty to result mapping.
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createInstanceOfResult | Create a new instance of the class of this result map.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
resolveSubMap | Result sub-mappings using the discriminiator column.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TResultProperty

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TResultProperty
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Column | string | name of the column in the result set from which the value will be used to populate the property.
 | ColumnIndex | int | index of the column in the ResultSet from which the value will be used to populate the object property.
 | LazyLoad | boolean | indicate whether or not the select statement's results should be lazy loaded.
 | NestedResultMap | TResultMap | nested result map.
 | NullValue | mixed | null value replacement.
 | Property | string | name of a property of the result object that will be set to.
RP | PropertyValueType | int | Determines if the type is an instance of ArrayAccess, TList or an array.
 | ResultMapping | string | ID of another used to fill the property.
 | Select | string | name of another mapped statement.
 | Type | string | property type of the object property to be set.
 | TypeHandler | string | custom type handler class name (may use namespace).
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createTypeHandler | Create type handler from setType() or setTypeHandler.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getPropertyValue | Gets the value for the current property, converts to applicable type if necessary.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getTypedValue | property value casted to specific type.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | instanceOfArrayType | Returns true if the result property getType() is of ArrayAccess or that the actual result object is an array or implements ArrayAccess .
 | instanceOfListType | Returns true if the result property getType() is of TList type or that the actual result object is an instance of TList.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TResultSetListItemParameter

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent »
TResultSetListItemParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | List | {unknown} | .
R | Parameter | {unknown} | .
R | Result | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TResultSetMapItemParameter

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent »
TResultSetMapItemParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Key | {unknown} | .
R | Map | {unknown} | .
R | Parameter | {unknown} | .
R | Value | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSafeHtml

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TSafeHtml
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | parseSafeHtml | Use SafeHTML to remove malicous javascript from the HTML content.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders body content.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldBase

Namespace: System.Data.ActiveRecord.Scaffold
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl »
TScaffoldBase
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultStyle | string | default scaffold stylesheet name.
 | EnableDefaultStyle | boolean | enable default stylesheet, default is true.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RecordClass | string | Name of the Active Record class to be viewed or scaffolded.
RP | RecordFinder | TActiveRecord | Active Record finder instance.
P | RecordObject | TActiveRecord | Gets the current Active Record instance.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TableInfo | TDbMetaData | table/view information.
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the default stylesheet file.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
P | clearRecordObject | Unset the current record instance and table information.
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
P | copyFrom | Copy the view details from another scaffold view instance.
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRecordPkValues | record primary key values.
P | getRecordPropertyValues | record property values.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TScaffoldEditView
  • TScaffoldListView
  • TScaffoldSearch
  • TScaffoldView
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldEditView

Namespace: System.Data.ActiveRecord.Scaffold
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TScaffoldBase »
TScaffoldEditView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
R | CancelButton | TButton | Button to cancel the edit action (e.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClearButton | TButton | Button to clear the editor inputs.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
RP | CurrentRecord | TActiveRecord | current Active Record instance.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultStyle | string | default scaffold stylesheet name. (inherited from TScaffoldBase)
 | EditRenderer | string | the class name for scaffold editor.
 | EnableDefaultStyle | boolean | enable default stylesheet, default is true. (inherited from TScaffoldBase)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
RP | InputRepeater | TRepeater | default editor input controls repeater.
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RecordClass | string | Name of the Active Record class to be viewed or scaffolded. (inherited from TScaffoldBase)
RP | RecordFinder | TActiveRecord | Active Record finder instance. (inherited from TScaffoldBase)
P | RecordObject | TActiveRecord | Gets the current Active Record instance. (inherited from TScaffoldBase)
 | RecordPk | array | Active Record primary key value.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SaveButton | TButton | Button triggered to save the Active Record.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TableInfo | TDbMetaData | table/view information. (inherited from TScaffoldBase)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
R | ValidationGroup | string | editor validation group name.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | Initialize the editor form if it is Visible.
OnPreRender | Publish the default stylesheet file. (inherited from TScaffoldBase)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Bubble the command name event.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
P | clearRecordObject | Unset the current record instance and table information. (inherited from TScaffoldBase)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
P | copyFrom | Copy the view details from another scaffold view instance. (inherited from TScaffoldBase)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createEditRenderer | Instantiate the external edit renderer.
P | createRepeaterEditItem | Initialize the default editor using the scaffold input builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | doSave | Check the validators, then tries to save the record.
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRecordPkValues | record primary key values. (inherited from TScaffoldBase)
P | getRecordPropertyValues | record property values. (inherited from TScaffoldBase)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
P | getScaffoldInputBuilder | Create the default scaffold editor control factory.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | initializeEditForm | Initialize the editor form.
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldInputBase

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
TScaffoldInputBase
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createControl | .
P | createControlLabel | .
S | createInputBuilder | .
 | createScaffoldInput | .
P | getControlValue | .
P | getIsEnabled | .
P | getParent | .
P | getRecordPropertyValue | .
 | loadScaffoldInput | .
P | setRecordPropertyValue | .
Derived classes
  • TScaffoldInputCommon
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldInputCommon

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
Inheritance: TScaffoldInputBase »
TScaffoldInputCommon
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createBooleanControl | .
P | createControl | . (inherited from TScaffoldInputBase)
P | createControlLabel | . (inherited from TScaffoldInputBase)
P | createDateControl | .
P | createDateTimeControl | .
P | createDefaultControl | .
P | createEnumControl | .
P | createFloatControl | .
S | createInputBuilder | . (inherited from TScaffoldInputBase)
P | createIntegerControl | .
P | createMultiLineControl | .
P | createRangeValidator | .
P | createRequiredValidator | .
 | createScaffoldInput | . (inherited from TScaffoldInputBase)
P | createSetControl | .
P | createTimeControl | .
P | createTypeValidator | .
P | createYearControl | .
P | getControlValue | . (inherited from TScaffoldInputBase)
P | getDateTimeValue | .
P | getDefaultControlValue | .
P | getEnumValue | .
P | getIsEnabled | . (inherited from TScaffoldInputBase)
P | getMatchingIndices | .
P | getParent | . (inherited from TScaffoldInputBase)
P | getRecordPropertyValue | . (inherited from TScaffoldInputBase)
P | getSetValue | .
P | getTimeValue | .
 | loadScaffoldInput | . (inherited from TScaffoldInputBase)
P | setDefaultProperty | .
P | setNotNullProperty | .
P | setRecordPropertyValue | . (inherited from TScaffoldInputBase)
Derived classes
  • TIbmScaffoldInput
  • TMssqlScaffoldInput
  • TMysqlScaffoldInput
  • TPgsqlScaffoldInput
  • TSqliteScaffoldInput
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldListView

Namespace: System.Data.ActiveRecord.Scaffold
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TScaffoldBase »
TScaffoldListView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultStyle | string | default scaffold stylesheet name. (inherited from TScaffoldBase)
RP | EditViewControl | TScaffoldEditView | control for editing selected Active Record, null if EditViewID is not set.
 | EditViewID | string | TScaffoldEditView control ID for editing selected Active Record.
 | EnableDefaultStyle | boolean | enable default stylesheet, default is true. (inherited from TScaffoldBase)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | Header | TRepeater | Repeater control for record property names.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
R | List | TRepeater | Repeater control for Active Record instances.
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Pager | TPager | List pager control.
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RecordClass | string | Name of the Active Record class to be viewed or scaffolded. (inherited from TScaffoldBase)
RP | RecordCriteria | TActiveRecordCriteria | sort/search/paging criteria.
RP | RecordFinder | TActiveRecord | Active Record finder instance. (inherited from TScaffoldBase)
P | RecordObject | TActiveRecord | Gets the current Active Record instance. (inherited from TScaffoldBase)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | SearchCondition | {unknown} | .
 | SearchParameters | array | search parameters.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | Sort | TDropDownList | Control that displays and controls the record ordering.
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TableInfo | TDbMetaData | table/view information. (inherited from TScaffoldBase)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Loads and display the data.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Continue bubbling the "edit" command, "delete" command is handled in this class.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
P | clearRecordObject | Unset the current record instance and table information. (inherited from TScaffoldBase)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
P | copyFrom | Copy the view details from another scaffold view instance. (inherited from TScaffoldBase)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
P | deleteRecord | Deletes an Active Record.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRecordPkValues | record primary key values. (inherited from TScaffoldBase)
P | getRecordPropertyValues | record property values. (inherited from TScaffoldBase)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
P | initializeEdit | Initialize the edit view control form when EditViewID is set.
P | initializeSort | Initialize the sort drop down list and the column names repeater.
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | listItemCreated | Initialize the default display for each Active Record item.
P | loadRecordData | Fetch the records and data bind it to the list.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | pageChanged | Updates repeater page index with the pager new index value.
P | populateField | Sets the Record primary key to the current repeater item's CustomData.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldSearch

Namespace: System.Data.ActiveRecord.Scaffold
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TScaffoldBase »
TScaffoldSearch
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultStyle | string | default scaffold stylesheet name. (inherited from TScaffoldBase)
 | EnableDefaultStyle | boolean | enable default stylesheet, default is true. (inherited from TScaffoldBase)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
RP | Fields | array | list of fields to be searched.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
RP | ListView | TScaffoldListView | the scaffold list view this search box belongs to.
 | ListViewID | string | ID of the TScaffoldListView this search control belongs to.
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RecordClass | string | Name of the Active Record class to be viewed or scaffolded. (inherited from TScaffoldBase)
RP | RecordFinder | TActiveRecord | Active Record finder instance. (inherited from TScaffoldBase)
P | RecordObject | TActiveRecord | Gets the current Active Record instance. (inherited from TScaffoldBase)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SearchButton | TButton | button with default label "Search".
R | SearchText | TTextBox | search text box.
 | SearchableFields | string | comma delimited list of fields that may be searched.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TableInfo | TDbMetaData | table/view information. (inherited from TScaffoldBase)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Publish the default stylesheet file. (inherited from TScaffoldBase)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Sets the SearchCondition of the TScaffoldListView as the search terms given by the text of the search text box.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
P | clearRecordObject | Unset the current record instance and table information. (inherited from TScaffoldBase)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
P | copyFrom | Copy the view details from another scaffold view instance. (inherited from TScaffoldBase)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createSearchCondition | the search criteria for the search terms in the search text box.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRecordPkValues | record primary key values. (inherited from TScaffoldBase)
P | getRecordPropertyValues | record property values. (inherited from TScaffoldBase)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScaffoldView

Namespace: System.Data.ActiveRecord.Scaffold
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl » TTemplateControl » TScaffoldBase »
TScaffoldView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AddButton | TButton | "Add new record" button.
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DefaultStyle | string | default scaffold stylesheet name. (inherited from TScaffoldBase)
R | EditView | TScaffoldEditView | scaffold edit view.
 | EnableDefaultStyle | boolean | enable default stylesheet, default is true. (inherited from TScaffoldBase)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control. (inherited from TTemplateControl)
R | ListView | TScaffoldListView | scaffold list view.
R | Master | TTemplateControl|null | master control associated with this control, null if none. (inherited from TTemplateControl)
 | MasterClass | string | master class name (in namespace form). (inherited from TTemplateControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | RecordClass | string | Name of the Active Record class to be viewed or scaffolded. (inherited from TScaffoldBase)
RP | RecordFinder | TActiveRecord | Active Record finder instance. (inherited from TScaffoldBase)
P | RecordObject | TActiveRecord | Gets the current Active Record instance. (inherited from TScaffoldBase)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | SearchControl | TScaffoldSearch | scaffold search textbox and button.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TableInfo | TDbMetaData | table/view information. (inherited from TScaffoldBase)
 | Template | ITemplate|null | Returns the template object associated with this control object. (inherited from TTemplateControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template. (inherited from TTemplateControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Copy basic record details to the list/edit/search controls.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Handle the "edit" and "new" commands by displaying the edit view.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
P | clearRecordObject | Unset the current record instance and table information. (inherited from TScaffoldBase)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
P | copyFrom | Copy the view details from another scaffold view instance. (inherited from TScaffoldBase)
 | createChildControls | Creates child controls. (inherited from TTemplateControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getRecordPkValues | record primary key values. (inherited from TScaffoldBase)
P | getRecordPropertyValues | record property values. (inherited from TScaffoldBase)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls. (inherited from TTemplateControl)
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders. (inherited from TTemplateControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class. (inherited from TTemplateControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control. (inherited from TTemplateControl)
 | registerContentPlaceHolder | Registers a content placeholder to this template control. (inherited from TTemplateControl)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
P | showAddView | Shows the add record view.
P | showEditView | Shows the edit record view.
P | showListView | Shows the view for listing the records.
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScalarDiff

Namespace: System.Web.UI.ActiveControls
Inheritance: TViewStateDiff »
TScalarDiff
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
getDifference | update viewstate value.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TScrollBars

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TScrollBars
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSecurityManager

Namespace: System.Security
Inheritance: TComponent » TApplicationComponent » TModule »
TSecurityManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Encryption | string | the algorithm used to encrypt/decrypt data.
 | EncryptionKey | string | the private key used to encrypt/decrypt data.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Validation | TSecurityManagerValidationMode | hashing algorithm used to generate HMAC.
 | ValidationKey | string | the private key used to generate HMAC.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | computeHMAC | Computes the HMAC for the data with ValidationKey.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | decrypt | Decrypts data with EncryptionKey.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | encrypt | Encrypts data with EncryptionKey.
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | generateRandomKey | Generates a random key.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hashData | Prefixes data with an HMAC.
 | init | Initializes the module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | validateData | Validates if data is tampered.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSecurityManagerValidationMode

Namespace: System.Security
Inheritance: TEnumerable »
TSecurityManagerValidationMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSelectMappedStatement

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent » TMappedStatement »
TSelectMappedStatement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TPreparedCommand | command to prepare SQL statements. (inherited from TMappedStatement)
R | ID | string | Name used to identify the TMappedStatement amongst the others. (inherited from TMappedStatement)
R | Manager | TSqlMapper | The SqlMap used by this MappedStatement. (inherited from TMappedStatement)
R | SqlString | {unknown} | . (inherited from TMappedStatement)
R | Statement | TSqlMapStatement | The SQL statment used by this MappedStatement. (inherited from TMappedStatement)
Events
Name | Description
OnExecuteQuery | Raise the execute query event. (inherited from TMappedStatement)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addResultMapGroupBy | ResultMap with GroupBy property. (inherited from TMappedStatement)
P | applyResultMap | Apply result mapping. (inherited from TMappedStatement)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | enquequePostSelect | Add nested result property to post select queue. (inherited from TMappedStatement)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | executeInsert | .
P | executePostSelect | Process 'select' result properties . (inherited from TMappedStatement)
 | executeQueryForList | Executes the SQL and retuns a List of result objects. (inherited from TMappedStatement)
 | executeQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. (inherited from TMappedStatement)
 | executeQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter. (inherited from TMappedStatement)
P | executeSQLQueryLimit | Execute SQL Query with limits. (inherited from TMappedStatement)
P | executeSelectKey | Execute the select key statement, used to obtain last insert ID. (inherited from TMappedStatement)
 | executeUpdate | .
P | fillArrayResultMap | Retrieve the result map as an array. (inherited from TMappedStatement)
P | fillDefaultResultMap | Fill the result map using default settings. (inherited from TMappedStatement)
P | fillPropertyWithResultMap | Fills the property with result mapping results. (inherited from TMappedStatement)
P | fillResultArrayList | Apply the result to a TList or an array. (inherited from TMappedStatement)
P | fillResultClass | Fill the result using ResultClass, will creates new result object if required. (inherited from TMappedStatement)
P | fillResultMap | Fills the result object according to result mappings. (inherited from TMappedStatement)
P | fillResultObjectProperty | Apply the result to an object. (inherited from TMappedStatement)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPostGeneratedSelectKey | Gets the inserted row ID after executing an insert statement. (inherited from TMappedStatement)
P | getPostSelectKeys | Finds in the post select property the SQL statement primary selection keys. (inherited from TMappedStatement)
P | getPreGeneratedSelectKey | Gets the insert generated ID before executing an insert statement. (inherited from TMappedStatement)
P | getResultMapGroupKey | Gets the result 'group by' groupping key for each row. (inherited from TMappedStatement)
P | getScalarResult | Converts the first array value to scalar value of given type. (inherited from TMappedStatement)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initialGroupByResults | Empty the group by results cache. (inherited from TMappedStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | raiseRowDelegate | Raises delegate handler. (inherited from TMappedStatement)
 | runQueryForList | Executes the SQL and retuns a List of result objects. (inherited from TMappedStatement)
 | runQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. (inherited from TMappedStatement)
 | runQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter. (inherited from TMappedStatement)
P | setObjectProperty | Set a property of the result object with appropriate value. (inherited from TMappedStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TServerValidateEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TServerValidateEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | IsValid | boolean | whether the value is valid.
R | Value | string | value to be validated.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TService

Namespace: System
Inheritance: TComponent » TApplicationComponent »
TService
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | Enabled | boolean | whether the service is enabled.
 | ID | string | id of this service.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the service and attaches run to the RunService event of application.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
run | Runs the service.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TFeedService
  • TJsonService
  • TPageService
  • TSoapService
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSessionIterator

Namespace: System.Web
TSessionIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array element.
key | Returns the key of the current array element.
next | Moves the internal pointer to the next array element.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an element at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSessionPageStatePersister

Namespace: System.Web.UI
Inheritance: TComponent »
TSessionPageStatePersister
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
HistorySize | integer | maximum number of page states that should be kept in session.
Page | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
load | Loads page state from session.
raiseEvent | Raises an event. (inherited from TComponent)
save | Saves state in session.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TShellApplication

Namespace: System
Inheritance: TComponent » TApplication »
TShellApplication
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | ApplicationStatePersister | IStatePersister | application state persister. (inherited from TApplication)
 | AssetManager | TAssetManager | asset manager. (inherited from TApplication)
R | AuthorizationRules | TAuthorizationRuleCollection | list of authorization rules for the current request. (inherited from TApplication)
 | BasePath | string | the directory containing the application configuration file (absolute path). (inherited from TApplication)
 | Cache | ICache | the cache module, null if cache module is not installed. (inherited from TApplication)
 | ConfigurationFile | string | the application configuration file (absolute path). (inherited from TApplication)
 | ErrorHandler | TErrorHandler | the error handler module. (inherited from TApplication)
 | Globalization | TGlobalization | globalization module. (inherited from TApplication)
 | ID | string | application ID. (inherited from TApplication)
 | Mode | TApplicationMode | application mode. (inherited from TApplication)
R | Modules | array | list of loaded application modules, indexed by module IDs. (inherited from TApplication)
 | PageServiceID | string | page service ID. (inherited from TApplication)
R | Parameters | TMap | Returns the list of application parameters. (inherited from TApplication)
 | Request | THttpRequest | the request module. (inherited from TApplication)
R | RequestCompleted | boolean | whether the current request is processed. (inherited from TApplication)
 | Response | THttpResponse | the response module. (inherited from TApplication)
 | RuntimePath | string | the directory storing cache data and application-level persistent data. (inherited from TApplication)
 | SecurityManager | TSecurityManager | the security manager module. (inherited from TApplication)
 | Service | IService | the currently requested service. (inherited from TApplication)
 | Session | THttpSession | the session module, null if session module is not installed. (inherited from TApplication)
R | UniqueID | string | an ID that uniquely identifies this Prado application from the others. (inherited from TApplication)
 | User | IUser | the application user. (inherited from TApplication)
Events
Name | Description
OnAuthentication | Raises OnAuthentication event. (inherited from TApplication)
OnAuthenticationComplete | Raises OnAuthenticationComplete event. (inherited from TApplication)
OnAuthorization | Raises OnAuthorization event. (inherited from TApplication)
OnAuthorizationComplete | Raises OnAuthorizationComplete event. (inherited from TApplication)
OnBeginRequest | Raises OnBeginRequest event. (inherited from TApplication)
OnEndRequest | Raises OnEndRequest event. (inherited from TApplication)
OnError | Raises OnError event. (inherited from TApplication)
OnLoadState | Raises OnLoadState event. (inherited from TApplication)
OnLoadStateComplete | Raises OnLoadStateComplete event. (inherited from TApplication)
OnPreFlushOutput | Raises OnPreFlushOutput event. (inherited from TApplication)
OnPreRunService | Raises OnPreRunService event. (inherited from TApplication)
OnSaveState | Raises OnSaveState event. (inherited from TApplication)
OnSaveStateComplete | Raises OnSaveStateComplete event. (inherited from TApplication)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyConfiguration | Applies an application configuration. (inherited from TApplication)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clearGlobalState | Clears a global value. (inherited from TApplication)
 | completeRequest | Completes current request processing. (inherited from TApplication)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flushOutput | Flushes output to client side. (inherited from TApplication)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getGlobalState | Returns a global value. (inherited from TApplication)
 | getModule | the module with the specified ID, null if not found. (inherited from TApplication)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initApplication | Loads configuration and initializes application. (inherited from TApplication)
P | loadGlobals | Loads global values from persistent storage. (inherited from TApplication)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | resolvePaths | Resolves application-relevant paths. (inherited from TApplication)
 | run | Runs the application.
 | runService | Runs the requested service. (inherited from TApplication)
P | saveGlobals | Saves global values into persistent storage. (inherited from TApplication)
 | setGlobalState | Sets a global value. (inherited from TApplication)
 | setModule | Adds a module to application. (inherited from TApplication)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | startService | Override parent implementation.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSimpleDateFormatter

Namespace: System.Util
TSimpleDateFormatter
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
format | Format the date according to the pattern.
getCharset | formatting charset.
getDayMonthYearOrdering | .
getDayPattern | .
getMonthPattern | .
getPattern | formatting pattern.
getYearPattern | .
isValidDate | true if the given value matches with the date pattern.
parse | Parse the string according to the pattern.
setCharset | .
setPattern | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSimpleDynamicParser

Namespace: System.Data.SqlMap.Configuration
TSimpleDynamicParser
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
parse | Parse the sql text for dynamic place holders of the form $name$.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSimpleDynamicSql

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent » TStaticSql »
TSimpleDynamicSql
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | PreparedStatement | {unknown} | . (inherited from TStaticSql)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
buildPreparedStatement | . (inherited from TStaticSql)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
replaceDynamicParameter | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSlider

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TSlider
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the slider value.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TSliderClientScript | Gets the TSliderClientScript to set the TSlider event handlers.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CssUrl | string | URL for the CSS file including all relevant CSS class definitions.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the value of the TSlider control.
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | Direction | TSliderDirection | Direction of slider (Horizontal or Vertical).
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | MaxValue | float | Maximum value for the slider.
 | MinValue | float | Minimum value for slider.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | ProgressIndicator | boolean | wether to display a progress indicator or not.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
RP | SliderOptions | array | Get javascript sliderr options.
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StepSize | float | Step size.
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
R | TagName | string | the HTML tag name for slider.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Value | float | current value of slider.
 | Values | array | list of allowed values the slider can take.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers CSS and JS.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
OnValueChanged | Raises OnValueChanged event.
Methods
 | Name | Description
P | addAttributesToRender | Add the specified css classes to the track .
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientScript | javascript event options.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
P | registerSliderClientScript | Registers the javascript code to initialize the slider.
P | registerStyleSheet | Registers the CSS relevant to the TSlider.
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Render the body content.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSliderClientScript

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TClientSideOptions »
TSliderClientScript
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | OnChange | string | javascript code to execute when the slider value is changed.
 | OnSlide | string | javascript code to execute when the slider moves.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Ensure that the javascript statements are wrapped in a javascript function block as function(sender, parameter){ //code }. (inherited from TClientSideOptions)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSliderDirection

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TSliderDirection
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSoapServer

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent »
TSoapServer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Actor | string | actor of the SOAP service.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ClassMaps | string | comma delimit list of complex type classes.
 | Encoding | string | encoding of the SOAP service.
 | ID | string | the ID of the SOAP server.
RP | Options | array | options for creating SoapServer instance.
 | Provider | string | the SOAP provider class (in namespace format).
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | RequestedMethod | string | Soap method guessed from the SOAP message received.
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SessionPersistent | boolean | whether the SOAP service is persistent within session.
 | Uri | string | the URI for the SOAP service.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Version | string | SOAP version, defaults to empty (meaning not set).
R | Wsdl | string | Returns the WSDL content of the SOAP server.
 | WsdlUri | string | the URI for WSDL.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createServer | Creates the SoapServer instance.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | fault | Generate a SOAP fault message.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | guessMethodCallRequested | Guess the SOAP method request from the actual SOAP message .
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | run | Handles the SOAP request.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSoapService

Namespace: System.Web.Services
Inheritance: TComponent » TApplicationComponent » TService »
TSoapService
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ConfigFile | string | external configuration file.
 | Enabled | boolean | whether the service is enabled. (inherited from TService)
 | ID | string | id of this service. (inherited from TService)
R | IsWsdlRequest | boolean | whether this is a request for WSDL.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | ServerID | string | the SOAP server ID.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | constructUrl | Constructs a URL with specified page path and GET parameters.
P | createServer | Creates the requested SOAP server.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | resolveRequest | Resolves the request parameter.
 | run | Runs the service.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlCriteria

Namespace: System.Data.DataGateway
Inheritance: TComponent »
TSqlCriteria
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Condition | string | search conditions.
R | IsNamedParameters | boolean | true if the parameter index are string base, false otherwise.
 | Limit | int | maximum number of records to return.
 | Offset | int | record offset.
 | OrdersBy | TAttributeCollection | ordering clause.
 | Parameters | TAttributeCollection | list of named parameters and values.
 | Select | mixed | Gets the field list to be placed after the SELECT in the SQL.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TActiveRecordCriteria
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapApplicationCache

Namespace: System.Data.SqlMap
TSqlMapApplicationCache
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | add | .
 | delete | .
 | flush | Deletes all items in the cache, only for data cached by sqlmap cachemodel.
 | get | Gets a cached object with the specified key.
P | getCache | Application cache instance.
P | getKeyList | Retreive keylist from cache or create it if it doesn't exists .
P | getKeyListId | a KeyListID for the cache model.
 | set | Stores a value identified by a key into cache.
P | setKeyList | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapCache

Namespace: System.Data.SqlMap
TSqlMapCache
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
add | .
delete | the object removed if exists, null otherwise.
flush | Clears the cache.
get | Retrieves a value from cache with a specified key. (inherited from ICache)
getCacheSize | cache size.
set | Stores a value identified by a key into cache. (inherited from ICache)
setCacheSize | Maximum number of items to cache.
Derived classes
  • TSqlMapFifoCache
  • TSqlMapLruCache
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapCacheKey

Namespace: System.Data.SqlMap.Configuration
TSqlMapCacheKey
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | generateKey | crc32 hash of the serialized object.
 | getHash | object hash.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapCacheModel

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TSqlMapCacheModel
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | FlushInterval | integer | cache duration.
R | HitRatio | float | cache hit ratio.
 | ID | string | unique cache model identifier.
 | Implementation | string | cache implements of TSqlMapCacheTypes, either 'Basic', 'LRU' or 'FIFO'.
R | ImplementationClass | string | cache implementation class name.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flush | Clears the cache.
get | cached value.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
initialize | Initialize the cache implementation, sets the actual cache contain if supplied.
raiseEvent | Raises an event. (inherited from TComponent)
registerTriggerStatement | Register a mapped statement that will trigger a cache flush.
set | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapCacheTypes

Namespace: System.Data.SqlMap.Configuration
Inheritance: TEnumerable »
TSqlMapCacheTypes
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapConfig

Namespace: System.Data.SqlMap
Inheritance: TComponent » TApplicationComponent » TModule » TDataSourceConfig »
TSqlMapConfig
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Client | TSqlMapGateway | Initialize the sqlmap if necessary, returns the TSqlMapGateway instance.
 | ConfigFile | string | SqlMap configuration file.
 | ConnectionClass | {unknown} | . (inherited from TDataSourceConfig)
 | ConnectionID | string | connection module ID. (inherited from TDataSourceConfig)
R | Database | TDbConnection | Alias for getDbConnection(). (inherited from TDataSourceConfig)
R | DbConnection | TDbConnection | Gets the TDbConnection from another module if ConnectionID is supplied and valid. (inherited from TDataSourceConfig)
 | EnableCache | boolean | true if configuration should be cached, false otherwise.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | SqlMapManager | TSqlMapManager | Create and configure the data mapper using sqlmap configuration file.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
P | cacheSqlMapManager | Saves the current SqlMap manager to cache.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clearCache | Deletes the configuration cache.
P | createSqlMapGateway | SqlMap gateway instance.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | findConnectionByID | Finds the database connection instance from the Application modules. (inherited from TDataSourceConfig)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initalize the database connection properties from attributes in tag. (inherited from TDataSourceConfig)
P | loadCachedSqlMapManager | Loads SqlMap manager from cache.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapConfigurationException

Namespace: System.Data.SqlMap
Inheritance: TException » TSqlMapException »
TSqlMapConfigurationException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TSqlMapException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
P | implodeNode | tag name and attribute names and values. (inherited from TSqlMapException)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapDelete

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent » TSqlMapStatement » TSqlMapUpdate »
TSqlMapDelete
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Cache | TSqlMapCacheModel | cache implementation instance for this statement. (inherited from TSqlMapStatement)
CacheModel | string | cache mode name. (inherited from TSqlMapStatement)
Extends | string | another statement element name. (inherited from TSqlMapStatement)
ID | string | name for this statement, unique to each sql map manager. (inherited from TSqlMapStatement)
ListClass | string | name of a PHP class that implements ArrayAccess. (inherited from TSqlMapStatement)
ParameterClass | string | parameter class name. (inherited from TSqlMapStatement)
ParameterMap | string | name of a parameter map. (inherited from TSqlMapStatement)
ResultClass | string | result class name. (inherited from TSqlMapStatement)
ResultMap | string | result map name. (inherited from TSqlMapStatement)
SqlText | TStaticSql | sql text container. (inherited from TSqlMapStatement)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createInstanceOf | Create a new instance of a given type. (inherited from TSqlMapStatement)
 | createInstanceOfListClass | new instance of list class. (inherited from TSqlMapStatement)
 | createInstanceOfResultClass | Create a new instance of result class. (inherited from TSqlMapStatement)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | . (inherited from TSqlMapStatement)
 | parameterMap | the parameter map corresponding to the getParameterMap() property. (inherited from TSqlMapStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | resultMap | the result map corresponding to the getResultMap() property. (inherited from TSqlMapStatement)
 | setInlineParameterMap | . (inherited from TSqlMapStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapDuplicateException

Namespace: System.Data.SqlMap
Inheritance: TException » TSqlMapException »
TSqlMapDuplicateException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TSqlMapException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
P | implodeNode | tag name and attribute names and values. (inherited from TSqlMapException)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapException

Namespace: System.Data.SqlMap
Inheritance: TException »
TSqlMapException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file.
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
P | implodeNode | tag name and attribute names and values.
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
  • TInvalidPropertyException
  • TSqlMapConfigurationException
  • TSqlMapDuplicateException
  • TSqlMapExecutionException
  • TSqlMapUndefinedException
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapExecutionException

Namespace: System.Data.SqlMap
Inheritance: TException » TSqlMapException »
TSqlMapExecutionException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TSqlMapException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
P | implodeNode | tag name and attribute names and values. (inherited from TSqlMapException)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapFifoCache

Namespace: System.Data.SqlMap
Inheritance: TSqlMapCache »
TSqlMapFifoCache
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
add | . (inherited from TSqlMapCache)
delete | the object removed if exists, null otherwise. (inherited from TSqlMapCache)
flush | Clears the cache. (inherited from TSqlMapCache)
get | Gets a cached object with the specified key.
getCacheSize | cache size. (inherited from TSqlMapCache)
set | Stores a value identified by a key into cache.
setCacheSize | Maximum number of items to cache. (inherited from TSqlMapCache)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapGateway

Namespace: System.Data.SqlMap
Inheritance: TComponent »
TSqlMapGateway
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection.
R | SqlMapManager | TSqlMapManager | sqlmap manager.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
delete | Executes a Sql DELETE statement.
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flushCaches | Flushes all cached objects that belong to this SqlMap.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
insert | Executes a Sql INSERT statement.
queryForList | Executes a Sql SELECT statement that returns data to populate a number of result objects.
queryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter.
queryForMapWithRowDelegate | Runs a query with a custom object that gets a chance to deal with each row as it is processed.
queryForObject | Executes a Sql SELECT statement that returns that returns data to populate a single object instance.
queryForPagedList | Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.
queryForPagedListWithRowDelegate | Executes the SQL and retuns a subset of the results in a dynamic TPagedList that can be used to automatically scroll through results from a database table.
queryWithRowDelegate | Runs a query for list with a custom object that gets a chance to deal with each row as it is processed.
raiseEvent | Raises an event. (inherited from TComponent)
registerTypeHandler | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
update | Executes a Sql UPDATE statement.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapInsert

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent » TSqlMapStatement »
TSqlMapInsert
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Cache | TSqlMapCacheModel | cache implementation instance for this statement. (inherited from TSqlMapStatement)
CacheModel | string | cache mode name. (inherited from TSqlMapStatement)
Extends | string | another statement element name. (inherited from TSqlMapStatement)
ID | string | name for this statement, unique to each sql map manager. (inherited from TSqlMapStatement)
ListClass | string | name of a PHP class that implements ArrayAccess. (inherited from TSqlMapStatement)
ParameterClass | string | parameter class name. (inherited from TSqlMapStatement)
ParameterMap | string | name of a parameter map. (inherited from TSqlMapStatement)
ResultClass | string | result class name. (inherited from TSqlMapStatement)
ResultMap | string | result map name. (inherited from TSqlMapStatement)
SelectKey | TSqlMapSelectKey | select key element.
SqlText | TStaticSql | sql text container. (inherited from TSqlMapStatement)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createInstanceOf | Create a new instance of a given type. (inherited from TSqlMapStatement)
 | createInstanceOfListClass | new instance of list class. (inherited from TSqlMapStatement)
 | createInstanceOfResultClass | Create a new instance of result class. (inherited from TSqlMapStatement)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | . (inherited from TSqlMapStatement)
 | parameterMap | the parameter map corresponding to the getParameterMap() property. (inherited from TSqlMapStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | resultMap | the result map corresponding to the getResultMap() property. (inherited from TSqlMapStatement)
 | setInlineParameterMap | . (inherited from TSqlMapStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapLruCache

Namespace: System.Data.SqlMap
Inheritance: TSqlMapCache »
TSqlMapLruCache
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
add | . (inherited from TSqlMapCache)
delete | the object removed if exists, null otherwise. (inherited from TSqlMapCache)
flush | Clears the cache. (inherited from TSqlMapCache)
get | Gets a cached object with the specified key.
getCacheSize | cache size. (inherited from TSqlMapCache)
set | Stores a value identified by a key into cache.
setCacheSize | Maximum number of items to cache. (inherited from TSqlMapCache)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapManager

Namespace: System.Data.SqlMap
Inheritance: TComponent »
TSqlMapManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | CacheDependencies | TChainedCacheDependency | @since 3.
 | DbConnection | TDbConnection | default database connection.
R | MappedStatements | TMap | mapped statements collection.
R | ParameterMaps | TMap | parameter maps collection.
R | ResultMaps | TMap | result maps collection.
R | SqlmapGateway | TSqlMapGateway | SqlMap gateway.
R | TypeHandlers | TTypeHandlerFactory | The TypeHandlerFactory.
Events
Methods
 | Name | Description
 | addCacheModel | Adds a named cache.
 | addMappedStatement | Adds a (named) MappedStatement.
 | addParameterMap | .
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | addResultMap | .
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | configureXml | Loads and parses the SqlMap configuration file.
P | createSqlMapGateway | Configures the current TSqlMapManager using the given xml configuration file defined in setConfigFile().
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flushCacheModels | Flushes all cached objects that belong to this SqlMap.
 | getCacheModel | Gets a cache by name .
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getMappedStatement | Gets a MappedStatement by name.
 | getParameterMap | the parameter with given ID.
 | getResultMap | Gets a named result map .
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapObjectCollectionTree

Namespace: System.Data.SqlMap.Statements
TSqlMapObjectCollectionTree
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | add | Add a new node to the object tree graph.
P | addNode | Find the parent node and add the new node as its child.
 | collect | object collection.
P | collectChildren | Visit all the child nodes and collect them by removing.
P | getCollection | object collection.
P | hasChildren | true if all nodes are leaf nodes, false otherwise.
 | isEmpty | true if the graph is empty.
P | onChildNodesVisited | Set the object properties for all the child nodes visited.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapPagedList

Namespace: System.Data.SqlMap
Inheritance: TComponent » TList » TPagedList »
TSqlMapPagedList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in current page. (inherited from TPagedList)
 | CurrentPageIndex | integer | current page index. (inherited from TPagedList)
 | CustomPaging | boolean | whether to use custom paging. (inherited from TPagedList)
R | IsFirstPage | boolean | whether the current page is the first page. (inherited from TPagedList)
R | IsLastPage | boolean | true if is the very last page, false otherwise.
R | IsMiddlePage | boolean | true if is not first nor last page, false otherwise.
R | IsNextPageAvailable | boolean | true if the next page is available, false otherwise.
R | IsPreviousPageAvailable | boolean | true if the previous page is available, false otherwise.
R | Iterator | Iterator | iterator. (inherited from TPagedList)
R | PageCount | integer | number of pages, -1 if under custom paging mode and VirtualCount is not set. (inherited from TPagedList)
 | PageSize | integer | number of items in each page. (inherited from TPagedList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
 | VirtualCount | integer | user-assigned number of items in data source. (inherited from TPagedList)
Events
Name | Description
OnFetchData | Raises OnFetchData event. (inherited from TPagedList)
OnPageIndexChanged | Raises OnPageIndexChanged event. (inherited from TPagedList)
Methods
 | Name | Description
 | add | Appends an item at the end of the list. (inherited from TList)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | clear | Removes all items in the list. (inherited from TList)
 | contains | whether the list contains the item. (inherited from TList)
 | copyFrom | Copies iterable data into the list. (inherited from TList)
 | count | Returns the number of items in the list. (inherited from TList)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | fetchDataFromStatement | Fetch data by executing the SqlMap statement.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOffsetAndLimit | Calculate the data fetch offsets and limits.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | gotoPage | Changes to a page with the specified page index. (inherited from TPagedList)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TPagedList)
P | initialize | Initialize the paged list.
 | insertAt | Inserts an item at the specified position. (inherited from TList)
 | itemAt | Returns the item at the specified offset. (inherited from TPagedList)
 | mergeWith | Merges iterable data into the map. (inherited from TList)
 | nextPage | Switches to the next page.
 | offsetExists | Returns whether there is an item at the specified offset. (inherited from TPagedList)
 | offsetGet | Returns the item at the specified offset. (inherited from TPagedList)
 | offsetSet | Sets the item at the specified offset. (inherited from TList)
 | offsetUnset | Unsets the item at the specified offset. (inherited from TList)
P | populateData | Populate the list with the fetched data.
 | previousPage | Switches to the previous page.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | remove | Removes an item from the list. (inherited from TList)
 | removeAt | Removes an item at the specified position. (inherited from TList)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | toArray | the list of items in array. (inherited from TPagedList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapSelect

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent » TSqlMapStatement »
TSqlMapSelect
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Cache | TSqlMapCacheModel | cache implementation instance for this statement. (inherited from TSqlMapStatement)
CacheModel | string | cache mode name. (inherited from TSqlMapStatement)
Extends | string | another statement element name. (inherited from TSqlMapStatement)
Generate | {unknown} | .
ID | string | name for this statement, unique to each sql map manager. (inherited from TSqlMapStatement)
ListClass | string | name of a PHP class that implements ArrayAccess. (inherited from TSqlMapStatement)
ParameterClass | string | parameter class name. (inherited from TSqlMapStatement)
ParameterMap | string | name of a parameter map. (inherited from TSqlMapStatement)
ResultClass | string | result class name. (inherited from TSqlMapStatement)
ResultMap | string | result map name. (inherited from TSqlMapStatement)
SqlText | TStaticSql | sql text container. (inherited from TSqlMapStatement)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createInstanceOf | Create a new instance of a given type. (inherited from TSqlMapStatement)
 | createInstanceOfListClass | new instance of list class. (inherited from TSqlMapStatement)
 | createInstanceOfResultClass | Create a new instance of result class. (inherited from TSqlMapStatement)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | . (inherited from TSqlMapStatement)
 | parameterMap | the parameter map corresponding to the getParameterMap() property. (inherited from TSqlMapStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | resultMap | the result map corresponding to the getResultMap() property. (inherited from TSqlMapStatement)
 | setInlineParameterMap | . (inherited from TSqlMapStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapSelectKey

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent » TSqlMapStatement »
TSqlMapSelectKey
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Cache | TSqlMapCacheModel | cache implementation instance for this statement. (inherited from TSqlMapStatement)
 | CacheModel | string | cache mode name. (inherited from TSqlMapStatement)
 | Extends | string | another statement element name. (inherited from TSqlMapStatement)
 | ID | string | name for this statement, unique to each sql map manager. (inherited from TSqlMapStatement)
R | IsAfter | boolean | true if key is generated after insert command, false otherwise.
 | ListClass | string | name of a PHP class that implements ArrayAccess. (inherited from TSqlMapStatement)
 | ParameterClass | string | parameter class name. (inherited from TSqlMapStatement)
 | ParameterMap | string | name of a parameter map. (inherited from TSqlMapStatement)
 | Property | string | property name for the generated key.
 | ResultClass | string | result class name. (inherited from TSqlMapStatement)
 | ResultMap | string | result map name. (inherited from TSqlMapStatement)
 | SqlText | TStaticSql | sql text container. (inherited from TSqlMapStatement)
 | Type | string | select generated key type, 'post' or 'pre'.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createInstanceOf | Create a new instance of a given type. (inherited from TSqlMapStatement)
 | createInstanceOfListClass | new instance of list class. (inherited from TSqlMapStatement)
 | createInstanceOfResultClass | Create a new instance of result class. (inherited from TSqlMapStatement)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | . (inherited from TSqlMapStatement)
 | parameterMap | the parameter map corresponding to the getParameterMap() property. (inherited from TSqlMapStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | resultMap | the result map corresponding to the getResultMap() property. (inherited from TSqlMapStatement)
 | setInlineParameterMap | . (inherited from TSqlMapStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapStatement

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TSqlMapStatement
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Cache | TSqlMapCacheModel | cache implementation instance for this statement.
CacheModel | string | cache mode name.
Extends | string | another statement element name.
ID | string | name for this statement, unique to each sql map manager.
ListClass | string | name of a PHP class that implements ArrayAccess.
ParameterClass | string | parameter class name.
ParameterMap | string | name of a parameter map.
ResultClass | string | result class name.
ResultMap | string | result map name.
SqlText | TStaticSql | sql text container.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createInstanceOf | Create a new instance of a given type.
 | createInstanceOfListClass | new instance of list class.
 | createInstanceOfResultClass | Create a new instance of result class.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | .
 | parameterMap | the parameter map corresponding to the getParameterMap() property.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | resultMap | the result map corresponding to the getResultMap() property.
 | setInlineParameterMap | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TSqlMapInsert
  • TSqlMapSelect
  • TSqlMapSelectKey
  • TSqlMapUpdate
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapTypeHandler

Namespace: System.Data.SqlMap
Inheritance: TComponent »
TSqlMapTypeHandler
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
DbType | string | database field type.
Type | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createNewInstance | Casts the string representation of a value into a type recognized by this type handler.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getParameter | Performs processing on a value before it is used to set the parameter of a IDbCommand.
getResult | Performs processing on a value before after it has been retrieved from a database .
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapTypeHandlerRegistry

Namespace: System.Data.SqlMap
TSqlMapTypeHandlerRegistry
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
convertToType | Converts the value to given type using PHP's settype() function.
createInstanceOf | Creates a new instance of a particular class (for PHP primative types, their corresponding default value for given type is used).
getDbTypeHandler | type handler for give database field type.
getTypeHandler | type handler.
registerTypeHandler | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapUndefinedException

Namespace: System.Data.SqlMap
Inheritance: TException » TSqlMapException »
TSqlMapUndefinedException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TSqlMapException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
P | implodeNode | tag name and attribute names and values. (inherited from TSqlMapException)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapUpdate

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent » TSqlMapStatement »
TSqlMapUpdate
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
Cache | TSqlMapCacheModel | cache implementation instance for this statement. (inherited from TSqlMapStatement)
CacheModel | string | cache mode name. (inherited from TSqlMapStatement)
Extends | string | another statement element name. (inherited from TSqlMapStatement)
ID | string | name for this statement, unique to each sql map manager. (inherited from TSqlMapStatement)
ListClass | string | name of a PHP class that implements ArrayAccess. (inherited from TSqlMapStatement)
ParameterClass | string | parameter class name. (inherited from TSqlMapStatement)
ParameterMap | string | name of a parameter map. (inherited from TSqlMapStatement)
ResultClass | string | result class name. (inherited from TSqlMapStatement)
ResultMap | string | result map name. (inherited from TSqlMapStatement)
SqlText | TStaticSql | sql text container. (inherited from TSqlMapStatement)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createInstanceOf | Create a new instance of a given type. (inherited from TSqlMapStatement)
 | createInstanceOfListClass | new instance of list class. (inherited from TSqlMapStatement)
 | createInstanceOfResultClass | Create a new instance of result class. (inherited from TSqlMapStatement)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | . (inherited from TSqlMapStatement)
 | parameterMap | the parameter map corresponding to the getParameterMap() property. (inherited from TSqlMapStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | resultMap | the result map corresponding to the getResultMap() property. (inherited from TSqlMapStatement)
 | setInlineParameterMap | . (inherited from TSqlMapStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TSqlMapDelete
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapXmlConfigBuilder

Namespace: System.Data.SqlMap.Configuration
TSqlMapXmlConfigBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createObjectFromNode | Create an instance of an object give by the attribute named 'class' in the node and set the properties on the object given by attribute names and values.
P | getAbsoluteFilePath | Gets the filename relative to the basefile.
P | getConfigFile | configuration file.
P | getElementByIdValue | Get element node by ID value (try for attribute name ID as case insensitive).
P | loadXmlDocument | Load document using simple xml.
P | setObjectPropFromNode | For each attributes (excluding attribute named in $except) set the property of the $obj given by the name of the attribute with the value of the attribute.
Derived classes
  • TSqlMapXmlConfiguration
  • TSqlMapXmlMappingConfiguration
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapXmlConfiguration

Namespace: System.Data.SqlMap.Configuration
Inheritance: TSqlMapXmlConfigBuilder »
TSqlMapXmlConfiguration
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | attachCacheModels | Set the cache for each statement having a cache model property.
 | configure | Configure the TSqlMapManager using the given xml file.
P | createObjectFromNode | Create an instance of an object give by the attribute named 'class' in the node and set the properties on the object given by attribute names and values. (inherited from TSqlMapXmlConfigBuilder)
P | getAbsoluteFilePath | Gets the filename relative to the basefile. (inherited from TSqlMapXmlConfigBuilder)
P | getConfigFile | .
P | getElementByIdValue | Get element node by ID value (try for attribute name ID as case insensitive). (inherited from TSqlMapXmlConfigBuilder)
 | getManager | .
P | loadDatabaseConnection | Load the database connection tag.
P | loadGlobalProperty | Load global replacement property.
P | loadSqlMappingFiles | Load SqlMap mapping configuration.
P | loadTypeHandler | Load the type handler configurations.
P | loadXmlDocument | Load document using simple xml. (inherited from TSqlMapXmlConfigBuilder)
 | replaceProperties | Replace the place holders ${name} in text with properties the corresponding global property value.
P | resolveResultMapping | Resolve nest result mappings.
P | setObjectPropFromNode | For each attributes (excluding attribute named in $except) set the property of the $obj given by the name of the attribute with the value of the attribute. (inherited from TSqlMapXmlConfigBuilder)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqlMapXmlMappingConfiguration

Namespace: System.Data.SqlMap.Configuration
Inheritance: TSqlMapXmlConfigBuilder »
TSqlMapXmlMappingConfiguration
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | applyInlineParameterMap | Extract inline parameter maps.
 | configure | Configure an XML mapping.
P | createInsertStatement | Create new insert statement from xml node.
P | createObjectFromNode | Create an instance of an object give by the attribute named 'class' in the node and set the properties on the object given by attribute names and values. (inherited from TSqlMapXmlConfigBuilder)
P | createParameterMap | Create a new parameter map from xml node.
P | createResultMap | Create a new result map and its associated result properties, disciminiator and sub maps.
P | getAbsoluteFilePath | Gets the filename relative to the basefile. (inherited from TSqlMapXmlConfigBuilder)
P | getConfigFile | .
P | getElementByIdValue | Get element node by ID value (try for attribute name ID as case insensitive). (inherited from TSqlMapXmlConfigBuilder)
P | loadCacheModel | Load cache models from xml mapping.
P | loadDeleteTag | Load delete statement from xml mapping.
P | loadFlushInterval | Load the flush interval .
P | loadFlushOnCache | Load the flush on cache properties.
P | loadInsertTag | Load insert statement from xml mapping.
P | loadParameterMap | Load parameter map from xml.
P | loadProcedureTag | Load procedure statement from xml mapping.
P | loadResultMap | Load the result maps.
P | loadSelectKeyTag | Load the selectKey statement from xml mapping.
P | loadSelectTag | Load select statement from xml mapping.
P | loadStatementTag | Load statement mapping from xml configuration file.
P | loadUpdateTag | Load update statement from xml mapping.
P | loadXmlDocument | Load document using simple xml. (inherited from TSqlMapXmlConfigBuilder)
P | prepareSql | Prepare the sql text (may extend to dynamic sql).
P | processSqlStatement | Load extended SQL statements if application.
P | registerCacheTriggers | Attach CacheModel to statement and register trigger statements for cache models.
P | setObjectPropFromNode | For each attributes (excluding attribute named in $except) set the property of the $obj given by the name of the attribute with the value of the attribute. (inherited from TSqlMapXmlConfigBuilder)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqliteCache

Namespace: System.Caching
Inheritance: TComponent » TApplicationComponent » TModule » TCache »
TSqliteCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | DbFile | string | database file path (in namespace form).
 | ID | string | id of this module. (inherited from TModule)
 | KeyPrefix | string | a unique prefix for the keys of cached values. (inherited from TCache)
 | PrimaryCache | boolean | whether this cache module is used as primary/system cache. (inherited from TCache)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | add | Stores a value identified by a key into cache if the cache does not contain this key. (inherited from TCache)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addValue | Stores a value identified by a key into cache if the cache does not contain this key.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes a value with the specified key from cache . (inherited from TCache)
P | deleteValue | Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Deletes all values from cache.
P | generateUniqueKey | a key generated from the provided key which ensures the uniqueness across applications. (inherited from TCache)
 | get | Retrieves a value from cache with a specified key. (inherited from TCache)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValue | Retrieves a value from cache with a specified key.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | offsetExists | Returns whether there is a cache entry with a specified key. (inherited from TCache)
 | offsetGet | . (inherited from TCache)
 | offsetSet | . (inherited from TCache)
 | offsetUnset | . (inherited from TCache)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | set | Stores a value identified by a key into cache. (inherited from TCache)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setValue | Stores a value identified by a key in cache.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqliteCommandBuilder

Namespace: System.Data.Common
Inheritance: TComponent » TDbCommandBuilder »
TSqliteCommandBuilder
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | DbConnection | TDbConnection | database connection. (inherited from TDbCommandBuilder)
R | LastInsertID | mixed | Iterate through all the columns and returns the last insert id of the first column that has a sequence or serial. (inherited from TDbCommandBuilder)
R | SelectFieldList | array | Different behavior depends on type of passed data string usage without modification null will be expanded to full list of quoted table column names (quoting depends on database) array - Column names will be quoted if used as key or value of array array('col1', 'col2', 'col2') // SELECT `col1`, `col2`, `col3` FROM. (inherited from TDbCommandBuilder)
 | TableInfo | {unknown} | . (inherited from TDbCommandBuilder)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | applyCriterias | . (inherited from TDbCommandBuilder)
 | applyLimitOffset | Alters the sql to apply $limit and $offset.
 | applyOrdering | modified SQL applied with ORDER BY. (inherited from TDbCommandBuilder)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | bindArrayValues | . (inherited from TDbCommandBuilder)
 | bindColumnValues | Bind the name-value pairs of $values where the array keys correspond to column names. (inherited from TDbCommandBuilder)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommand | corresponding database command. (inherited from TDbCommandBuilder)
 | createCountCommand | Creates a count(*) command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createDeleteCommand | Creates a delete command for the table described in TableInfo. (inherited from TDbCommandBuilder)
 | createFindCommand | Appends the $where condition to the string "SELECT * FROM tableName WHERE ". (inherited from TDbCommandBuilder)
 | createInsertCommand | Creates an insert command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createUpdateCommand | Creates an update command for the table described in TableInfo for the given data. (inherited from TDbCommandBuilder)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | getColumnBindings | Create a name-value or position-value if $position=true binding strings. (inherited from TDbCommandBuilder)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInsertFieldBindings | Returns a list of insert field name and a list of binding names. (inherited from TDbCommandBuilder)
S | getPdoType | PDO parameter types. (inherited from TDbCommandBuilder)
P | getSearchCondition | search condition for all words in one column. (inherited from TDbCommandBuilder)
 | getSearchExpression | Computes the SQL condition for search a set of column using regular expression (or LIKE, depending on database implementation) to match a string of keywords (default matches all keywords). (inherited from TDbCommandBuilder)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
P | hasIntegerKey | true if any array key is an integer. (inherited from TDbCommandBuilder)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqliteMetaData

Namespace: System.Data.Common.Sqlite
Inheritance: TComponent » TDbMetaData »
TSqliteMetaData
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | DbConnection | TDbConnection | database connection. (inherited from TDbMetaData)
R | TableInfo | TDbTableInfo | Obtains table meta data information for the current connection and given table name. (inherited from TDbMetaData)
RP | TableInfoClass | string | TDbTableInfo class name.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | Creates a command builder for a given table name. (inherited from TDbMetaData)
P | createTableInfo | Get the column definitions for given table.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getForeignKeys | foreign key details.
S | getInstance | Obtain database specific TDbMetaData class using the driver name of the database connection. (inherited from TDbMetaData)
P | getIsView | true if the table is a view.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | isForeignKeyColumn | true if column is a foreign key.
P | processColumn | column details.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqliteScaffoldInput

Namespace: System.Data.ActiveReecord.Scaffold.InputBuilder
Inheritance: TScaffoldInputBase » TScaffoldInputCommon »
TSqliteScaffoldInput
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | createBooleanControl | . (inherited from TScaffoldInputCommon)
P | createControl | .
P | createControlLabel | . (inherited from TScaffoldInputBase)
P | createDateControl | .
P | createDateTimeControl | .
P | createDefaultControl | . (inherited from TScaffoldInputCommon)
P | createEnumControl | . (inherited from TScaffoldInputCommon)
P | createFloatControl | . (inherited from TScaffoldInputCommon)
S | createInputBuilder | . (inherited from TScaffoldInputBase)
P | createIntegerControl | . (inherited from TScaffoldInputCommon)
P | createMultiLineControl | . (inherited from TScaffoldInputCommon)
P | createRangeValidator | . (inherited from TScaffoldInputCommon)
P | createRequiredValidator | . (inherited from TScaffoldInputCommon)
 | createScaffoldInput | . (inherited from TScaffoldInputBase)
P | createSetControl | . (inherited from TScaffoldInputCommon)
P | createTimeControl | . (inherited from TScaffoldInputCommon)
P | createTypeValidator | . (inherited from TScaffoldInputCommon)
P | createYearControl | . (inherited from TScaffoldInputCommon)
P | getControlValue | .
P | getDateTimeValue | .
P | getDefaultControlValue | . (inherited from TScaffoldInputCommon)
P | getEnumValue | . (inherited from TScaffoldInputCommon)
P | getIsEnabled | . (inherited from TScaffoldInputBase)
P | getMatchingIndices | . (inherited from TScaffoldInputCommon)
P | getParent | . (inherited from TScaffoldInputBase)
P | getRecordPropertyValue | . (inherited from TScaffoldInputBase)
P | getSetValue | . (inherited from TScaffoldInputCommon)
P | getTimeValue | . (inherited from TScaffoldInputCommon)
 | loadScaffoldInput | . (inherited from TScaffoldInputBase)
P | setDefaultProperty | . (inherited from TScaffoldInputCommon)
P | setNotNullProperty | . (inherited from TScaffoldInputCommon)
P | setRecordPropertyValue | . (inherited from TScaffoldInputBase)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqliteTableColumn

Namespace: System.Data.Common.Sqlite
Inheritance: TComponent » TDbTableColumn »
TSqliteTableColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowNull | boolean | specifies whether value Null is allowed, default is false. (inherited from TDbTableColumn)
R | AutoIncrement | boolean | true if column will auto-increment when the column value is inserted as null.
R | ColumnId | string | name of the column with quoted identifier. (inherited from TDbTableColumn)
R | ColumnIndex | integer | zero-based ordinal position of the column in the table. (inherited from TDbTableColumn)
R | ColumnName | string | name of the column in the table (identifier quoted). (inherited from TDbTableColumn)
R | ColumnSize | string | size of the column. (inherited from TDbTableColumn)
R | DbType | string | column type. (inherited from TDbTableColumn)
R | DefaultValue | mixed | default column value if column value was null. (inherited from TDbTableColumn)
R | IsExcluded | boolean | whether this column is excluded from insert and update. (inherited from TDbTableColumn)
R | IsForeignKey | boolean | whether this column is a foreign key, default is false. (inherited from TDbTableColumn)
R | IsPrimaryKey | boolean | whether this column is a primary key for the table, default is false. (inherited from TDbTableColumn)
R | MaxiumNumericConstraint | {unknown} | . (inherited from TDbTableColumn)
R | NumericPrecision | string | precision of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | NumericScale | string | scale of the column data, if the data is numeric. (inherited from TDbTableColumn)
R | PHPType | boolean | Overrides parent implementation, returns PHP type from the db type.
R | PdoType | {unknown} | . (inherited from TDbTableColumn)
R | SequenceName | {unknown} | . (inherited from TDbTableColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableColumn)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | hasSequence | true if auto increment is true.
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSqliteTableInfo

Namespace: System.Data.Common.Sqlite
Inheritance: TComponent » TDbTableInfo »
TSqliteTableInfo
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ColumnNames | array | table column names (identifier quoted). (inherited from TDbTableInfo)
R | Columns | TMap | TDbTableColumn column meta data. (inherited from TDbTableInfo)
R | ForeignKeys | array | tuples of foreign table and column name. (inherited from TDbTableInfo)
R | IsView | boolean | whether the table is a view, default is false. (inherited from TDbTableInfo)
R | LowerCaseColumnNames | array | lowercased column key names mapped to normal column ids. (inherited from TDbTableInfo)
R | PrimaryKeys | string[] | . (inherited from TDbTableInfo)
R | TableFullName | string | full name of the table, database dependent.
R | TableName | string | name of the table this column belongs to. (inherited from TDbTableInfo)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createCommandBuilder | new command builder.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getColumn | column information. (inherited from TDbTableInfo)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getInfo | information array value. (inherited from TDbTableInfo)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setInfo | . (inherited from TDbTableInfo)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStack

Namespace: System.Collections
Inheritance: TComponent »
TStack
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the stack.
R | Iterator | Iterator | Returns an iterator for traversing the items in the stack.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the stack.
contains | whether the stack contains the item.
copyFrom | Copies iterable data into the stack.
count | Returns the number of items in the stack.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
peek | Returns the item at the top of the stack.
pop | Pops up the item at the top of the stack.
push | Pushes an item into the stack.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in stack.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStackIterator

Namespace: System.Collections
TStackIterator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
current | Returns the current array item.
key | Returns the key of the current array item.
next | Moves the internal pointer to the next array item.
rewind | Rewinds internal array pointer.
valid | Returns whether there is an item at current position.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStatements

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TStatements
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Statements | string | the statements to be executed.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the evaluation result of the statements.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStaticSql

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent »
TStaticSql
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | PreparedStatement | {unknown} | .
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
buildPreparedStatement | .
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TSimpleDynamicSql
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStyle

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TStyle
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | BackColor | string | the background color of the control.
 | BorderColor | string | the border color of the control.
 | BorderStyle | string | the border style of the control.
 | BorderWidth | string | the border width of the control.
 | CssClass | string | the CSS class of the control.
 | CustomStyle | string | the custom style of the control.
 | DisplayStyle | TDisplayStyle | display style.
R | Font | TFont | the font of the control.
 | ForeColor | string | the foreground color of the control.
 | Height | string | the height of the control.
R | StyleFields | array | list of style fields.
 | Width | string | the width of the control.
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clearStyleField | Clears a single style field value; .
copyFrom | Copies the fields in a new style to this style.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getStyleField | a single style field value set via setStyleField.
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasCssClass | true if CSS is set or empty.
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasFont | true if font is set.
hasProperty | Determines whether a property is defined. (inherited from TComponent)
hasStyleField | whether a style field has been defined by setStyleField.
mergeWith | Merges the style with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Resets the style to the original empty state.
setStyleField | Sets a single style field value.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TPanelStyle
  • TTableItemStyle
  • TTableStyle
  • TWizardNavigationButtonStyle
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStyleDiff

Namespace: System.Web.UI.ActiveControls
Inheritance: TViewStateDiff »
TStyleDiff
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | getCombinedStyle | all the style properties combined.
P | getCssClassDiff | changes to the CSS class name.
 | getDifference | list of changes to the control style and CSS class name.
P | getStyleDiff | list of changes to the control style.
P | getStyleFromString | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TStyleSheet

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TStyleSheet
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | MediaType | string | media type of the CSS (such as 'print', 'screen', etc.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StyleSheetUrl | string | URL to the stylesheet file.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers the stylesheet file and content to be rendered.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSubMap

Namespace: System.Data.SqlMap.Configuration
Inheritance: TComponent »
TSubMap
Properties | Events | Methods | Derived classes | All classes
Properties
Name | Type | Description
ResultMapping | string | The result map to use when the Value matches the discriminator column value.
Value | string | value for comparison with discriminator column value.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TSystemException

Namespace: System.Exceptions
Inheritance: TException »
TSystemException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
  • TConfigurationException
  • TDbException
  • THttpException
  • TIOException
  • TInvalidDataTypeException
  • TInvalidDataValueException
  • TInvalidOperationException
  • TNotSupportedException
  • TPhpErrorException
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTabPanel

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTabPanel
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | ActiveTabCssClass | string | CSS class for the active tab.
R | ActiveTabStyle | TStyle | the style for the active tab div.
 | ActiveView | TTabView | Returns the currently active view.
 | ActiveViewID | string | Returns the ID of the active tab view.
 | ActiveViewIndex | integer | Returns the index of the active tab view.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientOptions | array | the options for JavaScript.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | CSS class for the whole tab control div.
 | CssUrl | string | URL for the CSS file including all relevant CSS class definitions.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabCssClass | string | CSS class for non-active tabs.
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
R | TabStyle | TStyle | the style for all the inactive tab div.
RP | TagName | string | tag name for the control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ViewCssClass | string | CSS class for the currently displayed view div.
R | ViewStyle | TStyle | the style for all the view div.
R | Views | TTabViewCollection | list of TTabView controls.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers CSS and JS.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | activateView | Activates the specified view.
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds object parsed from template to the control.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls .
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
P | registerClientScript | Registers the relevant JavaScript.
 | registerObject | Registers an object by a name. (inherited from TControl)
P | registerStyleSheet | Registers the CSS relevant to the TTabControl.
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the tab control.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTabView

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTabView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Active | boolean | whether this tab view is active.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Caption | string | the caption displayed on this tab.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | NavigateUrl | string | the URL of the target page.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | the | tag name for the view element.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content displayed on this view.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the tab view.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | renderTab | Renders the tab associated with the tab view.
P | renderTabContent | Renders the content in the tab.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTabViewCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList » TControlCollection »
TTabViewCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TControl | the control that owns this collection. (inherited from TControlCollection)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Overrides the parent implementation by invoking clearNamingContainer. (inherited from TControlCollection)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
findIndexByID | Finds the index of the tab view whose ID is the same as the one being looked for.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TControlCollection)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTable

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTable
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BackImageUrl | string | the URL of the background image for the table.
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | Caption | string | table caption.
 | CaptionAlign | TTableCaptionAlign | table caption alignment.
 | CellPadding | integer | the cellpadding for the table.
 | CellSpacing | integer | the cellspacing for the table.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
 | GridLines | TTableGridLines | the grid line setting of the table.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the table content.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Rows | TTableRowCollection | list of TTableRow controls.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name for the table.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds object parsed from template to the control.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls .
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the table control which will render table caption if present.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableCaptionAlign

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTableCaptionAlign
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableCell

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTableCell
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | ColumnSpan | integer | the columnspan for the table cell, 0 if not set.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the table cell.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | RowSpan | integer | the rowspan for the table cell, 0 if not set.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name for the table cell.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the table cell.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a table cell.
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table cell.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TTableHeaderCell
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableCellCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList » TControlCollection »
TTableCellCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TControl | the control that owns this collection. (inherited from TControlCollection)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Overrides the parent implementation by invoking clearNamingContainer. (inherited from TControlCollection)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TControlCollection)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableFooterRow

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTableRow »
TTableFooterRow
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | Cells | TTableCellCollection | list of TTableCell controls. (inherited from TTableRow)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TableSection | string | location of a row in a table.
RP | TagName | string | tag name for the table. (inherited from TTableRow)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TTableRow)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TTableRow)
P | createStyle | Creates a style object for the control. (inherited from TTableRow)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table row . (inherited from TTableRow)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableGateway

Namespace: System.Data.DataGateway
Inheritance: TComponent »
TTableGateway
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
RP | Command | TDataGatewayCommand | command builder and executor.
R | DbConnection | TDbConnection | database connection.
R | LastInsertId | mixed | last insert id, null if none is found.
 | TableInfo | {unknown} | .
 | TableName | {unknown} | .
Events
Name | Description
OnCreateCommand | Raised when a command is prepared and parameter binding is completed.
OnExecuteCommand | Raised when a command is executed and the result from the database was returned.
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | count | Find the number of records.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | deleteAll | Delete records from the table with condition given by $where and binding values specified by $parameter argument.
 | deleteAllByPks | Alias for deleteByPk().
 | deleteByPk | Delete records by primary key.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | find | Find one single record that matches the criteria.
 | findAll | Accepts same parameters as find(), but returns TDbDataReader instead.
 | findAllByPks | Similar to findByPk(), but returns TDbDataReader instead.
 | findAllBySql | Execute arbituary sql command with binding parameters.
 | findByPk | Find one record using only the primary key or composite primary keys.
 | findBySql | Execute arbituary sql command with binding parameters.
P | getCriteria | Create a new TSqlCriteria object from a string $criteria.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initCommandBuilder | .
 | insert | Inserts a new record into the table.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | update | Updates the table with new name-value pair $data.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableGridLines

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTableGridLines
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableHeaderCell

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTableCell »
TTableHeaderCell
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AbbreviatedText | string | the abbr attribute of the HTML th element.
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CategoryText | string | the axis attribute of the HTML th element.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | ColumnSpan | integer | the columnspan for the table cell, 0 if not set. (inherited from TTableCell)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the table cell. (inherited from TTableCell)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableCell)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | RowSpan | integer | the rowspan for the table cell, 0 if not set. (inherited from TTableCell)
 | Scope | TTableHeaderScope | the scope of the cells that the header cell applies to.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name for the table header cell.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the table cell. (inherited from TTableCell)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableCell)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a table cell. (inherited from TTableCell)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attributes to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object for the control. (inherited from TTableCell)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table cell. (inherited from TTableCell)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableHeaderRow

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTableRow »
TTableHeaderRow
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | Cells | TTableCellCollection | list of TTableCell controls. (inherited from TTableRow)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TableSection | string | location of a row in a table.
RP | TagName | string | tag name for the table. (inherited from TTableRow)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'. (inherited from TTableRow)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds object parsed from template to the control. (inherited from TTableRow)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TTableRow)
P | createStyle | Creates a style object for the control. (inherited from TTableRow)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table row . (inherited from TTableRow)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableHeaderScope

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTableHeaderScope
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableItemStyle

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TStyle »
TTableItemStyle
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | BackColor | string | the background color of the control. (inherited from TStyle)
 | BorderColor | string | the border color of the control. (inherited from TStyle)
 | BorderStyle | string | the border style of the control. (inherited from TStyle)
 | BorderWidth | string | the border width of the control. (inherited from TStyle)
 | CssClass | string | the CSS class of the control. (inherited from TStyle)
 | CustomStyle | string | the custom style of the control. (inherited from TStyle)
 | DisplayStyle | TDisplayStyle | display style. (inherited from TStyle)
R | Font | TFont | the font of the control. (inherited from TStyle)
 | ForeColor | string | the foreground color of the control. (inherited from TStyle)
 | Height | string | the height of the control. (inherited from TStyle)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the contents within the table item, defaults to THorizontalAlign::NotSet.
R | StyleFields | array | list of style fields. (inherited from TStyle)
 | VerticalAlign | TVerticalAlign | the vertical alignment of the contents within the table item, defaults to TVerticalAlign::NotSet.
 | Width | string | the width of the control. (inherited from TStyle)
 | Wrap | boolean | whether the content wraps within the table item.
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clearStyleField | Clears a single style field value; . (inherited from TStyle)
copyFrom | Copies the fields in a new style to this style.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getStyleField | a single style field value set via setStyleField. (inherited from TStyle)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasCssClass | true if CSS is set or empty. (inherited from TStyle)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasFont | true if font is set. (inherited from TStyle)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
hasStyleField | whether a style field has been defined by setStyleField. (inherited from TStyle)
mergeWith | Merges the style with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Sets the style attributes to default values.
setStyleField | Sets a single style field value. (inherited from TStyle)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableRow

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTableRow
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | Cells | TTableCellCollection | list of TTableCell controls.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | HorizontalAlign | string | the horizontal alignment of the contents within the table item, defaults to 'NotSet'.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TableSection | TTableRowSection | location of a row in a table.
RP | TagName | string | tag name for the table.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | VerticalAlign | string | the vertical alignment of the contents within the table item, defaults to 'NotSet'.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds object parsed from template to the control.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls .
P | createStyle | Creates a style object for the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body contents of the table row .
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TDataGridItem
  • TTableFooterRow
  • TTableHeaderRow
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableRowCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList » TControlCollection »
TTableRowCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TControl | the control that owns this collection. (inherited from TControlCollection)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Overrides the parent implementation by invoking clearNamingContainer. (inherited from TControlCollection)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TControlCollection)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableRowSection

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTableRowSection
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTableStyle

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TStyle »
TTableStyle
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | BackColor | string | the background color of the control. (inherited from TStyle)
 | BackImageUrl | string | the URL of the background image for the table.
 | BorderCollapse | boolean | whether the table borders should be collapsed.
 | BorderColor | string | the border color of the control. (inherited from TStyle)
 | BorderStyle | string | the border style of the control. (inherited from TStyle)
 | BorderWidth | string | the border width of the control. (inherited from TStyle)
 | CellPadding | integer | cellpadding of the table.
 | CellSpacing | integer | cellspacing of the table.
 | CssClass | string | the CSS class of the control. (inherited from TStyle)
 | CustomStyle | string | the custom style of the control. (inherited from TStyle)
 | DisplayStyle | TDisplayStyle | display style. (inherited from TStyle)
R | Font | TFont | the font of the control. (inherited from TStyle)
 | ForeColor | string | the foreground color of the control. (inherited from TStyle)
 | GridLines | TTableGridLines | the grid line setting of the table.
 | Height | string | the height of the control. (inherited from TStyle)
 | HorizontalAlign | THorizontalAlign | the horizontal alignment of the contents within the table, defaults to THorizontalAlign::NotSet.
R | StyleFields | array | list of style fields. (inherited from TStyle)
 | Width | string | the width of the control. (inherited from TStyle)
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer.
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clearStyleField | Clears a single style field value; . (inherited from TStyle)
copyFrom | Copies the fields in a new style to this style.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getStyleField | a single style field value set via setStyleField. (inherited from TStyle)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasCssClass | true if CSS is set or empty. (inherited from TStyle)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasFont | true if font is set. (inherited from TStyle)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
hasStyleField | whether a style field has been defined by setStyleField. (inherited from TStyle)
mergeWith | Merges the style with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Sets the style attributes to default values.
setStyleField | Sets a single style field value. (inherited from TStyle)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTarFileExtractor

Namespace: System.IO
TTarFileExtractor
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
P | _dirCheck | Check if a directory exists and create it (including parent dirs) if not.
P | _error | .
P | _extractList | .
P | _translateWinPath | .
 | extract | .
P | extractModify | This method extract all the content of the archive in the directory indicated by $p_path.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTemplate

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent »
TTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | ContextPath | string | context directory path.
R | Directive | array | name-value pairs declared in the directive.
R | HashCode | string | hash code that can be used to identify the template.
R | IncludedFiles | array | list of included external template files.
R | IsSourceTemplate | boolean | whether this template is a source template, i.
R | Items | array | the parsed template.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | TemplateFile | string | template file path if available, null otherwise.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | configureComponent | Configures a property of a non-control component.
P | configureControl | Configures a property/event of a control.
P | configureEvent | Configures an event for a control.
P | configureProperty | Configures a simple property for a component.
P | configureSubProperty | Configures a subproperty for a component.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | handleException | Handles template parsing exception.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | instantiateIn | Instantiates the template.
P | parse | Parses a template string.
P | parseAttribute | Parses a single attribute.
P | parseAttributes | Parses the attributes of a tag from a string.
P | parseTemplateProperty | .
P | preprocess | Preprocesses the template string by including external templates .
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | validateAttributes | .
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTemplateColumn

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TDataGridColumn »
TTemplateColumn
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | AllowSorting | boolean | Returns a value indicating whether this column allows sorting. (inherited from TDataGridColumn)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | EditItemRenderer | string | the class name for the edit item cell renderer.
 | EditItemTemplate | ITemplate | the edit item template.
 | EnableCellGrouping | boolean | whether cells having the same content should be grouped together. (inherited from TDataGridColumn)
 | FooterRenderer | string | the class name for the column footer cell renderer. (inherited from TDataGridColumn)
R | FooterStyle | TTableItemStyle | the style for footer. (inherited from TDataGridColumn)
 | FooterTemplate | ITemplate | the footer template.
 | FooterText | string | the text to be displayed in the footer of this column. (inherited from TDataGridColumn)
 | HeaderImageUrl | string | the url of the image to be displayed in header. (inherited from TDataGridColumn)
 | HeaderRenderer | string | the class name for the column header cell renderer. (inherited from TDataGridColumn)
R | HeaderStyle | TTableItemStyle | the style for header. (inherited from TDataGridColumn)
 | HeaderTemplate | ITemplate | the header template.
 | HeaderText | string | the text to be displayed in the header of this column. (inherited from TDataGridColumn)
 | ID | string | the ID of the column. (inherited from TDataGridColumn)
 | ItemRenderer | string | the class name for the item cell renderer.
R | ItemStyle | TTableItemStyle | the style for item. (inherited from TDataGridColumn)
 | ItemTemplate | ITemplate | the item template.
 | Owner | TDataGrid | datagrid that owns this column. (inherited from TDataGridColumn)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SortExpression | string | the name of the field or expression for sorting. (inherited from TDataGridColumn)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether the column is visible. (inherited from TDataGridColumn)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBindColumn | Databinds a cell in the column.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
P | formatDataValue | Formats the text value according to a format string. (inherited from TDataGridColumn)
P | getDataFieldValue | Fetches the value of the data at the specified field. (inherited from TDataGridColumn)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getViewState | Returns a viewstate value. (inherited from TDataGridColumn)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | initialize | Initializes the column. (inherited from TDataGridColumn)
 | initializeCell | Initializes the specified cell to its initial values.
P | initializeFooterCell | Initializes the footer cell. (inherited from TDataGridColumn)
P | initializeHeaderCell | Initializes the header cell. (inherited from TDataGridColumn)
 | loadState | Loads persistent state values. (inherited from TDataGridColumn)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveState | Saves persistent state values. (inherited from TDataGridColumn)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setViewState | Sets a viewstate value. (inherited from TDataGridColumn)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTemplateControl

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TControl » TCompositeControl »
TTemplateControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | IsSourceTemplateControl | boolean | whether this control is a source template control.
R | Master | TTemplateControl|null | master control associated with this control, null if none.
 | MasterClass | string | master class name (in namespace form).
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Template | ITemplate|null | Returns the template object associated with this control object.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | TemplateDirectory | string | the directory containing the template.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the OnInit step for the control and all its child controls.
 | injectContent | Injects all content controls (and their children) to the corresponding content placeholders.
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | loadTemplate | Loads the template associated with this control class.
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerContent | Registers a content control.
 | registerContentPlaceHolder | Registers a content placeholder to this template control.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TDataRenderer
  • TPage
  • TScaffoldBase
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTemplateException

Namespace: System.Exceptions
Inheritance: TException » TSystemException » TConfigurationException »
TTemplateException
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | getCode | . (inherited from Exception)
 | getErrorCode | error code. (inherited from TException)
 | getErrorMessage | error message. (inherited from TException)
P | getErrorMessageFile | path to the error message file. (inherited from TException)
 | getFile | . (inherited from Exception)
 | getLine | . (inherited from Exception)
 | getLineNumber | the line number at which the template has error.
 | getMessage | . (inherited from Exception)
 | getPrevious | . (inherited from Exception)
 | getTemplateFile | the template file that causes the exception.
 | getTemplateSource | the template source code that causes the exception.
 | getTrace | . (inherited from Exception)
 | getTraceAsString | . (inherited from Exception)
 | setErrorCode | . (inherited from TException)
P | setErrorMessage | . (inherited from TException)
 | setLineNumber | .
 | setTemplateFile | .
 | setTemplateSource | .
P | translateErrorMessage | Translates an error code into an error message. (inherited from TException)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTemplateManager

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TModule »
TTemplateManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getLocalizedTemplate | Finds a localized template file.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getTemplateByClassName | Loads the template corresponding to the specified class name.
 | getTemplateByFileName | Loads the template from the specified file.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the module.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTemplatedWizardStep

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TView » TWizardStep »
TTemplatedWizardStep
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Active | boolean | whether this view is active. (inherited from TView)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowReturn | boolean | whether this step can be re-visited. (inherited from TWizardStep)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | ContentTemplate | ITemplate | the template for the content of the wizard step.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
R | NavigationContainer | TWizardNavigationContainer | the control containing the navigation.
 | NavigationTemplate | ITemplate | the template for displaying the navigation UI of a wizard step.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StepType | TWizardStepType | the wizard step type. (inherited from TWizardStep)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Title | string | the title for this step. (inherited from TWizardStep)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether this view is visible. (inherited from TView)
 | Wizard | TWizard | the wizard owning this step. (inherited from TWizardStep)
Events
Name | Description
OnActivate | Raises OnActivate event. (inherited from TView)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDeactivate | Raises OnDeactivate event. (inherited from TView)
OnInit | Ensures child controls are created.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
 | instantiateNavigationTemplate | Instantiates the navigation template if any.
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextAlign

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTextAlign
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextBox

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTextBox
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoCompleteType | TTextBoxAutoCompleteType | the AutoComplete type of the textbox.
 | AutoPostBack | boolean | a value indicating whether an automatic postback to the server will occur whenever the user modifies the text in the TTextBox control and then tabs out of the component.
 | AutoTrim | boolean | a value indicating whether the input text should be trimmed spaces.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
 | CausesValidation | boolean | whether postback event trigger by this text box will cause input validation, default is true.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | Gets the name of the javascript class responsible for performing postback for this control.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | Columns | integer | the display width of the text box in characters, default is 0 meaning not set.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Data | string | Returns the text content of the TTextBox control.
R | DataChanged | boolean | Returns a value indicating whether postback has caused the control data change.
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableClientScript | boolean | whether to render javascript.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | IsValid | bool | Returns true if this control validated successfully.
 | MaxLength | integer | the maximum number of characters allowed in the text box, default is 0 meaning not set.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PersistPassword | boolean | whether password should be displayed in the textbox during postback.
RP | PostBackOptions | array | Gets the post back options for this textbox.
 | ReadOnly | boolean | whether the textbox is read only, default is false.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | Rows | integer | the number of rows displayed in a multiline text box, default is 4.
R | SafeText | string | safe text content with javascript stripped off.
RP | SafeTextParser | mixed | safe text parser.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name of the textbox.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text content of the TTextBox control.
 | TextMode | TTextBoxMode | the behavior mode of the TTextBox component.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group of validators which the text box causes validation upon postback.
R | ValidationPropertyValue | mixed | Returns the value to be validated.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
 | Wrap | boolean | whether the text content wraps within a multiline text box.
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnTextChanged | Raises OnTextChanged event.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
 | loadPostData | Loads user input data.
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | raisePostDataChangedEvent | Raises postdata changed event.
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders an additional line-break after the opening tag when it is in MultiLine text mode.
 | renderChildren | Renders the children of the control. (inherited from TControl)
P | renderClientControlScript | Renders the javascript for textbox.
 | renderContents | Renders the body content of the textbox when it is in MultiLine text mode.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TActiveTextBox
  • TColorPicker
  • TDatePicker
  • THtmlArea
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextBoxAutoCompleteType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTextBoxAutoCompleteType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextBoxMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTextBoxMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextHighlighter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl » TTextProcessor »
TTextHighlighter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableCopyCode | boolean | true will show "Copy Code" link.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
RP | HeaderTemplate | string | header template with "Copy code" link.
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | Language | string | language whose syntax is to be used for highlighting.
 | LineNumberStyle | TTextHighlighterLineNumberStyle | style of row number, Table by default.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowLineNumbers | boolean | whether to show line numbers in the highlighted result.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
 | TabSize | integer | tab size.
RP | TagName | string | tag name of the panel.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | text to be processed. (inherited from TTextProcessor)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | Registers css style for the highlighted result.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | HTML-decodes static text. (inherited from TTextProcessor)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | processText | Processes a text string.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
P | registerStyleSheet | Registers the stylesheet for presentation.
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body content. (inherited from TTextProcessor)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TMarkdown
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextHighlighterLineNumberStyle

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TTextHighlighterLineNumberStyle
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextProcessor

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TTextProcessor
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | text to be processed.
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | HTML-decodes static text.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | processText | Processes a text string.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders body content.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TTextHighlighter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTextWriter

Namespace: System.IO
Inheritance: TComponent »
TTextWriter
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
flush | Flushes the content that has been written.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
write | Writes a string.
writeLine | Writers a string and terminates it with a newline.
Derived classes
  • TCallbackResponseWriter
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTheme

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent »
TTheme
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | BasePath | string | the file path to the theme folder.
 | BaseUrl | string | the URL to the theme folder (without ending slash).
 | JavaScriptFiles | array | list of Javascript files (URL) in the theme.
 | Name | string | theme name.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | Skins | array | list of skins for the theme.
 | StyleSheetFiles | array | list of CSS files (URL) in the theme.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
applySkin | Applies the theme to a particular control.
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TThemeManager

Namespace: System.Web.UI
Inheritance: TComponent » TApplicationComponent » TModule »
TThemeManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | AvailableThemes | array | list of available theme names.
 | BasePath | string | the base path for all themes.
 | BaseUrl | string | the base URL for all themes.
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
getTheme | the theme retrieved.
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the module.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTimeTriggeredCallback

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TCallback »
TTimeTriggeredCallback
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ActiveControl | TBaseActiveCallbackControl | standard callback options. (inherited from TCallback)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for TTimeTriggeredCallback.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options. (inherited from TCallback)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | Interval | float | seconds between callback requests.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StartTimerOnLoad | boolean | true to start the timer when page loads.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
RP | TriggerOptions | array | list of timer options for client-side.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested. (inherited from TCallback)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event. (inherited from TCallback)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Registers the javascript code for initializing the active control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | startTimer | Registers the javascript code to start the timer.
 | stopTimer | Registers the javascript code to stop the timer.
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTranslate

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TControl » TI18NControl »
TTranslate
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | Catalogue | string | Get the message catalogue.
 | Charset | string | Gets the charset. (inherited from TI18NControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | Culture | string | Get the specific culture for this control. (inherited from TI18NControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | Key | string | Get the key for message lookup.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parameters | TAttributeCollection | Returns the list of custom parameters.
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Text | string | the text to be localized/translated.
 | Trim | boolean | Trim the content or not.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getParameter | parameter value, null if parameter does not exist.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasParameter | whether the named parameter exists.
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removeParameter | Removes the named parameter.
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | renders the translated string.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setParameter | .
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | translateText | Translates the text with subsititution.
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TChoiceFormat
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTranslateParameter

Namespace: System.I18N
Inheritance: TComponent » TApplicationComponent » TControl »
TTranslateParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | Key | string | Get the parameter substitution key.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parameter | string | parameter contents.
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Trim | boolean | Trim the content or not.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Value | {unknown} | .
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TTriggeredCallback

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TCallback »
TTriggeredCallback
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ActiveControl | TBaseActiveCallbackControl | standard callback options. (inherited from TCallback)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options. (inherited from TCallback)
 | ControlID | string | The ID of the server control the trigger is bounded to.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TargetControl | string | target control client ID or html element ID if control is not found in hierarchy.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
RP | TriggerOptions | array | list of trigger callback options.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested. (inherited from TCallback)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event. (inherited from TCallback)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TEventTriggeredCallback
  • TValueTriggeredCallback
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUpdateMappedStatement

Namespace: System.Data.SqlMap.Statements
Inheritance: TComponent » TMappedStatement »
TUpdateMappedStatement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Command | TPreparedCommand | command to prepare SQL statements. (inherited from TMappedStatement)
R | ID | string | Name used to identify the TMappedStatement amongst the others. (inherited from TMappedStatement)
R | Manager | TSqlMapper | The SqlMap used by this MappedStatement. (inherited from TMappedStatement)
R | SqlString | {unknown} | . (inherited from TMappedStatement)
R | Statement | TSqlMapStatement | The SQL statment used by this MappedStatement. (inherited from TMappedStatement)
Events
Name | Description
OnExecuteQuery | Raise the execute query event. (inherited from TMappedStatement)
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addResultMapGroupBy | ResultMap with GroupBy property. (inherited from TMappedStatement)
P | applyResultMap | Apply result mapping. (inherited from TMappedStatement)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | enquequePostSelect | Add nested result property to post select queue. (inherited from TMappedStatement)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | executeInsert | .
P | executePostSelect | Process 'select' result properties . (inherited from TMappedStatement)
 | executeQueryForList | .
 | executeQueryForMap | .
 | executeQueryForObject | .
P | executeSQLQueryLimit | Execute SQL Query with limits. (inherited from TMappedStatement)
P | executeSelectKey | Execute the select key statement, used to obtain last insert ID. (inherited from TMappedStatement)
 | executeUpdate | Execute an update statement. (inherited from TMappedStatement)
P | fillArrayResultMap | Retrieve the result map as an array. (inherited from TMappedStatement)
P | fillDefaultResultMap | Fill the result map using default settings. (inherited from TMappedStatement)
P | fillPropertyWithResultMap | Fills the property with result mapping results. (inherited from TMappedStatement)
P | fillResultArrayList | Apply the result to a TList or an array. (inherited from TMappedStatement)
P | fillResultClass | Fill the result using ResultClass, will creates new result object if required. (inherited from TMappedStatement)
P | fillResultMap | Fills the result object according to result mappings. (inherited from TMappedStatement)
P | fillResultObjectProperty | Apply the result to an object. (inherited from TMappedStatement)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPostGeneratedSelectKey | Gets the inserted row ID after executing an insert statement. (inherited from TMappedStatement)
P | getPostSelectKeys | Finds in the post select property the SQL statement primary selection keys. (inherited from TMappedStatement)
P | getPreGeneratedSelectKey | Gets the insert generated ID before executing an insert statement. (inherited from TMappedStatement)
P | getResultMapGroupKey | Gets the result 'group by' groupping key for each row. (inherited from TMappedStatement)
P | getScalarResult | Converts the first array value to scalar value of given type. (inherited from TMappedStatement)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initialGroupByResults | Empty the group by results cache. (inherited from TMappedStatement)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | raiseRowDelegate | Raises delegate handler. (inherited from TMappedStatement)
 | runQueryForList | Executes the SQL and retuns a List of result objects. (inherited from TMappedStatement)
 | runQueryForMap | Executes the SQL and retuns all rows selected in a map that is keyed on the property named in the keyProperty parameter. (inherited from TMappedStatement)
 | runQueryForObject | Executes an SQL statement that returns a single row as an object of the type of the $result passed in as a parameter. (inherited from TMappedStatement)
P | setObjectProperty | Set a property of the result object with appropriate value. (inherited from TMappedStatement)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TDeleteMappedStatement
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUri

Namespace: System.Web
Inheritance: TComponent »
TUri
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Fragment | string | fragment of the URI.
R | Host | string | hostname of the URI.
R | Password | string | password of the URI.
R | Path | string | path of the URI.
R | Port | integer | port number of the URI.
R | Query | string | query string of the URI.
R | Scheme | string | scheme of the URI, such as 'http', 'https', 'ftp', etc.
R | Uri | string | URI.
R | User | string | username of the URI.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUrlManager

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent » TModule »
TUrlManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
constructUrl | Constructs a URL that can be recognized by PRADO.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the module. (inherited from TModule)
parseUrl | Parses the request URL and returns an array of input parameters.
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TUrlMapping
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUrlMapping

Namespace: System.Web
Inheritance: TComponent » TApplicationComponent » TModule » TUrlManager »
TUrlMapping
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ConfigFile | string | external configuration file.
 | DefaultMappingClass | string | the default class of URL mapping patterns.
 | EnableCustomUrl | boolean | Returns a value indicating whether to enable custom constructUrl.
 | ID | string | id of this module. (inherited from TModule)
R | MatchingPattern | TUrlMappingPattern | the matched pattern, null if not found.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | UrlPrefix | string | the part that will be prefixed to the constructed URLs.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | constructUrl | Constructs a URL that can be recognized by PRADO.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
P | loadConfigFile | Initialize the module from configuration file.
P | loadUrlMappings | Load and configure each url mapping pattern.
 | parseUrl | Parses the request URL and returns an array of input parameters.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUrlMappingPattern

Namespace: System.Web
Inheritance: TComponent »
TUrlMappingPattern
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | CaseSensitive | boolean | whether the Pattern should be treated as case sensititve.
 | EnableCustomUrl | boolean | Returns a value indicating whether to use this pattern to construct URL.
R | IsWildCardPattern | boolean | whether this pattern is a wildcard pattern @since 3.
R | Manager | TUrlManager | the URL manager instance.
RP | ParameterizedPattern | string | Substitute the parameter key value pairs as named groupings in the regular expression matching pattern.
 | Parameters | TAttributeCollection | parameter key value pairs.
 | Pattern | string | url pattern to match.
 | RegularExpression | string | full regular expression mapping pattern.
 | ServiceID | string | service id.
 | ServiceParameter | string | service parameter, such as page class name.
 | UrlFormat | THttpRequestUrlFormat | the format of URLs.
 | UrlParamSeparator | string | separator used to separate GET variable name and value when URL format is Path.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
constructUrl | Constructs a URL using this pattern.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getPatternMatches | Uses URL pattern (or full regular expression if available) to match the given url path.
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
init | Initializes the pattern.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
supportCustomUrl | whether this pattern IS the one for constructing the URL with the specified GET items.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUser

Namespace: System.Security
Inheritance: TComponent »
TUser
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | IsGuest | boolean | if the user is a guest, defaults to true.
R | Manager | IUserManager | user manager.
 | Name | string | username, defaults to empty string.
 | Roles | array | list of roles that the user is of.
 | StateChanged | boolean | whether user session state is changed (i.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getState | Returns the value of a variable that is stored in user session.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | isInRole | whether the user is of this role.
 | loadFromString | the user object.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveToString | user data that is serialized and will be stored in session.
P | setState | Stores a variable in user session.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TDbUser
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUserManager

Namespace: System.Security
Inheritance: TComponent » TApplicationComponent » TModule »
TUserManager
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | GuestName | string | guest name, defaults to 'Guest'.
 | ID | string | id of this module. (inherited from TModule)
 | PasswordMode | TUserManagerPasswordMode | how password is stored, clear text, or MD5 or SHA1 hashed.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Roles | array | Returns an array of user role information.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | TUser | Returns a user instance given the user name.
 | UserFile | string | the full path to the file storing user/role information.
R | Users | array | Returns an array of all users.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getUserFromCookie | Returns a user instance according to auth data stored in a cookie.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes the module.
P | loadUserData | Loads user/role information from an XML node.
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | saveUserToCookie | Saves user auth data into a cookie.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | switchToGuest | Sets a user as a guest.
 | validateUser | Validates if the username and password are correct.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TUserManagerPasswordMode

Namespace: System.Security
Inheritance: TEnumerable »
TUserManagerPasswordMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidationCompareOperator

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TValidationCompareOperator
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidationDataType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TValidationDataType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
  • TRangeValidationDataType
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidationSummary

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TValidationSummary
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | AutoUpdate | boolean | Gets the auto-update for this summary.
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
RP | ClientScriptOptions | array | Get a list of options for the client-side javascript validation summary.
R | ClientSide | TClientSideValidationSummaryOptions | client-side validation summary event options.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TValidationSummaryDisplayStyle | the style of displaying the error messages.
 | DisplayMode | TValidationSummaryDisplayMode | the mode of displaying error messages.
 | EnableClientScript | boolean | whether the TValidationSummary component updates itself using client-side script.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
RP | ErrorMessages | array | Get the list of validation error messages.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
 | HeaderText | string | the header text displayed at the top of the summary.
 | Height | string | the height of the control. (inherited from TWebControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
 | ScrollToSummary | boolean | whether scroll summary into viewport or not.
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowAnchor | boolean | whether the validation summary should be anchored.
 | ShowMessageBox | boolean | whether the validation summary is displayed in a message box.
 | ShowSummary | boolean | whether the validation summary is displayed inline.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | Returns the tag name used for this control. (inherited from TWebControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | ValidationGroup | string | the group which this validator belongs to.
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | .
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createClientScript | javascript validation summary event options.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TWebControl)
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
P | renderBulletList | Render the validation summary as a bullet list.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Overrides parent implementation by rendering TValidationSummary-specific presentation.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | renderHeaderOnly | Render the validation summary header text only.
P | renderJsSummary | Render the javascript for validation summary.
P | renderList | Render the validation summary as a simple list.
P | renderSingleParagraph | Render the validation summary as a paragraph.
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidationSummaryDisplayMode

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TValidationSummaryDisplayMode
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidationSummaryDisplayStyle

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TValidationSummaryDisplayStyle
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidatorClientSide

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TClientSideOptions »
TValidatorClientSide
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | ObserveChanges | boolean | true to observe changes.
 | OnValidate | string | javascript code for client-side OnValidate event.
 | OnValidationError | string | javascript code for client-side OnError event.
 | OnValidationSuccess | string | javascript code for client-side OnSuccess event.
R | Options | TMap | gets the list of options as TMap. (inherited from TClientSideOptions)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
P | ensureFunction | Ensure that the javascript statements are wrapped in a javascript function block as function(sender, parameter){ //code }. (inherited from TClientSideOptions)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getOption | gets a particular option, null if not set. (inherited from TClientSideOptions)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
P | setFunction | Adds on client-side event handler by wrapping the code within a javascript function block. (inherited from TClientSideOptions)
P | setOption | . (inherited from TClientSideOptions)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValidatorDisplayStyle

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TValidatorDisplayStyle
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TValueTriggeredCallback

Namespace: System.Web.UI.ActiveControls
Inheritance: TComponent » TApplicationComponent » TControl » TCallback » TTriggeredCallback »
TValueTriggeredCallback
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | ActiveControl | TBaseActiveCallbackControl | standard callback options. (inherited from TCallback)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
RP | ClientClassName | string | corresponding javascript class name for TEventTriggeredCallback.
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
R | ClientSide | TCallbackClientSide | client side request options. (inherited from TCallback)
 | ControlID | string | The ID of the server control the trigger is bounded to. (inherited from TTriggeredCallback)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DecayRate | float | Gets the decay rate between callbacks.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
 | Interval | float | polling interval, 1 second default.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PropertyName | string | The control property name to observe value changes.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
RP | TargetControl | string | target control client ID or html element ID if control is not found in hierarchy. (inherited from TTriggeredCallback)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
RP | TriggerOptions | array | list of timer options for client-side.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnCallback | This method is invoked when a callback is requested. (inherited from TCallback)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseCallbackEvent | Raises the callback event. (inherited from TCallback)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Registers the javascript code for initializing the active control.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TVarDumper

Namespace: System.Util
TVarDumper
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
S | dump | Converts a variable into a string representation.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TVerticalAlign

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TVerticalAlign
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TView

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TView
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Active | boolean | whether this view is active.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether this view is visible.
Events
Name | Description
OnActivate | Raises OnActivate event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDeactivate | Raises OnDeactivate event.
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TWizardStep
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TViewCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList » TControlCollection »
TViewCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TControl | the control that owns this collection. (inherited from TControlCollection)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Overrides the parent implementation by invoking clearNamingContainer. (inherited from TControlCollection)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position. (inherited from TControlCollection)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TViewStateDiff

Namespace: System.Web.UI.ActiveControls
TViewStateDiff
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
getDifference | view state changes, nullObject if no difference.
Derived classes
  • TMapCollectionDiff
  • TScalarDiff
  • TStyleDiff
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWebControl

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TWebControl
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control.
 | BorderColor | string | the border color of the control.
 | BorderStyle | string | the border style of the control.
 | BorderWidth | string | the border width of the control.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control.
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | Font | TFont | the font of the control.
 | ForeColor | string | the foreground color of the control.
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information.
 | Height | string | the height of the control.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | Style | TStyle | the object representing the css style of the control.
 | TabIndex | integer | the tab index of the control.
RP | TagName | string | Returns the tag name used for this control.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control.
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer.
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data.
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control.
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createStyle | Creates a style object to be used by the control.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control.
 | renderBeginTag | Renders the openning tag for the control (including attributes) .
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag.
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control .
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TButton
  • TCheckBox
  • TClientScriptLoader
  • TDataBoundControl
  • TDataListItem
  • TFileUpload
  • THtmlElement
  • THyperLink
  • TImage
  • TInlineFrame
  • TJavascriptLogger
  • TKeyboard
  • TLabel
  • TLinkButton
  • TPager
  • TPanel
  • TSlider
  • TTabPanel
  • TTabView
  • TTable
  • TTableCell
  • TTableRow
  • TTextBox
  • TTextProcessor
  • TValidationSummary
  • TWizard
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWebControlAdapter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControlAdapter »
TWebControlAdapter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Control | TControl | the control to which this adapter is attached. (inherited from TControlAdapter)
R | Page | TPage | the page that contains the attached control. (inherited from TControlAdapter)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Name | Description
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControlAdapter)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControlAdapter)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControlAdapter)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControlAdapter)
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createChildControls | Creates child controls for the attached control. (inherited from TControlAdapter)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
loadState | Loads additional persistent control state. (inherited from TControlAdapter)
publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
raiseEvent | Raises an event. (inherited from TComponent)
render | Renders the control to which the adapter is attached.
renderBeginTag | Renders the openning tag for the attached control.
renderChildren | Renders the control's children. (inherited from TControlAdapter)
renderContents | Renders the body contents within the attached control tag.
renderEndTag | Renders the closing tag for the attached control.
saveState | Saves additional persistent control state. (inherited from TControlAdapter)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizard

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TWebControl »
TWizard
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | AccessKey | string | the access key of the control. (inherited from TWebControl)
 | ActiveStep | TWizardStep | the currently active wizard step.
 | ActiveStepIndex | integer | the zero-based index of the active wizard step.
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | BackColor | string | the background color of the control. (inherited from TWebControl)
 | BorderColor | string | the border color of the control. (inherited from TWebControl)
 | BorderStyle | string | the border style of the control. (inherited from TWebControl)
 | BorderWidth | string | the border width of the control. (inherited from TWebControl)
R | CancelButtonStyle | TWizardNavigationButtonStyle | the style for the cancel button.
 | CancelDestinationUrl | string | the URL that the browser will be redirected to if the cancel button in the wizard is clicked.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CssClass | string | the css class of the control. (inherited from TWebControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | Display | TDisplayStyle | display style of the control, default is TDisplayStyle::Fixed. (inherited from TWebControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | FinishCompleteButtonStyle | TWizardNavigationButtonStyle | the style for the complete button in the finish wizard step.
 | FinishDestinationUrl | string | the URL that the browser will be redirected to if the wizard finishes.
R | FinishNavigation | TWizardNavigationContainer | container of the finish navigation.
 | FinishNavigationTemplate | ITemplate | navigation template for the finish step.
R | FinishPreviousButtonStyle | TWizardNavigationButtonStyle | the style for the previous button in the start wizard step.
R | Font | TFont | the font of the control. (inherited from TWebControl)
 | ForeColor | string | the foreground color of the control. (inherited from TWebControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
R | HasStyle | boolean | whether the control has defined any style information. (inherited from TWebControl)
R | Header | TPanel | container of the wizard header.
R | HeaderStyle | TPanelStyle | the style for the header.
 | HeaderTemplate | ITemplate | template for wizard header.
 | HeaderText | string | header text.
 | Height | string | the height of the control. (inherited from TWebControl)
RP | History | TStack | history containing step indexes that were navigated before.
 | ID | string | Returns the id of the control. (inherited from TControl)
R | MultiView | TMultiView | Returns the multiview that holds the wizard steps.
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
R | NavigationButtonStyle | TStyle | the style common for all navigation buttons.
R | NavigationStyle | TPanelStyle | the style for the navigation panel.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | ShowCancelButton | boolean | whether to display a cancel button in each wizard step.
 | ShowSideBar | boolean | whether to display a side bar that contains links to wizard steps.
R | SideBar | TPanel | container of the wizard side bar.
R | SideBarButtonStyle | TStyle | the style for the buttons displayed in the side bar.
R | SideBarStyle | TPanelStyle | the style for the side bar.
 | SideBarTemplate | ITemplate | template for the side bar.
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
R | StartNavigation | TWizardNavigationContainer | container of the start navigation.
 | StartNavigationTemplate | ITemplate | navigation template for the start step.
R | StartNextButtonStyle | TWizardNavigationButtonStyle | the style for the next button in the start wizard step.
R | StepContent | TPanel | container of the wizard step content.
R | StepNavigation | TWizardNavigationContainer | container of the step navigation.
 | StepNavigationTemplate | ITemplate | navigation template for internal steps.
R | StepNextButtonStyle | TWizardNavigationButtonStyle | the style for the next button in each internal wizard step.
R | StepPreviousButtonStyle | TWizardNavigationButtonStyle | the style for the previous button in the start wizard step.
R | StepStyle | TPanelStyle | the style for each internal wizard step.
 | Style | TStyle | the object representing the css style of the control. (inherited from TWebControl)
 | TabIndex | integer | the tab index of the control. (inherited from TWebControl)
RP | TagName | string | tag name for the wizard.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | ToolTip | string | the tooltip of the control. (inherited from TWebControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
 | UseDefaultLayout | boolean | whether to use default layout to arrange side bar and the rest wizard components.
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
 | Width | string | the width of the control. (inherited from TWebControl)
R | WizardSteps | TWizardStepCollection | collection of wizard steps.
Events
Name | Description
OnActiveStepChanged | Raises OnActiveStepChanged event.
OnCancelButtonClick | Raises OnCancelButtonClick event.
OnCompleteButtonClick | Raises OnCompleteButtonClick event.
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | Creates the child controls of the wizard.
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnNextButtonClick | Raises OnNextButtonClick event.
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnPreviousButtonClick | Raises OnPreviousButtonClick event.
OnSideBarButtonClick | Raises OnSideBarButtonClick event.
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
P | addAttributesToRender | Adds attribute name-value pairs to renderer. (inherited from TWebControl)
 | addParsedObject | Adds TWizardStep objects into step collection.
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | addedWizardStep | Adds a wizard step to the multiview.
P | allowNavigationToPreviousStep | whether navigation to the previous step is allowed.
P | allowNavigationToStep | whether navigation to the specified step is allowed.
P | applyControlProperties | Applies various properties to the components of wizard.
P | applyHeaderProperties | Applies properties to the wizard header.
P | applyNavigationProperties | Apply properties to various navigation panels.
P | applySideBarProperties | Applies properties to the wizard sidebar.
P | applyStepContentProperties | Applies properties to the wizard step content.
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | Handles bubbled events.
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearStyle | Removes all style data. (inherited from TWebControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | copyBaseAttributes | Copies basic control attributes from another control. (inherited from TWebControl)
 | createChildControls | Creates child controls within the wizard.
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
P | createFinishNavigation | Creates finish navigation panel.
P | createHeader | Creates the wizard header.
P | createNavigation | Creates navigation panel.
P | createSideBar | Creates the wizard side bar.
P | createStartNavigation | Creates start navigation panel.
P | createStepContent | Creates wizard step content.
P | createStepNavigation | Creates step navigation panel.
P | createStyle | Creates a style object to be used by the control. (inherited from TWebControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | dataListItemCommand | Event handler for sidebar datalist's OnItemCommand event.
 | dataListItemDataBound | Event handler for sidebar datalist's OnItemDataBound event.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
P | getPreviousStepIndex | Determines the index of the previous step based on history.
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
P | getStepType | Determines the type of the specified wizard step.
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | removedWizardStep | Removes a wizard step from the multiview.
 | render | Renders the wizard.
 | renderBeginTag | Renders the openning tag for the control (including attributes) . (inherited from TWebControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderContents | Renders the body content enclosed between the control tag. (inherited from TWebControl)
 | renderControl | Renders the control. (inherited from TControl)
 | renderEndTag | Renders the closing tag for the control . (inherited from TWebControl)
P | requiresControlsRecreation | Indicates the wizard needs to recreate all child controls.
P | reset | Clears up everything within the wizard.
 | saveState | Saves the current active step index into history.
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
 | wizardStepsChanged | Updates the sidebar datalist if any.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardFinishNavigationTemplate

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TWizardNavigationTemplate »
TWizardFinishNavigationTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Wizard | TWizard | the wizard owning this template. (inherited from TWizardNavigationTemplate)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createNavigationButton | Creates a navigation button. (inherited from TWizardNavigationTemplate)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | instantiateIn | Instantiates the template.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardNavigationButtonStyle

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TStyle »
TWizardNavigationButtonStyle
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | BackColor | string | the background color of the control. (inherited from TStyle)
 | BorderColor | string | the border color of the control. (inherited from TStyle)
 | BorderStyle | string | the border style of the control. (inherited from TStyle)
 | BorderWidth | string | the border width of the control. (inherited from TStyle)
 | ButtonText | string | button caption.
 | ButtonType | TWizardNavigationButtonType | button type.
 | CssClass | string | the CSS class of the control. (inherited from TStyle)
 | CustomStyle | string | the custom style of the control. (inherited from TStyle)
 | DisplayStyle | TDisplayStyle | display style. (inherited from TStyle)
R | Font | TFont | the font of the control. (inherited from TStyle)
 | ForeColor | string | the foreground color of the control. (inherited from TStyle)
 | Height | string | the height of the control. (inherited from TStyle)
 | ImageUrl | string | image URL for the image button.
R | StyleFields | array | list of style fields. (inherited from TStyle)
 | Width | string | the width of the control. (inherited from TStyle)
Events
Methods
Name | Description
addAttributesToRender | Adds attributes related to CSS styles to renderer. (inherited from TStyle)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
apply | Applies this style to the specified button .
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clearStyleField | Clears a single style field value; . (inherited from TStyle)
copyFrom | Copies the fields in a new style to this style.
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getStyleField | a single style field value set via setStyleField. (inherited from TStyle)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasCssClass | true if CSS is set or empty. (inherited from TStyle)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasFont | true if font is set. (inherited from TStyle)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
hasStyleField | whether a style field has been defined by setStyleField. (inherited from TStyle)
mergeWith | Merges the style with a new one.
raiseEvent | Raises an event. (inherited from TComponent)
reset | Sets the style attributes to default values.
setStyleField | Sets a single style field value. (inherited from TStyle)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardNavigationButtonType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TWizardNavigationButtonType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardNavigationContainer

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TWizardNavigationContainer
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
 | CancelButton | mixed | the cancel button.
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
 | CompleteButton | mixed | the complete button.
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | NextButton | mixed | the next button.
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
 | PreviousButton | mixed | the previous button.
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardNavigationEventParameter

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TEventParameter »
TWizardNavigationEventParameter
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | CancelNavigation | boolean | whether navigation to the next step should be canceled.
R | CurrentStepIndex | integer | the zero-based index of the currently active step.
 | NextStepIndex | integer | the zero-based index of the next step.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardNavigationTemplate

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TWizardNavigationTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Wizard | TWizard | the wizard owning this template.
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createNavigationButton | Creates a navigation button.
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | instantiateIn | Instantiates the template.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
  • TWizardFinishNavigationTemplate
  • TWizardStartNavigationTemplate
  • TWizardStepNavigationTemplate
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardSideBarListItemTemplate

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TWizardSideBarListItemTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
instantiateIn | Instantiates the template.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardSideBarTemplate

Namespace: System.Web.UI.WebControls
Inheritance: TComponent »
TWizardSideBarTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
instantiateIn | Instantiates the template.
raiseEvent | Raises an event. (inherited from TComponent)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardStartNavigationTemplate

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TWizardNavigationTemplate »
TWizardStartNavigationTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Wizard | TWizard | the wizard owning this template. (inherited from TWizardNavigationTemplate)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createNavigationButton | Creates a navigation button. (inherited from TWizardNavigationTemplate)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | instantiateIn | Instantiates the template.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardStep

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl » TView »
TWizardStep
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Active | boolean | whether this view is active. (inherited from TView)
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
 | AllowReturn | boolean | whether this step can be re-visited.
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | StepType | TWizardStepType | the wizard step type.
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | Title | string | the title for this step.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | whether this view is visible. (inherited from TView)
 | Wizard | TWizard | the wizard owning this step.
Events
Name | Description
OnActivate | Raises OnActivate event. (inherited from TView)
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnDeactivate | Raises OnDeactivate event. (inherited from TView)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Renders the control. (inherited from TControl)
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
  • TCompleteWizardStep
  • TTemplatedWizardStep
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardStepCollection

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TList »
TWizardStepCollection
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardStepNavigationTemplate

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TWizardNavigationTemplate »
TWizardStepNavigationTemplate
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Wizard | TWizard | the wizard owning this template. (inherited from TWizardNavigationTemplate)
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | createNavigationButton | Creates a navigation button. (inherited from TWizardNavigationTemplate)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | instantiateIn | Instantiates the template.
 | raiseEvent | Raises an event. (inherited from TComponent)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TWizardStepType

Namespace: System.Web.UI.WebControls
Inheritance: TEnumerable »
TWizardStepType
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TXCache

Namespace: System.Caching
Inheritance: TComponent » TApplicationComponent » TModule » TCache »
TXCache
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
 | ID | string | id of this module. (inherited from TModule)
 | KeyPrefix | string | a unique prefix for the keys of cached values. (inherited from TCache)
 | PrimaryCache | boolean | whether this cache module is used as primary/system cache. (inherited from TCache)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
Events
Methods
 | Name | Description
 | add | Stores a value identified by a key into cache if the cache does not contain this key. (inherited from TCache)
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
P | addValue | Stores a value identified by a key into cache if the cache does not contain this key.
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | delete | Deletes a value with the specified key from cache . (inherited from TCache)
P | deleteValue | Deletes a value with the specified key from cache This is the implementation of the method declared in the parent class.
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | flush | Deletes all values from cache.
P | generateUniqueKey | a key generated from the provided key which ensures the uniqueness across applications. (inherited from TCache)
 | get | Retrieves a value from cache with a specified key. (inherited from TCache)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
P | getValue | Retrieves a value from cache with a specified key.
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
 | init | Initializes this module.
 | offsetExists | Returns whether there is a cache entry with a specified key. (inherited from TCache)
 | offsetGet | . (inherited from TCache)
 | offsetSet | . (inherited from TCache)
 | offsetUnset | . (inherited from TCache)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | set | Stores a value identified by a key into cache. (inherited from TCache)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
P | setValue | Stores a value identified by a key in cache.
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TXmlDocument

Namespace: System.Xml
Inheritance: TComponent » TXmlElement »
TXmlDocument
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Attributes | TMap | list of attributes. (inherited from TXmlElement)
R | Elements | TXmlElementList | list of child elements. (inherited from TXmlElement)
 | Encoding | string | encoding of this XML document.
R | HasAttribute | boolean | true if this element has attributes. (inherited from TXmlElement)
R | HasElement | boolean | true if this element has child elements. (inherited from TXmlElement)
 | Parent | TXmlElement | parent element of this element. (inherited from TXmlElement)
 | TagName | string | tag-name of this element. (inherited from TXmlElement)
 | Value | string | text enclosed between opening and closing tag of this element. (inherited from TXmlElement)
 | Version | string | version of this XML document.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getAttribute | the attribute specified by the name, null if no such attribute. (inherited from TXmlElement)
getElementByTagName | the first child element that has the specified tag-name, null if not found. (inherited from TXmlElement)
getElementsByTagName | list of all child elements that have the specified tag-name. (inherited from TXmlElement)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
loadFromFile | Loads and parses an XML document.
loadFromString | Loads and parses an XML string.
raiseEvent | Raises an event. (inherited from TComponent)
saveToFile | Saves this XML document as an XML file.
saveToString | Saves this XML document as an XML string .
setAttribute | . (inherited from TXmlElement)
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toString | string representation of this element. (inherited from TXmlElement)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TXmlElement

Namespace: System.Xml
Inheritance: TComponent »
TXmlElement
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Attributes | TMap | list of attributes.
R | Elements | TXmlElementList | list of child elements.
R | HasAttribute | boolean | true if this element has attributes.
R | HasElement | boolean | true if this element has child elements.
 | Parent | TXmlElement | parent element of this element.
 | TagName | string | tag-name of this element.
 | Value | string | text enclosed between opening and closing tag of this element.
Events
Methods
Name | Description
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getAttribute | the attribute specified by the name, null if no such attribute.
getElementByTagName | the first child element that has the specified tag-name, null if not found.
getElementsByTagName | list of all child elements that have the specified tag-name.
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
raiseEvent | Raises an event. (inherited from TComponent)
setAttribute | .
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toString | string representation of this element.
Derived classes
  • TXmlDocument
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TXmlElementList

Namespace: System.Xml
Inheritance: TComponent » TList »
TXmlElementList
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
R | Count | integer | the number of items in the list. (inherited from TList)
R | Iterator | Iterator | Returns an iterator for traversing the items in the list. (inherited from TList)
RP | Owner | TXmlElement | owner of this list.
 | ReadOnly | boolean | whether this list is read-only or not. (inherited from TList)
Events
Methods
Name | Description
add | Appends an item at the end of the list. (inherited from TList)
addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
canGetProperty | Determines whether a property can be read. (inherited from TComponent)
canSetProperty | Determines whether a property can be set. (inherited from TComponent)
clear | Removes all items in the list. (inherited from TList)
contains | whether the list contains the item. (inherited from TList)
copyFrom | Copies iterable data into the list. (inherited from TList)
count | Returns the number of items in the list. (inherited from TList)
createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
getSubProperty | Evaluates a property path. (inherited from TComponent)
hasEvent | Determines whether an event is defined. (inherited from TComponent)
hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
hasProperty | Determines whether a property is defined. (inherited from TComponent)
indexOf | the index of the item in the list (0 based), -1 if not found. (inherited from TList)
insertAt | Inserts an item at the specified position.
itemAt | Returns the item at the specified offset. (inherited from TList)
mergeWith | Merges iterable data into the map. (inherited from TList)
offsetExists | Returns whether there is an item at the specified offset. (inherited from TList)
offsetGet | Returns the item at the specified offset. (inherited from TList)
offsetSet | Sets the item at the specified offset. (inherited from TList)
offsetUnset | Unsets the item at the specified offset. (inherited from TList)
raiseEvent | Raises an event. (inherited from TComponent)
remove | Removes an item from the list. (inherited from TList)
removeAt | Removes an item at the specified position.
setSubProperty | Sets a value to a property path. (inherited from TComponent)
toArray | the list of items in array. (inherited from TList)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of TXmlTransform

Namespace: System.Web.UI.WebControls
Inheritance: TComponent » TApplicationComponent » TControl »
TXmlTransform
Properties | Events | Methods | Derived classes | All classes
Properties
 | Name | Type | Description
 | Adapter | TControlAdapter | control adapter. (inherited from TControl)
R | AllowChildControls | boolean | whether body contents are allowed for this control. (inherited from TControl)
R | Application | TApplication | current application instance. (inherited from TApplicationComponent)
R | Attributes | TAttributeCollection | Returns the list of custom attributes. (inherited from TControl)
P | ChildControlsCreated | boolean | whether child controls have been created. (inherited from TControl)
R | ClientID | string | Returns the client ID of the control. (inherited from TControl)
P | ControlStage | integer | Gets the lifecycle step the control is currently at. (inherited from TControl)
R | Controls | TControlCollection | the child control collection. (inherited from TControl)
 | CustomData | mixed | Returns custom data associated with this control. (inherited from TControl)
 | DocumentContent | string | XML data.
 | DocumentPath | string | The path to the XML document.
 | EnableTheming | boolean | whether theming is enabled for this control. (inherited from TControl)
 | EnableViewState | boolean | whether viewstate is enabled. (inherited from TControl)
 | Enabled | boolean | Returns a value indicating whether the control is enabled. (inherited from TControl)
R | HasAdapter | boolean | whether there is an adapter for this control. (inherited from TControl)
R | HasAttributes | boolean | whether the control has custom attributes. (inherited from TControl)
R | HasChildInitialized | boolean | true if the child control has been initialized. (inherited from TControl)
R | HasControls | boolean | whether the control has child controls. (inherited from TControl)
R | HasInitialized | boolean | true if the onInit event has raised. (inherited from TControl)
R | HasLoaded | boolean | true if the onLoad event has raised. (inherited from TControl)
R | HasLoadedPostData | boolean | true if the control has loaded post data. (inherited from TControl)
R | HasPreRendered | boolean | true if onPreRender event has raised. (inherited from TControl)
 | ID | string | Returns the id of the control. (inherited from TControl)
R | NamingContainer | TControl | the naming container of this control. (inherited from TControl)
 | Page | TPage | the page that contains this control. (inherited from TControl)
R | Parameters | TAttributeCollection | Returns the list of parameters to be applied to the transform.
R | Parent | TControl | the parent of this control. (inherited from TControl)
R | Request | THttpRequest | the current user request. (inherited from TApplicationComponent)
R | Response | THttpResponse | the response. (inherited from TApplicationComponent)
R | Service | IService | the current service. (inherited from TApplicationComponent)
R | Session | THttpSession | user session. (inherited from TApplicationComponent)
 | SkinID | string | the skin ID of this control, '' if not set. (inherited from TControl)
R | SourceTemplateControl | TTemplateControl | the control whose template is loaded from some external storage, such as file, db, and whose template ultimately contains this control. (inherited from TControl)
 | TemplateControl | TTemplateControl | the control whose template contains this control. (inherited from TControl)
 | TransformContent | string | XML style sheet as string.
 | TransformPath | string | The path to the XML style sheet.
R | UniqueID | string | Returns a unique ID that identifies the control in the page hierarchy. (inherited from TControl)
R | User | IUser | information about the current user. (inherited from TApplicationComponent)
 | Visible | boolean | Checks if a control is visible. (inherited from TControl)
Events
Name | Description
OnDataBinding | Raises 'OnDataBinding' event. (inherited from TControl)
OnInit | This method is invoked when the control enters 'OnInit' stage. (inherited from TControl)
OnLoad | This method is invoked when the control enters 'OnLoad' stage. (inherited from TControl)
OnPreRender | This method is invoked when the control enters 'OnPreRender' stage. (inherited from TControl)
OnUnload | This method is invoked when the control enters 'OnUnload' stage. (inherited from TControl)
Methods
 | Name | Description
 | addParsedObject | Adds the object instantiated on a template to the child control collection. (inherited from TControl)
P | addToPostDataLoader | Add controls implementing IPostBackDataHandler to post data loaders. (inherited from TControl)
 | addedControl | Adds a control into the child collection of the control. (inherited from TControl)
 | applyStyleSheetSkin | Applies a stylesheet skin to a control. (inherited from TControl)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | autoBindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
P | autoDataBindProperties | Auto databinding properties of the control. (inherited from TControl)
 | bindProperty | Sets up the binding between a property (or property path) and an expression. (inherited from TControl)
 | broadcastEvent | Broadcasts an event. (inherited from TControl)
 | bubbleEvent | This method responds to a bubbled event. (inherited from TControl)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
P | clearChildState | Clears up the child state data. (inherited from TControl)
P | clearControlState | Clears a controlstate value. (inherited from TControl)
 | clearNamingContainer | Resets the control as a naming container. (inherited from TControl)
 | clearViewState | Clears a viewstate value. (inherited from TControl)
S | convertUniqueIdToClientId | Converts a unique ID to a client ID. (inherited from TControl)
 | createChildControls | Creates child controls. (inherited from TControl)
P | createControlCollection | Creates a control collection object that is to be used to hold child controls . (inherited from TControl)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | dataBind | Performs the databinding for this control. (inherited from TControl)
P | dataBindChildren | Databinding child controls. (inherited from TControl)
P | dataBindProperties | Databinding properties of the control. (inherited from TControl)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | ensureChildControls | Ensures child controls are created. (inherited from TControl)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
 | findControl | Finds a control by ID path within the current naming container. (inherited from TControl)
 | findControlsByID | Finds all child and grand-child controls with the specified ID. (inherited from TControl)
 | findControlsByType | Finds all child and grand-child controls that are of the specified type. (inherited from TControl)
 | focus | Sets input focus to this control. (inherited from TControl)
 | getAttribute | attribute value, null if attribute does not exist. (inherited from TControl)
P | getControlState | Returns a controlstate value. (inherited from TControl)
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getRegisteredObject | Returns the named registered object. (inherited from TControl)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | getViewState | Returns a viewstate value. (inherited from TControl)
 | hasAttribute | whether the named attribute exists. (inherited from TControl)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
P | initRecursive | Performs the Init step for the control and all its child controls. (inherited from TControl)
P | isDescendentOf | if the control is a descendent (parent, parent of parent, etc. (inherited from TControl)
 | isObjectRegistered | whether an object has been registered with the name @see registerObject. (inherited from TControl)
P | loadRecursive | Performs the Load step for the control and all its child controls. (inherited from TControl)
 | loadState | This method is invoked right after the control has loaded its state. (inherited from TControl)
P | loadStateRecursive | Loads state (viewstate and controlstate) into a control and its children. (inherited from TControl)
P | preRenderRecursive | Performs the PreRender step for the control and all its child controls. (inherited from TControl)
 | publishAsset | Publishes a private asset and gets its URL. (inherited from TApplicationComponent)
 | publishFilePath | Publishes a file or directory and returns its URL. (inherited from TApplicationComponent)
P | raiseBubbleEvent | Invokes the parent's bubbleEvent method. (inherited from TControl)
 | raiseEvent | Raises an event. (inherited from TComponent)
 | registerObject | Registers an object by a name. (inherited from TControl)
 | removeAttribute | Removes the named attribute. (inherited from TControl)
 | removedControl | Removes a control from the child collection of the control. (inherited from TControl)
 | render | Performs XSL transformation and render the output.
 | renderChildren | Renders the children of the control. (inherited from TControl)
 | renderControl | Renders the control. (inherited from TControl)
 | saveState | This method is invoked when control state is to be saved. (inherited from TControl)
P | saveStateRecursive | Saves all control state (viewstate and controlstate) as a collection. (inherited from TControl)
 | setAttribute | Sets a custom control attribute. (inherited from TControl)
P | setControlState | Sets a controlstate value. (inherited from TControl)
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
 | setViewState | Sets a viewstate value. (inherited from TControl)
 | trackViewState | Sets a value indicating whether we should keep data in viewstate. (inherited from TControl)
P | traverseChildControls | Traverse the whole control hierarchy rooted at this control. (inherited from TControl)
 | unbindProperty | Breaks the binding between a property (or property path) and an expression. (inherited from TControl)
P | unloadRecursive | Performs the Unload step for the control and all its child controls. (inherited from TControl)
 | unregisterObject | Unregisters an object by name. (inherited from TControl)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO - Documentation of Translation

Namespace: System.I18N
Inheritance: TComponent »
Translation
Properties | Events | Methods | Derived classes | All classes
Properties
Events
Methods
 | Name | Description
 | addParsedObject | Processes an object that is created during parsing template. (inherited from TComponent)
 | attachEventHandler | Attaches an event handler to an event. (inherited from TComponent)
 | canGetProperty | Determines whether a property can be read. (inherited from TComponent)
 | canSetProperty | Determines whether a property can be set. (inherited from TComponent)
 | createdOnTemplate | This method is invoked after the component is instantiated by a template. (inherited from TComponent)
 | detachEventHandler | Detaches an existing event handler. (inherited from TComponent)
 | evaluateExpression | Evaluates a PHP expression in the context of this control. (inherited from TComponent)
 | evaluateStatements | Evaluates a list of PHP statements. (inherited from TComponent)
S | formatter | Get the static formatter from this component.
 | getEventHandlers | Returns the list of attached event handlers for an event. (inherited from TComponent)
 | getSubProperty | Evaluates a property path. (inherited from TComponent)
 | hasEvent | Determines whether an event is defined. (inherited from TComponent)
 | hasEventHandler | whether an event has been attached one or several handlers. (inherited from TComponent)
 | hasProperty | Determines whether a property is defined. (inherited from TComponent)
S | init | Initialize the TTranslate translation components.
 | raiseEvent | Raises an event. (inherited from TComponent)
S | saveMessages | Save untranslated messages to the catalogue.
 | setSubProperty | Sets a value to a property path. (inherited from TComponent)
Derived classes
Copyright © 2006 by the PRADO Group.


PRADO API Manual: Todo List

Todo List

System.Web

TAssetManager::copyDirectory()

  • a generic solution to ignore certain directories and files

System.Data.Common

TDbCommandBuilder::getSelectFieldList()

  • add support for quoting of column aliasing
  • add support for table aliasing

System.Util

TDbLogRoute::createDbTable()

  • create sequence for PostgreSQL

System.Data.SqlMap.Configuration

TSqlMapXmlMappingConfiguration::loadProcedureTag()

  • Implement loading procedure

TSqlMapXmlMappingConfiguration::prepareSql()

  • Extend to dynamic sql.


PRADO API Manual: Docs for page interfaces.php

Classes:

IModule
IModule interface.
IService
IService interface.
ITextWriter
ITextWriter interface.
IUser
IUser interface.
IStatePersister
IStatePersister class.
ICache
ICache interface.
ICacheDependency
ICacheDependency interface.
IRenderable
IRenderable interface.
IBindable
IBindable interface.
IStyleable
IStyleable interface.
IActiveControl
IActiveControl interface.
ICallbackEventHandler
ICallbackEventHandler interface.
IDataRenderer
IDataRenderer interface.

Page Details:

Core interfaces essential for TApplication class.

Tags:

version: | $Id: interfaces.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page prado.php

Classes:

Prado
Defines Prado class if not defined.

Page Details:

Prado bootstrap file.

This file is intended to be included in the entry script of Prado applications. It defines Prado class by extending PradoBase, a static class providing globally available functionalities that enable PRADO component model and error handling mechanism.

By including this file, the PHP error and exception handlers are set as PRADO handlers, and an __autoload function is provided that automatically loads a class file if the class is not defined.

Tags:

version: | $Id: prado.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>

Includes:

require_once(dirname(__FILE__).'/PradoBase.php') [line 24]
Includes the PradoBase class file

require_once(dirname(__FILE__).'/TApplication.php') [line 52]
Includes TApplication class file

require_once(dirname(__FILE__).'/TShellApplication.php') [line 57]
Includes TShellApplication class file

Copyright © 2006 by Prado Software Group.


PRADO API Manual: Docs for page PradoBase.php

Classes:

PradoBase
PradoBase class.
TReflectionClass
TReflectionClass class.

Page Details:

PradoBase class file.

This is the file that establishes the PRADO component model and error handling mechanism.

Tags:

version: | $Id: PradoBase.php 2782 2010-02-22 12:03:50Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2010 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>

PRADO_CHMOD [line 25]

PRADO_CHMOD = 0777
Defines the default permission for writable directories and files

[ Top ]

PRADO_DIR [line 20]

PRADO_DIR = dirname(__FILE__)
Defines the PRADO framework installation path.

[ Top ]


PRADO API Manual: Docs for page TApplication.php

Classes:

TApplication
TApplication class.
TApplicationMode
TApplicationMode class.
TApplicationConfiguration
TApplicationConfiguration class.
TApplicationStatePersister
TApplicationStatePersister class.

Page Details:

TApplication class file

Tags:

version: | $Id: TApplication.php 2704 2009-09-15 08:23:47Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>

Includes:

require_once(PRADO_DIR.'/interfaces.php') [line 16]
Includes core interfaces essential for TApplication class


PRADO API Manual: Docs for page TApplicationComponent.php

Classes:

TApplicationComponent
TApplicationComponent class

Page Details:

TApplicationComponent class

Tags:

version: | $Id: TApplicationComponent.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TComponent.php

Classes:

TComponent
TComponent class
TEnumerable
TEnumerable class.
TPropertyValue
TPropertyValue class
TEventParameter
TEventParameter class.
TComponentReflection
TComponentReflection class.

Page Details:

TComponent, TPropertyValue classes

Tags:

version: | $Id: TComponent.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TModule.php

Classes:

TModule
TModule class.

Page Details:

TModule class file.

Tags:

version: | $Id: TModule.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TService.php

Classes:

TService
TService class.

Page Details:

TService class file.

Tags:

version: | $Id: TService.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TShellApplication.php

Classes:

TShellApplication
TShellApplication class.

Page Details:

TShellApplication class file

Tags:

version: | $Id: TShellApplication.php 2751 2010-01-14 10:14:21Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TAPCCache.php

Classes:

TAPCCache
TAPCCache class

Page Details:

TAPCCache class file

Tags:

version: | $Id: TAPCCache.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Alban Hanry <compte_messagerie@hotmail.com>


PRADO API Manual: Docs for page TCache.php

Classes:

TCache
TCache class
TCacheDependency
TCacheDependency class.
TFileCacheDependency
TFileCacheDependency class.
TDirectoryCacheDependency
TDirectoryCacheDependency class.
TGlobalStateCacheDependency
TGlobalStateCacheDependency class.
TChainedCacheDependency
TChainedCacheDependency class.
TApplicationStateCacheDependency
TApplicationStateCacheDependency class.
TCacheDependencyList
TCacheDependencyList class.

Page Details:

TCache and cache dependency classes.

Tags:

version: | $Id: TCache.php 2513 2008-10-13 10:46:23Z carl $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDbCache.php

Classes:

TDbCache
TDbCache class

Page Details:

TDbCache class file

Tags:

version: | $Id: TDbCache.php 2741 2009-11-08 09:59:34Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TMemCache.php

Classes:

TMemCache
TMemCache class

Page Details:

TMemCache class file

Tags:

license: | http://www.pradosoft.com/license/
version: | $Id: TMemCache.php 2541 2008-10-21 15:05:13Z qiang.xue $
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>
author: | Carl G. Mathisen <carlgmathisen@gmail.com>


PRADO API Manual: Docs for page TSqliteCache.php

Classes:

TSqliteCache
TSqliteCache class

Page Details:

TSqliteCache class file

Tags:

version: | $Id: TSqliteCache.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TXCache.php

Classes:

TXCache
TXCache class

Page Details:

TXCache class file

Tags:

version: | $Id: TXCache.php 1994 2007-06-11 16:02:28Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TAttributeCollection.php

Classes:

TAttributeCollection
TAttributeCollection class

Page Details:

TAttributeCollection classes

Tags:

version: | $Id: TAttributeCollection.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDummyDataSource.php

Classes:

TDummyDataSource
TDummyDataSource class
TDummyDataSourceIterator
TDummyDataSourceIterator class

Page Details:

TDummyDataSource, TDummyDataSourceIterator classes

Tags:

version: | $Id: TDummyDataSource.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TList.php

Classes:

TList
TList class
TListIterator
TListIterator class

Page Details:

TList, TListIterator classes

Tags:

version: | $Id: TList.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TMap.php

Classes:

TMap
TMap class
TMapIterator
TMapIterator class

Page Details:

TMap, TMapIterator classes

Tags:

version: | $Id: TMap.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TPagedDataSource.php

Classes:

TPagedDataSource
TPagedDataSource class
TPagedListIterator
TPagedListIterator class
TPagedMapIterator
TPagedMapIterator class

Page Details:

TPagedDataSource, TPagedListIterator, TPagedMapIterator classes

Tags:

version: | $Id: TPagedDataSource.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TPagedList.php

Classes:

TPagedList
TPagedList class
TPagedListPageChangedEventParameter
TPagedListPageChangedEventParameter class.
TPagedListFetchDataEventParameter
TPagedListFetchDataEventParameter class.

Page Details:

TPagedList, TPagedListFetchDataEventParameter, TPagedListPageChangedEventParameter class file

Tags:

version: | $Id: TPagedList.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TQueue.php

Classes:

TQueue
TQueue class
TQueueIterator
TQueueIterator class

Page Details:

TQueue, TQueueIterator classes

Tags:

version: | $Id$
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TStack.php

Classes:

TStack
TStack class
TStackIterator
TStackIterator class

Page Details:

TStack, TStackIterator classes

Tags:

version: | $Id: TStack.php 2625 2009-03-19 22:07:39Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDataSourceConfig.php

Classes:

TDataSourceConfig
TDataSourceConfig module class provides <module> configuration for database connections.

Page Details:

TDataSourceConfig class file.

Tags:

version: | $Id: TDataSourceConfig.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TDbCommand.php

Classes:

TDbCommand
TDbCommand class.

Page Details:

TDbCommand class file

Tags:

version: | $Id: TDbCommand.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDbConnection.php

Classes:

TDbConnection
TDbConnection class
TDbColumnCaseMode
TDbColumnCaseMode
TDbNullConversionMode
TDbNullConversionMode

Page Details:

TDbConnection class file

Tags:

version: | $Id: TDbConnection.php 2760 2010-02-08 07:19:50Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDbDataReader.php

Classes:

TDbDataReader
TDbDataReader class.

Page Details:

TDbDataReader class file

Tags:

version: | $Id: TDbDataReader.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDbTransaction.php

Classes:

TDbTransaction
TDbTransaction class.

Page Details:

TDbTransaction class file

Tags:

version: | $Id: TDbTransaction.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TActiveRecordException.php

Classes:

TActiveRecordException
Base exception class for Active Records.
TActiveRecordConfigurationException
Base exception class for Active Records.

Page Details:

TActiveRecordException class file.

Tags:

version: | $Id: TActiveRecordException.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveRecord.php

Classes:

TActiveRecord
Base class for active records.
TActiveRecordChangeEventParameter
TActiveRecordChangeEventParameter class
TActiveRecordInvalidFinderResult
TActiveRecordInvalidFinderResult class.

Page Details:

TActiveRecord, TActiveRecordEventParameter, TActiveRecordInvalidFinderResult class file.

Tags:

version: | $Id: TActiveRecord.php 2649 2009-05-11 07:44:55Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveRecordConfig.php

Classes:

TActiveRecordConfig
TActiveRecordConfig module configuration class.

Page Details:

TActiveRecordConfig class file.

Tags:

version: | $Id: TActiveRecordConfig.php 2648 2009-05-10 10:51:52Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveRecordCriteria.php

Classes:

TActiveRecordCriteria
Search criteria for Active Record.

Page Details:

TActiveRecordCriteria class file.

Tags:

version: | $Id: TActiveRecordCriteria.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveRecordGateway.php

Classes:

TActiveRecordGateway
TActiveRecordGateway excutes the SQL command queries and returns the data record as arrays (for most finder methods).

Page Details:

TActiveRecordGateway, TActiveRecordStatementType, TActiveRecordEventParameter classes file.

Tags:

version: | $Id: TActiveRecordGateway.php 2618 2009-03-16 10:41:42Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveRecordManager.php

Classes:

TActiveRecordManager
TActiveRecordManager provides the default DB connection, default active record gateway, and table meta data inspector.

Page Details:

TActiveRecordManager class file.

Tags:

version: | $Id: TActiveRecordManager.php 2648 2009-05-10 10:51:52Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveRecordBelongsTo.php

Classes:

TActiveRecordBelongsTo
Implements the foreign key relationship (TActiveRecord::BELONGS_TO) between the source objects and the related foreign object. Consider the entity relationship between a Team and a Player.

Page Details:

TActiveRecordBelongsTo class file.

Tags:

version: | $Id$
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveRecordHasMany.php

Classes:

TActiveRecordHasMany
Implements TActiveRecord::HAS_MANY relationship between the source object having zero or more foreign objects. Consider the entity relationship between a Team and a Player.

Page Details:

TActiveRecordHasMany class file.

Tags:

version: | $Id$
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveRecordHasManyAssociation.php

Classes:

TActiveRecordHasManyAssociation
Implements the M-N (many to many) relationship via association table.

Page Details:

TActiveRecordHasManyAssociation class file.

Tags:

version: | $Id$
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveRecordHasOne.php

Classes:

TActiveRecordHasOne
TActiveRecordHasOne models the object relationship that a record (the source object) property is an instance of foreign record object having a foreign key related to the source object. The HAS_ONE relation is very similar to the HAS_MANY relationship (in fact, it is equivalent in the entities relationship point of view).

Page Details:

TActiveRecordHasOne class file.

Tags:

version: | $Id$
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveRecordRelation.php

Classes:

TActiveRecordRelation
Base class for active record relationships.

Page Details:

TActiveRecordRelation class file.

Tags:

version: | $Id$
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveRecordRelationContext.php

Classes:

TActiveRecordRelationContext
TActiveRecordRelationContext holds information regarding record relationships such as record relation property name, query criteria and foreign object record class names.

Page Details:

TActiveRecordRelationContext class.

Tags:

version: | $Id$
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TScaffoldBase.php

Classes:

TScaffoldBase
Base class for Active Record scaffold views.

Page Details:

TScaffoldBase class file.

Tags:

version: | $Id: TScaffoldBase.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TScaffoldEditView.php

Classes:

TScaffoldEditView
Template control for editing an Active Record instance.
IScaffoldEditRenderer
IScaffoldEditRenderer interface.

Page Details:

TScaffoldEditView class and IScaffoldEditRenderer interface file.

Tags:

version: | $Id: TScaffoldEditView.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TScaffoldListView.php

Classes:

TScaffoldListView
TScaffoldListView displays a list of Active Records.

Page Details:

TScaffoldListView class file.

Tags:

version: | $Id: TScaffoldListView.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TScaffoldSearch.php

Classes:

TScaffoldSearch
TScaffoldSearch provide a simple textbox and a button that is used to perform search on a TScaffoldListView with ID given by setListViewID.

Page Details:

TScaffoldSearch class file.

Tags:

version: | $Id$
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TScaffoldView.php

Classes:

TScaffoldView
TScaffoldView is a composite control consisting of TScaffoldListView

Page Details:

TScaffoldView class.

Tags:

version: | $Id: TScaffoldView.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TIbmScaffoldInput.php

Classes:

TIbmScaffoldInput
TIbmScaffoldInput class file.

Page Details:


PRADO API Manual: Docs for page TMssqlScaffoldInput.php

Classes:

TMssqlScaffoldInput
TMssqlScaffoldInput class file.

Page Details:


PRADO API Manual: Docs for page TMysqlScaffoldInput.php

Classes:

TMysqlScaffoldInput
TMysqlScaffoldInput class file.

Page Details:


PRADO API Manual: Docs for page TPgsqlScaffoldInput.php

Classes:

TPgsqlScaffoldInput
TPgsqlScaffoldInput class file.

Page Details:


PRADO API Manual: Docs for page TScaffoldInputBase.php

Classes:

TScaffoldInputBase
TScaffoldInputBase class file.

Page Details:


PRADO API Manual: Docs for page TScaffoldInputCommon.php

Classes:

TScaffoldInputCommon
TScaffoldInputCommon class file.

Page Details:


PRADO API Manual: Docs for page TSqliteScaffoldInput.php

Classes:

TSqliteScaffoldInput
TSqliteScaffoldInput class file.

Page Details:


PRADO API Manual: Docs for page TMssqlCommandBuilder.php

Classes:

TMssqlCommandBuilder
TMssqlCommandBuilder provides specifics methods to create limit/offset query commands for MSSQL servers.

Page Details:

TMsssqlCommandBuilder class file.

Tags:

version: | $Id: TDbCommandBuilder.php 1863 2007-04-12 12:43:49Z wei $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TMysqlCommandBuilder.php

Classes:

TMysqlCommandBuilder
TMysqlCommandBuilder implements default TDbCommandBuilder

Page Details:

TMysqlCommandBuilder class file.

Tags:

version: | $Id: TDbCommandBuilder.php 1863 2007-04-12 12:43:49Z wei $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TOracleCommandBuilder.php

Classes:

TOracleCommandBuilder
TOracleCommandBuilder provides specifics methods to create limit/offset query commands for Oracle database.

Page Details:

TOracleCommandBuilder class file.

Tags:

version: | $Id: TOracleCommandBuilder.php 2651 2009-05-11 08:48:37Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Marcos Nobre <marconobre[at]gmail[dot]com>


PRADO API Manual: Docs for page TOracleTableInfo.php

Classes:

TOracleTableInfo
TDbTableInfo class describes the meta data of a database table.

Page Details:

TOracleTableInfo class file.

Tags:

version: | $Id: TOracleTableInfo.php 2482 2008-07-30 02:07:13Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Marcos Nobre <marconobre[at]gmail[dot]com>


PRADO API Manual: Docs for page TPgsqlCommandBuilder.php

Classes:

TPgsqlCommandBuilder
TPgsqlCommandBuilder provides specifics methods to create limit/offset query commands for Pgsql database.

Page Details:

TPgsqlCommandBuilder class file.

Tags:

version: | $Id: TDbCommandBuilder.php 1863 2007-04-12 12:43:49Z wei $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqliteCommandBuilder.php

Classes:

TSqliteCommandBuilder
TSqliteCommandBuilder provides specifics methods to create limit/offset query commands for Sqlite database.

Page Details:

TSqliteCommandBuilder class file.

Tags:

version: | $Id: TDbCommandBuilder.php 1863 2007-04-12 12:43:49Z wei $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TDbCommandBuilder.php

Classes:

TDbCommandBuilder
TDbCommandBuilder provides basic methods to create query commands for tables giving by setTableInfo the property.

Page Details:

TDbCommandBuilder class file.

Tags:

version: | $Id: TDbCommandBuilder.php 2762 2010-02-13 15:37:13Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TDbMetaData.php

Classes:

TDbMetaData
TDbMetaData is the base class for retrieving metadata information, such as table and columns information, from a database connection.

Page Details:

TDbMetaData class file.

Tags:

version: | $Id: TDbMetaData.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TDbTableColumn.php

Classes:

TDbTableColumn
TDbTableColumn class describes the column meta data of the schema for a database table.

Page Details:

TDbTableColumn class file.

Tags:

version: | $Id: TDbTableColumn.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TDbTableInfo.php

Classes:

TDbTableInfo
TDbTableInfo class describes the meta data of a database table.

Page Details:

TDbTableInfo class file.

Tags:

version: | $Id: TDbTableInfo.php 2761 2010-02-08 08:44:21Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TMssqlTableColumn.php

Classes:

TMssqlTableColumn
Describes the column metadata of the schema for a Mssql database table.

Page Details:

TMssqlTableColumn class file.

Tags:

version: | $Id: TMssqlTableColumn.php 1863 2007-04-12 12:43:49Z wei $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TMssqlTableInfo.php

Classes:

TMssqlTableInfo
TMssqlTableInfo class provides additional table information for Mssql database.

Page Details:

TMssqlTableInfo class file.

Tags:

version: | $Id: TMssqlTableInfo.php 1861 2007-04-12 08:05:03Z wei $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TMysqlMetaData.php

Classes:

TMysqlMetaData
TMysqlMetaData loads Mysql version 4.1.x and 5.x database table and column information.

Page Details:

TMysqlMetaData class file.

Tags:

version: | $Id: TMysqlMetaData.php 2750 2010-01-12 11:18:57Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TMysqlTableColumn.php

Classes:

TMysqlTableColumn
Describes the column metadata of the schema for a Mysql database table.

Page Details:

TMysqlTableColumn class file.

Tags:

version: | $Id: TMysqlTableColumn.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TMysqlTableInfo.php

Classes:

TMysqlTableInfo
TMysqlTableInfo class provides additional table information for MySQL database.

Page Details:

TMysqlTableInfo class file.

Tags:

version: | $Id: TMysqlTableInfo.php 2482 2008-07-30 02:07:13Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TOracleMetaData.php

Classes:

TOracleMetaData
TOracleMetaData loads Oracle database table and column information.

Page Details:

TOracleMetaData class file.

Tags:

version: | $Id: TOracleMetaData.php 2653 2009-05-13 06:59:31Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Marcos Nobre <marconobre[at]gmail[dot]com>


PRADO API Manual: Docs for page TOracleTableColumn.php

Classes:

TOracleTableColumn
Describes the column metadata of the schema for a PostgreSQL database table.

Page Details:

TOracleTableColumn class file.

Tags:

version: | $Id: TOracleTableColumn.php 2482 2008-07-30 02:07:13Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Marcos Nobre <marconobre[at]gmail[dot]com>


PRADO API Manual: Docs for page TMssqlMetaData.php

Classes:

TMssqlMetaData
TMssqlMetaData loads MSSQL database table and column information.

Page Details:

TMssqlMetaData class file.

Tags:

version: | $Id: TPgsqlMetaData.php 1866 2007-04-14 05:02:29Z wei $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TPgsqlMetaData.php

Classes:

TPgsqlMetaData
TPgsqlMetaData loads PostgreSQL database table and column information.

Page Details:

TPgsqlMetaData class file.

Tags:

version: | $Id: TPgsqlMetaData.php 2641 2009-04-26 06:22:19Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TPgsqlTableColumn.php

Classes:

TPgsqlTableColumn
Describes the column metadata of the schema for a PostgreSQL database table.

Page Details:

TPgsqlTableColumn class file.

Tags:

version: | $Id: TPgsqlTableColumn.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TPgsqlTableInfo.php

Classes:

TPgsqlTableInfo
TPgsqlTableInfo class provides additional table information for PostgreSQL database.

Page Details:

TPgsqlTableInfo class file.

Tags:

version: | $Id: TPgsqlTableInfo.php 2654 2009-05-14 07:34:16Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqliteMetaData.php

Classes:

TSqliteMetaData
TSqliteMetaData loads SQLite database table and column information.

Page Details:

TSqliteMetaData class file.

Tags:

version: | $Id: TSqliteMetaData.php 1861 2007-04-12 08:05:03Z wei $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqliteTableColumn.php

Classes:

TSqliteTableColumn
Describes the column metadata of the schema for a PostgreSQL database table.

Page Details:

TSqliteTableColumn class file.

Tags:

version: | $Id: TSqliteTableColumn.php 1861 2007-04-12 08:05:03Z wei $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqliteTableInfo.php

Classes:

TSqliteTableInfo
TSqliteTableInfo class provides additional table information for PostgreSQL database.

Page Details:

TSqliteTableInfo class file.

Tags:

version: | $Id: TSqliteTableInfo.php 1861 2007-04-12 08:05:03Z wei $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TDataGatewayCommand.php

Classes:

TDataGatewayCommand
TDataGatewayCommand is command builder and executor class for TTableGateway and TActiveRecordGateway.
TDataGatewayEventParameter
TDataGatewayEventParameter class contains the TDbCommand to be executed as well as the criteria object.
TDataGatewayResultEventParameter
TDataGatewayResultEventParameter contains the TDbCommand executed and the resulting data returned from the database. The data can be changed by changing the setResult property.

Page Details:

TDataGatewayCommand, TDataGatewayEventParameter and TDataGatewayResultEventParameter class file.

Tags:

version: | $Id$
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqlCriteria.php

Classes:

TSqlCriteria
Search criteria for TDbDataGateway.

Page Details:

TDbSqlCriteria class file.

Tags:

version: | $Id: TDbSqlCriteria.php 1835 2007-04-03 01:38:15Z wei $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TTableGateway.php

Classes:

TTableGateway
TTableGateway class provides several find methods to get data from the database and update, insert, and delete methods.

Page Details:

TTableGateway class file.

Tags:

version: | $Id$
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TLazyLoadList.php

Classes:

TLazyLoadList
TLazyLoadList executes mapped statements when the proxy collection is first accessed.
TObjectProxy
TObjectProxy sets up a simple object that intercepts method calls to a particular object and relays the call to handler object.

Page Details:

TLazyLoadList, TObjectProxy classes file.

Tags:

version: | $Id: TLazyLoadList.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TPropertyAccess.php

Classes:

TPropertyAccess
TPropertyAccess class provides dot notation stype property access and setting.

Page Details:

TPropertyAccess class file.

Tags:

version: | $Id: TPropertyAccess.php 2644 2009-05-01 08:30:05Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqlMapCache.php

Classes:

TSqlMapCache
Allow different implementation of caching strategy. See <tt>TSqlMapFifoCache</tt> for a first-in-first-out implementation. See <tt>TSqlMapLruCache</tt> for a least-recently-used cache implementation.
TSqlMapFifoCache
First-in-First-out cache implementation, removes object that was first added when the cache is full.
TSqlMapLruCache
Least recently used cache implementation, removes object that was accessed last when the cache is full.
TSqlMapApplicationCache
TSqlMapApplicationCache uses the default Prado application cache for caching SqlMap results.

Page Details:

TSqlMapCache class file contains FIFO, LRU, and GLOBAL cache implementations.

Tags:

version: | $Id: TSqlMapCache.php 2757 2010-01-15 14:47:40Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqlMapException.php

Classes:

TSqlMapException
TSqlMapException is the base exception class for all SqlMap exceptions.
TSqlMapConfigurationException
TSqlMapConfigurationException, raised during configuration file parsing.
TSqlMapUndefinedException
TSqlMapUndefinedException, raised when mapped statemented are undefined.
TSqlMapDuplicateException
TSqlMapDuplicateException, raised when a duplicate mapped statement is found.
TInvalidPropertyException
TInvalidPropertyException, raised when setting or getting an invalid property.
TSqlMapExecutionException
TSqlMapException is the base exception class for all SqlMap exceptions.

Page Details:


PRADO API Manual: Docs for page TSqlMapPagedList.php

Classes:

TSqlMapPagedList
TSqlMapPagedList implements a list with paging functionality that retrieves data from a SqlMap statement.

Page Details:

TSqlMapPagedList class file.

Tags:

version: | $Id: TSqlMapPagedList.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqlMapTypeHandlerRegistry.php

Classes:

TSqlMapTypeHandlerRegistry
TTypeHandlerFactory provides type handler classes to convert database field type to PHP types and vice versa.
TSqlMapTypeHandler
A simple interface for implementing custom type handlers.

Page Details:

TSqlMapTypeHandlerRegistry, and abstract TSqlMapTypeHandler classes file.

Tags:

version: | $Id: TSqlMapTypeHandlerRegistry.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqlMapConfig.php

Classes:

TSqlMapConfig
TSqlMapConfig module configuration class.

Page Details:

TSqlMapConfig class file.

Tags:

version: | $Id: TSqlMapConfig.php 2745 2009-11-08 15:11:14Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqlMapGateway.php

Classes:

TSqlMapGateway
DataMapper client, a fascade to provide access the rest of the DataMapper framework. It provides three core functions:

Page Details:

TSqlMapGateway class file.

Tags:

version: | $Id: TSqlMapGateway.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqlMapManager.php

Classes:

TSqlMapManager
TSqlMapManager class holds the sqlmap configuation result maps, statements parameter maps and a type handler factory.

Page Details:

TSqlMapManager class file.

Tags:

version: | $Id: TSqlMapManager.php 2659 2009-05-23 07:52:15Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TDiscriminator.php

Classes:

TDiscriminator
The TDiscriminator corresponds to the <discriminator> tag within a <resultMap>.
TSubMap
TSubMap class defines a submapping value and the corresponding <resultMap>

Page Details:

TDiscriminator and TSubMap classes file.

Tags:

version: | $Id: TDiscriminator.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TInlineParameterMapParser.php

Classes:

TInlineParameterMapParser
TInlineParameterMapParser class.

Page Details:

TInlineParameterMapParser class file.

Tags:

version: | $Id: TInlineParameterMapParser.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TParameterMap.php

Classes:

TParameterMap
TParameterMap corresponds to the <parameterMap> element.

Page Details:

TParameterMap class file.

Tags:

version: | $Id: TParameterMap.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TParameterProperty.php

Classes:

TParameterProperty
TParameterProperty corresponds to the <property> tag and defines one object property for the <parameterMap>

Page Details:

TParameterPropert class file.

Tags:

version: | $Id: TParameterProperty.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TResultMap.php

Classes:

TResultMap
TResultMap corresponds to <resultMap> mapping tag.

Page Details:

TResultMap class file.

Tags:

version: | $Id: TResultMap.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TResultProperty.php

Classes:

TResultProperty
TResultProperty corresponds a <property> tags inside a <resultMap> tag.

Page Details:

TResultProperty class file.

Tags:

version: | $Id: TResultProperty.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSimpleDynamicParser.php

Classes:

TSimpleDynamicParser
TSimpleDynamicParser finds place holders $name$ in the sql text and replaces it with a TSimpleDynamicParser::DYNAMIC_TOKEN.

Page Details:

TSimpleDynamicParser class file.

Tags:

version: | $Id: TSimpleDynamicParser.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqlMapCacheModel.php

Classes:

TSqlMapCacheModel
TSqlMapCacheModel corresponds to the <cacheModel> sql mapping configuration tag.
TSqlMapCacheTypes
TSqlMapCacheTypes enumerable class.
TSqlMapCacheKey
TSqlMapCacheKey class.

Page Details:

TSqlMapCacheModel, TSqlMapCacheTypes and TSqlMapCacheKey classes file.

Tags:

version: | $Id: TSqlMapCacheModel.php 2757 2010-01-15 14:47:40Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqlMapStatement.php

Classes:

TSqlMapStatement
TSqlMapStatement class corresponds to <statement> element.
TSqlMapInsert
TSqlMapInsert class corresponds to the <insert> element.
TSqlMapUpdate
TSqlMapUpdate class corresponds to <update> element.
TSqlMapDelete
TSqlMapDelete class corresponds to the <delete> element.
TSqlMapSelectKey
TSqlMapSelect corresponds to the <selectKey> element.
TSqlMapSelect
TSqlMapSelect class file.

Page Details:

TSqlMapStatement, TSqlMapInsert, TSqlMapUpdate, TSqlMapDelete, TSqlMapSelect and TSqlMapSelectKey classes file.

Tags:

version: | $Id: TSqlMapStatement.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSqlMapXmlConfiguration.php

Classes:

TSqlMapXmlConfigBuilder
TSqlMapXmlConfig class file.
TSqlMapXmlConfiguration
TSqlMapXmlConfig class.
TSqlMapXmlMappingConfiguration
Loads the statements, result maps, parameters maps from xml configuration.

Page Details:

TSqlMapXmlConfigBuilder, TSqlMapXmlConfiguration, TSqlMapXmlMappingConfiguration classes file.

Tags:

version: | $Id: TSqlMapXmlConfiguration.php 2757 2010-01-15 14:47:40Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page IMappedStatement.php

Classes:

IMappedStatement
Interface for all mapping statements.

Page Details:

IMappedStatement interface file.

Tags:

version: | $Id: IMappedStatement.php 2541 2008-10-21 15:05:13Z qiang.xue $
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TCachingStatement.php

Classes:

TCachingStatement
TCacheingStatement class.

Page Details:

TCachingStatement class file.

Tags:

version: | $Id: TCachingStatement.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TDeleteMappedStatement.php

Classes:

TDeleteMappedStatement
TDeleteMappedStatement class.

Page Details:

TDeleteMappedStatement class file.

Tags:

version: | $Id: TDeleteMappedStatement.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TInsertMappedStatement.php

Classes:

TInsertMappedStatement
TInsertMappedStatement class.

Page Details:

TInsertMappedStatement class file.

Tags:

version: | $Id: TInsertMappedStatement.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TMappedStatement.php

Classes:

TMappedStatement
TMappedStatement class executes SQL mapped statements. Mapped Statements can hold any SQL statement and use Parameter Maps and Result Maps for input and output.
TPostSelectBinding
TPostSelectBinding class.
TSqlMapObjectCollectionTree
TSQLMapObjectCollectionTree class.
TResultSetListItemParameter
TResultSetListItemParameter class
TResultSetMapItemParameter
TResultSetMapItemParameter class.

Page Details:

TMappedStatement and related classes.

Tags:

version: | $Id: TMappedStatement.php 2625 2009-03-19 22:07:39Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TPreparedCommand.php

Classes:

TPreparedCommand
TPreparedCommand class.

Page Details:

TPreparedCommand class file.

Tags:

version: | $Id: TPreparedCommand.php 2629 2009-03-22 08:02:35Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TPreparedStatement.php

Classes:

TPreparedStatement
TpreparedStatement class.

Page Details:

TPreparedStatement class file.

Tags:

version: | $Id: TPreparedStatement.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TPreparedStatementFactory.php

Classes:

TPreparedStatementFactory
TPreparedStatementFactory class.

Page Details:

TPreparedStatementFactory class file.

Tags:

version: | $Id: TPreparedStatementFactory.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSelectMappedStatement.php

Classes:

TSelectMappedStatement
TSelectMappedStatment class.

Page Details:

TSelectMappedStatement class.

Tags:

version: | $Id: TSelectMappedStatement.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSimpleDynamicSql.php

Classes:

TSimpleDynamicSql
TSimpleDynamicSql class.

Page Details:

TSimpleDynamicSql class file.

Tags:

version: | $Id: TSimpleDynamicSql.php 2776 2010-02-20 09:18:40Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TStaticSql.php

Classes:

TStaticSql
TStaticSql class.

Page Details:

TStaticSql class file.

Tags:

version: | $Id: TStaticSql.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TUpdateMappedStatement.php

Classes:

TUpdateMappedStatement
TUpdateMappedStatement class.

Page Details:

TUpdateMappedStatement class file.

Tags:

version: | $Id: TUpdateMappedStatement.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TErrorHandler.php

Classes:

TErrorHandler
TErrorHandler class

Page Details:

TErrorHandler class file

Tags:

version: | $Id: TErrorHandler.php 2778 2010-02-20 18:56:09Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TException.php

Classes:

TException
TException class
TSystemException
TSystemException class
TApplicationException
TApplicationException class
TInvalidOperationException
TInvalidOperationException class
TInvalidDataTypeException
TInvalidDataTypeException class
TInvalidDataValueException
TInvalidDataValueException class
TConfigurationException
TConfigurationException class
TTemplateException
TTemplateException class
TIOException
TIOException class
TDbException
TDbException class
TDbConnectionException
TDbConnectionException class
TNotSupportedException
TNotSupportedException class
TPhpErrorException
TPhpErrorException class
THttpException
THttpException class

Page Details:

Exception classes file

Tags:

version: | $Id: TException.php 2606 2009-02-11 15:24:27Z haertl.mike $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TChoiceFormat.php

Classes:

TChoiceFormat
TChoiceFormat class.

Page Details:

TChoiceFormat, I18N choice format component.

Tags:

version: | $Id: TChoiceFormat.php 2482 2008-07-30 02:07:13Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TDateFormat.php

Classes:

TDateFormat
To format dates and/or time according to the current locale use

Page Details:

TDateFromat formatting component.

Tags:

version: | $Id: TDateFormat.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TGlobalization.php

Classes:

TGlobalization
TGlobalization contains settings for Culture, Charset and TranslationConfiguration.

Page Details:

TGlobalization class file.

Tags:

version: | $Id: TGlobalization.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo<weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TGlobalizationAutoDetect.php

Classes:

TGlobalizationAutoDetect
TGlobalizationAutoDetect class will automatically try to resolve the default culture using the user browser language settings.

Page Details:

TMultiView and TView class file.

Tags:

version: | $Revision: 1.66 $ $Date: ${DATE} ${TIME} $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo<weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TI18NControl.php

Classes:

TI18NControl
TI18NControl class.

Page Details:

Base I18N component.

Tags:

version: | $Id: TI18NControl.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TNumberFormat.php

Classes:

TNumberFormat
To format numbers in locale sensitive manner use

Page Details:

TNumberFromat component.

Tags:

version: | $Id: TNumberFormat.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page Translation.php

Classes:

Translation
Translation class.

Page Details:

Translation, static.

Tags:

version: | $Id: Translation.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TTranslate.php

Classes:

TTranslate
TTranslate class.

Page Details:

TTranslate, I18N translation component.

Tags:

version: | $Id: TTranslate.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TTranslateParameter.php

Classes:

TTranslateParameter
TTranslateParameter component should be used inside the TTranslate component to allow parameter substitution.

Page Details:

TTranslateParameter component.

Tags:

version: | $Id: TTranslateParameter.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TTarFileExtractor.php

Classes:

TTarFileExtractor
TTarFileExtractor class

Page Details:

TTarFileExtractor class file

Tags:

version: | $Id: TTarFileExtractor.php 1637 2007-01-17 22:26:53Z xue $
copyright: | Copyright &copy; 1997-2003 The PHP Group
author: | Vincent Blavet <vincent@phpconcept.net>


PRADO API Manual: Docs for page TTextWriter.php

Classes:

TTextWriter
TTextWriter class.

Page Details:

TTextWriter class file

Tags:

version: | $Id: TTextWriter.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page IUserManager.php

Classes:

IUserManager
IUserManager interface

Page Details:

IUserManager interface file

Tags:

version: | $Id: IUserManager.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TAuthManager.php

Classes:

TAuthManager
TAuthManager class

Page Details:

TAuthManager class file

Tags:

version: | $Id: TAuthManager.php 2526 2008-10-15 11:03:36Z mikl $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TAuthorizationRule.php

Classes:

TAuthorizationRule
TAuthorizationRule class
TAuthorizationRuleCollection
TAuthorizationRuleCollection class.

Page Details:

TAuthorizationRule, TAuthorizationRuleCollection class file

Tags:

version: | $Id: TAuthorizationRule.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDbUserManager.php

Classes:

TDbUserManager
TDbUserManager class
TDbUser
TDbUser class

Page Details:

TDbUserManager class

Tags:

version: | $Id: TDbUserManager.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TSecurityManager.php

Classes:

TSecurityManager
TSecurityManager class
TSecurityManagerValidationMode
TSecurityManagerValidationMode class.

Page Details:

TSecurityManager class file

Tags:

version: | $Id: TSecurityManager.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TUser.php

Classes:

TUser
TUser class

Page Details:

TUser class file.

Tags:

version: | $Id: TUser.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TUserManager.php

Classes:

TUserManager
TUserManager class
TUserManagerPasswordMode
TUserManagerPasswordMode class.

Page Details:

TUserManager class

Tags:

version: | $Id: TUserManager.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDataFieldAccessor.php

Classes:

TDataFieldAccessor
TDataFieldAccessor class

Page Details:

TDataFieldAccessor class file

Tags:

version: | $Id: TDataFieldAccessor.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDateTimeStamp.php

Classes:

TDateTimeStamp
TDateTimeStamp Class

Page Details:

TDateTimeStamp class file.

COPYRIGHT (c) 2003-2005 John Lim and released under BSD-style license except for code by jackbbs, which includes getTimeStamp, getGMTDiff, isLeapYear and originally found at http://www.php.net/manual/en/function.mktime.php

Tags:

version: | $Id: TDateTimeStamp.php 2488 2008-08-06 01:34:06Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>

ADODB_NO_NEGATIVE_TS [line 32]

ADODB_NO_NEGATIVE_TS = 1

[ Top ]


PRADO API Manual: Docs for page TLogger.php

Classes:

TLogger
TLogger class.

Page Details:

TLogger class file

Tags:

version: | $Id: TLogger.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TLogRouter.php

Classes:

TLogRouter
TLogRouter class.
TLogRoute
TLogRoute class.
TFileLogRoute
TFileLogRoute class.
TEmailLogRoute
TEmailLogRoute class.
TBrowserLogRoute
TBrowserLogRoute class.
TDbLogRoute
TDbLogRoute class
TFirebugLogRoute
TFirebugLogRoute class.
TFirePhpLogRoute
TFirePhpLogRoute class.

Page Details:

TLogRouter, TLogRoute, TFileLogRoute, TEmailLogRoute class file

Tags:

version: | $Id: TLogRouter.php 2694 2009-07-20 11:53:36Z carlgmathisen $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TParameterModule.php

Classes:

TParameterModule
TParameterModule class

Page Details:

TParameterModule class

Tags:

version: | $Id: TParameterModule.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TSimpleDateFormatter.php

Classes:

TSimpleDateFormatter
TSimpleDateFormatter class.

Page Details:

TSimpleDateFormatter class file

Tags:

version: | $Id: TSimpleDateFormatter.php 2488 2008-08-06 01:34:06Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TVarDumper.php

Classes:

TVarDumper
TVarDumper class.

Page Details:

TVarDumper class file

Tags:

version: | $Id: TVarDumper.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TAssetManager.php

Classes:

TAssetManager
TAssetManager class

Page Details:

TAssetManager class

Tags:

version: | $Id: TAssetManager.php 2674 2009-06-07 07:38:09Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TCacheHttpSession.php

Classes:

TCacheHttpSession
TCacheHttpSession class

Page Details:

TCacheHttpSession class

Tags:

version: | $Id: TCacheHttpSession.php 2541 2008-10-21 15:05:13Z qiang.xue $
since: | 3.1.1
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
author: | Carl G. Mathisen <carlgmathisen@gmail.com>
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page THttpRequest.php

Classes:

THttpRequest
THttpRequest class
THttpCookieCollection
THttpCookieCollection class.
THttpCookie
THttpCookie class.
TUri
TUri class
THttpRequestUrlFormat
THttpRequestUrlFormat class.

Page Details:

THttpRequest, THttpCookie, THttpCookieCollection, TUri class file

Tags:

version: | $Id: THttpRequest.php 2781 2010-02-22 08:56:54Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page THttpResponse.php

Classes:

THttpResponse
THttpResponse class

Page Details:

THttpResponse class

Tags:

version: | $Id: THttpResponse.php 2740 2009-11-08 09:46:55Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page THttpResponseAdapter.php

Classes:

THttpResponseAdapter
THttpResponseAdapter class.

Page Details:

THttpResponseAdatper class

Tags:

version: | $Id$
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page THttpSession.php

Classes:

THttpSession
THttpSession class
TSessionIterator
TSessionIterator class
THttpSessionCookieMode
THttpSessionCookieMode class.

Page Details:

THttpSession class

Tags:

version: | $Id: THttpSession.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page THttpUtility.php

Classes:

THttpUtility
THttpUtility class

Page Details:

THttpUtility class file

Tags:

version: | $Id: THttpUtility.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TUrlManager.php

Classes:

TUrlManager
TUrlManager class

Page Details:

TUrlManager class file

Tags:

version: | $Id $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TUrlMapping.php

Classes:

TUrlMapping
TUrlMapping Class
TUrlMappingPattern
TUrlMappingPattern class.

Page Details:

TUrlMapping and TUrlMappingPattern class file.

Tags:

version: | $Id: TUrlMapping.php 2604 2009-01-21 08:49:21Z haertl.mike $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TFeedService.php

Classes:

TFeedService
TFeedService class
IFeedContentProvider
IFeedContentProvider interface.

Page Details:

TFeedService and TFeed class file

Tags:

license: | http://www.pradosoft.com/license/
version: | $Id$
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com
author: | Qiang Xue <qiang.xue@gmail.com>
author: | Knut Urdalen <knut.urdalen@gmail.com>


PRADO API Manual: Docs for page TJsonService.php

Classes:

TJsonService
TJsonService class provides to end-users javascript content response in JSON format.
TJsonResponse
TJsonResponse Class

Page Details:

TJsonService and TJsonResponse class file.

Tags:

version: | $Id: TJsonService.php 2574 2008-11-30 23:09:51Z carlgmathisen $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TPageService.php

Classes:

TPageService
TPageService class.
TPageConfiguration
TPageConfiguration class

Page Details:

TPageService class file.

Tags:

version: | $Id: TPageService.php 2737 2009-11-08 07:33:48Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TSoapService.php

Classes:

TSoapService
TSoapService class
TSoapServer
TSoapServer class.

Page Details:

TSoapService and TSoapServer class file

Tags:

license: | http://www.pradosoft.com/license/
version: | $Id: TSoapService.php 2541 2008-10-21 15:05:13Z qiang.xue $
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Knut Urdalen <knut.urdalen@gmail.com>
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TCachePageStatePersister.php

Classes:

TCachePageStatePersister
TCachePageStatePersister class

Page Details:

TCachePageStatePersister class file

Tags:

version: | $Id: TCachePageStatePersister.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TClientScriptManager.php

Classes:

TClientScriptManager
TClientScriptManager class.
TClientSideOptions
TClientSideOptions abstract class.

Page Details:

TClientScriptManager and TClientSideOptions class file.

Tags:

version: | $Id: TClientScriptManager.php 2614 2009-02-24 09:54:08Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TCompositeControl.php

Classes:

TCompositeControl
TCompositeControl class.

Page Details:

TCompositeControl class file.

Tags:

version: | $Id: TCompositeControl.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TControl.php

Classes:

TControl
TControl class
TControlCollection
TControlCollection class
TEmptyControlCollection
TEmptyControlCollection class
INamingContainer
INamingContainer interface.
IPostBackEventHandler
IPostBackEventHandler interface
IPostBackDataHandler
IPostBackDataHandler interface
IValidator
IValidator interface
IValidatable
IValidatable interface
IBroadcastEventReceiver
IBroadcastEventReceiver interface
ITheme
ITheme interface.
ITemplate
ITemplate interface
IButtonControl
IButtonControl interface
ISurroundable
ISurroundable interface
TBroadcastEventParameter
TBroadcastEventParameter class
TCommandEventParameter
TCommandEventParameter class
TCompositeLiteral
TCompositeLiteral class

Page Details:

TControl, TControlCollection, TEventParameter and INamingContainer class file

Tags:

version: | $Id: TControl.php 2522 2008-10-13 21:40:53Z mikl $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TControlAdapter.php

Classes:

TControlAdapter
TControlAdapter class

Page Details:

TControlAdapter class file.

Tags:

version: | $Id: TControlAdapter.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TForm.php

Classes:

TForm
TForm class

Page Details:

TForm class file

Tags:

version: | $Id: TForm.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page THtmlWriter.php

Classes:

THtmlWriter
THtmlWriter class

Page Details:

THtmlWriter class file

Tags:

version: | $Id: THtmlWriter.php 2625 2009-03-19 22:07:39Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TPage.php

Classes:

TPage
TPage class
IPageStatePersister
IPageStatePersister interface.
TPageStateFormatter
TPageStateFormatter class.

Page Details:

TPage class file

Tags:

version: | $Id: TPage.php 2737 2009-11-08 07:33:48Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TPageStatePersister.php

Classes:

TPageStatePersister
TPageStatePersister class

Page Details:

TPageStatePersister class file

Tags:

version: | $Id: TPageStatePersister.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TSessionPageStatePersister.php

Classes:

TSessionPageStatePersister
TSessionPageStatePersister class

Page Details:

TSessionPageStatePersister class file

Tags:

version: | $Id: TSessionPageStatePersister.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TTemplateControl.php

Classes:

TTemplateControl
TTemplateControl class.

Page Details:

TTemplateControl class file.

Tags:

version: | $Id: TTemplateControl.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TTemplateManager.php

Classes:

TTemplateManager
TTemplateManager class
TTemplate
TTemplate implements PRADO template parsing logic.

Page Details:

TTemplateManager and TTemplate class file

Tags:

version: | $Id: TTemplateManager.php 2625 2009-03-19 22:07:39Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TThemeManager.php

Classes:

TThemeManager
TThemeManager class
TTheme
TTheme class

Page Details:

TThemeManager class

Tags:

version: | $Id: TThemeManager.php 2497 2008-08-14 21:15:30Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page THead.php

Classes:

THead
THead class
TMetaTag
TMetaTag class.
TMetaTagCollection
TMetaTagCollection class

Page Details:

THead class file

Tags:

version: | $Id: THead.php 2590 2008-12-10 11:34:24Z carlgmathisen $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Marcus Nyeholt <tanus@users.sourceforge.net> and Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page THtmlArea.php

Classes:

THtmlArea
THtmlArea class

Page Details:

THtmlArea class file.

Tags:

version: | $Id: THtmlArea.php 2643 2009-04-29 06:53:37Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveButton.php

Classes:

TActiveButton
TActiveButton is the active control counter part to TButton.

Page Details:

TActiveButton class file.

Tags:

version: | $Id: TActiveButton.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveCheckBox.php

Classes:

TActiveCheckBox
TActiveCheckBox class.

Page Details:

TActiveCheckBox class file.

Tags:

version: | $Id: TActiveCheckBox.php 2600 2009-01-07 12:58:53Z christophe.boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveCheckBoxList.php

Classes:

TActiveCheckBoxList
TActiveCheckBoxList class.

Page Details:

TActiveCheckBoxList class file.

Tags:

version: | $Id: TActiveCheckBoxList.php 2482 2008-07-30 02:07:13Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveControlAdapter.php

Classes:

TActiveControlAdapter
TActiveControlAdapter class.
TCallbackPageStateTracker
TCallbackPageStateTracker class.
TViewStateDiff
Calculates the viewstate changes during the request.
TScalarDiff
TScalarDiff class.
TStyleDiff
TStyleDiff class.
TMapCollectionDiff
TAttributesDiff class.

Page Details:

TActiveControlAdapter and TCallbackPageStateTracker class file.

Tags:

version: | $Id: TActiveControlAdapter.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveCustomValidator.php

Classes:

TActiveCustomValidator
TActiveCustomValidator Class
TActiveCustomValidatorClientSide
Custom Validator callback client side options class.

Page Details:

TActiveCustomValidator class file.

Tags:

version: | $Id: TActiveCustomValidator.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveDatePicker.php

Classes:

TActiveDatePicker
TActiveDatePicker class

Page Details:

TActiveDatePicker class file

Tags:

license: | http://www.pradosoft.com/license/
version: | $Id: TActiveDatePicker.php 2633 2009-04-08 07:10:01Z Christophe.Boulain $
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Bradley Booms <Bradley.Booms@nsighttel.com>
author: | Christophe Boulain <Christophe.Boulain@gmail.com>


PRADO API Manual: Docs for page TActiveDropDownList.php

Classes:

TActiveDropDownList
TActiveDropDownList class.

Page Details:

TActiveDropDownList class file.

Tags:

version: | $Id: TActiveDropDownList.php 2600 2009-01-07 12:58:53Z christophe.boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveFileUpload.php

Classes:

TActiveFileUpload
TActiveFileUpload

Page Details:

TActiveFileUpload.php

Tags:

version: | $Id: TActiveFileUpload.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
author: | Bradley Booms <Bradley.Booms@nsighttel.com>
author: | Christophe Boulain <Christophe.Boulain@gmail.com>


PRADO API Manual: Docs for page TActiveHiddenField.php

Classes:

TActiveHiddenField
TActiveHiddenField class

Page Details:

TActiveHiddenField class file.

Tags:

version: | $Id$
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Carl G. Mathisen <carlgmathisen@gmail.com>


PRADO API Manual: Docs for page TActiveHyperLink.php

Classes:

TActiveHyperLink
TActiveHyperLink class.

Page Details:

TActiveHyperLink class file.

Tags:

version: | $Id: TActiveHyperLink.php 2482 2008-07-30 02:07:13Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveImage.php

Classes:

TActiveImage
TActiveImage class.

Page Details:

TActiveImage class file.

Tags:

version: | $Id: TActiveImage.php 2482 2008-07-30 02:07:13Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveImageButton.php

Classes:

TActiveImageButton
TActiveImageButton class.

Page Details:

TActiveImageButton class file.

Tags:

version: | $Id: TActiveImageButton.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveLabel.php

Classes:

TActiveLabel
TActiveLabel class

Page Details:

TActiveLabel class file.

Tags:

version: | $Id: TActiveLabel.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveLinkButton.php

Classes:

TActiveLinkButton
TActiveLinkButton is the active control counter part to TLinkButton.

Page Details:

TActiveLinkButton class file.

Tags:

version: | $Id: TActiveLinkButton.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveListBox.php

Classes:

TActiveListBox
TActiveListBox class.

Page Details:

TActiveListBox class file.

Tags:

version: | $Id: TActiveListBox.php 2600 2009-01-07 12:58:53Z christophe.boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveListControlAdapter.php

Classes:

TActiveListControlAdapter
TActiveListControlAdapter class.
TActiveListItemCollection
TActiveListItemCollection class.

Page Details:

TActiveListControlAdapter class file.

Tags:

version: | $Id: TActiveListControlAdapter.php 2482 2008-07-30 02:07:13Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActivePageAdapter.php

Classes:

TActivePageAdapter
TActivePageAdapter class.
TCallbackErrorHandler
TCallbackErrorHandler class.
TInvalidCallbackException
TInvalidCallbackException class.

Page Details:

TActivePageAdapter, TCallbackErrorHandler and TInvalidCallbackException class file.

Tags:

version: | $Id: TActivePageAdapter.php 2681 2009-06-27 07:10:41Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActivePager.php

Classes:

TActivePager
TActivePager is the active control counter part of TPager.

Page Details:

TActivePager class file.

Tags:

version: | $Id: TActivePager.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | "gevik" (forum contributor) and Christophe Boulain (Christophe.Boulain@gmail.com)


PRADO API Manual: Docs for page TActivePanel.php

Classes:

TActivePanel
TActivePanel is the TPanel active control counterpart.

Page Details:

TActivePanel file.

Tags:

version: | $Id: TActivePanel.php 2642 2009-04-29 06:22:27Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveRadioButton.php

Classes:

TActiveRadioButton
TActiveRadioButton class.

Page Details:

TActiveRadioButton class file.

Tags:

version: | $Id: TActiveRadioButton.php 2600 2009-01-07 12:58:53Z christophe.boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveRadioButtonList.php

Classes:

TActiveRadioButtonList
TActiveRadioButtonList class.

Page Details:

TActiveRadioButtonList class file.

Tags:

version: | $Id: TActiveRadioButtonList.php 2573 2008-11-25 12:21:59Z carlgmathisen $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TActiveRatingList.php

Classes:

TActiveRatingList
TActiveRatingList Class

Page Details:

TActiveRatingList class file.

Tags:

license: | http://www.pradosoft.com/license/
version: | $Id$
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>
author: | Bradley Booms <bradley[dot]booms[at]gmail[dot]com>


PRADO API Manual: Docs for page TActiveTextBox.php

Classes:

TActiveTextBox
TActiveTextBox class.

Page Details:

TActiveTextBox class file.

Tags:

version: | $Id: TActiveTextBox.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TAutoComplete.php

Classes:

TAutoComplete
TAutoComplete class.
TAutoCompleteEventParameter
TAutCompleteEventParameter contains the getToken requested by the user for a partial match of the suggestions.
TAutoCompleteTemplate
TAutoCompleteTemplate class.

Page Details:

TAutoComplete class file.

Tags:

version: | $Id: TAutoComplete.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TBaseActiveControl.php

Classes:

TBaseActiveControl
TBaseActiveControl class provided additional basic property for every active control. An instance of TBaseActiveControl or its decendent TBaseActiveCallbackControl is created by TActiveControlAdapter::getBaseActiveControl() method.
TBaseActiveCallbackControl
TBaseActiveCallbackControl is a common set of options and functionality for active controls that can perform callback requests.

Page Details:

TBaseActiveControl and TBaseActiveCallbackControl class file.

Tags:

version: | $Id: TBaseActiveControl.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TCallback.php

Classes:

TCallback
TCallback component class.

Page Details:

TCallback class file.

Tags:

version: | $Id: TCallback.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TCallbackClientScript.php

Classes:

TCallbackClientScript
TCallbackClientScript class.

Page Details:

TCallbackClientScript class file

Tags:

version: | $Id: TCallbackClientScript.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TCallbackClientSide.php

Classes:

TCallbackClientSide
TCallbackClientSide class.

Page Details:

TCallbackClientSide class file

Tags:

version: | $Id: TCallbackClientSide.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TCallbackEventParameter.php

Classes:

TCallbackEventParameter
TCallbackEventParameter class.

Page Details:

TCallbackEventParameter class file.

Tags:

version: | $Id$
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TCallbackOptions.php

Classes:

TCallbackOptions
TCallbackOptions class.

Page Details:

TCallbackOptions component class file.

Tags:

version: | $Id: TCallbackOptions.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TCallbackResponseAdapter.php

Classes:

TCallbackResponseAdapter
TCallbackResponseAdapter alters the THttpResponse's outputs.
TCallbackResponseWriter
TCallbackResponseWriter class.

Page Details:

TCallbackResponseAdapter and TCallbackResponseWriter class file.

Tags:

version: | $Id: TCallbackResponseAdapter.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TDraggable.php

Classes:

TDraggable
TDraggable is a control which can be dragged
TDraggableConstraint
TEnumerable class.

Page Details:

TDraggable class file

Tags:

version: | $Id: TDraggable.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
license: | http://www.pradosoft.com/license
copyright: | Copyright &copy; 2008, PradoSoft
author: | Christophe BOULAIN (Christophe.Boulain@gmail.com)


PRADO API Manual: Docs for page TDropContainer.php

Classes:

TDropContainer
TDropContainer is a panel where TDraggable controls can be dropped.
TDropContainerEventParameter
TDropContainerEventParameter class

Page Details:

TDropContainer class file

Tags:

version: | $Id: TDropContainer.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
license: | http://www.pradosoft.com/license
copyright: | Copyright &copy; 2008, PradoSoft
author: | Christophe BOULAIN (Christophe.Boulain@gmail.com)


PRADO API Manual: Docs for page TEventTriggeredCallback.php

Classes:

TEventTriggeredCallback
TEventTriggeredCallback Class

Page Details:

TEventTriggeredCallback class file.

Tags:

version: | $Id: TEventTriggeredCallback.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TInPlaceTextBox.php

Classes:

TInPlaceTextBox
TInPlaceTextBox Class

Page Details:

TInPlaceTextBox class file.

Tags:

version: | $Id: TInPlaceTextBox.php 2765 2010-02-15 08:47:50Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TTimeTriggeredCallback.php

Classes:

TTimeTriggeredCallback
TTimeTriggeredCallback class.

Page Details:

TTimeTriggeredCallback class file.

Tags:

version: | $Id: TTimeTriggeredCallback.php 2532 2008-10-16 09:12:20Z tof $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TTriggeredCallback.php

Classes:

TTriggeredCallback
TTriggeredCallback abstract Class

Page Details:

TTriggeredCallback class file.

Tags:

version: | $Id: TTriggeredCallback.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TValueTriggeredCallback.php

Classes:

TValueTriggeredCallback
TValueTriggeredCallback Class

Page Details:

TValueTriggeredCallback class file.

Tags:

version: | $Id: TValueTriggeredCallback.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gamil[dot]com>


PRADO API Manual: Docs for page TBaseDataList.php

Classes:

TBaseDataList
TBaseDataList class

Page Details:

TBaseDataList class file

Tags:

version: | $Id: TBaseDataList.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TBaseValidator.php

Classes:

TBaseValidator
TBaseValidator class
TValidatorClientSide
TValidatorClientSide class.
TValidatorDisplayStyle
TValidatorDisplayStyle class.
TValidationDataType
TValidationDataType class.

Page Details:

TBaseValidator class file

Tags:

version: | $Id: TBaseValidator.php 2738 2009-11-08 08:05:18Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TBoundColumn.php

Classes:

TBoundColumn
TBoundColumn class

Page Details:

TBoundColumn class file

Tags:

version: | $Id: TBoundColumn.php 2705 2009-09-15 08:28:02Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TBulletedList.php

Classes:

TBulletedList
TBulletedList class
TBulletedListEventParameter
TBulletedListEventParameter Event parameter for TBulletedList::onClick event of the bulleted list. The getIndex gives the zero-based index of the item that is currently being clicked.
TBulletStyle
TBulletStyle class.
TBulletedListDisplayMode
TBulletedListDisplayMode class.

Page Details:

TBulletedList class file

Tags:

version: | $Id: TBulletedList.php 2673 2009-06-07 07:12:35Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TButton.php

Classes:

TButton
TButton class
TButtonType
TButtonType class.

Page Details:

TButton class file.

Tags:

version: | $Id: TButton.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TButtonColumn.php

Classes:

TButtonColumn
TButtonColumn class

Page Details:

TButtonColumn class file

Tags:

version: | $Id: TButtonColumn.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TCaptcha.php

Classes:

TCaptcha
TCaptcha class.

Page Details:

TCaptcha class file

Tags:

version: | $Id: TCaptcha.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TCaptchaValidator.php

Classes:

TCaptchaValidator
TCaptchaValidator class

Page Details:

TCaptchaValidator class file

Tags:

version: | $Id: TCaptchaValidator.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TCheckBox.php

Classes:

TCheckBox
TCheckBox class
TTextAlign
TTextAlign class.

Page Details:

TCheckBox class file

Tags:

version: | $Id: TCheckBox.php 2522 2008-10-13 21:40:53Z mikl $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TCheckBoxColumn.php

Classes:

TCheckBoxColumn
TCheckBoxColumn class

Page Details:

TCheckBoxColumn class file

Tags:

version: | $Id: TCheckBoxColumn.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TCheckBoxList.php

Classes:

TCheckBoxList
TCheckBoxList class

Page Details:

TCheckBoxList class file

Tags:

version: | $Id: TCheckBoxList.php 2702 2009-07-27 10:47:39Z carlgmathisen $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TClientScript.php

Classes:

TClientScript
TClientScript class

Page Details:

TClientScript class file

Tags:

version: | $Id: TClientScript.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TClientScriptLoader.php

Classes:

TClientScriptLoader
The TClientScriptLoader publish a collection of javascript files as assets.

Page Details:

TClientScriptLoader class file.

Tags:

version: | $Id: TClientScriptLoader.php 1827 2007-04-02 06:19:55Z wei $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TColorPicker.php

Classes:

TColorPicker
TColorPicker class.
TColorPickerMode
TColorPickerMode class.
TColorPickerClientSide
TColorPickerClientSide class.

Page Details:

TColorPicker class file

Tags:

version: | $Id: TColorPicker.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TCompareValidator.php

Classes:

TCompareValidator
TCompareValidator class
TValidationCompareOperator
TValidationCompareOperator class.

Page Details:

TCompareValidator class file

Tags:

version: | $Id: TCompareValidator.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TConditional.php

Classes:

TConditional
TConditional class.

Page Details:

TConditional class file.

Tags:

version: | $Id: TConditional.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TContent.php

Classes:

TContent
TContent class

Page Details:

TContent class file.

Tags:

version: | $Id: TContent.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TContentPlaceHolder.php

Classes:

TContentPlaceHolder
TContentPlaceHolder class

Page Details:

TContentPlaceHolder class file.

Tags:

version: | $Id: TContentPlaceHolder.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TCustomValidator.php

Classes:

TCustomValidator
TCustomValidator class
TServerValidateEventParameter
TServerValidateEventParameter class

Page Details:

TCustomValidator class file

Tags:

version: | $Id: TCustomValidator.php 2630 2009-04-04 09:53:57Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDataBoundControl.php

Classes:

TDataBoundControl
TDataBoundControl class.
TListItemType
TListItemType class.
IItemDataRenderer
IItemDataRenderer interface.

Page Details:

TDataBoundControl class file

Tags:

version: | $Id: TDataBoundControl.php 2492 2008-08-09 01:30:05Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDataGrid.php

Classes:

TDataGrid
TDataGrid class
TDataGridItemEventParameter
TDataGridItemEventParameter class
TDataGridPagerEventParameter
TDataGridPagerEventParameter class
TDataGridCommandEventParameter
TDataGridCommandEventParameter class
TDataGridSortCommandEventParameter
TDataGridSortCommandEventParameter class
TDataGridPageChangedEventParameter
TDataGridPageChangedEventParameter class
TDataGridItem
TDataGridItem class
TDataGridPager
TDataGridPager class.
TDataGridItemCollection
TDataGridItemCollection class.
TDataGridColumnCollection
TDataGridColumnCollection class.
TDataGridPagerMode
TDataGridPagerMode class.
TDataGridPagerButtonType
TDataGridPagerButtonType class.
TDataGridPagerPosition
TDataGridPagerPosition class.

Page Details:

TDataGrid related class files.

This file contains the definition of the following classes: TDataGrid, TDataGridItem, TDataGridItemCollection, TDataGridColumnCollection, TDataGridPagerStyle, TDataGridItemEventParameter, TDataGridCommandEventParameter, TDataGridSortCommandEventParameter, TDataGridPageChangedEventParameter

Tags:

version: | $Id: TDataGrid.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDataGridColumn.php

Classes:

TDataGridColumn
TDataGridColumn class
TButtonColumnType
TButtonColumnType class.

Page Details:

TDataGridColumn class file

Tags:

version: | $Id: TDataGridColumn.php 2756 2010-01-14 13:12:27Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDataGridItemRenderer.php

Classes:

TDataGridItemRenderer
TDataGridItemRenderer class

Page Details:

TDataGridItemRenderer class file

Tags:

version: | $Id: TDataGridItemRenderer.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDataGridPagerStyle.php

Classes:

TDataGridPagerStyle
TDataGridPagerStyle class.

Page Details:

TDataGridPagerStyle class file.

Tags:

version: | $Id: TDataGridPagerStyle.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDataList.php

Classes:

TDataList
TDataList class
TDataListItemEventParameter
TDataListItemEventParameter class
TDataListCommandEventParameter
TDataListCommandEventParameter class
TDataListItem
TDataListItem class
TDataListItemCollection
TDataListItemCollection class.

Page Details:

TDataList class file

Tags:

version: | $Id: TDataList.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDataListItemRenderer.php

Classes:

TDataListItemRenderer
TDataListItemRenderer class

Page Details:

TDataListItemRenderer class file

Tags:

version: | $Id: TDataListItemRenderer.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDataRenderer.php

Classes:

TDataRenderer
TDataRenderer class

Page Details:

TDataRenderer class file

Tags:

version: | $Id: TDataRenderer.php 2541 2008-10-21 15:05:13Z qiang.xue $
since: | 3.1.2
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDataSourceControl.php

Classes:

IDataSource
IDataSource class
TDataSourceControl
TDataSourceControl class
TReadOnlyDataSource
TDataSourceControl class

Page Details:

IDataSource, TDataSourceControl, TReadOnlyDataSource class file

Tags:

version: | $Id: TDataSourceControl.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDataSourceView.php

Classes:

TDataSourceSelectParameters
TDataSourceSelectParameters class
TDataSourceView
TDataSourceView class
TReadOnlyDataSourceView
TReadOnlyDataSourceView class

Page Details:

TDataSourceSelectParameters, TDataSourceView, TReadOnlyDataSourceView class file

Tags:

version: | $Id: TDataSourceView.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDataTypeValidator.php

Classes:

TDataTypeValidator
TDataTypeValidator class

Page Details:

TDataTypeValidator class.

Tags:

version: | $Id: TDataTypeValidator.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TDatePicker.php

Classes:

TDatePicker
TDatePicker class.
TDatePickerClientScript
TDatePickerClientScript class.
TDatePickerInputMode
TDatePickerInputMode class.
TDatePickerMode
TDatePickerMode class.
TDatePickerPositionMode
TDatePickerPositionMode class.

Page Details:

TDatePicker class file.

Tags:

version: | $Id: TDatePicker.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TDropDownList.php

Classes:

TDropDownList
TDropDownList class

Page Details:

TDropDownList class file

Tags:

version: | $Id: TDropDownList.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TDropDownListColumn.php

Classes:

TDropDownListColumn
TDropDownListColumn class

Page Details:

TDropDownListColumn class file

Tags:

version: | $Id: TDropDownListColumn.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TEditCommandColumn.php

Classes:

TEditCommandColumn
TEditCommandColumn class

Page Details:

TEditCommandColumn class file

Tags:

version: | $Id: TEditCommandColumn.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TEmailAddressValidator.php

Classes:

TEmailAddressValidator
TEmailAddressValidator class

Page Details:

TEmailAddressValidator class file

Tags:

version: | $Id: TEmailAddressValidator.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TExpression.php

Classes:

TExpression
TExpression class

Page Details:

TExpression class file

Tags:

version: | $Id: TExpression.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TFileUpload.php

Classes:

TFileUpload
TFileUpload class

Page Details:

TFileUpload class file

Tags:

version: | $Id: TFileUpload.php 2693 2009-07-20 10:36:48Z carlgmathisen $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Marcus Nyeholt <tanus@users.sourceforge.net>, Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TFont.php

Classes:

TFont
TFont class

Page Details:

TFont class file.

Tags:

version: | $Id: TFont.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page THiddenField.php

Classes:

THiddenField
THiddenField class

Page Details:

THiddenField class file.

Tags:

version: | $Id: THiddenField.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | BSD License
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.xisc.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page THtmlElement.php

Classes:

THtmlElement
THtmlElement class.

Page Details:

THtmlElement class file.

Tags:

version: | $Id: THtmlElement.php 2482 2008-07-30 02:07:13Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page THyperLink.php

Classes:

THyperLink
THyperLink class

Page Details:

THyperLink class file.

Tags:

version: | $Id: THyperLink.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | BSD License
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.xisc.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page THyperLinkColumn.php

Classes:

THyperLinkColumn
THyperLinkColumn class

Page Details:

THyperLinkColumn class file

Tags:

version: | $Id: THyperLinkColumn.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TImage.php

Classes:

TImage
TImage class

Page Details:

TImage class file.

Tags:

version: | $Id: TImage.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TImageButton.php

Classes:

TImageButton
TImageButton class
TImageClickEventParameter
TImageClickEventParameter class

Page Details:

TImageButton class file

Tags:

version: | $Id: TImageButton.php 2482 2008-07-30 02:07:13Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TImageMap.php

Classes:

TImageMap
TImageMap class
TImageMapEventParameter
TImageMapEventParameter class.
THotSpotCollection
THotSpotCollection class.
THotSpot
THotSpot class.
TCircleHotSpot
Class TCircleHotSpot.
TRectangleHotSpot
Class TRectangleHotSpot.
TPolygonHotSpot
Class TPolygonHotSpot.
THotSpotMode
THotSpotMode class.

Page Details:

TImageMap and related class file.

Tags:

version: | $Id: TImageMap.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TInlineFrame.php

Classes:

TInlineFrame
TInlineFrame class
TInlineFrameAlign
TInlineFrameAlign class.
TInlineFrameScrollBars
TInlineFrameScrollBars class.

Page Details:

TInlineFrame class file.

Tags:

license: | http://www.pradosoft.com/license/
version: | $Id: TInlineFrame.php 2541 2008-10-21 15:05:13Z qiang.xue $
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Jason Ragsdale <jrags@jasrags.net>
author: | Harry Pottash <hpottash@gmail.com>


PRADO API Manual: Docs for page TItemDataRenderer.php

Classes:

TItemDataRenderer
TItemDataRenderer class

Page Details:

TItemDataRenderer class file

Tags:

version: | $Id: TItemDataRenderer.php 2541 2008-10-21 15:05:13Z qiang.xue $
since: | 3.1.2
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TJavascriptLogger.php

Classes:

TJavascriptLogger
TJavascriptLogger class.

Page Details:

TJavascriptLogger class file.

Tags:

version: | $Id: TJavascriptLogger.php 2747 2010-01-11 12:58:38Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TKeyboard.php

Classes:

TKeyboard
Class TKeyboard.

Page Details:

TKeyboard class file.

Tags:

version: | $Id: TKeyboard.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
since: | 3.1.1
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Sergey Morkovkin <sergeymorkovkin@mail.ru> and Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TLabel.php

Classes:

TLabel
TLabel class

Page Details:

TLabel class file.

Tags:

version: | $Id: TLabel.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TLinkButton.php

Classes:

TLinkButton
TLinkButton class

Page Details:

TLinkButton class file

Tags:

version: | $Id: TLinkButton.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TListBox.php

Classes:

TListBox
TListBox class
TListSelectionMode
TListSelectionMode class.

Page Details:

TListBox class file

Tags:

version: | $Id: TListBox.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TListControl.php

Classes:

TListControl
TListControl class
TListItemCollection
TListItemCollection class.
IListControlAdapter
IListControlAdapter interface

Page Details:

TListControl class file

Tags:

version: | $Id: TListControl.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TListControlValidator.php

Classes:

TListControlValidator
TListControlValidator class.

Page Details:

TListControlValidator class file

Tags:

version: | $Id: TListControlValidator.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TListItem.php

Classes:

TListItem
TListItem class.

Page Details:

TListItem class file

Tags:

version: | $Id: TListItem.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TLiteral.php

Classes:

TLiteral
TLiteral class

Page Details:

TLiteral class file

Tags:

version: | $Id: TLiteral.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TLiteralColumn.php

Classes:

TLiteralColumn
TLiteralColumn class

Page Details:

TLiteralColumn class file

Tags:

version: | $Id: TLiteralColumn.php 1397 2006-09-07 07:55:53Z wei $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TMarkdown.php

Classes:

TMarkdown
TMarkdown class

Page Details:

TMarkdown class file

Tags:

version: | $Id: TMarkdown.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TMultiView.php

Classes:

TMultiView
TMultiView class
TViewCollection
TViewCollection class.
TView
TView class

Page Details:

TMultiView and TView class file.

Tags:

version: | $Id: TMultiView.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TOutputCache.php

Classes:

TOutputCache
TOutputCache class.
TOutputCacheCheckDependencyEventParameter
TOutputCacheCheckDependencyEventParameter class
TOutputCacheCalculateKeyEventParameter
TOutputCacheCalculateKeyEventParameter class

Page Details:

TOutputCache class file

Tags:

version: | $Id: TOutputCache.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TPager.php

Classes:

TPager
TPager class.
TPagerPageChangedEventParameter
TPagerPageChangedEventParameter class
TPagerMode
TPagerMode class.
TPagerButtonType
TPagerButtonType class.

Page Details:

TPager class file.

Tags:

version: | $Id: TPager.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TPanel.php

Classes:

TPanel
TPanel class

Page Details:

TPanel class file

Tags:

version: | $Id: TPanel.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TPanelStyle.php

Classes:

TPanelStyle
TPanelStyle class.
TContentDirection
TContentDirection class.
TScrollBars
TScrollBars class.

Page Details:

TPanelStyle class file

Tags:

version: | $Id: TPanelStyle.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TPlaceHolder.php

Classes:

TPlaceHolder
TPlaceHolder class

Page Details:

TPlaceHolder class file

Tags:

version: | $Id: TPlaceHolder.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TRadioButton.php

Classes:

TRadioButton
TRadioButton class

Page Details:

TRadioButton class file

Tags:

version: | $Id: TRadioButton.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TRadioButtonList.php

Classes:

TRadioButtonList
TRadioButtonList class

Page Details:

TRadioButtonList class file

Tags:

version: | $Id: TRadioButtonList.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TRangeValidator.php

Classes:

TRangeValidator
TRangeValidator class
TRangeValidationDataType
TRangeValidationDataType class.

Page Details:

TRangeValidator class file

Tags:

version: | $Id: TRangeValidator.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TRatingList.php

Classes:

TRatingList
TRatingList class.

Page Details:

TRatingList class file.

Tags:

version: | $Id: TRatingList.php 2562 2008-11-08 17:41:48Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TRegularExpressionValidator.php

Classes:

TRegularExpressionValidator
TRegularExpressionValidator class

Page Details:

TRequiredFieldValidator class file

Tags:

version: | $Id: TRegularExpressionValidator.php 2754 2010-01-14 11:29:33Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TRepeater.php

Classes:

TRepeater
TRepeater class.
TRepeaterItemEventParameter
TRepeaterItemEventParameter class
TRepeaterCommandEventParameter
TRepeaterCommandEventParameter class
TRepeaterItem
TRepeaterItem class
TRepeaterItemCollection
TRepeaterItemCollection class.

Page Details:

TRepeater class file

Tags:

version: | $Id: TRepeater.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TRepeaterItemRenderer.php

Classes:

TRepeaterItemRenderer
TRepeaterItemRenderer class

Page Details:

TRepeaterItemRenderer class file

Tags:

version: | $Id: TRepeaterItemRenderer.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TRepeatInfo.php

Classes:

IRepeatInfoUser
IRepeatInfoUser interface.
TRepeatInfo
TRepeatInfo class.
TRepeatDirection
TRepeatDirection class.
TRepeatLayout
TRepeatLayout class.

Page Details:

IRepeatInfoUser, TRepeatInfo class file

Tags:

version: | $Id: TRepeatInfo.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TRequiredFieldValidator.php

Classes:

TRequiredFieldValidator
TRequiredFieldValidator class

Page Details:

TRequiredFieldValidator class file

Tags:

version: | $Id: TRequiredFieldValidator.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TSafeHtml.php

Classes:

TSafeHtml
TSafeHtml class

Page Details:

TSafeHtml class file

Tags:

version: | $Id: TSafeHtml.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TSlider.php

Classes:

TSlider
TSlider class
TSliderClientScript
TSliderClientScript class.
TSliderDirection
TSliderDirection class.

Page Details:

TSlider class file.

Tags:

version: | $Id: TSlider.php 2564 2008-11-11 21:56:02Z carlgmathisen $
since: | 3.1.1
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Christophe Boulain <Christophe.Boulain@gmail.com>


PRADO API Manual: Docs for page TStatements.php

Classes:

TStatements
TStatements class

Page Details:

TStatements class file

Tags:

version: | $Id: TStatements.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TStyle.php

Classes:

TStyle
TStyle class
TDisplayStyle
TDisplayStyle defines the enumerable type for the possible styles that a web control can display.
TTableStyle
TTableStyle class.
TTableItemStyle
TTableItemStyle class.
THorizontalAlign
THorizontalAlign class.
TVerticalAlign
TVerticalAlign class.
TTableGridLines
TTableGridLines class.

Page Details:

TStyle class file.

Tags:

version: | $Id: TStyle.php 2624 2009-03-19 21:20:47Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TStyleSheet.php

Classes:

TStyleSheet
TStyleSheet class.

Page Details:

TStyleSheet class file.

Tags:

version: | $Id: TStyleSheet.php 2482 2008-07-30 02:07:13Z knut $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo <weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TTable.php

Classes:

TTable
TTable class
TTableRowCollection
TTableRowCollection class.
TTableCaptionAlign
TTableCaptionAlign class.

Page Details:

TTable and TTableRowCollection class file

Tags:

version: | $Id: TTable.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TTableCell.php

Classes:

TTableCell
TTableCell class.

Page Details:

TTableCell class file

Tags:

version: | $Id: TTableCell.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TTableFooterRow.php

Classes:

TTableFooterRow
TTableFooterRow class.

Page Details:

TTableFooterRow class file

Tags:

version: | $Id: TTableFooterRow.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TTableHeaderCell.php

Classes:

TTableHeaderCell
TTableHeaderCell class.
TTableHeaderScope
TTableHeaderScope class.

Page Details:

TTableHeaderCell class file

Tags:

version: | $Id: TTableHeaderCell.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TTableHeaderRow.php

Classes:

TTableHeaderRow
TTableHeaderRow class.

Page Details:

TTableHeaderRow class file

Tags:

version: | $Id: TTableHeaderRow.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TTableRow.php

Classes:

TTableRow
TTableRow class.
TTableCellCollection
TTableCellCollection class.
TTableRowSection
TTableRowSection class.

Page Details:

TTableRow and TTableCellCollection class file

Tags:

version: | $Id: TTableRow.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TTabPanel.php

Classes:

TTabPanel
Class TTabPanel.
TTabView
TTabView class.
TTabViewCollection
TTabViewCollection class.

Page Details:

TTabPanel class file.

Tags:

version: | $Id: TTabPanel.php 2773 2010-02-17 13:55:18Z Christophe.Boulain $
since: | 3.1.1
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Tomasz Wolny <tomasz.wolny@polecam.to.pl> and Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TTemplateColumn.php

Classes:

TTemplateColumn
TTemplateColumn class

Page Details:

TTemplateColumn class file

Tags:

version: | $Id: TTemplateColumn.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TTextBox.php

Classes:

TTextBox
TTextBox class
TTextBoxMode
TTextBoxMode class.
TTextBoxAutoCompleteType
TTextBoxAutoCompleteType class.

Page Details:

TTextBox class file.

Tags:

version: | $Id: TTextBox.php 2744 2009-11-08 11:47:56Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TTextHighlighter.php

Classes:

TTextHighlighter
TTextHighlighter class.
TTextHighlighterLineNumberStyle
TEnumerable class.

Page Details:

TTextHighlighter class file

Tags:

version: | $Id: TTextHighlighter.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Wei Zhuo<weizhuo[at]gmail[dot]com>


PRADO API Manual: Docs for page TTextProcessor.php

Classes:

TTextProcessor
TTextProcessor class.

Page Details:

TTextProcessor class file

Tags:

version: | $Id: TTextProcessor.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TValidationSummary.php

Classes:

TValidationSummary
TValidationSummary class
TClientSideValidationSummaryOptions
TClientSideValidationSummaryOptions class.
TValidationSummaryDisplayMode
TValidationSummaryDisplayMode class.
TValidationSummaryDisplayStyle
TValidationSummaryDisplay class.

Page Details:

TValidationSummary class file

Tags:

version: | $Id: TValidationSummary.php 2739 2009-11-08 08:26:42Z godzilla80@gmx.net $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TWebControl.php

Classes:

TWebControl
TWebControl class

Page Details:

TWebControl class file.

Tags:

version: | $Id: TWebControl.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TWebControlAdapter.php

Classes:

TWebControlAdapter
TWebControlAdapter class

Page Details:

TWebControlAdapter class file.

Tags:

version: | $Id: TWebControlAdapter.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TWizard.php

Classes:

TWizard
Class TWizard.
TWizardStep
TWizardStep class.
TCompleteWizardStep
TCompleteWizardStep class.
TTemplatedWizardStep
TTemplatedWizardStep class.
TWizardStepCollection
TWizardStepCollection class.
TWizardNavigationContainer
TWizardNavigationContainer class.
TWizardNavigationEventParameter
TWizardNavigationEventParameter class.
TWizardSideBarTemplate
TWizardSideBarTemplate class.
TWizardSideBarListItemTemplate
TWizardSideBarListItemTemplate class.
TWizardNavigationTemplate
TWizardNavigationTemplate class.
TWizardStartNavigationTemplate
TWizardStartNavigationTemplate class.
TWizardFinishNavigationTemplate
TWizardFinishNavigationTemplate class.
TWizardStepNavigationTemplate
TWizardStepNavigationTemplate class.
TWizardNavigationButtonType
TWizardNavigationButtonType class.
TWizardStepType
TWizardStepType class.

Page Details:

TWizard and the relevant class definitions.

Tags:

version: | $Id: TWizard.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TWizardNavigationButtonStyle.php

Classes:

TWizardNavigationButtonStyle
TWizardNavigationButtonStyle class.

Page Details:

TWizardNavigationButtonStyle class file.

Tags:

version: | $Id $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page TXmlTransform.php

Classes:

TXmlTransform
TXmlTransform class

Page Details:

TXmlTransform class file

Tags:

license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com
author: | Knut Urdalen <knut.urdalen@gmail.com>
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO API Manual: Docs for page captcha.php

Page Details:

CAPTCHA generator script.

Tags:

version: | $Id: captcha.php 2541 2008-10-21 15:05:13Z qiang.xue $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>

Includes:

require_once(dirname(__FILE__).'/captcha_key.php') [line 20]

THEME_HAS_GRID [line 15]

THEME_HAS_GRID = 0x0004

[ Top ]

THEME_HAS_SCRIBBLE [line 16]

THEME_HAS_SCRIBBLE = 0x0008

[ Top ]

THEME_MORPH_BACKGROUND [line 17]

THEME_MORPH_BACKGROUND = 0x0010

[ Top ]

THEME_NOISY_BACKGROUND [line 14]

THEME_NOISY_BACKGROUND = 0x0002

[ Top ]

THEME_OPAQUE_BACKGROUND [line 13]

THEME_OPAQUE_BACKGROUND = 0x0001

[ Top ]

THEME_SHADOWED_TEXT [line 18]

THEME_SHADOWED_TEXT = 0x0020

[ Top ]

addBackground [line 124]

void addBackground( mixed $image, mixed $width, mixed $height, mixed $opaque, mixed $noisy, mixed $hasGrid, mixed $hasScribble, mixed $morph)

[ Top ]

addGrid [line 167]

void addGrid( mixed $image, mixed $width, mixed $height)

[ Top ]

addNoise [line 151]

void addNoise( mixed $image, mixed $width, mixed $height)

[ Top ]

addScribble [line 185]

void addScribble( mixed $image, mixed $width, mixed $height)

[ Top ]

displayToken [line 77]

void displayToken( mixed $token, mixed $fontSize, mixed $theme)

[ Top ]

generateToken [line 52]

void generateToken( mixed $publicKey, mixed $privateKey, mixed $alphabet, mixed $tokenLength, mixed $caseSensitive)

[ Top ]

hash2string [line 58]

void hash2string( mixed $hex, mixed $alphabet)

[ Top ]

morphImage [line 202]

void morphImage( mixed $image, mixed $width, mixed $height)

[ Top ]


PRADO API Manual: Docs for page TXmlDocument.php

Classes:

TXmlElement
TXmlElement class.
TXmlDocument
TXmlDocument class.
TXmlElementList
TXmlElementList class.

Page Details:

TXmlElement, TXmlDocument, TXmlElementList class file

Tags:

version: | $Id: TXmlDocument.php 2771 2010-02-16 14:55:38Z Christophe.Boulain $
license: | http://www.pradosoft.com/license/
copyright: | Copyright &copy; 2005-2008 PradoSoft
link: | http://www.pradosoft.com/
author: | Qiang Xue <qiang.xue@gmail.com>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveButton/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49

<com:TContent ID="body">
<!-- $Id: Home.page 1650 2007-01-24 06:55:32Z wei $ -->
<h1>TActiveButton Samples (AJAX)</h1>

<table class="sampletable">

<tr><td class="samplenote">
A click button with <tt>OnClick</tt> event handler:
</td><td class="sampleaction">
<com:TActiveButton
    Text="click me"
    OnClick="buttonClicked" />
</td></tr>

<tr><td class="samplenote">
A command button with <tt>OnCallback</tt>:
</td><td class="sampleaction">
<com:TActiveButton
    Text="click me"
    OnCommand="buttonClicked"
    CommandName="test"
    ActiveControl.CallbackParameter="value"
    CommandParameter="value"
    OnCallback="buttonCallback"
    />
</td></tr>

<tr><td class="samplenote">
A button causing validation with <tt>OnCallback</tt>:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TActiveButton
    Text="submit"
    OnClick="buttonClicked"
    OnCallback="buttonCallback"
    ValidationGroup="Group" />
</td></tr>

</table>

<com:TJavascriptLogger />

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveButton/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

<?php

// $Id: Home.php 1405 2006-09-10 01:03:56Z wei $
class Home extends TPage
{
    public function buttonClicked($sender, $param)
    {
        if($param instanceof TCommandEventParameter)
            $sender->Text="Name: {$param->CommandName}, Param: {$param->CommandParameter}";
        else
            $sender->Text="I'm clicked";
    }

    public function buttonCallback($sender, $param)
    {
        $sender->Text .= ' using callback';
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveCheckBox/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77

<com:TContent ID="body">
<!-- $Id: Home.page 1650 2007-01-24 06:55:32Z wei $ -->
<h1>TActiveCheckBox Samples (AJAX)</h1>

<table class="sampletable">

<tr><td class="samplenote">
An active checkbox with <tt>OnCallback</tt>:
</td><td class="sampleaction">
<com:TActiveCheckBox
    AutoPostBack="true"
    Text="click me"
    OnCheckedChanged="checkboxClicked"
    OnCallback="checkboxCallback"
    />
</td></tr>

<tr><td class="samplenote">
A checkbox causing validation on a textbox:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TActiveCheckBox
    Text="submit"
    ValidationGroup="Group"
    OnCheckedChanged="checkboxClicked"
    OnCallback="checkboxCallback"
    />
</td></tr>

<tr><td class="samplenote">
A checkbox validated by a required field validator:
</td><td class="sampleaction">
<com:TActiveCheckBox
    ID="CheckBox"
    Text="Consent"
    AutoPostBack="false"
    OnCheckedChanged="checkboxClicked"
    ValidationGroup="Group2"
    />
<com:TActiveButton Text="Submit" ValidationGroup="Group2" />
<com:TRequiredFieldValidator
    ControlToValidate="CheckBox"
    Display="Dynamic"
    ErrorMessage="You must consent."
    ValidationGroup="Group2"
    />
</td></tr>

<tr><td class="samplenote">
A checkbox validated by a required field validator:
</td><td class="sampleaction">
<com:TActiveCheckBox
    ID="CheckBox2"
    Text="Agree"
    Checked="true"
    OnCheckedChanged="checkboxClicked"
    ValidationGroup="Group3"
    />
<com:TRequiredFieldValidator
    ControlToValidate="CheckBox2"
    Display="Dynamic"
    ErrorMessage="You must agree."
    ValidationGroup="Group3"
    />
</td></tr>

</table>

<com:TJavascriptLogger />

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveCheckBox/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

<?php
// $Id: Home.php 1405 2006-09-10 01:03:56Z wei $
class Home extends TPage
{
    public function checkboxClicked($sender,$param)
    {
        $sender->Text= $sender->ClientID . " clicked";
    }

    public function checkboxCallback($sender, $param)
    {
        $sender->Text .= ' using callback';
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveCustomValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22

<com:TContent ID="body">
<!-- $Id: Home.page 1650 2007-01-24 06:55:32Z wei $ -->
<h1>TActiveCustomValidator Samples (AJAX)</h1>

<table class="sampletable">

<tr><td class="samplenote">
Custom validator using callbacks:
</td><td class="sampleaction">
<com:TTextBox ID="textbox1" />
<com:TActiveCustomValidator
    ID="validator1"
    ControlToValidate="textbox1"
    ErrorMessage="Please enter 'Prado'"
    OnServerValidate="validator1_onvalidate" />
<com:TButton ID="button1" Text="Submit!" />
</td></tr>
</table>

<com:TJavascriptLogger />

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/ActiveControls/Samples/TActiveCustomValidator/Home.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Home extends TPage
{
    public function validator1_onvalidate($sender, $param)
    {
        $param->IsValid = $this->textbox1->Text == 'Prado';
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.de.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152

<%@ Title="Internationalisierung in PRADO "
    Page.Application.Globalization.TranslationCatalogue="index" %>
<com:TContent ID="body">
<h1>Internationalisierung in PRADO </h1>
<p>Diese Demo zeigt die grundlegenden Bestandteile, die in PRADO für den Prozess der Internationalisierung und regionalen Anpassung von Web-Anwendungen vorhanden sind. Das Beispiel verwendet mehrere sprachlich (bzw. kulturell) angepasste Templates, um eine lokalisierte Seite anzuzeigen. Um eine anderssprachige Version anzusehen, ändern Sie bitte die Spracheinstellungen in Ihrem Webbrowser.</p>

<p>
 Ihre aktuelle Kultur ist
<%= $this->Page->CurrentCulture %>.
<div class="links">
 Vorhandene Sprachversionen:
    <com:LanguageList />
</div>
</p>

<p>
Weiter mit dem Thema kulturell angepasster Templates. Text kann unter Zuhilfenahme vieler unterschiedlicher Übersetzungsquellen lokalisiert werden. PRADO stellt gettext-, XML-, SQLite- und MySQL-Container für die Speicherung von Nachrichtenübersetzungen zur Verfügung. Das Beispiel im folgenden Link zeigt, wie Text mit der TTranslate-Komponente lokalisiert werden kann.
<hr />
<h2>Einleitung </h2>
<p> Entwicklung und Wartung mehrsprachiger Sites ist ein weitverbreitetes Problem fÜr Web-Entwickler.</p>
<dl>
<dt><strong>Internationalisierung (I18N)</strong></dt>
<dd> Prozess der Entwicklung eines Produktes, so dass es mit Daten in unterschiedlichen Sprachen funktioniert und an verschiedene Zielmärkte ohne Technikänderungen angepasst werden kann. </dd>
<dt><strong>Lokalisation (L10N)</strong></dt>
<dd>Nachfolgender Prozess der Übersetzung und Anpassung eines Produktes an die kulturellen Konventionen eines gegebenen Marktes.</dd>
</dl>
<p> Die folgenden Merkmale werden von PRADO unterstützt: </p>
<ul id="u1" class="block-content">
  <li>Textübersetzung </li>
  <li>Attributübersetzung (noch zu implementieren) </li>
  <li>Parameteraustausch (falls erforderlich mit Übersetzung) </li>
  <li>Datums-, Zahlen- und Währungsformatierung</li>
  </ul>
<h2>Beispiele </h2>
<h3>Datum: volles Muster, Kultur en_GB</h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/> <br />
<hr />

<h3>Datum: kurzes Muster</h3>
<h4>Beispiel:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time2" Pattern="short" /&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TDateFormat ID="Time2" Pattern="short" /> <br />
<hr />

<h3>Datum: Standardmuster von <%= $this->Page->CurrentCulture %> </h3>
<h4>Beispiel:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time3" Value="2004/12/06" /&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TDateFormat ID="Time3" Value="2004/12/06" /> <br />
<hr />

<h3>Währung Standardformat </h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Value="12.4" /&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TNumberFormat Type="currency" Value="12.4" /> <br />

<hr />

<h3>Währung, Kultur de_DE mit Euro </h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/> <br />

<hr />

<h3>Währung, US-Format mit Euro </h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /> <br />
<hr />

<h3>Übersetzungsbeispiele </h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;Hello&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TTranslate>Hello</com:TTranslate> <br />
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" /&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TTranslate Text="Goodbye" /> <br />

<hr />
<h3>Using localization tag</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;%[ Goodbye ]%&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<%[ Goodbye ]%>
<br />

<hr />
<h3>Übersetzung mit Verwendung eines anderen Kataloges</h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" Catalogue="tests" /&gt;
</com:TTextHighlighter>
<h4>Resultat: </h4>
<com:TTranslate Text="Goodbye" Catalogue="tests" />
<br />

<hr />
<h3>Übersetzung mit Parameteraustausch </h3>
<h4>Beispiel: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;
    {greeting} {name}!, The unix-time is "{time}".
    &lt;com:TTranslateParameter Key="name"&gt;
        &lt;com:TTranslate Catalogue="tests" Text="World" /&gt;
    &lt;/com:TTranslateParameter&gt;
    &lt;com:TTranslateParameter Key="greeting" Value="Hello" /&gt;
    &lt;com:TTranslateParameter Key="time" Value="&lt;%= Time() %&gt;" /&gt;
&lt;/com:TTranslate&gt;
</com:TTextHighlighter>

<h4>Resultat: </h4>

<com:TTranslate>
    {greeting} {name}!, The unix-time is "{time}".
    <com:TTranslateParameter Key="name">
        <com:TTranslate Catalogue="tests" Text="World" />
    </com:TTranslateParameter>
    <com:TTranslateParameter Key="greeting" Value="Hello" />
    <com:TTranslateParameter Key="time" Value="<%= Time() %>" />
</com:TTranslate>

<div class="last-modified">$Id: Home.de.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.es.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150

<%@ Title="Internationlization en PRADO "
    Page.Application.Globalization.TranslationCatalogue="index" %>
<com:TContent ID="body">
<h1>Internationlization en PRADO </h1>
<p> Esta versión parcial de programa muestra los componentes básicos disponibles en PRADO para el proceso de internacionalizar y de localizar aplicaciones del Web. Esta paginación utiliza modelos enterados múltiples del locale (o cultura) para mostrar la paginación localizada apropiada. Para visión una diversa versión localizada, cambie por favor sus configuraciones del lenguaje en su browser. </p>

<p>
 Su cultura actual es
<%= $this->Page->CurrentCulture %>.
<div class="links">
 Versiones localizadas disponibles:
    <com:LanguageList />
</div>
</p>

<p>
 Además de modelo enterado de la cultura. El texto se puede localizar usando muchas diversas fuentes de la traducción. PRADO proporciona al gettext, al envase de XML, de SQLite, y de MySQL para salvar traducciones del mensaje. El ejemplo en la conexión siguiente demuestra cómo el texto se puede localizar usando el componente de TTranslate.
<hr />
<h2>Introducción </h2>
<p> Que desarrolla y que los mantiene el multi-lenguaje sitios es un problema común para los reveladores del Web.</p>
<dl>
<dt><strong>Internacionalización (I18N)</strong></dt>
<dd> Proceso de desarrollar un producto de una manera tal que trabaje con datos en diversos lenguajes y pueda ser adaptado a los varios mercados de blanco sin cambios de ingeniería. </dd>
<dt><strong>Localización (L10N)</strong></dt>
<dd> Proceso subsecuente de traducir y de adaptar un producto a las convenciones culturales de un mercado dado. </dd>
</dl>
<p> Las características siguientes son utilizadas por PRADO: </p>
<ul id="u1" class="block-content">
  <li>Traducción del texto </li>
  <li>Traducción del atributo (todo) </li>
  <li>Substitución de parámetro (con la traducción si es necesario) </li>
  <li>Fecha, número y formato de la modernidad </li>
  </ul>
<h2>Ejemplos </h2>
<h3>Fecha: modelo completo, cultura del en_GB </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/> <br />
<hr />

<h3>Fecha: modelo corto </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time2" Pattern="short" /&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TDateFormat ID="Time2" Pattern="short" /> <br />
<hr />

<h3>Modelo del valor por defecto de la fecha del <%= $this->Page->CurrentCulture %> </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time3" Value="2004/12/06" /&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TDateFormat ID="Time3" Value="2004/12/06" /> <br />
<hr />

<h3>Formato del valor por defecto de la modernidad </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Value="12.4" /&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TNumberFormat Type="currency" Value="12.4" /> <br />
<hr />
<h3>Modernidad, cultura del de_DE con el Euro </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/> <br />

<hr />

<h3>Modernidad, formato de los E.E.U.U. con el Euro </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /> <br />
<hr />

<h3>Ejemplos de la traducción </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;Hello&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TTranslate>Hello</com:TTranslate> <br />
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" /&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TTranslate Text="Goodbye" /> <br />

<hr />
<h3>Using localization tag</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;%[ Goodbye ]%&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<%[ Goodbye ]%>
<br />

<hr />
<h3>Traducción usando un diverso catálogo </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" Catalogue="tests" /&gt;
</com:TTextHighlighter>
<h4>Resultado: </h4>
<com:TTranslate Text="Goodbye" Catalogue="tests" />
<br />

<hr />
<h3>Traducción con la substitución de parámetro </h3>
<h4>Ejemplo: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;
    {greeting} {name}!, The unix-time is "{time}".
    &lt;com:TTranslateParameter Key="name"&gt;
        &lt;com:TTranslate Catalogue="tests" Text="World" /&gt;
    &lt;/com:TTranslateParameter&gt;
    &lt;com:TTranslateParameter Key="greeting" Value="Hello" /&gt;
    &lt;com:TTranslateParameter Key="time" Value="&lt;%= Time() %&gt;" /&gt;
&lt;/com:TTranslate&gt;
</com:TTextHighlighter>

<h4>Resultado: </h4>

<com:TTranslate>
    {greeting} {name}!, The unix-time is "{time}".
    <com:TTranslateParameter Key="name">
        <com:TTranslate Catalogue="tests" Text="World" />
    </com:TTranslateParameter>
    <com:TTranslateParameter Key="greeting" Value="Hello" />
    <com:TTranslateParameter Key="time" Value="<%= Time() %>" />
</com:TTranslate>

<div class="last-modified">$Id: Home.es.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.fr.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202

<%@ Title="Internationalisation dans PRADO"
    Page.Application.Globalization.TranslationCatalogue="index" %>
<com:TContent ID="body">
            <h1>Internationalisation&nbsp;avec PRADO
            </h1>
            <p>
                Cette démonstration présente&nbsp;les composants de base&nbsp;fournis
                par&nbsp;PRADO pour le processus d'internationalisation et de localisation des
                applications Web. Cette page utilise plusieurs gabarits en fonction de la
                localisation (ou de la culture) pour afficher le contenu&nbsp;approprié. Pour
                afficher une version localisée différente, veuillez changer la configuration
                des langues dans votre navigateur.
            </p>
            <p>
                Votre culture actuelle est <%= $this->Page->CurrentCulture %>.
                <div class="links">
                    Versions localisées disponibles :
                    <com:LanguageList />
                </div>
            <P></P>
            <p>
                En plus du support de la culture dans les gabarits, le&nbsp;contenu peut être
                localisé en utilisant différentes sources de traduction. PRADO permet
                d'utiliser gettext, XML, SQLite et MySQL pour enregistrer les traductions des
                messages. L'exemple suivant montre comment le texte peut être localisé en
                utilisant le composant TTranslate.
            <hr>
            <h2>Introduction
            </h2>
            <p>
                Développer et mettre à jour un site multi-langues est un problème classique
                pour les développeurs de sites Web.</p>
            <dl>
                <dt><strong>Internationalisation (I18N)</strong>
                    <dd>
                        Processus de développement d'un produit de telle manière qu'il fonctionne avec
                        des données dans différentes langues et puisse être adapté à
                        diverses&nbsp;cibles culturelles sans changement technique. <dt><strong>Localisation
                                (L10N)</strong>
                            <dd>
                                Processus ultérieur de traduction et d'adaptation d'un produit aux conventions
                                culturelles d'un marché donné.
                            </dd>
            </dl>
            <p>
                PRADO offrent les fonctionnalités suivantes&nbsp; :
            </p>
            <ul id="u1" class="block-content">
                <li>
                Traduction de contenu
                <li>
                Traduction des attributs (à faire)
                <li>
                Substitution des paramètres (avec traduction si nécessaire)
                <li>
                    Date, nombre et formatage des devises
                </li>
            </ul>
            <h2>Exemples</h2>
            <h3>Date : format long, culture en_GB</h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
            <com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB" />
            <br>
            <hr>
            <h3>Date : format court
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time2" Pattern="short" /&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
            <com:TDateFormat ID="Time2" Pattern="short" />
            <br>
            <hr>
            <h3>Format par défaut d'une date pour la culture
                <%= $this->Page->CurrentCulture %>
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time3" Value="2004/12/06" /&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
<com:TDateFormat ID="Time3" Value="2004/12/06" /> <br />
            <br>
            <hr>
            <h3>Format par défaut d'une devise
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Value="12.4" /&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
<com:TNumberFormat Type="currency" Value="12.4" /> <br />
            <br>
            <hr>
            <h3>Devise :&nbsp;culture de_DE avec devise Euro
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
            <com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR" />
            <br>
            <hr>
            <h3>Devise :&nbsp;culture en_US avec devise Euro
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /&gt;
</com:TTextHighlighter>
            <h4>Résultat
            </h4>
            <com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" />
            <br>
            <hr>
            <h3>Exemples de traduction
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;Hello&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
            <com:TTranslate>Hello</com:TTranslate>
            <br>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" /&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
            <com:TTranslate Text="Goodbye" />
            <br>

<hr />
<h3>Using localization tag</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;%[ Goodbye ]%&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<%[ Goodbye ]%>
<br />

            <hr>
            <h3>Traduction en utilisant un catalogue différent</h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" Catalogue="tests" /&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
<com:TTranslate Text="Goodbye" Catalogue="tests" />
            <br>
            <hr>
            <h3>Traduction avec substitution de paramètres
            </h3>
            <h4>Exemple :
            </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;
    {greeting} {name}!, The unix-time is "{time}".
    &lt;com:TTranslateParameter Key="name"&gt;
        &lt;com:TTranslate Catalogue="tests" Text="World" /&gt;
    &lt;/com:TTranslateParameter&gt;
    &lt;com:TTranslateParameter Key="greeting" Value="Hello" /&gt;
    &lt;com:TTranslateParameter Key="time" Value="&lt;%= Time() %&gt;" /&gt;
&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
            <h4>Résultat :
            </h4>
<com:TTranslate>
    {greeting} {name}!, The unix-time is "{time}".
    <com:TTranslateParameter Key="name">
        <com:TTranslate Catalogue="tests" Text="World" />
    </com:TTranslateParameter>
    <com:TTranslateParameter Key="greeting" Value="Hello" />
    <com:TTranslateParameter Key="time" Value="<%= Time() %>" />
</com:TTranslate>

<div class="last-modified">$Id: Home.fr.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161

<%@ Title="Internationlization  in PRADO"
    Page.Application.Globalization.TranslationCatalogue="index" %>
<com:TContent ID="body">

<h1>Internationlization  in PRADO</h1>
<p>This demo shows the basic components available in PRADO for the process of Internationalizing and Localizing web applications. This page utilize multiple locale (or culture) aware templates to show the appropriate localized page. To view a different localized version, please change your language settings in your browser.</p>

<p>
Your current culture is <%= $this->Page->CurrentCulture %>.
<div class="links">
    Available localized versions:
    <com:LanguageList />
</div>
</p>

<p>
    In addition to culture aware template. Text can be localized using many different translation sources. PRADO provides gettext, XML, SQLite, and MySQL container for storing message translations. The example in the following link demonstrates how text can be localized using the TTranslate component.
</p>
<hr />
<h2>Introduction</h2>
<p> Developing and maintaining multi-language sites is a common problem for web developers. </p>
<dl>
<dt><strong>Internationalization (I18N)</strong></dt>
<dd>Process of developing a product in such a way that it works with data in different languages and can be adapted to various target markets without engineering changes. </dd>
<dt><strong>Localization (L10N)</strong></dt>
<dd>Subsequent process of translating and adapting a product to a given market's cultural conventions.</dd>
</dl>
<p>The following features are supported by PRADO: </p>
<ul id="u1" class="block-content">
  <li>Text translation</li>
  <li>Attribute translation</li>
  <li>Parameter substitution (with translation if needed) </li>
  <li>Date, number and currency formatting </li>
</ul>
<h2>Examples</h2>
<h3>Date: full pattern, en_GB culture</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/&gt;
</com:TTextHighlighter>
<h4>Result:</h4>
<com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/> <br />
<hr />

<h3>Date: short pattern</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time2" Pattern="short" /&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TDateFormat ID="Time2" Pattern="short" /> <br />
<hr />

<h3>Date default pattern of <%= $this->Page->CurrentCulture %> </h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time3" Value="2004/12/06" /&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TDateFormat ID="Time3" Value="2004/12/06" /> <br />
<hr />

<h3>Currency default format</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Value="12.4" /&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TNumberFormat Type="currency" Value="12.4" /> <br />
<hr />
<h3>Currency, de_DE culture with Euro</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/> <br />

<hr />

<h3>Currency, US format with Euro</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /&gt;
</com:TTextHighlighter>

<h4>Result</h4>
<com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /> <br />
<hr />

<h3>Translation examples</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;Hello&lt;/com:TTranslate&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TTranslate>Hello</com:TTranslate> <br />
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" /&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TTranslate Text="Goodbye" /> <br />

<hr />
<h3>Using localization tag</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;%[ Goodbye ]%&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<%[ Goodbye ]%>
<br />

<hr />
<h3>Translation using a different catalogue </h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" Catalogue="tests" /&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<com:TTranslate Text="Goodbye" Catalogue="tests" />
<br />

<hr />
<h3>Translation with parameter substitution</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;
    {greeting} {name}!, The unix-time is "{time}".
    &lt;com:TTranslateParameter Key="name"&gt;
        &lt;com:TTranslate Catalogue="tests" Text="World" /&gt;
    &lt;/com:TTranslateParameter&gt;
    &lt;com:TTranslateParameter Key="greeting" Value="Hello" /&gt;
    &lt;com:TTranslateParameter Key="time" Value="&lt;%= Time() %&gt;" /&gt;
&lt;/com:TTranslate&gt;
</com:TTextHighlighter>

<h4>Result:</h4>

<com:TTranslate>
    {greeting} {name}!, The unix-time is "{time}".
    <com:TTranslateParameter Key="name">
        <com:TTranslate Catalogue="tests" Text="World" />
    </com:TTranslateParameter>
    <com:TTranslateParameter Key="greeting" Value="Hello" />
    <com:TTranslateParameter Key="time" Value="<%= Time() %>" />
</com:TTranslate>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45

<?php

class Home extends TPage
{
    /**
     * Change the globalization culture using value from request "lang" parameter.
     */
    public function __construct()
    {
        parent::__construct();
        $lang = $this->Request['lang'];
        $info = new CultureInfo();
        if($info->validCulture($lang)) //only valid lang is permitted
            $this->getApplication()->getGlobalization()->setCulture($lang);
    }

    /**
     * Initialize the page with some arbituary data.
     * @param TEventParameter event parameter.
     */
    public function onLoad($param)
    {
        parent::onLoad($param);
        $time1 = $this->Time1;
        $time1->Value = time();

        $number2 = $this->Number2;
        $number2->Value = 46412.416;

        $this->dataBind();
    }

    /**
     * Get the localized current culture name.
     * @return string localized curreny culture name.
     */
    public function getCurrentCulture()
    {
        $culture = $this->getApplication()->getGlobalization()->getCulture();
        $cultureInfo = new CultureInfo($culture);
        return $cultureInfo->getNativeName();
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.pl.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149

<%@ Title="Internacjonalizacja w PRADO"
    Page.Application.Globalization.TranslationCatalogue="index" %>
<com:TContent ID="body">
<h1>Internacjonalizacja w PRADO</h1>
<p>Ten przykład pokazuje podstawowe komponenty PRADO używane w procesach Internacjonalizacji i Lokalizacji aplikacji webowych. Ta strona używa wielu zlokalizowanych, pod względem językowo-kulturowym, szablonów aby wyświetlić właściwe tłumaczenie. Aby zobaczyć inne lokalizacje, musisz zmienić ustawienia językowe w swojej przeglądarce.
</p>

<p>
Twoim obecnym językiem jest: <%= $this->Page->CurrentCulture %>.
<div class="links">
    Dostępne lokalizacje:
    <com:LanguageList />
</div>
</p>

<p>
    Nawiązanie do szablonów kulturowo-językowych. Tekst może zostać zlokalizowany przy użyciu wielu źródeł tłumaczeń. PRADO umożliwia przechowywanie tłumaczeń przy pomocy następujących modułów: gettext, XML, SQLite oraz MySQL. Przykład do którego prowadzi poniższy odnośnik pokazuje jak można zlokalizować treść używając kontrolki TTranslate.
<hr />
<h2>Wstęp</h2>
<p> Tworzenie i utrzymywanie wielojęzykowych serwisów to problem który trapi wielu programistów. </p>
<dl>
<dt><strong>Internacjonalizacja (I18N)</strong></dt>
<dd> To proces takiego przygotowania produktu aby mógł operować na danych w różnych językach, na wielu rynkach bez konieczności zmian w nim samym. </dd>
<dt><strong>Lokalizacja (L10N)</strong></dt>
<dd> To kolejny etap, jest to proces tłumaczenia i dostosowywania produktu do konkretnych wymagań językowo-kulturowych.</dd>
</dl>
<p>PRADO obsługuje następujące mechanizmy: </p>
<ul id="u1" class="block-content">
  <li>Tłumaczenie tekstu </li>
  <li>Tłumaczenie atrybutów (todo) </li>
  <li>Podstawianie parametrów (wraz z koniecznym tłumaczeniem) </li>
  <li>Formatowanie dat, liczb i walut </li>
</ul>
<h2>Przykłady</h2>
<h3>Data: pełny format językowo-kulturowy: en_GB</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/> <br />
<hr />

<h3>Data: format krótki</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time2" Pattern="short" /&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TDateFormat ID="Time2" Pattern="short" /> <br />
<hr />

<h3>Domyślny format daty dla języka: <%= $this->Page->CurrentCulture %> </h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time3" Value="2004/12/06" /&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TDateFormat ID="Time3" Value="2004/12/06" /> <br />
<hr />

<h3>Domyślny format waluty</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Value="12.4" /&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TNumberFormat Type="currency" Value="12.4" /> <br />
<hr />
<h3>Waluty, format językowo-kulturowy de_DE w Euro</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/> <br />

<hr />

<h3>Waluty, format Amerykański w Euro</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /&gt;
</com:TTextHighlighter>
<h4>Wynik</h4>
<com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /> <br />
<hr />

<h3>Tłumaczenia</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;Hello&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TTranslate>Hello</com:TTranslate> <br />
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" /&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TTranslate Text="Goodbye" /> <br />

<hr />
<h3>Using localization tag</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;%[ Goodbye ]%&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<%[ Goodbye ]%>
<br />

<hr />
<h3>Tłumaczenie z wykorzystaniem innego katalogu </h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" Catalogue="tests" /&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>
<com:TTranslate Text="Goodbye" Catalogue="tests" />
<br />

<hr />
<h3>Tłumaczenie z wykorzystanie podstawiania parametru</h3>
<h4>Przykład:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;
    {greeting} {name}!, The unix-time is "{time}".
    &lt;com:TTranslateParameter Key="name"&gt;
        &lt;com:TTranslate Catalogue="tests" Text="World" /&gt;
    &lt;/com:TTranslateParameter&gt;
    &lt;com:TTranslateParameter Key="greeting" Value="Hello" /&gt;
    &lt;com:TTranslateParameter Key="time" Value="&lt;%= Time() %&gt;" /&gt;
&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
<h4>Wynik:</h4>

<com:TTranslate>
    {greeting} {name}!, The unix-time is "{time}".
    <com:TTranslateParameter Key="name">
        <com:TTranslate Catalogue="tests" Text="World" />
    </com:TTranslateParameter>
    <com:TTranslateParameter Key="greeting" Value="Hello" />
    <com:TTranslateParameter Key="time" Value="<%= Time() %>" />
</com:TTranslate>

<div class="last-modified">$Id: Home.pl.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/Home.zh.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156

<%@ Title="PRADO 国际化"
    Page.Application.Globalization.TranslationCatalogue="index" %>
<com:TContent ID="body">

<h1>PRADO 国际化</h1>
<p>本演示将介绍如何用PRADO中的一些部件对您的Web应用进行国际化和本地化。
本网页的显示是根据您的当地设置从多个不同语言的模板中选择进行的。
如果你想查看其它语言版本，请更改浏览器的语言设置。</p>

<p>
您目前的语言设置是
<%= $this->Page->CurrentCulture %>.
<div class="links">
可查看的语言版本包括：
    <com:LanguageList />
</div>
</p>

<p>
除了能自动侦知语言设置的模板外，文本也可以使用不同的翻译源进行本地化。
PRADO提供了gettext，XML，SQLite以及MySQL等手段用于存放消息的各种翻译。
下面连接所指向的例子展示了如何使用TTranslate部件对文本进行本地化。
<hr />
<h2>简介</h2>
<p>开发和维护多语言的站点对Web开发者而言是一个很常见的问题。</p>
<dl>
<dt><strong>国际化（I18N）</strong></dt>
<dd>产品开发的一个步骤，它使得产品能接受不同语言的数据，并且在没有更改设计
的情况下使产品能用于不同的市场。</dd>
<dt><strong>L本地化（L10N）</strong></dt>
<dd>国际化的一个细节步骤，它针对某个特定的市场文化对产品进行翻译和调整。</dd>
</dl>
<p>PRADO支持以下功能：</p>
<ul id="u1" class="block-content">
  <li>文本翻译</li>
  <li>属性翻译（尚未完成）</li>
  <li>参数替换（如需要可进行翻译）</li>
  <li>日期，数字和货币的格式化</li>
  </ul>
<h2>例子</h2>
<h3>日期：完整格式，en_GB语言设置</h3>
<h4>例: </h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/&gt;
</com:TTextHighlighter>
<h4>结果: </h4>
<com:TDateFormat ID="Time1" Pattern="full" Culture="en_GB"/> <br />
<hr />

<h3>日期：短格式</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time2" Pattern="short" /&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TDateFormat ID="Time2" Pattern="short" /> <br />
<hr />

<h3>日期：<%= $this->Page->CurrentCulture %>的缺省模式</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TDateFormat ID="Time3" Value="2004/12/06" /&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TDateFormat ID="Time3" Value="2004/12/06" /> <br />
<hr />

<h3>货币，缺省格式</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Value="12.4" /&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TNumberFormat Type="currency" Value="12.4" /> <br />
<hr />
<h3>货币，de_DE语言以及欧币</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TNumberFormat ID="Number2" Type="currency" Culture="de_DE" Currency="EUR"/> <br />

<hr />

<h3>货币, 美国格式以及欧币</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TNumberFormat Type="currency" Culture="en_US" Currency="EUR" Value="100" /> <br />
<hr />

<h3>翻译实例</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;Hello&lt;/com:TTranslate&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TTranslate>Hello</com:TTranslate> <br />
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" /&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TTranslate Text="Goodbye" /> <br />

<hr />
<h3>Using localization tag</h3>
<h4>Example:</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;%[ Goodbye ]%&gt;
</com:TTextHighlighter>

<h4>Result:</h4>
<%[ Goodbye ]%>
<br />

<hr />
<h3>用不同目录进行翻译</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate Text="Goodbye" Catalogue="tests" /&gt;
</com:TTextHighlighter>
<h4>结果：</h4>
<com:TTranslate Text="Goodbye" Catalogue="tests" />
<br />

<hr />
<h3>用参数替换进行翻译</h3>
<h4>例：</h4>
<com:TTextHighlighter Language="prado" CssClass="source">
&lt;com:TTranslate&gt;
    {greeting} {name}!, The unix-time is "{time}".
    &lt;com:TTranslateParameter Key="name"&gt;
        &lt;com:TTranslate Catalogue="tests" Text="World" /&gt;
    &lt;/com:TTranslateParameter&gt;
    &lt;com:TTranslateParameter Key="greeting" Value="Hello" /&gt;
    &lt;com:TTranslateParameter Key="time" Value="&lt;%= Time() %&gt;" /&gt;
&lt;/com:TTranslate&gt;
</com:TTextHighlighter>

<h4>结果：</h4>

<com:TTranslate>
    {greeting} {name}!, The unix-time is "{time}".
    <com:TTranslateParameter Key="name">
        <com:TTranslate Catalogue="tests" Text="World" />
    </com:TTranslateParameter>
    <com:TTranslateParameter Key="greeting" Value="Hello" />
    <com:TTranslateParameter Key="time" Value="<%= Time() %>" />
</com:TTranslate>

<div class="last-modified">$Id: Home.zh.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/LanguageList.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

<?php
/**
 * Language List
 * @author $Author: weizhuo $
 * @version $Id: LanguageList.php 1398 2006-09-08 19:31:03Z xue $
 * @package prado.examples
 */

/**
 *
 * @author $Author: weizhuo $
 * @version $Id: LanguageList.php 1398 2006-09-08 19:31:03Z xue $
 */
class LanguageList extends TTemplateControl
{

}

?>


PRADO QuickStart Source View

Template file: | Home.de.page
Template file: | Home.es.page
Template file: | Home.fr.page
Template file: | Home.page
Class file: | Home.php
Template file: | Home.pl.page
Template file: | Home.zh.page
Class file: | LanguageList.php
Template file: | LanguageList.tpl

/Advanced/Samples/I18N/LanguageList.tpl

1
2
3
4
5
6
7
8
9
10

<ul>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=en">English</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=zh">中文简体</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=zh_TW">中文繁體</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=de">Deutsch</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=es">Español</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=fr">Français</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=id">Bahasa Indonesia</a></li>
        <li><a href="index.php?page=<%= $this->Request->ServiceParameter %>&amp;lang=pl">Polska</a></li>
    </ul>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php
Template file: | LabeledTextBox.tpl

/Controls/Samples/LabeledTextBox1/Home.page

1
2
3
4
5
6
7
8
9
10
11

<com:TContent ID="body" >
<com:LabeledTextBox
    ID="Input"
    Label.Text="Username" />
<com:TButton
    Text="Submit"
    OnClick="buttonClicked" />
<com:TRequiredFieldValidator
    ControlToValidate="Input.TextBox"
    ErrorMessage="You must enter a value"/>
<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php
Template file: | LabeledTextBox.tpl

/Controls/Samples/LabeledTextBox1/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13

<?php

Prado::using('Application.pages.Controls.Samples.LabeledTextBox1.LabeledTextBox');

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $sender->Text=$this->Input->TextBox->Text;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php
Template file: | LabeledTextBox.tpl

/Controls/Samples/LabeledTextBox1/LabeledTextBox.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

<?php

class LabeledTextBox extends TTemplateControl
{
    public function getLabel()
    {
        $this->ensureChildControls();
        return $this->getRegisteredObject('Label');
    }

    public function getTextBox()
    {
        $this->ensureChildControls();
        return $this->getRegisteredObject('TextBox');
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php
Template file: | LabeledTextBox.tpl

/Controls/Samples/LabeledTextBox1/LabeledTextBox.tpl

1
2

<com:TLabel ID="Label" ForControl="TextBox" />
<com:TTextBox ID="TextBox" />


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php

/Controls/Samples/LabeledTextBox2/Home.page

1
2
3
4
5
6
7
8
9
10
11

<com:TContent ID="body" >
<com:LabeledTextBox
    ID="Input"
    Label.Text="Username" />
<com:TButton
    Text="Submit"
    OnClick="buttonClicked" />
<com:TRequiredFieldValidator
    ControlToValidate="Input.TextBox"
    ErrorMessage="You must enter a value"/>
<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php

/Controls/Samples/LabeledTextBox2/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13

<?php

Prado::using('Application.pages.Controls.Samples.LabeledTextBox2.LabeledTextBox');

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $sender->Text=$this->Input->TextBox->Text;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php
Class file: | LabeledTextBox.php

/Controls/Samples/LabeledTextBox2/LabeledTextBox.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33

<?php

class LabeledTextBox extends TCompositeControl
{
    private $_label;
    private $_textbox;

    public function createChildControls()
    {
        $this->_label=new TLabel;
        $this->_label->setID('Label');
        $this->getControls()->add($this->_label);
        $this->getControls()->add('&nbsp;');
        $this->_textbox=new TTextBox;
        $this->_textbox->setID('TextBox');
        $this->_label->setForControl('TextBox');
        $this->getControls()->add($this->_textbox);
    }

    public function getLabel()
    {
        $this->ensureChildControls();
        return $this->_label;
    }

    public function getTextBox()
    {
        $this->ensureChildControls();
        return $this->_textbox;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/ResetValidation/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25

<com:TContent ID="body">

<h1>Reset Validation using Javascript</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" />
<com:TRequiredFieldValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    Text="Field required." />
<com:TButton Text="Submit" ValidationGroup="Group1" />

<a href="javascript: Prado.Validation.reset('Group1')">Reset Validation</a>
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/ResetValidation/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TBulletedList/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83

<com:TContent ID="body">

<h1>TBulletedList Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Bulleted list with default settings:
</td>
<td class="sampleaction">
<com:TBulletedList>
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TBulletedList>
</td>
</tr>

<tr>
<td class="samplenote">
Bulleted list with customized color, font, bullet style:
</td>
<td class="sampleaction">
<com:TBulletedList
    BulletStyle="UpperRoman"
    FirstBulletNumber="5"
    BackColor="silver"
    Font.Size="12pt">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TBulletedList>
</td>
</tr>

<tr>
<td class="samplenote">
Bulleted list with image bullets:
</td>
<td class="sampleaction">
<com:TBulletedList BulletStyle="CustomImage" BulletImageUrl=<%~bullet.gif%> >
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TBulletedList>
</td>
</tr>

<tr>
<td class="samplenote">
Bulleted list of hyperlinks:
</td>
<td class="sampleaction">
<com:TBulletedList DisplayMode="HyperLink" Target="_blank">
  <com:TListItem Value="http://www.google.com/" Text="google" />
  <com:TListItem Value="http://www.yahoo.com/" Text="yahoo" />
  <com:TListItem Value="http://www.amazon.com/" Text="amazon" />
</com:TBulletedList>
</td>

<tr>
<td class="samplenote">
Bulleted list of link buttons (click on them to see the result):
</td>
<td class="sampleaction">
<com:TBulletedList DisplayMode="LinkButton" OnClick="buttonClicked">
  <com:TListItem Value="http://www.google.com/" Text="google" />
  <com:TListItem Value="http://www.yahoo.com/" Text="yahoo" />
  <com:TListItem Value="http://www.amazon.com/" Text="amazon" />
</com:TBulletedList>
<com:TLabel ID="Result" ForeColor="red" />
</td>

</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TBulletedList/Home.php

1
2
3
4
5
6
7
8
9
10
11
12

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $item=$sender->Items[$param->Index];
        $this->Result->Text="You clicked $item->Text : $item->Value.";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TButton/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51

<com:TContent ID="body">

<h1>TButton Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Button with customized color, font and width:
</td><td class="sampleaction">
<com:TButton
    Text="text"
    Width="200px"
    ForeColor="silver"
    BackColor="black"
    Font.Size="14pt"
/>
</td></tr>

<tr><td class="samplenote">
A click button:
</td><td class="sampleaction">
<com:TButton Text="click me" OnClick="buttonClicked" />
</td></tr>

<tr><td class="samplenote">
A command button:
</td><td class="sampleaction">
<com:TButton
    Text="click me"
    OnCommand="buttonClicked"
    CommandName="test"
    CommandParameter="value"
    />
</td></tr>

<tr><td class="samplenote">
A button causing validation:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TButton Text="submit" ValidationGroup="Group" />
</td></tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TButton/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        if($param instanceof TCommandEventParameter)
            $sender->Text="Name: {$param->CommandName}, Param: {$param->CommandParameter}";
        else
            $sender->Text="I'm clicked";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCheckBox/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93

<com:TContent ID="body">

<h1>TCheckBox Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A checkbox with customized text alignment, color and font:
</td><td class="sampleaction">
<com:TCheckBox
    Text="checkbox"
    TextAlign="Left"
    ForeColor="silver"
    BackColor="green"
    Font.Size="14pt"
/>
</td></tr>

<tr><td class="samplenote">
A checkbox with label and input attributes:
</td><td class="sampleaction">
<com:TCheckBox
    Text="click me"
    InputAttributes.value="value"
    LabelAttributes.style="color:red"
/>
</td></tr>

<tr><td class="samplenote">
An auto postback checkbox:
</td><td class="sampleaction">
<com:TCheckBox
    AutoPostBack="true"
    Text="click me"
    OnCheckedChanged="checkboxClicked"
    />
</td></tr>

<tr><td class="samplenote">
A checkbox causing validation on a textbox:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TCheckBox
    Text="submit"
    AutoPostBack="true"
    ValidationGroup="Group"
    />
</td></tr>

<tr><td class="samplenote">
A checkbox validated by a required field validator:
</td><td class="sampleaction">
<com:TCheckBox
    ID="CheckBox"
    Text="Consent"
    ValidationGroup="Group2"
    />
<com:TButton Text="Submit" ValidationGroup="Group2" />
<com:TRequiredFieldValidator
    ControlToValidate="CheckBox"
    Display="Dynamic"
    ErrorMessage="You must consent."
    ValidationGroup="Group2"
    />
</td></tr>

<tr><td class="samplenote">
A checkbox validated by a required field validator using AutoPostBack:
</td><td class="sampleaction">
<com:TCheckBox
    ID="CheckBox2"
    Text="Agree"
    Checked="true"
    AutoPostBack="true"
    ValidationGroup="Group3"
    />
<com:TRequiredFieldValidator
    ControlToValidate="CheckBox2"
    Display="Dynamic"
    ErrorMessage="You must agree."
    ValidationGroup="Group3"
    />
</td></tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCheckBox/Home.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Home extends TPage
{
    public function checkboxClicked($sender,$param)
    {
        $sender->Text="I'm clicked";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCheckBoxList/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208

<com:TContent ID="body">

<h1>TCheckBoxList Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Check box list with default settings:
</td>
<td class="sampleaction">
<com:TCheckBoxList>
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TCheckBoxList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list with customized cellpadding, cellspacing, color and text alignment:
</td>
<td class="sampleaction">
<com:TCheckBoxList
    CellPadding="5"
    CellSpacing="1"
    BackColor="silver"
    TextAlign="Left">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TCheckBoxList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list with vertical (default) repeat direction:
</td>
<td class="sampleaction">
<com:TCheckBoxList RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TCheckBoxList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list with horizontal repeat direction:
</td>
<td class="sampleaction">
<com:TCheckBoxList RepeatDirection="Horizontal"    RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TCheckBoxList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list with flow layout and vertical (default) repeat direction:
</td>
<td class="sampleaction">
<com:TCheckBoxList RepeatLayout="Flow" RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TCheckBoxList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list with flow layout and horizontal repeat direction:
</td>
<td class="sampleaction">
<com:TCheckBoxList
    RepeatLayout="Flow"
    RepeatDirection="Horizontal"
    RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TCheckBoxList>
</td>
</tr>

<tr>
<td class="samplenote">
Check box list's behavior upon postback:
</td>
<td class="sampleaction">
<com:TCheckBoxList ID="CheckBoxList">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Enabled="false" />
  <com:TListItem Value="value 5" Text="item 5" Selected="true" />
</com:TCheckBoxList>
<com:TButton Text="Submit" OnClick="buttonClicked" />
<br/>
<com:TLabel ID="SelectionResult" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Auto postback check box list:
</td>
<td class="sampleaction">
<com:TCheckBoxList
    AutoPostBack="true"
    OnSelectedIndexChanged="selectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Enabled="false" />
  <com:TListItem Value="value 5" Text="item 5" Selected="true" />
</com:TCheckBoxList>
<com:TLabel ID="SelectionResult2" ForeColor="red" />
</td>
</tr>

</table>

<h2>Checkbox Lists with DataBinding</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
Databind to an integer-indexed array:
</td>
<td class="sampleaction">
<com:TCheckBoxList ID="DBCheckBoxList1"
    AutoPostBack="true"
    OnSelectedIndexChanged="DBCheckBoxList1Changed" />
<com:TLabel ID="DBCheckBoxList1Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind to an associative array:
</td>
<td class="sampleaction">
<com:TCheckBoxList ID="DBCheckBoxList2"
    AutoPostBack="true"
    OnSelectedIndexChanged="DBCheckBoxList2Changed" />
<com:TLabel ID="DBCheckBoxList2Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind with DataTextField and DataValueField specified:
</td>
<td class="sampleaction">
<com:TCheckBoxList ID="DBCheckBoxList3"
    AutoPostBack="true"
    DataTextField="name"
    DataValueField="id"
    OnSelectedIndexChanged="DBCheckBoxList3Changed" />
<com:TLabel ID="DBCheckBoxList3Result" ForeColor="red" />
</td>
</tr>

</table>

<h2>CheckBox List with Validation</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
CheckBox list causing validation:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    ErrorMessage="You must enter a value"
    Display="Dynamic"
    ValidationGroup="Group2"
    />
<com:TCheckBoxList AutoPostBack="true" ValidationGroup="Group2">
  <com:TListItem Text="Agree" />
  <com:TListItem Text="Disagree" />
</com:TCheckBoxList>
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCheckBoxList/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $data=array('item 1','item 2','item 3','item 4');
            $this->DBCheckBoxList1->DataSource=$data;
            $this->DBCheckBoxList1->dataBind();

            $data=array('key 1'=>'item 1','key 2'=>'item 2',
                        'key 3'=>'item 3','key 4'=>'item 4');
            $this->DBCheckBoxList2->DataSource=$data;
            $this->DBCheckBoxList2->dataBind();

            $data=array(
                array('id'=>'001','name'=>'John','age'=>31),
                array('id'=>'002','name'=>'Mary','age'=>30),
                array('id'=>'003','name'=>'Cary','age'=>20));
            $this->DBCheckBoxList3->DataSource=$data;
            $this->DBCheckBoxList3->dataBind();
        }
    }

    protected function collectSelectionResult($input,$output)
    {
        $indices=$input->SelectedIndices;
        $result='';
        foreach($indices as $index)
        {
            $item=$input->Items[$index];
            $result.="(Index: $index, Value: $item->Value, Text: $item->Text)";
        }
        if($result==='')
            $output->Text='Your selection is empty.';
        else
            $output->Text='Your selection is: '.$result;
    }

    public function buttonClicked($sender,$param)
    {
        $this->collectSelectionResult($this->CheckBoxList,$this->SelectionResult);
    }

    public function selectionChanged($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->SelectionResult2);
    }

    public function DBCheckBoxList1Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBCheckBoxList1Result);
    }

    public function DBCheckBoxList2Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBCheckBoxList2Result);
    }

    public function DBCheckBoxList3Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBCheckBoxList3Result);
    }

}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TClientSideValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36

<com:TContent ID="body">
<h1>Conditional Validation (client-side + server side)</h1>

<table class="sampletable">
<tr>
<td class="samplenote">
Validator with default settings:<br />
Check "optional" to validate both textboxes
</td>
<td class="sampleaction">
        <com:TTextBox ID="text1" />
        <com:TRequiredFieldValidator
            ID="validator1"
            ControlToValidate="text1"
            ErrorMessage="*"
            ControlCssClass="required"/>
        <com:TTextBox ID="text2" />
        <com:TRequiredFieldValidator
            ID="validator2"
            ControlToValidate="text2"
            OnValidate="check_validate"
            ErrorMessage="*"
            ControlCssClass="required">
        <prop:ClientSide.OnValidate>
            sender.enabled = $('<%= $this->check1->ClientID %>').checked;
        </prop:ClientSide.OnValidate>

        </com:TRequiredFieldValidator>
        <com:TCheckBox ID="check1" Text="Optional" />
    <com:TButton ID="submit1" Text="Submit" />
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1784 2007-03-27 08:34:28Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TClientSideValidator/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

<?php

class Home extends TPage
{
    function check_validate($sender, $params)
    {
        $sender->enabled = $this->check1->checked;
    }

    function onPreRender($param)
    {
        //always re-enable the validator2 so as to display the client-side validator
        $this->validator2->enabled=true;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCompareValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76

<com:TContent ID="body">

<h1>TCompareValidator Samples</h1>
<p><strong>Note:</strong> TCompareValidator will start
to validate only if both inputs are not empty.</p>

<table class="sampletable">

<tr>
<td class="samplenote">
Compare validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" Text="a1" />
<com:TTextBox ID="TextBox11" Text="a2"/>
<com:TCompareValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    ControlToCompare="TextBox11"
    Text="The two textboxes must have the same value." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Compare validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" Text="b1"/>
<com:TTextBox ID="TextBox22" Text="b2" />
<com:TCompareValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    ControlToCompare="TextBox22"
    Text="The two textboxes must have the same value." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

<tr>
<td class="samplenote">
Comparing with a constant value:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox3" Text="a" />
<com:TCompareValidator
    ValidationGroup="Group3"
    ControlToValidate="TextBox3"
    ValueToCompare="test"
    Text="You must enter 'test'." />
<com:TButton Text="Submit" ValidationGroup="Group3" />
</td>
</tr>

<tr>
<td class="samplenote">
Comparing with an integer:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox4" Text="0" />
<com:TCompareValidator
    ValidationGroup="Group4"
    ControlToValidate="TextBox4"
    ValueToCompare="100"
    DataType="Integer"
    Operator="GreaterThan"
    Text="You must enter an integer greater than 100." />
<com:TButton Text="Submit" ValidationGroup="Group4" />
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCompareValidator/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCustomValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70

<com:TContent ID="body">

<script type="text/javascript"><!--
function myValidationFunction(sender, parameter)
{
    if(parameter == 'test')
        return true;
    else
        return false;
}
--></script>

<h1>TCustomValidator Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Custom validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" />
<com:TCustomValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    ClientValidationFunction="myValidationFunction"
    OnServerValidate="serverValidate"
    Text="You must enter 'test'." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Custom validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" />
<com:TCustomValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    ClientValidationFunction="myValidationFunction"
    OnServerValidate="serverValidate"
    Text="You must enter 'test'." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

<tr>
<td class="samplenote">
Custom validator with focus-on-error enabled and dynamic display:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox3" />
<com:TCustomValidator
    ValidationGroup="Group3"
    ControlToValidate="TextBox3"
    ClientValidationFunction="myValidationFunction"
    OnServerValidate="serverValidate"
    FocusOnError="true"
    Text="You must enter 'test'." />
<com:TButton Text="Submit" ValidationGroup="Group3" />
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TCustomValidator/Home.php

1
2
3
4
5
6
7
8
9
10
11
12

<?php

class Home extends TPage
{
    public function serverValidate($sender,$param)
    {
        if($param->Value!=='test')
            $param->IsValid=false;
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample1.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

<com:TContent ID="body">

<h1>TDataGrid Sample 1</h1>
<h2>Using Automatically Generated Columns</h2>

<com:TDataGrid
    ID="DataGrid"
    EnableViewState="false"
    CellPadding="2"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    />

<div class="last-modified">$Id: Sample1.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample1.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41

<?php

class Sample1 extends TPage
{
    protected function getData()
    {
        return array(
            array('id'=>'ITN001','name'=>'Motherboard','quantity'=>1,'price'=>100.00,'imported'=>true),
            array('id'=>'ITN002','name'=>'CPU','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN003','name'=>'Harddrive','quantity'=>2,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN004','name'=>'Sound card','quantity'=>1,'price'=>40.00,'imported'=>false),
            array('id'=>'ITN005','name'=>'Video card','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN006','name'=>'Keyboard','quantity'=>1,'price'=>20.00,'imported'=>false),
            array('id'=>'ITN007','name'=>'Monitor','quantity'=>2,'price'=>300.00,'imported'=>true),
            array('id'=>'ITN008','name'=>'CDRW drive','quantity'=>1,'price'=>40.00,'imported'=>true),
            array('id'=>'ITN009','name'=>'Cooling fan','quantity'=>2,'price'=>10.00,'imported'=>false),
            array('id'=>'ITN010','name'=>'Video camera','quantity'=>20,'price'=>30.00,'imported'=>true),
            array('id'=>'ITN011','name'=>'Card reader','quantity'=>10,'price'=>24.00,'imported'=>true),
            array('id'=>'ITN012','name'=>'Floppy drive','quantity'=>50,'price'=>12.00,'imported'=>false),
            array('id'=>'ITN013','name'=>'CD drive','quantity'=>25,'price'=>20.00,'imported'=>true),
            array('id'=>'ITN014','name'=>'DVD drive','quantity'=>15,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN015','name'=>'Mouse pad','quantity'=>50,'price'=>5.00,'imported'=>false),
            array('id'=>'ITN016','name'=>'Network cable','quantity'=>40,'price'=>8.00,'imported'=>true),
            array('id'=>'ITN017','name'=>'Case','quantity'=>8,'price'=>65.00,'imported'=>false),
            array('id'=>'ITN018','name'=>'Surge protector','quantity'=>45,'price'=>15.00,'imported'=>false),
            array('id'=>'ITN019','name'=>'Speaker','quantity'=>35,'price'=>65.00,'imported'=>false),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataGrid->DataSource=$this->Data;
            $this->DataGrid->dataBind();
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample2.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64

<com:TContent ID="body">

<h1>TDataGrid Sample 2</h1>
<h2>Using Manually Specified Columns</h2>

<com:TDataGrid
    Width="700px"
    CellPadding="2"
    ID="DataGrid"
    AutoGenerateColumns="false"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF">

    <com:THyperLinkColumn
        HeaderText="Book Title"
        DataTextField="title"
        DataNavigateUrlField="ISBN"
        DataNavigateUrlFormatString="http://www.amazon.com/gp/product/%s"
        Target="_blank"
        />
    <com:TBoundColumn
        HeaderText="Publisher"
        DataField="publisher"
        />
    <com:TBoundColumn
        ItemStyle.HorizontalAlign="Right"
        ItemStyle.Wrap="false"
        ItemStyle.Font.Italic="false"
        ItemStyle.ForeColor="green"
        HeaderText="Price"
        DataField="price"
        DataFormatString="$%.2f"
        />
    <com:TCheckBoxColumn
        HeaderText="In-stock"
        HeaderStyle.Wrap="false"
        DataField="instock"
        />
    <com:TTemplateColumn>
        <prop:HeaderTemplate>Rating</prop:HeaderTemplate>
        <prop:ItemTemplate>
        <img src="images/star<%#$this->Parent->DataItem['rating']%>.gif" alt="" />
        </prop:ItemTemplate>
    </com:TTemplateColumn>
</com:TDataGrid>

<com:TPanel GroupingText="Column Visibility" Width="200px">

<com:TCheckBoxList
     AutoPostBack="true"
     OnSelectedIndexChanged="toggleColumnVisibility">
    <com:TListItem Text="Book Title" Selected="true" />
    <com:TListItem Text="Publisher" Selected="true" />
    <com:TListItem Text="Price" Selected="true" />
    <com:TListItem Text="In-stock" Selected="true" />
    <com:TListItem Text="Rating" Selected="true" />
</com:TCheckBoxList>

</com:TPanel>

<div class="last-modified">$Id: Sample2.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample2.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86

<?php

class Sample2 extends TPage
{
    protected function getData()
    {
        return array(
            array(
                'ISBN'=>'0596007124',
                'title'=>'Head First Design Patterns',
                'publisher'=>'O\'Reilly Media, Inc.',
                'price'=>29.67,
                'instock'=>true,
                'rating'=>4,
            ),
            array(
                'ISBN'=>'0201633612',
                'title'=>'Design Patterns: Elements of Reusable Object-Oriented Software',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>47.04,
                'instock'=>true,
                'rating'=>5,
            ),
            array(
                'ISBN'=>'0321247140',
                'title'=>'Design Patterns Explained : A New Perspective on Object-Oriented Design',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>37.49,
                'instock'=>true,
                'rating'=>4,
            ),
            array(
                'ISBN'=>'0201485672',
                'title'=>'Refactoring: Improving the Design of Existing Code',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>47.14,
                'instock'=>true,
                'rating'=>3,
            ),
            array(
                'ISBN'=>'0321213351',
                'title'=>'Refactoring to Patterns',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>38.49,
                'instock'=>true,
                'rating'=>2,
            ),
            array(
                'ISBN'=>'0735619670',
                'title'=>'Code Complete',
                'publisher'=>'Microsoft Press',
                'price'=>32.99,
                'instock'=>false,
                'rating'=>4,
            ),
            array(
                'ISBN'=>'0321278658',
                'title'=>'Extreme Programming Explained : Embrace Change',
                'publisher'=>'Addison-Wesley Professional',
                'price'=>34.99,
                'instock'=>true,
                'rating'=>3,
            ),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataGrid->DataSource=$this->Data;
            $this->DataGrid->dataBind();
        }
    }

    public function toggleColumnVisibility($sender,$param)
    {
        foreach($this->DataGrid->Columns as $index=>$column)
            $column->Visible=$sender->Items[$index]->Selected;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample3.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83

<com:TContent ID="body">

<h1>TDataGrid Sample 3</h1>
<h2>Interacting with TDataGrid</h2>

<com:TDataGrid
    Width="800px"
    CellPadding="2"
    ID="DataGrid"
    DataKeyField="ISBN"
    AutoGenerateColumns="false"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    EditItemStyle.BackColor="lightyellow"
    OnItemCreated="itemCreated"
    OnEditCommand="editItem"
    OnUpdateCommand="saveItem"
    OnCancelCommand="cancelItem"
    OnDeleteCommand="deleteItem"
    >

    <com:TBoundColumn
        ID="BookTitleColumn"
        HeaderText="Book Title"
        HeaderStyle.Width="400px"
        DataField="title"
        />
    <com:TBoundColumn
        ID="PublisherColumn"
        HeaderText="Publisher"
        HeaderStyle.Width="150px"
        DataField="publisher"
        />
    <com:TBoundColumn
        ID="PriceColumn"
        ItemStyle.HorizontalAlign="Right"
        ItemStyle.Wrap="false"
        ItemStyle.Font.Italic="false"
        ItemStyle.ForeColor="green"
        HeaderText="Price"
        HeaderStyle.Width="70px"
        DataField="price"
        DataFormatString="$%.2f"
        />
    <com:TCheckBoxColumn
        ID="InStockColumn"
        HeaderText="In-stock"
        DataField="instock"
        />
    <com:TDropDownListColumn
        ID="RatingColumn"
        HeaderText="Rating"
        DataTextField="rating"
        >
        <prop:DataTextFormatString><img src="images/star%s.gif" alt="" /></prop:DataTextFormatString>
        <com:TListItem Value="1" />
        <com:TListItem Value="2" />
        <com:TListItem Value="3" />
        <com:TListItem Value="4" />
        <com:TListItem Value="5" />
    </com:TDropDownListColumn>
    <com:TEditCommandColumn
        HeaderText="Edit"
        HeaderStyle.Width="100px"
        UpdateText="Save"
        ItemStyle.HorizontalAlign="Center"
        ItemStyle.Font.Italic="false"
        />
    <com:TButtonColumn
        ID="DeleteColumn"
        HeaderText="Delete"
        HeaderStyle.Width="50px"
        ItemStyle.HorizontalAlign="Center"
        ItemStyle.Font.Italic="false"
        Text="Delete"
        CommandName="delete"
        />
</com:TDataGrid>

<div class="last-modified">$Id: Sample3.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample3.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190

<?php

class Sample3 extends TPage
{
    private $_data=null;

    protected function getData()
    {
        if($this->_data===null)
            $this->loadData();
        return $this->_data;
    }

    protected function loadData()
    {
        // We use viewstate keep track of data.
        // In real applications, data should come from database using an SQL SELECT statement.
        // In the following tabular data, field 'ISBN' is the primary key.
        // All update and delete operations should come with an 'id' value in order to go through.
        if(($this->_data=$this->getViewState('Data',null))===null)
        {
            $this->_data=array(
                array(
                    'ISBN'=>'0596007124',
                    'title'=>'Head First Design Patterns',
                    'publisher'=>'O\'Reilly Media, Inc.',
                    'price'=>29.67,
                    'instock'=>true,
                    'rating'=>4,
                ),
                array(
                    'ISBN'=>'0201633612',
                    'title'=>'Design Patterns: Elements of Reusable Object-Oriented Software',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>47.04,
                    'instock'=>true,
                    'rating'=>5,
                ),
                array(
                    'ISBN'=>'0321247140',
                    'title'=>'Design Patterns Explained : A New Perspective on Object-Oriented Design',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>37.49,
                    'instock'=>true,
                    'rating'=>4,
                ),
                array(
                    'ISBN'=>'0201485672',
                    'title'=>'Refactoring: Improving the Design of Existing Code',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>47.14,
                    'instock'=>true,
                    'rating'=>3,
                ),
                array(
                    'ISBN'=>'0321213351',
                    'title'=>'Refactoring to Patterns',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>38.49,
                    'instock'=>true,
                    'rating'=>2,
                ),
                array(
                    'ISBN'=>'0735619670',
                    'title'=>'Code Complete',
                    'publisher'=>'Microsoft Press',
                    'price'=>32.99,
                    'instock'=>false,
                    'rating'=>4,
                ),
                array(
                    'ISBN'=>'0321278658 ',
                    'title'=>'Extreme Programming Explained : Embrace Change',
                    'publisher'=>'Addison-Wesley Professional',
                    'price'=>34.99,
                    'instock'=>true,
                    'rating'=>3,
                ),
            );
            $this->saveData();
        }
    }

    protected function saveData()
    {
        $this->setViewState('Data',$this->_data);
    }

    protected function updateBook($isbn,$title,$publisher,$price,$instock,$rating)
    {
        // In real applications, data should be saved to database using an SQL UPDATE statement
        if($this->_data===null)
            $this->loadData();
        $updateRow=null;
        foreach($this->_data as $index=>$row)
            if($row['ISBN']===$isbn)
                $updateRow=&$this->_data[$index];
        if($updateRow!==null)
        {
            $updateRow['title']=$title;
            $updateRow['publisher']=$publisher;
            $updateRow['price']=TPropertyValue::ensureFloat(ltrim($price,'$'));
            $updateRow['instock']=TPropertyValue::ensureBoolean($instock);
            $updateRow['rating']=TPropertyValue::ensureInteger($rating);
            $this->saveData();
        }
    }

    protected function deleteBook($isbn)
    {
        // In real applications, data should be saved to database using an SQL DELETE statement
        if($this->_data===null)
            $this->loadData();
        $deleteIndex=-1;
        foreach($this->_data as $index=>$row)
            if($row['ISBN']===$isbn)
                $deleteIndex=$index;
        if($deleteIndex>=0)
        {
            unset($this->_data[$deleteIndex]);
            $this->saveData();
        }
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataGrid->DataSource=$this->Data;
            $this->DataGrid->dataBind();
        }
    }

    public function itemCreated($sender,$param)
    {
        $item=$param->Item;
        if($item->ItemType==='EditItem')
        {
            // set column width of textboxes
            $item->BookTitleColumn->TextBox->Columns=40;
            $item->PriceColumn->TextBox->Columns=5;
        }
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem' || $item->ItemType==='EditItem')
        {
            // add an aleart dialog to delete buttons
            $item->DeleteColumn->Button->Attributes->onclick='if(!confirm(\'Are you sure?\')) return false;';
        }
    }

    public function editItem($sender,$param)
    {
        $this->DataGrid->EditItemIndex=$param->Item->ItemIndex;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function saveItem($sender,$param)
    {
        $item=$param->Item;
        $this->updateBook(
            $this->DataGrid->DataKeys[$item->ItemIndex],    // ISBN
            $item->BookTitleColumn->TextBox->Text,            // title
            $item->PublisherColumn->TextBox->Text,            // publisher
            $item->PriceColumn->TextBox->Text,                // price
            $item->InStockColumn->CheckBox->Checked,        // instock
            $item->RatingColumn->DropDownList->SelectedValue        // rating
            );
        $this->DataGrid->EditItemIndex=-1;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function cancelItem($sender,$param)
    {
        $this->DataGrid->EditItemIndex=-1;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function deleteItem($sender,$param)
    {
        $this->deleteBook($this->DataGrid->DataKeys[$param->Item->ItemIndex]);
        $this->DataGrid->EditItemIndex=-1;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample4.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55

<com:TContent ID="body">

<h1>TDataGrid Sample 4</h1>
<h2>Sorting with TDataGrid</h2>

<com:TDataGrid
    Width="700px"
    CellPadding="2"
    ID="DataGrid"
    AutoGenerateColumns="false"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    AllowSorting="true"
    OnSortCommand="sortDataGrid">

    <com:THyperLinkColumn
        SortExpression="title"
        HeaderText="Book Title"
        DataTextField="title"
        DataNavigateUrlField="ISBN"
        DataNavigateUrlFormatString="http://www.amazon.com/gp/product/%s"
        Target="_blank"
        />
    <com:TBoundColumn
        SortExpression="publisher"
        HeaderText="Publisher"
        DataField="publisher"
        />
    <com:TBoundColumn
        SortExpression="price"
        ItemStyle.HorizontalAlign="Right"
        ItemStyle.Wrap="false"
        ItemStyle.Font.Italic="false"
        ItemStyle.ForeColor="green"
        HeaderText="Price"
        DataField="price"
        DataFormatString="$%.2f"
        />
    <com:TCheckBoxColumn
        SortExpression="instock"
        HeaderText="In-stock"
        HeaderStyle.Wrap="false"
        DataField="instock"
        />
    <com:TTemplateColumn HeaderText="Rating" SortExpression="rating">
        <prop:ItemTemplate>
        <img src="images/star<%#$this->NamingContainer->DataItem['rating']%>.gif" alt="" />
        </prop:ItemTemplate>
    </com:TTemplateColumn>
</com:TDataGrid>

<div class="last-modified">$Id: Sample4.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample4.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<?php

Prado::using('Application.pages.Controls.Samples.TDataGrid.Sample2');

class Sample4 extends Sample2
{
    protected function sortData($data,$key)
    {
        $compare = create_function('$a,$b','if ($a["'.$key.'"] == $b["'.$key.'"]) {return 0;}else {return ($a["'.$key.'"] > $b["'.$key.'"]) ? 1 : -1;}');
        usort($data,$compare) ;
        return $data ;
    }

    public function sortDataGrid($sender,$param)
    {
        $this->DataGrid->DataSource=$this->sortData($this->Data,$param->SortExpression);
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample5.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62

<com:TContent ID="body">

<h1>TDataGrid Sample 5</h1>
<h2>Paging</h2>

<div style="width:500px">
<com:TDataGrid
    ID="DataGrid"
    AllowPaging="true"
    PageSize="5"
    PagerStyle.Mode="Numeric"
    PagerStyle.HorizontalAlign="Right"
    Width="100%"
    CellPadding="2"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    OnPageIndexChanged="changePage"
    OnPagerCreated="pagerCreated"
    />
</div>

<com:TPanel GroupingText="Pager Visibility" Width="300px">

<com:TCheckBoxList
     AutoPostBack="true"
     RepeatColumns="2"
     OnSelectedIndexChanged="changePagerPosition">
    <com:TListItem Text="Top" />
    <com:TListItem Text="Bottom"  Selected="true" />
</com:TCheckBoxList>

</com:TPanel>

<com:TPanel GroupingText="Pager Mode" Width="300px">

<com:TPanel GroupingText="NextPrev Pager" Width="300px">

Next Page Text:
<com:TTextBox ID="NextPageText" Text="Next" /><br/>
Prev Page Text:
<com:TTextBox ID="PrevPageText" Text="Prev" /><br/>
<com:TButton Text="Submit" OnClick="useNextPrevPager" />
</com:TPanel>

<com:TPanel GroupingText="Numeric Pager" Width="300px">

Page Button Count:
<com:TTextBox ID="PageButtonCount" Text="5" /><br/>
<com:TButton Text="Submit" OnClick="useNumericPager" />
</com:TPanel>

<com:TPanel GroupingText="Page Size" Width="300px">
<com:TTextBox ID="PageSize" Text="5" /><br/>
<com:TButton Text="Submit" OnClick="changePageSize" />
</com:TPanel>

</com:TPanel>

<div class="last-modified">$Id: Sample5.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample5.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68

<?php

Prado::using('Application.pages.Controls.Samples.TDataGrid.Sample1');

class Sample5 extends Sample1
{
    public function changePage($sender,$param)
    {
        $this->DataGrid->CurrentPageIndex=$param->NewPageIndex;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function pagerCreated($sender,$param)
    {
        $param->Pager->Controls->insertAt(0,'Page: ');
    }

    public function changePagerPosition($sender,$param)
    {
        $top=$sender->Items[0]->Selected;
        $bottom=$sender->Items[1]->Selected;
        if($top && $bottom)
            $position='TopAndBottom';
        else if($top)
            $position='Top';
        else if($bottom)
            $position='Bottom';
        else
            $position='';
        if($position==='')
            $this->DataGrid->PagerStyle->Visible=false;
        else
        {
            $this->DataGrid->PagerStyle->Position=$position;
            $this->DataGrid->PagerStyle->Visible=true;
        }
    }

    public function useNumericPager($sender,$param)
    {
        $this->DataGrid->PagerStyle->Mode='Numeric';
        $this->DataGrid->PagerStyle->NextPageText=$this->NextPageText->Text;
        $this->DataGrid->PagerStyle->PrevPageText=$this->PrevPageText->Text;
        $this->DataGrid->PagerStyle->PageButtonCount=$this->PageButtonCount->Text;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function useNextPrevPager($sender,$param)
    {
        $this->DataGrid->PagerStyle->Mode='NextPrev';
        $this->DataGrid->PagerStyle->NextPageText=$this->NextPageText->Text;
        $this->DataGrid->PagerStyle->PrevPageText=$this->PrevPageText->Text;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }

    public function changePageSize($sender,$param)
    {
        $this->DataGrid->PageSize=TPropertyValue::ensureInteger($this->PageSize->Text);
        $this->DataGrid->CurrentPageIndex=0;
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample6.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

<com:TContent ID="body">

<h1>TDataGrid Sample 6</h1>
<h2>Custom Paging</h2>

<div style="width:500px">
<com:TDataGrid
    ID="DataGrid"
    Width="100%"
    AllowPaging="true"
    AllowCustomPaging="true"
    VirtualItemCount="19"
    PageSize="5"
    PagerStyle.Mode="Numeric"
    PagerStyle.HorizontalAlign="Right"
    CellPadding="2"
    HeaderStyle.BackColor="black"
    HeaderStyle.ForeColor="white"
    ItemStyle.BackColor="#BFCFFF"
    ItemStyle.Font.Italic="true"
    AlternatingItemStyle.BackColor="#E6ECFF"
    OnPageIndexChanged="changePage"
    />
</div>

<div class="last-modified">$Id: Sample6.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php
Template file: | Sample6.page
Class file: | Sample6.php

/Controls/Samples/TDataGrid/Sample6.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56

<?php

Prado::using('Application.pages.Controls.Samples.TDataGrid.Sample1');

class Sample6 extends Sample1
{
    /**
     * Returns a subset of data.
     * In MySQL database, this can be replaced by LIMIT clause
     * in an SQL select statement.
     * @param integer the starting index of the row
     * @param integer number of rows to be returned
     * @return array subset of data
     */
    protected function getDataRows($offset,$rows)
    {
        $data=$this->getData();
        $page=array();
        for($i=0;$i<$rows;++$i)
        {
            if($offset+$i<$this->getRowCount())
                $page[$i]=$data[$offset+$i];
        }
        return $page;
    }

    /**
     * Returns total number of data rows.
     * In real DB applications, this may be replaced by an SQL select
     * query with count().
     * @return integer total number of data rows
     */
    protected function getRowCount()
    {
        return 19;
    }

    public function onLoad($param)
    {
        if(!$this->IsPostBack)
        {
            $this->DataGrid->DataSource=$this->getDataRows(0,$this->DataGrid->PageSize);
            $this->DataGrid->dataBind();
        }
    }

    public function changePage($sender,$param)
    {
        $this->DataGrid->CurrentPageIndex=$param->NewPageIndex;
        $offset=$param->NewPageIndex*$this->DataGrid->PageSize;
        $this->DataGrid->DataSource=$this->getDataRows($offset,$this->DataGrid->PageSize);
        $this->DataGrid->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php

/Controls/Samples/TDataList/Sample1.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49

<com:TContent ID="body">

<h1>TDataList Sample 1</h1>
<p>
TDataList is good at displaying tabular data in a non-tabular format. The following example displays a list of computer product information in 3 columns.
</p>
<p>
Since the page is mainly for display and does not require user interactions, the viewstate of TDataList is disabled to reduce page size.
</p>

<com:TDataList
     ID="DataList"
     EnableViewState="false"
     RepeatColumns="3"
     RepeatDirection="Horizontal"
     ItemStyle.Font.Italic="true"
     ItemStyle.BackColor="#BFCFFF"
     HeaderStyle.BackColor="black"
     HeaderStyle.ForeColor="white"
     FooterStyle.BackColor="gray"
     AlternatingItemStyle.BackColor="#E6ECFF">

<prop:HeaderTemplate>
<div style="font-weight:bold; text-align:center;">Computer Parts</div>
</prop:HeaderTemplate>

<prop:FooterTemplate>
<div style="font-weight:bold; text-align:center;">
Total <%# $this->Parent->ItemCount %> products.
</div>
</prop:FooterTemplate>

<prop:ItemTemplate>
<table border="0" width="100%">
<tr>
  <th>ID</th><th>Name</th><th>Quantity</th><th>Price</th>
</tr>
<tr>
  <td align="right"><%#$this->DataItem['id'] %></td>
  <td align="right"><%#$this->DataItem['name'] %></td>
  <td align="right"><%#$this->DataItem['quantity'] %></td>
  <td align="right">$<%#$this->DataItem['price'] %></td>
</tr>
</table>
</prop:ItemTemplate>

</com:TDataList>

<div class="last-modified">$Id: Sample1.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php

/Controls/Samples/TDataList/Sample1.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41

<?php

class Sample1 extends TPage
{
    protected function getData()
    {
        return array(
            array('id'=>'ITN001','name'=>'Motherboard','quantity'=>1,'price'=>100.00,'imported'=>true),
            array('id'=>'ITN002','name'=>'CPU','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN003','name'=>'Harddrive','quantity'=>2,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN004','name'=>'Sound card','quantity'=>1,'price'=>40.00,'imported'=>false),
            array('id'=>'ITN005','name'=>'Video card','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN006','name'=>'Keyboard','quantity'=>1,'price'=>20.00,'imported'=>false),
            array('id'=>'ITN007','name'=>'Monitor','quantity'=>2,'price'=>300.00,'imported'=>true),
            array('id'=>'ITN008','name'=>'CDRW drive','quantity'=>1,'price'=>40.00,'imported'=>true),
            array('id'=>'ITN009','name'=>'Cooling fan','quantity'=>2,'price'=>10.00,'imported'=>false),
            array('id'=>'ITN010','name'=>'Video camera','quantity'=>20,'price'=>30.00,'imported'=>true),
            array('id'=>'ITN011','name'=>'Card reader','quantity'=>10,'price'=>24.00,'imported'=>true),
            array('id'=>'ITN012','name'=>'Floppy drive','quantity'=>50,'price'=>12.00,'imported'=>false),
            array('id'=>'ITN013','name'=>'CD drive','quantity'=>25,'price'=>20.00,'imported'=>true),
            array('id'=>'ITN014','name'=>'DVD drive','quantity'=>15,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN015','name'=>'Mouse pad','quantity'=>50,'price'=>5.00,'imported'=>false),
            array('id'=>'ITN016','name'=>'Network cable','quantity'=>40,'price'=>8.00,'imported'=>true),
            array('id'=>'ITN017','name'=>'Case','quantity'=>8,'price'=>65.00,'imported'=>false),
            array('id'=>'ITN018','name'=>'Surge protector','quantity'=>45,'price'=>15.00,'imported'=>false),
            array('id'=>'ITN019','name'=>'Speaker','quantity'=>35,'price'=>65.00,'imported'=>false),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataList->DataSource=$this->Data;
            $this->DataList->dataBind();
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php

/Controls/Samples/TDataList/Sample2.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125

<com:TContent ID="body">

<h1>TDataList Sample 2</h1>

<com:TDataList
     ID="DataList"
     DataKeyField="id"
     OnEditCommand="editItem"
     OnCancelCommand="cancelItem"
     OnUpdateCommand="updateItem"
     OnDeleteCommand="deleteItem"
     OnSelectedIndexChanged="selectItem"
     HeaderStyle.BackColor="black"
     HeaderStyle.ForeColor="white"
     ItemStyle.BackColor="#BFCFFF"
     AlternatingItemStyle.BackColor="#E6ECFF"
     EditItemStyle.BackColor="lightgreen"
     SelectedItemStyle.BackColor="lightyellow">

<prop:HeaderTemplate>
<div style="font-weight:bold; text-align:center;">Computer Parts</div>
</prop:HeaderTemplate>

<prop:ItemTemplate>
<table border="0" width="100%">
<tr>
  <td>
  <com:TLinkButton
       Text=<%#$this->DataItem['id']%>
       CommandName="select"
       />
  <%#$this->DataItem['name']%>
  </td>
  <td align="right">
  <com:TLinkButton
       Text="Edit"
       CommandName="edit"
       />
  <com:TLinkButton
       Text="Delete"
       CommandName="delete"
       Attributes.onclick="if(!confirm('Are you sure?')) return false;"
       />
  </td>
</tr>
</table>
</prop:ItemTemplate>

<prop:SelectedItemTemplate>
<table border="1" width="100%">
<tr>
  <th>ID</th><th>Name</th><th>Quantity</th><th>Price</th>
</tr>
<tr>
  <td align="right"><%#$this->DataItem['id'] %></td>
  <td align="right"><%#$this->DataItem['name'] %></td>
  <td align="right"><%#$this->DataItem['quantity'] %></td>
  <td align="right">$<%#$this->DataItem['price'] %></td>
</tr>
<tr>
  <td colspan="4" align="right">
  <com:TLinkButton
       Text="Edit"
       CommandName="edit"
       />
  <com:TLinkButton
       Text="Delete"
       CommandName="delete"
       Attributes.onclick="if(!confirm('Are you sure?')) return false;"
       />
  </td>
</tr>
</table>
</prop:SelectedItemTemplate>

<prop:EditItemTemplate>
<table border="0" width="100%">
<tr>
  <td align="right">ID</td>
  <td><b><%#$this->DataItem['id']%></b></td>
</tr>
<tr>
  <td align="right">Name</td>
  <td><com:TTextBox
           ID="ProductName"
           Text=<%#$this->DataItem['name'] %>
           />
  </td>
</tr>
<tr>
  <td align="right">Quantity</td>
  <td><com:TTextBox
           ID="ProductQuantity"
           Text=<%#$this->DataItem['quantity'] %>
           />
  </td>
</tr>
<tr>
  <td align="right">Price</td>
  <td><com:TTextBox
           ID="ProductPrice"
           Text=<%#$this->DataItem['price'] %>
           />
  </td>
</tr>
<tr>
  <td align="right">Imported</td>
  <td><com:TCheckBox
           ID="ProductImported"
           Checked=<%#$this->DataItem['imported'] %>
           />
  </td>
</tr>
<tr>
  <td colspan="2" align="right">
    <com:TLinkButton Text="Save" CommandName="update" />
    <com:TLinkButton Text="Cancel" CommandName="cancel" />
  </td>
</tr>
</table>
</prop:EditItemTemplate>

</com:TDataList>

<div class="last-modified">$Id: Sample2.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php

/Controls/Samples/TDataList/Sample2.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132

<?php

class Sample2 extends TPage
{
    private $_data=null;

    protected function getData()
    {
        if($this->_data===null)
            $this->loadData();
        return $this->_data;
    }

    protected function loadData()
    {
        // We use viewstate keep track of data.
        // In real applications, data should come from database using an SQL SELECT statement.
        // In the following tabular data, field 'id' is the primary key.
        // All update and delete operations should come with an 'id' value in order to go through.
        if(($this->_data=$this->getViewState('Data',null))===null)
        {
            $this->_data=array(
                array('id'=>'ITN001','name'=>'Motherboard','quantity'=>1,'price'=>100.00,'imported'=>true),
                array('id'=>'ITN002','name'=>'CPU','quantity'=>1,'price'=>150.00,'imported'=>true),
                array('id'=>'ITN003','name'=>'Harddrive','quantity'=>2,'price'=>80.00,'imported'=>false),
                array('id'=>'ITN004','name'=>'Sound card','quantity'=>1,'price'=>40.00,'imported'=>false),
                array('id'=>'ITN005','name'=>'Video card','quantity'=>1,'price'=>150.00,'imported'=>true),
                array('id'=>'ITN006','name'=>'Keyboard','quantity'=>1,'price'=>20.00,'imported'=>true),
                array('id'=>'ITN007','name'=>'Monitor','quantity'=>2,'price'=>300.00,'imported'=>false),
            );
            $this->saveData();
        }
    }

    protected function saveData()
    {
        $this->setViewState('Data',$this->_data);
    }

    protected function updateProduct($id,$name,$quantity,$price,$imported)
    {
        // In real applications, data should be saved to database using an SQL UPDATE statement
        if($this->_data===null)
            $this->loadData();
        $updateRow=null;
        foreach($this->_data as $index=>$row)
            if($row['id']===$id)
                $updateRow=&$this->_data[$index];
        if($updateRow!==null)
        {
            $updateRow['name']=$name;
            $updateRow['quantity']=TPropertyValue::ensureInteger($quantity);
            $updateRow['price']=TPropertyValue::ensureFloat($price);
            $updateRow['imported']=TPropertyValue::ensureBoolean($imported);
            $this->saveData();
        }
    }

    protected function deleteProduct($id)
    {
        // In real applications, data should be saved to database using an SQL DELETE statement
        if($this->_data===null)
            $this->loadData();
        $deleteIndex=-1;
        foreach($this->_data as $index=>$row)
            if($row['id']===$id)
                $deleteIndex=$index;
        if($deleteIndex>=0)
        {
            unset($this->_data[$deleteIndex]);
            $this->saveData();
        }
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataList->DataSource=$this->Data;
            $this->DataList->dataBind();
        }
    }

    public function editItem($sender,$param)
    {
        $this->DataList->SelectedItemIndex=-1;
        $this->DataList->EditItemIndex=$param->Item->ItemIndex;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }

    public function cancelItem($sender,$param)
    {
        $this->DataList->SelectedItemIndex=-1;
        $this->DataList->EditItemIndex=-1;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }

    public function updateItem($sender,$param)
    {
        $item=$param->Item;
        $this->updateProduct(
            $this->DataList->DataKeys[$item->ItemIndex],
            $item->ProductName->Text,
            $item->ProductQuantity->Text,
            $item->ProductPrice->Text,
            $item->ProductImported->Checked);
        $this->DataList->EditItemIndex=-1;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }

    public function deleteItem($sender,$param)
    {
        $this->deleteProduct($this->DataList->DataKeys[$param->Item->ItemIndex]);
        $this->DataList->SelectedItemIndex=-1;
        $this->DataList->EditItemIndex=-1;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }

    public function selectItem($sender,$param)
    {
        $this->DataList->EditItemIndex=-1;
        $this->DataList->DataSource=$this->Data;
        $this->DataList->dataBind();
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TDataTypeValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58

<com:TContent ID="body">

<h1>TDataTypeValidator Samples</h1>
<p><strong>Note:</strong> TDataTypeValidator will start
to validate only if both inputs are not empty.</p>

<table class="sampletable">

<tr>
<td class="samplenote">
Data type validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" Text="a" />
<com:TDataTypeValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    DataType="Float"
    Text="You must enter a floating number." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Data type validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" Text="a"/>
<com:TDataTypeValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    DataType="Integer"
    Text="You must enter an integer." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

<tr>
<td class="samplenote">
Validating a date input:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox3" Text="a" />
<com:TDataTypeValidator
    ValidationGroup="Group3"
    ControlToValidate="TextBox3"
    DataType="Date"
    DateFormat="d/M/yyyy"
    Text="You must enter a valid date (d/M/yyyy)." />
<com:TButton Text="Submit" ValidationGroup="Group3" />
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TDataTypeValidator/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TDatePicker/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61

<com:TContent ID="body">

<h1>TDatePicker Samples</h1>

<table class="sampletable">

<tr>
    <td class="samplenote">Default TDatePicker</td>
    <td class="sampleaction">
        <com:TDatePicker />
    </td>
</tr>

<tr>
    <td class="samplenote">Button Mode, <br />pre-selected date 20-10-2005</td>
    <td class="sampleaction">
        <com:TDatePicker Mode="Button" Date="20-10-2005"/>
    </td>
</tr>

<tr>
    <td class="samplenote">InputMode="DropDownList", <br />custom DateFormat="yyyy/MMM"</td>
    <td class="sampleaction">
        <com:TDatePicker DateFormat="yyyy/MMM" InputMode="DropDownList"/>
    </td>
</tr>

<tr>
    <td class="samplenote">InputMode="DropDownList", <br/>custom DateFormat="MMM/yyyy", <br/>Culture="fr"</td>
    <td class="sampleaction">
        <com:TDatePicker DateFormat="MMM/yyyy" Culture="fr" InputMode="DropDownList"/>
    </td>
</tr>

<tr>
    <td class="samplenote">Custom DateFormat="日期：yyyy年M月d日", <br/>culture="zh_CN", <br />ImageButton mode, <br />pre-selected using Timestamp=&lt;%= @strtotime("-1 year") %&gt;</td>
    <td class="sampleaction">
        <com:TDatePicker Mode="ImageButton" Culture="zh_CN"
            DateFormat="日期：yyyy年M月d日"
            Timestamp=<%= @strtotime("-1 year") %>/>
    </td>
</tr>

<tr>
    <td class="samplenote">Custom DateFormat="yyyy/MMMM/dd", <br />DropDownList, <br />pre-selected Date="2005/05/15"</td>
    <td class="sampleaction">
        <com:TDatePicker DateFormat="yyyy/MMMM/dd" Date="2005/05/15" InputMode="DropDownList"/>
    </td>
</tr>

<tr>
    <td class="samplenote">DropDownList, <br />pre-selected date Timestamp=&lt;%= @strtotime("-1 month") %&gt;</td>
    <td class="sampleaction">
        <com:TDatePicker InputMode="DropDownList" Timestamp=<%= @strtotime("-1 month") %>/>
    </td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TDropDownList/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203

<com:TContent ID="body">

<h1>TDropDownList Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Dropdown list with default settings:
</td>
<td class="sampleaction">
<com:TDropDownList />
</td>
</tr>

<tr>
<td class="samplenote">
Dropdown list with initial items:
</td>
<td class="sampleaction">
<com:TDropDownList>
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TDropDownList>
</td>
</tr>

<tr>
<td class="samplenote">
List box with customized row number, color and font:
</td>
<td class="sampleaction">
<com:TDropDownList ForeColor="blue" Font.Size="14pt">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TDropDownList>
</td>
</tr>

<tr>
<td class="samplenote">
Disabled dropdown list:
</td>
<td class="sampleaction">
<com:TDropDownList Enabled="false">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TDropDownList>
</td>
</tr>

<tr>
<td class="samplenote">
Auto postback dropdown list:
</td>
<td class="sampleaction">
<com:TDropDownList
    AutoPostBack="true"
    OnSelectedIndexChanged="selectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TDropDownList>
<com:TLabel ID="SelectionResult" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Dropdown list's behavior upon postback:
</td>
<td class="sampleaction">
<com:TDropDownList ID="DropDownList1">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TDropDownList>
<com:TButton Text="Submit" OnClick="buttonClicked"/>
<com:TLabel ID="SelectionResult2" ForeColor="red" />
</td>
</tr>

</table>

<h2>DropDown Lists with DataBinding</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
Databind to an integer-indexed array:
</td>
<td class="sampleaction">
<com:TDropDownList ID="DBDropDownList1"
    AutoPostBack="true"
    OnSelectedIndexChanged="DBDropDownList1Changed" />
<com:TLabel ID="DBDropDownList1Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind to an associative array:
</td>
<td class="sampleaction">
<com:TDropDownList ID="DBDropDownList2"
    AutoPostBack="true"
    OnSelectedIndexChanged="DBDropDownList2Changed" />
<com:TLabel ID="DBDropDownList2Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind with DataTextField and DataValueField specified:
</td>
<td class="sampleaction">
<com:TDropDownList ID="DBDropDownList3"
    AutoPostBack="true"
    DataTextField="name"
    DataValueField="id"
    OnSelectedIndexChanged="DBDropDownList3Changed" />
<com:TLabel ID="DBDropDownList3Result" ForeColor="red" />
</td>
</tr>

</table>

<h2>List Boxes with Validation</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
Dropdown list is being validated:
</td>
<td class="sampleaction">
<com:TDropDownList ID="VDropDownList1">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TDropDownList>
<com:TRequiredFieldValidator
    ControlToValidate="VDropDownList1"
    ErrorMessage="You must make a selection other than the first option"
    InitialValue="value 1"
    Display="Dynamic"
    ValidationGroup="Group1"
    />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Dropdown list causing validation:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    ErrorMessage="You must enter a value"
    Display="Dynamic"
    ValidationGroup="Group2"
    />
<com:TDropDownList
    ID="VDropDownList2"
    AutoPostBack="true"
    ValidationGroup="Group2">
  <com:TListItem Text="Agree" />
  <com:TListItem Text="Disagree" />
</com:TDropDownList>
</td>
</tr>

<tr>
<td class="samplenote">
Dropdown list with option groups:
</td>
<td class="sampleaction">
<com:TDropDownList>
  <com:TListItem Value="value 1" Text="item 1" Attributes.Group="group 1"/>
  <com:TListItem Value="value 2" Text="item 2" Attributes.Group="group 1"/>
  <com:TListItem Value="value 3" Text="item 3" Attributes.Group="group 2"/>
  <com:TListItem Value="value 4" Text="item 4" Attributes.Group="group 2"/>
</com:TDropDownList>
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TDropDownList/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $data=array('item 1','item 2','item 3','item 4');
            $this->DBDropDownList1->DataSource=$data;
            $this->DBDropDownList1->dataBind();

            $data=array('key 1'=>'item 1','key 2'=>'item 2',
                        'key 3'=>'item 3','key 4'=>'item 4');
            $this->DBDropDownList2->DataSource=$data;
            $this->DBDropDownList2->dataBind();

            $data=array(
                array('id'=>'001','name'=>'John','age'=>31),
                array('id'=>'002','name'=>'Mary','age'=>30),
                array('id'=>'003','name'=>'Cary','age'=>20));
            $this->DBDropDownList3->DataSource=$data;
            $this->DBDropDownList3->dataBind();
        }
    }

    protected function collectSelectionResult($input,$output)
    {
        $indices=$input->SelectedIndices;
        $result='';
        foreach($indices as $index)
        {
            $item=$input->Items[$index];
            $result.="(Index: $index, Value: $item->Value, Text: $item->Text)";
        }
        if($result==='')
            $output->Text='Your selection is empty.';
        else
            $output->Text='Your selection is: '.$result;
    }

    public function DBDropDownList1Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBDropDownList1Result);
    }

    public function DBDropDownList2Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBDropDownList2Result);
    }

    public function DBDropDownList3Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBDropDownList3Result);
    }

    public function selectionChanged($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->SelectionResult);
    }

    public function buttonClicked($sender,$param)
    {
        $this->collectSelectionResult($this->DropDownList1,$this->SelectionResult2);
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TEmailAddressValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57

<com:TContent ID="body">

<h1>TEmailAddressValidator Samples</h1>
<p><strong>Note:</strong> TEmailAddressValidator will start
to validate only if the input is not empty.</p>

<table class="sampletable">

<tr>
<td class="samplenote">
Email address validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" Text="a"/>
<com:TEmailAddressValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    Text="Invalid email address." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Email address validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" Text="b"/>
<com:TEmailAddressValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    Text="Invalid email address." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

<tr>
<td class="samplenote">
Email address validator with focus-on-error enabled and dynamic display:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox3" Text="c"/>
<com:TEmailAddressValidator
    ValidationGroup="Group3"
    ControlToValidate="TextBox3"
    FocusOnError="true"
    Display="Dynamic"
    Text="Invalid email address." />
<com:TButton Text="Submit" ValidationGroup="Group3" />
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TEmailAddressValidator/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TExpression/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

<com:TContent ID="body">

<h1>TExpression Sample</h1>

<table class="sampletable">

<tr><td class="samplenote">
Using expression component tag:
</td><td class="sampleaction">
<com:TExpression Expression="$this->Page->Head->Title" />
</td></tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TFileUpload/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

<com:TContent ID="body">

<h1>TFileUpload Sample</h1>

<p>
Please choose a file to upload:
</p>

<com:TFileUpload OnFileUpload="fileUploaded" />

<com:TButton Text="Upload" />

<br/>

<com:TLabel ID="Result" />

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TFileUpload/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<?php

class Home extends TPage
{
    public function fileUploaded($sender,$param)
    {
        if($sender->HasFile)
        {
            $this->Result->Text="
                You just uploaded a file:
                <br/>
                Name: {$sender->FileName}
                <br/>
                Size: {$sender->FileSize}
                <br/>
                Type: {$sender->FileType}";
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/THtmlArea/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63

<com:TContent ID="body">

<h1>THtmlArea Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
THtmlArea with default settings:
</td><td class="sampleaction">
<com:THtmlArea ID="HtmlArea1" />
<com:TButton Text="Submit" OnClick="button1Clicked" />
<br/>
<com:TLiteral Encode="true" ID="Result1" />
</td></tr>

<tr><td class="samplenote">
Full featured THtmlArea example
</td><td class="sampleaction">
<com:THtmlArea ID="HtmlArea2" Width="670px" Height="300px">
  <prop:Options>
        theme : "advanced",
        plugins : "devkit,style,layer,table,save,advhr,advlink,emotions,iespell,insertdatetime,preview,media,searchreplace,print,contextmenu,paste,directionality,fullscreen,noneditable,visualchars,nonbreaking,xhtmlxtras",
        theme_advanced_buttons1_add_before : "save,newdocument,separator,styleselect",
        theme_advanced_buttons1_add : "separator,insertdate,inserttime,preview,separator,advsearchreplace",
        theme_advanced_buttons2_add_before: "cut,copy,paste,pastetext,pasteword,separator,search,replace,separator",
        theme_advanced_buttons3 : "tablecontrols,separator,emotions,iespell,media,advhr,separator,print,separator,ltr,rtl,separator,fullscreen",
        theme_advanced_buttons4 : "insertlayer,moveforward,movebackward,absolute,|,styleprops,|,cite,abbr,acronym,del,ins,|,visualchars,nonbreaking",
        theme_advanced_toolbar_location : "top",
        theme_advanced_toolbar_align : "left",
        theme_advanced_path_location : "bottom",
        content_css : "example_full.css",
        plugin_insertdate_dateFormat : "%Y-%m-%d",
        plugin_insertdate_timeFormat : "%H:%M:%S",
        extended_valid_elements : "hr[class|width|size|noshade],font[face|size|color|style],span[class|align|style]",
        external_link_list_url : "example_link_list.js",
        external_image_list_url : "example_image_list.js",
        flash_external_list_url : "example_flash_list.js",
        media_external_list_url : "example_media_list.js",
        file_browser_callback : "fileBrowserCallBack",
        theme_advanced_resize_horizontal : false,
        theme_advanced_resizing : true,
        nonbreaking_force_tab : true,
        apply_source_formatting : true
  </prop:Options>
</com:THtmlArea>
<com:TButton Text="Submit" OnClick="button2Clicked" />
<br/>
<com:TLiteral Encode="true" ID="Result2" />
</td></tr>

<tr><td class="samplenote">
THtmlArea with visual editting disabled:
</td><td class="sampleaction">
<com:THtmlArea ID="HtmlArea3" EnableVisualEdit="false" />
<br/>
<com:TButton Text="Submit" OnClick="button3Clicked" />
<br/>
<com:TLiteral Encode="true" ID="Result3" />
</td></tr>

</table>

<div class="last-modified">$Id: Home.page 1916 2007-05-09 02:14:41Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/THtmlArea/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<?php

class Home extends TPage
{
    public function button1Clicked($sender,$param)
    {
        $this->Result1->Text="You have entered: ".$this->HtmlArea1->Text;
    }

    public function button2Clicked($sender,$param)
    {
        $this->Result2->Text="You have entered: ".$this->HtmlArea2->Text;
    }

    public function button3Clicked($sender,$param)
    {
        $this->Result3->Text="You have entered: ".$this->HtmlArea3->Text;
    }
}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/THyperLink/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50

<com:TContent ID="body">

<h1>THyperLink Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A regular hyperlink:
</td><td class="sampleaction">
Welcome to
<com:THyperLink
    NavigateUrl="http://www.pradosoft.com/"
    Text="PradoSoft.com"
    Target="_blank" />.
</td></tr>

<tr><td class="samplenote">
A text hyperlink with css style:
</td><td class="sampleaction">
Welcome to
<com:THyperLink
    NavigateUrl="http://www.pradosoft.com/"
    Text="PradoSoft.com"
    Target="_blank"
    BackColor="silver"
    Font.Italic="true" />.
</td></tr>

<tr><td class="samplenote">
An image hyperlink:
</td><td class="sampleaction">
<com:THyperLink
    NavigateUrl="http://www.pradosoft.com/"
    ImageUrl=<%~hello_world.gif%>
    Text="Hello World" />.
</td></tr>

<tr><td class="samplenote">
A hyerplink with body contents as link text:
</td><td class="sampleaction">
<com:THyperLink
    NavigateUrl="http://www.pradosoft.com/"
    Target="_blank">
Body contents
</com:THyperLink>
</td></tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Class file: | HelloWorld.html
Template file: | Home.page

/Controls/Samples/TImage/HelloWorld.html

1
2
3
4
5
6
7
8

<html>
<head>
<title>Hello World!</title>
</head>
<body>
This is Hello World long description file!
</body>
</html>


PRADO QuickStart Source View

Class file: | HelloWorld.html
Template file: | Home.page

/Controls/Samples/TImage/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41

<com:TContent ID="body">

<h1>TImage Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Image with only <tt>ImageUrl</tt> being set:
</td><td class="sampleaction">
<com:TImage ImageUrl=<%~hello_world.gif%> />
</td></tr>

<tr><td class="samplenote">
Image with <tt>AlterantiveText</tt> being set:
</td><td class="sampleaction">
<com:TImage
    ImageUrl=<%~hello_world.gif%>
    AlternateText="Hello World!"/>
</td></tr>

<tr><td class="samplenote">
Image with <tt>baseline</tt> alignment:
</td><td class="sampleaction">
Hello World! Hello World! Hello World! Hello World! Hello World! Hello World!
Hello World! Hello World! Hello World! Hello World! Hello World! Hello World!
Hello World! Hello World! Hello World! Hello World! Hello World! Hello World!
Hello World! Hello World! Hello World! Hello World! Hello World! Hello World!
<com:TImage ImageUrl=<%~hello_world.gif%> ImageAlign="baseline" />
</td></tr>

<tr><td class="samplenote">
Image with <tt>DescriptionUrl</tt>:
</td><td class="sampleaction">
<com:TImage
    ImageUrl=<%~hello_world.gif%>
    DescriptionUrl=<%~HelloWorld.html%> />
</td></tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TImageButton/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50

<com:TContent ID="body">

<h1>TImageButton Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A click image button showing the click location:
</td><td class="sampleaction">
<com:TImageButton
    ImageUrl=<%~ hello_world.gif %>
    Text="hello world"
    OnClick="buttonClicked"
    />
<com:TLabel ID="Result" />
</td></tr>

<tr><td class="samplenote">
A command image button:
</td><td class="sampleaction">
<com:TImageButton
    ImageUrl=<%~ hello_world.gif %>
    Text="hello world"
    OnCommand="buttonClicked"
    CommandName="test"
    CommandParameter="value"
    />
<com:TLabel ID="Result2" />
</td></tr>

<tr><td class="samplenote">
An image button causing validation:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TImageButton
    ImageUrl=<%~ hello_world.gif %>
    Text="hello world"
    ValidationGroup="Group"
    />
</td></tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TImageButton/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        if($param instanceof TCommandEventParameter)
        {
            $this->Result2->Text="Command name: $param->CommandName, Command parameter: $param->CommandParameter";
        }
        else
        {
            $this->Result->Text="You clicked at ($param->X,$param->Y)";
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TImageMap/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40

<com:TContent ID="body">

<h1>TImageMap Sample</h1>

<com:TImageMap
        ImageUrl=<%~hotspots.gif%>
        AlternateText="navigate buttons"
        OnClick="buttonClicked" >

<com:TCircleHotSpot
    HotspotMode="Navigate"
    NavigateUrl="http://www.pradosoft.com"
    AlternateText="Navigate to pradosoft.com"
    Target="_blank"
    X="80"
    Y="80"
    Radius="55" />

<com:TPolygonHotSpot
    HotspotMode="Inactive"
    AlternateText="Inactive area"
    Coordinates="200,137,255,95,313,137,291,204,219,204"
    />

<com:TRectangleHotSpot
    HotspotMode="PostBack"
    PostBackValue="Welcome!"
    AlternateText="Postback button"
    Top="52"
    Left="172"
    Bottom="259"
    Right="339" />

</com:TImageMap>

<br/>

<com:TLabel ID="Result" />

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TImageMap/Home.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $this->Result->Text="Your post value is : ".$param->PostBackValue;
    }
}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TInlineFrame/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34

<com:TContent ID="body">

<h1>TInlineFrame Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Inline frame with default settings:
</td><td class="sampleaction">
<com:TInlineFrame FrameUrl="http://www.google.com/" />
</td></tr>

<tr><td class="samplenote">
Inline frame customized with margins and align:
</td><td class="sampleaction">
<com:TInlineFrame
    MarginWidth="100"
    MarginHeight="100"
    Align="Right"
    FrameUrl="http://www.google.com/" />
</td></tr>

<tr><td class="samplenote">
Inline frame without scrollbars and border:
</td><td class="sampleaction">
<com:TInlineFrame
    ScrollBars="None"
    ShowBorder="false"
    FrameUrl="http://www.google.com/" />
</td></tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TLabel/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46

<com:TContent ID="body">

<h1>TLabel Samples</h1>

<div class="samplepanel">

<com:TLabel
    Text="This is a label with customized color and font."
    ForeColor="yellow"
    BackColor="blue"
    Font.Name="Arial"
    Font.Size="14pt"
/>

</div>

<div class="samplepanel">

<com:TLabel ID="Label1"
    Text="This is a form label associated with the TTextBox control below."
    ForControl="test"
/>

<br/><com:TTextBox ID="test" />

</div>

<div class="samplepanel">

<com:TLabel ForeColor="blue" Style="color:red;">
This is a label with empty Text property and <b>nonempty body</b>.
</com:TLabel>

</div>

<div class="samplepanel">

<com:TLabel
    Text="This is a disabled label."
    Enabled="false"
    ID="Label2"
/>

</div>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TLinkButton/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58

<com:TContent ID="body">

<h1>TLinkButton Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Link button with customized color and font:
</td><td class="sampleaction">
<com:TLinkButton
    Text="link button"
    ForeColor="silver"
    BackColor="black"
    Font.Size="14pt"
/>
</td></tr>

<tr><td class="samplenote">
Link button with only body content:
</td><td class="sampleaction">
<com:TLinkButton>
body content
</com:TLinkButton>
</td></tr>

<tr><td class="samplenote">
A click link button:
</td><td class="sampleaction">
<com:TLinkButton Text="click me" OnClick="buttonClicked" />
</td></tr>

<tr><td class="samplenote">
A command link button:
</td><td class="sampleaction">
<com:TLinkButton
    Text="click me"
    OnCommand="buttonClicked"
    CommandName="test"
    CommandParameter="value"
    />
</td></tr>

<tr><td class="samplenote">
A button causing validation:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TLinkButton Text="submit" ValidationGroup="Group" />
</td></tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TLinkButton/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        if($param instanceof TCommandEventParameter)
            $sender->Text="Name: {$param->CommandName}, Param: {$param->CommandParameter}";
        else
            $sender->Text="I'm clicked";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TListBox/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274

<com:TContent ID="body">

<h1>TListBox Samples</h1>

<h2>List Boxes in Single Selection Mode</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
List box with default settings:
</td>
<td class="sampleaction">
<com:TListBox />
</td>
</tr>

<tr>
<td class="samplenote">
List box with initial items:
</td>
<td class="sampleaction">
<com:TListBox>
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TListBox>
</td>
</tr>

<tr>
<td class="samplenote">
List box with customized row number, color and font:
</td>
<td class="sampleaction">
<com:TListBox Rows="3" ForeColor="blue" Font.Size="14pt">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TListBox>
</td>
</tr>

<tr>
<td class="samplenote">
Disabled list box:
</td>
<td class="sampleaction">
<com:TListBox Enabled="false">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TListBox>
</td>
</tr>

<tr>
<td class="samplenote">
Auto postback list box:
</td>
<td class="sampleaction">
<com:TListBox
    AutoPostBack="true"
    OnSelectedIndexChanged="selectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TListBox>
<com:TLabel ID="SelectionResult" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
List box's behavior upon postback:
</td>
<td class="sampleaction">
<com:TListBox ID="ListBox1">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TListBox>
<com:TButton Text="Submit" OnClick="buttonClicked"/>
<com:TLabel ID="SelectionResult2" ForeColor="red" />
</td>
</tr>

</table>

<h2>List Boxes in Multiple Selection Mode</h2>
<i>Use Ctrl + Mouse Click to change selection</i>
<br/>

<table class="sampletable">

<tr>
<td class="samplenote">
List box with default settings:
</td>
<td class="sampleaction">
<com:TListBox SelectionMode="Multiple" />
</td>
</tr>

<tr>
<td class="samplenote">
List box with initial items:
</td>
<td class="sampleaction">
<com:TListBox SelectionMode="Multiple">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TListBox>
</td>
</tr>

<tr>
<td class="samplenote">
List box's behavior upon postback:
</td>
<td class="sampleaction">
<com:TListBox ID="ListBox2" SelectionMode="Multiple">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TListBox>
<com:TButton Text="Submit" OnClick="buttonClicked2" />
<br/>
<com:TLabel ID="MultiSelectionResult2" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Auto postback list box:
</td>
<td class="sampleaction">
<com:TListBox AutoPostBack="true"
    SelectionMode="Multiple"
    OnSelectedIndexChanged="multiSelectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Selected="true" />
</com:TListBox>
<com:TLabel ID="MultiSelectionResult" ForeColor="red" />
</td>
</tr>

</table>

<h2>List Boxes with DataBinding</h2>
<i>Use Ctrl + Mouse Click to change selection</i>
<br/>

<table class="sampletable">

<tr>
<td class="samplenote">
Databind to an integer-indexed array:
</td>
<td class="sampleaction">
<com:TListBox ID="DBListBox1"
    AutoPostBack="true"
    SelectionMode="Multiple"
    OnSelectedIndexChanged="DBListBox1Changed" />
<com:TLabel ID="DBListBox1Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind to an associative array:
</td>
<td class="sampleaction">
<com:TListBox ID="DBListBox2"
    AutoPostBack="true"
    SelectionMode="Multiple"
    OnSelectedIndexChanged="DBListBox2Changed" />
<com:TLabel ID="DBListBox2Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind with DataTextField and DataValueField specified:
</td>
<td class="sampleaction">
<com:TListBox ID="DBListBox3"
    AutoPostBack="true"
    SelectionMode="Multiple"
    DataTextField="name"
    DataValueField="id"
    OnSelectedIndexChanged="DBListBox3Changed" />
<com:TLabel ID="DBListBox3Result" ForeColor="red" />
</td>
</tr>

</table>

<h2>List Boxes with Validation</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
List box is being validated:
</td>
<td class="sampleaction">
<com:TListBox ID="VListBox1">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TListBox>
<com:TRequiredFieldValidator
    ControlToValidate="VListBox1"
    ErrorMessage="You must make a selection"
    Display="Dynamic"
    ValidationGroup="Group1"
    />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
List box causing validation:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    ErrorMessage="You must enter a value"
    Display="Dynamic"
    ValidationGroup="Group2"
    />
<com:TListBox
    ID="VListBox2"
    AutoPostBack="true"
    ValidationGroup="Group2">
  <com:TListItem Text="Agree" />
  <com:TListItem Text="Disagree" />
</com:TListBox>
</td>
</tr>

<tr>
<td class="samplenote">
List box with option groups:
</td>
<td class="sampleaction">
<com:TListBox>
  <com:TListItem Value="value 1" Text="item 1" Attributes.Group="group 1"/>
  <com:TListItem Value="value 2" Text="item 2" Attributes.Group="group 1"/>
  <com:TListItem Value="value 3" Text="item 3" Attributes.Group="group 2"/>
  <com:TListItem Value="value 4" Text="item 4" Attributes.Group="group 2"/>
</com:TListBox>
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TListBox/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $data=array('item 1','item 2','item 3','item 4');
            $this->DBListBox1->DataSource=$data;
            $this->DBListBox1->dataBind();

            $data=array('key 1'=>'item 1','key 2'=>'item 2',
                        'key 3'=>'item 3','key 4'=>'item 4');
            $this->DBListBox2->DataSource=$data;
            $this->DBListBox2->dataBind();

            $data=array(
                array('id'=>'001','name'=>'John','age'=>31),
                array('id'=>'002','name'=>'Mary','age'=>30),
                array('id'=>'003','name'=>'Cary','age'=>20));
            $this->DBListBox3->DataSource=$data;
            $this->DBListBox3->dataBind();
        }
    }

    public function DBListBox1Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBListBox1Result);
    }

    public function DBListBox2Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBListBox2Result);
    }

    public function DBListBox3Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBListBox3Result);
    }

    protected function collectSelectionResult($input,$output)
    {
        $indices=$input->SelectedIndices;
        $result='';
        foreach($indices as $index)
        {
            $item=$input->Items[$index];
            $result.="(Index: $index, Value: $item->Value, Text: $item->Text)";
        }
        if($result==='')
            $output->Text='Your selection is empty.';
        else
            $output->Text='Your selection is: '.$result;
    }

    public function selectionChanged($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->SelectionResult);
    }

    public function buttonClicked($sender,$param)
    {
        $this->collectSelectionResult($this->ListBox1,$this->SelectionResult2);
    }

    public function multiSelectionChanged($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->MultiSelectionResult);
    }

    public function buttonClicked2($sender,$param)
    {
        $this->collectSelectionResult($this->ListBox2,$this->MultiSelectionResult2);
    }
}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TLiteral/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13

<com:TContent ID="body">

<h1>TLiteral Sample</h1>

<p>
<com:TLiteral Text="This is a piece of unencoded text." />
</p>

<p>
<com:TLiteral Text="This is a piece of encoded <a>text</a>." Encode="true"/>
</p>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TMultiView/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37

<com:TContent ID="body">

<h1>TMultiView Samples</h1>

<com:TMultiView ID="MultiView" ActiveViewIndex="0" OnActiveViewChanged="viewChanged">
  <com:TView ID="View1">
    <h2>View 1</h2>
    <p>Please enter a memo:</p>
    <com:TTextBox ID="Memo" />
    <hr/>
    <com:TButton Text="View 2" CommandName="NextView" />
    <com:TButton Text="View 3" CommandName="SwitchViewIndex" CommandParameter="2" />
  </com:TView>
  <com:TView>
    <h2>View 2</h2>
    <p>Please choose a color:</p>
    <com:TDropDownList ID="DropDownList">
      <com:TListItem Value="Red" />
      <com:TListItem Value="Blue" />
      <com:TListItem Value="Green" />
    </com:TDropDownList>
    <hr/>
    <com:TButton Text="View 1" CommandName="PreviousView" />
    <com:TButton Text="View 3" CommandName="NextView" />
  </com:TView>
  <com:TView>
    <h2>View 3</h2>
    <com:TLabel ID="Result1" />
    <br/>
    <com:TLabel ID="Result2" />
    <hr/>
    <com:TButton Text="View 1" CommandName="SwitchViewID" CommandParameter="View1" />
    <com:TButton Text="View 2" CommandName="PreviousView" />
  </com:TView>
</com:TMultiView>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TMultiView/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

<?php

class Home extends TPage
{
    public function viewChanged($sender,$param)
    {
        if($this->MultiView->ActiveViewIndex===2)
        {
            $this->Result1->Text="Your text input is: ".$this->Memo->Text;
            $this->Result2->Text="Your color choice is: ".$this->DropDownList->SelectedValue;
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php

/Controls/Samples/TPager/Sample1.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77

<com:TContent ID="body">

<h1>TPager Sample</h1>
<p>
The following sample displays three different pagers associated with a single TDataList control. The datalist control is enabled with custom paging, which allows it to read only one page of data each time. This is typical in DB-driven applications.
</p>

<div>
Go to page:
<com:TPager ID="Pager"
    ControlToPaginate="DataList"
    PageButtonCount="3"
    Mode="Numeric"
    OnPageIndexChanged="pageChanged"
    />
</div>

<com:TDataList
     ID="DataList"
     AllowPaging="true"
     AllowCustomPaging="true"
     PageSize="2"
     EnableViewState="true"
     RepeatColumns="2"
     RepeatDirection="Vertical"
     ItemStyle.Font.Italic="true"
     ItemStyle.BackColor="#BFCFFF"
     HeaderStyle.BackColor="black"
     HeaderStyle.ForeColor="white"
     FooterStyle.BackColor="gray"
     AlternatingItemStyle.BackColor="#E6ECFF">

<prop:HeaderTemplate>
<div style="font-weight:bold; text-align:center;">Computer Parts</div>
</prop:HeaderTemplate>

<prop:FooterTemplate>
<div style="font-weight:bold; text-align:center;">
Total <%# $this->Parent->PageCount %> pages.
</div>
</prop:FooterTemplate>

<prop:ItemTemplate>
<table border="0" width="300">
<tr>
  <th>ID</th><th>Name</th><th>Quantity</th><th>Price</th>
</tr>
<tr>
  <td align="right"><com:TLiteral Text=<%#$this->DataItem['id'] %> /></td>
  <td align="right"><com:TLiteral Text=<%#$this->DataItem['name'] %> /></td>
  <td align="right"><com:TLiteral Text=<%#$this->DataItem['quantity'] %> /></td>
  <td align="right">$<com:TLiteral Text=<%#$this->DataItem['price'] %> /></td>
</tr>
</table>
</prop:ItemTemplate>

</com:TDataList>

<com:TPager ID="Pager2"
    ControlToPaginate="DataList"
    FirstPageText="9"
    LastPageText=":"
    Mode="NextPrev"
    NextPageText="4"
    PrevPageText="3"
    Font.Name="Webdings"
    OnPageIndexChanged="pageChanged"
    />
<br/>
Choose page:
<com:TPager ID="Pager3"
    ControlToPaginate="DataList"
    Mode="DropDownList"
    OnPageIndexChanged="pageChanged"
    />

<div class="last-modified">$Id: Sample1.page 2060 2007-07-19 13:46:05Z xue $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php

/Controls/Samples/TPager/Sample1.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82

<?php

class Sample1 extends TPage
{
    /**
     * Returns total number of data items.
     * In DB-driven applications, this typically requires
     * execution of an SQL statement with COUNT function.
     * Here we simply return a constant number.
     */
    protected function getDataItemCount()
    {
        return 19;
    }

    /**
     * Fetches a page of data.
     * In DB-driven applications, this can be achieved by executing
     * an SQL query with LIMIT clause.
     */
    protected function getData($offset,$limit)
    {
        $data=array(
            array('id'=>'ITN001','name'=>'Motherboard','quantity'=>1,'price'=>100.00,'imported'=>true),
            array('id'=>'ITN002','name'=>'CPU','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN003','name'=>'Harddrive','quantity'=>2,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN004','name'=>'Sound card','quantity'=>1,'price'=>40.00,'imported'=>false),
            array('id'=>'ITN005','name'=>'Video card','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN006','name'=>'Keyboard','quantity'=>1,'price'=>20.00,'imported'=>false),
            array('id'=>'ITN007','name'=>'Monitor','quantity'=>2,'price'=>300.00,'imported'=>true),
            array('id'=>'ITN008','name'=>'CDRW drive','quantity'=>1,'price'=>40.00,'imported'=>true),
            array('id'=>'ITN009','name'=>'Cooling fan','quantity'=>2,'price'=>10.00,'imported'=>false),
            array('id'=>'ITN010','name'=>'Video camera','quantity'=>20,'price'=>30.00,'imported'=>true),
            array('id'=>'ITN011','name'=>'Card reader','quantity'=>10,'price'=>24.00,'imported'=>true),
            array('id'=>'ITN012','name'=>'Floppy drive','quantity'=>50,'price'=>12.00,'imported'=>false),
            array('id'=>'ITN013','name'=>'CD drive','quantity'=>25,'price'=>20.00,'imported'=>true),
            array('id'=>'ITN014','name'=>'DVD drive','quantity'=>15,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN015','name'=>'Mouse pad','quantity'=>50,'price'=>5.00,'imported'=>false),
            array('id'=>'ITN016','name'=>'Network cable','quantity'=>40,'price'=>8.00,'imported'=>true),
            array('id'=>'ITN017','name'=>'Case','quantity'=>8,'price'=>65.00,'imported'=>false),
            array('id'=>'ITN018','name'=>'Surge protector','quantity'=>45,'price'=>15.00,'imported'=>false),
            array('id'=>'ITN019','name'=>'Speaker','quantity'=>35,'price'=>65.00,'imported'=>false),
        );
        return array_slice($data,$offset,$limit);
    }

    /**
     * Determines which page of data to be displayed and
     * populates the datalist with the fetched data.
     */
    protected function populateData()
    {
        $offset=$this->DataList->CurrentPageIndex*$this->DataList->PageSize;
        $limit=$this->DataList->PageSize;
        if($offset+$limit>$this->DataList->VirtualItemCount)
            $limit=$this->DataList->VirtualItemCount-$offset;
        $data=$this->getData($offset,$limit);
        $this->DataList->DataSource=$data;
        $this->DataList->dataBind();
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->DataList->VirtualItemCount=$this->DataItemCount;
            $this->populateData();
        }
    }

    /**
     * Event handler to the OnPageIndexChanged event of pagers.
     */
    public function pageChanged($sender,$param)
    {
        $this->DataList->CurrentPageIndex=$param->NewPageIndex;
        $this->populateData();
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TPanel/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71

<com:TContent ID="body">

<h1>TPanel Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Panel with contents:
</td><td class="sampleaction">
<com:TPanel>
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
</com:TPanel>
</td></tr>

<tr><td class="samplenote">
Panel with customized background color, font and horizontal alignment:
</td><td class="sampleaction">
<com:TPanel
    BackColor="silver"
    Font.Size="14pt"
    HorizontalAlign="Center">
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
</com:TPanel>
</td></tr>

<tr><td class="samplenote">
Panel with customized background image, width and scroll bars:
</td><td class="sampleaction">
<com:TPanel
    BackImageUrl=<%~hello_world.gif%>
    Width="400px"
    Height="200px"
    ScrollBars="Both"
    Wrap="false">
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
</com:TPanel>
</td></tr>

<tr><td class="samplenote">
Panel with grouping text:
</td><td class="sampleaction">
<com:TPanel GroupingText="grouping text" Width="400px">
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />.
</com:TPanel>
</td></tr>

<tr><td class="samplenote">
Panel with a default button (hit 'enter' key to see what happened):
</td><td class="sampleaction">
<com:TPanel BackColor="#CCFFCC" DefaultButton="Button2" Width="400px">
This is panel content with a <com:TLabel Text="label" Font.Italic="true" />
and two buttons: <br/>
<com:TCheckBox />
<com:TButton ID="Button1" Text="button1" OnClick="buttonClicked" />
<com:TButton ID="Button2" Text="button2" OnClick="buttonClicked" />
<com:TLabel ID="Result" ForeColor="red" />
<br/>
When you change focus to the panel and hit 'enter' key, <tt>button2</tt>
will be clicked because it is set as the default button of the panel.
</com:TPanel>
</td></tr>
</table>
<com:TJavascriptLogger />
<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TPanel/Home.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Home extends TPage
{
    public function buttonClicked($sender,$param)
    {
        $this->Result->Text="You have clicked on '$sender->Text'.";
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TPlaceHolder/Home.page

1
2
3
4
5
6
7
8
9
10
11

<com:TContent ID="body">

<h1>TPlaceHolder Sample</h1>

<p>
This sample shows how to insert <com:TPlaceHolder ID="PlaceHolder1" />
at a place that is reserved on a template. The dynamic content can be
either static texts or controls.
</p>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TPlaceHolder/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

<?php

class Home extends TPage
{
    public function onInit($param)
    {
        parent::onInit($param);
        $label=new TLabel;
        $label->Text='dynamic';
        $label->BackColor='silver';
        $this->PlaceHolder1->Controls[]=$label;
        $this->PlaceHolder1->Controls[]=' content';
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRadioButton/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102

<com:TContent ID="body">

<h1>TRadioButton Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
A radiobutton with customized text alignment, color and font:
</td><td class="sampleaction">
<com:TRadioButton
    Text="radiobutton"
    TextAlign="Left"
    ForeColor="silver"
    BackColor="green"
    Font.Size="14pt"
/>
</td></tr>

<tr><td class="samplenote">
A radiobutton with label and input attributes:
</td><td class="sampleaction">
<com:TRadioButton
    Text="click me"
    InputAttributes.value="value"
    LabelAttributes.style="color:red"
/>
</td></tr>

<tr><td class="samplenote">
An auto postback radiobutton:
</td><td class="sampleaction">
<com:TRadioButton
    AutoPostBack="true"
    Text="click me"
    OnCheckedChanged="radiobuttonClicked"
    />
</td></tr>

<tr><td class="samplenote">
A radiobutton causing validation on a textbox:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    Display="Dynamic"
    ErrorMessage="input required in the textbox"
    ValidationGroup="Group"
    />
<com:TRadioButton
    Text="submit"
    AutoPostBack="true"
    ValidationGroup="Group"
    />
</td></tr>

<tr><td class="samplenote">
A radiobutton validated by a required field validator:
</td><td class="sampleaction">
<com:TRadioButton
    ID="RadioButton"
    Text="Consent"
    ValidationGroup="Group2"
    />
<com:TButton Text="Submit" ValidationGroup="Group2" />
<com:TRequiredFieldValidator
    ControlToValidate="RadioButton"
    Display="Dynamic"
    ErrorMessage="You must consent."
    ValidationGroup="Group2"
    />
</td></tr>

<tr><td class="samplenote">
A radiobutton group:
</td><td class="sampleaction">
<com:TRadioButton
    ID="Radio1"
    GroupName="RadioGroup"
    Text="Option 1"
    />
<com:TRadioButton
    ID="Radio2"
    GroupName="RadioGroup"
    Text="Option 2"
    />
<com:TRadioButton
    ID="Radio3"
    GroupName="RadioGroup"
    Text="Option 3"
    />
<com:TRadioButton
    ID="Radio4"
    Text="Option 4 (in a different group)"
    />
<br/>
<com:TButton Text="Submit" OnClick="selectRadioButton" />
<com:TLabel ID="Result" />
</td></tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRadioButton/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<?php

class Home extends TPage
{
    public function radiobuttonClicked($sender,$param)
    {
        $sender->Text="I'm clicked";
    }

    public function selectRadioButton($sender,$param)
    {
        $selection='';
        if($this->Radio1->Checked)
            $selection.='1';
        if($this->Radio2->Checked)
            $selection.='2';
        if($this->Radio3->Checked)
            $selection.='3';
        if($this->Radio4->Checked)
            $selection.='4';
        if($selection==='')
            $selection='empty';
        $this->Result->Text='Your selection is '.$selection;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRadioButtonList/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208

<com:TContent ID="body">

<h1>TRadioButtonList Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Radio button list with default settings:
</td>
<td class="sampleaction">
<com:TRadioButtonList>
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TRadioButtonList>
</td>
</tr>

<tr>
<td class="samplenote">
Radio button list with customized cellpadding, cellspacing, color and text alignment:
</td>
<td class="sampleaction">
<com:TRadioButtonList
    CellPadding="5"
    CellSpacing="1"
    BackColor="silver"
    TextAlign="Left">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TRadioButtonList>
</td>
</tr>

<tr>
<td class="samplenote">
Radio button list with vertical (default) repeat direction:
</td>
<td class="sampleaction">
<com:TRadioButtonList RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TRadioButtonList>
</td>
</tr>

<tr>
<td class="samplenote">
Radio button list with horizontal repeat direction:
</td>
<td class="sampleaction">
<com:TRadioButtonList RepeatDirection="Horizontal"    RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TRadioButtonList>
</td>
</tr>

<tr>
<td class="samplenote">
Radio button list with flow layout and vertical (default) repeat direction:
</td>
<td class="sampleaction">
<com:TRadioButtonList RepeatLayout="Flow" RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TRadioButtonList>
</td>
</tr>

<tr>
<td class="samplenote">
Radio button list with flow layout and horizontal repeat direction:
</td>
<td class="sampleaction">
<com:TRadioButtonList
    RepeatLayout="Flow"
    RepeatDirection="Horizontal"
    RepeatColumns="3">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" />
</com:TRadioButtonList>
</td>
</tr>

<tr>
<td class="samplenote">
Radio button list's behavior upon postback:
</td>
<td class="sampleaction">
<com:TRadioButtonList ID="RadioButtonList">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Enabled="false" />
  <com:TListItem Value="value 5" Text="item 5" />
</com:TRadioButtonList>
<com:TButton Text="Submit" OnClick="buttonClicked" />
<br/>
<com:TLabel ID="SelectionResult" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Auto postback radio button list:
</td>
<td class="sampleaction">
<com:TRadioButtonList
    AutoPostBack="true"
    OnSelectedIndexChanged="selectionChanged">
  <com:TListItem Value="value 1" Text="item 1" />
  <com:TListItem Value="value 2" Text="item 2" Selected="true" />
  <com:TListItem Value="value 3" Text="item 3" />
  <com:TListItem Value="value 4" Text="item 4" Enabled="false" />
  <com:TListItem Value="value 5" Text="item 5" />
</com:TRadioButtonList>
<com:TLabel ID="SelectionResult2" ForeColor="red" />
</td>
</tr>

</table>

<h2>Radio Button Lists with DataBinding</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
Databind to an integer-indexed array:
</td>
<td class="sampleaction">
<com:TRadioButtonList ID="DBRadioButtonList1"
    AutoPostBack="true"
    OnSelectedIndexChanged="DBRadioButtonList1Changed" />
<com:TLabel ID="DBRadioButtonList1Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind to an associative array:
</td>
<td class="sampleaction">
<com:TRadioButtonList ID="DBRadioButtonList2"
    AutoPostBack="true"
    OnSelectedIndexChanged="DBRadioButtonList2Changed" />
<com:TLabel ID="DBRadioButtonList2Result" ForeColor="red" />
</td>
</tr>

<tr>
<td class="samplenote">
Databind with DataTextField and DataValueField specified:
</td>
<td class="sampleaction">
<com:TRadioButtonList ID="DBRadioButtonList3"
    AutoPostBack="true"
    DataTextField="name"
    DataValueField="id"
    OnSelectedIndexChanged="DBRadioButtonList3Changed" />
<com:TLabel ID="DBRadioButtonList3Result" ForeColor="red" />
</td>
</tr>

</table>

<h2>RadioButton List with Validation</h2>

<table class="sampletable">

<tr>
<td class="samplenote">
RadioButton list causing validation:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox"
    ErrorMessage="You must enter a value"
    Display="Dynamic"
    ValidationGroup="Group2"
    />
<com:TRadioButtonList AutoPostBack="true" ValidationGroup="Group2">
  <com:TListItem Text="Agree" />
  <com:TListItem Text="Disagree" />
</com:TRadioButtonList>
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRadioButtonList/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $data=array('item 1','item 2','item 3','item 4');
            $this->DBRadioButtonList1->DataSource=$data;
            $this->DBRadioButtonList1->dataBind();

            $data=array('key 1'=>'item 1','key 2'=>'item 2',
                        'key 3'=>'item 3','key 4'=>'item 4');
            $this->DBRadioButtonList2->DataSource=$data;
            $this->DBRadioButtonList2->dataBind();

            $data=array(
                array('id'=>'001','name'=>'John','age'=>31),
                array('id'=>'002','name'=>'Mary','age'=>30),
                array('id'=>'003','name'=>'Cary','age'=>20));
            $this->DBRadioButtonList3->DataSource=$data;
            $this->DBRadioButtonList3->dataBind();
        }
    }

    protected function collectSelectionResult($input,$output)
    {
        $indices=$input->SelectedIndices;
        $result='';
        foreach($indices as $index)
        {
            $item=$input->Items[$index];
            $result.="(Index: $index, Value: $item->Value, Text: $item->Text)";
        }
        if($result==='')
            $output->Text='Your selection is empty.';
        else
            $output->Text='Your selection is: '.$result;
    }

    public function buttonClicked($sender,$param)
    {
        $this->collectSelectionResult($this->RadioButtonList,$this->SelectionResult);
    }

    public function selectionChanged($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->SelectionResult2);
    }

    public function DBRadioButtonList1Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBRadioButtonList1Result);
    }

    public function DBRadioButtonList2Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBRadioButtonList2Result);
    }

    public function DBRadioButtonList3Changed($sender,$param)
    {
        $this->collectSelectionResult($sender,$this->DBRadioButtonList3Result);
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRangeValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45

<com:TContent ID="body">

<h1>TRangeValidator Samples</h1>
<p><strong>Note:</strong> TRangeValidator will start
to validate only if both inputs are not empty.</p>

<table class="sampletable">

<tr>
<td class="samplenote">
Range validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" Text="a1" />
<com:TRangeValidator
    ControlToValidate="TextBox1"
    ValidationGroup="Group1"
    MinValue="aaa"
    MaxValue="zzz"
    Text="Input must be between 'aaa' and 'zzz'." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Range validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" Text="11"/>
<com:TRangeValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    DataType="Integer"
    MinValue="100"
    MaxValue="999"
    Text="Input must be between 100 and 999." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRangeValidator/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRegularExpressionValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61

<com:TContent ID="body">

<h1>TRegularExpressionValidator Samples</h1>
<p>
<strong>Note:</strong> TRegularExpressionValidator will start
to validate only if the input is not empty.
</p>

<table class="sampletable">

<tr>
<td class="samplenote">
Regular expression validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" Text="xxx-xx-xxxx"/>
<com:TRegularExpressionValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    RegularExpression="\d{3}-\d{2}-\d{4}"
    Text="SSN must be in the format of xxx-xx-xxxx." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Regular expression validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" Text="b"/>
<com:TRegularExpressionValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    RegularExpression="[\w]{6,}"
    Text="Input must consist of at least 6 characters." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

<tr>
<td class="samplenote">
Regular expression validator with focus-on-error enabled and dynamic display:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox3" Text="c"/>
<com:TRegularExpressionValidator
    ValidationGroup="Group3"
    ControlToValidate="TextBox3"
    Display="Dynamic"
    RegularExpression="\d{5}(-\d{4})?"
    Text="Invalid US ZIP code." />
<com:TButton Text="Submit" ValidationGroup="Group3" />
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRegularExpressionValidator/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/RegionDisplay.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28

<?php

class RegionDisplay extends TRepeaterItemRenderer
{
    /**
     * This method is invoked when the data is being bound
     * to the parent repeater.
     * At this time, the <b>Data</b> is available which
     * refers to the data row associated with the parent repeater item.
     */
    public function onDataBinding($param)
    {
        parent::onDataBinding($param);
        $this->Repeater->DataSource=$this->Data['detail'];
        $this->Repeater->dataBind();
    }

    public function itemCreated($sender,$param)
    {
        static $itemIndex=0;
        $item=$param->Item;
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem')
            $item->Row->BackColor=$itemIndex%2 ? "#BFCFFF" : "#E6ECFF";
        $itemIndex++;
    }
}

?>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/RegionDisplay.tpl

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34

<tr>
<com:TTableCell ID="Cell"
    ForeColor="white"
    BackColor="<%# $this->ItemIndex%2 ? '#6078BF' : '#809FFF' %>"
    Text="<%#$this->Data['name'] %>"
    />
<td>

<com:TRepeater ID="Repeater" OnItemCreated="itemCreated">
<prop:HeaderTemplate>
<table cellspacing="1">
</prop:HeaderTemplate>

<prop:ItemTemplate>
<com:TTableRow ID="Row">
  <com:TTableCell Width="70px">
    <%#$this->Data['name'] %>
  </com:TTableCell>
  <com:TTableCell Width="20">
    <%#$this->Data['age'] %>
  </com:TTableCell>
  <com:TTableCell Width="150px">
    <%#$this->Data['position'] %>
  </com:TTableCell>
</com:TTableRow>
</prop:ItemTemplate>

<prop:FooterTemplate>
</table>
</prop:FooterTemplate>
</com:TRepeater>

</td>
</tr>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample1.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47

<com:TContent ID="body">

<h1>TRepeater Sample 1</h1>

<com:TRepeater ID="Repeater" EnableViewState="false">

<prop:HeaderTemplate>
<table cellpadding="2">
<tr style="color:white;background-color:black">
  <th>ID</th>
  <th>Name</th>
  <th>Quantity</th>
  <th>Price</th>
  <th>Imported</th>
</tr>
</prop:HeaderTemplate>

<prop:ItemTemplate>
<tr style="background-color:#BFCFFF">
<td><%#$this->Data['id']%></td>
<td><%#$this->Data['name']%></td>
<td><%#$this->Data['quantity']%></td>
<td><%#$this->Data['price']%></td>
<td><%#$this->Data['imported']?'Yes':'No'%></td>
</tr>
</prop:ItemTemplate>

<prop:AlternatingItemTemplate>
<tr style="background-color:#E6ECFF">
<td><%#$this->Data['id']%></td>
<td><%#$this->Data['name']%></td>
<td><%#$this->Data['quantity']%></td>
<td><%#$this->Data['price']%></td>
<td><%#$this->Data['imported']?'Yes':'No'%></td>
</tr>
</prop:AlternatingItemTemplate>

<prop:FooterTemplate>
<tr style="color:white;background-color:black;text-align:center;">
<td colspan="5">Computer Parts Inventory</td>
</tr>
</table>
</prop:FooterTemplate>

</com:TRepeater>

<div class="last-modified">$Id: Sample1.page 1688 2007-02-09 22:48:31Z xue $</div></com:TContent>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample1.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41

<?php

class Sample1 extends TPage
{
    protected function getData()
    {
        return array(
            array('id'=>'ITN001','name'=>'Motherboard','quantity'=>1,'price'=>100.00,'imported'=>true),
            array('id'=>'ITN002','name'=>'CPU','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN003','name'=>'Harddrive','quantity'=>2,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN004','name'=>'Sound card','quantity'=>1,'price'=>40.00,'imported'=>false),
            array('id'=>'ITN005','name'=>'Video card','quantity'=>1,'price'=>150.00,'imported'=>true),
            array('id'=>'ITN006','name'=>'Keyboard','quantity'=>1,'price'=>20.00,'imported'=>false),
            array('id'=>'ITN007','name'=>'Monitor','quantity'=>2,'price'=>300.00,'imported'=>true),
            array('id'=>'ITN008','name'=>'CDRW drive','quantity'=>1,'price'=>40.00,'imported'=>true),
            array('id'=>'ITN009','name'=>'Cooling fan','quantity'=>2,'price'=>10.00,'imported'=>false),
            array('id'=>'ITN010','name'=>'Video camera','quantity'=>20,'price'=>30.00,'imported'=>true),
            array('id'=>'ITN011','name'=>'Card reader','quantity'=>10,'price'=>24.00,'imported'=>true),
            array('id'=>'ITN012','name'=>'Floppy drive','quantity'=>50,'price'=>12.00,'imported'=>false),
            array('id'=>'ITN013','name'=>'CD drive','quantity'=>25,'price'=>20.00,'imported'=>true),
            array('id'=>'ITN014','name'=>'DVD drive','quantity'=>15,'price'=>80.00,'imported'=>true),
            array('id'=>'ITN015','name'=>'Mouse pad','quantity'=>50,'price'=>5.00,'imported'=>false),
            array('id'=>'ITN016','name'=>'Network cable','quantity'=>40,'price'=>8.00,'imported'=>true),
            array('id'=>'ITN017','name'=>'Case','quantity'=>8,'price'=>65.00,'imported'=>false),
            array('id'=>'ITN018','name'=>'Surge protector','quantity'=>45,'price'=>15.00,'imported'=>false),
            array('id'=>'ITN019','name'=>'Speaker','quantity'=>35,'price'=>65.00,'imported'=>false),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->Repeater->DataSource=$this->getData();
            $this->Repeater->dataBind();
        }
    }
}

?>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample2.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58

<com:TContent ID="body">

<h1>TRepeater Sample 2</h1>

<com:TRepeater ID="Repeater"
    EnableViewState="false"
    OnItemDataBound="dataBindRepeater2"
    OnItemCreated="repeaterItemCreated">

<prop:HeaderTemplate>
<table cellspacing="1" style="border:1px solid silver">
</prop:HeaderTemplate>

<prop:ItemTemplate>
<tr>
<com:TTableCell ID="Cell">
  <%#$this->Data %>
</com:TTableCell>
<td>
    <com:TRepeater
         ID="Repeater2"
         EnableViewState="false"
         OnItemCreated="Page.repeater2ItemCreated">

    <prop:HeaderTemplate>
    <table cellspacing="1">
    </prop:HeaderTemplate>

    <prop:ItemTemplate>
    <com:TTableRow ID="Row">
      <com:TTableCell Width="70px">
        <%#$this->Data['name'] %>
      </com:TTableCell>
      <com:TTableCell Width="20">
        <%#$this->Data['age'] %>
      </com:TTableCell>
      <com:TTableCell Width="150px">
        <%#$this->Data['position'] %>
      </com:TTableCell>
    </com:TTableRow>
    </prop:ItemTemplate>

    <prop:FooterTemplate>
    </table>
    </prop:FooterTemplate>

    </com:TRepeater>
</td>
</tr>
</prop:ItemTemplate>

<prop:FooterTemplate>
</table>
</prop:FooterTemplate>

</com:TRepeater>

<div class="last-modified">$Id: Sample2.page 1688 2007-02-09 22:48:31Z xue $</div></com:TContent>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample2.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79

<?php

class Sample2 extends TPage
{
    protected function getMasterData()
    {
        return array('North','West','East','South');
    }

    protected function getDetailData($region)
    {
        static $data=array(
            'North'=>array(
                array('name'=>'John','age'=>30,'position'=>'Program Manager'),
                array('name'=>'Edward','age'=>35,'position'=>'Developer'),
                array('name'=>'Walter','age'=>28,'position'=>'Developer'),
            ),
            'West'=>array(
                array('name'=>'Cary','age'=>31,'position'=>'Senior Manager'),
                array('name'=>'Ted','age'=>25,'position'=>'Developer'),
                array('name'=>'Kevin','age'=>28,'position'=>'Developer'),
            ),
            'East'=>array(
                array('name'=>'Shawn','age'=>30,'position'=>'Sales Manager'),
                array('name'=>'Larry','age'=>28,'position'=>'Document Writer'),
            ),
            'South'=>array(
                array('name'=>'King','age'=>30,'position'=>'Program Manager'),
                array('name'=>'Carter','age'=>22,'position'=>'Developer'),
            ),
        );
        return $data[$region];
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->Repeater->DataSource=$this->getMasterData();
            $this->Repeater->dataBind();
        }
    }

    public function dataBindRepeater2($sender,$param)
    {
        $item=$param->Item;
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem')
        {
            $item->Repeater2->DataSource=$this->getDetailData($item->DataItem);
            $item->Repeater2->dataBind();
        }
    }

    public function repeaterItemCreated($sender,$param)
    {
        static $itemIndex=0;
        $item=$param->Item;
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem')
        {
            $item->Cell->BackColor=$itemIndex%2 ? "#6078BF" : "#809FFF";
            $item->Cell->ForeColor='white';
            $itemIndex++;
        }
    }

    public function repeater2ItemCreated($sender,$param)
    {
        static $itemIndex=0;
        $item=$param->Item;
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem')
        {
            $item->Row->BackColor=$itemIndex%2 ? "#BFCFFF" : "#E6ECFF";
            $itemIndex++;
        }
    }
}

?>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample3.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92

<com:TContent ID="body">

<h1>TRepeater Sample 3</h1>

<p>
The following example allows users to modify the existing tabular data using a <tt>TRepeater</tt>. Two validators are used in the repeater to ensure the validity of user inputs. One is to ensure product names are not empty, the other ensures product prices are valid numeric format. After clicking on the <tt>save</tt> button, the input data is displayed in a table at the bottom of the page.
</p>

<table>
<tr>
  <th>Name</th>
  <th>Category</th>
  <th>Price</th>
  <th>Imported</th>
</tr>
<com:TRepeater ID="Repeater" OnItemDataBound="repeaterDataBound">
<prop:ItemTemplate>
<tr>
  <td>
  <com:TTextBox
       ID="ProductName"
       Text=<%#$this->Data['name']%> />
  </td>
  <td>
  <com:TDropDownList
       ID="ProductCategory" />
  </td>
  <td>
  <com:TTextBox
       ID="ProductPrice"
       Columns="7"
       Text=<%#$this->Data['price']%> />
  </td>
  <td>
  <com:TCheckBox
       ID="ProductImported"
       Checked=<%#$this->Data['imported']%> />
  <com:TRequiredFieldValidator
       ControlToValidate="ProductName"
       ErrorMessage="Product name cannot be empty."
       Display="Dynamic" />
  <com:TRegularExpressionValidator
       ControlToValidate="ProductPrice"
       RegularExpression="\d+(\.\d{1,2})?"
       ErrorMessage="Product price must be in the format of ddd.dd"
       Display="Dynamic" />
  </td>
</tr>
</prop:ItemTemplate>
</com:TRepeater>
</table>

<div>
<com:TButton Text="Save" OnClick="saveInput"/>
</div>

<com:TSafeHtml>
<com:TRepeater ID="Repeater2" EnableViewState="false">

<prop:HeaderTemplate>
<table cellpadding="2">
<tr style="color:white;background-color:black">
  <th>ID</th>
  <th>Name</th>
  <th>Category</th>
  <th>Price</th>
  <th>Imported</th>
</tr>
</prop:HeaderTemplate>

<prop:ItemTemplate>
<tr style="<%# 'background-color:' . ($this->ItemIndex%2 ? '#BFCFFF' : '#E6ECFF') %>">
<td><%#$this->Data['id']%></td>
<td><%#$this->Data['name']%></td>
<td><%#$this->Data['category']%></td>
<td><%#$this->Data['price']%></td>
<td><%#$this->Data['imported']?'Yes':'No'%></td>
</tr>
</prop:ItemTemplate>

<prop:FooterTemplate>
<tr style="color:white;background-color:black;text-align:center;">
<td colspan="5">Computer Parts Inventory</td>
</tr>
</table>
</prop:FooterTemplate>

</com:TRepeater>

</com:TSafeHtml>

<div class="last-modified">$Id: Sample3.page 1688 2007-02-09 22:48:31Z xue $</div></com:TContent>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample3.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79

<?php

class Sample3 extends TPage
{
    protected function getProducts()
    {
        return array(
            array('id'=>'ITN001','name'=>'Motherboard','category'=>'CAT004','price'=>100.00,'imported'=>true),
            array('id'=>'ITN002','name'=>'CPU','category'=>'CAT004','price'=>150.00,'imported'=>true),
            array('id'=>'ITN003','name'=>'Harddrive','category'=>'CAT003','price'=>80.00,'imported'=>true),
            array('id'=>'ITN006','name'=>'Keyboard','category'=>'CAT002','price'=>20.00,'imported'=>false),
            array('id'=>'ITN008','name'=>'CDRW drive','category'=>'CAT003','price'=>40.00,'imported'=>true),
            array('id'=>'ITN009','name'=>'Cooling fan','category'=>'CAT001','price'=>10.00,'imported'=>false),
            array('id'=>'ITN012','name'=>'Floppy drive','category'=>'CAT003','price'=>12.00,'imported'=>false),
            array('id'=>'ITN013','name'=>'CD drive','category'=>'CAT003','price'=>20.00,'imported'=>true),
            array('id'=>'ITN014','name'=>'DVD drive','category'=>'CAT003','price'=>80.00,'imported'=>true),
            array('id'=>'ITN015','name'=>'Mouse pad','category'=>'CAT001','price'=>5.00,'imported'=>false),
        );
    }

    protected function getCategories()
    {
        return array(
            array('id'=>'CAT001','name'=>'Accessories'),
            array('id'=>'CAT002','name'=>'Input Devices'),
            array('id'=>'CAT003','name'=>'Drives'),
            array('id'=>'CAT004','name'=>'Barebone'),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->Repeater->DataSource=$this->Products;
            $this->Repeater->dataBind();
        }
    }

    public function repeaterDataBound($sender,$param)
    {
        $item=$param->Item;
        if($item->ItemType==='Item' || $item->ItemType==='AlternatingItem')
        {
            $item->ProductCategory->DataSource=$this->Categories;
            $item->ProductCategory->DataTextField='name';
            $item->ProductCategory->DataValueField='id';
            $item->ProductCategory->dataBind();
            $item->ProductCategory->SelectedValue=$item->DataItem['category'];
        }
    }

    public function saveInput($sender,$param)
    {
        if($this->IsValid)
        {
            $index=0;
            $products=$this->Products;
            $data=array();
            foreach($this->Repeater->Items as $item)
            {
                $item=array(
                    'id'=>$products[$index]['id'],
                    'name'=>$item->ProductName->Text,
                    'category'=>$item->ProductCategory->SelectedItem->Text,
                    'price'=>TPropertyValue::ensureFloat($item->ProductPrice->Text),
                    'imported'=>$item->ProductImported->Checked,
                );
                $data[]=$item;
                $index++;
            }
            $this->Repeater2->DataSource=$data;
            $this->Repeater2->dataBind();
        }
    }
}

?>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample4.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<com:TContent ID="body">

<h1>TRepeater Sample 4</h1>

<p>Please enter the URL of your favorite websites in the following:</p>
<com:TRepeater ID="Repeater"
    OnItemCreated="itemCreated"
    ItemRenderer="TTextBox"
    />

<br/>

<com:TButton Text="Submit" OnClick="buttonClicked" />

<br/><br/>

<com:TLabel Text="You have entered the following URLs:"
    Visible="<%= $this->IsPostBack %>" />
<br/>

<com:TRepeater ID="Repeater2"
    OnItemCreated="itemCreated"
    ItemRenderer="THyperLink"
    />

<div class="last-modified">$Id: Sample4.page 1688 2007-02-09 22:48:31Z xue $</div></com:TContent>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample4.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37

<?php

Prado::using('System.Collections.TDummyDataSource');

class Sample4 extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            // use a dummy data source to create 3 repeater items
            $this->Repeater->DataSource=new TDummyDataSource(3);
            $this->Repeater->dataBind();
        }
    }

    public function itemCreated($sender,$param)
    {
        // $param->Item refers to the newly created repeater item
        $param->Item->Style="width:300px; margin:10px; margin-left:0px";
    }

    public function buttonClicked($sender,$param)
    {
        $links=array();
        foreach($this->Repeater->Items as $textBox)
        {
            if($textBox->Text!=='')
                $links[]=$textBox->Text;
        }
        $this->Repeater2->DataSource=$links;
        $this->Repeater2->dataBind();
    }
}

?>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample5.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

<com:TContent ID="body">

<h1>TRepeater Sample 5</h1>

<com:TRepeater ID="Repeater"
    ItemRenderer="Application.pages.Controls.Samples.TRepeater.RegionDisplay">

<prop:HeaderTemplate>
<table cellspacing="1" style="border:1px solid silver">
</prop:HeaderTemplate>

<prop:FooterTemplate>
</table>
</prop:FooterTemplate>

</com:TRepeater>

<div class="last-modified">$Id: $</div></com:TContent>


PRADO QuickStart Source View

Class file: | RegionDisplay.php
Template file: | RegionDisplay.tpl
Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TRepeater/Sample5.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52

<?php

class Sample5 extends TPage
{
    protected function getData()
    {
        return array(
            array(
                'name'=>'North',
                'detail'=>array(
                    array('name'=>'John','age'=>30,'position'=>'Program Manager'),
                    array('name'=>'Edward','age'=>35,'position'=>'Developer'),
                    array('name'=>'Walter','age'=>28,'position'=>'Developer'),
                ),
            ),
            array(
                'name'=>'West',
                'detail'=>array(
                    array('name'=>'Cary','age'=>31,'position'=>'Senior Manager'),
                    array('name'=>'Ted','age'=>25,'position'=>'Developer'),
                    array('name'=>'Kevin','age'=>28,'position'=>'Developer'),
                ),
            ),
            array(
                'name'=>'East',
                'detail'=>array(
                    array('name'=>'Shawn','age'=>30,'position'=>'Sales Manager'),
                    array('name'=>'Larry','age'=>28,'position'=>'Document Writer'),
                ),
            ),
            array(
                'name'=>'South',
                'detail'=>array(
                    array('name'=>'King','age'=>30,'position'=>'Program Manager'),
                    array('name'=>'Carter','age'=>22,'position'=>'Developer'),
                ),
            ),
        );
    }

    public function onLoad($param)
    {
        parent::onLoad($param);
        if(!$this->IsPostBack)
        {
            $this->Repeater->DataSource=$this->getData();
            $this->Repeater->dataBind();
        }
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRequiredFieldValidator/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122

<com:TContent ID="body">

<h1>TRequiredFieldValidator Samples</h1>

<table class="sampletable">

<tr>
<td class="samplenote">
Validator with default settings:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox1" />
<com:TRequiredFieldValidator
    ValidationGroup="Group1"
    ControlToValidate="TextBox1"
    Text="Field required." />
<com:TButton Text="Submit" ValidationGroup="Group1" />
</td>
</tr>

<tr>
<td class="samplenote">
Validator with client-side validation disabled:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox2" />
<com:TRequiredFieldValidator
    ValidationGroup="Group2"
    EnableClientScript="false"
    ControlToValidate="TextBox2"
    Text="Field required." />
<com:TButton Text="Submit" ValidationGroup="Group2" />
</td>
</tr>

<tr>
<td class="samplenote">
Validator with focus-on-error enabled and dynamic display:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox3" />
<com:TRequiredFieldValidator
    ValidationGroup="Group3"
    Display="Dynamic"
    ControlToValidate="TextBox3"
    FocusOnError="true"
    Text="Field required." />
<com:TButton Text="Submit" ValidationGroup="Group3" />
</td>
</tr>

<tr>
<td class="samplenote">
Validating if initial value (test) is changed:
</td>
<td class="sampleaction">
<com:TTextBox ID="TextBox4" Text="test" />
<com:TRequiredFieldValidator
    ValidationGroup="Group4"
    Display="Dynamic"
    ControlToValidate="TextBox4"
    InitialValue="test"
    Text="Input must not be 'test'." />
<com:TButton Text="Submit" ValidationGroup="Group4" />
</td>
</tr>

<tr>
<td class="samplenote">
Validating if checkbox is checked:
</td>
<td class="sampleaction">
<com:TCheckBox ID="CheckBox" Text="agree" />
<com:TRequiredFieldValidator
    ValidationGroup="Group5"
    Display="Dynamic"
    ControlToValidate="CheckBox"
    Text="You must agree." />
<com:TButton Text="Submit" ValidationGroup="Group5" />
</td>
</tr>

<tr>
<td class="samplenote">
Validating if a selection has been made in a dropdown list:
</td>
<td class="sampleaction">
<com:TDropDownList ID="DropDownList">
  <com:TListItem Value="value 1" Text="text 1" Selected="true" />
  <com:TListItem Value="value 2" Text="text 2" />
  <com:TListItem Value="value 3" Text="text 3" />
</com:TDropDownList>
<com:TRequiredFieldValidator
    ValidationGroup="Group6"
    ControlToValidate="DropDownList"
    InitialValue="value 1"
    Text="A selection must be made." />
<com:TButton Text="Submit" ValidationGroup="Group6" />
</td>
</tr>

<tr>
<td class="samplenote">
Validating if a selection has been made in a dropdown list:
</td>
<td class="sampleaction">
<com:TListBox ID="ListBox">
  <com:TListItem Value="value 1" Text="text 1" />
  <com:TListItem Value="value 2" Text="text 2" />
  <com:TListItem Value="value 3" Text="text 3" />
</com:TListBox>
<com:TRequiredFieldValidator
    ValidationGroup="Group7"
    ControlToValidate="ListBox"
    Text="A selection must be made." />
<com:TButton Text="Submit" ValidationGroup="Group7" />
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TRequiredFieldValidator/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TStatements/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

<com:TContent ID="body">

<h1>TStatements Sample</h1>

<table class="sampletable">

<tr><td class="samplenote">
Using TStatements component tag:
</td><td class="sampleaction">
<com:TStatements>
  <prop:Statements>
  $uid=$this->UniqueID;
  echo "UniqueID is '$uid'.";
  </prop:Statements>
</com:TStatements>
</td></tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TTable/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51

<com:TContent ID="body">

<h1>TTable Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Table with default settings (looks empty):
</td><td class="sampleaction">
<com:TTable />
</td></tr>

<tr><td class="samplenote">
Table with rows and customized font, background image, etc.:
</td><td class="sampleaction">
<com:TTable
    GridLines="Both"
    CellSpacing="0"
    CellPadding="2"
    BackImageUrl=<%~backimage.gif%>
    Caption="This is table caption"
    CaptionAlign="Bottom">
  <com:TTableRow BackColor="gray" ForeColor="white">
    <com:TTableHeaderCell>header cell 1</com:TTableHeaderCell>
    <com:TTableHeaderCell>header cell 2</com:TTableHeaderCell>
    <com:TTableHeaderCell>header cell 3</com:TTableHeaderCell>
  </com:TTableRow>
  <com:TTableRow HorizontalAlign="Right">
    <com:TTableCell Text="text">cell 1</com:TTableCell>
    <com:TTableCell>cell 2</com:TTableCell>
    <com:TTableCell BackColor="red">cell 3</com:TTableCell>
  </com:TTableRow>
  <com:TTableRow>
    <com:TTableCell ForeColor="red">cell 4</com:TTableCell>
    <com:TTableCell ColumnSpan="2" HorizontalAlign="Center">
    cell 5
    </com:TTableCell>
  </com:TTableRow>
</com:TTable>
</td></tr>

<tr><td class="samplenote">
A dynamically created table:
</td><td class="sampleaction">
<com:TTable ID="Table" />
</td>
</tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TTable/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        $this->Table->GridLines='Both';

        $row=new TTableRow;
        $this->Table->Rows[]=$row;

        $cell=new TTableHeaderCell;
        $cell->Text='Header 1';
        $row->Cells[]=$cell;

        $cell=new TTableHeaderCell;
        $cell->Text='Header 2';
        $row->Cells[]=$cell;

        $row=new TTableRow;
        $this->Table->Rows[]=$row;

        $cell=new TTableCell;
        $cell->Text='Cell 1';
        $row->Cells[]=$cell;

        $cell=new TTableCell;
        $cell->Text='Cell 2';
        $row->Cells[]=$cell;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TTextBox/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186

<com:TContent ID="body">

<h1>TTextBox Samples</h1>

<h2>SingeLine Text Boxes</h2>

<table class="sampletable">

<tr><td class="samplenote">
Text box with default settings:
</td><td class="sampleaction">
<com:TTextBox />
</td></tr>

<tr><td class="samplenote">
Text box with customized color, font, columns, maximum length:
</td><td class="sampleaction">
<com:TTextBox
    Text="text"
    ForeColor="yellow"
    BackColor="blue"
    Font.Size="14pt"
    Columns="4"
    MaxLength="6"
/>
</td></tr>

<tr><td class="samplenote">
Text box with vCard support:
</td><td class="sampleaction">
First Name: <com:TTextBox AutoCompleteType="FirstName" />
Last Name: <com:TTextBox AutoCompleteType="LastName" />
</td></tr>

<tr><td class="samplenote">
Disabled text box:
</td><td class="sampleaction">
<com:TTextBox Text="disabled" Enabled="false" />
</td></tr>

<tr><td class="samplenote">
Read-only text box:
</td><td class="sampleaction">
<com:TTextBox Text="read only" ReadOnly="true" />
</td></tr>

<tr><td class="samplenote">
Auto postback text box not causing validation:
</td><td class="sampleaction">
<com:TTextBox
    Text="change me"
    AutoPostBack="true"
    CausesValidation="false"
    OnTextChanged="textChanged" />
</td></tr>

<tr><td class="samplenote">
Auto postback text box causing validation:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox3"
    Width="300px"
    AutoPostBack="true"
    ValidationGroup="Group1"
    Text="change me to 'test' and see" />
<com:TRequiredFieldValidator
    ControlToValidate="TextBox3"
    ErrorMessage="You must enter a value not equal to 'test'."
    InitialValue="test"
    ValidationGroup="Group1" />
</td></tr>

<tr><td class="samplenote">
Text box's behavior upon postback:
</td><td class="sampleaction">
<com:TTextBox ID="TextBox1" Text="text" />
<com:TButton
    Text="Submit"
    OnClick="submitText" />
</td></tr>

<tr><td class="samplenote">
Safety feature (cross-site scripting prevention):
</td><td class="sampleaction">
<com:TTextBox
    ID="TextBox2"
    AutoPostBack="true"
    Text="<a href=javascript:xxx>test</a>"
    Width="200px"/>
<b>SafeText:</b>
<com:TLabel ID="Output"
    BackColor="silver"
    Text=<%#$this->TextBox2->SafeText%> />
</td></tr>

</table>

<h2>Password Text Boxes</h2>

<table class="sampletable">

<tr><td class="samplenote">
Password with default setting
</td>
<td class="sampleaction">
<com:TTextBox TextMode="Password" /> <com:TButton ID="PassButton1" Text="submit" />
</td></tr>

<tr><td class="samplenote">
Password with PersistPasswor set true
</td>
<td class="sampleaction">
<com:TTextBox ID="Password2" TextMode="Password" PersistPassword="true" />
<com:TButton ID="PassButton2" Text="submit" />
</td></tr>
</table>

<h2>MultiLine Text Boxes</h2>

<table class="sampletable">

<tr><td class="samplenote">
Text box with default settings:
</td><td class="sampleaction">
<com:TTextBox TextMode="MultiLine" />
</td></tr>

<tr><td class="samplenote">
Text box with customized dimensions, font and content:
</td><td class="sampleaction">
<com:TTextBox TextMode="MultiLine" Rows="6" Columns="60" Font.Italic="true">
  <prop:Text>
This is a multiline text box.
In HTML, it is displayed as a textarea.
  </prop:Text>
</com:TTextBox>
</td></tr>

<tr><td class="samplenote">
Disabled text box:
</td><td class="sampleaction">
<com:TTextBox
    TextMode="MultiLine"
    Text="disabled"
    Enabled="false" />
</td></tr>

<tr><td class="samplenote">
Read-only text box with text-wrapping disabled:
</td><td class="sampleaction">
<com:TTextBox
    TextMode="MultiLine"
    Text="This is a read-only text box with text-wrapping disabled."
    ReadOnly="true"
    Wrap="false"/>
</td></tr>

<tr><td class="samplenote">
Auto postback text box not causing validation:
</td><td class="sampleaction">
<com:TTextBox
    TextMode="MultiLine"
    Text="change me"
    AutoPostBack="true"
    CausesValidation="false"
    OnTextChanged="textChanged" />
</td></tr>

<tr><td class="samplenote">
Auto postback text box causing validation:
</td><td class="sampleaction">
<com:TTextBox ID="MultiTextBox3"
    TextMode="MultiLine"
    AutoPostBack="true"
    ValidationGroup="Group2"
    Text="change me to 'demo' and see" />
<com:TRequiredFieldValidator
    ControlToValidate="MultiTextBox3"
    ErrorMessage="You must enter a value not equal to 'demo'."
    InitialValue="demo"
    ValidationGroup="Group2" />
</td></tr>

</table>

<div class="last-modified">$Id: Home.page 1812 2007-03-31 13:19:58Z xue $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TTextBox/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22

<?php

class Home extends TPage
{
    public function onLoad($param)
    {
        parent::onLoad($param);
        $this->Output->dataBind();
    }

    public function textChanged($sender,$param)
    {
        $sender->Text="text changed";
    }

    public function submitText($sender,$param)
    {
        $this->TextBox1->Text="You just entered '".$this->TextBox1->Text."'.";
    }
}

?>


PRADO QuickStart Source View

Template file: Home.page

/Controls/Samples/TTextHighlighter/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<com:TContent ID="body">

<h1>TTextHighlighter Samples</h1>

<table class="sampletable">

<tr><td class="samplenote">
Highlighting PHP statements:
</td><td class="sampleaction">
<com:TTextHighlighter ShowLineNumbers="true" EnableCopyCode="true">
<?php
$str = 'one|two|three|four';
// will output an array
print_r(explode('|', $str, 2));
?>
</com:TTextHighlighter>
</td></tr>

<tr><td class="samplenote">
Highlighting control rendering results:
</td><td class="sampleaction">
<com:TTextHighlighter EnableCopyCode="false">
<com:TLabel Text="this is a label" />
</com:TTextHighlighter>
</td></tr>

</table>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TValidationSummary/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84

<com:TContent ID="body">

<h1>TValidationSummary Samples</h1>

<fieldset id="quickRegistration">
    <legend>Create New Account</legend>

<div class="username">
    Username:
    <com:TTextBox ID="Username" />
    <com:TRequiredFieldValidator
        ID="UsernameVal"
        ControlToValidate="Username"
        ValidationGroup="Group1"
        Text="*"
        ErrorMessage="a username is required." />
</div>
<div class="password">
    Password
    <com:TTextBox ID="Password" TextMode="Password" />
    <com:TRequiredFieldValidator
        ID="PasswordVal"
        ControlToValidate="Password"
        ValidationGroup="Group1"
        Text="*"
        ErrorMessage="a password is required." />
</div>

<div class="create">
    <com:TButton ID="Create" ValidationGroup="Group1" Text="Create New Account"/>
</div>

<div class="registrationSummary">
    <com:TValidationSummary
        ValidationGroup="Group1"
        Display="None"
        HeaderText="Unable to create new account because" />
</div>

</fieldset>

<fieldset id="LoginForm">
    <legend>Sign In</legend>

<div class="username">
    Login Name:
    <com:TTextBox ID="UserID" />

    <com:TRequiredFieldValidator
        ID="UserVal1"
        ControlToValidate="UserID"
        Display="None"
        ValidationGroup="Group2"
        ErrorMessage="the username or email was not provided" />
</div>

<div class="password" >
    Password:
    <com:TTextBox ID="Pass" TextMode="Password" />
    <com:TRequiredFieldValidator
        ID="loginValidator3"
        ControlToValidate="Pass"
        Display="None"
        ValidationGroup="Group2"
        ErrorMessage="the password was not provided" />
</div>

<com:TButton ID="login" ValidationGroup="Group2" CssClass="button" Text="Sign In" />

<div class="validation">
    <com:TValidationSummary
        ValidationGroup="Group2"
        AutoUpdate="false"
        Display="None"
        ShowMessageBox="true"
        HeaderText="You could not login because" />
</div>

</fieldset>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Controls/Samples/TValidationSummary/Home.php

1
2
3
4
5
6
7
8

<?php

class Home extends TPage
{

}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample1.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39

<com:TContent ID="body">

<h2>A Single-Step Wizard</h2>

<com:TWizard ID="Wizard1"
        BackColor="#FFFBD6"
        Width="400px"
        SideBarStyle.Width="120px"
        HeaderText="Please let us know your preference"
        OnCompleteButtonClick="wizardCompleted" >

  <com:TWizardStep Title="Step 1">
    <h3>Wizard Step 1</h3>
    <p>
    Your favorite color:
    <com:TDropDownList ID="DropDownList1">
      <com:TListItem Value="Red" />
      <com:TListItem Value="Blue" />
      <com:TListItem Value="Green" />
      <com:TListItem Value="Purple" />
      <com:TListItem Value="Black" />
      <com:TListItem Value="Yellow" />
      <com:TListItem Value="Orange" />
      <com:TListItem Value="Pink" />
      <com:TListItem Value="Cyan" />
    </com:TDropDownList>
    </p>
  </com:TWizardStep>

  <com:TWizardStep Title="Step 2" StepType="Complete">
    <h3>Wizard Step 2</h3>
    <p>
    <com:TLabel ID="Result" />
    </p>
  </com:TWizardStep>

</com:TWizard>

<div class="last-modified">$Id: Sample1.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample1.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Sample1 extends TPage
{
    public function wizardCompleted($sender,$param)
    {
        $this->Result->Text="Your favorite color is: " . $this->DropDownList1->SelectedValue;
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample2.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64

<com:TContent ID="body">

<h2>Wizard with Customized Styles</h2>

<com:TWizard ID="Wizard1"
        Width="400px"
        Height="100px"
        BackColor="#EFF3FB"
        BorderColor="#B5C7DE"
        BorderWidth="1px"
        BorderStyle="Solid"
        HeaderText="Please let us know your preference"
        StepStyle.HorizontalAlign="Center"
        NavigationStyle.HorizontalAlign="Center"
        SideBarButtonStyle.ForeColor="White"
        OnCompleteButtonClick="wizardCompleted" >

  <prop:SideBarStyle
        Width="100px"
        Height="100px"
        BackColor="#507CD1"
        HorizontalAlign="Center"
        />
  <prop:NavigationButtonStyle
        BackColor="White"
        BorderColor="#507CD1"
        BorderStyle="Solid"
        BorderWidth="1px"
        ForeColor="#284E98"
        />
  <prop:HeaderStyle
        BackColor="#284E98"
        Font.Bold="True"
        ForeColor="White"
        HorizontalAlign="Center"
        />

  <com:TWizardStep Title="Step 1">
    <p>
    Your favorite color:
    <com:TDropDownList ID="DropDownList1">
      <com:TListItem Value="Red" />
      <com:TListItem Value="Blue" />
      <com:TListItem Value="Green" />
      <com:TListItem Value="Purple" />
      <com:TListItem Value="Black" />
      <com:TListItem Value="Yellow" />
      <com:TListItem Value="Orange" />
      <com:TListItem Value="Pink" />
      <com:TListItem Value="Cyan" />
    </com:TDropDownList>
    </p>
  </com:TWizardStep>

  <com:TWizardStep Title="Step 2" StepType="Complete">
    <h3>Thank you for your answer!</h3>
    <p>
    <com:TLabel ID="Result" />
    </p>
  </com:TWizardStep>

</com:TWizard>

<div class="last-modified">$Id: Sample2.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample2.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Sample2 extends TPage
{
    public function wizardCompleted($sender,$param)
    {
        $this->Result->Text="Your favorite color is: " . $this->DropDownList1->SelectedValue;
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample3.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61

<com:TContent ID="body">

<h2>Nonlinear Wizard Navigation Sample</h2>

<p>
In the following survey, if you are a college student, you will be asked which major you are in. Otherwise, the question is skipped to your favorite sport. This demo also shows unidrectional navigation.
</p>

<com:TWizard ID="Wizard3"
        BackColor="#FFFBD6"
        Width="300px"
        HeaderText="A Mini Survey"
        ShowSideBar="false"
        HeaderStyle.BackColor="PaleGoldenrod"
        HeaderStyle.HorizontalAlign="Center"
        NavigationStyle.HorizontalAlign="Center"
        OnNextButtonClick="wizard3NextStep"
        OnCompleteButtonClick="wizard3Completed" >

  <com:TWizardStep Title="Background" AllowReturn="false">
    <b><%= $this->Title %></b>
    <br/><br/>
    <com:TCheckBox ID="StudentCheckBox" Text="I am a college student." />
    <br/><br/>
  </com:TWizardStep>

  <com:TWizardStep Title="Major" AllowReturn="false">
    <b><%= $this->Title %></b>
    <br/><br/>
    My major is
      <com:TDropDownList ID="DropDownList11">
        <com:TListItem Value="Computer Science" />
        <com:TListItem Value="Chemistry" />
        <com:TListItem Value="Mathematics" />
        <com:TListItem Value="Others" />
      </com:TDropDownList>
    <br/><br/>
  </com:TWizardStep>

  <com:TWizardStep Title="Hobbies" AllowReturn="false">
    <b><%= $this->Title %></b>
    <br/><br/>
    My favorite Sport is
      <com:TDropDownList ID="DropDownList22">
        <com:TListItem Value="Baseball" />
        <com:TListItem Value="Football" />
        <com:TListItem Value="Tennis" />
      </com:TDropDownList>
    <br/><br/>
  </com:TWizardStep>

  <com:TWizardStep Title="Summary" StepType="Complete">
    <h3>Thank you for taking this survey!</h3>
    <p>
    <com:TLabel ID="Wizard3Result" />
    </p>
  </com:TWizardStep>

</com:TWizard>

<div class="last-modified">$Id: Sample3.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample3.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25

<?php

class Sample3 extends TPage
{
    public function wizard3Completed($sender,$param)
    {
        if($this->StudentCheckBox->Checked)
        {
            $str="You are a college student.<br/>";
            $str.="You are in major: ".$this->DropDownList11->SelectedValue."<br/>";
            $str.="Your favorite sport is: ".$this->DropDownList22->SelectedValue;
        }
        else
            $str="Your favorite sport is: ".$this->DropDownList22->SelectedValue;
        $this->Wizard3Result->Text=$str;
    }

    public function wizard3NextStep($sender,$param)
    {
        if($param->CurrentStepIndex===0 && !$this->StudentCheckBox->Checked)
            $this->Wizard3->ActiveStepIndex=2;
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample4.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85

<com:TContent ID="body">

<h2>Customized Wizard Template Sample</h2>

<com:TWizard ID="Wizard1"
        BackColor="OldLace"
        Width="400px"
        SideBarStyle.Width="120px"
        StepStyle.BackColor="#FFFBD6"
        HeaderStyle.BackColor="Moccasin"
        NavigationStyle.BackColor="PaleGoldenrod"
        OnActiveStepChanged="wizardCompleted" >

        <prop:HeaderTemplate>
        <i>Header Template</i>
        <br/>
        <b>Step <%= $this->Parent->ActiveStepIndex+1 %> of 3</b>
        </prop:HeaderTemplate>

        <prop:SideBarTemplate>
        <i>SideBar Template</i>
        <br/>
        <com:TDataList ID="SideBarList">
                <prop:ItemTemplate>
                <com:TButton ID="SideBarButton" />
                </prop:ItemTemplate>
                <prop:SelectedItemTemplate>
                <com:TButton ID="SideBarButton" Font.Bold="true" />
                </prop:SelectedItemTemplate>
        </com:TDataList>
        </prop:SideBarTemplate>

        <prop:StartNavigationTemplate>
        <com:TLinkButton CommandName="NextStep" Text="Next &gt;" />
        <br/>
        <i>Start Navigation Template</i>
        </prop:StartNavigationTemplate>

        <prop:StepNavigationTemplate>
        <com:TLinkButton CausesValidation="False" CommandName="PreviousStep" Text="&lt; Previous" />
        <com:TLinkButton CommandName="NextStep" Text="Next &gt;" />
        <br/>
        <i>Step Navigation Template</i>
        </prop:StepNavigationTemplate>

        <prop:FinishNavigationTemplate>
        All navigation buttons are removed.
        <br/>
        <i>Step Navigation Template</i>
        </prop:FinishNavigationTemplate>

    <com:TWizardStep ID="WizardStep1" Title="Step 1">
    <i>Wizard Step Content</i>
    <br/><br/>
    Your favorite color:
    <com:TDropDownList ID="DropDownList1">
    <com:TListItem Value="Red" />
    <com:TListItem Value="Blue" />
    <com:TListItem Value="Green" />
    <com:TListItem Value="Purple" />
    <com:TListItem Value="Black" />
    <com:TListItem Value="Yellow" />
    <com:TListItem Value="Orange" />
    <com:TListItem Value="Pink" />
    <com:TListItem Value="Cyan" />
    </com:TDropDownList>
    <br/><br/>
    </com:TWizardStep>

    <com:TWizardStep ID="WizardStep2" Title="Step 2">
    <i>Wizard Step Content</i>
    <br/><br/>
    <com:TLabel ID="Result" />
    <br/><br/>
    </com:TWizardStep>

    <com:TWizardStep ID="WizardStep3" Title="Step 3">
    <i>Wizard Step Content</i>
    <br/><br/>
    Thank you for completing this survey.<br />
    <br/><br/>
    </com:TWizardStep>
</com:TWizard>

<div class="last-modified">$Id: Sample4.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample4.php

1
2
3
4
5
6
7
8
9
10
11

<?php

class Sample4 extends TPage
{
    public function wizardCompleted($sender,$param)
    {
        $this->Result->Text="Your favorite color is: " . $this->DropDownList1->SelectedValue;
    }
}

?>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample5.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51

<com:TContent ID="body">

<h2>Using Templated Wizard Steps</h2>

<com:TWizard ID="Wizard1"
        BackColor="#FFFBD6"
        Width="400px"
        SideBarStyle.Width="120px"
        HeaderText="Please let us know your preference"
        OnCompleteButtonClick="wizardCompleted" >

  <com:TWizardStep Title="Step 1">
    <p>
    Your favorite color:
    <com:TDropDownList ID="DropDownList1">
      <com:TListItem Value="Red" />
      <com:TListItem Value="Blue" />
      <com:TListItem Value="Green" />
      <com:TListItem Value="Purple" />
      <com:TListItem Value="Black" />
      <com:TListItem Value="Yellow" />
      <com:TListItem Value="Orange" />
      <com:TListItem Value="Pink" />
      <com:TListItem Value="Cyan" />
    </com:TDropDownList>
    </p>
  </com:TWizardStep>

  <com:TTemplatedWizardStep ID="Step2" Title="Templated Step">
    <prop:ContentTemplate>
      <p>
      Your favorite Sport:
      <com:TDropDownList ID="DropDownList2">
        <com:TListItem Value="Baseball" />
        <com:TListItem Value="Football" />
        <com:TListItem Value="Tennis" />
      </com:TDropDownList>
      </p>
    </prop:ContentTemplate>
  </com:TTemplatedWizardStep>

  <com:TWizardStep Title="Complete" StepType="Complete">
    <h3>Thank you for your answer!</h3>
    <p>
    <com:TLabel ID="Result1" /><br/><br/>
    <com:TLabel ID="Result2" />
    </p>
  </com:TWizardStep>
</com:TWizard>

<div class="last-modified">$Id: Sample5.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Sample1.page
Class file: | Sample1.php
Template file: | Sample2.page
Class file: | Sample2.php
Template file: | Sample3.page
Class file: | Sample3.php
Template file: | Sample4.page
Class file: | Sample4.php
Template file: | Sample5.page
Class file: | Sample5.php

/Controls/Samples/TWizard/Sample5.php

1
2
3
4
5
6
7
8
9
10
11
12

<?php

class Sample5 extends TPage
{
    public function wizardCompleted($sender,$param)
    {
        $this->Result1->Text="Your favorite color is: " . $this->DropDownList1->SelectedValue;
        $this->Result2->Text="Your favorite sport is: " . $this->Step2->DropDownList2->SelectedValue;
    }
}

?>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Fundamentals/Samples/Hangman/Home.page

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70

<%@ Title="Hangman Game" %>
<com:TContent ID="body">

<h1>Hangman Game</h1>

<com:TMultiView ID="GameMultiView">

<com:TView ID="IntroView">
<p>This is the game of Hangman. You must guess a word, a letter at a time.
If you make too many mistakes, you lose the game!</p>
<com:TRadioButtonList ID="LevelSelection">
  <com:TListItem Value="10" Text="Easy game; you are allowed 10 misses."/>
  <com:TListItem Value="5" Text="Medium game; you are allowed 5 misses."/>
  <com:TListItem Value="3" Text="Hard game; you are allowed 3 misses."/>
</com:TRadioButtonList>
<com:TButton Text="Play!" OnClick="selectLevel" />
<com:TLabel ID="LevelError" Text="You must choose a difficulty level!" ForeColor="red" Visible="false" />
</com:TView>

<com:TView ID="GuessView">
<h2>Please make a guess</h2>
<h3 style="letter-spacing: 4px;"><%= $this->Page->GuessWord %></h3>
<p>You have made <%=$this->Page->Misses %> bad guesses
out of a maximum of <%= $this->Page->Level %>.</p>
<p>Guess:
<com:TLinkButton ID="GuessA" Text="A" OnClick="guessWord" />
<com:TLinkButton ID="GuessB" Text="B" OnClick="guessWord" />
<com:TLinkButton ID="GuessC" Text="C" OnClick="guessWord" />
<com:TLinkButton ID="GuessD" Text="D" OnClick="guessWord" />
<com:TLinkButton ID="GuessE" Text="E" OnClick="guessWord" />
<com:TLinkButton ID="GuessF" Text="F" OnClick="guessWord" />
<com:TLinkButton ID="GuessG" Text="G" OnClick="guessWord" />
<com:TLinkButton ID="GuessH" Text="H" OnClick="guessWord" />
<com:TLinkButton ID="GuessI" Text="I" OnClick="guessWord" />
<com:TLinkButton ID="GuessJ" Text="J" OnClick="guessWord" />
<com:TLinkButton ID="GuessK" Text="K" OnClick="guessWord" />
<com:TLinkButton ID="GuessL" Text="L" OnClick="guessWord" />
<com:TLinkButton ID="GuessM" Text="M" OnClick="guessWord" />
<com:TLinkButton ID="GuessN" Text="N" OnClick="guessWord" />
<com:TLinkButton ID="GuessO" Text="O" OnClick="guessWord" />
<com:TLinkButton ID="GuessP" Text="P" OnClick="guessWord" />
<com:TLinkButton ID="GuessQ" Text="Q" OnClick="guessWord" />
<com:TLinkButton ID="GuessR" Text="R" OnClick="guessWord" />
<com:TLinkButton ID="GuessS" Text="S" OnClick="guessWord" />
<com:TLinkButton ID="GuessT" Text="T" OnClick="guessWord" />
<com:TLinkButton ID="GuessU" Text="U" OnClick="guessWord" />
<com:TLinkButton ID="GuessV" Text="V" OnClick="guessWord" />
<com:TLinkButton ID="GuessW" Text="W" OnClick="guessWord" />
<com:TLinkButton ID="GuessX" Text="X" OnClick="guessWord" />
<com:TLinkButton ID="GuessY" Text="Y" OnClick="guessWord" />
<com:TLinkButton ID="GuessZ" Text="Z" OnClick="guessWord" />
</p>
<p><com:TLinkButton Text="Give up?" OnClick="giveUp" /></p>
</com:TView>

<com:TView ID="WinView">
<h2>You Win!</h2>
<p>The word was: <%= $this->Page->Word %>.</p>
<p><com:TLinkButton Text="Start Again" OnClick="startAgain" /></p>
</com:TView>

<com:TView ID="LoseView">
<h2>You Lose!</h2>
<p>The word was: <%= $this->Page->Word %>.</p>
<p><com:TLinkButton Text="Start Again" OnClick="startAgain" /></p>
</com:TView>

</com:TMultiView>

<div class="last-modified">$Id: Home.page 1650 2007-01-24 06:55:32Z wei $</div></com:TContent>


PRADO QuickStart Source View

Template file: | Home.page
Class file: | Home.php

/Fundamentals/Samples/Hangman/Home.php

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121

<?php
class Home extends TPage
{
    public function onLoad($param)
    {
        if (!$this->IsPostBack)
            $this->GameMultiView->ActiveView=$this->IntroView;
    }

    public function selectLevel($sender,$param)
    {
        if(($selection=$this->LevelSelection->SelectedValue)==='')
        {
            $this->LevelError->Visible=true;
            return;
        }
        else
            $this->Level=TPropertyValue::ensureInteger($selection);
        $this->Word=$this->generateWord();
        $this->GuessWord=str_repeat('_',strlen($this->Word));
        $this->Misses=0;
        $this->GameMultiView->ActiveView=$this->GuessView;
    }

    public function guessWord($sender,$param)
    {
        $sender->Enabled=false;
        $letter=$sender->Text;
        $word=$this->Word;
        $guessWord=$this->GuessWord;
        $pos=0;
        $success=false;
        while(($pos=strpos($word,$letter,$pos))!==false)
        {
            $guessWord[$pos]=$letter;
            $success=true;
            $pos++;
        }
        if($success)
        {
            $this->GuessWord=$guessWord;
            if($guessWord===$word)
                $this->GameMultiView->ActiveView=$this->WinView;
        }
        else
        {
            $this->Misses++;
            if($this->Misses>=$this->Level)
                $this->giveUp(null,null);
        }
    }

    public function giveUp($sender,$param)
    {
        $this->GameMultiView->ActiveView=$this->LoseView;
    }

    public function startAgain($sender,$param)
    {
        $this->GameMultiView->ActiveView=$this->IntroView;
        $this->LevelError->Visible=false;
        for($letter=65;$letter<=90;++$letter)
        {
            $guessLetter='Guess'.chr($letter);
            $this->$guessLetter->Enabled=true;
        }
    }

    protected function generateWord()
    {
        $wordFile=dirname(__FILE__).'/words.txt';
        $words=preg_split("/[\s,]+/",file_get_contents($wordFile));
        do
        {
            $i=rand(0,count($words)-1);
            $word=$words[$i];
        } while(strlen($word)<5 || !preg_match('/^[a-z]*$/i',$word));
        return strtoupper($word);
    }

    public function setLevel($value)
    {
        $this->setViewState('Level',$value,0);
    }

    public function getLevel()
    {
        return $this->getViewState('Level',0);
    }

    public function setWord($value)
    {
        $this->setViewState('Word',$value,'');
    }

    public function getWord()
    {
        return $this->getViewState('Word','');
    }

    public function getGuessWord()
    {
        return $this->getViewState('GuessWord','');
    }

    public function setGuessWord($value)
    {
        $this->setViewState('GuessWord',$value,'');
    }

    public function setMisses($value)
    {
        $this->setViewState('Misses',$value,0);
    }

    public function getMisses()
    {
        return $this->getViewState('Misses',0);
    }
}
?>


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveButton

API Manual

TActiveButton is the active control counter part to TButton. When a TActiveButton is clicked, rather than a normal post back request a callback request is initiated. The OnCallback event is raised during a callback request and it is raise after the OnClick event.

When the ActiveControl.EnableUpdate property is true, changing the Text property during a callback request will update the button's caption on the client-side.

Since the OnCallback event is raised only during a callback request, the OnCallback event handler can be used to handle logic specifically related to callback requests. The OnClick event handler is raised when ever the button is clicked, even if javascript is disabled.

The following example the use of both the OnClick and OnCallback events of an TActiveButton.

Run Sample View Source

TActiveButton Class Diagram

The class diagram for TActiveButton is illustrated in the figure below. Most active control that can perform callback request have a similar structure.

TActiveButton class diagram

TActiveButton is an extension of TButton and implements two additional interfaces ICallbackEventHandler and IActiveControl. The TActiveButton contains an instance of TBaseActiveCallbackControl available through the ActiveControl property of TActiveButton. The following example set the callback parameter of the TActiveButton when a callback request is dispatched.

<com:TActiveButton
    Text="Click Me"
    OnCallback="button_callback"
    ActiveControl.CallbackParameter="value" />

In the OnCallback event handler method, the CallbackParameter is available in the $param object.

public function button_callback($sender, $param)
{
    echo $param->CallbackParameter; //outputs "value"
}

Adding Client Side Behaviour

With in the ActiveControl property is an instance of TCallbackClientSide available as a property ClientSide of TActiveButton. The ClientSide property contains sub-properties, such as RequestTimeOut, and client-side javascript event handler, such as OnLoading, that are used by the client-side when making a callback request. The following example demonstrates the toggling of a "loading" indicator when the client-side is making a callback request.

<com:TClientScript PradoScripts="effects" />
<span id="callback_status">Loading...</span>

<com:TActiveButton
    Text="Click Me"
    OnCallback="button_callback"
    ActiveControl.CallbackParameter="value" >
    <prop:ClientSide
        OnLoading="Element.show('callback_status')"
        OnComplete="Element.hide('callback_status')" />
</com:TActiveButton>

The example loads the "effects" javascript library using the TClientScript component. The ClientSide.OnLoading property value contains javascript statement that uses the "effects" library to show the "Loading..." span tag. Similarly, ClientSide.OnComplete property value contains the javascript statement that hides the "Loading..." span tag. See TCallbackClientSide for further details on client-side property details.

$Id: ActiveButton.page 1817 2007-03-31 23:36:00Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveCheckBox

API Manual

TActiveCheckBox is the active control counter part to TCheckbox. The AutoPostBack property of TActiveCheckBox is set to true by default. Thus, when the checkbox is clicked the OnCallback event is raise after the OnCheckedChanged event.

The Text and Checked properties of TActiveCheckBox can be changed during a callback request. The TextAlign property of TActiveCheckBox can not be changed during a callback request.

Run Sample View Source
$Id: ActiveCheckBox.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TActiveCustomValidator

API Manual

Performs custom validation using only server-side OnServerValidate validation event. The client-side uses callbacks to raise onServerValidate event. The ClientValidationFunction property is disabled and will throw an exception if trying to set this property.

Beware that the onServerValidate may be raised when the control to validate on the client side changes value, that is, the server validation may be called many times. After the callback or postback, the {@link onServerValidate onServerValidate} is raised once more. The IsCallback property of the TPage class will be true when validation is made during a callback request.

Run Sample View Source
$Id: ActiveCustomValidator.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

Overview of Active Controls

TODO:
$Id: Introduction.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TButton

API Manual

TButton creates a click button on a Web page. The button's caption is specified by Text property. A button is used to submit data to a page. TButton raises two server-side events, OnClick and OnCommand, when it is clicked on the client-side. The difference between OnClick and OnCommand events is that the latter event is bubbled up to the button's ancestor controls. An OnCommand event handler can use CommandName and CommandParameter associated with the event to perform specific actions.

Clicking on button can trigger form validation, if CausesValidation is true. And the validation may be restricted within a certain group of validator controls according to ValidationGroup.

Run Sample View Source
TODO: custom attributes
$Id: Button.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TCheckBox

API Manual

TCheckBox displays a check box on a Web page. A caption can be specified via Text and displayed beside the check box. It can appear either on the right or left of the check box, which is determined by TextAlign. You may further specify attributes applied to the text by using LabelAttributes.

To determine whether the check box is checked, test the Checked property. A CheckedChanged event is raised if the state of Checked is changed between posts to the server. If AutoPostBack is true, changing the check box state will cause postback action. And if CausesValidation is also true, upon postback validation will be performed for validators within the specified ValidationGroup.

Run Sample View Source
$Id: CheckBox.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TClientScript

API Manual

Including Bundled Javascript Libraries in Prado

TClientScript allows Javascript code to be insert or linked to the page template. PRADO is bundled with a large library of Javascript functionality including effects, AJAX, basic event handlers, and many others. The bundled Javascript libraries can be linked to the current page template using the PradoScripts property. Multiple bundled Javascript libraries can be specified using comma delimited string of the name of Javascript library to include on the page. For following example will include the "ajax" and "effects" library.

<com:TClientScript PradoScripts="ajax, effects" />

The available bundled libraries included in Prado are

  • prado : basic prado javascript framework based on Prototype
  • effects : visual effects from script.aculo.us
  • ajax : ajax and callback related based on Prototype
  • validator : validation
  • logger : javascript logger and object browser
  • datepicker : datepicker
  • colorpicker : colorpicker

Many of the libraries, such as validator and datepicker will automatically when controls that uses these libraries are visible on the page. For example, all the validators if they have their EnableClientScript set to true will include both the prado and validator javascript libraries. The dependencies for each library are automatically resolved. That is, specifying, say the "ajax", will also include the "prado" library.

Including Custom Javascript Files

Custom Javascript files can be register using the ScriptUrl property. The following example includes the Javascript file "test.js" to the page. In this case, the file "test.js" is relative the current template you are using. Since the property value is dynamic asset tag, the file "test.js" will be published automatically, that is, the file will be copied to the assets directory if necessary.

<com:TClientScript ScriptUrl=<%~ test.js %> />

You can include Javascript files from other servers by specifying the full URL string in the ScriptUrl property.

Including Custom Javascript Code Blocks

Any content within the TClientScript control tag will be considered as Javascript code and will be rendered where it is declared.

$Id: ClientScript.page 1846 2007-04-07 10:35:16Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TColorPicker

API Manual

TBD

$Id: ColorPicker.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TDataGrid

TDatagrid is an important control in building complex Web applications. It displays data in a tabular format with rows (also called items) and columns. A row is composed by cells, while columns govern how cells should be displayed according to their association with the columns. Data specified via DataSource or DataSourceID are bound to the rows and feed contents to cells.

TDataGrid is highly interactive. Users can sort the data along specified columns, navigate through different pages of the data, and perform actions, such as editing and deleting, on rows of the data.

Rows of TDataGrid can be accessed via its Items property. A row (item) can be in one of several modes: browsing, editing and selecting, which affects how cells in the row are displayed. To change an item's mode, modify EditItemIndex or SelectedItemIndex. Note, if an item is in edit mode, then selecting this item will have no effect.

Columns

Columns of a data grid determine how the associated cells are displayed. For example, cells associated with a TBoundColumn are displayed differently according to their modes. A cell is displayed as a static text if the cell is in browsing mode, a text box if it is in editing mode, and so on.

PRADO provides five types of columns:

  • TBoundColumn associates cells with a specific field of data and displays the cells according to their modes.
  • TLiteralColumn associates cells with a specific field of data and displays the cells with static texts.
  • TCheckBoxColumn associates cells with a specific field of data and displays in each cell a checkbox whose check state is determined by the data field value.
  • TDropDownListColumn associates cells with a specific field of data and displays the cells according to their modes. If in edit mode, a cell will be displayed with a TDropDownList.
  • THyperLinkColumn displays in the cells a hyperlink whose caption and URL can be either statically specified or bound to some fields of data.
  • TEditCommandColumn displays in the cells edit/update/cancel command buttons according to the state of the item that a cell resides in.
  • TButtonColumn displays in the cells a command button.
  • TTemplateColumn displays the cells according to different templates defined for it.

Item Styles

TDataGrid defines different styles applied to its items. For example, AlternatingItemStyle is applied to alternating items (item 2, 4, 6, etc.) Through these properties, one can set CSS style fields or CSS classes for the items.

Item styles are applied in a hierarchical way. Styles in higher hierarchy will inherit from styles in lower hierarchy. Starting from the lowest hierarchy, the item styles include item's own style, ItemStyle, AlternatingItemStyle, SelectedItemStyle, and EditItemStyle. Therefore, if background color is set as red in ItemStyle, EditItemStyle will also have red background color, unless it is explicitly set to a different value.

Events

TDataGrid provides several events to facilitate manipulation of its items,

  • OnItemCreated - raised each time an item is newly created. When the event is raised, data and child controls are both available for the new item.
  • OnItemDataBound - raised each time an item just completes databinding. When the event is raised, data and child controls are both available for the item, and the item has finished databindings of itself and all its child controls.
  • OnItemCommand - raised when a child control of some item (such as a TButton) raises an OnCommand event.
  • command events - raised when a child control's OnCommand event has a specific command name,
    • OnSelectedIndexChanged - if the command name is select.
    • OnEditCommand - if the command name is edit.
    • OnDeleteCommand - if the command name is delete.
    • OnUpdateCommand - if the command name is update.
    • OnCancelCommand - if the command name is cancel.
    • OnSortCommand - if the command name is sort.
    • OnPageIndexChanged - if the command name is page.

Using TDataGrid

Automatically Generated Columns

TDataGrid by default will create a list of columns based on the structure of the bound data. TDataGrid will read the first row of the data, extract the field names of the row, and construct a column for each field. Each column is of type TBoundColumn.

The following example displays a list of computer product information using a TDataGrid. Columns are automatically generated. Pay attention to how item styles are specified and inherited. The data are populated into the datagrid using the following code, which is common among most datagrid applications,

public function onLoad($param) {
    parent::onLoad($param);
    if(!$this->IsPostBack) {
        $this->DataGrid->DataSource=$this->Data;
        $this->DataGrid->dataBind();
    }
}
Run Sample View Source

Manually Specified Columns

Using automatically generated columns gives a quick way of browsing tabular data. In real applications, however, automatically generated columns are often not sufficient because developers have no way customizing their appearance. Manually specified columns are thus more desirable.

To manually specify columns, set AutoGenerateColumns to false, and specify the columns in a template like the following,

<com:TDataGrid ...>
  <com:TBoundColumn DataField="name" .../>
  <com:TBoundColumn DataField="price" .../>
  <com:TEditCommandColumn ...>
  ...
</com:TDataGrid>

Note, if AutoGenerateColumns is true and there are manually specified columns, the automatically generated columns will be appended to the manually specified columns. Also note, the datagrid's Columns property contains only manually specified columns and no automatically generated ones.

The following example uses manually specified columns to show a list of book information,

  • Book title - displayed as a hyperlink pointing to the corresponding amazon.com book page. THyperLinkColumn is used.
  • Publisher - displayed as a piece of text using TBoundColumn.
  • Price - displayed as a piece of text using TBoundColumn with output formatting string and customized styles.
  • In-stock or not - displayed as a checkbox using TCheckBoxColumn.
  • Rating - displayed as an image using TTemplateColumn which allows maximum freedom in specifying cell contents.

Pay attention to how item (row) styles and column styles cooperate together to affect the appearance of the cells in the datagrid.

Run Sample View Source

Interacting with TDataGrid

Besides the rich data presentation functionalities as demonstrated in previous section, TDataGrid is also highly user interactive. An import usage of TDataGrid is editing or deleting rows of data. The TBoundColumn can adjust the associated cell presentation according to the mode of datagrid items. When an item is in browsing mode, the cell is displayed with a static text; when the item is in editing mode, a textbox is displayed to collect user inputs. TDataGrid provides TEditCommandColumn for switching item modes. In addition, TButtonColumn offers developers the flexibility of creating arbitrary buttons for various user interactions.

The following example shows how to make the previous book information table an interactive one. It allows users to edit and delete book items from the table. Two additional columns are used in the example to allow users interact with the datagrid: TEditCommandColumn and TButtonColumn. In addition, TDropDownListColumn replaces the previous TTemplateColumn to allow users to select a rating from a dropdown list. Note, it is also possible to use TTemplateColumn to achieve the same task.

Run Sample View Source

Sorting

TDataGrid supports sorting its items according to specific columns. To enable sorting, set AllowSorting to true. This will turn column headers into clickable buttons if their SortExpression property is not empty. When users click on the header buttons, an OnSortCommand event will be raised. Developers can write handlers to respond to the sort command and sort the data according to SortExpression which is specified in the corresponding column.

The following example turns the datagrid in Example 2 into a sortable one. Users can click on the link button displayed in the header of any column, and the data will be sorted in ascending order along that column.

Run Sample View Source

Paging

When dealing with large datasets, paging is helpful in reducing the page size and complexity. TDataGrid has an embedded pager that allows users to specify which page of data they want to see. The pager can be customized via PagerStyle. For example, PagerStyle.Visible determines whether the pager is visible or not; PagerStyle.Position indicates where the pager is displayed; and PagerStyle.Mode specifies what type of pager is displayed, a numeric one or a next-prev one.

To enable paging, set AllowPaging to true. The number of rows of data displayed in a page is specified by PageSize, while the index (zero-based) of the page currently showing to users is by CurrentPageIndex. When users click on a pager button, TDataGrid raises OnPageIndexChanged event. Typically, the event handler is written as follows,

public function pageIndexChanged($sender,$param) {
    $this->DataGrid->CurrentPageIndex=$param->NewPageIndex;
    $this->DataGrid->DataSource=$this->Data;
    $this->DataGrid->dataBind();
}

The following example enables the paging functionality of the datagrid shown in Example 1. In this example, you can set various pager styles interactively to see how they affect the pager display.

Run Sample View Source

Custom Paging

The paging functionality shown above requires loading all data into memory, even though only a portion of them is displayed in a page. For large datasets, this is inefficient and may not always be feasible. TDataGrid provides custom paging to solve this problem. Custom paging only requires the portion of the data to be displayed to end users.

To enable custom paging, set both AllowPaging and AllowCustomPaging to true. Notify TDataGrid the total number of data items (rows) available by setting VirtualItemCount. And respond to the OnPageIndexChanged event. In the event handler, use the NewPageIndex property of the event parameter to fetch the new page of data from data source. For MySQL database, this can be done by using LIMIT clause in an SQL select statement.

Run Sample View Source

Extending TDataGrid

Besides traditional class inheritance, extensibility of TDataGrid is mainly through developing new datagrid column components. For example, one may want to display an image column. He may use TTemplateColumn to accomplish this task. A better solution is to develop an image column component so that the work can be reused easily in other projects.

All datagrid column components must inherit from TDataGridColumn. The main method that needs to be overridden is initializeCell() which creates content for cells in the corresponding column. Since each cell is also in an item (row) and the item can have different types (such as Header, AltneratingItem, etc.), different content may be created according to the item type. For the image column example, one may want to create a TImage control within cells residing in items of Item and AlterantingItem types.

class ImageColumn extends TDataGridColumn {
    ...
    public function initializeCell($cell,$columnIndex,$itemType) {
        parent::initializeCell($cell,$columnIndex,$itemType);
        if($itemType==='Item' || $itemType==='AlternatingItem') {
            $image=new TImage;
            // ... customization of the image
            $cell->Controls[]=$image;
        }
    }
}

In initializeCell(), remember to call the parent implementation, as it initializes cells in items of Header and Footer types.

$Id: DataGrid.page 2147 2007-08-23 17:39:00Z xue $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TDataList

TDataList represents a data bound and updatable list control. Like TRepeater, TDataList displays its content repeatedly based on the data fetched from DataSource. The repeated contents in TDataList are called items, which are controls and can be accessed through Items. When dataBind() is invoked, TDataList creates an item for each row of data and binds the data row to the item. Optionally, a TDataList can have a header, a footer and/or separators between items.

TDataList differs from TRepeater in that it introduces the concept of item state and allows applying different styles to items in different states. In addition, TDataList supports tiling the repeated items in various ways.

The layout of the repeated contents in TDataList are specified by inline templates. TDataList items, header, footer, etc. are being instantiated with the corresponding templates when data is being bound to the repeater.

Since v3.1.0, the layout can also be by renderers. A renderer is a control class that can be instantiated as datalist items, header, etc. A renderer can thus be viewed as an external template (in fact, it can also be non-templated controls). For more details, see the explanation about renderer in the TRepeater tutorial.

The following properties are used to specify different types of template and renderer for a datalist. If a content type is defined with both a template and a renderer, the latter takes precedence.

  • ItemTemplate, ItemRenderer: for each repeated row of data
  • AlternatingItemTemplate, AlternatingItemRenderer: for each alternating row of data. If not set, ItemTemplate or ItemRenderer will be used instead.
  • HeaderTemplate, HeaderRenderer: for the datalist header.
  • FooterTemplate, FooterRenderer: for the datalist footer.
  • SeparatorTemplate, SeparatorRenderer: for content to be displayed between items.
  • EmptyTemplate, EmptyRenderer: used when data bound to the datalist is empty.
  • EditItemTemplate, EditItemRenderer: for the row being editted.
  • SelectedItemTemplate, SelectedItemRenderer: for the row being selected.

When dataBind() is called, TDataList undergoes the following lifecycles for each row of data:

  1. create item based on templates or renderers
  2. set the row of data to the item
  3. raise an OnItemCreated event
  4. add the item as a child control
  5. call dataBind() of the item
  6. raise an OnItemDataBound event

TDataList raises an OnItemCommand whenever a button control within some datalist item raises an OnCommand event. Therefore, you can handle all sorts of OnCommand event in a central place by writing an event handler for OnItemCommand. An additional event is raised if the OnCommand event has one of the following command names (case-insensitive):

  • edit - user wants to edit an item. OnEditCommand event will be raised.
  • update - user wants to save the change to an item. OnUpdateCommand event will be raised.
  • select - user selects an item. OnSelectedIndexChanged event will be raised.
  • delete - user deletes an item. OnDeleteCommand event will be raised.
  • cancel - user cancels previously editting action. OnCancelCommand event will be raised.

TDataList provides a few properties to support tiling the items. The number of columns used to display the data items is specified via RepeatColumns property, while the RepeatDirection governs the order of the items being rendered. The layout of the data items in the list is specified via RepeatLayout, which takes one of the following values:

  • Table (default) - items are organized using HTML table and cells. When using this layout, one can set CellPadding and CellSpacing to adjust the cellpadding and cellspacing of the table, and Caption and CaptionAlign to add a table caption with the specified alignment.
  • Flow - items are organized using HTML spans and breaks.
  • Raw - TDataList does not generate any HTML tags to do the tiling.

Items in TDataList can be in one of the three states: being browsed, being editted and being selected. To change the state of a particular item, set SelectedItemIndex or EditItemIndex. The former will change the indicated item to selected mode, which will cause the item to use SelectedItemTemplate or SelectedItemRenderer for presentation. The latter will change the indicated item to edit mode and to use corresponding template or renderer. Note, if an item is in edit mode, then selecting this item will have no effect.

Different styles may be applied to items in different status. The style application is performed in a hierarchical way: Style in higher hierarchy will inherit from styles in lower hierarchy. Starting from the lowest hierarchy, the item styles include:

  • item's own style
  • ItemStyle
  • AlternatingItemStyle
  • SelectedItemStyle
  • EditItemStyle

Therefore, if background color is set as red in ItemStyle, EditItemStyle will also have red background color unless it is set to a different value explicitly.

When a page containing a datalist is post back, the datalist will restore automatically all its contents, including items, header, footer and separators. However, the data row associated with each item will not be recovered and become null. To access the data, use one of the following ways:

  • Use DataKeys to obtain the data key associated with the specified repeater item and use the key to fetch the corresponding data from some persistent storage such as DB.
  • Save the whole dataset in viewstate, which will restore the dataset automatically upon postback. Be aware though, if the size of your dataset is big, your page size will become big. Some complex data may also have serializing problem if saved in viewstate.

The following example shows how to use TDataList to display tabular data, with different layout and styles.

Run Sample View Source

A common use of TDataList is for maintaining tabular data, including browsing, editing, deleting data items. This is enabled by the command events and various item templates of TDataList.

The following example displays a computer product information. Users can add new products, modify or delete existing ones. In order to locate the data item for updating or deleting, DataKeys property is used.

Be aware, for simplicity, this application does not do any input validation. In real applications, make sure user inputs are valid before saving them into databases.

Run Sample View Source
$Id: DataList.page 2147 2007-08-23 17:39:00Z xue $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TDatePicker

API Manual

TDatePicker displays a text box for date input purpose. When the text box receives focus, a calendar will pop up and users can pick up from it a date that will be automatically entered into the text box. The format of the date string displayed in the text box is determined by the DateFormat property. Valid formats are the combination of the following tokens:

Character      Format Pattern (en-US)
---------------------------------------------------------------------
 d              day digit
 dd             padded day digit e.g. 01, 02
 M              month digit
 MM             padded month digit
 MMM            localized abbreviated month names, e.g. Mar, Apr
 MMMM           localized month name, e.g. March, April
 yy             2 digit year
 yyyy           4 digit year
---------------------------------------------------------------------

The date of the date picker can be set using the Date or Timestamp properties. The Date property value must be in the same format as the pattern specified in the DateFormat property. The Timestamp property only accepts integers such as the Unix timestamp.

TDatePicker has three Mode to show the date picker popup.

  • Basic - Only shows a text input, focusing on the input shows the date picker.
  • Button - Shows a button next to the text input, clicking on the button shows the date, button text can be by the ButtonText property.
  • ImageButton - Shows an image next to the text input, clicking on the image shows the date picker, image source can be change through the ImageUrl property.

The CssClass property can be used to override the CSS class name for the date picker panel. The CalendarStyle property changes the overall calendar style. The following CalendarStyle values are available:

  • default - The default calendar style.

The InputMode property can be set to "TextBox" or "DropDownList" with default as "TextBox". In DropDownList mode, in addition to the popup date picker, three drop down list (day, month and year) are presented to select the date . When InputMode equals "DropDownList", the order and appearance of the date, month, and year will depend on the pattern specified in DateFormat property.

The popup date picker can be hidden by specifying ShowCalendar as false. Much of the text of the popup date picker can be changed to a different language using the Culture property.

The calendar picker year limit can be set using the FromYear and UpToYear properties where FromYear is the starting year and UpToYear is the last year selectable. The starting day of the week can be changed by the FirstDayOfWeek property, with 0 as Sunday, 1 as Monday, etc.

Note 1: If the InputMode is "TextBox", the DateFormat should only NOT contain MMM or MMMM patterns. The server side date parser will not be able to determine the correct date if MMM or MMMM are used. When InputMode equals "DropDownList", all patterns can be used.

Note 2: When the TDatePicker is used together with a validator, the DateFormat property of the validator must be equal to the DateFormat of the TDatePicker AND must set DataType="Date" on the validator to ensure correct validation. See TCompareValidator, TDataTypeValidator and TRangeValidator for details.

Run Sample View Source
$Id: DatePicker.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TExpression

API Manual

TExpression evaluates a PHP expression and displays the evaluation result. To specify the expression to be evaluated, set the Expression property. Note, TExpression evaluates the expression during the rendering control lifecycle.

The context of the expression in a TExpression control is the control itself. That is, $this represents the control object if it is present in the expression. For example, the following template tag will display the title of the page containing the TExpression control.

<com:TExpression Expression="$this->Page->Title" />

Be aware, since TExpression allows execution of arbitrary PHP code, in general you should not use it to evaluate expressions submitted by your application users.

Run Sample View Source
$Id: Expression.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TFileUpload

API Manual

TFileUpload displays a file upload field on a Web page. Upon postback, the text entered into the field will be treated as the (local) name of the file that is uploaded to the server.

TFileUpload raises an OnFileUpload event when it is post back. The property HasFile indicates whether the file upload is successful or not. If successful, the uploaded file may be saved on the server by calling saveAs() method.

The following properties give the information about the uploaded file:

  • FileName - the original client-side file name without directory information.
  • FileType - the MIME type of the uploaded file.
  • FileSize - the file size in bytes.
  • LocalName - the absolute file path of the uploaded file on the server. Note, this file will be deleted after the current page request is completed. Call saveAs() to save the uploaded file.

If the file upload is unsuccessful, the property ErrorCode gives the error code describing the cause of failure. See PHP documentation for a complete explanation of the possible error codes.

Run Sample View Source
$Id: FileUpload.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

THead

API Manual

TBD

$Id: Head.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

THiddenField

API Manual

THiddenField represents a hidden field on a Web page. The value of the hidden field can be accessed via its Value property.

THiddenField raises an OnValueChanged event if its value is changed during postback.

$Id: HiddenField.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

THtmlArea

API Manual

THtmlArea displays a WYSIWYG text input field on a Web page to collect input in HTML format. The text displayed in the THtmlArea control is specified or determined by using the Text property. To adjust the size of the input region, set Width and Height properties instead of Columns and Rows because the latter has no meaning under this situation. To disable the WYSIWYG feature, set EnableVisualEdit to false.

THtmlArea provides the WYSIWYG feature by wrapping the functionalities provided by the TinyMCE project.

The default editor gives only the basic tool bar. To change or add additional tool bars, use the Options property to add additional editor options with each options on a new line. See TinyMCE website for a complete list of options. The following example displays a toolbar specific for HTML table manipulation,

<com:THtmlArea>
  <prop:Options>
    plugins : "table"
    theme_advanced_buttons3 : "tablecontrols"
  </prop:Options>
</com:THtmlArea>

The client-side visual editing capability is supported by Internet Explorer 5.0+ for Windows and Gecko-based browser. If the browser does not support the visual editing, a traditional textarea will be displayed.

                Windows XP        MacOS X 10.4
----------------------------------------------------
MSIE 6                  OK
MSIE 5.5 SP2            OK
MSIE 5.0                OK
Mozilla 1.7.x           OK              OK
Firefox 1.0.x           OK              OK
Firefox 1.5b2           OK              OK
Safari 2.0 (412)                        OK(1)
Opera 9 Preview 1       OK(1)           OK(1)
----------------------------------------------------
(1) - Partially working
----------------------------------------------------
Run Sample View Source
$Id: HtmlArea.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

THyperLink

API Manual

THyperLink displays a hyperlink on a page. The hyperlink URL is specified via the NavigateUrl property, and link text is via the Text property. The link target is specified via the Target property. It is also possible to display an image by setting the ImageUrl property. In this case, Text is displayed as the alternate text of the image. If both ImageUrl and Text are empty, the content enclosed within the control tag will be rendered.

Run Sample View Source
$Id: HyperLink.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TImage

API Manual

TImage displays an image on a page. The image is specified via the ImageUrl property which takes a relative or absolute URL to the image file. The alignment of the image displayed is set by the ImageAlign property. To set alternate text or long description of the image, use AlternateText or DescriptionUrl, respectively.

Run Sample View Source
$Id: Image.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TImageButton

API Manual

TImageButton is also similar to TButton, except that TImageButton displays the button as an image. The image is specified via ImageUrl, and the alternate text is specified by Text. In addition, it is possible to obtain the coordinate of the point where the image is clicked. The coordinate information is contained in the event parameter of the OnClick event (not OnCommand).

Run Sample View Source
$Id: ImageButton.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TImageMap

API Manual

TImageMap represents an image on a Web page with predefined hotspot regions that can respond differently to users' clicks on them. Depending on the HotSpotMode of the hotspot region, clicking on the hotspot may trigger a postback or navigate to a specified URL.

Each hotspot is described using a THotSpot object and is maintained in the HotSpots collection in TImageMap. A hotspot can be a circle, rectangle, polygon, etc.

Hotspots can be added to TImageMap via its HotSpots property or in a template like the following,

<com:TImageMap ... >
  <com:TCircleHotSpot ... />
  <com:TRectangleHotSpot ... />
  <com:TPolygonHotSpot ... />
</com:TImageMap>
Run Sample View Source
$Id: ImageMap.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TInlineFrame

API Manual

TInlineFrame displays an inline frame (<iframe>) on a Web page. The location of the frame content is specified by the FrameUrl property.

The appearance of a TInlineFrame may be customized with the following properties, in addition to those inherited from TWebControl.

  • Align - the alignment of the frame.
  • DescriptionUrl - the URI of a long description of the frame's contents.
  • MarginWidth and MarginHeight - the number of pixels to use as the left/right margins and top/bottom margins, respectively.
  • ScrollBars - whether scrollbars are provided for the inline frame. By default, it is Auto, meaning the scroll bars appear as needed. Setting it as None or Both to explicitly hide or show the scroll bars.

The following samples show TInlineFrame with different property settings. The Google homepage is used as the frame content.

Run Sample View Source
$Id: InlineFrame.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TJavascriptLogger

API Manual

TJavascriptLogger provides logging for client-side javascript. It is mainly a wrapper of the Javascript developed at http://gleepglop.com/javascripts/logger/.

To use TJavascriptLogger, simply place the following component tag in a page template.

<com:TJavascriptLogger />

Then, the client-side Javascript may contain the following statements. When they are executed, they will appear in the logger window.

Logger.info('something happend');
Logger.warn('A warning');
Logger.error('This is an error');
Logger.debug('debug information');

To toggle the visibility of the logger and console on the browser window, press ALT-D (or CTRL-D on OS X).

$Id: JavascriptLogger.page 2747 2010-01-11 12:58:38Z Christophe.Boulain $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TLabel

API Manual

TLabel displays a piece of text on a Web page. The text to be displayed is set via its Text property. If Text is empty, content enclosed within the TLabel component tag will be displayed. TLabel may also be used as a form label associated with some control on the form. Since Text is not HTML-encoded when being rendered, make sure it does not contain dangerous characters that you want to avoid.

Run Sample View Source
$Id: Label.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TLinkButton

API Manual

TLinkButton is similar to TButton in every aspect except that TLinkButton is displayed as a hyperlink. The link text is determined by its Text property. If the Text property is empty, then the body content of the button is displayed (therefore, you can enclose a <img> tag within the button body and get an image button.

Run Sample View Source
$Id: LinkButton.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TLiteral

API Manual

TLiteral displays a static text on a Web page. TLiteral is similar to the TLabel control, except that the TLiteral * control has no style properties, such as BackColor, Font, etc.

The text displayed by TLiteral can be programmatically controlled by setting the Text property. The text displayed may be HTML-encoded if the Encode is true (the default value is false).

TLiteral will render the contents enclosed within its component tag if Text is empty.

Be aware, if Encode is false, make sure Text does not contain unwanted characters that may bring security vulnerabilities.

Run Sample View Source
$Id: Literal.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TMultiView

API Manual

TMultiView serves as a container for a group of TView controls, which can be retrieved by the Views property. Each view contains child controls. TMultiView determines which view and its child controls are visible. At any time, at most one view is visible (called active). To make a view active, set ActiveView or ActiveViewIndex. Note, by default there is no active view.

To add a view to TMultiView, manipulate the Views collection or add it in template as follows,

<com:TMultiView>
   <com:TView>
      view 1 content
   </com:TView>
   <com:TView>
      view 2 content
   </com:TView>
</com:TMultiView>

TMultiView responds to the following command events to manage the visibility of its views.

  • NextView : switch to the next view (with respect to the currently active view).
  • PreviousView : switch to the previous view (with respect to the currently active view).
  • SwitchViewID : switch to a view by its ID path. The ID path is fetched from the command parameter.
  • SwitchViewIndex : switch to a view by its zero-based index in the Views collection. The index is fetched from the command parameter.

Upon postback, if the active view index is changed, TMultiView will raise an OnActiveViewChanged event.

The Hangman game is a typical use of TMultiView. The following example demonstrates another usage of TMultiView.

Run Sample View Source
$Id: MultiView.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TOutputCache

API Manual

TOutputCache enables caching a portion of a Web page, also known as partial caching. The content being cached are HTML page source coming from static texts on a PRADO template or rendered by one or several controls on the template. When the cached content is used, controls generating the content are no longer created for the page hierarchy and thus significant savings in page processing time can be achieved. The side-effect, as you might already find out, is that the content displayed may be stale if the cached version is shown to the users.

To use TOutputCache, simply enclose the content to be cached within the TOutputCache component tag on a template (either page or non-page control template), e.g.,

<com:TOutputCache>
   content to be cached
</com:TOutputCache>

where content to be cached can be static text and/or template tags. If the latter, the rendering results of the template tags will be cached. You can place one or several TOutputCache on a single template and they can be nested.

Note: TOutputCache stores cached content via PRADO cache modules (e.g. TSqliteCache) and thus requires at least one cache module loaded when the application runs.

The validity of the cached content is determined based on two factors: the Duration and the cache dependency. The former specifies the number of seconds that the data can remain valid in cache (defaults to 60s), while the latter specifies conditions that the cached data depends on. If a dependency changes (e.g. relevant data in DB are updated), the cached data will be invalidated and discarded.

There are two ways to specify cache dependency. One may write event handlers to respond to the OnCheckDependency event and set the event parameter's IsValid property to indicate whether the cached data remains valid or not. One can also extend TOutputCache and override its getCacheDependency() method.

The content fetched from cache may be variated with respect to some parameters. TOutputCache supports variation with respect to request parameters, which is specified by VaryByParam property. If a specified request parameter is different, a different version of cached content is used. This is extremely useful if a page's content may be variated according to some GET parameters. The content being cached may also be variated with user sessions if VaryBySession is set true. To variate the cached content by other factors, override calculateCacheKey() method.

Output caches can be nested. An outer cache takes precedence over an inner cache in determining the validity of cached contents. This means, if the content cached by the inner cache expires or is invalidated, while that by the outer cache not, the outer cached content will be used.

By default, TOutputCache is effective only for non-postback page requests and when a cache module is enabled. Do not attempt to address child controls of TOutputCache when the cached content is currently being used. Use ContentCached property to determine whether the content is cached or not.

$Id: OutputCache.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TPager

API Manual

TPager creates a pager that provides UI for end-users to interactively specify which page of data to be rendered in a TDataBoundControl-derived control, such as TDataList, TRepeater, TCheckBoxList, etc. The target data-bound control is specified by the ControlToPaginate property, which must be the ID path of the target control reaching from the pager's naming container.

Note, the target data-bound control must have its AllowPaging set to true. Otherwise the pager will be invisible. Also, in case when there is only one page of data available, the pager will also be invisible.

TPager can display one of the following three types of user interface, specified via its Mode property:

  • NextPrev - a next page and a previous page button are rendered on each page.
  • Numeric - a list of page index buttons are rendered.
  • DropDownList - a dropdown list of page indices is rendered.

These user interfaces may be further customized by configuring the following properties

  • NextPageText and PrevPageText - the label of the next/previous page button. These properties are used when the pager Mode is NextPrev or Numeric.
  • FirstPageText and LastPageText - the label of the first/last page button. If empty, the corresponding button will not be displayed. These properties are used when the pager Mode is NextPrev or Numeric.
  • PageButtonCount - the maximum number of page index buttons on a page. This property is used when the pager Mode is Numeric.
  • ButtonType - type of page buttons, either PushButton meaning normal form submission buttons, or LinkButton meaning hyperlink buttons.

TPager raises an OnPageIndexChanged event when an end-user interacts with it and specifies a new page (e.g. by clicking on a next page button that would lead to the next page.) Developers may write handlers to respond to this event and obtain the desired new page index from the event parameter's property NewPageIndex. Using this new page index, one can feed a new page of data to the associated data-bound control.

Run Sample View Source
$Id: Pager.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TPanel

API Manual

TPanel acts as a presentational container for other control. It displays a <div> element on a page. The property Wrap specifies whether the panel's body content should wrap or not, while HorizontalAlign governs how the content is aligned horizontally and Direction indicates the content direction (left to right or right to left). You can set BackImageUrl to give a background image to the panel, and you can set GroupingText so that the panel is displayed as a field set with a legend text. Finally, you can specify a default button to be fired when users press 'return' key within the panel by setting the DefaultButton property.

Run Sample View Source
$Id: Panel.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TPlaceHolder

API Manual

TPlaceHolder reserves a place on a template, where static texts or controls may be dynamically inserted.

Run Sample View Source
$Id: PlaceHolder.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TRadioButton

API Manual

TRadioButton is similar to TCheckBox in every aspect, except that TRadioButton displays a radio button on a Web page. The radio button can belong to a specific group specified by GroupName such that only one radio button within that group can be selected at most.

Run Sample View Source
$Id: RadioButton.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TRepeater

TRepeater displays its content repeatedly based on the data fetched from DataSource. The repeated contents in TRepeater are called items which are controls accessible through Items property. When dataBind() is invoked, TRepeater creates an item for each row of data and binds the data row to the item. Optionally, a repeater can have a header, a footer and/or separators between items.

The layout of the repeated contents are specified by inline templates. In particular, repeater items, header, footer, etc. are being instantiated with the corresponding templates when data is being bound to the repeater.

Since v3.1.0, the layout can also be specified by renderers. A renderer is a control class that can be instantiated as repeater items, header, etc. A renderer can thus be viewed as an external template (in fact, it can also be non-templated controls). A renderer can be any control class. By using item renderers, one can avoid writing long and messy templates. Since a renderer is a class, it also helps reusing templates that previously might be embedded within other templates. If implemented with one of the following interfaces, a renderer will be initialized with additional properties relevant to the repeater items:

  • IDataRenderer - the Data property will be set as the row of the data bound to the repeater item. Many PRADO controls implement this interface, such as TLabel, TTextBox, etc.
  • IItemDataRenderer - the ItemIndex property will be set as the zero-based index of the item in the repeater item collection, and the ItemType property as the item's type (such as TListItemType::Item). As a convenient base class, TRepeaterItemRenderer implements IDataItemRenderer and can have an associated template because it extends from TTemplateControl.

The following properties are used to specify different types of template and renderer for a repeater. If an item type is defined with both a template and a renderer, the latter takes precedence.

  • ItemTemplate, ItemRenderer - for each repeated row of data.
  • AlternatingItemTemplate, AlternatingItemRenderer: for each alternating row of data. If not set, ItemTemplate or ItemRenderer will be used instead, respectively.
  • HeaderTemplate, HeaderRenderer - for the repeater header.
  • FooterTemplate, FooterRenderer - for the repeater footer.
  • SeparatorTemplate, SeparatorRenderer - for content to be displayed between items.
  • EmptyTemplate, EmptyRenderer - used when data bound to the repeater is empty.

To populate data into the repeater items, set DataSource to a valid data object, such as array, TList, TMap, or a database table, and then call dataBind() for the repeater. That is,

class MyPage extends TPage {
    public function onLoad($param) {
        parent::onLoad($param);
        if(!$this->IsPostBack) {
            $this->Repeater->DataSource=$data;
            $this->Repeater->dataBind();
        }
    }
}

When dataBind() is called, TRepeater undergoes the following lifecycles for each row of data:

  1. create item based on templates or renderers
  2. set the row of data to the item
  3. raise an OnItemCreated event
  4. add the item as a child control
  5. call dataBind() of the item
  6. raise an OnItemDataBound event

Normally, you only need to bind the data to repeater when the page containing the repeater is initially requested. When the page is post back, the repeater will restore automatically all its contents, including items, header, footer and separators. However, the data row associated with each item will not be recovered and thus become null.

To access the repeater item data in postbacks, use one of the following ways:

  • Use DataKeys to obtain the data key associated with the specified repeater item and use the key to fetch the corresponding data from some persistent storage such as DB.
  • Save the whole dataset in viewstate, which will restore the dataset automatically upon postback. Be aware though, if the size of your dataset is big, your page size will become big. Some complex data may also have serializing problem if saved in viewstate.

TRepeater raises an OnItemCommand event whenever a button control within some repeater item raises a OnCommand event. Therefore, you can handle all sorts of OnCommand event in a central place by writing an event handler for OnItemCommand.

The following example shows how to use TRepeater to display tabular data.

Run Sample View Source

TRepeater can be used in more complex situations. As an example, we show in the following how to use nested repeaters, i.e., repeater in repeater. This is commonly seen in presenting master-detail data. To use a repeater within another repeater, for an item for the outer repeater is created, we need to set the detail data source for the inner repeater. This can be achieved by responding to the OnItemDataBound event of the outer repeater. An OnItemDataBound event is raised each time an outer repeater item completes databinding. In the following example, we exploit another event of repeater called OnItemCreated, which is raised each time a repeater item (and its content) is newly created. We respond to this event by setting different background colors for repeater items to achieve alternating item background display. This saves us from writing an AlternatingItemTemplate for the repeaters.

Run Sample View Source

Besides displaying data, TRepeater can also be used to collect data from users. Validation controls can be placed in TRepeater templates to verify that user inputs are valid.

The PRADO component composer demo is a good example of such usage. It uses a repeater to collect the component property and event definitions. Users can also delete or adjust the order of the properties and events, which is implemented by responding to the OnItemCommand event of repeater.

See in the following yet another example showing how to use repeater to collect user inputs.

Run Sample View Source

This sample shows how to use "drop-in" item renderers, available since v3.1.0. These renderers come in the PRADO release. They are essentially controls implementing the IDataRenderer interface. Common Web controls, such as TTextBox, TLabel, all implement this interface. When such controls are used item renderers, their Data property is assigned with the row of the data being bound to the repeater item.

Run Sample View Source

More often, one needs to customize the layout of repeater items. The sample above relies on OnItemCreated to adjust the appearance of the renderer. Templated item renderers are perferred in this situation, as they allow us to put in more complex layout and content in a repeater item. The following sample reimplements the nested repeater sample using a templated item renderer called RegionDisplay. As we can see, the new code is much easier to understand and maintain.

Run Sample View Source
$Id: Repeater.page 1688 2007-02-09 22:48:31Z xue $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TStatements

API Manual

TStatements evaluates a sequence of PHP statements and displays the content rendered by the statements. To specify the PHP statements to be evaluated, set the Statements property. For example, the following component tag displays the current time on the Web page,

<com:TStatements>
  <prop:Statements>
  setlocale(LC_ALL, 'nl_NL');
  echo strftime("%A %e %B %Y",time());
  </prop:Statements>
</com:TStatements>

Note, TStatements evaluates the PHP statements during the rendering control lifecycle. Unlike TExpression, TStatements only displays the content 'echoed' within the statements.

The context of the statements in a TStatements control is the control itself. That is, $this represents the control object if it is present in the statements. For example, the following statement tag will display the title of the page containing the TStatements control.

<com:TStatements>
  <prop:Statements>
  $page=$this->Page;
  echo $page->Title;
  </prop:Statements>
</com:TStatements>

Be aware, since TStatements allows execution of arbitrary PHP code, in general you should not use it to evaluate PHP code submitted by your application users.

Run Sample View Source
$Id: Statements.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TTable

API Manual

TTable displays an HTML table on a page. It is used together with TTableRow and TTableCell to allow programmatically manipulating HTML tables. The rows of the table is stored in Rows property. You may set the table cellspacing and cellpadding via the CellSpacing and CellPadding properties, respectively. The table caption can be specified via Caption whose alignment is specified by CaptionAlign. The GridLines property indicates how the table should display its borders, and the BackImageUrl allows the table to have a background image.

Run Sample View Source
$Id: Table.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TTextBox

API Manual

TTextBox displays a text box on a Web page. The content in the text box is determined by the Text property. You can create a SingleLine, a MultiLine, or a Password text box by setting the TextMode property. The Rows and Columns properties specify their dimensions. If AutoPostBack is true, changing the content in the text box and then moving the focus out of it will cause postback action.

Run Sample View Source
$Id: TextBox.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TTextHighlighter

API Manual

TTextHighlighter does syntax highlighting for its body content, including both static text and the rendering results of its child controls. The text being highlighted follows the syntax of the specified Language, which can be 'php' (default), 'prado', 'css', 'html', etc. Here, 'prado' stands for the syntax of PRADO control templates.

If line numbers are desired in front of each line, set ShowLineNumbers to true.

To use TTextHighlighter, simply enclose the contents to be syntax highlighted within the body of a TTextHighlighter control. The following example highlights a piece of PHP code,

<com:TTextHighlighter ShowLineNumbers="true">
<?php
$str = 'one|two|three|four';
print_r(explode('|', $str, 2)); // will output an array
?>
</com:TTextHighlighter>
Run Sample View Source
$Id: TextHighlighter.page 1650 2007-01-24 06:55:32Z wei $
Copyright © 2005-2007 PradoSoft.


PRADO QuickStart Tutorial

Available Languages:
  • English
  • Español
  • Français
  • Indonesian
  • 中文（简体）
  • Polski
  • 日本語

TWizard

API Manual

Overview

TWizard is analogous to the installation wizard commonly used to install software on Windows. It splits a large form and presents the user with a series of smaller forms, called wizard steps, to complete. The following figure shows how a wizard is composed of when presented to users, where step content is the main content of a wizard step for users to complete, header refers to header content common to all steps, navigation contains buttons that allow users to navigate step by step, and side bar contains a list of hyperlinks by which users can reach to any step with one click. The visibility of the side bar can be toggled by setting ShowSideBar.

components of wizard

By default, TWizard embeds the above components in an HTML table so that the side bar is displayed on the left while the rest on the right. If UseDefaultLayout is set to false, no HTML table will be used, and developers should use pure CSS techniques to position the wizard components. Note, each component is displayed as a <div> and the wizard itself is also a <div> that encloses its components' <div>.

Wizard steps are represented by TWizardStep and are maintained in TWizard through its WizardSteps property. At any time, only one step is visible, which is determined by the ActiveStep property. The ActiveStepIndex property gives the index of the active step in the step collection. Clicking on navigation buttons can activate different wizard steps.

Wizard steps are typically added to a wizard through template as follows,

<com:TWizard>
    <com:TWizardStep Title="step 1" StepType="Start">
    content in step 1, may contain other controls
    </com:TWizardStep>

    <com:TWizardStep Title="step 2" StepType="Step">
    content in step 2, may contain other controls
    </com:TWizardStep>

    <com:TWizardStep Title="finish step" StepType="Finish">
    content in finish step, may contain other controls
    </com:TWizardStep>
</com:TWizard>

In the above, StepType refers to the type of a wizard step, which can affect how the navigation appearance and behavior of the step. A wizard step can be of one of the following types:

  • Start - the first step in the wizard.
  • Step - the internal steps in the wizard.
  • Finish - the last step that allows user interaction.
  • Complete - the step that shows a summary to user. In this step, both side bar and navigation panel are invisible. Thus, this step usually does not allow user interaction.
  • Auto - the step type is determined by wizard automatically.

Using TWizard

A Single-Step Wizard Sample

In this sample, we use wizard to collect user's preference of color. In the first step, the user is presented with a dropdown list from which he can choose his favorite color. In the second step, the complete step, his choice in the previous step is displayed. In real application, at this step the choice may be stored in database in the backend.

Run Sample View Source

Customizing Wizard Styles

TWizard defines a whole set of properties for customization of appearance of its various components as shown in the above figure. In particular, the following properties are provided for style customization:

  • Header - HeaderStyle.
  • Step - StepStyle.
  • Navigation - NavigationStyle, StartNextButtonStyle, StepNextButtonStyle, StepPreviousButtonStyle, FinishPreviousButtonStyle, FinishCompleteButtonStyle, CancelButtonStyle.
  • Side bar - SideBarStyle, SideBarButtonStyle.
Run Sample View Source

Customizing Wizard Navigation

Given a set of wizard steps, TWizard supports three different ways of navigation among them:

  • Bidirectional - Users can navigate forward and backward along a sequence of wizard steps. User input data is usually collected at the last step. This is also known as commit-at-the-end model. It is the default navigation way that TWizard supports.
  • Unidirectional - Users can navigate forward along a sequence of wizard steps. Backward move is not allowed. User input data is usually collected step by step. This is also known as command-as-you-go model. To disallow backward move to a specific step, set its AllowReturn property to false.
  • Nonlinear - User input in a step determines which step to go next. To do so, set ActiveStepIndex to the step that you want the user to go to. In this case, when a user clicks on the previous button in the navigation panel, the previous step that they visited (not the previous step in the sequential order) will become visible.
Run Sample View Source

Using Templates in Wizard

TWizard supports more concrete control of its outlook through templates. In particular, it provides the following template properties that allow complete customization of the wizard's header, navigation and side bar.

  • Header - HeaderTemplate.
  • Navigation - StartNavigationTemplate, StepNavigationTemplate, FinishNavigationTemplate.
  • Side bar - SideBarTemplate.
Run Sample View Source

Using Templated Wizard Steps

Wizard steps can also be templated. By using TTemplatedWizardStep, one can customize step content and navigation through its ContentTemplate and NavigationTemplate properties, respectively. This is useful for control developers to build specialized wizards, such as user registration, shopping carts, etc.

Run Sample View Source
$Id: Wizard.page 2147 2007-08-23 17:39:00Z xue $
Copyright © 2005-2007 PradoSoft.